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CHAPTER1 Introduction

What is Smagglce?

Smagglce (Surface Modeling And Grid Generation for Iced Airfoils) is one

of NASA's aircraft icing research codes developed at the Glenn Research

Center. It is a software toolkit used in the process of aerodynamic

performance prediction of iced airfoils. It includes tools which

complement the 2D grid-based CFD process:

• geometry probing

• surface preparation for gridding:

smoothing and re-discretization of geometry

Future releases will also include support for all aspects of gridding:

• domain decomposition

• perimeter discretization

• grid generation and modificaUon

Release Information

Smagglce version 1.0 provides two types of software tools: interactive ice

shape probing and interactive ice shape control. The ice shape probing
tools provide users the means to measure the physical characteristics of

Ice such as icing limit locations, horn height and angle, and distance from

the leading edge to any prominent ice location. The Ice shape control

features provide the means to examine Input geometry data, correct or

modify any deficiencies of them, and perform a systematic smoothing of

ice to a level that will make the CFD process manageable.

The furnished code is still under development and is furnished as Is, with

no warranty of fitness for any particular use. You are not permitted to

give the Smagglce code to any other organizations and/or persons outside

your company. We would be interested in knowing about any problems or
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Introduction

errors that you experience with the codes, as well as any new features you
would like to see included in future releases.

Contact Information

Questions and comments can be sent via e-mail to:
smaggice@grc, nasa. gov

Capabilities

Ice Shape Probing

Interactive ice shape probing is used in the process of characterizing ice
shapes. Probing involves making measurements of the data on the
screen, recording those measurements in a table, and saving them to a
file. Once the boundary data is read in, the user may make probing mea-
surements. These include: point location (e.g., ice limits), distance
between two points (e.g., ice horn height or width), "arc length" (i.e., the
sum of the lengths of the line segments along a boundary between two
points on that boundary), angle between two lines (e.g., horn angle), and
(X-XIe)/C (i.e., (x-xLeadingEdge)/chordLength). Location and distance
may be normalized by the chord length of a clean airfoil. The probe
points can be selected by various methods: the closest point to any object,
the closest point to the current object, the closest point to the reference
object, or an arbitrary point in space. Probing information may be saved
to a text file and a corresponding graphics display can be saved to an
image file.

Ice Shape Control

Interactive ice shape control is used to prepare the surface for gridding.
The types of functions that can be applied to surfaces are curve smooth-
ing, discretlzation, and reshaping. Any subcurve (or the entire curve) of
an element can be selected for processing. Systematic smoothing of the
iced boundaries in a controlled manner is accomplished using a control
point formulation. Users can control the level of smoothing by choosing
the number of control points in constructing curves. Curve discretization
provides a means of Increasing/decreasing the number of points, distrib-

uting the points by curvature, and controlling the uniformity of their dis-
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Introduction

tribution. In addition, hyperbolic tangent stretching is provided. Direct

reshaping of the curve (to perhaps correct obvious ice shape errors) is
done by dragging control points associated with the curve. These control
features of Smagglce not only prepare the ice surface for the grid-based

CFD, but they also allow users to correct any deficiencies (e.g., tangles,
gaps, too many or too few points) in the input data.

Implementation Issues

SmaggIce is written in FORTRAN and C. FORTRAN is used for the
computational routines; C is used for the GUI, control, interaction,
graphics, and memory management.

SmaggIce is intended to run on any UNIX platform and has been tested
on SGI, Sun, IBM RS6000, and HP systems. The GUI was developed for
X-windows, using Motif, Xt Intrinsics, and XIib functions. This will aid in
the portability of the user interface across multiple computer platforms
running X. Whenever possible, the GUI uses higher level libraries (Motif
widgets) rather than the functionally equivalent Xt or X1ib libraries,
because the higher-level code hides many of the details. This makes the
code less complex, so the application is more easily maintained.

GUI Application

Standard

Libraries

User Interface

Motif (Xm)
m

Xt Intrinsics

Xlib (X Window System)

Operating System

Figure 1. Diagram of the user interface library model.

The GUI provides a graphical mechanism for the user to interact with the
data. Some of the Smagglce functionalities which support the primary
capabilities are: reading data, displaying 2D graphics objects, performing
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geometric transformations (such as translation, scaling, area zoom, zoom
in, zoom out), and saving data and images to files.

OpenGL is used for the graphics drawing. It uses the GLX extensions to X
to interface with the windowing system, but the Mesa library can be used
ff the workstation does not have OpenGL or if the X server does not sup-
port the GLX extensions.

Dynamic memory management is used to allocate only as much memory
as is necessary for data storage and access. This allows the program to
process models whose size is limited only by the amount of memory on
the host computer. It also allows multiple input files to be read in and
processed during a single session. In addition, when data is no longer
needed during a session, it can be cleared to allow for reading in new
data. The data structures that make use of dynamic memory in Smagg-

Ice version 1.0 are illustrated here (Figure 2). As objects are read in,
memory is allocated for them to store the object type as well as attributes
describing the object. Space is also allocated for the data points defining
the geometry, and a pointer stored with the object. When additional
objects are read in, or as geometry is modified (e.g., points are added),
memory is reallocated as needed. When objects are deleted, the memory
is freed to make room for new objects.

4

bject

/]object

object

object type
attribute

data pointer

geometry
points

i i D

I S  l eome 

_r_ _ points

geometry [

7_ points

Figure 2. Data structures for multiple objects using dynamic memory.
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CHAPTER2 Access and

Installation

How to get Smagglce

This computer program is available to any U.S. organization upon

request. It is furnished on the condition that it will be used only within

and for the U.S. organization which requests the software, and that it will

not be transmitted to other organizations.

E-mail requests for software should be directed to:

Yung. K. Choo@grc. nasa. gov

System Requirements

SmaggIce was designed and written to run on any Unix platform. It has

been built for the following systems:

SGI Irix 5.3 using X and OpenGL

SGI Irix 6.5 (32 bit) using X and OpenGL

SGI Irix 6.5 (32 bit) using X without OpenGL

SkIN SunOS 5.5. l using X without OpenGL

IBM RS6000 AIX 4.3 using X and OpenGL

IBM RS6000 AIX 4.3 using X without OpenGL

HP-UX 10.20 using X without OpenGL

If you decide to run a version that uses OpenGL, you must have the

OpenGL libraries installed on your system.

Currently, Smagglce is only distributed as a binary executable. If the

platform you are using is not listed here, try using one built for an earlier

version of the same operating system. In most cases, you can run that
successfully. If you need a version of Smagglce for a platform that is not

included in the distribution, please contact the Smagglce team.
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Accessand Installation

Distribution

Smagglce is distributed on a CD-ROM. The CD contains:

I. README file with a description of the CD-ROM contents, and direc-

Lions for installation and startup.

2. Executable Smagglce version 1.0 for each supported system.

3. Sample input geometry files used in the tutorial.

4. This user manual in Postscript and PDF format.

5. On-line help files in HTML format.

6. Auxiliary files needed to set up and run Smagglce.

You are not permitted to give the Smagglce code to any other organiza-

t_ions and/or persons outside your company. We would be interested in

knowing about any problems or errors that you experience with the

codes, as well as any new features you would like to see included in the
future.

If you need additional assistance, please contact the following developers:

Yung K. Choo at (216) 433-5868 or

Mary Vickerman at (216) 433-5067

e-mail: smaggice@grc.nasa.gov

fax: (216) 977-7469

Installation

I. Copythe contents of the CD-ROMto alocal directory. Forexample:
> mkdir SHOME/smaggice

> cp -r /CDROM/* $HOME/smaggice

2. Change to that directory and edit the file bin/runsmagg. Detailed
directions are in the file.

You will have to set at least two environmental variables in that file:

SMG_DTR - directory into which the Smagglce distribution was copied

SMG_VENDOR - the architecture on which you are running

On some systems, you have the option of displaying the graphics using
OpenGL or X only (without OpenGL). The default is to run the OpenGL

version, if it is available. If you would rather run the X-only version,

that option can be set here.

To display on-line help, you may need to set the variable NEBBROWSER.

NASA/'I'M--2000-209793



CHAPTER3 Usage

Getting Started

Before starting Smagglce, be sure you have modified the runsmagg script
(which can be found in the smaggice/bin directory), as described in step
2 of the Installation instructions.

To run Smagglce, invoke the runsmagg script in the smaggice/bin direc-

tory by specifying itsfullpathname. For example, ifyou have installed

Smagglce in the directory $HOME /smaggi ce, type:

> SHOME/smaggice/bin/runsmagg

Alternatively,you may wish to add the smaggice/bin directory to your

path, then simply type:

> runsmagg

The SmaggIce main window will be displayed.

Usage Overview

Smagglee deals with three main types of objects: elements, blocks, and

grids. An element is either the entire or partial boundary geometry of a
solid or a section of flow domain. For example, an element may be a clean

or iced airfoil, or an isolated ice shape between upper and lower Ice limits.

Elements are typically processed in preparation for gridding to correct

input errors, smooth the boundary, increase or decrease the number of

points, and/or redistribute the existing points.

Since SmaggIce allows you to work with multiple objects, it must neces-

sarily support the concept of a "current object". Details of how to switch

between objects and modify those objects are given in the next chapter.
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Usage

Many Smagglce functions are performed on subcurves of objects. Details
of how to select and modify subcurves are also given in the next chapter.

As you begin using Smagglce, you will see that the GUI is designed to pro-
vide "directed control" or "guided use". This means that the user will be
prevented, through the desensitization of wldgets (menus, buttons, slid-
ers, etc.), from selecting conflicting functions or functions that are invalid
in certain situations.

Error checking is performed at all levels, starting at the GUI, whenever
the user enters parameters. Any errors such as out-of-range data or
invalid values are immediately reported so that the user can correct them.

NASA/FM--2000-209793 10



CHAPTER 4 User Interface

Smagglce main window

SmaggIce consists of a primary Main Window tiffed "Smagglce - Surface

Modeling and Grid Generation for Iced Airfoils" and sub-windows called:

• File Open

• Screen Save

• Save As

• Messages

• Ice Shape Characteristics

• Save Probe Information

• Discretize Subcurve

• Change Free Form Subcurve

• Tanh Redistribution

The SmaggIce Main Window (Figure 3) is recognized by the following dis-
tinctive areas: MenuBar (F//e, Edit, View, Probe, Boundary, Grid-CN,

Grid-Direct, Solution, and Help pulldown menus), Information, Current
Object Info, Graphics Window Mode, View Manipulation, and Graphics Drawing

Area. Those items that are "grayed-out" are not available at this time.

Also, sometimes items are "grayed-out" when certain selections have been

made. This means that the item is temporarily unavailable. An example of

this is the Save As or Screen Save selection. These are "grayed-out" when

the user starts the application, because no data has been read, so there is

nothing that can be saved. Similarly, when the user removes the data

objects from the graphics window by selecting Edit->Clear All, many GUt
functions will not be available to the users. This section of the manual will

describe each of the functionalities that are currently supported.

NASA/TM--2000-209793 11



User Interface

_le E_dit _Vtew _Probe Boundary Grid-CN Grid- Direct S__olution Help

Information:

x = o.o_077z |:|
Y = 0.005079 [| Tr_m,';laL(_. (_calt,_ _'_,_a Z<}_>rn
End Point Index = 33Z [|

Y = 0.005079 |:|
# $ubcurve Pts = 332 ||

Current Object Info:

Number of points = 3_Z

Qosed Element

Object # E_-_- = of 3

Graphics Window Mode:

Current Mode:

i Choose Subcurve

Instructions:

press Left Mouse B ton. i |_

Figure 3. SmaggIce Main Window

Fog View Zoom In Zoom Out

kJ

Translate

MenuBar

There are nine menu items in the MenuBar: F//e, Edit, View, Probe,

Boundary, Grid-CN, Grid-Direct, Solution, and Help. Each of these will be
described later in the manual section tiffed "MenuBar" (p. 15).
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UserInterface

Information

While the user interacts with the graphics window, relevant information
is displayed in the scrollable text area (Figure 4). For example, while

probing, the coordinates of points are displayed here. As another
example, when a subcurve is being selected, information on tile subcurve

endpoints is displayed here.

Information:

ChooseSubcurve
I st Point Index = 1
X = 0.01877Z
V = 0.005079
EndPoint Index = 33Z
X : 0.01077Z ._.
Y = 0.005079

# Subcurve Pts = 33Z

Figure4. Information

Current Object Info

This area displays information about the current object such as: the type
of object, its index number, and a graphics diagram specifying the object
depending on its type (Figure 5). For example, when an element is
selected, the number of points in the element is displayed, along with an
indication of whether it is an open element or closed element. To switch to
another object, making it the current object, you may type its index in the
Object # text box and press <Enter>. Also, there is a non-editable textfield
that contains the total number of objects that are currently available.
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Current Object Info:

Number of points = 33;_

Closed Element

Object. # _ of 3

Figure5. Current Object Info

Graphics Window Mode

The current mode is displayed here, along with instructions (Figure 6).

Some of the graphics window modes are: Translate, Scale, Area Zoom,

Choose Subcurve, and Display Point Coordinates. Depending on the
mode, mouse movements and button clicks will have different effects.

How to use the mouse in each mode is described in the Instructions

scrollable text area.

Graphics Window Mode:

Current Mode: i

Instructions:

To select the starting point
press Left Mouse Button. ii!

To select the end point ii;i

press Middle Mouse Button _i

or Shift Left Mouse Button, _=i:

To finish press Right Mouse
Button.

Figure 6. Graphics Window Mode
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View Manipulation

These icon push buttons (Figure 7) modify your view of the geometry

without changing the data itself. The first set of buttons, labeled

[Translate], [Scale], and [Area Zoom], set the mouse mode so that mouse

button presses and movements modify the vlew continuously. [Translate]

moves the geometry around on the screen without changing its size.

[Scale] changes the apparent size of the geometry. [Area Zoom] allows you
to draw a box around an area of interest and zoom into that area.

InstrucUons for how to use the mouse in each instance Is displayed in the

Instructions scrollable text area in the Graphics Window Mode area. The

second set of buttons, labeled [Full View], [Zoom In], and [Zoom Out],

change the view immediately when you press one of them. [Full View]

modifies the view to include all geometry. [Zoom In] makes all geometry

appear a little larger. [Zoom Out] makes all geometry appear a little

smaller. The last set of arrow buttons labeled Translate also changes the

view immediately. When an arrow button is pressed, it will move the

geometry the indicated fraction of the screen width In that direction. The
fraction value may be changed by typing in another value in the textfield.
The default fraction is 0.2.

Translate Scale Area Zoom Full View Zoom In Zoom Out

:A

Translate

Figure7. View ManipulaUon

Graphics Drawing Area

The Graphics area is where geometry is displayed and direct interactive

manipulation of the geometry is performed. Depending on the current

graphics mode, mouse button presses and movements will have different
effects. Instructions for interactions in each mode is described in the

Instructions scrollable text area in the Graphics Window Mode area.

MenuBar

This section gives information on the nine components of the MenuBar:

File, Edit, View, Probe, Boundary, Grid-CN, Grid-Direct, Solution, and Help.
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File

Currently, there are four actions that can be selected from the File Menu.

They are Open, Save As, Screen Save, and Exit (Figure 8).

_en ... Ctrl+Oj

Save As ... Ctd+S i
7

Sc_reen Save ... i

Exit ... CtH+Q I

Figure8. File pu]ldown menu

Open... Displays the File Open window (Figure ] 8, p. 23}. This window

allows the user to select and read the geometry or solution file. More

information is available under the section "File Open window"

(p. 22).

Save As ... Displays the Save As window (Figure 19, p. 25). This window

allows the user to save the geometry of objects to a file. More

information is available under the section "Save As window" (p. 24).

Screen Save ... Displays the Screen Save window (Figure 20, p. 26). This

window allows the user to save the Graphics Window as an image
file. More information is available under the section "Screen Save

window" (p. 26).

Ex/t ... Presents a confirmation screen to either terminate the Smagglce

application or continue in the previous mode.

Edit

Currently, the only option available is Clear All (Figure 9).

R_?dt(_w

L_ado
! .....

,%."elect,

_RelH(_'e,

l)e|e_e

Figure 9. Edit pulldown menu
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View

Clear All - Removes all the data objects from the Graphics Window and

sets most of the attributes of Smagglce back to their initial state, as

when the program started.

This menu allows the user to access the following: Messages, Display

Point Coordinates, Highlight Tangle, Control Net, Grid, Solution, and

Messages (Figure 10).

Display Point Coordinates

_,f Highlight T_angle

Co'f_t_mlNet (CN)

Grid

W Solution

Messages ...

Figure 10. View pulldown menu

Display Point Coordinates - Once the user has selected this option, the

graphics mode will be changed to "Display Point Coordinates", so
that each left mouse button press in the graphics window will select

the closest boundary point in the current object. The point will be

highlighted in the graphics display, and its index and (x,y)

coordinates will be displayed in the Information section.

Instructions for selecting the closest point with the mouse button

will be displayed in the Instruction scrollable text area in the
Graphics Window Mode section of the main screen.

High//ght Tangle - Highlights tangles (intersecting lines along the

boundary) in elements. When an element is read in and after it is

modified in the Change Free Form Subcurve window, a search is

made for tangles in that element. Up to 25 intersections may be

found. If this check box is selected, the intersecting line segments

will be highlighted, and a box will be drawn around the point of

intersection. If the curve is later modified so as to remove the tangle,

the highlighted lines and box will be removed.

Control Net (CN) - Sets the visibility of the control net to be "On" or "Off'.

This setting currently has no effect.

Gr/d - Sets the visibility of the grid to be "On" or "Off'. This setting

currently has no effect.
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Probe

Solution - Sets the visibility of the solution data to be "On" or "Off'. This

setting currently has no effect.

Messages ... Displays the Messages window (Figure 1 1). This scrollable

window keeps a running log of information, warning, and error

messages.

Graphics lnfo: Empty Window ......
Curvature value must be greater than or equal to 0 _
Enter a value from 0 to 1O0 _E

Number of points must be greater than or equal to Z

Number of points must be greater than or equal to Z
Enter a value from 0 to 100

: =

Figure 11. Messages

This menu allows the user to access the following: Ice Shape

Characteristics, Set Reference Airfoil, Highlight Reference Airfoil, and

Display Glyphs (Figure 12).

_be _ Boundary Grid- CN

Set Reference Airfoil

j Highlight Reference Airfoil

[W Display Glyphs

Figure 12. Probe pul]down menu

Ice Shape Characteristics - Displays the ice Shape Characteristics window

(Figure 2 I, p. 27). This window allows the user to probe geometry

measurements (such as, location, length, arc length, angle, and
(X-XIe)/C) for various point selection methods (such as, all objects,

current object, hdy_°p_:_i_i.,,_:(_:;.(_,reference airfoil, and arbitrary point).
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The user can enter the probe information in the Probe Table, and

save the probe information to a file. More information is available
under the section "Ice Shape CharacterisUcs window" (p. 26).

Set Reference Airfoil - Identifies the current object as the reference airfoil.

In order to request some probing measurements, such as

normalized length or (X-Xle)/C, a reference airfoil (usually one

without ice accretion) must be specified so that the chord length

can be calculated and the leading edge can be identified.

Highlight Reference Airfoil - Sets the visibility of the reference airfoil to be

"On"/"OfF. If a reference airfoil has been set and this toggle is
checked (i.e., the box is colored), the reference airfoil will be

highlighted. Two additional reference points will also be displayed

and selectable during probing operations: the leading edge point,

and the center of the leading edge circle. If this toggle is not

checked, the reference airfoil will be displayed in the same colors as

all other objects, and the two additional reference points will not be

displayed or selectable. To set the reference airfoil, make the

reference airfoil the current object, and then select Probe->Set

Reference Airfoil from the main menu.

Display Glyphs - Sets the visibility of the probing glyphs "On" or "Off". If

this toggle ls checked (i.e., the box is colored), then glyphs {lines and

points representing measurements that are entered in the Probe

Table) will be shown in the graphics display area, overlaid on the

geometry. Turning off this toggle will turn off the display of these

glyphs. However, the glyphs will continue to be defined (and

displayable by setting the toggle on again), until Edit- >Clear All is

chosen from the main menu, or the [Clear All] button is pressed on

the Ice Shape Characteristics window.
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Botmcla__

Currently, there are five actions that can be selected from the Boundary
Menu. They are Choose Subcurve, Discretize Subcun,w., Change Free Form
Subcurve, Tanh Redistribution, and Switch Object.

I)iscretlze Subcurve ...

Paste N il_-¢_ I_iS|_butim_

H.. ........

rr

Figure 13. Boundary pulldown menu

Choose Subcu.rve- Selects the subcurve for the current object. By default,
when a boundary is read in, the subcurve is the entire boundary.
Several functions in SmaggIce (such as Discretize Subcurve, Change
Free Form Subcurve, and Tanh Redistribution) are performed on
=subcurves". Instructions for setting the endpoints of the subcurve
will be displayed in the Instructlons scroIlable text area in the
Graphics Window Mode area of the main screen.

Discretize Subcurve - Displays the Di$cretize Subcurve window (Figure 22,
p. 30). This window allows the user to discretize the selected
subcur_e of the current object. The new discretized points are
displayed as blue crosses overlaid on the graphics display. More
information is available under the section =Discretize Subcurve

window" (p. 30).

Change Free Form Subcurve - Displays the Change Free Form $ubcurve
window (Figure 23, p. 31). This window allows the user to change
the shape of the selected subcurve by using control points. More
information is available under the section *Change Free Form
Subcurve window" (p. 31).
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Tanh Redistribution -Displays the Tanh Redistributlon window (Figure 24,
p. 32). This window allows the user to redistribute the points of the"
selected subcurve of the current object using a hyperbolic tangent
redistribution method. The new point locations are displayed as
blue crosses overlaid on the graphics display. More information is
available under the section "Tanh Redistribution window" (p. 32).

Switch ObJect - Makes the next object in the list the current one.
Smagglce has the concept of a "current object', which is the object
upon which functions are performed. This menu selection allows
you to switch to the next object in the list of a-_ailable objects. The
hot key for this menu pick is <Ctrl>W. You may also switch to
another object by typing the object number into the Object # text box
in the Current Object Info area of the main screen and pressing
<Enter>.

Grid-CN

Currently, all the items in this menu are unavailable.

c. ,.,:%"<

-- .. : • _:+-_+ .... ,z'< +

-- -.... " + +LT)" "¢

Figure 14. Grld-CN pulldown menu

Grld-Di_ct

Currently, all the items in this menu are unavailable.

_I_','eII:l_iC-¢kl&,.<?<+.._:_-<

Re,ram _ L .... :::::.

•"e. :+ +'+::<+_.<++i+ +" .... :

+ +
i r

Figure 15. Grld-Direct pulldown menu
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Solution

Currently, all the items in this menu are unavailable.

FHure16. Solution pulldown menu

Help

This menu allows the user to access the following: On Verston .... Ont_
Help .... and Hints ... (Figure 17).

i I
FNunD17. Help pulldown menu

On Version ... Displays the following information: SmaggIee Version,
Release date, Copyright, and e-mall address of the contact person.

_ He_ ... Displays online HTML documentation

H_s ... Lists the most frequently asked questions.

File Open window

The File Open Window allows the user to select and read geometry and
solution data (Figure 18). The user selects from the Rle Type option menu
the type of data to be read in. There are four file types available: E/ement
Boundary, B/ock Boundary, Gr/d_ and So/ut/oru An element is an object
boundary. There are two different kinds of element boundarles. An open
element has the first and last points at different x,y coordinates. A dosed
element has the first and last points at the same x,y coordinates. The
user a_o selects from the File Format option menu the format of the file to
be read in. There axe three file format types available: Formatted,
Unformatted, and Binary. Detailed descriptions of these file formats can
be displayed by pressing the [Help] button in this window. Formatted files
contain ASCII data and can be created with a text editor or by writing the
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data using formatted write in a Fortran program or the pr/ntffunction in
a C program. Formatted files may also have blank lines and embedded
comments; everything on the line after a # is ignored. Unformatted files
contain binary data in records, where each record contains informaUon

about the record length. These files are normally written using an
unformatted write in a Fortran program. Binary files contain binary data
written as a stream of data. These files are normally written using the

fwrite function in a C program.

Rle Type: Rle Format:

lqlbl_

Directories Rles

! !il°'°'"

i fusrflerc/uumad.qcegridlsrc/g_d.r3elem.ice.gee
| .....................................................................................

Figure 18. File Open Window

The following controls are used to specify the file to be read: Filter, Direc-
tory, Files, and Selection.

Filter - Filters or limits the filenames displayed in the Files list box. The
directory initially displayed in this input box is the current directory
(the one you were in when you started the applicaUon). You may
also type directly into the Filter text box the full path followed by a
filename which may include an * to match any string of characters.
Then press the [Filter] button at the bottom of the window.
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Directories - Lists the directories matching the pattern in the Filter input
box. If more names exist than can be displayed in the list box, the

scrollbar will allow you to move through the list. You can navigate

through directories by double-clicking on an entry in this scroll list.

Files - Lists the filenames matching the pattern in the Filter input box. If

more names exist than can be displayed in the list box, the scrollbar

will allow you to move through the list. Select a filename from this

list by clicking on it or read the file by double-clicking its filename.

Selection - Displays the path and filename of the file you want to read. If

the desired filename is not displayed, use Filter, Directories, and Files

to select the desired filename or type the name of the path and file

you want in this area. If the Selection input box already contains a

name, you can edit the name as you would in any input box.

Pressing <Enter> after typing the filename is equivalent to clicking

the [Read] button or double-clicking a filename.

Save As window

The Save As window allows saving geometry and solution data to a file.

The user selects from the Save Object option menu the type of data to be

saved. There are five types of data that can be saved: Current Object, All

Elements, All Blocks, All Grids, and All Solutions. The Save Object option
determines what is written to the file:

Current Object - only the current object, regardless of its type, is written to
the file

All Elements - all existing elements are written out to a single file

All Blocks - all existing blocks are written out to a single file. Not yet
available.

All Grids, "all existing grids are written out to a single file. Not yet
available.

All Solutions - solution data is %n'itten out to a single file. Not yet
available.

Also, the user selects from the File Format option menu the format of the

file to be written out. There are three file format types available: Format-

ted, Unformatted, and Binary. For descriptions of each of these, see the

previous section "File Open window" (p. 22).
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I Save Object: Rle Fomlat: 1

Filtor

Directories Files

! Readme : ]1

iidlsrclcp _ _ Im_Bfile iJi1
!id/src/gol _ I imakefile,bak

!id/srctlnc ude J...j i ink.eels J

iid/srcfutJls _ i_mk;hpl_a! :! .--hp ;,hpux ............

............. J_

Selection

I _us r.qerc/uum arl/Icegrid/src!

Figure 19. Save As Window

The following controls are used to specify a file where the data will be

saved: Filter, Directory, Files, and Selection.

Selection - Displays the path and filenarne of the file you want to write to.

For the full description of each of these controls, see page 23 under the

section "File Open window".
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Screen Save window

The Screen Save window allows the user to save the Graphics Window to
a file. The File Type option menu determines the type of image file that
will be saved: GIF, TIFF, or PPM (portable plxrnap). The rest of the
controls are used the same way as in the File Open and Save As windows.

Rle Type:

Ntt_r

t_.=rtterc/uumari/icegddlsrcl*

Directories Rles

idlsrc/ _ _ !Readme _l

_id/src/graphlcs _ | imakeflle I,! _.
i d/src/gu _ [ imakefile.aJ_ch j:
lid/src,"Include _ [ _makeflle.bak ;[,,_:

_mk defs : _::,

Selection

/usr/e rc/uumad/Ic egdd/srcl i

Figure20. Screen Save Window

Ice Shape Characteristics window

The Ice Shape Characteristics window allows the user to probe geometry
measurements (such as location, length, arc length, angle, and (X-Xle)/C)
using various point selection methods (such as a_ll objects, current object,
[ntcrpolated, reference airfoil, and arbitrary point). The user can enter the

probe information in the Probe Table, and this information can be saved
to a file. This window consists of parameters, controls and buttons.

NASA/'FM--2000-209793 26



User Interface

Comment _.
r : .; Enter f

Label PointSelecUonMethod: ProbeMeasurement: ChordLength

Nom_alize
Label X Y Length ArcLength Angle (X- Ne) I C Factor

i :i ,

i............. ..............................
Figure 21. Ice Shape Characteristics Window

Parameters

Comment - Typing a string in this field has no effect until the Enter

Comment button is pressed. At that time, the comment is entered

on a separate line in the Probe Table.

Label - (up to 12 characters) Typing a string in this field just sets a value;
no information is entered into the table until a measurement is

made. At that time, this label, along with the measurement is

entered into the table. This field may be blank.

Point Selection Method - selects the method used to find points when

making measurements; one of: All Objects, Current Object,
lz_terpolated, Reference Airfoil, or Arbitrary Point.

All Objects - the closest point will be chosen by searching through

all the objects.

Current Objects - the closest point will be chosen from the cur-

rently-selected object only.

Interpoktted - a point v_d]i be chosen on a line segment which is

between t_-o points of the current element. This option is cur-

renfly not available.
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Reference Airfoil- the closest point on the reference airfoil will be
chosen. In order to select this choice, a reference airfoil must

have previously been set (menu selection: Probe-> Set Refer-
ence Airfoil). If the reference airfoil is highlighted (menu selec-
tion: Probe-> Highlight Reference Airfoil), two additional points

will be available to be chosen: the leading edge of the airfoil, or
the center of the leading edge circle.

Arbitrary Point - the point chosen does not have to be on an object.

You may change the point selection method at any time, even while in
the middle of making measurements. So for example, when measur-
ing length, one endpoint may be chosen using the Current Object
method, and the second endpoint may be chosen using the Arbitrary
Point method.

Probe Measurement - selects the probe type from the option menu; one of:
Location, Length, Arc Length, Angle, (X-XIe) / C, or None. This
determines how the mouse will be used and what type of
information will be entered into the Probe Table.

Location - a single point should be selected; its (x,y) coordinates can
be entered in the Probe Table.

Length - two points on the boundary of a single object should be
selected; the distance between the two points can be entered
in the Probe Table.

Arc Length - two points on the boundary of a single object should be
selected; the length of the line segments along the boundary
between two points on the boundary can be entered in the
Probe Table. The selection of the second point will be con-
strained to be on the same boundary as the first point. Also,
since the points must be on a boundary, the Arbitrary Point
selection method may not be used with this probe type.

Ang/e - two lines should be selected; the angle (in degrees) between
the two lines can be entered in the Probe Table

(X-XIe)/C - a single point should be selected; this value can be
entered in the Probe Table. Here X = the x-coordinate of the

selected point, Xle = the x-coordinate of the leading edge of the
reference airfoil, and C = the chord length of the reference air-
foil
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None - no probing type is active

Normalize - selects whether or not normalization will be performed when

calculating location and length. The data is normalized by dividing
by the chord length. This normalization factor (i.e., the chord
length) will be entered into the Probe Table. Because the chord
length is needed for normalized measurements, a reference airfoil
must be set in order to be able to choose this option.

Chord Length - displays the chord length of the reference airfoil when a
reference airfoil has been set. However, this field will only be used
in calculations when the Normalize box is checked.

Controls

Probe data are calculated and entered into the table by using the mouse.
The particular Probe Measurement selected determines how the mouse is
used. But in general, the left and middle mouse buttons are used to
select points or endpoints of lines, and the measurement information will
be displayed temporarily in the Information Ares of the Main Screen. Then
when the right mouse button is pressed in the graphics window, the
measurement information is entered into the Probe Table. The use of the
mouse button clicks will be described in the Instructions scrollable text

area in the Graphics Window Mode section of the Main Screen.

Buttons

[Enter Comment] - Enters the text specified in the comment field into the
Probe Table as a separate line.

[Close] - Closes the window

[Clear All] - Clears all entries in the Probe Table.

[Save ...] - Saves the data in the Probe Table to a file. A file selection
window will open to allow you to specify the output file.

[Help] - Displays help information for the Ice Shape Characteristics window.
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Discretize Subcurve window

The Discretize Subcurve window allows the user to discretize the selected

subeurve of the current object. The new discretized points are displayed

as blue crosses overlaid on the graphics display. This window consists of

parameters and buttons.

0

_.,.,.t,,., [o ..................

Num,of points

Figure 22. DiscretizeSubcurve Window

Parameters

Uniform - an Integer value in the range [0,10]. A value of 0 makes no

change to the original distribution, while a value of 10 distributes
the points on the subcurve uniformly. Change this parameter by

sliding the horizontal scroll bar.

Curvature - an integer value greater than or equal to zero. A greater

number will cluster points more tightly in areas of high curvature.

Change this parameter by typing an Integer in the text box and

pressing <Enter>.

Number of points - the number of points In the discretized subcurve; an

integer value greater than or equal to two. Change this parameter

by typing the number of desired points in the text box and pressing
<Enter>,

Buttons

[OK] -Applies changes and closes the window.

[Apply]-Permanently changes the curve, replacing the old points with the

newly discrctlzcd points.

[Close]- Closes the window without Applying changes.

[Help] - Displays help information for the Di$cretize Subcurve window.
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Change Free Form Subcurve window

The Change Free Form Subcurve window allows the user to change the

shape of the selected subcurve by using control points. The new point

locations are displayed as blue crosses overlaid on the graphics display.

This window consists of parameters, controls and buttons.

Num. Show
Pts Pts

Smoothed ;_t

Show

Cuwe

2J

.ova FF i

Figure23. Change Free Form Subcurve Window

Parameters

Number of Smoothed Points - this text.field contains the number of

smoothed points to be calculated for the new curve; an integer value

greater than or equal to 3 must be used. Change this parameter by

typing an integer in the text box and pressing <Enter>.

Number of Control Points - this textfield contains the number of control

points to be used; an integer value greater than or equal to 3 must

be used. Change this parameter by typing an integer in the text box

and pressing <Enter>.

Controls

Show check boxes - allows you to select what will be shown in the

graphics display while changing the free form subcurve. Points
and/or curves for the current subcurve, the smoothed (modified)

subcurve, and the control net can be displayed.

[Move FF Control Pts] - Sets the graphics mode to Move FF Control Points.

While in this mode, you may move the control points, thereby

changing the shape of the subcurve. Instructions for moving the
control points will be displayed in the Instructions scrollable text

area in the Graphics Window Mode area of the main screen.

Uniform - this option is currently not available.
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Buttons

[OK] - Applies changes and closes the window.

[Apply] - Permanently changes _e curve, replacing the old points with the

new points.

[Close] - Closes the window without Applying changes.

[Help] - Displays help information for the Change Free Form Subcurve
window.

Tanh Redistribution window

This window allows the user to redistribute the points of the selected

subcurve of the current object using a hyperbolic tangent redistribution
method. The new point locations are displayed as blue crosses overlaid on

the graphics display. This window consists of parameters and buttons.

Stretch CurrentValue

0

EndPt I / EndPt Z
0

i

Figure 24. Tanh Redistribution Window

Parameters

Stretch - the amount of stretch to apply; an Integer value in the range

[0,100]. Change this parameter by sliding the horizontal scroll bar

or by typing an integer in the text box and pressing <Enter>.

EndPtl/EndPt2 - indicates the endpoint toward which subcurve points will

be clustered; an integer value in the range [0,100]. A value of 50 will

stretch points equally towards both endpolnts. Change this

parameter by sliding the horizontal scroll bar or by typing an integer

in the text box and pressing <Eraser>.
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Buttons

[OK] - Applies changes and closes the window.

[Apply] - Permanently changes the curve, replacing the old points with the

redistributed points.

[Close] - Closes the window without Applying changes.

[Help] - Displays help information for the ranb Redistribution window.

Online Help

The Smagglce on-line help uses Netscape to display the help files, which
are stored in HTML format. If you have trouble displaying on-line help
from Smagglce, make sure Netscape is available on your workstation, and
check to make sure the environmental variable WEBBROWSERwas set

correctly in the file bin/runsrnagg in the smaggice directory. You may
also view the help files independently of Smagglce by pointing your
browser to the file help/index, htiul in the smaggice directory.

NASA/I-M--2000-209793 33



CHAPTER5  or/c 

This chapter will step you through the some general tasks in Smagglce,
and then present several scenarios: view modification, boundary
modification, and probing.

Note: If you have installed Smagglce in a directory other than
SHOME/smaggice, modify all the pathnames in the tutorial accordingly.

General tasks

This section will walk you through some general tasks that you will need
to be able to do whenever you use Smagglce.

Start Smaggice

Start up SmaggIce by executing the runsmagg script, which can be found
under the bin subdirectory of smaggice. Enter it at the shell prompt,
making sure to specify the full path name. For example:

SHOME/smaggice/bin/runsmagg

Read geometry

You will read in a three-element airfoil which is stored in a formatted

element file. Select from the main menu: File->Open

In the File Open window,

• Select Element Boundary as the File Type.

• Select Formatted as the File Format.

• Read the file: 3elem.all.geo

from the directory $HOME/smaggice / geometry.

• Close the window.
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Select current object

SmaggIce performs operations on the current object. You may select the

current object using one of these methods:

• Select from the main menu: Boundary->awitch Object. Do this several

times to switch between the three objects.

• Use the hot key <ctrl>w. You may do this several times In succession

to cycle among objects.

• Type an object number directly into the Object # text box in the Current

Object Info area of the main screen. Try entering 2 to switch to object
number 2.

Notice that the selected object is displayed in red, and the non-selected

objects are displayed in green. Also notice the information that is dis-

played in the Current Object Info area on the left portion of the main
screen.

Get on-line help

On-line help is available and displayed through your web browser.

• To request general help from the main window, select from the main

menu, Help- >Ordine Help...

• As you start using other Smagglce windows, you will see that specific

help may be accessed by pressing the [Help] button at the bottom of
each of those windows.

Clear all

At times you will want to clear all graphics and data, and return

Smagglce to its initial state.

• From the main menu, select: Edit- >Clear All.

Exit

To exit Smagglce,

• From the main menu, select: FX/e->Ex/t...

You will be asked to verify your choice.

• Press Wes] to exit.

NASNTM--2000-209793 35



Tutorial

Scenario 1 - View modification (geometry transformation)

This section will explain how to perform geometry transformations to
change the view you have of the geometry. You will be using the seven
widgets across the top of the screen to do this.

Startup

Start SmaggIce (or select Edit->Clear All, if already running a session).

Read the formatted element file: 3 elem. at I. geo

from the directory SHOME/smaggice/geometry.

Graphics Mode transformations

The three buttons on the top left of the graphics window ([Translate],
[Scale], and [Area Zoom]) set the Graphics Window mode so that mouse
movements in the graphics window will change the view. When you select
any one of these, you will notice that the mouse cursor changes to
indicate that you are in a special view manipulation mode.

• Press the [Translate] button (notice that it turns blue, to indicate that
the Translate mode is active), then follow the instructions in the lower

left corner of the main screen to move the geometry around.

• Press the [Scale] button. This will switch you to Scale mode and allow

you to enlarge or reduce the image.

• Press [Area Zoom]. This allows you to draw a box around an area that
will be enlarged to fill the screen.

* To exit any of these modes, click on the button again. The button will
turn gray to indicate that the mode is not active, and the mouse cursor
will return to its previous shape.

Immediate transformations

The four sets of buttons on the top right of the graphics window ([Full
View], [Zoom In], [Zoom Out], and Translate arrows) immediately change
your view of the geometry.

• Press [Full View] to reset the view to include all of the geometry.

• Press [Zoom In] or [zoom Out] to scale the geometry up or down
incrementally.

• Press one of the Translate arrows to move the geometry up, down, left, or

right by the specified window percentage. You may also change the
percentage by typing a new value in the center box of this widget.
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Scenario 2 - Boundary modification

This section will show you how to select and modify subcurves.

Startup

Start Smagglce (or select Edit- >Clear AIL if already running a session).

Read the formatted element file: c t ean +2 t c e. ge o

from the directory SHOME/smaggice/geometry.

Notice that there are three objects: the full clean airfoil (a closed
element) and two ice shapes (open elements). Make sure that object I
is selected.

Figure 25. Geometry file: clean+2ice.geo; object i selected.

Select subcurve

Initially, the selected subcurve for an element is the entire curve. You will
usually want to select only part of the curve to work with.

• From the main menu, select: Boundary->Choose Subcurve.

• Your cursor will change to indicate that you are in a special mode for
selecting points. The instructions in the lower left corner of the screen
will tell you how to select the endpoints of the subcurve. As you select
the endpoints of the subcurve, notice how the information in the upper
left corner of the screen changes. Also note that the points on the
subcurve are displayed in red, while the points not on the subcurve
are displayed in orange.

• Select the upper surface of the airfoil as the current subcurve. This
will be between point indices 1 and 83. You may find it easier to select

specific points by using the mouse to click near the point, then using
the arrow keys to set the exact point. The left and right arrow keys can
be used to change the index of the most recently selected subcurve

endpoint.

• To exit the Choose Subcurve mode, press the right mouse button.
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Hyperbolic tangent redistribution

This allows you to redistribute the points in the selected subcurve. This

tool will let you concentrate the distribuUon of points near the leading

and/or trailing edge(s).

• From the main menu, select: Boundary->Tanh Redistribution...

• NoUce that two sets of points are displayed: the current points as red

dots and the modified points as blue crosses.

• You may change the amount of stretch and how the stretching is

distributed between the two endpoints by using the sliders in this

window. You can also change a value by typing a number In the

appropriate text entry area and pressing <Enter>. Set the Stretch
value to 100 and the EndPil/EndPt:2 value to 50.

• If you would like to replace the current points with the modified points,

press (Apply]. To close the window without making the changes
permanent, press (Close]. Pressing (OK] will apply the changes and
close the window all at once.

Figure 26. Redistributed points on upper surface of airfoil.

Discretize subcurve

This allows you to change the number of points in the subcurve and how

they are distributed.

• Switch to object 2, and zoom in on the area at the leading edge of the

airfoil (Figure 27). Select indices I and 56 as the endpoints of the

subcurve by using the Boundary- >Choose Subcurve menu selection.

• From the main menu, select: Boundary->Discretize Subcurve... If this

menu selection is grayed out, it may be that you are still in the Choose
Subcurve mode. (Follow the instructions in the lower left corner of the

main screen, and click the right mouse button to exit that mode.)

• Again, the current points are displayed as red dots while the modified

points are displayed as blue crosses.

• To change the Uniform parameter, drag the slider. To evenly distribute

the points, set this to the maximum value of i 0.

• Change the number of points in the subcurve to i 00, by typing that

value in the text field and pressing <Enter>.
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• Press [Apply] to make the changes permanent.

• You may want to concentrate the distribution of points near areas of

high curvature. Set the Uniform parameter back to 0, then type a value
of 2 or 3 in the Curvature text field and press <Enter>.

• Make the changes permanent, or discard the changes the same way

you did in the Tanh Redistribution window.

Figure27. Left to right: original distribution; uniformly discretized to I00
points; discretized by curvature.

Change subcurve using free form method

This allows you to smooth the subcurve and modify the subcurve by
moving control points that define its shape.

• Make sure the view is zoomed into the area at the front of the airfoil

(Figure 28).

• Switch to object 3 and select indices 1 and 112 as the endpoints of the
subcurve. (Remember to exit Choose Subcurve mode when you are
done.)

• From the main menu, select:

Boundary- >Change Free Form Subcurve. . .

• The check boxes in this window will allow you to display the current
points, the smoothed (modified) points, and the control points, as well
as the lines connecting those points. Try turning these on and off.

• Increase the number of Smoothed points to 150 by typing that value in

the text box and pressing <Enter>.
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• Decrease the number of Control points to 4 0 by typing that value in the
text box and pressing <Enter>. This has the effect of smoothing the
subcurve.

• You may also modify the curve by moving the control points. Press the
[Move FF Control Pts] button. You are now in the Move FF Control
Points mode. Follow the instructions to move control points. To exit
this mode, press the right mouse button.

• Make changes permanent, or discard the changes the same way you
did in the Tanh Redistribution window.

Figure 28. Left to right: original points; curve smoothed using 40 control points

(control points not shown); new curve with 150 points.

Save modified geometry

After making these changes to the geometry, you may want to save the
geometry to a new file.

• From the main menu, select: Ftle->Save As...

• Under the Save Object option menu, select All Elements. Type the
name of the new file in the Selection text box and click [Save].

• You may want select Edit->Clear All and then read in this new file to

verify that the changes were saved.
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Scenario 3 - Probing

This section will step you through the process of making measurements
of ice shapes, i.e., probing.

Startup

Start Smagglce (or select Edit->Clear All, if already running a session).

Read the formatted element file: clean+3ice, scaled, geo. This file
contains 4 closed elements: a clean airfoil and three iced airfoils.

Zoom in to the area at the leading edge of the airfoil.

Select object 2 to be the current object.

Display point coordinates

You can display the coordinates of points in the current object. When
you select a point, both its index and its (x,y) coordinates are displayed in
the Information area of the main screen.

• From the main menu, select: View->Display Point Coordinates

• Follow the instructions in the lower left corner of the screen to select

points and display their coordinates in the Information area. These
coordinates are for immediate reference only. The following steps will
show you how to keep a record of point locations, as well as other
types of probing information.

• To exit Display Point Coordinates mode, press the right mouse button.

Select reference airfoil

For some probing measurements, such as (X - Xle) / C, a clean airfoil
must be identified as a reference, since the chord length C is determined
from the clean airfoil. The chord length can also be used to normalize
measurements such as length. In order to choose these calculations, you

must first identify the clean airfoil so that the chord length can be
determined.

• Select object l (the clean airfoil).

• From the main menu, select: Probe->Set Reference Airfoil.

° You may want to highlight the clean airfoil by selecting from the main
menu: Probe->Highlight Reference Airfoil. Notice that there are two
additional points marked with purple crosses: the leading edge point,
and the center of the leading edge circle. During probing, you may
select these points as you would others. (Figure 29)
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Probe measurements

From the main menu, select: Probe->Ice Shape Characteristics.

Comments may be entered at any time into the Probe Information

Table. Type "Probing Tutorial" in the comment text area, and press
the <Enter> key or the [Enter Comment] button.

Location

Make a location measurement:

• Select Location (X,Y) from the Probe Measurement option menu. Follow
the instructions in the Instruction area of the main window to select a

point. Now select a different point. Notice how the probe information
is displayed in the Information area of the main window. However,

nothing is entered into the Probe Table until you press the right mouse
button. Now enter the location into the Probe Table by pressing the

right mouse button.

Length

You will next make a measurement of normalized length:

• Change the Probe Measurement to Length.

• You are currently able to choose points from all objects. Now change
the Point Selection Method by selecting Current Object from that option
menu. This win limit the points which may be selected to those on the
current object only.

• Click on the Normalize check box to measure normalized length. This
will normalize all measurements by dividing them by the chord length,
which in this case is 8.000225.

• Type the string "T,_. circ racl" into the Label text field, indicating that
this will be a measurement of the radius of the circle inscribed in the

leading edge of the airfoil. This label will be entered into the Probe
Table when you enter the measurement.

• Follow the instructions to select two endpoints: one being the leading
edge of the airfoil, the other being the center of the leading edge circle
(both marked in purple crosses). Enter the measurement into the
Probe Table. Note that if the reference airfoil is not highlighted, you
will not be able to select these two points.

Glyphs

You will have noticed that after measurements are entered into the Probe

Table, symbols (or glyphs) such as points and lines are overlaid on the
geometry to indicate where the measurements were made. You may want
to turn off the display of these glyphs by selecting from the main menu:
Probe->Display Glyphs.
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Ate length

Arc length measures the sum of the lengths of the line segments along a
boundary between two points on that boundary.

• Set the Probe Measurement to Arc Length, and turn Normalize off.

• Select the two endpoints: one being the leading edge of the reference
airfoil, the other being the location where the ice attaches to the airfoil

at the upper surface.

• Change the Label to "ice limit", and enter the measurement into the
Probe Table.

To measure an angle, you will need to mark two lines between which the
angle will be measured. Normalizing this measurement has no effect.

• Set the Probe Measurement to Angle.

• Following the instructions in the Instruction area, set the endpoints of

the first line: the center of the leading edge circle and the leading edge
point itself.

• For the second line, set the first endpoint to again be the center of the

leading edge circle. For the second endpoint, set the Point Selection
Method to All Objects, and select the tip of the uppermost ice horn.

• Change the Label to "upper horn", and enter the measurement into
the Probe Table.

Figure 29. Left: highlighted reference airfoil with markers at leading edge and
center of leading edge circle; Right: glyphs marking measurements of
location, length, arc length, angle, and (X-XIe)/C.
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(X-Xle)IC

This measurement calculates the value (X-Xle)/C, where x is the

x-location of the point selected, Xle is the x-location of the leading edge,
and c is the chord length of the reference airfoil.

• Set the Probe Measurement to (X-XIe)/C.

• Set the Label to "ice tip", select the point on the tip of the uppermost
ice horn, and enter the measurement into the Probe Table.

Comment

Label Point Selection Method: Probe Measurement: (:hoed Length

Normalize

Label X V Length Arc bsngth _gle (X-_de)lC Factor

._ -4.8040e-02 9.9180e-02 |!|

LE clrc r_d 1.0156e-02 8.0002e+00 |_|

Ice licit l.B41Be-Ol |![

i upper horn -72.2 'I! I

Ice tip 1.52_8e-03 8.0002e*00

..................................................................................................................................b!!

Figure30. Ice Shape Characteristics window with entries in the Probe Table.

Save probe information

At this point, you may want to save the probe information to a file.

• In the Ice Shape Characteristics window, press the [Save..]. button. This
will bring up a subwlndow which will allow you to save the Probe Table
to a text file.

• You may also save a screen image of the geometry with the lines and
points of your measurements displayed. First turn glyph display back
on by selecting Probe->Display Glyphs from the main menu, then select
F_le->Screen Save .... You may choose to save the image as a TIFF, GIF,
or PPM image file.

• To clear the Probe Table and all associated glyphs, press the [Clear All]

button in the Ice Shape Characteristics window.
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