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Foreword
Thank you for purchasing the Xviewer (Model 701992/701994) waveform viewer

software.
This User’s Manual contains information on the functions and operation of Xviewer, as
well as precautions that must be observed.  This manual mainly focuses on operation

under Windows XP.  To ensure the correct operation of Xviewer, read this manual
thoroughly before attempting to use the product.
Keep this manual at hand for quick reference and to answer any questions you may

have about the software’s operation.
For information on the functions and operation of the DL series products, precautions to
be observed, or the operation of Windows, refer to their respective manuals.

Notes
• The contents of this manual are subject to change without prior notice due to

performance/functional improvements to the software or related products.  The
images appearing in this manual are for illustrative purposes only and may differ
slightly from the screens that actually appear on your machine.

• Every effort has been made in the preparation of this manual to ensure the accuracy
of its contents.  However, should you have any questions or find any errors, contact
your nearest Yokogawa dealer.

Trademarks
• Microsoft, MS-DOS, Windows, Windows NT, Windows 2000, and Windows XP are

either registered trademarks or trademarks of Microsoft Corporation in the United
States and/or other countries.

• Adobe and Adobe Acrobat are trademarks of Adobe Systems Incorporated.

• Zip is a registered trademark or trademark of Iomega Corporation in the United States
and/or other countries.

• In this manual, the TM and ® symbols do not accompany their respective trademark

names or registered trademark names.
• Other company names and product names are trademarks or registered trademarks

of their respective holders.

Revisions
• January 2005 1st edition issued

• July 2005 2nd edition issued
• October 2005 3rd edition issued

3rd Edition : October 2005 (YK)

All Rights Reserved, Copyright © 2005 Yokogawa Electric Corporation
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Terms and Conditions of the Software License

Yokogawa Electric Corporation, a Japanese corporation (hereinafter called “Yokogawa”), grants permission to use this Yokogawa Software
Program (hereinafter called the “Licensed Software”) to the Licensee  on the conditions that the Licensee agrees to the terms and conditions
stipulated in Article 1 hereof.
You, as the Licensee (hereinafter called “Licensee”), shall agree to the following terms and conditions for the software license (hereinafter called
the “Agreement”) based on the use intended for the Licensed Software.
Please note that Yokogawa grants the Licensee permission to use the Licensed Software under the terms and conditions herein and in no event
shall Yokogawa intend to sell or transfer the Licensed Software to the Licensee.
Licensed Software Name: Xviewer (Model 701992 and 701994)
Number of License: The number of licenses printed on the license seal

Article 1 (Scope Covered by these Terms and Conditions)
1.1 The terms and conditions stipulated herein shall be applied to any Licensee who purchases the Licensed Software on the condition that the

Licensee consents to agree to the terms and conditions stipulated herein.
1.2 The “Licensed Software” herein shall mean and include all applicable programs and documentation, without limitation, all proprietary

technology, algorithms, and know-how such as a factor, invariant or process contained therein.

Article 2 (Grant of License)
2.1 Yokogawa grants the Licensee, for the purpose of single use, non-exclusive and non-transferable license of the Licensed Software with the

license fee separately agreed upon by both parties.
2.2 The Licensee is, unless otherwise agreed in writing by Yokogawa, not entitled to copy, change, sell, distribute, transfer, or sublicense the

Licensed Software.
2.3 The Licensed Software shall not be copied in whole or in part except for keeping one (1) copy for back-up purposes.  The Licensee shall

secure or supervise the copy of the Licensed Software by the Licensee itself with great, strict, and due care.
2.4 In no event shall the Licensee dump, reverse assemble, reverse compile, or reverse engineer the Licensed Software so that the Licensee

may translate the Licensed Software into other programs or change it into a man-readable form from the source code of the Licensed
Software.  Unless otherwise separately agreed by Yokogawa, Yokogawa shall not provide the Licensee the source code for the Licensed
Software.

2.5 The Licensed Software and its related documentation shall be the proprietary property or trade secret of Yokogawa or a third party which
grants Yokogawa the rights.  In no event shall the Licensee be transferred, leased, sublicensed, or assigned any rights relating to the
Licensed Software.

2.6 Yokogawa may use or add copy protection in or onto the Licensed Software.  In no event shall the Licensee remove or attempt to remove
such copy protection.

2.7 The Licensed Software may include a software program licensed for re-use by a third party (hereinafter called “Third Party Software”, which
may include any software program from affiliates of Yokogawa made or coded by themselves.)  In the case that Yokogawa is granted
permission to sublicense to third parties by any licensors (sub-licensor) of the Third Party Software pursuant to different terms and conditions
than those stipulated in this Agreement, the Licensee shall observe such terms and conditions of which Yokogawa notifies the Licensee in
writing separately.

2.8 In no event shall the Licensee modify, remove or delete a copyright notice of Yokogawa and its licenser contained in the Licensed Software,
including any copy thereof.

Article 3 (Restriction of Specific Use)
3.1 The Licensed Software shall not be intended specifically to be designed, developed, constructed, manufactured, distributed or maintained for

the purpose of the following events:
a) Operation of any aviation, vessel, or support of those operations from the ground;,
b) Operation of nuclear products and/or facilities;,
c) Operation of nuclear weapons and/or chemical weapons and/or biological weapons; or
d) Operation of medical instrumentation directly utilized for humankind or the human body.

3.2 Even if the Licensee uses the Licensed Software for the purposes in the preceding Paragraph 3.1, Yokogawa has no liability to or responsibil-
ity for any demand or damage arising out of the use or operations of the Licensed Software, and the Licensee agrees, on its own responsibil-
ity, to solve and settle the claims and damages and to defend, indemnify or hold Yokogawa totally harmless, from or against any liabilities,
losses, damages and expenses (including fees for recalling the Products and reasonable attorney’s fees and court costs), or claims arising
out of and related to the above-said claims and damages.

Article 4 (Warranty)
4.1 The Licensee shall agree that the Licensed Software shall be provided to the Licensee on an “as is” basis when delivered.  If defect(s), such

as damage to the medium of the Licensed Software, attributable to Yokogawa is found, Yokogawa agrees to replace, free of charge, any
Licensed Software on condition that the defective Licensed Software shall be returned to Yokogawa’s specified authorized service facility
within seven (7) days after opening the Package at the Licensee’s expense.  As the Licensed Software is provided to the Licensee on an “as
is” basis when delivered, in no event shall Yokogawa warrant that any information on or in the Licensed Software, including without limitation,
data on computer programs and program listings, be completely accurate, correct, reliable, or the most updated.

4.2 Notwithstanding the preceding Paragraph 4.1, when third party software is included in the Licensed Software, the warranty period and terms
and conditions that apply shall be those established by the provider of the third party software.

4.3 When Yokogawa decides in its own judgement that it is necessary, Yokogawa may from time to time provide the Licensee with Revision
upgrades and Version upgrades separately specified by Yokogawa (hereinafter called “Updates”).

4.4 Notwithstanding the preceding Paragraph 4.3, in no event shall Yokogawa provide Updates where the Licensee or any third party conducted
renovation or improvement of the Licensed Software.

4.5 THE FOREGOING WARRANTIES ARE EXCLUSIVE AND IN LIEU OF ALL OTHER WARRANTIES OF QUALITY AND PERFORMANCE,
WRITTEN, ORAL, OR IMPLIED, AND ALL OTHER WARRANTIES INCLUDING ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR
FITNESS FOR A PARTICULAR PURPOSE ARE HEREBY DISCLAIMED BY YOKOGAWA AND ALL THIRD PARTIES LICENSING THIRD
PARTY SOFTWARE TO YOKOGAWA.

4.6 Correction of nonconformity in the manner and for the period of time provided above shall be the Licensee’s sole and exclusive remedy for
any failure of Yokogawa to comply with its obligations and shall constitute fulfillment of all liabilities of Yokogawa and any third party licensing
the Third Party Software to Yokogawa (including any liability for direct, indirect, special, incidental or consequential damages) whether in
warranty, contract, tort (including negligence but excluding willful conduct or gross negligence by Yokogawa) or otherwise with respect to or
arising out of the use of the Licensed Software.
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Article 5 (Infringement)
5.1 If and when any third party should demand injunction, initiate a law suit, or demand compensation for damages against the Licensee under

patent right (including utility model right, design patent, and trade mark), copy right, and any other rights relating to any of the Licensed
Software, the Licensee shall notify Yokogawa in writing to that effect without delay.

5.2 In the case of the preceding Paragraph 5.1, the Licensee shall assign to Yokogawa all of the rights to defend the Licensee and to negotiate
with the claiming party.  Furthermore, the Licensee shall provide Yokogawa with necessary information or any other assistance for
Yokogawa’s defense and negotiation.  If and when such a claim should be attributable to Yokogawa, subject to the written notice to
Yokogawa stated in the preceding Paragraph 5.1, Yokogawa shall defend the Licensee and negotiate with the claiming party at Yokogawa’s
cost and expense and be responsible for the final settlement or judgment granted to the claiming party in the preceding Paragraph 5.1.

5.3 When any assertion or allegation of the infringement of the third party’s rights defined in Paragraph 5.1 is made, or when at Yokogawa’s
judgment there is possibility of such assertion or allegation, Yokogawa will, at its own discretion, take any of the following countermeasures at
Yokogawa’s cost and expense.
a) To acquire the necessary right from a third party which has lawful ownership of the right so that the Licensee will be able to continue to use

the Licensed Software;
b) To replace the Licensed Software with an alternative one which avoids the infringement; or
c) To remodel the Licensed Software so that the Licensed Software can avoid the infringement of such third party’s right.

5.4 If and when Yokogawa fails to take either of the countermeasures as set forth in the preceding subparagraphs of Paragraph 5.3, Yokogawa
shall indemnify the Licensee only by paying back the price amount of the Licensed Software which Yokogawa has received from the
Licensee.  THE FOREGOING PARAGRAPHS STATE THE ENTIRE LIABILITY OF YOKOGAWA AND ANY THIRD PARTY LICENSING
THIRD PARTY SOFTWARE TO YOKOGAWA WITH RESPECT TO INFRINGEMENT OF THE INTELLECTUAL PROPERTY RIGHTS
INCLUDING BUT NOT LIMITED TO, PATENT AND COPYRIGHT.

Article 6 (Liabilities)
6.1 If and when the Licensee should incur any damage relating to or arising out of the Licensed Software or service that Yokogawa has provided

to the Licensee under the conditions herein due to a reason attributable to Yokogawa, Yokogawa shall take actions in accordance with this
Agreement.  However, in no event shall Yokogawa be liable or responsible for any special, incidental, consequential and/or indirect damage,
whether in contract, warranty, tort, negligence, strict liability, or otherwise, including, without limitation, loss of operational profit or revenue,
loss of use of the Licensed Software, or any associated products or equipment, cost of capital, loss or cost of interruption of the Licensee’s
business, substitute equipment, facilities or services, downtime costs, delays, and loss of business information, or claims of customers of
Licensee or other third parties for such or other damages. Even if Yokogawa is liable or responsible for the damages attributable to Yokogawa
and to the extent of this Article 6, Yokogawa’s liability for the Licensee’s damage shall not exceed the price amount of the Licensed Software
or service fee which Yokogawa has received.  Please note that Yokogawa shall be released or discharged from part or all of the liability under
this Agreement if the Licensee modifies, remodels, combines with other software or products, or causes any deviation from the basic
specifications or functional specifications, without Yokogawa’s prior written consent.

6.2 All causes of action against Yokogawa arising out of or relating to this Agreement or the performance or breach hereof shall expire unless
Yokogawa is notified of the claim within one (1) year of its occurrence.

6.3 In no event, regardless of cause, shall Yokogawa assume responsibility for or be liable for penalties or penalty clauses in any contracts
between the Licensee and its customers.

Article 7 (Limit of Export)
Unless otherwise agreed by Yokogawa, the Licensee shall not directly or indirectly export or transfer the Licensed Software to any countries other
than those where Yokogawa permits export in advance.

Article 8 (Term)
This Agreement shall become effective on the date when the Licensee receives the Licensed Software and continues in effect unless or until
terminated as provided herein, or the Licensee ceases using the Licensed Software by itself or with Yokogawa’s thirty (30) days prior written notice
to the Licensee.

Article 9 (Injunction for Use)
During the term of this Agreement, Yokogawa may, at its own discretion, demand injunction against the Licensee in case that Yokogawa deems
that the Licensed Software is used improperly or under severer environments other than those where Yokogawa has first approved, or any other
condition which Yokogawa may not permit.

Article 10 (Termination)
Yokogawa, at its sole discretion, may terminate this Agreement without any notice or reminder to the Licensee if the Licensee violates or fails to
perform this Agreement.  However, Articles 5, 6, and 11 shall survive even after the termination.

Article 11 (Jurisdiction)
Any dispute, controversies, or differences between the parties hereto as to interpretation or execution of this Agreement shall be resolved
amicably through negotiation between the parties upon the basis of mutual trust.  Should the parties fail to agree within ninety (90) days after
notice from one of the parties to the other, both parties hereby irrevocably submit to the exclusive jurisdiction of the Tokyo District Court (main
office) in Japan for settlement of the dispute.

Article 12 (Governing Law)
This Agreement shall be governed by and construed in accordance with the laws of Japan. The Licensee expressly agrees to waive absolutely
and irrevocably and to the fullest extent permissible under applicable law any rights against the laws of Japan which it may have pursuant to the
Licensee’s local law.

Article 13 (Severability)
In the event that any provision hereof is declared or found to be illegal by any court or tribunal of competent jurisdiction, such provision shall be
null and void with respect to the jurisdiction of that court or tribunal and all the remaining provisions hereof shall remain in full force and effect.
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Product Overview

Waveform Viewer Xviewer
Viewing and Analyzing Data Saved with the DL Series
Xviewer allows you to view and analyze waveform data that has been obtained and
saved using either the DL series* or WE7000.

* DL750 series, DL9000 series, DL7400 series, DL1700 series, DL1700E series, and DL1600 series

File Types Handled by Xviewer

• Files created with the DL series or WE7000 and saved in binary format (.wvf files)
or ASCII format (.csv files)

• Files created with real-time recording by the DL750 series (.wdf files)

• Data measured on the DL9000 series and saved in binary format (.wdf files)

Viewing and Transferring DL Series Files
Xviewer supports the viewing of DL750 series/DL1600/DL1700E/DL7400 series files as
well as the transfer of files between the DL unit and your PC by using the GP-IB/USB/
Ethernet interface.

Note
Xviewer file transfer from your PC to a DL unit is possible only via the USB interface.

Remote Control of the DL Series
With the GP-IB/USB/Ethernet interface, Xviewer supports the display of images (control
windows) from a DL series* unit on your PC, as well as the remote-control of the DL unit
as if you were operating the unit from its own control panel.  In addition, to enable the

setup of a control window environment, Xviewer features Environment Setting Keys,
which are not found on the DL unit.

* DL750 series, DL7400 series, DL1700 series, DL1700E series, DL1600 series, and DL9000
series

Downloading DL Series Acquisition Data
The DL750 series, DL1600 series, DL1700E series, and DL7400 series acquisition data
can be downloaded to a PC using the GP-IB, USB, or Ethernet interface.
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System Environment Requirements
PC Hardware
Xviewer requires a PC running Windows 2000 (Service Pack 4 and later) or Windows XP
(Service Pack 1 and later) and a Pentium 3 CPU running at 1 GHz or better, and at least

256 MB of memory (512 MB recommended).

Operating System (OS)
Xviewer requires Windows 2000 (Service Pack 4 and later) or Windows XP (Service
Pack 1 and later).
To use the USB interface, Xviewer requires that the USB driver for the DL series be

installed.

CD-ROM Drive
A CD-ROM drive is required to install this software.

Display, Printer, and Mouse
Display : XGA or higher
Colors : 65536 or more
The display must be supported by Windows 2000 (Service Pack 4 and later) or Windows

XP (Service Pack 1 and later).

GP-IB Board or PCMCIA Card (for Communication Through GP-IB Interface)
The PC must have a GP-IB board (made by National Instruments Corporation) installed,
or a PCMCIA card.  However, the operation of the PCMCIA-GPIB card is not guaranteed
on Windows XP.

Package Contents
After opening the package, check that it contains the items listed below.  If any of the
contents are incorrect, missing, or damaged, contact the dealer from whom you

purchased it.

CD-ROM
Xviewer
Model : 701992 (standard Xviewer)
Model : 701994 (upgraded version of 700919)

Manual
Xviewer User’s Manual

License seal × 1
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Important Notice

Keep the Original CD-ROM Safe
Keep the original Xviewer CD-ROM in a safe place.  Normally, the software should be

installed onto and run from a hard drive.

Precautions on the Use of Xviewer
• When you are using Xviewer, do not attempt to manipulate the DL series units

connected to it; the units may malfunction.
• Xviewer may be unable to operate if the PC goes into standby mode.  Disable

standby mode on your PC before starting up Xviewer.
• Whenever you operate Xviewer via the Ethernet interface, the Ethernet connection

will usually be handling no more than 400 Kbytes/s although this may occasionally

rise to 1 Mbyte/s.  Check with your network administrator as to whether these traffic
loads can be handled by your network.

• Do not attempt to use Xviewer to alter the network or communication settings of the

connected DL series units.  Doing so may lead to a communication failure between
the DL series units.

• Do not attempt any self-tests with Xviewer.

• One Xviewer instance can control only one DL series unit.  In addition, multiple PCs
cannot be connected to a single DL series unit.

• Xviewer does not support the thumbnail previews offered by the DL1600/DL1700E

series.  Also, Xviewer does not support the thumbnails or previews offered by the
DL7400 series.

• In the event of a connection error with a DL series unit, power off the DL unit, and

then turn it on again.
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Installing/Uninstalling Xviewer

Operations
Installing Xviewer

The steps below assume the use of Windows XP.
1. Turn on your PC, log on with the Administrator account, then wait for Windows

to start up.

2. Place the Xviewer CD-ROM in the PC’s CD-ROM drive.  The Xviewer Installer
starts automatically and begins to prepare the installation.

3. Follow the displayed instructions and then click Next.
4. The Agreements screen is displayed and prompts you to indicate whether you

agree with the conditions of use for the software.  Once you have read and
agreed to the conditions of use, place a check mark against I Agree with the
Conditions of Use and then click Next.

5. A screen for entering user information is displayed.  Enter the User Name,
Organization, and License Number, specify the users who will be allowed to

use Xviewer, and then click Next.  The license number can be found on a label
applied to the outside of the CD-ROM case.

Enter the license 
number printed on 
the installation disk 
package

Place a checkmark in this box to grant access only 
to the logged-in user who has installed Xviewer

6. A product information screen is displayed.  Click Next.
701992:
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701994:

 Note
• When you install 701994, the default folder for installation of 700919 is displayed.  If

700919 has not been installed in its default folder, specify the folder with 700919 installed.
• If the folder containing 700919 cannot be found, an error message will appear.  Input the

folder into which 700919 was installed.

7. The installation folder screen is displayed.  The default setting is C:\Program
Files\Yokogawa\Xviewer.  To specify a different installation folder, click Browse.
After specifying the installation folder, click Next.

8. The installation start screen is displayed.  Click Install to start installing Xviewer.
To change the installation settings, click Back.  To abandon the installation,

click Cancel.
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9. The Installer starts the installation of Xviewer.  Once the Installer has
successfully completed the installation of Xviewer, the following screen is

displayed:

10. Click Finish to close the Installer.  A Yokogawa > Xviewer selection will be
available when you click Start > Programs and a shortcut icon to Xviewer will

appear on the desktop.

Uninstalling Xviewer
The steps below assume the use of Windows XP.

1. Select Control Panel from the Start menu.
2. Double-click Add/Remove Programs on Control Panel.
3. Select Xviewer in the list displayed for Add/Remove Programs, and then click

Remove.
4. A screen appears asking you to confirm whether you want to delete Xviewer.

Click Yes to proceed.  Click No to cancel.

5. Xviewer is removed from your PC.

Explanation
USB Driver
To establish a USB connection with the DL series unit, Xviewer requires that the USB
driver be installed for that DL series unit.  The USB driver is included in the Xviewer

installation disk.  The most-recent USB driver can be downloaded from the following
Web page.
http://www.yokogawa.com/tm/tm-softdownload.htm

• Contents of the Installation Disc
The following two USB drivers for DL series instruments are included.  Please install
the USB driver for the DL series instrument you will be using.

• ykusb: For the DL1600/DL1700E/DL7400/DL7500 series
• ykUSBTMC: For the DL9000 series

Folder in which the 
USB driver for the 
DL series resides

Folder in which the USB driver for the DL series 
(other than the DL9000 series) resides

Manual containing installation instructions

Manual containing installation instructions
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Specifications

System Environment

CPU Pentium 3, 1 GHz or better
Memory 256 MB or more (512 MB recommended)
Space available on HDD 40 MB or more

PC Hardware

Display XGA or higher (Colors:  65536 or more)
Drive CD-ROM drive
Communication interface GP-IB/USB/Ethernet
GP-IB Board or PCMCIA Card GP-IB board made by National Instruments 
 Corporation or PCMCIA card
Sound capabilities Required to play back voice memos.

Peripherals

 Microsoft Windows 2000 (Service Pack 4 and later) or 
 Windows XP (Service Pack 1 and later)

Operating System

Applicable Models and Features

 Models from which Xviewer can load waveform data:

DL750 series, DL9000 series, DL7400 series, DL1700 series, DL1700E series, DL1600

series, and WE7000

 Models for which Xviewer can view, transfer and remote-control files:

DL750 series, DL7400 series, DL1700E series, and DL1600 series, DL9000 series*
* Only remote control possible

 File Types Supported by Xviewer

• Files created by the DL series or WE7000 and saved in either binary format (.wvf
files) or ASCII format (.csv files)

• Files of data created with real-time recording on the DL750 series (.wdf files)

• Data measured on the DL9000 series and saved in binary format (.wdf files)

 Models on which acquisition data can be downloaded

DL750 series (firmware version 6.01 or later)
DL1600 series (firmware version 1.30 or later)

DL1700E series (firmware version 2.11 or later)
DL7400 series (firmware version 2.11 or later)

 Available Functions

• Main waveform view, zoom waveform view, history waveform view, X-Y waveform

view, and measurement result view
• Measurements with vertical/horizontal/X-Y cursors
• Waveform parameter automatic measurement/computational measurement (optional)

• Data conversion (CSV)
• Saving and printing of measurement data
• Play back of voice memos saved with the DL750 series

• Viewing and transfer of remote files
• Remote control of the DL series
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Required Amount of Memory (Bytes)
60 Mbytes + (280 Kbytes + 40 Kbytes × (number of blocks +1)) × number of channels ×
(No.  of channels × No.  of blocks + No.  of points for computation × No.  of computation
channels × No.  of blocks) × 4

Note
If the Font size in Windows Display Properties is set to Large, Xviewer does not display the
characters properly.  Make sure to set the Font size to Normal (default setting) when using
Xviewer.

Specifications
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Functions Described in This Manual and the
Software Version

The contents of this manual describe Xviewer software version 1.20 or later.  The table
below shows the software versions and the corresponding added functions.  If the
software is not of the newest version, you will not be able to use all the functions covered

in this manual.  Check the software version on the version information screen that
appears by selecting Help > Version.  For details on the procedure, see section 8.2.

Software Versions and the Main Functions That Have Been Added

Version Added Function Applicable Models Reference Page/
Section/Chapter

1.10 or later Support for DL9000*1 DL9000 Series Page xi

ACQ save function DL750/DL1600 Series*2 Section 7.4
(Downloads the DL acquisition data to the PC)

Log scale – Page 3-5, section 3.4
(Set vertical and horizontal axes when displaying
the FFT waveform)

Display the range over which FFT is performed All models*3 Section 4.4
and set the start position

Display the computation start position marker All models*3 Page 4-11
 and set the start position

Analyze waveform data using H&V cursors All models*3 Section 4.2

File associations (wvf and wdf) – Page 1-1
(Double-click the file to start Xviewer)

Drag and drop CSV files on the viewer window – Page 2-3

Restore the waveform color and the number of DL750/DL9000 Series –
divided displays when the file is loaded

1.20 or later Supports the DL9000*4 DL9000 Page xi, section 7.5

ACQ save function DL1700E/DL7400 series*5 Section 7.4
(Downloads the DL acquisition data to the PC)

Copying of cursor/waveform parameter - Sections 4.2/4.3
measurement results to the clipboard

Automatic display of the measurement results - Section 4.1
window

Restored when loading waveform color, number DL1600/DL1700E/ -
of display divisions, and vertical axis upper and DL7400 series
lower limit values

Arrange Controller window/Xviewer tool - Section 1.2
bar/Viewer window

Displays T/Div and V/Div on the waveform - Section 3.4
display window

*1 Waveform data (wdf file) can be loaded.
*2 Supported on version 1.30 or later on the DL1600 Series and version 6.01 or later on the DL750 Series.
*3 DL750 Series, DL9000 Series, DL7400 Series, DL1700 Series, DL1700E Series, DL1600 Series, and WE7000.
*4 Only remote control possible
*5 DL1700E series: Version 2.11 or later, DL7400 series: version 2.11 or later
*6 With the DL750 series, even if you load files that were saved with P-P Com ON in the Save As dialog box, the Upper/Lower,

colors, and number of screen divisions are not restored.
*7 With the DL1600 series, even if you load files that were saved with Invert ON in the channel settings, the Invert information

is not restored.
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1.1 Starting and Closing Xviewer

Operations
Starting Xviewer
From the Windows Start menu, select Programs > Yokogawa > Xviewer.  Xviewer

starts up and displays the Xviewer toolbar, controller window, and viewer window, as
shown below:

Xviewer toolbar

Controller window Viewer window

Closing Xviewer
Select File > Close Xviewer from the Xviewer toolbar.

Note
If the extension of the waveform data files is as follows, you can double-click the file to start
Xviewer and display the waveform on the viewer.
• wvf
• wdf

Chapter 1   Basic Operations
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1.2 Basic Operations Performed From the Startup
Windows

Operations
Xviewer toolbar:
Used to manipulate the controller window and viewer windows and to control the
connection with the DL series unit.

Controller window:
Used to make one of the displayed viewer windows active.

Viewer window:
Used to load, display, and analyze waveform data.  Multiple viewer windows can be

displayed and used to load, display, and analyze waveform data in the respective viewer
windows.

Displays or hides the controller window
Control viewer windows

New Viewer : Opens a new viewer window
Close : Closes all the displayed viewer windows
Arrange : Arranges the displayed viewer windows into order

Control connection with the DL series unit

About the Xviewer version
Xviewer toolbar

Active viewer window

Viewer window

Loads a waveform data file
Controller Window

Clicking an icon makes the associated viewer window active Double-clicking it 
maximizes the window

CommSetting : Allows the specification of the settings for 
communicating with a DL series unit

Open DL : Makes a connection with a DL series unit to 
display and transfer files

DL Control :  Makes a connection with a DL series unit and 
displays a window for handling the target DL 
series unit

ACQ save       : Downloads the DL series acquisition data to  
the PC
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Explanation
Types of Viewer Window
There are five types of viewer window:
• Main waveform display window:  Displays all of the loaded waveform data.
• Zoom waveform display window:  Zooms the loaded waveform data.

• History waveform display window:  Displays all the waveform data records
obtained by means of sequential store, single (N) trigger mode, and/or history feature.

• X-Y waveform display window:  Plots a channel (trace) in the main/zoom window as

an X-Y view.
• Measurement result display window:  Measured values such as cursor

measurements, automatic measurements, and measurements through computation

are displayed as numerical values.

Main waveform display window History waveform display window

Measurement result 
display window

Zoom waveform display window X-Y waveform display window

Resizable Windows
By dragging the borders of the Xviewer tool bar, control window, and viewer window,
you can change the size of the window arbitrarily.
Click Arrange on the tool bar to adjust the size of the Viewer window according to that of

the Xviewer tool bar and control window.

1.2  Basic Operations Performed From the Startup Windows
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2.1 Loading Waveform Data

Operations
1. Click  or select File > Open.  The Open File dialog box appears.

2. To display a waveform, either select the file to open from the File name field, or
enter the name of the file and then click Open.   Or, drag the file that you want
to open and drop it onto the Viewer window.

Chapter 2   Displaying Waveform Data
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When opening a file with comments:
With the DL series, when you open a file that has been saved with comments, those

comments appear in the Comment field of the dialog box.

Comments are displayed here

When opening a file with voice memos:
With the DL750 series, when you open a file that has been saved with voice memos,
those voice memos can be played back.

Play back the selected voice memo

Selecting a file that 
has been saved with 
voice memos makes 
this pull-down menu 
active   

Voice memos 
selectable

Stop playback of the selected voice 
memo

Note
If your PC does not have audio capabilities, the Play and Stop buttons are grayed out.

2.1  Loading Waveform Data
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Explanation
Types of Files You Can Open with Xviewer
• Measured waveform files saved on the DL series or WE7000 (.wvf or .CSV files)
• Files saved with the real-time recording feature of DL750 series (.wdf files)
• Display setting files saved with Xviewer (.xml files)

Note
• To open a file, an .hdr file having the same name as the file you are trying to open must be

placed in the same folder.
• Xviewer cannot simultaneously display waveforms that are captured with different

measurement intervals, memory partitions (blocks), trigger points, or other conditions.  If
you attempt to load a file with waveforms that were measured under different conditions,
an error message is displayed and the file is not loaded into Xviewer.

• Xviewer cannot simultaneously display the channels of waveforms measured with different
sampling intervals, record lengths, or other conditions.  If you attempt to load a file with
waveforms that were measured under different conditions, an error message is displayed
and the file is not loaded into Xviewer.

• Xviewer cannot load files with a trace name that includes a space.  To load such a file, first
replace the spaces in TraceName in the header file (.hdr file) with underscores (_) or other
characters.

• An error may occur if the DL750.dll file is not of the latest version.  The latest version of
DL750.dll can be downloaded from (www.yokogawa.com/tm/700919).
Access the web site as described in Section 8.3 or directly enter the URL into your
browser.  Place DL750.dll in the Xviewer installation folder.

• Note that files containing more than 2G points cannot be handled.

Loading Multiple Files
A new Viewer window can be opened either by clicking the  button or selecting

Window > Viewer.  Multiple Viewer windows can be open at the same time, allowing you
to read and display the contents of multiple files.  When multiple Viewer windows are
being displayed, you can tile them by clicking the  button or selecting Window > Tile.

Open a new viewer window
Tile the displayed viewer windows

Files that can be dragged
The files with the following extensions can be dragged from the load source window onto
the viewer window.

• wvf
• wdf
• csv

2.1  Loading Waveform Data
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Setting Options for Loading Files
Click the More Options button to specify supplementary options for loading a file after

selecting that file.

Show or hide loading 
options

Prevent all waveform 
data from being 
loaded

Uncheck the box for 
loading waveform 
data, keeping the 
current waveform 
data displayed

List of waveforms in the selected file

Check the boxes corresponding to 
the waveform data that you want to 
load into the viewer Uncheck the box for loading new waveform 

data, keeping the current Y-axis scale 
unchanged

Loading Sequentially Numbered Files
Click either of the buttons shown below to load and display sequentially numbered files

in the folder containing the file you are currently viewing, switching the files in ascending
or descending order of file numbers.

Switches to the file whose name (number) is decremented by one
 (i.e., 0002.wvf   0001.wvf   0000.wvf)

Switches to the file whose name (number) is incremented by one
 (i.e., 0000.wvf   0001.wvf   0002.wvf)

Loading Files in DL Units
You can directly reference and load waveform data files saved into the media of the DL
units and which are connected to Xviewer.  For details, see Section 7.3.

2.1  Loading Waveform Data
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2.2 Displaying Waveforms in the Main View

Operations
Displaying Waveforms in the Main View
To display waveforms and measurement results, first open a waveform data file.  To

show or hide the main waveform display window, click the  button or select Window
> Main Window.

Show or hide the main waveform display window
Main waveform display window

Explanation
Details of the Main Waveform Display Window
The main waveform display window provides a global view of the measured waveform

data.

Trace name

Number of the displayed group
Trigger position

Trigger time

Section displayed in zoomed waveform 
display window (enclosed by the bold lines)

Number of points (record length)

Measurement 
interval

Time from a trigger

Scale values
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2.3 Displaying Waveforms in a Zoomed View

Operations
Displaying Waveforms in a Zoomed View
Click the  button or select Window > Zoom Window to display a zoomed view of

the section enclosed by the bold lines in the main waveform display window.

Setting the Zoom Factor
To increase or reduce the zoom factor, click the  (Zoom-In) or  (Zoom-Out) button.

Double-click to show the Display Setting dialog

Zoom-Out
Zoom-In

Show or hide the zoomed waveform display window

The section of the waveform enclosed by bold lines is 
displayed in the zoomed view

Number of points 
displayed

Select the number of points to be displayed

Drag to move the section to zoom

Moving the Zoomed-In Section
You can move the section to zoom by:

• Dragging the bold line
You can drag the bold line in the main waveform display window to move the

section to zoom.  Use the arrow buttons to move it automatically.
• Designating a point in the Display Setting dialog

You can double-click the bottom of the zoomed waveform display window to show

the Display Setting dialog in which you can designate a point at which to start the
zoomed section display.  Click OK to apply the point.

• Dragging the scroll bar
You can drag the scroll bar at the bottom of the zoomed waveform display window
to move the section to zoom.
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Scrolling Zoomed Waveforms
• Arrow Buttons

To scroll the zoomed waveforms, click the arrow button corresponding to the
direction in which you want to scroll.  The zoomed waveform view scrolls at the rate
specified on the control bar.

• Stop button
To stop scrolling, click the  button.
To resume scrolling, click the arrow button again.

Note
Once the scrolled view reaches the rightmost or leftmost end, click  to stop scrolling.

Select the scrolling direction or stop scrolling
Select the scrolling rate

Explanation
Zoom Rate
The maximum zoom rate depends on the data being displayed.  A view with 10 or fewer
points cannot be zoomed.

Scrolling the Zoomed Waveform View
The zoomed waveform view can be scrolled automatically.
Use the following buttons to select the scrolling direction and rate:

• Scrolling direction
: Scrolls to the right
: Scrolls to the left

: Stops scrolling
• Scrolling rate

Set one of the ten scrolling rates, from Slow to Fast.

Designating the Section to be Zoomed
To designate the point at which zooming is to start in the Display Setting dialog box,
specify the value of the leftmost point of the zoomed section that you want to view.  The
values that can be specified vary with the zoom rate and displayed waveforms.
Inputting the number of data points:  Input an integer to start display from that number of

data points.
Inputting a time: In relative time display mode, input a real number to

start display from that time.  At this time, m (10-3),
u (10-6),  n (10-9), and P (10-12) can be used.
(Example)
1.23 → 1.23s
1.23m → 1.23ms
1.23E-3 → 1.23ms
0.00123 → 1.23ms

2.3  Displaying Waveforms in a Zoomed View
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2.4 Displaying Waveforms in the History View

Operations
Displaying Waveforms in the History View
Click the  button or select Window > History Window to open the history waveform
display window.

Changing View Sizes
To change the size of the history waveform view, click the Size button corresponding to
the size that you want to apply to the history waveform display window.

Selecting the History Waveforms to be Displayed
To display all the history waveforms in the main waveform display window, click ON for
ALL.
To display only the active history waveforms in the main waveform display window, click
OFF.
You can place a checkmark in the check box corresponding to individual history
waveform views to select specific history waveform views to be displayed in the main
waveform display window.

Making a History Waveform Active
To make a history waveform active in the main waveform display window, click the
history waveform view.  The history waveform view is enclosed by blue lines and its
history waveform number is highlighted.
When other history waveform views are also displayed, the active history waveform view
appears brighter than the others.

Show or hide the history 
waveform display window

Change the size of the history 
waveform view

Select whether to show all the views 
or only the active view

History waveform 
display window

Active waveform view

Show or hide the waveform view in the main window

Sample of minimum-size views
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Explanation
Data That Can Be Loaded Using the History Waveform Display Window
The history waveform display window can display waveform records saved with the
sequential store, single (N) trigger mode, and/or history waveform handling features of
the DL series.

Note
An error message will appear if there is insufficient memory.
The history waveform display window can handle up to 2,048 waveforms.

Sizes of History Waveform Views
You can select one of three sizes for listing the history waveform views.

ALL ON/OFF
You can select whether to display all the history waveform views listed in the history

waveform display window in the main waveform display window:
ON: Displays all the history waveform views in the main waveform display window.
OFF: Displays only the active history waveform view.

Active History Waveform View
• Cursor measurements can be applied to active history waveforms.

• The waveforms of the active view appear brighter in the main waveform display
window.

• The number of the active view is highlighted in the history waveform display window.

2.4  Displaying Waveforms in the History View
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2.5 Displaying a Waveform in the X-Y View

Operations
Displaying a Waveform in the X-Y View
Click the  button or select Window > X-Y Window to display the X-Y waveform

display window.

Selecting a Waveform to be Displayed in the X-Y view
To see a waveform displayed in the main waveform display window in the X-Y view, click
Main under Range.
To see a waveform displayed in the zoomed waveform display window in the X-Y view,

click Zoom under Range.

Setting the X-Axis
Select a waveform (trace name) to be assigned to the X-axis by using the X-Trace list
box.
All waveforms other than that assigned to the X-axis are allocated to the Y-axis.

Waveform (trace name) assigned
 to the X-axis and its scale

Waveform (trace name) assigned to the Y-axis and
its scale

Show or hide the X-Y waveform
display window

Select a waveform (trace name) to 
be assigned to the X-axis

Select a waveform to 
be displayed in the 
X-Y view

Note
The X-Y waveform display window plots P-P data displayed in the main or zoom waveform
display window into the X-Y view.
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2.6 Moving Waveforms Vertically or Zooming-In/
Out

Operations
Moving a Waveform

1. Click  or select View > Waveform Vertical Move.
2. Using the mouse, drag the waveform you want to move.

Click this before moving a waveform 
Drag a waveform to move it

Zooming Waveforms In or Out
1. Click  or select View > Waveform Vertical Zoom.
2. Move the mouse pointer to the point at which you want to zoom in, and then left-

click;  the view around the clicked point is expanded.  Right-clicking the point
zooms out the surrounding view.

Click on the waveform to be zoomed in or out
Click this before zooming the waveforms in or out
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Explanation
Direction in Which You Can Move/Zoom In or Out
You can move or zoom in/out only in the vertical direction.  You cannot zoom in the
horizontal direction.

Windows You Can Move/Zoom In or Out
You can move or zoom in/out only in the main waveform display window or zoomed
waveform display window.

2.6  Moving Waveforms Vertically or Zooming-In/Out
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2.7 Splitting the Screen

Operations
Splitting Waveforms by a Trace
Click the  button or select View > Split to overlap the waveforms in the main

waveform display window or zoomed waveform display window, splitting them based on
the trace name.

Specified split settings

Turn the split view on or off

View displayed according 
to the split settings for the 
main waveform display 
window

Explanation
Split Settings
The default value for the number of split waveforms depends on the number of
waveforms that are automatically identified by Xviewer, and is used both for the main

waveform display window and zoomed waveform display window.  The default value can
be changed using the split setting dialog.  Using this dialog, you can specify different split
settings for the main waveform display window and zoomed waveform display window or

modify the default split settings.  For details, see Section 3.3.
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2.8 Switching between Groups

Operations
Switching between Groups
When you have already registered groups, you can switch between those groups either

by clicking the  button or  button, or by selecting View > Next Group/Previous
Group.

Number of the group currently being displayed

Switch to the group whose number is one greater 
than that of the current group
Switch to the group whose number is one less than 
that of the current group

Explanation
Measurement Groups
In the Channel Setting dialog box, you can group measurements by trace name.  In
addition, the specified number of channels can be automatically allocated to a single
group.  For details, see Section 3.2.

Note
If there are no groups, the  button and  button are unavailable (no operation even if
they are clicked).
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3.1 Loading Display Settings

Operations
Loading Display Settings
Click  or select File > Open to display the Open File dialog box.  Select Setting info
(*.xml) in Files of type, browse to the folder containing your target file, select the name
of the file you want to open, and then click the Open button.  The display settings are
loaded from the file into the viewer window.

Select Setting info (*.xml)

Select the folder containing your target file

Select the name of the 
file you want to open

Explanation
Application of Display Settings
Loading a Display Setting file already saved applies the display settings in the file to
waveform views.

Chapter 3   Specifying Display Settings for Waveform Data
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3.2 Setting Waveforms (Channels) to be Displayed

Operations
Displaying the Channel Setting Dialog Box
Click the  button or select View > Channel Setting to display the Channel Setting
dialog box.  Using this dialog, you can specify the display and group settings for the
respective channels.

Grouping Channels
You can group the channels (trace names) to be registered.  You can handle waveform
display settings in units of groups.

Select the tab corresponding to the group to be set up
Type in a name for the group

Channels (trace names) registered in the group

Setting Up Channels (Traces)
Set up the channels (traces) for each channel number.  Click a trace name to display the
Channel dialog box, and then select a channel (trace name) from the dialog box.

Specifying whether to Show or Hide Waveforms and Cursor Measurement Values
Specify whether to show or hide the waveform and cursor measurement values for each
channel number.

Setting Scales
Set the scale values for each channel number.

Setting Waveform Colors
Using the color palette, set the waveform colors for each channel number.
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3.2  Setting Waveforms (Channels) to be Displayed

Place a checkmark in the box to specify scale values

Specify whether to show or hide the cursor
measurement values 

Specify whether to show or hide the waveform

Click the name of a trace to be displayed in the Channel dialog box, 
and then select a channel (trace name) from the dialog box

Click to automatically 
set scale values 
according to the 
amplitude

Using the color 
palette, set a color 
for the waveform

Directly input scale values

Select the check box to enable log scale
(only shown when the waveform to be displayed is FFT)

Setting Notational Formats
Click the More Options button to show notational format fields in the expanded dialog
box.  You can specify how numerical values are to be displayed and the number of digits
to be used to indicate a numerical value in the viewer window, as well as specify the

display settings for the logic waveforms in the fields.

Specify how numerical values 
are to be displayed

Specify the number of digits 
to be used to indicate a 
numerical value

Specify the display settings for logic 
waveforms in the Bit Setting dialog
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Explanation
Channel (Trace Name) Settings Shared
Channel (trace name) settings are shared by the main waveform display window and the
zoomed waveform display window.  The cursor measurement value is used as the main
waveform display setting.

To apply different channel settings to each of the windows, remove the checkmark from
Apply Channel Settings in both Main/Zoom, place a checkmark in Main Window or
Zoom Window, and then make the individual channel (trace name) settings.

Number of Groups and Number of Channels (Traces) that Can Be Registered
Xviewer lets you create up to 10 channel (trace name) groups.  You can register up to 90

channels per group.

Setting Items to Copy and Paste
Xviewer lets you copy the settings for a channel (trace) selectively and then paste those
settings to another channel.  After pressing the Copy Item button to display the Select
Copied Items dialog box, you can define the setting items that you want to copy in

advance.  The Select Copied Items dialog box is also displayed when you execute a
paste command, allowing you to remove any unnecessary setting items and paste only
those which are required.

Select the setting items to be copied using the Select Copied Items dialog box

Select Copied Items dialog boxSelect (or deselect) a channel number

Paste the copied setting items to the selected channel
Copy the setting items from the selected channel

3.2  Setting Waveforms (Channels) to be Displayed
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Changing All Settings Together
The Channel Setting dialog box provides buttons that allow you to select and change all

the settings together.

Apply the settings 
for the channel at the 
top of the column to 
the other selected 
channels

Select or deselect all the channels

Turn the settings for all the selected channels on or off together

Restore all the settings for the selected 
channels to their initial values

Notational Format Items
You can specify the following notational format items:
• Format Type: Select Auto Floating Point, or Exponential

Selecting either Floating Point or Exponential causes the following

data to be displayed in the viewer windows, using the selected type of
notation:
Scale Values, Values of Cursor Measurement, and Waveform

Parameters (Amplitude Maximum, Minimum, High Level, Low Level,
Peak to peak value, Average, Middle, RMS, Int1TY, and Int2TY)

• Decimal Point: Specify the number of decimal places to be displayed for both the
floating point and exponential notations.

• Logic: Specify the display settings for the logic waveforms in the Bit Setting
dialog box.

Place a checkmark against those bits that are to be indicated
Select whether to display those waveforms that align only 
with turned-on bits at regular intervals (waveform view 
changed), or those waveforms that align with all the bits 
(waveform view unchanged) if any bits are turned off in the
 dialog box.

Display the logic waveforms using the entire window
Display logic waveforms in the upper half of the window
Display logic waveforms in the lower half of the window

Set the order in which the bits are displayed:
MSB: Displays the bits from the most significant bit
LSB: Displays the bits from the least significant bit

Apply Button for Confirmation
Clicking the Apply button after you have changed the settings applies the previously

specified settings to the window(s) while keeping the display setting screen displayed.

3.2  Setting Waveforms (Channels) to be Displayed
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Note
If you double-click the scale display area of the vertical axis, a channel setting window
(simplified version) appears as shown below.
On this window, you can turn OFF the display or set the scale for channels that have been
turned ON in advance on the channel setting window of page 3-2.

When the displayed waveform is FFT When the displayed waveform is not FFT

3.2  Setting Waveforms (Channels) to be Displayed
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3.3 Specifying Split Settings

Operations
Displaying the Split Settings Dialog box
Click  beside the  button or select View > Split Setting to display the Split
Setting dialog box.

Specifying Split Settings
In the Split Setting dialog box, specify whether to allow the main waveform display
window and zoomed waveform display window to share the split settings and the number
of waveform splits in the respective windows, and  then click OK.  The split settings that

you have specified are applied to the window(s).

Place a checkmark so as to make the main waveform display window and zoomed 
waveform display window share the split settings

Select the number of waveform splits in the main 
waveform display window

Select the number of waveform splits in the zoomed 
waveform display window

Explanation
Number of Waveform Splits that Can Be Specified
For each of the main waveform display window and the zoomed waveform display
window, you can specify Auto or any value between 1 and 16.  Auto sets the number of
waveform splits according to the number of waveforms to be displayed.

Order of Waveform Splits
When the screen is splitted, waveforms are displayed in the order of their channel

numbers, starting from the top of the window.  For details on the channel number
settings, see Section 3.2.

Split Settings for the History Waveform Display Window
Split settings made for the main waveform display window are also applied to the history
waveform display window.
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3.4 Specifying Display Settings

Operations
Displaying the Display Setting dialog box
Click  or select View > Display Setting to open the Display Setting dialog box.
Within the Display Setting dialog box, you can make display settings on the Graticule,
Horizontal Axis, and Colors tabs.

Making a Graticule Setting
Click the Graticule tab in the Display Setting dialog box.  The Graticule pane appears.
Using this pane, you can specify the graticule type and the units of the divisions on the
vertical axis.

Select the vertical 
division units

Select the type of graticule

Shows/Hides the supplementary
scale of the vertical axis 
(selectable only for FFT)

Setting the Horizontal Axis
Click the Horizontal Axis tab in the Display Setting dialog box to display the
Horizontal Axis pane.  Using this pane, you can specify the point at which to start
displaying the zoomed section, as well as the notational format for the horizontal axis.

        

Select the type of the time 
notation to be shown on 
the horizontal scale

Select the number of 
digits to be used for 
the time indication

Relative time:   
Time relative to the trigger 
point

Absolute time:   
Time of the measurement 
(unselectable when the 
duration of measurement 
time is 1 second or less)

Specify the point at which to start 
displaying the zoomed section in the 
zoomed waveform display window

Selects the horizontal scale (selectable only for FFT)       
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Setting the Colors
Click the Colors tab in the Display Setting dialog box to display the Colors pane.  In

this pane, you can specify the colors for the background, graticule, and text using the
color palette.

Changes the color tones (Color Set button)

Sets the background color for the waveforms
Sets the color of the text

Sets the colors of the 
graticule and the divisions

Sets the color of the 
cursors

Sets the background 
color of the windows

Restores the color settings to the defaults

Turning the T/div and V/div Display
Click the Other Information tab of the display settings dialog box to display the ON/OFF
setting screen for the T/div and V/div display.  In this screen, you can turn T/div and V/div
display ON and OFF.

Note
You can also double-click the scale display area of the horizontal axis to open the Display
Setting dialog box.

3.4  Specifying Display Settings
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3.4  Specifying Display Settings

Explanation
Setting the Grid
• Supplementary Grid

The supplementary grid can be selected only when the FFT computation waveform is
displayed.

Auto: Automatically determines whether to display the supplementary scale on the
vertical axis.

ON: Displays the supplementary scale on the vertical axis.

OFF: Does not display the supplementary scale on the vertical axis.

Setting the Horizontal Axis
• Display Format

Sets the time type (relative or absolute) and the number of displayed digits.  However,
the Display Format settings do not appear when the FFT computation waveform is

displayed.
• Zoom Start Position

When relative times are being displayed, the settings vary depending on whether an

integer or a real number is input.
Integer input:  Start data position
Real number input:  Start time (auxiliary units m, n, u , and P can be input.)

• Scale
Set the horizontal scale to LINEAR or LOG.  The horizontal scale can be selected
only when the FFT computation waveform is displayed.

Setting the Color
You cannot change the waveform colors in the Display Setting dialog box.  To

change colors of the waveforms, use the Channel Setting dialog box.  For details,
see Section 3.2.

• Changing the color tone

Clicking the Color Set button makes the appropriate color settings for monochrome
printing.  To restore the color settings, click the Color Set button again.

• INIT.

Initializes the color settings to the default condition.

T/div and V/div Display
You can display T/div and V/div in the waveform display window.  The values of the
selected items are displayed.  If multiple waveforms are displayed in the waveform
display window, the V/div of the active waveform is displayed.

Display V/div Display T/div
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3.4  Specifying Display Settings

Checking the Changed Settings
Clicking the Apply button while you are changing settings applies the settings you

have already made for the window(s) to the waveform display, without closing the
Display Setting dialog box.

Note
The Supplementary Grid of the Graticule tab and the Scale of the Horizontal Axis tab can be
set only on Xviewer with the computation option (-GP01/05/10/20 option).
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4.1 Displaying Measurement Results

Operations
Displaying Measurements in the Result View
Open a waveform data file for which waveforms and measurement results are to be

displayed.  To display or hide the measurement result display window, click the 
button or select Window > Measure Result.

Measurement result 
display window

Display or hide the measurement 
result display window

Explanation
Items and Measured Values That Are Displayed
The items and measured values that are displayed depend on the measurements and

waveforms.

Reference to Cursor Positions
The positions of the cursors are indicated using either of the references below, according
to the notational format of the horizontal axis:
• Absolute time: The positions of cursors are indicated as absolute times.

• Relative time: The positions of cursors are indicated as being relative to the trigger
position.

Note
If you perform cursor measurement or automatic measurement of waveform parameters
without the measurement results display window being displayed, the measurement results
window is automatically displayed.

Chapter 4   Analyzing Waveform Data
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4.2 Analyzing Waveform Data Using Cursors

Operations
Analyzing Waveform Data Using Cursors
Choose Vertical Cursor from the  icon drop-down menu or choose Analysis >
Analysis Mode > Vertical Cursor to display two vertical cursors in the main waveform
display window and the zoomed waveform display window.
The measurement result window displays the cursor positions (time) and measured
values as well as the difference in the time and measured values between the cursors.
Each cursor can be moved by dragging.  You can also click on the window to move
Cursor 1 to that position.  Likewise, you can right-click on the window to move Cursor 2
to that position.

Cursor 2

Cursor 2 (drag to move)
Cursor 1 (drag to move)

Make vertical cursors active

Indicates the position 
of the cursor
Differences in time 
between Cursor 1 
and Cursor 2

Differences in 
measured values 
between Cursor 1 
and Cursor 2

Measured value on 
Cursor 2
(intersections of 
Cursor 2 and 
waveforms)

Measured value on 
Cursor 1 
(intersections of 
Cursor 1 and 
waveforms)

Cursor 1

Analyzing Waveform Data Using Horizontal Cursors
Choose Horizontal Cursor from the  icon drop-down menu or choose Analysis >
Analysis Mode > Horizontal Cursor to display two horizontal cursors in the main
waveform display window and the zoomed waveform display window.
The measurement result window displays the measured value at each cursor.
Each cursor can be moved by dragging.  You can also click on the window to move
Cursor 1 to that position.  Likewise, you can right-click on the window to move Cursor 2
to that position.

Make horizontal cursors active

Cursor 2 (drag to move)
Cursor 1 (drag to move)

Differences in 
measured values 
between Cursor 1 
and Cursor 2

Measured value on 
Cursor 2 
(intersections of 
Cursor 2 and 
waveforms)

Measured value on 
Cursor 1 
(intersections of 
Cursor 1 and 
waveforms)Cursor 1 Cursor 2
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4.2  Analyzing Waveform Data Using Cursors

Analyzing Waveform Data Using X-Y Cursors
Choose X-Y Cursor from the  icon drop-down menu or choose Analysis > Analysis
Mode > X-Y Cursor to display two vertical cursors and two horizontal cursors in the X-Y
waveform display window.  You can move a cursor by dragging it.  The measurement

result display window displays the measured values at the cursor positions at that time,
as well as the differences in the measured values.

Select a waveform (trace name) assigned to the X axis

Cursor 1 Cursor 2

Make the X-Y 
cursors active Waveform (trace name) assigned 

to the X-axis
Measured value on 
Cursor 1
Measured value on 
Cursor 2
Differences in 
measured values 
between Cursor 1 
and Cursor 2

Differences in 
measured values 
between Cursor 3 
and Cursor 4
Measured value on 
Cursor 4
Measured value on 
Cursor 3

Waveforms (trace names) 
assigned to the Y-axisCursor 4

Cursor 3

Show waveforms assigned to the Y-axis

Analyzing Waveform Data Using H&V Cursors
Choose H&V Cursor from the  icon drop-down menu or choose Analysis >
Analysis Mode > H&V Cursor to display four cursors (two vertical cursors and two

horizontal cursors) in the main waveform display window and the zoomed waveform
display window.  The measurement result window displays the measured value at each
cursor and the differences between the measured values between the cursors.

Explanation
Cursor Measurements on History Waveform Views
When you are displaying history waveform views, only the active waveform view can be
used for measurement using the cursors.

Linking of Vertical Cursors or Horizontal Cursors
If you drag a vertical cursor or horizontal cursor while holding down the Ctr key, the two

vertical or horizontal cursors can be moved simultaneously.
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*** Indication
If the measurement result is invalid, “***” is displayed as the measured value.

Note
Copying Measurement Results to the Clipboard
You can copy the contents of the measurement results display window to the clipboard.
Specify the range to be copied, press Ctrl + C, then the measured results are copied to the
clipboard.  The following methods can be used to specify a range.
• Press Ctrl + C without specifying a range to copy:

All contents in the measurement results display window are selected
• Click Trace:

All rows are selected except for the data at the cursor.
• Click or drag the trace names of the items to copy:

The rows of the clicked or dragged traces are selected

Selects all rows except the cursor information. 
Click once again to clear the selection.

If no range is specified, 
all are copied

4.2  Analyzing Waveform Data Using Cursors
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4.3 Automated Measurement of Waveform
Parameters

Operations
Automated Measurement of Waveform Parameters
Click the  button or select Analysis > Analysis Mode > Measure Waveform
Parameter to allocate two vertical cursors in the main waveform display window and

display the results for the waveforms, after they are automatically analyzed, in the
measurement result display window.  By setting waveform parameters for the items to be
measured, you can automatically measure the waveform parameters in the range

specified by the cursors.

Changing the Range of Automated Measurement
You can change the range of automatic measurement by dragging the two vertical

cursors to the new measurement start and end points.

Positions of the cursors
Show the Measure dialog box

Select automated measurement waveform parameters

Time difference 
between the cursors

Show measured 
values

Measurement result 
display window

Items to be automatically measured 
(specifiable in the Measure dialog box)

Show the measurement statusRange of measurement
Start-point 
cursor

End-point 
cursor

Setting Items That Are Automatically Measured
Click  beside the  button, or select Analysis > Measure Waveform Parameter to
display the Measure dialog box.  In the dialog box, you can specify the display settings
for the items to be measured and the measured values.

Select the number of rows 
to be used to display 
measured values
(allowable range:  1 to 26).

Names of items to be measured

Select or deselect the item

Items related to the 
power scale

Items related 
to the time scale

Items related to 
the size of areas

Place a checkmark to 
allocate traces to the 
vertical axis in the 
measurement result 
display window
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4.3  Automated Measurement of Waveform Parameters

Explanation
Items that Can Be Specified
You can set and measure items related to the power scale and time scale as waveform
parameters.

• Items related to the power scale

P-P Value

Max

Min

High Level

Low Level

Overshoot

Undershoot

Maximum : Maximum voltage [V]
Minimum : Minimum voltage [V]
High level : High voltage [V]
Low level : Low voltage [V]
Peak to peak value : P-P value (Max - Min) [V]
Amplitude : Amplitude (High - Low) [V]

Average : Average voltage (1/n)Σxi [V]
RMS : Root-mean-square value (1 /   n  )(Σ(xi)2)1/2 [V]
Middle : Mean value for amplitude (Max + Min)/2 [V]
Standard deviation : Standard deviation (1/n(Σx2 - (Σx2)/n)1/2

Overshoot : Amount of overshoot (Max - High)/(High - Low)_100 [%]
Undershoot : Amount of undershoot (Low - Min)/(High - Low)_100 [%]

• Items related to the time scale

+Width -Width
Period

Distal line (90%)

Mesial line (50%)

Proximal line (10%)

Rise Time Fall Time

High Level (100%)

Low  Level (0%)

Plus duty : Duty ratio, Width1/Period_100 [%]
Minus duty : Duty ratio, Width2/Period_100 [%]
Plus width : Time width greater than the mesial value [s]
Minus width : Time width less than the mesial value [s]

Rise time : Rise time [s]
Fall time : Fall time [s]
Frequency : Frequency [Hz]
Period : Cycle [s]

Pulse : Pulse count

When Pulse=3

Adjust the measurement scope to 
the pulses you want to measure.

Distal line (90%)
Mesial line (50%)
Proximal line (10%)

T1 T2
Measurement 
scope

Burst1, Burst2 : Burst width [s] Adjust the measurement scope to the 
burst widths you want to measure.

Distal line (90%)

Mesial line (50%)

Proximal line (10%)

Burst1
Burst2

T1 T2
Measurement 
scope
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4.3  Automated Measurement of Waveform Parameters

• Items related to the size of areas
Int1TY: Size of the positive portion of an amplitude

Int2TY: Size of the positive portion of an amplitude - Size of the negative portion of
an amplitude

Int1TY

S1
S2

Size of only the positive areas : S1+S2

Int2TY

S1
S3

S2

Size of both positive and negative areas : S1+S3-S2

*** Indication
If the measurement result is invalid or impossible, “***” is displayed as the measured

value.  Waveforms with small amplitudes may fail to produce correct readings.

Data Obtained through Automatic Measurements with Waveform Parameters
To keep the obtained data, save it into a file.  For details, see Section 5.4.

Icon Displayed during Automatic Measurement
While automatic measurement is being performed, the icon shown below appears in the
status bar.

 :  Performing automatic measurement (blinks on and off)

Note
• When the scope to analyze includes two cycles or more of a waveform, time-axis

parameters are analyzed only for the fist cycle.
• No logic waveform can be automatically analyzed.
• It may take a long time to automatically analyze a waveform with some conditions for the

scope, number of items, and/or waveforms to analyze.
• An FFT computation allows to make measurement only for Max and Min.
• Copying Measurement Results to the Clipboard

You can copy the contents of the measurement results display window to the clipboard.
Specify the range to be copied, press Ctrl + C, then the measured results are copied to the
clipboard.  The following methods can be used to specify a range.
• Press Ctrl + C without specifying a range to copy:

All contents in the measurement results display window are selected
• Click Measure Item:

All rows are selected except for the data at the cursor.
• Click or drag the measurement items of the items to copy:

The rows of the clicked or dragged items are selected

Selects all rows except the cursor information. 
Click once again to clear the selection.

If no range is specified, 
all are copied
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4.4 Analyzing Waveforms by Computations
(Optional)

Operations
Displaying Waveforms in the Computation View
Click the  button or select Analysis > Math Setting to display the Math Setting
dialog box for analyzing waveforms by computational expressions.  The Math Setting
dialog box allows you to set computational expressions, filters, FFT computations, and
other computations for waveforms.

Displays the Math Setting dialog box

Displays the computation 
status

Computationally 
analyzed waveform

Label of the 
computationally
analyzed waveform

Setting Computational Expressions
Click a computational expression in the Math Setting dialog box to display the
Computational Expression screen, which allows you to specify user-defined
computation settings.  Set up a required computational expression by using variables
and operators.

Apply the setting 
made for the 
computational 
expression at the top 
of the column to the 
other computational 
expressions

Computational 
expression number

Set the label, unit, and 
computation expression 
in the Computational 
Expression screen Set a constant 

(allowable range:  
-1.0000E+30 to 
1.0000E+30)
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4.4  Analyzing Waveforms by Computations (Optional)

Specify a name for the label (using up to 31 one-byte characters)
Set the units (up to 15 one-byte characters)

Displays the trace names corresponding 
to the variables

Set a computational 
expression 
(up to 63 characters)

Buttons for setting 
numerals and variables

Display the operators menu

PS_LOGMAG simple input

Show other computational expressions

Setting Filters
Use the FILT1 and FILT2 tabs on the Math Setting dialog box to set up the filters.

Switch between the 
filter 1 and filter 2 
panes

Select the type
Select the band

Set the cut-off frequency

Specifying FFT Settings
Use FFT Setting on the Math Setting dialog box to specify the FFT settings.

Select the number of points to be used for FFT computations  
Select a time window type

Set the FFT start point
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4.4  Analyzing Waveforms by Computations (Optional)

Explanation
Function Menu Button
The Function menu button of the Computational Expression dialog contains operators
that can be specified for user-defined computational expressions, as follows:

Basic:  SHIFT, ABS, SQRT, LOG, EXP, NEG, P2, P3, F1, F2
Trigonometric:  SIN, COS, TAN, ATAN, PH
Pulse Width:  PWHH, PWHL, PWLH, PWLL, PWXX, FV, DUTYH, DUTYL
DIF & INTG:  DIF, DDIF, INTG, IINTG
Filter:  FILT1, FILT2, HLBT, MEAN, BIN
FFT > LS : LS-REAL, LS-IMAG, LS-MAG, LS-LOGMAG, LS-PHASE

RS : RS-MAG, RS-LOGMAG
PS : PS-MAG, PS-LOGMAG, PSD-MAG, PSD-LOGMAG
CS : CS-REAL, CS-IMAG, CS-MAG, CS-LOGMAG, CS-PHASE
TF : TF-REAL, TF-IMAG, TF-MAG, TF-LOGMAG, TF-PHASE
CH : CH-MAG

Settings for the Filters
• Type/Band

Gauss (gauss) : Lowpass
Sharp (sharp) : Lowpass/Highpass/Bandpass
IIR (butterworth): Lowpass/Highpass/Bandpass

• CutOff1/CutOff2
Set either or both cutoff frequencies as a ratio to the sampling frequency.  The
allowable range is 2.0% to 30.0% (0.2% steps).  When you specify Bandpass for
Band, specify the orders of both CutOff1 and CutOff2.  The higher the order, the
longer the computation.

Settings for FFT
• Points (number of points used for computation):

Select 100 points, 200 points, 500 points, 1000 points, 2000 points, 5000 points,
10000 points, 20000 points, 50000 points, 100000 points, 200000 points, 500000
points, 1000000 points, or 2000000 points.

Note
Executing an FFT calculation with 1000000 points or more, only M1 is calculated and the
result is displayed.

• FFT start point:
When the number of loaded points is less than 10M: Specify 0 to “Number of
loaded points-no. of FFT computation points”
When larger than 10M: set between computation start point and “computation start

point + 10M - no. of FFT points”
• Window (time window):

Select the Rect (rectangle), Hanning (hanning), or FlatTop (flat-top) window.

Number of Points for Computation
•  There are 10M points for computation/channel.
•  Computation with more than 2G points is not possible.

Variables and Operators
The variables and operators that can be used in computational expressions are listed
below.  You can use up to 63 characters to define a computational expression.  You can
register up to 10 computational expressions.

Computational accuracy
Single-precision floating-point type
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4.4  Analyzing Waveforms by Computations (Optional)

Variables

Variable Sample Use Description

Cx C1+C2 Value measured on channel CHx
My ABS(M1) Value of computation (Math)
T SIN(T) Integrated value for the number of data points to the time axis
x:  stands for a number, However, specify the number according to the number of channels that

are loaded.  For example, if three channels, CH1, CH5, and CH8, are loaded, specify the
channels as C1, C2, and C3.

y: stands for a number

Operator

Operator Sample Use Description

+, - , *, / C1+C2 Four arithmetical Operationss on two specified waveforms
SHIFT SHIFT(C1,1000) Phase shift
ABS ABS(M1) Absolute value of a specified waveform
SQRT SQRT(C2) Square root of a specified waveform
LOG LOG(C1) Logarithm of a specified waveform
EXP EXP(C1) Exponent of a specified waveform
NEG NEG(C1) Inversion
SIN SIN(T) Sine of a specified waveform
COS COS(C1) Cosine of a specified waveform
TAN TAN(C1) Tangent of a specified waveform
ATAN ATAN(C1,C2) Arctangent of two specified waveforms (value within ± π )
P2 P2(C1) Square of a specified waveform
P3 P3(C1) Cube of a specified waveform
F1 F1(C1,C2) √|C12 + C22| of a specified waveform
F2 F2(C1,C2) √|C12 – C22| of a specified waveform
K1 to K10 C1 + K1 Constant (any value specified)
BIN BIN(C1,A,B) Binarization of a specified waveform
PWHH PWHH(M1,A,B) Computation of a pulse width between a rising edge and the next rising edge
PWHL PWHL(C2,A,B) Computation of a pulse width between a rising edge and the next falling edge
PWLH PWLH(C1,A,B) Computation of a pulse width between a falling edge and the next rising edge
PWLL PWLL(C1,A,B) Computation of a pulse width between a falling edge and the next falling edge
PWXX PWXX(C2,A,B) Computation of a pulse width between a raising/falling edge and the next rising/falling edge
FV FV(C1,A,B) PWHH reciprocal
DUTYH DUTYH(C1,A,B) Duty cycle between a rising edge and the next rising edge
DUTYL DUTYL(C1,A,B) Duty cycle between a falling edge and the next falling edge
MEAN MEAN(C1) 10th moving average of a specified waveform
DIF DIF(C1) Differentiation of a specified waveform
DDIF DDIF(C1) Second-order derivative of a specified waveform
INTG INTG(C1) Integration of a specified waveform
IINTG IINTG(C1) Second-order integration of a specified waveform
PH PH(C1,C2) Phases of two specified waveforms
HLBT HLBT(C1) Hilbert function of a specified waveform
FILT1 FILT1(C1) Filter for a specified waveform
FILT2 FILT2(C1) Filter for a specified waveform
LS-REAL LS-REAL(C1) Real part of the linear spectrum of a specified waveform
LS-IMAG LS-IMAG(C1) Imaginary part of the linear spectrum of a specified waveform
LS-MAG LS-MAG(C1) Amplitude of the linear spectrum of a specified waveform
LS-LOGMAG LS-LOGMAG(C1) Logarithmic amplitude of the linear spectrum of a specified waveform
LS-PHASE LS-PHASE(C1) Phase of the linear spectrum of a specified waveform
RS-RS-MAG RS-MAG(C1) Amplitude of the effective spectrum of a specified waveform
RS-LOGMAG RS-LOGMAG(C1) Logarithmic amplitude of the effective spectrum of a specified waveform
PS-MAG PS-MAG(C1) Amplitude of the power spectrum of a specified waveform
PS-LOGMAG PS-LOGMAG(C1) Logarithmic amplitude of the power spectrum of a specified waveform
PSD-MAG PSD-MAG(C1) Amplitude of the power spectrum density of a specified waveform
PSD-LOGMAG PSD-LOGMAG(C1) Logarithmic amplitude of the power spectrum density of a specified waveform
CS-REAL CS-REAL(C1,C2) Real part of the cross spectrum of two specified waveforms
CS-IMAG CS-IMAG(C1,C2) Imaginary part of the cross spectrum of two specified waveforms
CS-MAG CS-MAG(C1,C2) Amplitude of the cross spectrum of two specified waveforms
CS-LOGMAG CS-LOGMAG(C1,C2) Logarithmic amplitude of the cross spectrum of two specified waveforms
CS-PHASE CS-PHASE(C1,C2) Phase of the cross spectrum of two specified waveforms
TF-REAL TF-REAL(C1,C2) Real part of the transfer function of two specified waveforms
TF-IMAG TF-IMAG(C1,C2) Imaginary part of the transfer function of two specified waveforms
TF-MAG TF-MAG(C1,C2) Amplitude of the transfer function of two specified waveforms
TF-LOGMAG TF-LOGMAG(C1,C2) Logarithmic amplitude of the transfer function of two specified waveforms
TF-PHASE TF-PHASE(C1,C2) Phase of the transfer function of two specified waveforms
CH-MAG CH-MAG(C1,C2) Amplitude of the coherence function of two specified waveforms



4-12 IM 701992-01E

4.4  Analyzing Waveforms by Computations (Optional)

Restrictions Imposed on Computational Expressions
• When m ≤ n, a computational expression for Mathm cannot include the variable Mn

(Operations for Mathn).
Example of an expression that is not allowed:  Math5 = M6 + M3

• One FFT computation allows the specification of one waveform.

Example of an expression that is not allowed:  PS-MAG(C1+C2)
• A computation cannot be performed on the result of an FFT computation.

Example of an expression that is not allowed:  PS-MAG(C1)+C2

Cautions on Computations
• An FFT computation that does not have a record length that is sufficient for the

required number of points for computation in the target view cannot be performed.

Changing the Computation Start Position
If the record length (the number of data points) is greater than or equal to 10 Mpoints,
you can specify the computation start point and perform the computation.
If the record length is greater than or equal to 10 Mpoints, a yellow mark indicating the

computation start position appears on the screen as shown below.  If you drag the yellow
mark, a cursor appears allowing you to move the computation start position.

Computation start position

Icon displayed during measurement through computation
While measurement through computation is being performed, the icon shown below
appears in the status bar.

: Computing (blinks on and off)
: Accessing file
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4.4  Analyzing Waveforms by Computations (Optional)

Displaying the FFT Range
The FFT range is indicated with a green bar on the main waveform display window and

the zoomed waveform display window.
Drag the bar to move the computation range.
If FFT cannot be performed, the bar indicating the range and the word “FFT” turn red.

FFT range

Details of Various Computations

Filter (FILT1/FILT2)

Type

Type Bandwidth

Gauss Lowpass
Sharp Lowpass/Highpass/Bandpass
IIR (Butterworth) Lowpass/Highpass/Bandpass

Filter Orders

See the following table for the filter orders.

Cutoff frequency/sampling frequency × 100 2% 5% 10% 20% 30%

Gauss Lowpass 49 21 9 5 5
Sharp Lowpass 88 36 18 9 8

Highpass 159 65 33 17 13
IIR Lowpass 4 4 4 3 2

Highpass 4 4 4 4 3

Note
• You can set the cutoff frequency in the range from 2 to 30% of the sampling frequency (in

0.2% steps).
• The higher the filter order, the longer computation takes.

Filter Characteristics

Filter Passband Ripple Attenuation slope Attenuation in the Phase
Stopband

Gauss 0 dB * - Linear

Sharp ±0.3 dB –40 dB at 1 oct (Lowpass), –40 dB Linear
–40 dB at –1 oct (Highpass)

IIR 0 dB –5 dB at 1/6 oct (Lowpass), - Non-linear
–20 dB at –1 oct (Highpass)

* Attenuation for a Gauss filter is –3.0×(f/fc)2 dB (where f is the frequency and fc is the cutoff
frequency).
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Examples of Frequency Characteristics for Various Filters

Gauss (cutoff 10%) Sharp (Lowpass, cutoff 10%) IIR (Lowpass, cutoff 10%)

f :  Sampling Frequency

Hilbert Function (HLBT)

Normally, when we analyze a real time signal, it is convenient to think of the signal as the

real part of a complex valued signal.  Analysis is often more convenient when done using

the complex signal.  Given that the real time signal is considered to be the real part of

the complex signal, the imaginary part is then equal to the Hilbert transform of the real

part.  When performing a Hilbert transform on a signal in the time domain, the signal is

first transformed into the frequency domain using the Fourier transform.  Next, the phase

of each frequency component is shifted by -90 degrees if the frequency is positive and

+90 degrees if negative.  Lastly, the Hilbert transform is completed by taking the inverse

Fourier transform.  As can be seen from the above description, the Hilbert transform

does not change the order of the individual variables.  The Hilbert transform of a time

signal results in another time signal.

Application Example

The Hilbert transform can be used to analyze an envelope waveform.

AM (amplitude modulation): SQRT(C1*C1+HLBT(C1)*HLBT(C1))

Demodulation of a FM signal: DIF(PH(C1, HLBT(C1)))

Phase Function (PH)

Phase function PH(C1, C2) computes tan-1 (C1/C2).  However, the phase function takes

the phase of the previous point into consideration and continues to sum even when the

value exceeds ±π (The ATAN function reflects at ±π).  The unit is radians.

Previous point

Previous point

θ2

θ2

θ2=θ1+∆θ2 θ2=θ1–∆θ2

∆θ2

∆θ2

θ1

θ1
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4.4  Analyzing Waveforms by Computations (Optional)

Binary Conversion (BIN)

Performs binary conversion with respect to the specified threshold level.

The threshold level is specified as follows:

A and B represent the Upper and Lower threshold levels, respectively.

BIN(C1, A, B)

1

0

Upper threshold level

Lower threshold level

Pulse Width Computation (PWHH/PWHL/PWLH/PWLL/PWXX)

The signal is converted into binary values by comparing to a preset threshold level, and

the time of the pulse width is plotted as the Y-axis value for that interval.

The following 4 intervals are available:

PWHH: From the rising edge to the next rising edge.

PWHL: From the rising edge to the next falling edge.

PWLH: From the falling edge to the next rising edge.

PWLL: From the falling edge to the next falling edge.

PWXX: From the rising or falling edge to the next rising or falling edge.

The threshold level is specified as follows:

A and B represent the Upper and Lower threshold levels, respectively.

PWHH (C1, A, B)

When the Interval is Set to PWHH

Waveform to 
be computed

A: Upper threshold level

t1 t2 t3

Computed 
waveform

B: Lower threshold level

t1

t2 t3
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FFT

Linear Spectrum (LS-REAL/LS-IMAG/LS-MAG/LS-LOGMAG/LS-PHASE)

The linear spectrum is directly determined by the FFT.  The power spectrum and cross

spectrum can be determined from one or two linear spectra.

The FFT is a complex function, and thus the linear spectrum is composed of both a real

and an imaginary part.  The magnitude and phase of the frequency components of the

measured waveform can be derived from the real and imaginary parts of the FFT result.

The following spectra can be determined:

Item Expression Computation

Real part LS-REAL R
Imaginary part LS-IMAG I
Magnitude LS-MAG (R2+I2)
Log magnitude LS-LOGMAG 20×log (R2+I2)
Phase LS-PHASE tan–1(I/R)

Log magnitude reference (0 dB): 1 Vpeak
R, I: R and I represent the real part and the imaginary part, respectively, when each frequency
component G of a linear spectrum is represented by “R+jI.”

Rms Value Spectrum (RS-RS-MAG/RS-LOGMAG)

Rms value spectrum expresses the rms value of the magnitude of the linear spectrum.  It

does not contain phase information.

The following spectra can be determined:

Item Expression Computation

Magnitude RS-MAG (R2+I2)/2
Log magnitude RS-LOGMAG 20×log (R2+I2)/2

Log magnitude reference (0 dB): 1 Vrms

Power Spectrum (PS-MAG/PS-LOGMAG/PSD-MAG/PSD-LOGMAG)

The power spectrum expresses the power of each frequency component included in the

measured signal.  It is determined by taking the product of the linear spectrum and its

complex conjugate.  It does not contain phase information.

The following spectra can be determined:

Item Expression Computation

Magnitude PS-MAG (R2+I2)/2
Log magnitude PS-LOGMAG 10*log(R2+I2)/2

Log magnitude reference (0 dB): 1 Vrms2

Power Spectral Density (PSD-MAG/PSD-LOGMAG)

The power spectral density (PSD) expresses the power spectrum per unit frequency.  It

is determined by dividing the power spectrum by the frequency resolution ∆f found during

the analysis of the power spectrum.  The results of the PSD computation vary depending

on the window function chosen.  The power spectral density is used to compare power

spectra analyzed at different frequency bands.  However, it is not necessary for signals

having a line spectrum such as a sine wave.

The following spectra can be determined:

Item Expression Computation

Magnitude PSD-MAG PS-MAG/∆f (for rectangular window)
PS-MAG/1.5∆f (for Hanning window)

Log magnitude PSD-LOGMAG 10×logPS-MAG/∆f (for rectangular window)
10×logPS-MAG/1.5∆f (for Hanning window)

Log magnitude reference (0 dB): 1 Vrms2
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4.4  Analyzing Waveforms by Computations (Optional)

Cross Spectrum (CS-REAL/CS-IMAG/CS-MAG/CS-LOGMAG/CS-PHASE)

The cross spectrum is determined from 2 signals.  It is found by taking the product of the

linear spectrum of one signal(Gx) and the complex conjugate (Gx*) of the linear

spectrum of the other signal (Gy).

If the linear spectra of the 2 signals are represented by

Gx=Rx+jIx

Gy=Ry+jIy

then the cross spectrum Gyx is

Gyx=Gy×Gx*

 =(Ry+jIy)(Rx-jIx)=Ryx+jIyx

where Ryx=RyRx+IyIx

Iyx=RxIy-RyIx

The following spectra can be determined:

Item Expression Computation

Real part CS-REAL Ryx/2
Imaginary part CS-IMAG Iyx/2
Magnitude CS-MAG (Ryx2+Iyx2)/2
Log magnitude CS-LOGMAG 10×log (Ryx2+Iyx2)/2
Phase CS-PHASE tan–1(Iyx/Ryx)

Transfer Function (TF-REAL/TF-IMAG/TF-MAG/TF-LOGMAG/TF-PHASE)

The transfer function expresses the frequency characteristics between the input and the

output of a system.  The transfer function is given by the ratio of the linear spectrum of

the output(Gy) to the spectrum of the input(Gx) at each frequency.  Also, as can be seen

from the equation below, the transfer function can be defined as the ratio of the cross

spectrum of the input and output (Gyx) and the input power spectrum (Gxx).

Transfer Function = Gy/Gx = (Gy×Gx*)/(Gx×Gx*) = Gyx/Gxx = (Ryx+jIyx)/(Rx2+Ix2)

The following items can be determined:

Item Expression Computation

Real part TF-REAL Ryx/(Rx2+Ix2)
Imaginary part TF-IMAG Iyx/(Rx2+Ix2)
Magnitude TF-MAG (Ryx2+Iyx2)/(Rx2+Ix2)
Log magnitude TF-LOGMAG 20×log (Ryx2+Iyx2)/(Rx2+Ix2)
Phase TF-PHASE tan–1(Iyx/Ryx)

The magnitude of the transfer function gives the ratio of the magnitudes of the linear

spectra of the output and input, whereas phase of the transfer function gives the phase

difference between the two.

Coherence Function (CH-MAG)

This function expresses the ratio of the output power generated by the input to the

system to the total output power.

Coherence function = Gyx×Gyx*/(Gxx×Gyy)

Item Expression Computation

Magnitude CH-MAG (Ryx2+Iyx2)/(Gxx×Gyy)

If the output signal is due entirely to the input signal, the coherence function becomes 1.

As the ratio decreases, it falls below 1.  Thus, the coherence function always takes on a

value between 0 and 1.

Note
• On one data acquisition, the coherence function becomes 1 across all frequencies.
• The computed waveform must be averaged.
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4.4  Analyzing Waveforms by Computations (Optional)

Number of Computed Points

You can select 100 points, 200 points, 500 points, 1000 points, 2000 points, 5000 points,

10000 points, 20000 points, 50000 points, 100000 points, 200000 points, 500000 points,
1000000 points, or 2000000 points.

About Time Windows

You can select rectangular, Hanning, or flattop as the time window.

The rectangular window is best suited to transient signals, such as an impulse wave, that

attenuate completely within the time window.  The Hanning window allows continuity of

the signal by gradually attenuating the parts of the signal located near the ends of the

time window down to the “0” level.  Hence, it is best suited to continuous signals.  The

frequency resolution of the Hanning window is higher compared with the Flattop window.

However, the flattop window has a higher level of accuracy of the spectrum.  When the

waveform being analyzed is a continuous signal, consider the above characteristics

when selecting the proper window to use.

T

T

T

T

t

Sine wave

Window Integral Power spectrum
Rectangular 

window

Hanning window

Rectangular window

Hanning window

Flattop window

: W(t)=u(t)–u(t–T)      U(t) : Step function

: W(t)=0.5–0.5cos(2π    )

: W(t)={0.54–0.46cos(2π    )}

T

TFlattop 
window

t
T

t
T

sin{2π(1–2t/T)}
2π(1–2t/T)
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4.5 Specifying Annotations for Waveforms

Operations
Specifying Annotations for Waveforms
To display the Annotation Setting dialog box, either select  and double-click a point

in a window, or select View > Add Annotation.  Type annotations into the field on the
dialog box, and then click OK to have the annotations appear in the window.  When you
double-click on a waveform, you can insert an annotation at the position linked to the

waveform data.  When you double-click a point other than the waveform, you can insert
an annotation at a relative position on the screen.

Previously entered annotation 

Show the Annotation dialog box Type annotations into the field

Open the Fonts 
dialog to specify 
the annotation format

Deleting Annotations
To delete annotations that have already been entered, select View > Delete
Annotations > Selected Item or All Item.
To delete an annotation, click it (such that the frame around the annotation is bolded),
and then press the Delete key.

Select an item to delete
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4.5  Specifying Annotations for Waveforms

Copying and Pasting the Annotations
Click the annotation to be copied (such that the frame around the annotation is bolded)

and right-click to display the menu shown below.  Select Copy, right-click the position
where you wish to paste the annotation, and select Paste.

Explanation
The only setting data that is saved is the annotatins that are inserted at relative positions
on the screen.

Adding Annotations
You can add annotations for each history waveform.

The following two types of annotations can be added.
• Annotations linked to the waveform data

You can add an annotation for each waveform data.  The annotation for each

waveform data is linked to the waveform data even if the displayed group is switched.
This type of annotations can be added to the main waveform display window or the
zoomed waveform display window.

• Relative positions on the window
This type of annotations can be added to the main waveform display window, the
zoomed waveform display window, or the XY waveform display window.

Copying and Pasting the Annotations
Place the mouse pointer on an annotation or window and right-click to carry out the

following operations.

Operation When pointing to an annotation When pointing on the window

Add No Yes
Delete Yes No
Copy Yes No
Paste No Yes
Edit Yes No
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4.6 Transferring a Waveform View to the Clipboard

Operations
Transferring a Waveform View to the Clipboard
Click  to transfer the viewer window you are viewing as image data to the clipboard.

You can see the image by executing a paste command in an application that can handle
image data.

Transfer to Clipboard button

Note
Only the waveform view is transferred to the clipboard without any image of the menu bars
and other functional components.
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5.1 Saving Waveform Data

Operations
Saving Waveform Data in Binary Format
Click  or select File > Save to display the Save File dialog box.  Select the folder

into which you want to save the file, specify the file name, select Yokogawa Waveform
Data File (*.wvf) in Files of type, set any other required options, and then click the Save
button.  To set the options, click the More Options button.

Select the folder into which you want to save the file

Type comments

Specify a file name

Select Yokogawa 
Waveform Data File
(*.wvf)

Select the waveforms 
to save

Set options for the 
data format

Chapter 5   Saving Data/Converting Data Formats
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Saving Waveform Data in ASCII Format
Click  or select File > Save to display the Save File dialog box.  Select the folder

into which you want to save the file, specify the file name, select ASCII File (*.csv) in
Files of type, set any other required options, and then click the Save button.  To set the
options, click the More Options button.

Select the folder into which you want to save the file

Specify a file name

Set options for the 
data format

Set options for the 
file format

Select ASCII File 
(*.csv) 

Select the waveforms 
to save

5.1  Saving Waveform Data
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Saving Waveform Data in XLS Format
Click  or select File > Save to display the Save File dialog box.  Select the folder

into which you want to save the file, specify the file name, select Excel File (*.xls) in
Files of type, set any other required options, and then click the Save button.  To set the
options, click the More Options button.

Select the folder into which you want to save the file

Specify a file name

Set options for the 
data format

Set options for the 
file format

Select Excel File 
(*.xls)

Select the waveforms 
to save

5.1  Saving Waveform Data
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Explanation
Files Saved in Binary Format
Files saved in binary format conform to our proprietary WVF format.  The saved data
consists of the active waveform data and that for the block checked in the history
window.

Options for Saving Binary Files
When you save waveform data in WVF format, you can not only select the waveforms to

save but you can also set the following options:
• Range to save:  Select All, Zoom Range, or Cursor Range
• Compression:  Select None, PP Comp, or Decim
• Compression Rate:  Selectable when Compression is specified.

Select 5, 10, 20, 50, 100, 200, 500, 1000, 2000, 5000, or 10000.

Files Saved in ASCII Format
Files saved in ASCII format conform to CSV format.

Note
For waveform data that is divided into blocks, you can save only one block in ASCII format
(CSV file).

Options for Saving CSV Files
When you save waveform data in CSV format, you can not only select the waveforms to
save but also set the following options:

Data format options:
• Range to save:  Select All, Zoom Range, or Cursor Range
• Compression:  Select None, PP Comp, or Decim
• Compression Rate:  Selectable when Compression is specified.

Select 5, 10, 20, 50, 100, 200, 500, 1000, 2000, 5000, or 10000.
File format options:
• Header:  Select whether to set a header
• Time-Axis:  Select whether to set information about the time-axis

Files Saved in XLS Format
Files saved in XLS format conform to MS Excel format.

Options for Saving XLS Files
When you save waveform data in XLS format, you can not only select waveforms to
save but also set the following options:

Data format options:
• Range to save:  Select All, Zoom Range, or Cursor Range
• Compression:  Select None, PP Comp, or Decim
• Compression Rate:  Selectable when Compression is specified.

Select 5, 10, 20, 50, 100, 200, 500, 1000, 2000, 5000, or 10000.
File format options:
• Header:  Select whether to set a header
• Time-Axis:  Select whether to set information about the time-axis

Note
• For waveform data divided by the block, you can save only one block you focus on into the

XLS format.
• Data saved in WVF format cannot be loaded on DL series instruments.

5.1  Saving Waveform Data
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5.2 Transferring Waveform Data into Excel

Operations
Transferring Waveform Data into Excel
Click  or select File > Save to display the Save File dialog box.  Select Excl
transport (*) in Files of type, set any other required options, and then click the Save
button.  To set the options, click the More Options button.

Need not be set

File name fixed

Select Transfer to 
Excel (*)

Select the waveforms 
to transfer

Set options for the 
data format

Set options for the 
file format

Explanation
Transfer to Excel
The Transfer to Excel command directly redirects data for the selected waveforms to an
Excel sheet.  Clicking the Save button automatically starts up Excel and then plots the
waveform data onto an Excel sheet according to the specified format options.

Note
• If there are a number of channels, Transfer to Excel may take a long time to complete in

some operating environments.  In such a case, save the data into a CSV file, and then
read the file into Excel.

• Using the mouse to close the sheet opened by the Transfer to Excel feature causes
Xviewer to malfunction when you execute Transfer to Excel again.  If you need to close
the sheet and execute Transfer to Excel again, close the first sheet, quit Xviewer, and then
execute Transfer to Excel again.

• When the measured values exceed the measurement range, or the size of the computed
waveform data is smaller than that of the measured waveform data, the measured data is
not saved.  In this case, a value of “65535” is written into each cell.

Options for Transfer to Excel
When you transfer waveform data to Excel, you can not only select the waveforms to
transfer but also set the following options:

Data format options:
• Range to save:  Select All, Zoom Range or Cursor Range
• Compression:  Select None, PP Comp, or Decim
• Compression Rate:  Selectable when Compression is specified.

Select 5, 10, 20, 50, 100, 200, 500, 1000, 2000, 5000, or 10000.
File format options:
• Header:  Select whether to set a header
• Time-Axis:  Select whether to set information about the time-axis
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5.3 Saving Waveform Data in a View

Operations
Saving Waveform Data in a View
Click  or select File > Save to display the Save File dialog box.  Select the folder

into which you want to save the file, specify the file name, select Image File (*.bmp) or
Image file (*.png) in Files of type, and then click the Save button.

Select the folder into which you want to save the file

Type comments

Specify a file name

Select 
Image File (*.bmp) or 
Image File (*.png)

Explanation
Files Saved in BMP/PNG Format
You can save the viewer window you are viewing into an image data file in either BMP or
PNG format.  You can attach comments to the file, but the file can include only one line

of comments.
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5.4 Saving Automated Measurement Values for
Waveform Parameters

Operations
Saving Values Automated Measurement  Waveform Parameters
Click  or select File > Save to display the Save File dialog box.  Select the folder
into which you want to save the file, specify the file name, select Waveform Parameter
(*.csv) in Files of type, and then click the Save button.

Select the folder into which you want to save the file

Specify a file name

Select Waveform 
Parameter (*.csv)

Explanation
Files Saved in Waveform Parameters (*.csv) Format
You can save the automated measurement values for the specified waveform
parameters (values displayed in the measurement result display window) in a .csv file.

Saved Data
Among the automated measurement values, the following data is saved.

• Measurement results for block selected in the history window
• Trace measurement results for ch; .el setting for which the cursor display is ON
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5.5 Saving the Display Settings

Operations
Saving the Display Settings
Click  or select File > Save to display the Save File dialog box.  Select the folder

into which you want to save the file, specify the file name, select Setting info (*.xml) in
Files of type, and then click the Save button.

Select the folder into which you want to save the file

Type comments

Specify a file name

Setting info (*.xml)

Explanation
Files Saved in Setting info (*.xml) Format
You can save the display settings specified for the viewer window you are viewing into a
.xml file.  You can also include comments.  Loading a Display Setting file already saved

applies the display settings in the file to waveform views.
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5.6 Converting Multiple Waveform Data Files to
CSV Files

Operations
1. Close the viewer window.

2. Click Tools > Convert to CSV on the XViewer tool bar to display the Convert
to CSV dialog box.

Select the files to convert and options and click Save.
The selected files are stored into the folder in which the originals are included.

Select the 
required file

Set options for 
the file format

Set options for the data format

Note
Select multiple measurement data files in the Convert to CSV dialog box and click Save to
collectively convert the selected files to CSV files.
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Explanation
Setting Options
You can specify the following two options for waveform data files to convert to the CSV
format:

Data format options:
• Compression:  Select None, PP Comp, or Decim
• Compression Rate:  Selectable when Compression is specified.

Select 5, 10, 20, 50, 100, 200, 500, 1000, 2000, 5000, or 10000.

File format options:
• Header:  Select whether to set a header
• Time-Axis:  Select whether to set information about the time-axis

Records Horizontally Arranged
CH1-Record1-data001, CH2-Record1-data001

CH1-Record1-data002, CH2-Record1-data002
CH1-Record1-data003, CH2-Record1-data003
               :                                    :

CH1-Record1-data100, CH2-Record1-data100

CH1-Record2-data001, CH2-Record2-data001

CH1-Record2-data002, CH2-Record2-data002
CH1-Record2-data003, CH2-Record2-data003
               :                                    :

CH1-Record2-data100, CH2-Record2-data100

CH1-Record3-data001, CH2-Record3-data001

CH1-Record3-data002, CH2-Record3-data002
CH1-Record3-data003, CH2-Record3-data003
               :                                    :

CH1-Record3-data100, CH2-Record3-data100

5.6  Converting Multiple Waveform Data Files to CSV Files
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6.1 Setting Up a Printer

Operations
Setting Up a Printer
Select File > Printer Setup.... to display the Printer Setup dialog box.

Select a printer and specify the paper size, orientation, and other settings in the dialog
box, and then click OK.

Select a printer

Select the orientation

Set up the properties 
of the printer

Set up a network printer

Select the paper 
size and feed

Explanation
Set up the printer according to your system configuration.

Chapter 6   Printing Waveforms in the Displayed View
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6.2 Printing Displayed Waveforms

Operations
Setting Up the Print Format
Select File > Print Format to display the Print Format dialog box.  Fill in the comment,

header, and footer fields, specify the print mode settings, and then click the OK button.

Check to print the comments 
on the printout Enter comments

Enter text for 
the header

Enter text for 
the footer

Select print mode Select number of 
windows for LONG

Display a 
Print Preview

Printing
Click  to display the Print dialog box.  Click OK to start printing with the settings you
specified in the Print Format dialog box.

Print button Print dialog box
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Explanation
Printable Information
You can specify the printing of the following types of information on printouts:
• COMMENTS:  Comments (printed under the waveforms.)
• HEADER:  Page header

• FOOTER:  Page footer

Print Mode
Set the following items for the PRINT MODE selections:
• DISPLAY : Mode in which the display on the screen is printed as is
• LONG : Prints the waveforms (main waveform display window), separating them

by the zoom rate specified for the zoomed waveform display window.
(The entire waveform view is printed by the zoomed waveform display
window, starting from the left end.  In the dialog, the size of the zoomed

waveform display window is in units of one window*.)
Set a value of 1 to 10 for WINDOW/PAGE for the number of windows to
be printed on one page.

* The number of windows printed equals (the number of points displayed in the main waveform
display windows) divided by (the number of points displayed in the zoomed waveform display
windows), or (quotient of the division) + 1.

Print Preview
Click the Preview button or select File > Print Preview to switch the viewer window to
the print preview.  This lets you check the layout of the sheet you are going to print.  To
proceed with printing, click the Print button.

Printout Sample

Print Mode :  DISPLAY Print Mode :  LONG

6.2  Printing Displayed Waveforms
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7.1 Connecting to the DL Series

Note
Before attempting to use this function, connect the PC to the DL unit using an appropriate
communications cable.  For details on how to make this connection, see the manual provided
with your DL series unit.

Operations
Setting Up/Adding a Connection
On the Xviewer tool bar, click the CommSetting button to open the Communication
Setting dialog box.  Then, click the Add button to open the Devices dialog box, make the
settings for the connection interface and communications conditions, and then click OK.

Note
• If connections to DL units have already been registered, those connections will be

displayed as a list.  Select the required DL unit and then click the Connect button to
establish the connection with that unit.

• Up to 16 connections can be registered.

• GP-IB connection

• USB conneciton
  (Other than the DL9000 Series)

• USB conneciton
  (DL9000 Series)

• Network connection

Input the GP-IB 
address of the DL 
unit to be 
connected (0 to 30)

Input the USB ID 
number of the DL 
unit to be 
connected 
(0 to 127) Input the serial number of the 

DL9000 unit to be conncted
(9-digit)

Input the IP address of the DL 
unit to be connected

Input the network user name 
for the DL unit to be connected

Input the network password 
for the DL unit to be connected

Chapter 7   Communicating with the DL Series
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Modifying a Connection
On the Xviewer tool bar, click the CommSetting button to open the Communication
Setting dialog box.  Select the required DL unit and then click the Properties button to
open the Devices dialog box, change the settings as needed and then click OK.

Removing a Connection
On the Xviewer tool bar, click the CommSetting button to open the Communication
Setting dialog box.  Select the required DL unit and then click the Remove button to

remove the selected connection.

Establishing a Connection
On the Xviewer tool bar, click the CommSetting button to open the Communication
Setting dialog box.  Select the required DL unit and then click the Connect button to
establish the connection with the DL unit.

Note
If the DL unit contains a very large number of files, it may take some time to establish the
connection.

Select a connection

Establish the 
selected connection

Display the Devices dialog box, in which the settings 
for the selected connection can be changed

Remove the selected connection

Ending a Connection
A connection with a DL unit is ended when you exit from Xviewer.

Note
The connection with a DL unit cannot be ended while a file is being transferred.

7.1  Connecting to the DL Series
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Explanation
Setting Contents
Ensure that the interface settings and communication conditions are the same as for the
DL unit to which you want to connect.  Check the setting contents using the following
menu.

Address/ID Number
DL750, DL750P, DL1600, DL1700E : MISC > Remote Cntl
DL7400 : MISC > Remote Cntrol
DL9000 : SYSTEM > Remote Control > GPIB

Server
DL750, DL750P, DL1600, DL1700E, DL7400 : MISC > Network > TCP/IP Setup
DL9000 : SYSTEM > Network > TCP/IP Setup

> Configuraiton
User Name (for the Network interface)

DL750, DL750P, DL1600, DL1700E : MISC > Remote Cntl > User Account
DL7400 : MISC > Remote Cntrol > User Account
DL9000 : SYSTEM > Remote Control > Network

  (User Name/Password)
Serial No. (for the USB-TMC interface)

DL9000 : SYSTEM > Overview

“unknown” Model Name Display
Once you have made the connection settings and, using those settings, a connection is
made successfully, the model name of the connected device will appear under Model in
the Communication Setting dialog box.  If a connection cannot be established,

however, an error message is displayed and unknown appears as the model name.

Firmware Versions
Xviewer may not be able to establish a connection with a DL unit, depending on the

firmware version of the software installed in that unit.  Xviewer is compatible with the
following firmware versions.

DL750 series : Firmware versions 2.50 and later
DL1600 series : Firmware versions 1.12 and later
DL7400 series : Firmware versions 1.23 and later
DL1700E series : All firmware versions

Transfer Rate
GPIB downloading : 150 to 400 Kbytes/s
USB downloading : 300 to 600 Kbytes/s
Ethernet downloading : 400 to 800 Kbytes/s

USB uploading : 15 Kbytes/s

Note
The transfer rate varies depending on the networking environment and the model being used.

7.1  Connecting to the DL Series
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7.2 Displaying a File List

Operations
Displaying a File List
On the Xviewer tool bar, click the Open DL button to open the Communication Setting
dialog box.  Select the required DL unit and then click the Connect button to establish
the connection with the DL unit and display a file list.

Note
• If a connection has already been established with the required DL unit, the

Communication Setting dialog box does not appear and the file list appears immediately.
• When you click the DL Control button to enable operation of the DL unit from a PC, the

Open DL button is grayed out.
• If the DL unit contains a very large number of files, it may take some time for the file list to

appear.

Changing the Order of/Updating the File List
When you click the Name, Size, Type, or Updated button in the file list, the file list is
sorted based on that clicked item.  Clicking Update on the tool bar causes the file list to

be refreshed based on the latest information.

Update file list using latest information
Change the order of
the list

List of files on 
the DL unit

List of files on the PC
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7.2  Displaying a File List

Thumbnailing Image Files
Clicking Thumbnails on the tool bar causes the image files stored on the DL unit to be

displayed as thumbnails.

Note
• Files other than image files will be displayed as icons.
• Those image files for which there is no thumbnail file to display will be displayed as icons.

Thumbnail display on/off

Icon display (Example)

Changing the Size of the Displayed Thumbnails
Select Tools > Options on the file list menu bar to display the Option dialog box.  Select

a size for the thumbnails (width and height), and then click the OK button.

Explanation
Displaying Realtime Recording Data
On the DL750/DL750P with firmware version 6.01 or later, the file list of the [SCSI,4,0]
folder on the DL750/DL750P can be displayed.  The [SCSI,4,0] folder contains data that
has been real-time recorded on the DL750/DL750P (.wdf data).
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7.3 Manipulating Files

Operations
Downloading from a DL Unit to a PC
If you select a file from the list of files stored on the DL unit, the Download button is

enabled.  If you then click the Download button, the selected file is transferred to the PC.

Note
• Multiple files can be specified for transfer.
• While files are being transferred, the connection to the DL unit cannot be terminated.

Select the required file

Perform download

Indicates the transfer status

Uploading from a PC to a DL Unit
If you select a file from the list of files stored on the PC, the Upload button is enabled.  If

you then click the Upload button, the selected file is transferred to the DL unit.

Note
• Files can be transferred from the PC to the DL unit (upload) only when the USB interface

is being used for the connection.
• Multiple files can be specified for transfer.
• While files are being transferred, the connection to the DL unit cannot be terminated.
• The data in the [SCSI,4,0] folder in which the realtime recording data (DL750 series only)

can be downloaded to the PC.  However, you cannot create a directory in the folder or
upload data to the folder.

Select the required file Perform upload

Indicates the transfer status
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7.3  Manipulating Files

Deleting a File
If you select a file from the file list and then click the Delete button, the selected file is

deleted.

Note
• When you delete an image file, the corresponding thumbnail file is deleted at the same

time.
• A folder cannot be deleted.

Reading a Waveform Data File
If you select a WVF-format waveform data file (*.wvf / *.wdf) from the file list on the PC,
the Open in Viewer button is enabled.  If you then click the Open in Viewer button, the

selected file is read and the waveform data that it contains is displayed in the Viewer
window.

Display required file (waveform data) in the Viewer window
Delete file

Select required file

Creating a Folder
Select Tools > New Folder on the file list menu bar to display the folder creation dialog
box.  Input a name for the new folder, and then click the OK button.

Note
• The new folder will be created under the current directory of the file list.
• For the folder name, you can specify ASCII characters (alphanumerics, etc.) only.

Double-byte characters cannot be used.
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Explanation
Cautions to Observe When Transferring a Waveform Data File
A WVF-format waveform data file (*.wvf) cannot be opened unless there is an .hdr file
with the same name in the same folder.  Therefore, when transferring a WVF-format file,
be careful to also transfer the corresponding .hdr file.

Note
Right click the files selected to be manipulated, and select one of the following from the
shortcut menu.
Download: Available when DL internal files or folders are selected
Upload: Available when PC files or folders are selected
Delete: Available when a file is selected
Create folder: Available whether a file, folder, or nothing is selected
Update to Latest Information: Available whether a file, folder, or nothing is selected

When DL internal files 
are selected

When PC files 
are selected

When folders are 
selected

When right-clicking 
with nothing selected

7.3  Manipulating Files
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7.4 Operating DL Series Instruments from a PC
(Other than the DL9000 Series)

Operations
Displaying the Control Screen
Click the DL Control button on the Xviewer tool bar to display the Communication
Setting dialog box.  If you then select the required DL unit and then click the Connect
button, a connection with the DL is established and the control screen (an image of the
front panel) appears.

Note
• If a connection has already been established with the required DL unit, the

Communication Setting dialog box does not appear and the control screen appears
immediately.

• When you click the Open DL button to display a list of files on the DL unit, the DL Control
button is grayed out.

Controlling the Update of the Display
Click the UPDATE button on the control screen to forcibly update the control screen
display.  If you click the PAUSE button, the update of the control screen is stopped
temporarily.  Clicking the PAUSE button again restarts the update of the screen display.

Operation of the Control Screen
The control screen allows you to operate or control a DL unit using the PC's mouse or

keyboard.

Pause screen update

Set display options
Save image of the screen
Update screen display

Setting Screen Display Options
Click the OPTION button on the control screen to display the Option dialog box.  Set the

control screen display size, the refresh rate, and display brightness, and then click the
OK button.

Select screen size

Select screen refresh rate

Set screen brightness
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7.4  Operating DL Series Instruments from a PC (Other than the DL9000 Series)

Saving an Image of the Screen
Click the CAPTURE button on the control screen to display the file save dialog box.

Select the folder into which you want to save the file, specify the file name, select a save
color and then click the OK button.

Select a file save location

Input a file name

Select a save color

Note
Press the SHIFT key (keyboard) and click the CAPTURE button (control screen) to copy the
screen to the clipboard.

Explanation
Option Settings
The following settings can be made for the screen display options.
• Display size (Size) : Select 100%, 75%, or 50%
• Display refresh rate (Update Interval) : Select 1 sec, 2 sec, 5 sec,

10 sec, 30 sec, 1 Min, 5 Min, 10 Min, 20 Min,
30 Min, 1 hr, or Minimum

• Brightness (Brightness) : Adjust using the slide bar

Note
• Depending on the network transmission method or the communications load, the actual

display refresh rate may be slower that the set value.
• When you select Minimum for the screen refresh rate, the fastest possible refresh rate for

your environment is set automatically.  Note that if the connection to the DL unit is made
via a network, the network load may affect the refresh rate.

Using the Display Update Button
• The UPDATE button is used to forcibly refresh the display when, for example, a slow

refresh rate has been set or refresh has been temporarily stopped (when the PAUSE
button is available).

• The PAUSE button is used to temporarily stop refresh when the ON/OFF settings of
many items must be changed, values must be entered using the keyboard, or when
better system response is needed.

Screen Image Save Format
When you click the CAPTURE button to save a screen image, an image of the currently

displayed screen is saved as a BMP-format file.
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Screen Image Save Color
When you save a screen image, you can select and of the following colors.
• OFF : Screen image is saved in monochrome
• ON : Screen image colors are saved as is
• ON (Reverse) : Other than the channel colors are saved in monochrome
• ON (Gray) : Other than monochrome colors are saved as grays

Using the Mouse
If you position the mouse cursor to a control key or knob on the control screen, the

mouse pointer (icon) changes, indicating that that key or knob on the screen can be
operated.  The displayed icon and the action of the mouse changes depending on where
on the control screen it is positioned.

Mouse Pointer 

Position

Operation key

Soft key menu or 

dialog box

Voltage axis information 

display area

Time axis information 

display area

Jog shuttle left- and 

right-hand areas

V/DIV knob left- and 

right-hand areas

T/DIV knob left- and 

right-hand areas

Displayed Icon & 

Mouse Action

Click

Click

Wheel

Click

Wheel

Wheel

Click

Wheel

Click

Wheel

Click

Wheel

Setting Operation

Same as pressing an operation key

Same as pressing a soft key or a button

Same as turning the jog shuttle

Same as pressing a channel key

Same as turning the V/DIV knob

Same as turning the T/DIV knob

Same as turning the jog shuttle to the left of the right

Same as turning the jog shuttle

Same as turning the V/DIV knob to the left or the right

Same as turning the V/DIV knob

Same as turning the T/DIV knob to the left or the right

Same as turning the T/DIV knob

Example of Using the Control Screen
Using the Operation Keys

Click to select Sine

7.4  Operating DL Series Instruments from a PC (Other than the DL9000 Series)
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Soft Key Menu Operation

Turning the wheel here allows you to set a record length
Clicking here selects Envelope

Jog Shuttle Operation

Clicking or turning the wheel here lets you set a record length

V/DIV Knob Operation

Click or turn the wheel

Voltage axis information 
display area

Turning the wheel changes 
the V/div setting

7.4  Operating DL Series Instruments from a PC (Other than the DL9000 Series)
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T/DIV Knob Operation

Turning the wheel changes 
the T/div setting

Click or turn the wheel

Time axis information 
display area

Dialog Box Operation
• Position the mouse cursor to the item you want to turn ON:

Click the jog shuttle or turn the wheel

• ON/OFF setting: Click SELECT or click the item directly, as shown
below

7.4  Operating DL Series Instruments from a PC (Other than the DL9000 Series)
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7.5 Operating DL9000 Series Instruments from a
PC

Operations
Displaying the Control Screen
Click the DL Control button on the Xviewer tool bar to display the Communication
Setting dialog box.  If you then select the required DL9000 unit and then click the

Connect button, a connection with the DL9000 is established and the control screen (an
image of the front panel) appears.

Note
• If a connection has already been established with the required DL unit, the

Communication Setting dialog box does not appear and the control screen appears
immediately.

• When you click the Open DL button to display a list of files on the DL unit, the DL Control
button is grayed out.

Controlling the Update of the Display
Choose Menu > View > Update in the control screen to force an update of the control
screen. Choose Menu > View > Pause to pause updating of the control screen.  To
restart display updating, choose View > Pause again.

Operation of the Control Screen
The control screen allows you to operate or control a DL unit using the PC’s mouse or

keyboard.

Screen Display Size
Choose Menu > View > Zoom > Smaller, Standard, or Larger.  The control screen

changes to the selected size.
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Saving an Image of the Screen
Choose Menu > File > Save > Image in the control screen to display the file save dialog

box.  Select the folder into which you want to save the file, specify the file name and then
click the OK button.

Select a file save location

Input a file name

Note
If you hold down the ctrl key and right click in the control screen, you can select from the
following settings menu.
• Save > Image
• Zoom > Smaller, Standard, Larger
• Pause
• Update
• Options

Explanation
Screen Display Size
You can select the zone from below.

Smaller, standard, larger

Display Update Interval
You can select the zone from below.

300 ms, 500 ms, 1 s, 2 s, 5 s, 10 s

Note
Depending on the network transmission method or the communications load, the actual
display update interval may be slower that the set value.

Display Update Operation Control
• Forced updating is used when setting a slow display update rate or when pausing

display updating (by choosing Menu > View and selecting Pause).

• Pause is used to improve the response when turning many items ON/OFF at once, or
when entering numerical and other values with the keyboard.

Screen Image Save Format
An image of the currently displayed screen is saved as a BMP-format file.

7.5 Operating DL9000 Series Instruments from a PC
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Using the Mouse
If you position the mouse cursor to a control key or knob on the control screen, the

mouse pointer (icon) changes, indicating that that key or knob on the screen can be
operated.  The displayed icon and the action of the mouse changes depending on where
on the control screen it is positioned.

Mouse Pointer 

Position

Operation key

Roraty-knob left- and 

right-hand areas

Center of POSITION, 

SCALE knob

 

POSITION, SCALE, 

T/DIV, and MAG knob 

left- and right-hand 

areas

Displayed Icon & 

Mouse Action

Click

Click

Wheel

Click

Wheel

Click

Wheel

Setting Operation

Same as pressing an operation key

Same as turning the rotary knob to the left of the right

Same as turning the rotary knob

Same as pushing the POSITION knob or SCALE 

knob 

Same as turning the POSITION, SCALE, T/DIV, and 

MAG knob to the left or the right

Same as turning the POSITION, SCALE, T/DIV, and 

MAG knob

Example of Using the Control Screen
Using the Operation Keys

Click to display the cursor menu.

Rotary Knob Operation

Click or turn the wheel

7.5 Operating DL9000 Series Instruments for a PC
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7.5 Operating DL9000 Series Instruments for a PC

T/DIV Knob Operation

Click or turn the wheel

SCALE Knob Pushing Operation

Click
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7.6 Downloading DL Series Waveform Data

Operation
Click the ACQ save button on the Xviewer toolbar.  A control screen and file save dialog
box open.  If the connection with the DL is not established, the Communication Setting

dialog box opens.  Establish a connection with the DL according to the operations given
in section 7.1.

Saving the Waveform Data
Set the destination and file name and click the OK button.  The extension is .wvf.

Explanation
Waveform data can be downloaded (saved) to the PC.
Click the CAPTURE button on the control screen to display the file save dialog box.  Set
Save as type to *.wvf, specify the file name, and select Save to download (save) the

waveform data.

Waveforms That Are Saved
All waveforms including computed waveforms displayed on the control screen are saved.
However, if multiple history waveforms are displayed with the history memory function,
only the waveform selected with Select Record is saved.

Applicable Models
• DL750 series (firmware version 6.01 or later)

• DL1600 series (firmware version 1.30 or later)
• DL1700E series (software version 2.11 or later)
• DL7400 series (software version 2.11 or later)

Note
• If the data compression setting of the DL series (P-P Comp, Decim, etc.) is ON, turn data

compression OFF before saving the waveform data.
• On the DL1600 series, waveform data cannot be downloaded if the record length is

greater than or equal to 8 MW.
• When multiple history waveforms are displayed, the DL series settings are changed when

downloading is executed as follows:
DL750 series and DL7400 series: HISTORY > DisplayMode > One
DL1600 series and DL1700E series: HISTORY > Display > One

• Sub waveforms acquired using the dual capture function on the DL750 are not saved.
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8.1 Troubleshooting

Problem Probable Cause/Corrective Action

Xviewer cannot communicate with the
DL7400 series/DL750 series/DL1700E
series/DL1600 series.

A file cannot be opened.

A trace name is incorrectly displayed.

A voice memo cannot be played back.

Files saved with real time recording on
the DL750 series cannot be loaded.

Comments in files saved on the DL750
series are not displayed.

The Yokogawa web site is inaccessible.

A message stating “Insufficient memory.
Terminate any unnecessary
applications.” appears.

Chapter 8   Troubleshooting

The GP-IB or USB interface cable is incorrectly
connected.  Connect the cable correctly.

The address specified for the GP-IB interface is
incorrect.

The ID specified for the USB interface is incorrect.

No USB driver has been installed.

A .hdr file having the same name as the file you
are trying to open is not present in the same folder.
Place the header file in the folder.
The file is not of a type that the DL series Xviewer
can handle.

If a trace name includes a space, it may not
appear correctly.

Your PC does not support audio playback.  Use
Xviewer on a PC with sound capabilities.

The installed DL750.dll may not be of the latest
version.  Install the latest version of DL750.dll.

DL750.dll does not exist in the folder in which
Xviewer is installed, or an old version of DL750.dll
exists.  Install the latest version of DL750.dll.

Your PC is connected with the Internet.

There is insufficient memory.  Reduce the number
of waveforms to be loaded, or terminate another
application.
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8.2 Viewing Version Information

Operations
Select Help > About Xviewer.  The version of Xviewer you are currently using is
displayed.
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8.3 Starting Online Help

Operations
Click  or choose Help > Help > User’s manual on the tool bar.  If Acrobat Reader is
installed in the PC, it launches, and a pdf file of this instrument’s user’s manual is

displayed.

Explanation
Online Help
You can display a pdf file of this instrument’s user’s manual.  If a notice of alteration has
been made, you can display a pdf of the notice by choosing Help > Help > Notice of
Alteration from the tool bar.

Displaying the Latest User’s Manual/Notice of Alteration
If you copy the following pdf files to the installation folder specified in step 7 on page ix,

you can display the latest user’s manual and notice of alteration in the online help.
• File name of the latest user’s manual: IM701992E.pdf
• File name of the latest notice of alteration: AlterationsE.pdf

You can download the latest versions of the user’s manual and notice of alterations from
the following Web site under Download Version Upgrade Program > Procedure
(User’s Manual & Notice of Alteration).
http://www.yokogawa.co.jp/tm/Bu/701992/

Note
Adobe Reader by Adobe Systems is required to open PDF files.  You can download Adobe
Reader from the following Web page.
http://www.adobe.com/products/acrobat/readstep2.html
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8.4 Visiting the Yokogawa Electric Web Page

Operations
Select Help > YOKOGAWA Web Page > Test & Measurement, or Help >
YOKOGAWA Web Page > Xviewer to access our web page.

Explanation
When your PC is connected to the Internet, you can visit our web page.

Test & Measurement: Displays our Test & Measurement top page.
Xviewer: Displays the Xviewer page.
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