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What’s new in Coulomb 3 
 

Coulomb now runs on Mac, PC, and Unix computers: The program is very fast on a PC, has not 
yet been tested on the Vista operating system. For Mac, the operating system must be OS 10.X 
and later.  
 
Matlab 7.X or higher is required to run Coulomb. Coulomb 3.1 is now a Matlab application 
(www.mathworks.com), so you will need to install Matlab first. Make sure you also install the 
Matlab Mapping tool box in your Matlab library.  
 
Many features were added or enhanced: 
 

• You can now use latitude/longitude directly in the input and output files, and can now add 
active fault traces, coastlines, and earthquakes from online catalogs, websites, or Coulomb-
bundled files. These overlays can then be included compactly in the saved input files in 
.mat (Matlab binary) format so they automatically plot when the input file is re-run.  

 
• Stress changes can be resolved on faults in their individual rake directions, or on specified 

rakes. Resolved stress changes can be viewed graphically in 3D or output to tables. Shear 
and normal stress changes can also be imaged, and the friction can be changed on the fly. 
Draped wireframe and 3D deformation graphic outputs can be spun and tilted. 

 
• The Coulomb output files can now be exported automatically to Google Earth. This is 

implemented by using the ‘coulomb2googleearth’ plug-in. 
 

• You can use comprehensive moment centroids and MW to quickly create input faults with 
lengths, widths, and slip scaled by empirical relations. The slip on these sources can then 
be easily tapered for more realistic stress distributions. 

 
• Any of the 150 variable-slip source models for earthquakes in Martin Mai’s SCRMOD 

online database can be loaded into Coulomb as input files. 
 
• Active fault files for California, Japan and Turkey (both Le Pichon et al and Armijo et al 

interpretations of the Marmara sea faults) are included. Earthquake catalogs in any of 14 
formats can be filtered from websites and loaded into Coulomb. You can now graphically 
plot the Coulomb stress imparted to earthquake nodal planes. 

 
• The 1377-patch Fault-Section Database (part of the USGS-California Geological Survey 

California Reference Geologic Fault Parameter Database) is included as a Coulomb input 
file in three formats. These files supply all geometrical features needed to use the 
database faults as sources or receivers, including the top and bottom of each fault patch, 
the patch slip rate and rake. The fault network can be used to find the stress change 
caused by any earthquake on the known surrounding faults given their presumed rakes, 
and it can be also used to implement simple interseismic stressing by using the sources as 
virtual dislocations, which uses negative slip rates times the time period to get stress. Use 
‘CA_fault_database_slip_rate.mat’ to plot the fault slip rates or to use the sources as 
virtual dislocations for interseismic stressing. To resolve the stress imparted by an 
earthquake source on each receiver faults given the rake of each fault, use 
‘CA_fault_database_rake.mat’.  If you want to use the receiver faults and choose a 
common rake, use ‘CA_fault_database_noslip.mat’. Note that these are large files and 
take a long time to run. 

 
New to Coulomb 3.1 relative to Coulomb 3.0: 
 
Merging variable-slip sources to one input file (‘merge_input_file’ plugin) (Sec. 4.13). Making 
smoothed seismicity density plots (5.5). User-selected contour intervals (Sec. 6.7 and 7.6). Using 
the strike/dip/rake/friction slider in the Stress control panel (Sec. 7.2). Active fault files for the 
western US, Japan, and Turkey (with a readme file references) are now included.
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Chapter 1   
 
INTRODUCTION 
 
1.1 Why Coulomb? The rationale and philosophy of this program 
 
Coulomb is intended both for publication-directed research and for college and graduate school 
classroom instruction. It is designed to let one calculate static displacements, strains, and stresses 
caused by fault slip, magmatic intrusion or dike expansion/contraction. The displacements, 
strains, and stresses can be on calculated at any surface at any depth.   
 
There is now abundant evidence to support the hypothesis that faults interact by the transfer of 
stress; this is evident on the short time scales of earthquake sequences and aftershocks, and on 
longer time scales associated with the inter-event time of the largest shocks that occur in a given 
region. Key review papers include: Harris, R.A. (1998), Introduction to special section: Stress 
triggers, stress shadows, and implications for seismic hazard, J. Geophys. Res., 103, 24,347–24,358; 
Stein, R.S. (1999), The role of stress transfer in earthquake occurrence, Nature, 402, 605–609; King, 
G.C.P., and M. Cocco (2000), Fault interaction by elastic stress changes: New clues from 
earthquake sequences, Adv. Geophys., 44, 1–36; Freed, A.M. (2005), Earthquake triggering by 
static, dynamic, and postseismic stress transfer, Ann. Rev. Earth Planet. Sci. 33:335–67, doi: 
10.1146/annurev.earth.33.092203.122505; Steacy, S., J. Gomberg, and M. Cocco (2005), 
Introduction to special section: Stress transfer, earthquake triggering, and time-dependent 
seismic hazard, J. Geophys. Res., 110, B05S01, doi:10.1029/2005JB003692. There is also evidence 
that faults and magmatic systems interact as well, and that static stress changes influence 
intrusions and eruptions. Undoubtedly, other processes not included in Coulomb are also 
important, such as dynamic stresses, pore fluid diffusion, and viscoelastic rebound. Further, 
basins and crustal layering modify the stresses in comparison to the elastic halfspace 
implemented in Coulomb. Nevertheless, we believe that a simple tool that permits exploration of 
a key component of earthquake interaction has great value for understanding and discovery. 
 
Coulomb 3.1 is designed to investigate Coulomb stress changes on mapped faults and earthquake 
nodal planes, and is intended both for publication-directed research and for university teaching 
and instruction. One can calculate static displacements (on a surface or at GPS stations), strains, 
and stresses caused by fault slip, magmatic intrusion or dike expansion. Problems such as how an 
earthquake promotes or inhibits failure on nearby faults, or how fault slip or dike expansion will 
compress a nearby magma chamber, are germane to Coulomb. Geologic deformation associated 
with strike-slip faults, normal faults, or fault-bend folds is also a useful application. Calculations 
are made in an elastic halfspace with uniform isotropic elastic properties following Okada [1992].  

We believe that one learns best when one can see the most and can explore alternatives quickly. 
So the principal feature of Coulomb is ease of input, rapid interactive modification, and intuitive 
visualization of the results. The program has menus, sub-menus, check-items, and dialogue boxes 
to ease operation. The internal graphics are suitable for publication, and can be easily imported 
into illustration or animation programs for further enhancements.  

 
1.2 Hardware/software requirements: 
• Macintosh OSX, Windows PC, or UNIX computer 
 Note: We have not yet tested Coulomb 3.1 on Unix machines or the Vista operating system, 

but it does run on Intel Mac’s. 
• Matlab 7.X or higher is required. There are a few Matlab functions that work on PCs but not 

Mac’s. Matlab 7.5 is not advised; its full of bugs. 
• A color monitor of at least 600 x 400 pixel resolution. A laptop screen (1024 x 768 pixels) is 

fine. 
• A text editor to modify ascii input files, and a spreadsheet to read tab-delimited text files. 

Some output files are created as .csv (Excel-friendly) files. 
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1.3 Recommended extras: 
• A vector illustration program, such as Adobe Illustrator, is strongly recommended. 
• When editing input files, we recommend that you use a text editor that allows you to 

distinguish spaces from tabs, such as BBEdit (BBEdit Lite is free from 
http://www.barebones.com/) or Notepad on a Windows PC. Regardless of the editor, use a 
non-kerning (uniform-spacing) font, such as Monaco, so that numbers stay aligned. 

• Google Earth (which is free) 
 
1.4 User’s Guide Alerts 
1. Any words of wisdom in the manual are printed in red! 
2. The images used in the manual to show you what you will see on the screen were captured at 

low resolution (72 dpi). But don’t worry: you will save full-resolution vector files. 
 
1.5 Help menu 
This can be useful; there is a search command.  
 
1.6 Cover images 
The full-page cover page was designed by Serkan Bozkurt (now at Geomatrix Consulting) by 
importing Coulomb numerical output into ArcGIS. All of the interior cover images were made 
exclusively from Coulomb 3.1. 
 
1.7 Acknowledgements 
We are grateful for generous support by the Office of Foreign Disaster Assistance (OFDA) of the 
U.S. Agency for International Development (USAID) to code, test, and calibrate Coulomb 3.1.  
Geoffrey C.P. King’s 1995 GEN inspired Coulomb 1.0. We thank many users for testing the 
functions, finding errors and suggesting improvements.  
 
1.8 Citing Coulomb 
 
 
Coulomb is intended for teaching and research. If you use Coulomb in research you 
submit for publication, we ask only that you cite these two papers: 
   
Toda, S., R. S. Stein, K. Richards-Dinger and S. Bozkurt (2005), Forecasting the 
evolution of seismicity in southern California: Animations built on earthquake stress 
transfer, J. Geophys. Res., B05S16, doi:10.1029/2004JB003415. 
 
Lin, J. and R.S. Stein (2004), Stress triggering in thrust and subduction earthquakes, 
and stress interaction between the southern San Andreas and nearby thrust and 
strike-slip faults, J. Geophys. Res., 109, B02303, doi:10.1029/2003JB002607. 
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1.9 Some key papers that explain and use Coulomb 
 
Introduction without jargon or math: 
 Stein, R.S., Earthquake conversations, Scientific American, 288 (1), 72-79, January 2003. 

(http://quake.wr.usgs.gov/research/deformation/modeling/refs/ross_refs.html) 
 
Coulomb stress change concepts (for strike-slip faults): 
 King, G.C.P., R.S. Stein, and J. Lin, Static stress changes and the triggering of 

earthquakes, Bull. Seismol. Soc. Amer., 84 (3), 935-953, 1994. 
              (http://quake.wr.usgs.gov/research/deformation/modeling/papers/landers.html) 
 
Coulomb stress concepts (for thrust faults and interaction between thrust and strike-slip faults): 
 Lin, J., and R.S. Stein, Stress triggering in thrust and subduction earthquakes, and stress 

interaction between the southern San Andreas and nearby thrust and strike-slip faults, J. 
Geophys. Res., 109, B02303, doi:10.1029/2003JB002607, 2004. 

             (http://quake.usgs.gov/research/deformation/modeling/papers/jlin/lin_stein04.html 
 
Dislocation solution formulae: 
 Okada, Y., Internal deformation due to shear and tensile faults in a half-space, Bull. 

Seismol. Soc. Amer., 82 (2), 1018-1040, 1992. 
 
Application of Coulomb to seismic hazard: 
 Toda, S., R.S. Stein, P.A. Reasenberg, and J.H. Dieterich, Stress transferred by the Mw=6.5 

Kobe, Japan, shock: Effect on aftershocks and future earthquake probabilities, J. Geophys. 
Res., 103, 24,543-24,565, 1998. 

               (http://quake.usgs.gov/research/deformation/modeling/papers/kobe.html) 
 Toda, S., and R.S. Stein, Response of the San Andreas fault to the 1983 Coalinga-Nuñez 

Earthquakes: An application of interaction-based probabilities for Parkfield, J. Geophys. 
Res., 107, 10.1029/2001JB000172, 2002. 

 (http://quake.wr.usgs.gov/research/deformation/modeling/papers/parkfield/parkfiel
d.html) 
Toda, S., R. S. Stein, K. Richards-Dinger and S. Bozkurt (2005), Forecasting the evolution 
of seismicity in southern California: Animations built on earthquake stress transfer, 
J. Geophys. Res., B05S16, doi:10.1029/2004JB003415. 
http://quake.wr.usgs.gov/research/deformation/modeling/papers/2005/summaries/l
anders05JGR.html 

 
Application of Coulomb to dike inflation: 
 Toda, S., R.S. Stein and T. Sagiya, Evidence from the 2000 Izu Islands swarm that 

seismicity is governed by stressing rate, Nature, 419, 58-61, 2002. 
 (http://sicarius.wr.usgs.gov) 
 
Application of Coulomb to earthquake-volcano interaction: 

Nostro, C., R. S. Stein, M. Cocco, M. E. Belardinelli and W. Marzocchi, Two-way coupling 
between Vesuvius eruptions and southern Apennine earthquakes (Italy) by elastic stress 
transfer, J. Geophys. Res., 103, pp. 24,487-24,504, 1998.  
http://quake.wr.usgs.gov/research/deformation/modeling/papers/nostro.html 
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Chapter 2 
 
THE KEYS TO THE CITY, AND A QUICK TOUR 
 
 
2.1 The most important things to know about Coulomb 
 

• Source vs. receiver faults (p. 11) 
Sources have slip and impart stress; receivers do not have slip and receive stress 

 
• Coulomb failure hypothesis, Δσφ = Δτσ + µ ’ Δσν   (p. 35) 

Failure is promoted when the Coulomb stress increases. Dsf is the change in failure stress 
on the receiver fault caused by slip on the source fault(s), Dts is the change in shear stress 
(positive in the direction of receiver fault slip), Dsn is change in normal stress (positive when 
the receiver fault is unclamped), and m’ is effective fault friction coefficient on the receiver 
fault. 

 
• How faults are defined in the input files  (p. 16) 

Right-hand rule for start/fin. points, positive dip, rt-lat/reverse or rake/net slip 
 
• Coulomb stress on specified vs. optimally-oriented planes (p. 36) 
  assumed slip directions vs regional stress; visualizing slip lines, principal axes 
 
• Coulomb Figures  (p. 27) 
  “dead” editable vector .pdf files vs. “live” matlab 3D .fig files that can be spun 
 
 •  ‘inp’ vs. ‘mat’ input files  (p. 26) 
  .inp is editable text; .mat is a binary file, but can include fault and quake overlays 
 
• Keep an eye on the command window  
  For calculation progress, input/output file names, input source moment, errors 
 
• Start simple, and add complexity if needed later  

Even if you have a detailed variable-slip source model, start with idealized faults and 
develop intuition about the problem. Only then add more realistic detail. 

 
• For classroom instruction, use Cartesian coordinates unless you want to use overlays  

Its quicker and easier 
 
• How receivers are defined  (p. 38) 
  Specified faults via Aki-Richards, subdivided receivers, CMTs, and nodal planes: 
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2.2 A quick tour of Coulomb 3.1 
 
Here we just want you to learn the procedure to display and output graphics, and to save the 
results. We always recommend that you save all your current working documents frequently to 
prevent lost of files in the event of program crashes. 
 
Menus and their pull-down items turn from light white to black as they become options. Here is 
the procedure to lunch Coulomb: 
 

      
 

1. Launch Matlab on your computer. In the Matlab menu bar top line, click on the  icon 
enter the path of “Coulomb 3.1 folder” in your computer. For example, in the example shown 
below, the “Coulomb 3.1 folder“ has a path of “/Users/jlin/Desktop/Coulomb 3.1 folder”. 

 

 
 
2. In the Matlab Command Window, type “coulomb”. Coulomb will take 30 seconds or so to 

check the download site and notify you if a newer version is available. Always migrate to the 
latest version.  

 

 
 
3. Choose Input > Preferences. Colors, line widths, the ‘color map’ (the smoothly varying color 

gradient maps), and the output file folder can all be changed (below left). For input files with 
lat/lon information, you can also choose to plot maps with lat/lon rather than km frame tics. 
For now, leave them in the default setting. Note that ‘Fault’ refers to the source fault, not the 
active fault file. Replace screen shot; replace ‘Circle diameter’ for Earthquake to ‘Symbol size’ 
for Earthquake and Volcano. 
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4. In the pop-up Coulomb 3.1 window, choose Input > Open existing input file (above right). In 

the pop-up Open input file window, change to sub-directory “input_files”. Choose the 
“Example-2(LL)_lonlat.inp” from the dialog box, then hit <rtrn>. The program will 
automatically plot the 2D map view of the Grid menu in Functions.  

 
5. Once you release the mouse button, the calculation is performed and the program displays 

the result in the Coulomb 3.1 window. It’s a simple grid with a NE-striking fault in the middle 
of the grid, as shown below. The bottom right corner also shows the version of the Coulomb 
program you are using, current date/time, name of the input file you are using, type of 
calculation for the image, and the calculation depth. 

 

          
 
6. Now try, Functions > 3D grid, and play with the zoom  and swivel  tools. If you want 

to save this image, choose File > Save As. Rename the file in the dialog box, and save it as 
figure of one of the several types. Do not use “main_menu_window.fig” as the filename. 

 
7. You also have the options to Zoom In, Zoom Out, Pan, and Rotate your image by clicking on 

the lower line on the Column 3.0 menu bar. You can also perform these operations by 
choosing items in the Tools pull-down menu. 

 
8. If you click Functions > Displacements, in addition to making an image on your Coulomb 3.1 

window, a numerical output file called “Displacement.cou” will appear in the sub-folder 
you designated in the Preferences menu. Similarly, if you click Functions > Stress, a text 
output file called “dcff.cou” will be created and can be opened in Excel. 

 
9. To close the Coulomb 3.1 window, click Input > Quit. Do not quit out of Matlab if you want to 

continue with Coulonb. (If you wanted to quit Matlab program, type “exit” in the Matlab 
Command Window.) 
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Chapter 3   
 
CONCEPTS, DIMENSIONS AND SIGN CONVENTIONS 
 
This chapter briefly explains the things you must understand to use the software correctly and to 
avoid meaningless output. 
 
3.1 The crucial concept of source and receiver faults 
Source faults have slip, and so they impart stress to the surrounding crust and faults. Receiver 
faults have no slip (slip=0.0 m in the input files). Source and receiver faults otherwise look 
identical in the input files. The stress imparted by source faults are resolved on the receiver faults 
through the command Functions > Stress > Calc. stress on faults. Further options for resolving 
the stress on the receiver fault are controlled by the Stress on faults control panel, which 
automatically appears.  
 
3.2 Calculation procedure 
1. Launch Matlab; set the Matlab path to working directory “Coulomb 3.1 folder”. 
2. Type “coulomb” in Matlab Command Window. 
3. In Coulomb 3.1 window menu bar, choose Input> Open existing input file. 
4. In Coulomb 3.1 window menu bar, choose Functions > Grid, Displacements, Strain, or 

Stress. Many of these selections trigger requests for additional input, and let you modify the 
parameters in temporary windows. When you click “Calc. & view”, calculations are 
performed and a new image is displayed. 

5. You can perform many operations to the image on the Coulomb 3.1 window, including 
Zoom In, Zoom Out, Pan, Rotate 3D, Data Cursor, Insert Color Bar, Insert Color Legend, 
etc. You can choose these operations either by clicking the lower menu in the Coulomb 3.1 
window or the Tools pull down menu bar. While the graphic plot is open, you save this plot. 

6. To print a plot, save it as a pdf, and then print the small vector file from Acrobat Reader or an 
illustration program. Currently, the File > Print cmd in Matlab does not work properly. 

7. After you have finished all calculations, quit MATLAB.   
 
3.3 To change parameters interactively 
Most of the settings and parameters can be changed either by modifying an input file using a text 
editor, or by changing them interactively within Coulomb. Choose Functions > Change 
parameters. Parameters changed within the software interactively are transient and will not 
permanently modify the input file. Every time you select Input > Save input file, all current 
selections will be saved in an input file. Change the name of the file if you do not want it 
overwritten. 
 
3.4 To save, print, or modify a plot 
Choose File > Save As… We recommend you choose pdf, a compact vector format. Rename the 
file from the default ‘main_menu_window.fig’ or it will overwrite an important file. You then 
print the pdf from Acrobat Reader, or from an illustration program if you would like to spruce it 
up. Currently, the File > Print command in Matlab does not work properly. 
 
 
3.5 Coordinates, units, and sign conventions 
Coulomb 3.1 calculates in the (x, y, z) Cartesian coordinate system. When the lat/lon of the corner 
grid points are specified in the input file, it can also plot in lat/lon. In the map view projection on 
the monitor, x is positive from left to right, y is positive from bottom to top, z is positive upwards 
for displacement. DEPTH is positive downwards from the Earth’s surface. We use the standard 
Aki & Richards (1980, 2002) sign conventions for fault geometry and slip. The units for the input 
parameters are the following (see Chapters on Input and Output files for more detail): 
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Input parameters and their dimensions (think bars and meters) 
 
PR1    Poisson’s ratio: [dimensionless, -1 to 0.5]; 0.25 is typically used, and 0.5 is an 
imcompressible volume, such as can be used to make balanced cross-sections. 
E1  Young’s modulus: [bars]; 8x105 bars is typically used 
FRIC Friction coefficient: [dimensionless; roughly 0-1]; 0.4 is often used; 0.65 is for dry 
Byerlee’s law friction, 0.0-1.0 is typically considered the limits for the crust. 
Sym Obsolete legacy from Coulomb 1.0; ignore it 
 
Directions, angle, and dip: [degrees; dip must be positive] 
Grid and fault positions (x, y): [km] 
Depth: [km] downward is positive 
Displacements: [m] 
Faults: Right-lateral is positive, and reverse slip is positive [m] 
Dikes: Opening displacement is positive [m] 
Point Source: Inflation is positive [m3] 
Regional stress tensor, S1, S2, S3: positive in compression [bars] 
 
Output parameters and their dimensions 
 

Displacement: [m] North, East, and Up are positive 
Shear Strain: [dimensionless] Right-lateral is positive 
Principal Strain: [dimensionless] Extension is positive (tensor notation) 
Dilatational Strain: [dimensionless] Dilatation is positive 
Stress: [bars] Right-lateral and unclamping are positive 

 
 
 
Shear modulus, G.  Young’s modulus [E] and Poisson’s Ratio [PR] are specified in the input file. 

G = E/[2(1+PR)]. So the shear modulus for PR=0.25 and E=8x105 bars, G=3.2x105 bars or 
3.2x1011 dyne-cm.  
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Chapter 4   
 
BUILDING INPUT FILES 
 
All Coulomb calculations require input files; some require successive information for which you 
will be prompted. If an input file is improperly-formatted (e.g., it has tabs, or the number of faults 
is inconsistent with the ‘#fixed=’, a warning dialog will appear. If it is a text (.inp) file, you must 
modify the input using text editor. If it is a binary (.mat) file you cannot use it. You can also create 
an input file interactively or modify an existing file in Coulomb. Open this input file in a text 
editor: 
 

 
 
All numbers need a decimal point, except for the line starting “#reg1=” and the first three 
characters of the source parameters marked ‘#’. All format statements are shown at the end of 
this chapter. Right-lateral and reverse slip are reckoned positive (negative values denote left-
lateral and normal slip); dip must always be positive. “#reg2=” is an obsolete inheritance from 
Coulomb 1.0; ignore it. 
 
There is an alternate ‘rake’ input format that specifies rake (°) and net slip (m). This permits one 
to calculate the stress change on receivers (faults without slip) in their rake directions, where for 
example, a left-lat. stress increase would inhibit failure on a right-lateral fault. Try  Input > Open 
& edit input file > ‘Example-2(LL)rake.inp’ to see this: 
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4.1 Structure and format for input files 
An input file is composed of parameters for the halfspace, regional stress field, source fault 
positions and slip, receiver fault positions, grid information, graphical representation, and 
optional cross section and lat/lon information. See the figure, ‘Structure and formats of Input 
file’, which annotates the entries. The numbers should be filled within the designated areas with 
appropriate values. When making or modifying input files, use a non-kerning (uniform-spacing) 
font, such as Monaco, so that all numbers align under the xxxxxxxx headers.  
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4.2 Working in lat/lon coordinates 
Coulomb can read and display lat/lon’s if you include the lat/lon of the grid borders and the 
(0, 0 km) point in the input file, as seen here from ‘Example-SFBayArea.inp’ 

 
 

If you have lat/lon information for a source, you can convert it to Coulomb (x, y) input format by 
selecting Functions > Tools > Convert lat/lon to Cartesian, which brings up a calculator  
window. 
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4.3 To open, display and modify existing input file interactively 
1. Input > Open existing input file > Example-2(LL)-lonlat.inp in the “input_files” sub-folder 

within the “Coulomb 3.1” folder. 
2. The graphic on the left below appears in the Coulomb 3.1 window. You can see the 

undistorted grid (yellow) and the surface projection of the source fault (green). 
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3. To show the same plot with lat/lon tic marks, put the cursor on the frame numbers and make 
a right mouse-click (above right). Choose change coordinates and make a leftmouse-click. 
Alternatively, from the menu, Input > Preferences and change Coordinates from Cartesian to 
Lon. & Lat., and click OK.  

4. To modify a source or receiver fault, click on the fault with the right mouse click, and it will 
open the ‘change fault params’ window (below left). You can do the same thing to the blue 
study area border to change the study area boundaries. 

 

              
 

4.4 To display the undistorted grid in 3D view 
1. Choose Functions > Grid > 3D view. The graphic above right appears in the Coulomb 3.1 

window. You can see the undistorted grid in 3D view (yellow) and the fault patches colored 
by their input slip. You can examine the slip components, change the viewing angle 
numerically, or with the rotate tool to the right of the ‘hand’ icon. 

 
4.5 Modifying an existing file in a text editor 
1. Click one of the example files we prepared for tutorials. 
2. To duplicate it, type ‘d’ holding command key (command + D), or drag the icon holding 

option key. 
3. Rename it.  
4. Launch an editor and open the file using File > Open (command + O). 
5. Use a non-kerning (uniform-spaced) font, such as Monaco or Courier. Change the numbers 

you want, checking the units and format. If you want to add source or receiver faults, you 
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can add a new row. Make sure that the number of the rows (faults) and the number of the 
fixed faults (#fixed=  ) in the third row in the input file are the same. Some of the editors have 
an option to ‘show invisibles’. If your editor has the function, make sure that your modified 
numbers are filled in the properly formatted areas and there are no tabs. A tab will crash the 
program. 

6. Save the file. 
 
4.6 Editing existing input files within Coulomb (no need to worry about formats) 
If you already have an input file prepared, after launching the program the file is read by 
choosing Input > Open & Edit Input File. The “input_window” will appear as shown below. You 
can modify values in the boxes of elastic parameters, regional stress settings (only used for ‘Opt.-‘ 
stress calculations), Study area (grid), and Fault Data. If the ‘Total number of faults’ is greater 
than 1, enter the order number of a specific fault patch that you wish to modify below “#”. Then 
click “OK”, properties of that particular source will appear. 
 

 
 
4.7 Building an input file from a simple X,Y map 
To build an input file from map, you can select from menu Input > Build Input File from x & y 
Map. You can add Longitude and Latitude information of your study area by clicking the Add 
lon.lat. info button”.  We explain how the regional stress is used in Chapter 7, so don’t worry 
about it now. 
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Note that you must close the above warning message before specifying a fault on the following 
map. Click “OK” and the fault color will turn to green. 
 
4.8 Tapering the slip on a source fault 
To remove unrealistic stress concentrations at the edges of a fault, you can taper the slip 
automatically in Coulomb. Choose Input > Open an existing file and choose ‘Example-
2(TH).inp’. Then choose Functions > Tools > Taper or subdivide fault slip. When the Element 
input panel appears, choose ‘Linear tapering’. The tapered slip is built by nested rectangles. 
Choose 10 km along strike, 5 km down-dip, and 5 nested patches, and hit OK. Save the tapered 
input file by Input > Save input file as ascii with a new name, and open it in an editor to see the 
5 nested coplanar sources, as shown below.  
 

 
 
Notice that the patches get successively smaller on down the list, and that each patch has the 
same slip. The seismic moment (summed slip x area of each patch) of the tapered source is 
identical to that of the original uniform-slip input file. The larger the number of patches, the 
smoother the stress but the longer Coulomb needs to calculate. 
 
             Tapered slip (use for sources only)              Subdivided slip (for sources and receivers) 

                      
 
4.9 The seismic moment is calculated every time an input file is loaded 
Every time you launch an input file, it calculates the total seismic moment of the sources in the 
input file, using the fault area, slip, Young’s modulus, E, and Poisson’s ratio, PR, from the input 
file. The seismic moment (in dyne-cm) and the equivalent Mw appears in the Matlab window: 
 

 
 
So, if you want to the seismic moment of individual sources, remove the others from the input 
file. The tapered fault will always have the same moment as its untapered version. 
 
4.10   Sub-dividing or ‘tiling’ the slip on a fault  
Many large sources have variable slip models with numerous small patches of slip. You might 
also want to subdivide a receiver fault so that you can assess the variations in stress imparted by 
a nearby earthquake.  
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The simplest method is simply to change the number beneath the # in the input file from 1 (for 1 
patch) to a large number (for the number of patches). See p. 14 for a graphic). The ‘# fixed’ 
sources in the third line of the input file is unchanged.  
 
 As you did before, choose Input > Open an existing file and choose ‘Example-2(TH).inp’. Then 
choose Functions > Tools > Taper or subdivide fault slip. This time, when the Element input 
panel appears, click on ‘Splitting’. Now choose a 7 x 3 patch subdivision, and hit OK, and you will 
see the picture above right. Save the tiled input file by Input > Save input file as ascii with a new 
name, and open it in an editor to see the 21 adjacent coplanar sources, all with the same slip as 
the initial input file. You can now change the slip on each patch by hand. The input folder 
contains two examples of these (the 1992 M=7.3 Landers, California, and 1995 M=6.9 Kobe, Japan, 
shocks). 
 

 
 

If you are tapering or subdividing a vertical fault, you can still see the nested or tiled patches by 
choosing Functions > Grid > 3D view. Then you can use the swivel tool to view it on its side. 3D 
view is also valuable because the patches are colored by their slip, rather than being translucent. 
Notice the rake vectors with tiny arrow heads. 
 

Subdivided fault in 3D view   Use  swivel tool in menu 
 
 
4.11 Making realistically-scaled source faults from CMT or focal mechanism data 
1. Choose Input > Build input file from lon. & lat. map. The Map positions to Cartesian positions 

calculator will appear: 
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2.  Press 'Calc.' in the 'Study area' box (above) to calculate boundaries and grid increments of the 

study area (the yellow fields). Then hit 'Add to map' to apply changes to Coulomb window, 
which will create the grid. 

 
3.  To create the source fault from the CMT information, drop down to the 'Fault element' box 

(above left). You can choose the ‘Fault center’ (this is the geometrical center of the rectangle, so 
make sure the top of the fault is at or below the ground surface), or the ‘Start-point per Aki-
Richards' (this is the Coulomb start-x, start-y position), and then input the Mw, strike, dip, 
and rake from a CMT file. In this example, just change Mw to 6.8 and change the dip to 20°. 

 
4.  If you would like to use empirical magnitude-area relations to estimate appropriate fault 

lengths and widths, press the ‘From empirical relations' button, and the 'empirical 
relations…' box will appear (above right). Choose the type of fault (here, reverse) and hit 
‘Calc.’ To accept the length and width values, hit the 'Apply' button, and then close the 
'empirical relations’ window. You will see 'length' and 'width' information changed in the 
Fault elements box. Notice, however, that these relations permit the fault width in large 
strike-slip events to get too deep. 

 
5. Now press 'Calc.' in the Fault element window to calculate fault position, and press 'Add to 

map' to apply the fault to the coulomb window. A portion of the resulting map is shown 
above at right. Notice that the blue dot is the fault reference point you selected. To save the 
input file you just created, choose ‘Save input file as ascii’ in the Input menu, and name it. 
You can replace the comment lines to the file. 

 
6. If you would like to add more sources, after you have hit, ‘4) Add to Map’, just increment the 

‘ID number’ to 2 and put in the new values into the ‘Fault elements’ window.  
 
4.12 Converting online variable-slip coseismic models to Coulomb input files 
Martin Mai (ETH Zurich) has built the outstanding SRCMOD database of over 150 variable-slip 
input files from the literature, which can be read in as Coulomb input files. Bear in mind that 
these files can have hundreds to thousands of slip patches are so calculations, particularly ‘3D 
view’ and ‘calc. slip on faults’, can be very slow. 
 

1. Go to http://www.seismo.ethz.ch/srcmod/ and click on ‘Downloads’. Then download the 
most recent .mat file for Matlab 7 (the top file below left) to the Coulomb30 folder. Make 
sure you Save as a binary ‘.mat’ file, not a ‘.txt’ file. 
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2. In the Matlab command window, type the plugin ‘srcmod2coulomb’. You will then see 
the file selection window (above right). The selected file will automatically be saved into 
the input file folder as an .mat input file. The file name will also indicate the number of 
sources (‘_100f_’ means 100 slip patches). Warning: A large number of patches demands 
much more calculation time. 

3. Then, Input > Open existing input file > Grid >3D view. The example below left is 
‘s1987WHITTIhart_100f_coulomb.mat’, the 1987 Mw=6 Whittier Narrows shock: 

 

     
 

4.13 Merging several variable-slip models to one input file (‘merge_input_files’ plugin) 
Sometimes you will want to take many variable-slip input files for nearby earthquakes and 
merge them into one .mat input file. Here’s how you do it: 

1. Open an existing input file. Type ‘merge_input_file’ into the Matlab command window. 
You are then requested to choose the second input file. This process is repeated until you 
have included all files that you want.  

2. Save the combined file with any name you would like. In the example above right, we 
used the Overlay > Annotation tool to add the quake names to the map. They will be 
preserved in the .mat file, although you need to uncheck and recheck them when you 
next plot the file (a Matlab bug). 
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Chapter 5 
   
EARTHQUAKE, FAULT, AND COASTLINE OVERLAYS 
 
5.1 Overlays (coastlines, active fault traces, seismicity) 
1. It is often enormously valuable to plot your map with lat/lon tic marks and overlay 

geographic or seismic catalog information. This is easy to do as long as the input file (.inp or 
.mat) has lat/lon information which is the last item in the input file, such as 

 

 
To plot with lat/lon tic marks, Input > Preferences > Coordinates > lon. & lat. and then 
launch the input file. (If you do not have this information, you can calculate it using the 
Coulomb tools: Functions > Tools > Convert lat/lon to Cartesian, which opens a calculator 
window that will create your input file for you.) 

 
2. Use of the National Geophysical Data Center Coastline Extractor. Go to 

http://www.ngdc.noaa.gov/mgg_coastline/ and input the boundary coordinates, or ‘use Java 
Map for lat/lon’, zooming in as needed. We recommend the Medium Resolution (1:70,000) 
Coastline database. Select the Matlab Format, choose no compression, and preview it with a 
GMT plot. Hit the ‘SUBMIT’ button. Save the resulting ‘.dat’ file in the Coulomb 
‘coastline_data’ folder, and rename it if you like. 

 

                  
 
5.2  How to use overlays in 2D and 3D plots 
 
1. Launch ‘Example-SFBayArea.inp’. Now, Overlay > Coastlines. Open the ‘coastline data’ 

folder in the Coulomb30 folder, and select ‘california_coastline_di_neg.dat’. The ‘di’ refers to 
intermediate resolution, there is also a high resolution ‘dh’ file in the folder.  Answer the 
pop-up question, ‘no’. Some datasets treat western longitudes as negative; others do not. 
The coastline will appear on your plot. Now try, Overlay > Active faults. (You could load 
folds or roads or anything you like; the formats are explained in a pop-up window). Choose 
‘California faults_longlat_dat’. It's a large file but shortly will plot on your map. The 
Coastline and active fault data format windows are shown below: 
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2. Now choose Overlay > Earthquakes, and choose the‘(NCSN) readable’ format in the 

Earthquake catalog formats menu below left. Then select the ‘readable’ format of the actual data 
file in the data folder. It is only important that the format chosen matches the format of the 
dataset you are opening.  Fourteen formats are supported by Coulomb from global data, the 
U.S., Japan, and Turkey, and we plan to add more. 
 

               
 

An Earthquake_screening window (shown above right) will appear that lets you filter the time, 
location, depth, and magnitude of earthquakes you would like to plot. It if is a large catalog, this 
can take time. For the CMT ‘ndk’ format, go to http://www.globalcmt.org/cmtfiles.html. 
 
3. For this exercise, just click ‘OK’ to plot all 324 earthquakes that occurred in the grid are 

defined in the input file, and you should see the image below. The default colors appear 
below, but the colors of all overlays are controlled in the Preferences panel. 
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You can remove any overlay by Overlay > Clear overlay from memory, if you want to use a 
different dataset instead, or you can toggle on/off any overlay by unchecking it. Note that 
coastlines are continuous lines; by editing them in Illustrator, you can fill the land or sea area. 
Faults are line segments. 
 
4. Save an input file with all of the overlays by Input > Save Input + Overlays as .mat. Name it 

uniquely. This will create a compact binary file that you can use in the future—a great time 
savings—although it cannot be epened in an editor.  

 
5.3 Adding source or receiver faults by tracing active faults (or folds) 
1. It is very fast and easy to build source or receiver faults by tracing the active faults on the 

map. Starting from where you left off in the previous exercise, Overlay > Trace and put 
faults into input. Instructions pop up to remind you that you use your left mouse button for 
the Start end of the fault and your right mouse button for the Finish end. Remember that the 
right-hand rule means that for non-vertical sources, the Start-Finish order determines which 
direction it dips: the fault dips to the right when you are looking toward the Finish from the 
Start (see the all-important Aki-Richards convention diagram in Chapter 4). 

 
The Element input panel appears (see below) with the Start-Finish coordinates you moused on the 
map. Now, add the slip and top/bottom depth and hit ‘OK’. Remember that if the fault is non-
vertical and blind, it will be offset from the trace as a function of its dip and upper depth (refer to 
the ‘Map Positioning’ figure in Chapter 4 to see this). The new fault appears in red (below); when 
you hit OK, it turns green to indicate it is now the trace of a source or receiver. If you save the 
input file, the new source or receivers will be included. A corresponds to Start, and B 
corresponds to Finish. 
 

 
 
5.4 Making 3D source and seismicity figures that you can spin and roll 
Matlab lets you create very compact ‘figure’ files that can be manipulated in 3D to see, for 
example, if your coseismic source fault is properly located with respect to its aftershocks. 
 

1. Input > Preferences > Cartesian. Open an input file, add the coastline and earthquake 
catalog overlays. Now, Functions > Grid > 3D view (see below left). 

2. Switch to the Matlab command window, and type the plug-in, ‘earthquake_plot3’. You 
will asked on screen if you would like the earthquake magnitude scaled by circle size and 
depth scaled by color (choose Y); circles or filled disks (choose N). 



COULOMB 3.1 
User guide 

28 

 

 

3. You can use the  tool to blow up the area of interest, but the file will still contain the 
full data. Now use the  to spin and roll the view. A portion is shown below, at right. 
With this tool selected, a right mouse-click lets you to reset to a regular map, side, or 
depth view. The source slip is scaled by its color. 

4. If you are using a PC, you can save this file and re-open it later. File > Save as > 
‘yourname.fig.’ Its an amazingly small file. 

5. If you simply double-click on this figure, it opens in Matlab (not Coulomb) and can again 
be maninpulated. Matlab has yet to implement this feature on Mac’s. 

 
              3D view in Grid              using ‘earthquake_plot3’ plugin 

 

            
 
 
5.5 Making smoothed seismicity density plots 
Rather than showing earthquakes, you might want to plot seismicity density smoothed over 
some radius. This can be accomplished by plotting an earthquake catalog in a 2d Grid view, and 
then typing in the plugin, ‘smoothed_background’. You will choose a smoothing radius, and it 
will plot the seismicity density over a box reduced in size to the original so that the smoothing 
kernal can use all cells, as shown below. 
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5.6 Volcano overlays. 
 
1) Open the input file 'Niigata-Chuetsuoki-2007.mat' 
2) Click Overlay >Volcanoes   
3) You will see the yellow triangles on the map. 
4) You can change the size and color in the Input > Preferences (for volcanoes and     

earthquakes, ’point’ controls the symbol size) 
 
This function uses NOAA Active Volcano Database, ‘volcanoes_NGDC_NOAA.mat’ , which 
is in ‘plug-in’ folder. To see the database file content: 
1) Type load volcanoes_NGDC_NOAA.mat into MATLAB command line window.  
2) It will appear as MATLAB Structure file type in your workspace as titled VOLCANO.  
3) You can modify this file and create your own database. The file contains various 

information (name, eruption type, Lon, Lat, elevation, etc.) for all the volcanoes as many 
as 1500 around the globe.   

4) You can see the detail from the webpage: 
http://www.ngdc.noaa.gov/nndc/struts/form?t=102557&s=5&d=5 
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Chapter 6 
   
DEFORMATION, GPS DISPLACEMENT AND STRAIN  
 
Here we guide you in calculating deformation caused by an earthquake and display the results 
graphically. 
 
 
6.1 To display horizontal displacement vectors 
1. Input > Preferences and change Coordinates from Cartesian to Lon. & Lat. Input > Open 

existing input file > ‘Example-2(LL)-lonlat.inp’. Then, Functions > Displacements > 
Horizontal displ. (vectors). You will see a dense vector image in the Coulomb 3.1 window. To 
plot fewer vectors,  Functions > Change parameters > Grid size, and change it from 0.06° x 
0.04° to 0.12° x 0.08°, and hit OK. Now repeat Functions > Displacements > Horizontal 
displ. (vectors). After you’ve seen the plot, return the coordinate system to (x, y) by Input > 
Preferences and change Coordinates from Lon. & Lat. to Cartesian, and click OK. 

 
No reference point          Reference point by mouse click 

           
 
2. To change vector scale and reference frame: In the Displacement control panel, either move the 

slider (which rescales the vectors on the fly) or type in a number (try 10,000) in the text field 
(these means the vector scale is 10,000 x the distance scale). Then click on Fixed point, hit the 
Mouse click button and click on a point to the SE of the fault, and hit “Calc. & view.” You 
should now see a plot like that above right, with the reference point indicated by a red circle. 

 
 3. Numerical output files are created every time you make a run. Every time when you click “Cal. & 

View” in the Displacement control panel, a text output file called “Displacement.cou” will be 
created or updated and saved in a sub-folder called “Output files” within the “Coulomb 3.1 
folder”. When you want to save your latest runs, remember to rename the 
“Displacement.cou” file; otherwise it will be overwritten by your next displacement 
calculations. Below left is an excerpt of a “Displacement.cou” text output file. 

 
              Coordinates                 Displacements 

            
 
4. Change sampling depth of calculation: In the Displacement control panel, type your desired value 

after “Depth”. Most often for displacements, one sets DEPTH to 0.0 to compare the results to 
geodetic data. 
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5. Make a displacement cross-section: Choose Input > Open existing input file > Example-

2(TH).inp. Next, Functions > Displacements > Horizontal displ (vectors).  In the 
Displacement control panel, choose “Cross section”. Change the increments to 2 km by 2 km. 
This is a reverse fault; the dashed blue line in the plot below is the depth of the vectors in the 
map view plot. The cross-section line was included in the input file (this optional information 
is shown above right). You can change the cross-section line interactively in the Cross section 
control panel. Use the left mouse button to click the start (A) point, and the right mouse 
button to click the end (B) point, and make sure that the starting point is to the left of the 
ending point. If you do not have a two-button mouse, use ctrl+click for the right button. To 
save the changes, choose Input > Save input file as ascii with a new file name. 

 

     
 
 

For displacement plots, the dip of the cross section is always vertical. Within the 
Cross section window, you can chose items on the menu bars to Zoom In, Zoom Out, 
Pan, and 3D Rotate. 
 
6.2 To display observed and modelled GPS vectors 
1. You can create a GPS file with five columns: lon.°, lat.°, dx, dy, dz (m), in space delimited 

format. If easier, prepare the file in Excel and then save as ‘Formatted text (space 
delimited)’. An example of the format is shown below. Also, see ‘gps_example.dat’ in the 
GPS_data folder.  

 

 
 
2. After you have plotted a figure, choose Overlay > GPS stations, and select the file you 

created. If you did not set ‘Depth’ in the input file to zero, choose Functions > Change 
Parameters > Calculation depth. If the input file has a source fault, you will see a plot 
like the one below for the observed and modelled vectors (no error ellipses; the circles 
mark the stations) and a meter scale bar. Here we saved the file as a pdf and added the 
legend in Illustrator. 

 
3.  To output a numerical file of the observed and modelled displacements, follow the 

instructions in the command window (reproduced below). The GPS_DATA file 
can be opened in Excel for further calculations of residuals. The example below 
uses the input file, Niigata-Chuetsuoki-2007.may and  the GPS file ‘Niigata-
Chuetsuoki-2007-GPS.dat. 
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6.3 To display crustal deformation as wireframe images 
1. Using Example-2(TH).inp, Choose Functions > Displacements > Horizontal displ. 

(wireframe). The undistorted grid is in yellow and the distorted grid in blue. For a cross-
section, use the default cross-section line, but change the horizontal and depth increments to 
2 km in the Cross section control panel to see the images below. These cross-sections conserve 
area (they are ‘retrodeformable’ in geological jargon) if you set Possion’s ratio to 0.5 by 
Functions > Change Parameters >All input parameters: 

 

 
 
2. The wireframe cross-sections are useful to illustrate deformed strata associated with thrust 

and normal faults and ramp-thrusts. You can pop them into Illustrator and color the layering 
so it appears like strata. 
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6.4 To display the vertical displacement by color gradients and contours 
1. Choose Input > Open an existing file ‘Example-2(LL)-latlon.inp’; then Functions > 

Displacements > Vertical displ. (color & contours). You will see the following left image in 
the Coulomb 3.1 window. 

 
Tiled      Interpolated 

       
 
2. Data smoothing and color scale options: In the Vertical displ. control panel, you can choose either 

Mosaic, i.e., un-interpolated data (left image shown above) or Interp., i.e., interpolated (right 
image shown above). Color saturation: You can adjust color scale by moving the slider bar 
under “Color saturation” or type the value in the box, hit return, and then click ‘Calc. & 
View” in the Displacement control panel (below left).  
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3. Contours: In the Displacement control panel, choose “Contours” and click “Calc. & View”. 

Contours showing vertical displacements are superimposed on the color image (image above 
right). You can choose the contour interval. 

 
4. Cross section: Choose “Cross section” in the Displacement control panel. The methods of making 

cross sections are similar to those described in previous sections. 
 
6.5 To display the vertical displacement as a 3D image drape 
1. Choose Functions > Displacements > 3D image drape. The color scale is controlled by the 

parameter in your input file. 
 
2. To control the amount of vertical exaggeration (the “m” factor in the screen images), choose 

Functions > Change parameters > Vertical, and you will see a pop-up Vertical exaggeration 
window, in which you can change vertical exaggeration by entering a new value and then 
clicking “OK”. 

 

 
 

3. In the Coulomb 3.1 window, you can use options of Zoom In, Zoom Out, Pan, 3D Rotate, 
Insert/Remove ColorBar, and Insert/Remove Legend, as described in previous sections. 

 
6.6 To display the vertical displacement as 3D image wireframed surface 
1. Choose Functions > Displacements > 3D image wireframed surface. The color scale is 

controlled by the parameter in your input file. 
2. You can use options of Zoom In, Zoom Out, Pan, 3D Rotate, Insert/Remove ColorBar, and 

Insert/Remove Legend, as described in previous sections. Now try changing the vertical 
exaggeration by choosing Functions > Change parameters > Vertical exaggeration > 8000. 
Then, again choose Functions > Displacements > 3D image wireframed surface. Now 
change the azimuth to 10° and Elevation to 40° in the Viewpoint window by hitting tab after 
each number and the screen will redraw: 
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6.7 To display and output the horizontal and vertical surface deformation in cross-section 
Both ‘Horizontal Displ. (vectors)’ and ‘Horizontal displ. (wireframe)’ provide cross-
section outputs. These also produce numerical output files of the ground surface 
deformation components, Ux, Uy, and Uz. 
 

 
 
6.8 To display any component of the strain field 
1. Choose Functions > Strain. A Strain control panel will appear (below right). 
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2. In the Strain control panel, choose the type of strain you want to calculate. For example, 
choose Eyy and you will see the image above right. 

 
3.  Numerical output files. Every time you click “Cal. & View” in the Strain control panel, an output 

file called “dilatation_section.cou” will be created or updated. When you want to save your 
latest runs, remember to rename the “dilatation_section.cou” file within the “output files” 
sub-folder; otherwise it will be written over by your future displacement calculations. Here is 
an example of “dilatation_section.cou” output file: 

 

 
 
4. By choosing parameters in the Strain control panel, you have the options to switch between the 

tiled versus interpolated data grid, change color saturation, and contours, as explained in 
previous sections.  
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Chapter 7 
   
COULOMB STRESS CALCULATIONS 
 
Here we calculate static stress changes caused by the displacement of a fault or dike or point 
source (we refer to these as ‘source faults’), derived from the strain field shown in previous 
sections. We resolve the shear and normal components of the stress change on grid node points 
or on specified ‘receiver’ fault planes. Receiver faults are planes with specified strike, dip, and 
rake, on which the stress changes caused by the source faults are resolved. The shear stress 
change (an increase or decrease) is dependent on the position, geometry, and slip of the source 
fault, and on the position and geometry of the receiver fault geometry (including its rake). The 
normal stress change (clamping or unclamping) alone is independent of the receiver fault rake.  
 
We use the Coulomb failure criterion, Δσf = Δ ts + µ’ Δ σn, in which failure is hypothesized to be 
promoted when the Coulomb stress change is positive. Here, Δσf is the change in failure stress on 
the receiver fault caused by slip on the source fault(s), Δ ts is the change in shear stress (reckoned 
positive when sheared in the direction of fault slip), Δ σn is change in normal stress (positive in 
unclamping of the fault), and µ’ is effective coefficient of friction on the fault. 
 
We’ll explore three kinds of receiver faults: (1) receiver faults listed in the input file with no slip, 
(2) focal mechanism files, and (3) faults optimally-oriented for failure. Their optimal orientations 
are a function of the regional stress, the stress change associated with the source fault, and the 
assumed friction coefficient.  
 
On the following page are Figures 2 and 3 from King et al. [1994], which graphically present the 
Coulomb stress change resolved on vertical strike-slip faults parallel to the source fault (Fig. 2a); 
and resolved on optimally oriented planes (Fig. 2b) for a given regional uniaxial compression and 
friction coefficient. In Figure 3, the influence of the regional stress magnitude is seen on the 
orientation of the optimal planes, and on the stress change resolved on these planes. These 
figures were made in a primordial version of Coulomb. 
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Illustration of the Coulomb stress change (Fig. 2 from King et al [1994]). The panels show a map 
view of a vertical strike-slip fault embedded in an elastic halfspace, with imposed slip that tapers 
toward the fault ends. Stress changes are depicted by graded colors; green represents no change 
in stress. (A) Graphical presentation of equation 8 of King et al (1994), a “specified fault” 
calculation. (B) Graphical presentation of equation 13 of King et al (1994), for optimally-oriented 
strike-slip (“opt strike-slip”) faults.  
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Dependence of the Coulomb stress change on the regional stress magnitude, σ r, for a given 
earthquake stress drop, Δτ (Fig. 3 from King et al. [1994]). If the earthquake relieves all of the 
regional stress (left panel), resulting optimum slip planes rotate near the fault. If the regional 
deviatoric stress is much larger than the earthquake stress drop (right panel), the orientations of 
the optimum slip planes are more limited, and regions of increased Coulomb stress diminish in 
size and become more isolated from the source fault. In this and subsequent plots, the maximum 
and minimum stress changes exceed the plotted color bar range (in other words, the scale is 
saturated). 
 
7.1 Coulomb stress change on specified receiver faults (‘Specified faults’) 
This is the simplest calculation, and is widely used by researchers. To resolve the stress, you need 
to specify the fault strike, dip, and rake of the receiver planes following the Aki & Richards 
convention, shown graphically in the next page of this manual. 
 
1. Launch Matlab/Coulomb 3.1. 
2. Choose Input > Open existing input file. Then in the Open input file window, choose the 

“input_files” sub-folder within the “Coulomb 3.1” folder, and select “Example-2(LL)-
lonlat.inp” 

3. Choose Functions > Stress > Coulomb stress change. 
4. You will see the pop-up Stress control panel. 
5. To calculate stress changes on specified receiver fault planes, click “Specified faults”. 

Coulomb averages the information on all input fault patches listed in the input file and puts 
the values in the boxes, but you can change them. Strike, dip, and rake are defined following 
the conventions of Aki & Richards (1980, 2002): 
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For practice, choose a strike/dip/rake of 360°/90°/0°, change the friction coefficient to 0.0, set the 
stress-change color saturation to ±5 bars, and hit ‘Calc. & View’. 
 

 
 
The Coulomb stress changes default using our “Anatolia” color scheme. Other schemes 
(“Rainbow” or “Black & White”) can be changed by pulling down the Input > Preferences menu 
bar and clicking on “Color Map”. Then re-run the input file.  
 
7.2 Using the strike/dip/rake/friction slider (Specified slip control panel) 
To vary these parameters on the fly, hit the > button in the Stress control panel, and the Specified 
slip control panel pops up (see it above). Slide the balls to explore how the stress pattern changes. 
 
7.3 Saving the graphic and numerical output of stress calculations 
To save this graphic, File > Save As… > choose a .pdf format and rename it; its only 40 kb but is a 
full vector image. Stress change is calculated in the lower left corner of each grid square at the 
target depth specified in the input file. Calculated values of stress change may saturate (exceed 
the plotted range), so experiment with the slider to see more subtle features. The stress-scale 
legend is to the right of the plot. 
 
 
Every time you click “Cal. & View” in the Stress control panel, a numerical output file called 
“dcff.cou” will be created or updated and saved in a sub-folder you designate in the Preferences 
menu. Remember to rename “dcff.cou” if you want to save the numerical file; otherwise they will 
be overwritten. 
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7.4 The importance of the receiver fault geometry in Coulomb modeling 
In the figure below, from Lin & Stein (JGR, 2004), the source is an idealized M~7.9 right-lateral 
southern San Andreas rupture. The most familiar stress pattern is the case of source and receiver 
faults with the same strike, dip and rake (a). But look how strongly the pattern changes when the 
receiver faults are nearby thrusts (b-c) or left-lateral faults (d). Thus, a stress shadow for one 
receiver may be a stress trigger zone for another receiver fault. Note also that we tend to assume 
a high coefficient of friction (~0.8) for continental thrust faults, moderate friction (0.4) for strike-
slip or unknown faults, and very low friction (>0.2) for major transforms, such as the San 
Andreas. 
 

 
 
7.5 Adding Coulomb stress to an overlay plot and viewing it in 3D 
1.  Launch ‘Example-SFBayArea.inp’. Overlay > Coastlines. Open the ‘coastline data’ folder in 

the Coulomb30 folder, and select ‘california_coastline_di_neg.dat’ Answer the pop-up 
question, ‘no’ (some datasets treat western longitudes as negative; others do not). Now, 
Overlay > Active faults. Choose ‘California faults_longlat_dat’.  

 



COULOMB 3.1 
User guide 

42 

 

 

2.  You can now add any kind of stress changes to this plot without losing any of the overlays. 
Just hit Functions > Stress > Coulomb stress change, and select a stress component and 
option, and you will see a map view image such as that below left. 

 

      
 

 
3. After completing any Coulomb stress calculation made over the grid, such as Coulomb stress 
change, Shear stress change, or Normal stress change, just return to the MATLAB window and 
type in "coulomb_3d_view". This calls a plugin (which can be found in the plugin folder in 
Coulomb30 folder). It executes a 3D view that you can manipulate and save as a pdf file, such as 
that above right. 
 
7.6  Coulomb stress cross-sections 
1. Choose Input > Open existing input file > Example-2(TH).inp. Next, choose Functions > 

Stress > Coulomb stress change. Change the color saturation to 3.0 bars, and hit ‘Calc. & 
View’ in the Stress control panel. After the mapview plot appears, hit the Cross section button 
on the Stress control panel, which displays the cross section parameters from your input file 
(left plot below). Click “Calc. & View” and you will see the image below left. Now change the 
saturation to ±10 bars and chose interpolated shading, and hit  “Calc. & View” again (right 
panel below).  

 
Mosaic, ±3 bars          Interpolated, ±10 bars 
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2.  When building a cross-section, the “Start (A)” point should always be on the left side of the 
“Finish (B)” point (see below right).  You can overlay seismicity in cross-sections if you first 
plot the mapview with earthquakes and then make the section. The default setting plots 
seismicity within ±20 km of the section line. To change this, print EQPICK_WIDTH=5 for ±5 
km, etc, in the command window. 

 

            
 

3. You can also change the dip angle of the cross section by entering a new value in the “Dip” 
box in the above panel. The blue dashed line is the depth at which stress was sampled in the 
map view. The red line is the intersection of the fault plane with the cross-section line.  These 
can be seen in map view, which has a blue cross-section line, a red fault perimeter, a green 
line where the fault projects to the ground surface, and a black line where the fault intersects 
the depth at which stress is being sampled. You can change the depth, and many other 
parameters, in the Stress control panel. 
 

4. You can calculate the maximum or mean values of Coulomb stress changes between various 
depth ranges. Click “Depth range” and then “Cal. & View” in the Stress control panel, you 
will see Depth control panel. In the Depth control panel, enter depths of the top and bottom 
surfaces, as well as the depth increment, for which you want to perform the comparisons. 
You can calculate either “Maximum values” of Coulomb stress changes over the given depth 
range (below left), or the “Mean values” over the range (below, right). The numerical output 
file shows the maximum value at each grid point. The maps below were made using the left-
lateral strike-slip fault input file, Example-2(LL)-lonlat.inp.  

 
 Max stress change over a depth range       Mean stress change over a depth range 
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5. You can plot the orientation of the ‘specified fault’ strike in map view. Choose Input > Open 

existing input file > Example-2(LL).inp. Next, choose Functions > Stress > Coulomb stress 
change. Check the “Strike line” box in the Stress control panel, and for practice, change friction 
to 0.0, shading to interpolatedand then “Calc. & View”, resulting in the following image on 
the left. Notice that the lines strike 41° as specified. Stresses and slip lines are plotted on the 
lower left corner of each grid box. 

 

      
 
7.7 To display the principal stress axes rotated by the earthquake stress change 
Coulomb makes the tensor addition of the earthquake stress change, which diminishes with 
distance from the source fault, and the regional stress, which is assumed uniform, to calculate the 
total principal stress axes. Once the total principal stress axes are determined, Coulomb uses this 
and the assumed friction coefficient to determine the optimum planes.  
 
Choose Input > Open existing input file > Example-2(LL).inp. Then, Functions > Change 
parameters > Grid, and change the grid to 5.0 x 5.0 km so the axes are not too crowded (this is 
not a requirement; you can choose any grid spacing of interest). Now, Functions > Stress > 
Coulomb stress change. In the pop-up Stress control panel, choose “Opt. Strike S.”, “Principal 
Stress”,  and “Interpolating”, and click “Calc. & View”. You will see the image on left below. 
Using Tools > Zoom In, you will see the right image below.  
 
            Normal view with principal axes              Zoomed view 

         
 
The axes are not scaled by their stress magnitudes, since too many would be invisible. Notice that 
the axes rotate in 3D, not just in the horizontal plane, and so � 3 deviates from being vertical close 
to the source, as a result of the stress changes imparted by the earthquake. This means that � 3 can 
be seen in the lower left corner of the zoomed image. 
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7.8 Using the regional or ‘tectonic’ stress in optimally-oriented stress calculations 
The regional stress is used only when you choose Functions > Stress > Coulomb stress changes 
AND choose one of the optimally-oriented (“Opt.”) stress changes in the Stress control panel. 
Otherwise the regional stresses are ignored (see below). See King et al (BSSA, 1994) for more on 
this topic.  
 

       
 

1. All of the example input files contain simple regional stress fields. The sign convention 
for S1, S2, and S3 is positive in compression [bars]. Although you can assign axes that are 
neither horizontal nor vertical (in other words, they plunge at angles other than 0° and 
90°), and you can assign a vertical gradient in the stress axes, such that the stress 
magnitude increases (or decreases) with depth, we advise you to keep it simple. We 
almost always make the greatest principal stress, S1, horizontal and about 100 bars, and 
the intermediate principal stress about 0 bars. 

2. A reasonable regional stress must promote slip on all the faults in your area. You can use 
the P and T axes from focal mechanisms of earthquakes off the main faults, hydrofrac or 
borehole breakout information, and fault striae inversions to assess the strike of the 
greatest and least principal axes. The World Stress Map (http://www-wsm.physik.uni-
karlsruhe.de/) may also be useful for this purpose. But most important, ask yourself if 
the stress tensor you are proposing is consistent with the fault types and orientations in 
the area of study.  

3. You can build principal stress axes (which must be mutually perpendicular) by selecting 
Functions > Tools > Principal axis calculator. You can also visualize the principal axes 
by Functions > Stress > Coulomb stress change, and then by checking ‘Principal axes’ in 
the pop-up Stress control panel. 

 
7.9 To display Coulomb stress changes on the optimally oriented strike-slip, thrust, and normal 

faults (with the fault dip fixed) in map view 
“Optimally-oriented” planes are those oriented such that the Coulomb stress change resolved on 
them is most positive (in our plots, most red). Here one assumes that aftershocks have a range of 
orientations, and will be most abundant at the depth, location and with the geometry that most 
promotes failure. So at every point on our grid, we find the receiver plane along which the 
resolved Coulomb stress change is most positive. If the regional stress were zero, there would be 
a positive Coulomb stress change on some plane everywhere. But at large distances from a source 
fault, the earthquake stress change will be much smaller than the regional stress, so the planes 
rotate very little.  
 
1. Choose Input > Open existing input file> “Example-2(LL).inp”. To calculate optimally 

oriented faults, one must specify the regional (sometimes called, tectonic) stress field in the 
input file. “Example-2(LL).inp” contains a sample 3D regional stress field. If you use your 
own input file, make sure the regional stress tensor is properly defined. To make sure that the 
directions of your regional stress axes are geometrically compatible (i.e., orthogonal to each 
other), choose Functions > Tools > Principal axes calculator. You will see a pop-up 
Coordinate axes for principal stress window (below). 
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To check the compatibility of regional stress axes, first enter the azimuth (strike) and plunge 
(dip) of the greatest principal axis, S1 azimuth and S1 plunge. Click “Calc”. Then enter the 
plunge of the intermediate principal stress axis (“S2 plunge”), which should stay within the 
shown permissible range of values (“Plunge range”) to ensure that three principal axes are 
mutually perpendicular, which is obligatory. Click “Calc” again, and you will see four sets of 
combinations for the three principal axes, all of which are consistent with the entered values. 

 
2. Choose Functions > Stress > Coulomb stress change. You will see the following in the pop-

up Stress control panel: 
 

 
 

In Stress control panel, the alternatives are “Opt Thrusts”, “Opt Normal”, and “Opt Faults”. 
‘Opt fault’ is an exceedingly slow grid search over the entire focal sphere for the receiver 
planes at every grid point, and so you need patience in waiting for the completing of the 
calculation. Here, choose “Opt Strike S.” and click on Strike lines; then click “Calc. & View” 
and you will see this in the interior of the plot: 
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3. Explanation of the Slip lines. For the “Opt Strike S.” option, the receiver faults dip vertically 

and their strikes are a function of S1 (α1) and the friction coefficient µ (FRIC in Coulomb). The 
right-lateral and left-lateral optimum planes are plotted at every grid point. Their internal 
angle is a function only of the friction coefficient; they are orthogonal for zero friction and 
acute for high friction. You can see large rotations of these planes very close to the source 
fault, because the earthquake stress change is about as large as a the assumed regional stress, 
~100 bars. Far from the source, the slip lines are parallel and their orientation is a function of 
the regional stress in the input file, because at these distances from the source, the earthquake 
stress changes are negligible. For the thrust and normal faults, their dip is a function of the 
friction coefficient, and their strike is perpendicular to S1 (α1) and S3 (α3), respectively. The 
relationship of the angle, β between S1 and the dip (for strike-slip faults) or strike (for dip-
slip faults) is tan 2β  = 1/FRIC.  See King et al. [1994], which can be accessed online from the 
Coulomb web site at 

 http://quake.wr.usgs.gov/research/deformation/modeling/papers/landers.html 
 
4. For a friction coefficient of zero, the optimum planes would be orthogonal and we could 

compare them to aftershock focal mechanisms unambiguously. Try checking this by selecting 
Functions > Change parameters > Coeff. Friction. In the pop-up Coeff. Friction window, type 
0.0 and click “OK”. Then, Functions > Change parameters > Grid, and change the grid to 5.0 
x 5.0. (For normal and thrust planes, the strike for the two planes is the same and their dip is 
a function of the friction coefficient). Then hit Functions > Stress > Coulomb stress change. 
In the Stress control panel, check ‘Opt. Strike S.’, and ‘Strike line’. An excerpt is shown below 
left. Repeat the process and in the Stress control panel, change the friction to 0.8 and hit the tab. 
You’ll see the image on the right. 
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   Friction coefficient = 0.0        Friction coefficient = 0.8   

          
 

The stress changes are larger and more asymmetrical about the fault plane for high friction, 
and the rotation of the optimal planes near the source fault are a little greater. These aspects 
are discussed in King et al [BSSA, 1994]. 

 
5.  Strike lines for optimally-oriented thrust faults. Choose Input > Open an existing file and 

choose ‘Example-2(TH).inp’. Then choose Functions > Stress > Coulomb stress change. In 
the Stress control panel, check ‘Opt. thrusts’, ‘Strike line’, and ‘Tiled’ image shading, and hit 
‘Calc. & View’. You will see an image like this: 

 

 
 

Here the two strike lines are parallel to the mapview (they would not be so in cross-section), 
so only one is visible. The rotations are greatest in the deep red and blue areas, where the 
stress change is large relative to the assumed regional stress. In this example, the fault is not 
quite orthogonal to the assumed regional stress. 

 
6. In addition to “Opt Strike S.”, Opt Thrust”, and “Opt Normals”, you can also calculate 

optimally-oriented receiver faults on which Coulomb stress is maximum while not restricting 
fault types. Click “Opt Faults” and “Calc. & View” in the Stress control panel. You will see 
the following pop-up window: 
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You are requested to enter interval of grid research (°) in the Grid interval window. Small 
intervals take time to calculate. We recommend an interval of 10° or greater, at least until 
you’ve settled on all the parameters you want to use.  

 
7.10 To resolve stress changes on receiver faults (‘Calc. stress on faults’) 
This is perhaps the simplest Coulomb calculation, and is widely used in research. The regional 
stress information is not used, regardless of whether it is included in the input file. Coulomb 
permits one to show the resolved stresses graphically and output the numerical results. 
1. Open ‘Example-1.inp’ in an editor; notice that there is a source fault with slip, and two 

receiver faults (called receivers because they lack slip). These two faults are automatically 
broken up in to 5 patches by placing the number ‘5’ in the ‘#’ column. This permits a stress 
calculation at the center of each patch on a plane. This is much easier and faster than 
inputting 10 receiver faults. 
 

2. Now, Input > SFBay_rake.inp; Functions > Stress > Calc. stress on faults. A Stress on faults 
control panel will open to let you choose the stress component that you would like to resolve 
on the faults. A specified uniform rake of 135° was used in the plot below, with the (blue) 
stress drop on the source fault and one of the receiver faults, and the (red) stress increase on 
the other receiver patches, which varies along strike. 
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3. If your input file used the (rake, net slip) format rather than the (rt.lat. slip, reverse slip) 
format, then you could use the ‘Coulomb for individual rake’ option. To switch how the 
input file is interpreted, it searches for the word, “rake”, so don’t misspell it. In the input 
folder, the full 1400-patch California Reference Database is included in various formats. ‘CA-
fault-database-rake.inp’ (and ‘CA-fault-database-rake.mat’) are formatted by rake for this 
purpose. Because it is a large file, it takes time to calculate. Here are the first two sources in 
the database input file, with the right-lateral (rake rake=180° ) Green Valley reverse 
(rake=90°) Mount Diablo thrust faults: 

 

 
 
4. You can also use a subset and plot it, since all the faults have their associated names. 

Remember to make sure the ‘#fixed=’ in the third line of the input file is changed to reflect 
the number of faults in the input file (‘#fixed=faults+receivers). 

 
5. A more complex case is represented for the 1995 Kobe earthquake. Both a uniform-slip and 

variable slip source model input files are included in the input file folder, in addition to about 
50 surrounding faults with various orientations and dips. Input > Preferences > Cartesian; 
then Input > ‘Kobe-uniform-slip.inp’; then Functions > Stress > Calc. stress on faults. Note 
that a numerical output file is created each time you make a Calc. stress on faults run, which 
is very useful for further analysis. Two stress components are shown below. Experiment with 
different viewing angles and azimuths using the numerical input window; using the rotation 
tool with files this large is difficult due to the time lag. 

 
 

Stress from the 1995 Kobe variable-slip model resolved on surrounding faults 
 

  
 
Notice that on the Kobe rupture itself, there are both red and blue patches. The Coulomb stress 
change is not uniformly negative (blue) because of the irregular coseismic slip which leaves 
spikes of stress increase, the presumed sites of along-fault aftershocks. 
 
7.11 Calculating stress change on a subdivided (tiled) receiver fault 
Often one would like to determine the distribution of Coulomb stress change on a large receiver 
fault. This can be easily done and visualized in Coulomb 3.1. 
 
 
1. Open ‘Example-1.inp’ in a text editor and change the ‘5’ in the # column for ‘receiver-2’ to 1, 

so it's now a single patch. Then launch ‘Example-1.inp’ in Coulomb. Functions > Tools > 
Taper or subdivide fault slip, type fault 3 in the fault # box, and split the source into 8 x 4 
patches, and hit OK (below left). So now you have subdivided it into 32 patches. 
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2. Functions > Stress > Calculate stress on faults. You can zoom in and spin the view, as 

shown above right. The Coulomb stress change is colored and the rake vectors are plotted in 
blue. You can change the rake in the Stress on faults control panel. 
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Chapter 8 
 
ADVANCED STRESS FEATURES AND MAGMATIC SOURCES  
 
At this point we assume that you are now familiar with the typical steps and menu options in 
Coulomb, and our instructions will be more abbreviated, but still accurate. 
 
8.1 Coulomb stress changes resolved on earthquake nodal planes 
1. If there is focal mechanism information available, you may want to test whether the fault 

plane associated with each earthquake was brought closer to Coulomb failure. This is 
presumably a more stringent test than determining if earthquakes occurred in the red 
regions, although typically only the fraction of the catalog contains reliable focal 
mechanisms.  

 
If the friction were 0, this would be a straight-forward test because the shear stress change on 
the orthogonal nodal planes is identical (eg., Parsons, JGR, 2002). But for non-zero friction, the 
optimum Coulomb planes are not orthogonal, and so they will be different. In fact, one plane 
may have a stress increase and the other a decrease. You can sometimes identify the fault 
plane based on independent information, and there are published approaches others have 
taken, such as comparing the percentage of stress increases on seismicity in the region before 
and after a mainshock (Hardebeck et al, JGR, 1998; Ma et al, JGR, 2005), or by using seismicity 
alignments (Seeber & Armbruster, Nature, 2000). 

 
2. Using the same ‘Example-SFBayArea.inp’ you used in the last section, Overlay > Clear 

overlay data from memory > Clear earthquake data (because the file used did not contain 
focal mechanisms). Now, Overlay > Earthquakes > In the Earthquake catalog formats window, 
select ‘NCSN fpfit (focal mech)’, and then choose the dataset with this name from the folder. 
Earthquake circles plot on the map. 

 
3. Functions > Stress > Calc. stress on nodal planes. If the focal mechanism file only includes 

one set of nodal planes, Coulomb asks you if you want it to generate the other set, so answer 
‘yes’. A window appears to ask you which set (Nodal set 1 or set 2, which are usually 
arbitrarily ordered in a catalog, or Shuffle—random selection of set 1 or 2). It will assign 
colors to each earthquake according to how much the nodal planes were brought closer to or 
farther from failure. You should see this plot: 
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You can plot each set (Nodal plane 1 or Nodal plane 2) separately, shuffle them randomly, or you 
can edit the catalog in an editor to make set 1 the likely fault planes. The numerical output file 
also calculates the maximum (most positive) Coulomb stress on each plane, and gives the 
corresponding rake for the maximum. 
 
8.2  Coulomb stress at a point, from lat/lon, x/y, or a mouse click 
Sometimes you want to probe the calculated stress changes at a given point, rather than over a 
regular grid or on receiver faults. This is easy to do in Coulomb by using the mouse or by 
entering a lat/lon or UTM coordinates.  
 
1. Functions > Stress > Calc. stress at a point.  A Stress calculation on a point window pops up. 

You can enter the coordinates and depth of interest, and you can also enter the receiver fault 
geometry. The output is numerical, and appears in the Output window, with blue numbers 
when negative and red when positive (see below).  



COULOMB 3.1 
User guide 

54 

 

 

 

 
 
2. When using the Calc. stress at a point option, you can change the assumed friction coeffient 

in the same manner that you can for other stress calculations, by choosing Functions > 
Change parameters > Change Coefficient fric., and entering the new number. If you want to 
use x/y values, change to Cartesian coordinates in the Preferences menu. Then return to the 
Calc. stress at a point selection and use the Stress calculation on a point window. The lat/lon 
vs. Cartesian options are highlighted above in the red box. 

 
8.3 Point shear sources for small quakes or curved faults (Kode 400) 
1. If you specify Kode 400 rather than 100 in the input file, Coulomb will interpret it as a point 

source with rt.-lateral and reverse slip components. The location of the point source is 
defined by the rectangle in the input file. The point is located at the center of the rectangle: 
the midpoint of the start and end positions, and at the mid-depth of the top and bottom 
positions. The plane defined by this geometry is used for strike and dip of the point source. 
This is a simple way to represent small shocks. 

2. Another use of Kode 400 sources is if you have a very crenulated or curved fault, the overlap 
and underlap of the rectangles can be avoided by making a mesh of point sources (shown 
schematically below left). But this is demanding, and don’t sample the stress closer to the fault 
than the point spacing, or you will see numerical noise. 

 

              
 
3. We provide an input file with a single point source, ‘Example-Kode400.inp’. Note that the rt.-

lateral and reverse units are in potency (m3), not in slip (m), since a point has no area (see 
above right, from open & edit input file). Potency, also called the ‘geometric moment,’ is the 
seismic moment/G, where G is the shear modulus (see boxed equation in Chapter 3 to 
calculate G from E and PR). 

 
8.4  Crack opening or closing (Tensile Kode 200 and 300 sources) 
Many magmatic intrusion problems involve a tabular body, such as dike or sill, undergoing 
expansion or contraction. Here we introduce the deformation and stress change caused by a 
tensile component of displacement, such as the opening or closing of a tabular or crack-like body, 
using the equations of Okada [1992]. For simplicity, the input file format for the Coulomb has only 
two slip components, labelled ‘rt.lat’ and ‘reverse’. So, when you change the Kode of the source 
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to 200 or 300, the first of these slip components takes on a tensile-displacement interpretation by 
the program, as described below.  
 
1. Kode 200 permits tensile (opening) slip and strike-slip to be input. Put lateral slip in the 

‘rt.lat.’ column and tensile slip in the ‘reverse’ column (dike opening is positive; unit = meters), 
‘Example-6(200Kode).inp’. Here’s how a Kode 200 source appears in the Functions > Open & 
edit input file window, 

 

 
 
2. Kode 300 permits tensile (opening) slip and dip-slip to be input. For Kode 300, put tensile 

slip in the ‘rt.lat.’ column (again, dike opening is positive), and put reverse slip in the 
‘reverse’ column.  

3. If the element has three components of slip (strike-slip, dip-slip, and tensile-slip), you can 
accomplish this by including both Kode 200 and a Kode 300 sources in the input file as 
shown in the file below, ‘Example-7(200-300kode).inp’. To the right of the ‘bot’ values you 
can add comments that help you keep track of the source or receiver name; this is true for all 
.inp files. 

 

 
 
4. Define the dike geometry (endpoints, dip, and top/bottom depth) as you do for faults. 

Unfortunately, the way we define sources and receivers does not permit one to put in a 
strictly horizontal plane, since the top and bottom depths would be identical, but you can put 
a tiny dip (~1°), and it will work fine. 

5. Uniform opening or closing of a dike is likely to be unrealistic. Just as you can for faults, you 
can taper the displacement toward the edges by Functions > Tools >  Taper. 

6. Select the file, Example-8(dike).inp, and then choose Functions > Displacements > 
3D Vectors. You will get the image shown on the left. Now, Functions > Change Parameters 
> Vertical Exaggeration > 25000, and change Calculation depth to the surface (0.0 km). You 
will get the image on the right. Experiment with view angles. 

 
  3D Vectors at 10 km depth for a dike               3D Vectors at the free surface 
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8.5 Point source of deflation or inflation (Kode 500) 
We have implemented the formula of Okada (BSSA, 1992) for a buried point source of expansion 
or contraction. Of course, the calculated stress changes very close to such a point source are 
infinite and are thus unreliable, but at larger distances, this source is useful for magmatic 
intrusion problems, such as studying how an intrusion event may bring other faults or dikes 
closer to failure. An example of this is Nostro et al., Two-way coupling between Vesuvius 
eruptions and southern Apennine earthquakes by elastic stress transfer, JGR, 103, 24,487-24,504, 
1998, which is on our web site at 
http://quake.usgs.gov/research/deformation/modeling/papers/nostro.html. As with the dike 
or sill source, we have created two kodes for mixed volumetric and shear displacements. 
 

 
 
1. The unit for deflation or inflation is potency (m3), the volume change associated with the 

evacuation or expansion of a spherical magma chamber. Expansion is positive. Potency, also 
called the ‘geometric moment,’ is equivalent to the seismic moment/G, where G is the shear 
modulus. As discussed previously (see boxed equation in Chapter 3), in Coulomb one inputs 
Young’s modulus (E) and Poisson’s ratio (PR), from which G can be computed. The units for 
the strike or dip slip is meters, as usual. One designates the source as Kode 500. 

2. Kode 500 permits both a dike and point source of expansion to be input. Put the tensile 
opening in the first (‘rt-lat.’) column (units are m3; right-lateral is positive), and put the point 
source in the ‘reverse’ column (units are m3; expansion is positive).  

3. The location of the point source is defined by a plane in the input file. The point is located at 
the midpoint of the start and end positions, and at the midpoint of the top and bottom 
positions. The plane defined by this geometry is used for the dike opening. So if you only 
calculate the point-source expansion, the length and width of the plane are unimportant; only 
if you also want to consider opening or closing of the planar dike do these dimensions get 
used in the calculation. The point source is indicated graphic output files as a small black 
circle. 

 
The following figure was made using ‘Example-9(Kode500).inp’ with two different 
Displacement options selected. The surface projection of the dike is the short green line. 
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               Vertical displ. (color & contours)             3D image drape 
 

          
 
In the example below, we have chosen Stress > Coulomb stress change > Opt Normal with a 1 x 
1 km grid, friction=0.8, depth of 8 km, and color saturation of ±0.25 bars: 
 

Coulomb stress change (bars) on optimally oriented normal faults 
 

  
 
 
8.6 Displaying Coulomb Displacement, Stress and Overlay graphics in Google Earth 
Google Earth offers wonderful opportunities to drape Coulomb files on satellite images and 
DEMs. You need to download and install Google Earth on your computer before following these 
steps. In addition to this, you will need Adobe Illustrator or any reasonable graphic application. 
 
1. Make sure that you have selected the lon. & lat. Coordinate option in the Preferences menu. 
2. Run any horizontal displacement function, such as Horizontal displ. (vectors) or Horizontal 

displ. (wireframe). Add the Overlay options that you would like in the plot. When the final 
plot appears in the Coulomb 3.1 window, type “coulomb2googleearth” in the MATLAB 
command window, and hit return. You will get messages in the command window once files 
are saved. Then, you can drag the kml files onto the Google Earth icon on your computer dock 
or desktop, or you can open the files from the Google  Earth menu. 
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This file was made using the input file, ‘Landers-uniform-slip.inp’ and Displacement > 
Horizontal Displ. (Vectors). 
 
3.  For color gradient images such as are created in the Coulomb stress change, Shear stress 

change, Normal stress change options, or the Vertical displacement (color) options File > 
Save As... pdf using the commands, renaming them. 

4.  Open the .pdf files in Illustrator or the graphics software you are using, and remove all the 
text and lines, and keep only the color (raster) image. Save the color image as .jpeg file, and 
name it  ''coulombmap.jpeg'' in the Coulomb directory. 

5.  Type ''coulomb2googleearth'' in the command window. This calls a script that is run by 
Coulomb; this is not a feature of the normal pull-down menus.  You will get the overlay kml 
file. 
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In the plot above, a Coulomb stress change image was added. The DEM exaggeration (3:1) was 
maximized in Google Earth with an oblique viewing angle from the south. Google Earth also lets 
you control the translucency of the jpeg. 
 
6. The full plugin script can be found in the plugins folder in the Coulomb30 folder: 
 

 
 
8.7 Digitize Polygon Function (to select and create a lat/lon file of any area, such as a Coulomb 

stress-change or deformation contour)  
 
The Digitize Polygon function is useful for comparing a zone of Coulomb stress change or 
deformation with aftershocks or the seismicity rate change as calculated from the independent 
Matlab program, ZMAP. 
 
1.   Make sure that you have selected the lon. & lat. Coordinate option in the Preferences menu. 
2. Run any map view function (not 3D) in Coulomb, and then type “digitize_polygon” in the 

MATLAB command window, and hit return. In the example below, we have used the input 
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file, ‘Example-SFBayArea.inp’ and selected a Coulomb mapview. Below we have digitized 
the -3 bar contour. 

 

 
 
3. The mouse becomes a digitizing cursor in the Coulomb main window. You will see a large 

“+” over the map (above right). To digitize, make multiple left-button clicks to circumscribe 
an area. Finalize and close the area by using a right-button click; the graphic will then show 
the completed area (above right). A window (left below) asks if you intend to digitize multiple 
areas; hit ‘no’ if this is it. The digitized file is saved in the "coulomb" folder. The first 8 lines 
of the file, ‘polygons1.dat’ is shown below at right; notice it is in lat/lon coord’s with the 
convention that western longitudes are negative. 

 

              
 

4. In ZMAP, you can move the file to the ZMAP folder and then read it from the area selection 
function.  

5. The ZMAP software, by Prof. Stefan Wiemer at ETH Zurich, is available on 
http://www.earthquake.ethz.ch/software/zmap 
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Chapter 9  
  
NUMERICAL OUTPUT FILES 
 
In addition to Coulomb’s internal graphics, you may want to analyse or plot the underlying 
numerical output, so all Coulomb graphics calculations produce a numerical output file with 
useful headers. These can be opened in Excel or brought into a rasterizing program for replotting. 
 
9.1 Map view displacement output file 
Every time when you click “Cal. & View” in the Displacement control panel, a text output file called 
“Displacement.cou” will be created or updated and saved in the sub-folder you designated in the 
Coulomb preferences menu (the default is ‘output_files’). When you want to save your latest 
runs, remember to rename the “Displacement.cou” file within the “Output files” sub-folder; 
otherwise it will be overwritten by your future calculations. Here is an example of 
“Displacement.cou” text output file. 
 

 
 
9.2 Map view strain output file 
Every time when you click “Cal. & View” in the Strain control panel, a text output file called 
“strain.cou” will be created or updated and saved in a sub-folder called “output files” within the 
“Coulomb 3.1 folder”. When you want to save your latest runs, remember to rename the 
“strain.cou” file within the “output files” sub-folder; otherwise it will be written over by your 
future displacement calculations. Following is an example of “strain.cou” text output file. 
 

 
 
9.3 Cross-section dilatation output file 
When you click “Cal. & View” in the Strain control panel, and have selected the ‘Dilatation cross 
section’ option, a text output file called “dilatation_section.cou” will be created or updated and 
saved in the sub-folder.  
 
9.4 Map view Coulomb stress output file 
Every time when you click “Cal. & View” in the Stress control panel, a text output file called 
“dcff.cou” will be created or updated and saved. ‘Dcff’ is an abbreviation for the change in the 
Coulomb failure function. When you want to save your latest runs, remember to rename the 
“dcff.cou” file within the “Output files” sub-folder ; otherwise it will be written over by your 
future calculations. Following is an example of “dcff.cou” text output file. 

 
 
9.5 Cross-section Coulomb stress output file 
Every time when you click “Calc. & View” in the Cross section control panel, a text output file 
called “dcff_section.cou” will be created or updated. Remember to rename it if you want to save 
the latest cross section run since “dcff_section.cou” will be overwritten. The following is an 
example of “dcff_section.cou” text output file. 
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9.6 Element Conditions stress output file for ‘Calc. stress on faults’ option 
Every time when you select ‘Calc. stress on faults’, Coulomb produces a ‘Element_conditions.csv’ 
file with the results in tabular form. It includes not only the specified rake you selected for the 
calculation, but also the maximum (most positive) Coulomb stress change and the associated rake 
for this maxima. 
 

 
 
9.7 Numerical output file for Focal mechanism calculations, Focal_mech_stress.csv. 
Here is sample output of the focal mechanism file; you will see that it contains considerably more 
information than is contained in the graphical output. 
 

 
 

 


