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14 Chapter 1: Introducing the IDL iTools
Introducing the iTools 

The new IDL Intelligent Tools (iTools) are a set of interactive utilities that combine 
data analysis and visualization with the task of producing presentation quality 
graphics. Based on the IDL Object Graphics system, the iTools are designed to help 
you get the most out of your data with minimal effort. They allow you to continue to 
benefit from the control of a programming language, while enjoying the convenience 
of a point-and-click environment.

In IDL 6.0, five pre-built iTools are exposed for immediate interactive use. Each of 
these five tools is designed around a specific data or visualization type, including:

• Two and three dimensional plots (line, scatter, polar, and histogram style)

• Surface representations

• Contour maps

• Image displays

• Volume visualizations

The iTools are built upon a new object-oriented framework, or set of object classes, 
that serve as the building blocks for the interface and functionality of the Intelligent 
Tools. IDL programmers can easily use this framework to create custom data analysis 
and visualization environments. Such custom Intelligent Tools may be called from 
within a larger IDL application, or they may serve as the foundation for a complete 
application in themselves.

A Single Tool with Many Faces

What sets the Intelligent Tools apart from precursors such as the Live Tools (now 
obsolete with IDL 6.0) — and what gives them their optimal power, flexibility, and 
extensibility — is the cohesive, open architecture of the Intelligent Tools system. The 
iTools system is actually comprised of a single tool, which adapts to handle the data 
that you pass to it. The plot, surface, image, contour, and volume tools are simply 
shortcut configurations, which facilitate ad hoc data analysis and visualization. Each 
tool encapsulates the functionality (data operations, display manipulations, and 
visualization types) required to handle its data or visualization type. However, you 
are not constrained to work with a single data or visualization type. Instead, using the 
Intelligent Tools system, you may start by bringing up a surface plot in a surface tool 
and then import scattered point data into the same plot to see the relationship between 
two datasets. Or, you may start with an image display, overlay contours from another 
dataset, and map both the image and contours onto a three-dimensional surface 
Introducing the iTools iTool User’s Guide
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representation of a third dataset. By throwing new data into an iTool, it is easy to end 
up with a hybrid tool that can handle complex, composite visualizations.

Of course, you have always been able to create these kinds of powerful, composite 
visualizations in IDL to reveal important relationships and trends in data. The main 
enhancements the new iTools provide are more mouse interactivity, WYSIWYG 
(What-You-See-Is-What-You-Get) printing, built-in analysis, undo-redo capabilities, 
layout control, and better-looking plots. These robust, pre-built tools reduce the 
amount of programming IDL users must do to create interactive visualizations. At the 
same time, the iTools integrate seamlessly with the IDL Command Line, user 
interface controls, and custom algorithms. In this way, the iTools maintain and 
enhance the control and flexibility IDL users rely on for data exploration, algorithm 
design, and rapid application development.

Foundation for the Future

As you will discover, the iTools are compelling new tools to add to your arsenal. They 
complement the strong foundation that IDL has maintained over the course of its 
evolution. This foundation has made possible countless valuable user-written 
applications across many disciplines and industries. However, the iTools also 
represent the start of a new, updated display paradigm for IDL. While the iTools 
system in IDL 6.0 is a powerful and flexible environment that will allow you to 
immediately accelerate your data interpretation and reporting, it is only the 
beginning. We will continue to build on this new technology in future releases. You 
can look forward to more functionality, flexibility, and optimization as the iTools 
system continues to grow.

We look forward to members of the IDL community building on the iTools system as 
well. The iTools source code is included in the IDL distribution to allow you to:

• extend the pre-built tools with your own operations, manipulations, 
visualization types, and GUI controls,

• create your own custom tools based on the iTools component framework,

• share your inventions with others in the IDL community via the RSI User-
Contributed Library (www.RSInc.com/codebank) or other avenues of 
collaboration and distribution. 

Note
For more information on building your own iTools or building hybrid iTools, see the 
iTool Developer’s Guide. 

Tips and instructions for using this Guide are detailed in the following section.
iTool User’s Guide Introducing the iTools
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Using this Guide

The iTool User Guide can show you important iTool functionality such as how to start 
the iTools, how to import data into an iTool, how to export data out of an iTool, the 
general layout of the iTools, and how to perform common iTool tasks.

This User Guide is organized to help you make the most of the IDL iTools. The User 
Guide contains the following chapters:

• Chapter 2, “Importing and Exporting Data” - This chapter introduces you to 
bringing data into the iTools as well as exporting data.

• Chapter 3, “iTool Common Tasks” - Many iTool tasks are common to each 
tool. These tasks are described in this chapter.

• Chapter 4, “Working with Images” - This chapter describes the iImage tool and 
gives you insight into unique image visualization and manipulation tasks.

• Chapter 7, “Working with Plots” - This chapter describes the iPlot tool and 
gives you insight into unique plotting and plot manipulation tasks.

• Chapter 5, “Working with Surfaces” - This chapter describes the iSurface tool 
and gives you insight into unique surfacing and surface manipulation tasks.

• Chapter 6, “Working with Contours” - This chapter describes the iContour tool 
and gives you insight into unique contouring and contour manipulation tasks.

• Chapter 8, “Working with Volumes” - This chapter describes the iVolume tool 
and gives you insight into unique volume visualization and volume 
manipulation tasks.

• Appendix A, “iTools Interface Reference” - This appendix gives you a detailed 
look at the iTool interface and its components.

• Appendix B, “Property Controls” - This appendix describes the iTool controls 
used to set properties in the iTool property sheets.

• Appendix C, “Operations Properties” - This appendix describes the properties 
of the iTools found in the Operations Browser of each iTool.

• Appendix D, “Visualization Properties” - describes the properties of the iTools 
found in the Visualization Browser of each iTool.
Using this Guide iTool User’s Guide
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This chapter describes how to access data using the iTool.
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18 Chapter 2: Importing and Exporting Data
About the iTools Data Manager 

All data used by any iTool is first loaded into the iTools data manager, which keeps 
track of which data items are associated with an iTool visualization. The process of 
loading data into the data manager is entirely automatic if you specify data when 
launching an iTool at the IDL command line or if you open a data file using the Open 
command from the iTool’s File menu. In these cases, the iTool will import the data in 
the specified file or variable and create a visualization of the default type for the 
selected data and the iTool you are using.

If you want more control over the process of creating a visualization, you can load 
data into the data manager manually, either from a data file or from one or more 
variables that exist in your current IDL session. Once a data item is placed in the data 
manager, it is available to all iTools until it is removed. The methods of placing data 
into the data manager are described throughout this chapter.

The data manager dialog provides a convenient and structured environment in which 
to import and view files and variables. Any data which is placed in the iTools system 
is stored in this repository. This chapter outlines the ways  you can import data into 
the data manager as well as ways to export data out of the data manager into a file on 
your computer or a variable in the current IDL session.

The IDL iTools support several data types. Data import and export capabilities within 
each iTool allow you to access these various types of data. Standard file readers are 
provided in the IDL iTools to import data stored in binary formats, ASCII files, and 
several image file types.

Figure 2-1: The iTools Data Manager
About the iTools Data Manager iTool User’s Guide
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Note
You can also create file readers for other data types besides those provided in IDL 
6.0. For more information on creating file readers and creating your own iTools, see 
Chapter 8, “Creating a File Reader” in the iTool Developer’s Guide manual.

Data Manager Utilities

Within the data manager you can perform important tasks such as removing, 
renaming, copying, and importing data. 

• Deleting data — Unused or outdated data items can be manually removed 
from the data manager by selecting and right-clicking to choose the Delete 
option.

• Renaming data — Data items can be renamed at any time by selecting and 
right-clicking to chose the Rename option.

• Duplicating data — Data items can be copied at any time by selecting and 
right-clicking to chose the Duplicate option.

• Importing data — Importing data into the data manager is described in this 
chapter in the sections which follow.
iTool User’s Guide About the iTools Data Manager
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About the Parameter Editor 

Every iTool requires that data be assigned to one or more parameters before a 
visualization can be created and displayed. If you specify data when launching an 
iTool at the IDL command line or if you open a data file using the Open command on 
an iTool’s File menu, the iTool will attempt to assign the specified data to the correct 
parameters for the visualization you are creating.

If you have already created a visualization, you can change the data associated with 
one or more visualization parameters using the Parameter Editor. To display the 
Parameter Editor, select your visualization, then select Edit → Parameters....

Similarly, if you choose to create a visualization by selecting Visualization from the 
iTool’s Insert menu, you will have the chance to select data for each parameter used 
by the visualization manually. (The Insert Visualization dialog contains all of the 
fields shown in the Parameter Editor, and additionally allows you to select a 
visualization type. See “Using Insert Visualization” on page 23 for details.)

To associate data with a visualization’s parameters using the Parameter Editor:

1. Select Edit → Parameters.

2. Do one of the following:

Figure 2-2: Parameter Editor
About the Parameter Editor iTool User’s Guide
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• Select an item already in the Visualization Tree.

• Click Import File to import a file into the Visualization Tree, and select 
the file.

• Click Import Variable to import a variable into the Visualization Tree, 
and select the variable.

3. Assign the item to the appropriate input variable by clicking the Assign Data 
 button beside the input variable field. To remove an item from an input 

variable field, click the Clear button . Also, if you double-click on an item 
in the tree, it will move to the field of your selected parameter.

4. Click OK to close the Parameter Editor.
iTool User’s Guide About the Parameter Editor



22 Chapter 2: Importing and Exporting Data
Data Import Methods 

Data items in the data manager are available to all iTools until it they are removed. 
There are five ways to bring data into the iTool data manager:

• Using the Insert Visualization dialog (Insert → Visualization)

• Using the Data Import Wizard (File → Import)

• By opening a data file directly (File → Open)

• Using the Data Manager dialog (Window → Data Manager)

• At the Command Line of IDL (for example, iPlot, indgen(20))

These methods are described in the following sections.
Data Import Methods iTool User’s Guide
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Using Insert Visualization 
One simple method to import data into the data manager is to use the 
Insert → Visualization feature from the iTool window. To use this method, select 
Insert Visualization from your iTool window.

To access data using Insert → Visualization from your tool:

1. Start an iTool.

2. Select Insert → Visualization and the Insert Visualization Dialog appears

The Insert Visualization dialog contains the following items:

• Visualization Tree — This area shows the tree structure of imported data 
and/or variables available for visualization.

• Visualization Type Drop-down Menu — This menu allows you to select 
the visualization type to use with the selected data. 

• Input Parameters — These are the input parameters for the visualization 
type selected in the Visualization Type Drop-down Menu. These input 
variables will change per visualization type.

• Import Variable — gives you the ability to select a variable to import into 
the data manager via the Insert Visualization Browser. For more 

Figure 2-3: Insert Visualization Dialog With Image Visualization Type Selected
iTool User’s Guide Data Import Methods
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information on importing a variable into your data manager, see 
“Importing a Variable” on page 42.

• Import File — gives you the ability to select data from a file to import into 
the data manager via the Insert Visualization Browser.

3. Next, assign data in the dialog to the parameters of the visualization being 
inserted.

4. Select the visualization type from the visualization type drop-down menu.

5. Now click OK to finish inserting the visualization.

Note
The OK button on the insert visualization dialog is disabled until all required 
parameters have associated data.

The Insert Visualization feature can display your data file according to its file type. 
For an explanation of the handling of various file types see the following sections:

• For Image Data see “Importing Image Data” on page 33.

• For ASCII Data see “Importing ASCII Data” on page 34.

• For Binary Data see “Importing Binary Data” on page 38.
Data Import Methods iTool User’s Guide



Chapter 2: Importing and Exporting Data 25
Using the Data Import Wizard 
Another option when importing data into the data manager is to use the Data Import 
Wizard. The Data Import Wizard matches your visualization parameters 
automatically rather than needing you to match them individually as in the parameter 
editor. Here is an example of how to import a JPEG image file using the Data Import 
Wizard and display the image:

1. From an iTool window (in this example iImage since our data is image data) 
select File → Import.

The IDL Data Import Wizard: Step 1 of 3 dialog contains the following 
items:

• From a File — gives you the ability to select data from a file to import 
into the data manager.

• From an IDL Variable — gives you the ability to select a variable to 
import into the data manager. For more information on importing a 
variable into your data manager, see “Importing a Variable” on page 42.

Figure 2-4: The IDL Data Import Wizard, Showing Step 1 of 3
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2. Select From a File and click Next.

The IDL Data Import Wizard: Step 2 of 3 dialog contains the following 
items:

• File Name — used to show the name and path of the file you chose from 
the File Open button.

• File Open button  — used to show the Please Select a File for 
Reading dialog.

• Data Import Name — used to name or rename (if desired) a selected file 
to import.

• Options — TBD.

3. In the File Name field, type the path to the desired file, or click the File Open 
button  just to the right of the File Name field to search the directory 

Figure 2-5: The IDL Data Import Wizard, Showing Step 2 of 3
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structure for the desired file. Select a file in the examples/data directory 
named endocell.jpg. Click Next.

The IDL Data Import Wizard: Step 3 of 3 dialog contains the following 
items:

• Select the desired visualization to create — used to select the type of 
visualization to create based upon the data type to be visualized.

• Name — displays the visualization type name.

• Description — shows the visualization type.

4. Select Image as the desired visualization to create since we have a JPEG 
image.

Figure 2-6: The IDL Data Import Wizard, Showing Step 3 of 3
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5. Click Finish and the visualization appears in the iTool window:

Note
This example shows a JPEG image visualized using the iImage tool. The iImage 
tool has unique features such as the tab to the right of the image pane which shows 
you pixel location and pixel value. For more information on the iImage tool and its 
functions and features, see Chapter 4, “Working with Images”.

The Data Import Wizard can visualize your data file according to its file type. For an 
explanation of the handling of various file types see the following sections:

• For Image Data see “Importing Image Data” on page 33

• For ASCII Data see “Importing ASCII Data” on page 34

• For Binary Data see “Importing Binary Data” on page 38

Figure 2-7: JPEG Image Visualized Using the Data Import Wizard
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Using File Open

Yet another method to import data into your data manager is to use File → Open to 
import data if you already know your data type. Using File → Open will also match 
your parameters automatically.

To access data using File → Open from your tool:

1. Start your desired iTool (depending upon your data type) at the IDL command 
line.

2. Select File → Open or the File Open icon  at the top left of your iTool 
window, and the File Open Dialog appears.

3. Select the desired file from your directory structure.

4. The iTool will visualize your data file according to its file type, or, if the data is 
binary or ASCII, will prompt you with a template to read the file into the data 
manager. For an explanation of the handling of various file types see the 
following sections:

• For Image Data see “Importing Image Data” on page 33

• For ASCII Data see “Importing ASCII Data” on page 34

• For Binary Data see “Importing Binary Data” on page 38.

Figure 2-8: The Open Dialog From Which to Choose Data
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Using the Data Manager Dialog

The most direct way to import data into an iTool is from the data manager. 

Here is an example of how to import a JPEG image file using the data manager and 
display the image:

1. From an iTool window select Window → Data Manager.

The Data Manager Browser appears. This browser shows you any imported 
data in the window to the left of the browsers (here it is shown empty). Also 
any selected data displays its name, type, description, and size in the 
appropriate fields on the right. At the bottom of the browser are the options to 
import a variable, import a file or dismiss the browser. You can also perform 
such options as deleting, duplicating, and renaming your data items by right-
clicking on them in the Data Manager and then selecting from Delete, 
Duplicate, or Rename.

Figure 2-9: The iTools Data Manager
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Importing From a File

You can import a file into an existing visualization within the iTools.

1. From your iTool window, select Insert → Visualization.

2. Select Import File and the File Import dialog appears. 

The File Import dialog contains the following items:

• File Name — used to show the name and path of the file you chose from 
the File Open button.

• File Open button  — used to show the Please Select a File for 
Reading dialog.

• File Type — used to show the file format type of the selected file (if any).

• Data Import Name — used to name or rename (if desired) a selected file 
to import.

Figure 2-10: The File Import Dialog with JPEG File Selected
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3. In the File Name field, type the path to the desired file, or click the File Open 
button  just to the right of the File Name field to search the directory 
structure for the desired file. Select a file in the examples/data directory or 
any other data files you wish to visualize.

4. Click OK to dismiss the File Import dialog.

5. Select the visualization type from the drop-down list at the top-right of the 
Insert Visualization dialog.

6. From the Insert Visualization dialog, expand the tree of the file you wish to 
see.

7. In this example of image data, select Image Planes and then click the small 
arrow next to IMAGEPIXELS.

8. Select Palette from the files tree and then click the little arrow next to 
PALETTE. (This is optional and in this particular example we have no 
palette)

9. Click OK and your data will then be visualized according to your selections, 
or, in the case of binary and ASCII data, you will be prompted by a template 
for more information about your data.

Figure 2-11: The Insert Visualization Dialog
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Importing Image Data

Image data of many common file formats can be visualized by IDL iTools. Common 
image file formats accepted are:

Note
You can also use the iTool’s export and export variable features to export image data 
and variables. For more information on exporting, see “Exporting Data” on page 44.

You may import common image files into the IDL iTools using any of the previously 
described methods. For information on these methods, see “Data Import Methods” on 
page 22. This section also shows examples of importing image data.

Note
For more information on the iImage tool and its functions and features, see Chapter 
4, “Working with Images”.

• BMP • JPEG • PNG

• DICOM • PICT • TIFF
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Importing ASCII Data

When you open a file containing ASCII data, you must specify the format of the file 
before the iTool can read the data and place it into the data manager. The iTool opens 
the ASCII Template dialog to allow you to specify the format of the ASCII data.

Note
You can also use the iTool’s export and export variable features to export ASCII 
data and variables. For more information on exporting, see “Exporting Data” on 
page 44.

Here is an example of opening an ASCII file using the ASCII Template as well as 
information on the ASCII template’s layout:

1. From the iTool window open an example file named sine_waves.txt from 
the examples\data subdirectory of your IDL distribution. You can open the 
file either by selecting File → Open or by clicking the Import File button in 
the Data Manager or Insert Visualization dialog.

2. The ASCII Template window is displayed:

The first step of the ASCII Template contains the following items:

Figure 2-12: The ASCII Template Step 1, Defining Data Type and Range
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• Field Type — Select the field type which best describes your data. Choose 
from fixed width or delimited.

• Comment Strings to Ignore — Allows you to note any comment strings 
you wish to be ignored.

• Data Starts at Line — Allows you to specify from which line data should 
first be read.

• Selected Text File — Shows the real data from the selected text file. The 
option is also given to Get next 50 Lines.

3. Choose the field type. Here it is delimited by white space.

4. There are no comment strings to ignore here, and the line upon which to begin 
your data is 1. Now select Next.

The second step of the ASCII Template contains the following items:

• Number of Fields Per Line — Allows you to specify how many fields 
should appear per line.

• Delimiter Between Data Elements — Allows you to select the delimeter 
type between data elements.

• Value to Assign to Missing Data — Allows you to choose a value to 
assign any missing data.

Figure 2-13: The ASCII Template Step 2, Defining Delimeters/Fields
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• Selected Records — Shows the data itself in its desired column-delimited 
format.

5. Next, enter the Number of Fields Per Line as two, and the Delimiter 
Between Data Elements should be set to White Space. Click Next.

The third step of the ASCII Template contains the following items:

• Name — Allows you to name your fields. Default values are Field1, 
Field2, and so on. You can enter the name into the Name field to the right.

• Data Type — Allows you to set the data type for your fields. You can 
enter the type by selecting it from the Type drop-down menu.

• Grouping — Allows you the option of joining fields to be manipulated or 
displayed as a group. You can group certain fields, group all, ungroup 
certain fields and ungroup all. The default is no grouping.

• Sample Record — Shows you a sample of the configuration you have set.

Figure 2-14: ASCII Template Step 3, Field Specifications
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6. Next, at step three, the defaults are all correct for the data to visualize. Click 
Finish and the data is plotted:

For more information on using the ASCII file reader, see “ASCII_TEMPLATE” in 
the IDL Reference Guide manual.

For more information on plotting and plot functions, see Chapter 7, “Working with 
Plots”.

Figure 2-15: ASCII Data Plotted Using the ASCII Template
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Importing Binary Data

When you open a file containing binary data that is not of a format recognized by any 
other file reader available to your iTool, you must specify the format of the file before 
the iTool can read the data and place it into the data manager. The iTool opens the 
Binary Template dialog to allow you to specify the format of the binary data.

Note
If the file contains binary data of a recognized format, such as TIFF or JPEG, the 
iTool will automatically choose the correct file reader to read the binary data.

Note
You can also use the iTool’s export and export variable features to export binary 
data and variables. For more information on exporting, see “Exporting Data” on 
page 44.

Here is an example of opening a binary file using the Binary Template as well as 
information on the binary template’s layout:

1. From the iTool window open an example file nanamed damp_sn.dat from 
the examples\data subdirectory of your IDL distribution. You can open the 
file either by selecting File → Open or by clicking the Import File button in 
the Data Manager or Insert Visualization dialog. This is a data file containing a 
damped sine wave with severe high frequency noise.

2. The Binary Template window is then displayed. 

The Template Name is optional, and can be any string.

Figure 2-16: The Binary Template
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The byte order in the file is selected using the using the File’s byte ordering: 
pull-down menu. The choices are:

• Native — The type of storage method that is native to the machine you are 
currently running. Little Endian for Intel microprocessor-based machines 
and Big Endian for Motorola microprocessor-based machines. No byte 
swapping will be performed.

• Little Endian — A method of storing numbers so that the least significant 
byte appears first in the number. Specify this if the original file was created 
on a machine that uses an Intel microprocessor.

• Big Endian — A method of storing numbers so that the most significant 
byte appears first in the number. Specify this if the original file was created 
on a machine that uses a Motorola microprocessor.

3. From this template, click New Field.

The New Field dialog contains the following items:

• The Field Name can be any string.

• The Type of each Template-specified field is selected from a droplist that 
offers the following IDL types: byte, integer, long, float, double, complex, 

Figure 2-17: Defining a New Field in the Binary Template
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dcomplex, uint, ulong, long64 and ulong64. Strings are read as an array of 
bytes for later conversion to type STRING. 

• Offsets can be specified using integer values, field names, or any valid 
IDL expression. An absolute integer offset specifies a fixed location (in 
bytes) from the beginning of the file (or the initial file position for an 
externally opened file). A relative integer offset specifies a position relative 
to the current file position pointer after the previous field (if any) is read. 
Relative offsets are shown in the binary template user interface with a 
preceding > or < character, to indicate a positive (>) or negative (<) byte 
offset. Expressions can include the names of fields that will be read before 
the current field — that is, the field number of the referenced field must be 
lower than the field number of the field being defined.

• The Verify field can contain an integer, field name, or any valid IDL 
expression. Only scalar fields can be verified. 

• The Number of Dimensions of a field can be set via a droplist of values 0 
(scalar) to 8 (which is the maximum number of dimensions that an IDL 
variable can have.) The size of each dimension can be an integer, field 
name, or any valid IDL expression. Any of the first three dimensions of 
array data can also be specified to be reversed in order. 

Click OK to create the new field definition, and repeat to define all necessary 
fields. 

Note
If the iTool is running in the IDL Virtual Machine, the Offsets, Verify, and Size 
fields can contain integers or field names, but not an IDL expression. For additional 
information on the binary template, see “BINARY_TEMPLATE” in the IDL 
Reference Guide manual.

4. In this example, name the field “dampsn”. The type is Byte data. The number 
of dimensions is 1 and the dimension size is 512. 
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5. Click OK and then OK again to close the Binary Template dialog. The Plot 
appears in the iTool window.

For more information on the binary file reader, see “BINARY_TEMPLATE” in the 
IDL Reference Guide manual.

For more information on plotting and plot functions, see Chapter 7, “Working with 
Plots”.

Figure 2-18: Binary Data File Displayed in the iTool Window
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Importing a Variable

Variables in your current IDL session can be imported into the data manager to be 
visualized in an iTool. Once you have entered variables into the IDL session at the 
command line, you can import a variable directly from the Data Manager dialog, or 
by using File → Import. 

Note
If you specify a variable as a parameter to the iTool at the IDL command line, the 
variable is automatically imported into the data manager.

The following is an example of importing a variable using the Data Manager dialog:

1. From the Data Manager dialog, select Import Variable. The IDL Variable 
Browser appears.

Figure 2-19: The IDL Variable Browser
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From the IDL Variable Browser you can select available variables which you have 
entered at the Command Line and click OK to add them to your Data Manager as 
available variables.

Figure 2-20: Imported Variable with Imported Files
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Exporting Data 

You can export data from an iTool to a data file or back to the current IDL session:

• Exporting Data to a File (following)

• Exporting Data to the IDL Session (page 46)

Exporting Data to a File

You can export the contents of an entire iTool window into a single image or data file 
using the IDL Data Export Wizard.

For example, to export a file:

1. Select File → Export. The IDL Data Export Wizard appears.

2. The first step asks you to choose to export the data to either a file or an IDL 
variable. Select File and then Next.

Figure 2-21: The IDL Data Export Wizard, Showing Step 1 of 3
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Note
For more information on exporting data to an IDL variable, see the following 
section, “Exporting Data to the IDL Session” on page 46.

3. From the next screen, select the data which you wish to export. Notice that 
only the Window level or View level can be exported. Click Next.

Figure 2-22: The IDL Data Export Wizard, Showing Step 2 of 3

Figure 2-23: The IDL Data Export Wizard, Showing Step 3 of 3
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4. You are now prompted for selection of the destination and file type. After 
entering a desired filename, extension, and destination, click Finish. The file is 
then exported.

Exporting Data to the IDL Session

You can export data from an iTool into a single variable using the IDL Data Export 
Wizard.

For example, to export data to an IDL variable:

1. Select File → Export. The IDL Data Export Wizard appears.

Figure 2-24: The IDL Data Export Wizard, Exporting a Variable Step 1 of 3
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2. Select To an IDL Variable.

Figure 2-25: The IDL Data Export Wizard, Exporting a Variable Step 2 of 3
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3. From the next screen, select the data which you wish to export. Notice that 
only data items can be exported as variables. Click Next.

4. The final screen and step allow you to name your variable as you wish. A 
default name also appears as representative of the data item. Name your 
variable and click Finish.

5. The variable will now appear in the data manager.

Exporting via Context Menu

An alternate way to export a variable to IDL is to select the variable within the 
Visualization browser and right-click to choose Export to IDL. For more 
information on the Visualization browser, see Appendix D, “Visualization 
Properties”.

Figure 2-26: The IDL Data Export Wizard, Exporting a Variable Step 3 of 3
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Unknown Data 

If you supply data in a format not recognized by the current iTool, the Create 
Visualization dialog allows you to specify how the data is to be used.

You will see this dialog if the data you supply when launching an iTool from the IDL 
command line does not match a known data organization for the selected tool, or if 
you open an ASCII text file containing data that appears to be irregularly gridded.

The Create Visualization dialog contains the following choices:

• Launch the gridding wizard

This option lets you transform irregularly-gridded data into regularly-gridded 
data using IDL’s gridding routines. The resulting regularly-gridded data will be 
displayed by the iTool. See “Gridding Wizard” on page 50 for details.

• Select a visualization and specify parameters

This option lets you manually specify how the data should be assigned to a 
selected visualization’s parameters.

• Do not create a visualization

Figure 2-27: The iTools Create Visualization Dialog
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Gridding Wizard

The iTools Gridding Wizard allows you to convert irregularly-gridded data into 
regularly-gridded data using a variety of methods. The gridding wizard processes 
your irregularly-gridded data in three steps.

The IDL Gridding Wizard Step 1 of 3 dialog contains the following items:

• Number of points entered

• X Coordinates — The X coordinate range

• Y Coordinates — The Y coordinate range

• Data values — The data minimum and maximum values

• Spherical data checkbox — Check this box if the data is spherical

• Coordinate diagram — Shows coordinates of grid data

• Show points checkbox — Select to show all points (default = checked)

• Help — Obtain help on this dialog

• Back — Return to previous step

• Next — Proceed to Step 2 of 3

• Cancel — Dismiss the Gridding Wizard

Figure 2-28: The IDL Gridding Wizard Step 1 of 3
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The IDL Gridding Wizard Step 2 of 3 dialog contains the following items:

• X Coordinates — modify dimension, start or end

• Y Coordinates — modify dimension, start or end

• Coordinate diagram — Shows coordinates of grid data

• Show points checkbox — Select to show all points (default = checked)

• Help — Obtain help on this dialog

• Back — Return to previous step

• Next — Proceed to Step 3 of 3

• Cancel — Dismiss the Gridding Wizard

Figure 2-29: The IDL Gridding Wizard Step 2 of 3
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The IDL Gridding Wizard Step 3 of 3 dialog contains the following items:

• Choose gridding method — Choose from pull-down list of methods. See 
“GRIDDATA” in the IDL Reference Guide manual for a discussion of the 
gridding methods.

• Preview — Click to preview selected method and data

• Auto preview — Checkbox to turn auto preview on (default = off)

• Statistics tab — Shows data statistics

• Options tab — Set options for missing values, smoothing, weighting, and 
anistropy between axes

• Search tab — Set options for using search ellipse

• Coordinate diagram — Shows coordinates of grid data

• Show points checkbox — Select to show all points (default = checked)

• Help — Obtain help on this dialog

• Back — Return to previous step

• Finish — Dismiss the Gridding Wizard with data gridded

Figure 2-30: The IDL Gridding Wizard Step 3 of 3
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• Cancel — Dismiss the Gridding Wizard
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Chapter 3:

iTool Common Tasks
This chapter describes the following common tasks that can be performed with all of the IDL 
Intelligent Tools:
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The Preferences Browser  . . . . . . . . . . . . . .  87
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Introduction

The Standard IDL Intelligent Tools supplied in the IDL 6.0 distribution comprise five 
distinct tools: iImage, iPlot, iSurface, iContour, and iVolume. Each tool performs a 
specific set of tasks related to the type of data it is designed to use. In addition to 
these specific tasks, all five tools have a number of tasks they perform in common. 
This chapter describes only those common tasks; for information about specific tasks 
performed by the individual iTools, refer to the chapters describing those tools.

The common iTool tasks include selecting objects, retracing steps with the 
Undo/Redo commands, and manipulating data. All iTools share a common interface 
for setting properties, browsing the available operations and visualizations, adjusting 
the window layout, and ending the iTool session.

Note
This chapter describes only the Standard IDL iTools, those iTools supplied in the 
IDL 6.0 distribution. Other iTools written by users and third-party developers share 
a common interface with the RSI iTools because the iTools framework is used to 
create all iTools. However, the specific functionality of such iTools may be different 
from the functionality of the RSI iTools described here.
Introduction iTool User’s Guide



Chapter 3: iTool Common Tasks 57
Selection of Objects

iTool elements such as axes and annotations have objects associated with them. These 
objects have their own associated properties  — such as color, line style, size, and so 
on. There are two ways to select objects in IDL iTools:

• With the Select arrow

• From the Visualization Browser

To select an object or group of objects with the Select arrow:

1. If necessary, click the Select button  on the toolbar to enter Select mode.

2. Position the arrow mouse pointer over the object and click. A selection box 
appears around the object.

3. To select additional objects, hold down the SHIFT key while clicking them.

To select an object or group of objects from the Visualization Browser:

1. Select Window → Visualization Browser.

2. Click the name of the object in the Visualization Browser list. A selection box 
or selection highlight appears on that object in the iTool window.

3. To select additional objects, hold down the SHIFT key while selecting the 
names of additional objects in the Visualization Browser list.

Select All

Select All selects all objects (visualizations, annotations, legends, etc.) displayed in 
the iTool window.

To select all objects:

1. Select Edit → Select All. All displayed objects are selected.

2. CTRL + click to deselect any objects that you do not want to include.
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Undo/Redo

Any action performed in an iTool window can be undone or redone. The Undo and 
Redo mechanism provides a useful way of retracing and repeating steps that have 
been performed in the iTool window.

Note
Operations which cannot be undone are: Open, Save, Export, Export variable, Print, 
Exit, and window moving and resizing.

To undo the most recent action, do one of the following:

• Select Edit → Undo.

or

• Click .

To undo multiple actions, simply repeat these commands. When no more actions 
remain to be undone, the Undo menu item or toolbar button is no longer active.

To repeat actions that have been undone, do one of the following:

• Select Edit → Redo.

or

• Click .or

Tip
Look at the text following the Undo or Redo menu item, or hover the mouse pointer 
over the Undo or Redo button on the toolbar to display the tooltip, to identify the 
action that will be undone or redone.
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Common Manipulation Tasks

All iTools have the following manipulation tasks in common: translating, scaling, 
zooming, rotating, transforming, and filtering.

Translating

Translation moves an object or group of objects in a specified direction. When an 
object is selected, a bounding box appears around the object. 

To translate a selected object to another location: 

1. Position the pointer inside the bounding box. The mouse pointer changes to the 
translation pointer .

2. Drag in the desired direction. The entire object moves to the new location.

Figure 3-1: Translating Objects
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Note
For information on creating a surface visualization which you can translate such as 
the one shown in the previous figure, see Chapter 5, “Working with Surfaces”.

Scaling

Two types of scaling are possible: constrained scaling and unconstrained scaling. 

Constrained Scaling

Constrained scaling permits scaling of only one dimension while preserving the other 
dimensions.

Constrained Scaling of 2-D Objects

To scale one dimension of a 2-D object, click on the object so that eight small 
selection-boxes appear at each corner of the object and also midway along each side 
of the object. Then position the mouse onto one of these boxes so that the mouse 
pointer changes to a four-headed arrow pointer (see the following figure). Drag the 
mouse in the desired direction to scale the object in the selected dimension.

Figure 3-2: Resizing a 2-D Plot

Resize On Selection Boxes
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Constrained Scaling of 3-D Objects

Two types of constrained scaling are available for 3-D objects: multiple-axis scaling 
and single-axis scaling. 

The multiple-axis scaling mouse pointer for 3-D objects is a three-headed arrow  
displayed when the mouse pointer is positioned over a corner of a 3-D object’s data 
space. Dragging the constrained scaling pointer scales the object a fixed distance 
along all axes in the direction of the drag.

Figure 3-3: Constrained Scaling
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The single-axis scaling pointer for 3-D objects is a two-headed arrow , displayed 
when the pointer is positioned over an axis “whisker” in a 3-D image. Dragging an 
axis “whisker” scales the object only in the direction of the arrows.

Unconstrained Scaling

Unconstrained scaling allows you to scale all dimensions of an object at once from 
any point within the object. Unconstrained scaling is different for 2-D and 3_D 
objects.

Figure 3-4: Resizing a 3-D Surface

Axis handle Resizing pointer
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Unconstrained Scaling of 2-D Objects

Unconstrained scaling of 2-D objects occurs when a corner of the data set bounding 
box is dragged. The mouse pointer changes to an unconstrained scaling pointer , 
and the object is scaled in the direction of the drag.

Figure 3-5: Unconstrained Scaling of a 2-D Plot

Unconstrained scaling pointer
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Unconstrained Scaling of 3-D Objects

Unconstrained scaling of 3-D objects occurs when a single side of the data set 
bounding box is dragged. The mouse pointer changes to an unconstrained scaling 
pointer , and the object is scaled along the dimensions of the selected side.

Zooming

Two types of zooming are available in all iTools: Canvas Zoom, which increases or 
decreases the magnification of the entire display canvas by a specified percentage, 
and View Zoom, which zooms in or out on a specific portion of the display area.

Canvas Zoom

Canvas Zoom increases or decreases magnification of the entire iTool window 
without moving the observer’s “eye.”

To zoom in or out with Canvas Zoom:

Figure 3-6: Unconstrained Scaling of a 3-D Surface

Bounding box
side

Unconstrained
scaling pointer
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1. Click the browse button  and select a percentage from the list.

• To increase magnification, choose a percentage greater than 100%.

• To decrease magnification, choose a percentage less than 100%.

• To specify an arbitrary percentage, edit the number in the zoom text box.

2. Select 100% to return to the default magnification.

View Zoom

View Zoom increases or decreases magnification at a specific point in the iTool 
window. This is similar to moving the observer’s “eye” closer to or farther away from 
the object. Clicking with the mouse specifies the point of interest, and dragging the 
mouse makes it possible to zoom in or out.

To zoom in or out in Zoom mode:

1. Click Zoom  on the toolbar to enter Zoom mode.

2. Position the mouse pointer on the viewplane. The pointer changes to a zoom 
pointer .

3. Do either of the following:

• Drag the zoom pointer toward the top of the iTool window to enlarge the 
display.

• Drag the zoom pointer toward the bottom of the iTool window to make the 
display smaller.

4. Click on the arrow Select button to leave Zoom mode and return to Select 
mode. The mouse pointer changes to an arrow pointer. In Select mode, 
dragging the arrow pointer positions the zoomed image.

Figure 3-7: Canvas Zoom List
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Rotating

The iTools provide a number of ways to rotate graphical objects. 3-D objects can be 
rotated freely or along an axis using the mouse. In addition, both 2-D and 3-D objects 
can be rotated left or right in 90-degree increments, or they can be rotated by a 
specified number of degrees. These tools rotate the entire data space.

Mouse Rotation

To rotate a 3-D object with the mouse:

1. Select the object in the iTool window.

2. Click Rotate  on the toolbar to enter Rotate mode. The rotation sphere, 
consisting of circular x-, y-, and z-dimension axes, is displayed around the 
object, as illustrated in Figure 3-8 and Figure 3-9:

3. 3-D objects can be constrained to rotate only along one of the three displayed 
axes, or they can be rotated freely.

• To rotate an object along an axis, position the mouse pointer on the axis. 
The constrained rotation pointer  is displayed. Drag in the desired 
direction to rotate the object along the selected axis.

Figure 3-8: Rotating a 3-D Object
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• To rotate an object freely, position the mouse pointer anywhere on the 
object.The free rotation pointer  is displayed. Drag in any direction to 
rotate the object in that direction.

4. Click  or select Edit → Undo to undo the rotation, or click  to leave 
rotate mode.

Rotate Left and Rotate Right

To rotate a selected 2-D or 3-D object 90° left or right, select 
Operations → Rotate → Rotate Left or Operations → Rotate → Rotate Right.

Note
For three-dimensional objects, the rotation is about the Z axis.

Figure 3-9: Free Rotation
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Rotate by Specified Angle

To rotate a selected 2-D or 3-D object a specific number of degrees, select 
Operations → Rotate → Rotate by Angle, specify the number of degrees in the 
Rotate Angle dialog, and click OK.

Transforming

Three types of transforms are common to all iTools: Resample, Rotate Data and Scale 
Data.

Resample

The Resample transform resamples the selected data. Resampling operation 
properties include factors for each dimension of the data, as well as the interpolation 
method to be used. 

Figure 3-10: Rotate Angle Dialog

Figure 3-11: Resample Dialog
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For example, if the X, Y, or Z value of a visualization needs to be different from the 
original data value, you can resample the data to adjust the X, Y, or Z value by the 
specified resample factor. Or, if the default interpolation method produces 
undesirable artifacts in the visualization of the data, the data can be resampled with a 
different interpolation method.

To resample data:

1. Select one or more objects in the iTool window for resampling.

2. Select Operation → Transform → Resample.

3. Use the property sheet that appears to specify the resampling factor in each 
dimension, along with the interpolation method. See “Resample Properties” on 
page 258 for details.

4. Click OK to resample the data, or Cancel to abort the operation.

Note
For more information on the iTool’s Operations Browser, see Appendix C, 
“Operations Properties”.

Rotate Data

The Rotate Data transform makes it possible to rotate the data within the visualization 
by a specified number of degrees without affecting the rest of the data space 
(graphical objects and axes).

To rotate data:

1. Select the visualization.

2. Select Operation → Transform → Rotate Data. The Rotate Angle dialog is 
displayed.

Figure 3-12: Rotate Angle Dialog
iTool User’s Guide Common Manipulation Tasks



70 Chapter 3: iTool Common Tasks
3. Specify the number of degrees to rotate by clicking the up-down control, or by 
editing the text.

4. Click OK.

Scale Data

The Scale Data transform makes it possible to scale the data within an object by a 
specified scale factor.

To scale data:

1. Select one or more objects which contain the data to be scaled.

2. Select Operations → Scale Data. The Scale Factor dialog appears.

3. Change the scale factor, if necessary, by editing the number in the Scale Factor 
text box, and click OK to scale the selected object(s) and close the Scale 
Factor dialog, or Cancel to close the Scale Factor dialog without scaling the 
object(s).

Filtering

Three types of filters are common to all iTools: Smooth filtering, Median Filtering, 
and Convolution.

Smooth Filter

To remove unwanted noise from data, apply the Smooth filter to the data.

To apply the Smooth filter:

1. Select the data that you want to smooth.

2. Select Operations → Filter → Smooth.

Figure 3-13: Scale Factor Dialog
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Median Filter

Median smoothing replaces each point with the median (a value in an ordered set of 
values with an equal number of values above and below it) of the one- or two-
dimensional neighborhood of a given width. It is similar to smoothing with a boxcar 
or average filter but does not blur edges larger than the neighborhood. Median 
filtering is effective in removing “salt and pepper” noise, (isolated high or low 
values). 

To apply the Median filter:

1. Select the data that you want to smooth.

2. Select Operations → Filter → Median.

Convolution Filter

To convolve data:

1. Select the data to be convolved.

2. Select Operations → Filter → Convolution. The Convolution Kernel Editor 
window is displayed.

Figure 3-14: Convolution Kernel Editor
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3. Change Convolution Kernel Editor settings as necessary by modifying any of 
the following:

• Select a filter type from the list. The default filter is named Default.

• Edit the number of Columns and Rows, if necessary.

• Choose between a One Dimensional and a Two Dimensional 
convolution.

• Scaling is automatic by default. To choose a different scaling factor, clear 
the Automatic scaling check box and enter a new factor in the Scale by 
text box.

• Position is Centered by default. Clear the check box to turn centering off.

• Edges Wrap by default. To choose a different edge format, select Zero or 
Repeat from the list.

• If Show dialog next time is selected, the Convolution Kernel Editor 
window will be displayed the next time the Convolution filter is selected. 
Clear the check box to apply the filter without displaying the dialog.

4. Click OK to apply the filter with the current settings and close the Convolution 
Kernel Editor window, or click Cancel to close the window without applying 
the filter.

Morphing

Mathematical morphology is a method of processing digital images on the basis of 
shape. Six morphing options are available for use in iTools: dilate, erode, morph 
open, morph close, morph gradient, and morph tophat.

Morphing 
Option Description

Dilate Dilate is commonly known as “fill”, “expand”, or “grow.” It 
can be used to fill “holes” of a size equal to or smaller than the 
structuring element.

Erode  Erode does to the background what dilation does to the 
foreground. Given an image and a structuring element, erode 
can be used to remove islands smaller than the structuring 
element. 

Table 3-1: Morph Menu Options
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To apply a morphology option:

1. Select the object to be morphed.

2. Select Operations → Morph → <option>.

Morph open  Morph open is simply an erosion operation followed by a 
dilation operation. Applying morph open more than once 
produces no further effect.

Morph close  Morph close is simply a dilation operation followed by an 
erosion operation. Applying morph close more than once 
produces no further effect.

Morph gradient  Morph gradient is the subtraction of an eroded version of the 
original image from a dilated version of the original image. 

Morph tophat Morph tophat is implemented by first applying the opening 
operator to the original image, then subtracting the result from 
the original image. Applying tophat shows the bright peaks 
within the image. 

Morphing 
Option Description

Table 3-1: Morph Menu Options
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Legends

Legends identify the visualizations displayed in the iTool window. For example, a 
legend displayed in an iPlot window can include a description of each plot line in a 
plot. Or a legend can be displayed in an iSurface window to identify surfaces and 
contour levels displayed on those surfaces.

To insert a legend for a surface or contour:

1. Select specific items to include in the legend, or click in an empty area of the 
iSurface window dataspace to select the dataspace and include all items in the 
legend.

2. Select Insert → Legend.

To add to a legend:

1. Select the legend by clicking the legend border.

2. Click Add to Legend  in the Manipulator toolbar.

3. Click the item in the iTool window to add to the legend.

Each legend entry consists of a sample and a label. For example, in Figure 3-15, the 
sample for the first entry is an unbroken line of thickness 1, and the label is Noisy 
Sine Plot. The sample for the second is a broken blue line of thickness 2, and the label 
is Clean Sine Plot.

Figure 3-15: Legend for Two Plot Lines
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Tip
To alter your legend’s properties such as in the example shown previously, display 
the property sheet. To do this, double-click the border of the legend box.
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Annotations

The following types of annotations can be added to iTool visualizations:

Note
Annotations are 2D in nature and are defined in their own data space. They are most 
useful for adding notes to a data visualization for which the orientation has been 
finalized.

Text Annotations

To add a text annotation:

1. Click the Text Annotation button  on the toolbar. 

2. Click anywhere on the canvas. A text insertion bar appears where you click.

3. Type the annotation text.

• To add a new line, press CTRL + ENTER.

• To add superscript characters, press CTRL + U.

Annotation 
Type Description

Text Single lines or multiple lines of text can be added to a 
visualization to provide a label or description.

Line Straight line annotations can be added to a visualization to link 
labels to objects or to identify an object.

Rectangle Rectangular annotations can be added to a visualization to 
identify rectangular areas.

Oval Oval annotations can be added to a visualization to identify 
circular areas.

Polygon Polygon annotations can be added to a visualization to identify 
areas bounded by a multi-sided polygon.

Freehand Freehand annotations can be added to a visualization to 
identify an area.

Table 3-2: Types of Annotations
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• To add subscript characters, press CTRL + D.

• To return to normal characters, press CTRL + N.

Note
For information on how to embed these and other formatting commands from 
the Text Annotation property sheet, refer to “Text Annotation Properties” in 
Appendix D.

4. Press ENTER. A bounding box appears around the annotation text.

• To position the annotation, position the mouse pointer within the bounding 
box so that it changes to a translation pointer . Click and drag the 
annotation to the desired location.

• To display and modify text annotation properties such as font, text color 
and transparency, double-click the bounding box or inside the bounding 
box.

Line Annotations

To add a line annotation:

1. Click the Line Annotation button  on the toolbar.

2. Click in an empty part of the canvas and, without releasing the mouse button, 
drag to draw a line of the desired length.

• To constrain in the direction that you are drawing, hold down the SHIFT 
key while drawing.

• To draw the line from the center, hold down the CTRL key while drawing.

3. Release the mouse button. Selection handles appear at both ends of the line 
annotation.

• To position the line annotation, position the mouse pointer over the 
selected line so that it changes to a translation pointer . Click and drag 
the annotation to the desired location.

• To resize the line annotation, position the mouse pointer over the selection 
handle at one end of the line so that it changes to a resize pointer . Click 
and drag the selection handle to obtain the desired line length.

• To display and modify line annotation properties such as line thickness and 
arrow style, double click the annotation.
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Rectangle Annotations

To add a rectangle annotation:

1. Click the Rectangle Annotation button  on the toolbar.

2. Click in an empty part of the canvas and, without releasing the mouse button, 
drag to draw a rectangle of the desired size.

• To constrain the rectangle to a square, hold down the SHIFT key while 
drawing.

• To draw the rectangle from the center, hold down the CTRL key while 
drawing.

3. Release the mouse button. Selection handles appear at the corners and sides of 
the rectangle annotation.

• To position the rectangle annotation, position the mouse pointer inside the 
selected rectangle so that it changes to a translation pointer . Click and 
drag the annotation to the desired location.

• To resize the rectangle annotation, position the mouse pointer over the 
selection handle on one side of the rectangle so that it changes to a resize 
pointer . Click and drag the selection handle to obtain the desired shape.

• To scale the rectangle annotation, position the mouse pointer over the 
selection handle at one corner of the rectangle so that it changes to an 
unconstrained scaling pointer . Click and drag the selection handle to 
obtain the desired scaling.

• To display and modify rectangle annotation properties such as background 
color and transparency, double click the annotation.

Oval Annotations

To add an oval annotation:

1. Click the Oval Annotation button  on the toolbar.

2. Click in an empty part of the canvas and, without releasing the mouse button, 
drag to draw a circular annotation of the desired size.

• To constrain the oval to a circle, hold down the SHIFT key while drawing.

• To draw the oval from the center, hold down the CTRL key while drawing.

3. Release the mouse button. Selection handles appear at the corners and sides of 
the oval annotation.
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• To position the oval annotation, position the mouse pointer inside the 
selected oval so that it changes to a translation pointer . Click and drag 
the annotation to the desired location.

• To resize the oval annotation, position the mouse pointer over the selection 
handle on one side of the oval so that it changes to a resize pointer . 
Click and drag the selection handle to obtain the desired shape.

• To scale the oval annotation, position the mouse pointer over the selection 
handle at one corner of the oval so that it changes to an unconstrained 
scaling pointer . Click and drag the selection handle to obtain the 
desired scaling.

• To display and modify oval annotation properties such as background 
color and transparency, double click the annotation.

Polygon Annotations

To add a polygon annotation:

1. Click the Polygon Annotation button  on the toolbar.

2. Click in an empty part of the canvas to specify the first point of the polygon.

3. Click again to specify the second point of the polygon. A line is drawn to 
connect the first and second points.

4. Click to specify the third and each consecutive point of the polygon. Lines are 
drawn to connect each subsequent point, forming a multi-sided shape. 

Tip
To remove the last point, press the ESC key.

5. Double-click to specify the last point of the polygon. Selection boxes appear at 
the corners and sides of the newly-created annotation.

• To position the polygon annotation, position the mouse pointer inside the 
selected polygon so that it changes to a translation pointer . Click and 
drag the annotation to the desired location.

• To resize the polygon annotation, position the mouse pointer over the 
selection handle on one side of the polygon so that it changes to a resize 
pointer . Click and drag the selection handle to obtain the desired shape.

• To scale the polygon annotation, position the mouse pointer over the 
selection handle at one corner of the polygon so that it changes to an 
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unconstrained scaling pointer . Click and drag the selection handle to 
obtain the desired scaling.

• To display and modify polygon annotation properties such as background 
color and transparency, double click the annotation.

Freehand Annotations

To add a freehand annotation:

1. Click the Freehand Annotation button  in the toolbar.

2. Click in an empty part of the canvas and, without releasing the mouse button, 
drag to draw a freehand shape.

3. Release the mouse button. Selection handles appear at the corners and sides of 
the selected freehand annotation.

• To position the freehand annotation, position the mouse pointer inside the 
selected freehand shape so that it changes to a translation pointer . Click 
and drag the annotation to the desired location.

• To resize the freehand annotation, position the mouse pointer over the 
selection handle on one side of the freehand shape so that it changes to a 
resize pointer . Click and drag the selection handle to obtain the desired 
shape.

• To scale the freehand annotation, position the mouse pointer over the 
selection handle at one corner of the freehand shape so that it changes to an 
unconstrained scaling pointer . Click and drag the selection handle to 
obtain the desired scaling.

• To display and modify rectangle annotation properties such as background 
color and transparency, double click the annotation.
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Additional Axes

By default, X, Y and (for 3-D data spaces) Z axes are displayed in the iTool window. 
The display of these axes is controlled by property sheets for the axes container and 
for individual axes (see “Axes” in Appendix D). Additional X, Y or Z axes can be 
added to most data spaces to make it easier to identify characteristics.

To add an additional axis to your data space:

1. Select the data space.

2. Select Insert → Axis.

3. Choose from the following options:

• X axis

• Y axis

• Z axis

Use the mouse to position the new axis, and double-click the axis to display the axis 
property sheet.

Note
For a 3D visualization, you can use the Shift + Ctrl to translate an axis in the 
opposite direction. This will be shown in the Status message when an axis is 
selected for translation. You can also use the arrow keys to change axes placement 
direction.
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Rendering Translucent Objects

In many places in iTools, you can set the transparency of an object to make it appear 
totally opaque, transparent, or translucent. An isosurface is an example of such an 
object. The text objects can also be made partially transparent so that you can see 
through the labels on a complex plot and still see both the labels and the data beneath 
the label. In most situations consisting of several opaque objects representing data 
and some translucent text labeling, the translucent rendering works well.

However, translucent rendering does not always work well in more complex 
situations. The reason for this is that translucent objects must be strictly rendered 
from the back (far from the viewer) towards the front, or closer to the viewer. IDL 
accomplishes translucent rendering by blending the pixels already drawn on the 
device with the pixels that are drawn to represent a translucent object. Therefore, it is 
important that the objects that are positioned behind the translucent object be 
rendered before the translucent object. If the ordering is not correct, then you will not 
be able to see the objects behind the translucent object.

For most cases in iTools, the ordering issue is not a problem. If you encounter such a 
problem, the Bring to Front (and related) operations in the tools may help you 
improve the appearance of translucent objects. But in some cases the ordering can not 
be easily accomplished. For example, a complex isosurface rendered as a translucent 
object does not always look correct from all viewing angles. An isosurface is 
composed of a large number of triangles stored in an IDLgrPolygon object. The 
triangles are always drawn in the same order, the order in which they are stored in the 
object.

So, as the viewing angle changes, the apparent back-to-front ordering of the triangles 
also changes. In some cases, the triangles closest to the viewer draw first and end up 
blocking the view of other triangles drawn later and behind them that should be 
visible through the translucent triangles drawn first.

Transparency should be used with care with objects like complex isosurfaces, 
keeping in mind that the rendering of the objects may not appear completely correct.
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Property Sheets

Most iTool visualizations and operations have attributes or properties that can be 
modified to change their characteristics. These properties are organized into property 
sheets for each operation and visualization type. For example, the skin of a surface 
visualization has a gold color by default. To change this color, modify the surface 
color property in the surface visualization property sheet.

Visualization Property Sheets

Visualization property sheets can be displayed from the Visualization Browser or 
from the iTool window.

To display a visualization’s property sheet from the Visualization Browser:

1. Select Window → Visualization Browser.

2. Select the name of the object in the Visualization Browser list. The object’s 
properties are displayed in the right-hand pane of the Visualization Browser 
window (the small arrows at the top-left of the Browser window will allow you 
to display both panes).

To display a visualization’s property sheet from the iTool window:

1. Click to select the object in the iTool window.

2. Do one of the following to display the property sheet for the selected 
visualization:

• Double-click the visualization in the iTool window.

• Select Edit → Properties.

• Right-click to display the Context Menu, and select the Properties menu 
item.

Note
For detailed information on Visualization Browser properties, see Appendix D, 
“Visualization Properties”.

Operations Property Sheets

Operations property sheets can only be displayed from the Operations Browser. To 
display an operations property sheet:
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1. Select Operations → Operations Browser.

2. Select the name of the operation in the Operations Browser list. The operation 
properties are displayed in the right-hand pane of the Operations Browser 
window (the small arrows at the top-left of the Browser window will allow you 
to display both panes).

Note
For detailed information on Operations Browser properties, see Appendix C, 
“Operations Properties”.
Property Sheets iTool User’s Guide



Chapter 3: iTool Common Tasks 85
The Visualization Browser

The Visualization Browser provides access to visualizations (objects displayed in the 
iTool window) and the properties of those visualizations. When the Visualization 
Browser is displayed, you can select graphical objects from a nested list and display 
the property sheets for those objects. For example, if a surface visualization is 
displayed and you would like to change the appearance of the X axis in that 
visualization, you can select the axis in the Visualization Browser (Figure 3-16), 
display the property sheet for that axis (Figure 3-17), and modify the properties to 
change the appearance of the axis.

To select an object with the visualization browser:

1. Select Window → Visualization Browser.

2. Select the name of the object in the list. The element is highlighted in the iTool 
window.

• To expand a list item, click the + icon . 

• To collapse an expanded list item, click the - icon .

Figure 3-16: Visualization Browser with Axis 0 Selected

Property Sheet Expansion ButtonElement name selected

Element highlighted in iTool window
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3. To display the property sheet for the object, click the expansion button to the 
right of the list or double-click the property.

4. To change a property setting, click in the settings column. 

• If a drop-down button  appears in the settings column, click the button 
to choose a new setting from the list of options, activate a slider to change 
the setting value, display a selection dialog or list, or display an Edit button 
providing access to a user-defined property control.

• If the text is editable, edit the text to change the setting.

See Appendix B, “Property Controls” for a detailed description of the 
types of property settings included in property sheets.

5. Click the Close button  to close the Visualization Browser.

Note
Properties of standard graphical objects are described in detail in Appendix D, 
“Visualization Properties” and in the “IDL Commands” chapter of the IDL 
Reference Guide.

Figure 3-17: Visualization Browser with Property Sheet Displayed
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The Preferences Browser 

The Preferences Browser provides a means of setting preferences, or default 
properties, for the visualizations, annotations, and file readers and writers used by all 
iTools. For example, if you prefer the projection of contours displayed on surfaces to 
be three-dimensional rather than planar, you can change the default property for 
projecting contours from Planar to Three-D in the Preferences Browser, as shown in 
Figure 3-18.

For more information on the property sheets displayed in the right-hand pane of the 
Preferences Browser, see Appendix D, “Visualization Properties”.

The Preferences Browser displays a nested list of visualizations, annotations, file 
readers, and file writers available for all iTools in the left-hand pane, and a property 
sheet for the currently selected item in the right-hand pane. 

• To expand a list item, click the + icon . 

• To collapse an expanded list item, click the - icon .

Figure 3-18: Preferences Browser with Contour Projection Properties Displayed
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To change the properties of a a visualization, annotation, file reader, or file writer 
from the Preferences Browser:

1. Select File → Preferences.

2. Select the name of the visualization, annotation, file reader, or file writer in the 
list. A list of properties and the current property settings appears in the right-
hand pane of the Preferences Browser window.

3. Locate the property you want to change in the list, and click in the settings 
column. 

• If a drop-down button  appears in the settings column, click the button 
to choose a new setting from the list of options, activate a slider to change 
the setting value, display a selection dialog or list, or display an Edit button 
providing access to a user-defined property control.

• If the text is editable, edit the text to change the setting.

See Appendix B, “Property Controls” for a detailed description of the 
types of property settings included in property sheets.

4. Click the Close button  to close the Preferences Browser.

Note
Changes to preferences are saved between iTool sessions. When the Preferences 
browser is closed, preferences are saved in their current state.

General Settings 

The first option on the Preferences Browser is the General Settings option. Settings 
listed here will be applicable to all iTools if altered. The properties listed here are:

Property Control Type: Values

Unlimited Buffer Boolean: Set to determine buffer size as limited or unlimited:

• True

• False

Default = True

Table 3-3: General Settings Properties
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Note
The Restore Defaults button at the bottom of the Preferences Browser restores all 
default settings immediately.

Visualizations

Select this folder to edit visualization preferences and properties for various object 
types. For detailed information on visualization properties, see Appendix D, 
“Visualization Properties”.

Operations

Select this folder to edit operation preferences and properties for various object types. 
For detailed information on operation properties, see Appendix C, “Operations 
Properties”.

File Readers 

Select this folder to edit file reader preferences and properties. Available file reader 
types and their editable properties are listed in the following tables. For more 
information on reading in data of various types, see Chapter 2, “Importing and 
Exporting Data”.

Zoom on Window 
Resize

Boolean: Set to determine if iTool data resizes upon window 
resizing:

• True

• False

Default = False

Change directory 
on open

Boolean: Set to be prompted to change directory upon open:

• True

• False

Default = True

Property Control Type: Values

Table 3-3: General Settings Properties (Continued) 
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iTools State

The iTools State File Reader properties are:

Windows Bitmap

The Windows Bitmap File Reader properties are:

Joint Photographic Experts Group

The Joint Photographic Experts Group File Reader properties are:

Macintosh PICT

The Macintosh PICT File Reader properties are:

Property Control Type: Values

None The iTools State File Reader has no configurable properties 
other than Name and Description.

Table 3-4:  iTools State File Reader Properties

Property Control Type: Values

None The Windows Bitmap File Reader has no configurable 
properties other than Name and Description.

Table 3-5: Windows Bitmap File Reader Properties

Property Control Type: Values

None The Joint Photographic Experts Group File Reader has no 
configurable properties other than Name and Description.

Table 3-6:  Joint Photographic Experts File Reader Properties

Property Control Type: Values

None The Macintosh PICT File Reader has no configurable 
properties other than Name and Description.

Table 3-7:  Macintosh PICT File Reader Properties
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Portable Network Graphics

The Portable Network Graphics File Reader properties are:

Tag Image File Format

The Tag Image File Format File Reader properties are:

Property Control Type: Values

None The Portable Network Graphics File Reader has no 
configurable properties other than Name and Description.

Table 3-8:  Portable Network Graphics File Reader Properties

Property Control Type: Values

Image index Number: Level at which to begin image index. Edit the 
number to change the value. Default = 0

Image Stacking String List: Image stacking method. Select a method from the 
list. Choose between these values:

• +X

• -X

• +Y

• -Y

• +Z

• -Z

Default = Read Single Image

Table 3-9:  Tag Image File Format File Reader Properties
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DICOM Image

The DICOM Image File Reader properties are:

Windows Waveform Audio Stream

The Windows Waveform Audio Stream File Reader properties are:

ASCII text

The ASCII text File Reader properties are:

Binary data

The Binary data File Reader properties are:

Property Control Type: Values

None The DICOM Image File Reader has no configurable properties 
other than Name and Description.

Table 3-10:  DICOM Image File Reader Properties

Property Control Type: Values

None The Windows Waveform Audio Stream File Reader has no 
configurable properties other than Name and Description.

Table 3-11:  Windows Waveform Audio Stream File Reader Properties

Property Control Type: Values

None The ASCII text File Reader has no configurable properties 
other than Name and Description.

Table 3-12:  ASCII Text File Reader Properties

Property Control Type: Values

None The Binary data Graphics File Reader has no configurable 
properties other than Name and Description.

Table 3-13:  Binary Data File Reader Properties
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File Writers 

Select this folder to edit file write preferences and properties. Available file writer 
types and their editable properties are shown in the following tables. For more 
information on writing data of various types, see Chapter 2, “Importing and 
Exporting Data”.

iTools State

The iTools State File Writer properties are:

Windows Bitmap

The Windows Bitmap File Writer properties are:

Property Control Type: Values

None The iTool State File Writer has no configurable properties 
other than Name and Description.

Table 3-14:  iTools State File Writer Properties

Property Control Type: Values

Bit depth String List: Bit depth in bits. Select a depth from the list. 
Choose between these values:

• Automatic

• 8 bit

• 24 bit

Default = Automatic

Table 3-15:  Windows Bitmap File Writer Properties
iTool User’s Guide The Preferences Browser



94 Chapter 3: iTool Common Tasks
Joint Photographic Experts Group

The Joint Photographic Experts Group File Writer properties are:

Macintosh PICT

The Macintosh PICT File Writer properties are:

Property Control Type: Values

Bit depth String List: Bit depth in bits. Select a depth from the list. 
Choose between these values:

• Automatic

• 8 bit

• 24 bit

Default = Automatic

Quality Number: Factor from 0 - 100 determining the level of quality. 
Move slider to change the level.

Default = 75

Table 3-16:  Joint Photographic Experts Group File Writer Properties

Property Control Type: Values

None The Macintosh PICT File Writer has no configurable 
properties other than Name and Description.

Table 3-17:  Macintosh PICT File Writer Properties
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Portable Network Graphics

The Portable Network Graphics File Writer properties are:

Tag Image File Format

The Tag Image File Format File Writer properties are:

Property Control Type: Values

Bit depth String List: Bit depth in bits. Select a depth from the list. 
Choose between these values:

• Automatic

• 8 bit

• 24 bit

Default = Automatic

Table 3-18:  Portable Network Graphics File Writer Properties

Property Control Type: Values

Bit depth String List: Bit depth in bits. Select a depth from the list. 
Choose between these values:

• Automatic

• 8 bit

• 24 bit

Default = Automatic

Compression String List: Compression type. Select a type from the list. 
Choose between these values:

• None

• Packbits

• JPEG

Default = None

Table 3-19:  Tag Image File Format File Writer Properties
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ASCII text

The ASCII text File Writer properties are:

Binary data

The Binary data File Writer properties are:

Property Control Type: Values

Separator Enter a value.

Default = None

Use default 
format

Boolean: Use default format? Choose True or False. 

Default = True

Format string Number: Enter a number to change the value. 

Default = G9.2

Table 3-20:  ASCII Text File Writer Properties

Property Control Type: Values

Byte ordering String List: Byte ordering type. Select from the list. Choose 
between these values:

• Native

• Little endian

• Big endian

Default = Native

Table 3-21:  Binary Data File Writer Properties
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The Operations Browser

The Operations Browser provides a quick way to display and modify the properties 
for a given iTool operation (task performed on iTool data) before that operation is 
performed. For example, to display the properties of the Convolution filter, select the 
name of the filter in the left-hand pane of the Operations Browser (see Figure 3-19), 
and modify the Scale factor property value in the right-hand pane to change the 
default scale factor for convolution. 

The Operations Browser displays a nested list of operations available in the current 
iTool in the left-hand pane, and a property sheet for the currently selected operation 
in the right-hand pane. 

• To expand a list item, click the + icon . 

• To collapse an expanded list item, click the - icon .

To change the properties of an operation from the Operations Browser:

1. Select Operations → Operations Browser.

2. Select the name of the operation in the list. A list of properties and the property 
settings appears in the right-hand pane of the Operations Browser window.

3. Locate the property you want to change in the list, and click in the settings 
column. 

Figure 3-19: Operations Browser with Convolution Filter Properties Displayed
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• If a drop-down button  appears in the settings column, click the button 
to choose a new setting from the list of options, activate a slider to change 
the setting value, display a selection dialog or list, or display an Edit button 
providing access to a user-defined property control.

• If the text is editable, edit the text to change the setting.

See Appendix B, “Property Controls” for a detailed description of the 
types of property settings included in property sheets.

4. Click the Close button  to close the Operations Browser.

Note
Properties of standard iTool operations are described in Appendix C, “Operations 
Properties” and in the “IDL Commands” chapter of the IDL Reference Guide.
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Window Layouts

You can change the minimum size of the canvas displayed in the iTool window, 
display multiple views in the iTool window, or select a preset arrangement of views, 
with the Window Layout dialog. 

Note
If you are in Freeform mode, canvas size can also be changed interactively by 
dragging the corners or sides of the iTool window.

To change the minimum size of the canvas displayed in the iTool window:

1. Select Window → Layout.

2. Edit the pixel values in the Width and Height text boxes. (Default = Width 
512, Height 384.) A preview of the shape of the new canvas size is displayed in 
the Preview window.

3. Click OK to apply the changes, or Cancel to close the window without 
applying changes.

To change the number of views displayed:

1. Select Window → Layout.

2. Select Gridded from the Layout list.

3. Edit the number of columns and rows in the Grid text boxes. (Default = 1 by 
1.)

Figure 3-20: Window Layout Tool
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4. Click OK to apply the changes, or Cancel to close the window without 
applying changes.

To select a preset arrangement of views:

1. Select Window → Layout.

2. Select from the following arrangements in the Layout list:

3. Click OK to apply the changes, or Cancel to close the window without 
applying changes.

1 x 1 Gridded Trio Left

Inset Trio Right

Trio Top Freeform

Trio Bottom
Window Layouts iTool User’s Guide
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File Operations

File operations are provided in the iTools to allow you to open files, save files, import 
variables and files, export variables, or export the contents of the iTool window as an 
image file. Printing and exiting the iTool are additional file operations.

Opening Files

Data files, text files, and previously saved iTools State (*.isv) files can be opened 
with File → Open. For more information on opening files, see “Using File Open” on 
page 29.

Importing Variables and Files

IDL variables and files can be imported into the current iTool with File → Import. 
The IDL Data Import Wizard offers you the choice of importing a variable or a file, 
and then asks you to identify the location of the data source and the type of 
visualization to be created with the data. 

Import a Variable

The Data Import Wizard can import an IDL variable created at the IDL command line 
or exported from an iTool session into the current iTool. For more information on 
importing variables, see “Importing a Variable” on page 42.

Import a File

The Data Import Wizard can import text files, data files, or image files into the 
current iTool. For more information on importing files, see “Importing ASCII Data” 
on page 34, “Importing Binary Data” on page 38, or “Importing Image Data” on 
page 33.

Saving Files

The current state of the iTool can be saved as an iTools State (*.isv) file. Whenever 
you close an iTool window, you will be prompted to save the current state as an 
*.isv file so that you can return to the current state of the data later when you open 
the *.isv file. Other IDL users running IDL 6.0 for Windows, UNIX or Mac OS X 
can open *.isv files.
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Save

File → Save saves the state of the current iTool to a file. If the file has already been 
saved, it will be saved under the same filename it was previously saved under. If the 
state has not been previously saved and has no filename, enter a filename. The saved 
file can be opened by IDL on either the Windows or the UNIX platform.

Save As...

File → Save As also saves the state of the current iTool to a file, but it prompts you to 
enter a filename even if the file has been saved previously. Use Save As to save an 
existing iTools State file under a different name.

Exporting Variables and Files

Data items created within the current iTool can be exported as IDL Variables, and the 
contents of the current iTool window can be exported as an image file. Select 
File → Export, and follow the instructions in the IDL Data Export Wizard.

Export as a Variable

Data from the currently selected object can be exported as a variable from the IDL 
Data Export Wizard to the main IDL program.

For more information, see “Exporting Data to the IDL Session” on page 46.

Export as a File

The contents of the current window can be exported from the IDL Data Export 
Wizard as an image file.

For more information, see “Exporting Data to a File” on page 44.

Printing

File → Print sends the current view of the contents of the graphics window to the 
specified printer via the standard Windows or Motif printer dialog. If the contents 
have been modified in the current view, they will appear modified in the printer 
output.

To print the contents of the graphics window:

1. Select File → Print. The standard Windows or Motif printer dialog appears.

2. Select the desired printer and printer properties from the printer dialog. 
File Operations iTool User’s Guide
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3. Click Print. The contents of the graphics window are sent to the chosen 
printer, with the chosen options.

Exiting the iTool

Clicking the Close button  on the iTool window will close the selected window. 
File → Exit also closes the iTool window. You will be prompted to save any changes 
to the current state (see File → Save above for details). All visualizations and views 
within the window are removed from memory. 
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Additional Operations

The Histogram, Statistics, and Console tools display additional information about 
data displayed in the iTool windows, and about operations performed with the iTools.

Plotting a Histogram

Histogram displays a histogram plot of the data currently selected in the iTool 
window. The Histogram plot appears in a separate iPlot window.

To display a histogram plot:

1. Select an object or group of objects in the iTool window. 

2. Select Operations → Histogram.

Figure 3-21: Histogram Plot
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Displaying Statistics

The Statistics dialog displays all available statistical information pertaining to the 
object or objects currently selected in the iTool window.

To display the Statistics dialog:

1. Select an object or a group of objects in the iTools window.

2. Select Operations → Statistics. The Statistics window is displayed.

The information displayed in the Statistics window varies depending upon the type of 
objects selected.

• For scalars, the name of the variable and its value are displayed in the Statistics 
window.

• For arrays, the following information is displayed:

• Name

• Maximum & location

• Dimensions

• Standard deviation

• Mean

Figure 3-22: The iTools Statistics Window
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• Variance

• Absolute deviation

• Total

• Skewness

• Minimum & location

• Kurtosis - 3

The information in the Statistics window can be edited (by selecting Edit), printed, or 
saved as a file.

• On Windows platforms, the standard Windows editing context menu 
containing Cut, Copy, Paste and Delete commands can be displayed by right-
clicking anywhere in the Statistics window.

• On UNIX platforms, use the left or right mouse buttons to cut, copy or paste.

To save the text as an ASCII file:

1. Select File → Save As.

2. Enter a filename. If the filename already exists, you will be asked if you want 
to replace the file.

3. Select Cancel to return to the Statistics window without saving the file.

To print the text, select File → Print. The standard Windows or Motif printer dialog 
is displayed.

To close the Statistics window, select File → Close.

Resetting Dataspace Ranges

You can reset the ranges of your dataspace to accommodate all your contained 
visualizations. When you reset your ranges, the following properties of the dataspace 
are reset to a value of True:

• Automatic X range updates

• Automatic Y range updates

• Automatic Z range updates

To reset the ranges of your dataspace, select Operations →  Dataspace →  Reset 
Ranges.
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Recording a Message Log

Use Console to record a log of Status Bar information for each action performed with 
the current iTool.

To use Console:

1. Select Window → Console. A blank Message Log dialog appears.

2. As actions are performed in the iTool window, the Status Bar message 
associated with each action is recorded in the Message Log along with the date 
and time of the action. These messages can be selected and cut, copied or 
pasted:

• In Windows, the standard Windows editing context menu containing Cut, 
Copy, Paste and Delete commands can be displayed by right-clicking 
anywhere in the Message Log dialog.

Figure 3-23: Blank Message Log Dialog
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• In UNIX or Mac OS X, use the left or right mouse buttons to cut, copy or 
paste.

3. Click OK to close the Message Log dialog and stop recording messages.

Figure 3-24: Message Log Dialog with Context Menu
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Working with Images 
This chapter describes how to use the Image iTool.
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Introduction

The IDL iImage tool displays your data in image form. The iImage tool then allows 
you great flexibility in manipulating and visualizing image data. To use iImage, from 
the IDL Command Line, type iImage. An empty iImage tool appears. You can then 
import image data using any of several data import methods. For more information 
importing image data see Chapter 2, “Importing and Exporting Data”.

Note
For more information on accepted arguments and keywords, see “IIMAGE” in the 
IDL Reference Guide manual.

The iImage tool can be launched in many different ways:

• At the IDL Command Line without arguments or keywords

• At the IDL Command Line with arguments or keywords

• Through the File → New → Visualization → iImage menu option in the IDL 
Development Environment

• Through the File → New → iImage menu option in an iTool

Common image file formats accepted are:

• BMP • JPEG • PNG

• DICOM • PICT • TIFF
Introduction iTool User’s Guide
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Colors in the iImage Tool

The iImage tool allows you flexibility with colors and your visualization. RGB 
images contain their own color information while indexed images have their own 
color information which is separate from the image itself. Binary and greyscale 
images do not contain any color information. Color information can be modified for 
indexed, binary, and greyscale images. 

In order to modify color attributes for indexed, binary, and greyscale images, you can 
highlight the image data by clicking once on the visualization and then double-
clicking on it to bring up the Visualization Browser.

Figure 4-1: The Visualization Browser in the iImage Tool

Select to Edit
Color Table
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From the Visualization Browser you can select Image Palette → Edit Color Table 
→ Edit.

The Palette Editor contains these items:

• Current Palette colorbar and Reference colorbar — Shows a colorbar 
containing a display of the current palette and displays it below the 
reference colorbar.

• Channel and Histogram Display — The palette channel vectors are 
displayed; the red channel is displayed in red, the Green channel in green, 
the Blue channel in blue, and the optional Alpha channel in purple. The 
optional Histogram vector is displayed in Cyan. An area with a white 
background represents the current selection, with gray background 
representing the area outside of the current selection. Yellow drag handles 
are an additional indicator of the selection endpoints. These selection 
endpoints represent the range for some editing operations. In addition, 

Figure 4-2: The iImage Tool’s Palette Editor

Current Palette colorbar

Reference colorbar

Channel and Histogram
Display
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cursor X,Y values and channel pixel values at the cursor location are 
displayed in a status area below the graphics area.

• Zoom Options — The available buttons for zooming are from left to right:

• Color Space — A droplist allows selection of RGB, HSV or HLS color 
spaces. RGB is the default color space.

Note
Regardless of the color space in use, the color vectors retrieved with the 
GET_VALUE keyword to WIDGET_CONTROL are always in the RGB 
color space.

• Editing Mode — A droplist allows selection of the editing mode. 
Freehand is the default editing mode. The droplist options are:

Zoom Current Zooms to show the current selection.

Zoom In Zooms in 50% (factor of 2)

Zoom Out Zooms out 100% (factor of 2)

Zoom Return Returns the display to the full palette.

Table 4-1: 

Freehand The user can click and drag in the graphics 
area to draw a new curve. Editable channel 
vectors will be modified to use the new curve 
for that part of the X range within the 
selection that was drawn in Freehand mode.

Line Segment A click, drag and release operation defines the 
start point and end point of a line segment. 
Editable channel vectors will be modified to 
use the new curve for that part of the X range 
within the selection that was drawn in Line 
Segment mode.

Table 4-2: Editing Mode Droplist Options
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Note
Unless noted previously, editing operations apply only to the channel vectors 
currently selected for editing and apply only to the portion of the vectors 
within the selection indicators. 

• Editing Operations — The buttons that provide editing operations but do 
not require cursor input are:

Barrel Shift Click and drag operations in the horizontal 
direction cause the editable curves to be 
shifted right or left, with the portion which is 
shifted off the end of selection area wrapping 
around to appear on the other side of the 
selection area. Only the horizontal component 
of drag movement is used.

Slide Click and drag operations in the horizontal 
direction cause the editable curves to be 
shifted right or left. Unlike the Barrel Shift 
mode, the portion of the curves shifted off the 
end of the selection area does not wrap 
around. Only the horizontal component of 
drag movement is used.

Stretch Click and drag operations in the horizontal 
direction cause the editable curves to be 
compressed or expanded. Only the horizontal 
component of drag movement is used.

Ramp Causes the selected part of the editable curves to be 
replaced with a linear ramp from 0 to 255.

Smooth Causes the selected part of the editable curves to be 
smoothed.

Posterize Causes the selected part of the editable curves to be 
replaced with a series of steps.

Table 4-3: Editing Operations

Table 4-2: Editing Mode Droplist Options
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• Channel Display and Edit — A row of checkboxes allows the user to 
indicate which channels of Red, Green, Blue and the optional Alpha 
channel should be displayed. A second row of checkboxes allows the user 
to indicate which channels should be edited by the current editing 
operation. The checkboxes for the Alpha channel will be sensitive only if 
an Alpha channel is loaded relative to the color table.

Reverse Causes the selected part of the editable curves to be 
reversed in the horizontal direction.

Invert Causes the selected part of the editable curves to be 
flipped in the vertical direction.

Duplicate Causes the selected part of the editable curves 
to be compressed by 50% and duplicated to 
produce two contiguous copies of the channel 
vectors within the initial selection.

Load 
PreDefined

Leads to additional choices of pre-defined 
palettes. Loading a pre-defined palette 
replaces only the selected portion of the 
editable color channels, limited by the settings 
of the selection endpoints and editable 
checkboxes. This allows loading only a single 
channel or only a portion of a pre-defined 
palette.

Table 4-3: Editing Operations
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Displaying Images

The iImage tool’s primary design is to visualize image data, though the tool is 
capable of much more once the data is displayed. The iImage tool also allows you to 
manipulate and edit the displays. The first task is to display the image data.

Your options for calling the iImage tool are:

• At the IDL Command Line without arguments or keywords

• At the IDL Command Line with arguments or keywords

Note
Arguments and keywords are accepted at the IDL Command Line for the iImage 
tool, for more information on accepted arguments and keywords, see “IIMAGE” in 
the IDL Reference Guide manual.

• Through the File → New → Visualization → iImage menu option in the IDL 
Development Environment

• Through the File → New → iImage menu option in an iTool

To visualize image data in the iImage tool:

1. Image data can be loaded into the data manager. You may do this using any of 
the previously described methods in “Data Import Methods” in Chapter 2, 
Importing and Exporting Data.

2. Image data of any supported type can also be directly visualized into the 
iImage tool using File → Open or the File Open icon  at the top left of your 
iImage window, and the File Open Dialog appears.

Figure 4-3: The Open Dialog From Which to Choose Data
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3. Select the desired image file from your directory structure. For example here 
we will visualize an examples/data file named meteor_crater.jpg. 
Select the file name and click Open.

Note
The examples/data directory of your IDL 6.0 distribution contains a text file 
named index.txt. This file lists all data files available in the example directory 
and also lists their dimensions and values.

Displaying Multiple Images

You can use the window layout console to provide for multiple image display within 
your window. To add another image to the view of the image you just visualized:

Figure 4-4: A JPEG File Visualized Using the iImage Tool
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1. From the iImage window displaying the meteor crater JPEG image, select 
Window → Layout.

The Window Layout dialog contains these items:

• Dimensions — Allows you to enter specific window dimensions if 
desired, also reflects default window dimensions for selected views.

• Layout — Allows you to pick from a scroll-down list of layout options 
and grids.

• Preview — Gives you a visual preview of the selected layout.

For more information on working with window layouts, see “Window 
Layouts” in Chapter 3, iTool Common Tasks.

2. Select a layout, in this case select Gridded and then enter 2 and 2 for Columns 
and Rows and then OK.

Figure 4-5: The Window Layout Dialog
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3. The window now displays a two by two arrangement of views. You will notice 
the original meteor crater image is shifted to the top-left viewpane. Select and 
highlight the top-right viewpane.

4. Select File → Open or the File Open icon  at the top left of your iImage 
window, and from the File Open Dialog select the examples/data image 
named marsglobe.jpg and click Open.

5. The second image of the planet Mars now appears in the top-right viewpane.

Figure 4-6: Displaying Multiple Images in iImage
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Image Properties

The iImage window is a self-contained image display and manipulation device. You 
can import, export, modify, and manipulate image data. For more information on the 
basic iImage interface and its layout, see Appendix A, “iTools Interface Reference”.

Modifying Properties

By selecting Edit → Properties from the iImage tool, you may modify your image 
properties. You may modify your image’s name, description, background color, 
transparency as well as the projection and stretch properties. For more information on 
editing properties in the iTools, see Appendix D, “Visualization Properties”.
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Adding a Colorbar

You can add a colorbar to your visualized image which will show on a color scale the 
minimum to maximum values of data in the visualization. To add a colorbar, click on 
the image data and then from the iImage window, select Insert → Colorbar. A 
colorbar will be placed in the visualization window. This colorbar can be resized and 
moved around the data space. You can also double-click on the colorbar to invoke the 
Visualization Browser which will allow you to change the values for the colorbar.

Figure 4-7: Image With Inserted Colorbar
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Adding Axes

You can add X and Y axes to your image data by selecting Insert → Axis from the 
iTool window. From here you can select X Axis or Y Axis. By double-clicking on the 
axis itself after it is added you can modify axis properties.

Figure 4-8: Image in iImage with Axes Inserted and Placed
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Modifying Image Brightness

The Data Window on the iImage tool allows you to adjust and manipulate the image 
brightness by changing the RGA or indexed channel values. For indexed color 
images, Channel 0 represents the image data values. For RGBA images, Channel 0 
represents the red values, Channel 1 represents the green values and Channel 2 
represents the blue values. Within each channel is a red bar representing minimum 
values and a green bar representing maximum values. You can click on each bar in 
each channel (which are tabbed) to manipulate these values.
iTool User’s Guide Modifying Image Brightness
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Resampling an Image

Resampling re-imports the selected image data using parameters specified in the 
Resample properties. Resampling parameters include factors for adjusting the X, Y, 
or Z dimensions of the data, as well as the interpolation method to be used.

To resample image data:

1. Select one or more images in the iImage window for resampling.

2. If necessary, use the Operations Browser to set the desired parameters through 
the Resample properties. See “Resample Properties” on page 258 for details.

3. Select Operation → Transform → Resample.
Resampling an Image iTool User’s Guide



Chapter 4: Working with Images 125
Filtering an Image

There are five types of filters available in the iImage.

Smoothing an Image

The smooth filter removes unwanted noise from an image using a weighted average.

To apply the smooth filter to an image:

1. Select the image.

2. Select Operations → Filter → Smooth.

Convolving an Image

To convolve an image:

1. Select the image to be convolved.

2. Select Operations → Filter → Convolution.

For more details on the convolution filter, see “Convolution Filter” on page 71 in 
Chapter 3, iTool Common Tasks.

Applying a Median Filter

The median filter replaces each point with the median (a value in an ordered set of 
values with an equal number of values above and below it) of the one- or two-
dimensional neighborhood of a given width.

To apply the smooth filter to an image:

1. Select the image.

2. Select Operations → Filter → Median.

For more details on the median filter, see “Median Filter” on page 71 in Chapter 3, 
iTool Common Tasks.

Applying a Roberts Filter

The Roberts filter uses the Roberts edge enhancement operator to detect edges within 
the image.

To apply the smooth filter to an image:

1. Select the image.

2. Select Operations → Filter → Roberts.
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Applying a Sobel Filter

The Sobel filter uses the Sobel edge enhancement operator to detect edges within the 
image.

To apply the smooth filter to an image:

1. Select the image.

2. Select Operations → Filter → Sobel.
Filtering an Image iTool User’s Guide
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Morphing an Image

Mathematical morphology is a method of processing digital images on the basis of 
shape. Six morphing options are available for use in iImage: dilate, erode, morph 
open, morph close, morph gradient, and morph tophat. For more information on 
morphing, see “Morphing” on page 72 in Chapter 3, iTool Common Tasks. To morph 
your image, select Operations → Morph → <option>.
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Contouring an Image

You can also insert contouring into your visualized image in iTool by selecting 
Operations → Contour. The following figure shows contouring added to the image 
of a meteor surface.

You can highlight and double-click your contoured image data, invoking the 
Visualization Browser which allows you to edit Contour Level properties and 
Contour Level color table data. For more information on these edit options, see 
“Contour” in Appendix D, Visualization Properties.

Figure 4-9: A Contoured Image in iImage
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Surfacing an Image

You can also insert a surface or your image data into your visualized image in iTool 
by selecting Operations → Surface. This causes the image display to become three-
dimensional. The following figure shows a surface added to the image of a meteor 
surface.

You can highlight and double-click your surfaced image data, invoking the 
Visualization Browser which allows you to edit surface properties. For more 
information on these edit options, see “Surface” in Appendix D, Visualization 
Properties.

Figure 4-10: Image Data Shown as a Surface
iTool User’s Guide Surfacing an Image
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Manipulating the Image Display

The iImage tool allows you many options to manipulate your existing image displays. 
Once you have visualized your image, you may rotate, flip, translate, scale, and zoom 
as well as modify image properties, scroll, and select image ROIs. The following 
options are available for manipulating images.

For more information on tasks which are common to iImage as well as other iTools, 
see Chapter 3, “iTool Common Tasks”.

Rotating an Image

Rotating makes it possible to rotate the image within the visualization by a specified 
number of degrees. To rotate your image, select 
Operations → Transform → Rotate Data. For more information about rotating, see 
“Rotate Data” on page 69 in Chapter 3, iTool Common Tasks.

Scaling an Image and Byte Scaling an Image

It is possible to scale the data within an image by a specified scale factor. To scale 
your image, select Operations → Transform → Scale Data. For more information 
on scaling data, see “Scale Data” on page 70 in Chapter 3, iTool Common Tasks.

To scale the image data to bytes, select Operations → Transform → Byte Scale.

Inverting an Image

You can also invert the data associated with your image, or with each channel of an 
RGB or RGBA image. If the data is byte data, the inversion occurs relative to the 
maximum byte value (255). Otherwise, the inversion occurs relative to the maximum 
data value per channel. To invert your image, select 
Operations → Transform → Invert Image.

Flipping an Image

You can flip your image within the data space either horizontally or vertically. These 
operations flip the actual data associated with the image. To flip your data, select 
Operations → Flip → Flip Horizontal or Operations → Flip → Flip Vertical.
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View Zoom

View Zoom allows you to zoom in or out on a specific area of the image display area. 
To zoom in or out in View Zoom mode click Zoom  on the toolbar. For more 
information on working with View Zoom, see “Common Manipulation Tasks” in 
Chapter 3, “iTool Common Tasks”.

Canvas Zoom

Canvas Zoom allows you to increase or decrease the magnification of the entire 
display canvas (which may contain multiple views, depending on the layout) by a 
specified percentage. Canvas Zoom is available by selecting the pull-down 
percentage list from the top of the tool just under the Help menu. For more 
information on working with Canvas Zoom, see “Common Manipulation Tasks” in 
Chapter 3, “iTool Common Tasks”.

Image ROIs

Regions of interest may be drawn on images in order to highlight specific areas of 
interest. ROI buttons exist on the iImage tool toolbar. Freehand, rectangular and line 
options are available by simply selecting the desired button from the ROI Toolbar on 
the iImage pane.

Region Growing

The iImage region growing function lets you apply a region growing algorithm to the 
currently selected ROI. A new ROI is then created and displayed. To apply region 
growing to your ROI, select Operations →  Region Grow.

Adding Annotations

Annotations can be added to label or describe image visualizations displayed in the 
iImage tool.

Figure 4-11: The Annotation Toolbar Including ROIs
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The following types of annotations can be added to iImage displays:

For more information on creating and using annotations, see “Annotations” in 
Chapter 3, “iTool Common Tasks”.

Line Profiles

You can plot image pixel values along a selected line. To extract a line profile of part 
of your surface visualization in an iPlot window:

1. Click on the Line Profile icon on the iImage window toolbar.

2. use the mouse to position the jagged-edge line profile tool over the place which 
you wish your line profile to begin.

3. Drag to the ending point of your line profile.

4. A new plot window appears showing a plot of the image pixel values that fall 
along that line. 

Once a line profile has been drawn, it will remain until deleted. The line may be 
translated (or its endpoints moved individually) by switching back to the arrows. If it 
is translated or edited, the profile plot will automatically update.

Image 
Annotation 

Type
Description

Text Single lines or multiple lines of text can be added to a 
visualization to provide a label or description.

Line Straight line annotations can be added to a visualization to link 
labels to objects or to identify an object.

Rectangle Rectangular annotations can be added to a visualization to 
identify rectangular areas.

Oval Oval annotations can be added to a visualization to identify 
circular areas.

Polygon Polygon annotations can be added to a visualization to identify 
areas bounded by a multi-sided polygon.

Freehand Freehand annotations can be added to a visualization to 
identify an area.

Table 4-4: Types of Image Annotations
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Panning

To pan an image, select the Pan tool button  on the toolbar and then click on the 
image and drag until the desired dataspace range is visible. Panning causes the 
extents of the current dataspace to be shifted left, right, up, or down.

Selecting the Data Range

Your data range can be manipulated in several ways. First, enter into the Data Range 
tool mode by clicking on the Data Range button on the toolbar. You can then 
manipulate your data range in the following ways:

• Clicking and dragging a selection box within the view. The selected range 
becomes the new data range.

• Panning in one direction or another along a single axis by clicking on the arrow 
manipulators.

• Zooming in or out by clicking on one of the plus or minus symbols. When 
isotropic scaling is in effect (the default for the iImage tool), these symbols 
appear at the axis origin, and will impact both the X and Y ranges 
simultaneously.

Note
Images are clipped to fit within newly selected data ranges.
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iImage Tool Operations

The iImage tool provides the following operations:

Viewing a Histogram

A histogram is a density plot showing a distribution of data values. The widths or 
heights of these bars represent data values. To view a histogram of image data, use the 
iTool’s histogram feature by selecting Operations →  Histogram. For information 
on histogram creation, see “Plotting a Histogram” in Chapter 3, iTool Common Tasks.

Viewing Image Statistics

To view statistics for image data, use the iTool’s statistics feature by selecting 
Operations →  Statistics. For information on viewing statistics, see “Displaying 
Statistics” in Chapter 3, iTool Common Tasks.

Resetting Dataspace Ranges

You can reset the ranges of your dataspace to accommodate all your contained 
visualizations. When you reset your ranges, the following properties of the dataspace 
are reset to a value of True:

• Automatic X range updates

• Automatic Y range updates

• Automatic Z range updates

To reset the ranges of your dataspace, select Operations →  Dataspace →  Reset 
Ranges.

Note
You can turn automatic range updates on and off in the Visualization Browser. For 
more information, see Appendix D, “Visualization Properties”.

Dataspace Pixel Scaling

Pixel scaling resets the data ranges of your dataspace so that one display pixel will 
correspond to a given number of image pixels. The number of image pixels per 
display pixel can be set as a property of this operation via the Operations Browser. 
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The default value is 1. To pixel scale your dataspace, select Operations →  
Dataspace →  Pixel Scale.
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Working with Surfaces 
This chapter describes how to work with surfaces in the iSurface tool.
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Introduction

The IDL iSurface tool provides interactive access to surface data. You can visualize 
surfaces and then modify and manipulate those surfaces in the ways that you need. 
The following sections describe how surfaces can be displayed, modified, and 
manipulated in iSurface.

To use iSurface from the IDL Command Line, type iSurface. An empty iSurface tool 
appears. You can then import surface data using any of several data import methods. 
For more information on importing surface data, see Chapter 2, “Importing and 
Exporting Data”.

Note
For more information on accepted arguments, see “ISURFACE” in the IDL 
Reference Guide manual.

The iSurface tool can be launched in the following ways:

• At the IDL Command Line without arguments or keywords

• At the IDL Command Line with arguments and keywords

• Through the File → New → Visualization → iSurface menu option in the 
IDL Development Environment

• Through the File → New → iSurface menu option in an existing iTool
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Displaying Surfaces

Three-dimensional visualizations of surfaces can be displayed in the iSurface 
window.

To open an iSurface window, do one of the following:

• At the IDL command line, enter ISURFACE.

• From an iTool window, select File → New, and select iSurface.

Surface data can be displayed by specifying data parameters at the IDL command 
line, or by importing a binary or ASCII text file containing surface data.

To import a file containing surface data into the iSurface tool:

1. Select File → Open from the iSurface tool, and locate the file to open. For 
example from your IDL examples/data directory select idemosurf.dat.

2. Double-click the filename, or select the filename and click Open to open the 
surface data file. You will be prompted to enter information regarding your file 
type (for example, ASCII or binary). For more information on entering this 
information and on importing data, see Chapter 2, “Importing and Exporting 
Data”. In this example, enter demosurface for your template name and then 
select New Field and specify demosurface as the Field Name and specify it as 
a two-dimensional 200 by 200 Floating type. 
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3. Then select OK and OK to dismiss and visualize.

Figure 5-1: Surface Data Visualized in iSurface
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Surface Properties

Surfaces have attributes or properties that can be modified to change their 
characteristics. These properties are organized into property sheets for each operation 
and visualization type. For example, the skin of a surface visualization has a gold 
color by default. To change this color, modify the surface color property in the 
surface visualization property sheet.

To display the property sheet for a surface, do one of the following:

• Double-click the surface in the iTool window.

• Select the surface, and select Edit → Properties.

• Display the Visualization Browser, and double-click the entry for the surface.

For more information, see “Property Sheets” on page 83 in Chapter 3, iTool Common 
Tasks.

The Visualization Browser

The Visualization Browser provides a nested list of all visualizations displayed in the 
iSurface window. From the Visualization Browser, you can select visualizations and 
display property sheets for those visualizations.

To display the Visualization Browser:

1. Select Window → Visualization Browser.

2. Do either of the following:

• Click an item to select it in the Visualization Browser.

• Double-click an item in the iTool window to display its property sheet.

For more information, see “The Visualization Browser” on page 85 in Chapter 3, 
iTool Common Tasks and Appendix D, “Visualization Properties”.

The Operations Browser

The Operations Browser provides a nested list of all operations available from the 
iSurface Operations menu. From the Operations Browser, you can display property 
sheets for each of the items in the iSurface Operations menu.

To display the Operations Browser:

1. Select Operations → Operations Browser.
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2. Click an item to display its property sheet.

For more information, see “The Operations Browser” on page 97 in Chapter 3, iTool 
Common Tasks and Appendix C, “Operations Properties”.
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Adding a Colorbar

If you have added vertex coloring or texture to your surface visualization, you can 
add a colorbar which will show on a color scale the minimum to maximum values of 
data in the visualization. To add a colorbar, click on the surface data and then from 
the iSurface window, select Insert → Colorbar. A colorbar will be placed in the 
visualization window. This colorbar can be resized and moved around the data space. 
You can also double-click on the colorbar to invoke the Visualization Browser which 
will allow you to change the values for the colorbar. For more information on the 
colorbar, see “Colorbar” in Appendix D, Visualization Properties.
iTool User’s Guide Adding a Colorbar



144 Chapter 5: Working with Surfaces
Adding a Light

Adding a light to your surface display allows you to highlight various parts of the 
surface. To add a light to your surface display, select Insert → Light. you can click 
on the light bulb which appears and drag it around the display area to manipulate the 
lighting. You can also adjust the lighting settings using the Visualization Browser by 
double-clicking on the light bulb.

Figure 5-2: Inserting Light into a Surface Display
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Adding a Legend

Legends identify the visualizations displayed in the iTool window. Legends can be 
displayed in the iSurface window to identify surfaces and contours on those surfaces.

To insert a legend for a surface or contour:

1. Select specific items to include in the legend, or click in an empty area of the 
iSurface dataspace to deselect and include all dataspace items in the legend.

2. Select Insert → Legend.

To add to a legend:

1. Select the legend by clicking the legend border.

2. Click Add to Legend  in the Manipulator toolbar.

3. Click the item in the iTool window to add to the legend.

For more information, see “Legends” on page 74 in Chapter 3, iTool Common Tasks.
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Adding Axes

By default, surfaces are displayed with X, Y and Z axes. The display of these axes is 
controlled by property sheets for the axes container and for individual axes (see 
“Axes” in Appendix D). Additional X, Y or Z axes can be added to a surface 
visualization to make it easier to identify surface characteristics.

To add an axis to your surface visualization:

1. Select the surface.

2. Select Insert → Axis.

3. Choose from the following options:

• X axis

• Y axis

• Z axis

Use the mouse to position the new axis, and double-click the axis to display the axis 
property sheet. 

For more information on adding axes, see “Additional Axes” on page 81 in Chapter 3, 
iTool Common Tasks.
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Imaging a Surface

You can insert an image of your surface data by using Operations → Image. An 
image visualization of your original surface data is then displayed with your original 
surface visualization.

For example at the IDL command line enter:

1. iSurface, DIST (10)

2. Now select Operations → Image

Figure 5-3: Surface Visualization with Image Added
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Contouring a Surface

Contour lines can be drawn directly on a surface to provide information about the 
levels of the surface, such as elevation. Two types of contours can be applied: 
multiple-level contour operations that apply to the surface in general, and single-level 
contour objects applied at a specific location on the surface.

To add contour lines to a surface:

1. Select the surface in the iTools window. For example, select the 
isurfdemo.dat surface data previously visualized.

2. Select Operations → Contour. Contour lines will be applied to the surface at 
the interval specified in the contour properties page.

3. To adjust the properties of the contour, double-click the contour in the iTool 
window or in the Visualization Browser to display the Contour property sheet. 
For information on the contour properties, see “Contour” in Appendix D, 
Visualization Properties.

Figure 5-4: Surface with Contours Added
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To insert a contour object at a specific location on a surface:

1. Select a surface in the iSurface window.

2. Click the Surface Contour button  in the Manipulator toolbar. 

3. Click the level on the surface at which you would like the contour to appear. 
Contour lines are displayed on the surface at that level.

4. To adjust the properties of the contour object, double-click the contour object 
in the iTool window or in the Visualization Browser to display the Contour 
property sheet. For information on the contour properties, see “Contour” in 
Appendix D, Visualization Properties.
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Resampling a Surface

Once surface data has been imported into the iSurface window, that data can be re-
imported using different import parameters by resampling the data. See “Resample” 
in Chapter 3, iTool Common Tasks for details.

To resample a surface:

1. Select a surface in the iSurface window. For example, select the 
isurfdemo.dat surfaced data.

2. Select Operations → Transform → Resample.

Figure 5-5: Resampled Surface in iSurface
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Filtering a Surface

Two types of filters are available in the iSurface tool: smooth filtering and 
convolution filtering.

Smoothing a Surface

The smooth filter removes unwanted noise from a surface. 

To apply the smooth filter to a surface:

1. Select the surface.

2. Select Operations → Filter → Smooth.

For details on using the smooth filter, see “Smooth Filter” on page 70 in Chapter 3, 
iTool Common Tasks.

Convolving a Surface

To convolve a surface:

1. Select the surface to be convolved.

2. Select Operations → Filter → Convolution. 

For details on using the convolution filter, see “Convolution Filter” on page 71 in 
Chapter 3, iTool Common Tasks.

Median a Surface

The median filter replaces each point with the median (a value in an ordered set of 
values with an equal number of values above and below it) of the one- or two-
dimensional neighborhood of a given width.

to median a surface:

1. Select the surface.

2. Select Operations → Filter → Median.

For details about using the median filter, see “Median Filter” on page 71 in Chapter 3, 
iTool Common Tasks.
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Adding a Texture Map

An image file can be imported into a surface visualization to serve as a texture map: 
an image projected onto the surface skin in place of the default red skin.

To add a texture map to a surface:

1. Select the surface.

2. Select Edit → Parameters to open the Parameter Editor.

3. Click Import File to import the image file to be used as a texture map into the 
Data Manager.

4. Find the image file in the list of files in the Data Manager tree and select either 
a specific image channel to import, or select Image Planes to import all 
channels of the image.

5. Click the Assign Data button  under TEXTURE. The name of the data to 
import appears in the TEXTURE field.

6. Click OK. The Parameter Editor window closes, and the texture map appears 
on the surface.

Figure 5-6: TEXTURE Field in Parameter Editor

Clear data

Assign data
Data name
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Manipulating Surface Displays

The iSurface tool provides options for manipulating surface data. You can rotate as 
well as scale surfaces. These manipulations are described in the following sections.

Rotating a Surface

Rotation tools are provided in the iSurface tool to make it easier to see all aspects of a 
3-D surface visualization. Surfaces can be rotated freely or along an axis with the 
mouse, and they can be rotated in fixed or arbitrary increments from the Operations 
menu.

To rotate a surface freely or along an axis with the mouse:

1. Select the surface in the iSurface window.

2. Click Rotate  on the Manipulator toolbar. The rotation sphere is displayed 
around the surface.

Figure 5-7: Surface with Rotation Sphere Displayed
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• To rotate the surface freely, position the mouse pointer over the surface so 
that it changes to a free rotation pointer . Click and drag to rotate the 
surface in the desired direction.

• To rotate the surface along an axis, position the mouse pointer over an axis 
so that it changes to an axis rotation pointer . Click and drag to rotate 
the surface along the axis in the desired direction.

To rotate a surface in 90° increments left or right from the Operations menu:

1. Select the surface in the iTool window.

2. Select Operations → Rotate → Rotate Left or Operations → Rotate → 
Rotate Right.

To rotate a surface an arbitrary number of degrees from the Operations menu:

1. Select the surface in the iTool window.

2. Select Operations → Rotate → Rotate by Angle.

3. In the Rotate Angle dialog, enter the desired number of degrees to rotate the 
surface.

For more information, see “Rotating” on page 66 in Chapter 3, iTool Common Tasks.

Scaling a Surface

Surfaces can be scaled freely, or scaling can be constrained to one or more 
dimensions.

To scale a surface freely:

1. Select the surface in the iTool window.

2. Position the mouse pointer over a side of the data set bounding box so that it 
changes to an unconstrained scaling pointer . 

3. Click and drag to scale all points of the surface in the desired direction.

To constrain scaling of a surface:

1. Select the surface in the iTool window.
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2. Position the mouse pointer over an axis “whisker” to scale along only one axis, 
or over a corner of the bounding box for multi-axis scaling.

3. Click and drag to scale in the desired direction.

For more information, see “Scaling” on page 60 in Chapter 3, iTool Common Tasks.

Adding Annotations

Annotations can be added to label or describe surface visualizations displayed in the 
iSurface tool.

The following types of annotations can be added to iSurface displays:

Figure 5-8: Constrained Single-Axis (left) and Multi-Axis (right) Scaling

Plot 
Annotation 

Type
Description

Text Single lines or multiple lines of text can be added to a 
visualization to provide a label or description.

Line Straight line annotations can be added to a visualization to link 
labels to objects or to identify an object.

Table 5-1: Types of Surface Annotations
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For more information on creating and using annotations, see “Annotations” in 
Chapter 3, “iTool Common Tasks”.

View Zoom

View Zoom allows you to zoom in or out on a specific area of the surface display 
area. To zoom in or out in View Zoom mode click Zoom  on the toolbar. For more 
information on working with View Zoom, see “Common Manipulation Tasks” in 
Chapter 3, “iTool Common Tasks”.

Canvas Zoom

Canvas Zoom allows you to increase or decrease the magnification of the entire 
display canvas (which may contain multiple views, depending on the layout) by a 
specified percentage. Canvas Zoom is available by selecting the pull-down 
percentage list from the top of the tool just under the Help menu. For more 
information on working with Canvas Zoom, see “Common Manipulation Tasks” in 
Chapter 3, “iTool Common Tasks”.

Extracting a Line Profile

To extract a line profile of part of your surface visualization in an iPlot window:

1. Click on the Line Profile icon on the iSurface window toolbar.

Rectangle Rectangular annotations can be added to a visualization to 
identify rectangular areas.

Oval Oval annotations can be added to a visualization to identify 
elliptical areas.

Polygon Polygon annotations can be added to a visualization to identify 
areas bounded by a polygon.

Freehand Freehand annotations can be added to a visualization to 
identify an area.

Plot 
Annotation 

Type
Description

Table 5-1: Types of Surface Annotations (Continued) 
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2. use the mouse to position the jagged-edge line profile tool over the place which 
you wish your line profile to begin.

3. Drag to the ending point of your line profile.

4. The profile plot appears in an iPlot window.

Once a line profile has been drawn, it will remain until deleted. The line may be 
translated (or its endpoints moved individually) by switching back to the arrows. If it 
is translated or edited, the profile plot will automatically update.
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iSurface Tool Operations

The iSurface tool provides the following operations:

Viewing a Histogram Plot

To display a histogram plot of your surface:

1. Select the surface.

2. Select Operations → Histogram. 

For more information, see “Plotting a Histogram” on page 104 in Chapter 3, iTool 
Common Tasks.

Viewing Statistics

To display the Statistics dialog:

1. Select an object or a group of objects in the iTools window.

2. Select Operations → Statistics. The Statistics window displays the statistics 
for the selected object(s).

For more information, see “Displaying Statistics” on page 105 in Chapter 3, iTool 
Common Tasks.
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Working with Contours 
This chapter describes how to work with contours in the iContour tool.
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Introduction

The IDL iContour tool allows you interactive access to contour data. You may 
visualize contours and then modify and manipulate those contours in the ways that 
you need.

The IDL iContour tool displays your data as contours and allows you great flexibility 
in manipulating and visualizing these contours. The iContour tool can be used for 
irregular or regular grid data. Irregularly-grid data arranged as three fields (three one-
dimensional vectors) are gridded by a Gridding Wizard if this data is imported into 
the iTool. Regular grid data arranged as a two-dimensional array is directly imported.

To use iContour from the IDL Command Line, type iContour. An empty iContour 
tool appears. You can then import contour data using any of several data import 
methods. For more information on importing contour data, see Chapter 2, “Importing 
and Exporting Data”.

Note
For more information on accepted arguments and keywords, see “ICONTOUR” in 
the IDL Reference Guide manual.

The iContour tool can be launched in the following ways:

• At the IDL Command Line without arguments or keywords

• At the IDL Command Line with arguments and keywords

• Through the File → New → Visualization → iContour menu option in the 
IDL Development Environment

• Through the File → New → iContour menu option in an existing iTool
Introduction iTool User’s Guide
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Displaying Contours

The iContour tool’s primary purpose is to display contours, though the tool is capable 
of much more once the data is displayed. The iContour tool can display regular-grid 
data or irregular-grid data. Gridding is the creation of uniformly-spaced planar data 
from data points. These points may initially be irregular.

Displaying Regular-grid Data

Regular-grid data points are presented by two-dimensional arrays. The following 
example shows one way of importing and displaying this type of data into the 
iContour tool. The 248 by 248 two-dimensional array contained within the 
convec.dat binary file in the examples/data directory is imported into IDL with 
the READ_BINARY function. The iContour tool then displays this data as contours.

At the IDL Command Line, enter:

file = FILEPATH('convec.dat', SUBDIRECTORY = ['examples', 'data'])
data = READ_BINARY(file, DATA_DIMS = [248, 248])
iContour, data

Figure 6-1: Earth Convection Contours in the iContour Tool
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Note
The examples/data directory of your IDL 6.0 distribution contains a text file 
named index.txt. This file lists all data files available in the example directory 
and also lists their dimensions and values.

Displaying Irregular-grid Data

Irregular-grid data points are presented by three one-dimensional vectors, usually 
known as fields. The following example shows one way of importing and displaying 
this type of data into the iContour tool. The three fields contained within the 
irreg_grid1.txt ASCII file in the examples/data directory is imported into 
IDL with the File → Open option in the iContour tool. This option uses the ASCII 
Template wizard to import the data, which is then gridded into contour data with the 
Gridding Wizard. The iContour tool then displays this data as contours.

1. At the IDL Command Line, enter:

ICONTOUR

2. Select File → Open from the pulldown menus of the empty iContour tool. The 
Open dialog will appear.

3. Use the Open dialog to find and select the irreg_grid1.txt file in the 
example/data directory. The ASCII Template wizard will appear.

The irreg_grid1 file contains three columns of data points. These columns 
represent the x-locations, y-locations, and the elevation (respectively) of this 
data. These columns are specified as three fields (vectors) of data with the 
ASCII Template wizard.
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4. Click Next on the first and second step of the wizard, then click Finish on the 
third (last) step of the wizard. The IDL iTools Create Visualization dialog 
will appear.

The IDL iTools Create Visualization dialog contains the following choices:

• Launch the gridding wizard

• Select a visualization and specify parameters

• Do not create a visualization

Figure 6-2: The iTools Create Visualization Dialog
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5. Select the Launch the gridding wizard radio button, then click OK. The IDL 
Gridding Wizard Step 1 of 3 dialog will appear.

The Gridding Wizard allows you to specify the method of gridding while 
showing you the possible results for that method. The IDL Gridding Wizard 
Step 1 of 3 dialog contains the following items:

• Number of points entered

• X Coordinates — X coordinate range

• Y Coordinates — Y coordinate range

• Data values

• Spherical data checkbox — Check to make data spherical

• Coordinate diagram — Shows coordinates of grid data

• Show points checkbox — Select to show all points (default = checked)

• Help — Obtain help on this dialog

• Back — Return to previous step

• Next — Proceed to Step 2 of 3

Figure 6-3: The IDL Gridding Wizard Step 1 of 3
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• Cancel — Dismiss the Gridding Wizard

6. In the Gridding Wizard Step 1, click Next to accept the interpolation of data 
values and locations. The IDL Gridding Wizard Step 2 of 3 dialog will 
appear.

The IDL Gridding Wizard Step 2 of 3 dialog contains the following items:

• X Coordinates — modify dimension, start or end

• Y Coordinates — modify dimension, start or end

• Coordinate diagram — Shows coordinates of grid data

• Show points checkbox — Select to show all points (default = checked)

• Help — Obtain help on this dialog

• Back — Return to previous step

• Next — Proceed to Step 3 of 3

• Cancel — Dismiss the Gridding Wizard

Figure 6-4: The IDL Gridding Wizard Step 2 of 3
iTool User’s Guide Displaying Contours



166 Chapter 6: Working with Contours
7. At Step 2, click Next to accept the dimensions, start and spacing. The IDL 
Gridding Wizard Step 3 of 3 dialog will appear.

The IDL Gridding Wizard Step 3 of 3 dialog contains the following items:

• Choose gridding method — Choose from pull-down list of methods

• Preview — Click to preview selected method and data

• Auto preview — Checkbox to turn auto preview on (default = off)

• Statistics tab — Shows data statistics

• Options tab — Set options for missing values, smoothing, weighting, and 
anistropy between axes

• Search tab — Set options for using search ellipse

• Coordinate diagram — Shows coordinates of grid data

• Show points checkbox — Select to show all points (default = checked)

• Help — Obtain help on this dialog

• Back — Return to previous step

• Finish — Dismiss the Gridding Wizard with data gridded

Figure 6-5: The IDL Gridding Wizard Step 3 of 3
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• Cancel — Dismiss the Gridding Wizard

8. At Step 3, select Inverse Distance as the gridding method and click Finish to 
display the surface.

9. The resulting contours are displayed in the iContour tool.

Figure 6-6: Irregular-grid Elevation Contours in the iContour Tool
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Contour Properties

The iContour window is a self-contained contour display and manipulation device. 
You can import and export contour data, and modify and manipulate contours. For 
more information on the basic iContour interface and its layout, see Appendix A, 
“iTools Interface Reference”.

With the contour selected, the Edit → Properties... option allows access to the 
contour property sheet. You can change many contour properties through this sheet 
including contour labels, colors, and fill values.

The following examples show how to modify some contour properties. These 
examples are performed on the contours imported by using the following steps:

1. At the IDL Command Line, enter:

ICONTOUR

2. Select File → Open from the pulldown menus of the empty iContour tool. The 
Open dialog will appear.

Figure 6-7: Contour Property Sheet
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3. Use the Open dialog to find and select the convec.dat file in the 
example/data directory. The Binary Template wizard will appear.

4. In the Binary Template dialog, click New Field, and enter the following 
information in the New Field dialog:

• Field name: data (or a name of your choosing)

• Type: byte

• Number of dimensions: 2

• 1st dimension Size: 248

• 2nd dimension Size: 248

5. Click OK to close the New Field dialog and the Binary Template dialog, and 
the contours are displayed in the tool.

Figure 6-8: Earth Convection Contours in the iContour Tool
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Labelling Contours

Each contour level line has its own properties. You can access these properties 
through Contour level properties in the contour property sheet by clicking Contour 
level properties, clicking on the arrow button, and then clicking Edit... The Contour 
Levels property sheet will appear.

Figure 6-9: Contour Levels Property Sheet
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The first column of the Contour Levels property sheet contains the property values 
for all the levels. In this column, change the Label setting from None to Value. The 
value of each contour line appears as labels in the iContour display.

Figure 6-10: Labelled Contour Levels
iTool User’s Guide Labelling Contours
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Changing the Contour Colors

The columns after the first one are for each individual contour level. In each level 
column, change the Color setting from black to a different color making sure to use a 
different color for each level. When a level color is changed in the property sheet, that 
level is updated in the iContour display.

The resulting display contains a different color contour for each level.

After changing the colors of each level, click OK in the Contour Levels property 
sheet. The Contour Labels property sheet will go away.

Figure 6-11: Color Contour Levels
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Filling Contours

The Fill contours setting in the original contour property sheet controls whether the 
contour levels are filled or not. Change the Fill contours setting to True.

Note
You must also change the Use palette color setting to True as well before colors 
can be used. After that, you can choose or set your own color scheme from the 
Levels Color Table → Edit color table function.
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The contour colors are now more distinctive.

Even more detail can be added by increasing the number of levels in the contour 
display. Change the Number of levels from 6 to 20.

Figure 6-12: Filled Contour Levels Using the Predefined Blue Waves Scheme
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The color set for each of the original seven levels is repeated every set of seven within 
the 20 new levels.

Figure 6-13: 20 Filled Contour Levels Reset at 20 Levels
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Adding a Colorbar

You can add a colorbar to your visualized contour which will show on a color scale 
the minimum to maximum values of data in the visualization. To add a colorbar, click 
on the contour data and then from the iContour window, select Insert → Colorbar. 
A colorbar will be placed in the visualization window.

Note
Be sure that the Use palette color setting in the Visualization Browser is True so 
that colors can be used. After that, you can choose or set your own color scheme 
from the Levels Color Table → Edit color table function.

This colorbar can be resized and moved around the data space. You can also double-
click on the colorbar to invoke the Visualization Browser which will allow you to 
change the values for the colorbar and edit color tables. For more information on the 
colorbar, see “Colorbar” in Appendix D, Visualization Properties.
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Adding a Legend

You can add a legend to your contour which shows the levels of the contour in their 
increments. To add a legend, select Insert → Legend from the iContour tool window.

Once you have placed a legend on your contour can edit the legend settings such as 
the title and level increments as well as the color options on the legend. Double-
clicking on the legend itself will show you the Visualization Browser. For more 
information on the options available, see “Legend Properties” in Appendix D, 
Visualization Properties.

Figure 6-14: A Contour With Legend Added Showing Levels
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Adding Axes

You can also add axes to your contour as visual aids for reading contour data. 
Although axes are added to two-and three dimensional contour data there are 
advantages to adding additional axes. For example in the figure which follows, 
additional axes have been added in order to create a box-style contour showing the 
tick marks and increments on all sides of the image. You can add X, Y and Z axes 
depending on your contour and needs. To insert axes, select Insert → Axis and then 
select X Axis, Y Axis, or Z Axis or from the Visualization Browser, select the Axes 
group and then set Style to Box Axes.

Once you have placed an axis on your contour you can edit the axis settings by 
changing the title and increments as well as the color options on the axis. Double-
clicking on the axis itself will show you the Visualization Browser.

Figure 6-15: A Contour With Axes Added and Altered in Box-Style
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Filtering a Contour

The iContour tool allows you to modify your contour data in the following ways:

Contour Smoothing

Within the iContour tool, contours can also be smoothed to refine edges or 
compensate for random noise in the data. To smooth your data from the iContour 
window, select Operations →  Filter →  Smooth

Note
The previous figure shows brain MRI data taken from the IDL examples\data 
directory in a file named mr_brian.dcm.

Note
The window’s default size is three, however this can be changed via the operations 
browser. For more information on smoothing properties, see “Smooth Properties” in 
Appendix C, “Operations Properties”.

Figure 6-16:  Brain MRI Data (left) and Smoothed Data (right)
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Contour Convolution

You can also use iContour convolution feature by selecting Operations →  Filter →  
Convolution. By selecting this, the Convolution Editor appears:

Figure 6-17: Default Convolution Editor Dialog
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From this dialog, you can select the desired convolution type from a drop-down list or 
you may manipulate the columns and rows and scale factor and details manually.

For more information on convolution properties, see “Convolution Properties” in 
Appendix C, “Operations Properties”.

Figure 6-18: Brain MRI Data (left) and Convolved (right) Using the Default 
Gaussian Convolution
iTool User’s Guide Filtering a Contour
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Manipulating the Contour Display

The iContour tool allows you many options to manipulate your existing plot displays. 
Once you have visualized your contours, you may rotate, flip, translate, scale, and 
zoom as well as modify contour properties, scroll, and select contour ROIs. The 
following options are available for manipulating contours.

Translating

Translation moves an object or group of objects in a specific direction. When an 
object is selected, a bounding box appears around the object. For information on 
translating objects, see “Common Manipulation Tasks” in Chapter 3, “iTool Common 
Tasks”.

View Zoom

View Zoom allows you to zoom in or out on a specific area of the contour display 
area. To zoom in or out in View Zoom mode click Zoom  on the toolbar. For more 
information on working with View Zoom, see “Common Manipulation Tasks” in 
Chapter 3, “iTool Common Tasks”.

Flipping a Contour

You can flip your contour within the data space either horizontally or vertically. 
These operations flip the actual data associated with the contour. To flip your data, 
select Operations → Flip → Flip Horizontal or Operations → Flip → Flip 
Vertical.

Canvas Zoom

Canvas Zoom allows you to increase or decrease the magnification of the entire 
display canvas (which may contain multiple views, depending on the layout) by a 
specified percentage. Canvas Zoom is available by selecting the pull-down 
percentage list from the top of the tool just under the Help menu. For more 
information on working with Canvas Zoom, see “Common Manipulation Tasks” in 
Chapter 3, “iTool Common Tasks”.
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Scaling a Contour Display

The iContour tool allows you to scale your contour data by selecting 
Operations → Transform → Scale Data. You can scale your data by a factor which 
you provide in the Scale Factor dialog.

Once you have set the scale factor, select OK and the scaling takes place.

You may zoom in and out from your plot using either the Zoom In and Zoom Out 
buttons on the iPlot toolbar, or by selecting Window → Zoom In or 
Window → Zoom Out. 

Adding Annotations

The following types of annotations can be added to iContour displays:

Figure 6-19: Setting the Contour Scale Factor

Plot 
Annotation 

Type
Description

Text Single lines or multiple lines of text can be added to a 
visualization to provide a label or description.

Line Straight line annotations can be added to a visualization to link 
labels to objects or to identify an object.

Rectangle Rectangular annotations can be added to a visualization to 
identify rectangular areas.

Oval Oval annotations can be added to a visualization to identify 
oval areas.

Table 6-1: Types of Contour Annotations
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For more information on creating and using annotations, see “Annotations” in 
Chapter 3, “iTool Common Tasks”.

Polygon Polygon annotations can be added to a visualization to identify 
areas bounded by a polygon.

Freehand Freehand annotations can be added to a visualization to 
identify an area.

Plot 
Annotation 

Type
Description

Table 6-1: Types of Contour Annotations
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iContour Tool Operations

Viewing a Histogram

A density histogram is a density plot showing the distribution of data values. The X-
axis represents data values and the Y-axis represents density or frequency. Another 
type of histogram is a style plot histogram. To view a density histogram of contour 
data, use the iTool’s histogram feature by selecting Operations →  Histogram. For 
information on histogram creation, see “Plotting a Histogram” in Chapter 3, iTool 
Common Tasks.

Viewing Statistics

To view statistics for contour data, use the iTool’s statistics feature by selecting 
Operations →  Statistics. For information on viewing statistics, see “Displaying 
Statistics” in Chapter 3, iTool Common Tasks.
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Working with Plots
This chapter describes plotting tasks and the iPlot tool.
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Introduction

The IDL iPlot tool displays your data in plot form. The iPlot tool then allows you 
great flexibility in manipulating and visualizing plot data. iPlot can be used for any 
type of two- or three-dimensional plot, including scatter plots, line plots, polar plots, 
and histogram plots. To use iPlot, from the IDL Command Line, type iPlot. An 
empty iPlot tool appears. You can then import plot data using any of several data 
import methods. For more information importing plot data see Chapter 2, “Importing 
and Exporting Data”.

Note
For more information on accepted arguments, see “IPLOT” in the IDL Reference 
Guide manual.

The iPlot tool can be launched in many different ways:

• At the IDL Command Line without arguments or keywords

• At the IDL Command Line with arguments or keywords

• Through the File → New → Visualization → iPlot menu option in the IDL 
Development Environment

• Through the File → New → iPlot menu option in an iTool
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Displaying Two-Dimensional Plots

The iPlot tool’s primary design is to display plot data, though the tool is capable of 
much more once the data is plotted. The iPlot tool can display multiple types of plots 
and allows you to manipulate and edit the displays. 

The first task is to display plot data. Here is a simple example of how to display a 
plot.

At the IDL command line, enter:

iPlot, RANDOMU(seed, 20)

Note
The examples/data directory of your IDL 6.0 distribution contains a text file 
named index.txt. This file lists all data files available in the example directory 
and also lists their dimensions and values.

Figure 7-1: A Simple 2D Plot Using the iPlot Tool
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Displaying Three-Dimensional Plots

iPlot can display multiple types of plots and allows you to manipulate and edit the 
displays. You can also display three-dimensional plots. Here is a simple example of 
how to display a 3D plot. 

At the IDL command line, enter:

iPlot, FINDGEN(20), FINDGEN(20), RANDOMU(seed, 20)

Figure 7-2: A Simple 3D Plot Using the iPlot Tool
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Displaying Polar Plots

iPlot can display multiple types of plots and allows you to manipulate and edit the 
displays. You can also display polar plots. Here is a simple example of how to display 
a polar plot.

At the IDL command line, enter:

iPlot, FINDGEN(20), FINDGEN(20), /POLAR

Note
The examples/data directory of your IDL 6.0 distribution contains a text file 
named index.txt. This file lists all data files available in the example directory 
and also lists their dimensions and values.

Figure 7-3: A Simple Polar Plot Using the iPlot Tool
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Overplotting

Once you have plotted data, you may overplot new plot data in the original iPlot 
window. Overplotting is the process of plotting new data over the top of original data 
or datasets for the purpose of analyzing or comparing more than one dataset at a time.

For example, in order to overplot cosine data onto a plot of sine wave data follow 
these steps:

1. Create a variable named “theory” to contain sine wave data to be plotted:

theory = SIN(2.0*FINDGEN(200)*!PI/25.0)*EXP(-0.02*FINDGEN(200))

2. Plot theory using iPlot:

iPlot, theory 

Figure 7-4: Sin Wave Data Plotted
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3. Create a variable named “newtheory” which stores cosine data to be used for 
overplotting:

newtheory = COS(2.0*FINDGEN(200)*!PI/25.0)*EXP(-0.02*FINDGEN(200))

4. Now overplot the new cosine data onto your original plot:

iPlot, newtheory, /OVERPLOT

Figure 7-5: Cosine Data Overplotted on Sine Data
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Plot Properties

The iPlot window is a self-contained plot display and manipulation device. You can 
import and export plot data, and modify and manipulate plot data. For more 
information on the basic iPlot interface and its layout, see Appendix A, “iTools 
Interface Reference”.

Modifying Properties

By selecting Edit → Properties from the iPlot tool, you may modify your plot 
properties. You may modify your plot’s name, description, fill type and fill color, 
opacity as well as the show/hide properties and the line color, style and thickness. For 
more information on editing properties in the iTools, see Appendix D, “Visualization 
Properties”.
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Adding Legends

A legend is text that describes aspects of a visualization. For example, a legend might 
show the plot line or plot points. If multiple plots are present the legend may show 
which colors and linestyles represent which plots. An inserted legend will include 
items selected at the time of insertion. If no specific dataset is selected, the legend 
will include all datasets in the plot. 

To add a legend to your plot, select Insert → Legend. 

You can add new information to your existing legend or you can also use the 
Insert → Legend option can be used over again to add more legends. For example, 
in the theory plot with newtheory overplot displayed in the previous section, you 
can add a legend for each plot:

1. Select the newtheory plot by clicking once on the line. 

Figure 7-6: A Simple Sine Plot with Default Legend Added
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2. Select Insert → Legend. A new legend appears on top of the previous legend 
(this new legend can be selected and repositioned).

You can double-click on the legend to bring up a property sheet to alter its settings. 
Through the property sheet, you can also access the Visualization Browser, which can 
be used to navigate through other legends and objects within the visualization. In the 
previous example the names of the legends have been altered to reflect the data 
names. For more information editing settings in the Visualization Browsers, see “The 
Visualization Browser” in Appendix D, “Visualization Properties”.

Figure 7-7: Plot and Overplot in iPlot with Legend Added for Each
Adding Legends iTool User’s Guide



Chapter 7: Working with Plots 197
Adding a Colorbar

You can add a colorbar to your visualized plot which will show on a color scale the 
minimum to maximum values of data in the visualization. To add a colorbar, first 
double-click on the plot to bring up the Visualization Browser. Then set the vertex 
coloring to True. Now you can click on the plot data and then from the iPlot window, 
select Insert → Colorbar. A colorbar will be placed in the visualization window. 
This colorbar can be resized and moved around the data space. You can also double-
click on the colorbar to invoke the Visualization Browser which will allow you to 
change the values for the colorbar. For more information on the colorbar, see 
“Colorbar” in Appendix D, Visualization Properties.
iTool User’s Guide Adding a Colorbar



198 Chapter 7: Working with Plots
Adding Error Bars

Error bars are used to show uncertainty in data values. These uncertainties may be 
caused by measurement errors or instrument noise, and are usually specified in terms 
of standard deviations away from the data value.

For example, to create a 2D plot with asymmetric error bars on the X and Y axes, 
follow these steps:

1. To set asymmetric error bars for X and Y with X bars initially hidden, enter:

err = FLTARR(2,10)
err[0, *] = FINDGEN(10)/10.
err[1, *] = FLTARR(10) + 0.5

2. Plot the error bars in the iPlot window:

iPlot, FINDGEN(10), COLOR = [255, 0, 255],$
ERRORBAR_COLOR = [255, 0, 0], $
ERRORBAR_CAPSIZE = 0.25, X_ERRORBARS = 0, $
XERROR = err, YERROR = err

Figure 7-8: 2D Plot with Error Bars
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Also, to create a 3D plot with asymmetric error bars on the X, Y and Z axes:

1. To set asymmetric error bars for a 3D plot, enter:

nVerts = 30
x = FINDGEN(nVerts)/10.
y = (SIN(x*2) + 1.)*25.
z = x
err = FLTARR(2, nVerts)
err[0, *] = RANDOMU(seed, nVerts)
err[1, *] = RANDOMU(seed, nVerts)

2. Plot the error bars in the iPlot window with 3D plot and name the plot “3D Plot 
with Error Bars”:

iPlot, x, y, z, COLOR = [0, 0, 255], $
THICK = 2, ERRORBAR_COLOR = [255, 0, 0], $
XERROR = err/2., YERROR = err*5., ZERROR = err, $
NAME = '3D Plot with Error Bars'

For more information on error bar properties, see “Plot” in Appendix D, 
“Visualization Properties”.

Figure 7-9: 3D Plot with Error Bars and Name
iTool User’s Guide Adding Error Bars
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Curve Fitting

Curve fitting is the process of finding various ways to fit a curve to a series of data 
points which best represents all points. More specifically, since data, such as plot 
data, is often given as values along a continuum, you may wish at times to give 
estimates at points between values. Curve fitting allows you to find intermediate 
estimates for these values.

For example, to fit a curve to the damped sine plot we have already created:

1. Select Operations →  Filter →  Curve Fitting.

2. The Curve Fitting dialog appears. 

The Curve Fitting dialog contains the following fields:

• Curve fitting model - used to select the type of model used to try to fit a 
curve to the data.

• Initial parameters and results - used to specify the initial values of the 
parameters of the model used to fit a curve to the data and to display the 
resulting values of these parameters for the model selected in the Curve 
fitting model drop-down list. The initial values are specified in the text 
boxes on the left side and the results are shown in the labels on the right 
side.

• Equation of the model - shows the equation of the model used to try to fit a 
curve to the data. This model is selected from the Curve fitting model.

Figure 7-10: The Curve Fit Dialog with Curve Fitting Model Choices
Curve Fitting iTool User’s Guide
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• Display of resulting fit - graphically shows how well the model specified 
by the Curve fitting model drop-down menu and the Initial parameters 
text boxes fits the data.

• Chi-square value - shows the resulting chi-square value, which is a 
measure of goodness-of-fit.

You can use this dialog to determine what type of model would best fit your 
data by changing the Curve fitting model drop-down menu setting and the 
Initial parameters text boxes values.

3. Select the desired curve fit from the Curve fitting model drop-down list. You 
can also set initial parameters if desired.

The new curve created by the curve fitting operation is added to the Data 
Manager.

Figure 7-11: A Quintic Curve Fit to a Sin Wave Plot
iTool User’s Guide Curve Fitting
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Filtering a Plot

The iPlot tool allows you to modify your plot data in the following ways:

Plot Smoothing

Within the iPlot tool, plots can also be smoothed to soften edges or compensate for 
random noise in the plot. To smooth your plot from the iPlot window, select 
Operations →  Filter →  Smooth

Note
The example shown in the previous figures is taken from example data available in 
the examples\data directory of your IDL installation. The data is contained in a 
file called damp_sn.dat.

Note
The window’s default size is three, however this can be changed via the operations 
browser. For more information on smoothing properties, see “Smooth Properties” in 
Appendix C, “Operations Properties”.

Figure 7-12:  Damped Sine Plotted Data (left) and Smoothed Data (right)
Filtering a Plot iTool User’s Guide
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Plot Convolution

You can also use iPlots convolution feature by selecting Operations →  Filter →  
Convolution. By selecting this, the Convolution Editor appears:

Figure 7-13: Default Convolution Editor Dialog
iTool User’s Guide Filtering a Plot
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From this dialog, you can select the desired convolution type from a drop-down list or 
you can manually manipulate the columns, rows, scale factor, and details.

For more information on convolution properties, see “Convolution Properties” 
in Appendix C, “Operations Properties”.

Plot Median

The median filter replaces each point with the median (a value in an ordered set of 
values with an equal number of values above and below it) of the one- or two-
dimensional neighborhood of a given width.

To apply the smooth filter to an image:

1. Select the plot.

2. Select Operations → Filter → Median.

For more details on the median filter, see “Median Filter” on page 71 in Chapter 3, 
iTool Common Tasks.

Figure 7-14: Sine Wave Plotted (left) and Convolved (right) Using Line Vertical 
Convolution
Filtering a Plot iTool User’s Guide
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Manipulating the Plot Display

The iPlot tool allows you many options to manipulate your existing plot displays. 
Once you have visualized your plot data, you may rotate, flip, translate, scale, and 
zoom as well as modify plot properties, scroll, and select plot ROIs. The following 
options are available for manipulating plots.

Translating

Translation moves an object or group of objects in a specific direction. When an 
object is selected, a bounding box appears around the object. For information on 
translating objects, see “Common Manipulation Tasks” in Chapter 3, “iTool Common 
Tasks”.

Adding Annotations

The following types of annotations can be added to iPlot displays:

Plot 
Annotation 

Type
Description

Text Single lines or multiple lines of text can be added to a 
visualization to provide a label or description.

Line Straight line annotations can be added to a visualization to link 
labels to objects or to identify an object.

Rectangle Rectangular annotations can be added to a visualization to 
identify rectangular areas.

Oval Oval annotations can be added to a visualization to identify 
elliptical areas.

Polygon Polygon annotations can be added to a visualization to identify 
areas bounded by a multi-sided polygon.

Freehand Freehand annotations can be added to a visualization to 
identify an area.

Table 7-1: Types of Plot Annotations
iTool User’s Guide Manipulating the Plot Display



206 Chapter 7: Working with Plots
For more information on creating and using annotations, see “Annotations” in 
Chapter 3, “iTool Common Tasks”.

View Zoom

View Zoom allows you to zoom in or out on a specific area of the plot display area. 
To zoom in or out in View Zoom mode click Zoom  on the toolbar. For more 
information on working with View Zoom, see “Common Manipulation Tasks” in 
Chapter 3, “iTool Common Tasks”.

Canvas Zoom

Canvas Zoom allows you to increase or decrease the magnification of the entire 
display canvas (which may contain multiple views, depending on the layout) by a 
specified percentage. Canvas Zoom is available by selecting the pull-down 
percentage list from the top of the tool just under the Help menu. For more 
information on working with Canvas Zoom, see “Common Manipulation Tasks” in 
Chapter 3, “iTool Common Tasks”.

Selecting the Data Range

In a two-dimensional plot, your data range can be manipulated in several ways. First, 
enter into the Data Range tool mode by clicking on the Data Range button on the 
toolbar. You can then manipulate your data range in the following ways:

• Clicking and dragging a selection box within the view. The selected range 
becomes the new data range.

• Panning in one direction or another along a single axis by clicking on the arrow 
manipulators.

• Zooming in or out by clicking on one of the plus or minus symbols. When 
isotropic scaling is in effect (the default for the iPlot tool), these symbols 
appear at the axis origin, and will impact both the X and Y ranges 
simultaneously.

Note
Plots are clipped to fit within newly selected data ranges.
Manipulating the Plot Display iTool User’s Guide
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iPlot Tool Operations

The iPlot tool allows you many operations for your existing plot displays. Once you 
have visualized your plot data, you can scale and filter as well as creating a histogram 
or viewing statistics for your plot. The following operations are available for plots.

Scaling a Plot Display

iPlot allows you to scale your plotted data by selecting Operations → Transform 
→ Scale Data. You can scale your data by a factor which you provide in the Scale 
Factor dialog.

Once you have set the scale factor, select OK and the scaling takes place.

Figure 7-15: Setting the Plot Scale Factor

Figure 7-16: Sine Wave Plot with Scale Factor of 2 (left) and Adjusted to Scale 
Factor of 10 (right)
iTool User’s Guide iPlot Tool Operations
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Viewing a Histogram

A density histogram is a plot consisting of either horizontal or vertical bars. The 
widths or heights of these bars represent data values. Another type of histogram is a 
style plot histogram which plots different data sets side-by-side using differently 
styled points or bars to represent the data. To view a density histogram of plot data, 
use the iTool’s histogram feature by selecting Operations →  Histogram. For 
information on histogram creation, see “Plotting a Histogram” in Chapter 3, iTool 
Common Tasks.

Viewing Statistics

To view statistics for plot data, use the iTool’s statistics feature by selecting 
Operations →  Statistics. For information on viewing statistics, see “Displaying 
Statistics” in Chapter 3, iTool Common Tasks.
iPlot Tool Operations iTool User’s Guide
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Working with Volumes
This chapter describes how to use the iVolume tool.
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Introduction

The IDL iVolume tool displays your data in volume form. The iVolume tool then 
allows you great flexibility in manipulating and visualizing volume data. To use 
iVolume, from the IDL Command Line, type iVolume. An empty iVolume tool 
appears. You can then import volume data using any of several data import methods. 
For more information importing volume data see Chapter 2, “Importing and 
Exporting Data”.

Note
For more information on accepted arguments, see “IVOLUME” in the IDL 
Reference Guide manual.

The iVolume tool can be launch in many different ways:

• At the IDL Command Line without arguments or keywords

• At the IDL Command Line with arguments or keywords

• Through the File → New → Visualization → iVolume menu option in the 
IDL Development Environment

• Through the File → New → iVolume menu option in an iTool

Note
The iVolume tool continues to be updated in IDL 6.0. This chapter will be written to 
accommodate additional iVolume functionality and this chapter reflects only 
current configuration.
Introduction iTool User’s Guide
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Displaying Volumes

The iVolume tool’s primary purpose is to visualize volume data, though the tool is 
capable of much more once the data is displayed. The iVolume tool also allows you to 
manipulate and edit the displays. The first task is to display the volume data.

Before displaying, volume data must be loaded into the tool. Here is a simple 
example of one way to load in some data.

At the IDL command line, enter:

file = FILEPATH('head.dat', $
SUBDIRECTORY = ['examples', 'data'])

data = READ_BINARY(file, DATA_DIMS = [80, 100, 57])
IVOLUME, data

Note
The examples/data directory of your IDL 6.0 distribution contains a text file 
named index.txt. This file lists all data files available in the example directory 
and also lists their dimensions and values.

Multi-Channel Volumes

The data in the previous example is a single-channel volume which is volume data 
specified in a single parameter. This is the simplest and most common way to display 
volume data. The iVolume tool also supports two-channel and four-channel volume 
rendering. Two-channel rendering allows you to combine or blend two volume arrays 
together. Four-channel rendering is useful when your volume data is composed of a 
volume array for each of the red, green, blue, and alpha display channels. Note that 
the dimensions of all the volume arrays used in multi-channel volume rendering must 
be the same.

In the following example, the second volume array of a two-channel volume is used 
as a mask to cut out a portion of the volume to create a hole. With the head.dat data 
already loaded from the examples/data directory, a mask volume is created and 
displays the result:

mask = BYTARR(80, 100, 57)
mask[*] = 255
mask[30:50, *, 20:30] = 0
IVOLUME, data, mask

A rectangular hole through the middle of the head is created, making portions of the 
inside more visible.
iTool User’s Guide Displaying Volumes
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The following is an example of a four-channel volume:

red = BYTARR(20,20,20)
green = BYTARR(20,20,20)
blue = BYTARR(20,20,20)
alpha = BYTARR(20,20,20)

red[10:*,*,*]=255
green[*,10:*,*]=255
blue[*,*,10:*]=255
alpha[*] = 128
IVOLUME, red, green, blue, alpha

Rendering Volumes

Volume data does not automatically appear in the tool window since volume 
rendering can be a time consuming operation. To render the volume, click the 
Render button on the tool. Auto-render is available but not set by default since it can 
slow down your iTool session if you have simultaneous operations.

Note
Volume data is only rendered if the volume dataspace is selected. Thus, if you have 
multiple volumes in your dataspace, auto-render must be turned on in order to 
render both simultaneously.
Displaying Volumes iTool User’s Guide
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The data loaded earlier can be displayed by clicking the Render button.

Rendering Quality

The volume can be rendered in two quality modes:

• Low — Done with a stack of 2D texture-mapped semi-transparent polygons. 
The polygons are oriented so that the flat sides face the viewer as directly as 
possible. On most systems, Low-quality mode renders faster than High-quality 
mode, but not as accurately.

• High — Done with the IDLgrVolume ray-casting volume renderer. This 
quality mode is CPU-intensive and will usually take much longer than the 
Low-quality mode.

Extents

Since the volume is not always rendered, iVolume draws wireframe volume extents to 
help you locate and select the volume. You can select the volume by selecting on the 

Figure 8-1: Rendered MRI Head Volume Data
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extents, without rendering the volume. By default, iVolume draws a translucent solid 
cube with internal extents. You can also select a wire frame, or no extents within the 
visualization browser.

Note
Use caution when turning off extents. If extents are turned off and Auto-Render is 
also off, you may need to use the Visualization Browser to select the volume again.
Displaying Volumes iTool User’s Guide
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Volume Properties

The iVolume window is a self-contained volume display and manipulation device. 
You can import and export volume data, and modify and manipulate volume data. For 
more information on the basic iVolume interface and its layout, see Appendix A, 
“iTools Interface Reference”.

Modifying Properties

By selecting Edit → Properties from the iVolume tool, you may modify your 
volume properties. You may modify your volume’s name, description as well as the 
show/hide properties and the line color, style and thickness. For more information on 
editing properties in the iTools, see Appendix D, “Visualization Properties”.
iTool User’s Guide Volume Properties
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Adding a Colorbar

You can add a colorbar to your visualized volume which will show on a color scale 
the minimum to maximum values of data in the visualization. To add a colorbar, click 
on the volume visualization and then from the iVolume window, select 
Insert → Colorbar. A colorbar will be placed in the visualization window. This 
colorbar can be resized and moved around the data space. You can also double-click 
on the colorbar to invoke the Visualization Browser which will allow you to change 
the properties for the colorbar.

Figure 8-2: Rendered Volume with Colorbar Added
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Adding Axes

By default, volumes are displayed with X, Y and Z axes. The display of these axes is 
controlled by property sheets for the axes container and for individual axes (see 
“Axes” in Appendix D). Additional X, Y or Z axes can be added to a volume 
visualization to make it easier to identify volume characteristics.

To add an axis to your volume visualization:

1. Select the volume.

2. Select Insert → Axis.

3. Choose from the following options:

• X axis

• Y axis

• Z axis

Use the mouse to position the new axis, and double-click the axis to display the axis 
property sheet. 

For more information on adding axes, see “Additional Axes” on page 81 in Chapter 3, 
iTool Common Tasks.
iTool User’s Guide Adding Axes
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Resampling Volumes

Resampling re-imports the selected volume data using parameters specified in the 
Resample properties. Resampling parameters include factors for adjusting the X, Y, 
or Z dimensions of the data, as well as the interpolation method to be used.

To resample volume data:

1. Select one or more volumes in the iVolume window for resampling.

2. If necessary, use the Operations Browser to set the desired parameters through 
the Resample properties. See “Resample Properties” on page 258 for details.

3. Select Operation → Transform → Resample.

Figure 8-3: Resampled and Rendered Volume
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Showing an Image Plane

An image plane is a visualization of a slice of the volume. An image plane can be 
dragged and rotated within the volume. To show an image plane for a portion of 
volume data, first be sure your volume is selected and then choose 
Operations → Volume → Image Plane. An image plane appears showing a cross-
section of your volume data. You can change the orientation of an image plane by 
double-clicking on the image plane to bring up the property browser. You can also 
click on the edge of the plane and move it to various other points in the volume data.

Viewing the Image Plane in iImage

Image plane data is available in Data Manager and can be utilized in the iImage tool 
for closer image analysis. The image plane image data is always a 4-channel RGBA 
truecolor image. To view your image plane in iImage, from the iVolume tool select 
Operations → Image Plane → Launch iImage.

Figure 8-4: Image Plane of a Rendered Volume
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Extracting an IsoSurface

An isosurface is a set of polygons drawn in the volume to represent a surface that has 
a specific constant value (the isovalue). An isosurface cannot be translated, scaled, or 
rotated relative to the volume but does move with the volume.

To create an isosurface, select Operations → Volume → Isosurface and iVolume 
displays a dialog allowing you to specify the isovalue. If the volume is multi-channel, 
you can select a channel and set its isovalue.

Figure 8-5: Isosurface Value Selector for iVolume
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You will then create an isosurface for that channel by selecting OK.

Note
Isosurfaces often contain a large number of polygons, which may degrade 
iVolume’s display performance. When selecting the isovalue, you can also specify a 
decimation percentage to reduce the number of polygons in the resulting isosurface. 
This decimation step requires additional time, but the resulting isosurface will 
contain fewer triangles and will draw faster.

Figure 8-6: Isosurfaced Rendered Volume
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222 Chapter 8: Working with Volumes
Extracting an Interval Volume

An interval volume is a set of tetrahedra that span a space between two isovalues 
within a volume. Since a tetrahedral mesh is a solid, iVolume displays the outer 
surface of the mesh as a set of polygons. This surface cannot be translated, scaled, or 
rotated relative to the volume but does move with the volume.

To create an interval volume, select Operations → Volume → Interval Volume and 
a dialog appears allowing you to set two isovalues.

Figure 8-7: Interval Volume Value Selector for iVolume
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If the volume is multi-channel, you can select a channel for setting the isovalues and 
then create an interval volume for that channel by selecting OK.

Note
Vertex colors are not persevered during decimation.

Note
Interval volume surfaces often contain a large number of polygons. These can 
degrade iVolume’s display performance. When selecting isovalues, you can specify 
a decimation percentage to reduce the number of polygons in the resulting surface. 
This decimation step requires additional time, but the resulting surface will contain 
fewer triangles and will draw faster.

Figure 8-8: Original Volume Visualization and Interval Volume
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Manipulating the Volume Display

The iVolume tool allows you many options to manipulate your existing volume 
displays. Once you have visualized your volume data, you may rotate, translate, 
scroll, and zoom as well as modify volume properties. The following options are 
available for manipulating volumes.

Rotating a Volume

Rotating makes it possible to rotate the volume within the visualization without 
affecting the rest of the data space (graphical objects and axes). To rotate your 
volume, from the toolbar on the iVolume window, select the Rotate button. For more 
information about rotating, see “Rotate Data” on page 69 in Chapter 3, iTool 
Common Tasks.

Scaling a Volume

It is possible to scale the data within a volume by a specified scale factor. To scale 
your volume, select Operations → Transform → Scale Data. For more information 
on scaling data, see “Scale Data” on page 70 in Chapter 3, iTool Common Tasks.

View Zoom

View Zoom allows you to zoom in or out on a specific area of the volume display 
area. To zoom in or out in View Zoom mode click Zoom  on the toolbar. For more 
information on working with View Zoom, see “Common Manipulation Tasks” in 
Chapter 3, “iTool Common Tasks”.

Canvas Zoom

Canvas Zoom allows you to increase or decrease the magnification of the entire 
display canvas (which may contain multiple views, depending on the layout) by a 
specified percentage. Canvas Zoom is available by selecting the pull-down 
percentage list from the top of the tool just under the Help menu. For more 
information on working with Canvas Zoom, see “Common Manipulation Tasks” in 
Chapter 3, “iTool Common Tasks”.
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Morphing a Volume

Mathematical morphology is a method of processing digital images on the basis of 
shape. Six morphing options are available for use in iVolume: dilate, erode, morph 
open, morph close, morph gradient, and morph tophat. For more information on 
morphing, see “Morphing” on page 72 in Chapter 3, iTool Common Tasks. To morph 
your image, select Operations → Morph → <option>.

Adding Annotations

Annotations can be added to label or describe volume visualizations displayed in the 
iVolume tool.

The following types of annotations can be added to iVolume displays:

For more information on creating and using annotations, see “Annotations” in 
Chapter 3, “iTool Common Tasks”.

Plot 
Annotation 

Type
Description

Text Single lines or multiple lines of text can be added to a 
visualization to provide a label or description.

Line Straight line annotations can be added to a visualization to link 
labels to objects or to identify an object.

Rectangle Rectangular annotations can be added to a visualization to 
identify rectangular areas.

Oval Oval annotations can be added to a visualization to identify 
circular areas.

Polygon Polygon annotations can be added to a visualization to identify 
areas bounded by a multi-sided polygon.

Freehand Freehand annotations can be added to a visualization to 
identify an area.

Table 8-1: Types of Volume Annotations
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iVolume Tool Operations

The iVolume tool allows you operations for your existing volume displays. Once you 
have visualized your volume data, you can scale and filter as well as creating a 
histogram or viewing statistics for your volume. The following operations are 
available for volumes.

Viewing a Histogram

A density histogram is a plot consisting of either horizontal or vertical bars. The 
widths or heights of these bars represent data values. Another type of histogram is a 
style plot histogram which plots different data sets side-by-side using differently 
styled points or bars to represent the data. To view a density histogram of volume 
data, use the iTool’s histogram feature by selecting Operations →  Histogram. For 
information on histogram creation, see “Plotting a Histogram” in Chapter 3, iTool 
Common Tasks.

Viewing Statistics

To view statistics for volume data, use the iTool’s statistics feature by selecting 
Operations →  Statistics. For information on viewing statistics, see “Displaying 
Statistics” in Chapter 3, iTool Common Tasks.

Smoothing a Volume

Within the iVolume tool, plots can also be smoothed to soften edges or compensate 
for random noise in the volume.

To apply the smooth filter to a volume:

1. Select the volume.

2. Select Operations → Filter → Smooth.
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iTools Interface 
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This appendix describes the following common features of the IDL Intelligent Tools interface:
Introduction . . . . . . . . . . . . . . . . . . . . . . . .  228
File Menu . . . . . . . . . . . . . . . . . . . . . . . . . .  229
Edit Menu  . . . . . . . . . . . . . . . . . . . . . . . . .  230
Insert Menu  . . . . . . . . . . . . . . . . . . . . . . . .  232
Operations Menu . . . . . . . . . . . . . . . . . . . .  233
Window Menu . . . . . . . . . . . . . . . . . . . . . .  236

Help Menu  . . . . . . . . . . . . . . . . . . . . . . . .  237
File Toolbar  . . . . . . . . . . . . . . . . . . . . . . .  238
Edit Toolbar  . . . . . . . . . . . . . . . . . . . . . . .  239
Manipulator Toolbar . . . . . . . . . . . . . . . . .  240
Annotation Toolbar . . . . . . . . . . . . . . . . . .  241
Context Menu . . . . . . . . . . . . . . . . . . . . . .  242
iTool User’s Guide 227



228  
Introduction

The Standard IDL Intelligent Tools comprise five distinct tools: iImage, iPlot, 
iSurface, iContour, and iVolume. Each tool has a specific set of functions related to 
the type of data it is designed to use. In addition to these specific tasks, all four tools 
have a number of functions in common. This appendix describes those functions that 
all iTools have in common; for information about the functions unique to the 
individual iTools, refer to the chapters describing those tools.

This appendix is an overview of these menu items and toolbar buttons that are 
common to all iTools:

Menu Bar Items

The following menus appear on the iTool menu bar:

• File Menu

• Edit Menu

• Insert Menu

• Operations Menu

• Window Menu

• Help Menu

Toolbar Items

The following toolbars appear at the top of each iTool window:

• The File toolbar, containing the New, Open, Save, and Print buttons.

• The Edit toolbar, containing the Undo, Redo, Cut, Copy, and Paste buttons.

• The Manipulator toolbar, containing the Select, Rotate, and View Zoom 
buttons, as well as the Canvas Zoom drop-down list.

• The Annotation toolbar, containing the Text and line buttons as well as the 
Line, Rectangle, Oval, Polygon, and Freehand Region of Interest buttons.
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File Menu 

The File menu contains tools for creating, opening, printing and saving files, as well 
as tools for importing and exporting data and images. The file menu items are 
common to all standard iTools.

Menu 
Selection

Function

New Creates a new iTool of the specified type. Options: iImage, 
iPlot, iSurface, iContour, iVolume.

Open... Opens a file for import into the current iTool. If this is a data 
file, such as an image file, ASCII file, or binary file, a new 
data object will be created and, if applicable, a new 
visualization will be created. 

Import... Imports an IDL variable or file to the current iTool. See “Data 
Import Methods” on page 22 for details.

Export... Exports the data from the currently-selected object to the IDL 
main program level, or exports the current window to an image 
file. 

Save Saves the state of the current iTool to a file. If the state has not 
been previously saved and has no filename, enter a filename. 

Save As... Prompts you to enter a filename, and then saves the state of the 
current iTool.

Print Preview... Shows a preview of the visualization to print and allows you to 
reorient (Portrait or Landscape) as well as Center, Print, Close 
or change printer Setup.

Print... Prints the entire contents of the graphics window. 

Preferences... Displays the Preferences Browser. See “The Preferences 
Browser” on page 87 for details.

Exit Exits the iTool window, closing all visualizations and views 
within the window and removing them from memory. 

Table 8-2: The File Menu
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Edit Menu

The Edit menu contains tools for editing and deleting data within the tool, retracing 
your steps with the Undo/Redo commands, and displaying properties for selected 
objects. The Edit menu items are common to all standard iTools.

Menu 
Selection

Function

Undo Nullifies the previous operation and restores the iTool to its 
state before that operation. The name of the previous operation 
appears after Undo.

Note - Operations such as open, save, export, export variable, 
print, exit, and window moving and resizing cannot be 
undone.

Redo Nullifies the previous Undo command and restores the iTool to 
its state before the Undo command was issued. Any action that 
can be undone can also be redone.

Cut Deletes the selected item(s) and places a copy on the local 
clipboard.

Copy Copies the selected item to the local clipboard. If a view is 
copied, then a bitmap copy of that view (not the entire 
Window) is also put on the System clipboard. 

Paste Pastes the current local clipboard contents into the selected 
view. If a view is pasted, it is added to the current Window 
layout and becomes the currently-selected view.

Paste Special Pastes the current local clipboard contents into the selected 
view, and makes a reference to all contained data.

Delete Deletes the currently-selected item(s), without putting a copy 
on the local or system clipboards. Deletion can be reversed 
with Undo.

Select All Selects all items in the current view.

Grouping Select Group to add all selected objects to a group, Ungroup 
to remove them from the group.

Table 8-3: The Edit Menu
Edit Menu iTool User’s Guide



 231
Order Change the display order of the selected object(s).Choose 
from these options:

• Bring to Front: Move selected object(s) to the top display 
level.

• Send to Back: Move selected object(s) to the bottom 
display level.

• Bring Forward: Move selected object(s) up one display 
level.

• Send Backward: Move selected object(s) down one 
display level.

Parameters... Displays the Parameter Editor. See “About the Parameter 
Editor” on page 20 for details.

Properties... Brings up the property sheet for the currently-selected item(s). 
If only the view is selected, the property sheet for the view 
layer is presented. Only one property sheet may be displayed 
at a time. If a different item or view is selected, the contents of 
the property sheet change to the properties of the new item or 
view. For grouped items, a single property sheet with the 
intersection of the properties is displayed. When the property 
values are not the same for the grouped items, those properties 
are set to undefined or default. Setting a property for a grouped 
item sets that property for all items in the group.

Menu 
Selection Function

Table 8-3: The Edit Menu (Continued) 
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Insert Menu

The Insert menu contains tools for adding visualization elements to the displayed 
data. Contents of the Insert menu vary from iTool to iTool.

Menu 
Selection Function

Visualization Inserts a new visualization into the current window. See 
“Using Insert Visualization” on page 23 for details.

View Inserts a new view into the current window.

• If the window is currently locked, this menu item will be 
grayed out.

• If the window is not locked, the new view is added to the 
layout in the appropriate location, depending upon the 
currently active layout.

Light Inserts a new light into the current window. See “Lights” in 
Appendix D for details.

Axis Inserts a new axis. Choose from these options:

• X: inserts an additional X axis

• Y: inserts an additional Y axis

• Z: inserts an additional Z axis

See “Additional Axes” on page 81 for details.

Legend Inserts a legend for the data set or for the selected 
visualization(s) into the current window. See “Legends” on 
page 74 for details.

Colorbar Inserts a colorbar for the selected item.

Note - Only available for indexed color images.

{Additional items vary depending on the iTool selected.} For example:

Insert Dataspace Inserts dataspace. (useful when overplotting such as in iPlot)

Table 8-4: The Insert Menu
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Operations Menu

The Operations menu contains commands for performing operations on the selected 
data. Contents of the Operations menu vary from iTool to iTool.

Menu 
Selection Function

Operations 
Browser

Displays a hierarchical nested list of all tools in the menus and 
toolbars. See “The Operations Browser” on page 97 for 
details.

Statistics Computes the statistical properties of the selected item(s), and 
displays the results in a separate dialog.

See “Displaying Statistics” on page 105 for details.

Histogram Displays a histogram plot of the selected data. See “Plotting a 
Histogram” on page 104 for details.

Filter Choose from these options:

• Smooth

• Median

• Convolution

See “Filtering” on page 70 for details.

{Additional filters vary depending on the iTool selected.}

Table 8-5: The Operations Menu
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Morph Choose from the following options:

• Dilate is commonly known as “fill”, “expand”, or “grow.” 
It can be used to fill “holes” of a size equal to or smaller 
than the structuring element.

• Erode does to the background what dilation does to the 
foreground. Given an image and a structuring element, 
erode can be used to remove islands smaller than the 
structuring element. 

• Morph open is simply an erosion operation followed by a 
dilation operation. Applying morph open more than once 
produces no further effect.

• Morph close is simply a dilation operation followed by an 
erosion operation. Applying morph close more than once 
produces no further effect.

• Morph gradient is the subtraction of an eroded version of 
the original image from a dilated version of the original 
image. 

• Morph tophat is implemented by first applying the 
opening operator to the original image, then subtracting 
the result from the original image. Applying tophat shows 
the bright peaks within the image. 

See “Morphing” on page 72 for details.

Rotate

Rotate Left

Rotate Right

Rotate by Angle

Rotate the selected data space left 90°.

Rotate the selected data space right 90°.

Specify the number of degrees to rotate the selected data 
space.

Menu 
Selection Function

Table 8-5: The Operations Menu (Continued) 
Operations Menu iTool User’s Guide



 235
Transform • Resample: Resample the selected data using parameters 
specified in Resample property settings.

• Rotate Data: Rotate the data within the visualization by a 
specified number of degrees without affecting the rest of 
the data space.

• Scale Data: Scale the selected object by a specified scale 
factor.

See “Transforming” on page 68 for details.

{Additional transformations vary depending on the iTool 
selected.}

{Additional items vary depending on the iTool selected.}

Menu 
Selection Function

Table 8-5: The Operations Menu (Continued) 
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Window Menu

The Window menu contains commands for displaying the Data, Operations and 
Visualization browsers, for zooming in and out of the display, for modifying the 
window layout, and for displaying a log of system messages. The Window menu 
items are common to all iTools.

Menu 
Selection Function

Data Manager Displays the Data Manager for the current iTool. See “About 
the iTools Data Manager” on page 18 for details.

Visualization 
Browser

Displays a hierarchical nested list of all visualization elements 
in the display area. See “The Visualization Browser” on 
page 85 for details.

Zoom on Resize If this menu item is checked, views will be resized whenever a 
visualization is zoomed in any way.

• by default, the view will not be resized if zoom is 
performed.

Layout... Displays the window layout dialog, which allows the user to 
change the current view layout and the window dimensions.

Console... Displays the Message Log dialog containing all system 
messages and error logs.

• The Message Log dialog is a simple uneditable text box.

• To close the dialog, click OK or the Close button .

Table 8-6: The Window Menu
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Help Menu

The Help menu contains commands for displaying online help and information about 
the iTools. The Help menu items are common to all iTools.

Note
In the Operations and Preferences browser windows, help for the selected item is 
also available on the context menu.

Menu Selection Function

Help on iTools Displays help for the iTools system.

Help on the iTools 
Data Manager

Displays help on the Data manager.

Help on the iTools 
Parameter Editor

Displays help on the Parameter Editor

Help on Selected Item Displays help for the item selected in the iTool 
visualization or browser window.

Help on this iTool Displays help for the current iTool.

About iTools Displays a dialog describing the iTools and giving the 
version number.

Table 8-7: The Help Menu
iTool User’s Guide Help Menu



238  
File Toolbar

The File toolbar contains the following buttons:

Button Tool Name Function

New Creates a new iTool of the same type as the current 
tool with no data or visualizations.

Open Opens a file for import into the current iTool. If this is 
a data file, such as an image file, ASCII file, or binary 
file, a new data object will be created and, if 
applicable, a new visualization will be created. 

Save  Saves the state of the current iTool to a file. If the 
state has not been previously saved and has no 
filename, enter a filename. The saved file is cross-
platform.

Print Prints the entire contents of the graphics window. 

Table 8-8: File Toolbar Buttons
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Edit Toolbar

The Edit Toolbar contains the following buttons:

Button Tool Name Function

Undo Nullifies the previous operation and restores the iTool 
to its state before that operation.

Note - Operations such as open, save, export, export 
variable, print, exit, and window moving and resizing 
cannot be undone.

Redo Nullifies the previous Undo command and restores 
the iTool to its state before the Undo command was 
issued. Any action that can be undone can also be 
redone.

Cut Deletes the selected item(s) and places a copy on the 
local clipboard. If the window layout is locked, you 
will be asked if a copy of the view should be placed 
on the System clipboard.

Copy Copies the selected item to the local clipboard. If a 
view is copied, then a bitmap copy of that view (not 
the entire Window) is also put on the System 
clipboard. 

Paste Pastes the current local clipboard contents into the 
selected view. If a view is pasted, it is added to the 
current Window layout and becomes the currently-
selected view.

Table 8-9: Edit Toolbar Buttons
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Manipulator Toolbar

The Manipulator Toolbar contains the following buttons:

Button Tool Name Function

Select Click to enter select mode. The arrow pointer is 
displayed, and objects can be selected in the display 
area. Click to select an object; a selection box appears 
around the current selection.

Rotate Click to enter rotate mode. A rotation sphere appears 
around the currently selected object. 

• Position the mouse pointer on an axis, and the 
axis rotation pointer is displayed. Drag in the 
desired direction to rotate the object along the 
axis. 

• Position the mouse pointer anywhere on the 
selected object, and the free rotation pointer is 
displayed. Drag in the desired direction to rotate 
the object freely.

View Zoom Click to enter zoom mode. The zoom cursor is 
displayed, and dragging the mouse closer to or farther 
from the center of the canvas decreases or increases 
magnification at the initial point of clicking.

Canvas Zoom Click  to select a magnification percentage for the 
entire canvas, or type a percentage in the text box and 
press ENTER.

Table 8-10: Manipulator Toolbar Buttons
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Annotation Toolbar

The Annotation Toolbar contains the following buttons:

Button Tool Name Function

Text Click to enter text annotation mode. The insert pointer 
is displayed, and text can be entered from the 
keyboard.

Line Click to enter line annotation mode. The crosshairs 
pointer is displayed. Click at the starting point for the 
line and drag in the desired direction. Release the 
mouse button to terminate the line.

Rectangle Click to enter rectangle annotation mode. 

Oval Click to enter oval annotation mode.

Polygon Click to create a polygon annotation. Click to define 
vertices, double-click to complete polygon.

Freehand Click to enter freehand annotation mode. The cross-
hairs pointer is displayed. Click at a starting point and 
drag to create the desired shape. Release the mouse 
button to complete the polygon.

Table 8-11: Annotation Toolbar Buttons
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Context Menu

Right-clicking on the visualization window brings up a context menu at that location. 
The context menu is common to all iTools, and it contains the following menu items:

Menu 
Selection Description

Cut Deletes the selected item(s) and places a copy on the local 
clipboard. If the window layout is locked, you will be asked if 
a copy of the view should be placed on the System clipboard.

Copy Copies the selected item to the local clipboard. If a view is 
copied, then a bitmap copy of that view (not the entire 
Window) is also put on the System clipboard. 

Paste Pastes the current local clipboard contents into the selected 
view. If a view is pasted, it is added to the current Window 
layout and becomes the currently-selected view.

Delete Deletes the currently-selected item(s), without putting a copy 
on the local or system clipboards. Deletion can be reversed 
with Undo.

Grouping: Grouping gives you the advantage of allowing desired items to 
operate together and be manipulated as a single unit.

Group

Ungroup

Groups the currently-selected items into a single unit.

If the selected item is currently a group, then it is ungrouped.

Note - You cannot group items across separate visualization 
and annotation layers.

Order:

Table 8-12: The Context Menu
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Bring To Front

Send To Back

Bring Forward

Send Backward

Brings the selected item(s) to the front of the graphics 
hierarchy.

Sends the selected item(s) to the back of the graphics 
hierarchy.

Bring the selected item(s) forward one position in the graphics 
hierarchy.

Send the selected item(s) back one position in the graphics 
hierarchy.

Export to IDL Exports the currently-selected item(s) to your IDL session.

Parameters... Brings up the parameter editor for the currently-selected 
item(s).

Properties… Brings up the property sheet for the currently-selected item(s). 
If only the view is selected, the property sheet for the view 
layer is presented. Only one property sheet may be displayed at 
a time. If a different item or view is selected, the contents of 
the property sheet change to the properties of the new item or 
view. For grouped items, a single property sheet with the 
intersection of the properties is displayed. When the property 
values are not the same for the grouped items, those properties 
are set to undefined or default. Setting a property for a grouped 
item sets that property for all items in the group.

Menu 
Selection Description

Table 8-12: The Context Menu (Continued) 
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Appendix B:

Property Controls
The following user interface controls are used in iTool property sheets. The general 
function of these controls is described here. Refer to the individual property 
descriptions in Appendix C, “Operations Properties” and Appendix D, “Visualization 
Properties” for specific information on how to set individual property controls.
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Control Type Function

Boolean Click the browse button  to 
expand the list. Select either of the 
two choices (Show or Hide, True 
or False, etc.) from the list.

Number If the number is editable, type in a new value. You may be 
restricted to whole numbers or a range of numbers.

If a slider is displayed, slide to 
select a new value.

String Enter a string in the text box. If the 
string exceeds the length of the 
text box, a browse button is 
provided to expand the text box.

Table 8-13: Controls Used in Property Sheets
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Color Select a color from the palette displayed in the color selector:

Or click Custom Color (UNIX users right-click the color bar 
at the bottom of the window) to specify RGB or HSL values:

Windows users: 
enter Hue, Sat, 
Lum or Red, 
Green, Blue 
values and click 
OK to apply the 
new values. 
Click Add to 
Custom Colors 
to save your 
values.

UNIX users: 
drag the Red, 
Green, Blue or 
Hue, Lightness, 
Saturation 
sliders to change 
values, and click 
OK to apply the 
new values.

Control Type Function

Table 8-13: Controls Used in Property Sheets (Continued) 

Windows Color Picker

UNIX Color Picker
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Line Style Select a line style from the list. To 
make the line invisible, select No 
Line.

Line Thickness Select a line thickness from the list. 
Numbers indicate line thickness in 
pixels. Use the scroll bar to display 
additional items.

Symbol Select a symbol to appear at regular 
intervals on the selected line from 
the list. To remove a symbol from a 
line, select No Symbol. Use the 
scroll bar to display additional items.

String List Select an item from the list. Use 
the scroll bar to display additional 
items.

User Defined Click the Edit button to 
display the user-defined 
property control.

Control Type Function

Table 8-13: Controls Used in Property Sheets (Continued) 
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Appendix C:

Operations 
Properties

This appendix describes the following properties of the IDL Intelligent Tools interface found in the 
Operations Browser of each iTool:
The Operations Browser  . . . . . . . . . . . . . .  250
Statistics Properties . . . . . . . . . . . . . . . . . .  251
Filter Properties . . . . . . . . . . . . . . . . . . . . .  253
Morphing Properties  . . . . . . . . . . . . . . . . .  256
Rotate Properties . . . . . . . . . . . . . . . . . . . .  257
Transform Properties . . . . . . . . . . . . . . . . .  258
Dataspace Operation Properties  . . . . . . . .  262

Region Grow Properties . . . . . . . . . . . . . .  263
Surface Properties  . . . . . . . . . . . . . . . . . .  265
Contour Properties  . . . . . . . . . . . . . . . . . .  266
Image Properties . . . . . . . . . . . . . . . . . . . .  267
Volume Properties  . . . . . . . . . . . . . . . . . .  268
Image Plane Properties . . . . . . . . . . . . . . .  269
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The Operations Browser 

The Operations Browser provides a hierarchical tree view of the tools and operations 
available from the iTool Operations menu. The Operations Browser is used to set 
properties for operations and tools used in the iTool window. See “The Operations 
Browser” on page 97 for details on how to display and use the Operations Browser.

The property sheet for each operation displayed in the Operations Browser contains 
the Name and Description properties described in the following table. For each 
property, the type of control and the values that can be assigned are listed. For a 
description of how a particular control is used, refer to Appendix B, “Property 
Controls”

Figure 8-9: The Operations Browser

Property Control Type: Options

Name String: Name assigned to this statistics dialog. Edit the text to 
change the name.

Description String: Description of this statistics function. Edit the text to 
change the description.

Table 8-14: Statistics Operation Properties
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Statistics Properties 

The Statistics tool displays statistical information relating to the currently selected 
object or group of objects. The Statistics tool appears in the Operation Browser for all 
iTools. See “Displaying Statistics” on page 105 for details on how to use the Statistics 
tool.

Statistics has no properties that can be configured other than Name and Description.

Figure 8-10: Statistics Properties in the Operations Browser
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Histogram Properties 

The Histogram tool displays a histogram plot of the data selected in the iTool 
window. The Histogram tool appears in the Operation Browser for all iTools. See 
“Plotting a Histogram” on page 104 for details on how to use the Histogram tool.

Histogram has no configurable properties other than Name and Description.
Histogram Properties iTool User’s Guide
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Filter Properties 

The following properties control the iTool filters. 

Smooth Properties

The Smooth filter reduces noise within an image by applying low pass filters. Smooth 
filter properties appear on the Operations Browser for all iTools. See “Smooth Filter” 
on page 70 for details on applying the smooth filter. 

For each property, the type of control and the values that can be assigned are listed. 
For a description of how a particular control is used, refer to Appendix B, “Property 
Controls”. 

Median Properties

Median smoothing replaces each point with the median (a value in an ordered set of 
values with an equal number of values above and below it) of the one- or two-
dimensional neighborhood of a given width. See “Median Filter” on page 71 for 
details on applying the median filter. 

For each property, the type of control and the values that can be assigned are listed. 
For a description of how a particular control is used, refer to Appendix B, “Property 
Controls”. 

Property Control Type: Options

WIDTH Number: Width of the smooth window. Enter a whole number 
between 1 (no smoothing) and the width of the data. 
Default = 3

Table 8-15: Smooth Filter Properties

Property Control Type: Options

WIDTH Number: Width of the smooth window. Enter a whole number 
between 1 (no smoothing) and the width of the data. 
Default = 3

Table 8-16: Median Filter Properties
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Convolution Properties

Convolution smooths data by using a weighted moving average. Convolution filter 
properties appear on the Operations Browser for all iTools. See “Convolution Filter” 
on page 71 for details on applying convolution. 

For each property, the type of control and the values that can be assigned are listed. 
For a description of how a particular control is used, refer to Appendix B, “Property 
Controls”. 

Roberts Filter Properties

Roberts filter appears on the Operations Browser for the iImage tool only. Roberts 
filter has no configurable properties other than Name and Description. For more 
information on the Roberts filter, see “ROBERTS” in the IDL Reference Guide 
manual.

Even Average Boolean: If set to true and the Width property is set to an even 
number, the operation will return the average of the two 
middle numbers.

Property Control Type: Options

Show dialog Boolean: Display the Convolution Kernel Editor dialog when 
the Convolution filter is selected from the 
Operations → Filter menu. Choose True to display the 
dialog, or False to apply the Convolution filter without 
displaying the dialog. Default = True

Kernel User Defined: Display the Convolution Kernel Editor dialog. 
Click Edit to display the dialog. Default = <Default>

Table 8-17: Convolution Filter Properties

Property Control Type: Options

Table 8-16: Median Filter Properties
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Sobel Filter Properties

Sobel filter appears on the Operations Browser for the iImage tool only. Sobel filter 
has no configurable properties other than Name and Description. For more 
information on the Sobel filter, see “SOBEL” in the IDL Reference Guide manual.

Curve Fitting Properties

Curve Fitting Properties appear on the Operations Browser for the iPlot tool only. 
Curve Fitting has no configurable properties other than Name and Description. For 
more information on curve fitting a plot, see “Curve Fitting” in Chapter 7, Working 
with Plots.
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Morphing Properties 

The following properties control the iTool morphing filters. 

Mathematical morphology is a method of processing digital images on the basis of 
shape. Six morphing options are available for use in iTools: dilate, erode, morph 
open, morph close, morph gradient, and morph tophat. All six options share the same 
properties. See “Morphing” on page 72 for details on morphing data. 

For each property, the type of control and the values that can be assigned are listed. 
For a description of how a particular control is used, refer to Appendix B, “Property 
Controls”. 

Property Control Type: Options

Structure Shape String List: The shape of the structuring element used in the 
morph operation. Choose from these values:

• Square:

• Circle:

 Default = Square

Structure Width Number: The width of the structuring element.

Default = 3

Table 8-18: Morphological Filter Properties
Morphing Properties iTool User’s Guide



 257
Rotate Properties 

The following properties control the iTool Rotate tools. Rotate properties appear on 
the Operations Browser for all iTools (for iImage it is Rotate or Flip).

Rotate Left Properties

Rotate Left has no configurable properties other than Name and Description.

Rotate Right Properties

Rotate Right has no configurable properties other than Name and Description.

Rotate By Angle Properties

Rotate by Angle has no configurable properties other than Name and Description.

Flip Horizontal

Flip Horizontal has no configurable properties other than Name and Description.

Flip Vertical

Flip Vertical has no configurable properties other than Name and Description.
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Transform Properties 

The following properties control the iTool Transform tools. 

Resample Properties

The Resample transform resamples the selected data using the resamping factors and 
method specified in these properties. Resample Transform properties appear on the 
Operations Browser for all iTools. See “Resample” on page 68 for details on how to 
resample data.

For each property, the type of control and the values that can be assigned are listed. 
For a description of how a particular control is used, refer to Appendix B, “Property 
Controls”.

Property Control Type: Options

1st dimension 
factor

Number: The resampling factor for the first dimension (X). 
Edit the number to change the value. Default = 2

2nd dimension 
factor

Number: The resampling factor for the second dimension (Y). 
Edit the number to change the value. Default = 2

3rd dimension 
factor

Number: The resampling factor for the third dimension (Z). 
Edit the number to change the value. Default = 2

Interpolation 
method

String List: Method of interpolation to use in resampling. 
Select a method from the list. Choose from these values:

• Nearest neighbor: Assign the value of the nearest pixel to 
the pixel in the output image. Fastest method, but may 
cause jagged edges.

• Linear: Surveys the two closest pixels, drawing a line 
between them and designating a value along that line as 
the output pixel value.

• Cubic: Use cubic polynomial waveforms instead of linear 
waveforms. Most accurate method, but may require more 
processing time.

Default = Nearest neighbor

Table 8-19: Resample Transform Properties
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Rotate Data Properties

The Rotate Data operation allows you to rotate the data within the visualization by a 
specified number of degrees without affecting the rest of the data space (graphical 
objects and axes). See “Rotate Data” on page 69 for details on using the Rotate Data 
operation.

The following properties control the Rotate Data tool. For each property, the type of 
control and the values that can be assigned are listed. For a description of how a 
particular control is used, refer to Appendix B, “Property Controls”.

Property Control Type: Options

Angle Number: The angle of rotation in degrees clockwise. 
Default = 0

X center offset Number: X subscript of the center of rotation. Default = 0

Y center offset Number: Y subscript of the center of rotation. Default = 0

Magnification Number: Magnification factor. Default = 1

Interpolation 
method

String List: Method of interpolation to use when rotating. 
Select a method from the list. Choose from these values:

• Nearest neighbor: Assign the value of the nearest pixel to 
the pixel in the output image. Fastest method, but may 
cause jagged edges.

• Linear: Surveys the two closest pixels, drawing a line 
between them and designating a value along that line as 
the output pixel value.

• Cubic: Use cubic polynomial waveforms instead of linear 
waveforms. Most accurate method, but may require more 
processing time.

Default = Nearest neighbor

Extrapolate 
missing

Boolean: Extrapolate the value of a missing pixel from the 
value of nearby pixels. Default = True

Table 8-20: Rotate Data Properties
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Scale Data Properties

The Scale Data operation scales the selected objects by a specified scale factor. Scale 
Data properties appear on the Operations Browser for all iTools. See “Scale Data” on 
page 70 for details on using the Scale Data operation.

The following properties control the Scale Data tool. For each property, the type of 
control and the values that can be assigned are listed. For a description of how a 
particular control is used, refer to Appendix B, “Property Controls”.

Invert Image Properties

Invert Image Transform properties appear on the Operations Browser for iImage only. 
The operation has no unique properties. 

Missing value Number: A value to be substituted for pixels in the rotated 
image that fall outside the bounds of the unrotated image. This 
property is only used if the Extrapolate missing property is set 
to false. Default = 0

Pivot Boolean: If set to true, the image will be rotated around the 
point defined by the X center offset and Y center offset. If set 
to false, the image will be rotated around its center. 
Default = False

Property Control Type: Options

Scale Factor Number: Scale the selected data by this factor. Edit the number 
to change the factor that appears in the Scale Factor dialog. 
Scale Factor may be positive or negative. Default = 2

Table 8-21: Scale Data Properties

Property Control Type: Options

Table 8-20: Rotate Data Properties
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Byte Scale Properties

Byte Scale properties appear on the Operations Browser for iImage only. For each 
property, the type of control and the values that can be assigned are listed. For a 
description of how a particular control is used, refer to Appendix B, “Property 
Controls”.

Property Control Type: Options

Automatic 
Min/Max

Boolean: Automatically compute minimum and maximum 
values? Choose True or False. Default = True

Minimum cutoff Number: Minimum value of array to be considered. Edit the 
number to change the value. Default = 0

Maximum cutoff Number: Maximum value of array to be considered. Edit the 
number to change the value. Default = 255

Bottom byte Number: Minimum value of scaled result. Edit the number to 
change the value. Range = 0-255. Default = 0

Top byte Number: Maximum value of scaled result. Edit the number to 
change the value. Range = 0-255. Default = 255

Table 8-22: Byte Scale Transform Properties
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Dataspace Operation Properties 

Reset Ranges Properties

The Reset Ranges operation has no unique properties. 

Pixel Scale Properties

The Pixel Scale operation appears in the Operations browser for iImage only. For 
each property, the type of control and the values that can be assigned are listed. For a 
description of how a particular control is used, refer to Appendix B, “Property 
Controls”.

Property Control Type: Options

Pixel scale Number: The number of pixels that should be used to render 
each pixel in the original image. Default = 1

Table 8-23: Pixel Scale Properties
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Region Grow Properties 

Region growing expands a selected area to include nearby pixels that fall within a 
threshold range of the current selection. See “REGION_GROW” in the IDL 
Reference Guide manual for additional details. For a description of how a particular 
control is used, refer to Appendix B, “Property Controls”.

Property Control Type: Options

Region grow 
method

String List: The method used to select pixels that are similar to 
the current selection. Choose from these values:

• By threshold: The expanded region includes neighboring 
pixels that fall within the range defined by the Threshold 
minimum and Threshold maximum values.

• By standard deviation: The expanded region includes 
neighboring pixels that fall within the range of the mean of 
the region’s pixel values plus or minus the given multiplier 
times the sample standard deviation as follows: 

Mean +/- StdDevMultiplier * StdDev 

where Mean is the mean value of the selected pixels, 
StdDevMultiplier is the value specified by the 
Standard Deviation Multiplier property, and StdDev is the 
standard deviation of the selected pixels.

Default = By threshold

Pixel search 
method

String List: Specifies which pixels should be considered 
during region growing. 4-neighbor searching searches only the 
neighbors that are exactly one unit in distance from the current 
pixel; 8-neighbor searching searches all neighboring pixels.

Choose from these values:

• 4-neighbor: 

• 8-neighbor: 

Default = 4-neighbor

Table 8-24: Region Grow Operation Properties
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Threshold to use String List: Specifies the threshold values to use. Choose from 
these values:

• Source ROI/Image threshold: Base the threshold values 
on the pixel values in the currently selected region.

• Explicit: Specify the threshold values using the Threshold 
minimum and Threshold maximum properties.

Default = Source ROI/Image threshold

Threshold 
minimum

Number: The explicitly specified minimum threshold value. 
Default = 0

Threshold 
maximum

Number: The explicitly specified maximum threshold value. 
Default = 256

Standard 
deviation 
multiplier

Number: The number of standard deviations to use if the 
region growing method is By standard deviation. Default = 1

For an RGB(A) 
image use

String List: If the image has separate color channels, use the 
selected channel when growing the region. Choose from these 
values:

• Luminosity: Luminosity values

• Red Channel: Red values

• Green Channel: Green values

• Blue Channel: Blue values

• Alpha Channel: Transparency values.

Default = Luminosity

Property Control Type: Options

Table 8-24: Region Grow Operation Properties (Continued) 
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Surface Properties 

Surface Properties appear on the Operations Browser for iImage and iContour only. 
Surface has no configurable properties other than Name and Description.
iTool User’s Guide Surface Properties
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Contour Properties 

Contour Properties appear on the Operations Browser for iImage and iSurface only. 
Contour has no configurable properties other than Name and Description.
Contour Properties iTool User’s Guide
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Image Properties 

Image Properties appear on the Operations Browser for iSurface and iContour only. 
Image has no configurable properties other than Name and Description.
iTool User’s Guide Image Properties
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Volume Properties 

Volume Properties appear on the Operation Browser for the iVolume tool only.

Image Plane

Image Plane has no configurable properties other than Name and Description.

Isosurface

For each property, the type of control and the values that can be assigned are listed. 
For a description of how a particular control is used, refer to Appendix B, “Property 
Controls”.

Render Volume

Render Volume has no configurable properties other than Name and Description.

Interval Volume

For each property, the type of control and the values that can be assigned are listed. 
For a description of how a particular control is used, refer to Appendix B, “Property 
Controls”.

Property Control Type: Options

Show Dialog Boolean: Display the Isosurface Value Selector dialog when 
Isosurface is selected from the Operations → Volume menu. 
Choose True to display the dialog, or False to apply the 
isosurface without displaying the dialog. Default = True

Table 8-25: Isosurface Properties

Property Control Type: Options

Show Dialog Boolean: Display the Isosurface Value Selector dialog when 
Isosurface is selected from the Operations → Volume menu. 
Choose True to display the dialog, or False to apply the 
isosurface without displaying the dialog. Default = True

Table 8-26: Interval Volume Properties
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Image Plane Properties 

Image Plane Properties appear on the Operation Browser for the iVolume tool only.

Launch iImage

Launch iImage has no configurable properties other than Name and Description.
iTool User’s Guide Image Plane Properties
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Appendix D:

Visualization 
Properties

This appendix describes the following visualization properties of the IDL Intelligent Tools 
interface found in the Visualization Browser of each iTool:
Introduction . . . . . . . . . . . . . . . . . . . . . . . .  272
The Visualization Browser  . . . . . . . . . . . .  273
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2D Annotation Layer Properties  . . . . . . .  332
Legend Properties . . . . . . . . . . . . . . . . . . .  343
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Introduction

The IDL Intelligent Tools comprise five distinct tools: iImage, iPlot, iSurface, 
iContour, and iVolume. Each tool has a specific set of functions related to the type of 
data it is designed to use. In addition to these specific tasks, all five tools have a 
number of functions in common. 

This appendix describes those functions that all iTools have in common; for 
information about the functions unique to the individual iTools, refer to 

• Chapter 4, “Working with Images”

• Chapter 5, “Working with Surfaces”

• Chapter 6, “Working with Contours”

• Chapter 7, “Working with Plots”

• Chapter 8, “Working with Volumes”

This appendix is an overview of the menu items and toolbar buttons that are common 
to all iTools. 
Introduction iTool User’s Guide
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The Visualization Browser

The Visualization Browser provides a hierarchical tree view of all objects displayed 
in the iTool window. The Visualization Browser is used to select objects and to 
display the property sheets for selected objects. See “The Visualization Browser” on 
page 85 for details on how to display and use the Visualization Browser.

The Visualization Browser displays a list of the contents of the iTool window in the 
left pane. The property sheet for the object currently selected in the left pane can be 
displayed in the right pane of the Visualization Browser window by clicking on the 
small arrows to the top-right of the left pane and top-left of the right pane (in the 
middle if both are displayed). For example, to display the properties of the current 
window, select Window in the left pane of the Visualization Browser as shown in the 
following figure.
iTool User’s Guide The Visualization Browser
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Window Properties 

These properties control the display of the iTool window. For each property, the type 
of control and the values that can be assigned are listed. For a description of how a 
particular control is used, refer to Appendix B, “Property Controls”.

Figure 8-11: The Visualization Browser with Window Properties Displayed

Property Control Type: Values

Zoom on Resize Boolean: Zoom visualization upon resize of window? Choose 
True or False. Default = False

Window Width Number: Width of the current iTool window in pixels. Edit the 
number to change the value. Default = 640

Note - The minimum width of the window correlates to the 
width of the menubar.

Table 8-27: iTool Window Properties
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All property sheets displayed in the Visualization Browser, with the exception of the 
Window property sheet displayed above, include the Name, Description, and Show 
properties described in the following table:

Window Height Number: Height of the current iTool window in pixels. Edit 
the number to change the value. Default = 512 Minimum = 
100

Property Control Type: Values

Name String: Name assigned to this view. Edit the text to change the 
name. 

Description String: Description of this view. Edit the text to change the 
description. 

Show Boolean: Show this view? Choose True or False. 
Default = True

Table 8-28: Name and Description Properties

Property Control Type: Values

Table 8-27: iTool Window Properties
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View Properties

Each iTool window contains at least one view. If multiple views have been created 
from the Window Layout dialog, each view will be listed separately.

These properties control the display of the view or views contained in the iTool 
window. For each property, the type of control and the values that can be assigned are 
listed. For a description of how a particular control is used, refer to Appendix B, 
“Property Controls”

Figure 8-12: Visualization Browser with View Properties Displayed

Property Control Type: Values

Zoom Factor Number: Increase or decrease magnification of the view by 
this factor. Edit the number to change the value. Default = 1

Layout Position Displays the currently-selected layout view

Table 8-29: View Properties
View Properties iTool User’s Guide
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Visualization Layer Properties

The Visualization Layer contains the data space and, for three-dimensional objects, 
the lights, associated with a visualization. 

These properties control the visualization of the data space. For each property, the 
type of control and the values that can be assigned are listed. For a description of how 
a particular control is used, refer to Appendix B, “Property Controls”.

Figure 8-13: Visualization Browser with Visualization Layer Properties Displayed

Property Control Type: Values

Background 
Color 

Color: Visualization layer background color. Transparent must 
be set to False. Click to choose from the default color palette, 
or specify RGB values. Default = [255, 255, 255] (white)

Transparent Boolean: Make visualization layer transparent? Choose True 
or False. Default = True

Table 8-30: Visualization Layer Properties
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Projection String List: Projection method for displaying the visualization 
layer. Select a method from the list. Choose from these values:

• Orthogonal: Orthographic projection (objects are 
projected onto the visualization layer along lines 
perpendicular to the view plane)

• Perspective: Objects are projected onto the visualization 
layer along perspective lines that converge in the distance.

Default = Orthogonal

Stretch to Fit Boolean: Stretch visualization layer to fit window? Choose 
True or False. Default = False

Property Control Type: Values

Table 8-30: Visualization Layer Properties (Continued) 
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Data Space Properties

The data space contains the data type(s) displayed within the visualization, plus the 
axes associated with the data.

These properties control the visualization of the data space. For each property, the 
type of control and the values that can be assigned are listed. For a description of how 
a particular control is used, refer to Appendix B, “Property Controls”.

Figure 8-14: Visualization Browser with Data Space Properties Displayed

Property Control Type: Values

Isotropic scaling Scaling method. Select a method from the list. Choose 
between these values:

• Automatic: automatic scaling

• Isotropic: isotropic scaling

• Nonisotropic: nonisotropic scaling

Default = Automatic

Table 8-31: Data Space Properties
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X Minimum String: Minimum value for X coordinate of data set. 

X Maximum String: Maximum value for X coordinate of data set.

Y Minimum String: Minimum value for Y coordinate of data set.

Y Maximum String: Maximum value for Y coordinate of data set.

Z Minimum String: Minimum value for Z coordinate of 3-D data set.

Z Maximum String: Maximum value for Z coordinate of 3-D data set.

Automatic X 
range updates

Boolean: Automatically updates the range of X values. Choose 
True or False. Default = True

Automatic Y 
range updates

Boolean: Automatically updates the range of Y values. Choose 
True or False. Default = True

Automatic Z 
range updates

Boolean: Automatically updates the range of Z values. Choose 
True or False. Default = True

Color Color: Data space bounding box border color. Border Style 
must not be No line. Click to choose from the default color 
palette, or specify RGB values. Default = [0,0,0] (black)

Linestyle Line Style: Data set bounding box border line style. Select a 
line style from the list. Default = No line

Thickness Line Thickness: Data set bounding box border line thickness. 
Select a thickness from the list. Default = 1. 

Fill Background Boolean: Fills data space background with background color. 
Choose True or False. Default = True

Fill Color Color: Data space background color. Fill Background must be 
set to True. Click to choose from the default color palette, or 
specify RGB values. Default = [255, 255, 200] (cream)

Transparency Number: Transparency of data space background from 0% to 
100%. Fill Background must be set to True. Move slider to 
select a new percentage. Default = 100

Property Control Type: Values

Table 8-31: Data Space Properties (Continued) 
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Visualization Type Properties

Five types of visualizations can be displayed in iTool windows: images, plots, 
surfaces, contours, or volumes. Each data type has its own property sheet, which can 
be displayed in the Visualization Browser.

Image

These properties control image object visualizations. For each property, the type of 
control and the values that can be assigned are listed. For a description of how a 
particular control is used, refer to Appendix B, “Property Controls”.

Figure 8-15: Visualization Browser with Image Properties Displayed

Property Control Type: Values

Image Palette User Defined: By selecting Edit Color → Table Edit access 
the color table to manipulate plot color values

Table 8-32: Image Properties
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Interpolation String List: Method used for interpolating the image. Select a 
method from the list. Choose from these values:

• Nearest Neighbor: Assign the value of the nearest pixel 
to the pixel in the output image. Fastest method, but may 
cause jagged edges.

• Bilinear: Create a weighted average based on the nearness 
and brightness of the closest 4 pixels, and assign that value 
to the pixel in the output image. 

Default = Nearest Neighbor

Pixel size (x) Number: Pixel size for x value.

Default = 1

Pixel size (y) Number: Pixel size for y value.

Default = 1

Origin (x) Number: Origin point for x value.

Default = 0

Origin (y) Number: Origin point for y value.

Default = 0

Units Number: Number of units.

Default = None

Image 
transparency

Number: Transparency of the image, 0% - 100%. Move the 
slider to change the value. Default = 0 (no transparency)

Note - The transparency is changed by adding an alpha 
channel to the image. If your image has an alpha channel then 
the Transparency property is ignored.

Row Order String List: Select an order from the list. Choose from these 
values:

• Bottom-to-top

• Top-to-bottom

Default = Bottom-to-top

Property Control Type: Values

Table 8-32: Image Properties (Continued) 
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Plot

These properties control plot object visualizations. For each property, the type of 
control and the values that can be assigned are listed. For a description of how a 

Figure 8-16: Visualization Browser with Plot Properties Displayed
iTool User’s Guide Visualization Type Properties
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particular control is used, refer to Appendix B, “Property Controls”.

Property Control Type: Values

Vertex Colors 
Color Table

User Defined: By selecting Edit Color → Table Edit access 
the color table to manipulate plot color values

Color Color: Color for the plot line. Click to choose from the default 
color palette, or specify RGB values. Default = [0,0,0] 
(black)

Line style Line Style: Style for the plot line. Select a style from the list. 
Default = (solid line)

Thickness Line Thickness: Thickness for the plot line. Select a thickness 
from the list. Default = 1

Minimum value Number: Minimum value to include in the plot. Edit the 
number to change the value. 

Table 8-33: Plot Properties
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Maximum value Number: Maximum value to display in the plot. Edit the 
number to change the value. 

Histogram plot Boolean: Display plot as a histogram? Choose True or False. 
Default = False

Number of points 
to average

Number: Number of points to average when drawing the plot. 
Edit to change the value. Default = 1

Polar plot Boolean: Display plot as a polar plot? Choose True or False. 
Default = False

Fill plot Boolean: Fill between plot lines? Choose True or False. 
Default = False

Fill level Number: Level at which to begin the plot fill. Edit the number 
to change the value. Default = 0

Fill color Color: Color for the plot fill. Fill transparency must be less 
than 100%. Click to choose from the default color palette, or 
specify RGB values. Default = [255, 255, 255] (white)

Fill transparency Number: Transparency of the plot fill from 0% to 100%. Move 
the slider to change the value. Default = 0

Symbol Symbol: Symbol to appear at regular intervals on the plot line. 
Choose a symbol from the list. Default = No symbol

Symbol size Number: Factor from 0 - 1 determining the size of the selected 
symbol. Move slider to change the size. Default = 0.2

Use default color Boolean: Activate Symbol color property. Choose True or 
False. Default = False

Symbol color Color: Color for the selected symbol. Click to choose from the 
default color palette, or specify RGB values. Default = 
[0,0,0] (black)

Symbol thickness Number: Line thickness from 1 - 9.9 for the selected symbol. 
Move slider to change the thickness. Default = 1.

Property Control Type: Values

Table 8-33: Plot Properties (Continued) 
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Symbol 
increment

Number: Interval at which symbols will be displayed on the 
plot line. Influenced by Number of points to average (above). 
Edit to change the value. Default = 1

Property Control Type: Values

Table 8-33: Plot Properties (Continued) 
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Plot 3D

These properties control three-dimensional plot object visualizations. For each 
property, the type of control and the values that can be assigned are listed. For a 

Figure 8-17: Visualization Browser with 3D Plot Properties Displayed
iTool User’s Guide Visualization Type Properties
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description of how a particular control is used, refer to Appendix B, “Property 
Controls”.

Property Control Type: Values

Vertex color table User Defined: By selecting Edit Color → Table Edit access 
the color table to manipulate plot color values

XY Shadow Boolean: Show XY shadow? Choose Hide or Show. 

Default = Hide

YZ Shadow Boolean: Show YZ shadow? Choose Hide or Show. 

Default = Hide

XZ Shadow Boolean: Show XZ shadow? Choose Hide or Show. 

Default = Hide

Table 8-34: Plot 3D Properties
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Color Color: Color for the plot line. Click to choose from the default 
color palette, or specify RGB values. Default = [0,0,0] 
(black)

Line style Line Style: Style for the plot line. Select a style from the list. 
Default = (solid line)

Thickness Line Thickness: Thickness for the plot line. Select a thickness 
from the list. Default = 1

Shading String List: Shading method. Select a method from the list. 
Choose between these values:

• Flat: Flat shading

• Gouraud: Gouraud shading

Default = Flat

Symbol Symbol: Symbol to appear at regular intervals on the plot line. 
Choose a symbol from the list. Default = No symbol

Symbol size Number: Factor from 0 - 1 determining the size of the selected 
symbol. Move slider to change the size. Default = 0.2

Use default color Boolean: Activate Symbol color property. Choose True or 
False. Default = False

Symbol color Color: Color for the selected symbol. Click to choose from the 
default color palette, or specify RGB values. Default = 
[0,0,0] (black)

Symbol thickness Number: Line thickness from 1 - 9.9 for the selected symbol. 
Move slider to change the thickness. Default = 1.

Symbol 
increment

Number: Interval at which symbols will be displayed on the 
plot line. Influenced by Number of points to average (above). 
Edit to change the value. Default = 1

Property Control Type: Values

Table 8-34: Plot 3D Properties (Continued) 
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Surface

These properties control surface object visualizations. For each property, the type of 
control and the values that can be assigned are listed. For a description of how a 
particular control is used, refer to Appendix B, “Property Controls”.

Figure 8-18: Visualization Browser with Surface Properties Displayed

Property Control Type: Values

Color Color: Color of the surface visualization. Click to choose from 
the default color palette, or specify RGB values. Default = 
[255,184,0] (gold)

Use surface color 
for bottom

Boolean: Display a color for the bottom of the surface. Choose 
True or False. 

Default = False

Table 8-35: Surface Properties
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Image palette User Defined: By selecting Edit Color → Table Edit access 
the color table to manipulate surface color values

Bottom color Color: Color to be used for the bottom of the surface. Click to 
choose from the default color palette, or specify RGB values. 
Default = [255,255,255] (white)

Minimum value Number: Minimum value to display in the surface. Edit the 
number to change the value.

Maximum value Number: Maximum value to display in the surface. Edit the 
number to change the value.

Surface style String List: Style used for rendering the surface. Select a style 
from the list. Choose from these values: 

• Points: Data points in the surface are rendered as points.

• Wire mesh: Data points in the surface are connected with 
lines, forming a mesh.

• Filled: Data points in the surface are connected with filled 
quadrangles or triangles, forming a solid surface.

• Ruled XZ: Data points in the surface are connected with 
horizontal (Z-direction) lines, forming a grid.

• Ruled YZ: Data points in the surface are connected with 
vertical (Y-direction) lines, forming a grid.

• Lego: Stacked histogram-style plot in which each data 
value is rendered as an outline box covering the XY extent 
of the cell and with a height proportional to the Z value.

• Lego filled: Same as Lego, but the boxes are filled.

Default = Filled

Property Control Type: Values

Table 8-35: Surface Properties (Continued) 
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Fill shading String List: Method used for shading the surface polygons. 
Select a shading method from the list. Choose from these 
values:

• Flat: Shades polygons with a uniform fill.

• Gouraud: Interpolates intensities from each vertex along 
each edge. Then, when the polygons are converted, 
interpolates the shading along each scan line from the edge 
intensities. Results in a more natural appearance.

Default = Flat

Draw method String List: Method used for drawing the surface. Select a 
method from the list. Choose from these values:

• Quads: Draw a surface composed of quadrangles.

• Triangles: Draw a surface composed of triangles.

Default = Quads

Line style Line Style: Style of lines used for constructing the surface. 
Select a style from the list. Default = (solid 
line)

Line thickness Line Thickness: Thickness of lines used for constructing the 
surface. Select a thickness from the list. Default = 1

Remove hidden 
lines

Boolean: Hide lines that show through the surface mesh or 
grid. Choose True or False. 

Default = False

Show skirt Boolean: Display the edges of the surface as a filled skirt? 
Choose True or False. 

Default = False

Skirt bottom 
height

Number: Set bottom of displayed skirt to this height. Edit the 
number to change the value. 

Default = 0

Property Control Type: Values

Table 8-35: Surface Properties (Continued) 
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Texture 
interpolation

String List: Method used for interpolating selected texture 
map. Select a method from the list. Choose from these values:

• Nearest Neighbor: Assign the value of the nearest pixel to 
the pixel in the output image. Fastest method, but may 
cause jagged edges.

• Bilinear: Create a weighted average based on the nearness 
and brightness of the closest 4 pixels, and assign that value 
to the pixel in the output image. 

Default = Nearest Neighbor

Texture hires String List: Method used for tiling the selected high-resolution 
texture map. Select a tiling method from the list. Choose from 
these values:

• No tiling: Do not use tiling

• LOD tiling: Use Level Of Detail tiling

• Tiling: Use tiling

Default = No tiling

Skip zero opacity Boolean: Skip zero opacity for surface? Choose True or False. 

Default = True

Vertex Color 
Scale

User Defined: Select vertex color scale bottom/top.

Texture Map 
Scale

User Defined: Select texture map scale bottom/top.

Property Control Type: Values

Table 8-35: Surface Properties (Continued) 
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Contour

These properties control contour object visualizations. For each property, the type of 
control and the values that can be assigned are listed. For a description of how a 

Figure 8-19: Visualization Browser with Contour Properties Displayed
Visualization Type Properties iTool User’s Guide
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particular control is used, refer to Appendix B, “Property Controls”.

Property Control Type: Values

Contour level 
properties

User Defined: Click to edit individual or all contour level 
properties. Click  and Edit... to display Contour Levels 
window.

Use palette color Boolean: Use palette color? Choose True or False. Default = 
False

Planar Z Value Number: Z value of plane on which to project contours. Edit 
the number to change the value. Default = 0

Number of levels Number: Number of contour levels to display. Edit the number 
to change the value. Default = 5

Projection String List: Method of projection. Select a method from the 
list. Choose from these values:

• Three-D: Project in three dimensions

• Planar: Project onto a plane

Default = Planar

Fill contours Boolean: Fill space between contours? Choose True or False. 
Default = False

Table 8-36: Contour Properties
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Shading String List: Shading method. Select a method from the list. 
Choose between these values:

• Flat: Flat shading

• Gouraud: Gouraud shading

Default = Flat

Minimum value Number: Minimum value to display in the contour. Edit 
number to change value. No default value.

Maximum value Number: Maximum value to display in the contour.Edit number 
to change value. No default value.

Downhill ticks Boolean: Show downhill ticks? Choose Hide or Show. Default 
= Hide

Downhill tick 
interval

Number: Distance between downhill tick marks. Edit number 
to change value. Default = 0.2

Downhill tick 
length

Number: Length of downhill tick marks. Edit number to change 
value. Default = 0.2

Property Control Type: Values

Table 8-36: Contour Properties (Continued) 
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Volume

These properties control volume object visualizations. For each property, the type of 
control and the values that can be assigned are listed. For a description of how a 
particular control is used, refer to Appendix B, “Property Controls”.

Figure 8-20: Visualization Browser with Volume Properties Displayed

Property Control Type: Values

Display Scale Set the display scale for the selected volume.

Select Display Scale Bottom/Top → Edit 

Table 8-37: Volume Properties
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Color & Opacity 
Table 0

Color: By selecting Edit Color → Table Edit access the color 
table to manipulate plot color values

Note - To edit the opacity only in the editor, uncheck the R, G, 
and B boxes in both the Modify and Display rows. Edit the 
remaining line by clicking on and dragging the line in the 
window. Click OK when finished.

Color & Opacity 
Table 1

Color: By selecting Edit Color → Table Edit access the color 
table to manipulate plot color values.

Property Control Type: Values

Table 8-37: Volume Properties (Continued) 
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SubVolume String: Edit SubVolume Extents.

Color Color: Color for the volume. Click to choose from the default 
color palette, or specify RGB values. 

Default = [0,0,0] (black)

Ambient color String: Choose from default color palette, or specify RGB 
values. 

Default = [255, 255, 255] (white)

Composite 
function

String: Choose composite function.

Default = Alpha Blending

Acceleration hints Boolean: Use acceleration hints? Choose Enable or Disable. 
Default = Disable

Interpolation String List: Set interpolation type. Choose between these 
values:

• Nearest neighbor

• Trilinear

Default = Nearest neighbor

Use lighting Boolean: Use lighting? Choose True or False. Default = False

Property Control Type: Values

Table 8-37: Volume Properties (Continued) 
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Voxel gradient Color: Color of the volume. Click to choose from the default 
color palette, or specify RGB values. 

Default = [0,0,0] (black)

Update Z Buffer Boolean: Update Z Buffer? Choose True or False. 

Default = True

Skip zero opacity Boolean: Skip zero opacity? Choose True or False. 

Default = True

Property Control Type: Values

Table 8-37: Volume Properties (Continued) 
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Isosurface

These properties control Isosurface object visualizations. For each property, the type 
of control and the values that can be assigned are listed. For a description of how a 
particular control is used, refer to Appendix B, “Property Controls”

Figure 8-21: Visualization Browser with Isosurface Properties Displayed

Property Control Type: Values

Color Color: Color to be used for the isosurface lines in this 
visualization. Click to choose from the default color palette, or 
specify RGB values. 

Default = [0,0,0] (black)

Linestyle Line Style: Style of the isosurface lines. Select a line style 
from the list. 

Default = No line

Thickness Line Thickness: Thickness of the isosurface lines in points. 
Select a thickness from the list. 

Default = 1

Table 8-38: Isosurface Properties
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Fill background Boolean: Fill background? Choose True or False.

Default = True

Fill color Color: Color to fill. Click to choose from the default color 
palette, or specify RGB values.

Default = [255,0,0] (red)

Transparency Number: Level of transparency.

Default = 0

Isovalue String: Edit isovalue.

Source color String List: Choose from the following:

• Isovalue selected (Volume color table)

• User selected (Fill Color Property)

Default = Isovalue selected (Volume color table)

Property Control Type: Values

Table 8-38: Isosurface Properties
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Interval Volume

These properties control interval volume object visualizations. For each property, the 
type of control and the values that can be assigned are listed. For a description of how 
a particular control is used, refer to Appendix B, “Property Controls”

Figure 8-22: Visualization Browser with Interval Volume Properties Displayed

Property Control Type: Values

Color Color: Color to be used for the interval volume lines in this 
visualization. Click to choose from the default color palette, or 
specify RGB values.

Default = [0,0,0] (black)

Linestyle Line Style: Style of the interval volume lines. Select a line 
style from the list. 

Default = No line

Thickness Line Thickness: Thickness of the interval volume lines in 
points. Select a thickness from the list. 

Default = 1

Table 8-39: Interval Volume Container Properties
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Fill background Boolean: Fill background? Choose True or False.

Default = True

Fill color Color: Color to fill. Click to choose from the default color 
palette, or specify RGB values.

Default = [255,0,0] (red)

Transparency Number: Level of transparency.

Default = 0

Isovalues String: Edit isovalue.

Source Color String List: Set source color. Choose from the following:

• Isovalue selected (Volume color table)

• User selected (Fill Color Property)

Default = Isovalue selected (Volume color table)

Property Control Type: Values

Table 8-39: Interval Volume Container Properties
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Image Plane

These properties control image plane object visualizations. For each property, the 
type of control and the values that can be assigned are listed. For a description of how 
a particular control is used, refer to Appendix B, “Property Controls”

Figure 8-23: Visualization Browser with Image Plane Properties Displayed

Property Control Type: Values

Opacity Control String List: Set opacity. Choose from the following:

• Use Opacity Table

• Opaque

• Opacity Value

Default = Use Opacity Table

Opacity Value Number: Factor from 0 - 100 determining the level of opacity. 
Move slider to change the size.

Default = 50

Table 8-40: Image Plane Container Properties
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Orientation Set orientation.

Default = X

Color Color: Color to be used for the image plane lines in this 
visualization. Click to choose from the default color palette, or 
specify RGB values.

Default = [255, 255, 255] (white)

Bottom color Color: Color to be used for the image plane bottom color in 
this visualization. Click to choose from the default color 
palette, or specify RGB values.

Default = [255, 255, 255] (white)

Linestyle Line Style: Style of lines used for constructing the surface. 
Select a style from the list. 

Default = (solid line)

Thickness Line Thickness: Thickness of lines used for constructing the 
surface. Select a thickness from the list. 

Default = 1

Style Style: Style of lines used. Choose from the following:

• Points

• Lines

• Filled

Default = Filled

Depth offset Number: Set depth offset value. Enter value. 

Default = 1

Remove hidden Boolean: Remove hidden? Choose True or False.

Default = False

Skip zero opacity Boolean: Skip zero opacity? Choose True or False.

Default = True

Property Control Type: Values

Table 8-40: Image Plane Container Properties
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Polygon rejection String List: Set polygon rejection color. Choose from the 
following:

• None

• Normals point away

• Normals point toward

Default = None

Shading String List: Shading method. Select a method from the list. 
Choose between these values:

• Flat: Flat shading

• Gouraud: Gouraud shading

Default = Flat

Texture 
interpolation

String List: Set texture interpolation type. Choose between 
these values:

• Nearest neighbor

• Bilinear

Default = Nearest neighbor

Property Control Type: Values

Table 8-40: Image Plane Container Properties
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Colorbar

These properties control colorbar object visualizations. For each property, the type of 
control and the values that can be assigned are listed. For a description of how a 
particular control is used, refer to Appendix B, “Property Controls”

Figure 8-24: Visualization Browser with Colorbar Properties Displayed

Property Control Type: Values

Border Boolean: Set border on or off. Choose True or False.

Default = False

Orientation Boolean: Set orientation of colorbar. Choose Horizontal or 
Vertical.

Default = Horizontal

Table 8-41: Colorbar Container Properties
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Color Color: Color to be used for the colorbar in this visualization. 
Click to choose from the default color palette, or specify RGB 
values. Default = [0,0,0] (black)

Line style Line Style: Style of the colorbar lines. Select a line style from 
the list. Default = (solid line)

Line thickness Line Thickness: Thickness of the colorbar lines in points. 
Select a thickness from the list. Default = 1

Number of major 
ticks

Number: Set number of major tick marks. Enter value. 

Default = 3

Number of minor 
ticks

Number: Set number of minor tick marks. Enter value. 

Default = 0

Major tick length Number: Factor from 0 - 1 determining major tick length. 
Move slider to change the size. 

Default = .05

Minor tick length Number: Factor from 0 - 1 determining minor tick length. 
Move slider to change the size.

Default = 1

Tick interval Number: Set tick interval. Enter value. 

Default = 0

Tick layout String List: Set tick layout type. Choose between these values:

• Axis plus labels

• Labels only

• Box style

Default = Axis plus labels

Tick direction String List: Set tick direction. Choose between these values:

• Right/Above

• Left/Below

Default = Right/Above

Property Control Type: Values

Table 8-41: Colorbar Container Properties
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Text show Boolean: Set text to show or not show. Choose True or False.

Default = True (show)

Text position String List: Set text position. Choose between these values:

• Below/left

• Above/right

Default = Below/left

Property Control Type: Values

Table 8-41: Colorbar Container Properties
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Tick format String List: Set tick format type. Choose from these values:

• None

• Use Tick Format Code

• Year

• Month(I)/Year

• Month(A)/Year

• Month(A);Year

• Month(I)/Day/Year

• Year/Month(I)/Day

• Month(I)/Day/Year;Hour:Min:Sec

• Year/Month(I)/Day;Hour:Min:Sec

• Month(A)

• Month(I)/Day

• Month(A);Day

• Day

• Day;Hour:Min:Sec

• Hour

• Hour:Min

• Hour:Min:Sec

• Hour:Min:Sec.00

• Min

• Min:Sec

• Min:Sec.00

• Sec

• Sec.00

Default = None

Title Title: Enter title for colorbar.

Default = RGB Table 0

Property Control Type: Values

Table 8-41: Colorbar Container Properties
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Text color Color: Color to be used for the legend text. Click to choose 
from the default color palette, or specify RGB values. Default 
= [0,0,0] (black)

Text font String List: Font used for legend text. Select a font from the 
list. Choose from these values:

• Helvetica

• Courier

• Times

• Symbol

• Hershey

Default = Helvetica

Text style String List: Style used for legend text. Select a style from the 
list. Choose from these values:

• Normal

• Bold

• Italic

• Bold italic

Default = Normal

Text font size Number: Font size in points for the legend text. Edit the 
number to change the size. Default = 12

Property Control Type: Values

Table 8-41: Colorbar Container Properties
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Histogram

These properties control histogram object visualizations. For each property, the type 
of control and the values that can be assigned are listed. For a description of how a 

Figure 8-25: Visualization Browser with Histogram Properties Displayed
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particular control is used, refer to Appendix B, “Property Controls”

Property Control Type: Values

Vertex Colors 
Color Table

Color: By selecting Edit Color → Table Edit access the 
color table to manipulate plot color values

Histogram binsize Number: Set histogram binsize. 

Default = 1

Color Color: Color to be used for the plot lines. RGB values are 
assigned or you may edit your color. 

Default = varies

Line style Line Style: Style of the colorbar lines. Select a line style from 
the list. 

Default = (solid line)

Table 8-42: Histogram Container Properties
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Thickness Line Thickness: Thickness of the colorbar lines in points. 
Select a thickness from the list. 

Default = 1

Minimum value Number: Minimum histogram value. Enter a number. 

Default = varies

Maximum value Number: Maximum histogram value. Enter a number. 

Default = varies

Histogram plot Boolean: Set histogram to show or not show. Choose True or 
False.

Default = True (show)

Number of points 
to average

Number: Number of points in plot to be averaged. Enter a 
number. 

Default = 1

Polar plot Boolean: Set histogram to show or not show as a polar plot. 
Choose True or False.

Default = False (hide)

Fill plot Boolean: Set histogram to show or not show as a filled plot. 
Choose True or False.

Default = False (hide)

Fill level Number: Level to fill if fill plot is selected. Enter a number. 

Default = varies

Fill color Color: Color to be used for fill plot if selected. 

Default = [128, 128, 128] (grey)

Fill transparency Number: Value of transparency if fill plot is selected. Enter a 
number. 

Default = 0

Property Control Type: Values

Table 8-42: Histogram Container Properties
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Symbol String List: Font used for legend text. Select a font from the 
list. Choose from the list of symbols.

Default = No symbol

Symbol size Number: Value for symbol size in points if fill symbol is 
selected. Enter a number. 

Default = 0.2

Use default color Boolean: Set to use default color for symbols. Choose True or 
False.

Default = True (use default color)

Symbol color Color: Color to be used for symbols if default color is set to 
False. Enter a value.

Default = varies

Symbol thickness Number: Value for symbol thickness in points if symbol is 
selected. Enter a number.

Default = 1

Symbol 
increment

Number: Value for symbol increments if fill symbol is 
selected. Enter a number. 

Default = 1

Property Control Type: Values

Table 8-42: Histogram Container Properties
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Axes

These properties control axis object visualizations. For each property, the type of 
control and the values that can be assigned are listed. For a description of how a 
particular control is used, refer to Appendix B, “Property Controls”

Figure 8-26: Visualization Browser with Axis Properties Displayed
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The following table contains the properties that control the Container for the 
visualization axes.

Property Control Type: Values

Style String List: Select display style for axes. Choose from these 
values:

• None: Do not display axes.

• At Dataspace Minimum: Display 2 axes for 2-D 
visualization, 3 axes for 3-D visualization.

• Box Axes: Display 4 axes for 2-D visualization, 12 axes 
for 3-D visualization.

• Crosshairs: Display crosshair style axes.

Default = At Dataspace Minimum

Color Color: Color to be used for the axis lines in this visualization. 
Click to choose from the default color palette, or specify RGB 
values. Default = [0,0,0] (black)

Line style Line Style: Style of the axis tick lines. Select a line style from 
the list. Default = (solid line)

Line thickness Line Thickness: Thickness of the axis tick lines. Select a 
thickness from the list. Default = 1

Number of major 
ticks

Number: Set number of major tick marks. Enter value. 

Default = 0

Number of minor 
ticks

Number: Set number of minor tick marks. Enter value. 

Default = 0

Major Tick 
Length

Number: Normalized length of major tick marks for all axes 
from 0 (no ticks) to 1 (major tick marks span the 
visualization). Move the slider to change the value. Default = 
0.05.

Table 8-43: Axes Container Properties
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Minor tick length Number: Relative length of minor tick marks for all axes from 
-1 (minor tick marks extend the length of major tick marks on 
left side of axes) to 1 (minor tick marks extend same length as 
major tick marks on right side of axes). Move the slider to 
change the value. Default = 0.5 (Minor tick marks extend 
one-half the length of major tick marks on right side of axes).

Tick interval Number: Interval between ticks. Edit the number to change the 
value. Default = 0

Tick layout String List: Select layout style for major and minor tick 
visualization on all axes. Choose from these values:

• Axis plus labels: Display tick labels and marks.

• Labels only: Display tick labels only (no tick marks).

• Box style: Display tick labels and marks, with labels 
enclosed in boxes.

Default = Axis plus labels

Tick direction String List: Select a direction for tick marks. Choose from 
these values:

• Right/Above: Place tick marks to the right of or above the 
axis line.

• Left/Below: Place text to the left of or below the axis line.

Default = Right/Above

Text show Boolean: Set text to show or not show. Choose True or False.

Default = True (show)

Text position String List: Select a position for tick and label text. Choose 
from these values:

• Below/left: Place text below or to the left of the axis line.

• Above/right: Place text above or to the right of the axis 
line.

Default = Below/left

Property Control Type: Values

Table 8-43: Axes Container Properties
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Tick format String List: Choose a format code or time interval to use for 
each tick interval. Choose from these:

• None

• Use Tick Format Code

• Year

• Month(I)/Year

• Month(A)/Year

• Month(A);Year

• Month(I)/Day/Year

• Year/Month(I)/Day

• Month(I)/Day/Year;Hour:Min:Sec

• Year/Month(I)/Day;Hour:Min:Sec

• Month(A)

• Month(I)/Day

• Month(A);Day

• Day

• Day;Hour:Min:Sec

• Hour

• Hour:Min

• Hour:Min:Sec

• Hour:Min:Sec.00

• Min

• Min:Sec

• Min:Sec.00

• Sec

• Sec.00

Default = None

Title String: Title to apply to all axes for this visualization. Enter 
title text for the axes. No default value.

Property Control Type: Values

Table 8-43: Axes Container Properties
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This table contains the properties that control axis visualization X, Y, or (for three-
dimensional visualizations) Z. For each property, the type of control and the values 

Text color Color: Color to be used for the text. Click to choose from the 
default color palette, or specify RGB values. 

Default = [0,0,0] (black)

Text font String List: Font used for tick and label text. Select a font from 
the list. Choose from these values:

• Helvetica

• Courier

• Times

• Symbol

• Hershey

Default = Helvetica

Text style String List: Style used for tick and label text. Select a style 
from the list. Choose from these values:

• Normal

• Bold

• Italic

• Bold italic

Default = Normal

Text font size Number: Font size in points for the tick and label text. 
Edit the number to change the size. Default = 12

Property Control Type: Values

Table 8-43: Axes Container Properties
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that can be assigned are listed. For a description of how a particular control is used, 
refer to Appendix B, “Property Controls”.

Property Control Type: Values

Color Color: Color to be used for the axis line. Click to choose from 
the default color palette, or specify RGB values. Default = 
[0,0,0] (black)

Line style Line Style: Style of the axis tick lines. Select a line style from 
the list. Default = (solid line)

Line thickness Line Thickness: Thickness of the axis tick lines in points. 
Select a thickness from the list. Default = 1

Number of major 
ticks

Number: Number of major ticks marks to display along the 
axis. Edit the number to change the value. Default = 5

Number of minor 
ticks

Number: Number of minor ticks to display between major 
ticks. Edit the number to change the value. Default = 3

Major tick length Number: Normalized length of major tick marks for this axis 
from 0 (no ticks) to 1 (major tick marks span the 
visualization). Move the slider to change the value. Default = 
0.05

Minor tick length Number: Relative length of minor tick marks for this axis from 
-1 (minor tick marks extend the length of major tick marks on 
left side of axis) to 1 (minor tick marks extend same length as 
major tick marks on right side of axis). Move the slider to 
change the value. Default = 0.5 (Minor tick marks extend 
one-half the length of major tick marks on right side of axis).

Tick interval Number: Interval between major tick marks. Edit the number 
to change the value. Default = 0 (use the default interval for 
the specified range)

Table 8-44: Property Settings for Individual Axes
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Tick layout String List: Select layout style for major and minor tick 
visualization. Choose from these values:

• Axis plus labels: Display tick labels and marks.

• Labels only: Display tick labels only (no tick marks).

• Box style: Display tick labels and marks, with labels 
enclosed in boxes.

Default = Axis plus labels

Tick direction String List: Select a direction for tick marks. Choose from 
these values:

• Right/Above: Place tick marks to the right of or above the 
axis line.

• Left/Below: Place text to the left of or below the axis line.

Default = Right/Above

Text show Boolean: Show tick and label text? Choose True or False. 
Default = True.

Text position String List: Select a position for tick and label text. Choose 
from these values:

• Below/left: Place text below or to the left of the axis line.

• Above/right: Place text above or to the right of the axis 
line.

Default = Below/left

Property Control Type: Values

Table 8-44: Property Settings for Individual Axes (Continued) 
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Tick format String List: Choose a format code or time interval to use for 
each tick interval. Choose from these:

• None

• Use Tick Format Code

• Year

• Month(I)/Year

• Month(A)/Year

• Month(A);Year

• Month(I)/Day/Year

• Year/Month(I)/Day

• Month(I)/Day/Year;Hour:Min:Sec

• Year/Month(I)/Day;Hour:Min:Sec

• Month(A)

• Month(I)/Day

• Month(A);Day

• Day

• Day;Hour:Min:Sec

• Hour

• Hour:Min

• Hour:Min:Sec

• Hour:Min:Sec.00

• Min

• Min:Sec

• Min:Sec.00

• Sec

• Sec.00

Default = None

Title String: Title to apply to this axis. Enter title text for the axes. 
No default value.

Property Control Type: Values

Table 8-44: Property Settings for Individual Axes (Continued) 
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Text color Color: Color to be used for the text. Click to choose from the 
default color palette, or specify RGB values. Default = 
[0,0,0] (black) 

Text font String List: Font used for tick and label text. Select a font from 
the list. Choose from these values:

• Helvetica

• Courier

• Times

• Symbol

• Hershey

Default = Helvetica

Text style String List: Style used for tick and label text. Select a style 
from the list. Choose from these values:

• Normal

• Bold

• Italic

• Bold italic

Default = Normal

Text font size Number: Font size in points for the tick and label text. Edit 
the number to change the size. Default = 12

Property Control Type: Values

Table 8-44: Property Settings for Individual Axes (Continued) 
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Lights

Lights properties control the lighting of the data space. These properties are available 
only for 3-D Surface and Volume visualizations. 

Three types of lights can be configured through the Lights properties: Ambient Light, 
Light 1 (from above), and Light 2 (from below). Each type of light has the same set of 
properties, as described in Table 8-45.

Figure 8-27: Visualization Browser with Light Properties Displayed
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For each property, the type of control and the values that can be assigned are listed. 
For a description of how a particular control is used, refer to Appendix B, “Property 
Controls”.

Property Control Type: Values

Type String List: Type of light source for this light. Select a type of 
light from the list. Choose from these options:

• Ambient: Universal light source with no direction or 
position. An ambient light illuminates every surface in the 
scene equally, which means that no edges are made visible 
by contrast. Ambient light controls the overall brightness 
and color of the scene.

• Positional: Supplies divergent light rays so that the edges 
of surfaces can be made visible by contrast. A positional 
light source can be located anywhere in the scene.

• Directional: Supplies parallel light rays from a light 
source located at an infinite distance from scene.

• Spotlight: Illuminates only a specific area defined by the 
light's position, direction, and the cone angle (angle the 
spotlight covers).

Default = Positional

Distance Number: Distance of the light source from the visualization 
from -1 (in front of the visualization) to 1 (behind the 
visualization). Move the slider to change the value. 
Default = -1 for Ambient Light and Light 1, 1 for Light 2

Intensity Number: Intensity of this light from 0 (no light) to 1 (bright 
light). Move the slider to change the value. Default = 0.5 for 
Ambient Light, 0.8 for Light 1 and Light 2

Color Color: Color of this light. Click to choose from the default 
color palette, or specify RGB values. Default = 
[255,255,255] (white) 

Cone angle Number: Angle the spotlight covers from 0º to 180º. Active 
only when Spotlight type is selected. Move the slider to 
change the value. Default = 60

Table 8-45: Property Settings for Lights
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Focus attenuation Number: Floating-point value from 0 to 128 that attenuates the 
intensity of spotlights as the distance from the center of the 
cone of coverage increases. This factor is used as an exponent 
to the cosine of the angle between the direction of the spotlight 
and the direction from the light to the vertex being lighted. 
Active only when Spotlight type is selected. Move the slider to 
change the value. Default = 0

Property Control Type: Values

Table 8-45: Property Settings for Lights (Continued) 
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Polygonal ROI

These properties control polygonal ROI object visualizations. For each property, the 
type of control and the values that can be assigned are listed. For a description of how 
a particular control is used, refer to Appendix B, “Property Controls”

Figure 8-28: Visualization Browser with Polygon ROI Properties Displayed

Property Control Type: Values

Color Color: Color to be used for the line. Click to choose from the 
default color palette, or specify RGB values. Default = 
[0,0,0] (black)

Linestyle Line Style: Style of the polygon lines. Select a line style from 
the list. Default = (solid line)

Thickness Line Thickness: Thickness of the polygon lines in points. 
Select a thickness from the list. Default = 1

Fill background Boolean: Fill background? Choose True or False.

Default = True

Table 8-46: Property Settings for Polygonal ROI
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Fill color Color: Color to fill. Click to choose from the default color 
palette, or specify RGB values.

Default = [255,255, 255] (white)

Transparency Number: Level of transparency.

Default = 0

Property Control Type: Values

Table 8-46: Property Settings for Polygonal ROI
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IDL Graphics Objects

You can import an IDL graphics object into an iTool and display it directly by 
selecting the “IDL Graphics Object” visualization type. The properties available will 
depend on the type of graphics object. See the properties listing for the specific 
graphics object in the IDL Reference Guide for details.

Note
The behavior of IDL graphics objects imported into an iTool may not be the same as 
that of the corresponding iTool visualization. While importing an existing graphics 
object into an iTool will often work, you will generally obtain better results using an 
iTool visualization type.

Tip
In order to display properties for a generic IDL graphics object in the iTool property 
sheet interface, the graphics object must have been created with the 
REGISTER_PROPERTIES keyword set. If no properties are registered, only the 
three standard iTool properties (Name, Description, and Show) will be present, as 
displayed in the previous figure.

Figure 8-29: Visualization Browser with 
IDL Graphics Object Properties Displayed.
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2D Annotation Layer Properties

The following types of annotations can be added to iTool visualizations: Text, Line, 
Line Profile, Rectangle, Oval, Polygon, and Freehand annotations. The following 
table contains properties that control the Annotation layer. Subsequent tables describe 
the properties specific to each type of annotation.

Figure 8-30: Visualization Browser with Annotation Properties Displayed

Property Control Type: Values

Background color Color: Color to be used for the Annotation Layer background. 
For background to display, Transparent property must be set to 
False. Click to choose from the default color palette, or 
specify RGB values. Default = [255,255,255] (white)

Transparent Boolean: Make the annotation layer transparent? Choose True 
or False. Default = True.

Table 8-47: Annotation Layer Properties
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Text Annotation Properties

These properties control text annotation visualizations. For each property, the type of 
control and the values that can be assigned are listed. For a description of how a 
particular control is used, refer to Appendix B, “Property Controls”.

Property Control Type: Values

Text string String: Text that appears in the annotation. Edit to change the 
text, or to add formatting commands such as the following: 

• !C: Add new line.

• !U: Add superscript characters.

• !D: Add subscript characters.

• !N: Return to normal characters.

For a complete list of embedded text formatting commands, 
refer to “Embedded Formatting Commands” in Appendix H of 
the IDL Reference Guide. No default value.

Horizontal 
alignment

String List: Horizontal alignment of multiple lines within text 
box. Choose from these values:

• Left: Align text along the left border of the text box.

• Center: Align text in the center of the text box.

• Right: Align text along the right border of the text box.

Default = Left

Color Color: Color to be used for the text. Click to choose from the 
default color palette, or specify RGB values. Default = 
[0,0,0] (black)

Fill background Boolean: Fill the background of the text with the background 
color? Choose True or False. Default = False

Transparency Number: Transparency of the text annotation from 0% to 
100%. Move the slider to change the value. Default = 0

Table 8-48: Text Annotation Properties
iTool User’s Guide 2D Annotation Layer Properties



334  
Text font String List: Font used for text annotation. Select a font from 
the list. Choose from these values:

• Helvetica

• Courier

• Times

• Symbol

• Hershey

Default = Helvetica

Text style String List: Style used for text annotation. Select a style from 
the list. Choose from these values:

• Normal

• Bold

• Italic

• Bold italic

Default = Normal

Text font size Number: Font size in points for the text annotation. Edit 
the number to change the size. Default = 12

Property Control Type: Values

Table 8-48: Text Annotation Properties (Continued) 
2D Annotation Layer Properties iTool User’s Guide



 335
Line Annotation Properties

These properties control line annotation visualizations. For each property, the type of 
control and the values that can be assigned are listed. For a description of how a 
particular control is used, refer to Appendix B, “Property Controls”.

Property Control Type: Values

Color Color: Color to be used for the line. Click to choose from the 
default color palette, or specify RGB values. Default = 
[0,0,0] (black)

Linestyle Line Style: Style of the line annotation. Select a line style from 
the list. Default = (solid line)

Thickness Line Thickness: Thickness of the line annotation in points. 
Select a thickness from the list. Default = 1

Arrow style Arrow Style Selector: Select an arrow style from the list. 
Choose from these values:

Default =  (no arrow)

Arrowhead size Number: Size of arrowhead in normalized units. Arrow 
style must be selected for arrowhead to display. Move the 
slider to change the value. Default = 0.05

Table 8-49: Line Annotation Properties
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Line Profile Annotation Properties

These properties control line profile annotation visualizations. For each property, the 
type of control and the values that can be assigned are listed. For a description of how 
a particular control is used, refer to Appendix B, “Property Controls”

Property Control Type: Values

Vertex Colors 
Color Table

User Defined: By selecting Edit Color → Table Edit access 
the color table to manipulate plot color values

Color Color: Color to be used for the line. Click to choose from the 
default color palette, or specify RGB values. Default = 
[0,0,0] (black)

Line style Line Style: Style of the line profile annotation. Select a line 
style from the list. Default = (solid line)

Table 8-50: Line Profile Annotation Properties
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Thickness Line Thickness: Thickness of the line profile annotation in 
points. Select a thickness from the list. Default = 1

Minimum value Number: Minimum value for line profile. Edit number to 
change value. No default value.

Maximum value Number: Maximum value for line profile.Edit number to 
change value. No default value.

Histogram plot Boolean: Show line profile as a histogram plot? Choose True 
or False. 

Default = False

Number of points 
to average

Number: Set number of points to average. Enter a value. 

Default = 1

Polar plot Boolean: Show line profile as a polar plot? Choose True or 
False. 

Default = False

Fill plot Boolean: Fill plot? Choose True or False. 

Default = False

Fill level Number: Set level to fill. Enter value.

Default = 71

Fill color Color: Color used for fill. For color to display, Fill Plot 
property must be set to True. Click to choose from the default 
color palette, or specify RGB values. 

Default = [255,255,255] (white)

Fill transparency Number: Transparency of the plot fill from 0% to 100%. Move 
the slider to change the value. Default = 0

Symbol Symbol: Symbol to appear at regular intervals on the plot line. 
Choose a symbol from the list. Default = No symbol

Symbol size Number: Factor from 0 - 1 determining the size of the selected 
symbol. Move slider to change the size. Default = 0.2

Property Control Type: Values

Table 8-50: Line Profile Annotation Properties
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Use default color Boolean: Activate Symbol color property. Choose True or 
False. Default = False

Symbol color Color: Color for the selected symbol. Click to choose from the 
default color palette, or specify RGB values. Default = 
[0,0,0] (black)

Symbol thickness Number: Line thickness from 1 - 9.9 for the selected symbol. 
Move slider to change the thickness. Default = 1.

Symbol 
increment

Number: Interval at which symbols will be displayed on the 
plot line. Influenced by Number of points to average (above). 
Edit to change the value. Default = 1

Property Control Type: Values

Table 8-50: Line Profile Annotation Properties
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Rectangle Annotation Properties

These properties control rectangle annotation visualizations. For each property, the 
type of control and the values that can be assigned are listed. For a description of how 
a particular control is used, refer to Appendix B, “Property Controls”.

Property Control Type: Values

Color Color: Color to be used for the rectangle outline. Click to 
choose from the default color palette, or specify RGB values. 
Default = [0,0,0] (black)

Linestyle Line Style: Style of the rectangle outline. Select a line style 
from the list. 

Default = (solid line)

Thickness Line Thickness: Thickness of the rectangle outline in points. 
Select a thickness from the list. 

Default = 1

Fill background Boolean: Fill rectangle background? Choose True or False. 
Default = True

Fill color Color: Color to be used for the background. For background 
color to display, Fill Background property must be set to True. 
Click to choose from the default color palette, or specify RGB 
values. 

Default = [255,255,255] (white) 

Transparency Number: Transparency of the rectangle background fill 
from 0% to 100%. Move the slider to change the value. 
Default = 0

Table 8-51: Rectangle Annotation Properties
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Oval Annotation Properties

These properties control oval annotation visualizations. For each property, the type of 
control and the values that can be assigned are listed. For a description of how a 
particular control is used, refer to Appendix B, “Property Controls”.

Property Control Type: Values

Color Color: Color to be used for the oval outline. Click to choose 
from the default color palette, or specify RGB values. Default 
= [0,0,0] (black)

Linestyle Line Style: Style of the oval outline. Select a line style from 
the list. Default = (solid line)

Thickness Line Thickness: Thickness of the oval outline in points. Select 
a thickness from the list. Default = 1

Fill background Boolean: Fill oval background? Choose True or False. 
Default = True

Fill color Color: Color to be used for the background. For background 
color to display, Fill Background property must be set to True. 
Click to choose from the default color palette, or specify RGB 
values. Default = [255,255,255] (white) 

Transparency Number: Transparency of the oval background fill from 
0% to 100%. Move the slider to change the value. 
Default = 0

Table 8-52: Oval Annotation Properties
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Polygon Annotation Properties

These properties control polygon annotation visualizations. For each property, the 
type of control and the values that can be assigned are listed. For a description of how 
a particular control is used, refer to Appendix B, “Property Controls”.

Property Control Type: Values

Color Color: Color to be used for the polygon outline. Click to 
choose from the default color palette, or specify RGB values. 
Default = [0,0,0] (black)

Linestyle Line Style: Style of the polygon outline. Select a line style 
from the list. Default = (solid line)

Thickness Line Thickness: Thickness of the polygon outline in points. 
Select a thickness from the list. Default = 1

Fill background Boolean: Fill polygon background? Choose True or False. 
Default = True

Fill color Color: Color to be used for the background. For background 
color to display, Fill Background property must be set to True. 
Click to choose from the default color palette, or specify RGB 
values. Default = [255,255,255] (white) 

Transparency Number: Transparency of the polygon background fill 
from 0% to 100%. Move the slider to change the value. 
Default = 0

Table 8-53: Polygon Annotation Properties
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Freehand Annotation Properties

These properties control freehand annotation visualizations. For each property, the 
type of control and the values that can be assigned are listed. For a description of how 
a particular control is used, refer to Appendix B, “Property Controls”.

Property Control Type: Values

Color Color: Color to be used for the freehand shape outline. Click to 
choose from the default color palette, or specify RGB values. 
Default = [0,0,0] (black)

Linestyle Line Style: Style of the freehand shape outline. Select a line 
style from the list. Default = (solid line)

Thickness Line Thickness: Thickness of the freehand shape outline in 
points. Select a thickness from the list. Default = 1

Fill background Boolean: Fill freehand shape background. Choose True or 
False. Default = True

Fill color Color: Color to be used for the background. For background 
color to display, Fill Background property must be set to True. 
Click to choose from the default color palette, or specify RGB 
values. Default = [255,255,255] (white) 

Transparency Number: Transparency of the freehand background fill 
from 0% to 100%. Move the slider to change the value. 
Default = 0

Table 8-54: Freehand Annotation Properties
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Legend Properties

These properties control legend annotations. For each property, the type of control 
and the values that can be assigned are listed. For a description of how a particular 
control is used, refer to Appendix B, “Property Controls”.

Note
This section discusses the properties of the legend container, which can contain 
multiple legend items of different types. The individual legend types are described 
in:

“Legend Contour Items” on page 347
“Legend Contour Level Items” on page 348
“Legend Plot Items” on page 349
“Legend Surface Items” on page 350

Figure 8-31: Visualization Browser with Legend Properties Displayed
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Property Control Type: Values

Location String List: Position of the legend within the iTool window. 
Select a location from the list. Choose from these values:

• Top Right

• User Specified

• Top Left

• Top Center

• Bottom Left

• Bottom Center

• Bottom Right

Default = Top Right

Layout String List: Arrange the legend elements in columns or rows. 
Select a layout from the list. Choose from these values:

• Columns

• Rows

Default = Columns

Sample width Number: Width in normalized units of the element sample that 
appears in the legend box. Range = 0.0 to 0.5. Move the 
slider to change the value. Default = 0.15

Horizontal 
spacing

Number: Space in normalized units between samples and text 
in the legend box. Range = 0.0 to 0.25. Move the slider to 
change the value. Default = 0.02

Vertical spacing Number: Space in normalized units between lines in the 
legend box. Move the slider to change the value. Default = 
0.02

Text color Color: Color to be used for the legend text. Click to choose 
from the default color palette, or specify RGB values. Default 
= [0,0,0] (black)

Table 8-55: Legend Properties
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Text font String List: Font used for legend text. Select a font from the 
list. Choose from these values:

• Helvetica

• Courier

• Times

• Symbol

• Hershey

Default = Helvetica

Text style String List: Style used for legend text. Select a style from the 
list. Choose from these values:

• Normal

• Bold

• Italic

• Bold italic

Default = Normal

Text font size Number: Font size in points for the legend text. Edit the 
number to change the size. Default = 10

Color Color: Color to use for the legend border. Legend object must 
be deselected for border attributes to be visible. Click to 
choose from the default color palette, or specify RGB values. 
Default = [0,0,0] (black)

Linestyle Line Style: Style of the legend border. Select a line style from 
the list. Default = (solid line)

Thickness Line Thickness: Thickness of the legend border in points. 
Select a thickness from the list. Default = 1

Fill background Boolean: Fill legend background? Choose True or False. 
Default = True

Property Control Type: Values

Table 8-55: Legend Properties (Continued) 
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Fill color Color: Color to be used for the background. For background 
color to display, Fill Background property must be set to True. 
Click to choose from the default color palette, or specify RGB 
values. Default = [255,255,255] (white) 

Transparency Number: Transparency of the background fill from 0% to 
100% Move the slider to change the value. Default = 0%

Property Control Type: Values

Table 8-55: Legend Properties (Continued) 
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Legend Contour Items 

The following are properties of the top-level Contour legend item. For a description 
of how a particular control is used, refer to Appendix B, “Property Controls”.

Property Control Type: Values

Show Levels Boolean: Show contour levels in the legend. Choose True 
or False. Default = True

Text String: Text that labels the contour object in the legend.

Text color Color: Color to be used for the legend text. Click to choose 
from the default color palette, or specify RGB values. Default 
= [0,0,0] (black)

Text font String List: Font used for legend text. Select a font from the 
list. Choose from these values:

• Helvetica

• Courier

• Times

• Symbol

• Hershey

Default = Helvetica

Text style String List: Style used for legend text. Select a style from the 
list. Choose from these values:

• Normal

• Bold

• Italic

• Bold italic

Default = Normal

Text font size Number: Font size in points for the legend text. Edit the 
number to change the size. Default = 12

Table 8-56: Contour Legend Properties
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Legend Contour Level Items 

The following are properties of individual Contour level legend items. For a 
description of how a particular control is used, refer to Appendix B, “Property 
Controls”

Property Control Type: Values

Text String: Text that labels the contour object in the legend.

Text color Color: Color to be used for the legend text. Click to choose 
from the default color palette, or specify RGB values. Default 
= [0,0,0] (black)

Text font String List: Font used for legend text. Select a font from the 
list. Choose from these values:

• Helvetica

• Courier

• Times

• Symbol

• Hershey

Default = Helvetica

Text style String List: Style used for legend text. Select a style from the 
list. Choose from these values:

• Normal

• Bold

• Italic

• Bold italic

Default = Normal

Text font size Number: Font size in points for the legend text. Edit the 
number to change the size. Default = 12

Table 8-57: Contour Level Legend Properties
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Legend Plot Items 

The following are properties of Plot legend items. For a description of how a 
particular control is used, refer to Appendix B, “Property Controls”.

Property Control Type: Values

Text String: Text that labels the plot object in the legend.

Text color Color: Color to be used for the legend text. Click to choose 
from the default color palette, or specify RGB values. Default 
= [0,0,0] (black)

Text font String List: Font used for legend text. Select a font from the 
list. Choose from these values:

• Helvetica

• Courier

• Times

• Symbol

• Hershey

Default = Helvetica

Text style String List: Style used for legend text. Select a style from the 
list. Choose from these values:

• Normal

• Bold

• Italic

• Bold italic

Default = Normal

Text font size Number: Font size in points for the legend text. Edit the 
number to change the size. Default = 12

Table 8-58: Plot Legend Properties
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Legend Surface Items 

The following are properties of individual Surface legend items. For a description of 
how a particular control is used, refer to Appendix B, “Property Controls”.

Property Control Type: Values

Text String: Text that labels the surface object in the legend.

Text color Color: Color to be used for the legend text. Click to choose 
from the default color palette, or specify RGB values. Default 
= [0,0,0] (black)

Text font String List: Font used for legend text. Select a font from the 
list. Choose from these values:

• Helvetica

• Courier

• Times

• Symbol

• Hershey

Default = Helvetica

Text style String List: Style used for legend text. Select a style from the 
list. Choose from these values:

• Normal

• Bold

• Italic

• Bold italic

Default = Normal

Text font size Number: Font size in points for the legend text. Edit the 
number to change the size. Default = 12

Table 8-59: Surface Legend Properties
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byte ordering
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files (continued)
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iTools (continued)
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plots (continued)
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volumes
adding a colorbar to, 216
adding a histogram to, 226
adding an axis to, 217
adding statistics to, 226
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displaying, 211
displaying multi-channel, 211
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