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Hyperion Enterprise Reporting Windows 
Client User’s Guide Purpose

This guide provides you with all the information you need to understand the basic 
functions and purpose of Hyperion Enterprise Reporting Windows Client. It 
explains all of Hyperion Enterprise Reporting Windows Client’s features and 
options, and contains the concepts, processes, procedures, formats, tasks, and 
examples you need to use the software. 

Audience
This guide is for analysts who use Hyperion Enterprise Reporting Windows Client 
with other Hyperion products, such as Hyperion Enterprise™ at their site.

Related Documentation
Hyperion Solutions provides the following documentation for this product:

� Hyperion Enterprise Reporting Windows Client Getting Started Guide

� Hyperion Enterprise Reporting Windows Client User’s Guide

� Hyperion Enterprise Reporting Windows Client Help

The following documents contain additional related information: 

� Hyperion Enterprise User’s Guide, for more information about Hyperion 
Enterprise.

� Hyperion Essbase Database Administrator’s Guide, for more information 
about Hyperion Essbase.

Preface
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Using Online Help

➤ To access online Help, select Help > Contents in Hyperion Enterprise Reporting 
Windows Client.

➤ To print an online Help topic, display the topic and select File > Print.

Using Online Guides
The online guides are an electronic version of the printed documentation.

➤ To display an online guide, do one of the following:

� Select Help > Online Guides (PDFs) > name of guide in Hyperion Enterprise 
Reporting Windows Client where name of guide is the actual title of the guide.

� Select Help > name of guide in Hyperion Enterprise Reporting Windows 
Client Help where name of guide is the actual title of the guide.

Conventions
The following table shows the conventions used in this document.

Table i: Conventions Used in This Document 

Item Meaning

➤ Arrows indicate the beginning of a procedure, which 
consists of one or more sequential steps.

Square Brackets [ ] In examples, square brackets indicates that the 
enclosed elements are optional.

Braces {} In examples, braces are used for grouping elements 
together.

Bold Boldface text indicates words or characters that you 
type exactly as they appear on the page or menu 
commands and selections shown in procedures.
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Additional Support
In addition to using the documentation and online Help, Hyperion Solutions offers 
the following additional support for product information.

CAPITAL LETTERS Capital letters denote file names, functions, DOS 
commands, and various IDs. For example, the text 
might refer to the GDC.INI file.

Example text Text shown in this font indicates that the material 
shown is an example for your use.

Ctrl + 0 Keystroke combinations indicate that you should press 
the keys simultaneously (yet still somewhat 
sequentially) as shown.

Italics Italic text indicates a variable field in command 
syntax. Substitute your own values in place of the 
variable shown in italics.

Ellipses Use of an ellipses indicates an omission of irrelevant 
material, which is typically used in an example to 
show only the relevant material.

Mouse orientation This document provides examples and procedures 
using a right-handed mouse. If you are using a 
left-handed mouse, adjust the procedures accordingly.

Menu commands Menu commands are presented in the following 
format:
Menu name > Menu command > Extended menu 
command 
For example:   File > Desktop > Accounts.

n, x The variable n indicates that you must supply a 
generic number; the variable x indicates that you must 
supply a generic letter. 

icons For documents using special icons, list them and 
define them here.

Table i: Conventions Used in This Document (Continued)

Item Meaning
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Ordering Documentation
Additional copies of printed documentation may be ordered through your local 
support office.

Training Services
Hyperion Solutions offers two avenues for classroom training: direct training by 
Hyperion’s own professional training staff, available for all Hyperion products, 
and through partner-owned authorized training centers for selected courses and 
partner-developed courses.

Hyperion Solutions provides training geared to end users, administrators, and IS 
professionals. Classroom training is delivered in the formats and locations needed 
by Hyperion’s diverse, global customers. Custom training, training on the 
configured and tailored applications that employees will use on the job, is another 
option to enhance user productivity and ensure smooth day-to-day operations.

Hyperion offers multimedia training in a variety of formats for selected products 
and topics, and new programs are always in development. Several of our end user 
training courses are available as computer-based training (CBT) courses, which 
provides a cost-effective means of giving users a hands-on introduction to product 
features and functions.   In addition, we offer videotape- and CD-ROM- based 
training as a source of skills enhancement beyond basic user training, again for 
selected products and topics. CBT and multimedia provide high-quality interactive 
training at the end user’s convenience, regardless of location. For more information 
about training, contact your local support office.

Consulting Services
The company’s consulting services are globally coordinated, with a regional focus. 
Hyperion Solutions’ Consulting Services provides design review, project 
management, implementation, technical, and additional support across the full 
product line. Consulting services are also available from our Hyperion Alliance 
Partners, and information about these services can be found on the Hyperion 
Solutions Web site (www.hyperion.com). For more information, please contact 
your local support office.
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Technical Support
Telephone and Web-based support are provided to ensure clients resolve any 
product issues quickly and accurately. It is available for all Hyperion products at 
no additional cost to all clients with a current maintenance agreement. Additional 
support is available for clients with 7x24 coverage needs or global requirements 
that include multiple languages and time zones. For more information, contact 
your local support office.

Support and Services Page on the Web
Detailed information about Hyperion’s service and support programs may be 
found on our secured Web site for clients, the Support and Services Page. The site 
offers a vast array of service and support information, including an in-depth 
Service & Support Guide, product news and updates, training schedules and online 
enrollment forms, documentation information, key contacts, downloadable 
patches, release notes, installation instructions, technical support information and 
online submission forms, user forms, product modification request listings and 
lookups, product help, user group meetings, committee meeting minutes and 
schedules, and a User Forum. To find out how to register for access to the site, 
contact your local support office. 
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Customizing Your Desktop 

You can customize the point of view bar, formula bar, and the dimension icons for 
your report and book windows on your Hyperion Enterprise Reporting Windows 
Client Desktop.

Customize Dimensions

You can customize dimensions as follows:

� Specify the name or description for dimensions that appear in the menu 
options, status bar, and tool tips for the point of view and formula bar. You can 
also specify the name or description for the point of view dialog box tabs.

� Change the icon or use a custom icon for dimensions that appear in the point 
of view and formula bar.

When you manage dimensions to customize Hyperion Enterprise Reporting 
Windows Client, any changes that you make apply to your user ID only. Your 
custom settings remain in effect until you change them. For example, if you use a 
custom icon for the entity dimension, the next time you start Hyperion Enterprise 
Reporting Windows Client, that entity dimension’s custom icon appears. 

The recommended size for a custom icon is 16 x 16 pixels, and the recommended 
background is RGB (192,192,192). If you are using a custom icon, you must 
update the [Product-Server-Application Set-Application] section in your 
REPENG.INI file as follows:

Applies To:

1
Chapter
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[Product-Server-ApplicationSet-Application]

DimensionCustomBitmap_xxx = e:\newicon.bmp

Note: The syntax is not case sensitive.

➤ To customize a dimension:

1. From a report or book window, select Task > Customize Dimensions.

2. Select a dimension from the dimension list and do one of the following:

� To change the dimension icon to the default, click Default Icon.

� To change the icon, select an icon or specify the name of a custom icon. 

Note: The custom icon must remain in the directory you specify.

� To display the name of the dimension, click the Name button.

� To display the description of the dimension, click the Description button.

Note: The dimension’s description and name are the same for Hyperion 
Enterprise applications.

3. Click OK.

Where... Is...

Product The product name, Enterprise or Essbase.

Server The Hyperion Essbase server name which is 
OLAP. Omit this parameter for Hyperion 
Enterprise.

ApplicationSet The Hyperion Essbase application name. Omit 
this parameter for Hyperion Enterprise.

Application The Hyperion Enterprise application name or the 
Hyperion Essbase database name.

xxx Name of the dimension.

e:\newicon.bmp Path and file name of the custom icon.



Customizing Your Desktop

� 23Hyperion Enterprise Reporting Windows Client User’s Guide

1

Customize the Formula Bar

You can customize the appearance of the formula bar by specifying which 
dimensions appear on the formula bar.

➤ To customize the formula bar:

1. Select Task > Customize Formula Bar or position the cursor on the formula 
bar, click the right mouse button, then click Customize. 

2. Click the Show Button check box for each dimension you want to appear on 
the formula bar.

3. Click OK.

Customize the Point of View Bar

You can customize the appearance of the point of view bar. You can specify which 
dimension buttons appear and whether the dimension buttons display an icon, 
name, or description. You can also specify the font to use for the name or 
description.

➤ To customize the point of view bar:

1. Select Task > Customize POV Bar or position the cursor on the point of view 
bar, click the right mouse button, and click Customize. 

2. Do one or more of the following:

Applies To:

Applies To:
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� Click Show Icon to display the dimension icon for each dimension button 
on the point of view bar.

Note: To change the dimension icon, see Customize Dimensions on 
page 21.

� Click Name, Description, or None to display the name, description, or no 
text for each dimension button on the point of view bar.

Tip: Click the Font button to specify font options for the name and 
description.

� Click the Show Button check box for each dimension button you want to 
appear on the point of view bar.

3. Click OK.
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Creating and Saving Reports 
and Books

You use Hyperion Enterprise Reporting Windows Client to create reports in a grid 
that is similar to a spreadsheet. You can create a standard report or a compound 
report. Once you create a report, you can use Hyperion Enterprise Reporting 
Windows Client to edit or print the report. You should decide on a design before 
you create reports.

You create a report by assigning dimensions to the columns and rows of the grid. 
You create a book by adding lines that specify dimension sections, dimension 
changes, and reports. You can define a report or book point of view for one or more 
dimensions, so that the report or book retrieves data for those dimensions unless 
you override the point of view within the report or book. For more information, see 
Set a Report Point of View on page 44.

You can use Report Wizard to create dynamic ad hoc queries within Hyperion 
Enterprise Reporting Windows Client. You can load a Hyperion Analyst query as 
a starting point for a Report Wizard query. You can preview a Report Wizard 
query to see how the query would look as a report, and you can save the query as 
a report. For more information about the Report Wizard, see Chapter 7. 

The first time you save a report or book, you provide a file name and assign the 
report or book to a report or book set. You can also provide a title for the report or 
book, and you can add comments. 

After you save a report or book, you can run the report or book to create a hard 
copy of the output or print the output to a file. You can also preview a report to see 
the output on the screen. For more information, see Report and Book Output on 
page 193.

2
Chapter
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Create Reports or Books

You create a report by assigning dimensions and dimension IDs to the columns 
and rows in the grid of a report window. You create a book in a book window by 
adding lines for reports, dimension sections, and dimension ID changes.

You might create a standard report called Income Statement that shows the income 
and expense data for several entities for the current month. You could assign the 
entities to the report’s columns and assign the income and expense accounts to the 
rows.

Alternatively, you might create a compound report that includes both an income 
statement and a balance sheet for the current month. You set up columns and rows 
for each standard report within the compound report.

You can create intercompany matching reports to show transactions between 
entities within the same organization. For applications with organizations that 
change over time, you can create reports to show changes in intercompany 
ownership from one period to another within an organization. For more 
information, see the Hyperion Enterprise User’s Guide or Hyperion Enterprise 
Reporting Windows Client Help.

You might create a book called Quarterly Reports that you run at the end of each 
quarter. The Quarterly Reports book might include the Income Statement Report, 
balance sheets, and other reports. 

➤ To create a report or book:

1. Select File > New or the New toolbar icon.

2. Select Standard Report, Compound Report, or Book.

3. Click OK.

Applies To:
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Close Reports or Books

When you close a report or book that contains unsaved changes, the system 
prompts you to save the changes. If you have not saved the report or book before, 
the system displays the Save As dialog box so that you can name the report or 
book.

➤ To close a report or book, from the report or book window, select File > Close.

Tip: You can close all reports and books by selecting Window > Close All.

Save Reports or Books

You save a report or book to store any changes that you make while creating or 
editing the report or book. You can also rename a report or book when you save it. 
When you save a report or book, the report or book window remains open so that 
you can continue editing. 

When you save a report or book for the first time, you must add the report or book 
to at least one existing report set or book set, and you must specify its security 
class. You can also specify a title for the report or book, and you can record 
comments about it.

� You might save a first-quarter balance sheet report with the file name 
Q1BAL.RPT and the security class Manager, with a comment describing 
the report’s contents. You might add the report to the Balance Sheets 

Applies To:

Applies To:
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report set. You might save a book of balance sheets and income statements 
with the file name BALINC.BPT and the security class Director, with a 
comment describing the contents of the book. 

➤ To save the active report or book, from the report or book window, do one of the 
following:

� To save a report or book that has not been saved before, select File > Save or 
the Save toolbar icon, specify a file name, a security class, a set, an optional 
title, and optional comments for the report, then click OK.

� To save a previously saved report or book, select File > Save or the Save 
toolbar icon.

� To save changes to all open reports and books, select File > Save All. 

� To rename a report or book or to change its set or other information, from a 
report window, select File > Save As or the Save toolbar icon, then make your 
changes. 

Compound Reports

A compound report contains two or more reports that you want to display together. 
The reports that a compound report contains are called embedded reports. The 
layout of a compound report determines the number of embedded reports and their 
arrangement in the output of the compound report. 

The report window for a compound report contains a tabbed panel for each 
embedded report. In each panel, you create or edit the embedded report in the same 
way that you create or edit a standard report. You use the panel tabs or commands 
on the View menu to move among embedded reports. 

Applies To:
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The following figure shows a Compound Report window with two report panels.

Figure 1: Compound Report Window

A compound report has a report point of view that applies to all embedded reports. 
The compound report can have a header and a footer, which is information that 
appears at the top and bottom of each page when you run the report. You can also 
create a header and footer for each embedded report.

You can paste a standard report as an embedded report in a compound report. You 
can also import a standard report as an embedded report into a compound report. 
This creates a link to the standard report so that when it changes, the embedded 
report also changes. For more information, see Paste Report or Book Areas on 
page 52. 

When you run a compound report, the system runs all embedded reports within the 
compound report. To run an embedded report as an individual report, you must 
copy it and paste it into a new standard report.

You can preview a compound report to see its output on the screen before you print 
it. The Preview window shows the compound report’s data, title, and format. You 
can print a compound report from the Preview window, or you can return to the 
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report window to change the report’s formulas or format before you print it. For 
more information, see Preview the Active Report, Batch of Reports, or Batch of 
Report Sets on page 194. 

The following figure shows the Preview window with a sample compound report.

Figure 2: Preview Window with Sample Compound Report

Compound reports have the extension .CRB. This distinguishes them from 
standard reports, which have the .RPT extension, and from books, which have the 
.BPT extension.

Note: Hyperion Schedules and Hyperion Distributed Schedules do not use 
compound reports. Any schedule you attempt to produce with a 
compound report will be empty.

Create Compound Reports 

You create a compound report in a compound report window, which has a panel 
where you set up each embedded report. By default, a compound report has two 
embedded reports, but you can select a layout that uses three or four reports.

Applies To:
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A compound report can have any of these layouts:

� Two side-by-side reports

� Two side-by-side reports above a third report

� One report above two side-by-side reports

� Two, three, or four stacked reports

For each layout, you specify the position of each embedded report. For example, 
in a compound report with three embedded reports, you specify which embedded 
report appears on the top-left, which appears on the top-right, and which appears 
on the bottom. You can reposition or rename each embedded report at any time. 
You set these spacing options in a compound report layout:

� Portrait or landscape printing

� Page order for printing

� Page margins

➤ To create a compound report:

1. Select File > New or the New toolbar icon, then select Compound Report.

2. To select a layout, set up a compound report header or footer, select spacing 
options, or rearrange the order in which the embedded reports appear, select 
View > Layout or double-click on any panel, then do one of the following: 

� To select a report layout, select a report template.

� To create a compound report header or footer, select the Compound 
Report Header icon or the Compound Report Footer icon.

� To reposition a report, highlight the embedded report and select the Move 
Up or Move Down icon.

� To set spacing options, select the Compound Report Spacing Options 
icon.

3. To create an embedded report, click on its panel at the bottom of the compound 
report window or select the embedded report from the View menu. 

4. To copy an existing standard report into a compound report, do the following:

a. Select File > Open, highlight a standard report name, then click OK.

b. Highlight the entire standard report, then select Edit > Copy or the Copy 
toolbar icon.
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c. Select File > New, then select Compound Report.

d. Highlight an entire embedded report panel, select Edit > Paste Special, 
click All, then click OK.

e. Select Format > Spacing, set the top, bottom, left, and right margins to 
zero, then click OK.

Tip: You can link a standard report to an embedded report in a 
compound report by selecting View > Import Options. For 
more information, see Import Reports on page 68.
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Setting a Point of View 

Each cell in a report retrieves data for the dimensions that you assign to the 
columns and rows. For any dimension that you do not assign in a report, the cell 
inherits the setting from the report point of view, the book point of view, or the 
Hyperion Enterprise Reporting Windows Client point of view.

Hyperion Enterprise Reporting Windows Client uses these point-of-view settings 
in this order to determine the data values to retrieve:

� The columns and rows in an individual report

� The report point of view, which you define for an individual report

� The sections defined in a book, if you are running the report in a book

� The book point of view, if you are running the report in a book

� The Hyperion Enterprise Reporting Windows Client point of view

Hyperion Enterprise Reporting Windows 
Client Point of View

Hyperion Enterprise Reporting Windows Client inherits a point of view from the 
current Hyperion Solutions product application, but you can reset the Hyperion 
Enterprise Reporting Windows Client point of view at any time. Your new settings 
remain in effect until you change the settings within Hyperion Enterprise 

Applies To:

3
Chapter
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Reporting Windows Client. Any changes you make in the Hyperion Enterprise 
Reporting Windows Client point of view apply to your user ID only and do not 
affect the application database. The system saves your Hyperion Enterprise 
Reporting Windows Client point of view when you exit Hyperion Enterprise 
Reporting Windows Client, so that your changes apply to your next work session.

Each dimension has a Hyperion Enterprise Reporting Windows Client point of 
view in Hyperion Enterprise Reporting Windows Client. You can include as many 
of these dimensions as you want on the point of view bar. For instructions on 
customizing the point of view bar, see Customize the Point of View Bar on 
page 23.

Book Point of View

You can set a book point of view that overrides the Hyperion Enterprise Reporting 
Windows Client point of view. When you run a book, Hyperion Enterprise 
Reporting Windows Client uses the IDs in the book point of view for any 
dimensions that you do not assign in the columns and rows of the reports in the 
book, in the report point of view, or in the lines and sections of the book. 

For example, suppose the Quarterly Reports book point-of-view category is 
Actual. The book might include a report with a report point of view that specifies 
the Forecast category. When you run the book, that report retrieves Forecast data. 
Any report in the book that does not have its own point-of-view category retrieves 
Actual data.

Applies To:
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Report Point of View

You can set a report point of view that overrides the Hyperion Enterprise 
Reporting Windows Client point of view. When you run a report, Hyperion 
Enterprise Reporting Windows Client refers first to the report point of view for any 
dimensions that you do not specifically assign to the columns and rows. If you 
include a report in a book, the report point of view overrides the book point of 
view. 

For example, suppose you assign only accounts to rows and only categories to 
columns in a report, and you create a report point of view that assigns a period. 
When you run the report, Hyperion Enterprise Reporting Windows Client retrieves 
data for the report point-of-view period, and for the categories and accounts that 
you assigned to the rows. The system refers to the Hyperion Enterprise Reporting 
Windows Client point of view for all other dimensions. If you run the report as part 
of a book, the system refers to the book point of view and then to the Hyperion 
Enterprise Reporting Windows Client point of view for all other dimensions. 

Applies To:
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The Point of View Dialog Box
You use the point of view dialog box to assign dimension IDs to the point of view. 
The following figure shows the Point of View dialog box and its components. For 
more information about the components, see the topics following the figure.

Figure 3: Point of View Dialog Box

1. Available List

2. Find Options

3. Available Options

4. Splitter Bar

5. Filters

6. Filters Summary
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Set the Hyperion Enterprise Reporting 
Windows Client Point of View

The Hyperion Enterprise Reporting Windows Client point of view specifies IDs 
for dimensions that you have not assigned in a column or row, in the point of view 
of the active report, or in the point of view of the active book. The first time you 
start Hyperion Enterprise Reporting Windows Client with a Hyperion Enterprise 
application, Hyperion Enterprise Reporting Windows Client inherits the point of 
view for the application. You can reset the Hyperion Enterprise Reporting 
Windows Client point of view at any time, using either the point of view bar or the 
Point of View command on the Edit menu. Hyperion Enterprise Reporting 
Windows Client saves the new settings for your next Hyperion Enterprise 
Reporting Windows Client session, but your changes do not affect the Hyperion 
Enterprise point of view for an application.

Suppose you do not assign entities to the columns or rows in the Balance Sheet 
report. If you run the report with Evergreen Paper Company as the point-of-view 
entity, the report retrieves values for Evergreen Paper Company. If you change the 
point-of-view entity to Diamond Business Papers and run the report again, the 
report retrieves values for Diamond Business Papers. The next time you run 
Hyperion Enterprise Reporting Windows Client with the application, Diamond 
Business Papers is the Hyperion Enterprise Reporting Windows Client 
point-of-view entity.

Note: You will not be able to set the Hyperion Enterprise Reporting 
Windows Client point of view for Hyperion Essbase if you have 
Web=Yes set in your REPENG.INI file, and you have Hyperion 
Enterprise Reporting Web Server installed. If you do not have a 
Hyperion Enterprise Reporting Windows Client point of view set, 
Hyperion Enterprise Reporting Windows Client will not start.

Applies To:
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➤ To set the Hyperion Enterprise Reporting Windows Client point of view:

1. From the point of view bar in a report or book window, select Edit > Point of 
View and a dimension name.

Tip: Instead of using the Edit menu, you can click the button for the 
dimension from the point of view bar.

2. To specify the IDs that appear in the Available list, specify the filters.

3. Select a dimension ID.

4. To set another dimension, select the panel for that dimension and proceed with 
step 2. 

5. Click OK. 

Available List

You use filters to specify the dimension IDs that appear in the Available list. You 
use find options and available options to find and view dimension IDs, functions, 
and lists in the available list. The following table describes these components.

Table 1: Filters, Find Options, and Available Options 

Use... To...

Filters Specify which dimension IDs 
appear in the Available list.

Find Options Search the Available list for an item.

Available options View the available list in a tree or 
list format. You can also specify the 
attributes that appear for each item.
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Dimension IDs that appear in the available list are proceeded by an icon. The icon 
denotes which dimension IDs are loaded in memory. If you search for an ID, it is 
found only if it is loaded in memory. The following table lists each dimension ID 
icon and its meaning. 

Filters

You use filters to specify which IDs appear in the Available list of a dialog box. 
By using filters you can view only the IDs you need. 

Note: The field and view dimensions do not use filters.

The IDs that appear in the Available list match at least one of the specifications 
within every filter. The range filter is applied last. Initially the filters are set to 
display the top or parent IDs. After you set a filter within an application, it remains 
in effect until you change it. 

Note: You can click the Filters Summary icon to view all the filters that are 
set and their values. 

Table 2: Dimension ID Icons 

Icon... Definition...

The top level ID is loaded in List view.

The top level ID is loaded in Tree view.

The top level ID and its children are loaded in 
Tree view, if you used the available options to 
populate the tree. The top level ID and its 
children or the top level ID and all its 
descendants are loaded in Tree view, if you 
selected the Plus icon to populate the tree.

The top level ID and all its descendents are 
loaded in Tree view.

The bottom level ID is loaded in List view.
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If you have a large selection of IDs, you should deactivate the Auto refresh option, 
located in available options, until you make your filter selections. You can refresh 
the member selections by selecting the Refresh icon. The following table describes 
the types of filters you can use.

 Hyperion Enterprise Example

In the following example, the Parent dimension has four filters:

Organization is set to ORG1 and ORG3

Name is set to d* and f* 

Description is set to *

Range is set with first = 5 and last = 27

All the entity IDs that are part of ORG1 or ORG3, and whose name starts with the 
letter d or the letter f, match the filters. From those IDs, the 5th through the 27th 
appear in the Available list. 

Table 3: Filter Types 

Use this filter type... To...

List Specify IDs that match one or more of the selected items 
in the list. For example, using the organization filter, if 
Org1 and Org4 are selected, then all the IDs that are in 
Org1 or Org4 are matching IDs. 

Range Specify IDs within a range. The range is applied to the list 
of IDs after all the other filters have been applied. For 
example, after applying all the filters there are 100 
matching IDs, and the range is set to 5-23. The 5th ID 
through the 23rd ID appear in the Available list. 

Wildcard Specify items using the * or ? wildcard symbol. You can 
specify several searches using the blank character as a 
separator. For example, using the name filter, if you 
specify d* w*, all names that start with d or w match. If 
the wildcard text box is blank, no IDs match.

On/Off Specify IDs that match the selected check box. For 
example, using the subentities filter, if entities with 
substructures are selected, all the IDs with substructures 
are matching IDs. 
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 Hyperion Essbase Example

Suppose you have a dimension with the following filters:

List is set to Gen1, Account

Balance has Opening selected

Name is set to r* w*

All IDs in the Gen1, Account list with an Opening balance and a name that starts 
with r or w, appear in the Available list.

Filters Summary

You use the Filters Summary icon to view all the filters that are set and their 
values. 

Find Options

Specify Find options to search for an item in the Available list. The item must be 
loaded into memory so the system can locate it. For more information on items 
loaded in memory, see Available List on page 38.

Table 4: Find Options

Select… To…

Name Search Search by name.

Description Search Search by description.

Wildcard Search Specify items using the * or ? wildcard symbol. You can 
specify several searches using the blank character as a 
separator. For example, if you specify d* w*, all items 
that start with d or w match. 

Case Sensitive Search  Perform a case sensitive search.

Auto Search  Search the list as you type characters. If this is not 
selected, you must press the Find Previous or Find Next 
icons to perform the search.
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Available Options

Specify Available options to view the items in the Available list.

Splitter Bar

You use the splitter bar to size the panes in the window. If there are filters, the 
splitter bar displays in the middle of the dialog box. If there are no filters, the 
splitter bar displays at the bottom of the dialog box by default. After the splitter bar 
has been moved, the specified position becomes the default.

Table 5: Available Options 

Select… To…

List View Display the items in a list.

Tree View Display the items in a hierarchical tree.

Expand All Expand all items in the tree.

Collapse All Collapse all items in the tree.

Expand Selected Expand all highlighted items in the tree.

Collapse Selected Collapse all highlighted items in the tree.

Load All Load all descendants starting at the top level.

Load Selected Load all descendants of the selected IDs.

Auto Refresh Refresh the Available list each time a filter 
changes. If you turn Auto Refresh off, you 
must select the Refresh icon to view the 
filtered IDs.

Visible Attributes > 
Attribute List 

Display the attribute.
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Set a Book Point of View

You can set a point of view for a book using one or more dimensions, so that the 
book retrieves data for those dimensions by default when you run the book. The 
book point of view overrides the Hyperion Enterprise Reporting Windows Client 
point of view, but any dimension assignments or point-of-view settings for reports 
within the book override the book point of view.

Suppose the Hyperion Enterprise Reporting Windows Client point of view entity 
is Evergreen Paper Company. If you run a book that has no assigned entity, the 
book retrieves data for Evergreen Paper Company. If you set the book point of 
view to use the Diamond Business Papers entity, the book retrieves data for 
Diamond Business Papers regardless of the Hyperion Enterprise Reporting 
Windows Client point of view. 

➤ To set a book point of view:

1. From the book window, select Edit > Book Point of View.

2. To clear the point of view for one or more dimensions, do one of the following:

� To clear a single dimension setting, highlight the dimension setting and 
click Clear.

� To clear all of the dimension settings, click Clear All.

3. Highlight a dimension that you want to set in the book point of view, then click 
Set or double-click on an ID for the dimension.

4. Select the ID or Function tab.

5. Select an ID or function for the book point of view, then click OK. For 
instructions, see the Chapter 5.

6. Repeat steps 3 through 5 for each dimension that you want to set in the book 
point of view, then click OK.

Applies To:
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Set a Report Point of View

You can set a point of view for a report using one or more dimensions, so that the 
report retrieves data for those dimensions by default when you run the report. The 
report point of view overrides the book point of view and the Hyperion Enterprise 
Reporting Windows Client point of view.

If you set the Income Statement report point of view to use the Diamond Business 
Papers entity, the report retrieves data for Diamond Business Papers, regardless of 
the Hyperion Enterprise Reporting Windows Client point of view. If you run a 
book that includes the Income Statement report, the report retrieves Diamond 
Business Papers data, regardless of the book point of view. 

➤ To set a report point of view:

1. From the report window, select Edit > Report Point of View.

2. To clear one or more dimensions, do one of the following:

� To clear a single dimension setting, highlight that dimension setting and 
click Clear.

� To clear all dimension settings, click Clear All.

3. Highlight any dimension that you want to set in the report point of view, then 
click Set, or double-click on an ID for the dimension.

4. Select the ID or Function tab.

5. Select an ID or function for the report point of view, then click OK.

6. Repeat steps 3 through 5 for each dimension that you want to set in the report 
point of view, then click OK.

Applies To:
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Editing Reports and Books 

You can open any existing report or book for editing. Editing a report or book can 
involve any of these tasks:

� Cutting, copying, pasting, or inserting an area of a report or book 

� Inserting or replacing reports in books

� Setting report options, such as reversing the signs of accounts with specific 
attributes for presentation purposes

� Setting book options, such as page numbering, content, formatting, and 
orientation for the book and the book table of contents

� Editing summary information about a report or book

� Setting up headers and footers

� Importing reports into the current report

Headers and footers display text at the top and bottom, respectively, of each page 
in the output of a report. Headers and footers can include formulas that contain text 
functions, which retrieve text such as the application name or descriptions for 
dimensions.

You can center a header or footer or align it to the right or left. You can also specify 
font, color, and other text attributes for the entire header or footer, or for each line 
in the header or footer. If you specify a font in a header or footer, this setting 
overrides the header font that is set in the Page Format dialog box for the active 
report. 

Note: The font style and color that you specify for a header or footer appear 
only when you preview or run the report. 

4
Chapter
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The following figure shows a header that uses the @FLT function to retrieve and 
display the title of the report in the center of each page.

Figure 4: Sample Header Using @FLT Function

The following figure shows how the header appears on each page if the report title 
is Cash Accounts. The header uses the Arial font in 16-point bold.

Figure 5: Sample Header Output
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The following figure shows a footer that uses the @TIM text function to display 
the current application description on the bottom left side of each page and the 
@TOD text function to display the current date on the bottom right side of each 
page.

Figure 6: Sample Footer Using @TIM and @TOD

The following figure shows how this footer appears if you run the report at 1:42 
pm on May 29, 1998. The footer in the figure uses the default font options.

Figure 7: Sample Footer Output

Security for Hyperion Essbase Reports
Hyperion Essbase report security is inherited from the Hyperion Essbase 
application which is setup in the Hyperion Essbase application manager. For 
example suppose you have read only access to an application and your ID belongs 
to a group that has read only access. If you create a report, you can save it in one 
of the following ways:
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� Save the report to public, and you still have modify access rights to the report. 

� Save the report to your ID, and you still have modify access rights to the 
report. 

� Save the report to your group, and you do not have modify access rights to the 
report.

Report and Book Areas

When you edit a standard report, compound report, or book in Hyperion Enterprise 
Reporting Windows Client, you first open it in a report or book window. The file 
name and title of the report or book appear in the title bar of the report or book 
window. You have the option of saving the report or book with a different file 
name and title.

A report area can consist of one or more consecutive columns, rows, or headings. 
A report area can also comprise all the data in a report or the entire report, 
including all headings and data. A book area consists of one or more lines in a 
book.

You select report and book areas for editing. For example, you can select the first 
three columns of a report, copy the columns, then paste the columns after column 
12. 

Applies To:
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Open Reports or Books

➤ To open an existing report or book from any Hyperion Enterprise Reporting 
Windows Client window:

1. Select File > Open or the Open toolbar icon. 

2. Do one of the following:

� To reopen any of the last four reports or books that you opened, select the 
report or book file name from the list at the bottom of the File menu.

� To open a report, select the Report tab, select one or more reports, then 
click OK.

� To open a book, select the Book tab, select one or more books, then click 
OK.

� To open a report set, select the Report Set tab, select one or more report 
sets, then click OK.

� To open a book set, select the Book Set tab, select one or more book sets, 
then click OK.

Note: The last report, report set, book, or book set used is highlighted.

Select or Deselect Report or Book Areas

You select areas of reports or books to edit the areas and assign dimensions, 
formulas, or format settings. When you select an area, it appears highlighted. 

Applies To:

Applies To:
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You must select an area before you can use menu commands, toolbar icons, or the 
formula bar. The area that you select determines which menu commands are 
available. You deselect an area when you no longer want to work with it.

For example, you might select a report column and assign a period and a category 
to the column. You then might select the column heading and select a font and 
other format options for the heading.

➤ To select or deselect a report or book area, do one of the following:

� To select a report column or row or a line in a book, click on the column or 
row number or the line. 

� To select a range of consecutive columns or rows in a report or a range of 
consecutive lines in a book, hold down the left mouse button and drag the 
pointer through the range.

Tip: Alternatively, you can select the first column, row, or line in the 
range, hold down Shift, then select the last column, row, or line in 
the range.

� To deselect a report or book area, click anywhere in the report or book 
window, outside the selected area.

Cut Book Areas

You cut columns or rows from a report or lines from a book to remove the selected 
area and place the selection in the clipboard. You can then paste the area from the 
clipboard to another location in the same report or book or in a different report or 
book. When you cut a report area, any assigned format attributes remain with the 
area. The report or book area you cut replaces any item previously placed in the 
clipboard.

Applies To:
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➤ To cut a report or book area:

1. Select the area.

Tip: You can select the report section icon instead of selecting the 
entire section.

2. Select Edit > Cut or the Cut toolbar icon.

Copy Report or Book Areas

You copy a report or book area to place a copy of the selected report area in the 
clipboard. You can then paste the area from the clipboard to another location in the 
same report or book or in a different report or book. When you copy a report area, 
any assigned format attributes remain with the copy. The area you copy replaces 
any item previously placed in the clipboard.

➤ To copy a report or book area:

1. Select the area.

Tip: You can select a report section icon instead of selecting the entire 
section.

2. Select Edit > Copy or the Copy toolbar icon. 

Applies To:
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Paste Report or Book Areas

You paste report and book areas to place a copy of the area from the clipboard next 
to the selected area. If you select one or more rows in a report and then paste the 
area from the clipboard, the pasted area appears above the selected rows. If you 
select one or more columns in a report, the pasted area appears to the left of the 
selected columns. If you select one or more lines in a book, the pasted area appears 
above the selected lines. 

After you paste an area, a copy remains in the clipboard. You can paste this area 
into another location in the same report or book or in a different report or book.

When you cut or copy a report area, the copy in the clipboard retains the format 
attributes of the area. You can paste the copy with or without its format attributes. 
If you copy an entire report, you can paste the format settings that apply to the 
entire report without pasting its dimensions.

In a report, you can paste rows into rows, columns into columns, rows into 
columns, or columns into rows, provided that the dimensions assigned to the 
columns and rows do not conflict.

For example, you might copy the February column, which has light shading for the 
data. You can paste the column in a new location, such as a section for a different 
account, to create a new February column. You can paste the column with its 
shading and other format attributes, or you can paste only its dimensions to set up 
a new February column with the default format attributes.

➤ To paste report or book areas:

1. From a report or book window, cut or copy the report or book area to place it 
in the report clipboard.

2. In the same report or book window or in a different report or book window, do 
one of the following:

� To paste one or more rows in a report, select the row above which you 
want the rows in the clipboard to appear.

Applies To:
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� To paste one or more columns in a report, select the column before which 
you want the columns in the clipboard to appear.

� To paste one or more lines in a book, select the line before which you want 
the lines in the clipboard to appear.

3. Do one of the following:

� To paste the report area with its dimensions and format attributes, select 
Edit > Paste or the Paste toolbar icon.

� To paste the report area with its dimensions but not its format attributes, 
or with its format attributes but not its dimensions, select Edit > Paste 
Special.

Note: To paste only the format attributes that apply to an entire report, 
you must copy and paste the entire report. For more information, 
see Copy Format on page 168.

Insert Blank Columns or Rows

You can insert a blank column or row before any column, row, or section or within 
any section in a report. The Insert command on the Edit menu varies depending on 
whether you select a column or a row. If you select a row, the Insert Row menu 
command appears on the Edit menu. If you select a column, the Insert Column 
menu command appears. For more information, see Insert Sections on page 93.

➤ To insert a blank column or row:

1. Do one of the following:

� To insert a blank column or row before an existing column or row, select 
the existing column or row.

� To insert a blank column or row before a section, select the section icon.

� To insert a blank column or row before a column or row within a section, 
select the column or row within the section.

Applies To:
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2. Select Edit > Insert Column or Edit > Insert Row.

Delete Report or Book Areas

You delete a report or book area to remove the selected area from the report or 
book without copying the area to the clipboard. When you delete a column, all 
columns to the right of it shift to the left. When you delete a row, all rows below 
the deleted row shift upward. 

➤ To delete a report or book area:

1. Select the report or book area.

Tip: You can select a report section icon instead of selecting the entire 
section.

2. Select Edit > Delete.

Tip: To restore the report or book area you deleted, select Edit > Undo 
before you perform another edit on the report or book.

Undo Edits

You can undo edits to reverse the last edit that you made in the active report. For 
example, if you delete a row by mistake, you can restore the row. Undo is available 
only when there is an edit to undo.

Applies To:

Applies To:
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➤ To undo an edit in a report or book, select Edit > Undo.

Set Report Options for Hyperion Enterprise

You can set report options for the active report to do any of the following:

� Display data based on actual ownership. 

� Run large reports more efficiently when less than 50 percent of the cells in the 
report contain data. 

� Speed the running of reports that contain large volumes of accounts, entities, 
and categories by retrieving only the accounts that contain data for the entities 
and categories. 

� Identify the account that holds the number of days in each month. The system 
uses the data in the days-in-month account with the DWV field to calculate 
average days weighted data.

� Enumerate entities in statutory reporting based on the category specified in the 
point of view, all categories, or a specific category that you select. 

� Reverse the sign of a group of accounts for presentation purposes.

For example, you might have a report with the account Sales that appears as 2,199. 
You can reverse the sign of the account so it appears as (2,199).

➤ To set report options for Hyperion Enterprise:

1. Select Task > Report Options.

2. Do one or more of the following:

� In the Days-in-Month Account edit box, type the ID of the account that 
holds the days in each month, or select the Lookup icon to select the 
account from a list.

� To run a large report more efficiently when less than 50 percent of its cells 
contain data, select Optimize Report for Sparse Data. 

Applies To:
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� To reverse the sign of an account attribute select the Reverse Sign check 
box. 

� To specify one or more categories for use in listing entities, select ALL or 
a specific category. 

� To speed the running of a report with a large number of accounts click 
Reporting on Large Volumes. 

� To display data based on actual ownership, click Vary Organization by 
Period. 

3. Click OK.

Set Report Options for Hyperion Essbase

You can set report options for the active report to do any of the following:

� Run large reports more efficiently when less than 50 percent of the cells in the 
report contain data. 

� Speed the running of reports that contain large volumes of members for 
dimensions.

� Reverse the sign of a group of accounts for presentation purposes.

You might have a report with several accounts that have the Expense attribute. 
Typically, the Expense attribute displays a negative value. If you reverse the sign 
of the Expense attribute, all the Expense accounts appear as positive values.

For example, suppose you have a report with Travel, Labor, and Material accounts 
with the Expense attribute, which would normally have a negative value. If you 
reverse the sign of the Expense attribute, all the Expense accounts appear as 
positive values.

➤ To set report options for Hyperion Essbase:

1. Select Task > Report Options.

Applies To:
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2. Do one or more of the following:

� To run a large report more efficiently when less than 50 percent of its cells 
contain data, click Optimize for sparse data. 

� To run a large report more efficiently with a large number of cells 
containing data, click Optimize for large volumes, then select any of the 
following:

� To suppress cells containing zero data, click Suppress zero data.

Note: Selecting this option automatically forces the selection of the 
Suppress No Data option.

� To suppress cells containing no data, click Suppress no data.

� To merge all subqueries into a single query, click Merge Into a Single 
Query. 

Note: Use the Merge Into a Single Query function when multiple 
functions in a report contain an overlap in the returned query 
results.

� To retrieve information on whether cells contain criteria, or whether cells 
are source locked, input or calculated, click Retrieve status information.

� To reverse the sign of an account attribute click the Reverse Sign check 
box. 

3. Click OK.

Set Book Options 

Overview

You can set book options within the active book to do any of the following:

Applies To:
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� Assign page numbers to be continuous, to restart at each section, or to restart 
at each report within the book.

� Prefix the page numbers with chapter numbers, section numbers, or dimension 
values within a book.

� Print the book table of contents, which lists sections and reports within a book.

� Specify content, a global font, and orientation options for the book table of 
contents.

The restart page number and section information options specify the page number 
format and the table of contents for the book. The page numbers use the start page 
number, which is set using the File > Page Setup command. The following table 
describes the restart page number options.

The section information is used to prefix the page numbers within the book and the 
table of contents for the book. You can prefix the page numbers with chapter 
numbers, section numbers, or dimension values. This option also specifies the 
section and report information listed in the table of contents for the book. The 
following table describes the section information options.

Figure 8: Restart Page Number Options

Use... To...

Continuous Use the start page number once, at the 
beginning of the book

At Each Section Use the start page number at the 
beginning of each section.

At Each Report Use the start page number at the 
beginning of each report.

Figure 9: Section Information Options

Use... To...

None Use no prefix on the page numbers.

Chapter Number Prefix the page numbers with the chapter 
number. The chapter number is equivalent 
to the section number and is incremented 
each time a dimension changes within a 
section.



Editing Reports and Books

� 59Hyperion Enterprise Reporting Windows Client User’s Guide

4
The print table of contents options are used to format the table of contents for the 
book. You can specify whether to print the book and report names and titles, page 
orientation, and font options. The book and report names and titles appear in the 
table of contents as follows:

Table of Contents

Book Name

Book Title

Report Name - Report Title

Report Name - Report Title

The following table describes the print table of contents options:

Section Number Prefix the page numbers with the section 
number. The section number is 
incremented each time a dimension 
changes within a section.

 Dimension Value Prefix the page numbers with the section’s 
dimension value.

Figure 10: Print Table of Contents Options 

Use... To...

Book Name Print the book name at the top of the table of contents.

Book Title Print the book title at the top of the table of contents.

Report Name Print the report name to the left of the table of contents.

Report Title Print the report title to the left of the table of contents.

Page Setup Labels Print the general, date, time, and text page labels within the 
table of contents.

Note: Use the File > Page Setup command to define the 
page setup labels. When this option is selected, the page 
numbers defined in the page setup labels are not printed. 

Figure 9: Section Information Options(Continued)

Use... To...
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Examples

The following book has a category section, an entity section, and several reports. 
All the reports within this book are one page in length.

Figure 11: Hyperion Enterprise Reporting Windows Client Book

Orientation Print the table of contents with portrait, landscape, or system 
default orientation.

Note: Use your default printer options to set the system 
default orientation.

Font Set the font options for the table of contents.

Figure 10: Print Table of Contents Options (Continued)

Use... To...
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If the book options have the restart page number set to Continuous, and the section 
information set to None, the reports are listed in the table of contents for the book 
and displayed as follows:

Table of Contents
BOOK 5
Category and Entity Reports

Bugattr Report...........................1

Export Report............................2

Bugattr Report...........................3

Export Report............................4

If the book options have the restart page number set to At Each Section, and the 
section information set to Chapter Number, the sections and reports are listed in 
the table of contents for the book and displayed as follows:

Table of Contents
BOOK 5
Category and Entity Reports

1 Actual-USELIM

Bugattr Report..........................1-1

Export Report...........................1-2

2 Actual-US100

Bugattr Report..........................2-1

Export Report...........................2-2

If the book options have the restart page number set to At Each Report, and the 
section information set to Section Number, the sections and reports are listed in the 
table of contents for the book and displayed as follows:

Table of Contents
BOOK 5
Category and Entity Reports

1 Actual

1-1 USELIM

Bugattr Report..........................1-1-1

Export Report...........................1-1-1

1-2 US100

Bugattr Report..........................1-2-1
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Export Report...........................1-2-1

If the book options have the restart page number set to Continuous, the section 
information set to Dimension Value, and the book name and book title set to Print, 
the sections and reports are listed in the table of contents for the book and 
displayed as follows:

Table of Contents
BOOK 5
Category and Entity Reports

1 Actual

1-1 USELIM

Bugattr Report................Actual-USELLIM-1

Export Report.................Actual-USELLIM-2

1-2 US100

Bugattr Report.................Actual-US100-3

Export Report..................Actual-US100-4

➤ To set book options:

1. Select Task > Book Options.

2. Do one or more of the following:

� Use the start page number to specify the page numbers for the entire book, 
each section, or each report.

Note: Use the File > Page Setup command to define the start page 
number.

� Specify a prefix to use with the page numbers.

� Specify the chapter, section, and report information to list in the table of 
contents for the book.

� Specify whether to print the table of contents for the book.

� Specify font and orientation options for the table of contents for the book.

3. Click OK.
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Insert Reports in Books

A book is a group of reports that you run at the same time. For example, you might 
create one book of reports that you run at the end of each quarter and another book 
of reports that you run each week. You can insert a report above or below any other 
line or within a section in a book. You can also replace any report in a book with 
a different report. For more information about replacing reports, see Replace 
Reports in Books on page 64.

You might include the same reports in a book several times, to produce data for 
different dimension settings. If you insert a report that prompts for dimension 
settings, you can assign values for the prompts so that they do not appear when you 
run the book. For more information, see Assign Values for Prompts on page 97.

Note: Hyperion Enterprise Reporting Windows Client suppresses reports 
that do not contain data when you run books. For more information, 
see Print Active Reports or Books on page 195.

➤ To insert a report in a book:

1. From a book window, select the line where you want to insert the report.

2. Select Edit > Insert Report or the Insert Report toolbar icon.

3. To filter the list of reports, select a set that contains the report that you want to 
insert.

4. Type the name of the report in the File Name edit box or select one from the 
list.

5. Select a position option to insert the report above or below the selected line or 
within the selected section.

6. Click OK. 

Applies To:
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Replace Reports in Books

You can replace any report in a book with a different report. For example, suppose 
the First Quarter Forecasts book contains the Western Division - Administration 
report, but you want the book to run the Southern Division - Manufacturing report 
instead. You can replace the Western Division - Administration report with the 
Southern Division - Manufacturing report. This process is quicker than deleting 
the Western Division - Administration report and then inserting the Southern 
Division - Manufacturing report. 

➤ To replace a report in a book:

1. From a book window, select the line that includes the report that you want to 
replace, then select Edit > Replace Report, or double-click on the report line.

2. To filter the list of reports, select a set that contains the report that you want to 
use.

3. Type the report name in the File Name edit box or select one from the list, then 
click OK. 

Edit Report or Book Summaries

A report or book summary shows the file name, security class, and title of the 
report or book, and the report or book set to which the report or book belongs. You 
can edit the title and comments in a report or book summary.

Applies To:

Applies To:



Editing Reports and Books

� 65Hyperion Enterprise Reporting Windows Client User’s Guide

4

➤ To edit a report or book summary:

1. From a report or book window, select File > Summary Info. 

2. Do one or both of the following:

� Edit the title of the report or book.

� Edit comments about the report or book.

3. Click OK.

Set Up Headers or Footers

Headers and footers display text at the top and bottom, respectively, of each page 
in the output of a report. Headers and footers can include formulas that contain text 
functions, which retrieve text such as the application name or descriptions for 
dimensions.

You can center a header or footer or align it to the right or left. You can also specify 
font, color, and other text attributes for the entire header or footer, or for each line 
in the header or footer. If you specify a font in a header or footer, this setting 
overrides the header font that is set in the Page Format dialog box for the active 
report. 

Note: The font style and color that you specify for a header or footer appear 
only when you preview or run the report. 

Applies To:
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The following figure shows a header that uses the @FLT function to retrieve and 
display the title of the report in the center of each page. 

Figure 12: Sample Header Using @FLT Function

The following figure shows how the header appears on each page if the report title 
is Cash Accounts. The header uses the Arial font in 16-point bold.

Figure 13: Sample Header Output
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The following figure shows a footer that uses the @TIM text function to display 
the current application description on the bottom left side of each page and the 
@TOD text function to display the current date on the bottom right side of each 
page.

Figure 14: Sample Footer Using @TIM and @TOD

The following figure shows how this footer appears if you run the report at 1:42 
pm on May 29, 1998. The footer in the figure uses the default font options.

Figure 15: Sample Footer Output

When you edit a standard report, compound report, or book in Hyperion Enterprise 
Reporting Windows Client, you first open it in a report or book window. The file 
name and title of the report or book appear in the title bar of the report or book 
window. You have the option of saving the report or book with a different file 
name and title.



68 �

Editing Reports and Books

Hyperion Enterprise Reporting Windows Client User’s Guide

➤ To set up a header or footer:

1. From a report window, select View > Header or View > Footer or the Header 
or Footer toolbar icon.

2. In the Left, Center, and Right edit boxes, do one or more of the following:

� To enter text, position the cursor and type the text for the header or footer.

� To paste a formula in the header or footer, position the cursor where you 
want to insert the formula, click the Edit Formulas icon, then create the 
formula using text functions and any required parameters. For 
instructions, see Edit Heading Formulas on page 128.

� To set font and style attributes for all of the text in the header or footer, 
click the Default Font and Shading/Border icon, then select the font and 
shading/border attributes. For instructions, see Formatting Options on 
page 147.

� To set font and style attributes for individual lines in the header or footer, 
click the Line Font and Shading/Border icon, then select the font and 
shading/border attributes. For instructions, see Formatting Options on 
page 147.

3. Click OK.

Import Reports

You import a report to merge columns or rows from that report into the active 
report each time you run the report. You can also set up a report so that each time 
you run it, the system prompts for another report to import. You can specify a set 
name so that users can select the report from a specific set. When you import 
reports, the merged rows or columns can appear before the active report, after the 
columns in the active report, or after the rows in the active report.

Applies To:
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For example, you might create a report named Actual/Forecast that consists only 
of columns for the Actual and Forecast categories. You can then create another 
report with rows for accounts and import the Actual/Forecast report to set up the 
columns in the new report. 

➤ To import a report:

1. From a report window, select View > Import Options.

2. In the Import Before Current Report, Import After Columns, or Import After 
Rows list box, select the line within the list box where you want to import the 
report or prompt.

3. Do one or both of the following:

� To import a specific report, click Paste Report, then select a report from 
the report list. You can filter the report list by selecting a report set from 
the Set list.

� To set up a prompt for requesting a report to import, click Paste Prompt, 
then type a title for the Prompt dialog box and select a set to limit the 
reports users can import.

4. Click OK.
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Assigning Dimensions

You can use several methods to assign dimensions in reports and books. The 
available methods are determined by the Hyperion Solutions product you are using 
and the dimension that you are assigning. The following table describes the 
dimension assignment methods.

You can insert dimension changes to change the point of view for a report area. 
You can also insert sections in reports or books. A report section sets up columns 
or rows for a series of dimensions. A book section runs reports for a series of 
dimensions. A section serves the same purpose as several individual dimension 
changes. 

You can assign a dimension to columns if you have not assigned it to rows, and 
you can assign a dimension to rows if you have not assigned it to columns.

Table 6: Dimension Assignment Methods

Use this 
method... With… To assign…

ID Hyperion Enterprise 
and Hyperion Essbase

Specific IDs or 
members.

Function Hyperion Enterprise 
or Hyperion Essbase

Functions that 
assign IDs or 
members 
depending on other 
settings when you 
run the report or 
book.

List Hyperion Enterprise 
only

Entity lists, or 
account lists.

Chapter

5
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For any dimensions that you do not assign to columns or rows and that you do not 
set in the report point of view, the report refers to the book point of view if you 
include it in a book. If there is no book point of view, the report refers to the 
Hyperion Enterprise Reporting Windows Client point of view. For example, if you 
do not assign periods to columns or rows in a report and do not include the report 
in a book, the report shows data for the Hyperion Enterprise Reporting Windows 
Client point-of-view period. For more information, see the Hyperion Enterprise 
Reporting Windows Client Getting Started Guide.

A dimension assignment for a single column or row in a report window can 
produce several columns or rows of data when you run the report. For example, 
suppose you select a column and then assign the January, February, and March 
periods. The report output shows a separate column for each period.

Report Columns and Rows

When you build a report, you set up columns and rows using dimensions. For 
example, you might build an income statement showing quarterly year-to-date 
data, with rows for accounts and columns for categories. You can assign 
dimensions by selecting individual IDs, by selecting functions for dynamic 
dimension settings, or by selecting both IDs and functions. The data appears when 
you run the report. 

By default, Hyperion Enterprise Reporting Windows Client shows dimension IDs 
in the column headings and dimension descriptions in the row headings. For 
example, suppose you assign the Sales and Cost of Sales accounts to rows and the 
Actual and Budget categories to columns. The row headings are the account 
descriptions, Sales and Cost of Sales. If the IDs for the Actual and Budget 
categories are ACTUAL and BUDGET, the column headings are ACTUAL and 
BUDGET. You can override this default and view the definitions for the data in 
the report instead. For more information, see View Definitions on page 128.

You can select text functions to edit the column and row headings. You can also 
enter text in data cells for the selected column or row. For information about text 
functions, see Chapter 12.

Applies To:
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Once you define the data and headings for a report, you can set up the format for 
the report. For example, you can format a report so that row headings appear in 
italics, column headings appear bold, and some columns of data appear shaded. 
For more information, see Chapter 7.

Report Sections

You can create a report section to retrieve data for a series of dimensions in one 
report. You create or edit a report section to specify the dimensions the section 
includes.

A report section can serve the same purpose as several dimension changes. 
Inserting a report section is more efficient than inserting the dimension changes 
individually. A report section overrides the report and Hyperion Enterprise 
Reporting Windows Client points of view. 

An icon indicates the dimension for each section. For a list of the icons Hyperion 
Enterprise Reporting Windows Client uses by default to represent dimensions, see 
the Quick Tables chapter in the Hyperion Enterprise Reporting Windows Client 
Getting Started Guide.

Applies To:
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The following figure shows a report with entities section that shows values for 
three entities each time you run the report. The formula in the formula bar edit box 
identifies the entities.

Figure 16: Sample Report with Entities Section
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The following figure shows how the report looks if you use separate dimension 
changes instead of one section.

Figure 17: Sample Report with Separate Dimension Changes

The output from the reports in the two previous figures is the same.

A report can have nested sections, which are sections within sections. For 
example, you can insert a section for several accounts, and you can insert a section 
for the Actual and Budget categories within the account section.
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Book Sections

You can create a book section to retrieve data for a series of dimensions in one 
book. You create or edit a book section to specify the dimensions the section 
includes.

A book section can serve the same purpose as several dimension changes. 
Inserting a book section is more efficient than inserting the dimension changes 
individually. A book section overrides the book and Hyperion Enterprise 
Reporting Windows Client points of view. 

An icon at the end of a section line indicates a dimension section. For a complete 
list of icons the system uses to represent dimensions, see the Quick Tables chapter 
in the Hyperion Enterprise Reporting Windows Client Getting Started Guide. 

Applies To:
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The following figure shows a book with a period section that runs two expense 
reports for three periods. The formula in the formula bar edit box shows the period 
IDs.

Figure 18: Sample Book with Period Section
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The following figure shows how the book would look with separate period 
changes instead of one section.

Figure 19: Sample Book with Separate Period Changes

A book can have nested sections, which are sections within sections. For example, 
you can insert a section for the Sales and Administration accounts, and within that 
section you can insert a section for the January, February, and March periods. 

Dimension Changes in Reports

You can insert a dimension change in a report area to show data for a different 
dimension ID. You can specify a dimension ID, or you can use the @ASK function 
to prompt for a dimension ID each time the report is run. The change remains in 
effect for all columns or rows until you insert another change for that dimension.

Applies To:
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A report dimension change overrides the report and Hyperion Enterprise 
Reporting Windows Client points of view. If you include the report in a book, the 
dimension change also overrides the book point of view. 

When you insert a dimension change, an icon appears in the column or row where 
the dimension change occurs. The ID for the selected dimension change appears 
in the formula bar edit box when you select the icon. You can edit a dimension 
change to use a different ID.

The following figure shows a report with dimension change icons.

Figure 20: Sample Report with Dimension Change Icons
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Dimension Changes in Books

You can insert a dimension change in a book area to show data for a different 
dimension ID. You can specify a dimension ID, or you can use the @ASK function 
to prompt for a dimension ID each time the book is run. The change remains in 
effect until you insert another change for that dimension. A book dimension 
change overrides the book and Hyperion Enterprise Reporting Windows Client 
points of view. 

When you insert a dimension change in a book, an icon for the dimension appears 
at the end of the line where the dimension change occurs. The ID for the dimension 
change appears in the formula bar edit box when you select the icon. The following 
figure shows an entity change line in a book.

Figure 21: Entity Change Line

Using Dimension IDs, Functions, and Lists
You use the Edit Dimensions dialog box to assign dimension IDs, functions, and 
lists for a report, book, section change, or prompt. 

Applies To:
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The following figure shows the Edit Dimensions dialog box and its components. 
For more information about the components, see the topics following the figure.

Figure 22: Edit Dimensions Dialog Box

1. Available List

2. Find Options

3. Available Options

4. Splitter Bar

5. Filters

6. Filters Summary

7. Selected List

8. Parameters

9. Preview
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Available List

You use filters to specify the dimension IDs that appear in the Available list. You 
use find options and available options to find and view dimension IDs, functions 
and lists in the Available list. 

Note: When you assign functions and lists, all the IDs are used in the 
calculations, even if they are not displayed in the Available list.

The following table describes these components.

Dimension IDs that appear in the Available list are proceeded by an icon. The icon 
denotes which dimension IDs are loaded in memory. If you search for an ID, it is 
found only if it is loaded in memory. The following table lists each dimension ID 
icon and its meaning. 

Table 7: Filters, Find Options, and Available Options

Use... To...

Filters Specify which dimension IDs appear in 
the Available list.

Find Options Search the Available list for an item.

Available options View the Available list in a tree or list 
format. You can also specify the 
attributes that appear for each item.

Table 8: Dimension ID Icons 

Icon... Definition...

The top level ID is loaded in List view.

The top level ID is loaded in Tree view.

The top level ID and its children are loaded in Tree 
view, if you used the available options to populate 
the tree. The top level ID and its children or the top 
level ID and all its descendants are loaded in Tree 
view, if you selected the plus icon to populate the 
tree.
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Filters

You use filters to specify which IDs appear in the Available list of a dialog box. 
By using filters you can view only the IDs you need. 

Note: The field and view dimensions do not use filters.

The IDs that appear in the Available list match at least one of the specifications 
within every filter. The range filter is applied last. Initially the filters are set to 
display the top or parent IDs. After you set a filter within an application it remains 
in effect until you change it. 

Note: You can select the filters summary icon to view all the filters that are 
set and their values. 

If you have a large selection of IDs, you should deactivate auto refresh, located in 
available options, until you make your filter selections. You can refresh the 
member selections by selecting the refresh icon.

The following table describes the types of filters you can use.

The top level ID and all its descendents are loaded 
in Tree view.

The bottom level ID is loaded in List view.

Table 9: Filter Types 

Use this filter type... To...

List Specify IDs that match one or more of the selected items 
in the list. For example, using the organization filter, if 
Org1 and Org4 are selected, then all the IDs that are in 
Org1 or Org4 are matching IDs. 

Range Specify IDs within a range. The range is applied to the list 
of IDs after all the other filters have been applied. For 
example, after applying all the filters there are 100 
matching IDs, and the range is set to 5-23. The 5th ID 
through the 23rd ID appear in the Available list. 

Table 8: Dimension ID Icons (Continued)

Icon... Definition...
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 Hyperion Enterprise Example

For example the Parent dimension has four filters which are set as follows:

Organization is set to ORG1 and ORG3

Name is set to d* and f* 

Description is set to *

Range is set with first = 5 and last = 27

All the entity IDs that are part of ORG1 or ORG3, and whose name starts with the 
letter d or the letter f, match the filters. From those IDs the 5th through the 27th 
appear in the Available list. 

 Hyperion Essbase Example

Suppose you have a dimension with the following filters set:

List is set to Gen1, Account

Balance has Opening selected

Name is set to r* w*

All IDs in the Gen1, Account list with an Opening balance, and with a name that 
starts with r or w, appear in the Available list.

Wildcard Specify items using the * or? wildcard symbol. You can 
specify several searches using the blank character as a 
separator. For example, using the name filter, if you 
specify d* w*, all names that start with d or w match. If 
the wildcard text box is blank, no IDs match.

On/Off Specify IDs that match the selected check-box. For 
example, using the subentities filter, if entities with 
substructures are selected, all the IDs with substructures 
are matching IDs. 

Table 9: Filter Types (Continued)

Use this filter type... To...
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Filters Summary

You use the Filters Summary icon to view all the filters that are set and their 
values. 

Find Options

Specify Find Options to search for an item in the Available list. The item must be 
loaded into memory for the find to locate it. For more information on items loaded 
in memory, see Available List on page 82. The Available list drop-down holds the 
last 25 searches. Use Find Next or Find Previous to log searches to the list.

Available Options

Specify Available Options to view the items in the Available list.

Table 10: Find Options

Select... To...

Name Search Search by name.

Description Search Search by description.

Wildcard Search Specify items using the * or ? wildcard symbol. You 
can specify several searches using the blank character 
as a separator. For example, if you specify d* w*, all 
items that start with d or w match.

Case Sensitive Search Perform a case sensitive search.

Auto Search Search the list as you type characters. If this is not 
selected you must press the Find Previous or Find 
Next icons to perform the search.

Table 11: Available Options 

Select... To...

List view Display the items in a list.

Tree View Display the items in a hierarchical 
tree.

Expand All Expand all items in the tree.



86 �

Assigning Dimensions

Hyperion Enterprise Reporting Windows Client User’s Guide

Splitter Bar

You use the splitter bar to size the panes in the window. If there are filters, the 
splitter bar displays in the middle of the dialog box. If there are no filters, the 
splitter bar will display at the bottom of the dialog box by default. After the splitter 
bar has been moved, the specified position becomes the default.

Collapse All Collapse all items in the tree.

Expand Selected Expand all highlighted items in the 
tree.

Collapse Selected Collapse all highlighted items in the 
tree.

Load All Load all descendants starting at the 
top level.

Load Selected Load all descendants of the selected 
IDs.

Auto Refresh Refresh the Available list each time 
a filter changes. If you turn Auto 
Refresh off, you must select the 
Refresh icon to view the filtered 
IDs.

Visible Attributes > 
Attribute List 

To display the attribute.

Table 11: Available Options (Continued)

Select... To...
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Selected List

To assign an item you must add it to the selected list. The following table describes 
the items and icons in the selected list.

Parameters

You use the parameters panel to enter parameters for a function. The following 
table describes the parameters and the icons that proceed them.

Preview

You use preview to view expanded dimension functions and dimension lists from 
the selected list.

This item...
Is preceded by this 
icon...

Top level dimension ID

Bottom level dimension ID

Function

List

If the parameter...
It is Proceeded by 
this icon...

Is required

Is optional 
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Assign Dimension IDs

You can assign specific dimension IDs to report columns and rows or to book 
areas. For example, you can select the period IDs JAN and FEB to assign the 
January and February periods to columns in a report.

➤ To assign dimension IDs:

1. Do one of the following:

� From a report window, select a column or row.

� From a book window, select a line in the book.

2. Select Edit > Dimensions > Dimension, where Dimension is any valid 
dimension.

Tip: You can also select the icon for the dimension from the formula 
bar.

3. To specify the IDs that appear in the Available list, specify the filters.

4. From the Available panel, do one or more of the following:

� Add dimension IDs to the selected report or book area.

� Remove dimension IDs from the selected report or book area. 

� Reorder the dimension IDs.

5. Click OK.

Applies To:
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Assign Dimension Functions

You can assign dimension functions to set up columns or rows with dimension 
settings that change depending on the point of view settings. For example, you 
might set up a report column for the Field dimension. If you assign the Field 
dimension using the @CUR function, the column shows values for the current 
point of view field when you run the report. The functions that are available 
depend on the Hyperion Solutions product you are using, and the dimension that 
you are assigning. 

➤ To assign dimension functions:

1. Do one of the following:

� From a report window, select a column or row.

� From a book window, select a line in the book.

2. Select Edit > Dimensions > Dimension, where Dimension is any valid 
dimension.

Tip: You can also select the icon for the dimension from the formula 
bar.

3. Select the Function tab.

Note: When you assign a function, all the IDs are used in the 
calculation even if the IDs are not displayed in the Available list.

4. Do one or more of the following:

� Add functions to the selected report or book area.

� Specify parameters for the function.

� Remove functions from the selected report or book area. 

� Reorder the functions.

5. To preview expanded dimension functions, click Preview.

Applies To:
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6. Click OK.

Assign Dimension Lists

 Hyperion Enterprise Overview

In a report, you can create a column or row for each entity list or account list, or 
you can use the @ASK function to set up a report to prompt you to select a list 
when you run the report.

 Hyperion Essbase Overview

In a report, you can create a column or row for each level list, generation list, or 
user defined attribute list, or you can use the @ASK function to set up a report to 
prompt you to select a list when you run the report.

Available dimension lists for Hyperion Essbase are: Level lists, Generation lists, 
and User Defined Attribute lists.

➤ To assign dimension lists:

1. Do one of the following:

� From a report window, select a column or row.

� From a book window, select a line in the book.

2. Select Edit > Dimensions > Dimension, where Dimension is Entity or 
Account.

Tip: You can also select the icon for the dimension from the formula 
bar.

Applies To:
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3. Select the List tab.

Note: When you assign a list, all the IDs are used in the calculation even 
if the IDs are not displayed in the Available list.

4. Do one or more of the following:

� Add entity lists, name lists, or account lists to the selected report or book 
area.

� Specify parameters to use with the lists.

� Remove lists from the selected report or book area. 

� Reorder the lists.

5. To preview expanded dimension lists, click Preview.

6. Click OK.

Insert Dimension Changes

You can insert a dimension change in a report or book to show data for a different 
dimension ID. The change remains in effect until you insert another change for that 
dimension. 

A dimension change in a report overrides the report and Hyperion Enterprise 
Reporting Windows Client points of view for that dimension. A dimension change 
in a book overrides the book and Hyperion Enterprise Reporting Windows Client 
points of view.

➤ To insert a dimension change:

1. Do one of the following:

� From a report window, select the report area before which you want to 
insert a dimension change.

Applies To:
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� From a book window, select the line before which you want to insert a 
dimension change.

2. Select Edit > Insert Change > Dimension, where Dimension is any 
dimension.

3. To specify the IDs that appear in the Name list, specify a filter.

4. Select an ID from the ID panel or a function from the Function panel.

5. Click OK. 

Edit Dimension Changes

You can edit the dimensions in a dimension change. For example, suppose you 
change the period to July 1998. If you later want to change the period to August 
1998, you can edit the dimension change.

In a report, a dimension icon appears in each column or row where a change for 
that dimension occurs. In a book, a dimension icon appears at the end of each line 
where a change for that dimension occurs. You can select an icon to edit the 
dimension change that the icon represents.

➤ To edit a dimension change:

1. Do one of the following:

� From a report window, select the icon for the dimension change that you 
want to edit.

Note: Select the dimension change icon only, not the entire row or 
column.

� From a book window, select or double-click a dimension change line.

2. Select Edit > Dimensions > Dimension, where Dimension is the dimension 
that you want to change.

3. To specify the IDs that appear in the Name list, specify a filter.

Applies To:
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4. Select an ID from the ID panel or a function from the Function panel.

5. Click OK.

Insert Sections

You insert a section in a report or book to show data for several dimension IDs. A 
report section overrides the report and Hyperion Enterprise Reporting Windows 
Client points of view. A book section overrides the book and Hyperion Enterprise 
Reporting Windows Client points of view. For example, if a report point-of-view 
account is Direct Labor, you can insert an account section in the report to show 
data for the Purchase Labor and Shipping Supplies accounts instead. 

➤ To insert a report or book section:

1. Do one of the following:

� From a report window, select the column or row before which you want 
to insert the section.

� From a book window, select the line before which you want to insert a 
section.

2. Select Edit > Insert Section > Dimension, where Dimension is any valid 
dimension.

3. To specify the IDs that appear in the Name list, specify a filter.

4. Select one or more IDs or functions for the dimension.

Tip: Once you insert a section, you can label the section, then cut and 
paste the report rows that you want to use in the section. 

5. Click OK.

Applies To:
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Insert Sections within Sections

You can insert sections within sections, which is called nesting sections in a report 
or book. 

The following figure shows a report with a period section nested in an entity 
section.

Figure 23: Sample Report with Period Section Nested in Entity Section

Applies To:
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The following figure shows a book with an account section nested in an entity 
section.

Figure 24: Sample Book with Account Section Nested within Entity Section 

Once you create a section, you can label it so it is easier to work with. You can also 
build a report section using Report Wizard. For more information, see Chapter 7.

➤ To insert a section within a section:

1. To insert a report section, do one of the following:

� In a row, select the cell to the right of the section icon for the section in 
which you want to insert another section.

� In a column, select the cell below the section icon for the section in which 
you want to insert another section.

2. To insert a book section, do the following:

a. Select the section line within which you want to insert another section.

b. Insert any report within the selected section to act as a placeholder for the 
nested section. For instructions, see Insert Reports in Books on page 63.

c. Select the line that contains the placeholder report. 
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3. Select Edit > Insert Section > Dimension, where Dimension is any valid 
dimension.

4. To specify the IDs that appear in the Name list, specify a filter.

5. Select the items that you want to include in the section, then click OK.

6. If you are inserting a book section, delete the line that contains the placeholder 
report. 

Edit Sections

A section sets up columns or rows for a series of dimension IDs. It serves the same 
purpose as several dimension changes and is more efficient than inserting the 
dimension changes individually. You can edit a report or book section to change 
the dimension IDs the section includes. 

➤ To edit a section:

1. From a report or book window, select the section that you want to edit. 

2. Select Edit > Dimensions > Dimension, where Dimension is the dimension 
for the section. 

3. To specify the IDs that appear in the Name list, specify a filter.

4. Select the items that you want to include in the section, then click OK.

Applies To:



Assigning Dimensions

� 97Hyperion Enterprise Reporting Windows Client User’s Guide

5

Assign Values for Prompts

When you insert reports in a book, you can assign values for any prompts in the 
reports so that the prompts do not appear when you run the book. For example, if 
a report prompts for a category, you can specify the Actual category when you 
insert the report in a book. When you run the book, the report retrieves Actual data 
without prompting for a category.

Before you assign values for prompts in a book, you must preview the reports in 
the book to determine which reports include prompts, and for which dimensions. 
For more information, see Reporting Batch Commands, Batch Files, and Task 
Files on page 198.

You can assign values for some prompts in a report without assigning values for 
other prompts in the same report. For example, if a report prompts for a category 
and a period, you can assign a value for the category prompt without assigning a 
value for the period prompt. When you run the book, the report prompts you for a 
period, but not for a category.

➤ To assign a value for a prompt in a report:

1. From a book window, select the line for the report that contains the prompt.

2. Select Edit > Paste Prompt Values > Dimension, where Dimension is the 
dimension for the prompt.

3. To specify the IDs that appear in the Name list, specify a filter.

4. Select one or more IDs or functions.

Tip: If you show data formulas in the formula bar edit box, you can type IDs 
and functions instead of selecting them. 

5. Click OK. 

Applies To:
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Using Data and Heading 
Formulas 

You use formulas in a report to retrieve or to calculate data or display text. Data 
formulas contain financial functions and other expressions for calculating data in 
report columns and rows. Many data formulas require you to specify parameters. 
Heading formulas contain text functions for displaying text in column and row 
headings.

You use the formula bar edit box or the Edit Formulas toolbar icon to create and 
edit formulas. You can toggle between showing data formulas or heading formulas 
with the View > Formula Bar menu command or the View Data > Heading 
Formula toolbar icon. For more information, see the Hyperion Enterprise 
Reporting Windows Client Getting Started Guide.

Heading Formulas

You use heading formulas to specify text for column and row headings. You can 
also use heading formulas to create columns and rows that contain only text. You 
can type text in the formula bar edit box to enter it in the selected column or row 
or use the Edit Formulas toolbar icon. 

You also use heading formulas in headers and footers. You can use text fields to 
include notations and local headings in reports. For more information about 
notations and local headings, see Notations and Local Headings Setup on 
page 169.

Applies To:

6
Chapter
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Text Entry Rules 
You enter text in the formula bar edit box. The rules for entering text depend on 
whether the formula bar edit box shows heading formulas or data formulas. Follow 
these guidelines for entering text in reports:

� If the formula bar edit box shows data formulas, enclose the text that you type 
in quotation marks ( “ “ ).

� If the formula bar edit box shows heading formulas, do not enclose the text 
that you type in quotation marks. 

For more information about viewing data formulas and heading formulas, see the 
Hyperion Enterprise Reporting Windows Client Getting Started Guide.

Data Formulas

Data formulas can use dimension expressions, which include keywords, to retrieve 
data for specific dimension IDs. They can also use financial functions and other 
expressions, such as arithmetical operators and numbers, to produce data. For 
example, this data formula uses the financial function AVG to show the average 
value for the rows 1, 3, and 7:

AVG(1, 3, 7)

You can use the formula bar edit box or the Edit Formulas toolbar icon to create 
or edit formulas in a column or row. For more information, see the Hyperion 
Enterprise Reporting Windows Client Getting Started Guide. 

Applies To:
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Expressions

You use expressions in data formulas for columns and rows to determine the data 
that columns and rows show. For example, this row formula consists of an 
expression that multiplies the data in row 3 by the data in row 4:

[3] * [4]

Some financial functions require expressions as part of their syntax. For example, 
the SUM function requires an expression that specifies which columns or rows the 
function adds. 

Expressions can include operators, which are symbols that perform arithmetical 
tasks or comparisons, and operands, which specify the values an operator uses to 
produce a result. They can also include functions and other expressions, such as 
dimensions.

When you select a financial function that requires an expression, you access a 
dialog box where you build the expression graphically. The expression appears 
with the function in the formula bar edit box when you show data formulas. You 
can also create or edit expressions in the formula bar edit box without opening 
dialog boxes.

Operators in Expressions

Operators are symbols that perform arithmetical tasks or comparisons, refer to 
ranges of columns or rows, or introduce text in formulas. Natural precedence 
determines the order the system follows for carrying out operations in an 
expression with more than one operator.

Applies To:

Applies To:
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The following table explains the types of operators that expressions in data 
formulas and criteria statements can include.

Table 12: Operators 

Type Operator Description Example

Arithmetical + Adds This row formula adds the 
values in rows 4 and 5:
[4] + [5]

Arithmetical - Subtracts This row formula subtracts 3 
from the values in row 4:
[4] - 3

Arithmetical * Multiplies This row formula multiplies the 
absolute values in row 4 by 150:
ABS[4] * 150 

Arithmetical / Divides This row formula divides the 
values in row 4 by the values in 
row 5:
[4] / [5]

Reference : Specifies a 
range with the 
SUM function

This row formula adds the 
values in rows 4 through 12:
SUM (4:12)

Unary minus - Changes the 
sign of a value

This column expression divides 
the values in column 4 by 12 
and changes the sign of the 
result:
-([4] / 12)

Criteria IS Has a specified 
attribute

This criteria statement tests 
values for the Asset attribute 
and applies any conditional 
formatting to values that have it:
VALUE IS ASSET

Criteria IS NOT Does not have 
a specified 
attribute

This criteria statement tests 
values for the Liability attribute 
and applies any conditional 
formatting to values that do not 
have it:
VALUE IS NOT LIABILITY
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Criteria AND And This criteria statement applies 
conditional formatting to values 
greater than 50 and less than 
250:
VALUE > 50 AND < 250

Criteria BETWEEN Is between This criteria statement applies 
any conditional formatting to 
values in the selected column or 
row if they are between 100 and 
200:
VALUE BETWEEN 100, 200

Criteria OR Or This criteria statement 
determines test values for the 
Liability and Expense attributes 
and applies any conditional 
formatting to values that do not 
have either of those attributes:
VALUE IS NOT LIABILITY 
OR EXPENSE

Criteria NOT Is not This criteria statement applies 
any conditional formatting if the 
result is not more than 75: 
NOT (VALUE > 75)

Criteria = Equal to This criteria statement applies 
any conditional formatting to all 
values of 100:
VALUE = 100

Criteria < Less than This criteria statement applies 
any conditional formatting to all 
values less than 100:
VALUE < 100

Table 12: Operators (Continued)

Type Operator Description Example
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Except for the IS and IS NOT operators, you can use the criteria operators in 
formulas for columns and rows as well as in criteria statements. For example, the 
following row formula compares each value in row 4 with 150:

[4] <> 150

The previous formula produces a 1 for each column where the value in row 4 is 
less than or greater than 150. For each column where the value in row 4 equals 150, 
the result is a 0 (zero).

Criteria > Greater than This criteria statement applies 
any conditional formatting to 
values in the selected column or 
row if they are greater than the 
corresponding values in column 
6:
VALUE > [6]

Criteria <= Less than or 
equal to

This criteria statement applies 
any conditional formatting to 
values in the selected column or 
row if they are less than or equal 
to the corresponding values in 
column 6:
VALUE <= [6]

Criteria >= Greater than or 
equal to

This criteria statement applies 
any conditional formatting to 
values in the selected column or 
row if they are greater than or 
equal to the corresponding 
values in column 6:
VALUE >= [6]

Criteria <> Not equal to This criteria statement applies 
any conditional formatting to 
values in the selected column or 
row that do not equal the 
corresponding values in column 
6:
VALUE <> [6]

Table 12: Operators (Continued)

Type Operator Description Example
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Natural Precedence

If an expression has two or more operators, the system performs the operations in 
the order of the operators’ natural precedence. Here is the order of natural 
precedence that the system follows for performing operations in an expression that 
has more than one operator:

� unary minus and NOT

� (x) multiplication and (/) division

� (-) subtraction and (+) addition

� (=) equals and (-) subtraction

� (<) less than, (>) greater than, (>=) greater than or equal to, and (<=) less than 
or equal to

� (=) equals and (<>) does not equal

� AND

� OR

For example, suppose a row formula uses this expression:

[10] + 3 * 4

In this example, if a column in row 10 has a value of 8, the above expression 
produces a value of 20 for that column by calculating 3 * 4 + 8 = 20, following the 
order of natural precedence.

Applies To:



106 �

Using Data and Heading Formulas

Hyperion Enterprise Reporting Windows Client User’s Guide

Operands in Expressions

Operands specify what values an operator uses to produce a result. The following 
table explains the types of operands.

Note: You use the VALUE operand in criteria statements only. You add it to 
a criteria statement by pasting the Current Value variable.

In this row formula, which consists of an expression that multiplies the values in 
row 3 by 100, the row reference [3] and the absolute 100 are both operands:

[3] * 100

Applies To:

Table 13: Operands  

Type of Operand Examples

Absolute 3, 0.0, 27.5, 65.1987

Row or column reference [1], [4], [8]

Database retrieval [ACC SALES CAT BUDGET],
[DAT @CUR CAT ACTUAL]

Functions AVG, BET, CHG

VALUE This criteria statement applies conditional 
formatting to all values greater than 100:
VALUE > 100
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Keywords

Each dimension in a Hyperion Enterprise product application has a keyword that 
identifies the dimension. Hyperion Enterprise Reporting Windows Client 
formulas can use keywords with IDs, functions, or both to retrieve data for the 
dimensions. 

The dimensions in the current application determine what keywords can appear in 
the formulas you create in Hyperion Enterprise Reporting Windows Client. 

The following keywords represent the dimensions in Hyperion Enterprise 
applications: 

� ACC - Account  

� CAT - Category 

� CONSOL - Consolidation Detail 

� CURR - Currency 

� DAT - Period 

� ENT - Entity 

� FIE - Field  

� FRE - Frequency  

� PAR - Parent 

� SUBACC1 - First Subaccount Set  

� SUBACC2  - Second Subaccount Set  

� SUBENT - Subentity 

Applies To:
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ACC - Account 

The ACC keyword creates columns or rows for accounts. Formulas that use the 
ACC keyword also use IDs or these functions to specify accounts:

� @ALL

� AS

� @ASK

� @CUR

� @SUB

The ACC keyword appears in this format when you assign individual accounts 
rather than a range of accounts: 

ACC Account1[,...Accountn]

This formula creates a series of columns or rows for the Sales, Rentals, and Service 
accounts:

ACC SALES, RENTALS, SERVICE

The ACC keyword appears in this format when you create columns or rows for a 
range of consecutive accounts:

ACC FROM First UNTIL Last 

Applies To:

Where... Is...

Account1 An ID or function for the first account you are assigning. 

Accountn An ID or function for the last account you are assigning. 

Where... Is...

First An ID or function for the first account in the range. 

Last An ID or function for the last account in the range. 
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For example, this formula creates columns of data for a range of accounts that 
begins with Sales, ends with Net Income, and includes all first-level subaccounts:

ACC FROM SALES UNTIL NETINC WITHSUB1

Note: The function WITHSUB or WITHSUB1 appears if you select the 
Include Subaccounts or Include First Level Subaccounts option in the 
Edit Dimensions - Account dialog box. 

CAT - Category

The CAT keyword creates columns or rows for data categories. Formulas that use 
the CAT keyword can use IDs to specify categories, or they can use the AS, 
@ASK, and @CUR functions. 

The CAT keyword appears in this format:

CAT Category1[,...,Categoryn]

For example, this formula creates a column or row for the Actual category:

CAT ACTUAL

This formula creates columns or rows for the Actual and Budget categories: 

CAT ACTUAL, BUDGET

Applies To:

Where... Is...

Category1  The first category you are assigning. 

Categoryn  The last category you are assigning. 



110 �

Using Data and Heading Formulas

Hyperion Enterprise Reporting Windows Client User’s Guide

CONSOL - Consolidation Detail 

The CONSOL keyword creates columns or rows that show data for specific 
consolidation detail. 

For example, this formula retrieves elimination data for the current dimension 
settings:

CONSOL Elimination

Note: When you assign consolidation details using the function method, 
you can select any of these functions for use with the CONSOL 
keyword:

� AS

� @ASK

� @CUR

The CONSOL keyword appears in this format when you assign consolidation 
details using the ID method:

CONSOL Detail 

Applies To:

Where... Is...

Detail Adjustment, Contribution, Elimination, NONE, Proportion, or 
Translation. The default is NONE, for no consolidation detail.
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CURR - Currency 

The CURR keyword creates columns or rows for currencies. Formulas that use the 
CURR keyword can use IDs to specify currencies, or they can use the AS, @ASK, 
or @CUR function. 

You can use the currency dimension to show amounts for several entities in one 
currency rather than in the currency of each entity. For example, suppose a report 
has rows for France, Italy, and Germany. Using the CURR keyword, you can set 
up the columns to show all amounts in lire rather than show amounts for France in 
francs, amounts for Italy in lire, and amounts for Germany in deutschemarks. 

The CURR keyword appears in this format:

Table 14: Consolidation Detail Types

Type Description

Adjustment consolidation 
detail

The total balance of all parent journal adjustments 
made to the amount that the dependent contributes 
to the parent.

Contribution consolidation 
detail

The sum of the adjustment, elimination, 
proportion, and translation detail that rolls up to the 
parent.

Elimination consolidation 
detail

The amount that consolidates to the parent after 
intercompany eliminations.

Proportion consolidation 
detail

The amount of the dependent entity’s translated 
value that the parent owns.

Translation consolidation 
detail

The result of the dependent entity’s base data 
translated to its parent’s currency.

Applies To:
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CURR Currency1[,..., Currencyn]

For example, this formula retrieves data in French francs:

CURR FF

This formula creates columns or rows for U.S. dollars, French francs, and German 
deutschemarks: 

CURR USD, FF, DM

DAT - Period 

The DAT keyword creates columns or rows for periods. Formulas that use the 
DAT keyword also use IDs or numbers to specify periods, or they can use any of 
these functions:

� AS

� @ASK

� @CMO

� @CUR

� @END

� @START

The DAT keyword appears in this format when you assign individual periods 
rather than a range of periods: 

Where... Is...

Currency1  The first currency you are assigning. 

Currencyn  The last currency you are assigning. 

Applies To:
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DAT Period1[,..., Periodn]

This formula sets up a column or row for the period prior to the current period:

DAT @CUR-1

If you run the report and the current period is March, the formula retrieves 
February values.

The DAT keyword appears in this format when you create columns or rows for a 
range of consecutive periods:

DAT FROM First UNTIL Last 

This formula sets up columns or rows from the FEB period to the current entity’s 
ending period:

DAT FROM FEB UNTIL @END

ENT - Entity

The ENT keyword creates columns or rows for entities. Formulas that use the ENT 
keyword also use IDs or these functions to specify entities:

Where... Is...

Period1 An ID, number, or function for the first period you are assigning.

Periodn An ID, number, or function for the last period you are assigning.

Where... Is...

First An ID, number, or function for the first period in the range.

Last An ID, number, or function for the last period in the range.

Applies To:

• @ALL • @CON

• AS • @CUR
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The ENT keyword appears in this format:

ENT Entity1[,...,Entityn]

For example, this formula retrieves data for the JUNIPER entity:

ENT JUNIPER

This formula creates columns or rows for the DIAMOND, JUNIPER, and 
PEBBLE entities: 

ENT DIAMOND, JUNIPER, PEBBLE

FIE - Field 

The FIE keyword creates columns or rows for fields. Formulas that use the FIE 
keyword can use IDs to specify fields, or they can use the AS, @ASK, or @CUR 
function. 

The FIE keyword appears in this format:

FIE Field1[,..., Fieldn]

• @ASK • @DEP

• @BAS • @PAR

Where... Is...

Entity1  The first entity you are assigning. 

Entityn  The last entity you are assigning. 

Applies To:

Where... Is...

Field1  The first field you are assigning. 

Fieldn  The last field you are assigning. 
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You can use the ID method to assign any of these fields: A24, BAS, Credits, CUM, 
Debits, DIF, DWV, OPE, PRE, or VAL.

In Hyperion Enterprise, you can also use the ID method to assign any of these 
fields: IC1, IC2, PCONS, PCTRL, POWN, SHAROS, SHAROW, VSHAROS, 
and VSHAROW.

Note: The default field is VAL.

For example, this formula retrieves data for the previous period for the current 
dimension settings:

FIE PRE

This formula creates columns or rows for the OPE, PRE, and VAL fields:

FIE OPE, PRE, VAL

BAS Field

The BAS field retrieves the beginning balance for the current dimension settings.

The value that the BAS field produces depends on the account type. For an 
account, which has a type Asset, Balance, or Liability the BAS field always shows 
the beginning balance. For an account, which has an account type Expense, Flow, 
or Income, the BAS field always shows 0 (zero) as the base value.

For example, this formula retrieves the base value of the Cash account:

FIE BAS ACC CASH

Debits Field

The Debits field retrieves the total debits for the current dimension settings.

Credits Field

The Credits field retrieves the total credits for the current dimension settings.
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IC1 Field

The IC1 field exchanges the current entity with the current first-level subaccount. 
For example, if you set up rows in an intercompany matching report for an entity 
and first-level subaccounts from the IC subaccount table, you should set up a 
column for a major account and the IC1 field to show values for the entities in the 
subaccount table. 

IC2 Field

The IC2 field exchanges the current entity with the current second-level 
subaccount. For example, if you set up rows in an intercompany matching report 
for an entity and second-level subaccounts from the IC subaccount table, you 
should set up a column for a major account and the IC2 field to show values for 
the entities in the subaccount table. 

SHAROS Field

The SHAROS field retrieves the total shares outstanding for the current dimension 
settings.

VSHAROS Field

The VSHAROS field retrieves the total voting shares outstanding for the current 
dimension settings.

SHAROW Field

The SHAROW field retrieves the total shares owned for the current dimension 
settings.

VSHAROW Field

The VSHAROW field retrieves the total voting shares owned for the current 
dimension settings.

PCTRL Field

The PCTRL field retrieves the ultimate percent control value for the current 
dimension settings.
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PCONS Field

The PCONS field retrieves the percent consolidation value for the current 
dimension settings.

POWN Field

The POWN field retrieves the ultimate percent ownership value for the current 
dimension settings.

A24 Field

The A24 field retrieves the 24-point average for a Balance, Asset, or Liability 
account. You can use the A24 field only for year-to-date views that are linked to 
prior categories. The system uses this formula to calculate the 24-point average:

This formula calculates the 24-point average of the Cash account:

FIE A24 ACC CASH

DIF Field

The DIF field calculates the difference between the current period’s value and the 
previous period’s value for the current dimension settings.

For example, this formula calculates the difference in the Cash account between 
the previous period and the current period:

FIE DIF ACC CASH

DWV 

The DWV field calculates the average days weighted value for the current 
dimension settings. It is useful for calculating a weighted average of sales when 
periods, such as months, are not equal in length.

Note: The DWV calculation uses the Days-in-Month Account setting in the 
Report Options dialog box. You access this dialog box from the Task 
menu.

OpeningBalance SumofStartPeriodthroughPreviousPeriod(( ) 2 ) CurrentPeriod+×+
2 NumberofElapsedPeriods×

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
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For each period, the system multiplies the account value by the number of days in 
the period and keeps a running total of the result. The system also keeps a running 
total of the number of days in each period. The DWV field divides the running total 
weight factor by the running total of the number of days in each period to automate 
these two calculations:

For example, this formula calculates the weighted average of the Sales account:

FIE DWV ACC SALES

CUM Field

The CUM field retrieves cumulative values from the starting period of the current 
category for the current dimension settings.

VAL Field

The VAL field retrieves the value for the current dimension settings.

OPE Filed

For Income, Expense, and Flow accounts, the OPE field retrieves the opening 
value for the current dimension settings. For Asset, Liability, and Balance 
accounts, the OPE field shows the ending balance for the previous category.

PRE Field

The PRE field shows amounts from the previous period for the current dimension 
settings.

For example, this formula retrieves the Cash account’s value for the previous 
period:

FIE PRE ACC CASH

Note: If the reporting period is the first period for the current category, and 
the category is linked to a prior category, the system retrieves the 
value for the last period for the prior category.

WeightedFactor Account )( NumberofDaysinPeriod( )×=

WeightedFactor RunningTotalWeightFactor=( )
RunningTotalDays

----------------------------------------------------------------------------------------------------------------------------------
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FRE - Frequency 

The FRE keyword creates columns or rows for frequency and view combinations. 
Formulas that use the FRE keyword can use IDs to specify frequencies and views, 
or they can use the AS, @ASK, and @CUR functions. 

Note: The frequency you assign must have no more periods per fiscal year 
than the current category’s frequency. For example, if the current 
entity’s frequency is quarterly, you can assign a yearly frequency but 
not a monthly frequency.

The FRE keyword appears in this format:

FRE Frequency1.View1[,…,Frequencyn.Viewn]

For example, this formula retrieves data with a monthly frequency and 
year-to-date view:

FRE M.YTD

This formula creates columns or rows for the Monthly Periodic and Quarterly 
Year-to-Date frequencies: 

FRE M.PER, Q.YTD

Applies To:

Where... Is...

Frequency1  A frequency ID or function for the first frequency you are 
assigning. 

View1  A view ID or function for the first frequency you are assigning. 

Frequencyn  A frequency ID or function for the last frequency you are 
assigning. 

Viewn  A view ID or function for the last frequency you are assigning. 
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The following table explains the frequency IDs.

The following table explains the view IDs.

Table 15: Reporting Frequencies

This frequency... Retrieves...

D Daily data.

W Weekly data.

M Monthly data.

Q Quarterly data.

T Trimesterly data.

H Half-yearly data.

Y Yearly data.

Table 16: View IDs

This view... Retrieves...

PER Periodic values, which are not accumulated over several 
periods.

WTD Accumulated values from the beginning of the current week.

MTD Accumulated values from the beginning of the current month.

QTD Accumulated values from the beginning of the current quarter.

TTD Accumulated values from the beginning of the current 
trimester.

HTD Accumulated values from the beginning of the current 
half-year.

CTD Accumulated values from the beginning of the current 
category.

YTD Accumulated values from the beginning of the current calendar 
year.
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PAR - Parent Entity 

The PAR keyword creates columns or rows for parent entities. In an organization 
that changes by period, the parent dimension sets the relationship the report uses 
for the entities specified in the report. Formulas that use the PAR keyword also use 
IDs or these functions to specify parents:

The PAR keyword appears in this format:

PAR Entity1[Entity,...,Entityn]

For example, this formula retrieves data for the COMP1 entity:

PAR COMP1

This formula retrieves columns for the COMP1 and COMP2 entities:

PAR COMP1,COMP2

Applies To:

• @ALL • @CUR

• AS • @DEP

• @ASK • @ENT

• @BAS • @PAR

• @CON

Where... Is...

Entity1 The entity for the first column or row.

Entity An entity ID, a function, or NONE.

Entityn The entity for the last column or row.
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SUBACC1 - First Subaccount Set 

The SUBACC1 keyword creates columns or rows for the first or only set of 
subaccounts in a specified table. Formulas that use the SUBACC1 keyword also 
use IDs or these functions to specify subaccounts:

� @ALL

� AS

� @ASK

� @CUR

Note: SUBACC1 is not reserved for first-level subaccounts. 

The SUBACC1 keyword appears in this format when you assign individual 
subaccounts rather than a range of subaccounts:

SUBACC1 Table1.Subacct1[,...,Tablen.Subacctn]

This formula creates columns containing data for the SHOES subaccount in the 
PRODUCT subaccount table, the BALLS subaccount in the PROD subaccount 
table, and the TENNIS subaccount in the DIVISION subaccount table:

SUBACC1 PRODUCT.SHOES,PROD.BALLS,DIVISION.TENNIS

The SUBACC1 keyword appears in this format when you create columns or rows 
for a range of consecutive subaccounts in a subaccount table:

Applies To:

Where... Is...

Table1 The first subaccount table in a list.

Subacct1 The subaccount in the first subaccount table.

Tablen The last subaccount table in a list.

Subacctn The subaccount in the last subaccount table.
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SUBACC1 FROM Table.Subacct1 UNTIL Subacctn

This formula creates rows for the BALLS through the SHOES subaccounts in the 
PROD subaccount table:

SUBACC1 FROM PROD.BALLS UNTIL SHOES

SUBACC2 - Second Subaccount Set 

The SUBACC2 keyword creates columns or rows for the second set of 
subaccounts in a specified table. Formulas that use the SUBACC2 keyword also 
use IDs or these functions to specify subaccounts:

� @ALL

� AS

� @ASK

� @CUR

Note: SUBACC2 is not reserved for second-level subaccounts. 

The SUBACC2 keyword appears in this format:

SUBACC2 Table1.Subacct1[,...,Tablen.Subacctn]

Where... Is...

Table The subaccount table.

Subacct1 The first subaccount in a range.

Subacctn The last subaccount in a range.

Applies To:

Where... Is...

Table1 The first subaccount table in a list.

Subacct1 The subaccount in the first subaccount table.
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This formula creates columns containing data for the SHOES subaccount in the 
PRODUCT subaccount table, the BALLS subaccount in the PROD subaccount 
table, and the TENNIS subaccount in the DIVISION subaccount table:

SUBACC2 PRODUCT.SHOES,PROD.BALLS,DIVISION.TENNIS

The SUBACC2 keyword appears in this format when you create columns or rows 
for a range of consecutive subaccounts in a subaccount table:

SUBACC1 FROM Table.Subacct1 UNTIL Subacctn

This formula creates rows for the BALLS through the SHOES subaccounts in the 
PROD subaccount table:

SUBACC2 FROM PROD.BALLS UNTIL SHOES

SUBENT - Subentity 

The SUBENT keyword creates columns or rows for subentities. Formulas that use 
the SUBENT keyword can use IDs to specify subentities, or they can use the 
@ASK or @CUR function. 

Tablen The last subaccount table in a list.

Subacctn The subaccount in the last subaccount table.

Where... Is...

Table The subaccount table.

Subacct1 The first subaccount in a range.

Subacctn The last subaccount in a range.

Applies To:

Where... Is...
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The SUBENT keyword appears in this format:

SUBENT Subentity1[,...,Subentityn]

For example, this formula creates columns for the post-adjustment and base 
subentities:

SUBENT PADJ,BASE

Edit Data Formulas

Data formulas contain financial functions or dimension expressions for column 
and row values. You can use financial functions in data formulas to perform 
calculations. 

Many financial functions require you to specify parameters. For example, if you 
paste the CHG financial function to calculate the difference between values in two 
columns or rows, you then must type the numbers of the columns or rows that you 
want to compare. 

With some financial functions, you can use expressions that specify dimensions. 
You can paste the dimensions in the expressions using either the ID or function 
method. Expressions can also include arithmetical symbols, and they can refer to 
columns and rows by their number. 

For example, you might paste the function ABS to produce the absolute value of 
an expression. You can then create the expression by pasting the Sales account 
dimension, a minus sign, and the Cost of Sales account dimension. The resulting 
formula produces the absolute value of Sales less the Cost of Sales.

Where... Is...

Subentity1 An ID or function for the first subentity you are assigning.

Subentityn An ID or function for the last subentity you are assigning.

Applies To:
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The following table shows the financial functions that you can paste into a data 
formula for a column or row in reports for any Hyperion Solutions product 
application. 

Table 17: Financial Functions 

Use this function... To...

ABS Produce the absolute value for an expression. 

AVG Calculate the average value for a group of columns or rows.

BET Calculate the difference between the values in two columns 
or rows, and determine whether the difference represents 
better or worse variance.

CELL Retrieve a value from another cell to be used in an 
expression.

CHG Calculate the difference between the values in two columns 
or rows without evaluating the difference.

CPN Retrieves the number of the current period.

DUR Display a specific value or expression result in a range of 
columns or rows.

IFT Display a specific value or expression result depending on 
whether the result of an expression is negative, equal to zero, 
or positive.

MUL Multiply the values of two columns or rows.

PBE Calculate the percentage change between the values in two 
columns or rows, and determine whether the difference 
represents better or worse variance.

PCH Calculate the percentage change between the values in two 
columns or rows, without evaluating whether the difference 
represents better or worse variance.

PCR Calculate the values in a specified column as a percentage of 
the values in a specified row, or the values in a specified row 
as a percentage of the values in a specified column.

PCT Express the ratio between the values in two columns as 
percentages.

RAT Calculate the ratios of the values in two columns or rows.
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➤ To edit a data formula:

1. From a report window, select a column or row.

2. Select Edit > Formulas or the Edit Formulas toolbar icon, or press Shift + F2.

3. To create or edit a data formula, select a data formula type from the Type 
drop-down list, then do one of the following:

� For data formulas that contain financial functions, select a function from 
the Function drop-down list, click the Paste Function icon, then select or 
type any parameters the function requires. For information about the 
function you select, click the Function Help icon.

� For data formulas that contain dimension expressions, select a dimension 
from the Dimension drop-down list, click the Dimension icon, then select 
the dimension or type any parameters the dimension requires.

Note: If you change the data formula type, the system erases the current 
formula.

4. Click OK.

Tip: Instead of selecting financial functions or dimension expressions 
and parameters to paste into data formulas, you can type them in 
the formula bar edit box. 

RND Round the result of an expression.

SUM Add the values of specified columns or rows.

Table 17: Financial Functions (Continued)

Use this function... To...
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View Definitions

Column and row headings appear in report windows by default, but you can use 
the Definitions command on the View menu to show the formulas for the data in 
the columns and rows instead. The Definitions command affects the report 
window only, not report previews or printed copies.

For example, suppose you set up a column with this heading to show the positive 
or negative percentage difference between the values in columns 3 and 7: 

Percent Change

The heading appears in the report window by default. If you select the Definitions 
command, this formula appears in the report window in place of the column 
heading:

PBE [3,7]

➤ To view definitions, from a report window, select View > Definitions. 

Note: A check mark appears to the left of the Definitions command on 
the menu when the command is selected.

Edit Heading Formulas

You can use text functions in a heading formula to retrieve text in a report, such as 
dimension IDs or descriptions. For example, you might use the @DES function to 
show the descriptions for the dimension IDs that you assign to a column. 

Applies To:

Applies To:
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➤ To edit a heading formula:

1. From a report window, select a column or row.

2. Select Edit > Formulas or the Edit Formulas toolbar icon, then select the 
Heading tab.

3. From the Function drop-down list, select the function you want to paste, select 
or type any parameters that the function requires, then click the Paste Function 
icon. 

Tip: For information about the function you select, click the Function 
Help icon. Instead of selecting text functions and parameters to 
paste into heading formulas, you can type them in the formula bar 
edit box.

4. Click OK.
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Using Report Wizard 

Report Wizard is a graphical tool for creating dynamic ad hoc queries within 
Hyperion Enterprise Reporting Windows Client. The following figure shows a 
Report Wizard query.

Figure 25: Report Wizard Query

You can move dimensions between the query point of view and the columns and 
rows of the query. You can also change the order of the dimensions within the 
columns and rows. 

7
Chapter
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You can load a Hyperion Analyst query as a starting point for a Report Wizard 
query. You can preview a Report Wizard query to see how it would look as a 
report, and you can display the query results in the active report window.

Report Wizard Icons

The following table describes the four icons that appear to the right of the Report 
axis.

Applies To:

Table 18: Report Wizard Icons

Use this icon... To...

Set suppression and display options in the Pivot Table Options 
dialog box. 

Load a Hyperion Analyst .HAQ file as a starting point for a 
Report Wizard query. 

Preview a Report Wizard query as a report.

 View or edit the EXPAND.REL file, which determines the 
results of expansions.
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Create Queries

You create a Report Wizard query by assigning dimensions to columns and rows. 
The query retrieves data after you assign at least one dimension to columns and at 
least one dimension to rows. 

All dimensions on the point of view bar are displayed initially on the Report axis, 
which appears under the point of view bar. You can move dimensions between the 
point of view bar and the Columns and Rows axes at any time. You can also move 
dimensions between the Columns and Rows axes, and you can move dimensions 
within an axis to change the order of dimensions in the query. 

➤ To create a query:

1. From a report window, select Task > Report Wizard. 

Note: If you change the point of view for a query, your changes do not 
affect Hyperion Enterprise Reporting Windows Client. If you 
save the query as a report, the point of view is not saved with it. 

2. Drag a dimension from the Report axis to the Rows axis and select one or more 
values for that dimension.

Note: The function panels in the Edit Dimensions dialog boxes show 
only the functions that apply to queries. 

3. Drag another dimension from the Report axis to the Columns axis, then select 
one or more values for that dimension. 

4. To nest dimensions, drag one or more additional dimensions to the Columns 
or Rows axis.

5. To remove a dimension from the rows of the query, drag the dimension to the 
point of view bar or to the Columns axis.

6. To remove a dimension from the columns of the query, drag the dimension to 
the point of view bar or to the Rows axis.

Applies To:
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7. To exit the query, do one of the following:

� To display the query as a report in the active report window, click OK.

� To exit the query without displaying it in the active report window, click 
Cancel.

Note: If you display the query as a report, the new report replaces the 
contents of the active report. Hyperion Enterprise Reporting 
Windows Client places any essential dimensions that are not used 
in columns or rows in the report header.

Nested Dimensions

When you add dimensions and dimension values to columns or rows that already 
contain one or more dimensions, the additional dimension values are nested. The 
nested dimensions appear in a section for each of the dimension IDs that were 
already in the column or row. 

Applies To:
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The following figure shows a query with accounts added to rows that already 
contained entities.

Figure 26: Query with Nested Account Sections

Note: Sections appear bold and indented by default.

Expand or Collapse Dimension Values

A dimension value with a plus sign ( + ) to its left contains summary data, and you 
can expand the dimension value to show detail data. A dimension value with a 
minus sign ( - ) to its left can be collapsed to hide detail data that is currently 
displayed. 

Applies To:
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In the following figure, the USA and CANADA entities are expandable.

Figure 27: Report Wizard Query with Data
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You can expand TOP to show data for the dependents of TOP. From this expanded 
view, you can double-click on TOP to hide the detail and show only the summary 
values, as shown in the following figure. 

Figure 28: Report Wizard Query with Expanded Entity

➤ To expand or collapse a dimension value, do one of the following:

� To expand a value, double-click on a value that is preceded by a plus sign ( + ).

� To collapse a value, double-click on a value that is preceded by a minus sign 
( - ).
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Display Queries as Reports

When you finish building a Report Wizard query, you can display the query as a 
report. The results replace any previous content in the report window.

If the report window already contains a saved report when you display the query 
as a report, the report file name does not change. If you save the report, the query 
results overwrite the previous contents of the report.

➤ To display a query as a report:

1. From the Report Wizard dialog box, click OK. 

2. Click Yes when Hyperion Enterprise Reporting Windows Client prompts you 
to overwrite the current report. This returns you to the report window, where 
the query results appear.

Applies To:
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Formatting Reports

The format of a report determines how the output looks when you print or preview 
the report. The format specifies column widths, fonts for titles, headings, data, and 
other attributes of the report’s appearance. You can use the default format, or you 
can select a report area and specify format characteristics for it. 

Report Formatting Controls

You can select these report areas and set formatting options for them while you are 
building a report:

� The entire report

� All data

� All column or row headings

� Entire columns or rows

� Data in individual columns or rows

� Individual column or row headings

The report area that you select determines which formatting options are available. 
For example, if you select column headings, you can set font options, but you 
cannot set number options because number formatting does not apply to headings. 

Applies To:

8
Chapter



140 �

Formatting Reports

Hyperion Enterprise Reporting Windows Client User’s Guide

The following table describes the formatting options.

Note: When you select a command from the Format menu, some of the 
options that appear are available only under certain conditions. For 
example, the Page Orientation options in the Spacing panel are 
available only if you select the entire report. When you follow the 
procedures, skip any steps involving options that are unavailable.

Table 19: Format Options 

Select... To specify...

Font • A font.

• A point size.

• Underlining or overlining.

• Color.

• Justification.

• Italics or bold.

• Hidden columns or rows.

Shading/ Border • Light, dark, or no shading.

• Borders and grids.

Number • Scaling by a power of 10.

• A format for numerical values.

• A rounding factor for numerical values.

• Calculation of rows before columns or columns before rows.

• The account attribute for columns or rows with calculations 
involving conflicting account attributes.
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Spacing • Portrait, landscape, or system default page orientation.

• Page order, for printing pages across and then down, or down 
and then across.

• Whether the system expands the lines in a row or the width 
of a column, when the text does not fit in a cell.

• Data and row heading column widths.

• Page margins.

• The number of lines in a row.

• The number of pages printed for the entire report. You can 
specify how many pages wide or long you want the report to 
be. For example, if a report spans two pages in width, you can 
set the Fit width to 1 page wide, and the report is reduced in 
size to fit on one page.

• The number of lines in column headings.

• The placement of the row headings. 

Display • Text for cells with zero values, no data, errors, or where 
division by zero occurs.

• Suppression of selected columns or rows.

• Suppression of the detail in a column or row containing 
multiple dimensions. Only the total for the column or row 
appears.

• Suppression of columns or rows with only zero values, no 
data, errors, or where division by zero occurs.

• Suppression of columns or rows based on expressions.

Headings • Headings for the selected columns or rows.

• What part of dimension IDs and descriptions appears in 
column and row headings.

• Whether to display the column headings that are identical 
and located next to each other, once across the columns to 
which they apply.

Table 19: Format Options (Continued)

Select... To specify...
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The format you create for a column or row in a report window might affect several 
columns or rows in the output. For example, suppose you select a column in the 
report window that specifies a range of periods. If you then specify formatting 
options, these options affect all the columns for the periods in the output.

For information about selecting areas in a report, see the Reporting Basics chapter 
in the Hyperion Enterprise Reporting Windows Client Getting Started Guide.

Inherited Format Options

Hyperion Enterprise Reporting Windows Client follows an order of inheritance to 
resolve conflicts between option settings for different report areas. For example, 
suppose you specify the 12-point Helvetica bold font without underlining for the 
entire report, and then you specify double underlining for one row. 

Sort • The column or row that contains the values on which the sort 
is based.

• The order in which to sort.

• Whether to rank the data.

Expansions • Hyperion Enterprise Reporting Web Server expansion 
options. 

Investigations • Hyperion Enterprise Reporting Web Server investigation 
options.

Criteria • Criteria and formats for values that meet the criteria.

Applies To:

Table 19: Format Options (Continued)

Select... To specify...
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The following table shows the order in which report areas inherit format settings.

Check Box States

A check box in a panel in the Format dialog box can have any of these states:

Table 20: Former Setting Inheritance

Settings for... Override settings for...

All data The entire report.

Column data The entire report and all data.

Row data The entire report, all data, and column 
data.

All column headings or all row 
headings

The entire report.

Individual column headings The entire report and all column headings.

Individual row headings The entire report and all row headings.

Applies To:

Checked indicates that the option is selected. This overrides the 
inherited setting for the selected report area. For example, suppose 
you select a row heading and change the Italic check box in the Font 
panel to checked. The selected heading appears in italics, even if you 
have set the Italic option as unchecked for the entire report.

Unchecked indicates that the option is deselected. This overrides the 
inherited setting for the selected report area. For example, suppose 
you select a row heading and change the Bold check box in the Font 
panel to unchecked. The selected heading appears without bold, even 
if you have set the Bold option as checked for the entire report.
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Account Attributes 

Each account has a default attribute that describes the type of data for the account 
and determines how the system treats it in calculations. You can use account 
attributes as conditions for formatting and suppression in criteria statements. You 
can also use them with financial functions.

You can reverse the sign of a group of accounts by reversing the sign of its 
attribute. You might have a report with several accounts that have the Expense 
attribute. Typically, the Expense attribute will show negative values. If you 
reverse the sign of the Expense attribute, all the Expense accounts appear as 
positive values.

For example, suppose you have a report with Travel, Labor, and Material accounts 
with the Expense attribute, which would typically have a negative value. If you 
reverse the Expense attribute, the Travel, Labor, and Materials accounts appear as 
positive values.

Selecting attributes in reporting affects only report production. It does not 
permanently change account attributes. For instructions on reversing the sign of 
the account attribute, see Set Report Options for Hyperion Enterprise on page 55 
or Set Report Options for Hyperion Essbase on page 56.

Shading indicates that the selected report area has more than one 
setting for the option. For example, suppose you selected several 
rows, and the If No Data suppression option in the Display panel is 
shaded. The selected rows do not all have the same setting for this 
option. With the current settings, some rows might appear only if they 
contain data, and others might appear with or without data. If you 
reset the option, the new setting applies to all selected rows.

Inherited indicates that the selected report area inherits the option 
setting from another area. If you reset the option, the new setting 
overrides the inherited setting.

Applies To:
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The following lists show the account attributes for Hyperion Enterprise and 
Hyperion Essbase.

Account Attributes for Hyperion Enterprise

� ASSET

� BALANCE

� EXPENSE

� FLOW

� INCOME

� LIABILITY

� MAJOR

� CALCACC

Account Attributes for Hyperion Essbase

� BALAVERAGE

� BALFIRST

� BALLAST

� BALNONE

� CCVTANCESTOR

� CCVTCATEGORY

� CCVTNONE

� Essbase user defined attribute

� EXPENSE

� NON-EXPENSE
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Custom Number Formats

You can customize Hyperion Enterprise Reporting Windows Client to replace the 
default number format masks with masks that your company uses most frequently. 
For example, you might want to use formats that include symbols for currencies 
you use in reports.

You edit your RW32.INI file to replace the default number formats that you can 
select from the Number tab. The RW32.INI file is an ASCII file in your Windows 
directory that contains information about your session in Hyperion Enterprise 
Reporting Windows Client. 

The number formats you specify in the RW32.INI file appear in the Format 
drop-down list on the Number tab. You customize number formats by adding or 
editing the following line in the Format section of your RW32.INI file:

[Format]

NumFormat=Mask1[\nMaskn]

For example, you might type the following line to enter new formats for 
deutschemarks:

NumFormat=#:#0DM\n-#:#0DM\n###0.00DM 

Note: If you specify new formats in your RW32.INI file, the default formats 
are no longer available.

Applies To:

Where... Is...

Mask1
The first customized number format.

Maskn
The last customized number format. You must precede each 
customized number format after the first one with the characters \n.
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Formatting Options 

You can set formatting options for these attributes of data and text in a report: 

� Font

� Shading and borders

� Number format, scaling, rounding, and calculation order

� Spacing

� Data display

� Headings

� Sorting

� Criteria

Set Font Options

You can set the font options to override the default page format and specify a font, 
type size, and type style for a selected report area when you are formatting a report. 
For example, you might use a bold type style to emphasize a column of data for a 
specific entity.

You can use any font available to the system and any size available for the selected 
font. You can use double or single underlining, continuous underlining, or no 
underlining. You can select a color; you can use left, center, or right justification; 

Applies To:

Applies To:
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and you can use italic, bold, and overline. You can also hide the selected report 
area in the report output. The Sample box in the Font panel shows how text appears 
with the options you select.

➤ To set font options:

1. From a report window, select the report area that you want to format, then 
select Format > Font or the Font toolbar icon.

2. From the Font panel, select one or more of the available font options.

3. To hide the selected report area in the output, click Hidden.

Note: If you select Hidden, all other options in the Font panel are 
unavailable for the selected area.

4. To return all settings in the panel to their defaults, click Use Defaults.

5. Click OK. 

Set Shading and Border Options 

You can set shading and border options for the selected report area when you are 
formatting a report. You can specify border options for the entire area or for the 
individual cells within the area. You can also specify options for page borders, 
which appear on each page of the output. For example, if you specify a right page 
border for three consecutive rows, the border appears at the right edge of those 
rows on each page.

Cell borders and shading options apply to each cell in the selected report area. For 
example, you might use cell borders to create a grid within a column, or you might 
use shading to highlight a row.

Note: The Auto Outline toolbar icon adds a box around the selected report 
area without displaying the Shading/Border panel.

Applies To:
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➤ To set shading and border options:

1. From a report window, select the report area that you want to format, then 
select Format > Shading/Border.

2. Specify cell border or selection border options.

Note: In the Cell Border and Selection Border check boxes, the checked 
state appears as a line to indicate a border.

3. From the Shading drop-down list, select a shading option.

4. To return all settings in the panel to the default settings, click Use Defaults.

5. Click OK. 
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Set Numeric Options 

You can set numeric options to affect numeric values in reports when you are 
formatting a report. The following table describes the numeric option settings.

Applies To:

Table 21: Numeric Options 

This option... Determines...

Scaling The power of 10 by which the system scales values.

Format The number mask, or display pattern, that specifies these 
characteristics of numerical values by default:

• What character, if any, separates thousands. By default, the 
system uses a comma ( , ) to separate thousands.

• Whether negative values appear with minus signs ( - ) or are 
enclosed in parentheses ( ( ) ). By default, they are enclosed in 
parentheses.

• Whether values use characters such as a dollar sign ( $ ) or a 
percent sign ( % ), and whether those characters precede or 
follow numbers. By default, the system displays numbers 
without these characters.

• The number of places to the right of the decimal that appear in 
the report. By default, the system does not display decimal 
places.

Rounding 
Calculation

The factor by which the system rounds values before it calculates 
values. For example, you can select .01 to round values to the 
nearest hundredth. By default, the system does not round values 
before calculation.

Calculation 
Order

The order in which column and row values are calculated. By 
default, columns are calculated before rows.
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Mask Options

The following table shows the number masks you can select from the Format 
drop-down list and examples of how positive and negative values appear with each 
mask. To replace number masks in the Format drop-down list, you edit the 
RW32.INI file. For instructions, see Custom Number Formats on page 146.

Note: You can edit the selected number mask to use any additional 
characters. For example, you can select the mask ###0 and add a K 
after the zero to represent thousands. If you scale values to thousands, 
the edited mask shows the number 100,000 as 100K.

Display Format 
Order

The order in which column and row formats defined by font, 
shading/border, number, and criteria options are used. By 
default, row formats are used before column formats, followed 
by report formats. For example, if you have row, column, and 
report formats specified and the number format order is columns 
before rows, then the column formats are used before the row 
and report formats.

Account 
Attribute

The account attribute for selected columns or rows defined with 
expressions that calculate values from accounts with conflicting 
attributes.

Table 22: Number Masks 

Mask Positive Value Negative Value

Default 1,000,000,000 (1,000,000,000)

Product Define Defined in the application. Defined in the application.

#,##0 100,000 -100,000

###0 100000 -100000

#,##0.00 100,000.00 -100,000.00

###0.00 100000.00 -100000.00

($#,##0) $100,000 ($100,000)

($#,##0.00) $100,000.00 ($100,000.00)

Table 21: Numeric Options (Continued)

This option... Determines...
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#,##0% 100,000% -100,000%

###0% 100000% -100000%

#,##0.00% 100,000.00% -100,000.00%

###0.00% 100000.00% -100000.00%

(#,##0%) 100,000% (100,000%)

(#,##0.00%) 100,000.00% (100,000.00%)

{$}#,##0 or

#,##0{%}

You can specify any single 
character symbol within the 
braces { }, as a suffix or a 
prefix. 

Note: Use this mask to 
display a symbol once within 
a report.

$100,000

or 100,000%

The symbol is displayed once 
in the first row or column of 
the report.

-$100,000 or 

-100,000%

The symbol is displayed once 
in the first row or column of 
the report.

[$]#,##0 or

#,##0[%]

You can specify any single 
character symbol within the 
brackets [ ], as a suffix or a 
prefix. 

Note: Use this mask to 
display a symbol once within 
expanded rows or columns, or 
iterations of a section. An 
expanded row or column uses 
a function or a list of 
dimensions, which generate 
more than one row or column, 
such as the @SUB function.

$100,000

or 100,000%

The symbol is displayed in 
one of the following:

• The first row or column of 
each iteration of a section.

• The first row or column of 
each expanded row or 
column.

• The first row or column of 
the report.

-$100,000 or 

-100,000%

The symbol is displayed in 
one of the following:

• The first row or column of 
each iteration of a section.

• The first row or column of 
each expanded row or 
column.

• The first row or column of 
the report.

Table 22: Number Masks (Continued)

Mask Positive Value Negative Value
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Masks and Scaling

The system bases scaled values on the number masks for the values. This might 
require the system to round the scaled values. For example, suppose a report uses 
a number mask that specifies no decimal places. If you scale values to thousands, 
the system displays an input value of 1,500 as 2 after scaling it. The exact scaled 
value is 1.500, but the system rounds a scaled value up to the nearest integer if its 
number mask specifies no decimals. In calculations, the system always uses the 
input value.

➤ To set numeric options:

1. From a report window, select the report area that you want to format, then 
select Format > Number.

2. Select one or more of the available numeric options.

3. Click OK. 

Set Spacing Options 

When you format a report, you can define column widths, margins, and other 
spacing options to determine how data and headings are placed on a page. The 
following table shows the spacing options you can set.

Applies To:

Table 23: Spacing Options 

This option or 
group...

Determines...

Page Orientation Whether the system uses landscape, portrait, or the system 
default orientation for a report. The default is landscape.

Page Order Whether the system prints pages across and then down, or 
down and then across. The default is across and then 
down.
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Cell Autofit Whether the system expands the lines in a row or the 
width of a column, when text does not fit in a cell. Select 
row to expand the lines in the row to accommodate the 
text. Specify column to expand the column width to 
accommodate the text. Specify None, to use the default 
settings for the lines in a row and column width which are 
set with the Row and Width options. If you specify None 
and the text does not fit in the cell it is truncated.

Note: You must select the entire report to use this option.

Column/Row Spacing Whether the report contains a blank column and the width 
of that column before or after the highlighted column, a 
blank row and the height of that row before or after a 
highlighted row, or a page break after a highlighted 
column or row. By default, the system does not leave a 
blank column or row.

Note: A column width of one is equal to the width of one 
character, and a row height of one is equal to the height of 
one character or line. 

Widths The widths, in characters of columns for data and row 
headings. The default widths are 15 characters for data 
columns and 20 characters for the row headings column.

Margins The top, bottom, left, and right margins for report pages. 
For default margins, the system uses the default page 
setup.

Rows The number of lines in each highlighted row in the output. 
The default is 1.

Table 23: Spacing Options (Continued)

This option or 
group...

Determines...
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➤ To set spacing options:

1. From a report window, select the report area that you want to format, then 
select Format > Spacing.

2. Select one or more of the available spacing options.

Note: The Column/Row Spacing check boxes have only two states, 
checked and unchecked.

3. Click OK. 

Fit To The number of pages printed for the entire report. You can 
specify how many pages wide or long you want the report 
to be. For example, if a report spans two pages in width, 
you can set the Fit width to 1 page wide, and the report is 
reduced in size to fit on one page.

Note: You can only specify a height or width smaller than 
the current report size.

Headings The number of lines in column headings, and the 
placement of the row headings. For example, if you 
specify three lines for column headings, the system wraps 
words to the second line if they do not fit on the first, and 
to the third line if they do not fit on the second. The 
system truncates text that does not fit in the specified 
number of lines. If you specify the placement of the row 
descriptions after column 3, the row headings are placed 
in column 4 of the report.

Table 23: Spacing Options (Continued)

This option or 
group...

Determines...



156 �

Formatting Reports

Hyperion Enterprise Reporting Windows Client User’s Guide

Set Display Options 

When you format a report, you set display to control the display of report data. For 
example, you can define the text that appears in cells when no data is available. 

You can also set data suppression options to suppress selected columns or rows 
under specific circumstances. Suppressed data is not used in calculations. For 
example, if you suppress rows 23 and 24 and then calculate a sum for rows 10 
through 30, the sum does not include the values in rows 23 and 24.

The following table shows the display options that you can set. For each option, 
you can specify a maximum of 20 characters.

Applies To:

Table 24: Display Options 

This option... Defines text for...

Zero All values that equal zero. By default, the system displays 
zeros in these cells.

No Data Cells for which no data is available. By default, these cells 
are blank.

Error Cells where data cannot be retrieved or calculated because 
of errors. The default is ERR.

Division By Zero Cells where division by zero occurs. By default, these cells 
are blank.
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The following table shows the suppression options you can set. The default is no 
suppression.

➤ To set display options:

1. From a report window, select the report data area that you want to format, then 
select Format > Display.

Note: To set display options, you must select the entire report.

2. From the Display panel, specify any text and suppression options that you 
want to set.

3. To suppress an expression, click the Edit Expression icon.

4. Click OK. 

Table 25: Suppression Options

This option... Suppresses...

Always An individual column or row whenever you run the report. 
You can refer to a suppressed column or row in expressions 
in other columns or rows.

Detail (Show 
Summary)

A column or row containing a series of dimension 
definitions. For example, suppose a report has one row with 
Losses, Product Returns, and Bad Debt accounts. If you 
select the Detail (Show Summary) suppression option for 
the row, the report output shows one row with the total of the 
accounts. The system suppresses the expanded rows for the 
individual accounts. You must add the heading to reflect the 
totaling.

If Zero Columns or rows that contain only zeros or that contain no 
data.

If No Data Columns or rows that contain no data.

If Division By Zero Columns or rows divided by zero values.

If Error Columns or rows where the system cannot show data 
because of errors.

If Expression Columns or rows based on an expression.
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Set Headings Options 

You can use the Headings options when you are formatting a report to specify a 
formula for selected column or row headings. You can specify a heading to appear 
in one column or across several columns. If the formula for the selected headings 
uses the @LAB or @DES function to retrieve dimension IDs or descriptions 
dynamically, you can specify which parts of the IDs or descriptions you want to 
use. 

For example, you might specify a heading formula that shows account 
descriptions, then specify that the account descriptions start with the fifth character 
and end with the twelfth character. By default, dimension IDs and descriptions in 
headings start with their first characters and end with their last characters. For 
information about the @LAB and @DES functions, see Chapter 12.

You can specify column headings to appear in separate columns or across multiple 
columns. In the following report, the columns headings appear in separate 
columns.

Applies To:
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The following report is identical to the previous report except that the column 
headings are specified to display across multiple columns. USDIV spans columns 
1-4, Actual spans column 1-2 and Budget span columns 3-4 and the year headings 
on the third line do not span a column. 

➤ To set headings options:

1. From a report window, select the column or row headings that you want to 
format, then select Format > Headings.

2. Type a new formula in the Heading edit box.

3. If the heading formula uses the @LAB or @DES function to retrieve a 
dimension ID or description, do one or both of the following:

Note: Select the dimension from the Dimension list box.

To abbreviate a dimension ID or description, select a dimension 
and specify the starting and ending character numbers.

Tip: You can select an area that includes both columns and rows and 
abbreviate the dimension ID or description for the headings within 
the selected area.

4. Specify whether you want a heading to display in one column or across several 
columns. 

Tip: You must select the entire report or all the columns, to use this 
option. The headings that are identical and located next to each 
other, are displayed once across the columns to which they apply.

5. Click OK. 
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Set Sorting Options 

When you format a report, you can set sorting options to sort a range of columns 
or rows by the values in a specified column or row. If you select a range of 
columns, the system sorts the columns by their values in a row that you specify. If 
you select a range of rows, the system sorts the rows by their values in a column 
that you specify. You can sort the selected columns or rows in ascending or 
descending order. You can also rank data by the values in a column or row. When 
you rank data, you can display the ranking of all the data or a specified number of 
columns or rows in the output. All suppressed rows or columns are omitted from 
sorting.

You can sort rows or columns alphabetically by their headings. Within each report, 
you can sort one range of columns and one range of rows.

A green bar with a sort icon indicates sorted columns or rows in a report. The icon 
uses a right arrow for columns, a down arrow for rows, and the numbers 0 and 10 
to show the direction of the sort. For an ascending sort, the icon uses 0 followed 
by 10. For a descending sort, it uses 10 followed by 0. 

Applies To:
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The following figure shows a report with all rows sorted in ascending order for the 
values in a column.

Figure 29: Report with Sorting

➤ To set sorting options:

1. From a report window, select the rows or columns for which you want to set 
sorting options, then select Format > Sort.

2. From the Sort panel, select one of the following:

� On to turn sorting on for the selected report area.

� Off to turn sorting off for the selected report area.

3. Select sorting and ranking options.

Tip: To display both the ranking and the ranked data within a report, 
duplicate the ranked column or row and set the ranking for the 
duplicate column or row to None.

4. Click OK. 
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Set Criteria 

You can define criteria to specify conditional formatting for data in a report. 
Criteria are logic conditions that values must meet if the values are to appear with 
the specified attributes. For example, you might define criteria for sales account 
values so that they appear bold if the values are seriously below expectations, and 
with underlining if the values exceed expectations. 

You use the Criteria options to add, delete, or modify criteria. You can define 
criteria for an entire report or for individual columns or rows. A value takes on the 
formatting specified for all the criteria that it meets. For example, suppose you set 
criteria for an entire report to format values above 1,000 in italics. If you also set 
criteria for a single row in that report to format values above 1,000 in bold, the 
values above 1,000 in that row appear in bold italics. 

Applies To:
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Use this format to create criteria statements:

(Variable Operator Att/Value) [Connector (Variable Operator Att/Value)]

For example, you can select a column and then create this criteria statement:

VALUE > 500

If you then select the criteria statement and change the font to bold, values for the 
selected column appear bold in the output if the values are greater than 500.

You can create criteria statements to hide the values in specific cells. For example, 
you can create this criteria statement:

ROWREF(11:15) AND COLREF(2:2)

Where... Is...

Variable The current values in the selected columns or rows, or the current 
values in the columns, rows, or cells that you specify by number.

Operator Any of these symbols or words:

• IS, which is used to specify selected attributes as criteria.

• IS NOT, which is used to specify the absence of selected attributes 
as criteria.

• BETWEEN, which is used to specify values within a range.

• An equal sign ( = ) for equal to.

• A left angle bracket and a right angle bracket ( < > ) for not equal 
to.

• A right angle bracket ( > ) for greater than.

• A right angle bracket with the equal sign ( > = ) for greater than or 
equal to.

• A left angle bracket ( < ) for less than.

• A left angle bracket with the equal sign ( < = ) for less than or 
equal to.

• Parentheses ( ( ) ) to control the order in which the system 
performs calculations.

Att Any attribute available in the Attribute list. Attributes are 
conditions that describe the type of data.

Value A number that you type.

Connector AND or OR.
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If you then select the previous criteria statement and change the font to hidden, the 
values for rows 11 through 15 in column 2 are hidden in the output.

Variables in Criteria Statements for Hyperion 
Enterprise

The following table describes the variables that you can use in criteria statements 
in Hyperion Enterprise.

Table 26: Variables in Criteria Statements for Hyperion Enterprise 

This variable... Refers to...

BALANCE The account of the current cell is a balance account.

BASE The current cell is a base level dimension member.

CALCACC The current cell is a calculated account.

CALCULATED The current cell is marked as source-calculated.

CELL The column and row numbers for one cell.

[COL/ROW] Number A column or row number.

COLREF A range of columns.

DBZ The current cell is marked as divide-by-zero.

ERROR The current cell is marked as an error.

EXPENSE The account of the current cell is expense. (Use only if 
the Account dimension exists).

FLOW The account of the current cell is a flow account. 

INCOME The account of the current cell is an income account.

INPUT You can enter information into this cell.

LIABILITY The account of the current cell is a liability account.

LOCKED The current cell is marked as locked.

MAJOR The account of the current cell is an major account, top 
level detail.

NODATA The current cell is marked as having no data.
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Variables in Criteria Statements for Hyperion 
Essbase

The following table describes the variables that you can use in criteria statements 
in Hyperion Essbase. 

NONEXPENSE The account of the current cell is non-expense. (Use 
only if the Account dimension exists).

PARENT The current cell is a parent member.

PERIODIC The current cell is a periodic value.

ROWREF A range of rows.

RPTCALC The current cell is marked as report calculated.

UDA (User Defined 
Attributes)

The values for the user defined attribute selection.

VALUE The values in the selected columns or rows.

YTD The current cell is a year to date value.

Table 27: Variables in Criteria Statements for Hyperion Essbase 

This variable... Refers to...

BALAVERAGE The account of the current cell is an average time balance; 
the average value of all children. (Use only if the Account 
and Time dimensions exist).

BALFIRST The account of the current cell is a beginning time balance; 
the value of the first child. (Use only if the Account and 
Time dimensions exist).

BALLAST The account of the current cell is an ending time balance; the 
value of the last child. (Use only if the Account and Time 
dimensions exist).

BALNONE The account of the current cell is not a time balance. (Use 
only if the Account and Time dimensions exist).

Table 26: Variables in Criteria Statements for Hyperion Enterprise (Continued)

This variable... Refers to...
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CALCULATED The current cell is marked as source-calculated.

CCVTNONE The account of the current cell has no currency conversion. 
(Use only if the Account and Currency dimensions exist).

CCVTANCESTOR The account of the current cell has the currency conversion 
of its ancestor. (Use only if the Account and Currency 
dimensions exist).

CCVTCATEGORY The account of the current cell has the currency conversion 
of a category. (Use only if the Account and Currency 
dimensions exist).

CELL The column and row numbers for one cell.

[COL/ROW] 
Number

A column or row number.

COLREF A range of columns.

DBZ The current cell is marked as divide-by-zero.

ERROR The current cell is marked as an error.

EXPENSE The account of the current cell is expense. (Use only if the 
Account dimension exists).

INPUT You can enter information into this cell.

LOCKED The current cell is marked as locked.

NODATA The current cell is marked as having no data.

NONEXPENSE The account of the current cell is non-expense. (Use only if 
the Account dimension exists).

ROWREF A range of rows.

RPTCALC The current cell is marked as report calculated.

UDA (User Defined 
Attributes)

The values for the user defined attribute selection.

VALUE The values in the selected columns or rows.

Table 27: Variables in Criteria Statements for Hyperion Essbase (Continued)

This variable... Refers to...
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➤ To set criteria:

1. From a report window, select the report area for which you want to set criteria 
options, then select Format > Criteria.

2. From the Criteria panel, select one of the following:

– On to turn criteria on for the selected report area.

– Off to turn criteria off for the selected report area.

– Default to use the default criteria settings.

3. If you are using criteria, type one or more criteria statements in the edit box.

Tip: You can also select any item from the Variables, Operators, 
Attributes, or Connectors list box to paste at the current cursor 
position.

4. Specify criteria options.

5. Click OK. 

View Drafts or Formatted Reports 

You can view reports in report windows with their formatting, or you can use the 
Draft option for faster processing. The Draft option displays reports without the 
fonts and other formatting options you selected. For example, if you select shading 
for a column, the shading does not appear in the report window when you use the 
Draft option, but it does appear in the output when you preview or print the report. 
For information about printing and previewing, see Chapter 10.

➤ To view a draft or a formatted report, from a report window, select View > Draft. 

Note: A check mark appears to the left of the Draft menu command when 
this option is selected. 

Applies To:
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Copy Format 

You can copy the format of one report to another report without copying 
dimensions or formulas. For example, suppose a report has 14-point Arial bold 
column headings and 12-point Arial bold italic row headings, with categories 
assigned to columns and accounts assigned to rows. You can copy the formatting 
to another report that has different dimensions assigned to the columns and rows.

➤ To copy format:

1. From a report window, select the entire report, then select Edit > Copy.

2. Open a new report window, then select the entire new report.

3. Select Edit > Paste Special.

4. Click Formats, then click OK. 

Copy Dimensions and Formulas 
You can paste the dimensions and formulas from a selected report area to another 
area in the same report or to a different report without copying the format. For 
example, if you select a column, you can copy the dimensions and formulas to 
another column in the same report or to a different report without copying the 
format.

➤ To copy dimensions and formulas:

1. From a report window, select the report area that you want to copy, then select 
Edit > Copy.

2. In the same report window or in a different report window, select the area 
where you want to paste the copy.

3. Select Edit > Paste Special.

4. Click Values, then click OK. 

Applies To:
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Copy Format, Dimensions, and Formulas 

You can paste the formatting, dimensions, and formulas from a selected report area 
to the same report or a different report. For example, if you have selected a column, 
you can copy its format, dimensions, and formulas to a different column in the 
same report or to a column in another report. 

➤ To copy format, dimensions, and formulas:

1. From a report window, select the report area that you want to copy, then select 
Edit > Copy. 

2. In the same report window or in a different report window, select the area 
where you want to paste the copy.

3. Select Edit > Paste or Edit > Paste Special.

4. Click All, then click OK. 

Notations and Local Headings Setup

You can use fields in Hyperion Enterprise Reporting Windows Client to include 
these features in reports:

� Notations, which are text entries such as descriptions or comments

� Local headings, which replace the descriptions of individual dimensions based 
on the other dimension settings in the report

Applies To:

Applies To:
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Notations are fields that you use for comments and other textual data that provide 
information in report output. Notations can vary by entity, period, or any other 
dimension. For example, you might create a field called Notes1 to include 
notations, such as reasons for increases or decreases, on the Total Sales account 
for different entities, periods, and categories.

Local headings are fields that you use as alternate descriptions based on the 
dimension settings in a report. For example, a company’s chart of accounts might 
include the account Cost A. In the Canada Division, Cost A might represent 
transportation expenses, while in the Northeast Division, Cost A might represent 
packaging expenses. You can create a field called Alternate to store alternative 
descriptions for accounts for the different entities in an organization. For Cost A, 
the Canada Division would use the local description Transportation Costs, while 
the Northeast Division would use the description Packaging Costs. 

The following table shows the tasks involved in using notations and local 
headings, and where you perform those tasks.

Table 28: Tasks Involved in Using Notations and Local Headings 

Use... To...

Hyperion DataExtend Set up fields to use for notations or local headings. 
For more information, see the Hyperion 
DataExtend User’s Guide or Hyperion DataExtend 
Help.

Hyperion Enterprise 
Reporting Windows Client

Create reports that you use for presenting data in 
reports using notations and local headings.

Hyperion Schedules Enter text as notations and local headings. For 
more information, see the Hyperion Schedules 
User’s Guide or Hyperion Schedules Help.
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Set Up Notations

You set up notations in your reports to provide rows or columns of textual 
information. When you set up notations, you create a field in Hyperion 
DataExtend, assign the field to a column or row in Hyperion Enterprise Reporting 
Windows Client, and enter the text in Hyperion Schedules. 

➤ To set up notations in reports:

1. From a report window, select a column or row and assign the field where you 
want the notation to appear. 

2. Before setting up the notation in a report, you must create a text field to use 
for notations in reports using Hyperion DataExtend. For instructions, see the 
Hyperion DataExtend User’s Guide.

3. Save the report.

Tip: To add notations to a report, open the report in Hyperion 
Schedules and type the notations. For instructions, see the 
Hyperion Schedules User’s Guide. 

Set Up Local Headings in Reports

You set up local headings in your reports to provide alternate descriptions for 
dimensions. For example, you might set up local headings for two subsidiaries that 
use different headings for the same account. 

Applies To:

Applies To:
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When you set up local headings, you create a local heading in Hyperion 
DataExtend, assign the local heading to a column or row in Hyperion Enterprise 
Reporting Windows Client, and enter the text in Hyperion Schedules. 

In any report in Hyperion Enterprise Reporting Windows Client, you can assign 
the text field to the opposite axis from where you want the local headings to 
appear. You then suppress the row or column to which you assign the text field. 
For example, if you want to allow a local heading in each row, assign the text field 
to any column and suppress the column. 

You use the @LOCAL function to assign a local heading to a report’s column or 
row. Use this syntax to specify a local heading in a column or row heading:

@LOCAL(field,default)

For example, typing the formula @LOCAL(lochead,@DES) for the heading of a 
row containing a range of accounts produces these results:

� If no local heading is assigned to the account, then the account’s description 
appears when you run the report or open it in Hyperion Schedules.

� If a local heading is assigned to an account, then the local heading appears 
instead of the description.

After you set up local headings, you use Hyperion Schedules for data entry. For 
more information, see the Hyperion Schedules User’s Guide or Hyperion 
Schedules Help.

➤ To set up local headings in reports:

1. From a report window, select a column or row and assign the text field to the 
opposite axis from where you want the local heading to appear.

Tip: Before setting up the local heading in a report, you must create the 
field using Hyperion DataExtend. For instructions, see the 
Hyperion DataExtend User’s Guide.

2. Do the following to suppress the column or row to which you assigned the 
field:

� Select the column or row and select Format > Display.

Where... Is...

field The ID of a field defined in Hyperion DataExtend.

default The text that will appear if no local heading is assigned.
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� In the Suppression Options group, click Always, then click OK.

3. Save the report.

Tip: To add local headings to a report, open the report in Hyperion 
Schedules and type the headings. For instructions, see the 
Hyperion Schedules User’s Guide. 

Expansions and Investigations

You use Hyperion Enterprise Reporting Windows Client to set expansions, set 
investigations, and manage expansions options for use in Hyperion OnTrack or 
Hyperion Enterprise Reporting Web Server. Expansions and investigations are 
features that allow you to specify levels of detail for data that appears in a report 
in Hyperion OnTrack or Hyperion Enterprise Reporting Web Server. You can also 
manage expansions for Hyperion Analyst. 

The investigations and expansions command is disabled on the Format menu, and 
the manage expansions command is disabled on the Task menu by default. To 
activate the investigations and expansions command, you must edit the DEFAULT 
section of the REPENG.INI file which is located in your Windows directory. The 
section appears as follows:

[DEFAULT]

OnTrack=1

Applies To:
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Set Expansions

You set expansions to define Hyperion OnTrack or Hyperion Enterprise Reporting 
Web Server expansion options for selected columns and rows. The options you 
specify do not affect report output. Expansions give users immediate access to data 
for additional dimensions from within a report. For example, you can expand a 
column that shows Second Quarter data to show columns for April, May, or June 
data. 

You can turn expansions on or off for a selected report area. The following table 
shows the expansion options you can set for any report area.

➤ To set expansions:

1. From a report window, select the report area you want to format, then select 
Format > Expansions.

2. Set expansion options.

3. Click OK. 

Applies To:

Table 29: Expansions Options

This option... Determines...

Dimension The dimension or dimensions on which the expansion is 
based. The system uses the dimension for the current 
column or row by default.

Position Whether expansion data appears before or after the summary 
column or row.

Expansion Tag The expansion tags defined for the current dimension using 
the Manage Expansions dialog box.

Parent Override The parent relationship defined for the current dimension 
using the Manage Expansions dialog box.
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Set Investigations

You set investigations so that you can use investigations in Hyperion OnTrack, 
Hyperion Enterprise Reporting Web Server, or Hyperion Schedules to view 
different levels of report detail. The options you set do not affect report output. 

You can turn on automatic or custom investigations, turn off all investigations, or 
use the default investigation setting for the selected report area. If you turn on 
custom investigations, you can select a report set that contains the investigation 
report you want to use and then select a report from that set. You can also select a 
report without first selecting a set.

➤ To set investigations:

1. From a report window, select the report area you want to format, then select 
Format > Investigations.

2. To turn investigation options on or off, do one of the following:

� To turn on automatic investigations for the selected report area, click Auto.

� To turn on custom investigations for the selected report area, click On.

� To turn off all investigations for the selected area, click Off.

3. To filter the list of reports, select the set that contains the report you want to 
insert.

4. Type the report label in the Report Name edit box or select the report from the 
list.

5. Click OK. 

Applies To:
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Manage Expansions

Managing expansions involves defining expansions to specify what detail appears 
when you expand a dimension from a Hyperion OnTrack or Hyperion Enterprise 
Reporting Web Server screen and identifying the parent-child relationships for the 
expansion. The options you specify do not affect report output. 

You can also manage expansions for Hyperion Analyst. For more information on 
expansions, see the Hyperion Analyst User’s Guide or Hyperion Analyst Help.

Expansions give users immediate access to data for additional dimensions from 
within a Hyperion OnTrack screen, Hyperion Enterprise Reporting Web Server 
screen, or Hyperion Analyst worksheet. For example, you can expand a column 
that shows First Quarter to show columns for January, February, or March data.

A parent-child relationship specifies what detail appears when you expand data. 
The parent-child relationship tells the system whether to use relationships defined 
within the Manage Expansions dialog box, or follow the parent-child relationships 
within your data structure.

The following table shows the expansion options you can set.

Applies To:

Table 30: Manage Expansions Options

This option... Determines...

Dimension The dimension value for which you display detail 
in Hyperion OnTrack, Hyperion Enterprise 
Reporting Web Server, or Hyperion Analyst.

Expansion Tag The names of the expansion tags for the selected 
dimension.

Parent Relationships The parent-child relationships for the selected 
dimension. 
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➤ To manage expansions:

1. From a report window, select the report area you want to format, then select 
Task > Manage Expansions.

2. Select the dimension you want to expand.

3. Create, edit, or delete expansion tags and parent relationships for that 
dimension.

4. Click Close. 
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Managing Reports and 
Books 

You manage reports and books to create report and book sets, to add reports and 
books to sets and to the current application, to remove reports and books from sets, 
and to delete sets, reports, and books from the system when you no longer need 
them. Report management also involves checking reports and books created or 
edited outside Hyperion Enterprise Reporting Windows Client. You can change 
the titles or security classes of existing sets, reports, and books. You can also 
specify whether you want a report set to be available for data entry in Hyperion 
Schedules.

Note: For more information, see Hyperion Schedules Help or Hyperion 
Distributed Schedules Help. 

You manage reports and books from the Manage Reports and Books dialog box, 
which contains icons for the report and book management tasks. The following 
table describes the icons.

Table 31: Manage Reports and Books Dialog Box Icons 

The Insert New icon creates a report set or book set, or adds a report 
or book to the application and the specified report set or book set.

The Delete icon deletes the selected report set, book set, report, or 
book from the application.

The Edit icon allows you to edit report set, book set, report, or book 
information.

The Add to Set icon adds the selected reports or books to an existing 
set.

9
Chapter
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Report and Book Sets 

Report and book management involves grouping reports or books into sets. A set 
contains related reports or books that you group for your convenience. A report or 
book set might include all reports or books that pertain to specific tasks, such as a 
group of monthly internal reports or books. Before you can run a report or book, 
the report or book must be in at least one report or book set.

You can create sets that reflect the way you use reports or books. You might 
maintain sets that group reports or books by task: a set of income statements, a set 
of balance sheets, and so on. You can add any report or book to as many different 
sets as necessary. The sets, reports, and books for the application appear 
alphabetically in the Manage Reports and Books dialog box.

Grouping reports or books in sets makes it easier and faster to locate a report or 
book that you want to run or edit. Searching through a set takes less time than 
searching through all the individual reports or books in the application. The reports 
and books within a set appear in the order that they were loaded into the set.

The Check icon verifies the syntax of the selected reports or books.

The Remove from Set icon removes the selected reports or books 
from the selected set.

Applies To:

Table 31: Manage Reports and Books Dialog Box Icons (Continued)

The Insert New icon creates a report set or book set, or adds a report 
or book to the application and the specified report set or book set.
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Create Report or Book Sets 

You create report and books sets to hold the reports and books that you create. You 
must create report or book sets before you can add new or existing reports or books 
to them. For a Hyperion Enterprise application, you can create as many report or 
book sets as you need. For a Hyperion Enterprise application, you can create up to 
16,000 report sets.

When you create a report or book set, you specify a name, security class, and title 
for the set. The sets, reports, and books are displayed in the order that they were 
added. The reports or books within a set also appear in the order that they were 
added.

Tip: For Hyperion Enterprise, you can control the display of IDs listed in 
the All Reports, All Books, Report Sets, and Book Sets window. If the 
SortSets option in the ENTERPRISE section of your REPENG.INI file 
is set to 1 or missing, the IDs are displayed alphabetically. If the 
SortSets option is set to 0, the IDs are displayed in the order they were 
entered. 

You can also specify whether you want the report set to be available for data entry 
in Hyperion Schedules or Hyperion Distributed Schedules. The Allow Input via 
Hyperion Schedules option allows you to limit the report sets that users can access 
in Hyperion Schedules and Hyperion Distributed Schedules. 

➤ To create a report or book set:

1. From a report or book window, select Task > Manage Reports and Books.

2. From the Report or Book panel, click the Insert New Set icon.

3. Specify a name, security class, and title for the set.

Applies To:
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4. If you do not want a report set to be available for data entry in Hyperion 
Schedules, deselect Allow Input via Hyperion Schedules.

Note: For more information, see the Hyperion Schedules User’s Guide, 
Hyperion Schedules Help, Hyperion Distributed Schedules 
User’s Guide, or Hyperion Distributed Schedules Help. 

5. Click OK.

Delete Report or Book Sets

When you no longer need to work with a particular group of reports or books as a 
set, you can remove all of the books or reports in the set, then delete the set from 
the application. 

➤ To delete a report or book set:

1. From a report or book window, select Task > Manage Reports and Books.

2. From the Report or Book panel, select the set that you want to delete.

3. Click the Delete Set icon, then click Yes.

Note: Before you can delete a report or book set, you must remove all 
the reports or books from the set. For instructions, see Remove 
Reports or Books from Sets on page 185.

Applies To:
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Edit Report or Book Set Information

You can edit report or book set information to give a report or book set a new name 
or title, or to change its security class. You can also specify whether you want the 
report set to be available for data entry in Hyperion Schedules or Hyperion 
Distributed Schedules. Editing set information does not affect the individual 
reports or books within the set. 

➤ To edit report or book set information:

1. From a report or book window, select Task > Manage Reports and Books.

2. From the Report or Book panel, select the set that you want to edit.

3. Click the Edit Set Info icon.

4. Change the name, security class, or title of the set.

5. To specify whether a report set is available for data entry in Hyperion 
Schedules, select or deselect the Allow Input via Hyperion Schedules.

Note: For more information, see the Hyperion Schedules User’s Guide, 
Hyperion Schedules Help, Hyperion Distributed Schedules 
User’s Guide, or Hyperion Distributed Schedules Help. 

6. Click OK. 

Applies To:
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Add Reports or Books to Sets

You can add any report or book in the application to any existing report or book 
set. For example, suppose you create a set of trend reports or books for the 
Marketing Department. If you then create a new trend report or book, you can add 
that report or book to the set. You can add a report or book to multiple sets.

➤ To add a report or book to a set:

1. From a report or book window, select Task > Manage Reports and Books.

2. From the Report or Book panel, select the set to which you want to add the 
report or book.

Tip: You must add the report or book to a specific set, you cannot add 
it to the set ALL, which contains all reports or books.

3. In the Reports in System or Books in System list box, select one or more 
reports or books to add to the set.

Tip: To select multiple reports or books, hold down Ctrl and select 
each report or book. To select a range of reports or books, hold 
down the left mouse button and drag the pointer through the range 
of reports or books.  

4. Click the Add to Set icon.  

Applies To:
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Remove Reports or Books from Sets

You can remove reports or books from sets when you want to keep a report or book 
in the application but remove the report or book from a specific set. Removing a 
report or book from a set does not delete the report or book from the application. 
For instructions on deleting a report or book from the application, see Delete 
Reports or Books from the Application on page 188.

➤ To remove a report or book from a set:

1. From a report or book window, select Task > Manage Reports and Books.

2. From the Report or Book panel, select the set from which you want to remove 
reports or books.

3. From the Reports in Set or Books in Set list, select one or more reports or 
books to remove from the set.

Tip: To select multiple reports or books, hold down Ctrl and select 
each report or book. To select a range of reports or books, hold 
down the left mouse button and drag the pointer through the range 
of reports or books.

4. Click the Remove from Set icon.

Edit Report or Book Information 

You can edit report or book information to give a report or book a new title or 
security class. For example, if you make changes to a report, you might want to 
change the title of the report to reflect your changes.

Applies To:

Applies To:
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➤ To edit report or book information:

1. From a report or book window, select Task > Manage Reports and Books.

2. From the Report or Book panel, select the set and then select the report or book 
for which you want to edit information.

3. Click the Edit Report Info or Edit Book Info icon.

4. Change the security class or title of the report or book.

5. Click OK. 

Check Reports or Books

You check reports or books for syntax errors. Reports and books must use 
Hyperion Enterprise Reporting Windows Client syntax so that the application can 
interpret the instructions that the report or book contains. 

When you insert a new report, Hyperion Enterprise Reporting Windows Client 
performs the check automatically. When report sets and book sets contain reports 
or books that were created in a prior version or edited outside the application, you 
must check the reports or books before you can run them. For information on 
inserting new reports, see Add Reports or Books to the Application on page 187. 

Note: Book sets are supported in Hyperion Enterprise.

➤ To check a report or book:

1. From a report or book window, select Task > Manage Reports and Books.

2. From the Report or Book panel, use the Reports in System list box to select 
one or more reports or books that you want to check.

Tip: To select all reports or books in the application, select one report 
or book and press Ctrl + /.

Applies To:



Managing Reports and Books

� 187Hyperion Enterprise Reporting Windows Client User’s Guide

9

3. Click the Check Report or Check Book icon.

Note: If the report or book contains a syntax error, an error message 
appears when you check the report or book. You must correct the 
error and check the report or book again before you can run the 
report or book.  

Add Reports or Books to the Application

You can add reports or books to the application in a specific report set or book set. 
For example, if you receive a copy of a report or book on a disk, you can add it to 
the application and specify the report or book set to which the report or book is 
added. Hyperion Enterprise Reporting Windows Client checks reports and books 
as you add them to the application. 

Note: Book sets are supported in Hyperion Enterprise.

➤ To add a report or book to the application:

1. From a report or book window, select Task > Manage Reports and Books.

2. From the Report or Book panel, select a report or book set.

3. Select the Insert New Report or Insert New Book icon, then specify a name, 
security class, and title for the report or book.

4. Select the Select File icon to specify the load file name, file type, drive, and 
directory for the report or book, then click Open.

5. Click OK.

Applies To:
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Delete Reports or Books from the Application

If you no longer need a report or book, you can delete it from the application. You 
can delete several reports or books at once. When you delete a report or book from 
the application, Hyperion Enterprise Reporting Windows Client deletes it from all 
sets, and its name and title no longer appear in the Reports in System or Books in 
System list box in the Manage Reports and Books dialog box.

Hyperion Enterprise Reporting Windows Client does not delete the report or book 
from the disk. You can recover a deleted report or book by adding the report or 
book back to the application. For instructions, see Hyperion Enterprise Reporting 
Windows Client User’s Guide.

➤ To delete a report or book from the application:

1. From a report or book window, select Task > Manage Reports and Books.

2. From the Report or Book panel, in the Reports in System list box or Books in 
System list box, select one or more reports or books to delete.

Tip: To select multiple reports or books, hold down Ctrl and select 
each report or book. To select a range of reports or books, hold 
down the left mouse button and drag the pointer through the range 
of reports or books.

3. Click the Delete Report or Delete Book icon.

4. Click Yes to delete an individual report or book, or click Yes to All to delete 
all selected reports or books. 

Applies To:



� 189Hyperion Enterprise Reporting Windows Client User’s Guide

Running Reports and Books 

You run reports and books to retrieve, calculate, and present the data you set up in 
Hyperion Enterprise. You can run reports individually, or you can run a book that 
specifies a series of reports to be run together. 

Data appears in the columns and rows of the reports when you run the reports or 
books. You can send the output from a report or book to a printer or to a file, and 
you can preview the output of an individual report on the screen before you print 
the report. You can print reports and books individually or in batches. You can also 
export a report to Microsoft Excel, then create graphs and charts and refine the 
format of the report.

Before you run a report or book, you might want to change the defaults for these 
groups of settings:

� Page format, which includes fonts, type sizes, and type styles

� Page setup, which includes margins

� Label setup, which includes placement of page numbers, dates, and other 
information

Reports and books have different defaults for these groups of settings. For 
example, you might use different default margins for books than for reports that 
you run individually. These default settings are stored in the application for each 
user.

Note: You can also run reports and books from the Reports or Books 
module in Hyperion Enterprise.

10
Chapter
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Change the Default Page Format

You specify and maintain separate default page formats for reports and books, and 
you can change the default page format at any time to alter the font, point size, 
style, and color for the text in specified areas of report pages. The following table 
explains the areas that you can change.

If a report contains specific formatting instructions for a specified area, these 
instructions override the default page format. For example, if you set up a report 
with underlined column headings, the headings appear underlined in the output, 
regardless of whether the default page format specifies underlined column 
headings. For more information about formatting reports, see Chapter 8 .

Page format, page setup, and label setup settings apply when you run reports and 
books in Hyperion Enterprise Reporting Windows Client and in the Reports or 
Books window in Hyperion Enterprise. For example, if you change the default 
margin settings for reports in Hyperion Enterprise Reporting Windows Client, this 
setting is used in the Reports window in Hyperion Enterprise. Likewise, if you 
change the default font for footers in the Books window in Hyperion Enterprise, 
this setting is used for books in Hyperion Enterprise Reporting Windows Client.

Applies To:

Table 32: Page Format Options 

This area... Affects...

Label Text that appears at the top or bottom of every page, such as the 
current date, time, or page number.

Header The title of the report, which appears on every page.

Column Column headings.

Row Row headings.

Data The data in the columns and rows.

Footer Text that appears at the bottom of every page, such as the current 
date, time, or page number.
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➤ To change the default page format:

1. From a report or book, select File > Page Format.

2. Double-click on an area in the page model to view its font description and a 
sample of the current font option settings.

3. To change the default font options for the selected area, click Font.

4. Reset the font options, then click OK twice.

Change the Default Page Setup 

You can change the default page setup at any time. When you change the default 
page setup, you can specify margins, and where the time, date, page numbers, and 
text appear on report and book pages. You specify and maintain defaults for 
reports and books separately.

You determine the position of the time, date, page numbers, and text by selecting 
the left, center, or right zone within the top or bottom label. For example, you 
might set up the time, date, or page numbers to appear on the top-left or 
bottom-center of a page. You might also include a brief line of text as a label, such 
as Monthly Income.

The top and bottom labels each contain one or more lines where the date, time, 
page numbers, and text appear when you preview or print the report or book. On a 
top label, the first line contains the date, time, or page number and the last line 
contains the label text. In a bottom label, the first line contains the label text and 
the last line contains the date, time, or page number. 

Applies To:
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The following figure shows a report with top and bottom labels.

Figure 30: Report with Top and Bottom Labels

1. Contains the date.

2. Contains label text.

3. Contains text.

4. Contains the time.

➤ To change the default label setup:

1. From a report or book window, select File > Page Setup.

2. Do one of the following:

� To specify the margins, select the General tab and specify the top, 
bottom, left, and right margins.

� To specify the date, select the Date tab and specify the date option.

� To specify the time, select the Time tab and specify the time option.
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� To specify the page numbers, select the Page Numbers tab and specify 
the page numbers option.

� To specify the text, select the Text tab and specify the text option.

3. Click OK.  

Report and Book Output

You can preview report output in the Preview window before you print the report. 
You can also send the report or book output to a printer or to a file. 

You can print an entire report or book, a specific range of pages, or a batch of 
reports or books. You can also print a report, a book, or a batch of reports or books 
to a file so that you can save the output for future use. For example, you might want 
to save the output of a report so that you can use a text editor to include the report 
in other documents.

Select a Printer 

You can select a printer and specify the options such as paper size, source, 
orientation, page setup, and advanced properties. 

➤ To select a printer:

1. From a report window, select File > Printer Select.

2. Select a printer.

3. Click Setup to specify the paper size, source, and orientation.

Applies To:

Applies To:
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4. Click Properties to specify the page setup and advanced options.

Note: The printer options you specify are saved in your REPENG.INI 
file and are reused for the selected printer until you change them.

Preview the Active Report, Batch of Reports, 
or Batch of Report Sets

You can preview the active report, batch of reports, or batch of report sets in the 
Preview window before you print. From the Preview window, you can view 
individual pages or sections of a report, view the margin outlines, or print the 
report. 

➤ To preview the active report, batch of reports, or batch of report sets:

1. Do one of the following:

� To preview the active report, select File > Preview or the Preview toolbar 
icon.

Tip: To print from the Preview window, click Print. 

� To preview a batch of reports, select File > Preview Batch, select the 
Report tab, select the report set, then select one or more reports.

� To preview a batch of report sets, select File > Preview Batch, select the 
Report Set tab, then select one or more report sets.

2. View the report output, then click Close to return to the report window.

Note: Click Cancel to stop previewing the entire batch.

Applies To:
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Print Active Reports or Books

You can print the output of an entire report or book, or you can print specified 
pages of its output. For example, you can print pages 3 through 10 of the active 
report.

You have the option of using draft-quality printing, which is faster but less refined 
than regular printing. When you use draft-quality printing, the system might not 
use the fonts you specified for data. You can use the draft-quality option to make 
copies of the report or book for review rather than for final distribution or 
publication.

You can also print a report or book to a file to save the output in ASCII format. By 
default, Hyperion Enterprise Reporting Windows Client saves the file with a .TXT 
extension in the report directory for the current application, but you can specify a 
different extension or directory.

When you print a book, Hyperion Enterprise Reporting Windows Client 
suppresses reports that do not contain any printable rows or columns. For example, 
if all the rows in a report are suppressed, the report is not printed. For a Hyperion 
Enterprise application, Hyperion Enterprise Reporting Windows Client does not 
print reports that specify the dependents for entities when the dependents do not 
exist.

Note: You can use the File > Printer Select option to select your printer. If 
you select the Generic/Text Only on File printer, the output is an 
ASCII text file without Windows formatting. Windows formatting is 
not controlled by Hyperion Enterprise Reporting Windows Client. 
For instructions on selecting or setting up a printer, see the Microsoft 
Windows User’s Guide.

➤ To print the active report or book:

1. From a report or book, select File > Print or the Print toolbar icon.

Tip: From a report window, you can also select File > Preview and 
then click Print from the Preview window.

Applies To:
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2. To print the report or book to a file, click Print to ASCII File.

3. Specify printing options.

4. Click OK.  

Print a Batch of Reports, Report Sets, Books, 
or Book Sets

You can print a batch of reports, report sets, books, or book sets to a printer or an 
ASCII file. You can print batches to a printer only.

You can use the File > Printer Select option to select your printer. If you select 
the Generic/Text Only on File printer, the output is an ASCII text file without 
Windows formatting. Windows formatting is not controlled by Hyperion 
Enterprise Reporting Windows Client. For instructions on selecting or setting up 
a printer, see the Microsoft Windows User’s Guide.

➤ To print a batch of reports, report sets, books, or book sets:

1. From a window, select File > Print Batch.

2. Do one of the following:

� Select the Report or Report Set tab to print a batch of reports or report 
sets. 

� Select the Book or Book Set tab to print a batch of books or book sets.

3. From the Reports in Set, Books in Set or Set list box, select the names of the 
reports, report sets, books, or book sets that you want to print, then click OK.

Tip: To print a batch of reports to an ASCII file, you must place them 
in a book and then print the book using the Print to ASCII File 
option. 

Applies To:
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4. Click OK. 

Note: Press ESC to stop printing the entire batch.

Export the Active Report, Batch of Reports, or
Batch of Report Sets to Microsoft Excel 

You can export the active report, batch of reports, or batch of report sets to 
Microsoft Excel. You can then use Excel to create graphs, produce charts, and 
format the data in the report.

When you export a report to Excel, the report orientation and most of the report 
formatting options are exported. The following table describes the formatting 
options that are not exported:

Add the following line to use OLE automation and export a report without 
formatting options in Excel version 5.0 or higher.

[PE]

ExcelOLENoFormat=1

➤ To export the active report, batch of reports, or batch of report sets to Excel:

1. Do one of the following:

Applies To:

Table 33: Formatting Options Not Exported

If you select... Then...

View > Header or
View > Footer

The Color, and all Underline options except for 
Characters are not exported.

Format > Shading/Border The Shading, Cell Border, and Selection Border 
options are not exported.

Format > Font The Underline options except for Characters are 
not exported.
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� To export the active report, select File > Export.

� To export a batch of reports or batch of report sets, select File > Export 
Batch, select the Report or Report Set tab, then select the reports or 
report sets.

2. Specify export options.

Tip: The file name defaults to the report name. If you export the active 
report, you can specify another file name. 

3. Click OK. 

Note: Press ESC to stop exporting the entire batch.

Reporting Batch Commands, Batch Files, and 
Task Files 

Reporting batch commands specify actions and parameters that allow you to 
execute Hyperion Enterprise Reporting Windows Client tasks. A batch file is a text 
file that contains MS-DOS batch commands and reporting batch commands. Task 
files and response files are text files that contains reporting batch commands only. 
You can specify a log file which is updated with status information for reporting 
batch commands.

The following table lists each file and its purpose.

Applies To:

Table 34: Reporting Files 

Use this file... To...

Batch File Run Hyperion Enterprise Reporting Windows Client, log a 
user on to an application, initiate a log file, and run a task file.

Task File Set a point of view, print, preview or export reports, report sets, 
books, and book sets, specify a response file.
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Reporting batch commands allow you to do the following:

� Log on to a Hyperion Enterprise Reporting Windows Client application, 
application set, or server.

� Print, or export a report, report set, book, or book set.

� Preview a report or report set.

� Change the point of view within a report, report set, book, or book set.

� Respond to the @ASK function prompt within a report, report set, book, 
and book set.

� Create and update a log file which records the batch, task, and response 
file processing.

The following table lists the reporting batch commands that you can use to log on 
to an application. 

Response File Answer the @ASK function within reports and books.

Log File Log the status of executed reporting batch commands.

Table 35: Reporting Batch Commands for the Batch File 

Use this 
command...

With this 
parameter... To...

/user= userid Specify the user.

/pass= password Specify the password.

/prod= Hyperion product 
name

Specify the Hyperion product. Check the 
DRIVERS32 section in your REPENG.INI 
file for the Hyperion product name. This 
command machine is dependent because it is 
based on the settings in the REPENG.INI file 
on your machine.

Use either the /prod or /drv command to 
specify the product.

Table 34: Reporting Files (Continued)
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The following table lists the reporting batch commands that you can use to perform 
actions. You can place these commands in the batch or task file.

/drv= driver Specify the product driver. Use 1 for 
Hyperion Enterprise, 7 for Hyperion Essbase, 
or 4 for Hyperion Enterprise SE. This 
command is machine independent.

Note: Use either the /prod or /drv command 
to specify the product.

/srv= server name or IP 
address

Specify the Hyperion Essbase server.

/appset= application set Specify the Hyperion Essbase application set.

/app= application Specify the Hyperion Enterprise or Hyperion 
Essbase application. 

/taskfile= path and file name Specify the path and file name of the task file.

Table 36: Reporting Batch Commands for a Batch or Task File 

Use this 
command... With this parameter... To...

/logfile= path and file name The path and file name of the log file.

/printer= printer name Specify the printer. 

/pov= “dimension name or 
keyword ““dimension 
ID””” 

Specify the dimension IDs for the point 
of view.

/doctype= report, report set, book, 
or book set

Specify the document type.

/docaction= print, preview, export Specify the action.

/docname= name Specify the name of the report, report 
set, book, or book set.

Table 35: Reporting Batch Commands for the Batch File (Continued)

Use this 
command...

With this 
parameter... To...
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The following table lists the reporting batch commands that you can use in a 
response file.

Syntax

Reporting batch commands cannot have the space character before or after the 
equals ( = ) sign. For example, the command /doctype must appear without any 
spaces as follows:

/doctype=print

/exportpath= path Specify the export file path. The file 
name defaults to the name of the report 
or book.

/exporttype= text, data, custom1, 
custom2, excel, adobe

Specify the export file type.

/responsefile
=

path and file name The path and file name of the response 
file.

/responseres
et=

EndOfLine, EndOfFile, 
EndOfDocument

Specify when to rewind the response 
file.

Table 37: Reporting Batch Commands for a Response File

Use this 
command... With this parameter... To...

/keydef= “dimension ID, list, or 
function”

Specify the dimension ID, list or 
function for the LIST @ ASK 
function.

/povdef= “dimension name or 
keyword ““dimension 
ID””” 

Specify the point of view for the 
@ASK function.

/reportname= “report name” Specify the report name to import for 
the @ASK function.

Table 36: Reporting Batch Commands for a Batch or Task File (Continued)

Use this 
command... With this parameter... To...
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Quotes

All parameters that contain a space character must be wrapped with double quotes. 
All IDs or names with a non-alphanumeric or a space character must be wrapped 
with two double quotes. The following commands always require double quotes 
around the parameter:

� /pov

� /povdef

Suppose you have the /keydef command which specifies the LIST Status Report. 
The parameter and name contain a blank character, therefore the parameter is 
wrapped in double quotes, and the name is wrapped in two double quotes.

/keydef=”LIST ““Status Report”””

Following is an example of the /pov command which specifies the entity ID 
USDIV and the Field ID Field 1. The parameter is wrapped in double quotes, and 
the name is wrapped in two double quotes.

/pov= “entity USDIV Field ““Field 1”””

Case

The syntax for reporting batch commands is not case sensitive. The member names 
in Hyperion Essbase may be case sensitive. 

Comments

You can enter comments in a batch, task, or response file by using the following 
characters at the beginning of a line:

; // or rem

The following three lines are comments:

rem This is a comment line

// This is a comment line 

; This is a comment line
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Running the Batch and Task Files
The batch, task, and response files work together. Typically, the batch file invokes 
the task file which, in turn, invokes the response file. Each line in a batch and task 
file is executed independently from the other lines. For example, if you want to 
print a report, you must put the /docaction, /doctype, and /docname commands on 
the same line in the task file.

The following figure shows a batch and task file from the command line:

Figure 31: Running the Batch File from the Command Line

1. A command is executed from the batch file, the batch file invokes the task file.

2. A command is executed from the task file one line at a time. If information is 
missing from a line in the task file, it is retrieved from the batch file. If the 
information is not in the batch file, the line is aborted.

3. If a response file is used, it is opened and read starting with the first line.

Note: From the batch file, you can specify several different actions and 
then run the task file for each action. For example, the batch file 
can preview, print, and export the same task file.
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The following figure shows a task file from within Hyperion Enterprise Reporting 
Windows Client.

Figure 32: Running a Task File

➤ To run a task file from within Hyperion Enterprise Reporting Windows Client:

1. Select File > Run Tasks.

2. Enter a task file name. You can enter options in the Run Task dialog box, that 
you would otherwise specify on the MS-DOS command line.

Note: The commands execute one line at a time from the task file. If 
information is missing from a line, it retrieves from the options 
on the Run Task dialog box. If the information is not in the 
options, the line is aborted. If a response file is used, it opens and 
reads starting with the first line.
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Examples
The following example shows a batch, task, and response file that work together.

Note: Each line in the file is labeled with a number. This indicates that the 
batch and task file contain only one line, and the response file 
contains three lines. Do not include the line number in your batch, 
task, or response files.

Sample Batch File - DEMO.BAT

The following example shows a batch file that contains MS-DOS and reporting 
batch commands. This batch file runs Hyperion Enterprise Reporting Windows 
Client, and logs the user named admin on to a Hyperion Essbase application, 
initiates a log file, and runs the DEMO.TXT task file.

REM**********run Hyperion Enterprise Reporting Windows Client

REM specify the user, password and application information REM 
preview, print, and export the task file

Line 1: c:\program files\hyperion 
solutions\reporting\rw32.exe

/USER=ADMIN

/PASS=essbase

/PROD = Essbase

/Srv=server1

/SET=demo

/APP=basic

/logfile=”Batch file log”

/docaction=preview /TASKFILE=demo.txt

Sample Task File - DEMO.TXT

The following example shows a task file that contains reporting batch commands 
on one line. This task file sets the point of view, specifies a report set, uses the 
DEMO.RSP response file, and rewinds the DEMO.RSP file after each report runs.
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Line 1: /POV="ENT ““US DIV”””

/DOCTYPE=ReportSet

/DOCNAME=AUTO

/RESPONSEFILE=\server\demo\demo.rsp

/RESPONSERESET=ENDOFDOCUMENT

Sample Response File - DEMO.RSP

The following example shows a response file that answers @ASK, LIST@ASK 
and @ASK for a report name.

Line 1: /POVDEF="FX Local Category Actual”
Line 2: /KEYDEF="@CUR, USDIV, LIST ““TOP”””
Line 3: /REPORTNAME=”Status Report”

➤ To create a batch, task, or response file:

1. Create the file using a text editor.

Note: Use the .BAT extension for the batch file.

2. Do one or more of the following:

� Type the batch commands and parameters, and save the file.

� If you are creating a task file, you can select File > Run Task and type or 
select options. As you specify options, the reporting batch command 
appears in the Command Line text box. You can copy the command from 
the Command Line text box and paste it into your task file.

Running Batch and Task Files

You can run batch files from the MS-DOS command prompt or a task file from 
within Hyperion Enterprise Reporting Windows Client. 

Applies To:
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➤ To run a batch file from the MS-DOS command prompt:

1. Select the MS-DOS Command Prompt from your Start menu.

2. Enter the batch file name, and press Enter.

➤ To run a task file from within Hyperion Enterprise Reporting Windows Client:

1. Select File > Run Tasks.

2. Type the task file name in the Task File Name edit box, or click the Lookup 
button to select a task file.

Note: You must specify a task.

3. Do one of the following to run the task file:

� Click OK.

� Specify options, then click OK.

Note: The Run Task options are used if information is missing from the 
task file. For example, if the task file specifies a report named 
report1 without an action, then the action is retrieved from the 
Document Action field.
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Quick List of Functions 

Hyperion Enterprise Reporting Windows 
Client Functions for Hyperion Enterprise and 
Hyperion Essbase

The following list provides summaries of the Hyperion Enterprise Reporting 
Windows Client functions and shows which functions are available for each 
product. For more information about functions, see Chapter 12.

Applies To:

Table 38: Hyperion Enterprise Reporting Windows Client Functions for Hyperion 
Enterprise and Hyperion Essbase 

Function Description
Hyperion 
Enterprise 

Hyperion 
Essbase

ABS - Absolute 
Value

Retrieves the absolute value for an 
expression. 

✔ ✔

@ACODE - 
Account Code 

Retrieves the code of the current 
account code.

✔

11
Chapter
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@ALL - All  Creates columns or rows for all 
descendants of the current or 
specified entity, account, or 
subaccount. In Hyperion 
Enterprise, you can also use 
@ALL to create columns or rows 
for all descendants of the current 
or specified parent.

✔ ✔

@ALT - Current 
Alias Table 

Allows you to retrieve the current 
alias table name.

✔

@AMCODE- 
Chart Method 
Code 

Retrieves the code of the chart 
method assigned to the current 
entity.

✔

@ANC- All 
Ancestor Members

Retrieves the ancestors 
immediately above the specified 
member or current member.

✔

@APD - 
Application 
Description

Retrieves the current application 
description in a heading.

✔ ✔

@APN - 
Application Note

Retrieves the description of the 
current application note.

✔

@APP - 
Application Name

Retrieves the name of the current 
application or data repository.

✔ ✔

AS - Same 
Member as 
Row/Column

Creates a column or row for the 
same dimension setting as another 
column or row, specified by 
number.

✔ ✔

@ASK - Prompt 
User

Prompts users to specify a 
dimension when they run a report. 

✔ ✔

AVG - Average Calculates the average value of a 
group of columns or rows.

✔ ✔

Table 38: Hyperion Enterprise Reporting Windows Client Functions for Hyperion 
Enterprise and Hyperion Essbase (Continued)

Function Description
Hyperion 
Enterprise 

Hyperion 
Essbase
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@BAS - Base 
Level

Creates columns or rows for 
base-level dependents of the 
current or specified entity.

✔ ✔

BET - Evaluate 
Difference

Calculates the difference between 
the values in two columns or rows 
and shows whether the difference 
represents better or worse 
variance. 

✔ ✔

@BOT - 
Descendants at 
level 0

Retrieves all descendant members 
at level zero of the specified 
member or current member.

✔

CELL - Specific 
Cell Value

Identifies a specific cell value by 
its column and row numbers.

✔ ✔

CHANGE - 
Dimension Change

Marks a dimension change in a 
report or book.

✔ ✔

@CHART - Chart 
Logic Expansion

Expands a calculated account 
based on chart logic to show the 
calculation detail.

✔

CHG - Calculate 
Difference

Calculates the difference between 
the values in two rows or columns 
without evaluating the difference.

✔ ✔

@CHL - Children Retrieves the children of the 
specified member or current 
member.

✔

@CMCODE - 
Consolidation 
Method Code 

Retrieves the code of the 
consolidation method for the 
current entity.

✔

@CMO - Current 
Category Period 
Number

Creates a row or column for a 
period based on its relation to the 
current point-of-view period.

✔

Table 38: Hyperion Enterprise Reporting Windows Client Functions for Hyperion 
Enterprise and Hyperion Essbase (Continued)

Function Description
Hyperion 
Enterprise 

Hyperion 
Essbase
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@CON - 
Dependent Entities

Creates columns or rows for 
summary entities below the 
current or specific entity. In 
Hyperion Enterprise, you can 
create columns or rows for entities 
below the current or specified 
parent.

✔

CPN - Current 
Period Number

Retrieves the number of the 
current period. 

✔

@CUR - Current 
Dimension Setting

Creates a column or row for a 
specified dimension using the 
current point of view setting.

✔ ✔

@CURCY - 
Currency Text

Retrieves the identifying ID or 
description of the current entity. 
You can also retrieve the symbol 
for a currency.

✔

@DAT - Period 
Description

Retrieves a custom description for 
the current period.

✔

@DEP - 
Dependents

Creates columns or rows for all 
dependents of the current or 
specified entity. In Hyperion 
Enterprise, you can create 
columns or rows for all 
dependents of the current specified 
parent.

✔ ✔

@DES - 
Dimension 
Descriptions

Retrieves the description of the 
current dimension. 

✔ ✔

@DSC - 
Descendant 
Members

Retrieves the descendants of the 
specified member or current 
member. 

✔

Table 38: Hyperion Enterprise Reporting Windows Client Functions for Hyperion 
Enterprise and Hyperion Essbase (Continued)

Function Description
Hyperion 
Enterprise 

Hyperion 
Essbase
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DUR - Specific 
Value

Shows a specified value or 
expression in a range of columns 
or rows. 

✔ ✔

@ECODE - Entity 
Code 

Retrieves the code of the current 
entity.

✔

@END - Ending 
Period

Creates a row or column for the 
ending period or for a period that 
is offset from the ending period.

✔

@ENT - Entity as 
Parent

Creates a column or row with the 
current entity as the parent.

✔

@FIRST - First 
Subaccount

Specifies the first subaccount in 
the subaccount table assigned to 
an account.

✔

@FLN - File 
Name

Retrieves the active report’s file 
name.

✔ ✔

@FLT - File Title Retrieves the active title of the 
active report. 

✔ ✔

FOR - Section Marks the beginning of a section 
in a report or book.

✔ ✔

@FRD - 
Frequency 
Description 

Retrieves the description for the 
current frequency.

✔

@FRL - 
Frequency 
Identifying Label

Retrieves the ID, or label, for the 
current frequency.

✔

FROM - Start of 
Range

Marks the start of a range of 
dimension values, such as 
accounts.

✔ ✔

@GEN - Same 
Generation

Retrieves all of the members in the 
generation of the specified or 
current member.

✔

Table 38: Hyperion Enterprise Reporting Windows Client Functions for Hyperion 
Enterprise and Hyperion Essbase (Continued)

Function Description
Hyperion 
Enterprise 

Hyperion 
Essbase
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IFT - If Then Shows a specific value or text, 
depending on whether the result of 
an expression is negative, zero, or 
positive.

✔ ✔

@IND - Indent Indents the text based on the 
generation number.

✔

@LAB - 
Dimension 
Identifying Labels

Retrieves the ID for the current 
dimension.

✔ ✔

@LAD - 
Lowest-level 
Account 
Description

Retrieves the lowest-level 
description for the current 
account.

✔

@LAL - 
Lowest-level 
Account 
Identifying Label

Retrieves the ID for the 
lowest-level of the current account 
or subaccounts.

✔

@LAST - Last 
Subaccount

Specifies the last subaccount in the 
subaccount table assigned to an 
account.

✔

LIST - List Defines columns or rows for the 
accounts in an account list when 
you use LIST with the ACC 
keyword, or the entities in an 
entity list when you use LIST with 
the ENT keyword.

✔ ✔

@LOCAL - Local 
Headings

Assigns local headings to columns 
or rows.

✔ ✔

@LRC - Linked 
Reporting 
Comments

Retrieves linked reporting objects 
which are comments.

✔

Table 38: Hyperion Enterprise Reporting Windows Client Functions for Hyperion 
Enterprise and Hyperion Essbase (Continued)

Function Description
Hyperion 
Enterprise 

Hyperion 
Essbase
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@LRD - 
Modification Date 
of a Linked 
Reporting Object

Retrieves the modification date of 
the currently linked reporting 
object.

✔

@LRF - Linked 
Reporting Files

Retrieves linked reporting objects 
which are files.

✔

@LRI - Index of a 
Linked Reporting 
Object

Retrieves the index of a currently 
linked reporting object.

✔

@LRO - Linked 
Reporting Objects

Retrieves linked reporting objects, 
including files and comments.

✔

@LRT - Type of a 
Linked Reporting 
Object

Retrieves the type of a currently 
linked reporting object.

✔

@LRU - User of a 
Linked Reporting 
Object

Retrieves the user of a currently 
linked reporting object.

✔

@LVL - Same 
Level

Retrieves all members at the same 
level as the specified member or 
current member.

✔

MUL - Multiply Multiplies the values of two 
columns or rows. 

✔ ✔

@OFF Creates a column or row for the 
offset of the current or specified 
period.

✔

@PAR - Parent Creates columns or rows for the 
parent dimension.

✔

PBE - Evaluate 
Percent Change

Calculates the percent change 
between the values in two columns 
or rows and determines whether 
the change represents a better or 
worse variance.

✔ ✔

Table 38: Hyperion Enterprise Reporting Windows Client Functions for Hyperion 
Enterprise and Hyperion Essbase (Continued)

Function Description
Hyperion 
Enterprise 

Hyperion 
Essbase
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PCH - Percent 
Change

Calculates the percent change 
between two rows or columns 
without evaluating the difference. 

✔ ✔

PCR - Percent by 
Row

Shows values in the current 
column or row as percentages of 
the value in a specified cell.

✔ ✔

PCT - Ratios as 
Percentages

Expresses the ratios of the values 
in one column or row to those in 
another as percentages.

✔ ✔

@PDES - Partial 
Description

Retrieves partial descriptions of 
entities or accounts with 
subentities or subaccounts. 

✔

@PLAB - Partial 
Dimension 
Identifying Label

Retrieves partial IDs, or labels, of 
entities or accounts with 
subentities or subaccounts.

✔

@PSF- 
Consolidation 
Status 

Retrieves the consolidation status 
of the current entity.

✔

RAT - Ratios Calculates the ratios of the values 
in one row or column to those in 
another row or column.

✔ ✔

REPORT - Report 
in Book 

Specifies a report in a book. ✔ ✔

RND - Round 
Specific Values

Rounds the results of expressions 
to the nearest designated value.

✔ ✔

@RNG Retrieves a range of dimension 
IDs.

✔ ✔

@RPD - Current 
Reporting 
Directory

Retrieves the name of the current 
reporting directory in the report 
directory setting in the 
REPENG.INI file.

✔

Table 38: Hyperion Enterprise Reporting Windows Client Functions for Hyperion 
Enterprise and Hyperion Essbase (Continued)

Function Description
Hyperion 
Enterprise 

Hyperion 
Essbase



Quick List of Functions

� 217Hyperion Enterprise Reporting Windows Client User’s Guide

11

@SCALE - 
Current Entity 
Scale

Retrieves a number that represents 
the scale for the current entity.

✔

@SED - Set 
Description

Retrieves the description of the 
current set description.

✔

@SET - Set Name Retrieves the description of the 
current set name.

✔

@SIB - All 
Siblings

Retrieves all siblings of the current 
member or specified member.

✔

@SLA - All 
Siblings to the Left

Expands to include all siblings to 
the left of the specified member, 
excluding the specified member.

✔

@SLF - First 
Sibling to the Left

Expands to include the first sibling 
to the left of the specified member, 
excluding the specified member.

✔

@SRA - All 
Siblings to the 
Right

Expands to include all the siblings 
to the right of the specified 
member, excluding the specified 
member.

✔

@SRF - First 
Sibling to the 
Right

Expands to include the first sibling 
to the right of the specified 
member, excluding the specified 
member.

✔

@SRN - Server 
Name

Retrieves the current server name. ✔

@START - 
Starting Period

Creates a row or column for the 
starting period or for a period that 
is offset from the starting period.

✔

@SUB - 
Subaccounts

Creates columns or rows for 
subaccounts of a specified 
account.

✔

Table 38: Hyperion Enterprise Reporting Windows Client Functions for Hyperion 
Enterprise and Hyperion Essbase (Continued)

Function Description
Hyperion 
Enterprise 

Hyperion 
Essbase
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SUM - Total Adds the values of specified 
columns or rows. 

✔ ✔

@TIM - Current 
Time

Retrieves the current system time. ✔ ✔

@TMCODE - 
Translation 
Method Code 

Retrieves the code of the current 
translation method.

✔

@TOD - Current 
Date

Retrieves the current system date. ✔ ✔

@TOP - Topmost 
Element

Topmost (unowned) elements in 
the dimension.

✔

UNTIL - End of 
Range

Marks the end of a range of 
dimension values such as 
accounts.

✔ ✔

@USR - User ID Retrieves the ID of the current 
user. 

✔ ✔

@VWD - View 
Description

Retrieves the description for the 
current view.

✔

@VWL - View 
Identifying Label

Retrieves the ID for the current 
view.

✔

WITHSUB - With 
Subaccounts

Includes all subaccounts in a range 
of accounts.

✔ ✔

WITHSUB1 - 
With First-level 
Subaccounts

Includes first-level subaccounts in 
a range of accounts.

✔ ✔

@WLD - Wildcard Retrieves all members that match 
your wildcard specification.

✔

Table 38: Hyperion Enterprise Reporting Windows Client Functions for Hyperion 
Enterprise and Hyperion Essbase (Continued)

Function Description
Hyperion 
Enterprise 

Hyperion 
Essbase
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Hyperion Enterprise Reporting Windows 
Client for Essbase Functions

The following list provides summaries of the Hyperion Enterprise Reporting 
Windows Client for Essbase functions. Unless specified, all functions in the list 
are available for all dimensions except the Field dimension. For more information 
about functions, see Chapter 12.

Applies To:

Table 39: Functions for Hyperion Enterprise Reporting Windows Client for 
Essbase 

Function Description

ABS - Absolute 
Value

Retrieves the absolute value of expression.

@ALL - All  Creates columns or rows for all descendants of the current or 
specified entity, account, or subaccount. 

@ALT- Current 
Alias Table

Retrieves the current alias table name. 

@ANC - All 
Ancestor Members

Retrieves the ancestor immediately above the specified 
member or current member.

@APD - 
Application 
Description

Retrieves the description of the current application.

@APN - 
Application Note

Retrieves the description of the current application note.

@APP - 
Application Name

Retrieves the name of the current application or data 
repository.

AS - Same Member 
as Row/Column

Creates a column or row for the same dimension setting as 
another column or row, specified by number.
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@ASK - Prompt 
User

Prompts users to specify a dimension when they run a 
report. 

AVG - Average Calculates the average value of a group of columns or rows.

@BAS - Base Level Creates columns or rows for base-level dependents of the 
current or specified entity.

BET - Evaluate 
Difference

Calculates the difference between the values in two columns 
or rows and shows whether the difference represents better 
or worse variance. 

@BOT - All 
Members at Level 0

Retrieves all descendant members at level zero of the 
specified member or current member.

CELL - Specific 
Cell Value

Identifies a specific cell value by its column and row 
numbers.

@CHL - Immediate 
Child Member

Retrieves all children of the specified member or current 
member.

CHANGE - 
Dimension Change

Marks a dimension change in a report or book.

CHG - Calculate 
Difference

Calculates the difference between the values in two rows or 
columns without evaluating the difference.

@CUR - Current 
Dimension Setting

Creates a column or row for a specified dimension using the 
current point of view setting.

@DEP - 
Dependents

Creates columns or rows for all dependents of the current or 
specified entity. 

@DES - Dimension 
Description

Retrieves the description of the current dimension. 

@DSC - 
Descendant 
Members

Retrieves all descendants of the specified member or current 
member. 

DUR - Specific 
Value

Shows a specified value or expression in a range of columns 
or rows. 

@FLN - File Name Retrieves the file name of the active report.

Table 39: Functions for Hyperion Enterprise Reporting Windows Client for 
Essbase (Continued)

Function Description
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@FLT - File Title Retrieves the title of the active report. 

FOR - Section Marks the beginning of a section in a report or book.

FROM - Start of 
Range

Marks the start of a range of dimension values, such as 
accounts.

@GEN - All 
Member of the 
Same Generation

Retrieves all of the members in the generation of the 
specified or current member. 

IFT - If Then Shows a specific value or text, depending on whether the 
result of an expression  is negative, zero, or positive.

@IND Indents text according to generation number.

@LAB - 
Dimension 
Identifying IDs

Retrieves the ID for the current dimension.

LIST - List Defines columns or rows for the accounts in an account list 
when you use LIST with the ACC keyword, or the entities in 
an entity list when you use LIST with the ENT keyword.

@LOCAL - Local 
Headings

Assigns local headings to columns or rows.

@LRC Retrieves comments attached to linked reporting objects. 
(Available only for the Field dimension).

@LRD Retrieves the modification date of the currently linked 
reporting object. (Available only for the Field dimension).

@LRF Retrieves the files attached to linked reporting objects. 
(Available only for the Field dimension).

@LRI Retrieves the index of currently linked reporting objects. 
(Available only for the Field dimension).

@LRO Retrieves linked reporting objects, including their attached 
files and comments. (Available only for the Field 
dimension).

@LRT Retrieves the type of currently linked reporting objects. 
(Available only for the Field dimension).

Table 39: Functions for Hyperion Enterprise Reporting Windows Client for 
Essbase (Continued)

Function Description
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@LRU Retrieves the user of currently linked reporting objects. 
(Available only for the Field dimension).

@LVL - All 
Members of Same 
Level

Retrieves all members at the same level of the specified 
member or current member.

MUL - Multiply Multiplies the values of two columns or rows. 

@PAR - Parents Retrieves the parent values of a specified member 
combination.

PBE - Evaluate 
Percent Change

Calculates the percent change between the values in two 
columns or rows and determines whether the change 
represents a better or worse variance.

PCH - Percent 
Change

Calculates the percent change between two rows or columns 
without evaluating the difference. 

PCR - Percent by 
Row

Shows values in the current column or row as percentages of 
the value in a specified cell.

PCT - Ratios as 
Percentages

Expresses the ratios of the values in one column or row to 
those in another column or row as percentages.

RAT - Ratios Calculates the ratios of the values in one row or column to 
those in another row or column.

REPORT - Report 
in Book 

Specifies a report in a book.

RND - Round 
Specific Values

Rounds the results of an expression to the nearest designated 
value.

@RNG

@RPD - Reporting 
Directory

Retrieves the name of the current reporting directory in the 
report directory setting in the REPENG.INI file.

@SED - Set 
Description

Retrieves the description of the current set description.

@SET - Set Name Retrieves the description of the current set name.

Table 39: Functions for Hyperion Enterprise Reporting Windows Client for 
Essbase (Continued)

Function Description
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@SIB - All Siblings Returns all siblings of the current member or specified 
member.

@SLA - All 
Siblings to the Left

Retrieves all siblings to the left of the current or specified 
member, excluding the member. 

@SLF - First 
Sibling to the Left

Retrieves the first sibling to the left of the current or 
specified member. 

@SRA - All 
Siblings to the 
Right

Retrieves all siblings to the right of the current or specified 
member, excluding the member.

@SRF - First 
Sibling to the Right

Retrieves the first sibling to the right of the current or 
specified member.

@SRN - Server 
Name

Retrieves the current server name.

SUM - Total Adds the values of specified columns or rows. 

@TIM - Time Retrieves the current system time.

@TOD - Date Retrieves the current system date.

@TOP - All 
Members of 
Generation 2

Creates a row or column for a dimension’s topmost unowned 
ID.

UNTIL - End of 
Range

Marks the end of a range of dimension values such as 
accounts.

@USR - User ID Retrieves the ID of the current user.

WITHSUB - With 
Subaccounts

Includes all subaccounts in a range of accounts.

WITHSUB1 - With 
First-level 
Subaccounts

Includes first-level subaccounts in a range of accounts.

@WLD - All 
Members that 
Match the Wildcard 
Specification

Retrieves all members of the wildcard specification.

Table 39: Functions for Hyperion Enterprise Reporting Windows Client for 
Essbase (Continued)

Function Description
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Functions

The Hyperion Essbase examples in this chapter are based on the Hyperion Essbase 
Demo application. 

ABS - Absolute Value

The financial function ABS produces the absolute value for an expression. For 
example, if the result for an expression is -1, its absolute value is 1. You use the 
ABS function to record variances as positive figures. If you use the Edit Formulas 
dialog box to paste this function into a column or row, the function appears in the 
formula bar edit box when you view data formulas. 

This formula appears for a column that shows the difference between columns 2 
and 1 as a positive number:

ABS([2]-[1])

This formula appears for a row that shows the difference between current account 
values for two entities as a positive number: 

ABS([ENT DIAMOND] - [ENT JUNIPER]) 

Applies To:

12
Chapter
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 Function

The ABS function appears in this format:

ABS(Value)

where Value is an expression. An expression can be an account ID. An expression 
can also use math symbols, and it can refer to other columns or rows by number.

Note: When you select the ABS function, the data formula appears as the 
column or row heading by default, but you can type a different 
heading in the formula bar edit box or in the Edit Formulas dialog 
box.

@ACODE - Account Code

The text function @ACODE produces a code, which you can define in Hyperion 
Enterprise, for grouping accounts. When you use the Edit Formulas dialog box to 
paste this function into a heading formula, the function appears in the formula bar 
edit box if you view heading formulas. You can also use the Header and Footer 
dialog boxes to paste this function into headers and footers.

For example, you can create this formula for a footer:

Account Group: @ACODE

If the current account code is T-FR, the formula produces this footer when you run 
the report:

Account Group: T-FR

Applies To:
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 Function

 The @ACODE function appears in this format:

[Before] @ACODE [After]

@ALL - All

The @ALL function creates columns or rows for all dependents of an entity or 
parent or for all subaccounts, first-level subaccounts, or second-level subaccounts 
of an account. You can select this function when you use the Edit menu or a 
formula bar button to assign the entity, account, or parent using the function 
method. 

When you use the Edit Formulas dialog box to paste the @ALL function into a 
heading formula, the function appears in the formula bar if you view heading 
formulas.

Note: The parent dimension is supported in Hyperion Enterprise.

 Hyperion Enterprise Example

This formula shows data for all entities below the current entity:

ENT @ALL 

This formula creates columns or rows for all subaccounts below the account 
C1SALES:

ACC @ALL(C1SALES)

Where... Is...

Before Any text that appears before the account code.

After Any text that appears after the account code.

Applies To:
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This formula creates columns or rows for all first-level subaccounts of the current 
account from the INTERCO subaccount table:

SUBACC1 @ALL(TABLE INTERCO)

 Hyperion Essbase Example

This formula shows data for all descendant entities below the current entity:

ENTITY @ALL 

This formula creates columns or rows for all descendants below the account 
C1SALES:

ACCOUNT @ALL(C1SALES)

Function

The @ALL function appears in these formats:

� Keyword or Dimension @ALL 

This format retrieves the descendants of the member in the current point of view 
for the dimension.

� Keyword or Dimension @ALL(ID) 

This format retrieves the descendants of the ID for the dimension.

Where... Is...

Keyword or Dimension The keyword for a dimension in Hyperion Enterprise 
or the dimension name in Hyperion Essbase.

ID An ID that overrides the current setting for the 
specified dimension. 
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@ALT - Current Alias Table

The text function @ALT allows you to retrieve the current alias table name. When 
you use the Edit Formulas dialog box to paste this function into a heading formula, 
the function appears in the formula bar edit box if you view heading formulas. You 
can also use the Header and Footer dialog boxes to paste this function into headers 
and footers.

For example, if the current alias table is named “La Table Francais,” and you apply 
the @ALT function in the heading formula, “La Table Francais” appears in the 
heading.

Note: The alias table name is initially set to “default” in the REPENG.INI 
file until you specify a new alias table. For more information on alias 
tables, see the Arbor Essbase Database Administrator’s Guide.

 Function

The function @ALT appears in this format:

@ALT

Applies To:
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@AMCODE - Chart Method Code

The text function @AMCODE produces a code, which you can define in Hyperion 
Enterprise, for grouping methods. When you use the Edit Formulas dialog box to 
paste this function into a heading formula, the function appears in the formula bar 
edit box if you view heading formulas. You can also use the Header and Footer 
dialog boxes to paste this function into headers and footers.

For example, you can create this formula for a footer:

Chart Method: @AMCODE

If the current chart method code is FR-ELIM, the formula produces this footer 
when you run the report:

Chart Method: FR-ELIM

 Function

The @AMCODE function appears in this format:

[Before] @AMCODE [After]

Applies To:

Where... Is...

Before Any text that appears before the chart method code.

After Any text that appears after the chart method code.



Functions

� 231Hyperion Enterprise Reporting Windows Client User’s Guide

12

@ANC - All Ancestor Members

The function @ANC retrieves the ancestors above the specified member or current 
member. It is supported for all dimensions except the Field and View dimensions. 
You can use this function as a parameter of another function where the required 
parameter is a list of members. 

When you use the Edit Formulas dialog box to paste this function into a heading 
formula, the function appears in the formula bar edit box if you view heading 
formulas. For example, the following statement retrieves: Market, East, Central, 
West.

Market @ANC

The following statement retrieves Year:

Period @ANC(QTR4)

 Function

The function @ANC appears in these formats:

� Dimension @ANC

This retrieves the ancestors above the member in the current point 
of view for the dimension.

� Dimension @ANC(mbrName)

This retrieves the ancestors above the mbrName for the dimension.

Applies To:

Where... Is...

Dimension A dimension name.

mbrName A specified member.
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@APD - Application Description

The text function @APD retrieves the current application description in a heading. 
You can use the Header and Footer dialog boxes to paste this function into the 
header and footer of your report.

For example, you can create this formula for a row heading:

Totals for @APD

If the current application is HQ, the formula produces this heading when you run 
the report:

Totals for Headquarters

 Function

The @APD function appears in this format:

[Before] @APD [After]

Applies To:

Where... Is...

Before Any text that appears before the current application description.

After Any text that appears after the current application description.
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@APN - Application Name

The text function @APN displays the Hyperion Essbase application name in a 
heading. You can use the Header and Footer dialog box to paste this function into 
a heading formula, the function appears in the formula bar if you view heading 
formulas. You can use the Header and Footer dialog boxes to paste this function 
into the header and footer of your report.

 Function

The @APN function appears in this format:

@APN

@APP - Application ID

The text function @APP displays the current application ID. You can use the 
Header and Footer dialog box to paste this function into a heading formula, the 
function appears in the formula bar if you view heading formulas. You can use the 
Header and Footer dialog boxes to paste this function into the header and footer of 
your report.

For example, you can create this formula for a footer:

Totals for @APP

Applies To:

Applies To:
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If the current application ID is Headquarters, the formula produces this footer 
when you run the report:

Totals for Headquarters

 Function

The @APP function appears in this format:

[Before] @APP [After]

AS - Same As

The AS function creates a column or row for the same dimension setting as another 
column or row, specified by number. You can select this function when you use 
the Edit menu or a formula bar button to specify a dimension setting using the 
function method.

For example, this formula creates a row for the same entity as row 15:

ENT AS 15

If the AS function refers to a dimension setting that you have changed, the AS 
function produces the current setting. For example, suppose this formula appears 
for a column: 

ENT AS 4

If you insert an entity change, the formula sets up a column for the current entity 
regardless of which column contains the change. 

Where... Is...

Before Any text that appears before the current application ID.

After Any text that appears after the current application ID.

Applies To:
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 Function

The AS function appears in this format:

Keyword or Dimension AS Number

@ASK - Prompt User

The @ASK function prompts you for dimension settings when you run a report. 
You can select this function when you use the Edit menu or a formula bar button 
to assign or change a dimension setting using the function method. When you 
select this function, it appears in the formula bar edit box if you view data 
formulas.

For example, this formula prompts you to select one or more categories when you 
run the report:

CAT @ASK

 Function

The @ASK function appears in this format:

Dimension @ASK

where Dimension is any dimension.

Where... Is...

Keyword or Dimension The keyword for a dimension in Hyperion 
Enterprise, or the dimension name in Hyperion 
Essbase.

Number The number of a column or row in the report.

Applies To:
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AVG - Average: Overview

The financial function AVG calculates the average value for a group of columns 
or rows. The columns or rows can be consecutive or nonconsecutive. When you 
use the Edit Formulas dialog box to paste this function into a column or row, the 
function appears in the formula bar edit box if you view data formulas. 

For example, this formula in a row produces average values for rows 1, 4, and 7:

AVG(1,4,7)

This formula in a column produces average values for columns 4 through 12:

AVG(4:12)

 Function

The AVG function in this format averages the values in specified columns or rows, 
regardless of whether the columns or rows are consecutive:

AVG(First,[...,]Last)

Applies To:

Where... Is...

First The first row or column included in the average.

Last The last row or column included in the average.
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The AVG function in this format averages a range of consecutive columns or rows:

AVG(First:Last)

@BAS - Base Level 

The @BAS function creates columns or rows for base-level IDs below the current 
or specified ID for a dimension. You can select this function when you use the Edit 
menu or the formula bar to assign dimension IDs using the function method. When 
you select this function, it appears in the formula bar edit box if you view data 
formulas.

This formula shows data for all base-level dependents of the current entity:

ENT @BAS 

 Function

The @BAS function appears in these formats:

� Keyword or Dimension @BAS 

This retrieves the bottom level children of the member in the current point of view 
for the dimension.

� Keyword or Dimension @BAS(ID) 

Where... Is...

First The first row or column in the range.

Last The last row or column in the range.

Applies To:
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This retrieves the bottom level children of the ID for the dimension.

BET - Evaluate Difference

The financial function BET calculates the difference between the values in two 
columns or rows and shows whether the difference represents better or worse 
variance. When you use the Edit Formulas dialog box to paste this function into a 
column or row, the function appears in the formula bar edit box if you view data 
formulas. 

The system evaluates the difference between the specified values based on account 
type for the current fully specified account. For an Income, Flow, Asset, or 
Balance account, a positive result represents an increase, so the result appears as a 
positive number. For an Expense or Liability account, a positive result represents 
a decrease, so the result appears as a negative number.

For example, this formula creates a column that evaluates and shows the 
differences between the values in columns 1 and 5:

BET(1,5)

Where... Is...

Keyword or Dimension The keyword for a dimension in Hyperion 
Enterprise, or
the dimension name in Hyperion Essbase.

ID An ID that overrides the current setting for the 
specified dimension. 

Applies To:
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 Function

The BET function appears in this format:

BET(First,Second)

@BOT - Members at Level 0

The function @BOT retrieves all members at level zero for the specified member 
or current member. It is supported for all dimensions except the Field and View 
dimensions.

You can use this function as a parameter of another function, where the required 
parameter is a list of members. 

When you use the Edit Formulas dialog box to paste this function into a heading 
formula, the function appears in the formula bar edit box if you view heading 
formulas. 

For example, the following statement:

@BOT(East)

retrieves:

New York, Connecticut, New Jersey

Where... Is...

First The number of the first column or row.

Second The number of the second column or row.

Applies To:
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 Function

The @BOT function appears in these formats:

� Dimension @BOT 

which retrieves the level 0 members of the current point of view for the dimension.

� Dimension @BOT(mbrName) 

which retrieves the level 0 members of the mbrName for the dimension.

� @BOT(All)

where ALL is all level 0 members.

CELL - Specific Cell Value

The cell function retrieves unscaled numeric values from a specific cell in a report 
identified by a column and row, or by an opposing column or row.

The cell referenced is the column and row as seen in the report before preview. A 
single row and column may contain more than one value, so the resulting cell may 
actually be a summarized value.

The financial function CELL identifies a specific cell value by its column and row 
numbers. You can use the CELL function in these ways:

� With some financial functions, including DUR and IFT.

� With the Suppress If Expression option to specify Display options for report 
formats. For more information, see Set Display Options on page 156.

Where... Is...

Dimension The dimension name.

mbrName A specified member.

Applies To:
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� In Criteria statements. For more information, see Set Criteria on page 162. 

� In an expression without other functions, to retrieve the value in one cell and 
display it in one or more other cells. For more information, see Expressions on 
page 101.

When you use the Edit Formulas dialog box to paste this function into a column or 
row, the function appears in the formula bar edit box if you view data formulas. 

For example, this formula for a row creates a value for the first column in that row 
that calculates the number in column 3, row 2 divided by the number in column 5, 
row 6:

DUR(1,1,CELL(3,2)/CELL(5,6))

For example:

Row 1 = ACCOUNT EXP1, EXP2

Col 1 = DAT JAN, FEB

The command CELL(1,1) is the sum of EXP1 and EXP2 for JAN and FEB.

Takes one or two parameters

One – Refers to the opposite report axis.

Two – The first one refers to the column, and the second one refers to the row.

Cell function with a single parameter

Evaluates values as previewed, which is an exception to the general rule that 
evaluates values as seen in the report. For example, the following line in the third 
row of a report suppresses each entity in column 1 with a value less than 10:

ENTITY @ALL(CORP) SUPPRESS IF CELL(1)<10

The following two-parameter use of the cell function evaluates the summarized 
third row and suppresses all rows if the combined total is less than 10.

ENTITY @ALL(CORP) SUPPRESS IF CELL(1,3)<10
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 Function

The CELL function appears in this format:

CELL(Column,Row)

CHANGE - Dimension Change

The CHANGE function marks a dimension change in a report or book. It is 
followed by a keyword or dimension. When you use the Edit menu to insert a 
dimension change, the CHANGE function appears in the formula bar edit box if 
you view data formulas.

For example, suppose the current category is Actual, and you use this formula in 
a column to change the current category to Budget, in Hyperion Enterprise:

CHANGE CAT BUDGET 

You use this formula in a column to change the current category to Budget, in 
Hyperion Essbase:

CHANGE CATEGORY BUDGET 

The report uses the Budget category for all subsequent columns, unless you insert 
another category change in a subsequent column. However, the report uses Actual 
as the default for any column where you have not specified a category before the 
first category change.

Where... Is...

Column The column number for a specific cell.

Row The row number for a specific cell.

Applies To:
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 Function

The CHANGE function appears in this format:

CHANGE Keyword or Dimension, ID

@CHART - Chart Logic Expansion

The @CHART function expands a calculated account based on chart logic or chart 
methods to show the calculation detail. You can select this function when you use 
the Edit menu or the Account formula bar button to assign accounts with the 
function method. When you select this function, it appears in the formula bar edit 
box if you view data formulas.

For example, the following formula produces columns or rows with calculation 
detail for the Net Sales account:

ACC @CHART (NETSALES)

If the chart logic or chart methods calculate the Net Sales account by subtracting 
Cost of Goods Sold from the Total Sales value, the formula expands Net Sales to 
show the Total Sales and Cost of Goods Sold values.

Where... Is...

Keyword or Dimension The keyword for a dimension in Hyperion 
Enterprise, or the dimension name in Hyperion 
Essbase.

ID The ID for the specified dimension.

Applies To:
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The following table shows the four types of chart logic or formulas that the 
@CHART function expands.

 Function

The @CHART function appears in this format:

ACC @CHART [(ID)]

where ID is an account ID. If you do not specify an account ID, the system uses 
the current account.

CHG - Calculate Difference

The financial function CHG calculates the difference between the values in two 
rows or columns. When you use the Edit Formulas dialog box to paste this function 
into a column or row, the function appears in the formula bar edit box if you view 
data formulas. 

For example, this formula calculates the difference between values in columns 1 
and 3:

CHG(1,3)

Table 40: Logic or Formula Types Expanded by the @CHART Function

Logic or Formula Type Description

<Subaccount Total> Equivalent to Account @SUB.

SUB(#acc) All accounts between #acc and the current account.

SUM(#acc1, #acc2) Accounts from #acc1 until #acc2.

TOT All accounts between the first account and the 
current account within the group.

Applies To:
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 Function

The CHG function appears in this format:

CHG(First,Second)

@CHL - Children

The function @CHL retrieves the children of the specified member or current 
member. It is supported by all dimensions except the Field and View dimensions. 
You can use this function as a parameter of another function, when the required 
parameter is a list of members.

When you use the Edit Formulas dialog box to paste this function into a heading 
formula, the function appears in the formula bar edit box if you view heading 
formulas. 

For example, the following statement retrieves the children of the Market 
dimension in the current point of view:

Market @CHL 

The following statement retrieves the children of the Margin account:

Account @CHL(Margin)  

Note: @DEP and @CHL perform the same function in Hyperion Essbase.

Where... Is...

First The number of the first column or row in the calculation.

Second The number of the second column or row in the calculation.

Applies To:
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 Function

The @CHL function appears in these formats:

� Dimension @CHL 

which retrieves the children of the member in the current point of view for the 
dimension.

� Dimension @CHL(mbrName) 

which retrieves the children of the mbrName for the dimension.

@CMCODE - Consolidation Method Code

The text function @CMCODE produces a code, which you can define in Hyperion 
Enterprise, for grouping methods. When you use the Edit Formulas dialog box to 
paste this function into a heading formula, the function appears in the formula bar 
edit box if you view heading formulas. You can also use the Header and Footer 
dialog boxes to paste this function into headers and footers.

For example, you can create this formula for a footer:

Consolidation Method: @AMCODE

If the current consolidation method code is FR-ELIM, the formula produces this 
footer when you run the report:

Consolidation Method: FR-ELIM

Where... Is...

Dimension The dimension name.

mbrName A specified member.

Applies To:
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 Function

The @CMCODE function appears in this format:

[Before] @CMCODE [After]

@CMO - Current Category Period Number

You use the @CMO function to create a row or column for a period based on its 
relation to the current point-of-view period. You can select this function when you 
use the Edit menu or the Period formula bar button to assign or change a period 
using the function method. When you select this function, it appears in the formula 
bar edit box if you view data formulas.

For example, this formula creates a row for the period that is six periods prior to 
the current point-of-view period minus 1 year:

DAT @CMO-6 -1Y

This formula creates a row for the fifth period after the current point-of-view 
period:

DAT @CMO+5

If you specify the @CMO function with categories in which periods do not align, 
the @CMO function retrieves data for the corresponding period for the category 
in the report. For example, suppose the current period is May 1999, and May 1999 

Where... Is...

Before Any text that appears before the consolidation method 
code.

After Any text that appears after the consolidation method code.

Applies To:
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is the first period for the current category. If you then use the @CMO function with 
the Prior category and Prior’s first period is February 1997, @CMO retrieves 
February 1997 data.

You can use @CMO without an operator and number to define a row or column 
for the current period on the point-of-view bar. For example, this formula creates 
a row for the current period on the point-of-view bar:

DAT @CMO

 Function

The @CMO function appears in this format:

DAT @CMO{[Operator][Number]}{[Operator][Number] [Y]}

Where... Is...

Operator A minus sign ( - ) to identify a period and or year before 
the current point-of-view period and or year, or a plus 
sign ( + ) to identify a period and or year after the current 
point-of-view period and or year. 

Number A number of periods before or after the current 
point-of-view period. 

Number A number of years before or after the current 
point-of-view year.

Y An identifier to indicate the number refers to years + or -.
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@CON - Summary IDs

You use the @CON function with the ENT keyword to create columns or rows for 
parents below the current or specified entity or parent. You can select this function 
when you use the Edit menu or the Entity formula bar button to assign entities 
using the function method. When you select this function, it appears in the formula 
bar edit box if you view data formulas.

Note: The parent dimension is supported in Hyperion Enterprise.

This formula creates columns or rows for all consolidated entities below the 
current entity:

ENT @CON

This formula creates columns or rows for all consolidated entities below the 
Diamond Business Papers entity: 

ENT @CON(DIAMOND)

 Function

The @CON function appears in this format:

Keyword @CON [(ID)]

where Keyword is the keyword for a dimension.

Applies To:
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CPN - Current Period Number

The financial function CPN retrieves the current period number for use in a 
formula. The CPN function is useful for showing monthly averages for any month. 
When you use the Edit Formulas dialog box to paste this function into a column or 
row, the function appears in the formula bar edit box if you view data formulas.  

Note: You must supply headings for calculated rows and columns.

For example, this formula divides the year-to-date sales for the PLSALES account 
by the current period number to show a monthly average:

[ACC PLSALES]/CPN

 Function

The CPN function appears in this format:

CPN

This function retrieves the current period number. It does not use any parameters.

Applies To:
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@CUR - Current Dimension Setting

You use the @CUR function with any keyword or dimension to create a column 
or row for the current value for a specified dimension. You can select this function 
when you use the Edit menu or a formula bar button to assign dimensions using 
the function method. When you select this function, it appears in the formula bar 
edit box if you view heading formulas.

 Hyperion Enterprise Example

If the current category is Budget, this formula produces values for the Budget 
category in a column or row:

CAT @CUR

 Hyperion Essbase Example

If the current category is Actual, this formula produces values for the Actual 
category in a column or row in Hyperion Essbase:

CATEGORY @CUR

 Function 

The @CUR function appears in this format:

Keyword or Dimension @CUR

Applies To:

Where... Is...

Keyword The keyword for a dimension in Hyperion Enterprise. 

Dimension The name in Hyperion Essbase.
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When you use @CUR with the DAT keyword, you can specify an offset from the 
current period and or year using this format:

DAT @CUR{[Operator][Number]}{[Operator][Number][Y]}

If the point-of-view is set to July of 1994, the following formula retrieves March 
of 1993. It would go back 4 months then go back 1 year:
DAT @CUR -4 -1Y

Note: DAT @CUR retrieves data for periods based on their relation to the 
current value of the DAT keyword. You can use the @CMO function 
to retrieve data for periods based on their relation to the current 
point-of-view period.

@CURCY - Currency Text

The text function @CURCY produces the symbol, description, or ID for a 
currency. 

Where... Is...

Operator A plus sign ( + ) for an offset later than the current period and 
or year, or a minus sign ( - ) for an offset earlier than the 
current period and or year. This option is supported in 
Hyperion Enterprise only.

Number The number of periods for the offset. This option is 
supported in Hyperion Enterprise only.

Number The number of years for the offset. This option is supported 
in Hyperion Enterprise only.

Y An identifier to indicate the number refers to years + or -.

Applies To:
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The following table shows what currency the @CURCY function uses to produce 
the text.

When you use the Edit Formulas dialog box to paste this function into a heading 
formula, the function appears in the formula bar edit box if you view heading 
formulas. You can also use the Header and Footer dialog boxes to paste this 
function into headers and footers.

For example, you can create this formula for a report’s header:

Total Sales in @CURCY(SHORT)

If there is no point-of-view currency or point-of-view consolidation detail, and the 
current entity’s currency is U.S. dollars, this header appears when you run the 
report:

Total Sales in USD

 Function

The @CURCY function appears in this format:

[Before] @CURCY(Text) [After]

Table 41: @CURCY and Currencies

If... Then @CURCY uses...

The point-of-view currency is not NONE The point-of-view currency.

The point-of-view currency is NONE, and the 
point-of-view consolidation detail is not NONE

The currency of the 
point-of-view entity’s parent.

The point-of-view currency is NONE, and the 
point-of-view consolidation detail is NONE

The currency of the 
point-of-view entity.

Where... Is...

Before Any text that appears before the currency symbol, description, or 
ID.

Text SHORT to produce a currency ID, LONG to produce a currency 
description, or SYMBOL to produce a currency symbol.

After Any text that appears after the currency symbol, description, or 
ID.
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Date Masks 

The following table describes the codes you can use in date masks.

Note: In Hyperion Enterprise, you can select date masks for use with the 
@DAT and @TOD text functions.

A date mask uses codes to represent different ways of showing the period, month, 
day of the week, and year. You can select date masks for use with the @DAT and 
@TOD text functions.

Applies To:

Table 42: Codes in Date Masks

Code Examples Result

SHORT JAN, Q1 Abbreviated period IDs.

LONG January, First 
Quarter

Unabbreviated period IDs.

yy 96, 97 Abbreviated calendar years.

yyyy 1996, 1997 Unabbreviated calendar years.

m 1, 2, 10 One- or two-digit numbers for months.

mm 01, 02, 10 Two-digit calendar period numbers.

d 1, 2, 23 One- or two-digit numbers for days of the 
month.

dd 01, 02, 23 Two-digit numbers for days of the month.

ddd Tue, Fri Three-letter abbreviations for days of the week.

dddd Tuesday, Friday Unabbreviated days of the week.
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You can select date masks when you paste period IDs or descriptions into 
formulas, and you can customize the date masks in the formula bar edit box. You 
can combine the date mask codes and enclose them in parentheses to show dates 
in different ways. If you do not specify a date mask, the system uses the mask 
SHORTyy for abbreviated period IDs followed by the last two digits of the year.

The following table shows examples of mask combinations that you can use with 
the @DAT and @TOD functions.

@DAT - Period Description

The text function @DAT produces a custom description for the current period. 
When you use the Edit Formulas dialog box to paste this function into a heading 
formula, the function appears in the formula bar edit box if you view heading 
formulas. You can also use the Header and Footer dialog boxes to paste this 
function into headers and footers.

Table 43: Date Mask Combinations with @DAT and @TOD

This code... Results in...

SHORT yy JAN 97

yy 97

FULL yyyy JANUARY 1997

mm/yy 01/97

SHORT, yyyy JAN, 1997

Applies To:
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The following table shows several examples of formulas you can create with the 
@DAT function with the results it would produce for the December 1997 period.

 Function

The @DAT function appears in this format:

[Before] @DAT [(Mask)] [After]

Table 44: @DAT Formula Examples

This formula... Produces this result...

@DAT DEC 97

@DAT (SHORT) DEC

@DAT (SHORT yyyy) DEC 1997

@DAT (FULL yy) December 97

@DAT (FULL yyyy) December 1997

Where... Is...

Before Any text that appears before the period description.

Mask Any date mask.

After Any text that appears after the period description.
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@DEP - IDs Immediately Below

You use the @DEP function to create columns or rows for all dependents of the 
current or specified entity or parent. You can select this function when you use the 
Edit menu or the Entity formula bar button. When you select this function, it 
appears in the formula bar edit box if you view heading formulas.

Note: The parent dimension is supported in Hyperion Enterprise. 

 Hyperion Enterprise Example

This formula shows data for all immediate dependents of the current entity in 
Hyperion Enterprise:

ENT @DEP

 Hyperion Essbase Example

This formula shows data for all immediate dependents of the current entity in 
Hyperion Essbase:

ENTITY @DEP

Note: @DEP and @CHL perform the same function in Hyperion Essbase.

 Function

The @DEP function appears in these formats:

� Keyword or Dimension @DEP 

which retrieves the children of the member in the current point of view for the 
dimension.

Applies To:
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� Keyword or Dimension @DEP(ID) 

which retrieves the children of the ID for the dimension.

@DES - Dimension Descriptions

The text function @DES displays dimension descriptions. When you use the Edit 
Formulas dialog box to paste this function into a heading formula, the function 
appears in the formula bar edit box if you view heading formulas. You can also use 
the Header and Footer dialog boxes to paste this function into headers and footers.

By default, the system uses the @DES function for row headings and the @LAB 
function for column headings. You can specify dimensions with the @DES 
function in headings to produce descriptions for those dimensions only. If you do 
not specify dimensions, the headings show the descriptions for all dimensions 
assigned to the selected columns or rows. 

For example in Hyperion Enterprise, if you assign categories and periods to 
columns and use this formula for their headings, the headings show only the 
category descriptions:

@DES(CAT)

Where... Is...

Keyword or Dimension The keyword ENT in Hyperion Enterprise, or 
the dimension name in Hyperion Essbase.

ID An ID that overrides the current setting for the 
specified dimension. If you do not specify an ID, 
the @DEP function assigns all IDs immediately 
below the current ID for the dimension.

Applies To:
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For example in Hyperion Essbase, if you assign categories and periods to columns 
and use this formula for their headings, the headings show only the category 
descriptions:

@DES(CATEGORY)

 Function

The @DES function appears in this format:

[Before] @DES[(Keyword or Dimension)][After]

@DSC - Descendant Members

The function @DSC retrieves the descendants of the specified member or current 
member. It is supported for all dimensions except the Field dimension. You can 
also use this function as a parameter of another function, where that parameter is 
a list of members.

Where... Is...

Before Any text that appears before the dimension 
description.

Keyword or Dimension The keyword for a dimension in Hyperion 
Enterprise, or
the dimension name in Hyperion Essbase.

After Any text that appears after the dimension 
description.

Applies To:



260 �

Functions

Hyperion Enterprise Reporting Windows Client User’s Guide

When you use the Edit Formulas dialog box to paste this function into a heading 
formula, the function appears in the formula bar edit box if you view heading 
formulas. 

For example, the statement:

Market @DSC(“East”)

retrieves the descendants for East member of the Market dimension: 

New York, Albany, New York City, Buffalo, Syracuse, 
Massachusetts, Boston, Springfield, Worcester, Brockton

and the statement:

Market @DSC

retrieves the descendants for the Market dimension member set in the point of 
view:

New York, Albany, New York City, Buffalo, Syracuse, 
Massachusetts, Boston, Springfield, Worcester, Brockton, 
California, Oregon, Washington, Utah, Nevada, Texas, Oklahoma, 
Louisiana, New Mexico, Illinois, Ohio, Wisconsin, Missouri, Iowa, 
Colorado

 Function

The function @DSC appears in the following formats:

� Dimension @DSC

which retrieves the descendants for the member in the current 
point of view for the dimension.

� Dimension @DSC(mbrName)

which retrieves the descendants of the mbrName for the 
dimension.

Where... Is...

Dimension A dimension name.

mbrName A single member specification.
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DUR - Specific Value 

The financial function DUR shows a specified value or expression in a range of 
columns or rows. In a column formula, it shows the value for a range of rows. In 
a row formula, it shows the value for a range of columns. When you use the Edit 
Formulas dialog box to paste this function into a column or row, the function 
appears in the formula bar edit box if you view data formulas. 

Note: You must supply headings for calculated rows and columns.

You can include account IDs as well as math symbols in the expressions that 
follow the DUR function. You can include more than one DUR function in a 
formula by separating them with a plus sign ( + ). You can use the DUR function 
with the CELL function to perform calculations on values in the report.

This row formula shows the value 378 for columns 6 through 12: 

DUR(6,12,378)

This row formula shows a value in columns 6 through 12 that is three times the 
current value of the Sales account:

DUR(6,12,[ACC SALES]*3)

This formula creates a row where the value 296 appears in the first and second 
columns and a value equal to half the value of the Sales value appears in columns 
3 through 10: 

DUR(1,2,296) + DUR(3,10,[ACC SALES]/2)

This formula on a row creates a value for the first column in that row that 
calculates the number in column 3, row 2 divided by the number in column 5, row 
6:

DUR(1,1,CELL(3,2)/CELL(5,6))

Applies To:
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 Function

The DUR function appears in this format:

DUR(First,Last,Value)

@ECODE - Entity Code

The text function @ECODE produces a code, which you can define in Hyperion 
Enterprise, for grouping entities. When you use the Edit Formulas dialog box to 
paste this function into a heading formula, the function appears in the formula bar 
edit box if you view heading formulas. You can also use the Header and Footer 
dialog boxes to paste this function into headers and footers.

For example, you can create this formula for a footer:

Entity Group: @ECODE

If the current entity code is FRS, the formula produces this footer when you run 
the report:

Entity Group: FRS

Where... Is...

First The number of the first row or column in the range. 

Last The number of the last row or column in the range. 

Value The value or expression you want to show. 

Applies To:
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 Function

The @ECODE function appears in this format:

[Before] @ECODE [After]

@END - Last ID

You use the @END function to create a row or column for the current entity’s 
ending period or a period offset from the ending period, or for a dimension’s last 
ID. You can select this function when you use the Edit menu or the Period formula 
bar button to assign dimensions using the function method. When you select this 
function, it appears in the formula bar edit box if you view data formulas.

This formula retrieves data for the last category:

CAT @END

This formula retrieves data for the current entity’s ending period:

DAT @END

If the current entity’s ending period is December 1999, this formula retrieves 
December 1998 data:

DAT @END-12

Where... Is...

Before Any text that appears before the entity code.

After Any text that appears after the entity code.

Applies To:
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 Function

The @END function appears in this format:

Keyword @END[Operator][Number]

@ENT - Entity as Parent

You use the @ENT function with the PAR keyword to create a column or row that 
uses the current entity as the parent. For example, if Diamond Business Papers is 
the current entity, you can use the @ENT function to create a column or row with 
Diamond Business Papers as the parent. You can select this function when you use 
the Edit menu or the Parent formula bar button to assign parents using the function 
method. When you select this function, it appears in the formula bar edit box if you 
view heading formulas.

For example, if the current entity is Europe, this formula creates a column or row 
with Europe as the parent:

PAR @ENT

Where... Is...

Keyword The keyword for a dimension.

Operator If the dimension is a period, a minus sign ( - ) for an 
offset earlier than the ending period. This option is 
supported in Hyperion Enterprise only.

Number If the dimension is a period that you want to offset, the 
number of periods for the offset. This option is supported 
in Hyperion Enterprise only.

Applies To:
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 Function

The @ENT function appears in this format:

PAR @ENT

@FIRST - First Subaccount

The @FIRST function specifies the first subaccount in the subaccount table 
assigned to the current or specified account. You can select this function when you 
use the Edit menu or the Account formula bar button to assign accounts using the 
range method. When you select this function, it appears in the formula bar edit box 
if you view data formulas.

Note: When a report is compiled, any account or subaccount specified with 
the @FIRST function is hard-coded. If the subaccount table changes, 
you need to recompile the report.

For example, this formula creates columns or rows for all subaccounts in the 
subaccount table assigned to the current point-of-view account:

ACC @FIRST UNTIL @LAST

 Function

The @FIRST function appears in this format:

ACC FROM @FIRST[(Account1)] UNTIL Last [(Accountn)]

Applies To:

Where... Is...

Account1 The major account for the first subaccount in the range.
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@FLN - File Name

The text function @FLN produces the active report’s file name. The @FLN 
function is useful for identifying report files in headers and footers.

When you use the Edit Formulas dialog box to paste this function into a heading 
formula, the function appears in the formula bar edit box if you view heading 
formulas. You can also use the Header and Footer dialog boxes to paste this 
function into headers and footers.

Note: The file name appears in the output only if you save the report. 

The @FLN function is useful for identifying report files in headers and footers. 
For example, you can create this formula for a footer:

Report File: @FLN

If the active report’s file name is REGPL, the formula produces this footer when 
you run the report:

Report File: REGPL

Last The ID for the last subaccount in the range.

Accountn The major account for the last subaccount in the range.

Applies To:

Where... Is...
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 Function

The @FLN function appears in this format:

[Before] @FLN [After]

@FLT - File Title

The text function @FLT produces the active report’s title. When you use the Edit 
Formulas dialog box to paste this function into a heading formula, the function 
appears in the formula bar edit box if you view heading formulas. You can also use 
the Header and Footer dialog boxes to paste this function into headers and footers. 

Note: The title appears in the output only if you have saved the report. 

The @FLT function is useful for identifying reports in headers and footers. For 
example, you can create this formula for a footer:

Report File: @FLT

If the active report’s file title is Western Region: Third Quarter, the formula 
produces this footer when you run the report:

Report File: Western Region: Third Quarter

Where... Is...

Before Any text that appears before the active report’s 
file name.

After Any text that appears after the active report’s 
file name.

Applies To:
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 Function

The @FLT function appears in this format:

[Before] @FLT [After]

FOR - Section For

The FOR function marks the beginning of a section in a report or book. It is 
followed by a keyword or dimension. When you use the Edit menu to insert a 
report or book section, the FOR function appears in the formula bar edit box if you 
view data formulas.

For example, this formula creates a section of columns or rows for the Diamond 
Business Papers, Evergreen Paper Company, and Juniper Paper Company entities:

FOR ENT DIAMOND, EVERGREEN, JUNIPER 

For example, this formula creates a section of columns or rows for the Diamond 
Business Papers, Evergreen Paper Company, and Juniper Paper Company entities:

FOR ENTITY DIAMOND, EVERGREEN, JUNIPER 

Where... Is...

Before Any text that appears before the 
active report’s title.

After
Any text that appears after the 
active report’s title.

Applies To:
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 Function

The FOR function appears in this format:

FOR Keyword or Dimension ID1,[...,] IDn

@FRD - Frequency Description

The text function @FRD produces the description for the current frequency. When 
you use the Edit Formulas dialog box to paste this function into a heading formula, 
the function appears in the formula bar edit box if you view heading formulas. You 
can also use the Header and Footer dialog boxes to paste this function into headers 
and footers.

For example, you can create this formula for a column heading:

@FRD Average

If the current frequency is Monthly, the formula produces this column heading 
when you run the report:

Monthly Average

Where... Is...

Keyword or Dimension The keyword for a dimension in Hyperion 
Enterprise, or the dimension name in Hyperion 
Essbase.

ID1 The first dimension ID for the section.

IDn The last dimension ID for the section.

Applies To:
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 Function

The @FRD function appears in this format:

[Before] @FRD [After]

@FRL - Frequency ID

The text function @FRL produces the ID for the current frequency. When you use 
the Edit Formulas dialog box to paste this function into a heading formula, the 
function appears in the formula bar edit box if you view heading formulas. You 
can also use the Header and Footer dialog boxes to paste this function into headers 
and footers.

For example, you can create this formula for a column heading:

@FRL Average

If the current frequency ID is Q, the formula produces this column heading when 
you run the report:

Q Average

Where... Is...

Before Any text that appears before the current frequency 
description.

After Any text that appears after the current frequency 
description.

Applies To:
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 Function

The @FRL function appears in this format:

[Before] @FRL [After]

FROM - Start of Range

The FROM function marks the start of a range of dimension IDs. 

Note: The @RNG function replaces the FROM and UNTIL functions, 
however the FROM and UNTIL functions are supported from the 
formula bar. For more information on the @RNG function, see 
@RNG - Range on page 307.

This formula creates consecutive columns or rows for the periods beginning with 
January 1988 and ending with June 1998:

DAT FROM JAN98 UNTIL JUN98 

This formula creates consecutive columns or rows for the periods beginning with 
January 1988 and ending with June 1998:

DATES FROM JAN98 UNTIL JUN98 

Where... Is...

Before Any text that appears before the current frequency ID.

After Any text that appears after the current frequency ID.

Applies To:
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 Function

The FROM function appears in this format:

Keyword or Dimension FROM First UNTIL Last

@GEN - Same Generation

The function @GEN retrieves all members in the generation of the specified 
member or current member. @GEN is supported for all dimensions except the 
Field and View dimensions. When you use the Edit Formulas dialog box to paste 
this function into a heading formula, the function appears in the formula bar edit 
box if you view heading formulas. 

For example, in the following statement:

@GEN(QTR3)

the formula would retrieve the following:

Qtr1

Qtr2

Qtr3

Qtr4

Where... Is...

Keyword or Dimension The keyword ACC or DAT in Hyperion Enterprise 
or
the dimension name in Hyperion Essbase.

First The ID for the first account or period in the range.

Last The ID for the last account or period in the range.

Applies To:
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 Function

The @GEN function appears in these formats:

� Dimension @GEN 

which retrieves the children of the member in the current point of view for the 
dimension.

� Dimension @GEN(mbrName) 

which retrieves the children of the mbrName for the dimension.

IFT - If Then 

The financial function IFT shows a specific value or text in the data section of a 
report, depending on whether the result of an expression is negative, zero, or 
positive. When you use the Edit Formulas dialog box to paste this function into a 
column or row, the function appears in the formula bar edit box if you view data 
formulas. 

Note: You must create a heading formula if you want to label the resulting 
row or column.

For example, this formula shows the word Loss of Sales minus Cost of Sales 
results in a negative number, the number 0 if the difference is zero, and the word 
Profit if the difference is positive:

IFT(SALES-COS),"Loss",0,"Profit"

Where... Is...

Dimension The dimension name.

mbrName A specified member.

Applies To:
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You can also use IFT with the CELL function to refer to a specific cell. For 
example, this formula shows the value of column 3, row 2 if that value is a negative 
number or zero, and it shows a zero if the value is positive:

IFT(CELL(3,2),CELL(3,2),CELL(3,2),0)

 Function

The IFT function appears in this format:

IFT(Test,Negative,Zero,Positive)

Note: If you use the IFT function to show text for a result, you must enclose 
the text in quotation marks ( " " ). The quotation marks do not appear 
in the report output.

@IND - Indent

The text function @IND indents the text based on the generation number. It is 
supported for all dimensions except the Field and View dimensions. When you use 
the Edit Formulas dialog box to paste this function into a heading formula, the 

Where... Is...

Test The expression that produces the result to be evaluated.

Negative The value or text that appears if the Test expression result 
is negative.

Zero The value or text that appears if the Test expression result 
is zero.

Positive The value or text that appears if the Test expression result 
is positive.

Applies To:
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function appears in the formula bar edit box if you view heading formulas. You 
can also use the Header and Footer dialog boxes to paste this function into headers 
and footers.

 Function

The text function @IND appears in this format:

@IND(Dimension[,Num Spaces[,Gen Offset]])

@LAB - Dimension IDs

The text function @LAB displays dimension IDs. When you use the Edit 
Formulas dialog box to paste this function into a heading formula, the function 
appears in the formula bar edit box if you view heading formulas. You can also use 
the Header and Footer dialog boxes to paste this function into headers and footers.

By default, the system uses the @LAB function for column headings and the 
@DES function for row headings. You can specify dimensions with the @LAB 
function to produce IDs for those dimensions only. If you do not specify 
dimensions, the headings show the IDs for all dimensions assigned to the selected 
columns or rows. 

Where... Is...

Dimension The dimension name. (Required).

Num Spaces The number of indented spaces. (Defaults to 1 for 
columns, 5 for rows).

Gen Offset Amount of space the text is offset from the generation 
number. (Defaults to 0).

Applies To:
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For example, in Hyperion Enterprise, if you assign categories and periods to 
columns and use this formula for their headings, the headings show only the 
category IDs:

@LAB(CAT)

For example, in Hyperion Essbase, if you assign categories and periods to columns 
and use this formula for their headings, the headings show only the category IDs:

@LAB(CATEGORY)

 Function

The @LAB function appears in this format:

[Before] @LAB[(Keyword or Dimension)][After]

@LAD - Lowest-level Account Description

The text function @LAD produces the lowest-level description for the current 
account. If the account has first- and second-level subaccounts, the @LAD 
function produces the description for the second-level subaccount. If the account 
has only a first-level subaccount, @LAD produces the description for that 
subaccount. If the account has no subaccounts, @LAD produces the description 
for the account. 

Where... Is...

Before Any text that appears before the dimension IDs.

Keyword or Dimension Keywords for a dimension in Hyperion Enterprise, 
or dimension names in Hyperion Essbase.

After Any text that appears after the dimension IDs.

Applies To:
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When you use the Edit Formulas dialog box to paste this function in a heading 
formula, the function appears in the formula bar edit box if you view heading 
formulas. You can also use the Header and Footer dialog boxes to paste this 
function into headers and footers.

For example, you might create this formula for row headings:

@LAD

In a row for the account SALES.PAPER.NE, the formula produces this heading if 
the description for the NE subaccount is Northeast:

Northeast

 Function

The @LAD function appears in this format:

[Before] @LAD[After]

@LAL - Lowest-level Account ID

The text function @LAL produces the lowest-level ID for the current account. If 
the account has first- and second-level subaccounts, the @LAL function produces 
the ID for the second-level subaccount. If the account has only a first-level 
subaccount, @LAL produces the ID for that subaccount. If the account has no 
subaccounts, @LAL produces the ID for the account. 

Where... Is...

Before Any text that appears before the account’s lowest-level 
description.

After Any text that appears after the account’s lowest-level 
description.

Applies To:
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When you use the Edit Formulas dialog box to paste this function into a heading 
formula, the function appears in the formula bar edit box if you view heading 
formulas. You can also use the Header and Footer dialog boxes to paste this 
function into headers and footers. 

For example, you might create this formula for row headings:

@LAL

In a row for the account SALES.PAPER.NE, the formula produces this heading:

NE

 Function

The @LAL function appears in this format:

[Before] @LAL[After]

@LAST - Last Subaccount 

The @LAST function specifies the last subaccount in the subaccount table 
assigned to the current or specified account. You can select this function when you 
use the Edit menu or the Account formula bar button to assign accounts using the 
function or range method. When you select this function, it appears in the formula 
bar edit box if you view data formulas.

Note: When a report is compiled, any account or subaccount specified with 
the @LAST function is hard-coded. If the subaccount table changes, 
you need to recompile the report.

Where... Is...

Before Any text that appears before the account’s lowest-level ID.

After Any text that appears after the account’s lowest-level ID.

Applies To:
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For example, this formula creates a column or row for the last subaccount in the 
subaccount table assigned to the Sales account:

ACC SALES @LAST

This formula creates columns or rows for all subaccounts in the subaccount table 
assigned to the current point-of-view account:

ACC @FIRST UNTIL @LAST

 Function

The @LAST function appears in this format when you use it to assign accounts 
using the function method: 

ACC @LAST[(Account)]

where Account is a major account or first-level subaccount ID. If you do not 
specify an account, the system uses the current point-of-view account.

When you select the @LAST function using the range method, it appears in this 
format:

ACC FROM First[(Account1)] UNTIL @LAST[(Account2)]

Where... Is...

First The @FIRST function or the ID for the first subaccount in 
the range.

Account1 The ID for the first major account or first-level 
subaccount in the range. If you do not specify an account, 
the system uses the current point-of-view account.

Account2 The first major account or first-level subaccount in the 
range. If you do not specify an account, the system uses 
the current point-of-view account.
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LIST - List 

You use the LIST function to define columns or rows for accounts in an account 
list or the entities in an entity list. The system includes one column or row for each 
account or subaccount in the specified account list or for each entity in the 
specified entity list. When you use the Edit menu or a formula bar button to assign 
accounts or entities using the list method, the LIST function appears in the formula 
bar edit box if you view data formulas.

You can select the @ASK function for use with the LIST function to prompt users 
to select account lists or entity lists when they run reports. 

Note: The LIST function applies to all Hyperion Essbase dimensions except 
View and Field.

 Hyperion Enterprise Example

For example, this formula creates a column for each account in an account list 
called USLIST: 

ACC LIST USLIST

 Hyperion Essbase Example

For example, this formula creates a column for each account in an account list 
called Gen2, Account: 

ACCOUNT LIST “Gen2, Account”

Applies To:
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 Function

The LIST function appears in this format in the formula bar edit box: 

Keyword or Dimension LIST List

@LOCAL - Local Headings 

You use the text function @LOCAL to assign a local heading to a column or row 
of a report. When you use the Edit menu to assign a local heading, the @LOCAL 
function appears in the formula bar edit box if you view heading formulas.

 Function

The @LOCAL function appears in this format:

@LOCAL(Field,Default)

Where... Is...

Keyword or Dimension The keyword ACC for an account list or ENT for 
an entity list in Hyperion Enterprise or the 
dimension name in Hyperion Essbase.

List The name of an account list or an entity list.

Applies To:

Where... Is...

Field The ID for a field defined in Hyperion DataExtend.

Default The text that appears if no local heading is assigned.
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@LRC - Linked Reporting Comments

The function @LRC retrieves linked reporting comments. You can specify 
particular linked comments by choosing one or more criteria, including the 
number of linked comments, the user, and the date.

When you use the Edit Formulas dialog box to paste this function into a heading 
formula, the function appears in the formula bar edit box if you view heading 
formulas. You can also use the Header and Footer dialog boxes to paste this 
function into headers and footers.

Note: The @LRC function is supported for the Field dimension only.

➤ To display link reporting comments within a report:

1. Select the Field dimension.

2. Select the Function panel.

3. Click @LRC in the functions list.

4. Do one or more of the following:

� To specify the number of linked comments to be included, type a number 
in the Limit field. For example, if you type 5, @LRC will retrieve the first 
five linked comments. The default is 1.

� To specify comments created by a certain user, type a user name in the By 
User field. The default is all users.

� To specify the end creation date of the comments to be included, type a 
date in the To date field in the format MM/DD/YYYY. The default is any 
date.

Applies To:
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5. Click OK.

Note: For more information on linked reporting object functions, see @LRF 
- Linked Reporting Files on page 284 and @LRO - Linked Reporting 
Objects on page 287.

For more information on how to retrieve information about currently 
linked reporting objects, see @LRD - Modification Date of a Linked 
Reporting Object on page 283, @LRI - Index of a Linked Reporting 
Object on page 286, @LRT - Type of a Linked Reporting Object on 
page 289, and @LRU - User of a Linked Reporting Object on 
page 290.

 Function

The @LRC function appears in this format in the formula bar edit box: 

@LRC (Limit, User, Date)

@LRD - Modification Date of a Linked 
Reporting Object

The function @LRD retrieves the modification date of the currently linked 
reporting object. 

Where... Is...

Limit The number of objects to display.

User The user name or blank for all users. The specified user’s 
objects are displayed.

Date The date or blank for all dates.

Applies To:
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When you use the Edit Formulas dialog box to paste this function into a heading 
formula, the function appears in the formula bar edit box if you view heading 
formulas. You can also use the Header and Footer dialog boxes to paste this 
function into headers and footers.

Note: The @LRD function is supported for the Field dimension only.

For more information on linked reporting object functions, see @LRC - Linked 
Reporting Comments on page 282, @LRF - Linked Reporting Files on page 284, 
and @LRO - Linked Reporting Objects on page 287.

For more information on how to retrieve information about currently linked 
reporting objects, see @LRI - Index of a Linked Reporting Object on page 286, 
@LRT - Type of a Linked Reporting Object on page 289, and @LRU - User of a 
Linked Reporting Object on page 290.

 Function

The @LRD function appears in this format:

@LRD

@LRF - Linked Reporting Files

The function @LRF retrieves linked reporting objects that are files. You can 
specify particular linked files by choosing one or more criteria, including the 
number of linked files, the user, and the date.

Applies To:
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When you use the Edit Formulas dialog box to paste this function into a heading 
formula, the function appears in the formula bar edit box if you view heading 
formulas. You can also use the Header and Footer dialog boxes to paste this 
function into headers and footers.

Note: The @LRF function is supported for the Field dimension only.

➤ To display link reporting files within a report:

1. Select the Field dimension.

2. Select the Function panel.

3. Click @LRF in the functions list and add it to the list below.

4. Do one or more of the following:

� To specify the number of linked files to be included, type a number in 
the Limit field. For example, if you type 5, @LRF will retrieve the 
first five linked files. The default
is 1.

� To specify objects created by a certain user, type a user name in the 
By User field. The default is all users.

� To specify the end creation date of the objects to be included, type a 
date in the To date field in the format MM/DD/YYYY. The default is 
any date.

5. Click OK.

Note: For more information on linked reporting object functions, see 
@LRC - Linked Reporting Comments on page 282, and @LRO - 
Linked Reporting Objects on page 287.

For more information on how to retrieve information about currently 
linked reporting objects, see @LRD - Modification Date of a Linked 
Reporting Object on page 283, @LRI - Index of a Linked Reporting 
Object on page 286, @LRT - Type of a Linked Reporting Object on 
page 289, and @LRU - User of a Linked Reporting Object on 
page 290.
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 Function

The @LRF function appears in this format in the formula bar edit box: 

@LRF (Limit, User, Date)

@LRI - Index of a Linked Reporting Object

The function @LRI retrieves the index of a currently linked reporting object. 

When you use the Edit Formulas dialog box to paste this function into a heading 
formula, the function appears in the formula bar edit box if you view heading 
formulas. You can also use the Header and Footer dialog boxes to paste this 
function into headers and footers.

Note: The @LRI function is supported for the Field dimension only. 

For more information on linked reporting object functions, see @LRC - Linked 
Reporting Comments on page 282, @LRF - Linked Reporting Files on page 284, 
and @LRO - Linked Reporting Objects on page 287.

For more information on how to retrieve information about currently linked 

Where... Is...

Limit The number of objects to display.

User The user name or blank for all users. The specified user’s 
objects are displayed.

Date The date or blank for all dates.

Applies To:
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reporting objects, see @LRD - Modification Date of a Linked Reporting Object on 
page 283, @LRT - Type of a Linked Reporting Object on page 289, and @LRU - 
User of a Linked Reporting Object on page 290.

 Function

The @LRI function appears in this format:

@LRI

@LRO - Linked Reporting Objects

The function @LRO retrieves linked reporting objects, including files and 
comments. You can specify particular objects by choosing one or more criteria, 
including the number of objects, the user, and the date.

When you use the Edit Formulas dialog box to paste this function into a heading 
formula, the function appears in the formula bar edit box if you view heading 
formulas. You can also use the Header and Footer dialog boxes to paste this 
function into headers and footers.

Note: The @LRO function is supported for the Field dimension only.

➤ To link reporting objects with the @LRO function:

1. Select the Field dimension.

2. Select the Function panel.

3. Click @LRO in the functions list and add it to the list below.

4. Do one or more of the following:

� To specify the number of linked objects, type a number in the Limit field. 
For example, if you type 5, @LRF will retrieve the first five linked 
objects. The default is 1.

Applies To:
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� To specify objects created by a certain user, type a user name in the By 
User field. The default is all users.

� To specify the end creation date of the objects to be included, type a date 
in the To date field in the format MM/DD/YYYY. The default is any date.

Note: If you leave a field blank, the system shows everything as the 
default.

5. Click OK.

Note: For more information on linked reporting object functions, see 
@LRC - Linked Reporting Comments on page 282, and @LRF - 
Linked Reporting Files on page 284.

For more information on how to retrieve information about currently 
linked reporting objects, see @LRD - Modification Date of a Linked 
Reporting Object on page 283, @LRI - Index of a Linked Reporting 
Object on page 286, @LRT - Type of a Linked Reporting Object on 
page 289, and @LRU - User of a Linked Reporting Object on 
page 290.

 Function

The @LRO function appears in this format in the formula bar edit box: 

@LRO (Limit, User, Date)

Where... Is...

Limit The number of objects to display.

User The user name or blank for all users. The specified user’s 
objects are displayed.

Date The date or blank for all dates.
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@LRT - Type of a Linked Reporting Object

The function @LRT retrieves the type of a currently linked reporting object. The 
reporting object types are cell notes, files, URLs and drill-throughs.

When you use the Edit Formulas dialog box to paste this function into a heading 
formula, the function appears in the formula bar edit box if you view heading 
formulas. You can also use the Header and Footer dialog boxes to paste this 
function into headers and footers.

Note: The @LRT function is supported for the Field dimension only.

For more information on linked reporting object functions, see @LRC - Linked 
Reporting Comments on page 282, @LRF - Linked Reporting Files on page 284, 
and @LRO - Linked Reporting Objects on page 287.

For more information on how to retrieve information about currently linked 
reporting objects, see @LRD - Modification Date of a Linked Reporting Object on 
page 283, @LRI - Index of a Linked Reporting Object on page 286, and @LRU - 
User of a Linked Reporting Object on page 290.

 Function

The @LRT function appears in this format:

@LRT

Applies To:
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@LRU - User of a Linked Reporting Object

The function @LRU retrieves the user of a currently linked reporting object. 

When you use the Edit Formulas dialog box to paste this function into a heading 
formula, the function appears in the formula bar edit box if you view heading 
formulas. You can also use the Header and Footer dialog boxes to paste this 
function into headers and footers.

Note: The @LRU function is supported for the Field dimension only.

For more information on linked reporting object functions, see @LRC - Linked 
Reporting Comments on page 282, @LRF - Linked Reporting Files on page 284, 
and @LRO - Linked Reporting Objects on page 287.

For more information on how to retrieve information about currently linked 
reporting objects, see @LRD - Modification Date of a Linked Reporting Object on 
page 283, @LRI - Index of a Linked Reporting Object on page 286, and @LRT - 
Type of a Linked Reporting Object on page 289.

 Function

The @LRU function appears in this format:

@LRU 

Applies To:
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@LVL - Same Level

The function @LVL retrieves all members at the same level as the specified 
member or current member. It is supported for all dimensions except the Field 
dimension. When you use the Edit Formulas dialog box to paste this function into 
a heading formula, the function appears in the formula bar edit box if you view 
heading formulas. 

For example, in the following statement:

@LVL(QTR3)

the formula would retrieve the following:

Qtr1

Qtr2

Qtr3

Qtr4

 Function

The @LVL function appears in these formats:

� Dimension @LVL 

which retrieves the children of the member in the current point of view for the 
dimension.

� Dimension @LVL(mbrName) 

Applies To:
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which retrieves the children of the mbrName for the dimension.

MUL - Multiply 

The financial function MUL multiplies the values of two columns or rows. When 
you use the Edit Formulas dialog box to paste this function into a column or row, 
the function appears in the formula bar edit box if you view data formulas. 

For example, this formula creates a column that shows the products of the values 
in columns 1 and 5:

MUL(1,5)

 Function

The MUL function appears in this format:

MUL(First,Second)

Where... Is...

Dimension The dimension name.

mbrName A specified member.

Applies To:

Where... Is...

First The number of the first row or column to be multiplied.

Second The number of the second row or column to be 
multiplied.
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@OFF - Offset of the Current or Optional 
Period 

You use the @OFF function with the period dimension to create a column or row 
for the offset of the current or specified period. You can select this function from 
the Edit menu or a formula bar button. When you click @OFF, it displays in the 
formula bar edit box if you view data formulas.

Hyperion Essbase Example

If the current period is Mar95, this formula produces a value two periods prior to 
March 95, which would result in January 95.

YEAR @OFF(MAR95,-2)

If the current period is Jun95, this formula produces a value two periods prior to 
the period set in the point of view, which would result in April 95.

YEAR @OFF(@CUR,-2)

You could also enter the previous example as:

YEAR @OFF(,-2)

Note: If the first parameter is empty, the system defaults to the period in the 
point of view.

Parameters

The last parameter is used as a mapping parameter. It specifies whether quarters or 
months are mapped.

For example:

YEAR @OFF(“May95”,-2)

This would result in Qtr2, referring back to the tree view of the year dimension.

Applies To:
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YEAR @OFF(“May95”,-2,LIST ”Monthly”)

This would result in March 95, referring back to the tree view of the year 
dimension. 

Functions

The @OFF function displays this format:

Dimension @OFF (Dimension Name, Offset, List)

@OFF with @RNG
The following example uses the @OFF function with the @RNG function.

YEAR @RNG(@OFF(@CUR,2,

LIST "Monthly"),"May96",
LIST "Monthly")

The starting ID is the data from the @OFF function within @RNG. If the current 
period is JAN96, the starting ID would result in MAR96. The range would be 
MAR96 to MAY96.

Other examples of @OFF with @RNG include:

From current period+N to end of year. List months only: 

YEAR @RNG(@OFF(@CUR,1),"DEC99",LIST"Monthly")

From current period-N to current period:

YEAR @RNG(@OFF(@CUR,-1),@CUR,LIST"Monthly")

Where... Is...

Dimension Name An optional member name.

Offset A minus sign ( - ) to identify a period before the current 
point of view period, or a plus sign ( + ) to identify a 
period after the current point of view period.
Note: The plus sign ( + ) is optional.

List A generation, level, or user-defined attribute (UDA) of 
periods.
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From current period to current period+N:

YEAR @RNG(@CUR, @OFF(@CUR,1,LIST"Monthly"),LIST "Monthly")

@PAR - Parent 

You use the @PAR function with the ENT or PAR keyword to create a column or 
row for the parent above the current or specified entity or parent. You can click the 
@PAR function when you use the Edit menu or a formula bar button to assign or 
change an entity or parent using the function method. When you click the @PAR 
function, it appears in the formula bar edit box if you view data formulas.

For example, this formula shows data for the parent above the current entity:

ENT @PAR

When the Parent dimension is set to retrieve Hyperion Enterprise data such as 
consolidated detail, ownership, or share data, you can set the parent dynamically 
based on the current entity. For example, this formula can be used as a row of a 
report to list the entities that are dependents to the entity in the point of view. Each 
entity’s parent is used to retrieve data instead of the current parent set in the point 
of view.

ENT @DEP PAR @PAR(@ENT)

You can control the results of the dynamic functions used with the parent 
dimension based on the current Hyperion Enterprise organization. You do this by 
setting UseEnterpriseOrg in the OPTIONS section of your REPENG.INI file. If 
you set UseEnterpriseOrg = 1, only the parents in the currently specified 
organization are returned. If you set UseEnterpriseOrg = 0, or UseEnterpriseOrg 
is not in your REPENG.INI file, all parents are returned regardless of the currently 
specified organization.

Note: The UseEnterpriseOrg setting does not alter the entities listed in the 
Reporting dialog boxes based on the current organization. It also does 
not prevent you from reporting on an entity that does not belong to the 
current organization.

Applies To:
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 Function

The @PAR function appears in these formats:

� Keyword @PAR 

which retrieves the children of the member in the current point of view for the 
dimension.

� Keyword @PAR(ID) 

which retrieves the children of the ID for the dimension.

PBE - Evaluate Percent Change 

The financial function PBE calculates the percent change between the values in 
two columns or rows and determines whether the change represents a better or 
worse variance. When you use the Edit Formulas dialog box to paste this function 
into a column or row, the function appears in the formula bar edit box if you view 
data formulas. 

The system evaluates percent changes based on account type. For an Income or 
Asset account, a positive result represents an increase, so the result appears as a 
positive number. For an Expense or Liability account, a positive result represents 
a decrease, so the result appears as a negative number.

Where... Is...

Keyword The keyword ENT or PAR.

ID An ID that overrides the current setting for the specified 
dimension. 

Applies To:
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The system uses this formula to calculate the PBE values:

For example, this formula calculates and evaluates the percent change between the 
values in rows 1 and 5:

PBE(1,5)

 Function

The PBE function appears in this format:

PBE(First,Second)

PCH - Percent Change 

The financial function PCH calculates the percent change between two rows or 
columns without evaluating the difference. When you use the Edit Formulas 
dialog box to paste this function into a column or row, the function appears in the 
formula bar edit box if you view data formulas. 

The system uses this formula to calculate the PCH values:

 

Where... Is...

First The number of the first column or row in the calculation.

Second The number of the second column or row in the calculation.

Applies To:

First Second–
Second

-------------------------------------- 100×

First Second–
Second

-------------------------------------- 100×
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For example, this formula calculates the percent change between the values in 
rows 1 and 5:

PCH(1,5)

 Function

The PCH function appears in this format:

PCH(First,Second)

PCR - Percent by Row 

In a column formula, the PCR financial function shows percentages of the values 
in a specified row. In a row formula, it shows percentages of the values in a 
specified column. You can use multiple ending points for calculations with the 
PCR function. For example, you can use it to set up a column that shows 
percentages from different rows within another column. When you use the Edit 
Formulas dialog box to paste this function into a column or row, the function 
appears in the formula bar edit box. 

In the following report, column 1 displays gross sales in rows 1-3 and the total 
gross sales in row 4. The function PCR (1,4) in column 2 displays the percentage 
that each gross sale contributes to the total gross sale. It uses values from column 

Where... Is...

First The number of the first column or row in the calculation.

Second The number of the second column or row in the calculation.

Applies To:
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1, and calculates percentages for rows 1-4. For example, Belgium contributes 25 
percent, Holland contributes 32 percent, and Sweden contributes 48 percent to the 
total gross sales. 

Figure 33: Gross Sales Report

In the following report, column 1 displays gross sales for Q4 in rows 1-3, total 
gross sales for Q4 in row4, gross sales for Q3 in rows 5-7, and total gross sales for 
Q3 in row 8. The function PCR(1,4,8) in column 2 displays the percentage that 
each gross sales contributes to the total gross sales. It uses values from column 1, 
and calculates percentages for rows 1-4 and 5-8. For example, in Q4, Belgium 
contributes 25 percent, Holland contributes 32 percent, and Sweden contributes 43 
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percent to the total gross sales for Q4. In Q3, Belgium contributes 23 percent, 
Holland contributes 26 percent, and Sweden contributes 50 percent to the total 
gross sales for Q3. 

Figure 34: Gross Sales Report

 Function

The PCR function appears in this format:

PCR (Place,End1[,...,Endn])

Where... Is...

Place The number of the column or row from which the system 
calculates the percentages.

End1 The column or row number for the first ending point in the 
percentage calculation. If Place is a column number, then End1 
is a row number. If Place is a row number, then End1 is a 
column number. 

Endn The column or row number for the last ending point in the 
percentage calculation. If Place is a column number, then End2 
is a row number. If Place is a row number, then End2 is a 
column number. 
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PCT - Ratios as Percentages 

The financial function PCT expresses the ratios of the values in one column or row 
to those in another as percentages. When you use the Edit Formulas dialog box to 
paste this function into a column or row, the function appears in the formula bar 
edit box if you view data formulas. 

For example, this row formula expresses the ratios of the values in row 6 to the 
values in row 10 as percentages:

PCT(6,10)

The system uses this formula to calculate the PCT values:

 Function

The PCT function appears in this format:

PCT(First,Second)

Applies To:

Where... Is...

First The number of the first column or row in the ratio.

Second The number of the second column or row in the ratio.

First
Second
------------------- 100×
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@PDES - Partial Description

The text function @PDES produces partial descriptions of entities or accounts 
with subentities or subaccounts. For example, you can use the @PDES function 
with a fully specified entity, which includes a subentity, to show the description of 
either the major entity or the subentity. 

When you use the Edit Formulas dialog box to paste this function into a heading 
formula, the function appears in the formula bar edit box if you view heading 
formulas. You can also use the Header and Footer dialog boxes to paste this 
function into headers and footers.

For example, in a column with a fully specified account, this formula produces the 
description for the second subaccount only:

@PDES(SUBACC2)

If the fully specified account description is Sales.Paper.New England, the formula 
produces this heading:

New England

 Function

The @PDES function appears in this format:

[Before] @PDES[(Keyword)][After]

Applies To:

Where... Is...

Before Any text that appears before the partial description.

Keyword ACC, ENT, SUBACC1, SUBACC2, or SUBENT.

After Any text that appears after the partial description.
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@PLAB - Partial Dimension ID 

The text function @PLAB produces partial IDs of entities or accounts with 
subentities or subaccounts. For example, you can use the @PLAB function with a 
fully specified entity, which includes a subentity, to show the ID of either the 
major entity or the subentity. 

When you use the Edit Formulas dialog box to paste this function into a heading 
formula, the function appears in the formula bar edit box if you view heading 
formulas. You can also use the Header and Footer dialog boxes to paste this 
function into headers and footers.

For example, in a column with a fully specified account, this formula produces the 
ID for the second subaccount only:

@PLAB(SUBACC2)

If the fully specified account ID is SALES.PAPER.NE, the formula produces this 
heading:

NE

 Function

The @PLAB function appears in this format:

[Before] @PLAB [(Keyword)][After]

Applies To:

Where... Is...

Before Any text that appears before the partial ID.

Keyword ACC, ENT, SUBACC1, SUBACC2, or SUBENT.

After Any text that appears after the partial ID.
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@PSF - Consolidation Status

The text function @PSF produces the consolidation status of the current entity. 
When you use the Edit Formulas dialog box to paste this function in a heading 
formula, the function appears in the formula bar edit box if you view heading 
formulas. You can also use the Header and Footer dialog boxes to paste this 
function into headers and footers.

For example, if you assign entities to columns and use this formula for their 
headings, the headings show the ID and consolidation status for each entity in 
parentheses:

@LAB(@PSF)

 Function

The @PSF function appears in this format:

[Before] @PSF [After]

Applies To:

Where... Is...

Before Any text that appears before the consolidation status for the 
current entity.

After Any text that appears after the consolidation status for the 
current entity.
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RAT - Ratios 

The financial function RAT calculates the ratios of the values in one row or 
column to those in another. When you use the Edit Formulas dialog box to paste 
this function into a column or row, the function appears in the formula bar edit box 
if you view data formulas. 

The system uses this formula to calculate the ratios:

For example, this row formula shows the ratios of the values in row 37 to the 
values in row 41:

RAT(37,41)

 Function

The RAT function appears in this format:

RAT(First,Second)

Applies To:

Where... Is...

First The number of the first column or row in the ratio.

Second The number of the second column or row in the ratio.

First
Second
-------------------
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REPORT - Report in Book 

The REPORT function specifies a report in a book. When you use the Edit menu 
to insert a report in a book, this function appears in the formula bar edit box if you 
view data formulas.

For example, this formula includes the INC report in a book: 

REPORT "INC" 

 Function

The REPORT function appears in this format:

REPORT "ID"

where ID is a report ID. 

RND - Round Specific Values

The financial function RND rounds the results of expressions to the nearest 
designated factor. When you use the Edit Formulas dialog box to paste this 
function into a column or row, the function appears in the formula bar edit box if 
you view data formulas. 

For example, this formula multiplies Cost of Sales values by 2 and rounds the 
results to thousandths:

RND(COS*2,.001)

Applies To:

Applies To:
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 Function

The RND function appears in this format:

RND(Expression,Factor)

@RNG - Range

The @RNG function retrieves a range of dimension IDs. In Hyperion Enterprise, 
@RNG is used for the period, account and subaccount dimensions. In Hyperion 
Essbase, @RNG is used for all dimensions except the View and Field dimensions.

Note: The @RNG function replaces the FROM and UNTIL functions; 
however the FROM and UNTIL functions are supported from the 
formula bar. 

 Hyperion Enterprise Example

Using the year dimension, the following formula displays all months between 
January 1998 and June 1998.

YEAR @RNG(“JAN98”,”JUN98”)

 Hyperion Essbase Example

Using the year dimension, the following formula displays all months between 
January 1998 and June 1998:

Where... Is...

Expression Any expression.

Factor The rounding factor expressed as a decimal.

Applies To:
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YEAR @RNG(“JAN98”,”JUN98”,LIST ”Monthly”)

The following figure shows the tree view of the Year dimension.

The following example displays all months from March 1995 to February 1996, if 
the point of view is set to March 1995.

YEAR @RNG (@CUR,”Feb96”,LIST ”Monthly”)

Following are other examples of @RNG:

From start of year to current period:

YEAR @RNG(,@CUR)

From start of year to end of year:

YEAR @RNG("Jan99","Dec99",List"Monthly")
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 Function

The @RNG function appears in this format:

Dimension name or Keyword @RNG (“Start ID”,“End ID”, “List”)]

@RPD - Current Reporting Directory

The text function @RPD retrieves the name of the current reporting directory in 
the report directory setting in the REPENG.INI file.

Where... Is...

Dimension name or 
Keyword

A keyword in Hyperion Enterprise, or a dimension 
name in Hyperion Essbase.

Start ID The first ID. If you leave this blank, the first ID in the 
dimension is used.
Note: The ID can be a name or function.

End ID The last ID. If you leave this blank, the last ID in the 
dimension is used.
Note: The ID can be a name or function.

List List of members. 
In Hyperion Enterprise, use a list for the account 
dimension only. Specify -1 for no list, 0 for withsub, 1 
for withsub1, and 2 for withsub2. If you leave this 
blank, it defaults to -1.
In Hyperion Essbase, if you do not specify a list, you 
get all the items in the range.

Applies To:
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When you use the Edit Formulas dialog box to paste this function into a heading 
formula, the function appears in the formula bar edit box if you view heading 
formulas. You can also use the Header and Footer dialog boxes to paste this 
function into headers and footers.

For example, if you click @RPD and apply it to a heading formula, 

D:\essbase\reports\server\appset\app 

could appear in the heading of the report.

 Function

The @RPD function appears in this format:

@RPD

@SCALE - Current Entity Scale 

The text function @SCALE shows the scale for the current entity. When you use 
the Edit Formulas dialog box to paste this function in a heading formula, the 
function appears in the formula bar edit box if you view heading formulas. You 
can also use the Header and Footer dialog boxes to paste this function into headers 
and footers.

For example, you can create this formula for a row heading:

Scale for @DES(ENT)= @SCALE

If the current entity is Diamond Business Papers, which has a scale of thousands, 
the formula produces this row heading when you run the report:

Scale for Diamond Business Papers = 3

Applies To:
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 Function

The @SCALE function appears in this format:

[Before] @SCALE [After]

@SED - Set Description

The function @SED retrieves the application set description. You can also use the 
Header and Footer dialog boxes to paste this function into headers and footers.

 Function

The @SED function appears in this format:

@SED

Where... Is...

Before Any text that appears before the current entity’s scale.

After Any text that appears after the current entity’s scale.

Applies To:
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@SET - Set Name

The function @SET retrieves the application set description. You can also use the 
Header and Footer dialog boxes to paste this function into headers and footers.

 Function

The @SET function appears in this format:

@SET

@SIB - Siblings

The function @SIB retrieves all siblings of the current member or specified 
member. It is supported by all dimensions except the Field and View dimensions. 
You can use this function as a parameter of another function, where that parameter 
is a list of members.

When you use the Edit Formulas dialog box to paste this function in a heading 
formula, the function appears in the formula bar edit box if you view heading 
formulas.

For example, the following statement:

@SIB(Boston)    

Applies To:

Applies To:
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retrieves:

New_York, Chicago

and the following statement:

@SIB(East)       

retrieves:

West, Central, South

 Function

The @SIB function appears in these formats:

� Dimension @SIB 

which retrieves the children of the member in the current point of view for the 
dimension.

� Dimension @SIB (mbrName) 

which retrieves the children of the mbrName for the dimension.

@SLA - Siblings to the Left

The function @SLA expands to include all the siblings to the left of the specified 
member, excluding the specified member. It supports all dimensions except the 
Field dimension. This function can also be used as a parameter of another function, 
where that parameter is a list of members.

Where... Is...

Dimension The dimension name.

mbrName A specified member.

Applies To:
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When you use the Edit Formulas dialog box to paste this function in a heading 
formula, the function appears in the formula bar edit box if you view heading 
formulas. 

For example, the following statement:

@SLA(QTR4)

retrieves:

Qtr1, Qtr2, Qtr3

 Function

The @SLA function appears in these formats:

� Dimension @SLA 

which retrieves the children of the member in the current point of view for the 
dimension.

� Dimension @SLA(mbrName) 

which retrieves the children of the mbrName for the dimension.

Where... Is...

Dimension The dimension name.

mbrName A specified member.
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@SLF - First Sibling to the Left

The function @SLF expands to include the first sibling to the left of the specified 
member, excluding the specified member. It supports all dimensions except the 
Field dimension. This function can also be used as a parameter of another function, 
where that parameter is a list of members.

When you use the Edit Formulas dialog box to paste this function in a heading 
formula, the function appears in the formula bar edit box if you view heading 
formulas. 

For example, the following statement:

@SLF(QTR4)

retrieves:

Qtr3

 Function

The @SLF function appears in these formats:

� Dimension @SLF 

which retrieves the children of the member in the current point of view for the 
dimension.

� Dimension @SLF(mbrName) 

which retrieves the children of the mbrName for the dimension.

Applies To:

Where... Is...

Dimension The dimension name.

mbrName A specified member.
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@SRA - All Siblings to the Right

The function @SRA expands to include all the siblings to the right of the specified 
member, excluding the specified member. It supports all dimensions except the 
Field dimension. This function can also be used as a parameter of another function, 
where that parameter is a list of members.

When you use the Edit Formulas dialog box to paste this function in a heading 
formula, the function appears in the formula bar edit box if you view heading 
formulas. 

For example, the following statement:

@SRA(QTR2)

retrieves:

Qtr3, Qtr4

 Function

The @SRA function appears in these formats:

� Dimension @SRA 

which retrieves the children of the member in the current point of view for the 
dimension.

� Dimension @SRA(mbrName) 

which retrieves the children of the mbrName for the dimension.

Applies To:

Where... Is...

Dimension The dimension name.

mbrName A specified member.
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@SRF - First Sibling to the Right

The text function @SRF expands to include the first sibling to the right of the 
specified member, excluding the specified member. It supports all dimensions 
except the Field dimension. This function can also be used as a parameter of 
another function, where that parameter is a list of members.

When you use the Edit Formulas dialog box to paste this function into a heading 
formula, the function appears in the formula bar edit box if you view heading 
formulas.

For example, the following statement:

@SRF(QTR2)

retrieves:

Qtr3

 Function

The @SRF function appears in these formats:

� Dimension @SRF 

which retrieves the children of the member in the current point of view for the 
dimension.

� Dimension @SRF(mbrName) 

which retrieves the children of the mbrName for the dimension.

Applies To:

Where... Is...

Dimension The dimension name.

mbrName A specified member.
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@SRN - Server Name

The text function @SRN retrieves the current Hyperion Essbase server name. You 

can also use the Header and Footer dialog boxes to paste this function into headers 
and footers.

 Function

The @SRN function appears in this format:

@SRN

@START - Starting Period 

You use the @START function to create a row or column for the current entity’s 
starting period or a period offset from the starting period, or for a dimension’s first 
ID. You can select this function when you use the Edit menu or the Period formula 
bar button to assign dimensions using the function method. When you select this 
function, it appears in the formula bar edit box if you view data formulas.

This formula shows data for the first category:

CAT @START

This formula shows data for the current entity’s starting period:

DAT @START

Applies To:

Applies To:
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If the current entity’s starting period is December 1998, this formula shows 
December 1999 data:

DAT @START+12

 Function

The @START function appears in this format:

Keyword @START[Operator][Number]

@SUB - Subaccounts 

The @SUB function creates columns or rows for the immediate subaccounts of a 
specified account. You can select this function when you use the Edit menu or the 
Account formula bar button to assign accounts with the function method. When 
you select this function, it appears in the formula bar edit box if you view data 
formulas.

This formula creates rows for all subaccounts of the Cost of Goods Sold account:

ACC @SUB(COSTGDS)

Where... Is...

Keyword The keyword for a dimension.

Operator For the period dimension, a plus sign ( + ) for an offset 
later than the first period or a minus sign ( - ) for an offset 
earlier than the first period. This option is supported in 
Hyperion Enterprise only.

Number The number of periods for the offset. This option is 
supported in Hyperion Enterprise only.

Applies To:
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 Function

The @SUB function appears in this format:

ACC @SUB [(Account)]

where Account is an account ID. If you do not specify an account, the system uses 
the current account.

SUM - Total 

The financial function SUM adds the values of specified columns or rows. When 
you use the Edit Formulas dialog box to paste this function into a column or row, 
the function appears in the formula bar edit box if you view data formulas. 

For example, this row formula shows the sums of the values in rows 2, 7, and 9:

SUM(2,7,9)

This column formula shows the sum of the values in column 12:

SUM(12)

This row formula shows the sums of the values in rows 2 through 7:

SUM(2:7) 

Instead of using the SUM function in a formula, you can enclose the line numbers 
in square brackets and separate them with plus signs. For example, this row 
formula shows sums of the values in rows 3 and 8 of the report: 

[3] + [8] 

Applies To:
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 Function

The SUM function appears in this format when it adds the values of 
nonconsecutive columns or rows:

SUM(First[,.,Last])

If the SUM function adds the values in a consecutive range of columns or rows, it 
appears in this format:

SUM(First:Last)

@TIM - Current Time 

The text function @TIM displays the current system time. When you use the Edit 
Formulas dialog box to paste this function into a heading formula, the function 
appears in the formula bar edit box if you view heading formulas. You can also use 
the Header and Footer dialog boxes to paste this function into headers and footers.

For example, you can create this formula for a row heading:

Totals as of @TIM

Where... Is...

First The number of the first column or row to be added.

Last The number of the last column or row to be added.

Where... Is...

First The number of the first column or row in the range. 

Last The number of the last column or row in the range. 

Applies To:
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If the current system time when you run the report is 11:35 a.m., the formula 
produces this heading: 

Totals as of 11:35 a.m.

 Function

The @TIM function appears in this format:

[Before] @TIM [Mask][After]

@TMCODE - Translation Method Code 

The text function @TMCODE displays a code, which you can define in Hyperion 
Enterprise, for grouping translation methods. When you use the Edit Formulas 
dialog box to paste this function into a heading formula, the function appears in the 
formula bar edit box if you view heading formulas. You can also use the Header 
and Footer dialog boxes to paste this function into headers and footers.

For example, you can create this formula for a footer:

Translation Method: @TMCODE

If the current chart method code is FR-ELIM, the formula produces this footer 
when you run the report:

Translation Method: FR-ELIM

Where... Is...

Before Any text that appears before the current system time.

Mask SHORT to show hour and minute, or LONG to show the hour, 
minute, and second. SHORT is the default option.

After Any text that appears after the current system time.

Applies To:
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 Function

The @TMCODE function appears in this format:

[Before] @TMCODE [After]

@TOD - Current Date 

The text function @TOD displays the current system date. When you use the Edit 
Formulas dialog box to paste this function into a heading formula, the function 
appears in the formula bar edit box if you view heading formulas. You can also use 
the Header and Footer dialog boxes to paste this function into headers and footers.

For example, you can create this formula for a row heading:

Totals as of @TOD

If the current system date is May 23, 1998, the formula produces this heading when 
you run the report:

Totals as of 05/23/98

Where... Is...

Before Any text that appears before the translation method 
code.

After Any text that appears after the translation method code.

Applies To:
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 Function

The @TOD function appears in this format:

[Before] @TOD [Mask][After]

@TOP - Topmost Member 

You use the @TOP function to create a row or column for a dimension’s topmost 
ID. You can select this function when you use the Edit menu or the Period formula 
bar button to assign dimensions using the function method. When you select this 
function, it appears in the formula bar edit box if you view data formulas.

This formula shows data for the topmost account:

ACCOUNT @TOP

 Function

The @TOP function appears in these formats:

� Dimension @TOP 

Where... Is...

Before Any text that appears before the current system date.

Mask SHORT to show a number for the month and only the last two 
digits of the year, LONG to spell out the date and show all four 
digits of the year, or another date mask. SHORT is the default 
mask.

After Any text that appears after the current system date.

Applies To:
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which retrieves the children of the member in the current point of view for the 
dimension.

� Dimension @TOP(mbrName) 

which retrieves the children of the mbrName for the dimension.

UNTIL - End of Range 

The UNTIL function marks the end of a range of dimensions. 

Note: The @RNG function replaces the FROM and UNTIL functions, 
however the FROM and UNTIL functions are supported from the 
formula bar. For more information on the @RNG function, see 
@RNG - Range on page 307.

For example, this formula creates consecutive columns or rows for the periods 
beginning with January 1998 and ending with June 1998:

DAT FROM JAN98 UNTIL JUN98 

For example, this formula creates consecutive columns or rows for the products 
beginning with Coffee and ending with Tea:

Product FROM Coffee UNTIL Tea

Where... Is...

Dimension The dimension name.

mbrName A specified member.

Applies To:
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 Function

The UNTIL function appears in this format:

Keyword or Dimension FROM First UNTIL Last

@USR - User ID 

The text function @USR produces the current user’s ID. When you use the Edit 
Formulas dialog box to paste this function into a heading formula, the function 
appears in the formula bar edit box if you view heading formulas. You can also use 
the Header and Footer dialog boxes to paste this function into headers and footers.

For example, you can create this formula for a footer:

Reported by @USR

If the current user’s ID is Supervisor, the formula produces this footer when you 
run the report:

Reported by Supervisor

Where... Is...

Keyword or Dimension The keyword ACC or DAT in Hyperion Enterprise or
the dimension name in Hyperion Essbase.

First The ID for the first account or period in the range.

Last The ID for the last account or period in the range.

Applies To:
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The @USR function appears in this format:

[Before] @USR [After]

@VWD - View Description 

The text function @VWD produces the description for the current view. When you 
use the Edit Formulas dialog box to paste this function into a heading formula, the 
function appears in the formula bar edit box if you view heading formulas. You 
can also use the Header and Footer dialog boxes to paste this function into headers 
and footers.

For example, you can create this formula for a report’s header: 

@VWD Expenses

If the current view description is Year To Date, the formula produces this header 
when you run the report:

Year To Date Expenses

Where... Is...

Before Any text that appears before the current user’s ID.

After Any text that appears after the current user’s ID.

Applies To:
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 Function

The @VWD function appears in this format:

[Before] @VWD [After]

@VWL - View ID 

The text function @VWL produces the ID for the current view. When you use the 
Edit Formulas dialog box to paste this function into a heading formula, the 
function appears in the formula bar edit box if you view heading formulas. You 
can also use the Header and Footer dialog boxes to paste this function into headers 
and footers.

For example, you can create this formula for a report’s header:

@VWL Expenses

If the current view is Year To Date and its ID is YTD, the formula produces this 
header when you run the report:

YTD Expenses

Where... Is...

Before Any text that appears before the current view 
description. 

After Any text that appears after the current view description. 

Applies To:
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 Function

The @VWL function appears in this format:

[Before] @VWL [After]

WITHSUB - With Subaccounts 

The WITHSUB function creates columns or rows for all subaccounts in a range of 
accounts. When you use the FROM and UNTIL functions, you can use the 
WITHSUB function from the formula bar.

For example, this formula creates columns of data for a range of accounts that 
begins with Sales, ends with Net Income, and includes subaccounts: 

ACC FROM SALES UNTIL NETINC WITHSUB

Note: The @RNG function replaces the FROM and UNTIL functions, 
however the FROM and UNTIL functions are supported from the 
formula bar. The WITHSUB function is supported from the formula 
bar only. For more information on the @RNG function, see @RNG - 
Range on page 307.

Where... Is...

Before Any text that appears before the current view ID.

After Any text that appears after the current view ID.

Applies To:
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 Function

The WITHSUB function appears in this format:

ACC FROM First[.Subfirst] UNTIL Last[.Sublast][WITHSUB]

WITHSUB1 - With First-level Subaccounts 

The WITHSUB1 function creates columns or rows for first-level subaccounts in a 
range of accounts. When you use the FROM and UNTIL functions, you can use 
the WITHSUB1 function from the formula bar.

For example, this formula creates columns of data for a range of accounts that 
begins with Sales, ends with Net Income, and includes subaccounts: 

ACC FROM SALES UNTIL NETINC WITHSUB1

Note: The @RNG function replaces the FROM and UNTIL functions, 
however the FROM and UNTIL functions are supported from the 
formula bar. The WITHSUB1 function is supported from the formula 
bar only. For more information on the @RNG function, see @RNG - 
Range on page 307.

Where... Is... 

First The ID for the first account in the range. 

Subfirst The ID for the first subaccount in the range. 

Last The ID for the last account in the range. 

Sublast The ID for the last subaccount in the range. 

Applies To:
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The WITHSUB1 function appears in this format:

ACC FROM First UNTIL Last[WITHSUB1]

@WLD - Wildcard

The text function @WLD retrieves all members that match your wildcard 
specification.

When you use the Edit Formulas dialog box to paste this function into a heading 
formula, the function appears in the formula bar edit box if you view heading 
formulas. You can also use the Header and Footer dialog boxes to paste this 
function into headers and footers.

You can use the ? symbol to replace one character and the * symbol to replace 
multiple characters. For example, if you are searching for all states that begin with 
the letter C, you can use this formula:

@WLD(“C*”)

Where... Is... 

First The ID for the first account in the range. 

Last The ID for the last account in the range. 

Applies To:
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 Function

The @WLD function appears in this format:

Dimension@WLD[wildcardspecifier]

Where... Is... 

Dimension The dimension name.

wildcardspecifier Any number of characters with a wildcard.



� 333Hyperion Enterprise Reporting Windows Client User’s Guide

Hyperion Analyst

Hyperion Analyst is a flexible, ad hoc query tool for analyzing data from a 
Hyperion Solutions product application in a Microsoft Excel or Lotus 1-2-3 
worksheet. With Hyperion Analyst, you can query an application for any 
dimensions that exist in the application.

Hyperion Analyst allows you to arrange dimensions in any combination of rows 
and columns to retrieve data and view the results instantly. You can then explore 
the application by moving the dimensions, selecting different dimension IDs, and 
viewing supporting information for specific values. 

A Hyperion Analyst worksheet can be converted for use in Hyperion Retrieve for 
Reporting for production reporting, charting, and presentation formatting. This 
allows you to take advantage of additional Microsoft Excel and Lotus 1-2-3 
functionality. For more information about Hyperion Retrieve for Reporting, see 
the Hyperion Retrieve for Reporting online Help. 

This chapter explains basic functions of Hyperion Analyst, such as starting and 
exiting. It describes Hyperion Analyst menu functions, worksheets, and how to 
work with queries, dimensions and expansions. It also explains how to create a 
Microsoft Excel worksheet template in Hyperion Analyst.

Add-in Files 
Before you run Hyperion Analyst, you must load an add-in file for your 
spreadsheet program. The file stays loaded, so that Hyperion Analyst is available 
whenever you start the spreadsheet program. You can unload the file if you want 
to start the spreadsheet program without Hyperion Analyst.

The tools for loading and unloading the add-in file depend on whether you are 
using Lotus 1-2-3 or Microsoft Excel. 

13
Chapter
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Load or Unload the Microsoft Excel Add-in File 

➤ To load or unload the Microsoft Excel add-in file:

1. Select Tools > Add-Ins.

2. If the list in the Add-Ins dialog box does not include Hyperion Analyst, click 
Browse, then select ANALYS32.XLA from the directory that contains your 
Hyperion Analyst program files.

3. Do one of the following:

� To load the add-in file, select Hyperion Analyst.

� To unload the add-in file, deselect Hyperion Analyst.

4. Click OK.

Load or Unload the Lotus 1-2-3 Add-in File

➤ To load or unload the Lotus 1-2-3 add-in file:

1. Select File > Add-Ins > Manage Add-Ins.

2. If the list in the Manage Add-Ins dialog box does not include ANALYST.12A, 
click Register, then navigate to where ANALYST.12A is located.

3. Do one of the following:

� To load the add-in file, select ANALYST.12A.

� To unload the add-in file, deselect ANALYST.12A.

4. Click Done.

Start Hyperion Analyst
When you start Hyperion Analyst, you may be prompted to select a Hyperion 
Solutions product, application set, and application, and then specify your user ID 
and password for the application. You can create additional queries in the same 
application without entering your ID and password again.



Hyperion Analyst

� 335Hyperion Enterprise Reporting Windows Client User’s Guide

13

Start Hyperion Analyst from Windows

➤ To start Hyperion Analyst from Windows:

1. Double-click on the Hyperion Analyst icon.

2. Select Analyst > New Query.

3. If a logon dialog box displays, select a Hyperion Solutions product and 
application, then enter your user ID and password.

4. Click OK.

Tip: You can create additional queries in the same application without 
entering your ID and password again. 

Start Hyperion Analyst from Microsoft Excel

➤ To start Hyperion Analyst from Microsoft Excel:

1. Do one of the following:

� If the Hyperion Analyst add-in is already loaded, go to step 4. 

� If the Hyperion Analyst add-in is not loaded, continue with step 2.

2. Select File > Open.

3. Select the Hyperion Analyst worksheet ANALYS32.XLA, which is in your 
Analyst program directory, then click OK.

4. Select Analyst > New Query.

5. If a logon dialog box displays, select a Hyperion Solutions product and 
application, then enter your user ID and password.

6. Click OK.

Tip: You can create additional queries in the same application without 
entering your user ID and password again. 
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Start Hyperion Analyst from Lotus 1-2-3 

➤ To start Hyperion Analyst from Lotus 1-2-3:

1. Select Analyst > New Query.

2. If a logon dialog box displays, select a Hyperion Solutions product and 
application, then enter your user ID and password.

3. Click OK.

Tip: You can create additional queries in the same application without 
entering your user ID and password again.

Exit Hyperion Analyst
When you exit Hyperion Analyst, the work session ends, and you also exit 
Microsoft Excel or Lotus 1-2-3.

➤ To exit Hyperion Analyst, select File > Exit.

Hyperion Analyst Toolbar
Changes have been made to the Hyperion Analyst toolbar for Hyperion Enterprise 
Reporting Windows Client 3.1.

Hyperion Analyst for Microsoft Excel 7

➤ To use the new toolbar for Microsoft Excel 7 users:

1. Select View > Toolbars.

2. Select Hyperion Analyst.

3. Select Delete.

4. Select OK to delete the Hyperion Analyst toolbar.

5. Exit Microsoft Excel.

The next time you open Microsoft Excel, the new Hyperion Analyst toolbar 
displays.
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Hyperion Analyst for Microsoft Excel 8

➤ To use the new toolbar for Microsoft Excel 8 users:

1. Select View > Toolbars > Customize.

2. On the Toolbar tab, select Hyperion Analyst.

3. Select Delete.

4. Select OK to delete the Hyperion Analyst toolbar.

5. Exit Microsoft Excel.

The next time you open Microsoft Excel, the new Hyperion Analyst toolbar 
displays.

Analyst Menu
Many of the tasks you perform in Hyperion Analyst involve selecting options from 
the Hyperion Analyst menu. Alternatively, Hyperion Analyst toolbar icons in 
Microsoft Excel provide quick mouse access to some Hyperion Analyst menu 
options. 

In Microsoft Excel, you use the View menu to show the Hyperion Analyst toolbar. 

The following table shows the Hyperion Analyst menu options, with the icon 
equivalents in Microsoft Excel.

Table 45: Hyperion Analyst Menu Options / Excel Icons 

Select...
Or click this icon in 
Excel... To...

New Query Create a query for retrieving data 
for specific dimension IDs from a 
Hyperion Solutions application.

Open Query Open an existing query.

End Query End a current query.
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Save Query Save a query you have created or 
modified.

Save Query As Save a query using a different file 
name or path.

Modify Query Modify an existing query.

Refresh Refresh the current query by 
retrieving new and changed data 
from the current application.

Convert to 
Functions

Convert all data in the Hyperion 
Analyst worksheet to Hyperion 
Retrieve for Reporting formulas 
or Hyperion Retrieve (HP 
Retrieve) formulas. For more 
information, see the Hyperion 
Retrieve for Reporting formulas 
topic in the Hyperion Retrieve for 
Reporting User’s Guide.

Hide Page 
Dimensions

Hide the worksheet point-of-view 
dimensions, so that you see only 
the dimensions assigned to 
columns and rows. You can then 
see more data at one time on the 
Hyperion Analyst worksheet.

Show Page 
Dimensions

Show the worksheet point of view 
dimensions on the Hyperion 
Analyst worksheet.

Table 45: Hyperion Analyst Menu Options / Excel Icons (Continued)

Select...
Or click this icon in 
Excel... To...
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The following table describes additional Hyperion Analyst menu options in both 
Microsoft Excel and Lotus 1-2-3. For information on the Help menu options, see 
Access Online Help on page 339.

Access Online Help
Hyperion Analyst Help allows you to obtain information quickly as you use 
Hyperion Analyst. 

➤ To access online Help, select Analyst > Help and select any of the pop-up menu 
items. 

The following table describes the various Help options.

Table 46: Additional Hyperion Analyst Menu Options

Select... To...

Manage Dimensions Specify the following options:

• Which dimensions appear in Hyperion Analyst 
queries.

• Whether IDs, descriptions, or both appear in 
Hyperion Analyst queries.

• Whether a dimension expansion shows all 
dependents below it or only the next level of 
dependents.

Note: Hyperion Analyst supports expansions for 
Hyperion Enterprise.

Manage Expansions Specify the detail that appears when you expand a 
dimension value.

Edit Suppress Options Suppress columns and rows that contain only zeros or 
no data, or where errors or division by zero occur.

Table 47: Online Help Options 

Select... To Access...

Help Hyperion Analyst Help.

Contents The table of contents for Hyperion Analyst Help.
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Hyperion Analyst Worksheet
The Hyperion Analyst worksheet links a Microsoft Excel or Lotus 1-2-3 
worksheet with a Hyperion Solutions product application. You create or modify 
queries in the worksheet to show data for specific dimension IDs in the worksheet.

Search for Help on A dialog box that you can use to find specific help 
topics.

Using Help Information about how to use Windows Help.

Hyperion Analyst Guide 
(PDF)

The online version of this guide. When you select 
this option, the file opens and you are in Adobe 
Acrobat Reader, where you can view or print the 
file.

About Hyperion Analyst Software version information about your Hyperion 
Analyst system.

The Help button or press F1 
within a dialog box or 
window

Dialog-box-level Help.

Table 47: Online Help Options (Continued)

Select... To Access...
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The following figure shows a sample Hyperion Analyst worksheet.

Figure 35: Hyperion Analyst Sample Worksheet

Change the Worksheet Point of View 
The Hyperion Analyst point of view is a set of dimension IDs that Hyperion 
Analyst uses to produce data from an application. 

The worksheet point of view specifies the default dimension IDs for your 
Hyperion Analyst work session. You can change the worksheet point of view in 
the Hyperion Analyst worksheet or the Modify Query dialog box. Any changes 
you make to the point of view are for the current Hyperion Analyst query only.

➤ To change the worksheet point of view:

1. Do one of the following:

� Select Analyst > Modify Query, then double-click on any dimension 
icon in the Worksheet point of view area.
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� In a Hyperion Analyst worksheet, double-click on a dimension name or 
dimension icon assigned to the worksheet point of view.

Tip: You can drag and drop dimensions to move them to or from the 
worksheet point of view. For more information, see Drag and Drop 
Dimensions on page 345.

2. Select a new ID for each dimension you want to change in the worksheet point 
of view.

Hyperion Analyst Queries
A Hyperion Analyst query is a set of dimension IDs arranged on a worksheet to 
retrieve data from a Hyperion Solutions product application.

Create Queries
You create a query to view data from the application without writing spreadsheet 
formulas or SQL queries.

➤ To create a query:

1. Select Analyst > New Query.

2. If a logon dialog box displays, select a Hyperion Solutions product and 
application, then enter your user ID and password.

3. From the Hyperion Analyst worksheet, select dimension IDs for the 
worksheet point of view and the worksheet’s columns and rows.

Open Queries
You open queries to see the data they produce. You can also modify open queries 
and save them with different paths or file names.

➤ To open a query:

1. Select Analyst > Open Query.

2. If a logon dialog box displays, select a Hyperion Solutions product and 
application, then enter your user ID and password.
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3. Select the query you want to open.

Modify Queries 
You can modify a query by changing the dimensions or dimension IDs for the 
worksheet point of view, columns, or rows in a Hyperion Analyst worksheet.

➤ To modify a query:

1. Open a query. For instructions, see Open Queries on page 342.

2. Select Analyst > Modify Query.

3. Double-click on dimension icons and select new IDs for the dimensions.

4. Click Close.

Note: You can also modify a query by dragging and dropping 
dimensions or double-clicking on dimension IDs to expand or 
collapse them. For more information, see Drag and Drop 
Dimensions on page 345 or Expand or Collapse Data on 
page 348.

End Queries
You end a query to stop retrieving data from the current application. After you end 
a query, the IDs from the query appear in a Microsoft Excel or Lotus 1-2-3 
worksheet without the dimension names or icons from the application.

➤ To end a query, select Analyst > End Query.

Save Queries
You save a Hyperion Analyst query to preserve the worksheet point of view and 
the dimension IDs for the rows and columns. You can open a saved query to use 
its point of view and the dimension IDs for columns and rows in a new query. 

Saving a Hyperion Analyst worksheet as a query, which you do from the Hyperion 
Analyst menu, is different from saving a Hyperion Analyst worksheet as a 
Microsoft Excel or Lotus 1-2-3 worksheet, which you do from the Hyperion 
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Analyst File menu. When you use the File menu to save a Hyperion Analyst 
worksheet as a Microsoft Excel or Lotus 1-2-3 worksheet, you cannot reopen that 
worksheet as a Hyperion Analyst query.

➤ To save a query, do one of the following:

� To save a new query, select Analyst > Save Query or Analyst > Save 
Query As.

� To save an existing query with its current path and file name, select 
Analyst > Save Query.

� To save an existing query with a different path or file name, select Analyst 
> Save Query As.

Edit Dimensions
You edit dimensions to assign dimension IDs or ranges to columns and rows. For 
example, you edit the account dimension to assign specific accounts to columns or 
rows.

➤ To edit a dimension:

1. Do one of the following:

� In a column or row, double-click on the dimension icon (Excel) or 
dimension name (Lotus 1-2-3).

� Select Analyst > Modify Query, then double-click on the dimension icon 
in the Columns or Rows area.

2. Select a dimension ID.

3. Click OK.

Manage Dimensions
You manage dimensions to specify which dimensions appear in queries. In a 
query, you double-click on the dimension icons (Excel) or dimension names 
(Lotus 1-2-3) to access dialog boxes where you select the specific dimension IDs 
for the worksheet point of view and the columns and rows. For example, you click 
on the Period icon in a Microsoft Excel query or on the Period icon in a Lotus 1-2-3 
query, then select specific periods.
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When you manage dimensions, Hyperion Analyst creates a new query. It prompts 
you to save the current query if you have not saved it already.

➤ To manage dimensions:

1. From a new or existing query, select Analyst > Manage Dimensions.

2. Select the following options:

� Which dimensions you want to appear in queries

� Whether IDs, descriptions, or both appear for the selected dimensions in 
queries

3. Click OK.

Drag and Drop Dimensions
You can move dimensions from one area of the Hyperion Analyst worksheet to 
another by dragging and dropping them on the worksheet or in the Modify Query 
dialog box. 

If you move a dimension with multiple IDs from columns or rows to the worksheet 
point of view, Hyperion Analyst uses the first ID for that dimension as the 
worksheet point of view. For example, suppose you assign the JAN.FY97, 
FEB.FY97, and MAR.FY97 periods to rows 1, 2, and 3, respectively. If you then 
move the period dimension to the worksheet point of view, the worksheet point of 
view period is JAN.FY97.

In the Hyperion Analyst worksheet, dragging and dropping with Microsoft Excel 
is slightly different from dragging and dropping with Lotus 1-2-3. In the Modify 
Query dialog box, dragging and dropping in Microsoft Excel is the same as in 
Lotus 1-2-3.

Drag and Drop Dimensions with Microsoft Excel 

➤ To drag and drop a dimension with Microsoft Excel:

1. Click on the dimension icon and hold down the left mouse button.

2. Move the mouse pointer to the new position for the dimension, then release 
the mouse button.
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Drag and Drop Dimensions with Lotus 1-2-3

➤ To drag and drop a dimension with Lotus 1-2-3:

1. Click once on the dimension name.

2. Move the mouse pointer slightly up or down until the pointer icon changes 
from an arrow to a hand, then click once and hold down the left mouse button. 

3. Move the mouse pointer to the new position for the dimension, then release 
the mouse button.

Note: By default, Lotus 1-2-3 prompts you to confirm whether you 
want each move when you drag and drop dimensions. You can 
turn off the prompts by selecting File > User Setup > 1-2-3 
Preferences, then deselecting the Confirm Drag and Drop option 
in the User Setup dialog box.

Reorder Dimensions
You can reorder dimensions within an area. For example, suppose you assign the 
account dimension, then the center dimension, then the period dimension to the 
Columns area. You might want to reorder the dimensions so that the period 
dimension is the first dimension.

You can also reorder dimensions by dragging and dropping dimension icons or 
dimension names in the Hyperion Analyst worksheet.

➤ To reorder dimensions:

1. Select Analyst > Modify Query.

2. Click and hold on the dimension icon with the left mouse button.

3. Drag the dimension icon to a different position within the area, then release 
the mouse button.

4. Click Close.
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Reorder Dimension IDs
You can reorder IDs in columns and rows. For example, suppose you assign the 
JAN.FY97, FEB.FY97, MAR.FY97, and FY97 periods to rows, in that order. You 
might want to reorder the periods so that FY97 appears in the first row instead of 
the last row.

➤ To reorder dimension IDs: 

1. Do one of the following:

� Double-click on the dimension icon (Excel) or dimension name (Lotus 
1-2-3) in the Hyperion Analyst worksheet.

� Select Analyst > Modify Query.

� Double-click on the dimension icon for the IDs you want to reorder.

2. Highlight an ID in the selected box and use the Up or Down button to move 
the ID.

3. Click OK.

4. Click Close.

Expansions
Expansions show detail data for dimension IDs in a Hyperion Analyst worksheet. 
For example, you can expand an entity in a Hyperion Enterprise application to 
show data for its dependents. If you then collapse the expansion, the worksheet 
shows only summary data for the dimension ID.

A plus sign ( +) to the left of a dimension ID in a Hyperion Analyst worksheet 
shows that the ID is expandable. A minus sign ( - ) shows that the ID is collapsible. 
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Default Expansions
The EXPAND.REL file, which is in the reporting subdirectory of your application, 
creates the Hyperion Enterprise default expansions shown in the following table.

Enable Expansions
Before you can expand data in an application, you must either enable the default 
expansions or manage expansions, depending on the Hyperion application you 
use.

� To enable Hyperion Analyst’s default expansions (Hyperion Enterprise), see 
Default Expansions on page 348.

� To enable expansions in addition to the Hyperion Analyst defaults, see 
Manage Dimensions on page 344. 

Expand or Collapse Data
You expand summary data to see details. For example, you can expand an ID for 
a parent in a Hyperion Enterprise application to see values for its dependents. 

You collapse data to see a summary value. For example, you can collapse the data 
for a group of dependents in a Hyperion Enterprise application to see a value for 
their parent. 

A plus sign (+) to the left of a dimension ID in a Hyperion Analyst worksheet 
shows you can expand the dimension ID. A minus sign ( - ) to the left of a 
dimension ID shows you the dimension ID is collapsible.

You manage expansions to specify whether each dimension expands to show 
detail for all dependents below it or for only the next level of dependents. For more 
information, see Manage Dimensions on page 344.

Table 48: Hyperion Enterprise Default Expansions

This dimension... Expands to show...

Entity Data for dependents of an entity or name.

Period Data for dependents of a period, such as weeks within a 
month.

Account Data for subaccounts of an account.
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Expand Data

➤ To expand data, double-click on a dimension ID that has a plus sign (+) to the left 
of it. 

Note: You must enable expansions before you can expand and collapse data.

Collapse Data

➤ To collapse data, double-click on a dimension ID that has a minus sign (-) to the 
left of it. 

Manage Expansions 
You manage expansions to specify the detail that appears when you expand a 
dimension. For example, you can set up the entity expansion for a Hyperion 
Enterprise application to show values for all dependents of the entities that you 
specify in queries.

➤ To manage expansions:

1. From a new query or existing query, select Analyst > Manage Expansions.

2. To set up expansions for a dimension, select the dimension and then create, 
edit, or delete a parent relationship for that dimension.

3. To display dependents before the parent data, select Expand Before.

Note: Dependents are usually displayed on the worksheet after the 
parent ID.

4. To continue with other options, go on to step 5; otherwise, click Close.

5. To extract or load text files containing information about parent relationships, 
or to delete all parent relationships, do the following: 

a. Select Advanced to display the Manage Expansions - Advanced dialog 
box. 

b. Select the advanced options you want.

c. Click Close.

d. Click Close.
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Hide or Show Expansion Signs
Expansion signs indicate whether you can expand dimensions to show detail or 
collapse them to show only summary values. A plus sign (+) before a dimension 
indicates that you can expand that dimension to show more detail. A minus sign ( 
- ) before a dimension indicates that you can collapse that dimension to show only 
summary data.

You can add a line to your ANALYST.INI file to hide or show expansion signs in 
queries. If you do not add the line, or if you delete the line, Hyperion Analyst 
shows expansion signs by default. 

The following table shows the correct file syntax to add to the [APPLICATION] 
section of the ANALYST.INI file to hide or show expansion signs in queries for 
an application.

Drill-through Function
You can drill from account balances in one Hyperion Solutions product 
application to see supporting data in other Hyperion Solutions product 
applications or in third-party products that handle other data such as human 
resources or manufacturing data. 

Drill-through is available in systems where an administrator has used Hyperion 
Analyst Drill Manager, a separate Hyperion Solutions product, to set up drills 
among Hyperion Solutions products and applications and external programs.

Each drill-through produces a new worksheet that displays the next level of detail. 
The query where you began the drill-through remains open, in a different tabbed 
panel.

Suppose you are using Hyperion Analyst to view administrative expenses stored 
in a Hyperion Enterprise application, and you find that expenses for the MIS cost 
center are unexpectedly high. If MIS maintains its balances in another application, 
you can drill through to those balances in a second query. From there, you might 

Table 49: ANALYST.INI File Syntax for Hiding or Showing Expansions

To... Type...

Hide expansion signs ShowSign=1

Show expansion signs ShowSign=0
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continue the drill-through to review the journal entries and transactions underlying 
the MIS expense balances in a third query. All three queries remain open, and you 
can tab from one to another.

Note: Your access privileges determine what data you can view with a 
drill-through. If you have access to some but not all of the supporting 
data for a summary balance, the supporting data you see might not 
equal the summary balance.

➤ To drill through to supporting data for a base-level value in a Hyperion Analyst 
worksheet, double-click on the value.  

Note: Drill-through produces supporting data for dimension IDs that you 
cannot expand in Hyperion Analyst. Double-clicking on a value with 
an expandable dimension produces an expansion rather than a 
drill-through. 

Convert Values to Hyperion Retrieve for 
Reporting Functions

The Convert to Functions option converts the data values in Hyperion Analyst 
worksheet cells to Hyperion Retrieve for Reporting functions. If you click on a cell 
in a worksheet that you have converted to a function, a Hyperion Retrieve for 
Reporting formula appears in the Microsoft Excel or Lotus 1-2-3 formula bar. 
Hyperion Analyst uses absolute cell references in the conversion, so if you copy a 
formula to another location, the cell references for the formula remain intact. 

Converting worksheet values to functions ends the current Hyperion Analyst work 
session and produces a Microsoft Excel or Lotus 1-2-3 worksheet. If you save a 
query using the Analyst menu before converting it to functions, you can reopen the 
query later.

You might want to keep the worksheet area that shows the dimensions for the point 
of view, rows, and columns from becoming scrollable after you convert to 
functions. 
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The following table shows the correct file syntax to add to the [DEFAULT] section 
of the ANALYST.INI file to turn the convert function on or off.

Note: You can load the Hyperion Analyst and Hyperion Retrieve for 
Reporting add-ins at the same time in both Microsoft Excel and Lotus 
1-2-3. 

➤ To convert values to Hyperion Retrieve for Reporting functions, select Analyst > 
Convert to Functions.

Note: The Hyperion Retrieve for Reporting Add-in needs to be loaded 
before you can covert values to Hyperion Retrieve for Reporting 
functions.

Create a Microsoft Excel Format Template
You can create templates in Microsoft Excel that contain formatting defaults for 
use in Hyperion Analyst for Microsoft Excel. You use these templates to 
customize the appearance of queries. 

➤ To create a Microsoft Excel format template:

1. From a new Microsoft Excel book, select Edit > Delete Sheet to delete all 
worksheets except Sheet1.

2. Use the Microsoft Excel menus and toolbar to add any formatting to the 
worksheet, such as color or alignment specifications.

3. Save the worksheet as a template and type the file name ANALYST.XLT in 
the XLSTART subdirectory of the Microsoft Excel program directory.

Table 50: ANALYST.INI File Syntax for the Convert Function

To... Type...

Turn off the function UnfreezePanesOnConvert=0

Turn on the function UnfreezePanesOnConvert=1

Get HP Retrieve formulas cdaval=0

Get Hyperion Retrieve for 
Reporting formulas

cdaval=1
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Frequently Asked Questions
This chapter provides the answers to commonly asked questions about Hyperion 
Analyst that are not covered in the other sections of this guide. 

If you are experiencing additional problems, or have questions that are not covered 
in this chapter, ask your system administrator or refer to the release notes. 

Occasionally when I start a new query, I see error message 
#91. What does that mean?

When you installed Hyperion Analyst, either the ANACTL32.DLL file, the 
ANACTL.DLL file, or both files did not register properly. Perform either of these 
two tasks to eliminate the problem:

� Reinstall Hyperion Analyst

� Register the files manually:

1. Access the Run menu either from the Start button in Windows 95 or NT 
systems, or from the File Manager in Windows 3.11 systems.

2. Do one of the following:

� Type the following line if you are running Windows 95/NT:

REGSVR C:\PROGRAM FILES\HYPERION SOLUTIONS\FILENAME

where filename is either ANACTL.DLL or ANACTL32.DLL

� Type the following line if you are running Windows 3.5.1:

REGSVR32 C:\PROGRAM FILES\HYPERION SOLUTIONS\FILENAME

where filename is either ANACTL.DLL or ANACTL32.DLL

You must repeat the steps for both files if you are registering both files.

How can I drag and drop a dimension icon properly in the 
worksheet? Either the dimension icon moves to the wrong 
place, or it won’t move at all.

You cannot drag and drop a dimension icon in the worksheet unless there is 
another dimension icon that can replace it in its former position. 
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If you have more than one dimension icon in your worksheet and you are still 
having trouble, try using the Modify Query option to drag and drop dimension 
icons. See Modify Queries on page 343.

Occasionally when I start Hyperion Analyst or start a new 
query, I see error message #76. What does that mean?

You may be experiencing either of the following conditions:

� The XLSTART subdirectory, containing the file XL5GALRY.XLS, is 
missing in the EXCEL directory on your PC.

� You do not have the proper security access to the XLSTART directory.

Perform the appropriate task(s) to eliminate the problem. If you are performing 
both they can be done in either order:

� Add the XLSTART subdirectory to the EXCEL directory.

� Obtain the proper security access.

You can also try reinstalling Microsoft Excel.

When I start a new query I see either error #48 or error #53. 
What do they mean?

You may be experiencing one of these conditions:

� The CDA directory, which contains the Hyperion Analyst program, is not 
specified in the path section of the AUTOEXEC.BAT file on the PC.

� The CDA directory is specified in the AUTOEXEC.BAT file, but the 
network logon script is overwriting the AUTOEXEC.BAT file logon 
script.

� The HYSOFT directory, which contains all Hyperion Solutions programs, 
files and subdirectories, is not specified in the path section of the 
AUTOEXEC.BAT file on the PC.

Perform the following steps to eliminate the problem: 

1. Open the AUTOEXEC.BAT file.

2. Add CDA or HYSOFT to the path section of the file if neither are specified.

3. Reboot the PC. 

4. After the PC logs in, exit to DOS and type path at the C: prompt. 
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5. If you do not see both CDA or HYSOFT specified in the path, the network 
logon script is overwriting the AUTOEXEC.BAT file script. See your system 
administrator to modify the network logon script.
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Hyperion Retrieve

Hyperion Retrieve is an add-in to Microsoft Excel and Lotus 1-2-3 that you use to 
move data between Hyperion Solutions product applications and Excel or Lotus 
1-2-3 worksheets. You can also use Hyperion Retrieve to save data from an Excel 
or Lotus worksheet to a Hyperion Enterprise application.

With Hyperion Retrieve, you can take advantage of the analysis, graphics, and 
presentation capabilities of a spreadsheet program to create custom displays and 
reports using data from Hyperion Solutions product applications. Hyperion 
Retrieve functions, which you use to define the content of cells in Excel or Lotus 
1-2-3, make it easy to retrieve and calculate data from the applications in 
spreadsheets.

Hyperion Retrieve provides access to all numeric data and text in the current 
application, including local headings and comments created with Hyperion 
DataExtend. You can retrieve data from multiple Hyperion Solutions products and 
applications into one worksheet. 

You can also use Hyperion Retrieve with Hyperion Analyst. This allows you to use 
Hyperion Analyst queries to create Hyperion Retrieve formulas.

Add-in Files 
Before you run Hyperion Retrieve, you must load an add-in file for your 
spreadsheet program. The procedures for loading and unloading the add-in file 
depend on whether you use Microsoft Excel or Lotus 1-2-3.

14
Chapter
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Load or Unload the Microsoft Excel Add-in File 
After you load the Microsoft Excel add-in file, the file stays loaded so that 
Hyperion Retrieve is available whenever you start the spreadsheet program. You 
can unload the file if you want to start the spreadsheet program without Hyperion 
Retrieve.

Load the Microsoft Excel Add-in File

➤ To load the Microsoft Excel add-in file:

1. Select Tools > Add-Ins.

2. Click Browse.

3. Navigate to the CDA directory, located within the Hyperion Solutions 
directory.

4. Select RETXL32.XLL.

5. Click OK.

6. Click OK.

Unload the Microsoft Excel Add-in File

➤ To unload the Microsoft Excel add-in file:

1. Select Tools > Add-Ins.

2. Click the checked box next to Hyperion Retrieve to deselect the add-in.

3. Click OK.

Load or Unload the Lotus 1-2-3 Add-in File 

After you load the Lotus 1-2-3 add-in file, the file stays loaded so that Hyperion 
Retrieve is available whenever you start the spreadsheet program. You can unload 
the file if you want to start the spreadsheet program without Hyperion Retrieve.
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Load the Lotus 1-2-3 Add-in File

➤ To load the Lotus 1-2-3 add-in file:

1. Select File > Add-Ins > Manage Add-Ins.

2. Do one of the following:

� If the list in the Manage Add-Ins dialog box does not include 
RETLOT32.12A, select Register, select RETLOT32.12A, then click 
Open.

� Select RETLOT32.12A.

3. Click Done.

Unload the Lotus 1-2-3 Add-in File

➤ To unload the Lotus 1-2-3 add-in file:

1. Select File > Add-Ins > Manage Add-Ins.

2. Deselect RETLOT32.12A.

3. Click Done.

Retrieve Menu
When you load the Hyperion Retrieve add-in file to Microsoft Excel or Lotus 
1-2-3, the Retrieve menu appears on the menu bar. The following table describes 
the commands on the Retrieve menu. For information on the Help menu 
commands, see Access Online Help on page 360. 

Table 51: Retrieve Menu Commands

Select this 
command... To...

Refresh Refresh worksheets with any new or changed data from 
Hyperion Solutions product applications.

Save Save data from the worksheet to Hyperion Enterprise 
applications.
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Access Online Help
Hyperion Retrieve Help contains the procedural information that is in this guide. 
In addition, it provides immediate online help for each Hyperion Retrieve dialog 
box. You can access Hyperion Retrieve Help in any of these ways:

� From within Hyperion Retrieve, select   Retrieve > Contents to access the 
table of contents.

� From within Hyperion Retrieve, select   Retrieve > Search for Help On to 
search for a specific help topic.

� Press F1 from anywhere in Hyperion Retrieve.

� Press the Help button in any dialog box.

Refresh Worksheets
You refresh worksheets to ensure that they contain the latest values from Hyperion 
Solutions products. For example, suppose that after you retrieve values from a 
Hyperion Enterprise application, another user changes some of those values in the 
application. You can refresh worksheets to retrieve the current values from the 
application and bring the worksheets up-to-date.

CAUTION: Refreshing the active worksheet discards any data changes 
you have made to the worksheet since you last used the 
Retrieve menu to save data to applications. 

Change POV Change the Hyperion Retrieve point of view for one or 
more dimensions.

Paste Value Paste a value from a Hyperion Solutions product 
application in the current worksheet cell.

Open Applications Open a Hyperion Solutions product application.

Table 51: Retrieve Menu Commands(Continued)

Select this 
command... To...
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➤ To refresh worksheets, select Retrieve > Refresh.

Save Data to Applications 
When you run Hyperion Retrieve with a Hyperion Enterprise application, you can 
save data from a worksheet to these applications. For example, suppose you 
retrieve sales values from a Hyperion Enterprise application and then change those 
values in the worksheet, either by typing or using a formula. You can then save the 
new sales values from the worksheet to the current application. 

If you refresh the worksheet, Hyperion Retrieve clears the temporary memory and 
uses the CDAVAL formula to produce the current value from the Hyperion 
Solutions product application.

Tip: Saving data changes does not save the worksheet. To save worksheets, 
you use the File menu in Excel or Lotus 1-2-3.

➤ To save data from the active worksheet to Hyperion Solutions product 
applications, select Retrieve > Save.

Change the Hyperion Retrieve Point of View
Hyperion Retrieve has a point of view that specifies default dimension settings for 
its formulas. The formulas retrieve and calculate values for the point-of-view 
dimension settings from an application unless you specify different settings. For 
example, if the Hyperion Retrieve point-of-view account is 0500, formulas that do 
not specify an account produce values for account 0500. However, you can 
override the Hyperion Retrieve point of view and create a formula that produces 
values for account 0700.

If you change the Hyperion Retrieve point of view, values for the new point of 
view appear immediately in the worksheet. For example, if you change the 
Hyperion Retrieve point-of-view account from 0500 to 0800, the worksheet 
changes to show data for account 0800.
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HDCDARET.INI File

Hyperion Retrieve inherits the current point of view from the HDCDARET.INI 
file. The first time you change the point of view in Hyperion Retrieve, the 
HDCDARET.INI file stores the changed point of view in the section labeled with 
your application’s name. You can edit this file directly to change the Hyperion 
Retrieve point of view without affecting the application point of view.

The following table shows the values you can alter in the [MAIN] section of the 
HDCDARET.INI file. These values control whether Hyperion Retrieve saves 
worksheet changes back to the product database, displays information about 
missing values in the worksheet, or scales values up to the nearest whole number.

Table 52: HDCDARET.INI File Point-of-view Values

This value.... Specifies...

CDAVAL_AllowSave=1 Enabling the bidirectional functionality of the 
CDAVAL function.

CDAVAL_AllowSave=0 Disabling the bidirectional functionality of the 
CDAVAL function.

CDALNK_AllowSave=1 Enabling the bidirectional functionality of the 
CDALNK function.

CDALNK_AllowSave=0 Disabling the bidirectional functionality of the 
CDALNK function.

MissingValues=1 Displaying a “0” for no data, and “ERR” for cell 
errors in the worksheet.

MissingValues=0 Displaying an “N/A” for cells for which there is no 
data, and “ERR” for cell errors in the worksheet.

MissingValues=2 Displaying a “0” in cells for which there is no data, 
and a “0” for cell errors in the worksheet.

ScaledValues=1 Displaying worksheet values in a scaled format if 
the values are scaled in the Hyperion product.

ScaledValues=0 Displaying worksheet values in a non-scaled 
format, even if the values are scaled in the 
Hyperion product.
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Note: If you use Hyperion Retrieve and Hyperion Analyst together, each 
product can have a different point of view. For example, the Hyperion 
Retrieve point-of-view category might be Actual, and the Hyperion 
Analyst worksheet point-of-view category might be Budget.

➤ To change the Hyperion Retrieve point of view:

1. From a worksheet, select Retrieve > Change POV.

2. Select the tab for a dimension.

3. Select a point-of-view setting for the dimension.

4. Click OK.

Paste Values
You use the Paste Value menu command to insert a Hyperion Retrieve formula 
into a cell. The inserted formula uses the CDAVAL function to retrieve the value 
for a point of view. You can specify a point of view for the value that overrides the 
Hyperion Retrieve point of view. For more information on the CDAVAL function, 
see CDAVAL - Produce Values from Hyperion Applications on page 380.

➤ To paste a value:

1. From the worksheet cell where you want to show the value, select Retrieve > 
Paste Value.

2. Select a point of view for the value.

3. Click OK.

Open Applications 
You open a Hyperion Solutions product application so you can retrieve data with 
Hyperion Retrieve. Several applications can be open at one time. For example, you 
can open the Hyperion Enterprise applications Tax and Legal to retrieve data from 
both applications for use in one worksheet.

If you have Hyperion Retrieve loaded while using Hyperion Analyst, the open 
applications in Hyperion Analyst are also open in Hyperion Retrieve. You can use 
the Hyperion Retrieve menu to open an additional application.
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➤ To open an application:

1. From a worksheet, select Retrieve > Open Applications.

2. If you currently have an application open and want to open an additional 
application, click Other.

3. If prompted, do the following:

� Select a Hyperion Solutions product and application set or reporting 
application name, depending on which Hyperion application you are 
using.

� Type your user ID and password for the application.

� Click OK.

Hyperion Retrieve Formulas
Hyperion Retrieve uses formulas that contain functions and parameters to retrieve 
and calculate data from Hyperion Solutions product applications. When you paste 
a value in a worksheet cell, a formula using the CDAVAL function appears in the 
Excel or Lotus 1-2-3 formula bar. You can also type and edit formulas.

Note: In Excel, you can select the Paste function option to create Hyperion 
Retrieve formulas. For more information about pasting functions, see 
Microsoft Excel online Help.

A Hyperion Retrieve formula consists of a Hyperion Retrieve function followed 
by these items:

� A Hyperion Solutions product name

� An application set name or reporting application name

� An application name

� Any additional parameters for the function

For example, a formula for the CDADES function, which produces descriptions 
for specified dimension settings, might look like this:

CDADES("Enterprise:Tax","CAT ACTUAL ENT USA")

The CDADES function is followed by the Hyperion product name, the application 
set name, a category ID, and an entity. The formula produces this text:

Actual Data United States Operations
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For information about the parameters and the formats for individual functions, see 
Hyperion Retrieve Functions on page 365. 

Hyperion Retrieve Functions
This table briefly describes the Hyperion Retrieve functions you use in formulas 
to retrieve and calculate data from Hyperion Solutions product applications.

Table 53: Hyperion Retrieve Functions 

Use this function... To...

CDABET Compare two values and show the result as a positive or 
negative number.

CDACAL Return a 1 if a specified point of view is calculated, or a -1 if 
it is not.

CDACHG Show the difference between two values.

CDADES Retrieve descriptions for specified dimension settings.

CDAINP Return a 1 if a specified point of view is an input point of 
view, or a -1 if it is not.

CDAKEY Create a placeholder you can select to display a dialog box 
for changing a dimension setting.

CDALAB Retrieve IDs for specified dimensions.

CDALNK Write values from the worksheet to Hyperion Enterprise 
applications.

CDAPAB Show the percentage difference between two values for a 
specified account. The difference appears with a plus sign ( 
+) if it is positive or a minus sign ( - ) if it is negative.

CDAPBE Show the percentage increase or decrease between two 
values, specifically for assets and liabilities.

CDAPCH Show the percentage change between two values without 
evaluating whether the change is positive or negative.

CDAPCT Show the contribution of one value to another. 



366 �

Hyperion Retrieve

Hyperion Enterprise Reporting Windows Client User’s Guide

CDABET - Compare Values for Two IDs 
The CDABET function compares the values for two IDs in any dimension, using 
the Hyperion Retrieve point of view for the other dimensions. For example, you 
can use the CDABET function to compare May and June values. It produces the 
result of the comparison as a positive or negative number. Use this format:

CDABET("Product:AppSet:Application","POV1","POV2")

This example shows the correct format to use to specify a Hyperion application in 
the formula. If this line appears in the DRIVERS32 section, you identify the 
product as Enterprise in the formula:

Enterprise=HPRED32.DLL, 

CDASTR Produce text from heading functions.

CDAVAL Retrieve a value from an application so that if you change 
the value you can write your change to the application.

Where... Is...

Product The name of a Hyperion Solutions product, which must match 
the name for the same product in the DRIVERS or DRIVERS32 
section of your REPENG.INI file. 

AppSet The name of an application set or reporting application name for 
the specified product.

Application The name of an application for the specified Hyperion Solutions 
product.

POV1 One or more dimensions and IDs for the first value in the 
comparison.

POV2 One or more dimensions and IDs for the second value in 
the comparison.

Table 53: Hyperion Retrieve Functions (Continued)

Use this function... To...
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CDABET Example Formula

CDABET uses the Hyperion Retrieve point of view for all dimension settings that 
you do not specify in the formula. For example, this formula compares the Actual 
and Budget values from the Hyperion Enterprise application Tax:

CDABET("Enterprise:Tax","CAT ACTUAL","CAT BUDGET")

Note: The system evaluates the difference between the values based on the 
account type. If you specify an income or an asset account and the 
second value is greater than the first, the result is negative. If you 
specify an expense or a liability account and the second value is 
greater than the first, the result is positive. 

CDACAL - Specify Calculated Point of View
The CDACAL function returns and shows a 1 if the specified point of view is a 
calculated point of view, or a -1 if it is not. Use this format:

CDACAL("Product:AppSet:Application","POV")

CDACAL Example Formula

This example shows the correct format to use. In this case, CDACAL returns a 1 
because for the entity USWEST in the Hyperion product application, the Total 
Sales account is a calculated account:

CDACAL (“ENTERPRISE:DEMO”,”ENT US WEST CAT ACTUAL ALL TOTSALES”)

Where... Is...

Product The name of a Hyperion Solutions product, which must match the 
name for the same product in the DRIVERS or DRIVERS32 section 
of your REPENG.INI file. 

AppSet The name of an application set or reporting application name for the 
specified product.

Application The name of an application for the specified product.

POV One or more dimensions and IDs.
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CDACHG - Show the Difference Between Values
The CDACHG function compares two values and shows their difference. Use this 
format:

CDACHG("Product:AppSet:Application","POV1","POV2")

This example shows the correct format to use to specify a Hyperion application in 
the formula. If this line appears in the DRIVERS32 section, you identify the 
product as Enterprise in the formula:

Enterprise=HPRED32.DLL, 

CDACHG Example Formula

This formula compares the values for the USA and CANADA entities in the 
Hyperion Enterprise application Tax, using the Hyperion Retrieve point of view 
for all dimensions other than entity:

CDACHG("Enterprise:Tax","ENT USA","ENT CANADA") 

CDADES - Show Descriptions for Dimension 
Settings

The CDADES function produces the descriptions for specified dimension settings. 
Use this format:

Where... Is...

Product The name of a Hyperion Solutions product, which must match the 
name for the same product in the DRIVERS or DRIVERS32 section 
of your REPENG.INI file. 

AppSet The name of an application set or reporting application name for the 
specified product.

Application The name of an application for the specified product.

POV1 One or more dimensions and IDs for the first value in the comparison.

POV2 One or more dimensions and IDs for the second value in the 
comparison.
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CDADES("Product:AppSet:Application","POV")

This example shows the correct format to use to specify a Hyperion application in 
the formula. If this line appears in the DRIVERS32 section, you identify the 
product as Enterprise in the formula:

Enterprise=HPRED32.DLL, 

CDADES Example Formula

This CDADES formula produces the descriptions for the ACTUAL category and 
the USA entity in the Hyperion Enterprise application Tax:

CDADES("Enterprise:Tax","CAT ACTUAL ENT USA")

If the category description is Actual Data and the entity description is United 
States Operations, the formula produces this text:

Actual Data United States Operations

CDAINP - Specify Input Point of View
The CDAINP function returns and shows a 1 if a specified point of view is an input 
point of view, or a -1 if it is not. Use this format:

Where... Is...

Product The name of a Hyperion Solutions product, 
which must match the name for the same 
product in the DRIVERS or DRIVERS32 
section of your REPENG.INI file. 

AppSet The name of an application set or reporting 
application name for the specified product.

Application The name of an application for the specified 
product.

POV One or more dimensions and IDs.
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CDAINP("Product:AppSet:Application","POV")

CDAINP Example Formula

This example shows the correct format to use. In this case, CDACAL returns a 1 
because for the entity USWEST in the Hyperion product application, the Total 
Sales account is an input account:

CDACAL (“ENTERPRISE:DEMO”,”ENT US WEST CAT ACTUAL ALL TOTSALES”)

CDAKEY - Change Dimension Settings
The CDAKEY function produces a placeholder that you can select to display a 
dialog box where you can change a dimension setting. Using the CDAKEY 
format, you set up a default value.

Note: From Excel, the dialog box appears only if Hyperion Analyst is 
loaded with Hyperion Retrieve.

Use this format:

CDAKEY("Product:AppSet:Application","Dimension ID")

Where... Is...

Product The name of a Hyperion Solutions product, which must 
match the name for the same product in the DRIVERS or 
DRIVERS32 section of your REPENG.INI file. 

AppSet The name of an application set or reporting application name 
for the specified product.

Application The name of an application for the specified product.

POV One or more dimensions and IDs.

Where... Is...

Product The name of a Hyperion Solutions product, which must match 
the name for the same product in the DRIVERS or 
DRIVERS32 section of your REPENG.INI file. 

AppSet The name of an application set or reporting application name 
for the specified product.

Application The name of an application for the specified product.
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This example shows the correct format to use to specify a Hyperion application in 
the formula. If this line appears in the DRIVERS32 section, you identify the 
product as Enterprise in the formula:

Enterprise=HPRED32.DLL, 

CDAKEY Example Formula

This formula produces the entity ID USA from the Hyperion Enterprise 
application Tax to act as a placeholder in a cell:

CDAKEY("Enterprise:Tax","ENT USA")

CDALAB - Produce IDs for Specified 
Dimensions 

The CDALAB function produces the IDs for specified dimensions. Use this 
format:

CDALAB("Product:AppSet:Application","POV")

Dimension A dimension.

ID An ID for the specified dimension.

Where... Is...

Product The name of a Hyperion Solutions product, which must match the 
name for the same product in the DRIVERS or DRIVERS32 
section of your REPENG.INI file. 

AppSet The name of an application set or reporting application name for 
the specified product.

Application The name of an application for the specified product.

POV One or more dimensions and IDs.

Where... Is...
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This example shows the correct format to use to specify a Hyperion application in 
the formula. If this line appears in the DRIVERS32 section, you identify the 
product as Enterprise in the formula:

Enterprise=HPRED32.DLL, 

CDALAB Example Formula

This formula produces category and entity IDs from the Hyperion Enterprise 
application Tax:

CDALAB("Enterprise:Tax","CAT ACTUAL ENT USA")

If the category description is Actual Data and the entry description is United 
States, the formula produces this text:

ACTUAL USA 

CDALNK - Send Values to Hyperion Applications
The CDALNK function sends a value from a worksheet to a Hyperion Enterprise 
application when you use the Retrieve menu to save data. Use this format:

CDALNK("Product:AppSet:Application",Value,"POV")

This example shows the correct format to use to specify a Hyperion application in 
the formula. For example, if this line appears in the DRIVERS32 section, you 
identify the product as Enterprise in the formula:

ENTERPRISE=HPRED32.DLL, 

Where... Is...

Product The name of a Hyperion Solutions product, which must match the 
name for the same product in the DRIVERS or DRIVERS32 section 
of your REPENG.INI file. 

AppSet The name of an application set for the specified product.

Application The name of an application for the specified Hyperion Solutions 
product.

Value A number or a cell reference.

POV One or more dimensions and IDs to override the Hyperion Retrieve 
point of view.



Hyperion Retrieve

� 373Hyperion Enterprise Reporting Windows Client User’s Guide

14

CDALNK Example Formula

This formula sends the value in cell A20 to the 0500 account’s OCT97 value in the 
Tax application from the Hyperion Enterprise application Worldwide:

CDALNK("Enterprise:Worldwide:Tax",A20,"ACCOUNT 0500 PERIOD 
OCT97") 

Note: You can also change data in the application by typing new values in 
cells containing CDAVAL formulas. For more information, see Save 
Data to Applications on page 361.

CDAPAB - Show the Percentage Difference 
Between Account Values 

You use the CDAPAB function to return the percentage difference between two 
values for a specified account. The difference appears with a plus sign ( + ) if it is 
positive or a minus sign ( - ) if it is negative. 

Note: The CDAPAB function differs from the CDAPBE function in that 
increased assets yields a positive and an increase in liabilities yields 
a negative. 

Use this format:

CDAPAB("Product:AppSet:Application",”Account”,"Value1","Value2")

Where... Is...

Product The name of a Hyperion Solutions product, which must match the 
name for the same product in the DRIVERS or DRIVERS32 section 
of your REPENG.INI file. 

AppSet The name of an application set or reporting application name for the 
specified product.

Application The application label.

Account The account label.

Value1 A formula, number, or cell reference for the first value.

Value2 A formula, number, or cell reference for the second value.
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This example shows the correct format to use to specify a Hyperion application in 
the formula. If this line appears in the DRIVERS32 section, you identify the 
product as Enterprise in the formula:

Enterprise=HPRED32.DLL, 

CDAPAB Example Formula

Suppose you want to return the percentage difference between the October 1994 
and November 1994 values of the Cost of Goods Sold account for the Tax 
application. If the account label appears in cell A5 of the worksheet, the November 
1994 value appears in cell D5, the October 1994 value appears in cell C5, and the 
application label appears in cell A1, you could use this formula to return the 
percentage difference between the two values:

CDAPAB(A1,A5,D5,C5,)

You could also use the CDAPAB function to return the percentage difference 
between an account’s values for two different categories or entities in the same 
period. For example, you might want to show the percentage difference between 
the Cash account’s February values in the Actual and Last Year categories, or the 
percentage difference between its values for the Italy and France entities.

Note: The system evaluates the difference between the two values based on 
the account type. If you specify an income or a liability account and 
the second value is greater than the first, the result is negative. If you 
specify an expense or an asset account and the second value is greater 
than the first, the result is positive.
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CDAPBE - Show the Percentage Difference 
Between Values

The CDAPBE function compares two values and shows the difference between 
them as a positive or negative percentage. Use this format:

CDAPBE("Product:AppSet:Application","POV1","POV2")

This example shows the correct format to use to specify a Hyperion application in 
the formula. If this line appears in the DRIVERS32 section, you identify the 
product as Enterprise in the formula:

Enterprise=HPRED32.DLL, 

CDAPBE Example Formula

For example, this formula compares the Q1 and Q2 periods in the Hyperion 
Enterprise application Tax and shows the difference as a positive or negative 
percentage, using the Hyperion Retrieve point of view for all other dimensions:

CDAPBE("Enterprise:Tax","DAT Q1","DAT Q2")

Note: The system evaluates the difference between the two values based on 
the account type. If you specify an income or an asset account and the 
second value is greater than the first, the result is negative. If you 
specify an expense or a liability account and the second value is 
greater than the first, the result is positive. 

Where... Is...

Product The name of a Hyperion Solutions product, which must match the 
name for the same product in the DRIVERS or DRIVERS32 section 
of your REPENG.INI file. 

AppSet The name of an application set or reporting application name for the 
specified product.

Application The name of an application for the specified product.

POV1 One or more dimensions and IDs for the first value in the comparison.

POV2 One or more dimensions and IDs for the second value in the 
comparison.
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CDAPCH - Show the Percentage Change 
Between Two Values

The CDAPCH function shows the percentage change between two values without 
evaluating whether the change is positive or negative. The system uses this 
formula:

Value 1 - Value 2  x 100

       Value 2

You might use the CDAPCH function to calculate the percentage change between 
an account’s values for two periods, regardless of account type. You might also use 
it to calculate the percentage change between an account’s values in the same 
period for two different categories or two different entities. The system does not 
evaluate whether the percentage change is positive or negative.

Use this format:

CDAPCH("Product:AppSet:Application",”Value1”,”Value2”) 

This example shows the correct format to use to specify a Hyperion application in 
the formula. If this line appears in the DRIVERS32 section, you identify the 
product as Enterprise in the formula:

Enterprise=HPRED32.DLL, 

Where... Is...

Product The name of a Hyperion Solutions product, which must match the 
name for the same product in the DRIVERS or DRIVERS32 section 
of your REPENG.INI file. 

AppSet The name of an application set or reporting application name for the 
specified product.

Application The application label.

Value1 A formula, number, or cell reference for the first value.

Value2 A formula, number or cell reference for the second value.
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CDAPCH Example Formula

For example, suppose you want to return the percentage change between the 
October 1994 and October 1995 values of an account for the Tax application. If 
the account’s October 1995 value appears in cell D5 of the worksheet and the 
account’s October 1994 value appears in cell C5, you could use this formula to 
return the percentage change between the values:

CDAPCH("TAX",D5,C5)

CDAPCT - Calculate Percentages
The CDAPCT function calculates the percentage that one value represents of a 
second value. Use this format:

CDAPCT("Product:AppSet:Application","POV1","POV2")

This example shows the correct format to use to specify a Hyperion application in 
the formula. If this line appears in the DRIVERS32 section, you identify the 
product as Enterprise in the formula:

Enterprise=HPRED32.DLL, 

Where... Is...

Product The name of a Hyperion Solutions product, which must match the 
name for the same product in the DRIVERS or DRIVERS32 
section of your REPENG.INI file. 

AppSet The name of an application set or reporting application name for 
the specified product.

Application The name of an application for the specified product.

POV1 One or more dimensions and IDs for the first value in the 
calculation.

POV2 One or more dimensions and IDs for the second value in the 
calculation.
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CDAPCT Example Formula

This formula shows the percentage that the NJ value represents of the USA value 
in the Hyperion Enterprise application Tax, using the Hyperion Retrieve point of 
view for all other dimensions:

CDAPCT("Enterprise:Tax","ENT NJ","ENT USA") 

CDASTR - Use Heading Functions to Produce 
Text

The CDASTR function uses heading functions from Hyperion Solutions products 
to produce text. Use this format:

CDASTR("Product:AppSet:Application","POV","Function")

This example shows the correct format to use to specify a Hyperion application in 
the formula. If this line appears in the DRIVERS32 section, you identify the 
product as Enterprise in the formula:

Enterprise=HPRED32.DLL, 

Where... Is...

Product The name of a Hyperion Solutions product, which must match the 
name for the same product in the DRIVERS or DRIVERS32 section 
of your REPENG.INI file. 

AppSet The name of an application set or reporting application name for the 
specified product.

Application The name of an application for the specified product.

POV One or more dimensions and IDs. If you are retrieving text for the 
Hyperion Retrieve  point of view with no overrides, you can use a 
pair of double quotation marks ("") with nothing between them 
instead of specifying a dimension name and ID.

Function A heading function that produces text for the specified dimensions, 
with parameters for the heading function.
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CDASTR Example Formula

This formula produces the description for the currency of the Canada entity in the 
Hyperion Enterprise application Tax:

CDASTR("Enterprise:Tax","ENT CANADA","@CURCY(LONG)")

If the description for the currency is Canadian Dollars, the formula produces this 
text:

Canadian Dollars

You can set up the following formula to let spreadsheet users select a point of 
view. Double-clicking on a cell that contains this formula displays a dialog box 
where users can change the point of view for a dimension:

CDASTR("Product:AppSet:Application","Function
(Dimension)")

This formula produces a dialog box where you can change the point of view for 
the Hyperion Enterprise application Tax, then produces the ID for the point of 
view account:

CDASTR("Enterprise:Tax","","@LAB(ACCOUNT)") 

Where... Is...

Product The name of a Hyperion Solutions product, which must match the 
name for the same product in the DRIVERS or DRIVERS32 
section of your REPENG.INI file.

AppSet The name of an application set or reporting application name for 
the specified product.

Application The name of an application, or database, for the specified product.

From Excel, the dialog box appears only if Hyperion Analyst is 
loaded with Hyperion Retrieve.

Function A heading function that produces text for the specified dimensions, 
with parameters for the heading function.

Dimension A dimension name.
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CDAVAL - Produce Values from Hyperion 
Applications

The CDAVAL function produces a specific value from a Hyperion Solutions 
product application. You can change the value in an application by typing a new 
value in the worksheet cell and then using the Retrieve menu to save the worksheet 
data. Use this format:

CDAVAL("Product:AppSet:Application","Dimension1 ID1"[,...,"Dimensionn 
IDn"]")

This example shows the correct format to use to specify a Hyperion application in 
the formula. For example, if this line appears in the DRIVERS32 section, you 
identify the product as Enterprise in the formula:

ENTERPRISE=HPRED32.DLL, 

CDAVAL Example Formula
This formula retrieves the Actual value of the PLNI account for the United States 
entity from the Hyperion Enterprise application Tax, using the Hyperion Retrieve 
point of view for all other dimensions:

CDAVAL("Enterprise:Tax","CAT ACTUAL ACC PLNI ENT USA")

You can also use the CDAVAL function to save data to an application database. 
For more information, see Save Data to Applications on page 361.

Where... Is...

Product The name of a Hyperion Solutions product, which must match the 
name for the same product in the DRIVERS or DRIVERS32 section 
of your REPENG.INI file. 

AppSet The name of an application set for the specified product.

Application The name of an application, or database, for the specified product.

Dimension1 The first dimension to override the Hyperion Retrieve point of view.

ID1 An ID for the first dimension to override the Hyperion Retrieve point 
of view.

Dimensionn The last dimension to override the Hyperion Retrieve point of view.

IDn An ID for the last dimension to override the Hyperion Retrieve point 
of view.
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Hyperion DataExtend

Hyperion DataExtend is a Hyperion Enterprise product that stores textual 
comments for individual enterprise detail and local headers. The information in 
DataExtend is stored in an .MDB file outside of the Hyperion database. 

Hyperion DataExtend allows you to enter text in Hyperion Schedules and include 
it in reports as data or headings. Hyperion DataExtend adds the following features 
to Hyperion Enterprise Reporting Windows Client:

� Notations, which are text entries such as descriptions or comments

� Local headings, which replace the descriptions of individual dimensions based 
on the other dimension settings in the report

You use Hyperion DataExtend and Hyperion Retrieve for Reporting to set up 
custom fields. These fields can vary by period, entity, subentity, or any other 
dimension. You enter text for the fields in Hyperion Schedules, and you can 
include the text in the report output. 

For example, you might create a field called Notes1 to include notations, such as 
reasons for increases or decreases, on the Gross Margin account for different 
entities, periods, and categories. You insert the Notes1 field in a row or column of 
a report, then use Hyperion Schedules to enter notations on the Gross Margin 
results for each entity and period. You can then run reports that include the 
notations.

You can assign a text field to replace the description of a dimension depending on 
the other dimensions in the point of view or the report. For example, suppose a 
chart of accounts includes the account Product 1 Sales. In the Eastern Division, 
Product 1 represents printers, while in the Western Division, Product 1 represents 
modems. You can create a field called Local Accounts to store alternative 
descriptions for accounts for the different entities in an organization. For Product 
1 Sales, the Eastern Division uses the local description Printer Sales, while the 
Western Division uses the description Modem Sales. 

15
Chapter
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You can use notations and local headings in Hyperion Enterprise Reporting 
Windows Client, Hyperion Retrieve for Reporting, and Hyperion Analyst. The 
following table shows the tasks involved in using notations and local headings, and 
where you perform those tasks.

For more information, see the Hyperion Enterprise Reporting Windows Client 
User’s Guide.

Start Hyperion DataExtend
You should have a basic understanding of the Microsoft Windows environment 
before you start Hyperion DataExtend. If you do not have experience using 
Windows, see the Microsoft Windows User's Guide.

When you install Hyperion DataExtend, an icon is set up for Hyperion DataExtend 
in the Hyperion Enterprise program group. The properties for the Hyperion 
DataExtend icon specify the path to the executable file in the Windows Command 
Line field.

Table 54: Tasks for Notations and Local Headings

Use... To...

Hyperion DataExtend Set up fields to use for notations or local headings.

Hyperion Schedules Enter text for notations and local headings. For more 
information, see the Hyperion Schedules User’s 
Guide.

Hyperion Enterprise 
Reporting Windows 
Client

Create reports that you use for the following tasks:

• Entering text for notations and local headings in 
Hyperion Schedules

• Presenting data with notations and local headings

Hyperion Analyst View notations and local headings during data 
analysis.
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When you start Hyperion DataExtend, you select a Hyperion Enterprise 
application and specify your user ID and password to access the application. For 
instructions on changing a user ID in Hyperion Enterprise, see the Hyperion 
Enterprise Administrator’s Guide. For instructions on changing a password in 
Hyperion Enterprise, see the Hyperion Enterprise User’s Guide.

Note: You can access only one Hyperion Enterprise application at a time 
from within Hyperion DataExtend.

➤ To start Hyperion DataExtend:

1. From Windows, double-click on the Hyperion DataExtend icon.

2. From Hyperion DataExtend, if a logon dialog box displays, select a Hyperion 
application, then enter your user ID and password.

3. Click OK.

Exit Hyperion DataExtend
You can exit Hyperion DataExtend to end the work session and return to 
Windows. 

➤ To exit Hyperion DataExtend, select File > Exit.

System Menus
Many tasks that you perform in Hyperion DataExtend involve selecting options 
from menus. The following sections describe the system menus.

File Menu
You use the File menu options to load and extract notations and local headings, 
switch to Hyperion Enterprise and exit Hyperion DataExtend.

Edit Menu
You use the Edit menu options to access the Edit Fields dialog box, which allows 
you to manage fields for notations and local headings.
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View Menu
You use the View menu options to display or hide the toolbar and the status bar in 
the Hyperion DataExtend window.

Help Menu
You use the Help menu options to access Hyperion DataExtend Help and the 
Hyperion DataExtend User’s Guide (.PDF), as well as version and copyright 
information. 

Toolbar
The toolbar provides quick mouse access to the most frequently used menu items 
in Hyperion DataExtend. The toolbar appears directly below the menu bar. You 
display or hide the toolbar by selecting or deselecting the Toolbar option on the 
View menu. The following table describes the toolbar icons.

Fields for Notations and Local Headings
To set up notations and local headings, you create fields in Hyperion DataExtend. 
The fields that you create are available as field dimensions in Hyperion Enterprise 
Reporting Windows Client, Hyperion Schedules, Hyperion Retrieve for 

Table 55: Toolbar Icons

Icon... Description...

The Load toolbar icon allows you to load data into text fields. It 
works the same as the File > Load menu item. 

The Extract toolbar icon allows you to extract data from text fields. It 
works the same as the File > Extract menu item. 

The Edit Fields toolbar icon allows you to access the Edit Fields 
dialog box to modify text fields. It works the same as the 
Edit > Fields menu item.
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Reporting, and Hyperion Analyst. You can insert them in the columns, rows, or 
point of view in a report, then use the report for data entry in Hyperion Schedules 
and for presenting information in Hyperion Enterprise Reporting Windows Client. 

Unlike standard Hyperion Enterprise Reporting Windows Client fields, which 
support numeric values only, fields created in Hyperion DataExtend support 
alphanumeric characters. Here are some uses for the field data in reports:

� Create notations to comment on data values such as unusual results.

� Create local headings to provide product detail for the different entities in an 
organization.

� Manage fields for notations and local headings by creating fields and deleting 
fields that you no longer need.

Create Fields
You create fields in Hyperion DataExtend to allow text to supplement Hyperion 
data. You can use the fields as notations only, or as alternative headings in reports.

Note: Once you create a field, the attributes cannot change.

When you create a field, you define the dimensions by which it can vary in reports. 
This determines where you can place the field in a report to produce data. For 
example, to enter comments for different periods and accounts, you create a field 
that varies by period and account.

➤ To create a field:

1. From the Hyperion DataExtend window, select Edit > Fields.

2. Select the New icon.

3. Type an ID and description for the field, then select the dimensions by which 
the field varies.

4. To save your changes, click Apply.

5. Repeat steps 2 through 4 for each field that you want to create.

6. When you finish creating fields, click Close.
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Delete Fields
You delete fields from an application when you no longer need the fields to 
supplement the Hyperion database. When you delete a field, you delete all data in 
the application that is associated with that field.

➤ To delete a field:

1. From the Hyperion DataExtend window, select Edit > Fields.

2. Select the field that you want to delete.

3. Click the Delete icon and click Yes to delete the field.

4. Repeat steps 2 and 3 for each field that you want to delete.

5. When you finish deleting fields, click OK.

Field Data Load and Extract
You can load alphanumeric data from text files and extract alphanumeric data to 
text files. This allows you to add fields, notations, or local headings quickly or to 
share the information between applications. The text files for loading and 
extracting field data contain the following two sections:

� The FIELD DEFINITIONS section contains information about the fields 
defined in Hyperion DataExtend.

� The DATA VALUES section contains the alphanumeric data for the fields.

Field Definitions Section
Use this format to specify each field in the FIELD DEFINITIONS section of a 
field data load and extract file:

FIELD=ID

DESC=Description

TEXTFUNCTIONOVERRIDE=Function Override

READONLYIFCALCULATED=Read

TYPE=Text
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DIMENSIONS=Dimensions

Data Values Section
Use this format to specify each field in the DATA VALUES section of a field data 
load and extract file:

POV=Dimension1=ID1,Dimension2=ID2, .. .. .. Dimension=IDn,Field=
FieldID

DATA=Text

Where... Is...

ID The field ID.

Description The field description.

Function Override None or @DES (Dimension).

Read True to make the field read-only for calculated or 
consolidated data, or False to allow text entries for 
calculated and consolidated data.

Text The text that is entered.

Dimensions The dimensions by which the field varies.

Where... Is...

Dimension1 The first dimension by which the field varies, such as entity, 
account, or period.

ID1 The ID of the specified first dimension. For example, if 
Dimension1 is Account, then ID1 might be SALES.

Dimension2 The second dimension by which the field varies, such as entity, 
account, or period.

ID2 The ID of the specified second dimension. For example, if 
Dimension2 is Period, then ID2 might be FEB.

Dimension The last dimension by which the field varies, such as entity, 
account, or period.

IDn The ID of the specified last dimension. For example, if 
Dimension is SubAcc1, then IDn might be EQUIP.



388 �

Hyperion DataExtend

Hyperion Enterprise Reporting Windows Client User’s Guide

Sample Text File
The following sample shows a field data text file. The file includes the definitions 
and data for two text fields, Comments and Results.

[FIELD DEFINITIONS]

FIELD=Comments

DESC=Comments on data

TEXTFUNCTIONOVERRIDE=None

READONLYIFCALCULATED=True

TYPE=Text

DIMENSIONS=Entity,Account

FIELD=Results

DESC=Management information on data results

TEXTFUNCTIONOVERRIDE=None

READONLYIFCALCULATED=False

TYPE=Text

DIMENSIONS=Entity,Period

[DATA VALUES]

POV=Entity=CARO,Account=Sales,Field=Comments

DATA=See report7 for detailed results

POV=Entity=CARO,Account=Costsales,
Field=Comments

DATA=See report8 for detailed results

POV=Entity=UTAH,Account=Sales,Field=Comments

DATA=Code 224

FieldID The ID of the field.

Text The alphanumeric data for the specified field and dimensions.

Where... Is...
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POV=Entity=UTAH,Account=Costsales,
Field=Comments

DATA=Code 226

POV=Entity=CARO,Period=FEB,Field=Comments

DATA=note dramatic increase

POV=Entity=CARO,Period=MAR,Field=Comments

DATA=increase reported by JHOBBES

POV=Entity=UTAH,Period=FEB,Field=Comments

DATA=no change

POV=Entity=CARO,Period=MAR,Field=Comments

DATA=slight decrease, climate

Load Field Data
You can use Hyperion DataExtend to load alphanumeric data from a text file into 
the fields in an application. This is a quick way to add a large number of notations 
or local headings. The files from which you load field data must follow a specific 
format. You can delete existing data before you load new data. For information, 
see the Field Data Load and Extract topic in this chapter.

➤ To load field data:

1. From the Hyperion DataExtend window, select File > Load or the Load 
toolbar icon.

2. Type the path and name of the file from which to load field data.

Tip: If you do not know the name or location of the file, you can select 
the Browse icon, search for the appropriate path, select the file, 
then select OK.

3. Click Apply to load the field data.
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Extract Field Data
You can extract field data from an application to a text file to share the information 
with other applications. When you extract field data, the information in the text file 
must follow a specific format. For information, see the Field Data Load and 
Extract topic in this chapter.

➤ To extract field data:

1. From the Hyperion DataExtend window, select File > Extract or the Extract 
toolbar icon.

2. Type the path and name of the file from which to extract field data.

Tip: If you do not know the name or location of the file, you can select 
the Browse icon, search for the appropriate path, select the file, 
then click OK.

3. Click Apply to extract the field data.

Frequently Asked Questions
This chapter provides the answers to commonly asked questions about Hyperion 
DataExtend that are not covered in the other sections of this guide. 

If you are experiencing additional problems, or have questions that are not covered 
in this chapter, refer to the Hyperion DataExtend Release Notes that came with this 
guide. 

Why doesn’t my edit fields dialog box come up after I have 
registered the data source? I am using Hyperion Enterprise 
4.2 16 bit.

You must be using the 16 bit driver which is either the Microsoft Access or the 
Microsoft Access 2.0 driver. In addition, the name of the file is 
ODBCJCT16.DLL.
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After registering the Microsoft Access driver, 
ODBCJCT16.DLL, the edit fields dialog box does not come up. 
What should I do?

Make sure you adhere to the following two guidelines:

� Be sure the .MDB file has the exact same name and syntax as the Hyperion 
Enterprise program. For example, a Hyperion Enterprise application named 
SBankss must have an .MDB file named SBankss.

� SBANKSS .MDB file must reside in the application directory.

I originally wanted to see comments on an account level, but I 
changed my mind. I want to see them at a subaccount level. I 
changed the DataExtend field to check off subaccounts and 
this does not work. Why?

You cannot edit an existing DataExtend field. You must create a new field.
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Hyperion Schedules

Hyperion Schedules is a spreadsheet interface that translates Hyperion Enterprise 
or Hyperion Essbase reports into forms for data entry. You use Hyperion 
Schedules to enter and modify data in reports that you create in Hyperion 
Enterprise Reporting Windows Client.

For example, you can create a report consisting of accounts in the columns and 
entities in the rows. You can then open the report in Hyperion Schedules and 
modify the data for those accounts and entities. The changes that you make affect 
the data in the Hyperion Enterprise or Hyperion Essbase database without 
changing the report structure.

You can also use Hyperion Schedules to enter text for notations and local 
headings. Notations and local headings supplement the numeric data in the reports 
you run in Hyperion Enterprise Reporting Windows Client. You use notations to 
provide explanations for data results or for other information that can enhance your 
reports. Local headings are text that can replace dimension descriptions depending 
on the other dimensions defined in a report or in the point of view. You enter the 
text for notations and local headings in Hyperion Schedules in reports that include 
special text fields defined by your system administrator.

For more information on creating reports in Hyperion Enterprise Reporting 
Windows Client, see Hyperion Enterprise Reporting Windows Client Help. For 
more information on text fields, see Hyperion DataExtend Help.

Applies To:

16
Chapter



394 �

Hyperion Schedules

Hyperion Enterprise Reporting Windows Client User’s Guide

Find Function

The Find function in Hyperion Schedules can search row or column headings for 
text headings. You can search the full name or partial name of a text heading. The 
Find function will find the matching text headings in sequential order.

➤ To find text heading:

1. Select Edit > Find, from the Hyperion Schedules main window.

2. Enter the name or partial name of the text heading in the Find What field.

3. Select Search in Row Headings or Search in Column Headings, then click 
Find Next.

Note: You must click Close to exit the Find Dialog box.

Show Suppressed Row or Column Sorting in 
Hyperion Schedules

In the Show Suppressed Rows and Show Suppressed Columns dialog boxes you 
can alphabetically sort rows and columns. Open and modify theHSCHED.INI file 
to include the following information:

[Default]

SortHiddenRowList=ON or SortHiddenRowList=OFF

SortHiddenColumnList=ON or SortHiddenColumnList=OFF

Note: This feature is OFF by default.

Applies To:
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Customize Point of View Bar

You can customize the point of view bar to turn off pictures. The text can be 
changed to names, descriptions, or none. You can change the font that the 
point-of-view dimension displays. You can turn off the point of view bar buttons 
by deselecting the corresponding dimension name button in the Show Button 
section.

You can click the right mouse button on the point of view bar to display a floating 
menu you can use to access the Customize Point of View Bar dialog box.

➤ To use the Customize Point of View Bar:

1. Select Task > Customize Point of View Bar.

Start Hyperion Schedules from Windows

When you install Hyperion Schedules, you set up an icon for Hyperion Schedules 
in the Windows 3.1 or Windows NT 3.51 Program Manager, or in your Windows 
95 or Windows NT 4.0 desktop in the Hyperion Enterprise or Hyperion Essbase 
program groups. The properties for the Hyperion Schedules icon specify the path 
to the executable file.

When you start Hyperion Schedules, you select a Hyperion Solutions product and 
application, and you specify your user ID and password to open the application. 
You can access only one application at a time. 

Applies To:

Applies To:
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➤ To start Hyperion Schedules from Windows:

1. Double-click on the Hyperion Schedules icon.

2. Select the Hyperion Enterprise application for which you want to modify data.

3. If prompted, type your user ID and password, then click OK.

Exit Hyperion Schedules from Windows

You can exit Hyperion Schedules to end the work session and return to Windows. 
After you exit Hyperion Schedules, you can continue working in Windows or exit 
to DOS.

➤ To exit Hyperion Schedules, select File > Exit.

Note: If you attempt to exit without saving your changes, a prompt appears. 
click Yes to save your changes.

Applies To:
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Hyperion Schedules Window

Hyperion Schedules consists of a single window where you enter and modify data. 
The following figure shows the parts of the Hyperion Schedules window.

Figure 36: Hyperion Schedules window

The header area displays the header that you defined for the report. If a report has 
no header, then the header area does not appear in the Hyperion Schedules 
window.

Applies To:
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The footer area displays the footer that you defined for the report. If a report has 
no footer, the footer area does not appear in the Hyperion Schedules window.

The row headings identify the dimensions in the rows of the report.

The column headings identify the dimensions in the columns of the report.

The data cells display the values from the Hyperion Enterprise database. You can 
enter or modify data in these cells. The colors that you define determine the 
shading of the cells. Gridlines separate the cells by column and row.

After you select a data cell, you can click the right mouse button to change the 
point of view of the active report to that of the selected data cell. You can also open 
a report, or you can use investigations to open the report associated with the 
selected data cell.

The title bar identifies the Hyperion Schedules system. If a report is open, the file 
name of the active report also appears in the title bar.

The menu bar lists the menus you can use to perform different tasks.

The status bar shows information about the current report, such as which rows and 
columns are selected in the spreadsheet.

The toolbar provides quick mouse access to the most frequently used menu items 
in Hyperion Schedules. 

The point of view bar shows the default dimensions for the current session. It 
provides quick mouse access to the Point of View dialog box in Hyperion 
Schedules. You can change the point of view at any time during a session. 

System Menus

Many of the tasks you perform in Hyperion Schedules involve selecting items 
from menus using either the mouse or the keyboard. The availability of some menu 
items can vary based on the selection in the Hyperion Schedules window.

Applies To:



Hyperion Schedules

� 399Hyperion Enterprise Reporting Windows Client User’s Guide

16

File Menu
You use the File menu to open, print, and close reports; to save changes that you 
made to the database; and to exit Hyperion Schedules.

Edit Menu
You use the Edit menu to modify the data in the report and to set the point of view. 
You can cut, copy, or paste data in Hyperion Schedules. The availability of the cut, 
copy, and paste items on the Edit menu depends on the selection in the window 
and on the contents of the clipboard. 

Options Menu
You use the Options menu to perform Hyperion Schedules tasks. From the Options 
menu, you can calculate formulas to see the values for calculated accounts. You 
can also show suppressed rows or columns so that you can enter data into them.

View Menu
You use the View menu to display or hide the toolbar, point of view bar, status bar, 
gridlines, header area, and footer area in the Hyperion Schedules window.

Help Menu
You use the Help menu to access Hyperion Schedules Help, as well as version and 
copyright information. 



400 �

Hyperion Schedules

Hyperion Enterprise Reporting Windows Client User’s Guide

Toolbar

The toolbar provides quick mouse access to the most frequently used menu options 
in Hyperion Schedules. It appears directly below the menu bar. You display or 
hide the toolbar by selecting or deselecting the Toolbar option on the View menu. 

Applies To:

Table 56: Toolbar 

Icon Menu Command Description

File > Open The Open toolbar icon allows you to open 
an existing report.

File > Save The Save toolbar icon allows you to save 
changes that you made to the data. 

File > Print The Print toolbar icon allows you to print 
the open report with the current data. 

File > Print Preview The Print Preview toolbar icon allows you 
to preview the open report on your screen. 

Edit > Cut The Cut toolbar icon allows you to cut the 
selected data and place it in the clipboard.

Edit > Copy The Copy toolbar icon allows you to copy 
the selected data and place it in the 
clipboard. 

Edit > Paste The Paste toolbar icon allows you to paste 
the data from the clipboard to the selected 
data cells.

Options > Calculate 
Formulas

The Show Suppressed Rows toolbar icon 
allows you to display rows that are 
suppressed, that are hidden, or do not 
contain data. 
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Right Mouse Button

The right mouse button provides quick access to a menu with a list of functions 
and reports. You can access the menu by selecting a data cell within a report and 
then clicking the right mouse button.

Note: Use the right mouse button if your mouse is configured for a 
right-handed person. If your mouse is configured for a left-handed 
person, use the left mouse button instead.

Options > Show 
Suppressed Rows

The Show Suppressed Rows toolbar icon 
allows you to display rows that are 
suppressed, hidden, or that contain no data. 

Options > Show 
Suppressed Columns

The Show Suppressed Columns toolbar icon 
allows you to display columns that are 
suppressed, or do not contain data.

Help The Help toolbar icon allows you to access 
Hyperion Schedules Help.

Applies To:

Function... Description...

Open Allows you to open an existing report. It works the same 
as the File > Open menu option.

Change POV Using 
Selected Cell 

Allows you to change the point of view of the active 
report to that of the selected data cell.

Change the POV Using 
Selected Cell and Open 

Allows you to open another report and change its point 
of view to that of the selected data cell.

Table 56: Toolbar (Continued)

Icon Menu Command Description
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Application and Point of View

The application and the point of view determine the data that you access during a 
work session. You access data for only one Hyperion Enterprise or Hyperion 
Essbase application at a time. You select an application when you start Hyperion 
Schedules, and you can switch applications at any time. The point of view 
determines which data Hyperion Schedules accesses within the application. The 
columns and rows of a report can specify many dimensions that define Hyperion 
Enterprise data. The system retrieves the dimensions not defined in the columns 
and rows from the point of view. For more information, see Hyperion Enterprise 
Reporting Windows Client Help.

Note: Entities are called names in early versions of Hyperion Enterprise.

By default, when you start Hyperion Schedules, the system uses the point of view 
that you last set in Hyperion Enterprise. The point of view allows you to select a 
different default entity, category, period, frequency, view, account, and field for 
your current work session. For more information on setting the point of view in 
Hyperion Enterprise, see the Hyperion Enterprise User’s Guide. 

Note: In Hyperion Enterprise, the point of view also allows you to select a 
different default consolidation detail, parent, and currency for your 
current work session.

Investigation Allows you to open the report associated with the 
selected data cell. You can use investigations to 
associate a cell with a report in Hyperion Enterprise 
Reporting Windows Client.

List of Reports Contains the last 10 opened reports and the point of 
view for each. You can select a report to open it.

Applies To:

Function... Description...
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When modifying data in Hyperion Schedules, you can use the point of view bar to 
change the default point of view. Any changes you make to the point of view are 
for the current Hyperion Schedules session only. For example, if you select July 
1996 as the current period, the system uses this until you change it for the current 
session. If you exit Hyperion Schedules and then restart it, the current period in 
Hyperion Schedules will return to the default in the point of view.

Note: In Hyperion Enterprise, if you exit Hyperion Schedules and then 
restart it, the current period in Hyperion Schedules will return to the 
default in the HYPENT.INI file.

When you select a button on the point of view bar, a dialog box appears with a list 
of valid selections. For example, if you select the Entity button, the Point of View 
dialog box appears with a list of the entities from which you can select a new entity 
point of view. 

When you select a data cell and then click the right mouse button, a menu appears 
with a list of functions and reports. The functions allow you to open a report and 
change the point of view of the active report or another report to that of the selected 
data cell. You can also use investigations to open the report associated with the 
selected data cell.

The list of reports allows you to open a report using its associated point of view. 
The list of reports is initially empty. Each time you open a report, the report and 
its current point of view are added to the list.

Select an Application

You select an application to display or modify data for that application. You can 
set the default application at any time, and your changes are retained.

➤ To select an application:

1. From the Hyperion Schedules window, select File > Select Application.

2. Select the application for which you want to modify data.

Applies To:
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3. Type your user ID and password, then click OK.

Change the Point of View Using the Selected 
Data Cell

You change the point of view of a report to view different data in Hyperion 
Schedules. You can change the point of view at any time. Each data cell has a 
specific point of view. You can change the point of view of the report you are 
viewing to that of a selected data cell.

➤ To change the point of view using the selected data cell:

1. From the Hyperion Schedules window, open a report, then select the data cell 
with the point of view you want to use, and click the right mouse button.

Note: Use the right mouse button if your mouse is configured for a 
right-handed person. If your mouse is configured for a 
left-handed person, use the left mouse button instead.

2. From the menu of functions and reports, do one of the following:

� To change the point of view of the active report to that of the selected cell, 
select Change POV Using Selected Cell.

� To open another report and change the point of view to that of the selected 
cell, select Change POV Using Selected Cell and Open, select a report 
set and type a file name or select one from the list, then click OK.

Applies To:
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Select an Entity

You select an entity to display or modify data for that entity. You can set the 
default entity at any time, and your changes are retained. 

Note: Entities are called names in early versions of Hyperion Enterprise.

➤ To select an entity:

1. From the Hyperion Schedules window, do one of the following:

� Select Edit > Point of View and select the Entity tab.

� Select the Entity button on the point of view bar.

Note: To filter the list of entities, select or deselect Parents, Base, and 
Subentities.

2. Type an entity ID or select one from the list.

Note: You can type the first letter or letters of an ID to select a specific 
entry in the list. To select the next ID that matches your entry, 
select the Find Next icon. To select the previous ID that matches 
your entry, select the Find Previous icon.

3. Click OK.

Select a Category

You select a category to display or modify data for that category. You can set the 
default category at any time, and your changes are retained. 

Applies To:

Applies To:
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➤ To select a category:

1. From the Hyperion Schedules window, do one of the following:

� Select Edit > Point of View and select the Category tab.

� Select the Category button on the point of view bar.

2. Type a category ID or select one from the list.

Note: You can type the first letter or letters of an ID to select a specific 
entry in the list. To select the next ID that matches your entry, 
select the Find Next icon. To select the previous ID that matches 
your entry, select the Find Previous icon.

3. Click OK.

Select an Account 

You select an account to display or modify data for that account. You can set the 
default account at any time and your changes are retained.

➤ To select an account:

1. From the Hyperion Schedules window, do one of the following:

� Select Edit > Point of View and select the Account tab.

� Select the Account button on the point of view bar.

Note: To filter the list of accounts, select or deselect Input, Calculated, 
and Subaccounts.

2. Type an account ID or select one from the list.

Note: You can type the first letter or letters of an ID to select a specific 
entry in the list. To select the next ID that matches your entry, 
select the Find Next icon. To select the previous ID that matches 
your entry, select the Find Previous icon.

Applies To:



Hyperion Schedules

� 407Hyperion Enterprise Reporting Windows Client User’s Guide

16

3. Click OK.

Select a Period

The available periods from which you can select are determined by the current 
category setting on the point of view bar. For example, if Actual is the current 
category, then you can select a period in the Actual category only.

➤ To select a period:

1. From the Hyperion Schedules window, do one of the following:

� Select Edit > Point of View and select the Period tab.

� Select the Period button on the point of view bar.

2. Type a period ID or select one from the list.

Note: You can type the first letter or letters of an ID to select a specific 
entry in the list. To select the next ID that matches your entry, 
select the Find Next icon. To select the previous ID that matches 
your entry, select the Find Previous icon.

3. Click OK.

Select a Frequency and View

You select a frequency and view to display or modify data for that frequency and 
view. You can set the default frequency and view at any time and your changes are 
retained.

Applies To:

Applies To:
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➤ To select a frequency and view:

1. From the Hyperion Schedules window, do one of the following:

� Select Edit > Point of View and select the Frequency tab.

� Select the Frequency button on the point of view bar.

2. Type a frequency ID or select one from the list.

3. Type a view ID or select one from the list.

Note: You can type the first letter or letters of an ID to select a specific 
entry in the list. To select the next ID that matches your entry, 
select the Find Next icon. To select the previous ID that matches 
your entry, select the Find Previous icon.

4. Click OK.

Select a Subentity

You select a subentity to display or modify data for that subentity. You can set the 
default subentity at any time, and your changes are retained. 

➤ To select a subentity:

1. From the Hyperion Schedules window, do one of the following:

� Select Edit > Point of View and select the SubEntity tab.

� Select the Subentity button on the point of view bar.

2. Type a subentity ID or select one from the list, or click NONE to use a point 
of view that does not reference a subentity.

Note: You can type the first letter or letters of an ID to select a specific 
entry in the list. To select the next ID that matches your entry, 
click the Find Next icon. To select the previous ID that matches 
your entry, click the Find Previous icon.

Applies To:
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3. Click OK.

Select a First-level Subaccount

You select a first-level subaccount to display or modify data for that subaccount. 
You can set the default subaccount at any time, and your changes are retained.

➤ To select a first-level subaccount:

1. From the Hyperion Schedules window, do one of the following:

� Select Edit > Point of View and select the SubAcc1 tab.

� Select the First-level Subaccount button on the point of view bar.

2. Type or select the ID of the subaccount table that contains the subaccount you 
want to select, or click NONE to use a point of view that does not reference a 
subaccount.

3. Type a subaccount ID or select one from the list.

Note: You can type the first letter or letters of an ID to select a specific 
entry in the list. To select the next ID that matches your entry, 
select the Find Next icon. To select the previous ID that matches 
your entry, select the Find Previous icon.

4. Click OK.

Applies To:
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Select a Second-level Subaccount

You select a second-level subaccount to display or modify data for that 
subaccount. You can set the default subaccount at any time, and your changes are 
retained.

➤ To select a second-level subaccount:

1. From the Hyperion Schedules window, do one of the following:

� Select Edit > Point of View and select the SubAcc2 tab.

� Select the Second-level Subaccount button on the point of view bar.

2. Type or select the ID of the subaccount table that contains the subaccount you 
want to select, or click NONE to use a point of view that does not reference a 
subaccount.

3. Type a subaccount ID or select one from the list.

Note: You can type the first letter or letters of an ID to select a specific 
entry in the list. To select the next ID that matches your entry, 
select the Find Next icon. To select the previous ID that matches 
your entry, select the Find Previous icon.

4. Click OK.

Applies To:
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Select a Consolidation Detail 

You select a consolidation detail to display or modify data for that consolidation 
detail. You can set the default consolidation detail at any time and your changes 
are retained. 

➤ To select a consolidation detail:

1. From the Hyperion Schedules window, do one of the following:

� Select Edit > Point of View and select the Consolidation Detail tab.

� Select the Consolidation Detail button on the point of view bar.

2. Type a consolidation detail ID or select one from the list.

Note: You can type the first letter or letters of an ID to select a specific 
entry in the list. To select the next ID that matches your entry, 
click the Find Next icon. To select the previous ID that matches 
your entry, click the Find Previous icon.

3. Click OK.

Select a Parent 

You select a parent to display or modify parent data. You can set the default parent 
at any time, and your changes are retained. 

➤ To select a parent:

1. From the Hyperion Schedules window, do one of the following:

Applies To:

Applies To:
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� Select Edit > Point of View and select the Parent tab.

� Select the Parent button on the point of view bar.

Note: To filter the list of parents, select or deselect Parents, Base, and 
SubEntities.

2. Type a parent ID or select one from the list.

Note: You can type the first letter or letters of an ID to select a specific 
entry in the list. To select the next ID that matches your entry, 
click the Find Next icon. To select the previous ID that matches 
your entry, click the Find Previous icon.

3. Click OK.

Select a Currency

You select a currency to display or modify currency data. You can set the default 
currency at any time, and your changes are retained.

➤ To select a currency:

1. From the Hyperion Schedules window, do one of the following:

� Select Edit > Point of View and select the Currency tab.

� Select the Currency button on the point of view bar.

2. Type a currency ID or select one from the list.

Note: You can type the first letter or letters of an ID to select a specific 
entry in the list. To select the next ID that matches your entry, 
click the Find Next icon. To select the previous ID that matches 
your entry, click the Find Previous icon.

3. Click OK.

Applies To:
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Select a Field

You select a field to view data for that field. For example, you can select the VAL 
field to view the current value of all data in the report. You can set the default field 
at any time, and your changes are retained.

➤ To select a field:

1. From the Hyperion Schedules window, do one of the following:

� Select Edit > Point of View and select the Field tab.

� Select the Field button on the point of view bar.

2. Type a field ID or select one from the list.

Note: You can type the first letter or letters of an ID to select a specific 
entry in the list. To select the next ID that matches your entry, 
click the Find Next icon. To select the previous ID that matches 
your entry, click the Find Previous icon.

3. Click OK.

Show or Hide Window Elements

You can specify whether to show the toolbar, status bar, point of view bar, header 
area, footer area, and gridlines in the Hyperion Schedules window. For example, 
you can hide the header area to provide room for more data cells.

Applies To:

Applies To:
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The system shows all of the window elements by default. You can hide window 
elements for the current Hyperion Schedules session only. If you exit and restart 
Hyperion Schedules, the system displays the window elements that you hid in the 
previous session.

Note: The system shows the header and footer areas only if the current 
report contains a header and footer.

➤ To show or hide window elements, select or deselect View and do one or more of 
the following:

� To show or hide the toolbar, select or deselect Toolbar.

� To show or hide the status bar, select or deselect Status Bar.

� To show or hide the point of view bar, select or deselect POV Bar.

� To show or hide the header area, select or deselect Header.

� To show or hide the footer area, select or deselect Footer.

� To show or hide gridlines, select or deselect Gridlines.

Open Reports

You open reports in Hyperion Schedules to enter and modify Hyperion Enterprise 
or Hyperion Essbase data. You can open only compiled reports in Hyperion 
Schedules.

You can select a data cell and then open a report and change the point of view to 
that of the selected data cell. This allows you to use the report with a different point 
of view.

Tip: The File menu shows up to the last 4 reports that you opened. The 
menu that appears when you select a data cell and click the right mouse 
button shows up to the last 10 opened reports and the point of view of 
each. You can select a report from one of these menus to open it in the 
Hyperion Schedules window.

Applies To:
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➤ To open a report:

1. Do one of the following:

� From the Hyperion Schedules window, select File > Open or the Open 
toolbar icon.

� From an open report, select a data cell, click the right mouse button, then 
select Open to open a report, select Change POV Using Selected Cell 
and Open to open another report and use the point of view of the selected 
cell, or select a report from the list of reports.

2. Select the set that contains the report you want to open.

3. Type a file name or select one from the list, then click OK.

Use Investigations from a Data Cell

You use investigations to open the report that is associated with the selected data 
cell. Reports are associated with data cells in Hyperion Enterprise Reporting 
Windows Client. 

➤ To use investigations from a data cell:

1. Select a data cell, then click on the right mouse button.

Note: Use the right mouse button if your mouse is configured for a 
right-handed person. If your mouse is configured for a 
left-handed person, use the left mouse button instead.

2. Click Investigations.

Applies To:
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3. Repeat steps 1 and 2 for each data cell from which you want to use 
investigations.

Note: You can associate a cell with a report in Hyperion Enterprise 
Reporting Windows Client using investigations. For more 
information, see Hyperion Enterprise Reporting Windows Client 
Help.

Define Cell Colors

Color-coded cells in Hyperion Schedules indicate the type of data contained in 
each cell. When you define the colors in Hyperion Schedules, the system saves the 
new colors as the defaults. You can change the colors at any time during a work 
session.

You define these colors to indicate types of data cells:

� Default color indicates valid input cells. You can enter or modify the data 
in default cells.

� Changed color indicates cells that contain unsaved data changes. You can 
make more changes to data in changed cells. To convert changed cells to 
default cells, you must save the changes.

� Locked color indicates display-only cells that are locked or journal locked 
in the database.

� Reporting Calculated color indicates display-only cells with data that is 
calculated based on Hyperion Enterprise Reporting Windows Client 
formulas. The values change when you calculate formulas.

� Application Calculated color indicates display-only cells with data that is 
calculated based on Hyperion Enterprise formulas. The values change 
when you calculate formulas.

� Text color indicates display-only cells that are empty or contain text.

Applies To:
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� Write-failed color indicates cells that contain data the system was unable 
to write to the database when you saved it.

� Read Only color indicates cells that contain read-only data. You cannot 
enter data into a read-only cell. For example, a data cell is read-only if its 
point of view is invalid.

➤ To define cell colors:

1. From the Hyperion Schedules window, select Options > Colors.

2. Select the cell type for which you want to define the color.

3. Do one or more of the following:

� To add more red, green, or blue to the selected cell type’s color, scroll the 
Red, Green, or Blue color bar to the right.

� To remove red, green, or blue from the selected cell type’s color, scroll the 
Red, Green, or Blue color bar to the left.

� To select a color for the selected cell type, click Choose, select a basic or 
custom color, then click OK.

� To return the selected cell type to the system default color, click Reset.

4. Repeat steps 2 and 3 for each cell type that you want to change.

Tip: To return all cell types to the system default colors, click Reset 
All.

5. Click OK to accept the new colors.

Set Preferences

You set preferences in Hyperion Schedules to determine how the system responds 
to your input. The preferences include Enter and Tab key behavior, as well as 
whether to calculate formulas as you enter data. When you set preferences, the 
system saves the settings for the next time you work in Hyperion Schedules. 

Applies To:
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You can choose how the cursor behaves when you press the Tab or Enter key. 
These are the options you can define:

� The cursor remains in the same cell.

� The cursor moves one cell to the right.

� The cursor moves one cell down.

You can specify whether to automatically calculate formulas as you enter data. 
These are the options you can define:

� The system does not automatically calculate formulas.

� The system automatically calculates Hyperion Enterprise Reporting Windows 
Client formulas only.

� The system automatically calculates Hyperion Enterprise Reporting Windows 
Client formulas and Hyperion Enterprise formulas.

Note: You can use the Calculate Formulas option to calculate data.

➤ To set preferences:

1. From the Hyperion Schedules window, select Options > Preferences.

2. To define the Tab and Enter key behavior, do one of the following:

� To make the cursor remain in the same cell when you press Tab or Enter, 
click Cause No Movement.

� To make the cursor move one cell to the right when you press Tab or Enter, 
click Move the Cursor to the Right.

� To make the cursor move one cell down when you press Tab or Enter, 
click Move the Cursor Down.

3. To make the cursor skip non-editable cells when you press Tab, click Skip 
Non-editable Cells.

4. To set up auto-recalculate, do one of the following:

� To perform no automatic calculations while entering data, click None.

� To automatically calculate Hyperion Enterprise Reporting Windows 
Client formulas but not Hyperion Enterprise formulas while entering data, 
click Reporting Formulas Only.
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� To automatically calculate Hyperion Enterprise Reporting Windows 
Client and Hyperion Enterprise formulas while entering data, click 
Reporting and Application Formulas.

5. Click OK.

Notations and Local Headings

You can use these text options in Hyperion Schedules:

� Notations, such as descriptions or comments

� Local headings, which replace the descriptions of individual dimensions based 
on the other dimension settings in the report

Notations are fields that you use for comments and other textual data that provide 
information in report output. Notations can vary by entity, period, or any other 
dimension. For example, you might create a field called Notes1 to include 
notations, such as reasons for increases or decreases, on account values for 
different entities, periods, and categories.

Local headings are notations that you use as alternate descriptions based on the 
dimension settings in a report. For example, a company’s chart of accounts might 
include the account Cost A. In the Canada Division, Cost A might represent 
transportation expenses, while in the Northeast Division, Cost A might represent 
packaging expenses. You can create a field called Accounts by Division to store 
alternative descriptions for accounts for the different entities in an organization. 
For Cost A, the Canada Division would use the local description Transportation 
Costs, while the Northeast Division would use the description Packaging Costs. 

Applies To:
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The following table shows the tasks involved in using notations and local 
headings, and where you perform those tasks.

Enter Notations

You enter notations to provide explanations for data results or other information 
that can enhance your Hyperion Enterprise reports. You enter notations in cells 
where a text field is defined in the column or row. 

The system handles the notations that you enter as text data. You can copy, edit, 
modify, move, and remove notations the same as you do numeric data.

➤ To enter notations:

1. In the Hyperion Schedules window, select the cell in which you want to enter 
or modify notations.

2. Type the text for the notation, then press ENTER.

Table 57: Using Notations and Local Headings

Use... To...

Hyperion DataExtend Set up fields to use for notations or local headings. For 
more information, see Hyperion DataExtend Help.

Hyperion Enterprise 
Reporting Windows 
Client

Create reports that you use for these tasks:

• Entering text for notations and local headings in 
Hyperion Schedules

• Presenting data with notations and local headings. For 
more information, see the Building Reports topic in 
Hyperion Enterprise Reporting Windows Client Help.

Hyperion Schedules Enter text for notations and local headings. For more 
information, see the Enter Notations and Enter Local 
Headings topics in this guide.

Applies To:
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Enter Local Headings

You enter local headings to provide alternate descriptions for dimensions in the 
headings of Hyperion Enterprise reports. When you enter a local heading, the row 
or column heading immediately changes to reflect your entry.

Note: You can enter local headings only for dimensions and reports that 
your administrator sets up to display local headings. 

➤ To enter local headings:

1. In the Hyperion Schedules window, double-click on the row or column 
heading you want to modify.

2. Type the text for the local heading, then click OK.

 Data Entry 

You use the spreadsheet interface in the Hyperion Schedules window to enter and 
modify data in reports. Data can be numeric, such as account values, or 
alphanumeric, such as notations or local headings. You can perform these 
time-saving tasks when you enter and edit data:

� Highlight blocks of data 

� Use operator keys to speed data entry 

� Move data 

� Copy data 

Applies To:

Applies To:
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� Remove data 

� Calculate formulas 

� Show suppressed rows and columns 

The cells of the spreadsheet that contain calculated and consolidated data are 
color-coded to show that you cannot enter or change data for these cells in 
Hyperion Schedules. For more information on calculated and consolidated data, 
see the Hyperion Enterprise User’s Guide. For more information on the color 
coding of cells, see Define Cell Colors on page 416.

Hyperion Schedules displays numeric data in the number format defined in the 
report. For information about defining number formats in reports, see Hyperion 
Enterprise Reporting Windows Client Help.

Operator Keys

Operator keys perform special functions that make data entry faster and easier. 
You can use the operator keys to perform calculations on data that is already in the 
report or to type fewer numbers in a cell. You use operator keys to enter numeric 
data only. The following table describes the operator keys. 

Applies To:

Table 58: Operator Keys

Key Operation Example

+ Adds the number you type to the number already in the 
cell.

30+

- Subtracts the number you type from the number already 
in the cell.

30-

* Multiplies the current cell value by the number you 
type.

5*

/ Divides the current cell value by the number you type. 10/
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Note: The P, K, T, M, B, and A operator keys are not case-sensitive.

Enter Numeric Data
You use the keyboard to enter and modify numeric data in selected cells. You can 
use operator keys to speed data entry. You can enter and modify numeric data in 
input cells only. 

➤ To enter numeric data:

1. From the Hyperion Schedules window, select the cell in which you want to 
enter or change data.

2. Type a value and any desired operator keys, then press Enter.

% + or 
% -

Increases or decreases the cell’s value by the percentage 
you type.

50%+

+ P or 
- P

Increases or decreases the cell’s value over the cell to 
the left by the amount or percentage you type.

30%+P

K or T Indicates thousands. 17K or 12T

M Indicates millions. 32M

B Indicates billions. 21B

A Allocates the amount that you type evenly among all 
selected cells.

1000A

? or - ? Fills all selected cells with random positive or negative 
values.

?

Table 58: Operator Keys

Key Operation Example
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Highlight Blocks of Data

You can highlight blocks of cells in the Hyperion Schedules window, then modify 
or enter data in all of the highlighted cells at once. You can highlight a row of data, 
a column of data, a block of cells, or the entire report. 

➤ To highlight a block of data, select a corner cell of the block you want to highlight, 
then drag the mouse until you highlight all of the desired cells.

Copy Data 

You can copy numeric or text data from one cell or block of cells to another cell 
or block of cells. This is faster than typing the data. The system copies the selected 
data from the report and places it in the clipboard. You can then paste the data from 
the clipboard into a selected location. For more information about the clipboard, 
see the Microsoft Windows User’s Guide.

You can copy calculated or invalid data; however, you cannot paste data into 
locked or calculated cells. All of the cells that appear in a report are color-coded 
to indicate the type of data in the cell. For more information, see Define Cell 
Colors on page 416.

➤ To copy data:

1. In the Hyperion Schedules window, select the cell or block of cells that 
contains the data you want to copy, then select Edit > Copy or the Copy 
toolbar icon. 

Applies To:

Applies To:
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2. Select the cell or block of cells into which you want to copy the data, then 
select Edit > Paste or the Paste toolbar icon.

Move Data

You can move numeric or text data from one cell or block of cells to another cell 
or block of cells. This is faster than typing the data in the new location and clearing 
it from the first location. 

The system places the data values in the clipboard, replacing the cell values with 
zeros. You can then move the data from the clipboard into a selected location. For 
more information about the clipboard, see the Microsoft Windows User’s Guide.

You cannot move data to or cut data from locked periods or calculated accounts. 
All of the cells that appear in a report are color-coded to indicate what type of data 
they contain and whether you can move data into the cells. For more information, 
see Define Cell Colors on page 416.

➤ To move data:

1. In the Hyperion Schedules window, select the cell or block of cells that 
contains the data you want to move, then select Edit > Cut or the Cut toolbar 
icon. 

2. Select the cell or block of cells into which you want to paste the data, then 
select Edit > Paste or the Paste toolbar icon.

Note: If you try to move data to an area that is a different size than the 
area from which you cut data, a message appears stating that the 
cut and paste areas are different sizes. You cannot paste the data 
into the selected area.

Applies To:
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Remove Data

You can remove numeric or text data from one cell or block of cells to set the data 
values to zero. You cannot remove values from locked periods or calculated 
accounts. All cells that appear in a schedule are color-coded to indicate what type 
of data they contain.

➤ To remove data:

1. In the Hyperion Schedules window, highlight the cell or block of cells that 
contains the data you want to remove.

2. Select Edit > Cut or the Cut toolbar icon.

Calculate Formulas

You calculate formulas in Hyperion Schedules to calculate data and see the results 
of your data entry. You calculate formulas for an entire report at once. 

When you calculate formulas, the values in the calculated cells change based on 
the formulas defined in Hyperion Enterprise. The input cells are not affected. The 
cells in the Hyperion Schedules window are color-coded to indicate the type of 
data they contain. You define the cell colors that indicate calculated and input data. 
For more information, see the auto-calculate option in Set Preferences on 
page 417.

Applies To:

Applies To:
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➤ To calculate formulas from the Hyperion Schedules window, select Options > 
Calculate Formulas or the Calculate Formula toolbar icon.

Show Suppressed Rows or Columns

When you create a report in Hyperion Enterprise Reporting Windows Client, you 
can specify to suppress individual rows or columns when they do not contain data. 
In Hyperion Schedules, you can show the suppressed report rows or columns in 
the report so that you can enter data into them.

➤ To show suppressed rows or columns:

1. From the Hyperion Schedules window, do one of the following:

� To show suppressed rows, select Options > Show Suppressed Rows or 
the Show Suppressed Rows toolbar icon.

� To show suppressed columns, select Options > Show Suppressed 
Columns or the Show Suppressed Columns toolbar icon.

Tip: To filter the list to include only rows or columns under the 
highlighted cell, select Include Suppressed Rows for Selected 
Cell Only or Include Suppressed Columns for Selected Cell 
Only.

2. Select the rows or columns that you want to display, then click OK.

Applies To:
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Change the Default Printer

When you print in Hyperion Schedules, you use the default printer. You can select 
only one default printer at a time. If you have several printers installed, you can 
change the default printer. 

Some printers require additional setup information. For information on setting 
printer options, see the Microsoft Windows User’s Guide.

➤ To change the default printer:

1. From the Hyperion Schedules window, select File > Printer Select.

2. Select the printer you want to use as the default printer.

3. To set up the printer, click Setup, then select the options you want.

4. Click OK.

Preview Data

You can preview the data in a report before printing it or saving it in a text file. 
This allows you to determine whether you want to change the content or format of 
the printout.

➤ To preview data:

1. From the Hyperion Schedules window, select File > Print Preview.

2. Do one or more of the following:

Applies To:

Applies To:
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� To view the first page of the printout, click First.

� To view the last page of the printout, click Last.

� To view the next page of the printout, click Next.

� To view the previous page of the printout, click Previous.

� To view a specific page of the printout, click Go to, type the page number, 
then click OK.

� To switch between the enlarged and full-page views of the pages, click 
Zoom.

� To print the data, click Print.

� To show or hide an outline of the page margins, click Margins.

� To end the preview, click Close.

Print Data

You can print a report in Hyperion Schedules. When you print a report, you print 
the current data in the Hyperion Schedules window. All header and footer 
information appears in the printout. You can print a hard copy of the report or print 
the data to a file.

If you select the Print to File option, Hyperion Schedules produces an ASCII text 
file with line lengths up to 32,000 characters, regardless of what printer is selected. 
If you do not select the Print to File option and the selected printer is Generic/Text 
Only on File, the output is an ASCII text file with Windows formatting.

➤ To print data:

1. From the Hyperion Schedules window, select File > Print or the Print toolbar 
icon.

2. In the Copies edit box, type the number of copies you want to print.

Applies To:
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3. To print draft-quality copies, click Draft Quality. 

Note: The Draft Quality option is not available if you select Print to 
File.

4. To specify the pages you want to print, do one of the following:

� To print all pages, click All.

� To print one page, click From, then type the number of the page you want 
to print.

� To print several consecutive pages, click From, then type the numbers of 
the first page and last page you want to print.

5. To save the output to a file, click Print to File, then type the name of the file 
in which to save the output.

Note: If you do not select the Print to File option and the selected 
printer is Generic/Text Only on File, the output is an ASCII text 
file with Windows formatting. The output from the Generic/Text 
Only on File printer is not controlled by Hyperion Schedules. For 
instructions on selecting or setting up a printer, see the Microsoft 
Windows User’s Guide.

6. Click OK to print the data.

Remove Dimensions from the Point of View 
Bar 

Note: This task is intended for administrators only.

You can remove a dimension from the point of view bar for an individual report. 
For example, you can create a report called Sales Data with individual accounts in 
the columns. There is no need for users to see or select an account in the point of 
view for the Sales Data report, so you can turn off the account dimension to avoid 
distracting or confusing users. 

Applies To:
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You remove dimensions by creating an .SCH file for the report. You create an 
.SCH file in any text editor, and you name the file Report.SCH, where Report is 
the ID of the report for which you want to limit dimensions. You store any .SCH 
files for an application in the application’s report directory.

The POVBAR section in a Report.SCH file determines the dimensions to display. 
Hyperion Schedules displays all dimensions in the point of view bar unless you 
specify to hide them in the Report.SCH file. Here is a sample POVBAR section:

[POVBAR]

ACCOUNT = OFF

CATEGORY = OFF

This sample specifies that the account and category do not appear in the point of 
view bar.

Hyperion Schedules with Validations
The 32-bit version of Hyperion Schedules has been enhanced to perform 
validations. You must have Visual Basic programming experience to set up 
validations. You can create a custom validations project that defines rules for 
opening, entering, and saving data in a schedule. The custom validation project can 
be created using VBScript or Visual Basic 4.0 or 5.0. 

To perform validations, Hyperion Schedules accesses your custom validations 
project, which is a user-programmable Visual Basic 4.0/5.0 OLE DLL or a 
VBScript text file. Your custom validations project contains three functions. These 
three user-defined functions are invoked by Hyperion Schedules as a result of the 
following actions:

� When a schedule is opened.

� When a user enters data in a cell.

� When a schedule is saved.

Each call to your custom validations project contains a reference to the OLE data 
type, which is IHypReportData. IHypReportData supplies information about the 
application, report, and user, and provides access to two additional OLE data 
types, which are IDisplayedData and ICompressedData. IDisplayedData retrieves 
Hyperion data values using row and column numbers displayed on the Hyperion 
Schedules grid. ICompressedData retrieves data values using row and column 
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numbers displayed in Hyperion Enterprise Reporting Windows Client. Both 
classes provide point of view (POV) information and status of the specified data 
cells.

Assumptions
To create a custom validations project you must be a proficient Visual Basic 
programmer. This document assumes that the reader is knowledgeable in Visual 
Basic programming. 

Point of view, compression, and expansions are referred to throughout this 
document. For more information on these elements, see the Hyperion Enterprise 
Reporting Windows Client and Hyperion Schedules online help systems.

Enable Validations with Hyperion Schedules
You must update your HSCHED.INI file located in your WINDOWS directory to 
use validations with your application. You need to add the following four lines:

Validation=1

VBScript=1

ValidationProjectName=projname.validate

ValidationScriptPath=c:\VBScript\
application1.vbs

Update the section that pertains to the Hyperion product and the application you 
are using. The section names are enclosed in square brackets. For example if you 
are using the Hyperion Enterprise product and the Application1 application, you 
would update the [Enterprise-Application1] section. 

Validation

Set Validation to 1 to enable validations, or set it to 0 to disable validations. When 
validations are enabled, Hyperion Schedules invokes the custom validations 
project you created.

VBScript

Set VBScript to 1 if you are using VBScript. If you are using VB 4.0 or 5.0, set it 
to 0. 
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Validation Project Name

If you are using VB 4.0 or 5.0, you must set the ValidationProjectName equal to 
NONE or to the actual project name that you specified in VB 4.0 or 5.0, with the 
extension .VALIDATE.

If you have named your project using the Hyperion product name followed by the 
application name, then you can set the ValidationProjectName equal to NONE, 
and the system will automatically use that project. For example, if you set 
ValidationProjectName = NONE, and you are using the Hyperion Enterprise 
product and the Application1 application, the system would automatically use the 
project named EnterpriseApplication1.VALIDATE.

If you have not named your project using the Hyperion product name followed by 
the application name, then you must set the ValidationProjectName equal to your 
project name, with the extension .VALIDATE. For example, if your project’s 
name is PROJECT 1, then use the statement:

ValidationProjectName=PROJECT1.VALIDATE

Note: If you are using VBScript, the ValidationProjectName is ignored.

Validation Script Path

Set the ValidationScriptPath to the directory where the VBScript file is located and 
the VBScript file name. For example, if you are using a VBScript text file named 
TEST.VBS, which is located in c:\VBScript, do the following:

ValidationScriptPath=c:\VBScript\test.vbs

Note: If you are using VB 4.0 or 5.0, the ValidationScriptPath is ignored.

Maintaining a Custom Validations Project Using 
VBScript

You can create a custom validations project in VBScript using a text editor. The 
project is interpreted and executed when Hyperion Schedules is running. 

➤ To create a custom validations project using VBScript:

1. Use any text editor to type the following function prototypes:

� Function ValidateOpenReport
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� Function ValidateEditedCell

� Function ValidateSaveReport

2. Customize your functions. To retrieve information from Schedules, use the 
global variable HypReportData. For more information, see Descriptions of 
Custom Validations Functions on page 437 and Methods and Properties of 
Validations OLE Classes on page 447 in this document.

3. Save the VBScript text file.

4. Distribute the VBScript text file to each user’s workstation. Place it in the 
directory specified by the ValidationScriptPath variable in your HSCHED.INI 
file.

5. Before your custom VBScript can be used by anyone else, appropriate entries 
must be created for it in the Windows registration database. This must be done 
for each workstation that is using the VBScript text file. To register 
VBScript.DLL and VALIDDLL.DLL, pass the complete path and the DLL 
name as arguments to REGSVR32.EXE.

Tip: If you are using Windows  NT, VBScript.DLL is located in your 
WINDOWS/SYSTEM32 directory. If you are using Windows 95, 
it is located in your WINDOWS/SYSTEM directory. 
VALIDDLL.DLL is located in the directory where Hyperion 
Schedules is installed; the default is C:\CDA.

Maintaining a Custom Validations Project Using 
VB 4.0

You can create a custom validations project using VB 4.0 or 5.0. The project is 
executed when Hyperion Schedules is running. To create the project using VB 5.0, 
go on to the next section. 

➤ To maintain a custom validations project using VB 4.0:

1. Open the 32-bit version of Visual Basic 4.0 and create a new project.

2. From the Project window, delete Form1.

3. From the Insert menu, click Module.

4. Type Sub Main in the newly created module, then press Enter.

Note: Visual Basic will insert End Sub.
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5. From the Insert menu, click Class Module.

6. Type the following function prototypes in the new class module:

� Public Function ValidateOpenReport(ByVal HypReportData As 
Object) As Boolean

� Public Function ValidateEditedCell(ByVal HypReportData As 
Object) As Boolean

� Public Function ValidateSaveReport(ByVal HypReportData As 
Object) As Boolean

7. Change the Class Module properties to the following: 

� Instancing: 2 Creatable MultiUse

� Name: Validate

� Public: True

8. From the Tools menu, click Options.

9. Select the Project tab.

10. Type your Hyperion Application name in the Project Name edit box. Use the 
Hyperion product name followed by the application name.

11. Save the VB Project.

12. Customize your functions. For more information, see Descriptions of Custom 
Validations Functions on page 437 and Methods and Properties of Validations 
OLE Classes on page 447 in this document.

13. From the File menu, click Make OLE DLL File.

14. Use your Hyperion Application name to specify a name for the DLL.

15. Distribute the DLL to each workstation.

Note: VB40032.DLL must be placed  on each workstation in the 
WINDOWS/SYSTEM32 directory for NT, or the 
WINDOWS/SYSTEM directory for Windows 95.

16. To register the DLL, pass the complete path and the DLL name as arguments 
to REGSVR32.EXE.
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Maintaining a Custom Validations Project Using 
VB 5.0

You can create a custom validations project using VB 4.0 or 5.0. The project is 
executed when Hyperion Schedules is running. To create the project using VB 4.0, 
go to the previous section.

➤ To maintain a custom validations project using VB 5.0:

1. Open the 32-bit version of Visual Basic 5.0 and create a new project.

2. Select the ActiveX DLL template.

3. Change the Class1 Class modules properties to the following:

� Name: Validate

� Instancing: Multiuse

4. Type the following function prototypes in the Validate class module:

� Public Function ValidateOpenReport(ByVal HypReportData As 
Object) As Boolean

� Public Function ValidateEditReport(ByVal HypReportData As 
Object) As Boolean

� Public Function ValidateSaveReport(ByVal HypReportData As 
Object) As Boolean

5. From the Project menu, select Project1 properties.

6. Type your Hyperion Application name in the Project Name edit box. Use the 
Hyperion product name followed by the application name. 

7. From the File menu, click Save Project; at the prompt, type the name in the 
format NAME.VBP.

8. Customize your functions. For more information, see Descriptions of Custom 
Validations Functions on page 437 and Methods and Properties of Validations 
OLE Classes on page 447 in this document.

9. From the File menu, Click Make Test DLL.
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10. Distribute the DLL to each workstation.

Note: MSVBVM50.DLL must be placed  on each workstation in the 
WINDOWS/SYSTEM32 directory for NT, or the 
WINDOWS/SYSTEM directory for Windows 95.

11. To register the DLL, pass the complete path and the DLL name as arguments 
to REGSVR32.EXE.

Descriptions of Custom Validations Functions 
The customizable validations functions to be implemented in Visual Basic include 
the following:

� Public Function ValidateOpenReport(ByVal HypReportData As Object) As 
Boolean

� Public Function ValidateEditedCell(ByVal HypReportData As Object) As 
Boolean

� Public Function ValidateSaveReport(ByVal HypReportData As Object) As 
Boolean

Validate OpenReport Function 
Hyperion Schedules invokes this customizable function when the user opens a 
schedule or changes the application’s point of view. This function allows the 
system administrator to validate the current report and specify data cells to be 
read-only.  The cells are displayed using user-defined colors that indicate its 
attributes.

Example of the ValidateOpenReport Function

This example of the ValidateOpenReport function shows the following:

� Denies certain users access to reports

� Sets the report to read-only if the Entity point of view is US100

� Sets the compressed column 1 to read only

� Prohibits opening a schedule by returning the value FALSE

Public Function ValidateOpenReport(ByVal HypReportData As 
Object) As Boolean
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ValidateOpenReport = True

Dim Str As String

Dim b As Boolean

Dim i As Integer

Dim j As Integer

Dim Row As Long

Dim Col As Long

Dim Msg As String

Dim Style As Integer

Dim Title As String

Dim Response As Integer

’*** Set COL 1 to Read Only.

If (HypReportData.ReportName = "DISP21")_Then

  HypReportData.DisplayedData.ColNum = 1

  For i = 1 To _ HypReportData.DisplayedData.NumRows

    HypReportData.DisplayedData.RowNum = i

    HypReportData.DisplayedData.ReadOnly _ = True

  Next i

End If

’*** Don’t allow the ADMIN user to open

’*** the "NOACCESS" report

If (HypReportData.UserID = "USER1" And _ 
HypReportData.ReportName _ ="NOACCESS") Then

  Msg = "User 1 is not allowed to access this _ report" ’_ 
Define message.

  Style = vbOKOnly ’ Define buttons.

  Title = "Visual Basic Validation" ’ Define 

   title.

  Response = MsgBox(Msg, Style, Title)

  ValidateOpenReport = False
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  Exit Function

End If

’*** Set the report to read only if

’*** the Entity Point of View is not set to US100.

If (HypReportData.ReportName = "US100") Then

  For Row = 1 To  

   HypReportData.DisplayedData.NumRows

    HypReportData.DisplayedData.RowNum = Row

    For Col = 1 To 

     HypReportData.DisplayedData.NumCols

       HypReportData.DisplayedData.ColNum = Col

       Str _ = HypReportData.DisplayedData.CellPOV(1)

       If Str <> "US100" Then

        HypReportData.DisplayedData.ReadOnly _ = True

       End If

    Next Col

  Next Row

End If

    ’*** Set COL 3 (Budget) to Read Only.

If (HypReportData.ReportName = "BVSA") Then

  HypReportData.DisplayedData.ColNum = 3

  For i = 1 To HypReportData.DisplayedData.NumRows

    HypReportData.DisplayedData.RowNum = i

    HypReportData.DisplayedData.ReadOnly = True

  Next i

End If
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’*** This will set the Compressed COL 3

’*** (index 1 only) to read only

If (HypReportData.ReportName = "COMP21") Then

  HypReportData.CompressedData.ColNum = 3

  HypReportData.CompressedData.ExpandedColIndex = 1

  For i = 1 To HypReportData.CompressedData.NumRows

   HypReportData.CompressedData.RowNum = i

   For j = 1 To 

   HypReportData.CompressedData.NumExpandedRows(i)

     HypReportData.CompressedData.ExpandedRowIndex 

      = j

    HypReportData.CompressedData.ReadOnly = True

   Next j

  Next i

End If

End Function

ValidateEditedCell Function
Hyperion Schedules invokes this customizable function after a user types a new 
value for a cell and then attempts to store the new value by pressing Enter, or by 
moving off of the cell.  This function allows the system administrator to ensure that 
the value passes validations criteria and that it displays error messages and 
warning messages to the end user.

Example of a ValidateEditedCell Function

This example of the ValidateEditedCell function shows the following:

� Ensures that the report named RANGE allows only the values between 100 
and 1000 to be entered in column 2

� Calculates and refreshes the report if the cell 1,1 is modified

� Prompts the user to enter a comment if an actual amount is over budget

� Displays a message for each actual value that is greater than 1000
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� Prohibits editing a cell by returning the value FALSE

Public Function ValidateEditedCell(ByVal HypReportData As 
Object) As Boolean

Dim bOK As Boolean

Dim i As Integer

Dim lNum1 As Double

Dim lNum2 As Double

Dim Budget As Double

Dim Actual As Double

Dim RN As Long

Dim CN As Long

Dim RNI As Long

Dim CNI As Long

Dim Str1 As String

Dim DispData As Object

Dim Response As Integer

Set DispData = HypReportData.DisplayedData

ValidateEditedCell = True

’*** For the report "RANGE" validate Col 2

’*** to have a range between 100 and 1000.

If (HypReportData.ReportName = "RANGE") Then

  If (HypReportData.DisplayedData.ColNum = 2) Then

    lnum1 = 

     HypReportData.DisplayedData.GetNumericValue

    If ((lNum1 < 100) Or (lNum1 > 1000)) Then

      Response = MsgBox("Value is out of 

       range.Please enter a value between 100 and 

       1000", 0, "Visual Basic Validation")

       ValidateEditedCell = False

       Exit Function
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    End If

  End If

End If

’*** If modifying cell 1,1 then

’*** calculate the report and refresh it.

If (HypReportData.ReportName = "SUM") Then

  If (HypReportData.DisplayedData.RowNum = 1 And 

   HypReportData.DisplayedData.ColNum = 1) Then

    lnum1 = 

     HypReportData.DisplayedData.GetNumericValue

    bOK = 

     HypReportData.DisplayedData.SetNumericValue

     (lNum1)

    HypReportData.DisplayedData.RowNum = 2

    HypReportData.DisplayedData.ColNum = 1

    bOK =   

     HypReportData.DisplayedData.SetNumericValue

     (lNum1 + 1)

    HypReportData.DisplayedData.RowNum = 3

    HypReportData.DisplayedData.ColNum = 1

    bOK = HypReportData.DisplayedData.

     SetNumericValue(lNum1 + 2)

    HypReportData.DisplayedData.RowNum = 4

    HypReportData.DisplayedData.ColNum = 1

    bOK = HypReportData.DisplayedData.

     SetNumericValue(lNum1 + 3)

    HypReportData.CalculateReport

    HypReportData.RefreshReport

  End If

End If
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’*** if the actual amount is over budget then

’*** enter a comment as to why.

If (HypReportData.ReportName = "BVSA") Then

  If (HypReportData.DisplayedData.RowNum = 2) Then

    Budget = HypReportData.DisplayedData

     .GetNumericValue

    If (Budget > 100) Then

      Response = MsgBox("Value not allowed", 0, 

       "Visual Basic Validation")

      ValidateEditedCell = False

      Exit Function

    End If

  End If

  If (HypReportData.DisplayedData.ColNum = 2) Then

‘*** if we are editing the budget column

    Budget = HypReportData.DisplayedData.

     GetNumericValue

    HypReportData.DisplayedData.ColNum = 3

    Actual = HypReportData.DisplayedData.

     GetNumericValue

    HypReportData.DisplayedData.ColNum = 1

    If (Budget > Actual) Then

      Str1 = InputBox("The Actual amount is over 

       the Budgeted amount. Please enter a comment 

       as to why", "Visual Basic Validation")

      If (Str1 = "") Then

      '*** no comment, so discard new value

        ValidateEditedCell = False

      Else



444 �

Hyperion Schedules

Hyperion Enterprise Reporting Windows Client User’s Guide

        bOK = HypReportData.DisplayedData.

         SetTextValue(Str1)

      End If

    End If

    HypReportData.RefreshReport

  End If

End If

’*** Allow over budget by $1000.

If (HypReportData.ReportName = "CALC") Then

  If (HypReportData.DisplayedData.ColNum = 1) Then

    Actual = HypReportData.DisplayedData.

     GetNumericValue

    HypReportData.DisplayedData.ColNum = 2

    Budget = HypReportData.DisplayedData.

     GetNumericValue

    If ((Actual - Budget) > 1000) Then

      Response = MsgBox("There is more than $1000 

       difference between Actual and Budget", 0, 

       "Visual Basic Validation")

      ValidateEditedCell = False

      Exit Function

    End If

    HypReportData.DisplayedData.ColNum = 3

    HypReportData.DisplayedData.SetTextValue 

     (Str(Actual - Budget))

    HypReportData.RefreshReport

  End If

End If

End Function
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ValidateSaveReport Function
Validations for Hyperion Schedules invokes this customizable function after a 
user attempts to save a schedule.  The function allows the system administrator to 
ensure that values on the schedule pass validations criteria.  The system 
administrator has the ability to display error and warning messages to the end-user, 
and to prohibit the saving of the schedule by returning a value of FALSE.

Note: Validations rules defined in this function are not enforced if your 
changes have already been updated to the database. 

Example of a ValidateSaveReport Function

This example of the ValidateSaveReport function shows the following:

� Changes any values in the report SAVE2 to 10 if any values are set to 0

� Prohibits saving the report SAVE1 if it contains 0

Public Function ValidateSaveReport(ByVal HypReportData As 
Object) As Boolean

Dim lValue As Double

Dim bOK As Boolean

ValidateSaveReport = True

Dim Str As String

Dim Response As Integer

’*** Do not save the SAVE1 report if it contains 

 Zeros.

If (HypReportData.ReportName = "SAVE1") Then

  For Row = 1 To 

   HypReportData.DisplayedData.NumRows

    HypReportData.DisplayedData.RowNum = Row

    For Col = 1 To 

     HypReportData.DisplayedData.NumCols

      HypReportData.DisplayedData.ColNum = Col

      bOK = HypReportData.DisplayedData.IsZero

      If bOK = True Then
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        ValidateSaveReport = False

        Response = MsgBox("Unable to save report 

         because some cell(s) contain Zero(s).", 

         0, "Visual Basic Validation")

        Exit Function

      End If

    Next Col

  Next Row

End If

’*** If any values in SAVE2 are Zeros then

’*** change them to 10.

If (HypReportData.ReportName = "SAVE2") Then

  For Row = 1 To 

   HypReportData.DisplayedData.NumRows

    HypReportData.DisplayedData.RowNum = Row

    For Col = 1 To 

      HypReportData.DisplayedData.NumCols

      HypReportData.DisplayedData.ColNum = Col

      bOK = HypReportData.DisplayedData.IsZero

      If bOK = True Then

        bOK = HypReportData.DisplayedData.

        SetNumericValue(10)

      End If

    Next Col

  Next Row

End If

End Function
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Methods and Properties of Validations OLE 
Classes

The following OLE classes are available for validating data:

� IIHypReportData

� IIDisplayedData

� IICompressedData

IIHypReportData
IIHypReportData is passed to each of the three validations functions written in 
Visual Basic. The following sections describe its methods and properties.

DisplayedData As Object

Description

Object that can be used to access data as viewed in the Schedule.

CompressedData As Object

Description

Object that can be used to access data as viewed in Hyperion Enterprise Reporting 
Windows Client.

ProductName As String Function

Description

Returns the product name.

Example

Dim Str1 As String

Str1 = HypReportData.ProductName
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ApplicationName As String Function

Description

Returns the application name.

Example

Dim Str1 As String

Str1 = HypReportData.ApplicationName

ReportName As String Function

Description

Returns the report name.

Example

Dim Str1 As String

Str1 = HypReportData.ReportName

UserID As String Function

Description

Returns the user ID.

Example

Dim Str1 As String

Str1 = HypReportData.UserID

NumPOVKeys As Integer Function

Description

Returns the number of POV dimensions.
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Example

Dim NumPOV As Integer

NumPOV = HypReportData.NumPOVKeys

POVKeyDesc(POVKeyIndex As Integer) As String Function

Description

Returns the POV dimension name, given the POV Key Index.

Example

Dim Str1 As String

Str1 = HypReportData.POVKeyDesc(1)

AppPOV(POVKeyIndex As Integer) As String Function

Description

Returns the POV dimension value.

Example

Dim Str1 As String

Str1 = HypReportData.AppPOV(1)

Sub CalculateReport Function

Description

Recalculates values in the report.

Example

HypReportData.CalculateReport
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Sub RefreshReport Function

Description

Redraws the schedule.

Example

HypReportData.RefreshReport

IIDisplayedData
An IIDisplayedData object can be retrieved through IIHypReportData. It provides 
access to data using row and column numbers from the  schedule.  The following 
sections describe its methods and properties.

NumRows As Long Function

Description

Returns the number of rows in a report.

Example

Dim NumOfRows As Long

NumOfRows = HypReportData.DisplayedData.NumRows

NumCols As Long Function

Description

Returns the number of columns in a report.

Example

Dim NumOfCols As Long

NumOfCols = HypReportData.DisplayedData.NumCols
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RowNum As Long Property

Description

This property holds the current row number. It is initialized to the row number of 
the selected cell when ValidateEditedCell is executed. You can either set or get the 
current row number.

Example

Dim RowNumber As Long

HypReportData.DisplayedData.RowNum = 2

RowNumber = HypReportData.DisplayedData.RowNum

ColNum As Long Property

Description

This property holds the current column number. It is initialized to the column 
number of the selected cell when ValidateEditedCell is executed. You can either 
set or get the current column number.

Example

Dim ColNumber As Long

HypReportData.DisplayedData.ColNum = 2

ColNumber = HypReportData.DisplayedData.ColNum

ReadOnly As Boolean Property

Description

This property sets the read-only flag for a specific cell.

Example

Dim ColNumber As Long

Dim RowNumber As Long
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HypReportData.DisplayedData.ColNum = 1 

HypReportData.DisplayedData.RowNum = 1

HypReportData.DisplayedData.ReadOnly = True

GetNumericValue As Double Function

Description

This function retrieves the numeric value of the current row and column number.

Example

Dim ColNumber As Long

Dim RowNumber As Long

Dim CellValue As Double

HypReportData.DisplayedData.ColNum = 1 

HypReportData.DisplayedData.RowNum = 1

CellValue = HypReportData.DisplayedData.GetNumericValue

SetNumericValue (ByVal dbValue As Double) As Boolean 
Function

Returns

TRUE if it succeeds, and FALSE if it does not succeed.

Description

This function sets the numeric value of the current row and column number.

Example

Dim ColNumber As Long

Dim RowNumber As Long

Dim OK As Boolean
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HypReportData.DisplayedData.ColNum = 1 

HypReportData.DisplayedData.RowNum = 1

OK = HypReportData.DisplayedData.SetNumericValue(10)

GetTextValue As String Function

Description

This function retrieves the text value of the current row and column number.

Example

Dim ColNumber As Long

Dim RowNumber As Long

Dim CellValue As String

HypReportData.DisplayedData.ColNum = 1 

HypReportData.DisplayedData.RowNum = 1

CellValue = HypReportData.DisplayedData.GetTextValue

SetTextValue (ByVal lpcstrText As String) As Boolean 
Function

Returns

TRUE if it succeeds, and FALSE if it does not succeed.

Description

This function sets the text value of the current row and column number.

Example

Dim ColNumber As Long

Dim RowNumber As Long

Dim OK As Boolean
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HypReportData.DisplayedData.ColNum = 1 

HypReportData.DisplayedData.RowNum = 1

OK = HypReportData.DisplayedData.SetTextValue(“Hello”)

IsValueNumeric As Boolean Function

Description

Returns TRUE if the current cell is of type numeric; otherwise, it returns FALSE.

Example

Dim IsCellNumeric As Boolean

IsCellNumeric = HypReportData.DisplayedData.IsValueNumeric

IsNoData As Boolean Function

Description

Returns TRUE if the current cell has no data; otherwise, FALSE is returned.

Example

Dim IsCellNoData As Boolean

IsCellNoData = HypReportData.DisplayedData.IsNoData

IsZero As Boolean Function

Description

Returns TRUE if the current cell is Zero; otherwise, FALSE is returned.

Example

Dim IsCellZero As Boolean

IsCellZero = HypReportData.DisplayedData.IsZero
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IsDivideByZero As Boolean Function

Description

Returns TRUE if the current cell is Divide By Zero; otherwise, FALSE is returned.

Example

Dim IsCellDBZ As Boolean

IsCellDBZ = HypReportData.DisplayedData.IsDivideByZero

IsError As Boolean Function

Description

Returns TRUE if the current cell is an Error cell; otherwise, FALSE is returned.

Example

Dim IsCellError As Boolean

IsCellError = HypReportData.DisplayedData.IsError

IsReadOnlyByApp As Boolean Function

Description

Returns TRUE if the current cell is report calculated, application calculated, or 
locked; otherwise, FALSE is returned.

Example

Dim IsCellAppReadOnly As Boolean

IsCellAppReadOnly = HypReportData.DisplayedData.IsReadOnlyByApp
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ErrorCode As Short Function

Description

Returns the error code of the last executed function. An error code of 0 means that 
the last function was successful.

Example

Dim ErrorCode As Short

ErrorCode = HypReportData.DisplayedData.ErrorCode

ErrorDescription As Variant Function

Description

Returns the error description of the last executed function.

Example

Dim ErrorDesc As String

ErrorDesc = HypReportData.DisplayedData.ErrorDescription

CellPOV(POVKeyIndex As Integer) As String Function

Description

Returns the POV dimension value given a dimension index.

Example

Dim POVKeyName As String

POVKeyName = HypReportData.DisplayedData.CellPOV(1)
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GetCompressedCell(ByRef RowNum As Long, ByRef 
ExpandedRowIndex As Long, ByRef ColNum As Long,ByRef 
ExpandedColIndex As Long) As Boolean Function

Note: This function is only available in VB 4.0 or 5.0.

Description

Retrieves the equivalent compressed Row/Col index of the current displayed cell.

Example

Dim RowNum As Long

Dim ColNum As Long

Dim ExpandedRowIndex As Long

Dim ExpandedColIndex As Long

Dim OK As Boolean

HypReportData.DisplayedData.RowNum = 2

HypReportData.DisplayedData.ColNum = 3

OK = HypReportData.DisplayedData.GetCompressedCell (RowNum, 
ExpandedRowIndex,

ColNum, ExpandedColIndex )

IsDirty As Boolean Function

Description

Returns TRUE if the current cell has been modified; otherwise, FALSE is 
returned.

Example

Dim IsCellDirty As Boolean

IsCellDirty = HypReportData.DisplayedData.IsDirty
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SetFocus As Boolean Function

Description

Changes the focus of the current cell.

Example

HypReportData.DisplayedData.RowNum = 2

HypReportData.DisplayedData.ColNum = 3

HypReportData.DisplayedData.SetFocus 

IICompressedData

An IICompressedData object can be retrieved through IHypReportData. It 
provides access to data using row and column numbers from the Hyperion 
Enterprise Reporting Windows Client product. The following sections describe its 
methods and properties.

NumRows As Long Function

Description

Returns the number of rows in a report.

Example

Dim NumOfRows As Long

NumOfRows = HypReportData.CompressedData.NumRows

NumExpandedRows (RowNum As Long) As Long Function

Description

Returns the number of expanded rows, given a row number.
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Example

Dim NumOfExpRows As Long

NumOfExpRows = HypReportData.CompressedData.NumExpandedRows(1)

NumCols As Long Function

Description

Returns the number of columns in a report.

Example

Dim NumOfCols As Long

NumOfCols = HypReportData.CompressedData.NumCols

NumExpandedCols (ColNum As Long) As Long Function

Description

Returns the number of expanded columns, given a column number.

Example

Dim NumOfExpCols As Long

NumOfExpCols = HypReportData.CompressedData.NumExpandedCols(1)

RowNum As Long Property

Description

This property holds the current row number. It is set to the current row number 
when ValidateEditedCell is executed. You can either set or get the current row 
number.

Example

Dim RowNumber As Long



460 �

Hyperion Schedules

Hyperion Enterprise Reporting Windows Client User’s Guide

HypReportData.CompressedData.RowNum = 2

RowNumber = HypReportData.CompressedData.RowNum

ExpandedRowIndex As Long Property

Description

This property holds the current expanded row number index. It is set to the current 
row index number when ValidateEditedCell is executed. You can either set or get 
the current expanded row index number.

Example

Dim ExpRowNumberIndex As Long

HypReportData.CompressedData.ExpandedRowIndex = 2

ExpRowNumberIndex = HypReportData.CompressedData.ExpandedRowIndex

ColNum As Long Property

Description

This property holds the current column number. It is set to the current column 
number when ValidateEditedCell is executed. You can either set or get the current 
column number.

Example

Dim ColNumber As Long

HypReportData.CompressedData.ColNum = 2

ColNumber = HypReportData.CompressedData.ColNum
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ExpandedColIndex As Long Property

Description

This property holds the current expanded column number index. It is set to the 
current column index number when ValidateEditedCell is executed. You can 
either set or get the current expanded column index number.

Example

Dim ExpColNumberIndex As Long

HypReportData.CompressedData.ExpandedColIndex = 2

ExpColNumberIndex = HypReportData.CompressedData.ExpandedColIndex

ReadOnly As Boolean Property

Description

This property sets or unsets the read only flag for a specific cell.

Example

Dim ColNumber As Long

Dim ExpColIndex As Long

Dim RowNumber As Long

Dim ExpRowIndex As Long

HypReportData.CompressedData.ColNum = 1

HypReportData.CompressedData.ExpandedColIndex = 1

HypReportData.CompressedData.RowNum = 1

HypReportData.CompressedData.ExpandedRowIndex = 1

HypReportData.CompressedData.ReadOnly = True



462 �

Hyperion Schedules

Hyperion Enterprise Reporting Windows Client User’s Guide

GetNumericValue As Double Function

Description

This retrieves the numeric value of the current row and column number.

Example

Dim ColNumber As Long

Dim RowNumber As Long

Dim CellValue As Double

HypReportData.CompressedData.ColNum = 1 

HypReportData.CompressedData.RowNum = 1

CellValue = HypReportData.CompressedData.GetNumericValue

SetNumericValue (ByVal dbValue As Double) As Boolean 
Function

Description

Sets the numeric value of the current row and column number. It returns TRUE if 
it succeeds and FALSE if it does not succeed.

Example

Dim ColNumber As Long

Dim RowNumber As Long

Dim OK As Boolean

HypReportData.CompressedData.ColNum = 1 

HypReportData.CompressedData.RowNum = 1

OK = HypReportData.CompressedData.SetNumericValue(10)
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SetTextValue (ByVal lpcstrText As String) As Boolean 
Function

Description

Sets the text value of the current row and column number. It returns TRUE if it 
succeeds and FALSE if it does not succeed.

Example

Dim ColNumber As Long

Dim RowNumber As Long

Dim OK As Boolean

HypReportData.CompressedData.ColNum = 1 

HypReportData.CompressedData.RowNum = 1

OK = HypReportData.CompressedData.SetTextValue(“Hello”)

GetTextValue As String Function

Description

Retrieves the text value of the current row and column number.

Example

Dim ColNumber As Long

Dim RowNumber As Long

Dim CellValue As String

HypReportData.CompressedData.ColNum = 1 

HypReportData.CompressedData.RowNum = 1

CellValue = HypReportData.CompressedData.GetTextValue
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IsValueNumeric As Boolean Function

Description

Returns TRUE if the current cell is of type numeric; otherwise, FALSE is returned.

Example

Dim IsCellNumeric As Boolean

IsCellNumeric = HypReportData.CompressedData.IsValueNumeric

IsNoData As Boolean Function

Description

Returns TRUE if the current cell has no data; otherwise, FALSE is returned.

Example

Dim IsCellNoData As Boolean

IsCellNoData = HypReportData.CompressedData.IsNoData

IsZero As Boolean Function

Description

Returns TRUE if the current cell is Zero; otherwise, FALSE is returned.

Example

Dim IsCellZero As Boolean

IsCellZero = HypReportData.CompressedData.IsZero

IsDivideByZero As Boolean Function

Description

Returns TRUE if the current cell is Divide By Zero; otherwise, FALSE is returned.
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Example

Dim IsCellDBZ As Boolean

IsCellDBZ = HypReportData.CompressedData.IsDivideByZero

IsError As Boolean Function

Description

Returns TRUE if the current cell is an Error cell; otherwise, FALSE is returned.

Example

Dim IsCellError As Boolean

IsCellError = HypReportData.CompressedData.IsError

IsReadOnlyByApp As Boolean Function

Description

Returns TRUE if the current cell is report calculated, application calculated, or 
locked. Otherwise FALSE is returned.

Example

Dim IsCellAppReadOnly As Boolean

IsCellAppReadOnly = HypReportData.CompressedData.IsReadOnlyByApp

ErrorCode As Short Function

Description

Returns the error code of the last executed function.

Example

Dim ErrorCode As Short

ErrorCode = HypReportData.CompressedData.ErrorCode
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ErrorDescription As Variant Function

Description

Returns the error description of the last executed function.

Example

Dim ErrorDesc As String

ErrorDesc = HypReportData.CompressedData.ErrorDescription

CellPOV(POVKeyIndex As Integer) As String Function

Description

Returns the POV Key value, given a dimension index.

Example

Dim POVKeyName As String

POVKeyName = HypReportData.CompressedData.CellPOV(1)

GetDisplayedCell(ByRef RowNum As Long, ByRef ColNum As 
Long) As Boolean Function

Note: This function is only available in VB 4.0 or 5.0.

Description

Retrieves the equivalent displayed row and column number of the current 
compressed cell.

Example

Dim RowNum As Long

Dim ColNum As Long

Dim bOK As Boolean

HypReportData.CompressedData.ColNum = 2
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HypReportData. CompressedData.RowNum = 1

HypReportData. CompressedData.ExpandedColIndex = 2

HypReportData. CompressedData.ExpandedRowIndex = 1

bOK = HypReportData. CompressedData.GetDisplayedCell( RowNum, ColNum 
)

IsDirty As Boolean Function

Description

Returns TRUE if the current cell has been modified; otherwise, FALSE is 
returned.

Example

Dim IsCellDirty As Boolean

I CellDirty = HypReportData.CompressedData.IsDirty 
SetFocus As Boolean Function

Description

Changes the focus of the current cell. It returns TRUE if successful; otherwise, 
FALSE is returned.

Example

HypReportData.CompressedData.RowNum = 2

HypReportData.CompressedData.ColNum = 3

HypReportData.CompressedData.SetFocus 
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Frequently Asked Questions

This chapter provides the answers to commonly asked questions about Hyperion 
Schedules that are not covered in the other sections of this guide. 

If you are experiencing additional problems, or have questions that are not covered 
in this chapter, refer to the Hyperion Schedules Release Notes that came with this 
guide. 

Why can’t I open a compound report from within Hyperion 
Schedules?

Compound reports are currently supported only within Hyperion Enterprise 
Reporting Windows Client. 

Why can’t I input into green cells within Hyperion Schedules?

Green cells indicate that it is either a calculated account or not an input account.

I cannot enter data into input level cells. Why?

Here are some reasons why you cannot input into a schedule:

� The user does not have security access.

� The period is locked.

� The view is incorrect; it needs to be CTD or PER, not YTD.

Why can’t I change my rows/columns in Hyperion Schedules?

Hyperion Schedules is designed for entering data only. Any changes to 
columns/rows should be done using Hyperion Enterprise Reporting Windows 
Client.

Applies To:
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Why can’t I access cells with calculated formulas?

These cells contain display-only data which is either calculated based on Hyperion 
Enterprise Reporting Windows Client formulas or from Hyperion Enterprise 
application calculations. The value changes when you calculate formulas.
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Here are some of the terms in the Hyperion Enterprise Reporting Windows Client 
User’s Guide.

Access rights. An option that determines whether a user can perform tasks or 
access specific application elements. 

Accounts. Location of data in entities, categories, and periods.

Add-in file. A small file you load within a larger software program which 
enhances the functions and capabilities of the larger program. For example, 
Hyperion Analyst is an add-in file you load within Microsoft Excel or Lotus 1-2-3.

Application. A set of organizations, accounts, data categories and other system 
dimensions that you use together.

Book. A container that holds a group of similar reports. Books may specify 
dimension sections, and/or dimension changes.

Book set. A group of books that you combine for convenience. For example, you 
might have a book set that includes all month-end books. 

Book windows. Where books are built and maintained.

Category. The classifications of data. You use categories to differentiate 
between the different types of data you can maintain, such as budget, actual, and 
forecast data. 

Compound report. A compound report is a container for several reports that you 
want to display together. 

Dimension. A holder for information.

Glossary
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Dimension Icon (Excel). An icon on a Microsoft Excel worksheet symbolically 
representing a dimension ID. You click on a dimension icon to access dialog boxes 
where you select the specific dimension IDs for the worksheet point of view and 
the columns and rows. Dimension Icons are called Dimension Names in Lotus 
1-2-3. See also Dimensions.

Dimension Name (Lotus). An icon on a worksheet symbolically representing a 
dimension ID. You click on a dimension name to access dialog boxes where you 
select the specific dimension IDs for the worksheet point of view and the columns 
and rows. Dimension Names are called Dimension Icons in Microsoft Excel. See 
also Dimensions.

Dimensions. Lotus or Excel worksheet icons representing point of view 
information. You can assign dimensions in the worksheet by clicking on 
dimension icons in Hyperion Analyst and selecting different IDs and functions.

Entities. The reporting units in an organization. Entities can represent any 
reporting units, such as subsidiaries, divisions, plants, or products. 

Expansions. An expansion shows detail data from dimension IDs in a worksheet. 
You expand an entity by clicking on the plus sign (+) next to the dimension ID.

Financial functions. Functions that retrieve and calculate financial data, such as 
the ratios between the values in two columns or rows.

Footer. Text that appears at the bottom of each page in a report.

Formula. A series of functions and parameters you use to retrieve and calculate 
data from a Hyperion Solutions product application.

Function. A mathematical code you use within a formula to retrieve and calculate 
data from a Hyperion Solutions product application. See also Formula.

Header. Text that appears at the top of each page in a report.

Hyperion DataExtend. A product that allows you to enter text in Hyperion 
Schedules and include it in reports as data or headings.

Hyperion Enterprise Reporting Windows Client. A powerful graphical tool 
for presenting financial data in formats such as cash management reports, 
forecasts, profit and loss statements, and balance sheets. With Hyperion Enterprise 
Reporting Windows Client, you can retrieve and calculate data from a Hyperion 
Solutions product application and specify how to present it.

Hyperion Schedules. A spreadsheet style interface that translates Hyperion 
reports into forms for data entry.
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Impact future categories. An option used to specify that changes to a prior 
linked category in the current category should impact periods in the current 
category. You might create formulas in methods that refer to and have 
dependencies on values in prior categories. As values change in prior categories, 
this option controls whether to impact values in future categories.

Local headings. Replaces the descriptions of individual dimensions based on 
other dimension settings in the report.

Main window. Starting point for all tasks in Hyperion Solutions products.

Menu bar. Lists the menus you can use to perform different tasks.

Notations. Text entries such as descriptions or comments.

Online help. Online navigational help system that contains procedural 
information that is also in the printed documentation.

Operator key. Keyboard keys that perform functions that make data entry faster 
and easier.

PDF. An Adobe Acrobat online electronic guide that contains conceptual and 
procedural information.

Periods. Time segments within categories.

Point of View. A set of dimensions you define to specify which data is access 
when you start an application.

Point of view bar. Shows the default dimensions for the current session.

Preview window. Where reports can be previewed before you print the report.

Query. A set of dimension IDs arranged on a worksheet to retrieve data from a 
Hyperion Solutions product application.

Proportion and elimination detail and translation detail. A feature used to 
store and report on proportion and elimination detail for entities during the 
consolidation process. Proportion detail includes post-translated values after the 
system executes consolidation methods and applies the percent consolidation for 
each dependent. Elimination detail includes all intercompany eliminations that the 
system has processed for each dependent. If you store proportion and elimination 
detail, you can select the particular categories and parent entities for which you 
want to store this detail. 

Refresh. A function which updates the application with any new information. 
Refresh also redraws the screen.
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Registry. A database used by the Windows 95/NT operating systems to store 
configuration information. Most Windows applications write data to the Registry 
during installation, and you often need to register newly installed files in the 
Registry in order for your software program to function properly.

Reports. Retrieve and calculate data from any Hyperion Solutions product 
application and specify how to present it.

Report set. A group of reports that you group together for convenience. For 
example, you might have a report set that includes all forecast reports.

Report windows. Where reports are built and maintained.

Report wizard. A graphical tool that you use to create dynamic, ad hoc queries 
within Hyperion Enterprise Reporting Windows Client.

Right mouse button. Provides quick access to a menu with a list of functions and 
reports.

SQL (Structured Query Language). A standardized query language for 
requesting information from a database. It supports distributed databases - 
databases spread out over several computer systems, such as Hyperion Enterprise. 
This enables several users on a local-area network (LAN) to access the same 
database simultaneously.

Status bar. Shows information about the program in which you are currently 
working.

Text functions. Functions that retrieve alphanumeric text, such as dimension IDs 
or descriptions.

Title bar. Identifies the system in which you are working.

Toolbar. Provides quick mouse access to the most frequently used menu items in 
Hyperion Solutions products.

User ID. A user name used to log on to a Hyperion Solutions product.

View menu. . Used to display or hide the toolbar, point of view bar, status bar, 
etc.
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A24 field, 117
about Hyperion DataExtend, 382
About Hyperion Schedules, 393
ABS function, 225
absolute operand, 106
Absolute Value function (@ABS), 225
ACC keyword, 108
access online help, 398
account attributes, for Hyperion Solutions 

applications, 145
Account Code function (@ACODE), 226
account default attributes, 144
Account keyword (ACC), 108
account signs, 144
accounts, selecting, 406
ACODE function, 226
Add to Set icon, 179
add-in files, 333, 334, 357, 358
adding to the application, 187
administrators’ tasks, 430
All Ancestor Members function (@ANC), 231
all column, row headings, and data format setting 

inheritances, 143
All function (@ALL), 227
All Siblings to the Right function (@SRA), 316
ALT function, 229
Always suppress option, 157
AMCODE function, 230
Analyst, 385
Analyst, see Hyperion Analyst
Analyst.ini file, 350, 352
ANC function, 230, 231

APD function, 232
APN function, 233
APP function, 233
Application Description function (@APD), 232
Application ID function (@APP), 233
Application Name function (@APN), 233
ApplicationName As String Function, 448
applications

opening, 360, 363
saving data to, 361

applications, specifying for batch files, 200
AppPOV(POVKeyIndex As Integer) As String, 449
arithmetical symbols, 101
AS function, 234
ASCII format

printing files in, 196
saving files in, 195

ASK function, 235
Asset account attribute, for Hyperion Enterprise, 145
attribute option, 151
attributes for accounts, 144
Available options, to search for dimension IDs, 85
Average function (@AVG), 236
AVG function, 236
axes, Columns, Reports and Rows, 133

B
BAL account attributes, for Hyperion Solutions 

applications, 145
bar, splitter, 86
BAS field, 115
BAS function, 237
Base Level function (@BAS), 237

Index
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batch files, 198
batch printing, 196, 198, 206
BET function, 238
bitmaps See icons
blank columns and rows, inserting, 53
book areas

copying, 51
cutting, 50
deleting, 54
deselecting, 49
pasting, 52
selecting, 49
undoing deletions, 54

book options, 57
book sections

editing, 96
for retrieving data for series of dimensions, 76
nested, 76

book sets
adding reports to, 184
creating, 181
deleting, 182
editing, 183
overview, 180
removing books from, 185
specifying for saved book, 27

book summaries, 64
books

adding to the application, 187
changing dimensions in, 80
closing, 27
compiling, 186
creating, 26
deleting from the application, 188
deselecting areas in, 49
dimension changes in, 80
editing, 45
editing summaries, 64
importing, 187
inserting reports in, 63
inserting sections in, 93
managing overview, 179
opening, 49
overview, 21, 25
overview of managing, 179
point of view, 34

previewing, 193
printing, 193
printing active, 195
printing batches, 196, 198, 206
removing from sets, 185
renaming, 27, 185
replacing reports in, 64
saving, 27
selecting areas in, 49
selecting ranges, 50
setting options, 57
setting point of view, 43

border format option, 140
border options, 148
BOT function, 239
ByRef ColNum As Long, 457
ByRef ExpandedColIndex As Long) As Boolean, 

457
ByRef ExpandedRowIndex As Long, 457

C
Calculate Difference function (CHG), 244
calculating formulas, 426
calculation order option, 150, 151
calculations/recalculations, 418, 422
calculator keys, 422
case sensitivity, in batch commands, 202
CAT keyword, 109
categories, selecting, 405
Category keyword (CAT), 109
CCVT account attributes, for Hyperion Essbase, 145
CDABET function, 366
CDACAL function, 367
CDACHG function, 368
CDADES function, 368
CDAINP function, 369
CDAKEY function, 370
CDALAB function, 371
CDALNK function, 372
CDAPAB function, 373
CDAPBE function, 375
CDAPCH function, 376
CDAPCT function, 377
CDASTR function, 378
CDAVAL function
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and pasting values, 363
description, 380
examples, 380
formulas, 373
saving to an application database, 380

cell colors, defining, 416
CELL function, 240
CellDirty, 467
CellPOV(POVKeyIndex As Integer) As String, 456, 

466
cells

calculated, 416
colors for, 416
highlighting data in, 424
unsaved, 416

center headings across columns, 158
CHANGE function, 242
change point of view (POV) option, 360
changing the worksheet point of view, 341
CHART function, 243
Chart Logic Expansion function (@CHART), 243
Chart Method Code function (@AMCODE), 230
check box states, 143
Check icon, 180
CHG function, 244
Children function (@CHL), 245
CHL function, 245
CMCODE function, 246
CMO function, 247
collapse data, 349
collapsing dimension values, 135
ColNum As Long Property, 451, 460
colors, cell, 416
column data format setting inheritance, 143
column heading defaults, 72
column headings format setting inheritance, 143
Column page format option, 190
column reference operand, 106
columns, 427

copying, 51
cutting, 50
in reports, 72
inserting blank, 53
pasting, 52
sorting, 160

Columns axis, 133

comments, in batch commands, 202
compound reports

copying standard information, 30
creating, 30
default layout, 30
layouts, 30
overview, 28

CompressedData, 447
CompressedData As Object Function, 447
CON function, 249
conditional formatting, 162
CONSOL keyword, 110
consolidation detail, selecting, 411
Consolidation Method Code function (@CMCODE), 

246
Consolidation Status function (@PSF), 304
convert values to functions, 351
copying data, 424
CPN function, 250
CRB file extension, 28
Credits field, 115
criteria format options

setting, 162
using, 142

criteria statements, 162
for Hyperion Enterprise, 164
for Hyperion Essbase, 165

criteria-based formatting, 162
CUM field, 118
CUR function, 251
CURCY function, 252
CURR keyword, 111
Currency Text function (@CURCY), 252
currency, selecting a, 412
Current alias table function (@ALT), 229
Current Category Period Number function (@CMO), 

247
Current Date function (@TOD), 323
Current Dimension Setting function (@CUR), 251
Current Entity Scale function (@SCALE), 310
Current Period Number function (CPN), 250
Current Reporting Directory function (@RPD), 309
Current Time function (@TIM), 321
customize query formats, 352
customizing

dimensions, 21
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formula bar, 23
icons in the desktop, 21
number formats, 146
point of view bar, 23

D
DAT function, 255
DAT keyword, 112
data

copying, 424
deleting, 426
detail, 135
editing formulas for, 125
extracting from Hyperion DataExtend, 390
formulas for, 100
loading to Hyperion DataExtend, 386, 389
moving from cells, 425
pasting, 52, 424
previewing before printing, 428
printing, 429
removing from cells, 425
saving to a text file, 428, 429
summary, 135
viewing in a field, 413

data entry, 421 to 427
data entry keys, 422
data formulas

changing types, 125
editing, 125
expressions in, 101

Data page format option, 190
data, changing, 361, 380
data, collapsing/expanding, 349
database retrieval operand, 106
DataExtend see Hyperion DataExtend
Date masks, 254
Debits field, 115
default expansions, 348
default point of view, 363
default printer, 428
defaults

column headings, 72
dimension settings, 33, 37
fonts, 190
for compound reports, 30

Hyperion Enterprise Reporting Windows Client 
point of view, 37

label setup, 191, 193
page format, 190
point of view for books, 43
point of view for reports, 23, 44
row headings, 72

definitions viewing, 128
delete data, 426
delete fields, 386
Delete icon, 179
DEP function, 257
DES function, 258
Descendant Members function (@DSC), 259
Descendants at level 0 function (@BOT), 239
Detail suppress option, 157
detailed data, 135
dialog boxes, 188

Dimension, 80
Edit Dimensions, 133
Edit Dimensions - Account, 109
Edit Formulas, 225
Expression, 101
Format, 143
Manage Expansions, 174, 176
Manage Reports and Books, 179, 180
Pivot Table Options, 132
point of view, 36
Report Options, 117
Report Wizard, 138
Run Task, 204
Save As, 27

DIF field, 117
dimension assignment methods, 71
dimension buttons, 21
Dimension Change function (CHANGE), 242
dimension changes

and dimension ID, 78, 80
editing, 92
in books, 80
in reports, 78
inserting, 91

Dimension Description function (@DES), 258
Dimension dialog box, 80
dimension expansion option, 174
dimension functions, assigning, 89
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Dimension ID function (@LAB), 275
dimension ID icons, 39, 82
dimension IDs, 347

assigning, 88
filters to specify, 83
selected list to assign items, 87

dimension lists, assigning, 90
dimension manage expansion option, 176
dimension settings

defaults, 33, 37
for books, 43
for reports, 23, 44

dimension values, 135
dimensions, 344, 346, 381, 384, 385, 387, 388, 430

changes and Hyperion Enterprise Reporting 
Windows Client point of view in books, 80

changes and Hyperion point of view in reports, 79
changes using Dimension dialog box, 80
changing column width, 21
copying with format, 169
copying without format, 168
customizing, 21
default settings for books, 43
default settings for reports, 23, 44
inserting changes, 71
keywords for Hyperion Enterprise, 107

display format options
division by zero, 156
error, 156
no data, 156
setting, 156
using, 141
zero, 156

display hidden rows and columns, 427
DisplayedData As Object Function, 447
division by zero display option, 156
draft reports, 167
drag and drop

with Lotus 1-2-3, 346
with Microsoft Excel, 345

drill-through, 350
DSC function, 259
DUR function, 261
DWV field, 117

E
ECODE function, 262
edit dimensions, 344
Edit Dimensions - Account dialog box, 109
Edit Dimensions dialog box, 133
Edit Formulas dialog box, 225
Edit icon, 179
Edit menu, 383, 398, 399
editing dimension changes, 92
edits undo, 54
embedded reports, 28
empty schedules, 28
END function, 263
End of Range function (UNTIL), 325
ENT function, 264
ENT keyword, 113
enter

data, 423
local headings, 421
notations, 420
numeric data, 423

Enter key, 417, 418
Enterprise See Hyperion Enterprise
Enterprise see Hyperion Enterprise
Enterprise, see Hyperion Enterprise
entities, 381, 385, 393, 402, 403, 405, 419
Entity as Parent function (@ENT), 264
Entity Code function (@ECODE), 262
Entity keyword (ENT), 113
error display option, 156
ErrorCode As Short Function, 456, 465
ErrorDescription As Variant Function, 456, 466
errors, checking for, 186
Essbase See Hyperion Essbase
Evaluate Difference function (BET), 238
Evaluate Percent Change function (PBE), 296
Excel, exporting reports to, 197
Excel, see Microsoft Excel
exiting Hyperion DataExtend, 383
exiting Hyperion Schedules, 396
expand data, 349
EXPAND.REL file, 132
Expand.rel file, 348
ExpandedColIndex As Long Property, 461
ExpandedRowIndex As Long Property, 460
expansion options
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dimension, 174
expansion tag, 174
parent override, 174
position, 174

expansion tag, 176
expansion tag option, 174
expansions, 339, 347 to 350

defining, 173
managing, 176
setting, 174

expansions format option, 142
Expense account attributes, for Hyperion Solutions 

applications, 145
exporting reports to Excel, 197
expression dialog box, 101
expressions

in data formulas, 101
in financial functions, 101
operands in, 106
operators in, 101
with multiple operators, 105

extracting data from Hyperion DataExtend, 390

F
FIE keyword, 114
field data text file, 386, 387, 388
field definitions section, 386
Field keyword (FIE), 114
fields

creating, 385
deleting, 386
uses of, 384

fields, selecting, 413
file

HDCDARET.INI, 362
REPENG.INI, 369

file formats, saving in ASCII text, 195
File menu, 383, 398, 399, 414
File Name function (@FLN), 266
File Title function (@FLT), 267
files

.CRB, 28

.HAQ, 132

.TXT, 195
ASCII format, 196

batch, 198
EXPAND.REL, 132
log, 199
REPENG.INI, 21, 173, 181, 194, 199
RW32.INI, 146, 151
task, 198

files, response, 198
filters summary icon, 83
filters, for specifying dimension IDs, 83
financial functions

expressions in, 101
in data formulas, 126
uses for, 126

Find options, to search for dimension IDs, 85
FIRST function, 265
First ID function (@START), 318
First Sibling to the Left function (@SLF), 315
First Sibling to the Right function (@SRF), 317
First Subaccount function (@FIRST), 265
First Subaccount Set keyword (SUBACC1), 122
first-level subaccount, selecting, 409
FLN function, 266
Flow account attribute, for Hyperion Enterprise, 145
FLT function, 267
font format options

changing defaults, 190
setting, 147
using, 140

fonts, 65
Footer page format option, 190
footers, 65
FOR function, 268
Format dialog box, 143
format options

attributes set for, 147
borders, 140
copying, 168
criteria, 142, 162
display, 141, 156
expansions, 142
fonts, 140, 147
headings, 141
inherited, 142
investigations, 142
number, 140
order of, 142
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shading, 140
shading and borders, 148
sort, 142
sorting, 160
spacing, 141, 153
suppression, 156

format setting inheritances, 143
format settings pasting, 52
format, Microsoft Excel template, 352
formats, 146

copying for reports, 168
customizing number format masks, 146
customizing numbers, 146
for label setup, 191, 193
for pages, 190
verifying, 186

formatted reports, 167
formatting controls overview, 139
formatting reports overview, 139
formula bar, customizing, 23
formulas, 399, 416, 417, 418, 422

calculating, 426
CDAVAL, 373
copying with format, 169
copying without format, 168
dimension settings, 361
editing for data, 125
editing for headings, 128
for data, 100
for headings, 23, 99
functions used in, 365
in Hyperion Retrieve, 364 to 365
inserting in footers, 65
inserting in headers, 65
overview, 99

FRD function, 269
FRE keyword, 119
Frequency Description function (@FRD), 269
Frequency ID function (@FRL), 270
Frequency keyword (FRE), 119
frequency, selecting a, 407
FRL function, 270
FROM function, 271
Function ApplicationName As String Function, 448
function dimension assignment method, 71
function operand, 106

functions, 401, 403, 422
ABS - Absolute Value, 225
ACODE - Account Code, 226
ALL - All, 227
ALT - Current Alias Table, 229
AMCODE - Chart Method Code, 230
ANC - All Ancestor Members, 230, 231
APD - Application Description, 232
APN - Application Name, 233
APP - Application ID, 233
AS - Same As, 234
ASK - Prompt User, 235
assigning for dimensions, 89
assigning with Dimension dialog box, 80
AVG - Average, 236
BAS - Base Level, 237
BET - Evaluate Difference, 238
BOT - Descendants at Level 0, 239
CDABET- Compare Values for Two IDs, 366
CDACAL - Specify Calculated Accounts, 367
CDACHG - Show the Positive Difference 

Between Values, 368
CDADES - Show Descriptions for Dimension 

Settings, 368
CDAINP - Specify Input Accounts, 369
CDAKEY - Change Dimension Settings, 370
CDALAB - Produce IDs for Specified 

Dimensions, 371
CDALNK - Send Values to Hyperion 

Applications, 372
CDAPAB - Show the Percentage Difference 

Between Account Values, 373
CDAPBE - Show Percentage Differences, 375
CDAPCH - Show the Percentage Change 

Between Two Values, 376
CDAPCT- Calculate Percentages, 377
CDASTR - Use Headings to Produce Text, 378
CDAVAL - Produce Values from Applications, 

363, 364, 365, 373, 380
CELL - Specific Cell Value, 240
CHANGE - Dimension Change, 242
CHART - Chart Logic Expansion, 243
CHG - Calculate Difference, 244
CHL - Children, 245
CMCODE - Consolidation Method Code, 246
CMO - Current Category Period Number, 247
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CON - Summary ID, 249
CPN - Current Period Number, 250
CUR - Current Dimension Setting, 251
CURCY - Currency Text, 252
DAT - Period Description, 255
DEP - IDs Immediately Below, 257
DES - Dimension Description, 258
DSC - Descendant function, 259
DUR - Specific Value, 261
ECODE - Entity Code, 262
END - Last ID, 263
ENT - Entity as Parent, 264
FIRST - First Subaccount, 265
FLN - File Name, 266
FLT - File Title, 267
FOR - Section for, 268
for Hyperion Enterprise, quick list of, 209
for Hyperion Essbase, quick list of, 209
FRD - Frequency Description, 269
FRL - Frequency ID, 270
FROM - Start of Range, 271
GEN - Same Generation, 272
IFT - If Then, 273
IND - Indent, 274
LAB - Dimension ID, 275
LAD - Lowest-level Account Description, 276
LAL - Lowest-level Account ID, 277
LAST - Last Subaccount, 278
LIST - List, 280
list of, 219
LOCAL - Local Headings, 281
LRC - Linked Reporting Comments, 282
LRD - Modification Date of a Linked Reporting 

Object, 283
LRF - Linked Reporting Files, 284
LRI - Index of a Linked Reporting Object, 286
LRO - Linked Reporting Objects, 287
LRT - Type of a Linked Reporting Object, 289
LRU - User of a Linked Reporting Object, 290
LVL - Same Level, 291
MUL - Multiply, 292
OFF - Offset of the Current or Optional Period, 

293
PAR - Parent, 295
PBE - Evaluate Percent Change, 296
PCH - Percent Change, 297

PCR - Percent by Row, 298
PCT - Ratios as Percentages, 301
PDES - Partial Description, 302
PLAB - Partial Dimension ID, 303
PSF - Consolidation Status, 304
RAT - Ratio, 305
REPORT- Report in Book, 306
RND - Round Specific Values, 306
RNG - Range, 307
RPD - Current Reporting Directory, 309
SCALE - Current Entity Scale, 310
SED - Set Description function, 311
SET - Set Name function, 312
SIB - Siblings, 312
SLA - Siblings to the Left, 313
SLF - First Sibling to the Left, 315
SRA - All Siblings to the Right, 316
SRF - First Sibling to the Right, 317
SRN - Server Name, 318
START - First ID, 318
SUB - Subaccounts, 319
SUM - Total, 320
TIM - Current Time, 321
TMCODE - Translation Method Code, 322
TOD - Current Date, 323
TOP - Topmost Unowned ID, 324
UNTIL - End of Range, 325
USR - User ID, 326
VWD - View Description, 327
VWL - View ID, 328
WITHSUB - With All Subaccounts, 329
WITHSUB1 - With First-level Subaccs, 330
WLD - Wildcard, 331

functions list, 209

G
GEN function, 272
GetCompressedCell(ByRef RowNum As Long, 457
GetDisplayedCell(ByRef RowNum As Long, ByRef 

ColNum As Long) As Boolean, 466
GetNumericValue As Double Function, 452, 462
GetTextValue As String Function, 453, 463
gridlines, 413
grouping, 180
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H
HAQ file, 132
HDCDARET.INI file, 362
Header page format option, 190
headers

inserting formulas in, 65
pasting, 52
selecting fonts for, 65
setting, 65

headers and footers, 413, 429
headings

editing formulas for, 128
formulas for, 23, 99

headings format options
setting, 158
spacing, 154
using, 141

headings spacing option, 155
Help menu, 398, 399
hidden rows and columns, 427
hide window elements, 413
hide/show expansion signs, 350
HSCHED.INI File, 432
HYPENT.INI file, 403
Hyperion Analyst, 382

and CDAKEY function, 370
menu, 337
point of view, 341
toolbar, 337
using with Hyperion Retrieve, 363
worksheet, 340

Hyperion Data Extend, 420
Hyperion DataExtend

exiting, 383
extracting data from, 386, 390
fields in, 384
icons,toolbar, 384
loading data to, 386, 389
menus, 383
sample field data text file, 388
starting, 382
toolbar, 384

Hyperion Enterprise, 339, 348, 382, 383, 393, 395, 
402, 405, 414

and CDALNK function, 372
book sets, 186

controlling display of IDs in windows, 181
creating reports or books sets with, 181
dimension assignment methods with, 71
ID methods, 115
keywords, 107
point of view inherited by Hyperion Enterprise 

Reporting Windows Client, 37
printing reports for, 195
product driver, specifying for, 200
quick list of functions, 209
Release 4XA only, 402, 403, 411, 412
report options, 55
Reports and Books module, 189
Reports or Books window, 190
saving data to worksheets, 359
specifying application for batch files, 200
using with Hyperion Retrieve, 357, 372
variables in criteria statements, 164
writing values from worksheets, 365

Hyperion Enterprise Reporting Windows Client, 382, 
384, 416, 420

list of functions, 209
point of view, 33

Hyperion Enterprise, functions used with
ABS-Absolute Value, 225
ACODE - Account Code, 226
ALL - All, 227
AMCODE - Chart Method Code, 230
APD - Application Description, 232
APP - Application ID, 233
AS - Same As, 234
ASK - Prompt User, 235
AVG - Average, 236
BAS - Base Level, 237
BET - Evaluate Difference, 238
CELL - Specific Cell Value, 240
Change - Dimension change, 242
CHART - Chart Logic Expansion, 243
CHG - Calculate Difference, 244
CMCODE - Consolidation Method, 246
CMO - Current Category Period Number, 247
CON - Summary IDs, 249
CPN - Current Period Number, 250
CUR - Current Dimension Settings, 251
CURCY - Currency Text, 252
DAT - Period Description, 255
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Date Masks, 254
DEP - IDs Immediately Below, 257
DES - Dimension Descriptions, 258
DUR - Specific Value, 261
ECODE - Entity Code, 262
END - Last ID, 263
ENT - Entity as Parent, 264
FIRST - First Subaccount, 265
FLN - File Name, 266
FLT - File Title, 267
FOR - Section For, 268
FRD - Frequency Description, 269
FRL - Frequency ID, 270
FROM - Start of Range, 271
IFT - If Then, 273
LAB -Dimension IDs, 275
LAD - Lowest-level Account Description, 276
LAL - Lowest-level Account ID, 277
LAST - Last Subaccount, 278
LIST - List, 280
LOCAL - Local Headings, 281
MUL - Multiply, 292
PAR - Parent, 295
PBE - Evaluate Percent Change, 296
PCH - Percent Change, 297
PCR - Percent by Row, 298
PCT - Ratios as Percentages, 301
PDES - Partial Description, 302
PLAB - Partial Dimension ID, 303
PSF - Consolidation Status, 304
RAT - Ratios, 305
REPORT - Report in Book, 306
RND - Round Specific Values, 306
RNG - Range, 307
SCALE - Current Entity Scale, 310
START - Starting Period, 318
SUB - Subaccounts, 319
SUM - Total, 320
TIM - Current Time, 321
TMCODE - Translation Method Code, 322
TOD - Current Date, 323
UNTIL - End of Range, 325
USR - User ID, 326
VWD - View Description, 327
VWL - View ID, 328
WITHSUB - With Subaccounts, 329

WITHSUB1 - With 1st Subaccounts, 330
Hyperion Essbase

account attributes, 145
available dimension lists, 90
case sensitivity in batch files, 202
dimension assignment methods with, 71
quick list of functions, 209
report options, 56
specifying application for batch files, 200
specifying product drivers, 200
variables in criteria statements, 165

Hyperion Essbase, functions used with
ABS - Absolute Value, 225
ALL - All, 227
ALT - Current Alias Table, 229
ANC - All Ancestor Members, 231
APD - Application Description, 232
APN - Application Name, 233
APP - Application ID, 233
AS - Same As, 234
ASK - Prompt User, 235
AVG - Average, 236
BAS - Base Level, 237
BET - Evaluate Difference, 238
BOT - Members at Level 0, 239
CELL - Specific Cell Value, 240
CHANGE - Dimension Change, 242
CHG - Calculate Difference, 244
CHL - Children, 245
CUR - Current Dimension Settings, 251
Date Masks, 254
DEP - IDs Immediately Below, 257
DES - Dimension Descriptions, 258
DSC - Descendant Members, 259
DUR - Specific Value, 261
FLN - File Name, 266
FLT - File Title, 267
FOR - Section For, 268
FROM - Start of Range, 271
GEN - Same Generation, 272
IFT - If Then, 273
IND - Indent, 274
LAB - Dimension IDs, 275
LIST - List, 280
LOCAL - Local Headings, 281
LRC - Linked Reporting Comments, 282
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LRD - Modification Date of a Linked Reporting 
Object, 283

LRF - Linked Reporting Files, 284
LRI - Index of a Linked Reporting Object, 286
LRO - Linked Reporting Object, 287
LRT - Type of a Linked Reporting Object, 289
LRU - User of a Linked Reporting Object, 290
LVL - Same Level, 291
MUL - Multiply, 292
OFF - Offset of the Current or Optional Period, 

293
PBE - Evaluate Percent Change, 296
PCH - Percent Change, 297
PCR - Percent by Row, 298
PCT - Ratios as Percentages, 301
RAT - Ratios, 305
REPORT - Report in Book, 306
RND - Round Specific Values, 306
RNG - Range, 307
RPD - Current Reporting Directory, 309
SED - Set Description, 311
SET - Set Name, 312
SIB - Siblings, 312
SLA - Siblings to the Left, 313
SLF - First Sibling to the Left, 315
SRA - All Siblings to the Right, 316
SRF - First Sibling to the Right, 317
SRN - Server Name, 318
SUM - Total, 320
TIM - Current Time, 321
TOD - Current Date, 323
TOP - Topmost Member, 324
UNTIL - End of Range, 325
USR - User ID, 326
WITHSUB - With Subaccounts, 329
WITHSUB1 - With 1st Subaccs, 330
WLD - Wildcard, 331

Hyperion Retrieve, 333, 338, 351
formulas, 364
functions overview, 365 to 366
overview, 357
point of view, 367, 378

Hyperion Schedules, 381
data entry keys, 422
exiting, 396
gridlines, 413

headers and footers, 413
icons, toolbar, 400
main window, 397 to 398
menus, 398
operator keys, 422
overview, 393
point of view bar, 413
starting, 395
status bar, 413
toolbar, 400, 413
window, 397

HypReportData.Compressed.IsDirtyFunctionSetFoc
us As Booleans Function, 467

I
IC1 field, 116
IC2 field, 116
icons

and dimension changes, 79
and dimension changes in books, 80
customizing for the desktop, 21
dimension IDs, 39
filters summary, 83
in Manage Reports and Books dialog box, 179
in Report Wizard, 132
Preview toolbar, 194
Print, 195
representing dimension IDs loaded in memory, 

82
representing dimension sections, 76
selecting to edit dimension changes, 92

icons, toolbar, 384, 400
ID dimension assignment method, 71
ID methods in Hyperion Enterprise, 115
IDs assigning dimension, 88
IDs Immediately Below function (@DEP), 257
IDs, dimension, 347
If Division By Zero suppression option, 157
If Error suppression option, 157
If Expression suppression option, 157
If No Data suppression option, 157
If Then function (IFT), 273
If Zero suppression option, 157
IFT function, 273
IICompressedData, 458
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IIDisplayedData, 450
IIHypReportData Function, 447
import options, 68
Income account attribute, for Hyperion Enterprise, 

145
IND function, 274
Indent function (@IND), 274
Index of a Linked Reporting Object function (@LRI), 

286
inheritance, 143
inherited format options, 142
inherited state, 144
Insert New icon, 179
investigations

defining, 173
format option, 142
setting, 175

investigations, using from a data cell, 415
IsCellDirty, 467
IsDirty As Boolean Function, 457, 467
IsDivideByZero As Boolean Function, 455, 464
IsError As Boolean Function, 455, 465
IsNoData As Boolean Function, 454, 464
IsReadOnlyByApp As Boolean Function, 455, 465
IsValueNumeric As Boolean Function, 454, 464
IsZero As Boolean Function, 454, 464

K
keyboard, 417, 422
keystrokes, 417
keywords

ACC - Account, 108
CAT - Category, 109
CONSOL - Consolidation Detail, 110
CURR - Currency, 111
DAT - Period, 112
ENT - Entity, 113
FIE - Field, 114
for Hyperion Enterprise, 107
FRE - Frequency, 119
list of, 219
overview, 107
PAR - Parent Entity, 121
SUBACC1 - First Subaccount Set, 122
SUBACC2 - Second Subaccount Set, 123

SUBENT - Subentity, 124

L
LAB function, 275
Label page format option, 190
label setup changing defaults, 191, 193
labeling sections, 93, 94
LAD function, 276
LAL function, 277
landscape printing, 30
LAST function, 278
Last ID function (@END), 263
Last Subaccount function (@LAST), 278
layouts, for compound reports, 30
level 1 subaccount, 409
level 2 subaccount, 410
Liability account attribute, for Hyperion Enterprise, 

145
Linked Reporting Comments function (@LRC), 282
Linked Reporting Files function (@LRF), 284
Linked Reporting Objects function (@LRO), 287
List dimension assignment methods, 71
List filters, to specify dimension IDs, 83
List function (LIST), 280
List, of available dimension IDs, 82
lists

assigning dimensions for, 90
assigning with Dimension dialog box, 80

load
Lotus 1-2-3 add-in files, 357
Microsoft Excel add-in files, 357

load add-in files, 334
load data to Hyperion DataExtend, 386
LOCAL function, 281
local headings

defining, 169
setting up in reports, 171

Local Headings function (@LOCAL), 281
local headings, creating, 381
local headings, entering, 421
log files, for reporting Windows Client batch 

commands, 198
logging in, to Hyperion Schedules, 402, 403
logging on, to Hyperion Schedules, 395
logic, 426
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Lotus 1-2-3
and CDAVAL function, 364
and converting values to functions, 351
and Hyperion Analyst, 333
and Hyperion Analyst worksheets, 340
and Hyperion Retrieve add-in file, 359
and saving worksheets, 361
drag and drop, 346
ending queries, 343
load/unload add-in files, 334
loading add-in files into, 357
saving worksheets as queries, 343
starting/exiting Hyperion Analyst from, 336
unloading add-in files from, 357
using with Hyperion Analyst, 333
using with Hyperion Retrieve, 357
worksheets, 351

Lowest-level Account Description function 
(@LAD), 276

Lowest-level Account ID function (@LAL), 277
LRC function, 282
LRD function, 283
LRF function, 284
LRI function, 286
LRO function, 287
LRT function, 289
LRU function, 290
LVL function, 291

M
main window, Hyperion Schedules, 397 to 398
manage dimensions, 344
manage expansion options, 176
manage expansions, 349
Manage Expansions dialog box, 174, 176
Manage Reports and Books dialog box, 179, 180, 188
managing dimensions See dimensions, customizing
managing expansions, 176
margins spacing option, 154
masks

customizing number format masks, 146
for dates, 254
options, 151

mathematical symbols, 101
menu, Hyperion Analyst, 337

menu, Retrieve, 359, 360, 363
menus

File, 398, 399, 414
options, 399
shortcuts, 400

menus, in Hyperion DataExtend, 383
Microsoft Excel

and CDAVAL function, 364
and Convert to Functions option, 351
and Hyperion Analyst, 370
and Hyperion Analyst toolbar, 337
and Hyperion Analyst worksheets, 340, 352
and saving worksheets, 361
creating a template, 352
drag and drop, 345
ending queries, 343
format for template, 352
Hyperion Analyst and, 335
load/unload add-in files, 334
loading add-in files into, 357
saving worksheets as queries, 343
starting/exiting Hyperion Analyst from, 336
unloading add-in files from, 357
using with Hyperion Retrieve, 357, 359
worksheets, 351

Microsoft Excel, exporting reports to, 197
Microsoft Windows, 335
Modification Date of a Linked Reporting Object 

function (@LRD), 283
modify queries, 343
move data in cells, 425
move dimensions and dimension IDs, 345 to 347
MS-DOS batch commands, 198
MUL function, 292
Multiply function (MUL), 292

N
natural precedence, 105
nested dimensions in Report Wizard, 134
nested sections

in books, 76
in reports, 73

nesting sections, 94
no data display option, 156
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Non-expense account attributes, for Hyperion 
Essbase, 145

notations
defining, 169
setting up in reports, 171

notations, creating, 381
notations, entering, 420
number format option, 140
number formats, customizing, 146
number masks for RW.INI file, 146
NumCols As Long Function, 450, 459
numeric data, entering, 423
numeric options

attribute, 151
calculation order, 150, 151
format, 150
rounding calculation, 150
scaling, 150
setting, 150

NumExpandedCols (ColNum As Long) As Long 
Function, 459

NumExpandedRows (RowNum As Long) As Long, 
458

NumPOVKeys As Integer Function, 448
NumRows As Long Function, 450, 458

O
Off function, 293
Offset of the Current and Optional Period 

function(@OFF), 293
On/Off filters, to specify dimension IDs, 84
online guide

accessing, xvi
displaying, xvi
searching, xvi

online Help
accessing, xvi
printing, xvi

online help, 398, 399
using, 339, 360

opening applications, 360, 363
opening reports, 401, 404, 414
operands, 106
operations order performed in expressions, 105
operator keys, 422

operators
in expressions, 101
multiple in expressions, 105
precedence of, 105

optimize reports for sparse data, 55, 57
options

for formatting, 147
for importing reports, 68
for report formatting, 139
inherited format, 142
mask, 151
setting criteria, 162
setting display, 156
setting numeric, 150
setting suppression, 156
sorting, 160
spacing, 153

options menu, 398, 399, 400
order of operations, 105
overview, of Hyperion Schedules, 393

P
page format changing defaults, 190
page margins for compound reports, 30
page order and orientation spacing options, 153
PAR function, 295
PAR keyword, 121
parameters, entering for a function in the Dimension 

dialog box, 87
Parent Entity keyword (PAR), 121
Parent function (@PAR), 295
parent override expansion option, 174
parent relationship manage expansion option, 176
parent, selecting, 411
Partial Description function (@PDES), 302
Partial Dimension ID function (@PLAB), 303
paste

functions into formulas, 364
values, 363

Paste Value option, 360
pasting data, 424
PBE function, 296
PCH function, 297
PCONS field, 117
PCR function, 298
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PCT function, 301
PCTRL field, 116
PDES function, 302
Percent by Row function (PCR), 298
Percent Change function (PCH), 297
Period Description function (@DAT), 255
Period keyword (DAT), 112
period, selecting a, 407
Pivot Table Options dialog box, 132
PLAB function, 303
point of view, 341

and assigning dimension changes, 71
and CDABET function, 367
and retrieving text, 378
books, 34
changing, 360, 361
Hyperion Enterprise Reporting Windows Client, 

33
overview, 33
reports, 35
setting, 37
setting for books, 43
setting for reports, 23, 44
settings, 361

point of view bar, 398, 413
point of view bar dimension buttons, 21
point of view bar, customizing, 23
point of view bar, removing dimensions from, 430
Point of View dialog box, 36
point of view, changing, 404
portrait printing, 30
position expansion option, 174
POVKeyDesc(POVKeyIndex As Integer) As String, 

449
POWN field, 117
PRE field, 118
precedence in expressions, 105
preferences, user, 417
Preview toolbar icon, 194
previewing reports, 194
Print icon, 195
print preview, 428
print reports, 429
printing

active book, 195
active report, 195

batched books, 196, 198, 206
batched reports, 196, 198, 206
from report preview, 194
to a file, 195

product drivers, specifying for Hyperion Solutions 
applications, 200

ProductName As String Function, 447
Prompt User function (@ASK), 235
prompts

assigning values for, 97
for importing reports, 68

PSF function, 304

Q
queries

additional, 334, 335
and entities, 349
and Manage Dimensions option, 339, 345
changing the point of view for, 133
creating, 342
creating in Report Wizard, 133
customizing templates for, 352
displaying as reports, 138
ending, 343
modifying, 343
opening, 342
saving, 343
with nested account sections, 134

quotes, in batch commands, 202

R
Range filters, to specify dimension IDs, 83
Range function (@RNG), 307
ranges, selecting, 50
RAT function, 305
Ratio function (RAT), 305
Ratios as Percentages function (PCT), 301
ReadOnly As Boolean Property, 451, 461
recovering deleted reports or books, 188
refresh, 338
Refresh option, 359, 360
Release 4XA only, 403, 411, 412
remove data from cells, 426
remove fields, 386
Remove from Set icon, 180
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remove keys, 430
renaming

books, 27, 185
reports, 27, 185
sets, 185

reorder dimensions and dimension IDs, 345 to 347
REPENG.INI file, 369

editing to activate investigations command, 173
Hyperion product name in, 199
printer options in, 194
setting SortSets option in, 181
setting UseEnterpriseOrg in, 295
updating when creating custom icon, 21

report areas
copying, 51
cutting, 50
deleting, 54
deselecting, 49
pasting, 52
selecting, 49
undoing deletions, 54

Report axis, 133
report columns default headings, 72
report formatting options

See formatting options, 139
REPORT function, 306
Report in Book function (REPORT), 306
report options

setting, 57
Report Options dialog box, 117
report options setting, 55
report rows default headings, 72
report sections

columns, 72
editing, 96
for retrieving data for series of dimensions, 73
nested, 73
rows, 72

report sets
adding reports to, 184
creating, 181
deleting, 182
editing, 183
overview, 180
removing reports from, 185
specifying for saved report, 27

report summaries, 64
Report Wizard

collapsing dimension values in, 135
creating queries in, 133
creating query reports with, 138
expanding dimension values, 135
icons, 132
nested dimensions in, 134
overview, 131

Report Wizard dialog box, 138
reporting dimensions, 21
Reporting, see Hyperion Enterprise Reporting 

Windows Client
ReportName As String Function, 448
reports, 414

adding to the application, 187
changing dimensions in, 78
closing, 27
columns in, 48
compiling, 186
compound, 26, 28
copying dimensions with formats, 169
copying dimensions without formats, 168
copying formats, 168
copying formulas with formats, 169
copying formulas without formats, 168
creating, 26
creating compound, 30
creating embedded, 30
customizing dimensions for, 21
deleting from the application, 188
deselecting areas in, 49
dimension changes in, 78
displaying queries as, 133, 138
editing, 45
editing summaries, 64
embedded, 28
exporting to Excel, 197
formatting overview, 139
importing, 187
inserting in books, 63
inserting sections in, 93
local headings in, 169
managing overview, 179
merging, 68
notations in, 169
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opening, 49, 401, 404, 414
optimizing for sparse data, 55, 57
overview, 21, 25
point of view, 35
previewing, 193, 194
printing, 193, 429
printing active, 195
printing batches, 196, 198, 206
removing from sets, 185
renaming, 27, 185
replacing in books, 64
rows in, 48
running faster, 55, 57
saving, 27
selecting areas in, 49
selecting ranges, 50
setting options, 55, 57
setting point of view, 23, 44
setting up local headings in, 171
setting up notations in, 171
standard, 26
viewing drafts of, 167
viewing formatted, 167

Reports and Books module in Hyperion Enterprise, 
189

Reports or Books window in Hyperion Enterprise, 
190

reset the point of view, 341
restoring deleted areas, 54
Retrieve menu

changing point of view (POV) option, 360
Open applications option, 360, 363
overview, 359, 360
Paste Value option, 360
Refresh option, 359
Save option, 359, 360

Retrieve, see Hyperion Retrieve
right mouse button, 401, 415
RND function, 306
RNG function, 307
Round Specific Values function (RND), 306
rounding calculation option, 150
row data format setting inheritance, 143
row heading defaults, 72
row headings format setting inheritance, 143
Row page format option, 190

row reference operand, 106
RowNum As Long Property, 451, 459
rows

copying, 51
cutting, 50
in reports, 72
inserting blank, 53
pasting, 52
sorting, 160

Rows axis, 133
rows spacing option, 154
rows, suppressed, 427
RPD function, 309
rules for text entry, 100
Run Task dialog box, 204
running

reports and books overview, 189
reports faster, 55, 57

RW.INI file number information, 146
RW32.INI file, 146, 151

S
Same As function (AS), 234
Same Generation function (@GEN), 272
Same Level function (@LVL), 291
sample field data text file, 388
Save As dialog box, 27
saving

data to applications, 361
worksheets, 359

saving data to a text file, 429
SCALE function, 310
scaling option, 150
SCH file, 431
Schedules see Hyperion Schedules
schedules, empty, 28
Schedules, see Hyperion Schedules
Second Subaccount Set keyword (SUBACC2), 123
second-level subaccounts, selecting, 410
Section for function (FOR), 268
sections

editing, 96
for books, 76
for reports, 73
inserting in books, 93
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inserting in reports, 93
inserting within sections, 94
labeling, 93, 94
nesting, 94
pasting, 52

sections within sections, 94
SED function, 311
select

accounts, 406
applications, 402
categories, 405
consolidation details, 411
currencies, 412
entities, 405
fields, 413
first level subaccounts, 409
frequencies, 407
parents, 411
periods, 407
second-level subaccounts, 410
views, 407

selected list, of dimension IDs, 87
Server Name function (@SRN), 318
Set Description function (@SED), 311
SET function, 312
Set Name function (@SET), 312
SetFocus As Boolean Function, 458
SetNumericValue (ByVal dbValue As Double) As 

Boolean, 452, 462
sets

creating, 181
deleting, 182
editing, 183
removing books from, 185
removing reports from, 185
renaming, 185

SetTextValue (ByVal lpcstrText As String) As 
Boolean, 453

SetTextValue (ByVal lpcstrText As String) As 
Boolean Function, 463

setting book options, 57
setting report options, 55, 57
setup, of Hyperion Analyst, 333
shading and border options, 148
shading format option, 140
shading state, 144

SHAROS field, 116
SHAROW field, 116
shortcuts, menu, 401
show window elements, 413
SIB function, 312
Siblings function (@SIB), 312
Siblings to the Left function (@SLA), 313
sideways printing, 30
SLA function, 313
SLF function, 315
sorting, 160
sorting format options

setting, 160
using, 142

spacing for compound reports, 30
spacing format options, 141
spacing options

headings, 154, 155
margins, 154
page order, 153
page orientation, 153
rows, 154
settings, 153
width, 154

sparse data, 55
Specific Cell Value function (CELL), 240
Specific Value function (DUR), 261
splitter bar, 86
spreadsheet formulas, 340
SRA function, 316
SRF function, 317
SRN function, 318
START function, 318
start Hyperion DataExtend, 382
start Hyperion Schedules from Windows, 395
Start of Range function (FROM), 271
states for check boxes, 143
status bar, 413
Structured Query Language (SQL), 342
Sub CalculateReport Function, 449
SUB function, 319
Sub RefreshReport Function, 450
SUBACC1 keyword, 122
SUBACC2 keyword, 123
Subaccounts function (@SUB), 319
SUBENT keyword, 124
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Subentity keyword (SUBENT), 124
SUM function, 320
summaries of books and reports, 64
summary data, 135
Summary ID function (@CON), 249
suppress options, 157
suppressed rows and columns, 400, 401, 422, 427
suppression options setting, 156
symbols, 101
syntax errors, 186
syntax, for batch commands, 201
system menus, 383, 398

T
Tab key, 417
task files, 198
Task menu, 383
templates, 352
text

creating fields for, 385
deleting fields of, 386

text data, 420
text entry rules, 100
text files, 386, 387, 388
TIM function, 321
TMCODE function, 322
TOD function, 323
toolbar, for Hyperion DataExtend, 384
toolbar, Hyperion Analyst, 337
toolbar, Hyperion Schedules, 400
TOP function, 324
Topmost Unowned ID function (@TOP), 324
Total function (SUM), 320
Translation Method Code function (@TMCODE), 

322
TXT files, 195
Type of a Linked Reporting Object function 

(@LRT), 289
types of reports, 26

U
unchecked state, 143
undeleting, 188
undoing deleted areas, 54
unload

Lotus 1-2-3 add-in files, 357
Microsoft Excel add-in files, 357

unload add-in files, 334
unsaved cells, 416
UNTIL function, 325
user defined account attributes, for Hyperion 

Essbase, 145
User ID function (@USR), 326
User of a Linked Reporting Object function (@LRU), 

290
user preferences, 413, 417
UserID As String Function, 448
USR function, 326

V
VAL field, 118
ValidateEditedCell Function, 440
ValidateOpenReport Function, 437
ValidateSaveReport Function, 445
VALIDDLL.DLL File, 434
value operand, 106
values for prompts, assigning, 97
variables in criteria statements

for Hyperion Enterprise, 164
for Hyperion Essbase, 165

VB40032.DLL File, 435
verifying reports, 186
view data in fields, 413
View Description function (@VWD), 327
View ID function (@VWL), 328
View menu, 383, 399
view, selecting a, 407
viewing

definitions, 128
draft reports, 167
formatted reports, 167

VSHAROS field, 116
VSHAROW field, 116
VWD function, 327
VWL function, 328

W
width spacing option, 154
Wildcard filters, to specify dimension IDs, 84
Wildcard function (@WLD), 331
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window elements, 413
Windows see Microsoft Windows
With All Subaccounts function (WITHSUB), 329
With First-level Subaccounts function 

(WITHSUB1), 330
WITHSUB function, 329
WITHSUB1 function, 330
WLD function, 331
worksheet point of view, changing, 341
worksheets, 340, 352

refreshing, 360
saving, 359

X
XLT files, 352

Z
zero display option, 156
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