
NRCS GPS Tools - ArcView

Step by Step Guide for Field Offices

Data Required:
- GPS Data

- PLGR Download (*.way file)
- Garmin Waypoint+ Download (*.txt file)

ArcView Setup:
- Extensions Used

- NRCS GPS Tools
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OVERVIEW - NRCS GPS Tools Extension:

   This Extension is designed to convert UTM NAD83 GPS data into ArcView Shapefiles.  Set Rockwell
PLGR Setup Units to UTM/UPS and Datum to NAR before downloading data.  Set Waypoint+, GPS Utility or
Map Source software programs to download data from GARMIN or MAGELLAN GPS units to UTM
NAD83/GRS80.  If you use another program to download GPS data, it is likely the program can export
downloaded data to the Waypoint+ file format for use in this Extension.  ArcView Shapefiles or Graphics
can be converted to Waypoint+ comma delimited text files for import into GPS units.  Again, if you use a
program other then Waypoint+, it is possible the program can import a Waypoint+ file, before sending the
data into your GPS unit.  For PLGR users, another step to convert a Waypoint+ file to a Mission Planning
Software .way file is available.  The .way file can be sent into PLGRs using Mission Planning Software.

Refer also to: http://www.ne.nrcs.usda.gov/www-nri/other/gpis.html.

ftp.ne.nrcs.usda.gov/outgoing/soils/arcview/notes/NRCS_GPS_Tools_ArcView.pdf

USDA NRCS Nebraska
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NRCS GPS Tools Extension to ArcView
USDA NRCS - Nebraska

The following guide illustrates the menu options of the NRCS GPS Tools Extension for
ArcView.

Install: Obtain the nrcs_gps_tools.avx file from the Nebraska FTP site at:
ftp.ne.nrcs.usda.gov/outogoing/soils/gps/nrcs_gps_tools.avx .

Save the file to: C:\Esri\Av_gis30\Arcview\Ext32\

Turn on the Extension from File>Extensions… by clicking the box to the left of  “NRCS GPS Tools”.

With a View active, the Extension adds a drop down menu to the ArcView main menu bar.

GPSàArcView:  To import a GPS file, select the first menu option “GPSà ArcView”.

IF your active View contains feature type Theme(s), you will get the following question pop-up box:

If you select Yes And:
- You only have one Theme in the View, you will be asked to confirm you want to append

GPS data to that theme.
- You have multiple Themes in the View, you will be given a pick list of Themes, choose the

theme you want GPS data appended to.
- In either case, the GPS data will be appended to the theme based on the existing Theme

type, Point, Line or Polygon.
If you select No, you will be asked later to name the new Shapefile you are creating from GPS data.
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The Select GPS File to Convert pop-up box appears.  Navigate to the GPS file location, select it and
click the [OK] button.

Note, if you are appending GPS data to an existing theme, you do not complete the following step.
If you are creating a new Shapefile, the following pop-up box appears.  The new Shapefile name is
defaulted to the same name and directory as the GPS input file.  You can change the name and
directory in the pop-up box.  Click [OK] to continue.

Note, if you are appending GPS data to an existing theme, you do not see the following.
The next pop-up window asks you to select how you want the GPS file locations converted.

Choose either a Point, Line or Polygon theme for the GPS data.  Lines and Polygons are created by
reading the GPS data sequentially.  Garmin Waypoint and Track data are used to create unique
polygons and lines!
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After the GPS data has been read, the following message box appears.  Click [OK] to continue.

The newly created Shapefile (Theme) is added to the active View and is turned on.  Below is an
example of a Garmin Track file converted to an ArcView Theme.  Each Track is recognized and the
legend is updated based on the individual tracks.

Most GPS data is imported using the this process.  A new polygon theme can be digitized based on the
Ortho Photo and GPS data.  Zoom in to an appropriate level and select View>New Theme  (CSToolkit
users use the Star button on the Toolkit Toolbar) to create/digitize a new theme based on the GPS
data.
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ArcView à Waypoint+

Before running this menu the first time, select menu “Set Default UTM Zone”, see page 7.

The ArcViewàWaypoint+ menu option will allow you to take an ArcView Graphic or Theme Feature
and convert it to a Waypoint+ file.  The resulting Waypoint+ file can be sent to a Garmin unit with
Waypoint+ software.  The Waypoint+ file can be converted to a MPS .way file for import to a PLGR
unit, see page 6.

Select ArcViewàWaypoint+ , the “Select Operation” pop-up window opens.  Choose the operation
you will execute.

Next you are asked to define the input type.  In this example we will convert from graphic points drawn
along a soil line.

If there are selected features (in a theme or graphics) they will be used.  Other wise all features will be
used.

Next, you are asked if the data is in the Default Projection.  Refer to page 7 for setting your default UTM
Zone.  If you select [No], you will be asked to define the Projection.
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The next pop-up window asks you to select the Garmin GPS unit you are using.  This is only used to
filter the number of waypoints written to the file based on the different unit’s maximum number of
waypoints they will hold.  You can select any unit and edit the Waypoint+ .txt file if needed.

The next pop-up window asks for the name of the output Waypoint+ .txt file.

A confirmation message is displayed.

Refer to page 9, NRCS GPS Tools Help, for instructions on how to use the newly created Waypoint+
.txt file in Waypoint+ software.
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Waypoint+ à Mission Planning

This menu option allows you to convert a Waypoint+ .txt file to a Mission Planning Software (MPS)
.way file.  MPS .way files can be sent to a PLGR GPS unit using Mission Planning Software.

When you choose this menu option the following pop-up window asks you to choose the Waypoint+ file
for conversion.  Choose the file and click [OK]

The following message is displayed:

The new MPS .way file is saved to the same directory as the Waypoint+ input .txt file.  The same
filename is used for the MPS file but the file extension is changed to .way.

Refer to page 10, NRCS GPS Tools Help, for instructions on how to use the newly created MPS .way
file in Mission Planning Software.
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Set Default UTM Zone

This menu option allows you to set a Default UTM Zone used by menu ArcView à Waypoint+.

Selecting the Set Default UTM Zone  menu option brings up this pop-up menu:

Scroll down the list, select your Zone number and click [OK].

The following message confirms your selection:

This option sets the default zone until the next time you select this menu option. The user defined
default UTM Zone is stored under $HOME in a text file named -nrcs_defz.txt.  This is usually
C:/TEMP/nrcs_defz.txt.  If the nrcs_defz.txt file is deleted, NRCS GPS Tools will fall back to the master
default UTM Zone 14.  Simply rerun this menu option to recreate the default zone file.

Refer to the Projection Utility ArcView note for GPS data collected across a UTM Zone boundary.
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NRCS GPS Help menu text print out further explains the extension and each menu option.

OVERVIEW - NRCS GPS Tools Extension:

   This Extension is designed to convert UTM NAD83 GPS data into ArcView Shapefiles.  Set Rockwell
PLGR Setup Units to UTM/UPS and Datum to NAR before downloading data.  Set Waypoint+, GPS Utility or
Map Source software programs to download data from GARMIN or MAGELLAN GPS units to UTM
NAD83/GRS80.  If you use another program to download GPS data, it is likely the program can export
downloaded data to the Waypoint+ file format for use in this Extension.  ArcView Shapefiles or Graphics
can be converted to Waypoint+ comma delimited text files for import into GPS units.  Again, if you use a
program other then Waypoint+, it is possible the program can import a Waypoint+ file, prior to sending the
data into your GPS unit.  For PLGR users, another step to convert a Waypoint+ file to a Mission Planning
Software .way file is available.  The .way file can be sent into PLGRs using Mission Planning Software.

MENU INFO - NRCS GPS Tools Extension:

GPS --> ArcView  [Convert these GPS file types to Shapefile]:

  - Waypoint+, decimal degrees or utm, Waypoint, Track or Combined file
  - PLGR, decimal degrees or utm, from Mission Planning Software or ASCII Out
  - GPS Utility, utm only, from Garmin (track or waypoint) or Magellan (waypoint)
- Map Source, utm only, track or waypoint (combined file treated as a waypoint)
     (only the waypoint portion of a Combine Map Source file is recognized)

GPS --> ArcView  [Conversion Notes]:

   Unlike the AVGarmin or Garmin GPS Utils ArcView Extensions (see below), this extension does not
project data during import.  This script is designed primarily to take UTM input data and convert it to a UTM
shapefile.  Note you can import Decimal Degree data from two file types but the resulting shapefile will be
in Decimal Degrees, not UTM.

The resulting shapefile is added to the View and the legend is identified as follows:
  - If points, unique legend based on the -P_TYPE- field.
  - If line/polygon, unique legend based on the -GPS_data- field.

GPS --> ArcView  [APPEND Feature]:

   The Append option becomes available when there is at least one Theme in the View.  If there is only one
theme in the View, the user must confirm they want to use that theme as the Append To theme.  Multiple
themes in the View will invoke a selection list box to pick the Append To theme.  During the append
operation a temporary shapefile is written to $HOME.  Normal attributes are developed for the temp
shapefile, in addition attributes standard to USDA Customer Service Toolkit (CST) shapefiles are created.
An attempt is made to transfer ALL attributes from the temp shapefile to the selected Append To theme.
At a minimum, the -Shape- attribute is transferred.  GPS file info will be appended to USDA CST shapefiles
in the -GPS File- or -Notes- attribute field depending on the CST shapefile type.  The Append operation
completes with an attempt to reapply a unique legend based on the -P_Type- and -GPS_data- fields as
described above.  If those fields are not found, the legend is reset to a new single symbol legend to alert
the user the Theme has been modified.  Finally the temp shapefile is deleted.
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GPS --> ArcView  [WARNING & ERROR MESSAGES]:

  - Numerous inconsistent input file type messages.  Try downloading the GPS data again.
  - Lack of GPS points to create a Line (2 points) or Polygon (3 points).
  - Attempts to Append a UTM theme to a Decimal Degree theme or vice versus.
  - Attempts to Append to a Non-Feature theme (image).

GPS --> ArcView  [Error/Bug Notes]:

   If ArcView reports an [AVArray:] error, the problem is a corrupt input file.  Error checking is employed to
assure the input file is correct in the header area, but each line of the input file is not error checked.  The
solution to this problem is to re-download the data from the GPS unit.  If the error continues open the
suspect input file in a text editor and scan for missing field delimiters in the file, such as a comma or extra
space in a PLGR download file.  If the error continues, contact doug.garrison@ne.usda.gov, to see if
support for this extension is still available or feel free to edit this script as needed.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

ArcView --> Waypoint+  [Highlights]:

   This is a modified version of the MN DNR ArcView --> Garmin GPS script (see below).  ArcView Graphics
or Shapefiles can be converted to a Waypoint+ comma delimited file.  You are asked to select the Garmin
GPS model being used.  Different models have a set threshold number of possible waypoints.  The output
file structure is the same, just the number of waypoints in the file is affected by this option.  When
converting line/polygons, the script helps the user reduce the number of points generated through a
generalization algorithm if needed.

ArcView --> Waypoint+  [Working with Projections & Default UTM Zone]:

   The script expects the Graphic or Shapefile to be converted is UTM NAD83, such as heads up digitizing
on a DOQ.  Users can set their default UTM Zone using the NRCS GPS Tools Menu Option -Set Default
UTM Zone- (described below).  If a USER defined default UTM Zone is not found, the script switches to a
MASTER defined default UTM Zone (14).  If the Graphic or Shapefile IS NOT UTM NAD83, the user can
select any other projection through a dialog box, such as UTM NAD27, Albers, etc...  The resulting
Waypoint+ comma delimited file is Geographic Decimal Degrees.

ArcView --> Waypoint+  [Using The New File In Waypoint+ Software Program]:

   Start the Waypoint+ program and select menu items File>Open.  Change File of types to -Waypoint Text
or Route Point (TRK) Text File-.  Navigate to the newly created Waypoint+ comma delimited text file and
select it.  Waypoint+ is now ready to send the data into your Garmin unit.  To send the data into a Garmin
unit, select menu items GPS>Send File To GPS.

NOTE: If Waypoint+ is Configured for UTM, the Waypoint+ comma delimited text file in Decimal Degrees
created by -ArcView --> Waypoint+- can be saved to a new Waypoint+ UTM comma delimited file using
Waypoint+ menu options File>Save.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
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Waypoint+ --> Mission Planning Software  [Overview]:

   This Menu option converts a NAD 83 UTM or Decimal Degrees, Waypoint+ comma delimited text file to a
Mission Planning Software (Rockwell PLGR) .way file.  The .way file is written to the same directory where
the Waypoint+ .txt file is located.  The .way file is given the same name as the original Waypoint+ .txt file,
but obviously the file extension is changed from .txt to .way.  No check is made to see if the .way file
already exists in the directory, the file is simply overwritten.

The resulting .way file can be used with Mission Planning Software (MPS) to load the waypoints into a
PLGR.  Move the newly created .way file to the library directory under MPS, ie. C:\MPS\LIBRARY.  The
script limits the user to 999 waypoints.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Set Default UTM Zone  [Notes]:

   This Menu option presents a List dialog box of all 60 UTM Zones followed by their Central Meridian value.
Select the Zone you wish to be stored as the USER defined default UTM Zone for the NRCS GPS Tools
menu option -ArcView --> Waypoint+- described above.  When the user exits the dialog box, they are
notified of the default Zone setting.  The USER defined default UTM Zone is stored under $HOME in a text
file named -nrcs_defz.txt-.  Error checking of the -nrcs_defz.txt- file is handled through the -ArcView -->
Waypoint+- menu option.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

** Related Info **

AV Garmin Extension Website: http://maphost.dfg.ca.gov/adt/download.htm#avgarmin

MN DNR Garmin GPS Utils Extension Website:
http://www.dnr.state.mn.us/mis/gis/tools/arcview/extensions/DNRGarmin/DNRGarmin.html

  Thanks to Chris Pouliot, MN DNR for letting us use their scripts.

NE NRCS GPS related Website: http://www.ne.nrcs.usda.gov/www-nri/other/gpis.html

Disclaimer:

This Software is provided 'as is' without express or implied warranties.  Use of Names in this Software
does not imply any type of endorsement.  Refer to the MN DNR Website for their License Agreement
information.


