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Desktop Radiance

Introduction
Desktop Radiance is a design tool that facilitates the design and analysis of buildings
to optimize the efficiency of daylighting systems and lighting technologies.  Desktop
Radiance is a plug-in module that works with other popular computer aided design
(CAD) tools to provide the user interaction and 3-d modeling capabilities.  Desktop
Radiance relies upon the popular Radiance Synthetic Imaging System to provide its
renderings and analytical results.

The first step in the process of performing a daylighting analysis is the creation of a
3D model in a Graphic Editor program, such as AutoCAD (See Setting Up A
Drawing).  The 3D model can then be detailed appropriately using the Desktop
Radiance library of materials, glazings, luminaires and furnishings. Once the model
is complete, you then define the analysis parameters such as camera views or
reference point calculations, building orientation and zone of interest.  Then you set
up a rendering or point calculation using the simulation menu commands that initiate
the export of the geometry and analysis parameters.  See the Simulation Manager
for more information about starting your simulations and Image Analyzer for more
information about analyzing your results.

This document is not intended to be a comprehensive discussion of the appropriate
modeling techniques for daylighting design. It is assumed that you are familiar with
daylighting design and fairly familiar with general 3-d modeling and AutoCAD in
particular.  You may wish to browse the Quick-start Tutorial for a brief introduction
to the various 3-d geometric primitives and how they can be assembled into a model
of a simple office space.

This document is organized according to the menu structure of Desktop Radiance as
found in Version 1.0 as of April 1, 2000.  It is also available through the on-line,
context-sensitive help system for Desktop Radiance.



2  •  Graphic Editor Desktop Radiance User Manual



Desktop Radiance User Manual Graphic Editor  •  3

Graphic Editor

Introduction
The Graphic Editor (AutoCAD for this document) is where you create the 3-D
representation of the geometry of the space you are designing.  All of the AutoCAD
native commands are available for this purpose.  Desktop Radiance adds the
“Radiance” menu item to the AutoCAD menubar.

Figure 1.  The Main Radiance Pulldown Menu

It is from this menu that all Desktop Radiance commands are accessed.  In most
cases, you first select the command, and then follow the prompts to provide the
requested information such as selecting the surfaces onto which you wish to perform
some action.  In some cases the command leads to a dialog box which requires your
input.  The following pages will explain each Radiance menu item in detail.

Setting Up A Drawing
The best way to get started with modeling your building is to set up your drawing
units.  AutoCAD and Radiance are both “unitless” modeling systems.  This means
the “size” of a unit of distance is defined by the user and implemented as a
convention.  Sometimes a scaling factor is also used which causes the unit to be
proportionately larger or smaller than its base unit size.  These settings for your
drawing can be defined in the Preferences Dialog Box see Preferences(p.22). Once
you have set up the units you are ready to start modeling and making attachments
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from the Radiance menu.  Below we will discuss each menu item in turn starting
with the Materials menu item.

Materials
Materials can be attached to any surface in your graphic editor 3-D model.  Radiance
is equipped with an extensive library of materials. You can also create your own
materials using the Materials Editor that can be reached through the Library
Manager.  For more information on materials and creating your own materials see
the Library Manager and the Material Editor.

Attach materials
The Materials Library dialog box(Figure 2) contains the database of available
materials that can be attached to surfaces in your drawing.

Figure 2. The Materials Library Dialog Box

To access the Materials Library Dialog Box, first use the menu command
Radiance→ Materials→ Attach Material, then when prompted select the surface or
surfaces that you want to attach a material to. After selecting surfaces you then press
<enter> (this implies, no more surfaces to select) and the Materials Library Dialog
Box will appear.

Scroll through the list and choose a material. After selecting a material, click the
ATTACH button at the bottom of the Materials Library dialog box. Doing so brings
back the AutoCAD window and associates the material to the selected surface.  In
AutoCAD, the surface will not change appearance; in other words, the line color will
not change.  Repeat the process for other surfaces in your model.  Only one material
can be attached to each plane or surface.  In other words, two materials cannot be
attached to the front and back of a surface.

You can sort the material library to make it easier to find a specific material. The
Materials Library can be sorted by the common name of the material, its
manufacturer, the manufacturer’s product code, the source of the data (the person or
company that entered it into the database), or by the material’s reflectance,
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transmittance, specularity, or roughness.  To sort the materials, select the desired
property in the drop-down list box next to the “SORT BY” button.  Then click
“SORT BY”.  You can click again to reverse the sort order.

Alternatively, you may search for a material by using the FIND function of the
Materials Library.  Type the first few characters of the name of the material or any
field in the materials library in the edit box adjacent to the FIND button.  Click on
the “FIND” button and it will find the first occurrence of the material that matches
the sequence of characters you have entered.  Click on “FIND” again to find the next
occurrence.

Detach Materials
To detach a material from an object click on Radiance→ Materials→ Detach Material.
Then select the object from which you want the material detached.

This tool can be used in conjunction with the “Show all attached materials” function
making it possible to select and detach all the materials in a drawing at one time.  To
do this go to Radiance→ Materials→ Show All Attached Materials.  When all
surfaces are selected go to Radiance→ Materials→ Detach Material.  At the prompt it
will ask you to select surfaces to detach materials.  Type the letter P for the previous
selection set, all surfaces with materials will be selected and highlighted, then hit
<enter>.  All materials will be detached.

Show All Attached Materials
This function selects all objects that have a material attached to them.  To use this
function go to Radiance→ Materials→ Show All Attached Materials.  The surfaces
with attached materials will become selected and displayed with dashed lines in the
Graphic Editor window.

Show Material Properties
This function allows you to view detailed information about a specific material.

For more information on how to use the Material Properties Dialog Box(Figure 14)
or to create new materials see Material Properties (p.16) or the Library Manager.

Luminaires

Place Luminaire
The Luminaires Library dialog box contains the database of available luminaires.
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Figure 3. The Luminaire Library Dialog Box

Modeling Tip:

It is usually easiest if you
display an axonometric view
to position the luminaire into
your drawing at the correct
height.  Use the appropriate
“snapping” method.  Then in
plan view you can move the
luminaire to the correct
horizontal position.

To access the Luminaires Library Dialog Box select Radiance→ Luminaires→ Place
Luminaires and the Luminaires Library Dialog Box will appear(Figure 3).

Scroll through the list and select a luminaire to place in your drawing. Next, click the
ATTACH button at the bottom of the Luminaires Library dialog box. Doing so
brings back the AutoCAD window. Select an insertion point for the luminaire and
then choose a rotation angle.  Repeat the process for other luminaires.

You can sort the luminaire library to make it easier to find a specific luminaire. You
may sort the luminaire library by the common name of the luminaire, its
manufacturer, the manufacturer’s product code, the source of the data (the person or
company that entered it into the database), the luminaire’s lamp type, dimming level
(watts), dimming level (lumens), or number of lamps.  To sort the luminaires, select
the desired property in the drop-down list box next to the “SORT BY” button.  Then
click “SORT BY”.  You can click again to reverse the sort order.

Alternatively, you may search for a luminaire by using the FIND function of the
Luminaire Library.  Type the name of the luminaire or a sequence of characters
matching any other field in the luminaire library in the edit box adjacent to the FIND
button.  Click on the “FIND” button and it will find the first occurrence of the
luminaire that matches the sequence of characters you have entered.  Click on
“FIND” again to find the next occurrence.

Delete Luminaire
To delete a luminaire from your drawing go to Radiance→ Luminaires→ Delete
Luminaire.  Then select the luminaire that you want deleted.  The AutoCAD erase
command also works.

Show Luminaire Aiming
This function allows you to see the direction that a luminaire is aimed.  To use this
tool, go to Radiance→ Luminaires→ Show Luminaire Aiming.  Select a luminaire as
prompted by the command line.  A red arrow will appear that shows the direction
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that the luminaire is pointing.  To change the luminaire aiming, use the standard
object rotation commands of the Graphic Editor.

In AutoCAD, the best way to aim a luminaire is through a series of rotations about
the Z-Axis of the user coordinate system (UCS).  First rotate your UCS such that the
z-axis is parallel to the axis on which you would like to rotate the luminaire, for
example “UCS, X, 90” will rotate the UCS about the x-axis of the current UCS by 90
degrees.  Then type the “rotate” command and select a point on the surface of the
luminaire.

Brightness
Not yet available.

Show All Luminaires
This function selects all luminaires in your drawing.  To access this function go to
Radiance→ Luminaires→ Show All Luminaires.  All luminaires will become
selected.  This tool can be used in conjunction with “Delete Luminaire” to delete all
the luminaires in your drawing at one time.

Show Luminaire Properties
This function allows you to view detailed information about a specific luminaire.

For more information on how to use the Luminaire Properties dialog box see the
Luminaire Properties dialog box (p.18).

Glazings

Attach glazing
The Glazings Library dialog box contains the database of available glazings that can
be attached to surfaces in your drawing(Figure 4).  The Desktop Radiance Glazing
database is based on glazing data from a program called Optics 5.  Optics 5 uses data
from the NFRC.  For more on Optics 5, see
http://windows.lbl.gov/Materials/optics5/.
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Figure 4.  The Glazings Library Dialog Box

To access the Glazings Library Dialog Box go to Radiance→ Glazings→ Attach
Glazing. The command line prompts you to select the surfaces that the glazing will
be attached to. After selecting surfaces you then press <enter> (no more surfaces to
select) and the Glazings Library Dialog Box will appear.  Scroll through the list and
select a glazing to attach to the selected window(s) in your drawing.  Next, click the
ATTACH button at the bottom of the Glazings library dialog box. Doing so brings
back the AutoCAD window and associates the glazing to the selected window.
Repeat the process for other windows.  For double paned windows, do not make two
layers of glass.  This will result in incorrect light calculations.

You can sort the database to make it more convenient to find a specific glazing.  You
may sort the glazings library by the common name of the glazing, its manufacturer,
the manufacturer’s product code, the source of the data (the person or company that
entered it into the database), or by the reflectance, transmittance, or thickness.  To
sort the glazings, select the desired property in the drop-down list box next to the
“SORT BY” button.  Then click “SORT BY”.  You can click again to reverse the
sort order.

Alternatively, you may search for a glazing using the FIND function of the Glazings
Library Dialog Box.  Type the name of the glazing or a sequence of characters
matching any other field in the glazing library in the edit box adjacent to the FIND
button.  Click on the “FIND” button and it will find the first occurrence of the
glazing that matches the sequence of characters you have entered.  Click on “FIND”
again to find next occurrence.

Detach Glazing
To detach a glazing from an object click on Radiance→ Glazings→ Detach Glazing.
Then select the object from which you want the glazing detached.  This tool can be
used in conjunction with the “Show all attached glazings” function making it
possible to select and detach all the glazings in a drawing at one time.  To do this go
to Radiance→ Glazings→ Show All Attached Glazing.  When all windows are
selected go to Radiance→ Glazings→ Detach Glazing.  At the prompt it will ask you
to select glazings to detach.  Type the letter P for the previous selection set, all
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glazings will be selected and highlighted, then hit <enter>.  All glazings will be
detached.

Show All Attached Glazing
This function selects all objects/surfaces that have a glazing attached to them.  To
use this function go to Radiance→ Glazings→ Show All Attached Glazings.  The
objects with glazings attached will become selected.

Show Glazing Properties
This function allows you to view and edit detailed information about a specific
glazing.

For more on how to use the Glazing Properties dialog box (Figure 16) see Glazing
Properties (p.17).

Furnishings

Place Furnishing
The Furnishings Library dialog box contains the database of available furnishings
that can be placed in your drawing(Figure 5).

Figure 5. The Furnishings Library Dialog Box
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Modeling Tip:

It is usually easiest if you
display an axonometric view
to position the furnishing into
your drawing at the correct
height.  Use the appropriate
“snapping” method.  Then in
plan view you can move the
furnishing to the correct
horizontal position.

To access the Furnishings Library Dialog Box go to Radiance→ Furnishings→ Place
Furnishing.  Scroll through the list and select a furnishing to place in your drawing.
Next, click the ATTACH button at the bottom of the Furnishing library dialog box.
Doing so brings back the AutoCAD window. Select an insertion point and rotation
angle for the furnishing as indicated by the AutoCAD command prompt.  Repeat the
process for other furnishings.

You can sort the database to make it more convenient to find a specific furnishing.
You may sort the furnishing library by the common name of the furnishing, its
manufacturer, the manufacturer’s product code, or by the source of the data (the
person or company that entered it into the database). To sort the furnishings, select
the desired property in the drop-down list box next to the “SORT BY” button.  Then
click “SORT BY”.  You can click again to reverse the sort order.  You can move,
copy and array these furnishings to create a furnishing plan suitable for the model.

Alternatively you may search for a furnishing using the FIND function of the
Furnishings Library Dialog Box.  Type the name of the furnishing or a sequence of
characters matching any other field in the furnishing library in the edit box adjacent
to the FIND button.  Click on the FIND button and it will find the first occurrence of
the furnishing that matches the sequence of characters you have entered.  Click on
FIND again to find next occurrence.

Delete Furnishing
To delete a furnishing from your drawing, click on Radiance→ Furnishings→ Delete
Furnishing.  Then select the furnishing that you want deleted.  The AutoCAD erase
command also deletes furnishings.

Show All Furnishings
This function selects all furnishings in your drawing.  To use this function go to
Radiance→ Furnishings→ Show All Furnishings.  This tool can be used in
conjunction with “Delete Furnishing” to delete all furnishings in a drawing at once.

Show Furnishing Properties
This function allows you to view and edit detailed information about a specific
furnishing.

For more on how to use the Furnishing Properties dialog box (Figure 15) see
Furnishing Properties (p.17).

Analysis
Desktop Radiance is equipped with several tools to allow for accurate lighting
analysis of buildings to fit the needs of the designer.

Define Zone
Use the Define Zone function to create a 3-dimensional box for the simulation to
focus on.

To define a zone, go to Radiance→ Analysis→ Define Zone.  The Zone Dialog Box
will appear(Figure 6).
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Figure 6.  The Zone Dialog Box

Type in a name for the zone being created and select interior or exterior space.  An
interior zone means that simulations will be from an enclosed interior space.  An
exterior zone means the simulation is from the outside.  If no zone is defined, the
default will be an interior zone the size of the scene bounding cube of the model.  A
zone is an optional component of your model.  Use of a zone is recommended when
the size of the room you are simulating is less than half the size of the entire building
model.  The zone is used by Radiance to adjust certain calculation parameters to
ensure an accurate simulation.

Define Orientation
This function allows you to define the direction of the north arrow of your model.

To use this tool, go to Radiance→ Analysis→ Define Orientation.  You are then
prompted to enter a name for the North Arrow, then you are asked to pick an
insertion point and a rotation angle.  The “Define Orientation” function is best used
in the plan view.

Note: The North Arrow icon may appear too large or too small if the units have not
been set up for your drawing.  For more on how to adjust this see Preferences.

Figure 7.  The AutoCAD North Arrow

Multiple north arrows are possible in one drawing to allow for parametric studies.

The default orientation, if none is defined, is with north pointing up and West to the
right, in plan view.

Define camera position
The define camera position function allows you to create and position a new camera.
To use this tool, go to Radiance→ Analysis→ Define Camera Position.  The Camera
Properties Dialog Box then appears(Figure 8) .
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Figure 8.  The Camera Properties Dialog Box and the camera icon

Enter a name for the camera and set the lens length.  The lens length determines how
long the zoom lens is.  Smaller numbers make the lens shorter and therefore give a
wider, farther away view.  Conversely, larger numbers make the lens longer and will
therefore give a narrower, closer view.  After clicking OK you are brought back to
the Graphic Editor window and prompted to give an insertion point, a rotation angle,
and the height above the insertion point for the origin of the camera’s view.  If you
enter a camera name that has already been used in the project, scenarios which use
this camera will be changed to the new view parameters.  The camera icon will then
appear in your drawing at the insertion point.  If the icon is either too small or too
large, this can be adjusted in the preferences dialog box which can be accessed
through the Radiance pulldown menu.  For more on this, see Preferences(p.22).

To change the view of a camera first type view↵  r↵  and then type the name of the
camera↵ .  The view of the camera will then appear with an outline representing the
camera lens.  Type dview↵ .  Several commands will appear at the command prompt
that allow you to adjust your viewpoint in different ways.  Consult the AutoCAD
help section for detailed information on using these commands.  Typically the Target
and Zoom commands are very useful.  Zoom allows you to zoom forwards and back.
Target allows you to move your viewpoint target in all directions.  Using these tools
is difficult because your wireframe scene disappears while you make adjustments.
After editing your camera view, hit enter at the dview prompt.  Your new view will
appear in wireframe.  If you are satisfied with the view, you must save it with the
ddview command.  If you are unsatisfied with the new view you must return to the
original view you started editing and then begin using the dview commands again.
Once you are satisfied with the new view, type ddview↵ , to save the new view.
Click on New and then enter the same name as the camera view that you were
originally editing.  Entering the same name will allow you to select the original
camera icon when starting a simulation, but with the updated view.  Entering a new
name will mean that you have to select the view name in the camera simulation setup
dialog box because there won't be a picture of a camera representing your new view.

The camera view can also be changed more easily and quickly but not permanently
in the rview program when you start a simulation.  This is useful for checking your
geometry or to find an ideal view.

Define Animation Path
Calculation of an Animation Path is not yet available on version 1.0 of Desktop
Radiance.  However, you can set up camera paths that will create individual cameras
for single frame renderings.
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Figure 9.  The Animation Path Properties Dialog Box and an animation path

Define Reference Point
Use Define Reference Point to place a light sensor at one specific point.  The light
sensor is used to find light value readings.  To use this tool, go to
Radiance→ Analysis→ Define Reference Point.  You are then prompted at the
command line to enter a name for the reference point, an insertion point, a rotation
angle, and a reference point height.

Figure 10.  A Reference Point Sensor

When inserting a reference point… preferences.

Define Reference Grid
Use Define Reference Grid to create a plane within the model where light values can
be taken.  To define a reference grid go to Radiance→ Analysis→ Define Reference
Grid.  You are then prompted to enter a name for the reference grid, the number of
rows in the grid (Y-axis), the number of columns in the grid (X-axis), and the first
and second corners of the grid.  If you are in a perspective view when defining the
corners of the grid, the box being defined will not appear to fit the plane in
perspective until after you have selected both corners.

The reference grid can be moved to the correct height by using standard graphic
editor commands if necessary.

Figure 11.  A Reference Grid of Sensors

Simulation
The simulation process can begin when all the Radiance attachments and settings are
ready to create a picture or calculate a point or grid quantity of your model.  This
process begins by selecting a camera, reference point, or reference grid to simulate.
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Then the scenario or simulation needs to be named and you choose the location, date,
and time that the scenario should portray.  These parameters then become part of a
single scenario.

When a simulation is done, it can be viewed first in the Interactive
Rendering(rview) and then in the Image Analyzer.

Camera
This function allows you to begin a Radiance simulation of your drawing.

To access this tool, go to Radiance→ Simulation→ Camera.  Then you are prompted
to select a camera in your drawing.  Then a window may appear that asks you to
enter a scenario name(Figure 12).

Figure 12.  Each scenario must have a unique name.

After entering a name and clicking OK, the command line prompts you to “select
objects”.  These will be the objects included in the simulation.  If you want all
objects included, type “all”.  Otherwise, select in your drawing the objects to include
and press enter.  For more on defining scenarios see Define Scenario.

In some cases a dialog box with the heading Define Project may appear.  For
information on this see Define Project.

The computer will then synchronize the database and the Camera Simulation Setup
Dialog Box will appear(Figure 13).  Synchronizing can sometimes take several
minutes to complete for large models as the selected library items are copied to your
project directory.  For more on simulating your model see Simulation Manager.
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Figure 13.  The Camera Simulation Setup Dialog Box.

Reference Point
This tool runs a simulation of a light sensor in your model.  It produces a luminance
value at the sensor for the scenario you have defined.  To use this tool go to
RadianceàSimulationàReference Point.

To place a sensor see Define Reference Point (p.13).

Reference Grid
This tool runs a simulation of a grid of light sensors in your model.  It produces an
array of luminance values for the sensors in the scenario you have defined.  To use
this tool go to RadianceàSimulationàReference Grid.

To define a reference grid see Define Reference Grid p.13).

Tools
The Radiance tools menu items consist of utilities that assist in the management of
your drawing model  and the corresponding Radiance project files.

Show All Attachments
This function highlights and selects all luminaires, furnishings, and surfaces with
materials or glazings attached to them.  To access this tool go to
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Radiance→ Tools→ Show All Attachments.  All Radiance attachments will become
selected.

Show All Unattached
This function selects and highlights all the objects and surfaces in the drawing that
do not have a material or glazing attached to them.  To use this tool go to
Radiance→ Tools→ Show All Unattached.  Objects and surfaces without Radiance
attachments will become selected.

Show Properties
This function allows you to view specific properties of Radiance elements including
Furnishings, Materials, Glazings, and Luminaires.

To access this function, go to Radiance→ Tools→ Show Properties.  Then select a
material, glazing, furnishing, or luminaire in your drawing.

Material Properties
To access the Material Properties dialog box(Figure 14) go to
Radiance→ Tools→ Show Properties and then select a material in your drawing.

Figure 14.  The Material Properties Dialog Box.

When attaching a new material, the Material Properties dialog can also be accessed
by clicking on the PROPERTIES button at the bottom of the Materials Library
dialog box.

You can change certain properties (comments) of a material in the Material
Properties dialog box.  This is done by adding inputs and clicking apply.

To create new materials you can go through either the Material Properties Dialog
Box or through the Library Browser (see  Library Manager).
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Furnishing Properties
To access the Furnishing Properties dialog box(Figure 15) go to
Radiance→ Tools→ Show Properties and then select a furnishing in your drawing.

Figure 15.  The Furnishing Properties Dialog Box.

The Furnishing Properties dialog can be accessed from the Furnishings Library
dialog box when placing a new furnishing or from the Library Browser. In the
Furnishings Library dialog box highlight a furnishing and click on the PROPERTIES
button.

You can change certain properties (comments) of a furnishing in the Furnishing
Properties dialog box.  This is done by adding inputs and clicking apply. This
doesn’t work yet.  APPLY is grayed out and clicking CLOSE closes without saving
edits.

Glazing Properties
To access the Glazing Properties dialog box(Figure 16) go to
Radiance→ Tools→ Show Properties and then select a glazing in your drawing.
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Figure 16.  The Glazing Properties Dialog Box.

The Glazing Properties dialog can be accessed from the Glazing Library dialog box
when placing a new glazing. In the Glazing Library dialog box select a glazing and
click on the PROPERTIES button at the bottom of the Luminaire Library dialog box.

The Simulation Control check box allows you to turn on and off the window as a
light source.  Unchecking this box will ignore all daylight that would be coming in
through this glazing.  For more information on this subject, see the Radiance
Reference Manual.

You can change certain properties (comments) of a glazing in the Glazing Properties
dialog box.  This is done by adding inputs and clicking apply.

Luminaire Properties
To access the Luminaire Properties dialog box(Figure 17) go to
Radiance→ Tools→ Show Properties and then select a luminaire in your drawing.
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Figure 17.  The Luminaire Properties Dialog Box.

When placing a new luminaire, the Luminaire Properties dialog can be accessed by
clicking on the PROPERTIES button at the bottom of the Luminaire Library dialog
box.

You can change certain properties (comments) of a luminaire in the Luminaire
Properties dialog box.  This is done by adding inputs and clicking apply. This
doesn’t work yet.  APPLY is grayed out and clicking CLOSE closes without saving
edits.

Detach All
This function detaches all materials, glazings, furnishings, and luminaires from
objects and surfaces in the model.

To use this tool go to Radiance→ Tools→ Detach All.  All objects with Radiance
attachments will be selected automatically and a window appears to confirm that you
want to detach all Radiance materials and glazings.  This restores your drawing to
the state it was in before the use of any Desktop Radiance commands.

Adjust Surface Normals
This command is used to check and adjust the orientation of surfaces in your model.
In general, the orientation of surfaces is not important for Radiance as it is with other
lighting analysis tools.  However, to calculate the distribution of daylight with
glazings to be treated as a “light source”, it is necessary to have the glazing surface
correctly oriented.  Material surfaces do not need correct surface normal orientation.
To use this function, go to Radiance→ Tools→ Adjust Surface Normals.  Then, as
you are prompted, select the glazing surface in your drawing.  A red arrow will
appear within the window.  A correctly oriented surface normal for a window or
skylight should be pointing in the direction of daylight travel from brightest to
dimmest regions.  The command line asks you if you want to flip the surface normal.
Type “N” if the arrow is pointing in the correct direction and “Y” if you want to
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switch it.  If the direction of the surface normal is not as you expected and cannot be
reversed with this tool, then the window surface needs to be recreated.

If the red surface normal arrow does not appear it may be that you are checking an
object that Desktop Radiance can't figure the front/back of, for example an exploded
ACIS solid.  The surfaces of an exploded ACIS solid will have normals pointing
outwards.    If the surface normal you are checking is not that of a surface of an
exploded ACIS object and you don't see the red surface normal arrow, see
Preferences(p.22).

Use the Right Hand Rule to correctly orient glazing surfaces:  Imagine placing your
right hand against the wall with the window, with your thumb pointing in the
direction that the light travels.  Your four other fingers now curl in the direction that
the vertices should be created to obtain a properly oriented surface.

Material Map
The Material Map function associates a surface with a specific layer or line color in
your graphic editor program or the specified Desktop Radiance material.  To use the
material map tool go to Radiance→ Tools→ Material Map and then the Material Map
dialog box will appear(Figure 18).

Figure 18.  The Material Map Dialog Box

To attach a material to all surfaces in a particular layer, click on ADD LAYER.  The
Material Layer Assignment Dialog Box will appear(Figure 19).

Figure 19.  The Material Layer Assignment Dialog Box

Click on layer name→ BROWSE to select a layer, from the Current Drawing Layers
Dialog  Box(Figure 20) that the material will be associated with.
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Figure 20.  The Current Drawing Layers Dialog Box

Then click on material→ BROWSE and select a material to be associated with the
layer.

To attach a material to all surfaces with a particular color, go to
RadianceàToolsàMaterial Map to get to the Material Map Dialog Box(Figure 18).
Click on ADD COLOR.

Figure 21.  The Material Color Assignment Dialog Box

In the Material Layer Assignment Dialog Box that will appear next(Figure 21), enter
either the color number or click on color number→ BROWSE to find the correct
color.  After finding a color click on material→ BROWSE to find the material to be
associated with the color.

After associating a layer or color with a material through the Material Map tool, new
objects created in that layer or color are not automatically associated with the
material.  The layer or color must be re-associated with the material for all new
objects of that layer or color to be included.

Library Manager
This tool allows you to easily keep track of all available Radiance libraries, these
include Furnishings, Glazings, Materials, and Luminaires (see Library Manager).

Future Plans for the Library Manager:

The Library Manager is still rapidly changing and developing.

Material Editor
This tool allows you to edit existing materials and create new materials altogether.
To use the Material Editor see Material Editor.
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Simulation Manager
The simulation manager keeps track of your simulation scenarios For more
information on using this tool (see Simulation Manager).

Image Analyzer
The Image Analyzer allows you to further analyze the lighting performance of your
model.  For more information (see Image Analyzer).

Preferences
The General Preferences Dialog Box(Figure 22) is used to set the units (metric or
imperial), unit size (meters, inches, etc.) of a drawing, and drawing “scale” for
appropriate sizing of the Desktop Radiance library items.  To use this tool go to
RadianceàPreferences.  There is an important relationship between the settings here
and the units format of your graphic editor program.  The most important
relationship is that if the units display in your graphic editor are “Architectural”, then
you will want to choose “Imperial” and “Inches” in the Desktop Radiance General
Preferences Dialog Box(Figure 22).  See the note on Setting Up A Drawing(p. 3)
for more explanation.

Sometimes when attaching or inserting a Radiance entity into your drawing, it will
appear much smaller or much larger than you want it to be.  This includes objects
such as furnishings, luminaires, cameras, north arrows, and surface normal arrows.
To fix this problem use the General Preferences tab dialog box.  Before attaching the
Radiance entity into your drawing, change the Symbol Scale value.  To make an
object larger, make the symbol scale value larger.  To make an object smaller, make
the symbol scale value smaller.  For example, changing the value from 1 to 10 would
make the object ten times as big as before.  Whereas, to make an object smaller,
changing the value from 1 to 0.1 would make the object one tenth as big as it was
before.  After changing the symbol scale value, then attach or insert the Radiance
entity to your drawing.

Figure 22.  General Preferencs Dialog Box
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The Desktop Radiance Export Preferences Dialog Box(Figure 23) determines which
entity types will be exported from your graphic editor for the simulation.

Figure 23.  The Export Preferences Dialog Box

The layers options refer to the various layer settings in your Graphic Editor program.
The Geometry option determines whether you want all geometry to be exported
automatically for simulations or if you want to select particular Geometry yourself.
Closed or Extruded 2D Geometry and 3D Geometry refer to types of geometry that
can be included in simulations.
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Library Manager

Introduction
The Library Manager is a collection of tools related to the maintanance of the
Desktop Radiance Materials, Luminaires, Glazings, and Furnishings.  As of version
1.0, its features are limited to the library browser and material editor.  This Library
Browser allows you to view detailed information about Radiance Furnishings,
Glazings, Luminaires, and Materials.  The Material Editor allows you to create new
Radiance materials.

To reach the Library Browser from inside the Graphic Editor, go to
Radiance→ Tools→ Library Manager.  Select the appropriate tab for Furnishings,
Glazings, Luminaires, or Materials.

The current state of the Library Browser does not include all future functionality.
Future version will have the ability to manage project specific libaray items and to
move items between a project database and the main library.

Material Library Browser
The Material Library Browser(Figure 24) allows you to view all the available
materials and their properties.  You can search for items in the Material Library by
scrolling through the list.  When an item has been highlighted the properties can be
viewed by clicking PROPERTIES.  Materials may be found by using the “Find”
Command.  Type the common name or a fragment of the common name in the white
box next to the FIND button.  Then click on the FIND button.  It will find the first
occurrence of the item.  Click on FIND again to find the next occurrence.
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Figure 24.  The Material Library Browser

Material Editor
In addition to the predefined Desktop Radiance materials, custom materials may be
created in the Material Editor.  Currently only reflective materials can be created.  It
is also not yet possible to “edit” existing materials in the library.  To enter the
Material Editor(Figure 24) from Desktop Radiance, go to
Radiance→ Tools→ Library Manager and select the Materials tab to bring the
Material Library to the foreground(Figure 25).  Material Editor may also be opened
by double clicking on the “Material Editor” icon created by the install program in the
Desktop Radiance directory.  Once in the Material Library Browser, click on the
NEW button and enter a new material name when prompted.  For every custom
material that you create, the Material Editor needs to know the material type, Red,
Green, and Blue values and Specularity and Roughness values.  You may optionally
specify information about the manufacturer of this material from the “manufacturer”
button.

Figure 25.  Material Editor

Material Type
To set material type, use the pull down menu located below the Material Name field.
Currently only plastic and metal may be created.  Plastic includes all opaque
materials which have colored diffuse reflections but uncolored specular (shiny)
components.  Plastic materials include formica, tile, glossy paint, and any similar
surfaces.  Materials that have colored specular highlights are appropriately modeled
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as “metal”.  Metal materials include bronze, gold, copper, aluminum, and similar
surfaces.  (More on this in Physical Properties)

Manufacturer
Next, if applicable, click on the MANUFACTURER button to bring up the
Manufacturer Contact Information Dialog box(Figure 26).  This information is not
required.  To save manufacturer information and return to Material Editor, close by
clicking on APPLY.  You man specify a new manufacturer by selecting “NEW”
from the pop-up list of manufacturers.

Figure 26.  Manufacturer Contact Information dialog box

Color
The range of values for Red, Green, and Blue is generally between 0.0-1.0, with 0.0
being the perfect absorber (black) and 1.0 being the perfect diffuser (white).
Radiance RGB values are not comparable to other RGB formats.  The RGB may be
thought of as a three-point sample of the radiometric spectral content of the material.
While it is physically possible to have one of the components greater than one (such
as fluorescent materials) the reflective average should not be allowed to exceed 1.0.
(see Physical Properties, below).  Click the “Pick Color” button to display the
standard windows color palette (Figure 27).  Click “Define Custom Colors” to
display the HSV color picker.  This standard color picker may be used to
approximate the color of your surface.  Click “add” to add this color to your palette.
Select this color on the left hand side of the color picker and then click OK.  The
RGB and average reflectance of the color you have created will then be displayed.  If
the average reflectance is incorrect, the value may be changed and the resulting RGB
values will be updated.
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Figure 27.  Color Picker

Physical Properties
The Average Reflectance displays the total, hemispherical average photopic
reflectance.  A plastic(Figure 28) or metal(Figure 29) “swatch” will appear,
depending on which has been selected as the Material Type, to help you find the
desired specularity and roughness combination.  The reasonable range for specularity
is between 0.0 and .07, with 0.0 being a matte surface and .07 being satin.  For
roughness, the reasonable range is between 0.0 and 0.2, with 0.0 being polished and
0.2 a low gloss.  Both of these parameters may be selected from the “Pick” putton
adjacent to the Specularity and Roughness values.  Select the sphere which most
closely resembles your material and click Ok.  The selected Specularity and
Roughness values will be displayed in the Material Editor dialog box.

Figure 28.  Plastic specularity and roughness samples
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Figure 29.  Metal specularity and roughness samples

After the Red, Green, Blue, Specularity, and Roughness of the new material is
defined, click on the UPDATE BITMAP button to begin creating the bitmap.  The
Editor will make the image in the background and display it(Figure 30).
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Figure 30.  A new material type displayed

You may display two bitmaps at once to compare them side by side.  The newer
materil will appear in the upper window.  Either one may be selected to display its
properties.  When you are satisfied with the new material, click APPLY to save the
selected material into the database.

Glazing Library Browser
The Glazing Library Browser allows you to view all the available glazings and their
properties.  The Glazing Library Browser(Figure 31) allows you to view all the
available glazings and their properties.  You can search for items in the Glazing
Library by scrolling through the list.  When an item has been highlighted the
properties can be viewed by clicking PROPERTIES.  Glazings may be found by
using the “Find” Command.  Type the common name or a fragment of the common
name in the white box next to the FIND button.  Then click on the FIND button.  It
will find the first occurrence of the item.  Click on FIND again to find the next
occurrence.

Figure 31.  The Glazing Library Browser

Furnishing Library Browser
The Furnishing Library Browser allows you to view all available furnishings and
their properties.  The Furnishing Library Browser(Figure 32) allows you to view all
the available furnishings and their properties.  You can search for items in the
Furnishing Library by scrolling through the list.  When an item has been highlighted
the properties can be viewed by clicking PROPERTIES.  Furnishings may be found
by using the “Find” Command.  Type the common name or a fragment of the
common name in the white box next to the FIND button.  Then click on the FIND
button.  It will find the first occurrence of the item.  Click on FIND again to find the
next occurrence.



30  •  Library Manager Desktop Radiance User Manual

Figure 32.  The Furnishing Library Browser

Luminaire Library Browser
The Luminaire Library Browser allows you to view all available luminaires and their
properties.  The Luminaire Library Browser(Figure 33) allows you to view all the
available luminaires and their properties.  You can search for items in the Luminaire
Library by scrolling through the list.  When an item has been highlighted the
properties can be viewed by clicking PROPERTIES.  Luminaires may be found by
using the “Find” Command.  Type the common name or a fragment of the common
name in the white box next to the FIND button.  Then click on the FIND button.  It
will find the first occurrence of the item.  Click on FIND again to find the next
occurrence

Figure 33.  The Luminaires Library Browser.



Desktop Radiance User Manual Simulation Manager  •  31

Simulation Manager

Introduction
The Simulation Manager is the component of Desktop Radiance in which you
simulate and render the model you have created in the graphic editor.  After
attaching Radiance entities to your drawing, for example: materials, luminaires,
furnishings, glazings, cameras, etc., you are ready to begin the simulation process.
The simulation process involves the calculation of light in your model.  These
calculations depend on the properties of the Radiance attachments, location/time and
day settings, and accuracy parameters.

The simulation manager dialog box(Figure 40) allows you to keep track of all your
simulations for a project.  Each simulation and its associated properties and settings
is called a “scenario”.  After completing a simulation, the interactive rendering or
rview tools allow you to preview your model.  Rview allows for adjustments to
viewpoint location.  The advanced dialog boxes of simulation setup provide a user-
friendly means of adjusting light and shadow specifications, and other parameters
that can create more accurate images, faster rendering images or a combination of
these two factors.  Through the use of the rview tools and then with the Image
Analyzer, you can create an image that best fits your design needs and objectives.

Simulation Setup
The Camera Simulation Setup dialog box(Figure 34) allows you to define the base
parameters for your simulation.  The Camera Simulation Setup dialog box is
accessed by beginning a simulation.  Go to
Radiance→ Simulation→ Camera/Reference Grid/Reference Point

Then you will be prompted to select a Camera/Reference Grid/Reference Point
<enter>.  A dialog box will appear that asks for a scenario name.  Enter a name
which is unique for this project and click OK.  Then, as prompted, select objects to
be included in the simulation or type all. <enter>.  The Camera Simulation Setup
Box will then appear.
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Figure 34.  The Camera Simulation Setup Box

The Scenario Name box tells you the name of this particular scenario.  It is the name
previously entered in the Define Scenario Dialog Box.  The scenario name is
uneditable in the Camera Simulation Setup Box.

The camera name box allows you to choose the camera or view that you would like
to simulate for this scenario.  It automatically selects the camera selected previously
in the process but others can be chosen from the pulldown menu.  To create new
saved views of your model in autocad, go to ViewàNamed Views or type ddview.
The dialog box that appears allows you to save the current view as a saved named
view that can be accessed from the Camera Simulation Setup Box for simulation.

The accuracy box allows you to select the accuracy.  For Version 1.02, only a
Medium level of accuracy is available.  However, this setting can be overwritten by
changing the parameters under the "Advanced" dialog box.

The Sky and Weather box allow you to choose the sky conditions for your model.
You can choose from CIE Clear, Overcast, Intermediate, and Uniform.  Clear will
have sharp patches of light and quite a bit of bright diffuse light.  Overcast will have
shadows, dimmer diffuse light, and some light specular highlights. Intermediate has
sharp patches of light but the dim diffuse light of an overcast rendering.  Uniform
will have shadows and dimmer diffuse light than overcast with very faint specular
highlights.  For more information, consult the CIE Handbook.

To render with no sky or to turn the sky off, select a date and time that is at night.

The location box allows you to choose the location, more specifically the latitude
and longitude, for the simulation.  There are a few predefined locations.  You can
also define new locations by selecting "New… " from the pulldown menu.  This will
bring you to the Add New Location dialog box(Figure 35, p. 33).  For more on
adding a new location see Add New Location.

The date, and time boxes allow you to define such factors for your scenario.

In the Camera Simulation Setup Box  there is also a Simulation Quantity choice of
Luminance or Illuminance.  This setting determines what kind of information your
image will contain.  Luminance is the amount of light leaving a surface from a
specific direction and includes the final surface reflectance.  It closely resembles
what the eye sees.  Illuminance, alternatively, represents the total amount of light
reaching a surface from all directions.  Illuminance does not include the reflectance
of the surface where the illuminance is being measured.  The "illuminance"
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simulation quantity setting changes the Radiance computation so that the final
surface reflectance is not included in the determination of the brightness of each
pixel of the image.

The Simulation Mode box gives you choices of interactive, batch, or test.  The
interactive mode will allow you to experiment with exposure, ambient light and other
settings in the interactive rendering program, rview.  After finding ideal settings for
your building in rview, then you can make these setting changes using the
ADVANCED button on the Camera Simulation Setup Box.  Then, instead of
rendering in the interactive mode, render in batch mode.  The Batch Mode will give
more accurate simulation than in the rview Interactive Mode.  The higher accuracy of
a batch mode simulation will also increase the simulating time.  After a batch mode
simulation  is finished, the image will not automatically appear.  Click on
DISPLAY/ANALYZE in the Simulation Manager(Figure 40, p. 39) to view the
image.  The Test Mode allows you to get a quick simple rendering of your building.
This can be useful for quickly seeing the aiming of a camera.  Like the Batch Mode,
no image will appear until you click on DISPLAY/ANALYZE.  No adjustments can
be made to the image for it will appear in the image analyzer - Winimage, not rview.

After making any changes to the Camera Simulation SetUp Box you have several
commands to choose from.  START will begin the simulation.  The QUEUE
command is currently unavilable.  CANCEL will close the Camera Simulation Setup
Box and not save your changes.  ADVANCED leads you to four dialog
boxes(Figure 36, Figure 37, Figure 38, and Figure 39, pgs. 35-38).

Add New Location
To add a new location, enter all the requested information, click OK and you will
have created a new location which is added to the main Desktop Radiance database
and can be accessed by other projects.

Figure 35.  The Add New Location Dialog Box

The "City" field is required, however it does not have to be a real city.  The latitude
is an angular measurement that defines where your location is relative to the equator.
The latitude of the equator is equal to 0.  The latitude of the North and South poles is
90 and –90, respectively.  The number you would enter for the latitude of your
location is between 90 and –90.  It should be entered in decimal form.  From 0 to 90
is in the northern hemisphere and from 0 to –90 is in the southern hemisphere.  So,
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for example, the approximate latitude of Athens, Greece would be Lat 37.9.  This
number means that Athens is 37.9 degrees north of the equator.

The longitude is an angular measurement that defines your location relative to the
standard meridian in Greenwich, England.  The longitude of the Greenwich Meridian
is equal to zero.  The number you would enter for the longitude of your location is
between –180 and 180.  Longitudes west of Greenwich are positive and those east of
Greenwich are negative.  Like the latitude, the longitude should also be entered in
decimal form.  Using Athens, Greece as an example again… Athens has a longitude
of –23.7.  This number means that Athens is 23.7 degrees east of Greenwich,
England.

The Time Zone allows you to give the name of the time zone that your location is in,
for example Pacific Standard Time, or PST.  If you don't know which Time Zone
you should be using or if yours is not listed, chose "Other… " from the bottom of the
list and then fill in the Standard Meridian field.

Standard Meridian is the longitude of the middle of your time zone. To find it you
calculate the difference in time between the new location and the Greenwhich,
England timezone and multiply that number by 15.  In equation form, the standard
meridian looks like this: (GMT)-(your time)*15)=Standard Meridian. For Athens-
Greece, it's -2*15, so the Standard Meridian is -30.  Hint:  Standard meridian is
always an interger, multiple by 15.

If you don't know the time difference between your time zone and Greenwich Mean
Time, there are many resources on the internet.

The following website allows you to easily find the latitude and longitude of your
location within the United States:

http://www.census.gov/cgi-bin/gazetteer

If your location is not in the United States then you can visit the following website to
find the latitude and longitude of your location, click on the "Access GEOnet"
button:

http://www.nima.mil/gns/html/

Advanced Calculation Properties
The Advanced Calculation Properties dialog boxes(Figure 36, Figure 37, Figure 38,
and Figure 39) are a series of settings under the main categories of Analysis,
Lighting, Geometry, and Rendering. They are most commonly used in the final steps
of creating a highly accurate, high quality rendering.  To access these dialog boxes
select ADVANCED on the Simulation Setup dialog box.  Many of these settings are
also found in the interactive rendering program, rview.  The settings in rview are
intended to allow the user to quickly and easily test different values and settings.
When ideal settings are found, then the user can make the changes in the Advanced
Calculation Properties dialog boxes which will save the setting with the scenario.
After making changes in the Advaned Calculation Properties dialog boxes a high
quality batch mode simulation can be made by selecting batch on the simulation
setup dialog box.

The Advanced Calculation Parameters Analysis dialog box(Figure 36) includes
settings that can help with the analysis of images created in a Radiance simulations.
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Figure 36. Advanced Calculation Parameters "Analysis" Dialog Box

The settings in the Image Exposure section affect how light/dark your image will be.
By selecting Auto (linear average), the exposure will automatically be set to 1.  This
is a good exposure starting point.  If you have a specific value or you want the image
to be darker or lighter than usual, then use the absolute settings or the relative f-stop
settings.

The "Use Custom Post-processing Settings" checkbox refers to whether you are
using a PFILT setting other than the default.  If you are using a different value then
this box should be checked.

The Save Z-buffer data check box applies to animations only.

The Advanced Calculation Parameters Lighting dialog box(Figure 37) refers to
settings that have to do with how light will act within your model.
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Figure 37.  Advanced Calculation Parameters "Lighting" Dialog Box

Ambient bounces sets the number of times light will bounce from surface to surface.
The lower the number, the faster the calculation.  A reasonable number to use is
anywhere between 1 and 5.  For a batch mode rendering, 1 ambient bounce works
well.

Ambient Value affects how generally light or dark the image is.

The Advanced Calculation Parameters Geometry dialog box(Figure 38) deals with
certain Graphic Editor related settings, many of which are also found directly within
the Radiance pulldown menu.
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Figure 38.  Advanced Calculation Parameters "Geometry" Dialog Box

This dialog box allows you to define a zone.  A zone is a volume of space that
indicates an area where the simulation should focus on.  To define a zone begin by
entering a name for the zone.   Then select the zone to be either interior or exterior.
Interior means that you will be looking at the space from within the space.  Exterior
means that you will be looking at the space from outside the space.

The 6 point definition boxes are for defining a rectangular volume  aligned parallel
to the xyz axes.

The Advanced Calculation Parameters Rendering Dialog Box(Figure 39) determines
the pictorial quality of the simulation image rendering from your Radiance model.
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Figure 39.  Advanced Calculation Parameters "Rendering" Dialog Box

The RIF Control File box shows the name of the file that you are dealing with.  This
box will already be set and can't be changed here.

Rendering quality sets the quality of the simulation.  With the soft shadows box
checked, there will be no sharp shadows and rendering time will be longer.

Final resolution determines the sharpness of the rendered image. The horizontal and
vertical boxes should have numbers that are exponentials of 2.  For a high quality
rendering choose 1024 horizontal and 1024 vertical.  For a lower quality rendering
512 x 512 will do fine.

Oversample Ratio is what affects jagged lines.  By increasing this value, lines will
become smoother.  Although, increasing this value greatly increases rendering time.
Increasing the oversample from 1x to 2x will increase rendering time by 4 times.

High Quality Renderings
Before creating a high quality rendering, it is best to validate your scenario in the
interactive rendering program rview.  To do this, simply render your image in the
Interactive Mode.  This is the default mode setting in the Simulation Setup Dialog
Box.  Once you are satisfied with the geometry, views, materials, and all other
aspects of your model, then it is time to start a high quality rendering.  In the
Simulation Manager dialog box select the scenario that you would like to create a
high quality rendering of and give it a new name as indicated.  Once the Simulation
Setup Dialog Box appears select Batch as the mode choice.  A batch rendering will
render the image of your model at a far greater resolution than your monitor
resolution.  Then click the ADVANCED button in the Simulation Setup dialog box
and select the RENDERING tab.  First select High or Medium quality for your
rendering.  Then enter the final resolution that you would like.  A good
recommended final resolution for high quality renderings is 1024 x 1024.  Last,
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select the amount of over sampling that you would like.  Over sampling reduces the
"jaggies".  Although be careful with this setting, each incremental increase of over
sampling can quadruple your rendering time.  A fairly high quality rendering can
also be created without increasing the oversampling ratio or with different variations
on the above mentioned settings in the Advanced Calculation dialog boxes.

Simulation Manager
The Simulation Manager allows you to keep track of all the scenarios you have
created.  To access the simulation manager go to Radiance→ Tools→ Simulation
Manager.

Figure 40.  The Simulation Manager dialog box

The START button will begin a simulation that you have highlighted from the list.
The DUPLICATE button allows you to duplicate a highlighted scenario and change
settings on the Simulation Setup Dialog Box.  MOVE UP and MOVE DOWN will
change the order of the scenarios.  DELETE will delete the highlighted scenario.
CLOSE closes the Simulation Manager dialog box.

Define Project
A project folder is created when you start a simulation in Desktop Radiance. The
project folder name is the same as the AutoCAD drawing name, and the default
location is the Desktop Radiance install path e.g., C:\Program Files\Desktop
Radiance. This is similar to how MSWord defaults to a directory called personal for
saving word documents. If you chose to save the autocad drawing in a different
location, for example the first level of C: drive, then the project folder will be created
on the first level of C: drive also.

If the drawing which you want to start the simulation and rendering of is sharing the
name of another project and/or drawing, you will be prompted with the Open Project
Dialog box (Figure 41, p. 40).  If Use Existing is selected, the information in the
existing project folder will be used and new information added to the existing project
database.  Information will not be overwritten, but if significant changes have been
made, overwriting the project may be recommanded.   If New is selected, you may
be prompted by another dialog box to locate and create the new directory (Figure 42,
p. 40).
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Figure 41.  The Open Project dialog box

When the project folder or database files have been deleted, the following dialog
boxes will appear.  They appear after attempting to start a simulation.  They first
inform you that the project database cannot be found(Figure 42, p.40).  Then an open
file dialog box will appear.  At this point, either find the database file called
dradproj.mdb if it still exists or click OPEN to create a new one.

Figure 42.  The Locate Project dialog box

This will bring up the Create New Project File dialog box(Figure 43, p.40).
Selecting Yes will create a new project folder with the given name.

Figure 43.  The Create New Project File dialog box

Reference Point Analysis
When simulating a reference point, the Reference Point Properties dialog box
(Figure 44, p. 41) can be accessed by first simulating by reference point and then by
clicking on the DISPLAY/ANALYZE button in the Simulation Manager(Figure 40,
p. 39).
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Figure 44.  The Reference Point Properties dialog box

Workplane Grid Analysis
When simulating a reference grid or doing a workplane analysis, the Workplane Grid
dialog box (Figure 45, p. 41) can be accessed by first simulating by reference grid
and then by clicking on DISPLAY/ANALYZE in the Simulation Manager (Figure
40, p. 39) .

Figure 45.  The Workplane Grid dialog box
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Define Scenario

Figure 46.  The Define Scenario Dialog box

Every scenario needs to have a unique name.  The name given becomes the prefix of
files created by the simulation manager.  For example, for a scenerio named room1,
the files created will have names such as room1_sky.rad and room1.rif.
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Image Analyzer

Introduction
The Image Analyzer(Figure 47), also known as winimage, may be opened from
within Desktop Radiance starting from Radiance→ Tools→ Image Analyzer, or by
double clicking on the Image Analyzer icon created by the install program.

Figure 47.  The Image Analyzer Dialog Box

The Image Analyzer displays and allows for analysis of Radiance images.  Radiance
images are saved with the default extension .pic.  You may also convert images (save
as) so they can be read by other imaging, paint, or presentation  programs.  All
commands operating within winimage, with the exception of redraw, will result in a
new image file being created.

The file naming convention in winimage is adding “_” and an abbreviation of the
executed command, i .e.  “fls” for falsecolor.  Thus, if falsecolor is performed on
drawing.pic, the resulting falsecolor image will be drawing_fls.pic. If an annotation
is performed on drawing_fls.pic, then the resulting image will be
drawing_fls_ann.pic.  The original drawing.pic is not overwritten.  However, if
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falsecolor is performed on the same image twice, the second version will overwrite
the earlier one.

The Radiance RGBE Format
A main advantage of the Radiance Synthetic Imaging System is the high dynamic
range provided by its RGBE image file format.  It allows for storing real-world
luminance and illuminance values across 77 orders of magnitude with 1% accuracy.

Images can contain either scalar data (which lacks the high dynamic range), or
luminance/illuminance values.  It is important to distinguish between those two
formats because scalar images are not appropriate for analysis as they lack the real-
world high dynamic range values.

File

Open
Image Analyzer will open Radiance created images for viewing and analysis only.  It
will not open pictures or images saved in other formats.

Save As
A Radiance image may be saved as a pic, gif, tiff, pct (mac pict file), eps, or bmp.
The saved image, if in a format other than Radiance’s .pic, will not be openable by
winimage again.

Image
The functions available under the Image menu result in new images which preserve
the real-world, high dynamic range of the original image.  Such images are suitable
for later manipulations with functions under the analysis menu.

Redraw
Image Analyzer→ Image→ Redraw, this function redraws/regenerates your image.  It
does not create a new drawing.

Exposure
Image Analyzer→ Image→ Exposure, this tool adjusts the exposure level of the
selected image, region, or point with a linear function with clamping.  The adjusted
image will be given a name and saved as a new .pic file automatically as it is being
displayed.  This is similar to how a camera works and can only partially compensate
for regions of the image which are too bright or too dark.  The sky outside of the
windows, for example, will appear completely white if the image is exposed for the
interior surfaces.  To make the image darker by picking a point or region, select a
point or region that is bright.  To make the image lighter, choose a point or region
that is one of the darker areas.
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Image
Image Analyzer→ Image→ Exposure→ Image, this tool adjusts the exposure by
averaging all pixels of an image.

Region
Image Analyzer→ Image→ Exposure→ Region, then select the region by clicking and
dragging.  The enclosed pixels will be averaged and the resulting value used to
determine the appropriate exposure.  If the image has a washed-out or brightly lit
window and a room’s interior, the window may be selected for exposing.  The
resulting new image will be of a dimmer interior and a window which seems less
bright.

Point
Image Analyzer→ Image→ Exposure→ Point, then select a point on the image with
the cursor.  The image will be adjusted with the selected point as the exposure set
point.

Rotate
Image Analyzer→ Image→ Rotate, then select either 90 degrees clockwise or 180
degrees.  A rotated image will appear.

Flip
Image Analyzer→ Image→ Flip, this function will flip (mirror) the image horizontally
or vertically.

Analysis
The functions available under the analysis menu result in new images which lose the
real-world luminance and illuminance values, i.e.  they become unsuitable for further
manipulations under the analysis menu.

Human Sensitivity
This tool is similar to an exposure adjustment but uses a variety of nonlinear and
linear filters to mimic human visual perception.  This tool compresses the dynamic
range so that most of the details in a high-contrast image may be displayed
simultaneously, similar to the visual experience one may have in the actual space.
(See also Pcond).

Image
Image Analyzer→ Analysis→ Human Sensitivity→ Image.  The human sensitivity
tool will consider the entire image (Figure 48, left) to determine the appropriate
perceptual exposure setting.  The resulting new image (Figure 48, right) may take a
few minutes to complete, especially for wide-angle views.
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Figure 48.  Image before (left) and after (right)  running Human Sensitivity

False Color

Figure 49.  The Falsecolor Dialog Box

Image Analyzer→ Analysis→ Falsecolor brings up the Falsecolor Dialog Box (Figure
49).  When applied to a luminance image, falsecolor outputs (Metric) candela/m2 or
(English) footlamberts.  When applied to an illuminance image, falsecolor outputs
lux or footcandle.  The number of divisions sets the number of intermediate, equally
spaced values between zero and the maxium value that will be displayed on the
legend.  Show pixel extrema, if selected, will cause falscolor to annotate the image
pixel with the max and min luminance or illuminance values (Figure 50).
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Figure 50.  Falsecolor image with Show Pixel Extreme selected

Iso Contour
Image Analyzer→ Analysis→ Iso Contour brings up the Iso Contour Dialog box
(Figure 51).

Figure 51.  The Iso Contour Dialog box

Iso contour is similar to falscolor.  Both output images with quantitative
measurements.  Iso contour draws demarcation lines in equal steps, according to
number of divisions specified, between zero and the maxium value.  Unlike
falsecolor, the resulting image will contain colored lines of equal value overlayed
upon the true color luminance or illuminance image (Figure 52).
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Figure 52.  Iso Contour image

Annotate
Image Analyzer→ Analysis→ Annotate brings up the annotate dialog box.  This tool
places text on image.  Type the annotation text in dialog box, press ok, and an
updated image with appear with overlay text.

Window

New Window
Image Analyzer→ Window→ New Window opens another window of the same
image.  This allows different parts of the image to be viewed simultaneously, or for
different analyses to be performed and compared side by side.

Cascade
Image Analyzer→ Window→ Cascade displays all open images in a cascading
fashion.

Tile
Image Analyzer→ Window→ Tile tiles all open drawings.

Arrange Icons
Image Analyzer→ Window→ Arrange Icons lines up minimized image icons at the
bottom of the winimage window.
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Interactive Rendering (rview)

Introduction
Desktop Radiance allows for real time, interactive rendering.  The image pixels
refine on the screen and start to give you an idea of what the scene will look like.
Rview is not meant to be a high resolution rendering tool but more for deciding
viewpoints and validating scene geometry (make sure window normals are correct,
furniture not floating in midair, walls meet, etc).  The rview interactive rendering is
the default mode for simulation.  To produce high quality images, select Batch mode
in the Camera Simulation Setup box.

  
Figure 53.  The rview window during rendering (right) and after rendering (right).

File

Append View to rif file
This function saves the view information as text into a specified .rif file in the project
directory.  A rif file is not an image and cannot be opened in the Image Analyzer or
rview.  But the view information saved within a .RIF file may be used in a later
rendering or simulation.

Append View to view file
This function saves the view information into a .vf file in the project directory.  A .vf
file is a text file and cannot be opened in the Image Analyzer Program.
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Load view from rif file
This function allows you to select and load into rview a view previously saved in the
rif file.

Load view from view file
This function allows you to choose and load a vf file into rview.

Save Image
Saves the image as a .pic file.  This type of file can be opened in the Image Analyzer
program.

Save Image As
Allows you to save an image as a .pic file.  A pic file can be opened in the Image
Analyzer.  The default location for a pic file is in the project file of your drawing.

Save Log File As

View Log File
The log file is created after you trace a ray in rview.  The log file records all rays
traced and all data associated with the ray.

Figure 54.  The View Log dialog box

Exit
Upon exiting rview, it will ask if you want to save the image.  If you click YES you
will be able to save the image as the default name given in the default location or as
another name in a location you choose.  Clicking NO will close rview and not save
the image.

View
This menu allows you to display or hide the rview tools.  The Toolbars include: the
command bar, the roll/pitch bar, the status bar, the main toolbar, and the
yaw/translate bar.  If they are not already there, they can be turned on through the
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rview→ View pull down menu on the rview screen.  All the toolbars except the Status
bar can be rearranged on the rview dialog borders.

Figure 55.  The rview window with all command bars visible

Command Bar
This is a small edit box which allows you to access some of the legacy features of
rview.

Figure 56.  The Command Bar edit box

You can type in commands for rview and press <enter>.  The available commands
can be found under the rview→ Help→ Commands pull down menu and they are:

Figure 57.  The available commands that can be used on the command bar in rview.

Roll/Pitch Bar
These sliders control the rotation of the camera in rview to the right, left, up, and
down.  Roll adjusts rotation to the right or left around a horizontal axis perpendicular
to the view plane, of the current view.  Moving the slider up will roll the camera to
the right, moving it down will roll the camera to the left.  Pitch adjusts rotation up
and down around a horizontal axis parallel to the view plane.  Moving the slider up
will rotate the camera forward/up and moving the slider down will rotate the camera
forward/down.
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Figure 58.  The Roll Pitch Bar

Status Bar
This is found near the bottom of the rview screen.  The status bar indicates the
progress of the rendering.  When the rendering process is finished the status bar will
display "Ready".

Figure 59.  The Rview Status Bar

Tool Bar
The main toolbar contains six different tools (Figure 60) that are useful in formatting
your rview screen to best fit your needs and analysis objectives.

Figure 60.  The main toolbar in rview

"E" adjusts the exposure.  This effects how light or dark your rview image is.  For
more on this see Exposure, p. 55.

"F" allows you to frame an area of the rview image for refinement.  For more on this
see Frame,p. 56.
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"N" redraws or regenerates the rview image.  This is sometimes necessary if you
have changed several parameters or settings in rview.  For more on this see Redraws
a New image, p.56.

"P" allows you to adjust certain image parameters in rview.  For more on this see
rview Parameters Dialog box, p. 56.

"T" allows you to ray trace.  For more on this see Ray Tracing, p. 61.

"V" allows you to adjust and set the rview view.  For more on this see  Set View,    p.
62.

Yaw and Translate Bar
The Yaw tool turns the view about the Z axis to the right or left.  Adjusting the Yaw
slider to a smaller number makes it turn left, and a larger number turns the camera to
the right.

Figure 61.  The Yaw and Translate Bar

The X,Y, and Z spinners move your viewpoint position along the X, Y, and Z axes.
The larger spinners move the viewpoint in larger increments.  The smaller spinners
move the viewpoint in smaller increments.  To adjust the increments that these
spinners set with see GUI Increments, p. 55.

The spinners labeled F/B, L/R, and U/D move the viewpoint from it's relative
position and angle, as opposed to along an axis which the X,Y, and Z spinners do.

The F/B spinners move the viewpoint forwards and backwards.The up pointing
spinners move the viewpoint forwards.  The down pointing spinners move the
viewpoint backwards.

The L/R spinners move the viewpoint to the left and right.  The spinner pointing up
moves the viewpoint to the left.  The spinner pointing down moves the viewpoint to
the right.

The U/D spinners move the viewpoint up and down.  The spinner pointing up moves
the viewpoint up.  The spinner pointing down moves the viewpoint down.
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Set
This menu item allows you to turn on and off certain features of rview.  SET also
provides another way of accessing some commands that are found on the main rview
toolbar.

Backface Visibility
This tool turns on and off the walls whose surface normal is pointing away from your
viewpoint.

   
Figure 62.  Without backface visibility (left) and with (right).

This tool is useful when you wish to see through the near side of a building.  With
one camera on the outside both the inside and outside of a building can be easily
viewed instantaneously in rview.  For this tool to work, the surface normals of the
wall surfaces must be oriented toward the inside of the building.  What this tool in
essence does is turn off the wall surfaces whose surface normal is pointing away
from the viewpoint.  For more information on orienting surface normals see Adjust
Normal Orientation in the Graphic Editor section.

Greyscale
This tool renders the image in black, white, and graytones.

Irradiance
If selected, rview simulates and calculates the Illuminance in the model.  Reflectance
of materials is not taken into account.  The amount of light that reaches each surface
in your model is measured and displayed.
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Figure 63.  An irradiance image

GUI Increments
The GUI increments are the increments that the sliders and spinners of rview tools
are setup with.  This tool allows you to adjust the increments that spinners and
sliders are set for.  The major spinners and sliders are meant to be set with relatively
large increments.  These allow you to move the view in large segments at a time.
The minor spinners and sliders are meant to be set with relatively small increments.
These allow you to fine tune the position of your view once you have moved the
majority of the distance with the major spinners and sliders.

Figure 64.  The Set GUI increments dialog box

Exposure

  When using the exposure tool, the higher the setting, the brighter the image will
be.  When “Relative Mode” is selected, the exposure will be set relative to your
choice of either a point that you select in the image or relative to the average value in
the image.
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Figure 65.  The rview Exposure tool

Frame

  This tool allows you to frame a section of an image for refinement.  After
clicking on “F” you are prompted to select an area for refinement.  Use the cursor to
drag a box around an area of the image.  To select the entire image, draw a box
around the entire rview window.  There is no frame all command as in previous Unix
versions of rview.

Redraws a New image

  This tool redraws/regenerates a new image.  This is sometimes necessary if the
image has been corrupted by other dialog boxes, or if you have significantly changed
your calculation parameters and want to start over.

rview Parameters Dialog box

 The rview parameters define the level of accuracy for the simulated image.  The
settings in this dialog box will determine if your model will simulate an image
quickly or more slowly to a high level of accuracy.  In the rview parameters dialog
box you can  manipulate things such as the number of ambient bounces that should
take place.  For information on choosing recommended values for rview parameter
settings see the Desktop Radiance User Manual→ Tips and Techniques→ Setting
Rendering Options.  This table will give you minimum, maximum, fast, and accurate
values.  In addition it tells you particular settings that can greatly affect the rendering
time of your model.

Ambient Parameter Tab

The Set Parameters→ Ambient dialog box(Figure 66) below sets the parameters for
the ambient light in the scene.  To access the Ambient Parameters dialog box go to
rview→ Set→ Parameters and click on the AMBIENT tab.
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Figure 66. The Ambient Tab in the Parameter Dialog Box

Value: three boxes representing red (top), green (middle), and blue (bottom).
Increasing these values evenly can make the scene darker, decreasing them will
make it lighter.

Weight: the average weight of the indirect light.  As new indirect lights are
computed the average value will be modified.  For a scene that includes indoor and
outdoor spaces, a value of zero is appropriate and is the default.

Accuracy: the accuracy of the ambiently lit areas of the model.  The smaller the
number, the smoother the rendering.  A value of zero is very accurate.  A value of
0.3 is a reasonable level to begin with.  The range of possible values that can be
entered is between 0 and 0.5.  Lower numbers are more accurate.

Divisions: the number of divisions in the ambient light.  A value of zero implies no
indirect calculation.  A reasonable value to begin with is 128.  The range of possible
values that can be entered is between 0 and 4096.  Higher numbers are more
accurate.

Super-samples: applied to ambient divisions that show a big difference in value
from one to the other.  A reasonable value to begin with is 96.  The range of possible
values that can be entered  is between 0 and 1024.  Higher numbers are more
accurate

Bounces: the maximum number of diffuse bounces that will be computed by the
indirect calculation.  To have no indirect calculation, enter a value of zero.  For a
medium quality rendering, a value of 2 or 3 is reasonable.  The range of possible
values that can be entered is between 0 and 8.  Higher numbers are more accurate.  If
your rview rendering first  appears very flat and shadowless, a low value for the
ambient bounces setting is usually the cause.

Resolution: the rendering of the ambient light areas of the model.  A value of zero
means that there is an unlimited amount of resolution.  A reasonable value to begin
with is 12.

Direct Parameters Tab

The Set Parameters→ Direct Dialog Box (Figure 67) sets the parameters for the
direct light in the scene.  To access the Direct Parameters dialog box, go to
rview→ Set→ Parameters and click on the DIRECT tab.
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Figure 67. The Direct Parameters Dialog Box

Direct-Certainty: value of one guarantees that the absolute accuracy of the direct
calculation will be equal to or better than that given in the Direct→ Threshold value.
A value of zero insures that all shadow lines resulting in a contrast change greater
than the specified Direct→ Threshold value will be calculated.  A reasonable value to
begin with is 0.25.  The range of possible values that can be entered is between 0 and
1.  Higher numbers are more accurate.

Direct-Jitter: controls the smoothness and accuracy of penumbras or soft shadows.
A value of zero means that shadows will be rendered without penumbras and a value
of 1.0 will maximally sample large area sources to provide the smoothest possible
penumbras.

If direct jitter is greater than 0.0 then pixel sampling must be 1.0.  A good value to
use for direct jitter is .67 when smooth shadows are desired.  This parameter can
greatly increase rendering time so use with caution.  A reasonable value to begin
with is 0.02.  The range of possible values that can be entered is between 0 and 1.
Higher numbers are more accurate.

Direct-Sampling: subdivides a light source until the width of each sample area
divided by the distance to the illuminated point is below this ratio. This assures
accuracy in regions close to large area sources at a slight computational expense. A
value of zero turns source subdivision off, sending at most one shadow ray to each
light source.  Large area sources are subdivided into at most 64 patches which can
lead to “hot spots” on immediately adjacent surfaces.

Direct-Threshold: minimum light value that a light source must have to be tested
for shadows.  A value of zero means all light sources will be tested for shadows.  A
reasonable value to begin with is 0.2.  The range of possible values that can be
entered is between 0 and 1.  Lower numbers are more accurate.

Direct-Visibility: allows you to make light sources appear black when looked at
directly, but light output will still be taken into account for the simulation and
analysis.  A value of zero will turn off the light source visibility.  Any number
greater than zero will turn it on.

Limit Parameters Tab

To access the Limit Parameters dialog box(Figure 68), go to
rview→ Set→ Parameters and click on the LIMIT tab.
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Figure 68.  The Limit Parameters Dialog Box

Limit-Reflection: defines the maximum number of specularly reflected and
refracted rays that can be spawned for each initial view ray.  A reasonable value to
begin with is 3.  The possible range of values that can be entered is between 0 and
16.  Higher numbers are more accurate.

Limit-Weight: the weight function stops the generation of specular rays when the
potential contribution is less than the specified minimum value.  If the amount
measured is less then the specified minimum weight, additional rays will not be
traced.  A reasonable value to begin with is 0.02.  The possible range of values that
can be entered is between 0 and 0.05.  Lower numbers are more accurate.

Medium Parameters Tab

Parameters in the Medium tab affect the way light is traced through “participating
media” such as mist or fog.  Volumes of participating media must be modeled with
the appropriate Radiance material.  Such materials are not yet available in Desktop
Radiance.

To access the Medium Parameters dialog box(Figure 69), go to
rview→ Set→ Parameters and click on the MEDIUM tab.

Figure 69.  The Medium Parameters Dialog Box
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Scattering Albedo: determines whether light from a medium is absorbed or
scattered.  From top to bottom the boxes stand for Red light, Green light, Blue light.
Only values between 0 and 1 can be entered.  A zero will cause all light not
transmitted by a medium to be absorbed.  A one will result in all light not transmitted
to be scattered elsewhere.

Extinction Coefficient: refers to the distance that light will be scattered or absorbed.
The three boxes from top to bottom stand for red light, green light, blue light.

Scattering Eccentricity: defines how much light scattering will tend towards the
forward direction.  Only values between 0 and 1 can be entered.  A value of one will
result in the most forward tending light scattering.

Mist Sampling Distance: defines the distance between samples taken during a
source scattering.  A value of zero means that only one sample will be taken.

Pixel Parameters Tab

To access the Pixel Parameters dialog box(Figure 70), go to
rview→ Set→ Parameters and click on the PIXEL tab.

Figure 70.  The Pixel Parameters Dialog Box

Sample: defines the amount of space in pixels that can be used for subdivisions on
the image plane.  A reasonable value to begin with is 16.  The range of values that
can be entered is between 1 and 16.  Lower numbers are more accurate.

Threshold: if two adjacent pixel samples differ by more than this amount, a third
sample will be taken.  A reasonable value to begin with is 0.08.  The range of values
that can be entered is between 0 and 1.  Lower numbers are more accurate.

Specular Parameter Tab

To access the Specular Parameters dialog box(Figure 71), go to
rview→ Set→ Parameters and click on the SPECULAR tab.
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Figure 71.  The Specular Parameters Dialog Box

Jitter: the amount that specular semi-highlights will be sampled.  A value of zero
will turn off specular sampling causing all light reflections to appear sharp.  A value
of one will make all specular reflections fully sampled allowing for soft reflections.
A reasonable value to begin with is 0.  The range of values that can be entered is
between 0 and 1.  Higher numbers are more accurate.  Changes in this value have no
effect on rendering time.

Threshold: the minimum specularity of materials under which specular sampling is
not performed.  A value of zero means specular sampling will always take place.  A
value of one means specular sampling will not take place at all.  Values between 0
and 1 will selectively allow specular sampling, for those materials whose specularity
is above the specified value.  A reasonable value to begin with is 0.001.  The range
of values that can be entered is between 0 and 1.  Lower numbers are more accurate.

Ray Tracing

  You select a point to find the level of luminance or illuminance, depending on
the calculation quantity(set→ irradiance or set→ radiance), in your model at that
point.

Figure 72.  The Raytrace information dialog box

The first line of output provides the name of the material (e.g. 2k217)
associated with the surface that the traced ray struck in the model
followed by the surface type (e.g. polygon) followed by the surface
identifier (e.g. document_53.2.0).
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The second line of output provides the location in space that the ray
struck (x, y, z coordinates)(e.g. -2.32832 e-010, 79.303, 86.9679) followed by the
length of the ray from the
camera position to that point (e.g. 117.71) in the units of your model.

The third line of output provides the computed luminance or illuminance
value, first in red, green and blue spectral quantities, then in average
luminance or illuminance quantity.

If your calculation quantity is set to illuminance, this value will
report the illuminance in Lux. If your calculation quantity is set to
luminance, this value will report the luminance in nits or candelas per
square meter. These units are always displayed in SI units, regardless
of the units specified in the preferences dialog box.

Set View

  The Set View Dialog Box(Figure 73) sets specifications for the view or camera.
The settings to specify include: Type, Size, Viewpoint, Clipping Plane, Direction,
Up, and Offset.

Figure 73.  The Set View Dialog Box

Type:

Angular allows for a fisheye view of the model with a horizontal and vertical view
size of up to 360 degrees.

Cylindrical gives a view of the model projected onto a horizontal cylinder as is used
with quicktime VR applications.

Hemispherical fisheye views of the model with view size up to 180 degrees.

Parallel gives a flat elevation, section, or plan view of the model.  View size is then
interpreted in world units instead of degrees.
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Perspective is a standard perspective view of the model from your viewpoint and
allows for a view size of up to 179 degrees.

Size:

Horizontal sets the view angle for a perspective or fisheye view.  For a parallel view
it sets the width of the view in world units.

Vertical sets the height of the view window.

Viewpoint:

The X,Y,Z coordinates determine the focal point for a perspective view or the center
point of a parallel projection image.

Clipping Plane:

This is a plane, perpendicular to your view direction, that cuts through and hides a
portion of the image of your model.  Fore and Aft refer to whether what is in front of
or behind the plane, respectively, is hidden.  The value that is entered in these boxes
determines the distance from your viewpoint that the clipping plane is situated.  If
your image is in a fisheye view then the clipping plane is a clipping sphere and the
value entered is the radius of the sphere.  The center of the sphere being your
viewpoint.

This tool is useful for viewing the inside of buildings by slicing off a wall on one
side.  A similar effect can be achieved with backface visibility.

Direction:

This tool defines the direction of the view vector that creates the view.  The X,Y,Z
boxes define a point that the view vector will pass through.

Up:

Up is defined by XYZ vectors, with the direction which appears to be the top of the
computer screen being up.  For example, for a view seen by a person standing and
looking straight towards the horizon, the up is along the Z axis, and is defined by
X=0 Y=0 Z=1.

Offset:

This tool offsets the view projection up, down, right, and left.  A positive Horiz
refers to a right offset.  A positive Vert refers to a vertical offset.

Help

Commands
This menu item provides you with commands that can be used in the rview
Command Bar.  For more information and to view the commands, see Command
Bar(p. 51).
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Defaults

Figure 74.  The Rview Defaults dialog box


