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Desktop Radiance

Introduction
Desktop Radiance is a design tool that facilitates the design and analysis of buildings
to optimize the efficiency of daylighting systems and lighting technologies.  Desktop
Radiance is a plug-in module that works with other popular computer aided design
(CAD) tools to provide the user interaction and 3-d modeling capabilities.  Desktop
Radiance relies upon the popular Radiance Synthetic Imaging System to provide its
renderings and analytical results.

The first step in the process of performing a daylighting analysis is the creation of a
3D model in a Graphic Editor program, such as AutoCAD (See Setting Up A
Drawing).  The 3D model can then be detailed appropriately using the Desktop
Radiance library of materials, glazings, luminaires and furnishings. Once the model
is complete, you then define the analysis parameters such as camera views or
reference point calculations, building orientation and zone of interest.  Then you set
up a rendering or point calculation using the simulation menu commands that initiate
the export of the geometry and analysis parameters.  See the Simulation Manager
for more information about starting your simulations and Image Analyzer for more
information about analyzing your results.

This document is not intended to be a comprehensive discussion of the appropriate
modeling techniques for daylighting design. It is assumed that you are familiar with
daylighting design and fairly familiar with general 3-d modeling and AutoCAD in
particular.  You may wish to browse the Quick-start Tutorial for a brief introduction
to the various 3-d geometric primitives and how they can be assembled into a model
of a simple office space.

This document is organized according to the menu structure of Desktop Radiance as
found in Version 2.0 BETA as of December 1, 2000.  It is also available through the
on-line, context-sensitive help system for Desktop Radiance.
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 Graphic Editor

Introduction
The Graphic Editor (AutoCAD for this document) is where you create the 3-D
representation of the geometry of the space you are designing.  All of the AutoCAD
native commands are available for this purpose.  Desktop Radiance adds the
“Radiance” menu item to the AutoCAD menubar.

Figure 1.  The Main Radiance Pulldown Menu

It is from this menu that all Desktop Radiance commands are accessed.  In most
cases, you first select the command, and then follow the prompts to provide the
requested information such as selecting the surfaces onto which you wish to perform
some action.  In some cases the command leads to a dialog box which requires your
input.  The following pages will explain each Radiance menu item in detail.

Setting Up A Drawing
When you first open a drawing with the Desktop Radiance icon, you will see the
Desktop Radiance Preferences Menu Figure 2

Figure 2
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Figure 2.  The Desktop Radiance Prefrences

The Preferences dialog box will appear everytime unless you uncheck the “Show this
dialog whenever a drawing is loaded” option.  The best way to get started with
modeling your building is to set up your drawing units.  AutoCAD and Radiance are
both “unitless” modeling systems.  This means the “size” of a unit of distance is
defined by the user and implemented as a convention.  Sometimes a scaling factor is
also used which causes the unit to be proportionately larger or smaller than its base
unit size.  These settings for your drawing can be defined in the Preferences Dialog
Box see Preferences. Once you have set up the units you are ready to start modeling
and making attachments from the Radiance menu.  Below we will discuss each menu
item in turn starting with the Materials menu item.

Materials
Materials can be attached to any surface in your graphic editor 3-D model.  Radiance
is equipped with an extensive library of materials. You can also create your own
materials using the Material Editor that can be reached through Radiance →
Materials →  New Materials or through the Library Manager.  For more information
on creating your own materials, see New Material or Material Editor

Attach materials
The Materials Library dialog box (Figure 3) contains the database of available
materials that can be attached to surfaces in your drawing.
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Figure 3. The Materials Library Dialog Box

To access the Materials Library Dialog Box, first use the menu command
Radiance→ Materials→ Attach Material, then when prompted, select the surface or
surfaces that you want to attach a material to. After selecting surfaces you then press
<enter> (this implies, no more surfaces to select) and the Materials Library Dialog
Box will appear.

Scroll through the list and choose a material. After selecting a material, click the
ATTACH button at the bottom of the Materials Library dialog box. Doing so brings
back the AutoCAD window and associates the material to the selected surface.  In
AutoCAD, the surface will not change appearance; in other words, the line color will
not change.  Repeat the process for other surfaces in your model.  Only one material
can be attached to each plane or surface.  In other words, two materials cannot be
attached to the front and back of a surface.

You can sort the material library to make it easier to find a specific material. The
Materials Library can be sorted by the common name of the material, its
manufacturer, the manufacturer’s product code, the source of the data (the person or
company that entered it into the database), or by the material’s reflectance,
transmittance, specularity, or roughness.  To sort the materials, select the desired
property in the drop-down list box next to the “SORT BY” button.  Then click
“SORT BY”.  You can click again to reverse the sort order.

Alternatively, you may search for a material by using the FIND function of the
Materials Library.  Type the first few characters of the name of the material or any
field in the materials library in the edit box adjacent to the FIND button.  Click on
the “FIND” button and it will find the first occurrence of the material that matches
the sequence of characters you have entered.  Click on “FIND” again to find the next
occurrence.

Detach Materials
To detach a material from an object click on Radiance→ Materials→ Detach Material.
Then select the object from which you want the material detached.

This tool can be used in conjunction with the “Show all attached materials” function
making it possible to select and detach all the materials in a drawing at one time.  To
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do this go to Radiance→ Materials→ Show All Attached Materials.  When all
surfaces are selected go to Radiance→ Materials→ Detach Material.  At the prompt it
will ask you to select surfaces to detach the materials from.  Type the letter P for the
previous selection set, all surfaces with materials will be selected and highlighted,
then hit <enter>.  All materials of the highlighted, selected surfaces will be detached.

Show All Attached Materials
This function selects all objects that have a material attached to them.  To use this
function go to Radiance→ Materials→ Show All Attached Materials.  The surfaces
with attached materials will become selected and displayed with dashed lines in the
Graphic Editor window.

Show Material Properties
This function allows you to view detailed information about a specific material.

For more information on how to use the Material Properties Dialog Box (Figure 22)
or to create new materials, see Material Properties or the Library Manager.

New Materials
New Opaque materials can be created and added to an user database by using the
Material Editor.

Luminaires

Place Luminaire
The Luminaires Library dialog box shows the database of available luminaires.

Figure 4. The Luminaire Library Dialog Box
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Modeling Tip:

It is usually easiest if you
display an axonometric view
of your drawing to position
the luminaire into your
drawing at the correct height.
Use the appropriate
“snapping” method.  Then in
plan view you can move the
luminaire to the correct
horizontal position.

To access the Luminaires Library Dialog Box select Radiance→ Luminaires→ Place
Luminaires and the Luminaires Library Dialog Box will appear (Figure 4)

Scroll through the list and select a luminaire to place in your drawing. Next, click the
ATTACH button at the bottom of the Luminaires Library dialog box. Doing so
brings back the AutoCAD window. Select an insertion point for the luminaire and
then choose a rotation angle.  Repeat the process for other luminaires.  You can also
create your own luminaires with custom IES photometry by using the Luminaire
Wizard.  You can reach the wizard through Radiance →  Luminaire →  New
Luminaire.  For more information on creating luminaires, see New Luminaire.

You can sort the luminaire library to make it easier to find a specific luminaire. You
may sort the luminaire library by the common name of the luminaire, its
manufacturer, the manufacturer’s product code, the source of the data (the person or
company that entered it into the database), the luminaire’s lamp type, dimming level
(watts), dimming level (lumens), or number of lamps.  To sort the luminaires, select
the desired property in the drop-down list box next to the “SORT BY” button.  Then
click “SORT BY”.  You can click again to reverse the sort order.

Alternatively, you may search for a luminaire by using the FIND function of the
Luminaire Library.  Type the name of the luminaire or a sequence of characters
matching any other field in the luminaire library in the edit box adjacent to the FIND
button.  Click on the “FIND” button and it will find the first occurrence of the
luminaire that matches the sequence of characters you have entered.  Click on
“FIND” again to find the next occurrence.

Delete Luminaire
To delete a luminaire from your drawing go to Radiance→ Luminaires→ Delete
Luminaire.  Then select the luminaire that you want deleted.  The AutoCAD erase
command also works.

Show Luminaire Aiming
This function allows you to see the direction that a luminaire is aimed.  To use this
tool, go to Radiance→ Luminaires→ Show Luminaire Aiming.  Select a luminaire as
prompted by the command line.  A red arrow will appear that shows the direction
that the luminaire is pointing.  To change the luminaire aiming, use the standard
object rotation commands of the Graphic Editor.

In AutoCAD, the best way to aim a luminaire is through a series of rotations about
the Z-Axis of the user coordinate system (UCS).  First rotate your UCS such that the
z-axis is parallel to the axis on which you would like to rotate the luminaire, for
example “UCS, X, 90” will rotate the UCS about the x-axis of the current UCS by 90
degrees.  Then type the “rotate” command and select a point on the surface of the
luminaire.

Show All Luminaires
This function selects all luminaires in your drawing.  To access this function go to
Radiance→ Luminaires→ Show All Luminaires.  All luminaires will become
selected.  This tool can be used in conjunction with “Delete Luminaire” to delete all
the luminaires in your drawing at one time.
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Show Luminaire Properties
This function allows you to view detailed information about a specific luminaire.  If
you would like to "turn off the lights", you can do so by changing the percent
dimming for lumens and watts to 0.  1 means 100% output (no dimming); 0 means
0% output (all dimming).

For more information on how to use the Luminaire Properties dialog box see the
Luminaire Properties dialog box.

New Luminaire
In addition to the predefined Desktop Radiance luminaires, custom luminaires may
be created through the Luminaire Wizard.  Before creating a new luminaire, you
will need to set up your drawing appropriately, create a project directory, and
synchronize your drawing.  To enter the Luminaire Wizard from Desktop Radiance,
go to Radiance →  Luminaires →  New Luminaire.  Then follow the steps to create
your luminaire.

Glazings

Attach glazing
The Glazings Library dialog box shows the database of available glazings that can be
attached to surfaces in your drawing (Figure 5).  The Desktop Radiance Glazing
database is based on glazing data from the program Optics5 which uses data from
the National Fenestration Ratings Council, http://www.nfrc.org.  For more on
Optics5, see http://windows.lbl.gov/Materials/optics5/.

Figure 5.  The Glazings Library Dialog Box

To access the Glazings Library Dialog Box go to Radiance→ Glazings→ Attach
Glazing. The command line prompts you to select the surfaces that the glazing will
be attached to. After selecting surfaces you then press <enter> (no more surfaces to
select) and the Glazings Library Dialog Box will appear.  Scroll through the list and
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select a glazing to attach to the selected window(s) in your drawing.  Next, click the
ATTACH button at the bottom of the Glazings library dialog box. Doing so brings
back the AutoCAD window and associates the glazing to the selected window.
Repeat the process for other windows.  For double paned windows, do not make two
layers of glass.  This will result in incorrect light calculations.

You can sort the database to make it more convenient to find a specific glazing.  You
may sort the glazings library by the common name of the glazing, its manufacturer,
the manufacturer’s product code, the source of the data (the person or company that
entered it into the database), or by the reflectance, transmittance, or thickness.  To
sort the glazings, select the desired property in the drop-down list box next to the
“SORT BY” button.  Then click “SORT BY”.  You can click again to reverse the
sort order.

Alternatively, you may search for a glazing using the FIND function of the Glazings
Library Dialog Box.  Type the name of the glazing or a sequence of characters
matching any other field in the glazing library in the edit box adjacent to the FIND
button.  Click on the “FIND” button and it will find the first occurrence of the
glazing that matches the sequence of characters you have entered.  Click on “FIND”
again to find next occurrence.

Detach Glazing
To detach a glazing from an object click on Radiance→ Glazings→ Detach Glazing.
Then select the object from which you want the glazing detached.  This tool can be
used in conjunction with the “Show all attached glazings” function making it
possible to select and detach all the glazings in a drawing at one time.  To do this go
to Radiance→ Glazings→ Show All Attached Glazing.  When all windows are
selected go to Radiance→ Glazings→ Detach Glazing.  At the prompt it will ask you
to select glazings to detach.  Type the letter P for the previous selection set, all
glazings will be selected and highlighted, then hit <enter>.  All glazings will be
detached from the highlighted, selected set

Show All Attached Glazing
This function selects all objects/surfaces that have a glazing attached to them.  To
use this function go to Radiance→ Glazings→ Show All Attached Glazings.  The
objects with glazings attached will become selected.

Show Glazing Properties
This function allows you to view and edit detailed information about a specific
glazing.

For more on how to use the Glazing Properties dialog box see Glazing Properties.

New Glazing
In addition to the predefined Desktop Radiance glazings, custom glazings may be
created by using the Glazing Wizard.  You will need to have Optics5 installed on
your computer.  If you do not have Optics5 installed, you can download it from here,
http://windows.lbl.gov/materials/optics5/download.htm.
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Furnishings

Place Furnishing
The Furnishings Library dialog box contains the database of available furnishings
that can be placed in your drawing (Figure 6)

Figure 6. The Furnishings Library Dialog Box

Modeling Tip:

It is usually easiest if you
display an axonometric view
of your drawing to position
the furnishing into your
drawing at the correct height.
Use the appropriate
“snapping” method.  Then in
plan view you can move the
furnishing to the correct
horizontal position.

To access the Furnishings Library Dialog Box go to Radiance→ Furnishings→ Place
Furnishing.  Scroll through the list and select a furnishing to place in your drawing.
Next, click the ATTACH button at the bottom of the Furnishing library dialog box.
Doing so brings back the AutoCAD window. Select an insertion point and rotation
angle for the furnishing as indicated by the AutoCAD command prompt.  Repeat the
process for other furnishings.

You can sort the database to make it more convenient to find a specific furnishing.
You may sort the furnishing library by the common name of the furnishing, its
manufacturer, the manufacturer’s product code, or by the source of the data (the
person or company that entered it into the database). To sort the furnishings, select
the desired property in the drop-down list box next to the “SORT BY” button.  Then
click “SORT BY”.  You can click again to reverse the sort order.  You can move,
copy and array these furnishings to create a furnishing plan suitable for the model.

Alternatively you may search for a furnishing using the FIND function of the
Furnishings Library Dialog Box.  Type the name of the furnishing or a sequence of
characters matching any other field in the furnishing library in the edit box adjacent
to the FIND button.  Click on the FIND button and it will find the first occurrence of
the furnishing that matches the sequence of characters you have entered.  Click on
FIND again to find next occurrence.

Delete Furnishing
To delete a furnishing from your drawing, click on Radiance→ Furnishings→ Delete
Furnishing.  Then select the furnishing that you want deleted.  The AutoCAD erase
command also deletes furnishings.
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Show All Furnishings
This function selects all furnishings in your drawing.  To use this function go to
Radiance→ Furnishings→ Show All Furnishings.  This tool can be used in
conjunction with “Delete Furnishing” to delete all furnishings in a drawing at once.

Show Furnishing Properties
This function allows you to view and edit detailed information about a specific
furnishing.

For more on how to use the Furnishing Properties dialog box see Furnishing
Properties.

New Furnishing
New furnishing items can be created and added to the database by using the
Furnishing wizard.
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Analysis
Desktop Radiance is equipped with several tools to allow for accurate lighting
analysis of buildings to fit the needs of the designer.

Define Zone
A zone is an optional component of your model.

Use of a zone is recommended when the size of the room you are simulating is less
than half the size of the entire building model.  The zone is used by Radiance to
adjust certain calculation parameters to ensure an accurate simulation.  A zone would
be useful, for instance, if you want to concentrate on a cubicle in an office building.
Use the Define Zone function to create a 3-dimensional box for the simulation to
focus on.

To define a zone, go to Radiance→ Analysis→ Define Zone.  The Zone Dialog Box
will appear (Figure 7)

Figure 7.  The Zone Dialog Box

Type in a name for the zone being created and select interior or exterior space.  An
interior zone means that simulations will be from an enclosed interior space.  An
exterior zone means the simulation is from the outside.  If no zone is defined, the
default will be an interior zone the size of the scene bounding cube of the model.

Define Orientation
This function allows you to define the direction of the north arrow of your model.

To use this tool, go to Radiance→ Analysis→ Define Orientation (Figure 8).

Figure 8.  The Define Orientation dialog box

Enter a name for the North Arrow in the dialog box then click OK to return to the
drawing.  Pick an insertion point and a rotation angle.  The “Define Orientation”
function is best used in the plan view.
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Note: The North Arrow icon may appear too large or too small if the units have not
been set up for your drawing.  For more on how to adjust this see Preferences.

Figure 9.  The AutoCAD North Arrow

Multiple north arrows are possible in one drawing to allow for parametric studies.

The default orientation, if none is defined, is with north pointing up and West to the
right, in plan view.  You can select North arrow for your simulation in the Advanced
Dialog box.

Define camera position
The define camera position function allows you to create and position a new camera.
To use this tool, go to Radiance→ Analysis→ Define Camera Position.  The Camera
Properties Dialog Box then appears (Figure 10).

Note: ELEVATION is defined by AutoCAD as “The default Z value above or below
the XY plane of the current user coordinate system… ”, and CURRENT
ELEVATION is “the Z value that is used whenever a 3D point is exptect but only X
and Y values are supplied.”

 
Figure 10.  The Camera Properties Dialog Box and the camera icon

Enter a name for the camera and set its height.  Check the “Height is relative to
current elevation” box if you would like the camera’s height to be incremented by
the current ACAD system “elevation” setting.  Then set the lens length.  The lens
length determines how long the zoom lens is.  Smaller numbers make the lens shorter
and therefore give a wider, farther away view.  Conversely, larger numbers make the
lens longer and will therefore give a narrower, closer view.  After clicking OK you
are brought back to the Graphic Editor window and prompted to give an insertion
point, a rotation angle, and the height above the insertion point for the origin of the
camera’s view.  If you enter a camera name that has already been used in the project,
scenarios which use this camera will be changed to the new view parameters.  The
camera icon will then appear in your drawing at the insertion point.  If the icon is
either too small or too large, this can be adjusted in the preferences dialog box which
can be accessed through the Radiance pulldown menu.  For more on this, see
Preferences.
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To change the view of a camera first type view↵  r↵  and then type the name of the
camera↵ .  The view of the camera will then appear with an outline representing the
camera lens.  Type dview↵ .  Several commands will appear at the command prompt
that allow you to adjust your viewpoint in different ways.  Consult the AutoCAD
help section for detailed information on using these commands.  Typically the Target
and Zoom commands are very useful.  Zoom allows you to zoom forwards and back.
Target allows you to move your viewpoint target in all directions.  Using these tools
is difficult because your wireframe scene disappears while you make adjustments.
After editing your camera view, hit enter at the dview prompt.  Your new view will
appear in wireframe.  If you are satisfied with the view, you must save it with the
ddview command.  If you are unsatisfied with the new view you must return to the
original view you started editing and then begin using the dview commands again.
Once you are satisfied with the new view, type ddview↵ , to save the new view.
Click on New and then enter the same name as the camera view that you were
originally editing.  Entering the same name will allow you to select the original
camera icon when starting a simulation, but with the updated view.  Entering a new
name will mean that you have to select the view name in the camera simulation setup
dialog box because there won't be a picture of a camera representing your new view.

In addition to the camera views represented by camera icons, you can also render the
“current view”.

The camera view can also be changed more easily and quickly in the winrview
program when you start a simulation.  This is useful for checking your geometry or
to find an ideal view.  Custom views can be saved for later use as described in the
File→ Append View to rif file and File →  Append View to view file sections of the
Interactive Rendering chapter.

Define Animation Path
Calculation of an Animation Path is not yet available on version 2.0 BETA of
Desktop Radiance.  However, you can set up camera paths that will create individual
cameras for single frame renderings.  The animation path is created as a polyline
(pline) and smoothed (splined) automatically after you right-click the mouse to
terminate.  Each click on the screen is equal to a vertex of the pline, not a camera
position, so the number of clicks can be different than the number of cameras you
want for the scene.

Figure 11.  The Animation Path Properties Dialog Box and an animation path

Define Reference Point
Use the Define Reference Point function to place a light sensor at one specific point
(Figure 12).  The sensor is used to measure illuminance which is how much light is
reaching that point from all directions.  To use this tool, go to
Radiance→ Analysis→ Define Reference Point.  You are then prompted to enter a
name for the reference point (which needs to be unique in the drawing) and a height.
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You should be aware of your drawing's current elevation and enter a height that is
appropriate.

Figure 12.  The Reference Point Properties dialog box

After clicking OK, you will return to the drawing and be ready to place the sensor
reference point (Figure 13).

Figure 13.  A Reference Point Sensor

Define Reference Grid
Use Define Reference Grid to create a plane within the model where illuminance
values can be measured.  To define a reference grid go to
Radiance→ Analysis→ Define Reference Grid (Figure 14).

Figure 14.  Grid Properties Dialog Box

Enter a name for the reference grid and the number of columns and rows for the
illuminance grid, then click OK to return to your drawing.  Then click in your
drawing to select the opposing corners of the grid.  If you are in a perspective view
when defining the corners of the grid, the box being defined will not appear to fit the
plane in perspective until after you have selected both corners.

The reference grid can be moved to the correct height and position by using standard
graphic editor commands if necessary.

Note:  Reference points and grids should be positioned above any occluding
surfaces.  This means that the height of the points and grids should be a fraction of a
unit larger than the surface’s height.
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Figure 15.  A Reference Grid of Sensors

Vertical and slopped grids are possible by changing the UCS of the drawing before
inserting, or by rotating the grids after inserting (Figure 16).  For more information
on how to change the UCS in your drawing, please consult the AutoCAD Command
Reference.

Figure 16.  Example of sloped and vertical reference grids

Show All Analysis
This command will highlight all the cameras, reference points and grids, and
animation paths in your scene.
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Simulation
The simulation process can begin when all the Radiance attachments and settings are
ready to create a picture or calculate a point or grid quantity of your model.  This
process begins by selecting a camera, reference point, or reference grid to simulate.
Then the scenario or simulation needs to be named and you choose the location, date,
and time that the scenario should portray.  These parameters then become part of a
single scenario.

When a simulation is done, it can be viewed first in the Interactive
Rendering(rview) and then in the Image Analyzer.

Camera
This function allows you to begin a Radiance simulation of your drawing.

To access the Camera Simulation dialog box, go to Radiance→ Simulation→ Camera
(Figure 17).

Figure 17.  Camera Simulation Dialog Box.

Here you can select to either render the current view (whatever you see in the ACAD
screen, this could mean looking through a camera, at an axonometic view, at a plan
view… ) or to select a camera in your drawing.  If you chose to select a camera, use
either the drag down menu to locate the name of your camera or click on the < button
to return to the drawing to manually select a camera.

Here you can also specify what geometry to export.  If you want to export all entities
in the current drawing, select the first option.  If you want to manually select the
geometry, click the second radio button and then the < button to return ot the ACAD
screen.

After entering a name and clicking OK, the command line prompts you to “select
objects”.  These will be the objects included in the simulation.  If you want all
objects included, type “all”.  Otherwise, select in your drawing the objects to include
and press enter.  For more on defining scenarios see Define Scenario.

In some cases a dialog box with the heading Define Project may appear.  For
information on this see Project Folder.

The computer will then synchronize the database and the Camera Simulation Setup
Dialog Box will appear (Figure 18).  Synchronizing can sometimes take several
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minutes to complete for large models as the selected library items are copied to your
project directory.  For more on simulating your model see Simulation Manager.

Figure 18.  The Camera Simulation Setup Dialog Box.

Reference Point

Figure 19.  The Reference Point Simulation Dialog Box

This tool runs a simulation of a light sensor (reference point) in your model.  It
produces an illuminance value at the sensor for the scenario you have defined.  To
use this tool, go to RadianceàSimulationàReference Point.

To place a sensor see Define Reference Point.
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Reference Grid

Figure 20.  The Reference Point Grid

This tool runs a simulation of a grid of light sensors in your model.  It produces an
array of illuminance values for the sensors in the scenario you have defined.  To use
this tool go to RadianceàSimulationàReference Grid.

To define a reference grid see Define Reference Grid.

Project

Project Folder

Figure 21.  The Project Database Conflict Dialog box

Synchronize Project
More text go here.
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Duplicate Project
More text go here.

Tools
The Radiance tools menu items consist of utilities that assist in the management of
your drawing model  and the corresponding Radiance project files.

Show All Attachments
This function highlights and selects all luminaires, furnishings, and surfaces with
materials or glazings attached to them.  To access this tool go to
Radiance→ Tools→ Show All Attachments.  All Radiance attachments will become
highlighted.  The AutoCAD “previous” command can be used within a subsequent
command to act upon these objects.  .

Show All Unattached
This function selects and highlights all the objects and surfaces in the drawing that
do not have a material or glazing attached to them.  To use this tool go to
Radiance→ Tools→ Show All Unattached.  Objects and surfaces without Radiance
attachments will become highlighted.  The AutoCAD “previous” command can be
used within a subsequent command to act upon these objects.

Show Properties
This function allows you to view specific properties of Radiance elements including
Furnishings, Materials, Glazings, and Luminaires, reference points, grids, cameras,
and arrows.

To access this function, go to Radiance→ Tools→ Show Properties.  Then select a
material, glazing, furnishing, or luminaire in your drawing.

Material Properties
To access the Material Properties dialog box (Figure 22) go to
Radiance→ Tools→ Show Properties and then select a material in your drawing.
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Figure 22.  The Material Properties Dialog Box.

When attaching a new material, the Material Properties dialog can also be accessed
by clicking on the PROPERTIES button at the bottom of the Materials Library
dialog box.

You can change certain properties (comments) of a material in the Material
Properties dialog box.  This is done by adding inputs and clicking apply.

To create new materials you can go through either the Material Properties Dialog
Box or through the Library Browser (see Library Manager).

Furnishing Properties
To access the Furnishing Properties dialog box (Figure 23) go to
Radiance→ Tools→ Show Properties and then select a furnishing in your drawing.
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Figure 23.  The Furnishing Properties Dialog Box.

The Furnishing Properties dialog can be accessed from the Furnishings Library
dialog box when placing a new furnishing or from the Library Browser. In the
Furnishings Library dialog box highlight a furnishing and click on the PROPERTIES
button.

Glazing Properties
To access the Glazing Properties dialog box (Figure 24) go to
Radiance→ Tools→ Show Properties and then select a glazing in your drawing.
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Figure 24.  The Glazing Properties Dialog Box.

The Glazing Properties dialog can be accessed from the Glazing Library dialog box
when placing a new glazing. In the Glazing Library dialog box, select a glazing and
click on the PROPERTIES button at the bottom of the Glazing Library dialog box.

The Simulation Control check box allows you to turn on and off the window "as a
light source".  If the box is checked, the mkillum command will be executed when a
simulation (rad, rpict or rview) begins.  Mkillum calculates the distribution of light
from windows or skylights, taking into account external obstructions and inter-
reflections.  If the box is unchecked, mkillum will not run when the simulation,
interactive or batch, is started, and the simulation will have to calculate (trace rays to
the outside) the contribution itself.  For more information on this subject, see
mkillum in the Radiance Reference Manual,
http://radsite.lbl.gov/radiance/man_html/mkillum.1.html.

You can change certain properties (comments) of a glazing in the Glazing Properties
dialog box.  This is done by adding inputs and clicking apply.

Luminaire Properties
To access the Luminaire Properties dialog box (Figure 25) go to
Radiance→ Tools→ Show Properties and then select a luminaire in your drawing.
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Figure 25.  The Luminaire Properties Dialog Box.

When placing a new luminaire, the Luminaire Properties dialog can be accessed by
clicking on the PROPERTIES button at the bottom of the Luminaire Library dialog
box.

Detach All
This function detaches all materials, glazings, furnishings, and luminaires from
objects and surfaces in the model.

To use this tool go to Radiance→ Tools→ Detach All.  All objects with Radiance
attachments will be selected automatically and a window appears to confirm that you
want to detach all Radiance materials and glazings.  This restores your drawing to
the state it was in before the use of any Desktop Radiance commands.

Note:  Detach all should be used with caution.  Save your drawing and/or make a
backup drawing before using this command because all of your work may be lost.
Detach all is sometimes useful to debug problems you may be having with your
drawing.

Adjust Surface Normals
This command is used to check and adjust the orientation of surfaces in your model.
In general, the orientation of surfaces is not important for Radiance as it is with other
lighting analysis tools.  However, to calculate the distribution of daylight with
glazings to be treated as a “light source”, it is necessary to have the glazing surface
correctly oriented.  Material surfaces do not need correct surface normal orientation.
To use this function, go to Radiance→ Tools→ Adjust Surface Normals.  Then, as
you are prompted, select the glazing surface in your drawing.  A red arrow will
appear within the window (Figure 26).
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Figure 26.  A surface with the Adjust Surface Normal arrow showing orientation

A correctly oriented surface normal for a window or skylight should be pointing in
the direction of daylight travel from brightest to dimmest regions.  The command
line asks you if you want to flip the surface normal.  Type “N” if the arrow is
pointing in the correct direction and “Y” if you want to switch it.  If the direction of
the surface normal is not as you expected and cannot be reversed with this tool, then
the window surface needs to be recreated.  Certain ACAD entities, ie region and
body, have surface normals that are intrinsic to the object itself and therefore cannot
be altered with this tool.  Those need to be recreated if they are to be correctly
oriented as glazing surfaces.

If the red surface normal arrow does not appear it may be that you are checking an
object that Desktop Radiance can't figure the front or back of, for example an
exploded ACIS solid.  The surfaces of an exploded ACIS solid will have normals
pointing outwards.    If the surface normal you are checking is not that of a surface of
an exploded ACIS object and you don't see the red surface normal arrow, see
Preferences.

If you would like to create your glazing surfaces with the proper orientation when
you first draw them, use the Right Hand Rule..  Imagine placing your right hand
against the wall with the window, with your thumb pointing in the direction that the
light travels.  Your four fingers now curl in the direction that the vertices should be
created to obtain a properly oriented surface.

Material Map
The Material Map function associates a surface with a specific layer or line color in
your graphic editor program or the specified Desktop Radiance material.  To use the
material map tool go to Radiance→ Tools→ Material Map and then the Material Map
dialog box will appear (Figure 27).

Figure 27.  The Material Map Dialog Box
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To attach a material to all surfaces in a particular layer, click on ADD LAYER.  The
Material Layer Assignment Dialog Box will appear (Figure 28).

Figure 28.  The Material Layer Assignment Dialog Box

Click on layer name→ BROWSE to select a layer, from the Current Drawing Layers
Dialog  Box (Figure 29) that the material will be associated with.

Figure 29.  The Current Drawing Layers Dialog Box

Then click on material→ BROWSE and select a material to be associated with the
layer.

To attach a material to all surfaces with a particular color, go to
RadianceàToolsàMaterial Map to get to the Material Map Dialog Box (Figure 27).
Click on ADD COLOR.

Figure 30.  The Material Color Assignment Dialog Box

In the Material Color Assignment Dialog Box that will appear next (Figure 28),
enter either the color number or click on color number→ BROWSE to find the
correct color.  After finding a color click on material→ BROWSE to find the material
to be associated with the color.

After associating a layer or color with a material through the Material Map tool, new
objects created in that layer or color are not automatically associated with the
material.  The layer or color must be re-associated with the material for all new
objects of that layer or color to be included.
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NOTE:  As of Version 1.02, the only name allowed for saving a map file is
savemap.lcm.  Any unique name you input will be ignored and the default
savemap.lcm name used.

Library Manager
This tool allows you to easily keep track of all available Radiance libraries, these
include Furnishings, Glazings, Materials, and Luminaires (see Library Manager).

Future Plans for the Library Manager:

The Library Manager is still rapidly changing and developing.

Material Editor
This tool allows you to edit existing materials and create new materials altogether.
For information on using the Material Editor see Material Editor.

Simulation Manager
The simulation manager keeps track of your simulation scenarios.  This menu item
allows you to launch “SimMan” (Figure 31) without starting a simulation.

Figure 31.  The simulation Manager window

For more information on using this tool (see Simulation Manager).

Image Analyzer
The Image Analyzer allows you to further analyze the lighting performance of your
model.  For more information (see Image Analyzer).

Preferences
The General Preferences Dialog Box (Figure 32) is used to set the units (metric or
imperial), unit size (meters, inches, etc.) of a drawing, and drawing “scale” for
appropriate sizing of the Desktop Radiance library items.  To use this tool go to
RadianceàPreferences.  There is an important relationship between the settings here
and the units format of your graphic editor program.  The most important
relationship is that if the units display in your graphic editor are “Architectural”, then
you will want to choose “Imperial” and “Inches” in the Desktop Radiance General
Preferences Dialog Box.  See the note on Setting Up A Drawing for more
explanation.
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Figure 32.  General Preferences Dialog Box

Sometimes when attaching or inserting a Radiance entity into your drawing, it will
appear much smaller or much larger than you want it to be.  This includes objects
such as cameras, north arrows, Reference Points, Reference Grids, and surface
normal arrows.  To fix this problem use the General Preferences tab dialog box.
Before attaching the Radiance entity into your drawing, change the Drawing Scale
value.  To make an object larger, make the symbol scale value larger.  To make an
object smaller, make the symbol scale value smaller.  For example, changing the
value from 1 to 10 would make the object ten times as big as before.  Whereas, to
make an object smaller, changing the value from 1 to 0.1 would make the object one
tenth as big as it was before.  After changing the symbol scale value, then attach or
insert the Radiance entity to your drawing.

Note:  One way to understand the use of the drawing scale is to imagine the actual
size of the photosensor (in real life) in relation to the size of its surrounding objects.
If a 2"x2"x1" photosensor is put on top of a table in real life, the objects will both be
visible.  The photosensor will seem of the right scale relative to the table in this case
if the drawing scale ratio is 1:1.

Likewise, if a 2"x2"x1" photosensor is placed on a big object in real life, for example
in the middle of the Golden Gate Bridge (1.7 miles long), you will have a hard time
seeing the photosensor unless you are standing very close to it at 1:1.  If you want to
see the photosensor and the whole bridge at the same time, the drawing scale needs
to be changed to 1:bigger number because the size of the photosensor needs to be
made bigger relative to the bridge.

The Desktop Radiance Export Preferences Dialog (Figure 33) determines which
entity types will be exported from your graphic editor for the simulation.
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Figure 33.  The Export Preferences Dialog Box

The layer options allow you to modify which entities of your drawing will be
included in the simulation.  They refer to the various layer settings in your Graphic
Editor program.  The Geometry option determines whether you want all geometry to
be exported automatically for simulations or if you want to select particular
Geometry yourself.  Closed or Extruded 2D Geometry and 3D Geometry refer to
types of geometry that can be included in simulations.
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Library Manager

Introduction
The Library Manager is a collection of tools related to the maintenance of the
Desktop Radiance Material, Luminaire, Glazing, and Furnishing libraries.  This
Library Browser allows you to view detailed information about Radiance
Furnishings, Glazings, Luminaires, and Materials.  The Editor and wizards allows
you to create new Desktop Radiance materials, glazings, luminaires and furnishings.

All items added to the libraries are accessible to any user of Desktop Radiance or
users who share the same main database.

To reach the Library Browser from inside the Graphic Editor, go to Radiance →
Tools →  Library Manager.  Select the appropriate tab for Furnishings, Glazings,
Luminaires, or Materials.

The current state of the Library Browser does not include all future functionality.
Future version will have the ability to edit specific library items and to move items
betweendifferent installations of Desktop Radiance.

Material Library Browser
The Material Library Browser (figure 1) allows you to view all of the available
materials and their properties.  You can browse for items in the Material Library by
scrolling through the list.  When an item has been highlighted the properties can be
viewed by clicking the PROPERTIES button. You can search the material library by
keyword using the “Find” button.  Type the common name or a fragment of the
common name in the white box next to the FIND button.  Then click on the FIND
button.  It will find the first occurrence of the item.  Click on FIND again to find the
next occurrence. You can sort the displayed items alphabetically by clicking on the
heading name for each column of the table.
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Figure 34.  The Material Library Browser

Material Editor
In addition to the predefined Desktop Radiance materials, custom materials may be
created in the Material Editor.  Currently only reflective materials can be created.  It
is also not yet possible to “edit” existing materials in the library.  To enter the
Material Editor (figure 1) from Desktop Radiance, go to Radiance →  Materials →
New Material (figure 2)  Material Editor may also be opened by choosing its icon
(created by the install program) from the Start Menu in the Desktop Radiance
directory..  From in the Material Library Browser, click on the NEW button and
enter a new material name when prompted.  For every custom material that you
create, the Material Editor needs to know the Material Type, Red, Green, and Blue
values and Specularity and Roughness values.  You may optionally specify
information about the manufacturer of this material from the “manufacturer” button.
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Figure 35.  Material Editor

Material Type
To set material type, use the pull down menu located below the Material Name field.
Currently only plastic and metal may be created.  Plastic materials include all opaque
materials that have colored diffuse reflections but uncolored specular (shiny)
components.  Plastic materials include formica, tile, glossy paint, and any similar
surfaces.  Materials that have colored specular highlights are appropriately modeled
as “metal”.  Metal materials include bronze, gold, copper, aluminum, and similar
surfaces.  (More on this in Physical Properties)

Manufacturer
Next, if applicable, click on the MANUFACTURER button to bring up the
Manufacturer Contact Information Dialog box (figure 3).  This information is
optional.  To save manufacturer information and return to Material Editor, click on
APPLY.  You man specify a new manufacturer by selecting “NEW” from the pop-up
list of manufacturers.

Figure 36.  Manufacturer Contact Information dialog box

Color
The range of values for Red, Green, and Blue is generally between zero and one,
with 0.0 being the perfect absorber (black) and 1.0 being the perfect reflector
(white).  Radiance RGB values are not comparable to other RGB formats because
the Radiance RGB values specify both the color and the reflectance.  The RGB may
be thought of as a three-point sample of the radiometric spectral content of the
material.  While it is physically possible to have one of the components greater than
one (such as fluorescent materials) the reflective average should not be allowed to
exceed 1.0.  (see Physical Properties, below).  Click the “Pick Color” button to
display the standard windows color palette (figure 4).  Click “Define Custom Colors”
to display the HSV color picker.  This standard color picker may be used to
approximate the color of your surface.  Click “add” to add this color to your palette.
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Select this color on the left-hand side of the color picker and then click OK.  The
RGB and average reflectance of the color you have created will then be displayed.  If
the average reflectance is incorrect, the value may be changed and the resulting RGB
values will be updated.

Figure 37.  Color Picker

Physical Properties
The Average Reflectance displays the total, hemispherical average photopic
reflectance.  A plastic (figure 5) or metal (figure 6) “swatch” will appear, depending
on the selected Material Type, to help you find the desired specularity and roughness
combination.  The reasonable range for specularity is between zero and .07, with 0.0
being a matte surface and .07 being satin (shiny).  For roughness, the reasonable
range is between 0.0 and 0.2, with 0.0 being polished and 0.2 a low gloss.  Both of
these parameters may be selected from the “Pick” button adjacent to the Specularity
and Roughness values.  Select the sphere which most closely resembles your
material and click Ok.  The selected Specularity and Roughness values will be
displayed in the Material Editor dialog box.

Figure 38.  Plastic specularity and roughness samples
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Figure 39.  Metal specularity and roughness samples

After the Red, Green, Blue, Specularity, and Roughness of the new material is
defined, click on the UPDATE BITMAP button to begin creating the bitmap.  The
Editor will render the image in the background and display it when finished (figure
7).  This usually takes less than one minute.
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Figure 40.  A new material type displayed

You may display two bitmaps at once to compare them side by side.  The newer
material will appear in the lower window.  Either one may be selected to display its
properties.  When you are satisfied with the new material, click APPLY to save the
selected material into the database.

Note:  The Library Manager window may need to be closed (for the bitmaps to
refresh) before the new material will be visible.

Glazing Library Browser
The Glazing Library Browser (figure 8) allows you to view all the available glazings
and their properties.  You can browse for glazings in the Glazing Library by scrolling
through the list.  When an item has been highlighted the properties can be viewed by
clicking the PROPERTIES button. You can search the glazing library by keyword
using the “Find” button.  Type the common name or a fragment of the common
name in the white box next to the FIND button.  Then click on the FIND button.  It
will find the first occurrence of the item.  Click on FIND again to find the next
occurrence. You can sort the displayed items alphabetically by clicking on the
heading name for each column of the table.
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Figure 41.  The Glazing Library Browser

Glazing Editor (Glazing Wizard)
In addition to the predefined Desktop Radiance glazings, you can create custom
glazings using the Glazing Wizard.  The Glazing Wizard guides you through the
steps necessary to create a new glazing and add it to the Glazing Library.  The
wizard relies upon the Lawrence Berkeley National Laboratory program called
Optics5 included with this version of Desktop Radiance.  Optics 5 (figure 10), uses
optical data from the National Fenestration Rating Council (NFRC) spectral data
library and allows you to create a Radiance description of a multi-layered glazing
assembly. To enter the Glazing Editor from Desktop Radiance, go to Radiance →
Glazings →  New Glazing.  Or select the Glazings tab of the Library Manager and
click NEW. At this point you will see the "Welcome to the Desktop Radiance
Glazing Wizard" screen (figure 9).

Figure 42 The "Welcome to the Desktop Radiance Glazing Wizard" screen.

"Welcome to the Desktop Radiance Glazing Wizard"

If you have already completed the modeling of your glazing with Optics5 and have
saved it as a Radiance glazing file, you can click on the "next" button in the Glazing
Wizard welcome page (the page currently open), and you will be lead to the “Select
the drawing and project folder” screen.  Otherwise, select the checkbox to be given
assistance on how to work with the Optics5 program to model the glazing you need,
beginning from “How to model a glazing and prepare it for the Desktop Radiance
Library”.

"How to model a glazing and prepare it for the Desktop Radiance Library"

The Wizard has started the Optics5 program and should now be running as a separate
application.  Check your taskbar if it does not immediately appear.  .
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Figure 43 Initial Optics 5 screen

Overview of the Optics5 User Interface

Optics5 has four main regions that allow you to model and analyze a glazing
assembly.   The upper left region shows a tabular representation of the layers of glass
that comprise your glazing assembly.  Each column represents a separate piece of
glass and is labeled at the top with #1, #2, etc.. Adjacent to these numbered columns
is a region labeled "Glz. Sys." That shows the spectral properties of the entire glazing
system (all glass layers combined).  When you first launch Optics5, the upper right
region (as seen in Figure 43) shows a tabular view of the glass products database,
one row for each possible manufacturer's product.  The lower region shows the
spectral properties of the selected layer or system on the left and a plot of the spectral
transmittance and reflectance (front and back) of the selected layer or glazing
system.  A glazing layer is selected by clicking on the corresponding column heading
(#1, #2, etc., or "Glz. Sys.").

Figure 44. Optics 5 Screen with a selected glazing

• After double-clicking and highlighting a particular glazing, the table in the upper
left corner of the Optics window will show each glazing layer from outside (left)
to inside (right).  Glazing layer #1 is the outermost layer.

• Select a particular layer to edit by clicking in the "Glazing ID" column heading
(figure 11).
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• Select the specific manufacturer's product to view its properties in the lower
region of the dialog.   Double-click on a glazing product to assign the specific
glass product to the selected layer.

• Repeat this process for the subsequent layers of your glazing assembly, if any.

• Use "File →  Create Radiance file..." to save the glazing as a Radiance input file
with a .RAD extension.  Select a convenient directory to save this file so you
can refer to it in a later wizard screen.  When the glazing file is saved, click
"Next" to continue to the next glazing wizard screen.

If you need more help with Optics5, please refer to the Optics5 help menu.

"Select the drawing and project folder"

At this point we assume that you have already modeled the new glazing and have the
Optics5 Radiance file ready.  If not, please click the "back" button to be guided
through this process (see above).

Figure 45.  The "Select the Drawing and Project Folder" screen.

• In the box next to “Glazing Name”, specify the glazing .RAD file name, or click
"Browse… " to search for it using the standard open file dialog box (figure 12).

"Describe new glazing"

• The glazing manufacturer, model name or number, and item description will
help you identify this glazing item in the library browser.  If the manufacturer
name is not included in the list, you can click the "New Manufacturer..." button
to define a new manufacturer name.

• Provide the information specified and click "Next" to continue (figure 13).

Figure 46.  The "Describe New Glazing" screen.

"New Glazing Preview"
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Click the preview button on the New Glazing Preview screen (figure 14) to inspect
your new glazing item before committing it to the library, and to create a preview
image for the browser.  To create the preview image, use the File →  Save as...
command of Winrview to save the image.  The default name oct_V1.pic needs to
be changed to reflect the actual name of your item (Figure 47) and (Figure 48)  .
In this example, the drawing name is testglzwiz1 so the image name has to be
testglzwiz1.pic.

Figure 47.  The Save Picture Dialog box of the Glazing Wizard with default file name

Figure 48.  The Save Picture Dialog box of the Glazing Wizard with correct file name
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Figure 49.  The "New Glazing Preview" screen.

You are now ready to make this glazing a permanent part of your database.  Click
"Finished" when you are ready to commit this item to the library.

Note:  The Library Manager window may need to be closed (for the bitmaps to
refresh) before the new glazing will be visible.

You have now successfully completed the creation of a new glazing item for
Desktop Radiance.  You can return to the library browser to view your custom
glazing item, or you can return to AutoCAD to attach it to the appropriate surface(s)
of your model.

NOTE:  If the spectral data library is out of date, updates are available from the
NFRC's Spectral Data Library webpage, http://www.nfrc.org/sdl.html/ .  After
downloading, extract contents into a convenient temporary directory.

Then in Optics5, use the "File →  Add files to User Database… command to select the
spectra data file(s) to be merged with the User Database.  Please see the Optics5 on-
line user manual for more information.  Updates for Optics5 are available from
http://windows.lbl.gov/materials/optics5/  .

Furnishing Library Browser
The Furnishing Library Browser allows you to view all available furnishings and
their properties.  The Furnishing Library Browser (figure 15) allows you to view all
the available furnishings and their properties.  You can browse for items in the
Furnishing Library by scrolling through the list.  When an item has been highlighted
the properties can be viewed by clicking the PROPERTIES button.  You can search
the furnishing library by keyword using the “Find” button.  Type the common name
or a fragment of the common name in the white box next to the FIND button.  Then
click on the FIND button.  It will find the first occurrence of the item.  Click on
FIND again to find the next occurrence.  You can sort the displayed items
alphabetically by clicking on the heading name for each column of the table.
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Figure 50.  The Furnishing Library Browser

Furnishing Editor (Furnishing Wizard)
In addition to the predefined Desktop Radiance furnishings, custom furnishings may
be created in the Furnishing Editor, through the Furnishing Wizard.  To enter the
Furnishing Editor from Desktop Radiance, go to Radiance →  Furnishings →  New
Furnishing.  Or select the Furnishings tab of the Library Manager to bring the
Furnishings Library to the foreground. At this point you will see the“Welcome to the
Desktop Radiance Furnishing Wizard” screen (figure 16.

"Welcome to the Desktop Radiance Furnishing Wizard"

Figure 51.  The "Welcome to the Desktop Radiance Furnishing Wizard" Screen.

This wizard will guide you through the process of creating a new furnishing item to
be added to the Desktop Radiance Furnishing Library.  Creating your new furnishing
begins by modeling your item in AutoCAD.  If you have completed the modeling of
your item, click the "next" button, and you will be lead to the “Select the drawing
and project folder” screen.  Otherwise, select the checkbox to be given assistance on
how to set up your drawing, beginning from “How to model a furnishing and prepare
it for the Desktop Radiance Library”.

"How to model a furnishing and prepare it for the Desktop Radiance Library "

• Launch Desktop Radiance and set the appropriate units for the drawing by
selecting Radiance →  Preferences…   Be sure that you model the furnishing with
a scale factor of 1.0.  In other words, one meter in your drawing represents one
meter in "real life".

• Next, model the geometry of the item using standard modeling techniques.
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• Attach the appropriate materials to the surfaces of your furnishing.  NOTE:  Do
not attach any other furnishing, glazing, or luminaire items.  They are ignored.

• When the furnishing model is complete, click "Next" to continue.

"Synchronize the drawing with a temporary project folder"

You are now ready to convert the contents of your drawing into Radiance format.

• To define a temporary project folder where the Radiance geometry for the
furnishing will be stored, use the Radiance →  Project →  Project Folder...
command.  A dialog box called "Open Project" will appear telling you that  "An
existing project directory is associated with this drawing.  Do you want to use
the existing directory, start over from scratch (overwriting the old project
information), or locate another project directory (new)?"  Select "New".

• A standard browse dialog box will appear.  Browse to a convenient directory,
then type the name of a temporary project directory in the "open" edit box.

• A dialog box called "Define Scenario" will appear.  Provide a name such as
"temp".

• Start the synchronize process with the Radiance →  Project →  Synchronize
command.  You will need to select the specific graphic entities that you want to
be part of your furnishing. If the furnishing includes everything, then type "all".
Press "Enter" two times to start synchronizing.  Very complex drawings may
take several minutes to complete.

• When the synchronization process is complete, click "Next" to continue.

"Select the drawing and project folder"

At this point you should have already modeled the new furnishing item and
synchronized your drawing.  If the drawing is not ready, please click the "back"
button to be guided through this process (see above).

Figure 52.  The "Select Drawing and Project Folder" screen.

• Specify the AutoCAD drawing name of the new furniture and project folder
(figure 17).

"Describe new furnishing"
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Figure 53.  The "Describe New Furnishing" screen.

• The furnishing manufacturer, model name or number, and item description will
help you identify this furnishing item in the library browser.  If the manufacturer
name is not in the list, you can click the "New Manufacturer..." button to define
a new manufacturer name.

• Provide the information specified and click "Next" to continue (figure 18).

"Specifying the drawing units"

Desktop Radiance needs to know the units (meters/inches) used for the furnishing so
that it is properly scaled when it is inserted into a new drawing.  You may have
previously specified the units in the Radiance →  Preferences... dialog box.

"New Furnishing Preview"

Click the preview button (figure 19) to start Winrview and to inspect/preview your
new furnishing item before committing it to the library.  To create the preview
image, use the File →  Save as... command of Winrview to save the image.  The
default name oct_V1.pic needs to be changed to reflect the actual name of your
item (Figure 54) and (Figure 55)  .  In this example, the drawing name is testfrnwiz1
so the image name has to be testfrnwiz1.pic.

Figure 54.  The Save Picture Dialog box of the Furnishing Wizard with default file name
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Figure 55.  The Save Picture Dialog box of the Furnishing Wizard with correct file name

Figure 56.  The "New Furnishing Preview" screen.

You are now ready to make this furnishing a permanent part of your database.  Click
"Finished" when you are ready to commit this item to the library.

Note:  The Library Manager window may need to be closed (for the bitmaps to
refresh) before the new furnishing will be visible.

You have now successfully completed the creation of a new furnishing item for
Desktop Radiance.

Luminaire Library Browser
The Luminaire Library Browser (figure 20) allows you to view all of the available
luminaires and their properties.  You can browse for items in the Luminaire Library
by scrolling through the list.  When an item has been highlighted the properties can
be viewed by clicking the PROPERTIES button. You can search the furnishing
library by keyword by using the “Find” button.  Type the common name or a
fragment of the common name in the white box next to the FIND button.  Then click
on the FIND button.  It will find the first occurrence of the item.  Click on FIND
again to find the next occurrence. You can sort the displayed items alphabetically by
clicking on the heading name for each column of the table.
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Figure 57.  The Luminaire Library Browser.

Luminaire Editor (Luminaire Wizard)
In addition to the predefined Desktop Radiance luminaires, custom luminaires may
be created in the Luminaires Editor, through the Luminaire Wizard (figure 21).  It is
not yet possible to “edit” existing luminaires in the library.  To enter the Luminaire
Editor from Desktop Radiance, go to Radiance →  Luminaires →  New Luminaire.
Or select the Luminaires tab of the Library Manager to bring the Luminaires Library
to the foreground.  At this point you will see the“Welcome to the Desktop Radiance
Luminaire Wizard” Screen.Wizard welcome screen will appear.

Figure 58.  The "Welcome to the Desktop Radiance Luminaire Wizard" screen.

"Welcome to the Desktop Radiance Luminaire Wizard"

This wizard will guide you through the process of creating a new luminaire item and
adding it to the Desktop Radiance Luminaire Library.  Creating your new luminaire
begins by modeling your item in AutoCAD.  If you have completed the modeling of
your item, you can click the "next" button, and go to the “Select the drawing and
project folder” screen.  Otherwise, select the checkbox to be given assistance on how
to set up your drawing, beginning from “How to model a luminaire and prepare it for
the Desktop Radiance Library”.

"How to model a luminaire and prepare it for the Desktop Radiance Library"

• Launch Desktop Radiance and set the appropriate units for the drawing by
selecting Radiance →  Preferences...  Be sure that you model the luminaire with
a scale factor of 1.0.  (1 meter in your drawing equals 1 meter in "real life.").

• Next, model the geometry of the item using standard modeling techniques.

• Attach the appropriate materials to the surfaces of your luminaire.  NOTE: Do
not include any luminaires, glazings or luminaires in your drawing.
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• When the luminaire model is complete, click "Next" to continue.

"Define the light-emitting surfaces"

Desktop Radiance Luminaires have two types of light-emitting surfaces that you
must create.  The first is the self-luminous surfaces such as the light source or "bulb",
and the second is the invisible light emitting or "imposter" surfaces.  The imposter
surface is typically a box enclosing the main light-making apparatus of your
luminaire.  For example, a pendant luminaire would have a box around the
suspended part of the fixture, but it does not enclose the suspension cables or other
mounting hardware.  You identify these surfaces by attaching a special material from
the materials library.  These materials are only visible in the library while the
Luminaire Wizard is active.

• Model the self-luminous or "bulb" geometry being careful to pay attention to
surface normal orientation.  Light emits only in the direction of the surface
normal.  Valid surface types include 3DFACES, closed 3DPLINES without
holes, circle with “thickness” for cylindrical and linear sources, sphere, and the
box.

• Attach the material called "Lamp Material" to the self-luminous surfaces.

• Model the imposter surface(s) of your model.  A box is usually the best way to
model this.

• Attach the material called "Luminaire Imposter Geometry” to the imposter in
your model. NOTE: Do NOT attach light-emitting materials to non-light-
emitting surfaces in your new luminaire!  This will cause inaccuracies.

• When the luminaire geometry and material attachments are ready, click "Next."

Note:  The accurate modeling of luminaires requires the accurate characterization of
both the appearance of the luminaire and its effect on its surroundings.  The
“Imposter” surfaces are the way that Radiance knows where to associate the light
distribution specified in the IES Candlepower Distribution file with your luminaire
geometry.  An invisible enclosing surface is required so that the surface geometries
of your luminaire do not block the light and cause unrealistic shadows.

"Synchronize the drawing with a temporary project folder"

You now are ready to convert the contents of your drawing into Radiance format.

• To define a temporary project folder where the Radiance geometry for the
luminaire will be stored, use the Radiance →  Project →  Project Folder...
command.  A dialog box called "Open Project" will appear telling you that  "An
existing project directory is associated with this drawing.  Do you want to use
the existing directory, start over from scratch (overwriting the old project
information), or locate another project directory (new)?"  Select "New".

• A standard browse dialog box will appear.  Click the "New Folder" icon, then
provide a name such as "temp".

• A dialog box called "Define Scenario" will appear.  Provide a name such as
"temp".

• Start the synchronize process with the Radiance →  Project →  Synchronize
command.  You will need to select the specific graphic entities that you want to
be part of your luminaire.  If the luminaire includes everything, then type "all".

• Press "Enter" two times to start synchronizing.  Very complex drawing may take
several minutes to complete.
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• When the synchronization process is complete, click "Next" to continue.

"Select the drawing and project folder"

Figure 59.  The "Select the Drawing and Project Folder" screen.

At this point we assume that you have already modeled the new luminaire item and
synchronized your drawing.  If the drawing is not ready, please click the "back"
button to be guided through this process.

• Please specify the drawing name and project folder (figure 22).

"Describe your new luminaire”

Figure 60.  The "Describe Your New Luminaire" screen.

• The luminaire manufacturer, model name or number, and item description will
help you identify this luminaire item in the library browser.  If the manufacturer
name is not in the list, you can click the "New Manufacturer..." button to define
a new manufacturer name.

• Provide the information specified below, then click "Next" to continue (figure
23).

"Specify the drawing units”

Desktop Radiance needs to know the units (meters/inches) used for the glazing so
that it is properly scaled when inserted into a new drawing.  You may have
previously specified in the Radiance →  Preferences... dialog box.
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"Specify the Luminaire Distribution”

Figure 61.  The "Specify the Luminaire Distribution" Screen.

Desktop Radiance needs to know how the light is distributed from this luminaire.
This information is provided by luminaire manufacturers for most commercial/office
type luminaires.  The candlepower distribution curve for the luminaire is usually
provided in the IESNA format.  Please select the IES file, then click "Next" to
continue (figure 24).

"New Luminaire Preview"

Figure 62.  The "New Luminaire Preview" Screen.

Click the preview button (figure 25) to start Winrview and to inspect/preview your
new luminaire item before committing it to the library.  To create the preview image,
use the File →  Save as... command of Winrview to save the image. The default
name oct_V1.pic needs to be changed to reflect the actual name of your item
(Figure 63) and (Figure 64)  .  In this example, the drawing name is testlumwiz1 so
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the image name has to be testlumwiz1.pic.

Figure 63.  The Save Picture Dialog box of the Luminaire Wizard with default file name

Figure 64.  The Save Picture Dialog box of the Luminaire Wizard with Correct file name

You are now ready to make this luminaire a permanent part of your database.  Click
"Finished" when you are ready to commit this item to the library.

Note:  The Library Manager window may need to be closed (for the bitmaps to
refresh) before the new glazing will be visible.
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Simulation Manager

Introduction
The Simulation Manager is the component of Desktop Radiance in which you
simulate and render the model you have created in the graphic editor.  After
attaching Radiance entities to your drawing (for example: materials, luminaires,
furnishings, glazings, cameras, etc.), you are ready to begin the simulation process.
The simulation process involves the simulation of light interacting with the surfaces
in your model.  These calculations depend on the properties of the Radiance
attachments, location/time and day settings, and accuracy parameters.

The simulation manager dialog box (Figure 76) allows you to keep track of all your
simulations for a project.  Each simulation and its associated properties and settings
is called a “scenario”.  After completing a simulation, the interactive rendering or
Winrview tools allow you to preview your model.  Rview allows for adjustments to
viewpoint location.  The advanced dialog boxes of simulation setup provide a user-
friendly means of adjusting light and shadow specifications, and other parameters
that can create more accurate images, faster rendering images or a combination of
these two factors.  Through the use of the winrview tools and then with the Image
Analyzer, you can create an image that best fits your design needs and objectives.

Camera Simulation
Here is where you can select a specific camera (view) to simulate and select the
entities (geometry).
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Figure 65.  The Camera Simulation Dialog Box

More text to go here.

Reference Point Simulation
Here is where you can select the reference point to simulate and specify the entities
(geometry) for including in the simulation.

Figure 66.  The Reference Point Simulation Dialog Box

More text go here.

Reference Grid Simulation
Here is where you can select the reference grid to simulate and specify the entities
(geometry) for including in the simulation.

Figure 67.  The Reference Grid Simulation Dialog Box

More text to go here.
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Camera Simulation Setup
The Simulation Setup dialog box allows you to define the base parameters for your
simulation scenerio.  Depending on the type of simulation you are performing,
Camera, Reference Point, or Reference Grid, You will see slightly differernt Setup
Screens.

The Camera Simulation Setup dialog box (Figure 68) is accessed by beginning a
simulation.  Go to Radiance→ Simulation→ Camera.

Note:  These following instructions describe the simulation setup process for a new
drawing with a unique filename.  If you have previously started a simulation of a
drawing with the same name, you will get slightly different responses at this step.
See PROJECT FOLDER for more info.

Figure 68.  The Camera Simulation Setup Box

The Scenario Name box tells you the name of this particular scenario.  It is the name
previously entered in the Define Scenario Dialog Box.  The scenario name is
uneditable in the Camera Simulation Setup Box.

The camera name box allows you to choose the camera or view that you would like
for this scenario.  It automatically selects the camera previously selected but others
can be chosen from the pulldown menu.  To create new saved views of your model
in autocad, go to ViewàNamed Views or type ddview.  More information on
ddview may be found in the ACAD help manual.

Note:  Winrview can also be used to create custom views such as plan or .  See ____
for more info.  The dialog box that appears allows you to save the current view as a
saved named view that can be accessed from the Camera Simulation Setup Box for
simulation.

The accuracy box allows you to select the accuracy.  For Version 2.0 BETA, only a
Medium level of accuracy is available.  However, this setting can be overwritten by
changing the parameters under the "Advanced" dialog box.
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The Sky and Weather box allow you to choose the sky conditions for your model.
You can choose from CIE Clear, Overcast, Intermediate, and Uniform.  Clear will
have sharp patches of light and quite a bit of bright diffuse light.  Overcast will have
shadows, dimmer diffuse light, and some light specular highlights. Intermediate has
sharp patches of light but the dim diffuse light of an overcast rendering.  Uniform
will have shadows and dimmer diffuse light than overcast with very faint specular
highlights.  For more information, consult the Illuminating Engineering Society of
North America (IESNA) Lighting Handbook.  .

To render with no sky or to turn the sky off, select a date and time that is at night.

The location box allows you to choose the location for the simulation. There are a
few predefined locations.  You can also define new locations by selecting "New… "
from the pulldown menu.  This will bring you to the Add New Location dialog
box(Figure 71, p. 58).  For more on adding a new location see Add New Location.
The box with three dots next to the Location Box will display the Longitude and
Latitude of the currently selected location.

The date, and time boxes allow you to define such factors for your scenario.

In the Camera Simulation Setup Box  there is also a choice of Luminance or
Illuminance.  The simulation quantity settings determine what kind of information
your image will contain.

Luminance is the amount of light leaving a surface from a specific
direction and includes the final surface reflectance.  It closely resembles
what the eye sees.

Illuminance is the total amount of light reaching a surface from all
directions.  Illuminance does not include the reflectance of the surface
where the illuminance is being measured.  The "illuminance" simulation
quantity setting changes the Radiance computation so that the final surface
reflectance is not included in the determination of the brightness of each
pixel of the image.

The Simulation Mode box gives you choices of interactive or batch.  Interactive
allows you to experiment with exposure, ambient light and other settings in the
interactive rendering program, Winrview.  There is an online table listing the
possible parameters and their effects at
http://radsite.lbl.gov/deskrad/param_table.htm

After determining the custom settings for your building in winrview, DUPLICATE
the scenerio and click on the ADVANCED button on the Camera Simulation Setup
Box to change the custom settings and then start the render using batch mode.  After
the simulation is finished, the image will not automatically appear.  Click on
DISPLAY/ANALYZE in the Simulation Manager to view the image
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Reference Point Calculation Setup

Figure 69.  The Reference Point Calculation Setup Dialog Box

More text here.

Reference Grid Calculation Setup

Figure 70.  The Reference Grid Calculation Setup Dialog Box

More text to go here.
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Add New Location
To add a new location, enter all the requested information, click OK and a new
location is added to the main Desktop Radiance database and can be accessed by
other projects.

Figure 71.  The Add New Location Dialog Box

The "City" field is required to identify your location and therefore must be a unique
name.  The latitude is an angular measurement that defines where your location is
relative to the equator.  The latitude of the equator is equal to 0.  The latitude of the
North and South poles is 90 and –90, respectively. It should be entered in decimal
degrees.  From 0 to 90 is in the northern hemisphere and from 0 to –90 is in the
southern hemisphere.  So, for example, the approximate latitude of Athens, Greece
would be Lat 37.9.  This number means that Athens is 37.9 degrees north of the
equator.

The longitude is an angular measurement that defines your location relative to the
standard meridian in Greenwich, England.  The longitude of the Greenwich Meridian
is equal to zero.  The number you would enter for the longitude of your location is
between –180 and 180.  Longitudes west of Greenwich are positive and those east of
Greenwich are negative.  Like the latitude, the longitude should also be entered in
decimal degrees.  Using Athens, Greece as an example again… Athens has a
longitude of –23.7.  This number means that Athens is 23.7 degrees east of
Greenwich, England.

The Time Zone allows you to give the name of the time zone that your location is in,
for example Pacific Standard Time, or PST.  If you don't know which Time Zone
you should be using or if yours is not listed, chose "Other… " from the bottom of the
list and then fill in the Standard Meridian field.

Standard Meridian is required when you do not specify a time zone.  It is the
longitude of the middle of your time zone. To  calculate it, take the difference in time
between the new location and the Greenwhich, England timezone and multiply that
number by 15.  In equation form, the standard meridian looks like this: (GMT)-(your
time)*15=Standard Meridian. For Athens-Greece, it's -2*15, so the Standard
Meridian is -30.  Hint:  Standard meridian is always an interger, multiple by 15.

If you don't know the time difference between your time zone and Greenwich Mean
Time, there are many resources on the internet.  The following website allows you to
easily find the latitude and longitude of your location within the United States:
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http://www.census.gov/cgi-bin/gazetteer

If your location is not in the United States then you can visit the following website to
find the latitude and longitude of your location, click on the "Access GEOnet"
button:

http://www.nima.mil/gns/html/

The turbidity factor corresponds to atmospheric scattering.  A turbidity factor of 1.0
indicates an ideal clear atmosphere  (i.e. a completely dark sky).  Values less than 1.0
are physically impossible.  The CIE standard value for Turbidity is 2.0 (very clear
sky) and the maxium is 6.0 (very hazy, polluted sky).  Unfortunately there is very
little data available for sky turbidity.

Advanced Calculation Properties
The Advanced Calculation Properties dialog boxes (Figure 72, Figure 73, Figure 74,
and Figure 75) are a series of settings under the main categories of Analysis,
Lighting, Geometry, and Rendering. They are most commonly used in the final steps
of creating a highly accurate, high quality rendering.  To access these dialog boxes
click ADVANCED on the Simulation Setup dialog box.  Many of these settings are
also found in the interactive rendering program, winrview.  The settings in winrview
are intended to allow the user to quickly and easily test different values and settings.
When ideal settings are found, then the user can make the changes in the Advanced
Calculation Properties dialog boxes which will save the setting with the scenario.
After making changes in the Advaned Calculation Properties dialog boxes a high
quality batch mode simulation can be made by selecting batch on the simulation
setup dialog box.

The tab of the Advanced Calculation Parameters dialog box (Figure 72) includes
settings that can help with the analysis of images created in a Radiance simulations.

Figure 72. The Advanced Tab of the Calculation Parameters "Analysis" Dialog Box
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The settings in the Image Exposure section affect how light/dark your image will
appear.  By selecting Auto (linear average), the exposure will automatically be set to
1.0.  This is a good exposure starting point.  If you have a specific value or you want
the image to be darker or lighter than usual, then use the absolute settings or the
relative f-stop settings.

The "Use Custom Post-processing Settings" checkbox refers to whether you are
using a PFILT setting other than the default.  If you are using a different value then
this box should be checked.

The Save Z-buffer data check box allows you to store in the specified file the
distance from the image plane to the ray intersection point in the scene.  This file can
be used to improve the rendering time of animations, but this is not currently
supported by Desktop Radiance.

TheLighting tab of the Advanced Calculation Parameters dialog box (Figure 73)
allows you to control various settings that have to do with how light will be
simulated in your model.

Figure 73.  The Lighting Tab of the Advanced Calculation Parameters Dialog Box

Ambient bounces sets the number of times light is required to bounce from surface to
surface before finding a light source such as the sun, the sky, or a luminaire.  The
lower the number, the faster the calculation but you may not be including all of the
ambient light in your scene.  At the last bounce of light, a constant background
ambient value is added to the computation as specified in the Ambient Value box.  A
reasonable number to use is anywhere between 1 and 5.

If you plan to compute many renderings of the same 3D model, you can check the
“keep ambient data” button and apply the name of a file to store the indirect lighting
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calculation.  This will allow subsequent simulations to compute much more quickly.
However, make sure that all geometry, sky, and lighting parameters remain constant
for any given ambient data file.

If your scene has complex glazings or fenestrations, you can select to “Perform
glazing pre-calculation”.  This causes Radiance to initiate a pre-calculation of the
distribution of light through your complex glazing or fenestration system. By default,
all Desktop Radiance glazings are identified as potential complex glazing surfaces.
Un-checking this box disables the pre-calculations and will result in a faster
calculation.

The glazing accuracy field sets overall accuracy and calculation requirements of the
glazing pre-calculation.  This field is currently set to medium accuracy only.  You
can provide more accurate pre-calculation parameters in the mkillum options field.
See Mkillum at http://radsite.lbl.gov/radiance/man_html/mkillum.1.html for more
information.

The Geometry Tab of the Advanced Calculation Parameters Dialog Box (Figure 74)
deals with various settings related to the 3-dimensional geometry of your scene.

Figure 74.  The Geometry Tab of the Advanced Calculation Parameters Dialog Box

A zone is a volume of space that indicates where you intend to focus the simulation
on.  The Zone is an optional parameter.  The default zone encompasses the entire
scene.  To increase the accuracy of your simulation, define a zone which
encompasses the smallest contiguous volume of space in which you intend to
perform lighting simulations.  For example, if you have an expansive model of a
high-rise office building but you are mainly interested in the left corner cubicle on
the 5th floor, you should define a zone which encompasses only the cubicle area by
using the Radiance →  Analysis →  Define Zone command within the graphic editor.
The name of the zone you create will appear in the Zone Name field. The 6 point
definition boxes (Xmin, Xmax, Ymin… ) are the dimensions of the selected zone. If
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your scene is predominately composed of small geometric entities relative to the
overall size of the scene, then the Geometric Detail setting can be used to improve
the accuracy of your simulations.  Medium is the default setting and is suitable for
most situations.  A low geometric detail setting may speed up the simulation process,
but the accuracy may be reduced.

The octree file specifies the name of the intermediate scene geometry file used for
increasing the speed of the ray-tracing calculations.  This value changes with the
name of your scenerio necessitating the re-generation of the octree for each scenario.
If your geometry has not changed from a previous scenerio, you can replace the
displayed filename with the octree file from the other scenerio that you would like to
use  For more information on the octree settings, see
http://radsite.lbl.gov/radiance/man_html/oconv.1.html.

The three selections below the octree settings box allow you to control how
frequently the intermeidate scene geometry file is rgenerated.  Usualy the octree is
regenerated only once the first time the scenario is simulated, regardless of whether
the geometry from the drawing changes.  The “Regenerate Octree When Geometry
Change” choice allows changes from your drawing to be carried forward into
sebsequent duplicated scenario.  “Always Regenerate Octree” will force the octree to
be regenerated everytime the simulation is started even if no geometry has changed.

The Rendering Tab of the Advanced Calculation Parameters Dialog Box (Figure 75)
determines the pictorial quality of the simulation image rendering from your
Radiance model.

Figure 75.  The Rendering Tab of the Advanced Calculation Parameters Dialog Box

The RIF Control File box shows the name of the scenerio you are dealing with.  This
value is determined by the scenario name and can't be changed here.
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Rendering quality sets the overall quality of the simulation.  With the soft shadows
box checked, penumbras will be rendered so that shadow edges are blurred when
illuminated by non-point source lights.  .  Rendering time will be significantly longer
with this option enabled.

Final resolution determines the horizontal and vertical pixel count of the rendered
image.  If the image is not square or if you do not know the exact size you would
like, you may supply just the horizontal size and the program will figure out the
vertical for you.

Usually Desktop Radiance filters the initial rendering to determine the average
exposure and to perform any image sampling to reduse jagged lines and deletes the
“raw” original image file.  However, if you would like to perform animations or if
you would like to be able to recover a very large image that has crashed for some
reason, then the raw image needs to be preserved.  Oversample Ratio allows you to
reduce aliasing and jagged lines in your image.  By increasing this value, lines will
become smoother.  Increasing this value increases rendering time proportional to the
product of the two resolution values.  Increasing the oversample from 1x to 2x will
increase rendering time by 4 times.

If you would like to preserve a history of the ray-tracing process for later analysis or
to determine possible causes of a failed simulation, then you can select the “save Job
Report Log” and provide the log file name.  The “Report Interval” field determines
how often the log file is updated with the rendering process.

High Quality Renderings
Before creating a high quality rendering, it is best to validate your scenario in the
interactive rendering program winview.  To do this, simply render your image in the
Interactive Mode.  This is the default mode setting in the Simulation Setup Dialog
Box.  Once you are satisfied with the geometry, views, materials, and all other
aspects of your model, it is ready to start a high quality rendering.  In the Simulation
Manager dialog box select the scenario that you would like to become a high quality.
Click “duplicate” and provide a new scenario name.  Once the Simulation Setup
Dialog Box appears select Batch as the mode choice.  A batch rendering allows you
to render the image of your model at a far greater resolution than your monitor
resolution. Click the ADVANCED button in the Simulation Setup dialog box and
select the RENDERING tab.  First select High or Medium quality for your rendering.
Then enter the final resolution that you would like.  Next, select the amount of over
sampling that you would like.  Over sampling reduces the "jaggies".  Although be
careful with this setting, each incremental increase of over sampling can quadruple
your rendering time.  A fairly high quality rendering can  be created by increasing
the oversampling ratio to 2x, on the “lighting” tab set the light variability to “high”,
on the “geometry tab set the geometric detail to “high”.  If the above settings do not
result in a high enough quality, then try setting rendering quality on the “rendering”
tab to “high”.

Simulation Manager
The Simulation Manager provides you with tools to manage your scenarios.  All of
the properties and settings of your simulation are associated with a scenario.  Each
scenario is represented on a separate row of the simulation manager dialog box grid.
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Figure 76.  The Simulation Manager dialog box

The START button will begin a simulation that you have highlighted from the list.
The DUPLICATE button allows you to duplicate a highlighted scenario and change
settings on the Simulation Setup Dialog Box.  MOVE UP and MOVE DOWN will
change the order of the scenarios.  DELETE will delete the highlighted scenario.
CLOSE closes the Simulation Manager dialog box.  After your rendering is finished
and saved, the Display/Analyze button can be used to launch Winimage, the image
analyzer.  For more information, see Image Analyzer.

The columns of the Simulation Manager grid include:

• Scenario Name – the name you specified in the Graphic Editor when
you started the simulation

• Simulation Type – Camera, Reference Point or Reference Grid
simulation

• Camera/Reference – the name of the Camera, Reference Point or
Reference Grid you selected when you set up the simulation.  This
column will show "current" if you did not select a specific camera, but
instead used the currently active view displayed in the Graphic Editor.

• Simulation Mode – interactive, batch, or test simulation

• Simulation Quantity – luminance or illuminance

• % Done – currently either Ready, In Progress, or Done

• Accuracy – currently only Medium is provided

• Sky Type – CIE Clear, CIE Intermediate, CIE Overcast, or Uniform
sky

• Location – The name of the location specified in the Simulation Setup
dialog box

• North Arrow – The name of the orientation North Arrow you selected
in the Simulation Setup Advanced dialog box, geometry tab

• Month – The month of the year on which the simulation will be
performed

• Day – The day of the month on which the simulation will be performed

• Time – The time of day on which the simulation will be performed

• Zone – The name of the Zone created in the Graphic Editor for this
simulation
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• RIF File Name – The name of the Radiance Input File that is created
by the Simulation Manager for each scenario.  This file can be found in
the project folder for the current drawing.

• Preprocess – The name of the Preprocess command file that is created
by Desktop Radiance to pre-compute the intermediate octree file for
block entities inside your drawing.

• Simmode String – This field is controlled by the Simulation Manager.
It displays the command-line options for the rad command that will be
used to start this simulation based on the parameters you specified.

Project Folder
All geometry, properties and settings of your scenarios are stored in a common
project folder.  The project folder is automatically created when you start your first
simulation.  The default project folder is located in the installation directory for
Desktop Radiance (usually C:\Program Files\Desktop Radiance) in a sub-folder with
the same name as the drawing.  You can change this directory or re-connect your
drawing with a project folder that has been moved with the Radiance à  Project à
Project Folder menu command.  You can duplicate the entire project folder keeping
all of the simulation data intact with the Radiance à  Project à  Duplicate Project
command. Because the Radiance for Windows rendering engine can not currently
deal with folder names with the full complexity of characters that Windows allows,
you should take care to specify a folder name that only includes alpha-numeric
characters, and the underscore.

If you select a project folder that already contains information from previous
simulations, Desktop Radiance will first attempt to validate that the drawing and the
simulations found in the specified folder match.  Desktop Radiance will first check
to see if a project database (DRADMAIN.MDB) exists in the specified project
folder, and if so it will compare the unique project identification number of the
Drawing with the project identification number stored in the project database.  If the
project identification numbers do not match, you will not be allowed to use the
specified project folder.  In earlier versions of Desktop Radiance (1.02 and earlier) it
was possible to override the fact the project identification numbers did not match.
This behavior has been changed to prevent the possible loss or corruption of
information that can occur if the drawing and database are not an appropriate match.

If the drawing which you want to start the simulation and rendering of conflicts with
the name of another project and/or drawing, you will be prompted with the Project
Database Conflict Dialog box (Figure 77, p. 66).  If Use Existing is selected, the
information in the existing project folder will be used and new information added to
the existing project database.  Information will not be overwritten, but if significant
changes have been made, overwriting the project may be recommanded.   If New is
selected, you may be prompted by another dialog box to locate and create the new
directory (Figure 78, p. 66).
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Figure 77.  The Project
Database Conflict Dialog Box

When the project folder or database files have been deleted, the following dialog
boxes will appear.  They appear after attempting to start a simulation.  They first
inform you that the project database cannot be found(Figure 78, p.66).  Then an open
file dialog box will appear.  At this point, if you know the folder and drawing exist
somewhere, click on the OK button, find the ACAD drawing which is the basis of
the simulation, and double click on it.  If either the folder and or drawing does not
exist, click on the OK button, and either find the database file called dradproj.mdb, if
it still exists, or click OPEN to create a new one.

Figure 78.  The Locate Project dialog box

This will bring up the Create New Project File dialog box(Figure 79, p.66).
Selecting Yes will create a new project folder with the given name.

Figure 79.  The Create New Project File dialog box

Reference Point Analysis
When simulating a reference point, the Reference Point Properties dialog box
(Figure 80, p. 67) can be accessed by first simulating by reference point and then by
clicking on the DISPLAY/ANALYZE button in the Simulation Manager(Figure 76,
p. 64).
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Figure 80.  The Reference Point Properties dialog box

Workplane Grid Analysis
The Workplane Grid dialog box (Figure 82) can be accessed by first simulating by
reference grid and when finished, click on DISPLAY/ANALYZE in the Simulation
Manager.

When simulating a grid or a point, most accurate results require that you set options
to high on the Geometry and Lighting Tabs of the Advanced Calculation Parameters,
and ambient value to 0.  Ambient value may be set to zero by clicking on the
ADVANCED button and adding –av 0 0 0 to the "Override Settings" box (Figure
12):

Figure 81.  The Override Settings box

The grid point values may be imported into Excel or other spreadsheet programs for
further manipulation.  The values are saved to a text file in the project folder.  The
name of the file is the grayed out file name shown in the "Data File:" field.
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Figure 82.  The Workplane Grid dialog box

Define Scenario

Figure 83.  The Define Scenario Dialog box

After initiating any of the Radiance →  Simulation commands, you are prompted to
define the scenario name.  The scenario contains all of the geometry, lighting,
camera or reference point/grid and accuracy parameters for a particular simulation.
Every scenario needs to have a unique name.  The name is shown in the first column
of the Simulation Manager and becomes the prefix of files created in the project
folder.  For example, for a scenerio named room1, the files created will have names
such as room1_sky.rad and room1.rif.  Only alpha-numeric characters and the
underscore _ are permitted.  No spaces can be used in scenario names.
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Image Analyzer

Introduction
The Image Analyzer (Error! Reference source not found.), also known as
Winimage, may be opened from within Desktop Radiance with the
Radiance→ Tools→ Image Analyzer menu, or by clicking on the Image Analyzer
icon created by the install program in the start menu.

Figure 84.  The Image Analyzer Dialog Box

The Image Analyzer displays Radiance images and provides you with tools to
perfrom various analyses and image manipulations.  Radiance images are saved with
the default extension .pic.  You may also convert images with the File →  Save As…
command so they can be read by other imaging, paint, or presentation  programs.
All commands operating within winimage, with the exception of redraw, will result
in a new image file being created in your project folder.  This is so the different
versions of the image will be distinguishable.

A file naming convention in Winimage is adding “_” and an abbreviation of the
executed command, i .e.  “fls” for falsecolor.  Thus, if falsecolor is performed on
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drawing.pic, the resulting falsecolor image will be drawing_fls.pic. If an annotation
is performed on drawing_fls.pic, then the resulting image will be
drawing_fls_ann.pic.  The original drawing.pic is not overwritten.  However, if
falsecolor is performed on the same image twice, the second version will overwrite
the earlier one.

Here is a list of possible file extensions and their meanings.

_avg = Image →  Exposure →  Image

_reg = Image →  Exposure →  Region (drag mouse to enclose a rectangular area)

_pt = Image →  Exposure →  Point (click on a point in scene)

_90 = Image →  Rotate →  90 degrees clockwise

_180 = Image →  Rotate →  180

_fh = Image →  Flip →  Horizontal

_fv = Image →  Flip →  Vertical

_pcd = Analysis →  Human Sensitivity →  Image

_fls = Analysis →  FalseColor or Analysis →  IsoContour

_ann = Analysis →  Annotate

The Radiance RGBE Format
An important advantage of the Radiance Synthetic Imaging System is the high
dynamic range provided by its RGBE image file format.  It allows for storing real-
world luminance and illuminance values across 77 orders of magnitude with 1%
accuracy.

Images can contain either scalar data (which lacks the high dynamic range), or
luminance/illuminance values.  It is important to distinguish between those two
formats because scalar images are not appropriate for analysis as they lack the real-
world high dynamic range values.

Scalar images result from the use of any of the commands under the Analysis menu.

High dynamic range images result from the use of any of the commands under the
“image” menu.  A scalar image cannot be converted backto a high dynamic image.

Luminance vs Illuminance Images
Radiance image files can contain either radiance (luminance) or irradiance
(illuminance) values.  Unfortunately, Winimage currently does not distinguish
between these two different types.  It is therefore possible to perform operations and
label images in a manner inconsistant with the underlying data stored in the image
file.  It is incombent upon the user to ensure that the appropriate quantities are
analyzed and displayed.
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File

Open
Image Analyzer will only open Radiance .pic images for viewing and analysis.  It
will not open pictures or images saved in other file formats.

Save As
A Radiance image may be saved as a pic, gif, tiff, pct (mac pict file), eps, or bmp.
The saved image, if in a format other than Radiance’s .pic, will not be openable by
winimage again.

Image
The functions available under the Image menu result in new images which preserve
the real-world, high dynamic range of the original image.  Such images are suitable
for later manipulations with functions under the analysis menu.  You can print
images by opening one of these files in a print program.

Redraw
Image Analyzer→ Image→ Redraw, this function redraws/regenerates your image.  It
does not create a new drawing.

Exposure
Image Analyzer→ Image→ Exposure, this tool adjusts the exposure level of the
selected image, region, or point using a linear function with clamping.  The adjusted
image will be given a name with the extension *_pt.pic and saved as a new .pic file
automatically as it is being displayed.  This is similar to how a camera works and can
only partially compensate for regions of the image which are too bright or too dark.
The sky seen outside of windows, for example, will appear completely white if the
image is exposed for the interior surfaces.

Image

Image Analyzer→ Image→ Exposure→ Image.  This tool adjusts the exposure by
averaging all pixels of the image displayed in the foreground.

Region

Image Analyzer→ Image→ Exposure→ Region, then select the region by clicking and
dragging.  This tool averages the  image displayed in the foreground based upon the
average value of a selected region.  If the image has a washed-out or brightly lit
window and a room’s interior, the window may be selected for exposing.  The
resulting new image will be of a dimmer interior and a window which seems less
bright.

Point

Image Analyzer→ Image→ Exposure→ Point, then select a point on the image with
the cursor.  This tool adjusts the exposure relative to the point you have selected.
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Rotate
Image Analyzer→ Image→ Rotate.  This tool rotates the image either 90 degrees
clockwise or 180 degrees.  It is sometimes necessary to rotate plan view images so
that the desired orientation of the image with respect to the top of the page is
achieved.

Flip
Image Analyzer→ Image→ Flip. This tool will flip (mirror) the image horizontally or
vertically.  This is useful for creating reflected ceiling plans from parallel projection
image looking “up” at the ceiling.

Analysis
The functions available under the analysis menu result in new images which lose the
real-world luminance and illuminance values because they contain scalar data, not
real-world luminance or illuminance values.  They become unsuitable for further
manipulations under the analysis menu.

Human Sensitivity
This tool is similar to an exposure adjustment but uses a variety of nonlinear and
linear filters to mimic human visual perception.  This tool compresses the dynamic
range so that most of the details in a high-contrast image may be displayed
simultaneously, similar to the visual experience one may have in the actual space.
(See also Pcond).

Image

Image Analyzer→ Analysis→ Human Sensitivity→ Image.  The human sensitivity
tool will consider the entire image (Error! Reference source not found., left) to
determine the appropriate perceptual exposure setting.  The resulting new image
(Error! Reference source not found., right) may take a few minutes to complete,
especially for wide-angle views.

Figure 85.  Image before (left) and after (right)  running Human Sensitivity.  Notice that
Human Sensitivity image shows exterior details that are not visible in the other image.
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False Color

Figure 86.  The Falsecolor Dialog Box

Image Analyzer→ Analysis→ Falsecolor brings up the Falsecolor Dialog Box
(Error! Reference source not found.).  When applied to a luminance image,
falsecolor outputs (Metric) candela/m2 or (English) footlamberts.  When applied to
an illuminance image, falsecolor outputs lux or footcandle.  The number of divisions
sets the number of intermediate, equally spaced values between zero and the maxium
value that will be displayed on the legend.  Show pixel extrema, if selected, will
cause falscolor to annotate the image pixel with the max and min luminance or
illuminance values (Error! Reference source not found.).  Be sure that the selected
quantity matches the underlying image type.

See Luminance vs Illuminance Images.

Figure 87.  Falsecolor image with Show Pixel Extrema selected
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Iso Contour
Image Analyzer→ Analysis→ Iso Contour brings up the Iso Contour Dialog box
(Error! Reference source not found.).

Figure 88.  The Iso Contour Dialog box

Iso contour is similar to falscolor.  Both output images with quantitative
measurements.  Iso contour draws demarcation lines in equal steps, according to
number of divisions specified, between zero and the maxium value.  Unlike
falsecolor, the resulting image will contain colored lines of equal value overlayed
upon the true color luminance or illuminance image (Error! Reference source not
found.).  When applied to a luminance image, iso-contour outputs (Metric)
candela/m2 or (English) footlamberts.  When applied to an illuminance image, iso-
contour outputs lux or footcandle.  The number of divisions sets the number of
intermediate, equally spaced values between zero and the maxium value that will be
displayed on the legend.  Show pixel extrema, if selected, will cause iso-contour to
annotate the image pixel with the max and min luminance or illuminance values .  Be
sure that the selected quantity matches the underlying image type.

Figure 89.  Iso Contour image
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Annotate
Image Analyzer→ Analysis→ Annotate brings up the annotate dialog box.  This tool
places text on image.  Type the annotation text in dialog box, press ok, and an
updated image with appear with overlay text.

Window

New Window
Image Analyzer→ Window→ New Window opens another window of the same
image.  This allows different parts of the image to be viewed simultaneously, or for
different analyses to be performed and compared side by side.

Cascade
Image Analyzer→ Window→ Cascade displays all open images in a cascading
fashion.

Tile
Image Analyzer→ Window→ Tile tiles all open drawings.

Arrange Icons
Image Analyzer→ Window→ Arrange Icons lines up minimized image icons at the
bottom of the winimage window.
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Interactive Rendering (Winrview)

Introduction
Desktop Radiance allows for real time, interactive rendering.  The image pixels
progressively refine on the screen and start to give you an idea of what the scene will
look like.  Winrview is not meant to be a high resolution rendering tool but more
for determining viewpoints and validating scene geometry (make sure window
normals are correct, furniture not floating in midair, walls meet, etc).  The winrview
interactive rendering is the default mode for camera simulations.  To produce high
quality images, select Batch mode in the Camera Simulation Setup box.

  
Figure 90.  The winrview window during rendering (right) and after rendering (right).

File

Append View to RIF file
This function saves the current view information as text into a specified .rif file in
the project directory which can be used for a subsequent rendering.  A RIF file is not
an image and cannot be opened in the Image Analyzer or winrview.  But a reference
to the view information saved within a .RIF file may be used in a later rendering or
simulation.  This tool suppliments the Define Camera Position command inside of
Desktop Radiance/Graphic Editor.  After starting an interactive rendering
(winrview), you can use Set →  View or the sliders to set up a different view for later
use.  When you are satisfied with the view, goto File →  Append View to rif file.
You will the see a browser window with RIF files listed (Figure 91).
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Figure 91.  Browser for Append view to rif file

Select a .rif file (possibily the one which started this current simulation), then input a
view name such as plan.  No spaces allowed for this name (Figure 92).

Figure 92.  Input View name for "Appending view to rif file" command

Then when prompted to save the .vf file, type the same name again follwed by the .vf
extension, in this case, plan.vf (Figure 93).

Figure 93.  The Append view to view file browser
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You can use the views you have appended to a RIF file in subsequent scenarios by
duplicating the scenario matching the RIF file which has appended the new view
information.

Append View to view file
This function saves the view information into a .VF file in the project directory.  A
.VF file is a text file and cannot be opened in the Image Analyzer Program.  It can be
loaded by winrview or rad in subsequent simulations.

Load view from RIF file
This function allows you to select and load into winrview a view previously saved to
a RIF file.  Access this by going to File →  Load View from rif file.  In the browser,
select the RIF file which contains the saved view definition (Figure 94).

Figure 94.  Browser for Load view from rif file

After selecting the rif file, you will be shown the available views (Figure 95).  Select
one, click ok, and you will return to winrview and begin to render the selected view
of your scene.

Figure 95.  Available views in the selected rif file
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Reusing saved views for batch mode simulations:
At the simulation manager dialog box, select a desired scenerio to duplicate.
(Duplicate means to start another simulation of the same geometry, but with possibly
different rendering parameters).  You will be prompted to give another unique
scenerio name so the duplicated parameters can be kept separate from the original
rendering.  In the pulldown combo box for Camera Name select the view name.
Click batch for the simulation mode, and a batch rendering (rpict) will start up in the
background using the saved view.

Load view from view file
This function allows you to choose and load a VF file into the interactive renderer.

Save Image
Saves the image as a .pic file.  This type of file can be opened in the Image Analyzer
program.

Save Image As
Allows you to save an image as a .pic file.  A pic file can be opened in the Image
Analyzer.  The default location for a pic file is in the project file of your drawing.

Save Log File As

View Log File
The log file is created after you trace a ray in rview.  The log file records all rays
traced and all data associated with the ray.

Figure 96.  The View Log dialog box



82  •  Interactive Rendering (Winrview) Desktop Radiance User Manual

Exit
Upon exiting rview, it will ask if you want to save the image.  If you click YES you
will be able to save the image as the default name given in the default location or as
another name in a location you choose.  Clicking NO will close winrview and not
save the image.

View
This menu allows you to display or hide the winrview tools.  The Toolbars include:
the command bar, the roll/pitch bar, the status bar, the main toolbar, and the
yaw/translate bar.  All the toolbars except the Status bar can be rearranged on the
winrview dialog borders.

Figure 97.  The winrview window with all command bars visible

Command Bar
This is a small edit box which allows you to access some of the legacy features of
rview.

Figure 98.  The Command Bar edit box

You can type in commands for winrview and press <enter>.  The available
commands can be found under the rview→ Help→ Commands pull down menu.
More information on the commands, how to use them, what do they do, may be
found at: http://radsite.lbl.gov/radiance/man_html/rview.1.html
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Figure 99.  The available commands that can be used on the command bar in rview.

Roll/Pitch Bar
These sliders control the rotation of the camera in winrview to the right, left, up, and
down.  Roll adjusts rotation to the right or left around a horizontal axis perpendicular
to the view plane of the current view.  Moving the slider up will roll the camera to
the right, moving it down will roll the camera to the left.  Pitch adjusts rotation up
and down around a horizontal axis parallel to the view plane.  Moving the slider up
will rotate the camera forward/up and moving the slider down will rotate the camera
forward/down.

Figure 100.  The Roll Pitch Bar

Status Bar
This is found near the bottom of the winrview screen.  The status bar indicates the
progress of the rendering.  When the rendering process is finished the status bar will
display "Ready".  When you first begin a rendering with high accuracy, the status bar
may display “Calculating initial ambient values. Wait… ”  This indicates that
winrview is busy even though few pixels may be displayed.
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Figure 101.  The winrview Status Bar

Tool Bar
The main toolbar contains six different tools (Figure 102) that are useful in
formatting your winrview screen to best fit your needs and analysis objectives.

Figure 102.  The main toolbar in rview

"E" adjusts the exposure.  This effects how light or dark your winrview image is.  For
more on this see Exposure.

"F" allows you to frame an area of the winrview image for refinement.  For more on
this see Frame.

"N" redraws or regenerates the winrview image.  This is sometimes necessary if you
have changed several parameters or settings in rview.  For more on this see Redraws
a New image.

"P" allows you to adjust certain image parameters in rview.  For more on this see
Winrview Parameters Dialog box.

"T" allows you to ray trace.  For more on this see Ray Tracing.

"V" allows you to adjust and set the winrview view.  For more on this see  Set View.

Yaw and Translate Bar
The Yaw tool turns the view about the Z axis to the right or left.  Adjusting the Yaw
slider to a smaller number makes it turn left, and a larger number turns the camera to
the right.
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Figure 103.  The Yaw and Translate Bar

The X,Y, and Z spinners move your viewpoint position along the X, Y, and Z axes.
The larger spinners move the viewpoint in larger increments.  The smaller spinners
move the viewpoint in smaller increments.  To adjust the increments that these
spinners set with see GUI Increments.

The spinners labeled F/B, L/R, and U/D move the viewpoint from it's relative
position and angle, as opposed to along an axis which the X,Y, and Z spinners do.

The F/B spinners move the viewpoint forward and backward. The up pointing
spinners move the viewpoint forwards.  The down pointing spinners move the
viewpoint backwards.

The L/R spinners move the viewpoint to the left and right.  The spinner pointing up
moves the viewpoint to the left.  The spinner pointing down moves the viewpoint to
the right.

The U/D spinners move the viewpoint up and down.  The spinner pointing up
moves the viewpoint up.  The spinner pointing down moves the viewpoint down.

Set
This menu item allows you to turn on and off certain features of rview.  SET also
provides another way of accessing some commands that are found on the main
winrview toolbar.

Backface Visibility
This tool turns on and off the walls whose surface normal is pointing away from your
viewpoint.

   
Figure 104.  Without backface visibility (left) and with (right).

This tool is useful when you wish to see through the near side of a building.  With
one camera on the outside both the inside and outside of a building can be easily
viewed instantaneously in rview.  For this tool to work, the surface normals of the
wall surfaces must be oriented toward the inside of the building.  This tool turns off
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the wall surfaces whose surface normal is pointing away from the viewpoint.  For
more information on orienting surface normals see Adjust Normal Orientation in
the Graphic Editor section.

Greyscale
This tool renders the image in black, white, and graytones.

Irradiance
If selected, winrview simulates and calculates the Illuminance in the model.
Reflectance of materials is not taken into account for the very last bounce of light
from the surface to the view point. The total amount of light that reaches each
surface in your model is calculated and displayed.

Figure 105.  An irradiance image

See related topics on The Radiance RGBE Format or Luminance vs Illuminace
Images.

GUI Increments
The set GUI increments dialog allows you to adjust the increments that spinners and
sliders are set for.  The major spinners and sliders are meant to be set with relatively
large increments.  These allow you to move the view in large segments at a time.
The minor spinners and sliders are meant to be set with relatively small increments.
These allow you to fine tune the position of your view once you have moved the
majority of the distance with the major spinners and sliders.
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Figure 106.  The Set GUI increments dialog box

Exposure

  When using the exposure tool, the higher the setting, the brighter the image will
be.  When “Relative Mode” is selected, the exposure will be set relative to your
choice of either a point that you select in the image or relative to the average value in
the image.

Figure 107.  The winrview Exposure tool

Frame

  This tool allows you to frame a section of an image for refinement.  After
clicking on “F” you are prompted to select an area for refinement.  Use the cursor to
drag a box around an area of the image.  To select the entire image, draw a box
around the entire winrview window.  There is no frame all command as in previous
Unix versions of rview.

Redraws a New image

  This tool redraws/regenerates a new image.  This is sometimes necessary if the
image has been corrupted by other dialog boxes, or if you have significantly changed
your calculation parameters and want to start over.
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Winrview Parameters Dialog box

 The winrview parameters define the level of accuracy for the simulated image.
The settings in this dialog box will determine if your model will simulate an image
quickly or more slowly to a high level of accuracy.  NOTE: if you want a highly
accurate image, use batch mode instead of interactive.  In the winrview
parameters dialog box you can  manipulate things such as the number of ambient
bounces that should take place.  For information on choosing recommended values
for winrview parameter settings see the Desktop Radiance User Manual→ Tips and
Techniques→ Setting Rendering Options.  This table will give you minimum,
maximum, fast, and accurate values.  In addition it tells you particular settings that
can greatly affect the rendering time of your model.

Ambient Parameter Tab

The Set Parameters→ Ambient dialog box (Figure 108) below sets the parameters
for the ambient light in the scene.  To access the Ambient Parameters dialog box go
to rview→ Set→ Parameters and click on the AMBIENT tab.

Figure 108. The Ambient Tab in the Parameter Dialog Box

Value: three boxes representing red (top), green (middle), and blue (bottom).
Increasing these values evenly can make the scene darker, decreasing them will
make it lighter.

Weight: the average weight of the indirect light.  As new indirect lights are
computed the average value will be modified.  For a scene that includes indoor and
outdoor spaces, a value of zero is appropriate and is the default.

Accuracy: the percent error allowd in lighting calculations.  The smaller the number,
the smoother the rendering.  A value of 0.3 is a reasonable level to begin with.  The
range of possible values that can be entered is between 0 and 0.5.  Lower numbers
are more accurate.

Divisions: the number of divisions of the hemisphere in the ambient lighting monte
carlo calculation.  A value of zero implies no indirect calculation.  A reasonable
value to begin with is 128.  The range of possible values that can be entered is
between 0 and 4096.  Higher numbers are more accurate.

Super-samples: specifies the maximum number of additional rays to be traced per
ambient division.  Where there is a big difference in value from adjacent rays.  A
reasonable value to begin with is half of the ambient divisions.  The range of
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possible values that can be entered  is between 0 and 1024.  Higher numbers are
more accurate

Bounces: the number of diffuse bounces that will be computed by the indirect
calculation.  To have no indirect calculation, enter a value of zero.  For a medium
quality rendering, a value of 2 or 3 is reasonable.  The range of possible values that
can be entered is between 0 and 8.  Higher numbers are more accurate.  If your
winrview rendering first  appears very flat and shadowless, a low value for the
ambient bounces setting is usually the cause.

Resolution: specifies the density of ambient calculation points.  A value of zero
means that an ambient point is computed for each pixel.  A reasonable value to begin
with is 12.

Direct Parameters Tab

The Set Parameters→ Direct Dialog Box (Figure 109) sets the parameters for the
direct light in the scene.  To access the Direct Parameters dialog box, go to
rview→ Set→ Parameters and click on the DIRECT tab.

Figure 109. The Direct Parameters Dialog Box

Direct-Certainty: value of one guarantees that the absolute accuracy of the direct
calculation will be equal to or better than that given in the Direct→ Threshold value.
A value of zero insures that all shadow lines resulting in a contrast change greater
than the specified Direct→ Threshold value will be calculated.  A reasonable value to
begin with is 0.25.  The range of possible values that can be entered is between 0 and
1.  Higher numbers are more accurate.

Direct-Jitter: controls the smoothness and accuracy of penumbras or soft shadows.
A value of zero means that shadows will be rendered without penumbras and a value
of 1.0 will maximally sample large area sources to provide the smoothest possible
penumbras.

If direct jitter is greater than 0.0 then pixel sampling must be 1.0.  A good value to
use for direct jitter is .67 when smooth shadows are desired.  This parameter can
greatly increase rendering time so use with caution.  A reasonable value to begin
with is 0.02.  The range of possible values that can be entered is between 0 and 1.
Higher numbers are more accurate.

Direct-Sampling: subdivides a light source until the width of each sample area
divided by the distance to the illuminated point is below this ratio. This assures
accuracy in regions close to large area sources at a slight computational expense. A
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value of zero turns source subdivision off, sending at most one shadow ray to each
light source.  Large area sources are subdivided into at most 64 patches which can
lead to “hot spots” on immediately adjacent surfaces.

Direct-Threshold: minimum light value that a light source must have to be tested
for shadows.  A value of zero means all light sources will be tested for shadows.  A
reasonable value to begin with is 0.2.  The range of possible values that can be
entered is between 0 and 1.  Lower numbers are more accurate.

Direct-Visibility: allows you to make light sources appear black when looked at
directly, but light output will still be taken into account for the simulation and
analysis.  A value of zero will turn off the light source visibility.  Any number
greater than zero will turn it on.

Limit Parameters Tab

To access the Limit Parameters dialog box (Figure 110), go to
rview→ Set→ Parameters and click on the LIMIT tab.

Figure 110.  The Limit Parameters Dialog Box

Limit-Reflection: defines the maximum number of specularly reflected and
refracted rays that can be spawned for each initial view ray.  A reasonable value to
begin with is 6.  The possible range of values that can be entered is between 0 and
16.  Higher numbers are more accurate.

Limit-Weight: the weight function stops the generation of specular rays when the
potential contribution is less than the specified minimum value.  If the amount
measured is less then the specified minimum weight, additional rays will not be
traced.  A reasonable value to begin with is 0.02.  The possible range of values that
can be entered is between 0 and 0.05.  Lower numbers are more accurate.

Medium Parameters Tab

Parameters in the Medium tab affect the way light is traced through “participating
media” such as mist or fog.  Volumes of participating media must be modeled with
the appropriate Radiance material.  Such materials are not yet available in Desktop
Radiance.

To access the participating Medium Parameters dialog box (Figure 111), go to
rview→ Set→ Parameters and click on the MEDIUM tab.
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Figure 111.  The participating Medium Parameters Dialog Box controls parameters related to
the rendering of fog and mist.

Scattering Albedo: determines whether light from a medium is absorbed or
scattered.  From top to bottom the boxes stand for Red light, Green light, Blue light.
Only values between 0 and 1 can be entered.  A zero will cause all light not
transmitted by a medium to be absorbed.  A one will result in all light not transmitted
to be scattered elsewhere.

Extinction Coefficient: refers to the distance that light will be scattered or absorbed.
The three boxes from top to bottom stand for red light, green light, blue light.

Scattering Eccentricity: defines how much light scattering will tend towards the
forward direction.  Only values between 0 and 1 can be entered.  A value of one will
result in the most forward tending light scattering.

Mist Sampling Distance: defines the distance between samples taken during a
source scattering.  A value of zero means that only one sample will be taken.

Pixel Parameters Tab

To access the Pixel Parameters dialog box (Figure 112), go to
rview→ Set→ Parameters and click on the PIXEL tab.

Figure 112.  The Pixel Parameters Dialog Box



92  •  Interactive Rendering (Winrview) Desktop Radiance User Manual

Sample: defines the amount of space in pixels that can be used for subdivisions on
the image plane.  A reasonable value to begin with is 16.  The range of values that
can be entered is between 1 and 16.  Lower numbers are more accurate.

Threshold: if two adjacent pixel samples differ by more than this amount, a third
sample will be taken.  A reasonable value to begin with is 0.08.  The range of values
that can be entered is between 0 and 1.  Lower numbers are more accurate.

Specular Parameter Tab

To access the Specular Parameters dialog box (Figure 113), go to
rview→ Set→ Parameters and click on the SPECULAR tab.

Figure 113.  The Specular Parameters Dialog Box

Jitter: the amount that semi-specular highlights will be sampled.  A value of zero
will turn off specular sampling causing all light reflections to appear sharp.  A value
of one will make all specular reflections fully sampled allowing for soft reflections.
A reasonable value to begin with is 0.  The range of values that can be entered is
between 0 and 1.  Higher numbers are more accurate.  Changes in this value have no
effect on rendering time.

Threshold: the minimum specularity of materials under which specular sampling is
not performed.  A value of zero means specular sampling will always take place.  A
value of one means specular sampling will not take place at all.  Values between 0
and 1 will selectively allow specular sampling, for those materials whose specularity
is above the specified value.  A reasonable value to begin with is 0.001.  The range
of values that can be entered is between 0 and 1.  Lower numbers are more accurate.

Ray Tracing

  You select a point to find the level of luminance or illuminance, depending on
the calculation quantity (set→ irradiance or set→ radiance), in your model at that
point.
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Figure 114.  The Raytrace information dialog box

The first line of output provides the name of the material (e.g. 2k217)
associated with the surface that the traced ray struck in the model
followed by the surface type (e.g. polygon) followed by the surface
identifier (e.g. document_53.2.0).

The second line of output provides the location in space that the ray
struck (x, y, z coordinates)(e.g. -2.32832 e-010, 79.303, 86.9679) followed by the
length of the ray from the
camera position to that point (e.g. 117.71) in the units of your model.

The third line of output provides the computed luminance or illuminance
value, first in red, green and blue spectral quantities, then in average
luminance or illuminance quantity.

If your calculation quantity is set to illuminance, this value will
report the illuminance in Lux. If your calculation quantity is set to
luminance, this value will report the luminance in nits or candelas per
square meter. These units are always displayed in SI units, regardless
of the units specified in the preferences dialog box.

The output from tracing rays as well as any error messages generated during the ray-
tracing process will be saved to a log file.  See Save Log File As or View Log File.

Set View

  The Set View Dialog Box (Figure 115) sets specifications for the view or
camera.  The settings to specify include: Type, Size, Viewpoint, Clipping Plane,
Direction, Up, and Offset.
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Figure 115.  The Set View Dialog Box

Type:

Angular allows for a fisheye view of the model with a horizontal and vertical view
size of up to 360 degrees.

Cylindrical gives a view of the model projected onto a horizontal cylinder as is used
with quicktime VR applications.  The maximum view size is 360 horizontal by 180
vertical.

Hemispherical fisheye views of the model with view size up to 180 degrees.

Parallel gives a flat elevation, section, or plan view of the model.  View size is then
interpreted in world coordinate system linear units instead of degrees.  The view
point is interpreted as the center of the image.

Perspective is a standard perspective view of the model from your viewpoint and
allows for a view size of up to 179 degrees.

Size:

Horizontal sets the view angle for a perspective or fisheye view.  For a parallel view
it sets the width of the view in world units.

Vertical sets the height of the view window.

Viewpoint:

The X,Y,Z coordinates determine the focal point for a perspective view or the center
point of a parallel projection image.

Clipping Plane:

This is a plane, perpendicular to your view direction, that cuts through and hides a
portion of the image of your model.  Fore and Aft refer to whether what is in front of
or behind the view point, respectively, is hidden.  The value that is entered in these
boxes determines the distance from your viewpoint that the clipping planes are
situated.  If your image is in a fisheye view then the clipping plane is a clipping
sphere and the value entered is the radius of the sphere.  The center of the sphere
being your viewpoint.
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This tool is useful for viewing the inside of buildings by slicing off a wall on one
side.  A similar effect can be achieved with backface visibility.

Direction:

This tool defines the direction of the view vector that creates the view.  The X,Y,Z
boxes define a point that the view vector will pass through.

Up:

Up is defined by XYZ vectors, with the direction which appears to be the top of the
computer screen being up.  For example, for a view seen by a person standing and
looking straight towards the horizon, the up is along the Z axis, and is defined by
X=0 Y=0 Z=1.

Offset:

This tool offsets the view projection up, down, right, and left.  A positive Horiz
refers to a right offset.  A positive Vert refers to a vertical offset.

Help

Commands
This menu item provides you with commands that can be used in the winrview
Command Bar.  For more information and to view the commands, see Command
Bar (p. 82).

Defaults

Figure 116.  The winrview Defaults dialog box


