
 1

MO-03 Technical Note 
Date: November 15, 2006 

 
Subject: Guidance for downloading and editing OSDs 
 
 Official Soil Series Descriptions (OSD) are the standard for soil series in the U.S. system 
of soil classification known as Soil Taxonomy.  Since about 1995 OSDs have been available to 
soil scientists and the general public on the World Wide Web using formatted HTML source 
code.  We often view and print these highly formatted documents in our work because they are 
easier to read than text-only versions of the OSD.  These HTML files have several font sizes, 
bold section headings, and hyperlinked names of other soil series.  Although these HTML files 
are useful for some aspects of our work, they cannot be used to reprocess the OSD, since they do 
not meet the rigid standard needed to pass the PERL processing program on the database server 
in Fort Worth.  Many soil scientists have downloaded these HTML files by viewing individual 
OSDs with their web browsers from the “View OSD by Series Name (with best-match feature)” 
webpage and then choosing the “save as” option to save the file with either a .doc or .txt 
extension.  Using a .doc extension will save most of the HTML formatting code while using a 
.txt extension will strip it out.  However, regardless of the file extension used, such a file will still 
not pass the OSDCheck program for uploading to the database server.  The correct way to 
download OSD files is to use the ftp procedure described below.  The proper way to edit these 
documents is also described in this guidance as well as helpful tips to make your work easier.  
Any OSD submitted for processing to the MO not following this guidance will be rejected and 
returned to the originator for correction.  Please carefully read and follow this guidance.  If you 
do not understand something in this document, please call your SDQS.  Learning and using this 
guidance will save you and your Soil Data Quality Specialists much time and frustration. 
 
Checking OSD version 
 
 You must ensure that you are using the most current version of the OSD for your 
revisions.  The risk in not using the most current version of the OSD is that an out-of-date file 
will be processed and will overwrite valid revisions that were already made for other reasons or 
by other soil survey staff.  This is careless and counter productive.  To avoid this happening, Do 
not download the OSD files until you are ready to enter your revisions in a timely manner.  A 
“timely manner” is just a few days lag time at best.  If you edit an OSD file for a commonly used 
series that you downloaded even a month ago (let alone several years ago), it may have been 
processed at least once since you downloaded it.  Any revised OSDs we receive for processing 
that were not made in the most current version of the series file will be rejected and returned to 
the originator for correction. 

 If you need to verify the date the OSD was last processed you can check this by using the 
webpage at the following URL: http://ortho.ftw.nrcs.usda.gov/cgi-bin/sc/scname.cgi. 
Enter the soil series name in the dialog box and click the process button.  The resulting page will 
look like the image shown in Figure 1, using the Domehill series as an example.  The most 
important date to consider is the one named “Date Description Updated”.  This date is a day with 
the format of month/day/year (e.g. 06/08/2006).  As the narrative in Figure 1 explains, this is the 
day the OSD document had any change made.  To ensure you are not revising an obsolete 
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version of the OSD (one that precedes the above date), download your OSDs only when you can 
enter your revisions promptly.  After you have completed the revisions, do not delay in sending 
them to the SDQS for review and processing. 

 
Downloading Procedure
 
 Here is the procedure to download OSDs needing revision or to use as templates to draft 
new OSDs: 

A.) On the main webpage for Official Soil Series Descriptions there are four links to Data 
Base Access.  The second link named “View OSDs by List of Series Names (with FTP option)” 
is used to download series.  Click this URL (or copy it into the Location field on your web 
browser: http://ortho.ftw.nrcs.usda.gov/cgi-bin/osd/osdlist.cgi.  See Figure 2.  

B.) The next page is named “Official Soil Series Descriptions View by List".  Enter soil 
names in the list box vertically (with only one name per line) on the left side of this page.  You 
can enter as many soil names as you need.  You can also copy a list of series names generated 
from NASIS component list reports and then paste them into the name box.  Some reports on the 
MO3 NASIS site that generate these lists of component names are “EXPORT - Series used list” 
and “MUG - NV - Component listing”.  Just run these reports on your selected set (which may 
be an entire survey area), save the report to your local drive, open the report in MS-Word, select 
the whole list (Ctrl+A), and copy the list into memory (Ctrl+C).  Then go to the “View by List” 
webpage and paste the names into the list box (Ctrl+V) and click the Process button. 
See Figure 3.  

C.) The next page will give you the option to either view the OSDs by clicking the “View 
Description” buttons or beginning the ftp download process.  Click the hyperlinked (colored) 
FTP icon that ends the sentence "This set of descriptions may be downloaded via FTP". 
See Figure 4. 

D.) The next page gives you options to select the format to receive the file in.  There are two 
sets of choices.  In the top choice list, accept the radio button of the first option labeled "zip file". 
This option is selected as the default.   In the bottom choice list, click the radio button of the 
second option labeled "DOS and MS Windows".  Then click the Download button.  Note that 
this download button creates the compressed (zip) file on the web server but it does not yet begin 
the ftp process of the file back to your computer.  See Figure 5. 

E.) The next page gives you the file size and a hyperlink to the name of the created file which 
is always called "osd.zip" based on the checked options selected in step 4.  Follow the page 
instructions to begin the download to your system by either clicking or right-clicking on the 
osd.zip hyperlink (if using Internet Explorer) and either clicking the Save button from the File 
Download window or choosing the “Save target as” option from the popup dialog box.  If using 
Netscape you can shift-click by keeping the shift key pressed down as you click with your mouse 
on the file name.  See Figures 6 and 7. 

F.) You should now have a "Save As" dialog box that lets you put the zip file where you 
want it on your computer.  Just navigate through your computer's directory structure to decide 
where you want the file placed.  You can even rename the file if you want to.  Then click the 
"Save" button.  See Figure 8. 
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G.) If using Netscape as your web browser, the next thing you'll see is a Password Entry 
Dialog box.  You don't need to enter a password in this field.  Just click the OK button.  You will 
then briefly see a "Savings Location" box with percent progress bars flash on your screen as the 
file is ftp'd from the server onto your computer. 
 
Extracting Procedure

 

I.) At this point you can close or minimize your web browser and navigate to the place on 
your hard drive using Windows Explorer where the zip file was saved.  Find the file named 
osd.zip (or whatever you renamed it to) and use the WinZip program to extract the OSD text files 
inside.  Highlight the zip file and then right-click to bring up a menu with extract options.  
Choose the “WinZip” and “Extract to” options and you bring up the WinZip Extract window.  
See Figure 9. 

II.) The WinZip Extract window has navigation options to have the program put the extracted 
OSD files where you want them.  If identically named files already exist in your target directory, 
you should see a warning box asking whether you want to overwrite the existing files. 
See Figure 10. 

III.) The extraction process takes just a few seconds and the individual files will quickly 
appear in your target directory.  You can then delete the zip file since you no longer need it.  The 
OSD files all have .txt extensions (e.g. alpineco.txt).  See Figure 11. 

 
Changing Default Program for Word Processing of Text files  
 
 If you double click the file name of these documents they will be opened into Microsoft 
Notepad, because Notepad is the default program for text (.txt) files on most PCs.  So instead 
launch Microsoft Word, Click Open, and navigate to the directory where the files are.  This 
works fine, but is cumbersome.  To speed the process, you can change the default program used 
to open .txt files from Notepad to MS-Word.  This is often very convenient if you are editing a 
lot of text files.  To change your default program for editing text files perform the following 
steps: 
 

 Open Windows Explorer 
 Choose Tools > Folder Options > File Types 
 Scroll down the list of registered file types and find “TXT file”. 
 In the part of the dialog box labeled “Details for TXT extension” there is button labeled 

“Change”. 
 Click the change button and a dialog box opens named “Open With”.  Find Microsoft 

Office Word and click OK and then click Close. See Figure 12 
 Now when you double click any file with a .txt extension, MS-Word will be launched 

instead of Notepad to use as your word processor.  You can always change this back to 
Notepad if you wish by repeating the steps above. 

 
 
 



 4

Editing OSDs using Microsoft Word 

a.) Now you are ready to enter your proposed revisions in the text files.  Open the text file in 
MS-Word.  Often the first thing you will see before the file actually opens is a “File Conversion” 
dialog box.  Just accept the default option for Windows and click the OK button.  Now choose 
Tools > Track Changes or simply double click the letters “TRK” in the status bar at the bottom 
of the window to activate the “track changes” feature.  See Figure 13. 

b.) The track changes feature documents any additions or deletions you make in the OSD.  
To easily see the deletions you make, choose View > Print Layout.  This will show your 
deletions off on the far right side of the window in a special small box.  See Figure 14. 

c.) After you make your first change in the OSD you should immediately save your work.  
The track changes feature is special formatting and cannot be saved in a simple text (.txt) file.  
To save your work, you must save the proposed OSD revision into a new file with word 
formatting (.doc).  Do this by choosing File > Save As.  In the “Save As” dialog box, click the 
drop down arrow next to the “Save as type” box and choose “Word Document  (*.doc).  This 
saves your track changes revisions into a new file with a series name having a .doc extension 
(e.g. domehill.doc).  The original text file will be unchanged and will close.  Now you can 
continue entering all your other proposed revisions into the OSD and you can simply do periodic 
Saves to the new word document.  See Figure 15. 

d.) After you have completed your proposed revisions, send the revised OSD (*.doc) to the 
SDQS in the Reno MO as a file attachment to an email message.  If you have a bunch of OSD 
files with revisions you can create a zipped file to contain them all.  Simply attach the zip file to 
your email.  Most proposed OSD revisions are self-explanatory and are usually needed to expand 
or correct the range in characteristics or geographic setting sections.  You should include 
comments on the rationale for some other revisions in the individual OSDs or in the body of your 
email message. 

e.) Please note the line labeled “MLRA OFFICE RESPONSIBLE” in the OSDs you have 
revised.  There are 18 MLRA Offices (MO) for the country.  Responsibility for soil series are 
assigned to these MOs and is based on entries in the Soil Classification (SC) database.  The SC 
database is directly linked to the OSD documents for which MO is responsible.  A change in 
responsibility cannot be made by simply editing the line in the OSD.  The change can only be 
made in the SC database by SDQS on the staff of the MO which is responsible for the series.  
Changes in series responsibility do not happen without due cause.  What this means to you is 
this: If an MO other than Reno, Nevada is the responsible office, you need to alert your MO3 
SDQS to that fact.  Tell the SDQS in your email message that certain of the revised series you 
are submitting for change (name them) are not ones that Reno is responsible for.  Do not send 
revised OSDs for series owned by another MO directly to that office.  The Reno SDQS are 
responsible for soil correlation and we need to see and approve the requested revisions whether 
we can process them or not.  After we review and approve the revisions for the OSDs we will 
upload the MO3 series for processing.  We will also forward revisions for series owned by other 
MOs to their respective SDQS with a request for processing if they think your changes are 
acceptable. 
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Figure 1. Results of query to Soil Classification database in “View by Name” webpage. 
 

The “Date SC Updated” is the last date that the Soil
Classification database (SC) was accessed by a SDQS
To change data elements such as taxonomic classification,
series status, benchmark soil status, states using, or MLRA using.
This date may be different (either older or younger)
than the “Date Description Updated” described below.

The “Description Date” is the last date (mo/yr) that the
OSD changed.  It agrees exactly with the date
displayed on line 5 of the OSD.  This date will

match either the “Date SC Updated” or the
“Date Description Updated”, whichever is more recent.

The “Date Description Updated”
is the last day that the OSD document had ANY change.
The change may have been substantial 
or it may have been only a change in a data element linked 
directly with the SC database such as 
taxonomic classification, Series Status, or States Using.

Note that “MLRAs Using” is not linked.

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Figure 2. Main OSD webpage with links to other web pages. 
 

Click this link 
for the FTP option
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Figure 3. OSD “View by List” webpage. 
 

This box is used to enter any number of
soil series names. You can copy and then 
paste a list of series names into this box.
Long lists are mainly exported from NASIS for 
an entire survey area. After entry of names,
Click this button.

This box is used to enter any number of
soil series names. You can copy and then 
paste a list of series names into this box.
Long lists are mainly exported from NASIS for 
an entire survey area. After entry of names,
Click this button.

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Figure 4. Webpage displaying query results of OSD database 
 
 

If any names are displayed here, the name is
either misspelled or the OSD does not exist in 
the database

Click this link to start the FTP process.

Clicking any of these buttons will allow you to view a 
single OSD just like when you view them from the 
“View OSD by Series Name (with best-match feature)” webpage.
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Figure 5. Webpage to set options for compressed file format 
 

Next you click on this button to change this setting.

Just accept this default setting.

Then click this button to create
the zip file you will soon download.

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Figure 6. Webpage to start the download to your computer via FTP protocol. 
 

You can either click or right-click
this link to start the download

process from the server to your
local computer.
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Figure 7. Screen showing file download box if using IE Explorer as web browser. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Figure 8. “Save as” dialog box if using IE as your web browser. 

You can change the default
file name from osd.zip to a
unique name if you wish.

Choose the directory where
you want to save the file.
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Figure 9. Using Windows Explorer to find OSD zip file on local computer. 
 

Find the zip file on your computer with Windows Explorer, 
select it, 

right-click, and choose
WinZip > Extract to …

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Figure 10. Using WinZip Extract to set options for extracting OSD files on local computer. 
 

You can leave these
options unchecked

Click this button
to navigate to the
directory you want
your OSD files in

Click this button
to begin extracting

the OSD files
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Figure 11. Directory with extracted OSD files. 
 

The result of the extraction process are the 
10 OSD files shown here.  They are text-only. 
After extraction is complete, you can delete 

the zip file that the OSDs were downloaded in.

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Figure 12. Changing default word processing program for text (.txt) files. 
 
 

After selecting the
TXT file type,

 
 
 
 
 
 
 
 
 
 

Click this button.

Choose MS-Word as the program
and then click OK to change.
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Figure 13. Activating the “track changes” feature of MS-Word. 

After opening the file, choose the
track changes option from the tools menu

or just double click on the TRK in the
status bar to activate.

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Figure 14. OSD file with revision made using “track changes” feature of MS-Word. 
 
 

Enter revisions in the OSD using 
“Track Changes” and with “Print Layout”

As the View option
shows the revisions

In red text and the deletions to the side.
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Figure 15. Using the “Save As” option to save track change revisions in a new Word doc. 
 

Choose Word document (.doc)
as the file type to save your

track change revisions.
Then click Save.

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 


