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Introduction
GeoVu is a data- and platform-independent browse and visualization application developed at the
National Geophysical Data Center (NGDC). GeoVu 6.0 operates in the Microsoft Windows, Macintosh,
and Sun and SGI Motif environments.

You need to install the GeoVu application software and you may want to install the GeoVu Data
Sampler, a data collection compiled for use with GeoVu demonstrations and tutorials. If you have data
collections published by NGDC, you may also want to install the set of menu files (*.men) to update
those you already have. Documentation files are also available.

Requirements

PC

Under Microsoft Windows, GeoVu operates on any IBM PC 386 or 486 or compatible personal
computer. The minimum configuration is DOS 5.0 running Microsoft Windows 3.xx or Windows 95.
A Windows-supported mouse device and video system of VGA or better resolution are required, and
optionally, a CD-ROM drive and standard CD-ROM file access software.

Macintosh

To run GeoVu on a Macintosh, you should have a 68020-based machine (Mac II or later) with a color
monitor, 4 MB of RAM, and System 6 or later. Note that PowerMacs run GeoVu in emulation mode
which results in poor performance of some functions.

Unix

GeoVu is also available as a Motif 1.1 program running on Sun Sparc workstations and as a Motif
1.2 program running on SGI workstations.

Obtaining GeoVu
GeoVu application software, the Data Sampler, menu files, and documentation files are accessible via
FTP and on-line from the World Wide Web (WWW), and are available on CD-ROMs published by
NGDC, and on diskettes (PC and Macintosh). If you are using your own data, you only need to obtain the
GeoVu application software. If you are using data collections published by NGDC, you should also get
the accompanying menu files (*.men). If you have no data but wish to check GeoVu's capabilities, you
should get the Data Sampler as well as the application software. The documentation for GeoVu
(available in several formats) includes this "Getting Started" guide, a user's reference guide, and a guide
to tools for data publishers.

FTP

If you want to download GeoVu to your computer, it must be connected to Internet and support the
ftp command.

To download GeoVu:

1. Enter ftp ftp.ngdc.noaa.gov. Log in using anonymous for the user ID; use your own e-mail
address or name for the password.
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2. Change directories to Access_Tools/GeoVu.
Here you will find subdirectories (PC, Mac, Unix_SGI, Unix_Sun) containing a GeoVu
installation file (self-extracting executable) for each platform.

3. Download the appropriate GeoVu installation file (PC–gvinstal.exe, Macintosh–
geovu.sea.hqx, Unix–geovu.tar.Z) and readme file in binary mode (PC, Unix) or ASCII
mode (Macintosh).

To download the Sampler, menu files, and documentation files:

1. The GeoVu Data Sampler, also in a self-extracting executable file (PC–sampler.exe,
Macintosh–gvdata.sea.hqx, Unix–sampler.tar.Z), is available in
Access_Tools/GeoVu/Sampler. Download the appropriate Sampler file in binary mode (PC,
Unix) or ASCII mode (Macintosh).

2. The menu files (*.men) are located in Access_Tools/GeoVu/Menu_Files. Download them
in binary mode.

3. The documentation files in several formats are located in Access_Tools/GeoVu/Doc_Files.

World Wide Web

To access GeoVu installation and accessory files, use the following URL:
ftp://ftp.ngdc.noaa.gov/Solid_Earth/Access_Tools/GeoVu
(subdirectories as above)

CD-ROM

Newer NGDC CD-ROMs include the platform-specific GeoVu installation file in the appropriate
subdirectory (pc, mac, unix_sgi, unix_sun) under \software\geovu. The Sampler executable is in the
\sampler subdirectory and GeoVu documentation files are in \documnt. Menu files are in the \gv_misc
subdirectory under the appropriate platform directory (pc, unix_sgi, etc.) On older NGDC CD-ROMs,
look for GeoVu files in \software; subdirectories may vary.

Diskettes

Contact us at the following address to order GeoVu for PC or Macintosh on diskettes (for which
there may be a nominal charge):

Solid Earth Geophysics Division
National Geophysical Data Center

325 Broadway E/GC1
Boulder, CO 80303

(303) 497-6472

Installing GeoVu
Your installation directory should be empty. Either create a new directory or clean out an existing
directory.

PC

You will need 4 MB of disk space on your PC to install GeoVu.
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To install GeoVu after it has been downloaded via FTP or WWW:

1. After getting gvinstal.exe, select the Run option from the File menu in the Windows 3.xx
Program Manager or use the Start menu on the Windows 95 desktop.

2. Type setup preceded by the drive, e.g., a:setup, then follow the installation instructions on
the screen.

The installation process places GeoVu software and accessory files on your computer's hard
drive in the directory or folder of your choice. The GeoVu Setup program installs or
modifies an initialization file (freeform.ini) and the path of the installation directory for
GeoVu is written into this file during setup.

To install GeoVu on a PC from an NGDC CD-ROM:

1. Select the Run option from the File menu in Windows 3.xx Program Manager or use the Start
menu on the Windows 95 desktop.

2. Run the GeoVu Setup program setup.exe, which is located on newer NGDC CD-ROMs in
the directory \software\geovu\pc or on older CD-ROMs in the directory \software. Type
setup preceded by the path (e.g., e:\software\geovu\pc\setup), then follow the installation
instructions on the screen.

To install GeoVu on a PC from diskettes:

1. Start Windows.

2. Insert the GeoVu Access Software diskette into the appropriate drive, e.g., a:

3. Select the Run option from the File menu in Windows 3.xx Program Manager or use the Start
menu on the Windows 95 desktop

4. Type setup preceded by the drive, e.g., a:setup, then follow the installation instructions on
the screen.

Macintosh

To install GeoVu after it has been downloaded via FTP or WWW:

1. When you download geovu.sea.hqx, decoding and installation of the geovu folder onto your
hard disk may take place automatically depending on the setup of your FTP or Web software.
If only the geovu.sea.hqx file is installed, decode it with StuffIt Expander or BinHex. These
are free software utilities available in many places on the Web including
http://hyperarchive.lcs.mit.edu/HyperArchive.html.

2. After decoding, double-click the geovu.sea icon to install the geovu folder wherever you
want on your hard drive. If you use StuffIt, this may happen automatically, depending on
your settings.

To install GeoVu on a Mac from an NGDC CD-ROM:

1. Copy the file geovu.sea.hqx to your hard drive (truncated to geovu_se.hqx or
geovusea.hqx) from the \software\geovu\mac directory on the CD-ROM (\software on
older NGDC CD-ROMs) to your hard drive. The file name is truncated because the CD-
ROM was made on a DOS-based PC.
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2. Decode the file with StuffIt Expander or BinHex.
These are free software utilities available in many places on the Web including:
http://hyperarchive.lcs.mit.edu/HyperArchive.html.

3. After decoding, double-click the geovu.sea icon to install the geovu folder wherever you
want on your hard drive. If you use StuffIt, this may happen automatically, depending on
your settings.

To install GeoVu on a Mac from diskettes:

Double-click the geovu.sea icon to install the geovu folder wherever you want on your hard
drive.

Unix

To install GeoVu after it has been downloaded via FTP or WWW:

1. After getting geovu.tar.Z, place it in the directory where you wish to install GeoVu
(typically your home directory).

2. Enter the following commands:

uncompress geovu.tar.Z
tar xvf geovu.tar

These commands generate the geovu/ directory and file g2, which is an X application
defaults file.

3. Place g2 (not g2.exe!) in your home (~) directory.

4. Be sure the environment variable GEOVUDIR points to the geovu directory. For example, if
you use the C Shell (and un-tar'd geovu.tar in your home directory), put the following line in
.cshrc:

setenv GEOVUDIR ~/geovu

To install GeoVu on a Unix machine from an NGDC CD-ROM:

1. Copy the file geovu.tar.Z (truncated to something like geovu_ta.z) from the
\software\geovu\unix_sun or unix_sgi directory on the CD-ROM (\software on older
NGDC CD-ROMs) and place it in the directory where you wish to install GeoVu (typically
your home directory). The file name is truncated because the CD-ROM was made on a DOS-
based PC.

2. Enter the following commands:

cp geovu_ta.z geovu.tar.Z
uncompress geovu.tar.Z
tar xvf geovu.tar

These commands generate the geovu/ directory and file g2, which is an X application
defaults file.

3. Place g2 (not g2.exe!) in your home (~) directory.
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4. Be sure the environment variable GEOVUDIR points to the geovu directory. For example, if
you use the C Shell (and un-tar'd geovu.tar in your home directory), put the following line in
.cshrc:

setenv GEOVUDIR ~/geovu

Installing the GeoVu Data Sampler

PC

The Sampler data are in the zipped executable file sampler.exe and occupy 9 MB of disk space when
expanded.

To install the Sampler on a PC:

1. Before getting sampler.exe, create the directory \gvdata at the root level, e.g., mkdir
c:\gvdata. Then place sampler.exe in \gvdata.

2. Run sampler.exe with the -d option (sampler.exe -d) to extract the data files.
The -d option recreates the directory structure.

3. Copy the accompanying menu file sampler.men to the GeoVu installation directory pointed
to by the environment variable GEOVUDIR, e.g., copy c:\gvdata\sampler.men c:\geovu.

Macintosh

The Sampler data are in the self-extracting archive gvdata.sea.hqx.

To install the Sampler on a Macintosh:

1. When you download gvdata.sea.hqx, decoding and installation of the gvdata folder onto
your hard disk may take place automatically depending on the setup of your FTP or Web
software. If only the gvdata.sea.hqx file is installed, decode it with StuffIt Expander or
BinHex. These are free software utilities available in many places on the Web including
http://hyperarchive.lcs.mit.edu/HyperArchive.html.

2. After decoding, double-click the gvdata.sea icon to install the gvdata folder on your hard
drive. If you use StuffIt, this may happen automatically, depending on your settings. It is
recommended that the gvdata folder be placed at the top level of your hard drive.

3. Copy the accompanying menu file sampler.men to your gvdata folder.

Unix

The Sampler data are in the compressed file sampler.tar.Z and occupy 9 MB of disk space when
expanded.

To install the Sampler on a Unix machine:

1. When you get sampler.tar.Z, place it in the directory where you wish to install the Sampler
data and enter the following commands:

uncompress sampler.tar.Z
tar xvf sampler.tar

These commands create the gvdata directory which contains the Sampler directories and
data files.
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2. Copy the accompanying menu file sampler.men to the GeoVu installation directory pointed
to by the environment variable GEOVUDIR (typically your home directory).

Installing Menu Files
After you download menu files (*.men) from FTP or WWW, place them in the GeoVu installation
directory, e.g., c:\geovu (PC), the geovu folder (Mac), /geovu (Unix). If installing GeoVu from diskette
(PC or Mac), copy any menu files you need to the GeoVu installation directory or folder. Menu files that
reside on CD-ROMs must likewise be copied into the GeoVu installation directory or folder.

Running GeoVu
The general sequence for accessing and viewing data is as follows:

1. Select a data file.

2. Optionally, browse information about the data (if displayed).

3. Specify search criteria if data are not automatically displayed.

4. Define desired output (screen display; save data to disk file).

5. Optionally, name the output file and specify an image's Save format.

See the GeoVu User's Guide for detailed information about GeoVu menus, tools, and controls.

Starting GeoVu

PC

There are several ways to start GeoVu for the PC:

• To start GeoVu as a Windows desktop application, double-click the GeoVu icon.

• From the File menu in the Windows 3.xx Program Manager or the Windows 95 Start menu,
select the Run option. Windows prompts you for the name of the application. Enter the full
path to g2, e.g., c:\geovu\g2.

• If your current working directory is the GeoVu directory, start GeoVu from the DOS
command line by entering win g2.

Macintosh

• To start GeoVu for Macintosh, double-click the GeoVu application icon in the geovu folder.

Unix

• To start GeoVu for Motif as a desktop application, double-click the GeoVu icon.

Exiting GeoVu

• To exit GeoVu, select Exit GeoVu from the File menu or use the close box on the GeoVu
application window.
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Viewing Data Files

To view a data file:

1. Start GeoVu and select Set Data Source from the File menu.
The Data Source dialog is displayed. A data source is a collection of data files on a CD-
ROM, hard disk, or diskette.

2. Change (if necessary) the drive letter (or path) shown in the text box with the title “CD-drive
or data's drive” to that of the drive (or directory) where the data source is located.
Examples
    e: (PC)
    :Pathfinder (Mac) Pathfinder is the name of the icon on the desktop
    /cdrom (Unix)

3. Choose the file in the data set that you want to view; you may have to navigate (with double-
clicks) through several menu levels. An Introduction screen is usually displayed first with
some information about the data collection.

 If the data publisher has activated the automatic display function, the data file is displayed
when you choose it. If not, you need to define a search.

Defining Searches

If the data publisher has not activated the automatic display function, you must define a "search" before
data are retrieved, processed, displayed, or written to disk file. After opening a data file, you use Search
menu options to define retrieval and display properties for that file. It is recommended that you
experiment with different settings. The result of a search on an open data file can be a plot display, an
image display, or a disk file.

To define a search:

1. After you open a data file, select Create from the Search menu to display the dialog or
window in which you can set search criteria. For image data, the Image Search Parameters
dialog is displayed; for point data, the Plots:Title window appears.

2. Set the criteria as you wish (specify geographic limits, display attributes, and so on), or click
OK (image) or GO (point) to accept the defaults. The data are displayed in a new window.

Note! Once you have defined a search, you can save it in GeoVu by title for future use. For
image data, use the Save Search Definition button in the Image Search Parameters
dialog. For point data, click the Output/View Type control button, then click “Save
the search definition only”.

3. You can now examine the data in more detail using the tools on the right side of the window
(COLOR, ZOOMIN, PROFILE, etc.) or you can open additional data display windows.
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Using Sampler Data

1. To access the GeoVu Sampler data, click the File menu item Set Data Source.

2. Select GeoVu Sampler Data from the list and change the drive letter designation to that of
the drive or path where the directory gvdata is located.

3. Navigate through the lists of titles until you find the name of the data file you want to view.
Double-click the title to open the data file or click the title, then the OK button.

4. If the data file isn't automatically displayed, you can select Create from the Search menu to
display the dialog or window in which you set search criteria.

File Extensions

GeoVu uses the following standard file extensions when reading and writing files. These extensions also
are used on NGDC’s CD-ROM products:

.dat ASCII data files

.bin binary data files

.fmt format description files

.hdr header files

.doc documentation files (usually IDRISI separated header files)

.hed text format grid documentation

.lst histogram information file for numeric variables

.cst histogram information file for character variables

.ind index files (indexing menu files)

Viewing Tips

• Data may have associated header files, format description files, image information files, and terms
files that define field names and code values. You can use options in the Edit menu to review and
change the information in these files.

• GeoVu treats images with coordinates specified by latitude and longitude pairs as georeferenced
images. The GeoReference menu contains several options that let you use georeferenced images with
vector overlays.

• Use Slide Show from the Utilities menu to sequentially display images in a data collection.

• To create enlarged or reduced images from an image display, select Image Processes from the
Utilities menu. The resulting images are no longer linked to the original data.

• To view histogram information (variable summary) files that indicate variable distribution, select
View File Histograms from the Utilities menu.
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• Double-click within an image to display image coordinates, data values, and data class names.

• The Help menu displays information found in the GeoVu User's Guide.

• The FACTS control button displays information about the currently displayed image, data classes,
and so on.

Questions?Questions?

Phone: 303-497-6764

FAX: 303-497-6513

Internet: geovu@mail.ngdc.noaa.gov
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