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IMPERATIVES are those words and phrases that command that something must be provided. 

         "SHALL" normally dictates the provision of a functional

         capability.

         "MUST" or "MUST NOT " normally establish performance

         requirements or constraints.  

         "WILL" normally indicates that something will be provided from

         outside the capability being specified. 

    An explicit specification will have most of its counts high in the

    IMPERATIVE list (i.e. shall, must, required).

    The counts of IMPERATIVES found in file SARA Requirements.txt are shown

    in the table below.

      
IMPERATIVE

OCCURRENCE

        
--------------------         

----------

        
shall                                
118

        
must                                   
0

        
is required to                         
0

         
are applicable                        
0

         
are to                                 
0

         
responsible for                       
0

         
will                                   
9

          
should                                
14

                                            

----------

         
TOTAL                 

141
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    CONTINUANCES are phrases such as "the following:" that follow an

    imperative and precede the definition of lower level requirement

    specifications.  The extent that CONTINUANCES are used is an

    indication that requirements have been organized and structured.

    These characteristics contribute to the tractability and

    maintenance of the subject requirement specification document.

    However, extensive use of continuances indicate multiple, complex

    requirements that may not be adequately factored into development

    resource and schedule estimates.

    The counts of CONTINUANCES found in file SARA Requirements.txt are shown

    in the table below.

          
CONTINUANCE

OCCURRENCE

           
--------------------          
----------

           
below:                                 
0

          
as follows:                            
0

         
following:                             
0

          
listed:                                
0

          
in particular:                         
0

          
support:                               
0

      
and             


40

              :                               

1

                                            

----------

          
TOTAL                  

41
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    DIRECTIVES are words or phrases that indicate that the document

    contains examples or other illustrative information.  DIRECTIVES

    point to information that makes the specified requirements more

    understandable.  The implication is the higher the number of Total

    DIRECTIVES the more precisely the requirements are defined.

    The counts of DIRECTIVES found in file SARA Requirements.txt are shown

    in the table below.

        
DIRECTIVE           

OCCURRENCE

          
--------------------      

----------

         
e.g.                           

0

          
i.e.                            

0

         
For example              

0

         
Figure                   

0

         
Table                        

0

         
Note:                        

0

                                     

----------

        
TOTAL                   

0
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    OPTIONS are those words that give the developer latitude in the

    implementation of the specification that contains them.  This type

    of statement loosens the specification, reduces the acquirer's

    control over the final product, and establishes a basis for

    possible cost and schedule risks.

    The counts of OPTIONS found in file SARA Requirements.txt are shown

    in the table below.

        
OPTION PHRASES

OCCURRENCE

         
--------------------  

----------

         
can                            

1

         
may                           

0

         
Optionally                 

0

                                        

----------

    
TOTAL                   

1
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    WEAK PHRASES are clauses that are apt to cause uncertainty and leave

    room for multiple interpretations.  Use of phrases such as 

    "adequate" and "as appropriate" indicate that what is required

    is either defined elsewhere or worst, the requirement is open to

    subjective interpretation.  Phrases such as "but not limited to" and 

    "as a minimum" provide the basis for expanding requirements that have been

    identified or adding future requirements.  WEAK PHRASE total is

    indication of the extent that the specification is ambiguous and incomplete.

    The counts of WEAK PHRASES found in file SARA Requirements.txt are shown

    in the table below.

         
WEAK PHRASE     

OCCURRENCE

         
--------------------       

----------

         
adequate                     

0

         
as appropriate            

0

          
be able to                

0

          
be capable of             

0

          
capability of                
0

          
capability to               

7

           
effective                    

0

          
as required                 

0

          
normal                       

0

           
provide for                 

0

           
timely                         

0

          
easy to                       

0

                                      

----------

 
TOTAL                   

7
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    INCOMPLETE is the category of words and phrases that indicate that the

    specification of requirements is not fully developed or provides a basis for

    expansion or addition of new requirements at a later date.

      "TBD" indicates that necessary information has yet TO BE DETERMINED.

      "TBS" indicates that a required event has yet TO BE SCHEDULED.

      "TBE" indicates that a needed designation has yet TO BE ESTABLISHED

            or yet TO BE ESTIMATED.

      "TBC" indicates that a needed value has yet TO BE COMPUTED.

      "TBR" indicates that a question regarding a condition or value

            as yet TO BE RESOLVED.

      "not defined" and "not determined" are phrases that explicitly 

            declare that a specification statement is incomplete.

      "but not limited to" and "as a minimum" are phrases that open the

            requirements specifications to future modifications or additions.

    The counts of INCOMPLETE words and phrases found inSARA Requirements.txt are

    shown in the table below.

          
INCOMPLETE       

OCCURRENCE

           
--------------------          
----------

          
TBD                                    
0

           
TBS                                    
0

           
TBE                                    
0

           
TBC                                    
0

          
TBR                                    
0

           
not defined                            
0

           
not determined                    
0

           
but not limited to

0

           
as a minimum                      
0

                                            

----------

         
TOTAL                   

0
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    NUMBERING STRUCTURE DEPTH provides a count of the numbered statements

    at each level of the source document.  These counts provide an

    indication of the document's organization and consistency and level

    of detail. High level specifications will usually not have numbered

    statements below a structural depth of four.  Detailed documents may

    have numbered statements down to a depth of nine. A document that is

    well organized and maintains a consistent level of detail will have a

    pyramidal shape (few numbered statements at level 1 and each lower

    level having more numbered statements than the level above it).

    Documents that have an hour-glass shape (many numbered statements at

    high levels, few at mid levels and many at lower levels) are usually

    those that contain a large amount of introductory and administrative

    information. Diamond shaped documents (a pyramid followed by

    decreasing statement counts at levels below the pyramid) indicate

    that subjects introduced at the higher levels are probably addressed

    at different levels of detail.

    SPECIFICATION DEPTH is a count of the number of imperatives at each

    level of the document.  These numbers also include the count of

    lower level list items that are introduced at a higher level by an

    imperative that is followed by a CONTINUANCE. This structure has the

    same implications as the numbering structure.  However, it is

    significant because it reflects the structure of the requirements as

    opposed to that of the document. Differences between the shape of the

    numbering and specification structure are an indication of the amount

    and location of background and/or introductory information that is

    included in the document.

    The NUMBERING and SPECIFICATION STRUCTURAL counts for SARA Requirements.txt are

    are provided by the following tables:

 
NUMBERING STRUCTURE      

SPECIFICATION STRUCTURE
DEPTH  

OCCURRENCE  
DEPTH

OCCURRENCE

----------            

--------------------      
----------       
--------------------

1                       
4             

1                        
0

2                      
13              

2       


11

3                      
43              

3                      
118

4                       
5              

4                       
15

5                       
0              

5                        
0

6                       
0              

6                        
0

7                       
0              

7                        
0

8                       
0              

8                        
0

9                       
0           

9                        
0

                          

-----                         



-----
TOTAL                    

65            

TOTAL                    
144
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    TEXT STRINGS are the number of individual lines of text read by the

    ARM program from the source file.

    UNIQUE SUBJECTS is the count of unique combinations and permutations of

    words immediately preceding imperatives in the source file.  This count

    is an indication of the scope of subjects addressed by the specification.

    Total text strings:  237           Unique Subjects:     96 

    The ratio of the total for SPECIFICATION STRUCTURE to total

    lines of text is an indication of how concise the document

    is in specifying requirements.

    Total for SPECIFICATION STRUCTURE:  144 

    Total text strings:  237 

    RATIO =   0.607594936708861 

    The ratio of unique subjects to the total for SPECIFICATION

    STRUCTURE is also an indicator of the specifications' detail.

    Unique Subjects:  0 

    Total for SPECIFICATION STRUCTURE:  144 
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shall # 1: In Line No. 8, ParNo. 2.1, @ Depth  2

The SARA tool SHALL use Windows 2000 and Windows XP as its host operating systems.

shall # 2: In Line No. 9, ParNo. 2.1, @ Depth  2

SARA SHALL be written using any object-oriented language allowing it to run on the above operating systems.

shall # 3: In Line No. 11, ParNo. 2.2, @ Depth  2

The SARA tool SHALL the able to run on a machine having the following specifications or greater:

shall # 4: In Line No. 15, ParNo. 3., @ Depth  2

There are SHALL be two input mode, static and dynamic.

shall # 5: In Line No. 17, ParNo. 3.1, @ Depth  2

The SARA tool SHALL accept for import a text file containing columns of data separated by the tab key with no column headers.

shall # 6: In Line No. 22, ParNo. 3.2, @ Depth  2

The SARA SHALL provide a grid consisting of rows and columns (table) which allows the user to enter failure data and related metrics by columns at runtime.

shall # 7: In Line No. 23, ParNo. 3.2, @ Depth  2

The user SHALL have the option to open multiple tables.

shall # 8: In Line No. 26, ParNo. 4., @ Depth  2

SARA SHALL implement a dropdown GUI menu.

shall # 9: In Line No. 27, ParNo. 4., @ Depth  2

The menu for SARA SHALL be implemented in the following order presented in this section.

shall # 10: In Line No. 31, ParNo. 4.1.1, @ Depth  3

The New menu SHALL be a submenu of the File menu.

shall # 11: In Line No. 32, ParNo. 4.1.1, @ Depth  3

Clicking on the New menu SHALL allow SARA to create a new data window (table) with default null values in it rows and columns.

shall # 12: In Line No. 33, ParNo. 4.1.1, @ Depth  3

The rows and column SHALL also contain default header titles.

shall # 13: In Line No. 35, ParNo. 4.1.2, @ Depth  3

The Open menu SHALL be a submenu of the File menu.

shall # 14: In Line No. 36, ParNo. 4.1.2, @ Depth  3

Clicking on the Open menu SHALL allow files to be open with the following extensions .sad, .sar, .sag, .txt, and .*.

shall # 15: In Line No. 40, ParNo. 4.1.3, @ Depth  3

The Close menu SHALL be a submenu of the File menu.

shall # 16: In Line No. 41, ParNo. 4.1.3, @ Depth  3

Clicking on the Close menu SHALL allow SARA to close the current live window.

shall # 17: In Line No. 42, ParNo. 4.1.3, @ Depth  3

If there is unsaved contents in the current live window, SARA SHALL ask the user if they wish to save the unsaved content.

shall # 18: In Line No. 44, ParNo. 4.1.4, @ Depth  3

The Save menu SHALL be a submenu of the File menu.

shall # 19: In Line No. 45, ParNo. 4.1.4, @ Depth  3

Clicking on the Save menu SHALL allow SARA to save the content of the current live window using a data, graphical, or report format depending on the type of current window open.

shall # 20: In Line No. 48, ParNo. 4.1.4, @ Depth  3

The file SHALL be save in the current directory the file is in or if the file is being save for the first time SARA should prompt the user for a directory in which to save the file.

shall # 21: In Line No. 50, ParNo. 4.1.5, @ Depth  3

The Save As menu SHALL be a submenu of the File menu.

shall # 22: In Line No. 51, ParNo. 4.1.5, @ Depth  3

Clicking on the Save As menu SHALL allow SARA to save the content of the current live window using a data, graphical, or report format depending on the type of current window open.

shall # 23: In Line No. 52, ParNo. 4.1.5, @ Depth  3

The Save As option SHALL also prompt the user for a file name which to name the file and a directory in which to save the file in.

shall # 24: In Line No. 54, ParNo. 4.1.6, @ Depth  3

The Print Preview menu SHALL be a submenu of the File menu.

shall # 25: In Line No. 55, ParNo. 4.1.6, @ Depth  3

Clicking on the Print Preview menu SHALL allow SARA to display the current live window (data, graphical, or report) in a preview window showing the user what the printed version of the current live window would look like.

shall # 26: In Line No. 57, ParNo. 4.1.7, @ Depth  3

The Print menu SHALL be a submenu of the File menu.

shall # 27: In Line No. 58, ParNo. 4.1.7, @ Depth  3

Clicking on the Print menu SHALL allow SARA to print the current live window.

shall # 28: In Line No. 59, ParNo. 4.1.7, @ Depth  3

In the case of a data window SARA SHALL print the text file associated with that window.

shall # 29: In Line No. 62, ParNo. 4.1.8, @ Depth  3

The Exit menu SHALL be a submenu of the File menu.

shall # 30: In Line No. 63, ParNo. 4.1.8, @ Depth  3

Clicking on the Exit menu SHALL allow SARA close all open windows and then close the application.

shall # 31: In Line No. 69, ParNo. 4.2.1, @ Depth  3

The Undo menu SHALL be a submenu of the Edit menu.

shall # 32: In Line No. 70, ParNo. 4.2.1, @ Depth  3

Clicking on the Undo menu SHALL allow SARA to undo at most the previous ten operations perform on a SARA data window grid.

shall # 33: In Line No. 72, ParNo. 4.2.2, @ Depth  3

The Redo menu SHALL be a submenu of the Edit menu.

shall # 34: In Line No. 73, ParNo. 4.2.2, @ Depth  3

Clicking on the Redo menu SHALL allow SARA to redo at most the previous ten operations perform by the Undo functionality on a SARA data window grid.

shall # 35: In Line No. 75, ParNo. 4.2.3, @ Depth  3

The Cut menu SHALL be a submenu of the Edit menu.

shall # 36: In Line No. 76, ParNo. 4.2.3, @ Depth  3

Clicking on the Cut menu SHALL allow SARA to remove the contents of a SARA graphical window and paste it onto a windows clipboard.

shall # 37: In Line No. 78, ParNo. 4.2.4, @ Depth  3

The Copy menu SHALL be a submenu of the Edit menu.

shall # 38: In Line No. 79, ParNo. 4.2.4, @ Depth  3

Clicking on the Cut menu SHALL allow SARA to copy the contents of a SARA graphical window and paste it onto a windows clipboard.

shall # 39: In Line No. 81, ParNo. 4.2.5, @ Depth  3

The Paste menu SHALL be a submenu of the Edit menu.

shall # 40: In Line No. 82, ParNo. 4.2.5, @ Depth  3

Clicking on the Paste menu SHALL allow SARA to remove the latest contents of a windows clipboard and paste it to another windows clipboard or a SARA graphical window.

shall # 41: In Line No. 84, ParNo. 4.2.6, @ Depth  3

The Clear menu SHALL be a submenu of the Edit menu.

shall # 42: In Line No. 85, ParNo. 4.2.6, @ Depth  3

Clicking on the Clear menu SHALL allow SARA to clear the contents of a SARA data or graphical window, if the window is currently active.

shall # 43: In Line No. 87, ParNo. 4.2.7, @ Depth  3

The Find menu SHALL be a submenu of the Edit menu.

shall # 44: In Line No. 88, ParNo. 4.2.7, @ Depth  3

Clicking on the Find menu SHALL allow SARA to find a specify value in an active SARA data window.

shall # 45: In Line No. 93, ParNo. 4.3.1, @ Depth  3

The Tool Bar menu SHALL be a submenu of the View menu.

shall # 46: In Line No. 94, ParNo. 4.3.1, @ Depth  3

Clicking on the Tool Bar menu SHALL allow SARA to switch between hiding the toolbar and displaying the toolbar in the main menu GUI window.

shall # 47: In Line No. 96, ParNo. 4.3.2, @ Depth  3

The Status Bar menu SHALL be a submenu of the View menu.

shall # 48: In Line No. 97, ParNo. 4.3.2, @ Depth  3

Clicking on the Status Bar menu SHALL allow SARA to switch between hiding the status bar and displaying the status bar in the main menu GUI window.

shall # 49: In Line No. 99, ParNo. 4.3.3, @ Depth  3

The View Data menu SHALL be a submenu of the View menu.

shall # 50: In Line No. 100, ParNo. 4.3.3, @ Depth  3

Clicking on the View Data menu SHALL allow SARA to switch from an active SARA variable window to a window displaying a SARA data window associated with that particular variable window.

shall # 51: In Line No. 102, ParNo. 4.3.4, @ Depth  3

The View Variable menu SHALL be a submenu of the View menu.

shall # 52: In Line No. 103, ParNo. 4.3.4, @ Depth  3

Clicking on the View Variable menu SHALL allow SARA to switch from an active SARA data window to a window displaying the variable(s) (column(s) headers) associated with that particular data window.

shall # 53: In Line No. 108, ParNo. 4.4.1, @ Depth  3

The Insert Rows menu SHALL be a submenu of the Data menu.

shall # 54: In Line No. 109, ParNo. 4.4.1, @ Depth  3

Clicking on the Insert Rows menu SHALL allow SARA to insert rows into an active SARA data window.

shall # 55: In Line No. 112, ParNo. 4.4.2, @ Depth  3

The Insert Columns menu SHALL be a submenu of the Data menu.

shall # 56: In Line No. 113, ParNo. 4.4.2, @ Depth  3

Clicking on the Insert Columns menu SHALL allow SARA to insert columns into an active SARA data window.

shall # 57: In Line No. 116, ParNo. 4.4.3, @ Depth  3

The Delete Rows menu SHALL be a submenu of the Data menu.

shall # 58: In Line No. 117, ParNo. 4.4.3, @ Depth  3

Clicking on the Delete Rows menu SHALL allow SARA to delete rows from an active SARA data window.

shall # 59: In Line No. 120, ParNo. 4.4.4, @ Depth  3

The Delete Columns menu SHALL be a submenu of the Data menu.

shall # 60: In Line No. 121, ParNo. 4.4.4, @ Depth  3

Clicking on the Delete Columns menu SHALL allow SARA to delete columns from an active SARA data window.

shall # 61: In Line No. 124, ParNo. 4.4.5, @ Depth  3

The Sort menu SHALL be a submenu of the Data menu.

shall # 62: In Line No. 125, ParNo. 4.4.5, @ Depth  3

Clicking on the Sort menu SHALL allow SARA to sort the data in a SARA data window on a particular column chosen among the columns in the data window in ascending or descending order.

shall # 63: In Line No. 128, ParNo. 4.4.6, @ Depth  3

The Go To Row menu SHALL be a submenu of the Data menu.

shall # 64: In Line No. 129, ParNo. 4.4.6, @ Depth  3

Clicking on the Go To Row menu SHALL allow SARA to change focus to a particular row requested by the user.

shall # 65: In Line No. 136, ParNo. 4.5.1, @ Depth  3

The Compute menu SHALL be a submenu of the Transform menu.

shall # 66: In Line No. 137, ParNo. 4.5.1, @ Depth  3

Clicking on the Compute menu SHALL allow SARA to transform the data in a SARA data window on a particular column chosen among the columns in the data window.

shall # 67: In Line No. 138, ParNo. 4.5.1, @ Depth  3

Transforms SHALL be multiplication of a column by a scalar, addition and subtraction between two columns, and vector multiplication between two columns.

shall # 68: In Line No. 140, ParNo. 4.5.2, @ Depth  3

The Count menu SHALL be a submenu of the Transform menu.

shall # 69: In Line No. 141, ParNo. 4.5.2, @ Depth  3

Clicking on the Count menu SHALL allow SARA to compute the minimum, maximum, mean, variance, standard deviation, skewness, and kurtosis of the columns in an active data window.

shall # 70: In Line No. 143, ParNo. 4.5.3, @ Depth  3

The Recode menu SHALL be a submenu of the Transform menu.

shall # 71: In Line No. 144, ParNo. 4.5.3, @ Depth  3

Clicking on the Recode menu SHALL display two further submenus namely Into Same Variables and Into Different Variables see the next two subsections.

shall # 72: In Line No. 146, ParNo. 4.5.3.1, @ Depth  4

The Into Same Variables menu SHALL be a submenu of the Recode menu.

shall # 73: In Line No. 147, ParNo. 4.5.3.1, @ Depth  4

Clicking on the Into Same Variable menu SHALL allow SARA to recode a data window column into the same column.

shall # 74: In Line No. 150, ParNo. 4.5.3.2, @ Depth  4

The Into Different Variables menu SHALL be a submenu of the Recode menu.

shall # 75: In Line No. 151, ParNo. 4.5.3.2, @ Depth  4

Clicking on the Into Different Variable menu SHALL allow SARA to recode a data window column into a different column.

shall # 76: In Line No. 160, ParNo. 4.6.1, @ Depth  3

The Descriptive Statistics menu SHALL be a submenu of the Execution menu.

shall # 77: In Line No. 161, ParNo. 4.6.1, @ Depth  3

Clicking on the Descriptive Statistics menu SHALL display a further submenu namely Frequencies see the next subsection.

shall # 78: In Line No. 163, ParNo. 4.6.1.1, @ Depth  4

The Frequencies menu SHALL be a submenu of the Descriptive Statistics menu.

shall # 79: In Line No. 164, ParNo. 4.6.1.1, @ Depth  4

Clicking on the Frequencies menu SHALL allow SARA to provide the user with a window containing checkboxes allowing the user to choose which frequencies that SARA should calculate.

shall # 80: In Line No. 168, ParNo. 4.6.2, @ Depth  3

The Reliability Modeling menu SHALL be a submenu of the Execution menu.

shall # 81: In Line No. 169, ParNo. 4.6.2, @ Depth  3

Clicking on the Reliability Modeling menu SHALL display two further submenus namely Parametric and Nonparametric see the next two subsections.

shall # 82: In Line No. 171, ParNo. 4.6.2.1, @ Depth  4

The Parametric menu SHALL be a submenu of the Reliability Modeling menu.

shall # 83: In Line No. 172, ParNo. 4.6.2.1, @ Depth  4

Clicking on the Parametric menu SHALL allow SARA to provide the user with a window containing checkboxes allowing the user to choose which parametric model that SARA should calculate.

shall # 84: In Line No. 176, ParNo. 4.6.2.2, @ Depth  4

The Nonparametric menu SHALL be a submenu of the Reliability Modeling menu.

shall # 85: In Line No. 177, ParNo. 4.6.2.2, @ Depth  4

Clicking on the nonparametric menu SHALL allow SARA to provide the user with a window containing checkboxes allowing the user to choose between a nonparametric model with or without reliability bounds, using the appropriate columns of an active data window as input the model.

shall # 86: In Line No. 183, ParNo. 4.7.1, @ Depth  3

The Bar menu SHALL be a submenu of the Graph menu.

shall # 87: In Line No. 184, ParNo. 4.7.1, @ Depth  3

Clicking on the Bar menu SHALL allow SARA to use the columns of an active SARA data widow as input to plot a bar graph and display it in a SARA graphical window.

shall # 88: In Line No. 186, ParNo. 4.7.1, @ Depth  3

The editing capabilities of the graph SHALL be cutting, copying, and pasting.

shall # 89: In Line No. 188, ParNo. 4.7.2, @ Depth  3

The Line menu SHALL be a submenu of the Graph menu.

shall # 90: In Line No. 189, ParNo. 4.7.2, @ Depth  3

Clicking on the Line menu SHALL allow SARA to use the columns of an active SARA data widow as input to plot a line graph and display it in a SARA graphical window.

shall # 91: In Line No. 191, ParNo. 4.7.2, @ Depth  3

The editing capabilities of the graph SHALL be cutting, copying, and pasting.

shall # 92: In Line No. 193, ParNo. 4.7.3, @ Depth  3

The Scatter menu SHALL be a submenu of the Graph menu.

shall # 93: In Line No. 194, ParNo. 4.7.3, @ Depth  3

Clicking on the Scatter menu SHALL allow SARA to use the columns of an active SARA data widow as input to plot a scatter plot graph and display it in a SARA graphical window.

shall # 94: In Line No. 196, ParNo. 4.7.3, @ Depth  3

The editing capabilities of the graph SHALL be cutting, copying, and pasting.

shall # 95: In Line No. 198, ParNo. 4.7.4, @ Depth  3

The Histogram menu SHALL be a submenu of the Graph menu.

shall # 96: In Line No. 199, ParNo. 4.7.4, @ Depth  3

Clicking on the Histogram menu SHALL allow SARA to use the columns of an active SARA data widow as input to plot a histogram and display it in a SARA graphical window.

shall # 97: In Line No. 201, ParNo. 4.7.4, @ Depth  3

The editing capabilities of the graph SHALL be cutting, copying, and pasting.

shall # 98: In Line No. 206, ParNo. 4.8.1, @ Depth  3

The Minimize All Windows menu SHALL be a submenu of the Window menu.

shall # 99: In Line No. 207, ParNo. 4.8.1, @ Depth  3

Clicking on the Minimize All Windows menu SHALL allow SARA to minimize all open SARA windows active or inactive.

shall # 100: In Line No. 209, ParNo. 4.8.2, @ Depth  3

The New Data Window menu SHALL be a submenu of the Window menu.

shall # 101: In Line No. 210, ParNo. 4.8.2, @ Depth  3

Clicking on the New Data Window menu SHALL allow SARA to create a new data SARA window and make it the current active window.

shall # 102: In Line No. 212, ParNo. 4.8.3, @ Depth  3

The Cascade menu SHALL be a submenu of the Window menu.

shall # 103: In Line No. 213, ParNo. 4.8.3, @ Depth  3

Clicking on the Cascade menu SHALL allow SARA to display any open SARA data or graphical window(s) in a cascade format view inside the SARA main window.

shall # 104: In Line No. 214, ParNo. 4.8.3, @ Depth  3

Note that SARA SHALL have a multiple document interface (MDI) where SARA main window is the parent window and the data and graphical window(s) are the child window(s).

shall # 105: In Line No. 216, ParNo. 4.8.4, @ Depth  3

The Tile Horizontal menu SHALL be a submenu of the Window menu.

shall # 106: In Line No. 217, ParNo. 4.8.4, @ Depth  3

Clicking on the Tile Horizontal menu SHALL allow SARA to display any open SARA data or graphical window(s) in a tile horizontal format view inside the SARA main window.

shall # 107: In Line No. 218, ParNo. 4.8.4, @ Depth  3

Note that SARA SHALL have a multiple document interface (MDI) where SARA main window is the parent window and the data and graphical window(s) are the child window(s).

shall # 108: In Line No. 220, ParNo. 4.8.5, @ Depth  3

The Tile Vertical menu SHALL be a submenu of the Window menu.

shall # 109: In Line No. 221, ParNo. 4.8.5, @ Depth  3

Clicking on the Tile Vertical menu SHALL allow SARA to display any open SARA data or graphical window(s) in a tile vertical format view inside the SARA main window.

shall # 110: In Line No. 222, ParNo. 4.8.5, @ Depth  3

Note that SARA SHALL have a multiple document interface (MDI) where SARA main window is the parent window and the data and graphical window(s) are the child window(s).

shall # 111: In Line No. 226, ParNo. 4.9.1, @ Depth  3

The Topics menu SHALL be a submenu of the Help menu.

shall # 112: In Line No. 227, ParNo. 4.9.1, @ Depth  3

Clicking on the Topics menu SHALL allow SARA to provide access to the Contents, Index, and Find tabs, which the user can use to find specific help topics.

shall # 113: In Line No. 229, ParNo. 4.9.2, @ Depth  3

The Tutorial menu SHALL be a submenu of the Help menu.

shall # 114: In Line No. 230, ParNo. 4.9.2, @ Depth  3

Clicking on the Tutorial menu SHALL allow SARA to provide the user with a introductory tutorial on the operation of SARA.

shall # 115: In Line No. 232, ParNo. 4.9.3, @ Depth  3

The Home Page menu SHALL be a submenu of the Help menu.

shall # 116: In Line No. 233, ParNo. 4.9.3, @ Depth  3

Clicking on the Home Page menu SHALL allow SARA to provide access to SARA home page, which provides general information about the tool and the organization, which created the tool.

shall # 117: In Line No. 235, ParNo. 4.9.4, @ Depth  3

The About menu SHALL be a submenu of the Help menu.

shall # 118: In Line No. 236, ParNo. 4.9.4, @ Depth  3

Clicking on the About menu SHALL allow SARA to display a popup window, which provides general information about the tool.

will # 1: In Line No. 18, ParNo. 3.1, @ Depth  2

The file WILL be prepared independently from SARA, that is SARA will not interactive participate in the making of this file.

will # 2: In Line No. 18, ParNo. 3.1, @ Depth  2

The file WILL be prepared independently from SARA, that is SARA WILL not interactive participate in the making of this file.

will # 3: In Line No. 46, ParNo. 4.1.4, @ Depth  3

The contents of the window WILL be save using the current file name or a default name if no prior file name was choose for the file.

will # 4: In Line No. 110, ParNo. 4.4.1, @ Depth  3

To bring the Insert Rows submenu into focus the user WILL click on a row header.

will # 5: In Line No. 114, ParNo. 4.4.2, @ Depth  3

To bring the Insert Columns submenu into focus the user WILL click on a column header.

will # 6: In Line No. 118, ParNo. 4.4.3, @ Depth  3

To bring the Delete Rows submenu into focus the user WILL click on a row header.

will # 7: In Line No. 122, ParNo. 4.4.4, @ Depth  3

To bring the Delete Columns submenu into focus the user WILL click on a column header.

will # 8: In Line No. 126, ParNo. 4.4.5, @ Depth  3

To bring the Sort menu into focus the user WILL click on a column header.

will # 9: In Line No. 130, ParNo. 4.4.6, @ Depth  3

To bring the Sort menu into focus the user WILL click on a column header.

should # 1: In Line No. 19, ParNo. 3.1, @ Depth  2

The file SHOULD contain at least one column listing the reliability data (failure data).

should # 2: In Line No. 20, ParNo. 3.1, @ Depth  2

The other optional columns SHOULD contain metrics relating to the failure data.

should # 3: In Line No. 48, ParNo. 4.1.4, @ Depth  3

The file SHALL be save in the current directory the file is in or if the file is being save for the first time SARA SHOULD prompt the user for a directory in which to save the file.

should # 4: In Line No. 60, ParNo. 4.1.7, @ Depth  3

In the case of a graphical window or report window SARA SHOULD print the graph or report contained in the window.

should # 5: In Line No. 64, ParNo. 4.1.8, @ Depth  3

However, before any window containing unsaved data is closed, SARA SHOULD prompt the user to save the data if the user which to do so.

should # 6: In Line No. 164, ParNo. 4.6.1.1, @ Depth  4

Clicking on the Frequencies menu SHALL allow SARA to provide the user with a window containing checkboxes allowing the user to choose which frequencies that SARA SHOULD calculate.

should # 7: In Line No. 166, ParNo. 4.6.1.1, @ Depth  4

SARA SHOULD also provide the user with the capability to print the frequencies as a report.

should # 8: In Line No. 172, ParNo. 4.6.2.1, @ Depth  4

Clicking on the Parametric menu SHALL allow SARA to provide the user with a window containing checkboxes allowing the user to choose which parametric model that SARA SHOULD calculate.

should # 9: In Line No. 174, ParNo. 4.6.2.1, @ Depth  4

SARA SHOULD also provide the user with the capability to print the result of the models as a report.

should # 10: In Line No. 178, ParNo. 4.6.2.2, @ Depth  4

SARA SHOULD also provide the user with the capability to print the result of the model as a report.

should # 11: In Line No. 185, ParNo. 4.7.1, @ Depth  3

SARA SHOULD also provide the user with the capability to print and edit the bar graph.

should # 12: In Line No. 190, ParNo. 4.7.2, @ Depth  3

SARA SHOULD also provide the user with the capability to print and edit the line graph.

should # 13: In Line No. 195, ParNo. 4.7.3, @ Depth  3

SARA SHOULD also provide the user with the capability to print and edit the scatter plot graph.

should # 14: In Line No. 200, ParNo. 4.7.4, @ Depth  3

SARA SHOULD also provide the user with the capability to print and edit the histogram.
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capability to # 1: In Line No. 166, ParNo. 4.6.1.1, @ Depth  4

SARA should also provide the user with the CAPABILITY TO print the frequencies as a report.

capability to # 2: In Line No. 174, ParNo. 4.6.2.1, @ Depth  4

SARA should also provide the user with the CAPABILITY TO print the result of the models as a report.

capability to # 3: In Line No. 178, ParNo. 4.6.2.2, @ Depth  4

SARA should also provide the user with the CAPABILITY TO print the result of the model as a report.

capability to # 4: In Line No. 185, ParNo. 4.7.1, @ Depth  3

SARA should also provide the user with the CAPABILITY TO print and edit the bar graph.

capability to # 5: In Line No. 190, ParNo. 4.7.2, @ Depth  3

SARA should also provide the user with the CAPABILITY TO print and edit the line graph.

capability to # 6: In Line No. 195, ParNo. 4.7.3, @ Depth  3

SARA should also provide the user with the CAPABILITY TO print and edit the scatter plot graph.

capability to # 7: In Line No. 200, ParNo. 4.7.4, @ Depth  3

SARA should also provide the user with the CAPABILITY TO print and edit the histogram.
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can # 1: In Line No. 227, ParNo. 4.9.1, @ Depth  3

Clicking on the Topics menu shall allow SARA to provide access to the Contents, Index, and Find tabs, which the user CAN use to find specific help topics.

