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Tips for working with ePublisher:

	Subject
	Task/Problems
	How

	Tech Support
	7/01/2006
	http://www.webworks.com/support/

	Appendix
	Appdx A still shows in topic
	In the Style Designer, select the Paragraph Styles left tab and then the Appendix style. Click the Options tab. Set Generate output to Disabled from drop-down menu. Repeat this process for the Appendix_name and Appendix_number styles.

	
	Not displaying in OH TOC
	In the Style Designer, select the Paragraph Styles left tab and then the Appendix_name style. Click the Options tab. Set Generate output to Enabled, and Table of contents level to 1.

	New Project
	Opening
	1. Select File > New Project or click the New Project button. The New Project dialog box appears.
2. In the Project name box, enter a name for the project. This name will become the context name for the online help (though you can change the context from within ePublisher Pro) and ePublisher creates a folder for the help output with this name.
3. In the Location box, specify the location where you would like ePublisher to create the new project.
Best practice: Create separate folders for the online help and put the ePublisher files in that folder. Example: <Project Name>\Online Help\<Help Project Name>.
4. Click Use Stationery and then the folder icon to its right. The Open dialog box appears. In the Files of type drop-down list, select ePublisher Standalone Stationery (.wxsp). Navigate to the stationery file and select it. The executable stationery file will have a name like this: WWHelp5.0-9.2.2 CBIIT 08-15-07 Standalone.wxsp. The latest stationery files are on the NCICB network (L:\Technical Writing\Templates).
Best practice: Create a folder on your hard drive for ePublisher stationery files. For example: Templates\ePublisher Stationery. When you copy the stationery files from the network to your hard drive, copy the entire folder; for example, L:\Technical Writing\Templates\WebWorks ePublisher Pro Stationery\WWHelp5.0-9.2.2 CBIIT 08-03-07 Standalone).
5. Click Next.

6. In the New Project Source dialog box, click the Add button, then navigate to the FM book file that will be the source for online help. Click Finish.

	
	Previewing
	Select the FM file you want to preview in the Document Manager and click the Display Preview button.

	
	New project with name of existing project/deleting a project
	To start over with ePub and use the same help project name, you must delete the project with that name first. When you delete an ePublisher project, you do not delete your source FrameMaker files, so you can completely delete your ePub project folder. Locate and delete the parent folder it created for your help project as well as the history (Edit > Preferences > General Tab, Clear List). Then you can start over with the same project name.

	Context Name
	Determining
	Developers must know the context name of a project before they can create the context-sensitive links. The context name is in this file: \WebWorks Help 5.0\{project name}\Output\WebWorks Help 5.0\{project name}\wwhdata\common\context.js.
You can define the context name yourself: Select Format > Merge Settings. Click on the display name for a group, and enter the text you want as context name in the Group Context text box. It will appear in context.js. Names can contain only letters (upper/lowercase), numbers and underscores.

	Conditional text
	Purpose
	When single-sourcing—using the same document as the source of an electronic or printed document and the online help files—you’ll have to customize some of the text so it will be appropriate in the output files. 
Example 1: You probably don’t want many of the figures to display in online help, so you’ll need to apply conditional text to text that refers to them in the FM files. Note: The ePub template has already been configured to exclude figure cross-references in the source document to which the Table Figure format has been applied.

Example 2: Because help is not organized in chapter format, you’ll want to customize certain text to eliminate references to chapters. Some text will be designated as “Print Only” and some designated “Help Only”. Based on how you assign the conditions, the appropriate text, such as chapter titles, will display or be hidden from the specified output files.

	Conditional text (cont’d)
	Setting up
	Note: Several condition tags have already been created in our FM template. This cell text describes how to work with the tags that already exist. To create your own condition tags, see the topic in this document: Images > Hiding images in a pdf from online help.

In FrameMaker: Always work with text symbols showing when you are using conditional text. (Note: A paragraph marker can be conditionalized just like any other text.)
1. Select text that you want to make conditional. 
2. Select Special > Conditional Text. 
3. Select the conditional text name and move it (with arrow or a double-click) to the appropriate scroll list. 

· To include text in a condition, move the condition tag to the In scroll list. 
· To exclude text from a condition, move the condition tag to the Not In scroll list. 
· Condition tags in the As Is scroll list will not be applied or removed.
The WWEP stationery has been modified to exclude Print Only from the output

	
	Assigning
	In FrameMaker: Once you’ve created a condition, click Apply. If text is selected, FrameMaker applies the setting and format to the text. If you have put an insertion point in the document, the settings apply to the text you will type until you move the insertion point or press Enter.

If the text to which you have tried to apply the conditional tag doesn’t show the correct format, click the Show/Hide button in the Conditional Text dialog box. Click both the Show All and Show Condition Indicators radio buttons. Leave these selected for every doc until it’s time to create the pdf. Then go into the same dialog box and hide the condition indicators.

	
	Conditionalizing a text marker
	You might want to hide the entire paragraph from the help or the PDF, making it look like the paragraph before and the one after have nothing in between. Be careful, though. If you unwittingly conditionalize a paragraph marker, you might get one long paragraph where before you intended to have two or more.

	
	Conditional text indicators show in OH output
	To reset the visibility of your conditions, in ePublisher (not the Style Designer), choose Format > Conditions. Clear the Visible checkbox for Print Only and select it for Help Only. Click OK and generate.

To reset the cross-reference rules, in ePublisher (again not the Style Designer) choose Format > Cross Reference Rules. In the Document Type drop-down list, select Adobe FrameMaker. Just for your information, the Adobe FrameMaker (PDF) option applies to PDFs that you create when you generate ePublisher, a feature we do not use.
Maximize the Cross Reference Rules dialog box by finding the arrow cursor on the box border and dragging the box open. Note all cross-reference styles that mention on page <$pagenum>. Delete this phrase from each style where you see it. In my test project those styles were Heading & Page, Page, Table Number & Page, See Heading and Page, Figure Caption & Page, See Step & Page, and Figure Number & Page.
In addition to clicking OK on each condition's dialog box, click OK on the Cross Reference Rules dialog itself. Then generate.

	Context sensitive links
	Assigning Topic Aliases in FM
	Topic aliases must be embedded in FM before generating the online help output in ePub. Topic aliases may not contain spaces except as indicated by underscores. You can only insert topic aliases in heading level paragraphs (Heading 1-4).
To assign topic aliases, in FM:

1. Navigate in the source document to the topic or paragraph that will be used as the help topic. Most often, this is a heading paragraph that will start a unique topic.

2. Insert a TopicAlias marker in the topic or paragraph using the topic alias as the marker value. To do this:

· Place the cursor at the beginning of the topic or paragraph.

· Select Special > Marker.

· In the Marker Type drop-down menu, select Edit…
· Name the marker TopicAlias and click Add. TopicAlias is now the specified Marker Type.

· In the Marker Text pane, enter the appropriate MapID.

· Click New Marker, and save the document. 

	
	Links not working in final deployment. Every link goes to “Welcome to camod” link.  
	· To the developer: Check to see if the “context” used for integration is the same as in the deployed output files. See the Integrating WebWorks ePub Pro 9.2 document (on GForge): https://gforge.nci.nih.gov/docman/index.php?group_id=226&selected_doc_group_id=1142&language_id=1 

· To the developer: Take a look at the {project name}\Output\WebWorks Help 5.0\{project name}\wwhdata\common\topics.js file.  Test the links in that file.  If they are opening the expected topics, then the problem is with the developer’s topic links.
· If #1 and #2 check out, (and for some reviewers, online help is working fine) the problem may be due to Internet caching. Compare OH as it opens in IE, Firefox, and/or Mozilla. If caching is not a problem in one browser, OH may work fine, but not work fine in another for which caching has become a problem.

To solve this:

1. In IE:

a. Go to: Tools > Internet Options. 

b. On the General tab, click Temporary Internet Files > Delete Files. This may take a while.

For a permanent solution in IE

a. On the General tab, click Temporary Internet Files > Settings.

b. Push the Amount of Disk Space to Use indicator all the way to the left (1MB) so the Web site does not save the pages in its storage. You may also want Check for Newer Versions of Stored Pages set to Automatically.

c. In Mozilla:

a. Click Edit > Preferences. 

b. Select the Advances category and click on Cache.

c. Under Select Cache Options, click the Clear Cache button. This may take a while.

d. In the Cache text box, reduce the cache capacity from 50 MB. (I reduced to 5, and it worked.)

e. Leave other default settings as they are, and click OK.

	Cross-references
	Fixing inactive hypertext links
	Hypertext links that you assign the HTML or URL character tag in FM may prove to be inactive in the ePub online help output files. If the HTML or URL character tag is applied to the text in FM, remove that tag, returning it back to default text styles. Then apply the character style again.

	
	Page numbers (for steps) are showing up in OH output
	To reset the visibility of your conditions, in ePublisher (not the Style Designer), choose Format > Conditions. Clear the Visible checkbox for Print Only and select it for Help Only. Click OK and generate.
 

To reset the cross-reference rules, in ePublisher, choose Format > Cross Reference Rules. In the Document Type drop-down list, select Adobe FrameMaker. (The Adobe FrameMaker (PDF) option applies to PDFs that you create when you generate ePublisher—but that’s not the way we create our PDFs.)
 

1. Maximize the Cross Reference Rules dialog box by finding the arrow cursor on the box border and dragging the box open. 

2. Note all cross-reference styles that mention on page <$pagenum>. Delete this phrase from each style where you see it. 

Those styles include Heading & Page, Page, Table Number & Page, See Heading and Page, Figure Caption & Page, See Step & Page, and Figure Number & Page. 

	Generating Output
	
	1. From the toolbar, click the Generate All button.
2. To view the output in the browser, select the top-level group in the Document Manager, and double-click the index.html file located under the Files directory in the Output Explorer pane.

	Hotspot (Dropdown)
	Creating
	A dropdown hot spot is a link to text that is hidden in an online help topic; it can be opened by clicking a small arrow above the topic. It can be hidden again by re-clicking the arrow.

1. Decide on a consistent way to use the hotspot. Enter the text that will introduce it, such as “The following topics are grouped according to your FIREBIRD role. Click the arrow to the right of the headings below to expand or collapse the procedure”. 
2. Then enter the headings that will introduce the hotspot, such as “For curators”. In FM, assign the appropriate style such as Body Text Drop Down style (the same as Body Text + bold) to the phrases that begin procedures. Do not end such phrases with a colon, because a tiny arrow follows the text. 

3. Apply Body Text Drop Down to the phrase topic paragraph that follows.
4. At the end of the procedure, following the last period and before the paragraph marker for that step, insert the DropDownEnd marker. Don't add any text in the Marker Text box. 

5. Assign HelpOnly conditional text to the appropriate phrases, such as the “Click the arrow…” sentence and perhaps even the following paragraph.
For tables, modify in this way:

1. For step two, assign Table Caption Indent Drop Down style.
2. In the table itself, apply the usual text styles such as Table Text and Table Header.
3. After the table caption (title), add a Body Text No Space paragraph.  Assign a tiny font size to reduce the space of that line.
4. Insert the DropDownEnd marker into the Body Text No Space paragraph. Make the paragraph Help Only so that you don’t see the extra white space in the PDF.
When you generate the help, the dropdown hotspots will default to the closed position. The arrow does not show until generated in ePub. 

	Images
	Hiding images in pdf from online help.
	1. Create a conditional tag in FM called Print Only and apply that tag to the graphic. To do this, open the FM document containing the graphic.

2. Select Special > Conditional Text. In the Conditional Text dialog box, click Edit Condition Tag. In the Tag box, enter Print Only. Select a color for this style. Click Set.

3. Before closing the Conditional Text dialog box, select the graphic in the document. In the Conditional Text dialog box, move the Print Only tag to the In: box. Click Apply.

Note: The WWEP stationery has been modified to exclude Print Only from the output.

	Images (cont’d)
	Improving image resolution
	While it's best to use Frame to resize graphics for a document, it's NOT good to do that for OH.  If you resize in a graphics program then pull them in, they're fine; if you try to resize in the authoring program you get a bunch of yuck.

1. Resized my images - snag-it was giving me issue, so I used the MSOffice Picture Manager, oddly enough, selected Resize then selected Web Large.  Saved the images -- same name so they'd be right there in Frame.

2. Went to each of my Anchored frames, selected the frame, hit Esc + m + p to "form fit" the frame to the graphic, then right-clicked the frame, selected Anchored Frame and made it "Insert Below Current Line"

3. Saved the file.

4. Opened Webworks.  In one of the properties (View > Style Settings?? soemthing like that) i clicked on Graphics on the left and then properties on the right and the second option from the top is "By reference graphics use document dimensions" - that is enabled in our template.  Disable it.  That's becuase it causes Frame and WW to again, resize the images which rasterizes them.  You've already resized them so you don't need the program(s) to do it for you.

5. Generate help.  Admire your work.

	Integrating ePub online help into software
	For successful integration
	Maintain existing directory structure as it is in output files.

	Layout
	Repositioning graphic objects (lightbulb note)
	1. In Style Designer, select Note paragraph style.

2. On the Properties tab, choose Bullet and choose Note in the drop-down menu for Character Style.

3. On the Character Styles tab, choose Note from the list of styles. 

4. In the right panel, choose HTML and change these properties.

HTML > Positioning:  Left = -20 px; Top = 5 px; Type = Relative
5. Close the Style Designer and regenerate the output.

	
	Space before/after lightbulb note
	When a Note paragraph comes before a Sidewords paragraph, it's best to put an empty paragraph before the Sidewords paragraph. Otherwise the Sidewords sit on top of the Note. Better yet, don’t use the Sidewords style at all if you plan to convert it to online help. Use Note Main Body instead.
 

The bottom margin of the paragraph before the Note plays a role in how much white space is there. In a situation where the white space is still too much or too little even after you apply the new stationery, might need to modify a single paragraph in the Document Designer in ePub, rather than apply a new definition to a style throughout the project. 

	Modifying Output
	Style Designer
	Modifies all content associated with a particular style.

1. Click the Style Designer button or choose View > Style Designer. You can select Paragraph, Character, Table, Marker, or Page styles to modify.

2. Select Paragraph Styles. Changes you make to Default style will affect all other styles.

3. To change font, click Font properties Options button.

4. From the Installed Fonts list, select font and click the Forward button to move it to selected fonts list. Click OK
5. Under Font Properties, select size, and other appropriate changes. 

6. During this time, you can place your cursor in text in the preview pane to select it. To see what tag was applied from the source file, select a paragraph or heading, etc., and the tag applied to that text displayed in the Document Designer’s Apply Style field.

7. Select View > Style Designer to refocus on the Style Designer. 

8. Under paragraph Styles, locate and select the style you want to modify.

9. Under Properties, select what you want to change. Example, select Text. Under General, select the Color field, and select the arrow to open the Color options dialog box.

	
	Document Designer
	Changes are localized to specific individual content selections made in the Preview Pane. Changes here override formatting you have applied using the Style Designer. 

	Page
	Overriding setting that creates new page for each heading level.
	You must do this locally to selected text using the Document Designer (note that this is different than Document Manager) in ePub. This overrides any settings made in the Style Designer for that text. You will be turning off the page break setting on selected headings (topics) so that they would not be their own topics but rather part of the higher level topic. To do this, follow these steps:
1. In the Document Manager, select the document that holds the high level topic.
2. Right-click and select Display Preview. A preview window should open to the right of the Document Manager. 
3. Choose View > Document Designer.
4. Put your cursor in the 1st sub-level title text in the preview window. Note that the Document Designer updates to reflect the properties associated with that style.
5. In the Document Designer, click the Options tab. 
6. From the Page Break Priority list, select None. 
7. Do steps 5 and 6 for other topic(s) as well.
8. Generate your project.
 

Note that any changes you make locally using the Document Designer do not get saved to a stationery file, so our stationery (template) will still break at each heading style by default. Only changes to the Style Designer get saved to a stationery file.

	Popups
	Creating popups, such as definitions
	If you are not creating popups but rather would just like to create a hyperlink, ignore step 1 and use the URL character style in step 3.
To create popups to glossary terms: 

1. In FrameMaker, first apply the Popup Text paragraph style (available in the template) to the glossary definition text.
2. Insert the Specify Named Destination hyperlink marker into that paragraph (Special > Hypertext, select the Specify Named Destination marker and use the format newlink linkname [just a name you select]).
3. Select the popup origin (such as the glossary term mentioned outside of the glossary) text. Apply the Popup character style to it. 
4. With that text still selected, insert the Jump to Named Destination hyperlink marker (Special > Hypertext, select the Jump to Named Destination marker and use the format gotolink Filename.fm:linkname).
5. Check in FM to see that the links resolve correctly. Press ctrl + alt when the link begins. Should jump to glossary.
After you generate output, check that the popups were created successfully. Hover the mouse over the popup text. If a small yellow window does not appear, check the settings for the Popup Text paragraph style in ePub. To do this, open the Style Designer and find the Popup Text paragraph style. Click the Options tab. For the Popup option, confirm that Define is selected. If Define with No Output is selected, glossary cells will be blank.
As a last resort, if the popup bubble is not opening, and you know the links are working properly, try creating a new OH project. In one case, the popup then worked correctly.    

	Related Topics buttons
	Creating
	In FrameMaker:

1. At the appropriate place, insert cross references with heading text for the topics (which are section headings) that you want included in the related topics button. 
2. Select all and apply the Related Topics tag.
In WebWorks ePub:

1. Open the Style Designer.

2. Select the paragraph style assigned to the Related Topics lists.

3. Select the Options tab, Related-topic option.

4. Click on the drop-down arrow to select the related-topic options.

· Choose Define for the relation topics list to display both within the body of the topic and when the related topics button is clicked.

· Choose Define-no-output for the related topics list to display only when the related topics button is clicked.

When the project is generated in WebWorks, the button will appear.

	Scan
	When to scan source files from ePub
	Anytime you add or delete docs, styles, conditions, markers or variables in FM, re-scan in ePub so it detects the changes.

You don’t need to re-scan if you just change text or headings, etc.

	Source Files
	Deleting a file (such as chapter) in source document does not remove it from output files
	With the project open in ePub, choose Project > Scan All Documents. Then regenerate.

	Tables
	Defining TableBullet style
	· For Table Bullet paragraph tag, assign ePub TableBullet Character Style in the Character Style drop-down. In the character style properties for Table Bullet, set the HTML positioning for Left to 10 px and Type to Relative. 

	
	Table Text too close to borders
	1. Open Style Designer

2. In Paragraph Style tab, select Table Text style.

3. On Properties tab, select Margins. Set the margins for Left, Right, Top and Bottom at 3 pt. 

	
	Column Width
	1. In Style Designer, select Tables tab.

2. Select Default > Options > Use Document Cell
Width = Disable
3. To make columns self-adjust, disable Options: Use document cell
widths. 

4. To make tables self-adjust, set Properties: HTML: Size: Width to a
percent, such as 90%. 

	
	Placed in right spot in FM, and in wrong spot in OH output.
	In this case, a series of steps occured in the proper order in the FM file. Step 4 is followed by a table that is referred to in the step. Step 5 follows the table.  In the help output, Step 4 was followed by Step 5 which is followed by the table. 

Table anchor was at the end of a figure caption (which is of course hidden in OH. I moved table anchor to next line and applied Help Only condition to that line (which is blank). Regenerated OH, and table was now in the correct position.

	Text
	Realigning
	1. Select View > Style Designer. Maximize the window and scroll down to Chapter Name (for example) or other heading tag in the Paragraph Style list.
2. On the Properties tab, select Text.
3. Find the Alignment section. From the Horizontal list, select your desired justification. Close the Style Designer (you do not need to save anything). When you next generate your project you will see the change you made to this style.

	Template
	Applying new to existing project
	You can’t apply a new template to an existing project. You must either modify an existing project using the Style or Document Designers, or create a new project with the template you want selected initially.

	TOC
	Getting TOC to always display on the browser, even from first topic
	This is controlled on the programmer's side. The view with the TOC to the left is called the frameset view, and the view we currently have for a context-sensitive topic is called the single topic view. The value single=true in the help call makes the single topic view happen. For example, this is the call that used in the SPORE  project:
<a href="javascript:openHelpWindow(

'webHelp/SPORE_1.0/index.html?single=true&amp;context=SPORE_1.0&amp;topic=
edit_spore_grant_data')" class="helpText">Help</a>
This help call built into the application results in topic view (a single context-sensitive topic page without a TOC).

This is the same help call, modified so that the single context-sensitive help topic appears in frameset view (with the TOC):
 

<a href="javascript:openHelpWindow('webHelp/SPORE_1.0/index.html?&amp;context=
SPORE_1.0&amp;topic=edit_spore_grant_data')" class="helpText">Help</a>
The single=true is removed, presumably resulting in the frameset view. You need to continue to include the part of the call that begins with context= or else you will see the top-level view of the help.

	Topic Aliases
	Verifying if they made it into ePublisher 9.2.
	1. Select Project > Generate Reports > Topics (and repeat for any other report types -- or select All). ePP will scan all files and generate all reports.
2. In the Document Manager window, select the Project name (the top of the tree).
3. Select View > Output Explorer. You see nodes for Navigation and Reports, plus a sub-node for each of the Report types. Double-click the Topics Report to open. Make sure that the HTML files mentioned in the Description column are correct. You can double-click them to confirm. These files display in order of the topics in the book.

	Variable
	Wrong Product Variable imported into ePub template
	Topics in OH display wrong product name. Variable is set up properly in FM, but Project Name in OH output shows differently, such as “CGEMS Online Help” when we are in caLAB.

1. In ePub, select Format > Variables.

2. In Conditions and Variables dialog box, select line of incorrect variable, and select the Use Document Value checkbox.
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