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Data Entry Procedures

Chapter 1.   Data Entry Overview

The Budget Execution Procedures perform the following functions:

u Identify transactions and inquiry tables associated with the Budget Execution subsystem

u Identify transactions and inquiry tables associated with tracking authority, commitments, obligations, and expenditures related to appropriated funds

u Provide procedures to enter and process budget transactions

A. Data Entry Documents and Budget Levels

Funds are distributed in HUDCAPS by processing budget documents. Some levels require both an entry transaction and approval transaction prior to further distributing the funds. The following table lists the necessary transactions for each budget level.

HUDCAPS Budget Level
HUDCAPS Budget Term
Entry Document(s)
Approval Document

1
Appropriation
Appropriation/ Apportionment(AA), and Appropriation Transfer (TA) 
Appropriation Transfer Approval (TC)

2
Apportionment
Appropriation/ Apportionment (AA) 
Apportionment Approval (PA)

3
Advice of Allotment
PAS Advice of Allotment (B4) or Budget Execution (BE)
- None -

4
Distribution to Program/Object Class
PAS Distribution to Pgm/Obj Cls (B5) or Budget Execution (BE)
- None -

5
Distribution to Program
PAS Distribution to Program (B6) or Budget Execution (BE)
- None -

6
Assignment/Operating Budget (level 1)
Assignment/Operating Budget (SA)
- None -

7
Assignment/ Operating Budget (level 2)
Assignment/Operating Budget (SA)
- None -

8
Assignment/Operating Budget (level 3)
Assignment/Operating Budget (SA)
- None -

Use the Budget Execution Document (BE) for entry of the administrative funds.

B. Verify Fund Availability

Prior to processing a HUDCAPS budget document, fund availability should be verified by scanning the budget inquiry table which corresponds to the preceding budget level.

HUDCAPS Budget Level 
HUDCAPS 

Budget Term
HUDCAPS Table 

1

2

3

4

5

6

7

8
Appropriation

Apportionment

Advice of Allotment

Distribution to Program/Object Class

Distribution to Program

Assignment/Operating Budget (Level 1)

Assignment/Operating Budget (Level 2)

Assignment/Operating Budget (Level 3)
APPR

APOR

ALOC

SALC

ALLT

SASP

SASP

SASP

Note
Users can not verify fund availability at the Appropriation level, as it is the first level of distribution.
Chapter 2. Appropriation/Apportionment for No-Year and     Multi-Year Funds

A. Appropriation/Apportionment (AA) Document for Appropriation of No-Year and Multi-Year Funds

1. Record Appropriation Amount to Master Fund Code With an AA Document 

a. Perform the following steps to process an Appropriation/Apportionment (AA) document to record appropriation amount:

(1) Select File from the Main menu.

(2) Select New from the File menu.

(3) From the Document drop-down list box, select Appropriation/Apportionment (AA).

(4) Enter the Document ID.

Note
All AA document IDs referencing a no-year or multi-year fund code include the allotment holder (ex: CFO, HSNG, CPD, PIH, etc.) in the first field. The last digit of the current fiscal year, the third and fourth digit of the fund code and the # sign are included in the second field (Example:  CFO 0HA#).  By entering the # sign, the system will assign the next available sequentail number for the document ID prefix entered.



(5) Select OK or press the Enter key.

Enter the following fields on the Appropriation tab:



Field
Description

(1) Budget Fiscal Year(s)
For a no-year fund enter the last two digits of the Budget Fiscal Year.  For a multi-year fund enter the last two digits of the Beginning Budget Fiscal Year and the Ending Budget Fiscal Year.

(2) Fund
Enter the appropriate master fund code for the no-year fund, or click on the search icon for a listing of valid fund codes.

(3) Budget Line Action
Select Add/Activate if this is the first AA document for the BFY/fund code, or select Change if previous AA documents have been processed for the BFY/fund code.

(4) Appropriation Trans Type
Enter 01 for an apportioned no-year fund. 

Enter 03 for an inactive, unanticipated, unapportioned no-year fund.

Enter 04 for an unapportioned no-year fund.

Enter MY for an apportioned multi-year fund.

(5) Appropriation - Inc/Dec Amount
Enter the appropriation amount from the SF-132.

(6) Select Document from the Main menu.

(7) Select Edit from the Document menu.

(8) View the message area at the bottom of the window for warning or error messages and make the necessary changes.

Note
If an error message occurs, use the Online Error Guide by double clicking on the error message. If unable to resolve the error with the Online Error Guide, call the HUDCAPS Help desk.

(9) Select Document from the Main menu.

(10) Select Process from the Document menu.

(11) When the message, “The document has been accepted, do you want to close the document?” appears, select Yes to close the document, or No to keep the document open.

Refer to Appendix A for examples of populated documents for a No-Year fund and a Multi-Year fund.  See Example A-1.A.

Create Component Fund Record with an AA Document

b. Perform the following steps to process an Appropriation/Apportionment (AA) document to establish each of the Component funds:

(1) Select File from the Main menu.

(2) Select New from the File menu.

(3) From the Document drop-down list box, select Appropriation/Apportionment (AA).

(4) Enter the Document ID.

Note
All AA document IDs referencing a no-year or multi-year fund code include the allotment holder (ex: CFO, HSNG, CPD, PIH, etc.) in the first field. The last digit of the current fiscal year, the third and fourth digit of the fund code and the # sign are included in the second field (Example:  CFO 0HA#).



(5) Select OK or press the Enter key.

Enter the following fields on the Appropriation tab:



Field
Description

(1) Budget Fiscal Year(s)
For a no-year fund enter the last two digits of the Budget Fiscal Year.  For a multi-year fund enter the last two digits of the Beginning Budget Fiscal Year and the Ending Budget Fiscal Year.

(2) Fund
Enter the component fund code, or click on the search icon for a listing of valid fund codes.

(3) Budget Line Action
Choose Add/Activate to add a new budget line.

(4) Appropriation Trans Type
Enter 01 for an apportioned no-year fund. 

Enter 03 for an inactive, unanticipated, unapportioned no-year fund.

Enter 04 for an unapportioned no-year fund.

Enter MY for an apportioned multi-year fund.

(5) Inc/Dec Amount
Enter zero or leave blank (the system will interpret the Inc/Dec Amount as zero when this field is left blank).

Note
No data needs to be entered on the Apportionment tab.

(6) Select Document from the Main menu.

(7) Select Edit from the Document menu.

(8) View the message area at the bottom of the window for warning or error messages and make the necessary changes.

Note
If an error message occurs, use the Online Error Guide by double clicking on the error message. If unable to resolve the error with the Online Error Guide, call the HUDCAPS Help desk.

(9) Select Document from the Main menu.

(10) Select Process from the Document menu.

(11) When the message, “The document has been accepted, do you want to close the document?” appears, select Yes to close the document, or No to keep the document open.

 Refer to Appendix A for examples of populated documents for a No-Year fund and a Multi-Year fund.  See Example A-1.A.

Appropriation Transfer (TA) Document for Transfer from a Master Fund to a Component Fund

2. Transfer Funds from Master Fund to Component Fund(s) with a TA Document

a. Perform the following steps to process an Appropriation Transfer (TA) document to transfer funds from the Master fund to the Component fund(s) for no-year funds:

(1) Select File from the Main menu.

(2) Select New from the File menu.

(3) From the Document drop-down list box, select Appropriation Transfer (TA).

(4) Enter the Document ID.

Note
All TA document IDs referencing a no-year or multi-year fund code include the allotment holder (ex: CFO, HSNG, CPD, PIH, etc.) in the first field. The last digit of the current fiscal year, the third and fourth digit of the fund code and the # sign are included in the second field (Example:  CFO 0HA#). 


(5) Select OK or press the Enter key.

b. Enter the following fields on the Main tab:



Field
Description

Default Line Action
Select New.

Document Type
Select Budget Authority.

Transfer Total
Enter the amount to be transferred.

Transfer Authorizing Document
Enter SF-132, appropriation symbol and approved date.

Refer to Appendix A for example of populated document.  See Example A-1.B.

Enter the following fields on the Details tab:



Field
Description

Line Number
Enter the appropriate three digit line number (001 for the first line, 002 for the second line, etc.).

Transfer Amount
Enter the dollar amount to transfer.

Inc
Select the radio button to increase funds.

From Trans Type
Enter the transaction type MC for current year funds.

From Srce Year(s)
Enter the last two digits of the Budget Fiscal Year.

From Fund
Enter the fund code of the Master fund from which the amount is being transferred.

To Trans Type
Enter the transaction type MC for current year funds.

To Srce Year(s)
Enter the last two digits of the Budget Fiscal Year.

To Fund
Enter the fund code of the Component fund to which the amount is being transferred.

Select Document from the Main menu.

Select Edit from the Document menu.

View the message area at the bottom of the window for warning or error messages and make the necessary changes.

Note
If an error message occurs, use the Online Error Guide by clicking on the error message. If unable to resolve the error with the Online Error Guide, call the HUDCAPS Help desk.

Select Document from the Main menu.

Select Process from the Document menu.

When the message, “The document has been accepted, do you want to close the document?” appears, select Yes to close the document, or No to keep the document open.

Refer to Appendix A for example of populated document.  See Example A-1.B.

 Appropriation Transfer Approval (TC) Document 

3. Approve Transfer with TC Document

a. Perform the following steps to process the Appropriation Transfer Approval (TC) Document:

(1) Select File from the Main menu.

(2) Select New from the File menu.

(3) From the Document drop-down list box, select Appropriation Transfer Approval (TC).

(4) Enter the Document ID.

Note
All TC document IDs referencing a no-year or multi-year fund code include the allotment holder (ex: CFO, HSNG, CPD, PIH, etc.) in the first field. The last digit of the current fiscal year, the third and fourth digit of the fund code and the # sign are included in the second field (Example:  CFO 0HA#).  By entering the # sign, the system will assign the next available sequential number for the document ID prefix entered.



(5) Select OK or press the Enter key.

Enter the following fields on an Appropriation Transfer Approval (TC) document:



Field
Description

Transfer Document
Enter the document ID of the Appropriation Transfer (TA) being approved. Enter TA in the first box and the Document ID in the second box.

Transfer Total
Enter the total dollar amount to approve (as entered on the Main tab of the TA).

Treasury Voucher Number
Enter SF-132.

Action
Select Approve Anticipated Amounts or Reject and Clear Anticipated Amounts.

Select Document from the Main menu.

Select Edit from the Document menu.

View the message area at the bottom of the window for warning or error messages and make the necessary changes.

Note
If an error message occurs, use the Online Error Guide by double clicking on the error message. If unable to resolve the error with the Online Error Guide, call the HUDCAPS Help desk.

Select Document from the Main menu.

Select Process from the Document menu.

When the message, “The document has been accepted, do you want to close the document?” appears, select Yes to close the document, or No to keep the document open.

Refer to Appendix A for example of populated document.  See Example A-1.C.

B.  Appropriation/Apportionment (AA) Document for Apportionment of No-Year and Multi-Year Funds

Funds transferred from a master fund code to a component fund code must be apportioned by the component fund code. Funds are not apportioned by the master fund code. Apportionment of component fund codes cannot take place until funds have been transferred to the component fund code by an Appropriation Transfer (TA) Document, and have been approved of by an Appropriation Transfer Approval (TC) Document. Subsequently, an Appropriation/Apportionment (AA) Document is required to apportion funds transferred to component fund codes of no-year appropriations.

1. Verify Funds with APPR 


a. The Appropriation Query (APPR) is displayed as follows:

(1) Select Options from the Main menu.

(2) Select Tables and Queries from the Options menu.

(3) Click on the Category drop-down list and select Budget Execution.

(4) Select the Appropriation Query (APPR).

(5) Choose the OK button.



(6) Enter the last two digits of the Budget Fiscal Year in the Budget Fiscal Year(s) field, and enter the fund code in the Fund field.

(7) Select Actions from the Main menu.

(8) Select Display from the Actions menu.

(9) Verify funds available in the Unapportioned Appropriation field.

Refer to Appendix A for example of populated document.  See Example A-8.A.

2. Apportion Funds with an AA Document

a. Perform the following steps to process an Appropriation/Apportionment (AA) document:

(1) Select File from the Main menu.

(2) Select New from the File menu.

(3) From the Document drop-down list box, select Appropriation/Apportionment (AA).

(4) Enter the Document ID.

Note
All AA document IDs referencing a no-year or multi-year fund code include the allotment holder (ex: CFO, HSNG, CPD, PIH, etc.) in the first field. The last digit of the current fiscal year, the third and fourth digit of the fund code and the # sign are included in the second field (Example:  CFO 0HA#).  By entering the # sign, the system will assign the next available sequential number for the document ID prefix entered.



(5) Select OK or press the Enter key.

b. Enter the following fields on the Appropriation tab:



Field
Description

Budget Fiscal Year(s)
Enter the last two digits of the Budget Fiscal Year.

Fund
Enter the Component fund code.

Budget Line Action
Defaults to Add/Activate. Select Change.

Note
Do NOT enter any additional data on the Appropriation tab.

Refer to Appendix A for example of populated documents for a No-Year fund and a Multi-Year fund.  See Example A-1.D.

c. Select the Apportionment tab and enter the following fields:



Field
Description

Apportionment Transaction Types Period 1-4
Enter PA (Pending Apportionment).

Apportionment Distribution Inc/Dec
Enter the dollar amount of the transaction. The amount must include a decimal and cents (enter two zeros if it is an even dollar amount). Apportion all program funds in quarter 1, and distribute administrative funds by the applicable quarters. 

Select Document from the Main menu.

Select Edit from the Document menu.

View the message area at the bottom of the window for warning or error messages and make the necessary changes.

Select Document from the Main menu.

Select Process from the Document menu.

When the message, “The document has been accepted, do you want to close the document?” appears, select Yes to close the document, or No to keep the document open.

Refer to Appendix A for example of populated document.  See Example A-1.D.

Apportionment Approval (PA) Document for No-Year and Multi-Year Funds

3. Approve Pending Apportionment with PA Document

a. Perform the following steps to process the Apportionment Approval (PA) document to approve and post pending apportionment amounts:

(1) Select File from the Main menu.

(2) Select New from the File menu.

(3) From the Document drop-down list box, select Apportionment Approval (PA).

(4) Enter the Document ID.

Note
All PA document IDs referencing a no-year or multi-year fund code include the allotment holder (ex: CFO, HSNG, CPD, PIH, etc.) in the first field. The last digit of the current fiscal year, the third and fourth digit of the fund code and the # sign are included in the second field (Example:  CFO 0HA#).  By entering the # sign, the system will assign the next available sequential number for the document ID prefix entered.



(5) Select OK or press the Enter key.

Enter the following fields on the Apportionment Approval (PA) document:



Field
Description

Budget Fiscal Year(s)
Enter the last two digits of the Budget Fiscal Year.

Fund
Enter the fund code, or click on the search icon for a listing of valid fund codes.

Budget Approval
Defaults to Approve Pending Amounts. Must select Reject and Clear Pending Amounts to reject and clear pending amounts.

Approval Transaction Type
Enter AP.

Post YTD Budget Authority
Select the box (ensure that there is an x in the box).

Posting Transaction Type
Enter 01.

Apportionment Period
Enter the appropriate period through which you are posting authority. Valid values are 1, 2, 3, 4.

Select Document from the Main menu.

Select Edit from the Document menu.

View the message area at the bottom of the window for warning or error messages and make the necessary changes.

Note
If an error message occurs, use the Online Error Guide by double clicking on the error message. If unable to resolve the error with the Online Error Guide, call the HUDCAPS Help desk.

Select Document from the Main menu.

Select Process from the Document menu.

When the message, “The document has been accepted, do you want to close the document?” appears, select Yes to close the document, or No to keep the document open.

Refer to Appendix A for example of populated documents for a No-Year fund and a Multi-Year fund.  See Example A-1.E.

4. Verify Approval with Apportionment Query (APOR)

The Apportionment Query (APOR) is used to review information about the status of an apportionment including the year-to-date  apportioned, committed, obligated, and expended amounts.

a. The Apportionment Query (APOR) is displayed as follows:

(1) Select Options from the Main menu.

(2) Select Tables and Queries from the Options menu.

(3) Click on the Category drop-down list and select Budget Execution.

(4) Select the Apportionment Query (APOR).

(5) Choose the OK button.



(6) Enter the last two digits of the Budget Fiscal Year(s) in the Budget Fiscal Year(s) field (for a multi-year fund, enter the last two digits of the beginning year and the last two digits of the ending year), and enter the fund code in the Fund field.

(7) Select Actions from the Main menu.

(8) Select Display from the Actions menu.

Refer to Appendix A for example of populated document.  See Example A-9.A.

(9) Click on the Distribution tab to view fund availability in the Quarterly Apportionments Approved field(s).



Refer to Appendix A for example of populated document.  See Example A-9.B.

Chapter 3.    Appropriation/Apportionment Annual Funds

A. Processing an Appropriation/Apportionment (AA) Document for Annual Funds

1. Record Appropriation Amount with an AA Document 

a. Perform the following steps to process an Appropriation/Apportionment (AA) document to record appropriation amount:

(1) Select File from the Main menu.

(2) Select New from the File menu.

(3) From the Document drop-down list box, select Appropriation/Apportionment (AA).

(4) Enter the Document ID.

Note
The AA Document ID referencing an annual fund includes the last digit of the current fiscal year, the last 4 digits of the Treasury symbol and the # sign in the second field (Example:  CFO 00143#). By entering the # sign, the system will assign the next available sequential number for the document ID prefix entered.



(5) Select OK or press the Enter key.

Enter the following fields on the Appropriation tab:



Field
Description

Budget Fiscal Year(s)
Enter the last two digits of the Budget Fiscal Year(s).

Fund
Enter the appropriate fund code for the annual fund, or click on the search icon for a listing or valid fund codes.

Budget Line Action
Select Add/Activate if this is the first AA document for the BFY/fund code, or select Change if previous AA documents have been processed for the BFY/fund code.

Appropriation Trans Type
Enter transaction type 01. 

Appropriation - Inc/Dec Amount
Enter the appropriation amount from the SF-132.

Refer to Appendix A for example of populated document.  See Example A-2.A.

b. Select the Apportionment tab and enter the following fields:



Field
Description

Apportionment Transaction Types Period 1-4
Enter PA (Pending Apportionment).

Apportionment Distribution Inc/Dec
Enter the dollar amount of the transaction. The amount must include a decimal and cents (enter two zeros if it is an even dollar amount). Apportion all program funds in quarter 1, and distribute administrative funds by the applicable quarters. 

Select Document from the Main menu.

Select Edit from the Document menu.

View the message area at the bottom of the window for warning or error messages and make the necessary changes.

Select Document from the Main menu.

Select Process from the Document menu.

When the message, “The document has been accepted, do you want to close the document?” appears, select Yes to close the document, or No to keep the document open.

Refer to Appendix A for example of populated document.  See Example A-2.A.

B.  Apportionment Approval (PA) Document for Annual Funds

1. Approve Apportionment with PA Document

a. Perform the following steps to process the Apportionment Approval (PA) document to approve and post pending apportionment amounts:

(1) Select File from the Main menu.

(2) Select New from the File menu.

(3) From the Document drop-down list box, select Apportionment Approval (PA).

(4) Enter the Document ID.

Note
The PA Document ID referencing an annual fund includes the last digit of the current fiscal year, the last 4 digits of the Treasury symbol and the # sign in the second field (Example:  CFO 00143#). By entering the # sign, the system will assign the next available sequential number for the document ID prefix entered.



(5) Select OK or press the Enter key.

Enter the following fields on the Apportionment Approval (PA) document:



Field
Description

Budget Fiscal Year(s)
Enter the last two digits of the Budget Fiscal Year(s). 

Fund
Enter the fund code, or click on the search icon for a listing of valid fund codes.

Budget Approval
Defaults to Approve Pending Amounts. Must select Reject and Clear Pending Amounts to reject and clear pending amounts.

Approval Transaction Type
Enter AP.

Post YTD Budget Authority
Select the box (ensure that there is an x in the box).

Posting Transaction Type
Enter 01.

Apportionment Period
Enter the appropriate period through which you are posting authority. Valid values are 1, 2, 3, 4.

Select Document from the Main menu.

Select Edit from the Document menu.

View the message area at the bottom of the window for warning or error messages and make the necessary changes.

Note
If an error message occurs, use the Online Error Guide by double clicking on the error message. If unable to resolve the error with the Online Error Guide, call the HUDCAPS Help desk.

Select Document from the Main menu.

Select Process from the Document menu.

When the message, “The document has been accepted, do you want to close the document?” appears, select Yes to close the document, or No to keep the document open.

Refer to Appendix A for example of populated document.  See Example A-2.B.

2. Verify Approval with Apportionment Query (APOR)

The Apportionment Query (APOR) is used to review information about the status of an apportionment including the year-to-date  apportioned, committed, obligated, and expended amounts.

a. The Apportionment Query (APOR) is displayed as follows:

(1) Select Options from the Main menu.

(2) Select Tables and Queries from the Options menu.

(3) Click on the Category drop-down list and select Budget Execution.

(4) Select the Apportionment Query (APOR).

(5) Choose the OK button.



(6) Enter the last two digits of the Budget Fiscal Year(s) in the Budget Fiscal Year(s) field and enter the fund code in the Fund field.

(7) Select Actions from the Main menu.

(8) Select Display from the Actions menu.

Refer to Appendix A for example of populated document.  See Example A-9.A.

(9) Click on the Distribution tab to view fund availability in the Quarterly Apportionments Approved field(s).



Refer to Appendix A for example of populated document.  See Example A-9.B.
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