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Part I

• Introduction to ISAW for New Users
– This section teaches how to download and 

install ISAW and how to use ISAW with the 
sample data files included in the distribution.  
It demonstrates the use of viewers, operators 
and scripts.



Install ISAW
• Ensure that Java is installed on your system

– the Java Runtime Environment (JRE) must be 
installed before installing ISAW. Java distributions are 
different for different platforms (see 
http://java.sun.com/j2se/ ), but the same ISAW 
installer works on all platforms 

• Download and install ISAW per instructions 
(0Readme.txt)  on the ISAW ftp site 
ftp://zuul.pns.anl.gov/isaw
– Because of the size of the files, be patient when 

downloading and opening them.



The ISAW ftp site



Run ISAW
• Run ISAW following the instructions in “Test 

Installation of ISAW” in the “0Readme.txt" file.
• The first time you run ISAW, the IsawProps.dat 

file will be created in your home directory.  This 
file will contain default locations for various files 
and directories used by ISAW, plus viewer 
defaults, etc.

• Choose "Edit Properties File" from the file menu 
to view and/or edit this file.  Choose “save and 
exit” to save your changes. 



A sample IsawProps.dat



Load some data
• From the "File" menu on the 

menu bar, select "Load Data", 
"Local" and select 
"sepd16837.run" from the file 
dialog box.

• Note that In the tree view,  the 
file name SEPD16837.RUN 
appears.  

• Click on the "pushpin" icon at 
the left of this filename to 
expand the view, then click on 
the icon to the left of 
H1_SEPD16837 to show the 
groups.  You may need to 
change component sizes by 
dragging the stippled bars to 
see details



View Attributes
• Click on the DataSet 

H1_SEPD16837 and the 
"Attributes" tab.

• Note the attributes information 
for the DataSet, then click on 
Group #1 and note the group 
attributes.   Detector ID's 1 
through 80 (1:80) are summed 
together in group 1.

• Click on Group 5 and see how 
non-contiguous ID's are listed.



Display an Image View

• Click on DataSet H1_SEPD16837, then select 
"Image View" from the "View" menu.

• Note the four bands of color in the image view.  
The horizontal axis refers to time-of-flight and 
the color indicates intensity.  The four color 
bands represent the four detector groups.   For 
DataSets with more groups, narrower bands will 
appear, down to one pixel wide.  If the number of 
groups/spectra exceeds the number of vertical 
pixels, scroll bars will appear.



ISAW Image View



Test Cursor Interaction
• Put the cursor over the image and drag it to 

different positions while holding down the left 
mouse button.

• Notice how the readout information in the lower 
right changes as the cursor moves.  Also notice 
that the lower graph changes when you point at 
different detector groups.

• Notice that the Attributes display on the ISAW 
GUI also responds to the cursor pointing at 
different groups.



Test arrow keys

• Use the up and down arrow keys to move 
between detector groups.  Notice that the 
cross hairs move exactly one group for 
each click.

• You can also move the cross hairs left and 
right using the arrow keys.

• Arrow key movements will leave the cross 
hairs on the display.



Transform X Axis
• Select "Axis Conversions" from the "View" menu 

and select convert to d-spacing.
• Use the cursor to find a good range of d-values 

and change the range by clicking in the range 
following "Angstroms" in the upper right of the 
image view and editing the numbers.  A colon 
separates the minimum and maximum values.

• You can also use an operator selected from the 
menu bar sub menus to convert axes.  This 
creates a new DataSet and puts it in the 
"Modified" folder of the tree view.



Test zoom function
• Hold down the middle mouse button and drag 

the cursor over the image to select an area to 
zoom into.  Double-click on the image to 
unzoom.  Select again to zoom multiple times.

• If you don't have a middle button, use the shift 
key with the left mouse button to select the zoom 
region.

• The graph region will not change until you drag 
the cursor on the image with the left mouse 
button down.



View all data points
• In the default image view the data is 

compressed horizontally to allow the full 
spectrum to be shown in the view area.  To see 
all points, select "Horizontal Scroll" from the 
"Options" menu.  You will now probably need to 
use the scroll bar to see all of the data for each 
spectrum.

• Uncheck "Horizontal Scroll" to return to the 
default (compressed) view.

• From the View menu on the image view, select 
"Axis Conversions" "None" to return to time-of-
flight axes.



Test Viewer Controls

• There are several display controls on the right of 
the image display.
– “num steps” is initially equal to the number of 

channels of data, but the data may be rebinned into 
fewer steps by editing the number.

– The “Brightness” slider controls image brightness.  
The lower half of the brightness bar above the slider  
shows the scale colors for negative numbers.

– The “Auto-Scale/%(max)” slider controls the 
percentage of maximum for the graph display.



Test Scrolled Graph View
• With H1_SEPD16837 still highlighted on the tree view, 

create a "Scrolled Graph View" from the "View" menu, or 
select “Additional View” from the View menu and use the 
View menu a second time to change the view type.

• Drag the new view window so both views can be seen.
• In the scrolled graph view, the spectrum for each 

detector group can be seen individually by dragging the 
scroll bar.

• Drag the cursor over the scrolled graph view and watch 
the response on the Graph Data cursor readout and the 
Attributes panel of the ISAW GUI.



Scrolled Graph View



Spectra selection
• Spectra can be marked 

as "Selected" through the 
tree view, image view, or 
scrolled graph view.  
– On the tree view, spectra 

are "selected" through a 
right-click operation as 
shown at the right.

– On the viewers, the spectra 
are "selected" through 
typing "S" to select a single 
spectrum or "shift-S" to 
select a range of spectra.



Image View selected graphs



“GRX_Y” Table View
• With H1_SEPD16837 still highlighted, select two or more 

spectra/groups.  On the menu bar, choose “Selected 
Table View“ and “GRX_Y” from the "View" menu.  In this 
view, spectra are listed one at a time, serially.

• The first column is the x value (initially time-of-flight) and 
the second column is the counts or other intensity value.  
The second selected spectrum will be listed after the first 
and so on.  

• Click on “Options” and “Show Errors” on the table view 
menu bar.  Before any data manipulations, the errors are 
just the square root of the counts in each channel.



“GRX_Y” Table View



“Parallel y(x)” Table view

• Use the View menu to choose “Parallel y(x)”
from the Selected Table View menu.

• In the “Parallel y(x)” view, ISAW will attempt to 
list selected spectra/groups in parallel columns 
following the x value column.  Empty cells may 
appear due to differences in X axes for different 
spectra/groups.  This view can follow the pointed 
at cursor position from other views.



Image view selected graphs

• When there are spectra selected, the 
image view graph area shows up to 16 of 
the selected spectra plus the spectrum 
pointed at by the cursor.  

• Try the different options under "Options", 
"Graph Selected (16 Max)".

• Use the Viewer “File” menu to close the 
DataSet viewers.



Load spectrometer data

• Use the ISAW GUI File menu to load file 
HRCS2447.RUN.

• Click on the push-pin icons to expand the 
tree view of the file, then select DataSet 
H1_HRCS2447.

• Compare the “Conversion” operations for 
this DataSet with the operations for 
DataSet H1_SEPD16837.



Spectrometer/Diffractometer 
operations

• The operations menu 
adjusts to the 
selected DataSet, so 
each DataSet has 
different operations.

• Note the difference in 
operations for 
spectrometer and 
diffractometer 
DataSets.



Load large DataSet
• Use the file menu to load file GLAD6942.RUN, 

click on the push pin to expand the tree view and 
select DataSet H1_GLAD6942. 

• Note that this DataSet has almost a thousand 
groups/spectra. 

• In Attributes for the groups, note that many of 
the groups (spectra) include data from a number 
of detector elements.

• When many large data sets are loaded, Java 
may run out of memory.  If this ever happens, 
stop and restart ISAW.



H1_GLAD6942 views 

• Create an Image View of H1_GLAD6942. 
• Create an additional view which is a 3D View of 

H1_GLAD6942 
• Click on the title bar and drag  the 3D view to 

uncover the Image View. 
• Notice how the 3D view changes as you adjust 

the view controls. 
• Notice how the VCR-like controls at the bottom 

allow you to step through frames/time-channels.



Image and 3D views 



Test 3D View 

• Drag the cursor over the Image view and notice 
the response on the cursor readout area, the 3D 
View, and the ISAW GUI Attributes display. 

• Select the "GLAD" link from the "Instrument Info" 
submenu of the ISAW GUI "View" menu. 

• On the 3D view, change the azimuthal angle to 
about 100 degrees and the altitude to about 45 
degrees, then compare the instrument sketch 
with the 3D view. 



GLAD 3D View and sketch 

3D view of GLAD6942.RUN Sketch of GLAD instrument



Scripts

• Scripts simplify operating on a large 
number of files or repeating complex 
operations.

• Download files: gppd11472:11603.run 
from the "MoreSampleData" folder at 
ftp://zuul.pns.anl.gov/isaw/
– These files are a parametric study of one 

sample



Use a Script to merge files
• Select the ISAW GUI "Scripts" tab.
• Select "Open Script" and open the "merge90_4" script.
• Select "Run Script" and enter 11472:11603 between the 

square brackets.  Make sure "instrument" is "GPPD".
• ISAW should start loading 132 files (on Windows, watch 

the DOS window for load messages).
• When loading finishes, an image display showing one 

group (angle -95 to -85) from each run should appear.
• Select "EXIT" on the script dialog box.
• Use the cursor to zoom in and examine the phase 

transition.



Image view of phase transition



Connect to live data server 

• From the ISAW menu 
bar, select File, Load 
Data, Live, DMIKK.

• DMIKK is a test data 
server.

• Select the tab labeled 
“DMIKK live data“. 

• Click the "Show" 
button on dataset #1. 



View Live Data 

• When the show or 
auto buttons are 
clicked on the live 
data server panel, an 
image view is 
generated.

• To copy the live data 
set to the ISAW tree, 
click "Record" 



Load Remote NeXus File 

• From the ISAW menu bar, 
select File, Load Data, 
Remote, Test(dmikk-Isaw) 

• Enter file name 
lrcs3000.nxs. 

• Wait for "Operation 
completed" message 

• Exit "LoadRemote" 
Operation and view dataset 
H1_lrcs3000 

• NeXus files can also be 
loaded through an NDS 
server, but this is much 
slower.



LRCS3000 from Remote NeXus 
File



View a Log File

• Load the file hrcs3118.sdds
– (you will have to change the file filter in the file 

chooser to allow seeing sdds files)
• Expand the tree node for the file and 

select the sample temperature dataset
• Create an image view or scrolled graph 

view of the dataset
• Drag the cursor over the plot and notice 

the readout of temperature versus time



An IPNS temperature log file



View Pulse Height Spectra
• Download the file new_smarts-o4.12.o2.nxs.gz 

from “More Sample Data” on zuul and unzip it.
• Load the file new_smarts-o4.12.o2.nxs
• Expand the tree view to show the datasets 

included in the file
• Click on the DataSet “pulse_heights”
• Create an image view of the specified dataset
• Notice the typical pulse height shape of the 

spectra
• Also notice that this is data from LANSCE!



Pulse Height data from LANSCE



View LANSCE SMARTS Data
• Click on the “data” smarts DataSet
• Create an image view
• This is data from the SMARTS instrument at 

LANSCE (Los Alamos).
• Choose “View”,  “Axis Conversions”, 

“d-spacings”
• By looking at all spectra you can see that the 

lines are curved--indicating a calibration 
problem, but this was their first data file in this 
format.



SMARTS Data



View Area Detector Data
• Load file SCD06496.RUN
• Select DataSet H1_SCD06496
• Create a Contour View which shows time slices 

of the area detector surface
• The cursor interaction in this view now works the 

same as the other views
• Use the arrow buttons to step to frame 38 to 

compare with the image on the next slide. You 
can step one slice at a time (>) or continuously 
(>>).  Clicking on “>>” a second time pauses 
stepping.



Area Detector View



Part II

• Be an ISAW Developer!
– Teaches more advanced users how to write 

scripts and operators.  This requires use of 
the Java Software Developer Kit (SDK).  This 
section teaches how to modify and recompile 
operators, and how to find documentation on 
using existing operators in scripts.

– This section uses MS Windows examples, but 
most parts apply to other platforms.



Be an ISAW Developer!

• Install the Java Developer Kit
– Download the Java Standard Edition (j2se) 

Software Developer Kit (SDK) without 
NetBeans from http://java.sun.com/j2se/

– Install the SDK using the installation 
instructions for your computing platform

– The j2se download page at the time this was 
written is shown on the next slide which 
highlights areas of interest.



The j2se SDK download page



Test the Java compiler
• Create a command window at the ISAW folder 

(If you have the PowerToy “Command Prompt 
Here” installed in Windows, you can create a 
command window by right-clicking on the ISAW 
folder icon and selecting “Command Prompt 
Here”.)

• Enter the command “javac” in the command 
window
– This is the Java compile command.
– If the software developer kit is installed correctly, you 

should get Java compiler information.  If you don’t, 
correct the installation.



Unpack the ISAW jar files
• Enter the command “jar –xvf Isaw.jar”

• Repeat for the “jhall.jar” file in the ISAW 
distribution.

• Edit the Isaw_exec.bat file and add “rem” in 
front of the first java command and remove the 
“rem” from the second java command.
– This will cause the compiler to look in the folders 

before looking in the jar files for sources.



Modify an Operator
• Edit the “HelloOperator.java” file in the 

“Operators” folder in the ISAW directory.
• Find the “getResult” method 

– (find public object getResult)
• Change the return text from “Hello” to “Good 

day”.
• From the ISAW folder command window, enter 

the command: 
“javac Operators/HelloOperator.java”

• This should produce a new version of 
“HelloOperator.class”



Test new Operator from ISAW GUI
(Windows platforms)

• Double-click on Isaw_exec.bat to start the 
ISAW GUI.

• Select “Macros”, then “Generic” and “Hello 
Operator”.

• Click the “Apply” button.
• Your modified return text should appear.



Determine the command for scripts

• Start the “Hello Operator” dialog box as in 
the last slide.

• Click the “Help” button.
• Scroll to the top of the Help Window.
• Notice the “Command:” specification 
“SayHello(String Name)”

• This tells you how to use the command in 
a script



Write to Status pane
• From the tabbed panes in the ISAW GUI, select 

the tab “Scripts”
• In the “Prgm Editor” pane enter

Display SayHello(“your name”)

• Click on the “Run Script” tab
• The Status pane should show a message with 

the text from the operator.
• Also try it with “Display SayHello()”
• Also use the immediate pane to enter the same 

command.



Write to command window

• Change “Display” to “Echo” in the 
script.

• Put parentheses around the command and 
text—for instance:
Echo (SayHello(“Master”) )

• Run the modified script
• Try with text added--for instance:

Echo (SayHello(“Master”) & “ How may I serve you?”)



Load DataSets
• Open the script “LoadTree.iss”
• The three lines starting with “$” will generate a dialog 

box to request parameters
• The first argument has a type, “DataDirectoryString”, 

which will result in a Browse button on the prompt, while 
the other two are just Strings.  

• These three parameters are combined in the “load”
command to make a complete file specification.

• The “load” command is a built in subroutine of the ISAW 
command processor.  For documentation, click on the 
“Help” item on the ISAW menu bar and select 
“Command pane”



Script variable types
• String (see LoadTree.iss)
• int (see find_multiple_peaks.iss)
• Float (see Denn1.iss)
• Array (see AutoplotSA.iss)
• Choice (see ChoiceTest.iss)
• Boolean (see find_multiple_peaks.iss)
• InstrumentNameString (see AutoplotSA.iss)
• DataDirectoryString (see convert_gsas.iss)
• LoadFileString (see find_multiple_peaks.iss)
• SaveFileString (see efficiency.iss)
• MonitorDataSet (see find_peaks.iss)
• SampleDataSet (see find_peaks.iss)
• ServerTypeString ( see SUMRUNS.iss)



Loading DataSets

• The first argument to the load command is 
a file name

• The second is a variable to receive the 
array of DataSets from the file.  The return 
value is the number of DataSets loaded 
from the file.

• The “LoadTree.iss” script also illustrates 
how to “send” a DataSet from a script to 
the ISAW GUI tree view.



Send DataSet to Viewer

• A script can send a DataSet to a specific 
viewer.  For viewer names, see the View 
menu.
– In LoadTree.iss, add the line:
display(vnam[i],“Image View")
after the “send” line.

• Run the script again and notice that image 
views of each DataSet are generated.


