
CM/ECF New Features - Version 3.2

Cascading Menu System

Search Feature for Menus and Docket Events

Event Searches during Docketing 

View Multiple Documents for Single Docket Entry

View and/or Download All Documents for Multiple Docket Entries

Produce Appendix (single PDF filed that includes complete docket sheet and images of
documents selected)

Hyperlinks to Other Documents in CM/ECF

Hyperlinks Between Documents Filed in CM/ECF

Pop Up Calendars

Docket Report Features

Case Opening

Claims/Creditors

Claims Register

Utility Features

Miscellaneous



Cascading Menus

The user has the option to use the new cascading menus or use the existing menus (See Figure 1)

Cascading menus allow the user to display itemos on a cm/ecf menu by hovering over its name
on the main blue bar.   A down arrow next to the categories Bankruptcy, Adversary, Reports and
Utilities indicates they have a sub-menu and therefore the cascading feature is available.

Some sub-menus may have more sub-menus which are indicated by the arrow to the right of the
menu name.   By pointing to the arrow to the right of the menu name, the sub-menu will display.

The original menus used in previous releases is still available by just clicking on the blue menu
bar item.

The menu items can also be displayed by pressing the ALT key along with the letter that is
underlined in the menu name (i.e. ALT - u will expand the Utilities menu). 



Search Option

The user has the ability to use the search option in the menus and event search.

Clicking on  Search on the main blue menu bar displays the “Search Menus and Events”
window. 

In the search window enter all or part of the name of the desired event. For example, to find a
Motion for Relief from Stay event, type “stay” in the box and press Enter or click the magnifying
glass to begin the search.

Menu Search Results for ‘stay’

CM/ECF will display a list of events that contain the entered word or string of words and the
menu on which the event can be found. To begin filing, click on the appropriate event.



Event Search During Docketing

When the user must select from a long list of events to docket (such as motions/applications
category), you no longer need to scroll through the list. A text box is provided above the list.

Enter the first few letters of the event and the full list will be replaced by a list of events which
match.



Highlight the event from the list and click Next.
To select multiple events, hold the CTRL key and click each event. Each event the user
highlights will appear in the Selected Events box.



View Multiple Documents for a Single Docket Entry

All the documents for a single docket entry can be combined and viewed in one PDF document.
When a document number hyperlink is clicked from the docket report, a list of the main
document and its attachments is displayed with “View All” and “Download All” buttons
appearing at the bottom of the list.

Selecting View All will combing the main document and its attachments into one PDF
document. Selecting Download All will combine the main document and its attachments into a
ZIP file.

A single PACER billing receipt page with multiple receipts (one per document) and a
confirmation button.

If the combined documents exceed 10 MB, an error will display. If the combined size of all the
documents on the docket report is close to or over 10 MB, the size of the document for each
docket entry is displayed in the new column so you may determine the combination of
documents that can be selected without exceeding 10 MB. 



View and/or Download all Documents for Multiple Docket Entries

This feature will enable users to view or download multiple docket entries in one PDF document.
Select Reports,  Docket Report, View Multiple Documents.

Selecting View Multiple Documents will create a new column in the docket report as seen
below.

Place a checkmark in the box for each docket entry to be included in the PDF document.

Select View Selected or Download Selected.

Selecting “View Selected” will combine the main document and its attachments into one PDF
document. “Download Selected” will combine the main document and all attachments into a ZIP
file. 

A single PACER billing receipt page is displayed with multiple receipts (one per document) and
a confirm button.

If the combined documents exceed 10 MB, an error will display. If the combined size of all the
documents on the docket report is close to or over 10 MB, the size of the document for each
docket entry is displayed in the new column so you may determine the combination of



documents that can be selected without exceeding 10 MB. 



Create Appendix

This features enables users to create a single PDF file that includes a complete docket sheet and
images of the documents selected.

This feature can be selected on the Docket Report page. Select Reports, Docket Report and place
checkmark in the box for Create Appendix. Once create appendix is selected, the “format”
options will disappear, and “view multiple documents” is disabled.



After the user selects run report a docket sheet will display with a checkbox next to each entry.
The user should place a checkmark in the box for each entry to be included in the appendix.
A “footer format” box allows specification of th text that should appear on each PDF page.

The final result is one PDF document with a complete docket sheet and the documents for the
docket entries selected. 



Hyperlinks in CM/ECF 

This new feature allows users to file documents which include hyperlinks to a previously filed
document in the same case or another case, as well as to a document being filed in the same
submission as attachments. 

When creating a single PDF from multiple documents using the “View Multiple Documents” or
“Create Appendix” option of the docket report.  Each of the documents in the consolidated PDF
may include links to other CM/ECF documents.  The links in the consolidated document are the
same as those in the original documents, so clicking one will display the referenced document in
a new window, even if the referenced document is included in the consolidated PDF. Therefore,
a PACER user would incur an additional fee.  To avoid additional fees, PACER users should
check the link description and look for the referenced document in the consolidated document
rather than clicking the link.

Creating a Hyperlink to a document already filed in cm/ecf.

A link can be made to another document in any database in the Federal Courts - District,
Bankruptcy or Appellate. 

1. Access cm/ecf and run the docket report for the case in which the document was filed.

2.  Locate the document from the docket entries.

3. Copy the URL of the document to the clipboard.  To do this, hover over the document link and
click the right mouse button, select Copy Shortcut or Copy Link Location.

4.  Open the word processing document. In the document, highlight the text for which you wish
to create the hyperlink.

5. Create the hyperlink using directions below depending on if you are using Word or
WordPerfect.

Creating the hyperlink if you are using WordPerfect:
A. Select Hyperlink form the Tools menu.

B. The Hyperlink Properties window opens. Paste the URL into the
Document/Macro box with CTRL-V.

Creating the hyperlink if you are using Microsoft Word:

A. Select Hyperlink form the Insert menu.



B The Insert Hyperlink window opens. Paste the URL into the Address box with
Ctrl-V.

6. If the citation is to a specific page in the document, append to th URL “?page=”, followed by
the page number e.g.,

https://ecf.njb.uscourts.gov/docs1/001010708409?page=23

Note: Because of incompatibility between the browser and Adobe Acrobat, the page number
pointer will not work if the user opens the document with Internet Explorer.

7.  Click OK button to close the hyperlink dialog box. 

8.  They hyperlink text is now underlined and blue (or whatever color is specified for links),
indicating a hyperlink has been created.  Save the word processing document.

9.  Produce the PDF file.

You must not use the “print” option in the word processing program, since the hyperlinks will
not be preserved (you may use this option if there are no hyperlinks in the document).  Instead,
use one of these methods:

a. If you are using a version of WordPerfect that has a “Publish to PDF” or “Publish to..”
option on the File menu, select it (if it is “Publish to..”, select “PDF” from the choices). 
If you are using an earlier version of WordPerfect that does not have one of these
options, you must upgrade to version 11 or higher.

b. If you are using a version of Word that has an “Adobe PDF” menu, select the “Convert to
Adobe PDF” option from it. 

c. If you are using Word but do not have an “Adobe PDF” menu, close the Word file. Open
the Adobe Acrobat application. From the File menu, select Create PDF and From
File...:

A navigation window opens; use it to find and select the document, then click Open.
A series of windows open as the document is converted.  When the conversion is complete, the
document is displayed in an Adobe Acrobat window, with an active hyperlink.

Close the Acrobat file, Respond “Yes” to the “Save Changes” prompt and store the PDF file in
appropriate directory.

10.  Docket an event and upload the PDF file to the docket entry as usual.

Creating a Hyperlink Between Documents Filed in the Same Event:



Instead of linking to a previously-filed document, you can link a document to one which will be
filed in the same event (e.g. create a hyperlink in the main document to an attachment).  The
procedure is different, since the referenced document does not yet have an address in cm/ecf.
When you create a link, it points to the referenced document where it exists on your local PC or
server; when the documents are filed in cm/ecf, the link is converted to a cm/ecf URL.

1.  Create PDF versions of any secondary documents (e.g. attachments) which will be referenced
by the main document.  See Step 9 in previous section.

2.  Open the main document in the word processing program (i.e. the document that will have
hyperlinks to the secondary documents).

3.  Select the text in the main document that will be displayed as the hyperlink.

4.  Create the hyperlink:

If you are using WordPerfect

Select Hyperlink from the Tools menu.
Click the folder icon to the right of the Document/Macro box:
Navigate to the referenced PDF document and click Select; click OK in the Hyperlink
Properties box.

If you are using Microsoft Word

Select Hyperlink from the Insert menu
Navigate to the referenced PDF document, select it, and click OK 

5.  If the citation is to a specific page in the document, append to the URL “?page=”, followed 
by the page number e.g.

https://ecf.njb.uscourts.gov/docs10010010708409?page=23

Note: because of an incompatibility between the browser and Adobe Acrobat, the page
number pointer will not work if the user opens the document with Internet Explorer.

6. Click the OK button to close the hyperlink dialog box.

7.  The hyperlink text is now underlined and blue (or whatever color is specified for links),
indicating a hyperlink has been created.  Save the word processing document.

8.  Follow the instructions in Step 9 of the previous section to produce the PDF version of the
“main” document.

9.  Docket an event and upload the main document and attachments as usual.



Calendar Pop Up

Clicking on the calendar button will display a pop up calendar which allows users to select a
hearing date from the calendar.

The calendar will highlight non working days in green.

The calendar will put a black box around the current date.

The arrows allow you to move to another month.



New Docket Report Features

Link to Associated Cases on a Bankruptcy Case Docket

Links to lead and associated cases on adversary proceeding docket report



Case Opening

Chapter Designation defaults to blank, rather than Chapter 7



Claims/Creditors

Holding the cursor over the creditor’s name will display the number of claim(s) filed by that
creditor.

Previously, if no creditors were returned form a search, an empty selection list was displayed.
Now a “no creditors found” message is shown.

There is also a “change search criteria” link which returns the user to the “search for creditor”
screen.

Previously, a claim was accepted as amending another claim only if the creditor selected for the
amended claim was the same as the creditor for the original claim. Now, any creditor can be
selected.

When filing an amended claim - there is a 



“Find” button next to the “Amends Claim #” field

New options have been added to the Proof of Claim screen so the user can easily clear values
that were copied from the amended claim



Claims Register

If a claim has been transferred, or the claimant has been changed via editing - a “Claimant
History” link is now displayed in the creditor section

A “details” link is now included in the “history” section for each claim

Details Link

Details Page



Court Information 

A summary of information is now displayed when the user clicks on the CM/ECF logo on the
left of the blue banner menu.



Internet Payments Due

A total of the amount due has been added to the report.



Miscellaneous Changes

SSN/ITIN
Throughout the application the label for Social Security Number has been changed to SSN/ITIN
since an Individual Tax Identification Number may be used instead of an SSN.

Tax ID/EIN
Throughout the application the label for a Tax Id Number has been changed to show that it is
also referred to as an Employer Identification Number.

Fees
Do not click X in upper right corner to close a fee window. Click Pay Now or Continue Filing. If
the window is closed by clicking on the X, subsequent pop up windows will no longer appear.
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