Список изменений

6.0.22 (2017-07-13)

  • Поиск через сервисы Amazon удален из программы после того, как Amazon аннулировала учетную запись проекта
  • Теперь все списки сохраненных шаблонов могут хранить до 50-и значений
  • Обновлена поддержка формата OPUS
  • Локализация: Bulgarian, German

6.0.21 (2017-05-11)

  • Поддержка DSDIFF файлов (.DFF)
  • Поддержка новых полей ID3v2 и MP4 тэгов, добавленных в iTunes
  • Новая функция isnumber(x)
  • Возможность переименовать поле в расширенном редакторе тэгов
  • Исправлена проблема с возможным повреждением FLAC файлов при отсутсвии в файле области резервирования
  • Временно отключен поиск по сайтам Amazon вне зоны US
  • Локализация: Japanese, Italian, Finnish, Catalan

6.0.20 (2017-03-09)

  • Новая функция для быстрого форматированя значения поля в редакторе
  • Теперь можно исключить поле из обработки, добавив знак минус к названию
  • Регулярные выражения теперь работают с многострочными полями
  • Исправлена проблема с чтением ID3v2 полей INVOLVEDPEOPLE и MUSICIANCREDITS
  • Обновлена поддержка FLAC и OPUS
  • Локализация: Bulgarian

6.0.19 (2017-01-18)

  • Новые функции: $swapprefix, $stripprefix
  • Улучшено распознавание APE тэгов
  • Исправлена проблема с управлением шаблонами для функции переменования папки по тэгу
  • Исправлена некорректная сортировка списка файлов по пользовательским колонкам
  • APEv2 тэги теперь являются основными для TTA файлов
  • Теперь программа при запуске открывает переданный в параметрах файл, а не сканирует папку в которой он лежит
  • Поддержка формата WavPack 5.0
  • Локализация: Turkish

6.0.18 (2016-12-05)

  • Чтение текстовых блоков с неуникальной маркировкой из ID3v2 тэгов (улучшение совместимости)
  • Ускорена обработка картинок для OGG и OPUS файлов
  • Новая переменная %_bitrate_type% для идникации VBR или CBR (если доступно)
  • Исправлена проблема с изменением описаний картинок в редакторе
  • Теперь устаревшие поля СOVERART из Vorbis Comments будут преобразованы в поля METADATA_BLOCK_PICTURE при сохранении
  • Теперь поле ENCODER для Vorbis Comments не сопоставляется с ENCODEDBY для избежания возможных проблем с декодированием MQA файлов

6.0.17 (2016-11-07)

  • Исправлена проблема с масштабированием интерфейса на hiDPI режимах с версии 6.0.16
  • Обновлена поддержка формата MPEG4
  • Улучшена поддержка сервиса Discogs
  • Новая функция $char(x) для получения символа юникода по его коду

6.0.16 (2016-10-20)

  • Программа теперь умеет работать с нестандартными FLAC файлами и пытается исправить их при сохранении
  • Переменные и функции теперь можно использовать для фильтрации
  • Мастер автонумерации теперь умеет брать формат из начального значения
  • Арифметические функции: $add(x,y) $sub(x,y) $div(x,y) $mod(x,y) $mul(x,y)
  • Логические функции: $greater(x,y) $longer(x,y)
  • Исправлена ошибка с инициализацией списка жанров в портативной версии
  • Локализация: Catalan, Greek

6.0.15 (2016-09-12)

  • Автонумерация дисков на основе групп файлов
  • Новая функция $cutmix(x) для удаления части строки в скобках с информацией о ремиксе
  • Улучшено поведение функции переименования папки по тэгу
  • Улучшено взаимодействие с сервисом MusicBrainz
  • Редактор теперь запоминает состояние скрытых блоков
  • Исправлена проблема с чтением настроек прокси
  • Исправлено чтение скриптов экспорта для некоторых ситуаций
  • Вновь доступен переключатель счетчика треков в редакторе (он был полезен в некоторых случаях)
  • Локализация: Chinese Simplified

6.0.14 (2016-07-14)

  • Функция поиска дубликатов возвращается с новыми возможностями
  • Теперь можно настраивать список предустановленных жанров
  • Поддержка синтаксиса преобразования регистра для замен в регулярных выражениях
  • Новая индикация проблем, связанных с доступом к файлам
  • Обновлены некоторые настройки по умолчанию
  • Локализация: Japanese, Turkish, Spanish

6.0.12 (2016-06-15)

  • Функция фильтрации списка файлов теперь позволяет искать по точному совпадению, учитывать регистр и использовать регулярные выражения
  • Пользовательские столбцы теперь имеют свойство выравнивания текста и могут быть удалены по отдельности
  • Регулярные выражения теперь проверяются на ошибки для предотвращения зависания программы
  • Исправлена проблема с удалением кадра ID3v2 TDAT при сохранении
  • Исправлено ошибочное удаление обложек из OGG файлов при выполнении некоторых операций, изменяющих тэг
  • Конфигуратор преобразований был немного упрощен
  • Более комфортная работа в hiDPI режимах
  • Подчищено содержимое файлов перевода
  • Локализация: French, Czech

6.0.11 (2016-06-01)

  • Теперь возможно использовать собственные шаблоны для столбцов в списке файлов
  • Команда "Поменять кодировку" теперь поддерживает изменение всех полей тэга за раз
  • Исправлена ошибка при Копировании/Вставке полей тэга в расширенном редакторе
  • Исправлены проблемы с обработкой пустых значений в функциях
  • Фреймы ID3v2.3 TYER/TDAT теперь объединяются в поле YEAR и выводятся как YYYY-MM-DD
  • Локализация: Spanish

6.0.10 (2016-05-22)

  • Обновлена поддержка формата ALAC
  • Исправлено экранирование некоторых символов в функциях
  • Исправлена проблема с удалением полей тэгов в расширеном редакторе тэгов
  • Испрвлена ошибка с сохранением параметров прокси
  • Исправлена проблема с настройкой юникода для ID3v2 тэга
  • Изменена логика чтения/записи тэгов WMA
  • Локализация: Polish, Greek, Japanese, Swedish

6.0.8 (2016-04-26)

  • Мастер массовой загрузки текстов из файлов
  • Исправлена ошибка с обрезанием наименований альбомов для FreeDB
  • Обновлён сценарий Discogs cleanup

6.0.7 (2016-04-19)

  • Переменная %_filedate_create% возвращает дату создания файла
  • Безопасная работа с поврежденными FLAC файлами
  • Исправлена поддержка FreeDB-совместимых сервисов с выхода 6ой версии

6.0.6 (2016-03-24)

  • Вспомогательная панель со всеми переменными и функциями в диалогах
  • Логические функции: $not, $and, $or
  • Работа с новым полем “Дирижер” для M4A файлов
  • Исправлна проблема с использованием шаблонов в диалоге импорта/экспорта обложек
  • Список переменных реорганизован
  • Программа теперь не удаляет неизвестные блоки в MP4 метаданных
  • Обновлены некоторые иконки для hiDPI режимов
  • Обновлён звуковой движок и плагины
  • Локализация: Chinese Simplified, Persian

6.0.5 (2016-03-10)

  • Более удобная работа с группами в списке файлов
  • Возможность перетаскивания файлов на журнал
  • Поддержка последних изменений в iTunes
  • Возможность сортировки пользовательских стилей
  • Исправлена прокрутка панелей колесиком на windows10
  • Исправлено формирование блока LIST INFO в WAV файлах
  • Локализация: Portuguese (Brazil), Chinese Simplified

6.0.4 (2016-02-23)

  • Столбец "картинка" теперь содержит размер данных в дополнение к размеру изображения
  • Восстановление метаданных из поврежденных AIFF файлов, которые пишет iTunes
  • Исправлена проблема с обновлением конфигурации генераторов при миграции с 5.1 на 6
  • Исправлена фильтрация полей при импорте с онлайна
  • Исправлена поддержка FLAC, WAV, MP4 после обновления 6.0.3
  • Обновлен внутренний скриптовый движок
  • Обновлена поддержка формата OPUS
  • Функция изменения размеров обложек больше не увеличивает маленькие картинки
  • Файлы скриптов преобразований теперь обновляются на диске по мере необходимости
  • Локализация: Portuguese (Portugal)

6.0.3 (2016-02-10)

  • Новое сетевое ядро с поддержкой безопасных соединений. Необходимо для предстоящих изменений на Discogs
  • Новая опция для уменьшения области резервирования во FLAC файлах
  • Возможность прямого перетаскивания обложек из Firefox и Google Chrome
  • Исправлена проблема с работой функций в некоторых случаях
  • Исправлена проблема с удалением обложек из FLAC файлов
  • Регистр пользовательских полей ID3v2 тэгов теперь не изменяется
  • Запись ID3v1 тэгов в mp3 файлах теперь зависит от специальной настройки
  • Обновлена поддержка формата Apple Lossless
  • Локализация: Ukrainian, Greek, Slovak, Dutch, French

6.0.1 (2016-01-20)

  • Более аккуратная сортировка по размеру картинки
  • Исправлена проблема с зависанием при "перемешивании" списка файлов
  • Исправлена проблема с зависанием при работе с сохраненными путями
  • Исправлено ошибочное удаление пользовательских полей при сохранении в стандартном редакторе тэгов
  • Вернулась загрузка пользовательских шаблонов для переименования папок
  • Обновлена поддержка кодека AAC
  • Функция реорганизации вновь учитывает папки при переносе

6.0.0 (2016-01-15)

  • Новый свежий интерфейс с поддержкой hiDPI
  • Работа с тэгами в AIFF и WAV файлах
  • Функции для манипуляций с текстом
  • Возможность загрузки скриптов из внешних файлов
  • Два режима работы для реорганизации файлов: Перенос и Копирование
  • Новая переменная %_bitspersample% с информацией о разрядности (если доступно)
  • Новая переменная %_tool% с информацией о инструменте кодирования (если доступно)
  • Теперь можно сохранять id3v2.4 тэги (2.3 по умолчанию)
  • Расширенные возможности по сортировке и группировке файлов, включая выбор нескольких полей
  • Возможность создавать свои столбцы в списке
  • Возможность фильтровать список файлов по нескольким полям
  • Новый диалог для удаления тэгов
  • Новый диалог для автонумерации
  • Новый диалог для переименования папок
  • Расширенный режим редактора тэгов с доступом ко всем возможным полям и возможностью создания собственных полей
  • Новые диалоги для импорта/экспорта обложек со расширенным функционалом
  • Возможность выбрать какие поля нужно заполнять из онлайна
  • Поддержка Socks прокси
  • Поиск на Amazon.in (India)
  • Горячие клавиши для Копировании/Вставки тэгов
  • Единый журнал для всех действий
  • Новая команда меню - Копировать имена файлов
  • Дополнительная фильтрация результатов с Discogs
  • Экспорт теперь записывает имена создаваемых файлов в журнал
  • Импорт обложек в автоматическом режиме теперь умеет подхватывать не только JPEG файлы
  • Для длинных списков теперь работает автодополнение
  • С помощью стрелок теперь можно двигать несколько файлов сразу
  • Настройки чтения и записи тэгов переосмыслены.
  • Корректная работа с полями ID3v2 тэгов, содержащими списки (например TIPL)
  • Корректная работа с полем 'тип медиаданных' для iTunes (MP4) тэгов
  • Изменено: Сортировка и группировка теперь независимы, режим Автогруппировки позволяет получить прежнее поведение
  • Изменено: Функция изменения кодировки перенесена из скриптов в основное меню
  • Изменено: APEv2 тэги теперь игнорируются для mp3-файлов при наличии ID3v2 тэгов
  • Изменено: Программа переключается на журнал только в режиме предпросмотра
  • Изменено: Журнал теперь показывает только изменяемые поля
  • Изменено: Функция "переместить The" пересмотрена в связи с последними изменениями на Discogs
  • Исправлена проблема с чтением ID3v2 тэгов из файлов больше 2Гб
  • Оптимизировано потребление памяти при интенсивной работе
  • Обновлена поддержка MusicBrainz
  • Локализация: Greek, Polish, Japanese, German, Swedish

5.1.668 (2015-06-15)

  • Чтение ID3v2.3 тэгов, содержащих данные маркированные версией 2.2
  • Иногда программа не удаляла пустые папки после окончания выполнения реструктуризации файлов
  • Поддержка Windows 10

5.1.667 (2015-03-31)

  • Более удобная работа при помощи клавиатуры
  • Исправлена проблема с сохранением плейлистов в нужном формате
  • Оптимизировано потребление памяти для функции отката изменений
  • Локализация: Chinese Simplified

5.1.665 (2015-02-24)

  • Обновлена поддержка сервиса Discogs
  • Доработан стандартный скрипт Discogs cleanup
  • Устранена проблема с блокировкой панели задач в полноэкранном режиме
  • Устранена проблема с редактированием скриптов
  • Локализация: Turkish, Japanese

5.1.663 (2015-02-17)

  • Новая опция для сохранения текущего выделения при сохранении тэга
  • Увеличена скорость запуска программы при сканировании начальной папки
  • Исправлены неточности отображения окна программы для старых версий Windows
  • Программа теперь запоминает состояние функции реструктуризации
  • Возможность создать список предопределенных путей для функции реструктуризации
  • Все выпадающие списки теперь работают как заложено системой

5.1.661 (2015-01-20)

  • Получение информации о составных треках для Discogs
  • Новый заполнитель %_paramstr% для вывода опций запуска программы
  • Упрощена установка обновлений

5.1.660 (2014-12-22)

  • Поддержка поля Initial Key (Тональность) для DJев и любителей классики
  • Теперь можно кликнуть на название диска в результатах поиска, чтобы выделить/снять выделение с треков текущего диска
  • Реализована поддержка технологии Snap на свежих редакциях Windows
  • Исправлена редкая проблема с применением условных секций к строкам, содержащим испанскую пунктуацию
  • Обновлена поддержка Flac
  • Добавлена возможность воспроизведения файлов DSF

5.1.657 (2014-11-09)

  • Поддержка редактирования тэгов в Direct Stream Digital (DSF) файлах
  • Исправлена проблема с блокировкой полей ввода после последнего обновления
  • Более точная обработка релизов с несколькими исполнителями с Discogs
  • Программа теперь использует новый диалог выбора папок для Windows Vista и выше

5.1.655 (2014-10-27)

  • Обновлена поддержка сервиса Discogs
  • Исправлена проблема с извлечением больших обложек
  • Устранена ошибка с чтением некоторых видов лирики из ID3v2 тэгов
  • Локализация: Ukrainian, French (новый)

5.1.652 (2014-09-02)

  • Исправлена проблема с чтением скриптов
  • Испавлена запись некоторых типов WMA файлов
  • Улучшена работа новой функции обновления данных на экране
  • Локализация: German (обновлен)

5.1.651 (2014-08-27)

  • Реализована авторизация запросов на сервисе Discogs
  • Дополнительная обработка результатов поиска на Amazon для сборников
  • Регулярные выражения в скриптах теперь ищут все совпадения (не останавливаются на первом)
  • Новые горячие клавиши [Ctrl+F5] пересканирует рабочую папку, [F5] перечитывает тэги для текущего списка файлов
  • Новая колонка в списке файлов с информацией о размере встроенных обложек
  • Обновлен плеер
  • Локализация: Czech (обновлен), Vietnamese (новый)

5.1.649 (2014-05-07)

  • Обновлена поддержка сервиса Discogs
  • Улучшено чтение поврежденных ID3v2.4 тэгов
  • Локализация: Ukrainian

5.1.648 (2014-03-11)

  • Улучшена работа с сетевыми сервисами
  • Новый фильтр для различных типов релизов на Discogs
  • Локализация: Catalan, Slovak, Spain

5.1.647 (2014-02-07)

  • Обновлена поддержка сервиса Discogs
  • Исправление ситуации когда после удаления тэга иногда не удалялись временные файлы
  • Изменена логика работы функции "Вырезать ТЭГ" - теперь программа удаляет из файла все возможные форматы метаданных в независимости от настроек
  • Локализация: Finnish, Portuguese (Portugal)

5.1.645 (2013-12-17)

  • Удалена поддержка сервиса Beatport по причине разногласий с новой политикой лицензирования
  • Улучшена работа с большими FLAC файлами
  • Исправлена проблема с сохранением тэга во время проигрывания файла
  • Локализация: Latvian (new), Chinese Traditional, Ukrainian, Polish, Chinese Simplified

5.1.643 (2013-11-07)

  • Теперь можно скачать дополнительные изображения для релиза
  • При выводе результатов поиска теперь показывается страна релиза, если такая информация есть
  • Увеличена скорость сохранения тэгов на сетевых дисках
  • Исправлена проблема с сохранением скриптов, содержащих служебные символы в их именах
  • Исправлены возможные проблемы с общим доступом к файлам на многопользовательских системах
  • Локализация: Turkish

5.1.641 (2013-10-13)

  • Откат изменений, которые скрывали файл от службы индексирования после сохранения тэга

5.1.640 (2013-10-09)

  • Восстановлена поддержка сервиса Beatport
  • Изменение регистра букв теперь работает в многострочных полях
  • Дата релиза из онлайн баз теперь может быть сохранена в полном формате
  • Увеличена скорость сохранения тэгов для большинства систем
  • Исправлены некоторые проблемы со стабильностью на Windows8

5.1.638 (2013-08-22)

  • Интелектуальная сортировка по номеру трека, BPM и размеру обложки
  • Автоисправление имён файлов при экспорте обложек в автоматическом режиме
  • Для FreeDB сервисов теперь вновь показывается Стиль альбома
  • Возможное исправление проблемы совместного доступа к файлам на Win8
  • Локализация: Dutch, Ukrainian, Chinese Simplified

5.1.637 (2013-06-04)

  • Теперь можно менять размер панелей действий
  • Преобразования теперь могут применяться сразу к нескольким полям
  • Интерфейс для работы с freedb базами переделан и теперь позволяет увидеть несколько результатов сразу
  • Изменено поведение некоторых диалогов
  • Исправлена проблема с утечкой памяти и "вылетами" программы после долгой работы

5.1.635 (2013-04-23)

  • Поддержка регулярных выражений в скриптах
  • Оптимизация поисковых запросов для Discogs и Beatport
  • Возможность получить обложки альбомов с дочерней базы MusicBrainz's coverartarchive.org
  • Улучшена стабильность работы на Windows8
  • Локализация: Polish, Ukrainian, Japanese

5.1.631 (2013-03-15)

  • Поиск информации об альбоме и обложек на amazon.it и amazon.es
  • Оптимизировано потребление памяти для операции отката изменений
  • Обновлён проигрыватель

5.1.630 (2013-01-16)

  • Улучшена работа с составными полями для MusicBrainz
  • Поддержка не-rgb изображений для встраиваемых обложек
  • Исправлена проблема с невозможностью изменения имени файла в диалоге экспорта
  • Исправлена ошибка со случайным удалением файла при переименовании прямо в списке
  • Локализация: German

5.1.625 (2012-11-14)

  • Поддержка свободного кодека Opus - информация о потоке и работа с метаданными (Vorbis Comments)
  • Улучшена релевантность поиска по базам Discogs и MusicBrainz
  • Чтение несинхронных ID3v2.3 тэгов
  • Чтение информации об аудиокодеке для MP4-видео
  • Чтение полей с несколькими исполнителями на MusicBrainz
  • Встроенный плеер теперь поддерживает управление с помощью мультимедия-кнопок
  • Программа теперь тестируется на совместимость с Windows 8

5.1.622 (2012-10-17)

  • Автоисправление пути к папке при вставке из буфера обмена
  • Отображение версий тэгов в списке файлов
  • Решена проблема с обработкой полей, содержащих %
  • Устранена проблема с чтением некоторых типов комментариев из ID3v2 тэгов
  • Локализация: Dutch

5.1.621 (2012-09-06)

  • Новое сочетание клавиш для быстрого перехода к следующему файлу CTRL+N
  • Исправлена ошибка, когда информация о рейтинге могла пропадать из ID3v2 тэга после сохранения имзенений
  • Исправлена проблема с редактированием тэгов в очень коротких OGG-файлах
  • Локализация: Chinese Traditional

5.1.620 (2012-07-11)

  • Добавлена поддержка крупнейшего магазина для DJ'ев Beatport.com с возможностью получить полную информацию о релизе и загрузить обложки дисков
  • Изменение логики: Значения TOTALTRACKS и TOTALDISCS теперь сохраняются в отдельных полях Vorbis Comments
  • Исправлена редкая проблема с чтением ID3v2 тэгов, содержащих расширенный заголовок
  • Обновлена поддержка сервиса Discogs
  • Локализация: Estonian, Chinese Simplified

5.1.612 (2012-05-23)

  • Возможность перемешать список файлов
  • Обновлена логика сортировки для некоторых полей
  • Исправлено поведение файловых диалогов в WinXP
  • Исправлено ложное отображение ошибки при записи ID3v1 тэгов
  • Обновлен втроенный проигрыватель

5.1.611 (2012-03-22)

  • Более аккуратный расчет битрейта для FLAC-файлов
  • Улучшено поведение при работе с файлами, блокированными другими программами (Winamp, iTunes и т.д.)
  • Исправлены проблемы с выполненем действий над отфильтрованным списком файлов
  • Исправлена проблема с позиционированием для систем с несколькими мониторами
  • Локализация: Greek

5.1.610 (2012-02-15)

  • Улучшена обработка старых релизов для Discogs
  • Доработано поведение контекстного меню для списка файлов
  • Изменение логики: Программа теперь сохраняет порядок файлов при загрузке плейлиста
  • Исправлены проблемы со стабильностью процессора тэгов
  • Обновлен список доступных заполнителей
  • Перенастроена поддержка Vorbis тэгов
  • Локализация: Swedish

5.1.608 (2012-01-24)

  • Обновлена поддержка формата WavPack
  • Унификация настроек обработки существующих значений для процессора тэгов
  • Исправлена ошибка записи обложки диска, вставленной из буфера обмена
  • Корректное отображение журнала результатов переименовая файлов
  • Исправлна проблема с чтением поля Артист Альбома для ID3v2.2 тэгов

5.1.607 (2012-01-12)

  • Обновлена поддержка сервиса Discogs
  • Обновлена поддержка сервиса TrackType
  • При переименовании файлов скрипты преобразования теперь могут применяться не только к имени файла, но и к отдельным заполнителям
  • Теперь для AAC-файлов используются по-умолчанию ID3v2 тэги
  • Исправлена ошибка чтения комментариев, содержащих доп.описание для ID3v2 тэгов
  • Исправлена редкая проблема с невозможностью удалить ID3v2 тэг для некоторых систем
  • Локализация: Japanese, Ukrainian, Turkish

5.1.605 (2011-12-01)

  • Добавлен регулятор громкости для встроенного плеера
  • Новый заполнитель %_filedate_rfc% для даты и времени файла в интернет (rfc822) формате
  • Возможность быстрого просмотра полноразмерной обложки альбома в редакторе тэгов
  • Заполнители реорганизованы в новый блок
  • Исправлены проблемы с потерей части текста при использовании условных секций
  • Исправлена ошибка восприятия строк со смешанным регистром букв, содержащих нелатинские символы, для скриптов преобразования и фильтра
  • Многие части интерфейса стали лучше отображаться на системах с повышенным DPI
  • Обновлён звуковой движок, устранена проблема с запуском на удаленном рабочем столе
  • Внутренние правила для скриптов были возвращены к состоянию до версии 5.1.602
  • Локализация: Chinese Simplified, Polish

5.1.602 (2011-11-04)

  • Переход на новый протокол Amazon Product Advertising API
  • Исправлены и перенастроены некоторые шаблоны и скрипты экспорта
  • Локализация: Italian, Portuguese (Brazil), Ukrainian

5.1.601 (2011-10-27)

  • Ускорена фильтрация списка файлов
  • Возможность запросить данные напрямую с MusicBrainz, зная PUID
  • Улучшен разбор данных для частично заполненных релизов Musicbrainz
  • Немного увеличена скорость сохранения тэгов на некоторых системах
  • Исправлена ошибка с выводом обложек дисков в обратном порядке при запросах к Amazon
  • Исправлена проблема обработки нескольких условных секций в одном шаблоне
  • Изменены правила для функции автоисправления имен файлов
  • Менее навязчивое поведение функции предложения вариантов поиска для онлайн запросов
  • Локализация: German, Ukrainian

5.1.600 (2011-09-15)

  • Поддержка открытой музыкальной энциклопедии MusicBrainz с возможностью подгрузки обложек альбомов со связанных с релизами сайтов
  • Переход на новый протокол Discogs API v2.0, старая версия будет отключена 15.12.2011
  • Правильное отображение многострочных полей в тэгах, созданных на Mac OS
  • Изменение логики: Программа теперь проверяет права на запись во временную папку, чтобы избежать проблем с сетевыми дисками
  • Изменение логики: Программа теперь пытается загружать обложки альбомов прежде чем будут загружены данные о всех найденных альбомах
  • Изменение логики: При передаче имени папки через консоль программа загружает только эту папку, а не всю вышестоящую иерархию
  • Исправлена проблема с интерпретацией данных при работе с несколькими выделенными файлами, содержащими пустые значения полей
  • Устранены возможные проблемы с авторизацией при посылке некоторых запросов к сервисам Amazon
  • Локализация: Serbian (Latin)

5.1.598 (2011-07-22)

  • Новый заполнитель %_nl% для вставки символа переноса строки
  • Улучшена обработка неправильно заполненных релизов с Discogs
  • Переносная версия теперь идёт без файла конфигурации чтобы не затирать старые настройки при обновлении
  • Локализация: Czech, Portuguese (Portugal)

5.1.597 (2011-04-14)

  • Исправлена работа функции переименования папки по тэгу для сетевых дисков
  • Поправлена обработка заполнителя %foldername% для сетевых путей
  • Визуальное выделение пробелов и пустых значений в редакторе скриптов
  • Обновлена поддержка сервиса Discogs
  • Программа больше не тестируется на совместимость с Windows2000
  • Локализация: Portuguese (Brazil), German

5.1.596 (2011-02-10)

  • Функция Экспорта теперь умеет сохранять текущий порядок файлов благодаря новому заполнителю %_index%. Скрипты для html и csv файлов, идущие в комплекте поставки, обновлены под новую логику
  • Автоматическая проверка и исправление создаваемого имени файла при Экспорте
  • Изменение логики: Восприятие VERSION -> REMIXEDBY для Vorbis comments
  • Изменения в обработке cue-файлов, содержащих несколько полей PERFORMER
  • При перетаскивании файлов из Проводника программа теперь использует путь к первому файлу как текущий рабочий каталог %workpath%
  • Исправлена проблема с обработкой условных секций [] в шаблонах
  • В режиме редактора в списке файлов нажатие на TAB теперь перемещает редактор к этому же полю следующего файла, аналогично проводнику Windows 7
  • Улучшена совместимость с другими программами для кадра POPM ID3v2 тэгов
  • Локализация: Bulgarian, Italian

5.1.595 (2011-01-26)

  • Теперь можно добавить файлы к текущему списку если удерживать клавишу Ctrl при перетаскивании файлов из проводника в окно программы
  • Чтение отдельных полей TOTALDISCS и TOTALTRACKS, используемых в некоторых программах (пример foobar2000)
  • Новые заполнители %foldername2% для имени папки на 2 уровня вверх и %foldername3% для имени папки на 3 уровня вверх
  • Возможность восстановления данных из ID3v2 тэгов с пустыми заголовками и кадрами
  • Изменение логики: Версия TagScanner для установки теперь сохраняет настройки и скрипты в текущем профиле пользователя %appdata%\TagScanner. Все старые настройки из виртуального хранилища Windows Vista и выше будут перенесены в новое место
  • Исправлена неправильная работа заполнителя %hascover%
  • Исправлена проблема, которая могла приводить к ошибке 'Out Of Resource' для систем с несколькими мониторами
  • Теперь программа всегда учитывает режим масштабирования, который установлен в Windows
  • Обновлен звуковой движок, улучшена совместимость с Windows7

5.1.594 (2010-11-18)

  • Дополнительная обработка данных из веб-сервисов для улучшения качества получаемой информации
  • Обновлена поддержка формата WMA
  • Устранено возникновение ошибки "Access violation" для некоторых операций
  • Исправлены проблемы с записью тэгов на сетевых дисках

5.1.593 (2010-11-09)

  • Значительна увеличена скорость работы с сетевыми и внешними дисками
  • Усилена защита от ошибок при чтении битых обложек из тэгов, также такие обложки теперь можно удалить
  • Заполнитель %_counter% теперь использует правила форматирования номеров аналогично %track%
  • Улучшено качество картинки для пережимаемых и масштабируемых обложек
  • Добавлена поддержка Вьетнамской кодировки
  • Автоисправление имён папок с пробелами в начале и в конце
  • Изменение логики: ID3v2 теперь игнорируются для FLAC файлов, содержащих корректные Vorbis comments
  • Изменение логики: Восприятие GROUPING -> CONTENTGROUP для Vorbis comments
  • Устранены утечки памяти при чтении ID3v2 тэгов
  • Исправлена пара ошибок при работе с WMA файлами
  • Доработано чтение ALAC файлов, созданных в старых версиях iTunes
  • Небольшие изменения в логике поиска
  • Переделаны некоторые группировки в списке файлов
  • Сброс позиции окна при старте если оно выходит за границы экрана
  • Локализация: Czech, German, Ukrainian

5.1.592 (2010-09-24)

  • Новый движок обработки тэгов
  • Новый заполнитель %_counter%
  • Улучшено чтение CUE-файлов для сборников
  • Улучшен механизм чтения поврежденных ID3v2 тэгов
  • Улучшена совместимость с iTunes 10
  • Программа теперь запоминает настройки блока реструктуризации файлов
  • Изменение логики: Убрано совмещение данных из тэгов ID3v1 и ID3v2
  • Изменение логики: Восприятие DESCRIPTION -> COMMENT для Vorbis comments
  • Изменение логики: Восприятие ORGANIZATION -> PUBLISHER для Vorbis comments
  • Исправлена проблема с генерацией по пустым блокам для генератора тэгов по имени файла
  • Исправлена проблема с интерпретацией слэша в модуле переименования файлов для некоторых редакций Windows7
  • Обновлена поддержка сервиса Discogs
  • На Windows Vista и выше программа теперь пытается использовать новые системные шрифты
  • Все файлы переводов теперь в кодировке utf-8
  • Программа перенесена на новый компилятор
  • Локализация: Polish, Czech, Chinese Traditional, Slovak, Korean

5.1.571 (2010-07-02)

  • Новинка: Теперь вы можете изменить размер данных и размер изображения для встраиваемых обложек
  • Новинка: Функция автонумерации треков теперь умеет сбрасывать счётчик для отдельных групп файлов
  • Текстовые скрипты теперь применяются для предпросмотра в реальном времени в модуле переименования файлов
  • Улучшена обработка множественных пользовательских <текстовых блоков> в модуле генератора тэгов по имени файла
  • Изменение логики: Текстовые скрипты теперь применяются только на захватываемую часть имени файла, а не весь путь, для генератора тэгов по имени файла
  • Изменение логики: Регистр букв в расширение файла теперь меняется только на все прописные или все заглавные
  • Исправлена проблема с игнорированием числовых значений для некоторых заполнителей в Процессоре тэгов
  • Программа теперь не блокирует работу с панелью задач, которая скрывается в автоматическом режиме
  • Переписан сетевой код для избежания проблем с нестабильным подключением (не надо перезапускать программу)
  • Изменен метод масштабирования интерфейса для нестандартных режимов Windows
  • Локализация: Portuguese (Brazil), Dutch, Italian, Turkish, Japanese, German

5.1.563 (2010-05-12)

  • Обновлены правила изменения регистра букв
  • Перенастроена функция автокорректировки имён файлов
  • Доработана функция импорта данных из CUE файла
  • Более мягкий переход с версии 5.0 на 5.1 с сохранением настроек
  • Локализация: Portuguese - European, Croatian (alternative)

5.1.562 (2010-04-29)

  • Возможность поиска по базе Amazon в разделе платных MP3 загрузок
  • Программа теперь может автоматически сохранять скаченные обложки в папку с альбомом
  • Программа теперь запоминает последнюю рабочую закладку
  • Программа теперь умеет сообщать о проблемах с доступом к файлам
  • Импорт дополнительной информации об артистах, причастных к записи трека, для базы Discogs
  • Теперь доступен полный перечень заполнителей метаданных в модулях List maker и Tag Processor
  • Реорганизован интерфейс для работы с веб-сервисами
  • Автокоррекция имён папок с точками в начале или в конце
  • Исправлена проблема с игнорированием последней строчки в текстовом файле при генерации тэгов
  • Исправлены ошибки в работе функции обрезания имён файлов
  • Исправлена ошибка с сохранением даты файла при удалении тэга при включенной опции сохранения
  • Исправлена проблема с чтением стилей, содержащих скобки
  • Локализация: Belarusian, Hebrew (new), Croatian (new), Japanese

5.1.559 (2010-03-16)

  • При отрисовке интерфейса программа теперь использует настройки масштабирования из системы
  • Функция сокращения длины имён файлов теперь также затрагивает создаваемые папки
  • Доработаны чтение и интерпретация поля "Артист альбома" для лучшей совместимости с другими программами
  • Новый заполнитель %foldername% для имени папки, в которой лежит текущий файл
  • Получение дополнительной информации с Discogs для релизов с несколькими исполнителями
  • Справка по программе теперь выводится в браузере по умолчанию
  • Изменены сочетания клавиш c Ctrl+Alt, чтобы не мешать набору текста в некоторых кодировках
  • Служебные комментарии iTunes в ID3v2 тэгах теперь всегда сохраняются в кодировке ISO-8859-1
  • Исправлены ошибки при удалении файлов из общего списка
  • Исправлено сохранение плейлистов в формат PLS
  • Исправлены проблемы с чтением CUE-файлов, для кодировок отличных от win1252
  • Исправлена ошибка с повторным чтением тэга из следующего файла при сохранении тэга
  • Для многих модулей улучшено взаимодействие с пользователем
  • Локализация: French (2 versions), Danish (new), Slovak, German, Dutch

5.1.555 (2009-12-17)

  • Возможность редактирования полей тэга прямо в списке файлов
  • Процессор тэгов теперь подсвечивает изменяемые поля
  • Теперь через скрипт можно заменить значение поля целиком, если в качестве оригинала указана пуская строка
  • Значительно ускорена обработка очень длинных или битых текстовых полей в ID3v2 тэгах
  • Скрипты для экспорта теперь обновляются в реальном времени при редактировании во внешней программе
  • Сворачивание секций в редакторе тэгов
  • Изменена логика работы функции "Переименование папки по тэгу", теперь она работает для всех выбранных файлов, а не только текущего
  • Изменение логики, теперь в режиме АВТО программа сохраняет только APEv2 тэги в ape,wv,mpc-файлы, если в них нет ID3v1 тэга
  • Исправлена проблема с обработкой ограничения на 99 треков в альбоме для сервисов freedb и tracktype
  • Исправлены проблемы с выделением последних файлов в основном окне на Win7
  • Новые сочетания клавиш: Ctrl+P - Настройки, Ctrl+Shift++/Ctrl+Shift+- - Равернуть/Свернуть группы, Ctrl+Shift+O - Открыть плейлист, Esc - Прервать любую длительную операцию
  • Улучшена совместимость с другими программами для некоторых кадров внутри ID3v2 тэгов
  • Локализация: Hungarian

5.1.553 (2009-10-08)

  • Значительно увеличена скорость обработки данных при выборе большого числа файлов в списке
  • Изменена логика работы html-фильтра при экспорте
  • Чтение ID3v2 тэгов с рассинхронизацией
  • Исправлена ошибка с чтением ID3v2.4 тэгов с описаниями картинок в utf-8 кодировке
  • Исправлены проблемы с изменением регистра в многострочных полях
  • Испправлена логика, когда Publisher прописывался в Album Artist для модулей процессора тэгов
  • Исправлена ошибка расчета размера MP4 тэга, которая мешала сохранению данных
  • Обновлены скрипты для экспорта
  • Локализация: German, Portuguese (Brazil)

5.1.551 (2009-08-27)

  • Появилась возможность убрать файлы из основного списка.
  • Исправлена ошибка 'List index out of bounds' при выполнении скриптов, которые очищают значения полей
  • Исправлены проблемы с функцией Автонумерации вне редактора тэгов
  • Последний выбранный файл добавлялся в плейлист дважды
  • Теперь программа вновь показывает смещение данных в mp3-файлах
  • Локализация: Greek

5.1.550 (2009-08-04)

  • Удалено: Модуль процессора тэгов: Копировать тэг в другую версию
  • Удалено: Отдельный редактор плейлистов, теперь его функционал интегрирован в основной список файлов
  • Новое: Модуль процессора тэгов: Манипулятор с полями тэгов - форматирование, смешивание и изменение данных на основе других полей
  • Новое: Модуль процессора тэгов: Импорт данных из текстового файла со списком
  • Новое: Специальное поле SOURCESTRING в редакторе текстовых скриптов для обработки исходных строк данных в новых модулях процессора
  • Новое: Фильтрация списка файлов
  • Новое: Функция преобразования кодировки тэга в скриптах (из выбранной кодировки в юникод)
  • Новое: Возможность быстро создать плейлист из выбранных файлов
  • Новое: Возможность создать полную копию всего скрипта, а не только отдельных преобразований
  • Новое: Алгоритм "естественной" сортировки списка файлов (доступно для WinXP и выше)
  • Новое: Модуль 'Экспорт списка файлов' на основе скриптов, в комплекте идут скрипты для xml, csv и html (документация по написанию своих будет доступна позже)
  • Новое: Библиотека для работы с Mpeg файлами теперь умеет угадывать базовый кодировщик и аккуратно высчитывает длительность и битрейт файла
  • Новое: Функция поиска похожих файлов (по названию, размеру и длительности)
  • Новое: Условные секции [...] для формирующих строк
  • Новое: Поддержка нового официального поля для встраиваемой графики в OGG Vorbis (METADATA_BLOCK_PICTURE)
  • Новое: Функция импорта/экспорта обложек для нескольких файлов сразу
  • Улучшено: Возможность сортировки списка файлов по наличию обложек дисков
  • Улучшено: Теперь вы можете копировать и вставлять тэги между различными медиа-форматами (Vorbis в ID3, APE в MP4 и т.д.)
  • Улучшено: Теперь в генераторе тэгов по имени файла можно добавлять произвольный текст к извлекаемым полям прямо в строке форматирования
  • Улучшено: Пользовательские шаблоны для функции переименования папок по тэгу из меню списка файлов
  • Улучшено: Пользовательские Стили для редактора тэгов
  • Улучшено: Возможность копировать и вставлять обложки дисков в/из буфера обмена
  • Улучшено: Функция 'Найти файл в проводнике' теперь подсвечивает выбранный файл и переводит на него фокус
  • Улучшено: В списке файлов теперь доступны для просмотра колонки от всех редактируемых полей
  • Улучшено: Получение дополнительной информации из баз Amazon и Discogs (Композитор, Дирижер, Ремикс и т.д.)
  • Улучшено: Дополнительные поля: CONDUCTOR, ISRC, REMIXEDBY, SUBTITLE, LYRICIST
  • Улучшено: Настройка для Discogs - Перемещать "The" в начало для имен исполнителей
  • Улучшено: Переход на новый протокол доступа к базе Amazon
  • Улучшено: Сохранение масштаба картинки при показе обложек в редакторе тэгов
  • Улучшено: Обновлена поддержка форматов MusePack и WavePack
  • Улучшено: Функция проверки обновлений при запуске программы
  • Улучшено: Возможность работы на не основном мониторе
  • Изменено: Операция "Откат" теперь восстанавливает изначальную кодировку тэга
  • Изменено: "Экспорт списка файлов" теперь работает для выбранных файлов
  • Изменено: Для редактора тэгов при удалении тэга теперь все поля кроме "закрепленных" очищаются
  • Изменено: Для улучшения совместимости с другими программами и железом программа теперь использует первое, а не последнее, вхождение фрейма для ID3v2 тэгов
  • Изменено: Теперь программа обновляет тэг с помощью информации из интернета, а не создает тэг заново
  • Исправлено: Чтение ID3v2 тэгов с фреймами типа GEOB
  • Исправлено: Запись описаний фреймов типа APIC для ID3v2 тэгов
  • Исправлено: Чтение ID3v2 тэгов с фреймами в кодировке utf-16 BigEndian
  • Исправлено: Запись обложек дисков в OGG файлы при скачивании из интернета
  • Исправлено: Использование путей файлов с юникод-символами в некоторых диалогах
  • Исправлено: Чтение текстовых файлов с маркером юникода (BOM)
  • Исправлены проблемы с утечкой памяти при длительной работе
  • Исправлены проблемы с обработкой файлов, перетянутых из проводника
  • Исправлены проблемы чтения MP4 файлов с очень длинными полями свободного формата
  • Новый внутренний движок хранения и обработки тэгов
  • Многие диалоги переделаны
  • Обновлен файл справки, добавлены примеры использования (включая нетривиальные) для всех модулей
  • Обновлен движок проигрывателя файлов
  • Локализация: Chinese Traditional, Japanese, Polish, Spanish
список изменений в предыдущих версиях...

(с) 1999-2017 Серков Сергей
xdev@yandex.ru