Introduction

Test Result

Result ID Profile Start time End time Benchmark Benchmark version
xccdf_org.open-scap_testresult_xccdf_preupg_profile_default xccdf_preupg_profile_default 2015-06-17 16:20 2015-06-17 16:24 embedded 1.0

Target info

Targets

  • qeos-46.lab.eng.rdu2.redhat.com

Addresses

  • 127.0.0.1
  • 172.16.36.46
  • 10.8.53.24
  • 0:0:0:0:0:0:0:1
  • fe80:0:0:0:f816:3eff:fe3c:5908

Platforms

  • cpe:/o:redhat:enterprise_linux:6
  • cpe:/o:redhat:enterprise_linux:6

Results overview

Rule Results Summary

pass fixed fail needs inspection needs action error not selected not checked not applicable informational unknown total
32 6 0 11 7 0 0 0 51 24 0 131
Title Result
Replaced rpms fixed
package downgrades fixed
SELinux Custom Policy fixed
OpenSSH sysconfig migration content fixed
State of LVM2 services. fixed
Workaround for crashing grubby. fixed
Compatibility Between iptables and ip6tables informational
Check NFSv2 informational
Postfix configuration compatibility check informational
Rsyslog configuration icompatibility informational
VCS repositories informational
Removed Options in coreutils informational
Removed options in gawk binaries informational
Removed options in grep binaries informational
Removed options in netstat binary informational
Removed options in quota tools informational
Removed or deprecated options in util-linux (util-linux-ng) binaries informational
GMP library incompatibilities informational
httpd configuration compatibility check informational
Disk quota tool warnquota moved into quota-warnquota package informational
Read Only FHS directories informational
Check FHS for /var incompabilities. informational
File Systems, Partitions and Mounts Configuration Review informational
Removable media in fstab informational
Sonamebumped libs informational
SonameKept Reusable Dynamic Libraries informational
Foreign Perl modules informational
PolicyKit (alias polkit) config files informational
UEFI bootloader informational
YUM informational
Packages not signed by Red Hat needs_action
Removed rpms needs_action
optional channel problems needs_action
General needs_action
Removed .so libs needs_action
Content for enabling and disabling services based on RHEL 6 system needs_action
Check system requirements needs_action
Configuration Files to Review needs_inspection
File Lists for Manual Migration needs_inspection
Check openssh-keycat needs_inspection
Check changed config files needs_inspection
Print removed and moved utilities needs_inspection
Obsoleted rpms needs_inspection
Binary rebuilds needs_inspection
Check for GRUB splash.xpm.gz file needs_inspection
Check for ethernet interface naming needs_inspection
Python 2.7.5 needs_inspection
Save repositories for kickstart needs_inspection
several kernel networking drivers not available in Red Hat Enterprise Linux 7 pass
several kernel storage drivers not available in Red Hat Enterprise Linux 7 pass
Check AuthorizedKeysCommand pass
Reusable Configuration Files pass
Check packages from other variants pass
NTP configuration pass
Information on time-sync.target pass
OpenSSH sshd_config migration content pass
Configuration for quota_nld service pass
Disk quota netlink message daemon moved into quota-nld package pass
Check rsync pass
Detect LUKS devices using Whirlpool for password hash. pass
Luks encrypted partition pass
Configuration for warnquota tool pass
Check for Add-On availability pass
Architecture Support pass
Debuginfo packages pass
In-place Upgrade Requirements for the /usr/ Directory pass
Cluster and High Availability pass
Check the system version pass
CA certificate bundles modified pass
Developer Tool Set packages pass
Obsoleted HAL (Hardware Abstraction Layer) pass
Hyper-V pass
User modification in /etc/rc.local and /etc/rc.d/rc.local pass
Plugable authentication modules (PAM) pass
SCL collections pass
Red Hat Subscription Manager pass
System kickstart pass
Check for usage of dangerous ranges of UID and GIDs pass
Incorrect usage of reserved UID/GIDs pass
Check libuser.conf pass

Results details

Result for Configuration Files to Review

Result: needs_inspection

Rule ID: xccdf_preupg_rule_backup_NoverifyConfigs_noverifycfg

Time: 2015-06-17 16:20

This module stores some system configuration files that can have been modified by the user when it is not possible to automatically upgrade them.

Remediation instructions

_backup_NoverifyConfigs_SOLUTION_MSG_TEXT

              
INPLACERISK: SLIGHT: We detected some files where modifications are not tracked in the rpms. You may need to check their functionality after successful upgrade.

            

Result for File Lists for Manual Migration

Result: needs_inspection

Rule ID: xccdf_preupg_rule_backup_UntrackedFiles_untracked

Time: 2015-06-17 16:20

This module generates lists of files, such as temporary, application, and user data files, which are not automatically migrated.

Remediation instructions

_backup_UntrackedFiles_SOLUTION_MSG_TEXT

              
INPLACERISK: SLIGHT: We detected some files untracked by rpms. Some of these may need manual check/migration after redhat-upgrade-tool and/or can cause conflicts or troubles during the installation. Try to reduce unnecessary untracked files before running redhat-upgrade-tool.

            

Result for several kernel networking drivers not available in Red Hat Enterprise Linux 7

Result: pass

Rule ID: xccdf_preupg_rule_drivers_ObsoletedNetworkDrivers_obsoletedNetworkDrivers

Time: 2015-06-17 16:20

Several kernel networking drivers were removed from Red Hat Enterprise Linux 7.

Result for several kernel storage drivers not available in Red Hat Enterprise Linux 7

Result: pass

Rule ID: xccdf_preupg_rule_drivers_ObsoletedStorageDrivers_obsoletedStorageDrivers

Time: 2015-06-17 16:20

Several kernel storage drivers were deprecated or removed in Red Hat Enterprise Linux 7.

Result for Compatibility Between iptables and ip6tables

Result: informational

Rule ID: xccdf_preupg_rule_networking_iptables_check_script

Time: 2015-06-17 16:20

The firewalld service is now the default firewall service.

File(s) affected:

  • /etc/sysconfig/iptables

  • /etc/sysconfig/ip6tables

Remediation instructions

_networking_iptables_SOLUTION_MSG_TEXT

              
INFO iptables: Creating /root/preupgrade/postupgrade.d/reenable-iptables
WARNING iptables: Please read Remediation instructions.

            

Result for Check NFSv2

Result: informational

Rule ID: xccdf_preupg_rule_networking_nfsv2_check

Time: 2015-06-17 16:20

NFSv2 is not supported since RHEL 7. Therefore check if exists configuration which requires directly NFSv2 and fix it if it's possible.

Remediation instructions

_networking_nfsv2_SOLUTION_MSG_TEXT

Result for Check AuthorizedKeysCommand

Result: pass

Rule ID: xccdf_preupg_rule_networking_openssh_check

Time: 2015-06-17 16:20

AuthorizedKeysCommand and AuthorizedKeysCommandUser are not accepted if they are under Match section.

Result for Check openssh-keycat

Result: needs_inspection

Rule ID: xccdf_preupg_rule_networking_openssh-keycat_check

Time: 2015-06-17 16:20

ssh-keycat is moved to own subpackage

Remediation instructions

_networking_openssh-keycat_SOLUTION_MSG_TEXT

              
INPLACERISK: MEDIUM: ssh-keycat files are moved to openssh-keycat

            

Result for Postfix configuration compatibility check

Result: informational

Rule ID: xccdf_preupg_rule_networking_postfix_check_script

Time: 2015-06-17 16:20

Checks postfix configuration compatibility

File(s) affected:

  • /etc/postfix/main.cf

Remediation instructions

_networking_postfix_SOLUTION_MSG_TEXT

Result for Reusable Configuration Files

Result: pass

Rule ID: xccdf_preupg_rule_others_NoVersionChangeEtc_nochange

Time: 2015-06-17 16:20

The module provides a list of the configuration files that can be reused in Red Hat Enterprise Linux 7.

Result for Check changed config files

Result: needs_inspection

Rule ID: xccdf_preupg_rule_others_configchanges_check

Time: 2015-06-17 16:20

Print modified config noreplace files which can generate .rpmnew (or .rpmsave) files. Specially check audit.rules which is generated by /sbin/augenrules since RHEL-6.6.

Remediation instructions

_others_configchanges_SOLUTION_MSG_TEXT

              
error: file /root/preupgrade/RHEL6_7/others/configchanges/etc/yum.repos.d/epel-testing.repo: No such file or directory
/root/preupgrade/RHEL6_7/others/configchanges/check.sh: line 53: & 16 : syntax error: operand expected (error token is "& 16 ")
INPLACERISK: SLIGHT: Some config files are changed and .rpmnew files will be generated.

            

Result for Rsyslog configuration icompatibility

Result: informational

Rule ID: xccdf_preupg_rule_others_rsyslog_check

Time: 2015-06-17 16:20

There is a change with journal (and thus socket logging) and some other incompatibilities in v7 as compared with older v5 version of rsyslog.

Remediation instructions

_others_rsyslog_SOLUTION_MSG_TEXT

Result for VCS repositories

Result: informational

Rule ID: xccdf_preupg_rule_others_vcsrepos_check_script

Time: 2015-06-17 16:20

Find Versin Control System repositories in /home and /root - git, svn, cvs, bzr.

Remediation instructions

_others_vcsrepos_SOLUTION_MSG_TEXT

Result for Print removed and moved utilities

Result: needs_inspection

Rule ID: xccdf_preupg_rule_packages_GenericUtilities_check

Time: 2015-06-17 16:20

Print utilities which were removed from packages, moved into another package or changed destination directory.

Remediation instructions

_packages_GenericUtilities_SOLUTION_MSG_TEXT

              
INPLACERISK: SLIGHT: Some utilities were removed, moved between packages or change path.

            

Result for Check packages from other variants

Result: pass

Rule ID: xccdf_preupg_rule_packages_InterVariants_check

Time: 2015-06-17 16:20

Packages from different variants could be installed on system. Print these packages which are from other variants.

Result for Packages not signed by Red Hat

Result: needs_action

Rule ID: xccdf_preupg_rule_packages_NonRHSignedPkg_nonrhpkg

Time: 2015-06-17 16:20

Packages not signed by Red Hat will not be upgraded

Remediation instructions

_packages_NonRHSignedPkg_SOLUTION_MSG_TEXT

              
INPLACERISK: HIGH: We detected some non-RH signed packages, you can find the list in [link:./kickstart/nonrhpkgs]. You need to handle them yourself!

            

Result for Obsoleted rpms

Result: needs_inspection

Rule ID: xccdf_preupg_rule_packages_ObsoletedPackages_ObsoletedPkg

Time: 2015-06-17 16:20

Some rpms were obsoleted from the set of the packages between RHEL 6 and RHEL 7. This content checks for the package obsoletes from your set of Red Hat packages.

Remediation instructions

_packages_ObsoletedPackages_SOLUTION_MSG_TEXT

              
INPLACERISK: MEDIUM: We detected some packages installed on the system were removed (obsoleted) between RHEL 6 and RHEL 7. This may break the functionality of the packages depending on them.

            

Result for Removed Options in coreutils

Result: informational

Rule ID: xccdf_preupg_rule_packages_RemovedOptions_coreutils_removedoptions

Time: 2015-06-17 16:20

Some options and binary files were removed from the coreutils packages between Red Hat Enterprise Linux 6 and Red Hat Enterprise Linux 7.

Remediation instructions

_packages_RemovedOptions_coreutils_SOLUTION_MSG_TEXT

Result for Removed options in gawk binaries

Result: informational

Rule ID: xccdf_preupg_rule_packages_RemovedOptions_gawk_removedoptions

Time: 2015-06-17 16:20

Some options and binaries were removed from gawk package between RHEL 6 and RHEL 7. This informative content lists the incompatibilities.

Remediation instructions

_packages_RemovedOptions_gawk_SOLUTION_MSG_TEXT

Result for Removed options in grep binaries

Result: informational

Rule ID: xccdf_preupg_rule_packages_RemovedOptions_grep_check

Time: 2015-06-17 16:20

Some commandline options are removed or deprecated in packages. Print list of changes.

Remediation instructions

_packages_RemovedOptions_grep_SOLUTION_MSG_TEXT

Result for Removed options in netstat binary

Result: informational

Rule ID: xccdf_preupg_rule_packages_RemovedOptions_nettools_removedoptions

Time: 2015-06-17 16:20

Some options were removed from netstat binary between RHEL 6 and RHEL 7. This informative content lists the incompatibilities.

Remediation instructions

_packages_RemovedOptions_nettools_SOLUTION_MSG_TEXT

Result for Removed options in quota tools

Result: informational

Rule ID: xccdf_preupg_rule_packages_RemovedOptions_quota_removedoptions

Time: 2015-06-17 16:20

Some options have been renamed at quota tools between Red Hat Enterprise 6 and 7. This informative content lists the incompatibilities.

Remediation instructions

_packages_RemovedOptions_quota_SOLUTION_MSG_TEXT

Result for Removed or deprecated options in util-linux (util-linux-ng) binaries

Result: informational

Rule ID: xccdf_preupg_rule_packages_RemovedOptions_util-linux_check

Time: 2015-06-17 16:20

Some commandline options are removed or deprecated in some packages. Print list of changes for util-linux.

Remediation instructions

_packages_RemovedOptions_util-linux_SOLUTION_MSG_TEXT

Result for Removed rpms

Result: needs_action

Rule ID: xccdf_preupg_rule_packages_RemovedPackages_RemovedPkg

Time: 2015-06-17 16:20

Some rpms were removed from the set of the packages between RHEL 6 and RHEL 7. This content checks for the package removals from your set of Red Hat packages.

Remediation instructions

_packages_RemovedPackages_SOLUTION_MSG_TEXT

              
INPLACERISK: HIGH: After upgrading to RHEL 7 there are still some el6 packages left. Add --cleanup-post option to redhat-upgrade-tool if you want to remove them automatically.
INPLACERISK: MEDIUM: We detected some packages installed on the system were removed between RHEL 6 and RHEL 7. This may break the functionality of the packages depending on them.

            

Result for Replaced rpms

Result: fixed

Rule ID: xccdf_preupg_rule_packages_ReplacedPackages_ReplacedPkg

Time: 2015-06-17 16:20

Some rpms were replaced between RHEL 6 and RHEL 7. This content checks for the package replacements from your set of Red Hat packages and generates the list of RH packages/yum groups for RHEL 7 kickstart.

Remediation instructions

_packages_ReplacedPackages_SOLUTION_MSG_TEXT

Result for GMP library incompatibilities

Result: informational

Rule ID: xccdf_preupg_rule_packages_gmp_check_script

Time: 2015-06-17 16:20

Incompatibilities between GMP 4 and GMP 5.1 libraries.

Remediation instructions

_packages_gmp_SOLUTION_MSG_TEXT

Result for optional channel problems

Result: needs_action

Rule ID: xccdf_preupg_rule_packages_optional-channel_optional

Time: 2015-06-17 16:20

detects upgrade problems with RHEL optional channel

Remediation instructions

_packages_optional-channel_SOLUTION_MSG_TEXT

              
DEBUG [unknown]: checking problems from Server
INPLACERISK: HIGH: Packages [xz-lzma-compat perl-YAML-Syck libreport-compat libproxy-bin libproxy-python apr-util-ldap libreport-plugin-logger PackageKit-yum-plugin system-config-firewall-tui groff aspell libreport-plugin-kerneloops] have been moved to Server Optional channel.

            

Result for package downgrades

Result: fixed

Rule ID: xccdf_preupg_rule_packages_pkgdowngrades_pkgdowngrades

Time: 2015-06-17 16:20

detects package downgrades from RHEL6 to RHEL7

Remediation instructions

_packages_pkgdowngrades_SOLUTION_MSG_TEXT

Result for SELinux Custom Policy

Result: fixed

Rule ID: xccdf_preupg_rule_selinux_CustomPolicy_check

Time: 2015-06-17 16:20

Solve problem with custom SE policy modules after migration

Remediation instructions

_selinux_CustomPolicy_SOLUTION_MSG_TEXT

Result for General

Result: needs_action

Rule ID: xccdf_preupg_rule_selinux_general_check

Time: 2015-06-17 16:20

There has to be some steps performed in order to have working SELinux on RHEL 7.

Remediation instructions

_selinux_general_SOLUTION_MSG_TEXT

              
INPLACERISK: HIGH: There were changes in SELinux policies between RHEL 6 and RHEL 7. Please, check solution in order to resolve this issue.

            

Result for httpd configuration compatibility check

Result: informational

Rule ID: xccdf_preupg_rule_services_httpd_check_script

Time: 2015-06-17 16:20

Checks httpd configuration compatibility

File(s) affected:

  • /etc/httpd/conf/httpd.conf

Remediation instructions

_services_httpd_SOLUTION_MSG_TEXT

              
LoadModule auth_basic_module modules/mod_auth_basic.so
LoadModule auth_digest_module modules/mod_auth_digest.so
LoadModule authn_file_module modules/mod_authn_file.so
LoadModule authn_alias_module modules/mod_authn_alias.so
LoadModule authn_anon_module modules/mod_authn_anon.so
LoadModule authn_dbm_module modules/mod_authn_dbm.so
LoadModule authn_default_module modules/mod_authn_default.so
LoadModule authz_host_module modules/mod_authz_host.so
LoadModule authz_user_module modules/mod_authz_user.so
LoadModule authz_owner_module modules/mod_authz_owner.so
LoadModule authz_groupfile_module modules/mod_authz_groupfile.so
LoadModule authz_dbm_module modules/mod_authz_dbm.so
LoadModule authz_default_module modules/mod_authz_default.so
LoadModule ldap_module modules/mod_ldap.so
LoadModule authnz_ldap_module modules/mod_authnz_ldap.so
LoadModule include_module modules/mod_include.so
LoadModule log_config_module modules/mod_log_config.so
LoadModule logio_module modules/mod_logio.so
LoadModule env_module modules/mod_env.so
LoadModule ext_filter_module modules/mod_ext_filter.so
LoadModule mime_magic_module modules/mod_mime_magic.so
LoadModule expires_module modules/mod_expires.so
LoadModule deflate_module modules/mod_deflate.so
LoadModule headers_module modules/mod_headers.so
LoadModule usertrack_module modules/mod_usertrack.so
LoadModule setenvif_module modules/mod_setenvif.so
LoadModule mime_module modules/mod_mime.so
LoadModule dav_module modules/mod_dav.so
LoadModule status_module modules/mod_status.so
LoadModule autoindex_module modules/mod_autoindex.so
LoadModule info_module modules/mod_info.so
LoadModule dav_fs_module modules/mod_dav_fs.so
LoadModule vhost_alias_module modules/mod_vhost_alias.so
LoadModule negotiation_module modules/mod_negotiation.so
LoadModule dir_module modules/mod_dir.so
LoadModule actions_module modules/mod_actions.so
LoadModule speling_module modules/mod_speling.so
LoadModule userdir_module modules/mod_userdir.so
LoadModule alias_module modules/mod_alias.so
LoadModule substitute_module modules/mod_substitute.so
LoadModule rewrite_module modules/mod_rewrite.so
LoadModule proxy_module modules/mod_proxy.so
LoadModule proxy_balancer_module modules/mod_proxy_balancer.so
LoadModule proxy_ftp_module modules/mod_proxy_ftp.so
LoadModule proxy_http_module modules/mod_proxy_http.so
LoadModule proxy_ajp_module modules/mod_proxy_ajp.so
LoadModule proxy_connect_module modules/mod_proxy_connect.so
LoadModule cache_module modules/mod_cache.so
LoadModule suexec_module modules/mod_suexec.so
LoadModule disk_cache_module modules/mod_disk_cache.so
LoadModule cgi_module modules/mod_cgi.so
LoadModule version_module modules/mod_version.so
LoadModule actions_module modules/mod_actions.so
LoadModule alias_module modules/mod_alias.so
LoadModule auth_basic_module modules/mod_auth_basic.so
LoadModule auth_digest_module modules/mod_auth_digest.so
LoadModule authn_anon_module modules/mod_authn_anon.so
LoadModule authn_dbm_module modules/mod_authn_dbm.so
LoadModule authn_file_module modules/mod_authn_file.so
LoadModule authz_dbm_module modules/mod_authz_dbm.so
LoadModule authz_groupfile_module modules/mod_authz_groupfile.so
LoadModule authz_host_module modules/mod_authz_host.so
LoadModule authz_owner_module modules/mod_authz_owner.so
LoadModule authz_user_module modules/mod_authz_user.so
LoadModule autoindex_module modules/mod_autoindex.so
LoadModule cache_module modules/mod_cache.so
LoadModule deflate_module modules/mod_deflate.so
LoadModule dir_module modules/mod_dir.so
LoadModule env_module modules/mod_env.so
LoadModule expires_module modules/mod_expires.so
LoadModule ext_filter_module modules/mod_ext_filter.so
LoadModule headers_module modules/mod_headers.so
LoadModule include_module modules/mod_include.so
LoadModule info_module modules/mod_info.so
LoadModule log_config_module modules/mod_log_config.so
LoadModule logio_module modules/mod_logio.so
LoadModule mime_magic_module modules/mod_mime_magic.so
LoadModule mime_module modules/mod_mime.so
LoadModule negotiation_module modules/mod_negotiation.so
LoadModule rewrite_module modules/mod_rewrite.so
LoadModule setenvif_module modules/mod_setenvif.so
LoadModule status_module modules/mod_status.so
LoadModule substitute_module modules/mod_substitute.so
LoadModule suexec_module modules/mod_suexec.so
LoadModule userdir_module modules/mod_userdir.so
LoadModule version_module modules/mod_version.so
LoadModule vhost_alias_module modules/mod_vhost_alias.so
LoadModule dav_module modules/mod_dav.so
LoadModule dav_fs_module modules/mod_dav_fs.so
LoadModule proxy_module modules/mod_proxy.so
LoadModule proxy_ajp_module modules/mod_proxy_ajp.so
LoadModule proxy_balancer_module modules/mod_proxy_balancer.so
LoadModule proxy_connect_module modules/mod_proxy_connect.so
LoadModule proxy_ftp_module modules/mod_proxy_ftp.so
LoadModule proxy_http_module modules/mod_proxy_http.so
LoadModule disk_cache_module modules/mod_disk_cache.so
LoadModule cgi_module modules/mod_cgi.so
LoadModule ldap_module modules/mod_ldap.so
LoadModule authnz_ldap_module modules/mod_authnz_ldap.so
LoadModule speling_module modules/mod_speling.so
LoadModule usertrack_module modules/mod_usertrack.so
LoadModule authn_alias_module modules/mod_authn_alias.so
LoadModule authn_default_module modules/mod_authn_default.so
LoadModule authz_default_module modules/mod_authz_default.so
LoadModule ldap_module modules/mod_ldap.so
LoadModule speling_module modules/mod_speling.so
LoadModule usertrack_module modules/mod_usertrack.so
/etc/httpd//conf/httpd.conf:    Order allow,deny
/etc/httpd//conf/httpd.conf:#        Order allow,deny
/etc/httpd//conf/httpd.conf:#        Order deny,allow
/etc/httpd//conf/httpd.conf:    Order allow,deny
/etc/httpd//conf/httpd.conf:    Order allow,deny
/etc/httpd//conf/httpd.conf:    Order allow,deny
/etc/httpd//conf/httpd.conf:        Order allow,deny
/etc/httpd//conf/httpd.conf:#    Order deny,allow
/etc/httpd//conf/httpd.conf:#    Order deny,allow
/etc/httpd//conf/httpd.conf:#    Order deny,allow
/etc/httpd//conf.d/99-preup-httpd.conf:            Order allow,deny

            

Result for NTP configuration

Result: pass

Rule ID: xccdf_preupg_rule_services_ntp_configuration_ntp

Time: 2015-06-17 16:20

Save ntp and ntpdate configuration files which are not tracked by rpm.

File(s) affected:

  • /etc/ntp.conf

  • /etc/ntp/step-tickers

Result for Information on time-sync.target

Result: pass

Rule ID: xccdf_preupg_rule_services_ntp_timesync_timesync

Time: 2015-06-17 16:20

Check if ntpdate service is enabled and print information on starting services with clock set

Result for OpenSSH sshd_config migration content

Result: pass

Rule ID: xccdf_preupg_rule_services_openssh_sshd_openssh-sshd

Time: 2015-06-17 16:20

This content has a aim to convert /etc/ssh/sshd_config file from openssh-server package

File(s) affected:

  • /etc/ssh/sshd_config

Result for OpenSSH sysconfig migration content

Result: fixed

Rule ID: xccdf_preupg_rule_services_openssh_sysconfig_openssh-sysconfig

Time: 2015-06-17 16:20

This content has a aim to convert /etc/sysconfig/sshd file from openssh-server package

File(s) affected:

  • /etc/sysconfig/sshd

Remediation instructions

_services_openssh_sysconfig_SOLUTION_MSG_TEXT

Result for Configuration for quota_nld service

Result: pass

Rule ID: xccdf_preupg_rule_services_quota_nld_configuration_checkscript

Time: 2015-06-17 16:20

Back configuration for quota_nld service up

File(s) affected:

  • /etc/sysconfig/quota_nld

Result for Disk quota netlink message daemon moved into quota-nld package

Result: pass

Rule ID: xccdf_preupg_rule_services_quota_nld_new_package_checkscript

Time: 2015-06-17 16:20

Install quota-nld package if the quota_nld service is enabled

Result for Check rsync

Result: pass

Rule ID: xccdf_preupg_rule_services_rsync_check

Time: 2015-06-17 16:20

There is now problem with rsync socket activation on RHEL-7.

Result for Detect LUKS devices using Whirlpool for password hash.

Result: pass

Rule ID: xccdf_preupg_rule_storage_cryptsetup-luks_detect-whirlpool-hash

Time: 2015-06-17 16:20

'Whirlpool hash implementation in libgcrypt of version <= 1.5.3 is broken. This content checks current system for presence of LUKS devices possibly using the bogus hash. In target system libgcrypt library is patched to use correct implementation so after reboot the freshly updated system may remain with LUKS devices imposibble to unlock.'

File(s) affected:

  • /etc/crypttab

Result for Luks encrypted partition

Result: pass

Rule ID: xccdf_preupg_rule_storage_luks_check

Time: 2015-06-17 16:20

Checks whether partition is crypted by CRYPTO-LUKS.

Result for State of LVM2 services.

Result: fixed

Rule ID: xccdf_preupg_rule_storage_lvm2-services_check_lvm2_services

Time: 2015-06-17 16:20

Some services are important for proper LVM functionality. This content checks for current state of existing services and makes sure the state is preserved over upgrade. Also, some systemd units should be enabled by default to allow for service's on-demand activation if needed.

Remediation instructions

_storage_lvm2-services_SOLUTION_MSG_TEXT

Result for Configuration for warnquota tool

Result: pass

Rule ID: xccdf_preupg_rule_storage_warnquota_configuration_checkscript

Time: 2015-06-17 16:20

Back configuration for warnquota tool up

File(s) affected:

  • /etc/quotagrpadmins

  • /etc/quotatab

  • /etc/warnquota.conf

Result for Disk quota tool warnquota moved into quota-warnquota package

Result: informational

Rule ID: xccdf_preupg_rule_storage_warnquota_new_package_checkscript

Time: 2015-06-17 16:20

Install quota-warnquota if need warnquota tool

Remediation instructions

_storage_warnquota_new_package_SOLUTION_MSG_TEXT

Result for Check for Add-On availability

Result: pass

Rule ID: xccdf_preupg_rule_system_AddOns_addons

Time: 2015-06-17 16:20

Content checks availability of High Availability, ResilientStorage and LoadBalancer Add-Ons.

Result for Architecture Support

Result: pass

Rule ID: xccdf_preupg_rule_system_Architecture_architecture

Time: 2015-06-17 16:20

Red Hat Enterprise Linux 7 does not support installations on 32-bit architectures, and performing an in-place upgrade is not possible on 32-bit systems.

Result for Binary rebuilds

Result: needs_inspection

Rule ID: xccdf_preupg_rule_system_BinariesRebuild_check

Time: 2015-06-17 16:21

Check all binaries installed on the assessment system which needs to be rebuilded on the target system

Remediation instructions

_system_BinariesRebuild_SOLUTION_MSG_TEXT

              
INPLACERISK: SLIGHT: Some scripts untracked by RPM were discovered on the system and may not work properly after upgrade.

            

Result for Debuginfo packages

Result: pass

Rule ID: xccdf_preupg_rule_system_Debuginfo_debuginfo

Time: 2015-06-17 16:21

This content checks for debuginfo packages and inform about potential risks for in-place upgrade.

Result for Read Only FHS directories

Result: informational

Rule ID: xccdf_preupg_rule_system_FHS_ReadOnlyFHS_check_script

Time: 2015-06-17 16:21

Check that critical directories of Filesystem Hierarchy Standard are not mounted read-only.

Remediation instructions

_system_FHS_ReadOnlyFHS_SOLUTION_MSG_TEXT

              
INPLACERISK: MEDIUM: Mount point /mnt/redhat is mounted read-only.
INPLACERISK: MEDIUM: Mount point /mnt/qa is mounted read-only.
INFO filesystem: Checking if /etc/mtab contains paths: ('/usr', '/var', '/var/run', '/var/lock')

            

Result for Check FHS for /var incompabilities.

Result: informational

Rule ID: xccdf_preupg_rule_system_FHS_Run_check

Time: 2015-06-17 16:21

Since RHEL 7 are some changes in FHS, which could be in conflicts with old system (e.g. movement /var/run -> /run).

Remediation instructions

_system_FHS_Run_SOLUTION_MSG_TEXT

Result for In-place Upgrade Requirements for the /usr/ Directory

Result: pass

Rule ID: xccdf_preupg_rule_system_FHS_UsrPartition_usr

Time: 2015-06-17 16:21

This module determines if the /usr/ directory is located on a separate partition.

Result for Cluster and High Availability

Result: pass

Rule ID: xccdf_preupg_rule_system_HA-Cluster_ha-cluster_hacluster

Time: 2015-06-17 16:21

Content checks Cluster and High Availability solutions for upgrade.

Result for File Systems, Partitions and Mounts Configuration Review

Result: informational

Rule ID: xccdf_preupg_rule_system_PartitionMounts_partmounts

Time: 2015-06-17 16:21

This module describes the new default file system and stores the partitions and mounts configuration.

Remediation instructions

_system_PartitionMounts_SOLUTION_MSG_TEXT

Result for Removable media in fstab

Result: informational

Rule ID: xccdf_preupg_rule_system_RemovableMedia_check_script

Time: 2015-06-17 16:21

Warn about removable media preventing boot

Remediation instructions

_system_RemovableMedia_SOLUTION_MSG_TEXT

Result for Sonamebumped libs

Result: informational

Rule ID: xccdf_preupg_rule_system_SonameBump_SonameBump

Time: 2015-06-17 16:21

If the dynamic library breaks the API/ABI compatibility, it is supposed to change its soname. This content checks for the soname bumps between RHEL 6 and RHEL 7 in your Red Hat packages.

Remediation instructions

_system_SonameBump_SOLUTION_MSG_TEXT

              
INPLACERISK: MEDIUM:  We detected some soname bumps in the libraries installed on the system. This may break the functionality of some of your 3rd party applications. They may need rebuild. Please check their requirements.

            

Result for SonameKept Reusable Dynamic Libraries

Result: informational

Rule ID: xccdf_preupg_rule_system_SonameKept_SonameKept

Time: 2015-06-17 16:21

This module provides an overview of the dynamic libraries from Red Hat Enterprise Linux 6 that can be reused in Red Hat Enterprise Linux 7, as the dynamic libraries remain compatible with both the application programming interface (API) and the application binary interface (ABI).

Remediation instructions

_system_SonameKept_SOLUTION_MSG_TEXT

Result for Removed .so libs

Result: needs_action

Rule ID: xccdf_preupg_rule_system_SonameRemoval_SonameRemoval

Time: 2015-06-17 16:22

Dynamic libraries are used provides symbols/functions to binaries. Some of the libraries were removed between RHEL 6 and RHEL 7. This content checks for the .so libraries removal between RHEL 6 and RHEL 7 in your Red Hat packages.

Remediation instructions

_system_SonameRemoval_SOLUTION_MSG_TEXT

              
INPLACERISK: HIGH: Library python-jinja2 (required by NonRH signed package(s):beaker-client ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl-XML-Parser (required by NonRH signed package(s):tps-devel ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library python-rhsm (required by NonRH signed package(s):redhat-upgrade-tool ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library rpm-python (required by NonRH signed package(s):preupgrade-assistant-contents preupgrade-assistant ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library rpm-python (required by NonRH signed package(s):preupgrade-assistant-contents preupgrade-assistant ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library aspell (required by NonRH signed package(s):qa-tools ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library aspell (required by NonRH signed package(s):qa-tools ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library python-lxml (required by NonRH signed package(s):beaker-client ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library python-krbV (required by NonRH signed package(s):beaker-redhat beaker-client ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library procps (required by NonRH signed package(s):qa-tools ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library mod_wsgi (required by NonRH signed package(s):preupgrade-assistant-ui ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library aspell (required by NonRH signed package(s):qa-tools ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library python-lxml (required by NonRH signed package(s):beaker-client ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library aspell (required by NonRH signed package(s):qa-tools ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library aspell (required by NonRH signed package(s):qa-tools ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library aspell (required by NonRH signed package(s):qa-tools ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
INPLACERISK: HIGH: Library perl (required by NonRH signed package(s):preupgrade-assistant-contents ) removed between RHEL 6 and RHEL 7
_speedups.so from python-jinja2 (required by NonRH signed package(s):beaker-client )
B.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
Base64.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
Byte.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
CN.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
Call.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
Cwd.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
DB_File.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
DProf.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
Dumper.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
EBCDIC.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
Encode.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
Expat.so from perl-XML-Parser (required by NonRH signed package(s):tps-devel )
FastCalc.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
Fcntl.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
FieldHash.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
GDBM_File.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
Glob.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
Hostname.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
IO.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
JP.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
KR.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
Langinfo.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
MD5.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
NDBM_File.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
Normalize.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
Opcode.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
POSIX.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
PPPort.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
Peek.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
SDBM_File.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
Socket.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
Soundex.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
Storable.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
Symbol.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
SysV.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
Syslog.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
TW.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
Unicode.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
Util.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
_certificate.so from python-rhsm (required by NonRH signed package(s):redhat-upgrade-tool )
_rpmbmodule.so from rpm-python (required by NonRH signed package(s):preupgrade-assistant-contents preupgrade-assistant )
_rpmmodule.so from rpm-python (required by NonRH signed package(s):preupgrade-assistant-contents preupgrade-assistant )
attrs.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
context-filter.so from aspell (required by NonRH signed package(s):qa-tools )
email-filter.so from aspell (required by NonRH signed package(s):qa-tools )
encoding.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
etree.so from python-lxml (required by NonRH signed package(s):beaker-client )
krbVmodule.so from python-krbV (required by NonRH signed package(s):beaker-redhat beaker-client )
libproc-3.2.8.so from procps (required by NonRH signed package(s):qa-tools )
mod_wsgi.so from mod_wsgi (required by NonRH signed package(s):preupgrade-assistant-ui )
mro.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
nroff-filter.so from aspell (required by NonRH signed package(s):qa-tools )
objectify.so from python-lxml (required by NonRH signed package(s):beaker-client )
re.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
scalar.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
sgml-filter.so from aspell (required by NonRH signed package(s):qa-tools )
shared.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
tex-filter.so from aspell (required by NonRH signed package(s):qa-tools )
texinfo-filter.so from aspell (required by NonRH signed package(s):qa-tools )
threads.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
via.so from perl (required by NonRH signed package(s):preupgrade-assistant-contents )
INPLACERISK: MEDIUM:  We detected some .so libraries installed on the system were removed between RHEL 6 and RHEL 7. This may break the functionality of some of your 3rd party applications.

            

Result for Check the system version

Result: pass

Rule ID: xccdf_preupg_rule_system_SystemVersion_check

Time: 2015-06-17 16:22

Check if the system is last released version

Result for CA certificate bundles modified

Result: pass

Rule ID: xccdf_preupg_rule_system_ca-certificates_checkbundles

Time: 2015-06-17 16:22

Later versions of RHEL include a shared store for certificate authorities. Additional trusted certificate authorities must be placed in the new location rather that modifying the distributed certificate authority bundles. The Preupgrade assistant cannot automatically identify how certificate bundles have been modified on this system.

Result for Developer Tool Set packages

Result: pass

Rule ID: xccdf_preupg_rule_system_dts_dts

Time: 2015-06-17 16:22

Content checks whether Red Hat Developer Tool Set packages are installed.

Result for Check for GRUB splash.xpm.gz file

Result: needs_inspection

Rule ID: xccdf_preupg_rule_system_grub_grub

Time: 2015-06-17 16:22

Content checks whether splash.xpm.gz file exists and backups them

Remediation instructions

_system_grub_SOLUTION_MSG_TEXT

              
INPLACERISK: SLIGHT: File splash.xpm.gz was backuped for inplace upgrade case and editing grub options

            

Result for Workaround for crashing grubby.

Result: fixed

Rule ID: xccdf_preupg_rule_system_grubby_check

Time: 2015-06-17 16:22

Workaround for crashing grubby. Fill initrd in /boot/grub/grub.conf by a postupgrade script.

Remediation instructions

_system_grubby_SOLUTION_MSG_TEXT

Result for Obsoleted HAL (Hardware Abstraction Layer)

Result: pass

Rule ID: xccdf_preupg_rule_system_hal_check_script

Time: 2015-06-17 16:22

Check for packages dependent on hal.

Result for Hyper-V

Result: pass

Rule ID: xccdf_preupg_rule_system_hyperv_check

Time: 2015-06-17 16:22

Check if this system runs on Hyper-V.

Result for Content for enabling and disabling services based on RHEL 6 system

Result: needs_action

Rule ID: xccdf_preupg_rule_system_initscripts_control_check

Time: 2015-06-17 16:22

The content checks what services are enabled or disabled on assessment system and if the services will be enabled or disabled on RHEL 7 system.

Remediation instructions

_system_initscripts_control_SOLUTION_MSG_TEXT

              
INPLACERISK: HIGH: The service blk-availability on RHEL 7 is disabled by default. Enable them via commands: systemctl enable blk-availability && systemctl start blk-availability.service .
INPLACERISK: HIGH: The service haldaemon on RHEL 7 is disabled by default. Enable them via commands: systemctl enable haldaemon && systemctl start haldaemon.service .
INPLACERISK: HIGH: The service ip6tables on RHEL 7 is disabled by default. Enable them via commands: systemctl enable ip6tables && systemctl start ip6tables.service .
INPLACERISK: HIGH: The service messagebus on RHEL 7 is disabled by default. Enable them via commands: systemctl enable messagebus && systemctl start messagebus.service .
INPLACERISK: HIGH: The service netfs on RHEL 7 is disabled by default. Enable them via commands: systemctl enable netfs && systemctl start netfs.service .
INPLACERISK: HIGH: The service network on RHEL 7 is disabled by default. Enable them via commands: systemctl enable network && systemctl start network.service .
INPLACERISK: HIGH: The service nfslock on RHEL 7 is disabled by default. Enable them via commands: systemctl enable nfslock && systemctl start nfslock.service .
INPLACERISK: HIGH: The service postfix on RHEL 7 is disabled by default. Enable them via commands: systemctl enable postfix && systemctl start postfix.service .
INPLACERISK: HIGH: The service rhsmcertd on RHEL 7 is disabled by default. Enable them via commands: systemctl enable rhsmcertd && systemctl start rhsmcertd.service .
INPLACERISK: HIGH: The service rpcgssd on RHEL 7 is disabled by default. Enable them via commands: systemctl enable rpcgssd && systemctl start rpcgssd.service .
INPLACERISK: HIGH: The service udev-post on RHEL 7 is disabled by default. Enable them via commands: systemctl enable udev-post && systemctl start udev-post.service .

            

Result for Check for ethernet interface naming

Result: needs_inspection

Rule ID: xccdf_preupg_rule_system_initscripts_ifcfg_check_script

Time: 2015-06-17 16:22

The content checks if network interface names set through /etc/sysconfig/network-scripts/ifcfg-* files are compatible with device naming in Red Hat Enterprise Linux 7.

Remediation instructions

_system_initscripts_ifcfg_SOLUTION_MSG_TEXT

              
INPLACERISK: SLIGHT: /etc/sysconfig/network-scripts/ifcfg-eth0 is old style ethX name without HWADDR, its name can change after upgrade.
DEBUG initscripts: checking ifcfg-lo, name: lo hwaddr: False
DEBUG initscripts: checking ifcfg-eth0, name: eth0 hwaddr: False

            

Result for User modification in /etc/rc.local and /etc/rc.d/rc.local

Result: pass

Rule ID: xccdf_preupg_rule_system_initscripts_rc-local_rclocal

Time: 2015-06-17 16:22

The content checks whether user modifies files /etc/rc.local and /etc/rc.d/rc.local

Result for Plugable authentication modules (PAM)

Result: pass

Rule ID: xccdf_preupg_rule_system_pam_pam

Time: 2015-06-17 16:22

Content checks for no-longer supported pluggable authentication modules

Result for Foreign Perl modules

Result: informational

Rule ID: xccdf_preupg_rule_system_perl_check

Time: 2015-06-17 16:24

Find Perl modules which need to be checked for proper functionality with newer Perl version on the Red Hat Enterprise Linux 7 system because they are not distributed by Red Hat

Remediation instructions

_system_perl_SOLUTION_MSG_TEXT

Result for PolicyKit (alias polkit) config files

Result: informational

Rule ID: xccdf_preupg_rule_system_polkit_check

Time: 2015-06-17 16:24

PolicyKit has important changes of config files. Check modyfied and owns config files.

Remediation instructions

_system_polkit_SOLUTION_MSG_TEXT

Result for Python 2.7.5

Result: needs_inspection

Rule ID: xccdf_preupg_rule_system_python_check

Time: 2015-06-17 16:24

This module provides you with a list of packages that need to be rebuilt for version 2.7.5 of the Python programming language that is shipped with Red Hat Enterprise Linux 7.

Remediation instructions

_system_python_SOLUTION_MSG_TEXT

              
INPLACERISK: SLIGHT: /usr/lib/python2.6/site-packages/Babel-0.9.4-py2.6.egg-info is owned by an RPM package that was not signed by Red Hat.
INPLACERISK: SLIGHT: /usr/lib/python2.6/site-packages/babel is owned by an RPM package that was not signed by Red Hat.
INPLACERISK: SLIGHT: /usr/lib/python2.6/site-packages/backports is owned by an RPM package that was not signed by Red Hat.
INPLACERISK: SLIGHT: /usr/lib/python2.6/site-packages/bkr is owned by an RPM package that was not signed by Red Hat.
INPLACERISK: SLIGHT: /usr/lib/python2.6/site-packages/bkr-20.1-py2.6.egg-info is owned by an RPM package that was not signed by Red Hat.
INPLACERISK: SLIGHT: /usr/lib/python2.6/site-packages/bkr.client-20.1-py2.6.egg-info is owned by an RPM package that was not signed by Red Hat.
INPLACERISK: SLIGHT: /usr/lib/python2.6/site-packages/kobo is not owned by any RPM package.
INPLACERISK: SLIGHT: /usr/lib/python2.6/site-packages/prettytable-0.6.1-py2.6.egg-info is owned by an RPM package that was not signed by Red Hat.
INPLACERISK: SLIGHT: /usr/lib/python2.6/site-packages/preup is owned by an RPM package that was not signed by Red Hat.
INPLACERISK: SLIGHT: /usr/lib/python2.6/site-packages/preup_ui is owned by an RPM package that was not signed by Red Hat.
INPLACERISK: SLIGHT: /usr/lib/python2.6/site-packages/preupgrade_assistant-0.11.12-py2.6.egg-info is owned by an RPM package that was not signed by Red Hat.
INPLACERISK: SLIGHT: /usr/lib/python2.6/site-packages/preuputils is owned by an RPM package that was not signed by Red Hat.
INPLACERISK: SLIGHT: /usr/lib/python2.6/site-packages/redhat_upgrade_tool is owned by an RPM package that was not signed by Red Hat.
INPLACERISK: SLIGHT: /usr/lib/python2.6/site-packages/rhts is owned by an RPM package that was not signed by Red Hat.
INPLACERISK: SLIGHT: /usr/lib/python2.6/site-packages/snake is owned by an RPM package that was not signed by Red Hat.
INPLACERISK: SLIGHT: /usr/lib64/python2.6/site-packages/report is not owned by any RPM package.
INPLACERISK: SLIGHT: /usr/lib64/python2.6/site-packages/reportclient is not owned by any RPM package.

            

Result for Save repositories for kickstart

Result: needs_inspection

Rule ID: xccdf_preupg_rule_system_repositories_check

Time: 2015-06-17 16:24

Content checks enabled repositories. Name and baseurl are stored to file available-repos in kickstart directory.

Remediation instructions

_system_repositories_SOLUTION_MSG_TEXT

              
INPLACERISK: SLIGHT: Repo beaker-harness is enabled.
INPLACERISK: SLIGHT: Repo rhel-source is not enabled.
INPLACERISK: SLIGHT: Repo rhel-source-beta is not enabled.
INPLACERISK: SLIGHT: Repo beaker-client is enabled.
INPLACERISK: SLIGHT: Repo beaker-client-testing is not enabled.
INPLACERISK: SLIGHT: Repo rhel is enabled.
INPLACERISK: SLIGHT: Repo rhel-opt is enabled.
INPLACERISK: SLIGHT: Repo qa-tools is enabled.
INPLACERISK: SLIGHT: Repo qa-tools-testing is not enabled.
INPLACERISK: SLIGHT: Repo epel is not enabled.
INPLACERISK: SLIGHT: Repo epel-debuginfo is not enabled.
INPLACERISK: SLIGHT: Repo epel-source is not enabled.
INPLACERISK: SLIGHT: Repo rhel-debuginfo is not enabled.
INPLACERISK: SLIGHT: Repo rhel-opt-debuginfo is not enabled.
INPLACERISK: SLIGHT: Repo preupgrade-assistant is enabled.
INPLACERISK: SLIGHT: Repo beaker-tasks is not enabled.
INPLACERISK: SLIGHT: Enabled repo files for kickstart generation are stored /root/preupgrade/kickstart/available-repos.

            

Result for Check system requirements

Result: needs_action

Rule ID: xccdf_preupg_rule_system_requirements_check

Time: 2015-06-17 16:24

Check if system comply minimum requirements

Remediation instructions

_system_requirements_SOLUTION_MSG_TEXT

              
INPLACERISK: HIGH: Diskspace is lower then minimum requirements for correct run of new system!

            

Result for SCL collections

Result: pass

Rule ID: xccdf_preupg_rule_system_scl-collection_scl

Time: 2015-06-17 16:24

Content checks whether RHSCL are installed

Result for Red Hat Subscription Manager

Result: pass

Rule ID: xccdf_preupg_rule_system_subscription-manager_check

Time: 2015-06-17 16:24

This module adds new option to the configuration file, if it is not there already.

Result for System kickstart

Result: pass

Rule ID: xccdf_preupg_rule_system_system-kickstart_ks

Time: 2015-06-17 16:24

Copy system kickstart from /root/ to directory with results

Result for UEFI bootloader

Result: informational

Rule ID: xccdf_preupg_rule_system_uefi_check

Time: 2015-06-17 16:24

It is necessary to migrate UEFI systems to grub2-efi

Remediation instructions

_system_uefi_SOLUTION_MSG_TEXT

Result for YUM

Result: informational

Rule ID: xccdf_preupg_rule_system_yum_yum

Time: 2015-06-17 16:24

Content checks YUM configuration file

Remediation instructions

_system_yum_SOLUTION_MSG_TEXT

Result for Check for usage of dangerous ranges of UID and GIDs

Result: pass

Rule ID: xccdf_preupg_rule_usrmgmt_DangerousRanges_dangerousranges

Time: 2015-06-17 16:24

This module checks for IDs in the 0-199 range used without reservations. This module also checks for IDs which need to be moved from the 501-999 range prior to migration.

Result for Incorrect usage of reserved UID/GIDs

Result: pass

Rule ID: xccdf_preupg_rule_usrmgmt_ReservedIDs_reservedids

Time: 2015-06-17 16:24

Reserved user and group IDs by setup package changed between the RHEL 6 and RHEL 7. This may in some cases cause the unfunctionality of your system after the migration. This check should mitigate the risks.

Result for Check libuser.conf

Result: pass

Rule ID: xccdf_preupg_rule_usrmgmt_libuser_check

Time: 2015-06-17 16:24

Check for rejected configuration in /etc/libuser.conf about combination ldap module with others, due to ambiguity in password handling.