
Section 508 Compliance Test Report
Department of Homeland Security (DHS)

Office of Accessible Systems & Technology (OAST)

Product Review Information
Requestor Component: HQ Review Date: 11/3/2014
Application Name: Mozilla Firefox 31.1.1 ESR (CR - HSD LAN-A)
Application Version: 31.1.1
Vendor: Mozilla    
URL/Product Type: COTS 3.0 Test Results: Not Compliant
Application Description: Internet browser
Functions Tested: Web, Software
Test Environment
Operating System: Windows 7
Browser: N/A
Compatibility View: N/A

ACMS Ticket #: 15-00280
3.0 Trusted Tester(s): Margaret Rasor
Trusted Tester ID#: 300073
Tester Component: HQ

Applicable Section 508 Standards
1194.21 (Software Applications and Operating Systems), 1194.22 (Web-based Intranet 
and Internet Information and Applications), 1194.31 (Functional performance)

Review History

DHS Test Step Section 508 Standard Test Results
1.1 Keyboard Access 21(a), 21(c), 31(a), 31(b) (11/3/2014) Review 1: NC
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1.2.1 SW: All interactive 
elements

21(d) (11/3/2014) Review 1: NC

1.2.2 Web: Forms 22(n) (11/3/2014) Review 1: NC
1.2.3 Web: Links and User 
Controls

31(a), 31(b) (11/3/2014) Review 1: NC

2.1 SW: Images 21(d) (11/3/2014) Review 1: NC
3.1 Color Dependence 21(i) (11/3/2014) Review 1: NC
3.2 Color Contrast 31(b) (11/3/2014) Review 1: NC
10 Web: Data Tables 22(g) (11/3/2014) Review 1: NC

Disabilities Impacted
Due to the Section 508 compliance issues identified in this report, this product may 
impact people with the following disabilities: Blind, Low Vision, Mobility, Other.

Comments
This application was tested according to DHS Section 508 Compliance Test Process for 
Applications, version 3.0.  The test process is posted online at 
http://dhsconnect.dhs.gov/org/comp/mgmt/cio/oast/Documents/OAST_Training. (In 
Word report, ** before a failure condition means it was part of version 2.8 of the DHS 
Test Process.)

2



Section 508 Compliance Test Report

DHS Test Description Results
1.1 Keyboard 
Access

1194.21 (Software Applications and Operating Systems) a (Executing Function From Keyboard), c (Input 
Focus), 1194.31 (Functional performance) a (Blindness), b (Low vision) Baselines: B01, B02, B03, B04

NC

Example 1 A. **An interactive element or function cannot be accessed or activated by keyboard (21(a), B01)

The icons on the Customize Firefox page are drag and drop and not accessible via the keyboard. The entire 
page is not accessible via the keyboard unless the mouse is used to place the cursor in the page. 

Location: From the browser menu, select View>Toolbars>Customize. 

(11/3/2014) 
Review 1: NC

Example 2 A. **An interactive element or function cannot be accessed or activated by keyboard (21(a), B01) (11/3/2014) 
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There is a text box that has two columns of sortable data, the column headers are clickable buttons that can be 
used to sort but are not available via the keyboard. 

Location: From the menu select Tools>Options window>Applications tab. 

Review 1: NC

Example 3 A. **An interactive element or function cannot be accessed or activated by keyboard (21(a), B01) (11/3/2014) 
Review 1: NC
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The  Certificate Manager modal dialog has an icon for displaying a menu that allows the user to change the 
column order in the list, it is not accessible via the keyboard. 

Location: From the browser menu select Tools>Options, from the Options window select the Advanced icon, 
then the Certificates tab. From the Certificates tab click the View Certificates pushbutton to display the 
Certificate Manager window. 

Example 4 A. **An interactive element or function cannot be accessed or activated by keyboard (21(a), B01)
There is a global defect in any of the dialogs that are available from various menu items. Where any text box 
has column headings for a data table, that are interactive, they are not accessible via the keyboard. 

(11/3/2014) 
Review 1: NC
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Example 5 A. **An interactive element or function cannot be accessed or activated by keyboard (21(a), B01)

The Editing Tools drop down icon in the Keyboard Shortcuts page is not accessible via the keyboard. 

Location: From the browser menu select Help>Keyboard Shortcuts. 

(11/3/2014) 
Review 1: NC

Example 6 E. **At any time, there is no visual indication of the current focus (loss of focus) (21(c), B02) (11/3/2014) 
Review 1: NC
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In the Certificate Manager dialog window there are various tabs, all have a data table with columns that are 
sortable. When navigating using the keyboard, focus is lost between the tab and the buttons beneath the data 
table.

Location: From the browser menu, select Tools>Options. From the Options window click on the Advanced 
icon, then on the Certificates tab. From the Certificates tab, click on the View Certificates button. From the 
Certificates Manager window, select any tab.  

Example 7 E. **At any time, there is no visual indication of the current focus (loss of focus) (21(c), B02) (11/3/2014) 
Review 1: NC
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In the Keyboard Shortcuts window the focus is lost after entering the Search Mozilla Support field. The Search 
icon is interactive but no focus appears. 

From the browser menu, select Help>Keyboard Shortcuts and navigate to the Search Mozilla Support field. 
Example 8 H. The visual focus does not move to revealed content and no description of the content change is provided  

(31(a), 31(b), B04)

When the user navigates to the Tools>Web Developer>Inspector, a pane is revealed on the bottom of the web 
page and it is not clear where focus is as three different areas appear to have focus. 

(11/3/2014) 
Review 1: NC

Example 9 H. The visual focus does not move to revealed content and no description of the content change is provided  
(31(a), 31(b), B04)

(11/3/2014) 
Review 1: NC
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The Certificate Manager modal dialog has a column sort order icon that has a popup that appears when the icon
is clicked. Focus does not move to the popup when it revealed and it cannot be accessed via the keyboard 
unless the user first uses the mouse. 

Location: From the menu select Tools>Options, from the Options window select the Advanced icon>then the 
Certificates tab. From the Certificates tab click the View Certificates pushbutton to display the Certificate 
Manager window.

1.2.1 SW: All 
interactive 

1194.21 (Software Applications and Operating Systems) d (Interface Elements), f (Textual Information), l 
(Electronic Forms) Baselines: B06, B11, B16

NC
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elements
Example 1 A. **A user control does not have a descriptive and unique Name property (21(d), B16)

The Options>Applications window has a table with two column headers that are clickable buttons that can be 
used to sort the contents of the table. The Name for Content Type column header is "". 

Location: From the browser menu select Tools>Options, then click on the Applications icon. 

(11/3/2014) 
Review 1: NC

Example 2 B. **A user control has an incorrect Role and/or State (21(d), B16) (11/3/2014) 
Review 1: NC
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The Options>Applications window has a table with two column headers that are clickable buttons that can be 
used to sort the contents of the table. The Role and State are incorrect. Role should be "push button" and State 
should be "focused, pressed". 

Location: From the browser menu select Tools>Options, then click on the Applications icon. 
Example 3 C. An interactive interface element that has multiple statuses does not indicate its current status (21(d), B06) (11/3/2014) 
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The Options>Applications window has a table with two column headers that are clickable buttons that can be 
used to sort the contents of the table either A-Z or Z-A. There is no indication of the sort order in the Name 
attribute. 

Location: From the browser menu select Tools>Options, then click on the Applications icon. 

Review 1: NC

1.2.2 Web: 
Forms

1194.22 (Web-based Intranet and Internet Information and Applications) n (Form Labels) Baselines: B11 NC

Example 1 A. **A Web form field has no markup to associate it to its complete instructions and cues (22(n), B11) (11/3/2014) 
Review 1: NC
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The Search Mozilla Support field has ID but no Label/For. The Customize this Article section Firefox 
checkbox and drop down menus do not have valid Label/For and ID. The Was this article helpful Yes and No 
buttons do not have valid Label/For and ID. 

Location: From the browser menu select Help>Keyboard Shortcuts. 
1.2.3 Web: 
Links and User
Controls

1194.22 (Web-based Intranet and Internet Information and Applications) l (Script Functional Text), 1194.31 
(Functional performance) a (Blindness), b (Low vision) Baselines: B16

NC

Example 1 A. A link does not have a unique and meaningful description (31(a), 31(b), B16) (11/3/2014) 
Review 1: NC
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There is a URL that does not have a meaningful title and a link that says "find out how" that is not meaningful. 
There is no TITLE attribute for either of them. 

2.1 SW: Images 1194.21 (Software Applications and Operating Systems) d (Interface Elements), e (Bitmap Images) Baselines: 
B06, B07, B13, B14

NC

Example 1 A. **An image does not have an equivalent text description (Name), correct Role, or correct State (21(d), B07)

The Reload Current Page icon on the address bar has a correct tooltip but Name attribute is "Location" which is
also the name of the icon to the left of it.  

(11/3/2014) 
Review 1: NC

Example 2 A. **An image does not have an equivalent text description (Name), correct Role, or correct State (21(d), B07) (11/3/2014) 
Review 1: NC
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The Name and State for the Search icon in the Search textbox are incorrect. Location: From the menu select 
Tools>Options window>Applications tab. 

Example 3 B. **Any interface element that has multiple statuses does not indicate its current status (21(d), B06)

In the table, the Name and State for the both the Content Type and Action columns' headers do not display the 
current Name or State when sorted. The sort order is not described. NOTE: This is a global defect anywhere 
there is a table that allows the user to use the column headers to sort the table. 

Location: From the menu select Tools>Options window>Applications tab. 

(11/3/2014) 
Review 1: NC

Example 4 C. **A data table's headers are not identified (21(d), B13) (11/3/2014) 
Review 1: NC
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In the table, the Name for the both the Content Type and Action columns' headers is "". 

Location: From the menu select Tools>Options window>Applications tab. 
3.1 Color 
Dependence

1194.21 (Software Applications and Operating Systems) i (Color Coding), 1194.22 (Web-based Intranet and 
Internet Information and Applications) c (Color Dependence) Baselines: B08

NC

Example 1 A. **In software, information is provided only by color (21(i), B08)

The Colors dialog has blocks of colors for Text and Background and Link Colors that are identified by color 
only. 

Location: From the browser menu, select Tools>Options. From the Options window select the Content icon, 

(11/3/2014) 
Review 1: NC
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then click the Colors button to display the Colors dialog. 
3.2 Color 
Contrast

1194.31 (Functional performance) b (Low vision) Baselines: B09 NC

Example 1 A. The contrast ratio is less than 4.5:1 for content background and foreground colors (31(b), B09)

Select the View menu>Toolbars>Customize, default text in the address bar is 1.77:1. 

(11/3/2014) 
Review 1: NC

Example 2 A. The contrast ratio is less than 4.5:1 for content background and foreground colors (31(b), B09)

The text inside the Search Mozilla Support field color ratio is 3.0:1.

Location: From the browser menu select Help>Keyboard Shortcuts.  

(11/3/2014) 
Review 1: NC

10 Web: Data 
Tables

1194.22 (Web-based Intranet and Internet Information and Applications) g (Data Table Headers), h (Complex 
Data Table Header-Cell Association) Baselines: B13, B14

NC

Example 1 A. **Any data table's row or column headers are not identified programmatically (22(g), B13) (11/3/2014) 
Review 1: NC
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There are several tables on the Keyboard Shortcuts that do not have scoped header and row cells. 

Location: From the browser menu, select Help>Keyboard Shortcuts. 

This application was tested according to DHS Section 508 Compliance Test Process for
Applications, version 3.0
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DHS Specific Test Approaches

DHS specific test approach for Flashing (Baseline 10 and Section 508 [21k and 22j])

The term 'flickering' encompasses interface elements that flash, blink, flicker repetitively, or elements that scroll (e.g., marquee text).
Current Section 508 requirements do not permit elements to flash or flicker at frequencies between 2Hz and 55Hz. To incorporate the expected 
update to this requirement, this flashing test adopts the WCAG 2.0 frequency restriction to below 3Hz.
Due to factors that are not within the developer's control (such as the refresh frequency of a user's monitor, Internet speed, and other display 
factors), the frequency of a flashing item can be unpredictable from computer to computer. Given this uncertainty, the only specification that can 
be inspected is the programmed frequency of flashing items. Flashing elements that do not have a frequency property or attribute will be found 
not compliant.

How To Test
1. Visually check for any flashing or blinking interface elements or scrolling text. Scrolling images should be tested under Section 2.2 (SW 
animation) or Section 2.4 (video).
2. Determine if the flickering element is Software or Web.
3. Determine the programmatic frequency of the flickering element. This will often require viewing source code and/or contacting the developer.
To view the source of a part of the page, highlight the section of the page using the mouse. Use WAT>Doc Info>View Partial Source. 

DHS specific test approach for Variety of Color Selections in SW (Section 508 21j)
If an application adopted the OS high contrast colors, 21(g) and 21(j) are compliant per Baseline 28. If the application did not adopt the OS high 
contrast colors, 21(g) is not compliant. However, if the application offers its own color options, then 21(j) can be compliant.
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Section 508 Test Results

21(a) Executing 
Function 
From 
Keyboard

NC

21(b) Accessibility 
Features

C

21(c) Input Focus NC
21(d) Interface 

Elements
NC

21(e) Bitmap 
Images

DNA

21(f) Textual 
Information

C

21(g) User Selected
Attributes

C

21(h) Animation DNA
21(i) Color Coding NC
21(j) Color 

Contrast 
Settings

C

21(k) Flashing or 
Blinking Text

DNA

21(l) Electronic 
Forms

C

22(a) Text C
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Equivalents
22(b) Multimedia: 

Captioning
DNA

22(c) Color 
Dependence

C

22(d) Style Sheet 
Dependence

C

22(e) Server Side 
Image Map 
Text Links

DNA

22(f) Use Client 
Side Image 
Maps

DNA

22(g) Data Table 
Headers

NC

22(h) Complex 
Data Table 
Header-Cell 
Association

DNA

22(i) Frame Titles DNA
22(j) Flicker DNA
22(k) Text-only 

Alternative
DNA

22(l) Script 
Functional 
Text

C

22(m
)

Plug-In Links DNA

22(n) Form Labels NC
22(o) Skip 

Navigation
C

22(p) Timed DNA
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Response
24(c) Captioned DNA
24(d) Audio 

Described
DNA

31(a) Blindness NC
31(b) Low vision NC

(C=Compliant, NC=Not Compliant, DNA=Does Not Apply)
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Baseline Test Results

B0
1

Keyboard 
navigation

NC

B0
2

Focus (visible) NC

B0
3

Focus (order) C

B0
4

Focus (Revealing 
hidden content)

NC

B0
5

Skip-navigation 
links

C

B0
6

Multi-state 
components

NC

B0
7

Images NC

B0
8

Color (meaning) NC

B0
9

Color (contrast) NC

B1
0

Flashing 
(reserved)*

DN
A

B11 Forms (associated
instructions)

NC

B1
2

Page Titles C
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B1
3

Data Tables 
(headers)

NC

B1
4

Data Tables (cell-
header mapping)

DN
A

B1
5

Headings C

B1
6

Links and user 
controls

NC

B1
7

Language C

B1
8

Audio 
(transcripts)

DN
A

B1
9

Video 
(descriptions)

DN
A

B2
0

Synchronized 
Media (captions)

DN
A

B2
1

Synchronized 
Media 
(descriptions)

DN
A

B2
2

Style-sheet non-
dependence

C

B2
3

Frames DN
A

B2
4

Alternate pages DN
A

B2
5

Time outs DN
A

B2
6

Image maps DN
A

B2
7

Plug-in Links DN
A

B2 Built-in C
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8 accessibility 
features

(C=Compliant, NC=Not Compliant, DNA=Does Not Apply)
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