
32 | Getting Started with LibreOffice 5.0
	 | 1
[bookmark: __RefHeading__5636_1566568644]Copyright
This document is Copyright © 2016 by the LibreOffice Documentation Team. Contributors are listed below. You may distribute it and/or modify it under the terms of either the GNU General Public License (http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution License (http://creativecommons.org/licenses/by/4.0/), version 4.0 or later.
All trademarks within this guide belong to their legitimate owners.
[bookmark: __RefHeading__5638_1566568644]Contributors
Jean Hollis Weber	Peter Schofield	Ron Faile Jr.
Martin Fox	Dan Lewis	David Michel
Andrew Pitonyak	Hazel Russman	Jeremy Cartwright
John A Smith	Martin Saffron	Laurent Balland-Poirier
Bruce Byfield	Reizinger Zoltán
Cover art:
Klaus-Jürgen Weghorn	Jean Hollis Weber
[bookmark: __RefHeading__5640_1566568644]Feedback
Please direct any comments or suggestions about this document to the Documentation Team’s mailing list: documentation@global.libreoffice.org
Note: Everything you send to a mailing list, including your email address and any other personal information that is written in the message, is publicly archived and cannot be deleted.
[bookmark: __RefHeading__5642_1566568644]Acknowledgments
This book is adapted and updated from Getting Started with OpenOffice.org 3.3. The contributors to that book are listed on page 13.
[bookmark: __RefHeading__5644_1566568644]Publication date and software version
Published 4 March 2016. Based on LibreOffice 5.0.

Contents
Copyright	2
Contributors	2
Feedback	2
Acknowledgments	2
Publication date and software version	2
 Preface	9
Who is this book for?	10
What's in this book?	10
Where to get more help	10
What you see may be different	11
Using LibreOffice on a Mac	12
What are all these things called?	12
Who wrote this book?	13
Acknowledgements	13
Frequently asked questions	13
What’s new in LibreOffice 5.0?	14
Chapter 1 Introducing LibreOffice	15
What is LibreOffice?	16
Advantages of LibreOffice	17
Minimum requirements	18
How to get the software	18
How to install the software	18
Extensions and add-ons	18
Starting LibreOffice	18
Parts of the main window	21
Starting new documents	26
Opening existing documents	27
Saving documents	28
Password protection	29
Renaming and deleting files	30
Open and Save As dialogs	30
Using the Navigator	30
Undoing and redoing changes	31
Closing a document	32
Closing LibreOffice	32
Chapter 2 Setting up LibreOffice	33
Choosing options for all of LibreOffice	34
Choosing Load/Save options	49
Choosing language settings	54
Choosing Internet options	58
Controlling LibreOffice’s AutoCorrect functions	59
Chapter 3 Using Styles and Templates	61
What is a template?	62
What are styles?	62
Applying styles	63
Modifying styles	65
Creating new (custom) styles	67
Copying styles from a template or document	68
Deleting styles	69
Using a template to create a document	69
Creating a template	70
Editing a template	72
Adding templates obtained from other sources	73
Setting a default template	74
Associating a document with a different template	75
Organizing templates	75
Examples of style use	77
Chapter 4 Getting Started with Writer	79
What is Writer?	80
The Writer interface	80
Changing document views	85
Moving quickly through a document	85
Working with documents	86
Working with text	87
Formatting text	96
Formatting pages	100
Adding comments to a document	105
Creating a table of contents	106
Creating indexes and bibliographies	107
Working with graphics	107
Printing	107
Using mail merge	107
Tracking changes to a document	108
Using fields	108
Linking to another part of a document	108
Using master documents	111
Creating fill-in forms	111
Chapter 5 Getting Started with Calc	112
What is Calc?	113
Spreadsheets, sheets and cells	113
Calc main window	113
Opening a CSV file	118
Saving spreadsheets	120
Navigating within spreadsheets	121
Selecting items in a spreadsheet	125
Working with columns and rows	127
Working with sheets	129
Viewing Calc	131
Using the keyboard	133
Speeding up data entry	137
Sharing content between sheets	140
Validating cell contents	141
Editing data	141
Formatting data	142
AutoFormat of cells	146
Using themes	147
Using conditional formatting	147
Hiding and showing data	148
Sorting records	149
Using formulas and functions	150
Analyzing data	150
Printing	151
Chapter 6 Getting Started with Impress	155
What is Impress?	156
Starting Impress	156
Main Impress window	156
Workspace views	160
Creating a new presentation using the Presentation Wizard	164
Formatting a presentation	167
Adding and formatting text	171
Adding pictures, tables, charts, and media	176
Working with slide masters and styles	179
Adding comments to a presentation	185
Setting up a slide show	186
Chapter 7 Getting Started with Draw	189
What is Draw?	190
Draw main window	190
Choosing and defining colors	194
Drawing basic shapes	195
Glue points and connectors	200
Drawing geometric shapes	202
Selecting objects	203
Moving and adjusting object size	205
Rotating and slanting an object	206
Editing objects	208
Formatting area fill	210
Using styles	211
Positioning objects	211
Applying special effects	213
Combining multiple objects	215
Arranging, aligning, and distributing objects	216
Inserting and editing pictures	217
Working with 3D objects	217
Exporting graphics	217
Inserting comments in a drawing	217
Chapter 8 Getting Started with Base	219
Introduction	220
Planning a database	221
Creating a new database	222
Creating database tables	223
Creating a database form	231
Entering data in a form	244
Creating queries	246
Creating reports	254
Accessing other data sources	257
Using data sources in LibreOffice	259
Chapter 9 Getting Started with Math	264
Introduction	265
Getting started	265
Creating formulas	267
Editing formulas	270
Formula layout	271
Changing formula appearance	277
Formulas in Writer	282
Formulas in Calc, Draw, and Impress	288
Chapter 10 Printing, Exporting, E‑mailing	290
Quick printing	291
Controlling printing	291
Exporting to PDF	299
Exporting to other formats	306
E-mailing documents	306
Digital signing of documents	309
Removing personal data	310
Chapter 11 Graphics, Gallery, Fontwork	311
Introduction	312
Adding images to a document	312
Modifying and positioning graphics	316
Managing the LibreOffice Gallery	316
Creating an image map	318
Using LibreOffice’s drawing tools	320
Using Fontwork	322
Chapter 12 Creating Web Pages	327
Introduction	328
Relative and absolute hyperlinks	328
Creating hyperlinks	329
Exporting web pages using the Web Wizard	332
Saving and exporting documents as web pages	335
Chapter 13 Getting Started with Macros	341
Introduction	342
Your first macros	342
Creating a macro	348
Macro recorder failures	352
Macro organization	353
How to run a macro	356
Extensions	358
Writing macros without the recorder	359
Finding more information	359
Chapter 14 Customizing LibreOffice	361
Introduction	362
Customizing menu content	362
Customizing toolbars	365
Assigning shortcut keys	368
Assigning macros to events	371
Adding functionality with extensions	371
Appendix A Keyboard Shortcuts	373
Introduction	374
General keyboard shortcuts	375
Navigating and selecting with the keyboard	376
Controlling dialogs	376
Controlling macros	377
Managing documents	377
Editing	377
Selecting rows and columns in a database table opened by F4	378
Shortcut keys for drawing objects	378
Defining keyboard shortcuts	379
Further reading	379
Appendix B Open Source, Open Standards, OpenDocument	380
Introduction	381
A short history of LibreOffice	381
The LibreOffice community	381
How is LibreOffice licensed?	382
What is “open source”?	382
What are “open standards”?	382
What is OpenDocument?	382
File formats LibreOffice can open	383
File formats LibreOffice can save to	385
Exporting to other formats	386
Index	387

Documentation for LibreOffice is available at http://www.libreoffice.org/get-help/documentation
8| Getting Started with LibreOffice 5.0
Getting Started with LibreOffice 5.0 | 7

[bookmark: __RefHeading__126734_789510747]
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[bookmark: __RefHeading___Toc76350_811363531]Who is this book for?
Anyone who wants to get up to speed quickly with LibreOffice will find this Getting Started Guide valuable. You may be new to office software, or you may be familiar with another office suite.
[bookmark: __RefHeading__6749_1241987491]What's in this book?
This book introduces the main components of LibreOffice:
· Writer (word processing)
· Calc (spreadsheets)
· Impress (presentations)
· Draw (vector graphics)
· Base (database
· Math (equation editor)
It also covers some of the features common to all components, including setup and customization, styles and templates, macro recording, and printing. For more detail, see the user guides for the individual components.
[bookmark: __RefHeading__6751_1241987491]Where to get more help
This book, the other LibreOffice user guides, the built-in Help system, and user support systems assume that you are familiar with your computer and basic functions such as starting a program, opening and saving files.
[bookmark: __RefHeading__22027_697337876]Help system
LibreOffice comes with an extensive Help system. This is your first line of support for using LibreOffice.
To display the full Help system, press F1 or select LibreOffice Help from the Help menu. In addition, you can choose whether to activate Tips, Extended tips, and the Help Agent (using Tools > Options > LibreOffice > General). 
If Tips are enabled, place the mouse pointer over any of the icons to see a small box (“tooltip”) with a brief explanation of the icon’s function. For a more detailed explanation, select Help > What's This? and hold the pointer over the icon.
[bookmark: __RefHeading__22029_697337876]Free online support
The LibreOffice community not only develops software, but provides free, volunteer-based support. See Table 1 and this web page: http://www.libreoffice.org/get-help/ 
You can get comprehensive online support from the community through mailing lists and the Ask LibreOffice website. Other websites run by users also offer free tips and tutorials. This forum provides community support for LibreOffice: http://en.libreofficeforum.org/
This site provides support for LibreOffice, among other programs:
http://forum.openoffice.org/en/forum/ 
[bookmark: Ref_Table0_label_and_number]Table 1: Free support for LibreOffice users
	Free LibreOffice support

	Ask LibreOffice
	Questions and answers from the LibreOffice community
http://ask.libreoffice.org/en/questions/ 

	Documentation
	User guides, how-tos, and other documentation. http://www.libreoffice.org/get-help/documentation/
https://wiki.documentfoundation.org/Documentation/Publications 

	FAQs
	Answers to frequently asked questions
http://wiki.documentfoundation.org/Faq

	Mailing lists
	Free community support is provided by a network of experienced users
http://www.libreoffice.org/get-help/mailing-lists/

	International support
	The LibreOffice website in your language.
http://www.libreoffice.org/international-sites/
International mailing lists
http://wiki.documentfoundation.org/Local_Mailing_Lists

	Accessibility options
	Information about available accessibility options. http://www.libreoffice.org/get-help/accessibility/


[bookmark: __RefHeading__262303_271332650]Paid support and training
Alternatively, you can pay for support services. Service contracts can be purchased from a vendor or consulting firm specializing in LibreOffice.
[bookmark: __RefHeading__11088_1241987491]What you see may be different
[bookmark: __RefHeading__1550_1307201209]Illustrations
LibreOffice runs on Windows, Linux, and Mac OS X operating systems, each of which has several versions and can be customized by users (fonts, colors, themes, window managers). The illustrations in this guide were taken from a variety of computers and operating systems. Therefore, some illustrations will not look exactly like what you see on your computer display.
Also, some of the dialogs may be different because of the settings selected in LibreOffice. You can either use dialogs from your computer system (default) or dialogs provided by LibreOffice. To change to using LibreOffice dialogs:
 1) On Linux and Windows operating systems, go to Tools > Options > LibreOffice > General on the menu bar to open the dialog for general options.
On a Mac operating system, go to LibreOffice > Preferences > General on the menu bar to open the dialog for general options.
 2) Select Use LibreOffice dialogs in Open/Save dialogs to display the LibreOffice dialogs.
 3) Click OK to save your settings and close the dialog.
[bookmark: __RefHeading__7596_641027044]Icons
The icons used to illustrate some of the many tools available in LibreOffice may differ from the ones used in this guide. The icons in this guide have been taken from a variety of LibreOffice installations that use different sets of icons.
[bookmark: __RefHeading__11174_1241987491]Using LibreOffice on a Mac
Some keystrokes and menu items are different on a Mac from those used in Windows and Linux. The table below gives some common substitutions for the instructions in this chapter. For a more detailed list, see the application Help.
	Windows or Linux
	Mac equivalent
	Effect

	Tools > Options menu selection
	LibreOffice > Preferences
	Access setup options

	Right-click
	Control+click and/or right-click depending on computer setup
	Open a context menu

	Ctrl (Control)
	⌘ (Command)
	Used with other keys

	F5
	Shift+⌘+F5
	Open the Navigator

	F11
	⌘+T
	Open the Styles and Formatting window


[bookmark: __RefHeading__10924_1241987491]What are all these things called?
The terms used in LibreOffice for most parts of the user interface (the parts of the program you see and use, in contrast to the behind-the-scenes code that actually makes it work) are the same as for most other programs.
A dialog is a special type of window. Its purpose is to inform you of something, or request input from you, or both. It provides controls for you to use to specify how to carry out an action. The technical names for common controls are shown in Figure 1 (legend is on next page). In most cases the technical terms are not used in this book, but it is useful to know them because the Help and other sources of information often use them.

[bookmark: Ref_Figure0_label_and_number]Figure 1: Dialog showing common controls

1. Tabbed page (not strictly speaking a control).
 5) Radio buttons (only one can be selected at a time).
 6) Checkbox (more than one can be selected at a time).
 7) Spin box (click the up and down arrows to change the number shown in the text box next to it, or type in the text box).
 8) Thumbnail or preview.
 9) Drop-down list from which to select an item.
 10) Push buttons.
In most cases, you can interact only with the dialog (not the document itself) as long as the dialog remains open. When you close the dialog after use (usually, clicking OK or another button saves your changes and closes the dialog), then you can again work with your document.
Some dialogs can be left open as you work, so you can switch back and forth between the dialog and your document. An example of this type is the Find & Replace dialog.
[bookmark: __RefHeading__1552_1307201209]Who wrote this book?
This book was written by volunteers from the LibreOffice community. Profits from sales of the printed edition will be used to benefit the community.
[bookmark: __RefHeading__6761_1241987491]Acknowledgements
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[bookmark: __RefHeading__6763_1241987491]Frequently asked questions
How is LibreOffice licensed?
LibreOffice 4.4 is distributed under the Open Source Initiative (OSI) approved Mozilla Public License (MPL). The MPL license is available from http://www.mozilla.org/MPL/2.0/.
May I distribute LibreOffice to anyone? May I sell it? May I use it in my business?
Yes.
How many computers may I install it on?
As many as you like.
Is LibreOffice available in my language?
LibreOffice has been translated (localized) into over 40 languages, so your language probably is supported. Additionally, there are over 70 spelling, hyphenation, and thesaurus dictionaries available for languages, and dialects that do not have a localized program interface. The dictionaries are available from the LibreOffice website at: www.libreoffice.org.
How can you make it for free?
LibreOffice is developed and maintained by volunteers and has the backing of several organizations.
I am writing a software application. May I use programming code from LibreOffice in my program?
You may, within the parameters set in the MPL. Read the license: http://www.mozilla.org/MPL/2.0/.
Why do I need Java to run LibreOffice? Is it written in Java?
LibreOffice is not written in Java; it is written in the C++ language. Java is one of several languages that can be used to extend the software. The Java JDK/JRE is only required for some features. The most notable one is the HSQLDB relational database engine.
Note: Java is available at no cost. If you do not want to use Java, you can still use nearly all of the features of LibreOffice.
How can I contribute to LibreOffice?
You can help with the development and user support of LibreOffice in many ways, and you do not need to be a programmer. To start, check out this webpage: http://www.documentfoundation.org/contribution/
May I distribute the PDF of this book, or print and sell copies?
Yes, as long as you meet the requirements of one of the licenses in the copyright statement at the beginning of this book. You do not have to request special permission. We request that you share with the project some of the profits you make from sales of books, in consideration of all the work we have put into producing them.
[bookmark: __RefHeading__11197_1646717133]What’s new in LibreOffice 5.0?
The LibreOffice 5.0 Release Notes are here: https://wiki.documentfoundation.org/ReleaseNotes/5.0
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[bookmark: __RefHeading___Toc78493_811363531]What is LibreOffice?
LibreOffice is a freely available, fully-featured office productivity suite. Its native file format is Open Document Format (ODF), an open standard format that is being adopted by governments worldwide as a required file format for publishing and accepting documents. LibreOffice can also open and save documents in many other formats, including those used by several versions of Microsoft Office.
LibreOffice includes the following components.
[bookmark: __RefHeading__22007_697337876]Writer (word processor)
Writer is a feature-rich tool for creating letters, books, reports, newsletters, brochures, and other documents. You can insert graphics and objects from other components into Writer documents. Writer can export files to HTML, XHTML, XML, Adobe Portable Document Format (PDF), and several versions of Microsoft Word files. It also connects to your email client.
[bookmark: __RefHeading__22009_697337876]Calc (spreadsheet)
Calc has all of the advanced analysis, charting, and decision making features expected from a high-end spreadsheet. It includes over 300 functions for financial, statistical, and mathematical operations, among others. The Scenario Manager provides “what if” analysis. Calc generates 2D and 3D charts, which can be integrated into other LibreOffice documents. You can also open and work with Microsoft Excel workbooks and save them in Excel format. Calc can also export spreadsheets in several formats, including for example Comma Separated Value (CSV), Adobe PDF and HTML formats.
[bookmark: __RefHeading__22011_697337876]Impress (presentations)
Impress provides all the common multimedia presentation tools, such as special effects, animation, and drawing tools. It is integrated with the advanced graphics capabilities of LibreOffice Draw and Math components. Slideshows can be further enhanced using Fontwork special effects text, as well as sound and video clips. Impress is compatible with Microsoft PowerPoint file format and can also save your work in numerous graphics formats, including Macromedia Flash (SWF).
[bookmark: __RefHeading__22013_697337876]Draw (vector graphics)
Draw is a vector drawing tool that can produce everything from simple diagrams or flowcharts to 3D artwork. Its Smart Connectors feature allows you to define your own connection points. You can use Draw to create drawings for use in any of the LibreOffice components, and you can create your own clip art and then add it to the Gallery. Draw can import graphics from many common formats and save them in over 20 formats, including PNG, HTML, PDF, and Flash.
[bookmark: __RefHeading__22015_697337876]Base (database)
Base provides tools for day-to-day database work within a simple interface. It can create and edit forms, reports, queries, tables, views, and relations, so that managing a relational database is much the same as in other popular database applications. Base provides many new features, such as the ability to analyze and edit relationships from a diagram view. Base incorporates two relational database engines, HSQLDB and PostgreSQL. It can also use dBASE, Microsoft Access, MySQL, or Oracle, or any ODBC compliant or JDBC compliant database. Base also provides support for a subset of ANSI-92 SQL.
[bookmark: __RefHeading__22017_697337876]Math (formula editor)
Math is the LibreOffice formula or equation editor. You can use it to create complex equations that include symbols or characters not available in standard font sets. While it is most commonly used to create formulas in other documents, such as Writer and Impress files, Math can also work as a standalone tool. You can save formulas in the standard Mathematical Markup Language (MathML) format for inclusion in web pages and other documents not created by LibreOffice.
[bookmark: __RefHeading__22019_697337876]Advantages of LibreOffice
Here are some of the advantages of LibreOffice over other office suites:
1. No licensing fees. LibreOffice is free for anyone to use and distribute at no cost. Many features that are available as extra cost add-ins in other office suites (like PDF export) are free with LibreOffice. There are no hidden charges now or in the future.
· Open source. You can distribute, copy, and modify the software as much as you wish, in accordance with the LibreOffice Open Source licenses.
· Cross-platform. LibreOffice runs on several hardware architectures and under multiple operating systems, such as Microsoft Windows, Mac OS X and Linux.
· Extensive language support. The LibreOffice user interface, including spelling, hyphenation, and thesaurus dictionaries, is available in over 100 languages and dialects. LibreOffice also provides support for both Complex Text Layout (CTL) and Right to Left (RTL) layout languages (such as Urdu, Hebrew, and Arabic).
· Consistent user interface. All the components have a similar “look and feel,” making them easy to use and master.
· Integration. The components of LibreOffice are well integrated with one another.
· All the components share a common spelling checker and other tools, which are used consistently across the suite. For example, the drawing tools available in Writer are also found in Calc, with similar but enhanced versions in Impress and Draw.
· You do not need to know which application was used to create a particular file. For example, you can open a Draw file from Writer.
· Granularity. Usually, if you change an option, it affects all components. However, LibreOffice options can be set at a component level or even at document level.
· File compatibility. In addition to its native OpenDocument formats, LibreOffice includes support for opening and saving files in many common formats including Microsoft Office, HTML, XML, WordPerfect, Lotus 1-2-3, and PDF.
· No vendor lock-in. LibreOffice uses OpenDocument, an XML (eXtensible Markup Language) file format developed as an industry standard by OASIS (Organization for the Advancement of Structured Information Standards). These files can easily be unzipped and read by any text editor, and their framework is open and published.
· You have a voice. Enhancements, software fixes, and release dates are community-driven. You can join the community and affect the course of the product you use.
You can read more about LibreOffice and The Document Foundation on their websites at http://www.libreoffice.org/ and http://www.documentfoundation.org/.
[bookmark: __RefHeading__22021_697337876]Minimum requirements
LibreOffice 5.0 requires one of the following operating systems:
1. Microsoft Windows XP, Vista, Windows 7, Windows 8/8.1, or Windows 10.
· GNU/Linux Kernel version 2.6.18, glibc2 v2.5 or higher, and gtk v2.10.4 or higher
· Mac OS X 10.8 (Mountain Lion) or higher
Administrator rights are needed for the installation process.
Some LibreOffice features (wizards and the HSQLDB database engine) require that the Java Runtime Environment (JRE) is installed on your computer. Although LibreOffice will work without Java support, some features will not be available.
For a more detailed listing of requirements, see the LibreOffice website, http://www.libreoffice.org/get-help/system-requirements/.
[bookmark: __RefHeading__22023_697337876]How to get the software
Versions of LibreOffice for Windows, Linux, and Mac OS X can be downloaded free from http://www.libreoffice.org/download. You can also download the software by using a Peer-to-Peer client, such as BitTorrent, at the same address.
Linux users will also find LibreOffice included in many of the latest Linux distributions; Ubuntu is just one example.
Mac OS X users can also get two versions of LibreOffice from the App Store: LibreOffice Vanilla (free) and LibreOffice-from-Collabora (an enterprise-ready version; small fee).
[bookmark: __RefHeading__22025_697337876]How to install the software
Information on installing and setting up LibreOffice on the various supported operating systems is given here: http://www.libreoffice.org/get-help/install-howto/.
[bookmark: __RefHeading__3640_1802778174]Extensions and add-ons
Extensions and add-ons are available to enhance LibreOffice. Several extensions are installed with the program and you can get others from the official extensions repository, http://extensions.libreoffice.org/. See Chapter 14 Customizing LibreOffice for more information on installing extensions and add-ons.
[bookmark: __RefHeading__22035_697337876]Starting LibreOffice
In general, you start LibreOffice the same way you start any other program on your computer.
On computers with Windows or Linux operating systems, a menu entry for LibreOffice and each LibreOffice component appears in the system menu of your computer. On computers operating Mac OS X, only a menu entry for LibreOffice is added to the Applications menu.
Clicking on the LibreOffice menu entry, desktop icon, or tile opens the LibreOffice Start Center (Figure 2) from where you can select the individual components of LibreOffice. You can also select to open an existing file or use a template.

[bookmark: Ref_Figure1_full][bookmark: Ref_Figure1_label_and_number]Figure 2: LibreOffice Start Center

[bookmark: __RefHeading__4143_129573012]Opening an existing document before starting LibreOffice
You can start LibreOffice by double-clicking the filename of an ODF document on the desktop, or in a file manager such as Windows Explorer or the Mac’s Finder. The appropriate component of LibreOffice will start and the document will be loaded.
If you do not have Microsoft Office installed on your computer, or if Microsoft Office is installed and you have associated Microsoft Office file types with LibreOffice, then when you double-click on the following files, they open in LibreOffice:
· A Word file (*.doc or *.docx) opens in Writer.
· An Excel file (*.xls or *.xlsx) opens in Calc.
· A PowerPoint file (*.ppt or *.pptx) opens in Impress.
If you did not associate the file types and Microsoft Office is installed on your computer, then when you double-click on a Microsoft Office file, it opens using the appropriate Microsoft Office component.
For more information on opening files, see “Opening existing documents” on page 27.
[bookmark: __RefHeading__22043_697337876]Quickstarter
When LibreOffice is installed on computers running Windows or Linux, a Quickstarter feature may also be installed. When Quickstarter is activated, the necessary library files are loaded when the computer system is started, resulting in a shorter startup time for LibreOffice components.
Computers with a Mac operating system do not have a Quickstarter.
[bookmark: __RefHeading__2061_1473490585]Activating Quickstarter
On computers operating a Linux or Windows operating system, the default installation of LibreOffice does not set the Quickstarter to load automatically. To activate it:
1. Open LibreOffice.
 12) Go to Tools > Options > LibreOffice > Memory on the Menu bar and select Load LibreOffice during system start-up (if using Windows) or select Enable systray Quickstarter (if using Linux).
 13) Close and restart LibreOffice to have Quickstarter appear.
[bookmark: __RefHeading__22045_697337876]Using Quickstarter on Windows or Linux
After Quickstarter has been activated, an icon  is installed into the system tray at the bottom of the display. Quickstarter is then available at all times, whether LibreOffice is open or not.
To start a LibreOffice component directly by using Quickstarter:
1. Right-click the Quickstarter icon in the system tray to open a pop-up menu (Figure 3).
 15) Select the LibreOffice component you want to open to create a new document, or select From Template to open the Template Manager, or select Open Document to open an existing document.

[bookmark: Ref_Figure2_label_and_number]Figure 3: Quickstarter menu in Windows

[bookmark: __RefHeading__15512_1081412569]Disabling Quickstarter
To temporarily close Quickstarter on a computer using a Windows operating system, right-click on the Quickstarter icon in the system tray and select Exit Quickstarter in the pop-up menu. However, when the computer is restarted, Quickstarter will be loaded again.
To prevent the Quickstarter from loading during system startup, do one of the following:
· Right-click on the Quickstarter icon and deselect Load LibreOffice during system start-up on the pop-up menu (on Windows) or select Disable systray Quickstarter (on Linux).
· Go to Tools > Options > LibreOffice > Memory on the Menu bar and deselect Load LibreOffice during system start-up (on Windows) or deselect Enable systray Quickstarter on Linux.
[bookmark: __RefHeading__22049_697337876]Reactivating Quickstarter
If Quickstarter has been disabled, you can reactivate it by using the instructions given in “Activating Quickstarter” above.
[bookmark: __RefHeading__4826_1132080204]Parts of the main window
The main window is similar for each component of LibreOffice, although some details vary. See the relevant chapters in this guide about Writer, Calc, Draw, and Impress for descriptions of those details.
Common features include the Menu bar, standard toolbar, and formatting toolbar at the top of the window and the status bar at the bottom.
[bookmark: __RefHeading__4828_1132080204]Menu bar
The Menu bar is located across the top of the LibreOffice window, just below the title bar. When you select one of the menus listed below, a sub-menu drops down to show commands.
1. File – contains commands that apply to the entire document such as Open, Save, and Export as PDF.
· Edit – contains commands for editing the document such as Undo, Find & Replace, Cut, Copy, and Paste.
· View – contains commands for controlling the display of the document such as Zoom and Web Layout.
· Insert – contains commands for inserting elements into your document such as Header, Footer, and Picture.
· Format – contains commands, such as Styles and Formatting and AutoCorrect, for formatting the layout of your document.
· Table – contains commands to insert and edit a table in a text document.
· Tools – contains functions such as Spelling and Grammar, Customize, and Options.
· Window – contains commands for the display window.
· Help – contains links to the LibreOffice Help file, What’s This?, and information about the program.
[bookmark: __RefHeading__22061_697337876]Toolbars
LibreOffice has two types of toolbars: docked (fixed in place) and floating. Docked toolbars can be moved to different locations or made to float, and floating toolbars can be docked.
In a default LibreOffice installation, the top docked toolbar, just under the Menu bar, is called the Standard toolbar. It is consistent across the LibreOffice applications.
The second toolbar at the top, in a default LibreOffice installation, is the Formatting bar. It is context-sensitive; that is, it shows the tools relevant to the current position of the cursor or the object selected. For example, when the cursor is on a graphic, the Formatting bar provides tools for formatting graphics; when the cursor is in text, the tools are for formatting text.
[bookmark: __RefHeading__22063_697337876]Displaying or hiding toolbars
To display or hide toolbars, go to View > Toolbars on the Menu bar, then click on the name of a toolbar from the drop-down list. An active toolbar shows a check-mark beside its name. Toolbars created from tool palettes are not listed in the View menu.
To close a toolbar go to View > Toolbars on the Menu bar and deselect the toolbar, or right-click in an empty space between the icons on a toolbar and select Close toolbar from the context menu.
[bookmark: __RefHeading__1972_1098315447]Sub-menus and tool palettes
Toolbar icons with a small triangle to the right will display sub-menus, tool palettes, and alternative methods of selecting items, depending on the icon.
Tool palettes can be made into a floating toolbar. Figure 4 shows an example of a tool palette from the Drawing toolbar made into a floating toolbar. See “Moving toolbars” and “Floating toolbars” below for more information on moving and floating these toolbars created from tool palettes.

[bookmark: Ref_Figure3_label_and_number]Figure 4: Example of tearing off a tool palette

[bookmark: __RefHeading__2643_161909][bookmark: Ref_moving_toolbars][bookmark: Ref_moving_toolbars]Moving toolbars
Docked toolbars can be undocked and moved to a new docked position or left as a floating toolbar.
1. Move the mouse cursor over the toolbar handle, which is the small vertical bar to the left of a docked toolbar and highlighted in Figure 5.
 1) Hold down the left mouse button and drag the toolbar to the new location. The toolbar can be docked in a new position at the top, sides or bottom of the main window, or left as a floating toolbar.
 2) Release the mouse button.
To move a floating toolbar, click on its title bar and drag it to a new floating location or dock the toolbar at the top or bottom of the main window.

[bookmark: Ref_Figure4_label_and_number]Figure 5: Toolbar handles

Note
You can also dock a floating toolbar by holding down the Ctrl key and double-clicking in the title bar of the toolbar.
[bookmark: __RefHeading__2442_651442457]Floating toolbars
LibreOffice includes several additional toolbars, whose default setting appear as floating toolbars in response to the current position of the cursor or selection. You can dock these toolbars to the top or bottom of the main window, or reposition them on your computer display (see “Moving toolbars” above).
Some of these additional toolbars are context sensitive and will automatically appear depending on the position of the cursor. For example, when the cursor is in a table, a Table toolbar appears, and when the cursor is in a numbered or bullet list, the Bullets and Numbering toolbar appears.
[bookmark: __RefHeading__2242_1986025576]Customizing toolbars
You can customize toolbars in several ways, including choosing which icons are visible and locking the position of a docked toolbar. You can also add icons and create new toolbars, as described in Chapter 14 Customizing LibreOffice. To access the customization options for a toolbar, right-click in an empty space between the icons on a toolbar to open a context menu as follows:
· To show or hide icons defined for the selected toolbar, click Visible Buttons. Visible icons on a toolbar are indicated by an outline around the icon (Figure 6) or by a check mark beside the icon, depending on your operating system. Select or deselect icons to hide or show them on the toolbar.

[bookmark: Ref_Figure5_label_and_number]Figure 6: Selection of visible toolbar icons

· Click Customize Toolbar to open the Customize dialog; See Chapter 14 Customizing LibreOffice for more information.
· Click Dock Toolbar to dock the selected floating toolbar. By default, a toolbar will dock at the top of the workspace. You can reposition the toolbar to a different docked position. See “Moving toolbars” on page 22.
· Click Dock All Toolbars to dock all floating toolbars. By default, toolbars will dock at the top of the workspace. You can reposition the toolbars to different docked positions. See “Moving toolbars” on page 22.
· Click Lock Toolbar Position to lock a docked toolbar into its docked position.
· Click Close Toolbar to close the selected toolbar.
[bookmark: __RefHeading___Toc17033_1210483707]Context menus
Context menus provide quick access to many menu functions. They are opened by right-clicking on a paragraph, graphic, or other object. When a context menu opens, the functions or options available will depend on the object that has been selected. A context menu can be the easiest way to reach a function, especially if you are not sure where the function is located in the menus or toolbars.
[bookmark: __RefHeading__65331_1365249792]Status bar
The status bar is located at the bottom of the workspace. It provides information about the document and convenient ways to quickly change some features. It is similar in Writer, Calc, Impress, and Draw, but each LibreOffice component includes some component-specific items. An example of the Writer status bar is shown in Figure 7.

[bookmark: Ref_Figure6_label_and_number]Figure 7: Example status bar from Writer

Page, sheet, or slide number and page count
Shows the current page, sheet, or slide number and the total number of pages, sheets, or slides in the document. Double-click on this field to open the Navigator. Other uses of this field depend on the LibreOffice component.
Words and characters
Shows the total number of words and characters in the document or in the selection.
Page style or slide design
Shows the current page style or slide design. To edit the current page style or slide design, double-click on this field. To choose a different page style or slide design, right-click on this field and select from the list that pops up.
Language
Shows the current language of the text at the current cursor position.
Insert mode
Shows the type of insert mode the program is in. This field is blank if the program is in Insert mode. Each time the Ins key is pressed, or this field is clicked, the mode toggles between Insert and Overwrite.
Selection mode
Click to choose different selection modes. The icon does not change, but when you hover the mouse pointer over this field, a tooltip indicates which mode is active.
Unsaved changes
The icon shown here is different when changes to the document have not been saved.
Digital signature
If the document has been digitally signed, an icon shows here. You can click the icon to sign the document, or to view the existing certificate.
Object information
Displays information relevant to the position of the cursor or the selected element of the document.
View layout
Select between Single-page view, Multiple-page view, and Book view to change how your document is displayed.
Zoom slider
Drag the Zoom slider, or click on the + and – signs to change the view magnification of your document.
Zoom percentage
Indicates the magnification level of the document. Right-click on the percentage figure to open a list of magnification values from which to choose. Double-clicking on this percentage figure opens the Zoom & View Layout dialog.
[bookmark: __RefHeading__8953_2107521479]Sidebar
To activate the Sidebar, select View > Sidebar from the Menu bar. The sidebar (Figure 8) is located on the right side of the edit views of Writer, Calc, Impress, and Draw. It contains one or more panels, based on the current document context. Panels are organized into decks. A tab bar on the right side of the sidebar allows you to switch between different decks. 
All components contain the Properties, Styles and Formatting, Gallery, and Navigator decks. Some components have additional decks, such as Master Pages, Custom Animation, and Slide Transition for Impress; Manage Changes for Writer; and Functions for Calc.
A panel is like a combination of a toolbar and a dialog. For example, you can freely mix working in the main edit window to enter text and use the Properties panel in the sidebar to change text attributes.
Tool bars and sidebar panels share many functions. For example, the buttons for making text bold or italic exist in both the Formatting toolbar and the Properties panel.
For more detail, see the Sidebar explanation in the relevant LibreOffice component’s user guide.
To hide the Sidebar, click on the gray Hide button on the left. Click on the same button to show the Sidebar again.
To undock the Sidebar and make it floating, and to dock a floating Sidebar, use the drop-down list at the top of the tab bar (see Figure 9). From the same list you can choose which items to include in the Sidebar.
[bookmark: Ref_Figure7_label_and_number]Figure 8: Properties panel of Sidebar in Writer

[bookmark: Ref_Figure8_label_and_number]Figure 9: Floating (undocking) or docking the Sidebar

[bookmark: __RefHeading__22077_697337876]Starting new documents
You can start a new, blank document in LibreOffice in several ways.
When LibreOffice is open but no document is open, the Start Center (Figure 2 on page 19) is shown. Click one of the icons to open a new document of that type, or click the Templates icon to start a new document using a template.
You can also start a new document in one of the following ways:
· Use File > New on the Menu bar and select the type of document from the context menu.
· Use the keyboard shortcut Ctrl+N to create a new document. The type of document created depends on which LibreOffice component is open and active. For example, if Calc is open and active, a new spreadsheet is created.
· Use File > Wizards on the Menu bar and select the type of document from the context menu.
· If a document is already open in LibreOffice, click the New icon on the Standard toolbar and a new document of the same type is created in a new window. For example, if Calc is open and active, a new spreadsheet is created. The New icon changes depending on which component of LibreOffice is open.
· If a document is already open in LibreOffice, click on the small triangle to the right of the New icon on the Standard toolbar and select the type of document from the context menu that opens.
· On Windows or Linux, use the Quickstarter feature included with LibreOffice. See “Quickstarter” on page 20 for more information.
Note
If all documents are closed without closing LibreOffice, then the Start Center will be displayed.
[bookmark: __RefHeading__35663913]Opening existing documents
You can also open an existing document in one of the following ways:
· When no document is open, click Open File in the Start Center to reach the Open dialog.
1. Go to File > Open on the Menu bar the reach the Open dialog.
· Use the keyboard shortcut Ctrl+O to reach the Open dialog.
· If a document is already open, click the Open icon on the Standard toolbar and select from a list of available documents from the Open dialog.
· Click the small triangle to the right of the Open icon and select from a list of recently opened documents.
· When no document is open, double-click on a thumbnail of recently opened documents displayed in the Start Center. You can scroll up or down in the Start Center to locate a recently opened document.
When using the Open dialog, navigate to the folder you want and select the file you want, and then click Open. If a document is already open in LibreOffice, the second document opens in a new window.
In the Open dialog, you can reduce the list of files by selecting the type of file you are looking for. For example, if you choose Text documents as the file type, you will only see documents Writer can open (including .odt, .doc, .txt); if you choose Spreadsheets, you will see .ods, .xls, and other files that Calc opens.
You can also open an existing document that is in a format that LibreOffice recognizes by double-clicking on the file icon on the desktop or in a file manager such as Windows Explorer. LibreOffice has to be associated with file types that are not ODF files for the appropriate LibreOffice component to open.
Note
You can choose whether to use the LibreOffice Open/Save dialogs or the ones provided by your computer’s operating system. See “Open and Save As dialogs” on page 30 for more information. This book uses the LibreOffice dialogs in illustrations.
[bookmark: __RefHeading__22079_697337876]Saving documents
You can save documents as follows:
· Save command – use if you are keeping the document, its current filename and location.
· Save As command – use if you want to create a new document, or change the filename and/or file format, or save the file in a different location on your computer.
· Password protection – use if you want to restrict who can open and read the document, or open and edit the document.
[bookmark: __RefHeading__5389_1247198942]Save command
To save a document if you are keeping the document’s current filename and location, do one of the following:
· Use the keyboard shortcut Ctrl+S.
· Go to File > Save on the Menu bar.
· Click the Save icon on the Standard toolbar.
Using the Save command will overwrite the last saved version of the file.
[bookmark: __RefHeading__5391_1247198942]Save As command

[bookmark: Ref_Figure9_full][bookmark: Ref_Figure9_label_and_number]Figure 10: Example of LibreOffice Save As dialog

To save a document if you want to create a new document, or change the filename and/or file format, or save the file in a different location on your computer:
· Use the keyboard shortcut Ctrl+Shift+S.
· Go to File > Save As on the Menu bar.
When the Save As dialog (Figure 10) or Save dialog opens, enter the file name, change the file type (if applicable), navigate to a new location (if applicable), and click Save.
The dialog that opens when using the Save As command depends on the options that have been set in LibreOffice. See “Open and Save As dialogs” on page 30 for more information.
[bookmark: __RefHeading__20523_24232397]Password protection
To protect a document and restrict who can open and read the document, or open and edit the document, you have to use password protection.
1. Using the Save As command above, select the Save with password option in the Save As dialog or Save dialog.
 4) Click Save and the Set Password dialog opens (Figure 11).
 5) In File Encryption Password, enter a password to open the document and then enter the same password as confirmation.
 6) To restrict who can edit the document, click Options.
 7) In File Sharing Password, select Open file read-only, enter a password to allow editing, and then enter the same password as confirmation.
 8) Click OK and the dialog closes. If the passwords match, the document is saved password-protected. If the passwords do not match, you receive an error message.

[bookmark: Ref_Figure10_label_and_number]Figure 11: Set Password dialog

Caution
LibreOffice uses a very strong encryption mechanism that makes it almost impossible to recover the contents of a document if you lose or forget the password.
[bookmark: __RefHeading__14630_129573012]Changing the password
When a document is password-protected, you can change the password while the document is open. Go to File > Properties > General on the Menu bar and click the Change Password button. This opens the Set Password dialog where you can enter a new password.
[bookmark: __RefHeading__22083_697337876]Saving documents automatically
LibreOffice can save files automatically as part of the AutoRecovery feature. Automatic saving, like manual saving, overwrites the last saved state of the file. 
To set up automatic file saving:
1. Go to Tools > Options > Load/Save > General on the Menu bar.
 1) Select Save AutoRecovery information every and set the time interval.
 2) Click OK.
[bookmark: __RefHeading__22085_697337876]Renaming and deleting files
You can rename or delete files within the LibreOffice dialogs, just as you can in a file manager. Select a file and then right click to open a context menu. Select either Delete or Rename, as appropriate. However, you cannot copy or paste files within the dialogs.
[bookmark: __RefHeading__22087_697337876][bookmark: Ref_Ref_28]Open and Save As dialogs
You can choose whether to use the LibreOffice Open and Save As dialogs or the ones provided by your operating system. This book uses the LibreOffice dialogs in illustrations.
· To use the operating system dialogs for saving or opening files, go to Tools > Options > LibreOffice > General and uncheck the option Use LibreOffice dialogs.
· To use LibreOffice dialogs for saving or opening files, go to Tools > Options > LibreOffice > General and check the option Use LibreOffice dialogs.
An example of a LibreOffice dialog is shown in Figure 10 on page 28. The three icons in the top right of these dialogs are as follows:
1. Server – a dialog opens allowing you to connect to a network server if the file you want is not located on your computer.
· Up One Level – moves up one folder in the folder hierarchy. Click and hold the mouse button on this icon to display a drop down a list of higher level folders. Move the cursor over a higher level folder and release the mouse button to navigate to that folder
· Create New Folder – creates a new sub-folder in the folder that is displayed in the dialog.
Use the File type field to specify the type of file to be opened or the format of the file to be saved.
The Read-only option on the Open dialog opens the file for reading and printing only. Most of the icons and most menu options are disabled on the toolbars. The Edit File icon becomes active on the Standard toolbar. Click on this icon to open the file for editing.
[bookmark: __RefHeading__22089_697337876]Using the Navigator
The LibreOffice Navigator lists objects contained within a document, collected into categories. For example, in Writer it shows Headings, Tables, Text frames, Comments, Graphics, Bookmarks, and other items, as shown in Figure 12. In Calc it shows Sheets, Range Names, Database Ranges, Graphics, Drawing Objects, and other items. In Impress and Draw it shows Slides, Pictures, and other items.
To open the Navigator, click the Navigator icon on the Standard toolbar, or press the F5 key, or go to View > Navigator on the Menu bar, or click the Navigator icon in the Sidebar.
In a default installation of LibreOffice, the Navigator is part of the Sidebar.
Click the marker (+ or triangle) by any of the categories to display the list of objects in that category.
The Navigator provides several convenient ways to move around a document and find items in it:
· When a category is showing the list of objects in it, double-click on an object to jump directly to that object’s location in the document.
· Objects are much easier to find if you have given them recognizable names when creating them, instead of keeping the default names, for example Sheet1, Table1, Table2, and so on. The default names may not correspond to the actual position of the object in the document.
1. Each Navigator in the individual LibreOffice components has a different range of functions. These functions are further explained in the user guide for each LibreOffice component.

[bookmark: Ref_Figure11_number_only]Figure 12: Navigator in Writer

[bookmark: __RefHeading__22091_697337876]Undoing and redoing changes
To undo the most recent change in a document, use the keyboard shortcut Ctrl+Z, or click the Undo icon on the Standard toolbar, or go to Edit > Undo on the Menu bar. Click the small triangle to the right of the Undo icon to get a list of all the changes that can be undone. You can select multiple changes and undo them at the same time.
After changes have been undone, you can redo changes. To redo a change use the keyboard shortcut Ctrl+Y, or click the Redo icon, or go to Edit > Redo on the Menu bar. As with Undo, click on the triangle to the right of the arrow to get a list of the changes that can be reapplied.
To modify the number of changes LibreOffice remembers, go to Tools > Options > LibreOffice > Memory on the Menu bar. In the Undo section increase or decrease the Number of steps. Be aware that asking LibreOffice to remember more changes consumes more computer memory.
[bookmark: __RefHeading__22093_697337876]Closing a document
If only one document is open and you want to close that document, go to File > Close on the Menu bar or click on the X on the right or left end of the Menu bar. On Windows and Linux, the document closes and the LibreOffice Start Center opens. On Mac OS X, the document closes and only the Menu bar remains at the top of the screen.
If more than one document is open and you want to close one of them, go to File > Close on the Menu bar or click on the X on the title bar of that document’s window. The X may be located on either the right or left end of the title bar.
If the document has not been saved since the last change, a message box is displayed. Choose whether to save or discard your changes.
Caution
Not saving your document could result in the loss of recently made changes, or worse still, the entire file.
[bookmark: __RefHeading__22095_697337876]Closing LibreOffice
To close LibreOffice completely, go to File > Exit on the Menu bar in Windows and Linux operating systems. In a Mac operating system, go to LibreOffice > Quit LibreOffice on the Menu bar.
When you close the last document using the X on the title bar of the window, then LibreOffice will close completely. A Mac operating system does not have this function; instead, you need to use to LibreOffice > Quit LibreOffice.
You can also use a keyboard shortcut as follows:
· In Windows and Linux – Ctrl+Q
· In Mac OS X – Command ⌘+Q
[bookmark: __RefHeading__5648_1566568644]If any documents have not been saved since the last change, a message box is displayed. Choose whether to save or discard your changes.
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