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[bookmark: __RefHeading__5391_1247198942]Save As command
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[bookmark: Ref_Figure3_label_and_number]Figure 1: Example of LibreOffice Save As dialog

To save a document if you want to create a new document, or change the filename and/or file format, or save the file in a different location on your computer:
· Use the keyboard shortcut Ctrl+Shift+S.
· Go to File > Save As on the Menumain menu bar.
When the Save As dialog (Figure 1) or Save dialog opens, enter the file name, change the file type (if applicable), navigate to a new location (if applicable), and click Save.
The dialog that opens when using the Save As command depends on the options that have been set in LibreOffice. See “Error: Reference source not found” on page Error: Reference source not found for more information.
[image: ]
Figure 2: Example of LibreOffice Save As dialog


Click the marker (+ or triangle) by any of the categories to display the list of objects in that category.
The Navigator provides several convenient ways to move around a document and find items in it:
· When a category is showing the list of objects in it, double-click on an object to jump directly to that object’s location in the document.
· Objects are much easier to find if you have given them recognizable names when creating them, instead of keeping the default names, for example Sheet1, Table1, Table2, and so on. The default names may not correspond to the actual position of the object in the document.
· Each Navigator in the individual LibreOffice components has a different range of functions. These functions are further explained in the user guide for each LibreOffice component.
[image: ]
Figure 3: Navigator in Writer

The Navigator provides several convenient ways to move around a document and find items in it:
1. When a category is showing the list of objects in it, double-click on an object to jump directly to that object location in the document.
· Objects are much easier to find if you have given them recognizable names when creating them, instead of keeping the LibreOffice default names, for example Sheet1, Table1, Table2, and so on. The default names may not correspond to the actual position of the object in the document.
1. Each Navigator in the individual LibreOffice components has a different range of functions and these functions are further explained in the appropriate user guides for each LibreOffice component.
[bookmark: __RefHeading__22091_697337876]Undoing and redoing changes
To undo the most recent change in a document, use the keyboard shortcut Ctrl+Z, or click the Undo icon [image: ] on the Standard toolbar, or go to Edit > Undo on the Menumenu bar. Click the small triangle to the right of the Undo icon to get a list of all the changes that can be undone. You can select multiple changes and undo them at the same time.
After changes have been undone, you can redo changes. To redo a change use the keyboard shortcut Ctrl+Y, or click the Redo icon [image: ], or go to Edit > Redo on the Menumenu bar. As with Undo, click on the triangle to the right of the arrow to get a list of the changes that can be reapplied.
To modify the number of changes LibreOffice remembers, go to Tools > Options > LibreOffice > Memory on the Menumenu bar. In the Undo section increase or decrease the Number of steps. Be aware that asking LibreOffice to remember more changes consumes more computer memory.
[bookmark: __RefHeading__22093_697337876]Closing a document
If only one document is open and you want to close that document, go to File > Close on the Menumenu bar or click on the X on the right or left end side of the Menumenu bar. On Windows and Linux, the The document closes and the LibreOffice Start Center opens. On Mac OS X, the document closes and only the Menu bar remains at the top of the screen.
If more than one document is open and you want to close one of them, go to File > Close on the Menumenu bar or click on the X on the title bar of that document’s window. The X may be located on either the right or left end of the title bar.
If the document has not been saved since the last change, a message box is displayed. Choose whether to save or discard your changes.
· Caution
Not saving your document could result in the loss of recently made changes, or worse still, the entire file.
	Caution
[image: ]
	Not saving your document could result in the loss of recently made changes, or worse still, the entire file.


[bookmark: __RefHeading__22095_697337876]Closing LibreOffice
To close LibreOffice completely, go to File > Exit on the Menumenu bar in Windows and Linux operating systems. In a Mac operating system, go to LibreOffice > Quit LibreOffice on the Menumenu bar.
When you close the last document using the X on the titleTitle bar of the window, then LibreOffice will close completely. A Mac operating system does not have this function; instead, you need to usego to LibreOffice > Quit LibreOffice on the menu bar.
You can also use a keyboard shortcut as follows:
· In Windows and Linux – Ctrl+Q
· In Mac OS X – Command ⌘+Q
[bookmark: __RefHeading__5648_1566568644]If any documents have not been saved since the last change, a message box is displayed. Choose whether to save or discard your changes.

Documentation for LibreOffice is available at http://www.libreoffice.org/get-help/documentation
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[bookmark: __RefHeading___Toc86651_811363531]Choosing options for all of LibreOffice
This section covers some of the settings that apply to all the components of LibreOffice. For information on settings not discussed here, see the Help.
Click Tools > Options. The list in the left-hand box of the Options – LibreOffice dialog varies depending on which component of LibreOffice is open. The illustrations in this chapter show the list as it appears when a Writer document is open.
Click the marker (+ or triangle) by LibreOffice on the left-hand side. A list of pages drops down. Selecting an item in the list causes the right-hand side of the dialog to display the relevant page.
[image: ]
Figure 4: LibreOffice options

· Note
The Reset button, located in the lower right of the full Options dialog, has the same effect on all pages of the dialog. It resets the options to the values that were in place when you opened the dialog.
	Note
	The Revert button, located in the lower right of the full Options dialog, has the same effect on all pages of the dialog. It resets the options to the values that were in place when you opened the dialog.


If you are using a version of LibreOffice other than US English, some field labels may be different from those shown in the illustrations.
[bookmark: __RefHeading__136120_780470623]User Data options
Because LibreOffice can use the name or initials stored in the LibreOffice – User Data page for several things, including document properties (created by and last edited by information) and the name of the author of comments and changes, you will want to ensure that the correct information appears here.
Fill in the form (not shown here), or amend or delete any existing information. If you do not want user data to be part of the document’s properties, clear the box at the bottom.
[bookmark: __RefHeading__136122_780470623]General options

[image: ]
Figure 5: Choosing accessibility options

[bookmark: __RefHeading__136142_780470623]Advanced options
Java options
If you install or update a Java Runtime Environment (JRE) after you install LibreOffice, or if you have more than one JRE installed on your computer, you can use the LibreOffice – Advanced options page to choose the JRE for LibreOffice to use.
[image: ]
Figure 6: Choosing a Java runtime environment

If you are a system administrator, programmer, or other person who customizes JRE installations, you can use the Parameters and Class Path pages (reached from the Java page) to specify this information.
If you do not see anything listed in the middle of the page, wait a few minutes while LibreOffice searches for JREs on the hard disk.
If LibreOffice finds one or more JREs, it will display them there. You can then select the Use a Java runtime environment option and (if necessary) choose one of the JREs listed.
[image: ]
Figure 7: Choosing a Java runtime environment

Optional (unstable) options
Enable experimental features
Selecting this option enables features that are not yet complete or contain known bugs. The list of these features is different version by version.
Enable macro recording (limited)
This option enables macro recording with some limitations. Opening a window, switching between windows, and recording in a different window to that in which the recording began, is not supported. Only actions relating to document contents are recordable, so changes in Options or customizing menus are not supported. For more about macro recording, see Chapter 13, Getting Started with Macros.
Expert Configuration
Most users will have no need to use this. Click the Expert Configuration button to open a new window in which you can fine-tune the LibreOffice installation. The page offers detailed configuration options for many aspects of LibreOffice’'s appearance and performance. Double-click on a listed preference to enter a value to configure the preference.
[bookmark: __RefHeading__34770_129573012]Basic IDE options
The Basic IDE Options are available after Enable experimental features has been selected on the Advanced page of the Options dialog and the options have been saved. These options are for macro programmers and are not discussed here.
 [image: ]
Figure 8: Basic IDE Options dialog

[bookmark: __RefHeading__23840_519196086]Online update options
On the LibreOffice – Online Update page (Figure 9), you can choose whether and how often to have the program check the LibreOffice website for program updates. If the Check for updates automatically option is selected, an icon appears at the right-hand end of the menu bar when an update is available. Click this icon to open a dialog where you can choose to download the update.
If the Download updates automatically option is selected, the download starts when you click the icon. To change the download destination, click the Change button and select the required folder in the file browser window.
[image: ]
[bookmark: Ref_Figure9_label_and_number]Figure 9: Online update options

[bookmark: __RefHeading__136148_780470623]Choosing Load/Save options
You can set the Load/Save options for loading and saving documents to suit the way you work.
If the Options dialog is not already open, click Tools > Options. Click the expansion symbol (+ or triangle) to the left of Load/Save.
[bookmark: __RefHeading__136150_780470623]General
Most of the choices on the Load/Save – General page are familiar to users of other office suites. Some items of interest are described below.
[image: ]
Figure 10: Choosing Load and Save options

Load user-specific settings with the document
A LibreOffice document contains certain settings that are read from the user’s system. When you save a document, these settings are saved with it.
Select this option so that when a document loads, it ignores the stored settings in favor of the settings on your computer.
Even if you do not select this option, some settings are taken from your LibreOffice installation:
· Settings available in File > Print > Options
· Name of Fax
· Spacing options for paragraphs before text tables
· Information about automatic updating for links, field functions and charts
· Information about working with Asian character formats.
The following setting is always loaded with a document, whether or not this option is marked:
· Data source linked to the document and its view.
If you deselect this option, the user’s personal settings do not overrule the settings in the document. For example, your choice (in the options for LibreOffice Writer) of how to update links is affected by the Load user-specific settings option.
Load printer settings with the document
If enabled, the printer settings will be loaded with the document. This can cause a document to be printed on a distant printer (perhaps in an office setting), if you do not change the printer manually in the Print dialog. If disabled, your standard printer will be used to print this document. The current printer settings will be stored with the document whether or not this option is selected.
Save AutoRecovery information every __ Minutes
Choose whether to enable AutoRecovery and how often to save the information used by the AutoRecovery process.
AutoRecovery in LibreOffice saves the information needed to restore all open documents in case of a crash. If you have this option set, recovering your document after a system crash will be easier.
Automatically save the document too
Specifies that LibreOffice saves all open documents when saving auto recovery information. Uses the same time interval as AutoRecovery does.
Edit document properties before saving
If you select this option, the Document Properties dialog pops up to prompt you to enter relevant information the first time you save a new document (or whenever you use Save As).
Always create backup copy
Saves the previous version of a document as a backup copy whenever you save a document. Every time LibreOffice creates a backup copy, the previous backup copy is replaced. The backup copy gets the extension BAK. Authors whose work may be very lengthy should always consider using this option.
Save URLs relative to file system / internet
Use this option to select the default for relative addressing of URLs in the file system and on the Internet. Relative addressing is only possible if the source document and the referenced document are both on the same drive.
A relative address always starts from the directory in which the current document is located. In contrast, absolute addressing always starts from a root directory. The following table demonstrates the difference in syntax between relative and absolute referencing:
	Examples
	File system
	Internet

	relative
	../images/img.jpg
	../images/img.jpg

	absolute
	file:///c|/work/images/img.jpg
	http://myserver.com/work/images/img.jpg


If you choose to save relatively, the references to embedded graphics or other objects in your document will be saved relative to the location in the file system. In this case, it does not matter where the referenced directory structure is recorded. The files will be found regardless of location, as long as the reference remains on the same drive or volume. This is important if you want to make the document available to other computers that may have a completely different directory structure, drive or volume names. It is also recommended to save relatively if you want to create a directory structure on an Internet server.
If you prefer absolute saving, all references to other files will also be defined as absolute, based on the respective drive, volume or root directory. The advantage is that the document containing the references can be moved to other directories or folders, and the references remain valid.
Default file format and ODF settings
ODF format version. LibreOffice by default saves documents in OpenDocument Format (ODF) version 1.2 Extended. While this allows for improved functionality, there may be backwards compatibility issues. When a file saved in ODF 1.2 Extended is opened in an editor that uses earlier versions of ODF (1.0/1.1), some of the advanced features may be lost. Two notable examples are cross-references to headings and the formatting of numbered lists. If you plan to share documents with people who use editors that use older versions of ODF, you may wish to save the document using ODF version 1.0/1.1.
Document type. If you routinely share documents with users of Microsoft Office, you might want to change the Always save as attribute for documents to one of the Microsoft Office formats. Current versions of Microsoft Word can open ODT files, so this may no longer be needed.
[bookmark: __RefHeading__48048_472912510]VBA Properties
On the VBA Properties page, you can choose whether to keep any macros in Microsoft Office documents that are opened in LibreOffice.
[image: ]
Figure 11: Choosing Load/Save VBA Properties

If you choose Load Basic code, you can edit the macros in LibreOffice. The changed code is saved in an ODF document but is not retained if you save into a Microsoft Office format.
If you choose Save original Basic code, the macros will not work in LibreOffice but are retained unchanged if you save the file into Microsoft Office format.
If you are importing a Microsoft Word or Excel file containing VBA code, you can select the option Executable code. Whereas normally the code is preserved but rendered inactive (if you inspect it with the StarBasic IDE you will notice that it is all commented), with this option the code is ready to be executed.
Save original Basic code takes precedence over Load Basic code. If both options are selected and you edit the disabled code in LibreOffice, the original Microsoft Basic code will be saved when saving in a Microsoft Office format.
To remove any possible macro viruses from the Microsoft Office document, deselect Save original Basic code. The document will be saved without the Microsoft Basic code.
[bookmark: __RefHeading__136154_780470623]Microsoft Office
On the Load/Save – Microsoft Office page, you can choose what to do when importing and exporting Microsoft Office OLE objects (linked or embedded objects or documents such as spreadsheets or equations).
Select the [L] options to convert Microsoft OLE objects into the corresponding LibreOffice OLE objects when a Microsoft document is loaded into LibreOffice (mnemonic: “L” for “load”).
Select the [S] options to convert LibreOffice OLE objects into the corresponding Microsoft OLE objects when a document is saved in a Microsoft format (mnemonic: “S” for “save”).
[image: ]
Figure 12: Choosing Load/Save Microsoft Office options

[bookmark: __RefHeading__136156_780470623]HTML compatibility
Choices made on the Load/Save – HTML Compatibility page affect HTML pages imported into LibreOffice and those exported from LibreOffice. See HTML documents; importing/exporting in the Help for more information.
[image: ]
Figure 13. Choosing HTML compatibility options

Font sizes
Use these fields to define the respective font sizes for the HTML <font size=1> to <font size=7> tags, if they are used in the HTML pages. (Many pages no longer use these tags.)
Import – Use 'English (USA)' locale for numbers
When importing numbers from an HTML page, the decimal and thousands separator characters differ according to the locale of the HTML page. The clipboard, however, contains no information about the locale. If this option is not selected, numbers will be interpreted according to the Locale setting in Tools > Options > Language Settings > Languages (see page 17). If this option is selected, numbers will be interpreted as for the English (USA) locale.
Import – Import unknown HTML tags as fields
Select this option if you want tags that are not recognized by LibreOffice to be imported as fields. For an opening tag, an HTML_ON field will be created with the value of the tag name. For a closing tag, an HTML_OFF will be created. These fields will be converted to tags in the HTML export.
Import – Ignore font settings
Select this option to have LibreOffice ignore all font settings when importing. The fonts that were defined in the HTML Page Style will be used.
Export
To optimize the HTML export, select a browser or HTML standard from the Export box. If LibreOffice Writer is selected, specific LibreOffice Writer instructions are exported.
Export – LibreOffice Basic
Select this option to include LibreOffice Basic macros (scripts) when exporting to HTML format. You must activate this option before you create the LibreOffice Basic macro; otherwise the script will not be inserted. LibreOffice Basic macros must be located in the header of the HTML document. Once you have created the macro in the LibreOffice Basic IDE, it appears in the source text of the HTML document in the header.
If you want the macro to run automatically when the HTML document is opened, choose Tools > Customize > Events. See Chapter 13, Getting Started with Macros, for more information.
Export – Display warning
When the LibreOffice Basic option (see above) is not selected, the Display warning option becomes available. If the Display warning option is selected, then when exporting to HTML a warning is shown that LibreOffice Basic macros will be lost.
Export – Print layout
Select this option to export the print layout of the current document as well. The HTML filter supports CSS2 (Cascading Style Sheets Level 2) for printing documents. These capabilities are only effective if print layout export is activated.
Export – Copy local graphics to Internet
Select this option to automatically upload the embedded pictures to the Internet server when uploading using FTP.
Export – Character set
Select the appropriate character set for the export.
[bookmark: __RefHeading__136158_780470623]Choosing language settings
To customize the language settings in LibreOffice, you can do any of the following:
1. Install the required dictionaries
· Change some locale and language settings
· Choose spelling options
[bookmark: __RefHeading__136160_780470623]Install the required dictionaries
LibreOffice automatically installs several dictionaries with the program. To add other dictionaries, be sure you are connected to the Internet, and then choose Tools > Language > More Dictionaries Online. LibreOffice will open your default web browser to a page containing links to additional dictionaries that you can install. Follow the prompts to select and install the ones you want.
[bookmark: __RefHeading__136162_780470623]Change some locale and language settings
You can change some details of the locale and language settings that LibreOffice uses for all documents, or for specific documents.
In the Options dialog, click Language Settings > Languages. The exact list shown depends on the Enhanced language support settings (see Figure 15).
[bookmark: Ref_Figure14_label_and_number]Figure [image: ][image: ]14: LibreOffice language options, without and with Asian and CTL options enabled

On the right-hand side of the Language Settings – Languages page, change the User interface, Locale setting, Default currency, and Default languages for documents as required. In the example, English (USA) has been chosen for all the appropriate settings.
[image: ]
[bookmark: Ref_Figure15_label_and_number]Figure 15: Choosing language options

User interface
The language of the user interface is usually set at the time LibreOffice is installed to match the language of the operating system. If more than one language has been installed for LibreOffice, you can select which language will be used for menus, dialogs, and help files.
Locale setting
The local setting is the basis for many other settings within LibreOffice, for example defaults for numbering, currency, and units of measure. Unless you select something else here, the locale of the operating system will be set as default.
Decimal separator key
If the Decimal separator key option is selected, LibreOffice will use the character defined by the default locale. If this option is not selected, the keyboard driver defines the character used.
Default currency
The Default currency is that used in the country entered as Locale. The default currency determines the proper formatting of fields formatted as currency. If the locale setting is changed, the default currency changes automatically. If the default currency is changed, all dialogs involving currency and all currency icons will be changed in all open documents. Documents that were saved with one currency as the default will open using the new currency defaults.
Date acceptance patterns
Date acceptance patterns define how LibreOffice recognizes input as dates. Locale also defines the default expression of dates. You can define additional date patterns, separated by semicolons, using Y, M, & D for Year, Month, and Day. LibreOffice will always correctly interpret dates entered in ISO 8601 format as Y-M-D and YYYY-MM-DD.
· Caution 
Data entered into a Calc spreadsheet or a Writer table must be entered in a format defined by Local in order to be recognized as dates.
	Caution
[image: ]
	Data entered into a Calc spreadsheet or a Writer table must be entered in a format defined by Local in order to be recognized as dates.


Default languages for documents
Select the languages used for the spelling checker, thesaurus, and hyphenation features of LibreOffice. If these options are only for the current document, select For the current document only.
If necessary, select the options to enable support for Asian languages (Chinese, Japanese, Korean) and support for CTL (complex text layout) languages such as Urdu, Thai, Hebrew, and Arabic. If you choose either of these options, the next time you open this dialog, you will see some extra choices under Language Settings, as shown in Figure 14. These choices (Searching in Japanese, Asian Layout, and Complex Text Layout) are not discussed here.
Enhanced language support – Ignore system input language 
Default language settings depend on the Locale setting. The default locale is based on that of the computer’'s operating system. A keyboard layout is normally based on the language used by the operating system but can be changed by the user. If this option is not selected, and there is a change in keyboard layout, input from the keyboard will be different from what is expected.
[bookmark: __RefHeading__136164_780470623]Choose spelling options
To choose the options for checking spelling, click Language Settings > Writing Aids. In the Options section of the page (Figure 16), choose the settings that are useful for you.
[image: ]
[bookmark: Ref_Figure16_label_and_number]Figure 16: Choosing languages, dictionaries, and options for checking spelling

Some considerations:
· If you do not want spelling checked while you type, deselect Check spelling as you type. This option can also be deselected using the AutoSpellcheck button on the Standard toolbar.
· If you want grammar to be checked as you type, you must have Check spelling as you type enabled too.
· If you use a custom dictionary that includes words in all upper case and words with numbers (for example, AS/400), select Check uppercase words and Check words with numbers.
· Check special regions includes headers, footers, frames, and tables when checking spelling.
Here you can also check which user-defined (custom) dictionaries are active by default, and add or remove user-installed dictionaries, by clicking the New or Delete buttons. Dictionaries installed by the system cannot be deleted.
[image: ]
Figure 17: Choosing languages, dictionaries, and options for checking spelling

[bookmark: __RefHeading__34772_129573012]English sentence checking
On the Language Settings > English sentence checking page, you can choose which items are checked for, reported to you, or converted automatically. This menu is also found in the English dictionaries extension installed by default by LibreOffice. Select Tools > Extension Manager, select the English spelling dictionaries and click the Options button to reveal the menu. Select which of the optional features you wish to check.
After selecting the additional grammar checks, you must restart LibreOffice, or reload the document, for them to take effect.
[bookmark: __RefHeading__9905_127699423][image: ]
Figure 18: Choosing options for checking sentences in English

[bookmark: __RefHeading__36393_196514830]Grammar checking
Possible mistakes
Checks for things such as; with it’'s, he don’'t, this things and so on.
Capitalization
Checks for the capitalization of sentences. The sentence boundary detection depends on abbreviations.
Word duplication
Checks for all word duplication, rather than just the default words ‘and’, ‘or’, ‘for’, and ‘the’.
Parentheses
Checks for pairs of parentheses and quotation marks.
[bookmark: __RefHeading__9907_127699423]Punctuation
Word spacing
This option is selected by default. It checks for single spaces between words, indicating instances of double or triple spaces, but not of more spaces than that.
Sentence spacing
Checks for a single space between sentences, indicating when one or two extra spaces are found.
More spaces
Checks word and sentence spacing for more than two extra spaces.
Em dash; En dash
These options force a non-spaced em dash to replace a spaced en dash, or force a spaced en dash to replace a non-spaced em dash, respectively.
Quotation marks
Checks for correct typographical double quotation marks.
Multiplication sign
This option is selected by default. It replaces an ‘x’'x' used as a multiplication symbol with the correct typographical symbol.
Apostrophe
Replaces an apostrophe with the correct typographical character.
Ellipsis
Replaces three consecutive periods (full stops) with the correct typographical symbol.
Minus sign
Replaces a hyphen with the correct minus typographical character.
[bookmark: __RefHeading__9909_127699423]Others
Convert to metric; Convert to non-metric
Converts quantities in a given type of unit to quantities in the other type of unit: metric to imperial or imperial to metric.
Thousands separation of large numbers
Converts a number with five or more significant digits to a common format, that is one which uses the comma as a thousands separator, or to the ISO format which uses a narrow space as a separator.
[bookmark: __RefHeading__136166_780470623]Choosing Internet options
The Internet options available depend on your operating system.
Use the Proxy page (if available) to save proxy settings for use with LibreOffice.
[image: ]
Figure 19: Internet options, showing E-mail page available to Linux users

If you are using a Mozilla browser (such as Firefox) on Windows or Linux, you can enable the Browser Plug-in so you can open LibreOffice files in your browser, print them, save them, and work with them in other ways.
If you are using a Unix- or Linux-based operating system (including Mac OS X), an additional page of E-mail options is available, where you can specify the e-mail program to use when you send the current document as e-mail. Under Windows the operating system’s default e-mail program is always used.
A MediaWiki publisher is included on Windows and Linux. To enable it, select MediaWiki in the Internet options, then click the Add button to open the dialog shown in Figure 20. Here you can specify the address (URL) and log-in information for a wiki. You can add several wikis to the list.
[image: ]
[bookmark: Ref_Figure19_label_and_number]Figure 20: Specifying a MediaWiki server account

[bookmark: __RefHeading__136168_780470623]Controlling LibreOffice’s AutoCorrect functions
Some people find some or all of the items in LibreOffice’s AutoCorrect function annoying because they change what you type when you do not want it changed. Many people find some of the AutoCorrect functions quite helpful; if you do, then select the relevant options. But if you find unexplained changes appearing in your document, this is a good place to look to find the cause.
To open the AutoCorrect dialog, click Tools > AutoCorrect Options. (You need to have a document open for this menu item to appear.) In Writer, this dialog has five tabs, as shown in Figure 21. In other components of LibreOffice, the dialog has only four tabs. More details are given in the component guides.
[bookmark: __RefHeading__5648_15665686441]
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[bookmark: Ref_Figure20_label_and_number]Figure 21: The AutoCorrect dialog in Writer, showing some of the choices on the Options tab
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