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[bookmark: __RefHeading___Toc86653_811363531]Chapter 3  
Using Styles and Templates
Using Consistent Formatting in Your Documents


Using consistent formatting in your documents



[bookmark: __RefHeading___Toc86655_811363531]What is a template?
A template is a model document that you use to create other documents. For example, you can create a template for business reports that has your company’s logo on the first page. New documents created from this template will all have your company’s logo on the first page.
Templates can contain anything that regular documents can contain, such as text, graphics, a set of styles, and user-specific setup information such as measurement units, language, the default printer, and toolbar and menu customization.
All documents in LibreOffice are based on templates. You can create a specific template for any document type (text, spreadsheet, drawing, presentation). If you do not specify a template when you start a new document, then the document is based on the default template for that type of document. If you have not specified a default template, LibreOffice uses the blank template for that type of document that is installed with LibreOffice. See “Setting a default template” on page 19 for more information.
Since LibreOffice version 4.4, you can create templates for Master Documents as well as for ordinary documents.
[bookmark: __RefHeading__165509_78047062311111]What are styles?
A style is a set of formats that you can apply to selected pages, text, frames, and other elements in your document to quickly change their appearance. Often applying a style means applying a whole group of formats at the same time.
Many people manually format paragraphs, words, tables, page layouts, and other parts of their documents without paying any attention to styles. They are used to writing documents according to physical attributes. For example, you might specify the font family, font size, and any formatting such as bold or italic.
Styles are logical attributes. Using styles means that you stop saying “font size 14pt, Times New Roman, bold, centered”, and you start saying “Title” because you have defined the “Title” style to have those characteristics. In other words, using styles means that you shift the emphasis from what the text (or page, or other element) looks like, to what the text is.
Styles help improve consistency in a document. They also make major formatting changes easy. For example, you may decide to change the indentation of all paragraphs, or change the font of all titles. For a long document, this simple task can require making individual changes in dozens of places. By contrast, when you use styles, you only need to make a single change.
In addition, styles are used by LibreOffice for many processes, even if you are not aware of them. For example, Writer relies on heading styles (or other styles you specify) when it compiles a table of contents. Some common examples of style use are given in “Examples of style use” on page 23.
LibreOffice supports the following types of styles:
· Page styles include margins, headers and footers, borders and backgrounds. In Calc, page styles also include the sequence for printing sheets.
· Paragraph styles control all aspects of a paragraph’s appearance, such as text alignment, tab stops, line spacing, and borders, and can include character formatting.
· Character styles affect selected text within a paragraph, such as the font and size of text, or bold and italic formats.
· Frame styles are used to format graphic and text frames, including text wrap, borders, backgrounds, and columns.
· List styles allow you to select, format, and position numbers or bullets in lists.
· Cell styles include fonts, alignment, borders, background, number formats (for example, currency, date, number), and cell protection.
· Graphics styles in drawings and presentations include line, area, shadowing, transparency, font, connectors, dimensioning, and other attributes.
· Presentation styles include attributes for font, indents, spacing, alignment, and tabs.
Different styles are available in the various components of LibreOffice, as listed in Table 1.
LibreOffice comes with many predefined styles. You can use the styles as provided, modify them, or create new styles, as described in this chapter.
[bookmark: Ref_Table0_label_and_number]Table 1. Styles available in LibreOffice components
	Style Type
	Writer
	Calc
	Draw
	Impress

	Page
	X
	X
	
	

	Paragraph
	X
	
	
	

	Character
	X
	
	
	

	Frame
	X
	
	
	

	Numbering
	X
	
	
	

	Cell
	
	X
	
	

	Presentation
	
	
	X
	X

	Graphics
	(included in Frame styles)
	
	X
	X


[bookmark: __RefHeading__165511_780470623]Applying styles
LibreOffice provides several ways for you to select styles to apply:
1. Styles and Formatting window (floating, or in Sidebar)
· Fill Format Mode
· Apply Style List
· Keyboard shortcuts
[bookmark: __RefHeading__165513_780470623]Using the Styles and Formatting window
The Styles and Formatting window includes the most complete set of tools for styles. To use it for applying styles:
1. Select Format > the Styles and Formatting from the Menu barbutton located at the left-hand end of the Formatting toolbar, or select Format > Styles and Formatting, or press F11 (⌘+T on a Mac), or click the Styles and Formatting tab in the Sidebar (View > Sidebar to open it).
The Styles and Formatting window shows previews of the styles availablethe types of styles available at the current position of the mouse cursor. Figure 1 shows the window for Writer, with Paragraph Styles visible. You can move this window to a convenient position on the screen or dock it to the right edge (hold down the Ctrl key and drag it by the title bar to where you want it docked).
You can move this window to a convenient position on the screen or dock it to the right edge (see Chapter 1 for more information).
 1) Select one of the buttons at the top left of the Styles and Formatting window to display a list of styles in thata particular category.
 2) To apply an existing style, position the insertion point in the paragraph, frame, page, or word, and then double-click the name of the style in one of these lists. To apply a character style to more than one word, select the characters first.
· Tip
At the bottom of the Styles and Formatting window is a drop-down list. In Figure 1 the window shows Applied Styles, meaning the list includes only the styles used in the document. You can choose to show all styles or other groups of styles, for example only custom styles.
	Tip
	At the bottom of the Styles and Formatting window is a drop-down list. In Error: Reference source not found the window shows Automatic, meaning the list includes only a standard set of styles suggested by LibreOffice. You can choose to show all styles or other groups of styles, for example only custom styles.


[image: ]
[bookmark: Ref_Figure4_label_and_number]Figure 1: The Styles and Formatting window for Writer, showing paragraph styles

[bookmark: __RefHeading__165515_780470623]Using Fill Format Mode
Use Fill Format to apply a style to many different areas quickly without having to go back to the Styles and Formatting window and double-click every time. This method is quite useful when you need to format many scattered paragraphs, cells, or other items with the same style:
1. Open the Styles and Formatting window and select the style you want to apply.
 1) Select the Fill Format Mode button.
 2) To apply a paragraph, page, or frame style, hover the mouse over the paragraph, page, or frame and click. To apply a character style, hold down the mouse button while selecting the characters. Clicking a word applies the character style for that word.
 3) Repeat step 3 until you have made all the changes for that style.
 4) To quit Fill Format mode, click the Fill Format Mode button again or press the Esc key.
· Caution
When this mode is active, a right-click anywhere in the document undoes the last Fill Format action. Be careful not to accidentally right-click and undo actions you want to keep.
	Caution
[image: ]
	When this mode is active, a right-click anywhere in the document undoes the last Fill Format action. Be careful not to accidentally right-click and undo actions you want to keep.


[bookmark: __RefHeading__165517_780470623]Using the Apply Style list
After you have used a paragraph style at least once in a document, the style name appears on the Apply Style list near the left-hand end of the Formatting toolbar, next to the Styles and Formatting button.
You can open this list and click the style you want, or you can use the up and down arrow keys to move through the list and then press Enter to apply the highlighted style.
· Tip
Select More at the bottom of the Apply Style list to open the Styles and Formatting window.
	Tip
	Select More at the bottom of the Apply Style list to open the Styles and Formatting window.


[image: ]
Figure 2: The Apply Style list on the Formatting toolbar

[bookmark: __RefHeading__165519_780470623]Using keyboard shortcuts
Some keyboard shortcuts for applying styles are predefined. For example, in Writer Ctrl+0 applies the Text body style, Ctrl+1 applies the Heading 1 style, and Ctrl+2 applies the Heading 2 style. You can modify these shortcuts and create your own; see Chapter 14, Customizing LibreOffice, for instructions.
· Caution
Manual formatting (also called direct formatting) overrides styles, and you cannot get rid of the manual formatting by applying a style to it.
To remove manual formatting, select the text, right-click, and choose Clear Direct Formatting from the context menu, or use Ctrl+M after selecting the text.
	Caution
[image: ]
	Manual formatting (also called direct formatting) overrides styles, and you cannot get rid of the manual formatting by applying a style to it.
To remove manual formatting, select the text, right-click, and choose Clear Direct Formatting from the context menu, or use Ctrl+M after selecting the text.


[bookmark: __RefHeading__165521_780470623]Modifying styles
LibreOffice includes predefined styles, but you can also create custom styles. You can modify both types of styles in several ways:
1. Change a style using the Style dialog
· Update a style from a selection
· Use AutoUpdate (paragraph and frame styles only)
· Load or copy styles from another document or template
· Note
Any changes you make to a style are effective only in the current document. To change styles in more than one document, you need to change the template or copy the styles into the other documents as described on page 11.
	Note
	Any changes you make to a style are effective only in the current document. To change styles in more than one document, you need to change the template or copy the styles into the other documents as described on page 11.


[bookmark: __RefHeading__165523_780470623]Changing a style using the Style dialog
To change an existing style using the Style dialog, right-click on the required style in the Styles and Formatting window and select Modify from the pop-up menu.
The Style dialog displayed depends on the type of style selected. Each Style dialog has several tabs. See the chapters on styles in the user guides for details.
[bookmark: __RefHeading__165525_780470623]Updating a style from a selection
To update a style from a selection:
1. Open the Styles and Formatting window.
 1) In the document, select an item that has the format you want to adopt as a style.
· Caution
When updating a paragraph style, make sure that the selected paragraph contains unique properties. If it mixes font sizes or font styles, those mixed properties will remain the same as before.
	Caution
[image: ]
	When updating a paragraph style, make sure that the selected paragraph contains unique properties. If it mixes font sizes or font styles, those mixed properties will remain the same as before.


 2) In the Styles and Formatting window, select the style to update, then click on the arrow next to the New Style from Selection icon and click Update Style.
[image: ]
[bookmark: Ref_Figure6_label_and_number]Figure 3: Updating a style from a selection

· Tip
You can also modify styles using the submenu on each style in the Apply Style list on the Formatting toolbar (see Figure 4).
[image: ]
[bookmark: Ref_Figure7_label_and_number]Figure 4: Modifying a style from the Apply Style list

[bookmark: __RefHeading__165527_780470623]Using AutoUpdate
AutoUpdate applies to paragraph and frame styles only. If the AutoUpdate option is selected on the Organizer page of the Paragraph Style or Frame Style dialog, applying direct formatting to a paragraph or frame using this style in your document automatically updates the style itself.
· Tip
If you are in the habit of manually overriding styles in your document, be sure that AutoUpdate is not enabled.
	Tip
	If you are in the habit of manually overriding styles in your document, be sure that AutoUpdate is not enabled.


[bookmark: __RefHeading__165529_780470623]Updating styles from a document or template
You can update styles by copying (loading)or loading them from a template or another document. See “Copying styles from a template or document” on page 12.
[bookmark: __RefHeading__165531_780470623]Creating new (custom) styles
You may want to add some new styles. You can do this by using either the StyleStyles dialog or the New Style from Selection tool.
[bookmark: __RefHeading__165533_780470623]Creating a new style using the Style dialog
To create a new style using the StyleStyles dialog, right-click in the Styles and Formatting window and select New from the pop-up menu.
If you want your new style to be linked with an existing style, first select that style and then right-click and select New.
If you link styles, then when you change the base style (for example, by changing the font from Times to Helvetica), all the linked styles will change as well. Sometimes this is exactly what you want; other times you do not want the changes to apply to all the linked styles. It pays to plan ahead.
The dialogs and choices are the same for defining new styles and for modifying existing styles. See the chapters on styles in the user guides for details.
[bookmark: __RefHeading__165535_780470623]Creating a new style from a selection
You can create a new style by copying an existing manual format. This new style applies only to this document; it will not be saved in the template.
1. Open the Styles and Formatting window and choose the type of style you want to create.
 1) In the document, select the item you want to save as a style.
 2) In the Styles and Formatting window, select on the New Style from Selection icon.
 3) In the Create Style dialog, type a name for the new style. The list shows the names of existing custom styles of the selected type. Click OK to save the new style.
[image: ]
Figure 5: Naming a new style created from a selection

[bookmark: __RefHeading__165537_780470623]Dragging and dropping to create a style
You can drag and drop a selection into the Styles and Formatting window to create a new style. The element to drag depends upon the LibreOffice application.
Writer
Select some text and drag it to the Styles and Formatting window. If Paragraph Styles are active, the paragraph style will be added to the list. If Character Styles are active, the character style will be added to the list.
Calc
Drag a cell selection to the Styles and Formatting window to create a cell stylecell styles.
Draw/Impress
Select and drag a drawing objectdrawing objects to the Styles and Formatting window to create a graphic stylegraphics styles.
[bookmark: __RefHeading__6250_424592115]Copying styles from a template or document
You can copy styles into a document by loading them from a template or from another document:
1. Open the document you want to copy styles into.
 1) In the Styles and Formatting window, click the arrow next to the New Style from Selection icon, and then select Load Styles (see Figure 3).
 2) Select the categories of styles to be copied. Select Overwrite if you want the styles being copied to replace any styles of the same names in the document you are copying them into.
 3) On the Load Styles dialog (Figure 7), find either a template or an ordinary document from which to copy stylesfiles from. Click the From File button to open a window from which to select the required document.
 4) [image: ]
Figure 6: Copying styles from a template into the open document

 5) Select the types of styles to copy from the checkboxes at the bottom of the dialog.
 6) Select Overwrite if you want to replace styles in the original document that have the same name as styles in the document from which you are importing styles. If this box is not selected, you will only copy styles whose names are not used in the original document.
 7) Click OK to copy the styles.
[image: ]
[bookmark: Ref_Figure9_label_and_number]Figure 7: Copying styles from a template into the open document

· Caution
If your document has a table of contents, and if you have used custom styles for headings, the heading levels associated with outline levels in Tools > Outline Numbering will revert to the defaults of Heading 1, Heading 2, and so on when you load Text Styles from a file that does not use the same custom styles. You will need to change these back to your custom heading styles.
	Caution
[image: ]
	If your document has a table of contents, and if you have used custom styles for headings, the heading levels associated with outline levels in Tools > Outline Numbering will revert to the defaults of Heading 1, Heading 2, and so on when you load Text styles from a file that does not use the same custom styles. You will need to change these back to your custom heading styles.


[bookmark: __RefHeading__165543_780470623]Deleting styles
You cannot remove (delete) any of LibreOffice’s predefined styles from a document or template, even if they are not in use.
You can remove any user-defined (custom) styles; but before you do, you should make sure the styles are not in use in the current document. If an unwanted style is in use, you can replace it with a substitute style.
To delete any unwanted styles, in the Styles and Formatting window select each one to be deleted (hold Ctrl while selecting multiple styles), and then right-click on a selected style and select Delete on the context menu.
If the style is not in use, it is deleted immediately without confirmation. If the style is in use, you receive a warning message asking you to confirm deletion.
· Caution
If you delete a style that is in use, all objects with that style will return to the default style.
	Caution
[image: ]
	If you delete a style that is in use, all objects with that style will return to the default style.


[bookmark: __RefHeading__165545_780470623]Using a template to create a document
To use a template to create a document:
 1) From the Menu bar, choose File > New > Templates. The Template Manager dialog opens.
 2) From the tabs at the top of the dialog, select the category of template you want to use.
 3) Select the folder that contains the template that you want to use. All the templates contained in that folder are listed on the page (as shown in Figure 8).
 4) Select the template that you want to use. If you wish to view the template’s properties, click the Properties button above the list of templates. The template’s properties appear in a pop-up window. Click Close to close this pop-up window.
 5) Select the required template. A new document based on the selected template opens in LibreOffice.
The template the document is based upon is listed in File > Properties > General. The connection between the template and the document remains until the template is modified and, the next time that the document is opened, you choose not to update it to match the template.
[image: ]
[bookmark: Ref_Figure10_label_and_number]Figure 8: Template Manager dialog, showing a selected template

[bookmark: __RefHeading__165547_780470623]Creating a template
You can create your own templates in two ways: by saving a document as a template or by or using a wizard.
[bookmark: __RefHeading__165549_780470623]Creating a template from a document
In addition to formatting, any settings that can be added to or modified in a document can be saved within a template. For example, you can also save printer settings, and general behaviors set from Tools > Options, such as Paths and Colors.
Templates can also contain predefined text, saving you from having to type it every time you create a new document. For example, a letter template may contain your name, address, and salutation.
You can also save menu and toolbar customizations in templates; see Chapter 14, Customizing LibreOffice, for more information.
To create a template from a document and save it to My Templates:
1. Open a new or existing document of the type you want to make into a template (text document, spreadsheet, drawing, or presentation).
 7) Add any content that you want to appear in any document you create from the new template, for example company logo, copyright statement, and so on.
 8) Create or modify any styles that you want to use in the new template.
 9) From the Menu bar, choose File > Templates > Save As Template. The Template Manager dialog (Figure 9) opens, displaying the default folders and any user-created folders.
 10) Select the My Templates folder.
 11) Select Save.
 12) In the dialog that opens, type a name for the new template and click OKAccept.
 13) Close the Template Manager dialog.
[image: ]
[bookmark: Ref_Figure11_label_and_number]Figure 9: Template Manager dialog

· Note
Although the Template Manager shows only a Documents tab when saving a new template of any type, the template will appear on the correct tab (Documents, Spreadsheets, Presentations, Drawings) when you return to this dialog.
In addition to formatting, any settings that can be added to or modified in a document can be saved within a template. For example, you can also save printer settings, and general behaviors set from Tools > Options, such as Paths and Colors.
Templates can also contain predefined text, saving you from having to type it every time you create a new document. For example, a letter template may contain your name, address, and salutation.
You can also save menu and toolbar customizations in templates; see Chapter 14, Customizing LibreOffice, for more information.
[bookmark: __RefHeading__165551_780470623]Creating a template using a wizard
You can use wizards to create templates for letters, faxes, and agendas, and to create presentations, and Web pages.
For example, the Fax Wizard guides you through the following choices:
1. Type of fax (business or personal)
· Document elements like the date, subject line (business fax), salutation, and complementary close
· Options for sender and recipient information (business fax)
· Text to include in the footer (business fax)
To create a template using a wizard:
1. From the Menu bar, choose File > Wizards > [type of template required] (see Figure 10).
 4) Follow the instructions on the pages of the wizard. This process is slightly different for each type of template, but the format is very similar.
 5) In the last section of the wizard, you can specify the template name which will show in the Template Manager, and also the name and location for saving the template. The two names can be different but this may later cause you confusion. The default location is your user templates directory, but you can choose a different location if you prefer.
 6) To set the file name or change the directory, select the Path button (the three dots to the right of the location). The Save As dialog opens. Make your selections and click Save to close the dialog.
[image: ]
[bookmark: Ref_Figure12_label_and_number]Figure 10: Creating a template using a wizard

 7) Follow the instructions on the pages of the wizard. This process is slightly different for each type of template, but the format is very similar.
 8) In the last section of the wizard, you can specify the template name which will show in the Template Manager, and also the name and location for saving the template. The two names can be different but may cause you confusion if you choose two different names. The default location is your user templates directory, but you can choose a different location if you prefer.
 9) Selecting the Path button to set the file name, and perhaps change the directory, causes the Save As dialog to open. Setting the file name and clicking Save closes the dialog.
 10) Finally, you can choose whether to create a new document from your template immediately, or manually change the template, and then click Finish to save the template by clicking Finish. For future documents, you can re-use the template created by the wizard, just as you would use any other template.
You may need to open the Template Manager and click Refresh on the Action menu to have any new templates appear in the listings.
[bookmark: __RefHeading__165553_780470623]Editing a template
You can edit a template’s styles and content, and then, if you wish, you can reapply the template’s styles to documents that were created from that template. You cannot reapply content.
To edit a template:
1. From the Menu bar, choose File > Templates Template> Manage or press Ctrl+Shift+N. The Template Manager dialog opens.
 15) Navigate to the template that you want to edit. Click once on it to activate the file handling controls (see Figure 8). Click Edit. The template opens in LibreOffice.
 16) Edit the template just as you would any other document. To save your changes, choose File > Save from the Menu bar.
[bookmark: __RefHeading__39375263]Updating a document from a changed template
If you make any changes to a template and its styles, the next time you open a document that was created fromon the template before the changes, a confirmation message is displayed.
To update the document:
1. Click Update Styles to apply the changed styles in the template to the document.
 12) Select Keep Old Styles if you do not want to apply the changed styles in the template to the document. (but see the Caution notice below).
· Caution
If you choose Keep Old Styles, the document is no longer connected to the template, even though the template is still listed under File > Properties > General. You can still import styles manually from the template, but to reconnect it to the template, you will have to copy it into an empty document based on the template. 
	Caution 
[image: ]
	If you choose Keep Old Styles, the document is no longer connected to the template, even though the template is still listed under File > Properties > General. You can still import styles manually from the template, but to reconnect it to the template, you will have to copy it into an empty document based on the template.


[bookmark: __RefHeading__40102586]Adding templates obtained from other sources
LibreOffice refers to sources for templates as repositories. A repository can be local (a directory on your computer to which you have downloaded templates) or remote (a URL from which you can download templates).
You can get to the official template repository by using the Get more templates for LibreOffice button at the right-hand end of the Template Manager dialog, as shown in Figure 11, or by typingentering http://templates.libreoffice.org/template-center in your browser’s address bar.
[image: ]
[bookmark: Ref_Figure13_label_and_number]Figure 11: Getting more templates for LibreOffice

If you have enabled experimental features in Tools > Options > LibreOffice > Advanced, the Template Manager shows a Repository button that you can use to add other template repositories. As this is an experimental feature, it may not work reliably.
On other websites you may find collections of templates that have been packaged into extension (OXT) files. These are installed a little differently, as described below.
[bookmark: __RefHeading__77599_886442828]Installing individual templates
To install individual templates:
1. Download the template and save it anywhere on your computer.
 14) Import the template into a template folder by following the instructions in “Importing a template” on page 22.
· Tip
You can manually copy new templates into the template folders. The location varies with your computer’s operating system. To learn where the template folders are stored on your computer, go to Tools > Options > LibreOffice > Paths.
	Tip
	You can manually copy new templates into the template folders. The location varies with your computer’s operating system. To learn where the template folders are stored on your computer, go to Tools > Options > LibreOffice > Paths.


[bookmark: __RefHeading__77601_886442828]Installing collections of templates
The Extension Manager provides an easy way to install collections of templates that have been packaged as extensions. Follow these steps:
1. Download the extension package (OXT file) and save it anywhere on your computer.
 1) In LibreOffice, select Tools > Extension Manager from the Menu bar. In the Extension Manager dialog, click Add to open a file browser window.
 2) Find and select the package of templates you want to install and click Open. The package begins installing. You may be asked to accept a license agreement.
 3) When the package installation is complete, restart LibreOffice. The templates are available for use through File > Templates > Manage and File > New > Templates and the extension is listed in the Extension Manager.
See Chapter 14 Customizing LibreOffice for more about the Extension Manager.
[bookmark: __RefHeading__7025_1080284074][bookmark: Ref_Setting_a_default_template][bookmark: Ref_Setting_a_default_template]Setting a default template
If you create a document by choosing File > New > Text Document (or Spreadsheet, Presentation, or Drawing) from the Menu bar, LibreOffice creates the document from the default template for that type of document. You can, however, change the default whenever you choose.
· Note for Microsoft Word users
You may know that Microsoft Word employs a normal.dot or normal.dotx file for its default template and how to regenerate it.
LibreOffice does not have a similar default template file; the “factory defaults” are embedded within the software.
	Note for Microsoft Word users
	You may know that Microsoft Word employs a normal.dot or normal.dotx file for its default template and how to regenerate it.
LibreOffice does not have a similar default template file; the “factory defaults” are embedded within the software.


[bookmark: __RefHeading__165557_780470623]Setting a template as the default
Most default settings, such as page size and page margins, can be changed in Tools > Options, but those changes apply only to the document you are working on. To make those changes the default settings for that document type, you need to replace the default template with a new one.
You can set any template displayed in the Template Manager dialog to be the default for that document type:
1. From the Menu bar, choose File > Templates > Manage.
 1) In the Template Manager dialog, open the folder containing the template that you want to set as the default, then select the template.
 2) Click the Set as default button above the list of templates (see Figure 8).
The next time that you create a document of that type by choosing File > New, the document will be created from this template.
Although many important settings can be changed in the Tools > Options dialog (see Chapter 2) for the default template, for example default fonts and page size, more advanced settings (such as page margins) can be changed only by replacing the default template with a new one.
[bookmark: __RefHeading__165559_780470623]Resetting the default template
To re-enable LibreOffice’s original default template for a document type as the default for that type:
1. In the Template Manager dialog, click the Action Menu icon on the right.
 1) Point to Reset Default Template on the drop-down menu, and click Text Document (or other template type).
These choices do not appear unless a custom template has been set as the default, as described in the previous section.
The next time that you create a document by choosing File > New, the document will be created from the original default template for the document type.
[image: ]
Figure 12: Resetting the default template for text documents

[bookmark: __RefHeading__165561_780470623]Associating a document with a different template
At the time of writing this chapter, LibreOffice has no direct method of changing the template that a document uses; the Template Changer extension has not been updated for this version of LibreOffice. However, you can copy the contents of a document into an empty document that uses a different template.
	Note
	In LibreOffice 3.x, you could use the Template Changer extension to simplify this process. Unfortunately, this extension does not work in LibreOffice 4.x.


For best results, the names of styles should be the same in the existing document and the new template. If they are not, use Edit > Find & Replace to replace old styles with new ones. See Chapter 4, Getting Started with Writer, for more about replacing styles using Find & Replace.
To associate a document with another template:
1. Use File > Templates > Manage to open the Template Manager dialog, and select the template you want to use. A new document opens, containing any text or graphics that were in the template.
 18) Delete any unwanted text or graphics from this new document.
 19) Open the document you want to change. Select Edit > Select All or press Ctrl+A.
 20) Select Edit > Copy, or press Ctrl+C, to copy the contents of the document to the clipboard.
 21) Click inside the blank document created in step 1. Go to Edit > Paste, or press Ctrl+V, to paste the contents from the old document into the new one.
 22) Update the table of contents, if there is one. Close the old file without saving. Go to File > Save As to save the new file with the name of the file from which content was taken. When asked, confirm that you want to overwrite the old file. You may prefer to save the new file under a new name and preserve the old file under its original name.
· Caution
Any changes recorded (tracked) in the document will be lost during this process. The resulting document will contain only the changed text.
[bookmark: __RefHeading__165563_780470623]Organizing templates
LibreOffice can use only those templates that are in its template folders. You can create new template folders and use them to organize your templates. For example, you might have one template folder for report templates and another for letter templates. You can also import and export templates.
To begin, choose File > Templates > Manage to open the Template Manager dialog.
[bookmark: __RefHeading__27761_1681342437]Creating a template folder
To create a template folder:
1. Go to the All Templates section of the Template Manager dialog.
 1) Click the New folder button (see Figure 13).
 2) In the pop-up dialog, type a name for the new folder and click OKAccept.
[image: ]
[bookmark: Ref_Figure15_label_and_number]Figure 13: Creating a new folder

[bookmark: __RefHeading__27763_1681342437]Deleting a template folder
You cannot delete template folders supplied with LibreOffice. Nor can you delete any folders addedcreated by the Extension Manager unless you first delete the extension that installed them. 
However, you can select a folder that you created and click the Delete button. When a message box appears, asking you to confirm the deletion, click Yes.
[bookmark: __RefHeading__27765_1681342437]Moving a template
To move a template from one template folder to another, select it in the Template Manager dialog, and click the Move to folder button above the list of templates (see Figure 14).
[image: ]
[bookmark: Ref_Figure16_label_and_number]Figure 14: Template file handling icons

[bookmark: __RefHeading__165571_780470623]Deleting a template
You cannot delete templates supplied with LibreOffice. Nor can you delete any templates installedcreated by the Extension Manager except by deleting the extension that installed them.
However, you can delete templates that you have created or imported:
1. In the Template Manager dialog, double-click the folder that contains the template you want to delete.
 1) Select the template to delete.
 2) ClickSelect the Delete button above the list of templates. A message box appears and asks you to confirm the deletion. Click Yes.
[bookmark: __RefHeading__165573_780470623]Importing a template
Before you can use a template in LibreOffice, it must be in one of the folders listed for the Template path in Tools > Options > LibreOffice > Paths:
 1) In the Template Manager dialog, select the folder into which you want to import the template.
 2) Click the Import button above the list of template folders. A standard file browser window opens.
 3) Find and select the template that you want to import and click Open. The file browser window closes and the template appears in the selected folder.
[bookmark: __RefHeading__165575_780470623]Exporting a template
To export a template from a template folder to another location:
1. In the Template Manager dialog, double-click the folder that contains the template to export.
 1) Select the template that you want to export.
 2) ClickSelect the Export button above the list of template folders. The Save As window opens.
 3) Find the folder into which you want to export the template and select Save.
[bookmark: __RefHeading__165577_780470623][bookmark: Ref_Examples_of_style_use][bookmark: Ref_Examples_of_style_use]Examples of style use
The following examples of common use of page and paragraph styles are taken from Writer. There are many other ways to use styles; see the guides for the various components for details.
[bookmark: __RefHeading__165579_780470623]Defining a different first page for a document
Many documents, such as letters and reports, have a first page that is different from the other pages in the document. For example, the first page of a letterhead typically has a different header, or the first page of a report might have no header or footer, while the other pages do. With LibreOffice, you can define the page style for the first page and specify the style for the following pages to be applied automatically.
As an example, we can use the First Page and Default page styles that come with LibreOffice. Figure 15 shows what we want to happen: the first page is to be followed by the default page, and all the following pages are to be in the Default page style. Details are in Chapter 4, Formatting Pages, in the Writer Guide.
[image: ]
[bookmark: Ref_Figure17_label_and_number]Figure 15: Flow of page styles

[bookmark: __RefHeading__165581_780470623]Dividing a document into chapters
In a similar way, you can divide a document into chapters. Each chapter might start with the First Page style, with the following pages using the Default page style, as above. At the end of the chapter, insert a manual page break and specify the next page to have the First Page style to start the next chapter, as shown in Figure 16.
[image: ]
[bookmark: Ref_Figure18_label_and_number]Figure 16: Dividing a document into chapters using page styles

[bookmark: __RefHeading__165583_780470623]Changing page orientation within a document
A Writer document can contain pages in more than one orientation. A common scenario is to have a landscape page in the middle of a document, whereas the other pages are in a portrait orientation. This setup can also be created with page breaks and page styles.
[bookmark: __RefHeading__165585_780470623]Displaying different headers on right and left pages
Page styles can be set up to have the facing left and right pages mirrored or only right (first pages of chapters are often defined to be right-page only) or only left. When you insert a header on a page style set up for mirrored pages or right-and-left pages, you can have the contents of the header be the same on all pages or be different on the right and left pages. For example, you can put the page number on the left-hand edge of the left pages and on the right-hand edge of the right pages, put the document title on the right-hand page only, or make other changes.
[bookmark: __RefHeading__165587_780470623]Controlling page breaks automatically
Writer automatically flows text from one page to the next. If you do not like the default settings, you can change them. For example, you can require a paragraph to start on a new page or column and specify the style of the new page. A typical use is for chapter titles to always start on a new right-hand (odd-numbered) page.
[bookmark: __RefHeading__165589_780470623]Compiling an automatic table of contents
To compile an automatic table of contents, first apply styles to the headings you want to appear in the contents list, then use Tools > Outline Numbering to tell Writer which styles go with which level in the table of contents. By default, tables of contents use Heading styles, but you can use whatever combination of styles you prefer. See Chapter 4 for more information.
[bookmark: __RefHeading__165591_780470623]Defining a sequence of paragraph styles
[bookmark: __RefHeading__5648_15665686442]You can set up one paragraph style so that when you press Enter at the end of that paragraph, the following paragraph automatically has the style you wish applied to it. For example, you could define a Heading 1 paragraph to be followed by a Text Body paragraph. A more complex example would be: Title followed by Author followed by Abstract followed by Heading 1 followed by Text Body. By setting up these sequences, you can usually avoid having to apply styles manually.
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[bookmark: __RefHeading___Toc86659_811363531]What is Writer?
Writer is the word processor component of LibreOffice. In addition to the usual features of a word processor (spelling check, thesaurus, hyphenation, autocorrect, find and replace, automatic generation of tables of contents and indexes, mail merge and others), Writer provides these important features:
· Templates and styles (see Chapter 3)
· Page layout methods, including frames, columns, and tables
· Automated tables of contents and indexes
· Embedding or linking of graphics, spreadsheets, and other objects
· Built-in drawing tools
· Master documents—to group a collection of documents into a single document
· Change tracking during revisions
· Database integration, including a bibliography database
· Mail merge
· Export to PDF, including bookmarks (see Chapter 10)
· And many more
These features are covered in detail in the Writer Guide.
[bookmark: __RefHeading__19478_697337876]The Writer interface
The main Writer workspace is shown in Figure 17. The menus and toolbars are described in Chapter 1, Introducing LibreOffice.
Some other features of the Writer interface are covered in this chapter.
[image: ]
[bookmark: Ref_Figure19_label_and_number]Figure 17: The main Writer workspace in Print Layout view (without the Sidebar)

[bookmark: __RefHeading__19480_697337876]Status Bar
The Writer Status Bar provides information about the document and convenient ways to quickly change some document features quickly.
[image: ]
Figure 18: Left end of Status Bar

[image: ]
Figure 19: Right end of Status Bar

Page number
Shows the current page number, the sequence number of the current page (if different), and the total number of pages in the document. For example, if you restarted page numbering at 1 on the third page, its page number is 1 and its sequence number is 3.
If any bookmarks have been defined in the document, a right-click on this field pops up a list of bookmarks; click on the required one.
To jump to a specific page in the document, double-click on this field. The Navigator opens. Click in the Page Number field and type the sequence number of the required page and press Enter.
Word and character count 
The word and character count of the document is shown in the Status Bar, and is kept up to date as you edit. Any text selected in the document will be counted and this count will replace the displayed count.
	[image: ]
	[image: ]


To display extended statistics such as character counts excluding spaces, double-click the word count in the Status Bar, or choose Tools > Word Count.
Page style
Shows the style of the current page. To change the page style, right-click on this field. A list of page styles pops up; choose a different style by clicking on it.
To edit the current page style, double-click on this field. The Page Style dialog opens.
Language
Shows the language at the cursor position, or for the selected text, that is used for checking spelling and forspellchecking, hyphenation and thesaurus.
Click to open a menu where you can choose another language for the selected text or for the paragraph where the cursor is located. You can also choose None (Do not check spelling) to exclude the text from a spelling check or choose More to open the Character dialog. Any directly formatted language settings can be reset to the default language from this menu.
Insert mode
This area is blank when in Insert mode. Double-click to change to Overwrite mode; single-click to return to Insert mode. In Insert mode, any text after the cursor position moves forward to make room for the text you type; in Overwrite mode, text after the cursor position is replaced by the text you type. This feature is disabled when in Edit > Changes > Record mode.
Selection mode
Click to choose different selection modes. The icon does not change, but when you hover the mouse pointer over this field, a tooltip indicates which mode is active.
When you click in the field, a context menu displays the available options.
	Mode
	Effect

	Standard selection
	Click in the text where you want to position the cursor; click in a cell to make it the active cell. Any other selection is deselected.

	Extending selection (F8)
	Clicking in the text extends or crops the current selection.

	Adding selection (Shift+F8)
	A new selection is added to an existing selection. The result is a multiple selection.

	Block selection (Ctrl+Shift+F8)
	A block of text can be selected.


On Windows systems, you can hold down the Alt key while dragging to select a block of text. You do not need to enter the block selection mode.
Document changes status
The icon that is displayed here changes from this one ([image: ]) if the document has no unsaved changes, to this one ([image: ]) if it has been edited and the changes have not been saved.
Digital signature
If the document has been digitally signed, this icon ([image: ]) is displayed here; otherwise, it is blank.  To view the certificate, double-click the icon.
Section or object information
When the cursor is on a section, heading, or list item, or when an object (such as a picture or table) is selected, information about that item appears in this field. Double-clicking in this area opens a relevant dialog. For details, consult the Help or the Writer Guide.
View layout
Click an icon to change between single page, side-by-side, and book layout views. The effect varies with the combination of window width and zoom factor in use. You can edit the document in any view. See Figure 20.
Zoom
To change the view magnification, drag the Zoom slider, or click on the + and – signs, or right-click on the zoom level percent to pop up a list of magnification values from which to choose. Zoom interacts with the selected view layout to determine how many pages are visible in the document window.
[image: ]
[image: ]
[bookmark: Ref_Figure22_label_and_number]Figure 20: View layouts: single, side-by-side, book.

[bookmark: __RefHeading__3714_2003494879]Sidebar
The Writer sidebar (View > Sidebar) is located on the right side of the edit view. It is a mixture of toolbar and dialog and consists of four decks: Properties, Styles and Formatting, Gallery, and Navigator.  Each deck has a corresponding icon on the Tab panel to the right of the sidebar, allowing you to switch between them.
Each deck consists of a title bar and one or more content panels. Toolbars and sidebar panels share many functions. For example, the buttons for making text bold or italic exist in both the Formatting toolbar and the Character panel of the Properties deck.
Some panels contain a More Options button ([image: ]) which when clicked opens a dialog to give greater choice of editing controls. The dialog that opens locks the document for editing until the dialog is closed.
The decks are described below.:
· Properties: Contains tools for direct formatting within the document. By default, the tools are separated into the following three panels for text editing:
· Character: Modify text by the font type, size, color, weight, style and spacing.
· Paragraph: Style the paragraph by alignment, lists or bullets, background color, indent, and spacing.
· Page: Format the page by orientation, margin, size, and number of columns.
If a graphic is selected, then the following panels open:;
· Graphic: Modify the graphic’'s brightness, contrast, color mode and transparency.
· Position: Modifications to width and height.
· Wrap: Permits wrap modifications where these are available.
If a drawing object is selected, then the following panels are available:;
· Area: Fill and transparency edits are available.
· Line: Permits edits to the line style, width, color, arrows, corners and cap styles.
· Position and Size: Enables edits to width, height, rotation and flip attributes.
If a frame is selected, then the wrap panel opens but may be grayed-out if frame wrap is not available.
· Caution
Be aware that by changing the options on the Page panel you will change the page style in use, modifying not only the current page but all pages using the same page style.
	Caution
[image: ]
	Be aware that by changing the options on the Page panel you will change the page style in use, modifying not only the current page but all pages using the same page style.


· Styles and Formatting: Manage the styles used on the document, applying existing styles, creating new ones or modifying them. This deck is also a floating toolbar that can be accessed from Format > Styles and Formatting from the Menu bar.
· Gallery: Add images and diagrams included in the Gallery themes. The Gallery displays as two sections; the first lists the themes by name (Arrows, Background, Diagrams, etc.) and the second displays the images in the selected category. Select the New Theme button to create new categories. To insert an image into a file, or add a new image to the new category, just drag and drop the selected image using the file manager. This deck is also a docked toolbar that can be accessed from Tools > Gallery or the Gallery button on the Standard Toolbar.
· Navigator: Browse the document and reorganize its content by selecting different content categories, such as headings, tables, frames, graphics, etc. This deck is similar to the floating toolbar that can be accessed from View > Navigator or the Navigator button on the Standard Toolbar. In contrast, the Sidebar Navigator does not contain a List Box On/Off button.
[image: ]
Figure 21: Sidebar Properties deck and text content panels

[bookmark: __RefHeading__19482_697337876]Changing document views
Writer has several ways to view a document: Print Layout, Web Layout, and Full Screen. To access these and other choices, go to the View menu and click on the required view. (When in Full Screen view, press the Esc key to return to either Print or Web Layout view.)
Print Layout is the default view in Writer. In this view, you can use the Zoom slider and the View Layout icons on the Status Bar to change the magnification.
You can also choose View > Zoom > Zoom from the menu bar to display the Zoom & View Layout dialog, where you can set the same options as on the Status Bar. In Web Layout view, most of the choices are not available.
[image: ]
Figure 22: Choosing Zoom and View Layout options.

[bookmark: __RefHeading__19484_697337876]Moving quickly through a document
In addition to the navigation features of the Status Bar (described above), you can use the Navigator window and the Navigation toolbar, either from the Standard toolbar or from the Sidebar, as described in Chapter 1, Introducing LibreOffice.
In Writer, you can also display the Navigation toolbar by clicking on the Navigation button near the lower right-hand corner of the window below the vertical scroll bar, as shown in Error: Reference source not found.
[image: ]
Figure 23: Navigation buttons

The Navigation toolbar (Figure 24) shows buttons for all the object types shown in the Navigator, plus some extras (for example, the Find command).
[image: ]
[bookmark: Ref_Figure25_label_and_number]Figure 24: Navigation toolbar

Click a button to select that object type. Now all the Previous and Next button presses (in the Navigator itself, in the Navigation Toolbar, and on the scroll bar) will jump to the next object of the selected type. This is particularly helpful for finding items like index entries, which can be difficult to see in the text. The names of the buttons (shown in the tooltips) change to match the selected category; for example, Next Graphic, Next Bookmark, or Continue search forward.
For more uses of the Navigator in Writer, see the Writer Guide.
[bookmark: __RefHeading__19486_697337876]Working with documents
Chapter 1, Introducing LibreOffice, includes instructions on starting new documents, opening existing documents, saving documents, and password-protecting documents. Chapter 3, Using Styles and Templates, covers how to create a document from a template.
[bookmark: __RefHeading__19488_697337876]Saving as a Microsoft Word file
If you need to exchange documents with users of Microsoft Word who are unwilling or unable to receive ODT files, you can open, edit, and save documents in save a document as a Microsoft Word formatsfile.
You can also create and edit ODT files and then save them as DOC or DOCX files. To do this:
1. Important—First save your document in the file format used by LibreOffice Writer (ODT). If you do not, any changes you made since the last time you saved will appear only in the Microsoft Word version of the document.
 16) Then choose File > Save As. On the Save As dialog (Figure 25), in the File type (or Save as type) drop-down menu, select the type of Word format you need. Files cannot be saved to the Word version 6.0/95 file format. Click Save.
From this point on, all changes you make to the document will occur only in the new document. You have changed the name and file type of your document. If you want to go back to working with the ODT version of your document, you must open it again.
[image: ]
[bookmark: Ref_Figure26_label_and_number]Figure 25: Saving a file in Microsoft Word format

· Tip
Saving in ODF format gives you the option to redo the document if the recipient of your document experiences trouble with the Microsoft format.
· Tip
To have Writer save documents by default in the Microsoft Word file format, go to Tools > Options > Load/Save > General. In the section named Default file format and ODF settings, under Document type, select Text document, then under Always save as, select your preferred file format. See Figure 26.
	Tip
	To have Writer save documents by default in the Microsoft Word file format, go to Tools > Options > Load/Save > General. In the section named Default file format and ODF settings, under Document type, select Text document, then under Always save as, select your preferred file format. See Error: Reference source not found.


	Caution
[image: ]
	It is recommended that if you use a Microsoft Word format, you use the DOC and not the DOCX format.
Saving in ODF format gives you the option to redo the document if the recipient of your document experiences trouble with the Microsoft format.


[image: ]
[bookmark: Ref_Figure27_label_and_number]Figure 26: Tools > Options > Load/Save > General page

[bookmark: __RefHeading__19490_697337876]Working with text
Working with text (selecting, copying, pasting, moving) in Writer is similar to working with text in any other program. LibreOffice also has some convenient ways to select items that are not next to each other, select a vertical block of text, and paste unformatted text.
[bookmark: __RefHeading__19492_697337876][bookmark: _Ref20121348]Selecting items that are not consecutive
To select nonconsecutive items (as shown in Figure 27) using the mouse:
1. Select the first piece of text.
 1) Hold down the Ctrl key and use the mouse to select the next piece of text.
 2) Repeat as often as needed.
Now you can work with the selected text (copy it, delete it, change the style, or whatever).
· Note
Macintosh users: substitute the Command key when instructions in this chapter say to use the Ctrl key.
	Note
	Macintosh users: substitute the Command key when instructions in this chapter say to use the Ctrl key.


[image: ]
[bookmark: Ref_Figure28_label_and_number]Figure 27: Selecting items that are not next to each other

To select nonconsecutive items using the keyboard:
1. Select the first piece of text. (For more information about keyboard selection of text, see the topic “Navigating and selecting with the keyboard” in the Help.)
 1) Press Shift+F8. This puts Writer in “Adding selection” mode.
 2) Use the arrow keys to move to the start of the next piece of text to be selected. Hold down the Shift key and select the next piece of text.
 3) Repeat as often as required.
Now you can work with the selected text.
Press Esc to exit from this mode.
[bookmark: __RefHeading__19494_697337876]Selecting a vertical block of text
You can select a vertical block or “column” of text that is separated by spaces or tabs (as you might see in text pasted from e-mails, program listings, or other sources), using LibreOffice’s block selection mode. To change to block selection mode, use Edit > Selection Mode > Block Area, or press Ctrl+F8, or click on the Selection icon in the Status Bar and select Block selection from the list.
[image: ]
Now highlight the selection, using mouse or keyboard, as shown below.
[image: ]
Figure 28: Selecting a vertical block of text

[bookmark: __RefHeading__19496_697337876]Cutting, copying, and pasting text
Cutting and copying text in Writer is similar to cutting and copying text in other applications. You can use the mouse or the keyboard for these operations. You can copy or move text within a document, or between documents, by dragging or by using menu selections, toolbar buttons, or keyboard shortcuts. You can also copy text from other sources such as Web pages and paste it into a Writer document.
To move (drag and drop) selected text using the mouse, drag it to the new location and release it. To copy selected text, hold down the Ctrl key while dragging. The text retains the formatting it had before dragging.
To move (cut and paste) selected text, use Ctrl+X to cut the text, insert the cursor at the paste-in point and use Ctrl+V to paste. Alternatively, use the buttons on the Standard toolbar.
When you paste text, the result depends on the source of the text and how you paste it. If you click on the Paste button, any formatting the text has (such as bold or italics) is retained. Text pasted from Web sites and other sources may also be placed into frames or tables. If you do not like the results, click the Undo button or press Ctrl+Z.
To make the pasted text take on the formatting of the surrounding text where it is being pasted:
· Choose Edit > Paste Special, or
· Click the arrow button of the combination Paste button, or
· Click the Paste button without releasing the left mouse button.
Then select Unformatted text from the resulting menu.
The range of choices on the Paste Special menu varies depending on the origin and formatting of the text (or other object) to be pasted. See Figure 29 for an example with text on the clipboard.
[image: ]
[bookmark: Ref_Figure30_label_and_number]Figure 29: Paste Special menu

[bookmark: __RefHeading__19498_697337876]Finding and replacing text and formatting
Writer has two ways to find text within a document: the Find toolbar for fast searching and the Find & Replace dialog. In the dialog, you can:
1. Find and replace words and phrases
· Use wildcards and regular expressions to fine-tune a search
· Find and replace specific attributes or formatting
· Find and replace paragraph styles
[bookmark: __RefHeading__83375_462712302]Using the Find toolbar
If the Find toolbar is not visible, you can display it by choosing View > Toolbars > Find from the Menu bar or by pressing Ctrl+F. The Find toolbar is shown docked at the bottom of the LibreOffice window (just above the Status Bar) in Figure 30, but you can float it or dock it in another location. For more information on floating and docking toolbars, see Chapter 1, Introducing LibreOffice.
[image: ]
[bookmark: Ref_Figure31_label_and_number]Figure 30: Docked position of Find toolbar

To use the Find toolbar, click in the box and type your search text, then press Enter to find the next occurrence of that term from the current cursor position. Click the Find Next or Find Previous buttons as needed. 
Click the Find All button to select all instances of the search term within the document. Select Match Case to find only the instances that exactly match the search term. Select the button to the right of Match Case to open the Find & Replace dialog. 
The Find toolbar can be closed by clicking the red X button on the left, or by pressing Esc on the keyboard when the text cursor is in the search box.
[bookmark: __RefHeading__83377_462712302]Using the Find & Replace dialog
To display the Find & Replace dialog, use the keyboard shortcut Ctrl+H or choose Edit > Find & Replace from the Menu bar. If the Find toolbar is open, click the Find and Replace button ([image: ]) on the toolbar. Once opened, optionally click the Other Options symbol to expand the dialog. Click the button again to reduce the dialog options.
To use the Find & Replace dialog:
1. Type the text you want to find in the Search for box.
 18) To replace the text with different text, type the new text in the Replace with box.
 19) You can select various options such as matching the case, matching whole words only, or doing a search for similar words.
 20) When you have set up your search, click Find. To replace the found text, click Replace.
For more information on using Find & Replace, see the Writer Guide.
· Tip
If you click Find All, LibreOffice selects all instances of the search text in the document. Similarly, if you click Replace All, LibreOffice replaces all matches.
· Caution
Use Replace All with caution; otherwise, you may end up with some hilarious (and highly embarrassing) mistakes. A mistake with Replace All might require a manual, word-by-word, search to fix.
	Tip
	If you click Find All, LibreOffice selects all instances of the search text in the document. Similarly, if you click Replace All, LibreOffice replaces all matches.


	Caution
[image: ]
	Use Replace All with caution; otherwise, you may end up with some hilarious (and highly embarrassing) mistakes. A mistake with Replace All might require a manual, word-by-word, search to fix.


[image: ]
Figure 31: Expanded Find & Replace dialog

[bookmark: __RefHeading__19500_697337876]Inserting special characters
A special character is one not found on a standard English keyboard. For example, © ¾ æ ç ñ ö ø ¢ are all special characters. To insert a special character:
1. Place the cursor where you want the character to appear.
 4) Choose Insert > Special Character to open the Special Characters dialog.
 5) Select the characters (from any font or mixture of fonts) you wish to insert, in order, then click OK. The characters selected for insertion are shown in the lower left of the dialog. As you select a character, it is shown on the right, along with its numerical code.
· Note
Different fonts include different special characters. If you do not find a particular special character, try changing the Font selection.
	Note
	Different fonts include different special characters. If you do not find a particular special character, try changing the Font selection.


[image: ]
Figure 32: The Special Characters dialog, where you can insert special characters

[bookmark: __RefHeading__19502_697337876]Inserting dashes and non-breaking spaces and hyphens
To prevent two words from being separated at the end of a line, press Ctrl+Shift when you type the space between the two words.
In cases where you do not want the hyphen to appear at the end of a line, for example in a number such as 123‑4567, you can press Shift+Ctrl+minus sign to insert a non-breaking hyphen.
To enter en and em dashes, you can use the Replace dashes option on the Options tab under Tools > AutoCorrect Options. This option replaces two hyphens, under certain conditions, with the corresponding dash.
–	is an en-dash; that is, a dash the width of the letter “n” in the font you are using. Type at least one character, a space, one or two hyphens, another space, and at least one more letter. The one or two hyphens will be replaced by an en-dash.
—	is an em-dash; that is, a dash the width of the letter “m” in the font you are using. Type at least one character, two hyphens, and at least one more character. The two hyphens will be replaced by an em-dash.
See the Help for more details. For other methods of inserting dashes, see Chapter 3, Working with Text in the Writer Guide.
[bookmark: __RefHeading__19504_697337876]Setting tab stops and indents
The horizontal ruler shows the tab stops. Any tab stops that you have defined will overwrite the default tab stops. Tab settings affect indentation of full paragraphs (using the Increase Indent and Decrease Indent buttons on the Formatting toolbar) as well as indentation of parts of a paragraph (by pressing the Tab key on the keyboard).
Using the default tab spacing can cause formatting problems if you share documents with other people. If you use the default tab spacing and then send the document to someone else who has chosen a different default tab spacing, tabbed material will change to use the other person’s settings. Instead of using the defaults, define your own tab settings, as described in this section.
To define indents and tab settings for one or more selected paragraphs, double-click on a part of the ruler that is not between the left and right indent icons to open the Indents & Spacing page of the Paragraph dialog. Double-click anywhere between the left and right indent icons on the ruler to open the Tabs page of the Paragraph dialog.
A better strategy is to define tabs for the paragraph style. See Chapters 6 and 7 in the Writer Guide for more information.
· Tip
Using tabs to space out material on a page is not recommended. Depending on what you are trying to accomplish, a table is usually a better choice.
	Tip
	Using tabs to space out material on a page is not recommended. Depending on what you are trying to accomplish, a table is usually a better choice.


[bookmark: __RefHeading__19506_697337876]Changing the default tab stop interval
· Caution
Any changes to the default tab setting will affect the existing default tab stops in any document you open afterward, as well as tab stops you insert after making the change.
	Note
	Any changes to the default tab setting will affect the existing default tab stops in any document you open afterward, as well as tab stops you insert after making the change.


To set the measurement unit and the spacing of default tab stop intervals, go to Tools > Options > LibreOffice Writer > General.
[image: ]
Figure 33: Selecting a default tab stop interval

You can also set or change the measurement unit for rulers in the current document by right-clicking on the ruler to open a list of units. Click on one of them to change the ruler to that unit. The selected setting applies only to that ruler.
[image: ]
Figure 34: Changing the measurement unit for a ruler

[bookmark: __RefHeading__19508_697337876]Checking spelling and grammar
Writer provides a spelling checker, which can be used in two ways.
	[image: ]
	AutoSpellcheck checks each word as it is typed and displays a wavy red line under any unrecognized words. When the word is corrected, the line disappears.

	[image: ]
	To perform a combined spelling and grammar check on the document (or a text selection) click the Spelling and Grammar button. This checks the document or selection and opens the Spelling and Grammar dialog if any unrecognized words are found. In order to use this, the appropriate dictionaries must be installed. By default, four dictionaries are installed: a spellchecker, a grammar checker, a hyphenation dictionary, and a thesaurus.


Here are some more features of the spelling checker:
1. You can right-click on a word with a wavy underline to open a context menu. If you select from the suggested words on the menu, the selection will replace the unrecognized word in your text. Other menu options are discussed below.
· You can change the dictionary language (for example, Spanish, French or German) on the Spelling and Grammar dialog.
· You can add a word to the dictionary. Click Add to Dictionary in the Spelling and Grammar dialog or in the context menu.
· Click the Options button on the Spelling and Grammar dialog to open a dialog similar to the one in Tools > Options > Language Settings > Writing Aids described in Chapter 2. There you can choose whether to check uppercase words and words with numbers, and you can manage custom dictionaries, that is, add or delete dictionaries and add or delete words in a dictionary.
· There are a number of different methods by which you can set paragraphs to be checked in a specific language (different from the rest of the document). For example by clicking on the Language button on the Status Bar. See Chapter 7, Working with Styles, in the Writer Guide for more information.
See Chapter 3, Working with Text, in the Writer Guide, for a detailed explanation of the spelling and grammar checking facility.
[bookmark: __RefHeading__19510_697337876]Using built-in language tools
Writer provides some tools that make your work easier if you mix multiple languages within the same document or if you write documents in various languages.
The main advantage of changing the language for a text selection is that you can then use the correct dictionaries to check spelling and apply the localized versions of Autocorrect replacement tables, thesaurus, grammar, and hyphenation rules.
You can also set the language for a paragraph or a group of characters as None (Do not check spelling). This option is especially useful when you insert text such as web addresses or programming language snippets that you do not want to check for spelling.
Specifying the language in character and paragraph styles can be problematic unless you use a particular style for a different language. Changing the Language on the Font tab of the Paragraph Styles dialog, will change the language for all paragraphs that use that paragraph style. You can set certain paragraphs be checked in a language that is different from the language of the rest of the document by putting the cursor in the paragraph and changing the language on the Status Bar. See Chapter 7, Working with Styles, in the Writer Guide for information on how to manage the language settings of a style.
You can also set the language for the whole document, for individual paragraphs, or even for individual words and characters, from Tools > Language on the Menu bar.
Another way to change the language of a whole document is to use Tools > Options > Language Settings > Languages. In the Default languages for documents section, you can choose a different language for all the text that is not explicitly marked as a different language.
The spelling checker works only for those languages in the list that have the symbol ([image: ]) next to them. If you do not see the symbol next to your preferred language, you can install the additional dictionary using Tools > Language > More Dictionaries Online.
The language used for checking spelling is also shown in the Status Bar, next to the page style in use.
[bookmark: __RefHeading__19512_697337876]Using AutoCorrect
Writer’s AutoCorrect function has a long list of common misspellings and typing errors, which it corrects automatically. For example, “hte” will be changed to “the”.
AutoCorrect is turned on when Writer is installed. To turn it off, uncheck Format > AutoCorrect > While Typing.
Choose Tools > AutoCorrect Options to open the AutoCorrect dialog. There you can define which strings of text are corrected and how. In most cases, the defaults are fine.
To stop Writer replacing a specific spelling, go to the Replace tab, highlight the word pair, and click Delete.
To add a new spelling to the list, type it into the Replace and With boxes on the Replace tab, and click New.
See the different tabs of the dialog for the wide variety of other options available to fine-tune AutoCorrect.
· Tip
AutoCorrect can be used as a quick way to insert special characters. For example, (c) will be changed to ©. You can add your own special characters.
	Tip
	AutoCorrect can be used as a quick way to insert special characters. For example, (c) will be changed to ©. You can add your own special characters.


[bookmark: __RefHeading__19514_697337876]Using word completion
If Word Completion is enabled, Writer tries to guess which word you are typing and offers to complete the word for you. To accept the suggestion, press Enter. Otherwise, continue typing.
To turn off Word Completion, select Tools > AutoCorrect Options > Word Completion and deselect Enable word completion.
You can customize word completion from the Word Completion page of the AutoCorrect dialog:
· Add (append) a space automatically after an accepted word
· Show the suggested word as a tip (hovering over the word) rather than completing the text as you type
· Collect words when working on a document, and then either save them for later use in other documents or select the option to remove them from the list when closing the document.
· Change the maximum number of words remembered for word completion and the length of the smallest words to be remembered
· Delete specific entries from the word completion list
· Change the key that accepts a suggested entry—the options are Right arrow, End key, Return (Enter), and Space bar
· Note
Automatic word completion only occurs after you type a word for the second time in a document.
	Note
	Automatic word completion only occurs after you type a word for the second time in a document.


Using AutoText
Use AutoText to store text, tables, graphics and other items for reuse and assign them to a key combination for easy retrieval. For example, rather than typing “Senior Management” every time you use that phrase, you can set up an AutoText entry to insert those words when you type “sm” and press F3.
AutoText is especially powerful when assigned to fields. See Chapter 14, Working with Fields, in the Writer Guide for more information.
[bookmark: __RefHeading__83379_462712302]Creating AutoText
To store some text as AutoText:
1. Type the text into your document.
 1) Select the text.
 2) Choose Edit > AutoText (or press Ctrl+F3).
 6) In the AutoText dialog box, type a name for the AutoText in the Name box. Writer will suggest a one-letter shortcut, which you can change.
 7) In the large box to the left, choose the category for the AutoText entry, for example My AutoText.
 8) Click the AutoText button on the right and select New (text only) from the menu.
 9) Click Close to return to your document.
· Tip
If the only option under the AutoText button is Import, either you have not entered a name for your AutoText or there is no text selected in the document.
	Tip
	If the only option under the AutoText button is Import, either you have not entered a name for your AutoText or there is no text selected in the document.


[bookmark: __RefHeading__83381_462712302]Inserting AutoText
To insert AutoText, type the shortcut and press F3.
[bookmark: __RefHeading__19518_697337876]Formatting text
[bookmark: __RefHeading__19520_697337876]Using styles is recommended
Styles are central to using Writer. Styles enable you to easily format your document consistently, and to change the format with minimal effort. A style is a named set of formatting options. When you apply a style, you apply a whole group of formats at the same time. In addition, styles are used by LibreOffice for many processes, even if you are not aware of them. For example, Writer relies on heading styles (or other styles you specify) when it compiles a table of contents.
· Caution
Manual formatting (also called direct formatting) overrides styles, and you cannot get rid of the manual formatting by applying a style to it.
· Tip
To remove manual formatting, select the text and choose Format > Clear Direct Formatting from the Menu bar, or right-click and choose Clear Direct Formatting from the context menu, or click the Clear Direct Formatting button on the Formatting toolbar, or use Ctrl+M from the keyboard.
	Caution
[image: ]
	Manual formatting (also called direct formatting) overrides styles, and you cannot get rid of the manual formatting by applying a style to it.


Writer defines several types of styles, for different types of elements: characters, paragraphs, pages, frames, and lists. See Chapter 3, Using Styles and Templates, in this book and Chapters 6 and 7 in the Writer Guide.
[bookmark: __RefHeading__19522_697337876]Formatting paragraphs
You can apply many formats to paragraphs using the buttons on the Formatting toolbar and by using the Paragraph panel of the Sidebar’'s Properties deck. Not all buttons are visible in a standard installation, but you can customize the toolbar to include those you use regularly. These buttons and formats include: (see Error: Reference source not found). Error: Reference source not found shows the Formatting toolbar as a floating toolbar, customized to show only the buttons for paragraph formatting. The appearance of the buttons may vary with your operating system and the selection of icon size and style in Tools > Options > LibreOffice > View.
· Apply Style
· Bullets On/Off (with a palette of bullet styles)
· Numbering On/Off (with a palette of numbering styles)
· Align Left, Center Horizontally, Align Right, or Justified
· Align Top, Center Vertically, Align Bottom
· Line Spacing (choose from 1, 1.15, 1.5, 2, or custom spacing
· Increase Paragraph Spacing, Decrease Paragraph Spacing
· Increase Indent, Decrease Indent
· Paragraph (to open the Paragraph dialog)
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Figure 35: Formatting toolbar, showing buttons for paragraph formatting

[bookmark: __RefHeading__19524_697337876]Formatting characters
You can apply many formats to characters using the buttons on the Formatting toolbar and by using the Character panel of the Sidebar’s Properties deck. Not all buttons are visible in a standard installation, but you can customize the toolbar to include those you use regularly. These buttons and formats include:. Error: Reference source not found shows the Formatting toolbar, customized to include only the buttons for character formatting. The Character panel of the Sidebar's Properties deck also provides buttons for character formatting.
· Font Name, Font Size
· Bold, Italic, Underline, Double Underline, Overline, Strikethrough, Outline
· Superscript, Subscript
· Uppercase, Lowercase
· Increase Font Size, Decrease Font Size
· Font Color (with a palette of colors)
· Background Color (with a palette of colors)
· Highlighting (with a palette of colors)
· Character (to open the Character dialog)
The appearance of the buttons may vary with your operating system and the selection of icon size and style in Tools > Options > LibreOffice > View.
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Figure 36: Formatting toolbar, showing buttons for character formatting

	Tip
	To remove manual formatting, select the text and choose Format > Clear Direct Formatting from the Menu bar, or right-click and choose Clear Direct Formatting from the context menu, or use Ctrl+M from the keyboard.


[bookmark: __RefHeading__19526_697337876]Autoformatting
You can set Writer to automatically format parts of a document automatically according to the choices made on the Options page of the AutoCorrect dialog (Tools > AutoCorrect Options).
· Tip
If you notice unexpected formatting changes occurring in your document, this is the first place to look for the cause.
	Tip
	If you notice unexpected formatting changes occurring in your document, this is the first place to look for the cause.


The Help describes each of these choices and how to activate the autoformats. Some common unwanted or unexpected formatting changes include:
1. Horizontal lines. If you type three or more hyphens (---), underscores (___) or equal signs (===) on a line and then press Enter, the paragraph is replaced by a horizontal line as wide as the page. The line is actually the lower border of the preceding paragraph.
· Bulleted and numbered lists. A bulleted list is created when you type a hyphen (-), star (*), or plus sign (+), followed by a space or tab at the beginning of a paragraph. A numbered list is created when you type a number followed by a period (.), followed by a space or tab at the beginning of a paragraph. Automatic numbering is only applied to paragraphs formatted with the Default, Text body or Text body indent paragraph styles.
To turn autoformatting on or off, choose Format > AutoCorrect and select or deselect the items on the list.
[bookmark: __RefHeading__19528_697337876]Creating numbered or bulleted lists
There are several ways to create numbered or bulleted lists:
1. Use autoformatting, as described above.
· Use list (numbering) styles, as described in Chapter 6, Introduction to Styles, and Chapter 7, Working with Styles, in the Writer Guide.
· Use the Numbering and Bullets buttons on the Formatting toolbar (see Error: Reference source not found) or on the Paragraph panel of the Sidebar’'s Properties deck: select the paragraphs for the list, and then click the appropriate button on the toolbar or in the Sidebar.
· Note
It is a matter of personal preference whether you type your information first, then apply numbering/bullets, or apply them as you type.
	Note
	It is a matter of personal preference whether you type your information first, then apply Numbering/Bullets, or apply them as you type.


[bookmark: __RefHeading__83383_462712302]Using the Bullets and Numbering toolbar
You can create nested lists (where one or more list items has a sub-list under it, as in an outline) by using the buttons on the Bullets and Numbering toolbar (Figure 37). You can move items up or down the list, create sub-points, change the style of bullets, and access the Bullets and Numbering dialog, which contains more detaileddetaled controls. Use View > Toolbars > Bullets and Numbering to see the toolbar.
· Note
If numbering or bullets are being applied automatically in a way that you find inappropriate, you can switch them off temporarily by unchecking Format > AutoCorrect > While Typing.
	Note
	If numbering or bullets are being applied automatically in a way that you find inappropriate, you can switch them off temporarily by unchecking Format > AutoCorrect > While Typing.


[bookmark: __RefHeading__83385_462712302]Using the Sidebar for Bullets and Numbering
The Bullets and Numbering features (drop-down palettes of tools) on the Paragraph panel on the Properties deck of the Sidebar can also be used to create nested lists and access the Bullets and Numbering dialog. However, the Sidebar does not include tools for promoting and demoting items in the list, as found on the Bullets and Numbering toolbar.
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[bookmark: Ref_Figure36_label_and_number]Figure 37: Bullets and Numbering toolbar

[bookmark: __RefHeading__19530_697337876]Hyphenating words
You have several choices regarding hyphenation: let Writer do it automatically (using its hyphenation dictionaries), insert conditional hyphens manually where necessary, or don’t hyphenate at all.
[bookmark: __RefHeading__83387_462712302]Automatic hyphenation
To turn automatic hyphenation of words on or off:
1. Press F11 (⌘+T on Mac) to open the Styles and Formatting window, or, if the Sidebar is open, click on the Styles and Formatting tab to open the Styles and Formatting deck.
1) On the Paragraph Styles page (Figure 38), right-click on Default Style and select Modify.
[image: ]
[bookmark: Ref_Figure37_number_only]Figure 38: Modifying a style

2) On the Paragraph Style dialog (Figure 39), go to the Text Flow page.
3) Under Hyphenation, select or deselect the Automatically option. Click OK to save.
· Note
Turning on hyphenation for paragraph Default Style affects all other paragraph styles that are based on Default Style. You can individually change other styles so that hyphenation is not active; for example, you might not want headings to be hyphenated. Any styles that are not based on Default Style are not affected. See Chapter 3, Using Styles and Templates, for more about styles based on other styles.
[image: ]
[bookmark: Ref_Figure38_full][bookmark: Ref_Figure38_label_and_number][bookmark: Ref_Figure38_number_only]Figure 39: Turning on automatic hyphenation

	Note
	Turning on hyphenation for paragraph Default Style affects all other paragraph styles that are based on Default Style. You can individually change other styles so that hyphenation is not active; for example, you might not want headings to be hyphenated. Any styles that are not based on Default Style are not affected. See Chapter 3, Using Styles and Templates, for more about styles based on other styles.


You can also set hyphenation choices through Tools > Options > Language Settings > Writing Aids. In Options, near the bottom of the dialog, scroll down to find the hyphenation settings.
[image: ]
Figure 40: Setting hyphenation options

To change the minimum number of characters for hyphenation, the minimum number of characters before a line break, or the minimum number of characters after a line break, select the item, and then click the Edit button in the Options section.
Hyphenation options set on the Writing Aids dialog are effective only if hyphenation is turned on through paragraph styles.
[bookmark: __RefHeading__83389_462712302]Manual hyphenation
To manually hyphenate words, do not use a normal hyphen, which will remain visible even if the word is no longer at the end of a line when you add or delete text or change margins or font size. Instead, use a conditional hyphen, which is visible only when required.
To insert a conditional hyphen inside a word, click where you want the hyphen to appear and press Ctrl+hyphen. The word will be hyphenated at this position when it is at the end of the line, even if automatic hyphenation for this paragraph is switched off.
[bookmark: __RefHeading__19534_697337876]Formatting pages
Writer provides several ways for you to control page layouts: page styles, columns, frames, tables, and sections. For more information, see Chapter 4, Formatting Pages, in the Writer Guide.
· Tip
Page layout is usually easier if you show text, object, table, and section boundaries in Tools > Options > LibreOffice > Appearance, and paragraph end, tabs, breaks, and other items in Tools > Options > LibreOffice Writer > Formatting Aids.
	Tip
	Page layout is usually easier if you show text, object, table, and section boundaries in Tools > Options > LibreOffice > Appearance, and paragraph end, tabs, breaks, and other items in Tools > Options > LibreOffice Writer > Formatting Aids.


[bookmark: __RefHeading__19536_697337876]Which layout method to choose?
The best layout method depends on what the final document should look like and what sort of information will be in the document. Here are some examples.
	For a book similar to this user guide, with one column of text, some figures without text beside them, and some other figures with descriptive text, use page styles for basic layout, and tables to place figures beside descriptive text when necessary.
	[image: ]

	For an index or other document with two columns of text, where the text continues from the left-hand column to the right-hand column and then to the next page, all in sequence (also known as “snaking columns” of text), use page styles (with two columns). If the title of the document (on the first page) is full-page width, put it in a single-column section.
	[image: ]

	For a newsletter with complex layout, two or three columns on the page, and some articles that continue from one page to some place several pages later, use page styles for basic layout. Place articles in linked frames and anchor graphics to fixed positions on the page if necessary.
	[image: ]

	For a document with terms and translations to appear side-by-side in what appear to be columns, use a table to keep items lined up, and so you can type in both “columns”.
	[image: ]


[bookmark: __RefHeading__19538_697337876][bookmark: Ref_Creating_headers_and_footers][bookmark: Ref_Creating_headers_and_footers]Creating headers and footers
A header is an area that appears at the top of a page above the margin. A footer appears at the bottom of the page below the margin. Information such as page numbers inserted into a header or footer displays on every page of the document with that page style.
[bookmark: __RefHeading__83391_462712302]Inserting a header or footer
To insert a header, you can either:
· Choose Insert > Header > Default Style (or some other page style, if not Default Style), or
· Click above the top margin to make the Header marker appear (Figure 41), and then click on the +. 
[image: ]
[bookmark: Ref_Figure40_label_and_number]Figure 41: Header marker at top of text area

After a header has been created, a down-arrow appears on the header marker. Click on this arrow to drop down a menu of choices for working with the header (Figure 42).
[image: ]
[bookmark: Ref_Figure41_label_and_number]Figure 42: Header menu

To format a header, you can use either the menu item shown in Figure 42 or Format > Page > Header. Both methods take you to the same tab on the Page Style dialog.
[bookmark: __RefHeading__83393_462712302]Inserting header and footer contents
Other information such as document titles and chapter titles is often put into the header or footer. These items are best added as fields. That way, if something changes, the headers and footers are updated automatically. Here is one common example.
To insert the document title into the header:
1. Choose File > Properties > Description and type a title for your document.
 1) Add a header (Insert > Header > Default).
 2) Place the cursor in the header part of the page.
 3) Choose Insert > Fields > Title. The title should appear on a gray background (which does not show when printed and can be turned off).
 4) To change the title for the whole document, go back to File > Properties > Description.
Fields are covered in detail in Chapter 14, Working with Fields, in the Writer Guide.
For more about headers and footers, see Chapter 4, Formatting Pages, and Chapter 6, Introduction to Styles, in the Writer Guide.
[bookmark: __RefHeading__19540_697337876]Numbering pages
[bookmark: __RefHeading__83395_462712302]Displaying the page number
To automatically display page numbers automatically :
1. Insert a header or footer, as described in “Creating headers and footers” above.
 1) Place the cursor in the header or footer where you want the page number to appear and choose Insert > Fields > Page Number.
[bookmark: __RefHeading__83397_462712302]Including the total number of pages
To include the total number of pages (as in “page 1 of 12”):
1. Type the word “page” and a space, then insert the page number as above.
 1) Press the space bar once, type the word “of” and a space, then choose Insert > Fields > Page Count.
· Note
The Page Count field inserts the total number of pages in the document, as shown on the Statistics tab of the document’s Properties window (File > Properties). If you restart page numbering anywhere in the document, then the total page count may not be what you want. See Chapter 4, Formatting Pages, in the Writer Guide for more information.
	Note
	The Page Count field inserts the total number of pages in the document, as shown on the Statistics tab of the document’s Properties window (File > Properties). If you restart page numbering anywhere in the document, then the total page count may not be what you want. See Chapter 4, Formatting Pages, in the Writer Guide for more information.


[bookmark: __RefHeading__83399_462712302]Restarting page numbering
Often you will want to restart the page numbering at 1, for example on the page following a title page or a table of contents. In addition, many documents have the “front matter” (such as the table of contents) numbered with Roman numerals and the main body of the document numbered in Arabic numerals, starting with 1.
You can restart page numbering in two ways.
Method 1:
1. Place the cursor in the first paragraph of the new page.
 1) Choose Format > Paragraph.
 2) On the Text Flow tab of the Paragraph dialog (Figure 39 on page 50), select Breaks.
 3) Select Insert and then With Page Style and specify the page style to use.
 4) Specify the page number to start from, and then click OK.
· Tip
Method 1 is also useful for numbering the first page of a document with a page number greater than 1. For example, you may be writing a book, with each chapter in a separate file. Chapter 1 may start with page 1, but Chapter 2 could begin with page 25 and Chapter 3 with page 51.
	Tip
	Method 1 is also useful for numbering the first page of a document with a page number greater than 1. For example, you may be writing a book, with each chapter in a separate file. Chapter 1 may start with page 1, but Chapter 2 could begin with page 25 and Chapter 3 with page 51.


Method 2:
1. Insert > Manual break.
 1) By default, Page break is selected on the Insert Break dialog (Figure 43).
 2) Choose the required page Style.
 3) Select Change page number.
 4) Specify the page number to start from, and then click OK.
[image: ]
[bookmark: Ref_Figure42_label_and_number]Figure 43: Restarting page numbering after a manual page break

[bookmark: __RefHeading__19542_697337876]Changing page margins
You can change page margins in three ways:
1. Using the page rulers—quick and easy, but does not have fine control
· Using the Page Style dialog—can specify margins to two decimal places
· Using the Page panel on the Properties deck of the Sidebar
· Caution
If you change the margins, the new margins affect the page style and will be shown in the Page Style dialog the next time you open it.
Because the page style is affected, the changed margins apply to all pages using that style.
	Caution
[image: ]
	If you change the margins, the new margins affect the page style and will be shown in the Page Style dialog the next time you open it.
Because the page style is affected, the changed margins apply to all pages using that style.


To change margins using the rulers:
1. The gray sections of the rulers are the margins. Put the mouse cursor over the line between the gray and white sections. The pointer turns into a double-headed arrow and displays the current setting in a tool-tip.
 1) Hold down the left mouse button and drag the mouse to move the margin.
[image: ]
[bookmark: Ref_Figure43_label_and_number]Figure 44: Moving the margins

· Caution
The small arrowheads (gray triangles) on the ruler are used for indenting paragraphs. They are often in the same place as the page margins, so you need to be careful to move the margin marker, not the arrows. The double-headed arrows shown in Figure 44 are mouse cursors shown in the correct position for moving the margin markers.
	Caution
[image: ]
	The small arrowheads on the ruler (the gray triangles) are used for indenting paragraphs. They are often in the same place as the page margins, so you need to be careful to move the margin marker, not the arrows. The double-headed arrows shown in Error: Reference source not found are mouse cursors shown in the correct position for moving the margin markers.


To change margins using the Page Style dialog:
1. Right-click anywhere in the text area on the page and select Page from the context menu.
 1) On the Page tab of the dialog, type the required distances in the Margins boxes.
To change margins using the Page panel of the Properties deck of the Sidebar:
1. On the open Sidebar (View > Sidebar) select the Properties tab.
 22) Open the Page panel if is not open by clicking the plus (+) symbol in the panel title
 23) Click the Margin button to open the sub-panel and enter the required dimensions in the Custom size boxes (clicking the More Options button will open the Page Style dialog). 
[bookmark: __RefHeading__19544_697337876]Adding comments to a document
Authors and reviewers often use comments to exchange ideas, ask for suggestions, or mark items needing attention.
You can select a contiguous block of text, which may be multiple paragraphs, for a comment; or you can select a single point at which the comment will be inserted.
To insert a comment, select the text, or place the cursor in the place the comment refers to, and choose Insert > Comment or press Ctrl+Alt+C. The anchor point of the comment is connected by a dotted line to a box on the right-hand side of the page where you can type the text of the comment. A Comments button is also added to the right of the horizontal ruler; you can click this button to toggle the display of the comments.
Writer automatically adds at the bottom of the comment the author’s name and a time stamp indicating when the comment was created. Figure 45 shows an example of text with comments from two different authors.
[image: ]
[bookmark: Ref_Figure44_label_and_number]Figure 45: Example of comments

Choose Tools > Options > LibreOffice > User Data to configure the name you want to appear in the Author field of the comment, or to change it.
If more than one person edits the document, each author is automatically allocated a different background color. 
Right-click on a comment to open a context menu where you can delete the current comment, all the comments from the same author, or all the comments in the document. From this menu, you can also open a dialog to apply some basic formatting to the text of commentsthe comment. You can paste saved text using the Paste button in the menu. You can also change the font type, size, and alignment in the usual editing manner.
To navigate from one comment to another, open the Navigator (F5), expand the Comments section, and click on the comment text to move the cursor to the anchor point of the comment in the document. Right-click on the comment to quickly edit or delete it.
You can also navigate through the comments using the keyboard. Use Ctrl+Alt+Page Down to move to the next comment and Ctrl+Alt+Page Up to move to the previous comment.
Comments can be printed next to the text in the right margin as they appear on screen. Each page is scaled down in order to make space for the comments to fit on the underlying paper size.
[bookmark: __RefHeading__19546_697337876]Creating a table of contents
Writer’s table of contents feature lets you build an automated table of contents from the headings in your document. Before you start, make sure that the headings are styled consistently. For example, you can use the Heading 1 style for chapter titles and the Heading 2 and Heading 3 styles for chapter subheadings.
Although tables of contents can be customized extensively in Writer, often the default settings are all you need. Creating a quick table of contents is simple:
1. When you create your document, use the following paragraph styles for different heading levels (such as chapter and section headings): Heading 1, Heading 2, Heading 3, and so on. These are what will appear in your table of contents.
 1) Place the cursor where you want the table of contents to appearbe inserted.
 2) Choose Insert > Indexes and Tables > Indexes and Tables.
 3) Change nothing in the Insert Index/Table dialog. Click OK.
If you add or delete text (so that headings move to different pages) or you add, delete, or change headings, you need to update the table of contents.
To do this:
1. Place the cursor within the table of contents.
 1) Right-click and choose Update Index/Table from the context menu.
· Note
If you cannot place the cursor in the table of contents, choose Tools > Options > LibreOffice Writer > Formatting Aids, and then select Enable in the Cursor in protected areas section.
	Note
	If you cannot place the cursor in the table of contents, choose Tools > Options > LibreOffice Writer > Formatting Aids, and then select Enable in the Cursor in protected areas section.


You can customize an existing table of contents at any time. Right-click anywhere in it and choose Edit Index/Table from the context menu. Chapter 12, Creating Tables of Contents, Indexes and Bibliographies, of the Writer Guide describes in detail all the customizations you can choose.
[bookmark: __RefHeading__19548_697337876]Creating indexes and bibliographies
Indexes and bibliographies work in a similar way to tables of contents. Chapter 12, Creating Tables of Contents, Indexes and Bibliographies, in the Writer Guide describes the process in detail.
In addition to alphabetical indexes, other types of indexes supplied with Writer include those for illustrations, tables, and objects, and you can even create a user-defined index. For example, you might want an index containing only the scientific names of species mentioned in the text, and a separate index containing only the common names of species. Before creating some types of indexes, you first need to create index entries embedded in your Writer document.
[bookmark: __RefHeading__19550_697337876]Working with graphics
Graphics in Writer are of three basic types:
1. Image files, including photos, drawings, scanned images, and others
· Diagrams created using LibreOffice’s drawing tools
· Charts created using LibreOffice’s Chart component
See Chapter 11, Graphics, the Gallery, and Fontwork, in this book and Chapter 8, Working with Graphics, in the Writer Guide.
[bookmark: __RefHeading__15546_508553458]Printing
See Chapter 10, Printing, Exporting, and E‑mailing, in this book and Chapter 5, Printing, Exporting, Faxing, and E‑mailing, in the Writer Guide for details on previewing pages before printing, selecting print options, printing in black and white on a color printer, printing brochures, and other printing features.
[bookmark: __RefHeading__15690_508553458]Using mail merge
Writer provides very useful features to create and print:
1. Multiple copies of a document to send to a list of different recipients (form letters)
· Mailing labels
· Envelopes
All these facilities use a registered data source (a spreadsheet or database containing the name and address records and other information). Chapter 11, Using Mail Merge, in the Writer Guide describes the process.
[bookmark: __RefHeading__19576_697337876]Tracking changes to a document
You can use several methods to keep track of changes made to a document.
1. Make your changes to a copy of the document (stored in a different folder, or under a different name, or both), then use Writer to combine the two files and show the differences. Choose Edit > Compare Document. This technique is particularly useful if you are the only person working on the document, as it avoids the increase in file size and complexity caused by the other methods.
 1) Save versions that are stored as part of the original file. However, this method can cause problems with documents of non-trivial size or complexity, especially if you save a lot of versions. Avoid this method if you can.
2) Use Writer’s change marks (often called “redlines” or “revision marks”) to show where you have added or deleted material, or changed formatting. Choose Edit > Changes > Record before starting to edit. Later, you or another person can review and accept or reject each change. Choose Edit > Track Changes > Show. Right-click on an individual change and choose Accept Change or Reject Change from the context menu, or choose Edit > Track Changes > Manage ChangesAccept or Reject to view the list of changes and accept or reject them. Details are in the Writer Guide.
· Tip
Not all changes are recorded. For example, changing a tab stop from align left to align right, and changes in formulas (equations) or linked graphics are not recorded.
	Tip
	Not all changes are recorded. For example, changing a tab stop from align left to align right, and changes in formulas (equations) or linked graphics are not recorded.


[bookmark: __RefHeading__23424_697337876]Using fields
Fields are extremely useful features of Writer. They are used for data that changes in a document (such as the current date or the total number of pages) and for inserting document properties such as name, author, and date of last update. Fields are the basis of cross-referencing (see below); automatic numbering of figures, tables, headings, and other elements; and a wide range of other functions—far too many to describe here. See Chapter 14, Working with Fields, in the Writer Guide for details.
[bookmark: __RefHeading__22921_697337876]Linking to another part of a document
If you type in cross-references to other parts of a document, those references can easily get out of date if you reorganize the order of topics, add or remove material, or reword a heading. Writer provides two ways to ensure that your references are up to date, by inserting links to other parts of the same document or to a different document: hyperlinks and cross-references.
Hyperlinks
· Cross-references
The two methods have the same result if you Ctrl+click the link when the document is open in Writer: you are taken directly to the cross-referenced item. However, they also have major differences:
· The text in a hyperlink does not automatically update if you change the text of the linked item (although you can change it manually), but changed text does automatically update in a cross-reference.
· When using a hyperlink, you do not have a choice of the content of the link (for example text or page number), but when using a cross-reference, you have several choices, including bookmarks.
· To hyperlink to an object such as a graphic, and have the hyperlink show useful text such as Figure 6, you need to give such an object a useful name (instead of a default name like Graphics6), or use the Hyperlink dialog to modify the visible text. In contrast, cross-references to figures with captions automatically show useful text, and you have a choice of several variations of the name.
· If you save a Writer document to HTML, hyperlinks remain active but cross-references do not. (Both remain active when the document is exported to PDF.)
[bookmark: __RefHeading__16987_537374987]Using hyperlinks
The easiest way to insert a hyperlink to another part of the same document is by using the Navigator:
1. Open the document containing the items you want to cross-reference.
 1) Open the Navigator by clicking its button, choosing View > Navigator, or by pressing F5.
 2) Click the arrow part of the combination Drag Mode button, and choose Insert as Hyperlink.
 3) In the list at the bottom of the Navigator, select the document containing the item that you want to cross-reference.
 4) In the Navigator list, select the item that you want to insert as a hyperlink.
 5) Drag the item to where you want to insert the hyperlink in the document. The name of the item is inserted in the document as an active hyperlink.
You can also use the Hyperlink dialog to insert and modify hyperlinks within and between documents. See Chapter 12, Creating Web Pages.
[image: ]
Figure 46: Inserting a hyperlink using the Navigator

[bookmark: __RefHeading__19586_697337876]Using cross-references
If you type in references to other parts of the document, those references can easily get out of date if you reword a heading, add or remove figures, or reorganize topics. Replace any typed cross-references with automatic ones and, when you update fields, all the references will update automatically to show the current wording or page numbers. The Cross-references tab of the Fields dialog lists some items, such as headings, bookmarks, figures, tables, and numbered items such as steps in a procedure. You can also create your own reference items; see “Setting References” in Chapter 14, Working with Fields, in the Writer Guide for instructions.
To insert a cross-reference to a heading, figure, bookmark, or other item:
1. In your document, place the cursor where you want the cross-reference to appear.
 1) If the Fields dialog is not open, click Insert > Cross-reference. On the Cross-references tab (Figure 47), in the Type list, select the type of item to be referenced (for example, Heading or Figure). You can leave this page open while you insert many cross-references.
 2) Click on the required item in the Selection list, which shows all the items of the selected type. In the Insert reference to list, choose the format required. The list varies according to the Type. The most commonly used options are Reference (to insert the full text of a heading or caption), Category and Number (to insert a figure number preceded by the word Figure or Table, but without the caption text), Numbering (to insert only the figure or table number, without the word “Figure” or “Table”), or Page (to insert the number of the page the referenced text is on). Click Insert.
[image: ]
[bookmark: Ref_Figure46_label_and_number]Figure 47: The Cross-references tab of the Fields dialog 

[bookmark: __RefHeading__19588_697337876]Using bookmarks
Bookmarks are listed in the Navigator and can be accessed directly from there with a single mouse click. You can cross-reference to bookmarks and create hyperlinks to bookmarks, as described above.
1. Select the text you want to bookmark. Click Insert > Bookmark.
 1) On the Insert Bookmark dialog, the larger box lists any previously defined bookmarks. Type a name for this bookmark in the top box, and then click OK.
[image: ]
Figure 48: Inserting a bookmark

[bookmark: __RefHeading__19580_697337876]Using master documents
Master documents are typically used for producing long documents such as a book, a thesis, or a long report; or when different people are writing different chapters or other parts of the full document, so you don’t need to share files. A master document joins separate text documents into one larger document, and unifies the formatting, table of contents (TOC), bibliography, index, and other tables or lists.
Since LibreOffice version 4.4, Master Document Templates can be added to the Template Manager and creating a new document based on a Master Document Template creates a Master Document with the same initial content as the template it is based upon. See Chapter 3, Styles and Templates, for more about creating and using templates.
Yes, master documents do work in Writer. However, until you become familiar with them, you may think that master documents are unreliable or difficult to use. See Chapter 13, Working with Master Documents, in the Writer Guide.
[bookmark: __RefHeading__19582_697337876]Creating fill-in forms
A standard text document displays information: a letter, report, or brochure, for example. Typically the reader may either edit everything or nothing in any way. A form has sections that are not to be edited, and other sections that are designed for the reader to make changes. For example, a questionnaire has an introduction and questions (which do not change) and spaces for the reader to enter answers.
Forms are used in three ways:
1. To create a simple document for the recipient to complete, such as a questionnaire sent out to a group of people who fill it in and return it.
· To link into a database or data source and allow the user to enter information. Someone taking orders might enter the information for each order into a database using a form.
· To view information held in a database or data source. A librarian might call up information about books.
[bookmark: __RefHeading__5648_15665686443]Writer offers several ways to fill information into a form, including check boxes, option buttons, text boxes, pull-down lists, and spinners. See Chapter 15, Using Forms in Writer, in the Writer Guide.
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