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Creating a new database
To create a new database, select File > New > Database from the menu bar, or click the arrow next to the New icon on the Standard toolbar and select Database from the drop-down menu. Both methods open the Database Wizard.
On the first page of the Database Wizard, select Create a new database and then click Next.
The second page has two questions. Make sure the choice for the first question is Yes, register the database for me and the choice for the second question is Open the database for editing. Click Finish.
· Note
In Writer and Calc, the F4 key opens and closes the Data Source window containing the list of registered databases. If a database is not registered, this window will not contain it, so you can not access the database in Writer or Calc.
Save the new database with the name Automobile. This opens the Automobile – LibreOffice Base window. Figure 1 shows part of this window.
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· If you have information that you would like to organize, Base will help you do this. You could use a spreadsheet to organize information, but maintaining a spreadsheet with Calc can often be more complex and time consuming than using a database with Base.
· This chapter is for the person who has not used Base before or who wants to review the basics of creating and using a database. Terminology is kept to a minimum. This chapter covers the wizards needed to create the database parts and the principles that the wizards use. It also provides references to more information in the Base Handbook or the Base Guide (being written).
· The Base Handbook and the Base Guide are for people who understand some of the basics of how Base works and want a more in-depth discussion.
	· Note
	· To use Base, you need to use a Java Runtime Environment (JRE). Please go to Tools > Options > LibreOffice > Advanced to choose a JRE from those installed on your computer.
· If no JRE is already installed, you will need to download and install one. For Windows, you need to get Java from . For Linux, you can download it from the same website or you can use openjdk-7-jre, available from the repository of your Linux version. Mac OS X users can install a JRE from Apple Inc. 


· One of the things that sometimes confuses people is terminology. Specifically, what is the difference between a database and a data source? Base uses the terms interchangeably, as synonyms. This is because a database is a collection of data that can come in different forms. These include text files, spreadsheets, or a file created by a database program.
· A collection of data does not serve a good purpose unless we can use the information it contains. Therefore, a structure has to be built using data. In a spreadsheet, formulas and cell links are used to obtain information from the data contained in it. Database programs can do the same thing.
· With Base, you create a Database document file. This file contains the data and all of the structures you create to obtain information from the data. Because everything is included in one file, it is known as an embedded database.
· Base can also be used to connect to other databases. In this case, Base creates a file to make the connection. These are not embedded databases since they exist outside the Base file. They are front end database documents. See the Base Handbook and Base Guide for more information.
· Types of database
· The two types of database are known as flat and relational. Base can create and work with both types. This chapter discusses flat databases. Relational databases are covered in detail in the Base Handbook and the Base Guide.
· A flat database contains one or more tables, each containing one or more fields. Each table is completely independent of all the other tables in the database. For example, you might have an address database with several tables in it. One might contain your family’s contacts, another your business contacts, and another your spouse’s family contacts. While some contacts are contained in more than one table, different tables may not have the same information about the same person.
· A relational database contains one or more tables with one or more relationships defined between those tables; each relationship is defined by a pair of fields. One field of each pair belongs to one table and the second field belongs to the same or a different table. Where relationships exist between fields in the same or different tables, a flat database could still be used, but it provides no mechanism for defining the relationship. Instead the same data must be entered in both fields, making data entry errors more likely. A well designed relational database requires the data to be entered only once, reducing possible errors.
· Flat database
· Consider an address book. Usually, the data in an address book can be divided into groups based upon the relationships between the data. For example, all the first names are put into one group. Other groups can include last names, spouse names, addresses, phone numbers, birthdays, and so on. You probably need to identify phone numbers based on their use (home, work, mobile). If you were keeping this information in a spreadsheet, you would use one column for each one of these groups. In a database, this column is called a field.
· Other relationships that exist between data can be used to further define the structure of that data. In an address book, one value in each of these groups describes a specific individual. In a spreadsheet, the columns would be as above. We would rearrange the rows so that each contains information about an individual.
· This divides the data into a table. Each column contains data with the same properties. Each row contains data that describes a specific entity or individual. Each row is called a record. The structure of rows and columns is called a table.
· The collection of data we mentioned was a flat database without any structure. Now with the table, we have a flat database we can use to obtain information from the data.
· We use queries to obtain the information. You can think of queries as way to ask questions in Base and receive the answers. If we want to give the information to someone else, we will give them a report that is based upon a query we created. (A report can be created from a table as well.)
· So, a flat database consists of a table whose columns are called fields and whose rows are called records. We use the table structure to ask questions and to receive answers using queries. When providing others with information obtained from a query, we create a report. These, then, are the things we use in a database: table with its fields and records, queries, and reports.
· Planning your database
	· Caution
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	· Before creating a database, you should take some time planning what you want it to do and why. The better your plan, the better the results you will get from using the database.


· You need to have an idea of what you want to do with the data that you have. This includes how you will divide the data into columns, the fields, and into rows, the records. This determines what the table will be. What information do you want to get from the data? This determines what the queries will be. What information do you want to have in a report? So, take some time to think through what you want first before ever creating a database.
· The Base Guide has an extensive discussion on this topic in Chapter 2, Planning and Designing your Database.
· The Table Wizard (see discussion beginning on page Error: Reference source not found) contains a list of suggested tables: some for business purposes, and some for personal purposes. The wizard also contains a list of fields for each of the suggested tables. Each of the fields also has been given the properties it needs.
· As a result, the wizard does most of your planning for you. However, you do need to make some decisions, for example whether to use all of the suggested fields. Will you want to use additional fields that the wizard did not include? What properties should these fields have?
· Therefore, you need to understand what you are doing as you do it. You need to practice creating the objects of a database before creating them in your database. Learn how to apply the principles first on an example. If necessary, take notes on the principles taught and how they are used.
· Creating a new Base file
· After you have planned your database, create a new Base file. To do this, open the Database Wizard using one of the following methods:
· Choose File > New > Database from the main menu bar.
· Click the arrow by the New icon on the Standard toolbar and select Database from the drop-down menu.
· Click the New Database icon on the splash screen if it appears when LibreOffice opens.
· Step 1 of the Database Wizard (Error: Reference source not found) has three parts. Use the top part to create a new database. The middle and bottom parts are used to open an existing database. (These two parts are briefly discussed in “Error: Reference source not found” on page Error: Reference source not found.)
· Creating a database using the wizard requires two steps.
· On the Select database page (Error: Reference source not found):
· Under the question What do you want to do?, choose Create a new database (it is selected by default).
· Click the Next >> button at the bottom of the wizard.
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Figure 2: Creating a new database using the Database Wizard

	· Note
	· Beginning with version 4.2.0, the first page of the Database Wizard has a new drop-down list for selecting the type of embedded database. At the time of writing, this feature has not yet been activated; it will not be discussed here.

	· Note
	· When you create a new database, you should register it. Registration lists the location of the database location in one of the configuration files of LibreOffice. You can then access the database from Writer or Calc.


· On the Save and proceed page (Error: Reference source not found):
· Choose Register the database for me (the default setting).
· Choose what you want to do after the database file is saved. In this example, we choose Open the database for editing.
· [image: ]Figure 3: Registering and opening the database file

	· Note
	· If you want to create a table with the wizard immediately after creating a new database, select Create tables using the table wizard in addition to Open the database for editing. If you do this, the main database window opens with the Table Wizard opening in front of it.
· We will discuss the main database window before the Table Wizard, so in our example the second choice is not checked.


· Click the Finish button at the bottom of the wizard. A standard Save as window opens. Name and save the database.
· You have created and saved a new database file that has opened the main database window. If you wish, you can close it now and reopen it later.
· Opening an existing database
· You can reopen your new database in several ways. In any file browser, you can browse to where you saved the database and double-click it. or you can right-click it and select LibreOffice to open it. You can also use the database wizard to open it, as described below.
· Using the database wizard to open an existing database
· Below the Open an existing database option on the first page of the Database Wizard is a drop-down list of the databases you have recently used. After creating your first database, its name will appear as the default value for this list. Once you create or open another database, other names will appear in this list. You can use this list to select the database that you want to open.
1. Open the database wizard like you did when you created your database.
· Click the Open an existing database option button.
· From the Recently used drop-down list, select the name of the database.
· Or, Click the Open button, browse to the location of the database, and select it.
· Click the Finish button.
· The third section of page 1 of the database wizard is used to connect to databases that have been created by other than Base. This includes text databases, spreadsheets, MySQL,  PostgreSQL, Oracle, and Access among the more well known ones.
	· Tip
	· These databases and how to connect to them using Base are discussed in Chapters 2 and 8 of the Base Guide.


· Main database window and its parts
· Everything you do with a database begins with the main database window (Error: Reference source not found). When performing some tasks, you will have to come back to this window to complete the task. So, become well acquainted with it.
· Once you have created a new database and saved it, this window opens. Opening a database file will also open it.
· The main database window contains three sections: Database, Tasks, and List. However, you will not see List as the heading of a section as you do for Database and Tasks. Instead, its heading depends upon which icon is selected in the Database section.
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Figure 4: Main Database window

· Database section
· This section is the column of icons on the left side of the window. There is an icon for each part of the database. Your first step after opening a database is to select what part of the database you will work in. The selection you make here changes what appears in the other sections, as explained below.
· Tasks section
· This section contains a list of tasks that can be done related to the icon selected in the Database section. When the Tables icon is selected in the Database section, three tasks appear in this section. Two of them help you create a table, and one helps you create a view. When the Queries icon is selected, three tasks appear to help you create a query. When the Forms icon is selected, two tasks appear to help you create a form. When the Reports icon is selected, two tasks appear to help you create a report.
· The right side of the Tasks section has the heading Description. This area gives you information about each of the tasks. Click any one of the tasks to see its description.
	· Note
	· In this chapter, we are using only the wizards to create the tables, queries, forms, and reports. The Base Guide discusses the rest of the tasks, their principles, and an example of their uses.


· List section
· This section contains a list of the objects whose icon is selected in the Database section. Click the Tables, Queries, Forms, or Report icon, and this section contains a list of the tables, queries, forms, or reports respectively. The title for this section is the name of the icon selected.
· A variety of things can be done with any member of the visible list by right-clicking the item and selecting an action that appears in the context menu. The standard actions are Copy, Delete, Rename, Edit, and Open. The context menu includes additional choices that depend upon the type of list.
· To the right of the list is a small window labeled Document view, giving you more information about the specific document (table, query, form, or report) you have selected. The view is controlled by a drop-down list containing three options: None, Document Information, and Document.
· When Tables or Queries is selected in the Database section, only two choices are available: None or Document. When Forms or Reports are selected, all three choices are available. Selecting None leaves the Document view window blank.
· Select Document information for a form to see who last modified the form and when it was modified. If it has not been modified, there is no information.
· Select Document and a member of the list, and you will see a snapshot of what you selected. In most cases, you see only the top left portion because of size limitations. For a table or query, you will see only the first few columns and rows along with any data. For a form, you will see the top left portion of it. (If the form is small, you will see all of it.)
	· Tip
	· Document view does not work for reports. You will see all three choices in the drop-down list, but you will not see anything when you make a selection.


· Views
· A View is a virtual table or stored query you create using the fields from one or more tables that you have already created. A View allows you to set relationships between tables using selected fields and view the results. View structures are written in the script file in the database folder of the database document file. (Queries are written in a different file in another location of the database document file.)
· When we click Create View in the Tasks section, the View Design dialog opens. This dialog is similar to the Query Design dialog. Discussing these dialogs is beyond the scope of this chapter. Both are discussed in detail in Chapter 5, Queries, in the Base Guide.
· Database objects
· Database objects are the tables, queries, forms, and reports of the database. When a new database is created, they have to also be created to make the database's data useful.
· This chapter discusses the use of wizards for creating these objects. The principles used by the wizards are included. The example database will be a household inventory.
· Tables: use wizard to create tables
· To open the table wizard, begin in the Database file window. Click the Tables icon in the Database section on the left. This places three tasks in the Tasks section. Click this task: Use Wizard to Create Table. The wizard opens to its first page.
· The table wizard uses several steps to create a table. Each step is located on a separate page. Within each step are smaller steps to do. The major steps are:
1. Select fields.
· Tip
Set types and formats.
Every time the Automobile database is opened, the Automobile – LibreOffice Base window opens. Changes can then be made to the database. The title for this window is always <database name> – LibreOffice Base.
· Caution
As you create a database, you should save your work regularly. This means more than saving what you have just created. You must save the whole database as well.
For example, when you create your first table, you must save it before you can close it. This makes it part of the database in memory. But it is only when you save the database file that the table is written to disk.
Set primary key.
Creating database tables
Create table.
In a database, a table stores information in a group of things we call fields. For example, a table might hold an address book, a stock list, a phone book or a price list. A database must have at least one table and may have several.
Each field of a table contains information of a single type. For example, the Phone field of an address book would only contain phone numbers. Similarly, a price list table could contain two fields: Name and Price. The Name field would contain the names of the items;  the Price field would contain the amount of each item.
To work with tables, click the Tables icon in the Database list, or press Alt+a. The three tasks that you can perform on a table are in the Tasks list (see Figure 1).
	Note
	Page 2, Set types and formats, refers to setting the types and formats for the fields. On this page, you can choose among the supplied fields, create new fields and set their type and format, and rename fields.


Table
A table consists of one or more vertical columns and one or more horizontal rows containing the data of the database. The data of a given table of a database share one or more common characteristic.
Field
A field is an attribute or characteristic that divides the data of a table into columns, one column for each attribute.
Record
A record is a row of a table. The word Tuple is sometimes used in place of record in database literature, but record is used more often. The contents of each row share a common characteristic.
Using the Wizard to create a table
Step 1: Select fields for your table
Wizards are designed to do the basic work. Sometimes this is not sufficient for what we want; in those cases we can use a wizard as a starting point and then build upon what it produces.
The Table Wizard in Base contains two categories of suggested tables: business and personal. Each category contains sample tables from which to choose. Each table has a list of available fields. We can delete some of these fields and add other fields.
A field in a table is one bit of information. For example, a price list table might have one field for item name, one for the description, and a third for the price.
Since none of the fields we need for our Automobile database are contained in any of the sample wizard tables, we will create a simple table using the wizard that has nothing to do with our database. This section is merely an exercise in explaining how the Wizard works.
The Wizard permits the fields of the table to come from more than one suggested table. We will create a table with fields from three different suggested tables in the Wizard.
· Caution
Every table requires a Primary key field. (What this field does will be explained later.) We will use this field to number our entries and want that number to automatically increase as we add each entry.
Click Use Wizard to Create Table. This opens the Table Wizard (Figure 6).
Step 1: Select fields
We will use the CD-Collection Sample table in the Personal category and Employees in the Business category to select the fields we need.
 1) Category has two choices that determines the type of tables that you can use: Business, and Personal. Select Business for business purposes and Personal for personal purposes.
 2) Sample tables is a drop-down list of tables based upon the table's purpose. Select a table from this list, and its fields appear in the Available fields list.
 3) Use the arrows in the middle to move fields in the Available fields list to or from the Selected fields.  A single arrow moves a single field; a double arrow moves all of the fields at one time. If you want to move more than one field at at time, highlight the fields first and then click the proper single arrow.
 4) The arrows on the right are for changing the order of the fields in the Selected fields list. Click a field to highlight it. Click the up arrow to move it toward the top, or click the down arrow to move it toward the bottom.
 5) [image: ]
1
Category labeled option buttons
3
Move selected fields from left to right
2
Move selected fields from right to left
4
Change the order of the listed fields
Figure 5: Step 1 of Table Wizard: Select fields

 6) Here are the smaller steps required on this page. These will be applied to selecting HouseholdInventory as the table and the fields in it in the example following these steps.
 7) Category: Select Personal. The Sample Tables drop down list changes to a list of personal sample tables.
 8) Select the category: Business or Personal. This determines what is listed in the Sample tables drop-down list. (Select Personal for the example.)
 9) Sample tables: Select CD-Collection. The Available fields box changes to a list of available fields for this table.
 10) Open the Sample tables drop-down list by clicking the down arrow.
 11) Select the table you want to use. 
(Select HouseholdInventory for the example. Available fields contains a list of this table's fields.)
 12) Move the fields you want to use in your database to the Selected fields list.
 13) To move all the fields at one time, click the double right arrow.
 14) To move one or more fields, highlight the fields and then click the single right arrow.
 15) To remove one or more fields from the Selected fields list, highlight the fields and click the left single arrow. (To remove them all, click the left double arrow.)
 16) Change the order of the fields.
 a) Click the field which you want to move up or down in the list of fields.
 b) Click the up arrow to move the field higher, or click the down arrow to move it lower.
 17) Click Next to go to Page 2.
· Practice exercise: Create the HouseholdInventory table
 18) Begin in the Database file window by clicking the Table icon. From the Task section, click Use Wizard to Create Table to open the Table Wizard.
 19) The wizard contains many suggested tables that you can use. Some of them are for business purposes and some are for personal purposes. The first thing to do is some research for the names of the sample tables. This requires you to click either the Business option button and search through the sample table names or click the Personal option button and search through its Sample table names. Make a note of any tables that you may find useful. Also note the category of the table (Business or Personal). When you want to use a sample table in a database, you will know where to look for it.
 20) If you looked through the sample table names, you discovered that its category is Personal. The available fields list appears when you select Personal as the category and HouseholdInventory from the Sample table drop-down list. So, make these selections now.
 21) Sixteen fields are available for this table. You can select all or only a few of them, depending upon the information needed for your database.
 22) Choosing what fields to use is part of the planning of the database. It pays to look through the available fields to see if specific fields should be part of the table. If you think that any of the fields should not be apart of the database, do not select them for your table.
 23) What if there is a field that you want to be part of the table, but it does not exist? You can create one in step 2 of the wizard. You can also select a similar field in step 1 and change its type and format in step 2.
 24) For example: you want to include the names of the rooms that contain furniture. One of the 16 fields is RoomID. You can select this field in this step. Then in page 2, change the name of the field from RoomID to Room. Also change the field type and format.
 25) For this exercise, use these fields:  AppraisedValue, DatePurchased, Description, Insured, Item, Manufacturer, ModelNumber, Notes, PlacePurchased, PurchasePrice, RoomID, SerialNumber, and InventoryID.
 26) Selected fields: Using the > button, move the following fields from the Available fields window to the Selected fields window in this order: CollectionID, AlbumTitle, Artist, DatePurchased, Format, Notes, and NumberofTracks.
 27) Move these fields from the Available fields to the Selected fields. You can click a single field or Control+click multiple fields to highlight them. Then click the single right arrow. If you accidentally move a field that should not be moved, click the field and then click the single left arrow.
 28) Selected Fields from another sample table. Click Business as the Category. Select Employees from the drop down list of sample tables. Use the > button to move the Photo field from the Available fields window to the Selected fields window. It will be at the bottom of the list directly below the NumberofTracks field.
 29) Now comes another part of the planning. Think about the order that you want to use when entering the data into your table. The fields are listed now in alphabetical order. Is that what you want? Chances are that the answer is no. Then what order do you want? One possible order is shown in Error: Reference source not found. This order will be used in the exercises for the rest of the steps of this wizard.
 30) To complete this part of the practice exercise, click the Next > button. The exercise continues on page Error: Reference source not found.
· Step 2: Set types and formats
 31) This page has two parts: the list of selected fields, and field information. The first part contains the same list as you created in page 1 including the order you gave them. When you select one of the fields in this list, the field's information appears in the second part (Figure Error: Reference source not found).
· Selected fields list
 32) If you make a mistake in selecting fields, click on the field name in the Selected fields list and use the < button to move it from the Selected fields list back to the Available fields list.
 33) There are a couple of things that you can do with the Selected fields list (Figure Error: Reference source not found). It has a pair of arrows at the bottom right. You can reorder the fields in this list just as you did on page 1.
 34) If you make a mistake in the order of the selected fields, click on the field name that is in the wrong order and use the Up or Down arrow on the right side of the Selected fields list to move the field name to the correct position.
 35) Click Next.
It also has a plus (+) button and minus (-) button. Use these to create a new field or delete an existing field. Use the plus to add a field or the minus to remove one. 
Be careful when removing a field. If you delete a field that should not be deleted, you will have to use the plus to add the field to the list. Then you will have to give this field its field information. So, before deleting any field, click it in the selected field list. Copy the field information that appears. Then if you accidentally delete a field, you can recreate it with all of its field information.
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[bookmark: Ref_Figure286_number_only]Figure 6: Selecting fields for the table

Step 2: Set field types and formats
Field information
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[bookmark: Ref_Figure287_label_and_number]Figure 7: Changing field types

In this step you give the fields their properties. When you click a field, the information on the right changes. (See Figure 7.) You can then make changes to meet your needs. Click each field, one at a time, and make the changes listed below.
· Note
If any of these fields requires a mandatory entry, set Entry required to Yes. A blank field will then not be allowed. In general, only set Entry required to Yes if something must always be put in that field. By default, Entry required is set to No.
· CollectionID: Change AutoValue from No to Yes. (example of a mandatory entry)
· AlbumTitle:
· All the fields have at least four items as field information. The actual number of items depends upon the field type. When the field type is Integer, there are five items.
· Most of the field types used in Base are similar to those used in database programs. However, different programs are likely to have some field types that are not available in Base. For example, MEDIUMINT, is used in MySQL. Its Length is less than INTEGER and larger than SMALLINT which Base uses.
	· Tip
	· Whether you are new to creating databases or new to using Base to create them, you will be selecting the field information for all of your fields. For this reason, those used in Base are discussed in Appendix I of the Base Guide, Field Information for Base.


· The Field name permits you to change the spelling of the field's name. The Field type determines the main characteristic of the field such as text, numbers, dates, times, timestamps, Boolean (for example, yes/no, true/false, or male/female), and very large fields including images.
· Entry required: Leave Entry required as No, unless all of your music is in albums.
· Use Entry required for any field that must always have a value by selecting Yes. Always be sure that an entry will always be required before selecting Yes.
· Length: Unless you have an album title that exceeds 100 characters counting the spaces, do not change the length.
· Artist: Use the Default setting. And since music always has artists, set Entry Required to Yes.
· Date Purchased: Field type: default date setting. Entry required should be No. (You may not know the date.)
· Note
In Base the maximum length of each field must be specified on creation. It is not easy to change this later, so if in doubt specify a greater length. Base uses VCHAR as the field format for text fields. This format uses only the actual number of characters in a field up to the limit set, so a field containing 20 characters will occupy only 20 characters even if the limit is set at 100. Two album titles containing 25 and 32 characters respectively will use space for 25 and 32 characters and not 100 characters.
	Caution
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	If you have a field that requires an entry, you will get an error message if you do not enter a value. You will be able add values to all the other fields once only before the error message, But you can not add any more values until you enter one in the field that requires one.


The Length property determines the size of the entry that can be used for a field. Each of the field types have specific maximum lengths. So, check what these are when entering a length, and enter what you need. You might need to change the field type if you need a larger length than your chosen field type will permit. Then again, a field type that has a smaller length might be more appropriate.
Text field types include CHAR, VARCHAR, VARCHAR_IGNORECASE, and MEMO. CHAR stores entries in a fixed length. For example, the selected length is 10 and the values entered were cat, mouse, leather, and something. These would be stored as cat0000000, mouse00000, leather000, and something0. The zeros are added to make the length of each one 10. When this field is later read, the zeros are ignored.
VARCHAR is variable character. Only the actual characters entered are stored up to the length selected. If it also has a selected length of 10, the above examples are stored as cat, mouse, leather, and something. So less storage is needed when using VARCHAR instead of CHAR. This is especially useful when a field's values vary considerable in length. So the suggested length of 50 can be used for VARCHAR as long as the longest entry is less than or equal to 50. With 50 as the selected length for VARCHAR with the examples above, the stored values are still cat, mouse, leather, and something.
Use these steps to set the fields and their properties for your table:
1. To verify or modify the Field information for the selected fields,
a) Click the field name in the Selected field list.
b) Compare the field information to what you want the field to have.
· Format: Only change the Entry Required setting: from No to Yes.
· Change any of it if necessary.
· Notes: No changes are required.
· Repeat steps 1a-c for the rest of the fields.
· NumberofTracks: Change the Field Type to Tiny Integer [TINYINT]. Your allowable number of tracks will be 127. Small Integer [SMALLINT] would allow 32768 tracks if you needed more than 127 tracks.
· To create a new field:
· Photo: Use the default settings.
Click the plus (+) button. (See Figure Error: Reference source not found.) 
When you have finished, click Next.
· Change Field name to the field name you want.
· Note
Each field has a Field Type, which must be specified. Types include text, integer, date, and decimal. If the field is going to have general information in it (for example, a name or a description), use text. If the field will always contain a number (for example, a price), the type should be decimal or another numerical field. The wizard picks the right field type, so to get an idea of how this works, see what the wizard has chosen for different fields.
Modify any of the other Field information to what you need.
c) Repeat steps 2a-c for additional fields to be created.
1) To delete an unneeded field:
a) Click the field you want to delete.
b) Click the minus (-) button.
c) Repeat steps 3a-b to delete any additional fields.
· Practice exercise
2) The field, RoomID, needs to change its name, field type, and length. Two of the fields, AppraisedValue and PurchasePrice, require a change in the number of decimal places. Both are accomplished in the same manner: click the field in the Selected Fields list, and then change the part of the field information that needs it. Finally, for field, InventoryID, Change Auto value from No to Yes. After making the changes a particular field needs, use the Tab key or click one of the other fields. This saves the values to memory.
3) First click the field, RoomID. Change the Field name to Room. Now use the Tab key to move to Field type. Click its drop-down list to open it. Now select Text[VARCHAR]. To finish the changes, change the Length to 50 unless you have a room with a name longer than 50 characters. Use the Tab key or click one of the other fields.
4) Click the field, AppraisedValue. Change Decimal places from 0 to 2. Now we can store values in dollars and cents. Change Decimal places for PurchasePrice the same way.
5) Click the field, InventoryID. Change the Auto value from No to Yes. This is because this field will be used as the table's primary key. (See Step 3 below for more information about primary keys.)
6) Use the Tab key or click one of the other fields. This saves the values you entered for the last field you changed.
7) Click Next > to go to Step 3.
	8) Note
	9) When using the table wizard to create a table, very seldom will you need to make any changes in the field information since the suggested values are usually the ones you need. However, check the Decimal places value for currency fields as the wizard suggests using 0.


Step 3: Set primary key
 1) First of all, what is a primary key, and what is its purpose? It consists of one or more fields that have a special characteristic: no two values of the primary key are the same. Its purpose is to identify the rows of a table.
 36) For beginners, any primary key used should be a single field. It is even better if this field has the field type, Integer, and has Auto value set to Yes. When you create your primary key this way, Base will assign values to the field beginning at 0. Each new value for this field will be an Integer that is one greater than the previous one. This guarantees this field will contain distinct values.
 37) A table consists of rows and columns of data. When the table contains a primary key, we can select a given row by selecting the primary key value for that row. Each column of the table contains the values of a specific field. So when we specify both a single value of the primary key and the name of a field, we can select a specific cell of the table. This is what we need when we want to search for specific information that the table contains: a way to determine what row and column we want to use in our search.
 38) Primary keys containing more than one field require more vigilance to make sure no two rows have the same values for these fields. Consider the table below. No two rows are identical even though Field1 has duplicate values as does Field2. However, together there are no duplications of the combination.
 39) Some types of tables do not require a primary key, but remembering which type of table does and which does not can lead to potential problems. So, it is best to have a primary key for every field unless you can always remember whether a table type requires one or not.
 2) Create a primary key should be checked.
 3) Table 5: Example of values for a two-field primary key
	 40) Field1
	 41) Field2

	 42) 1
	 43) 0

	 44) 0
	 45) 1

	 46) 0
	 47) 0

	 48) 1
	 49) 1

	 50) Caution
 51) [image: ]
	 52) When a table is created without a primary key and should have one, you will not be able to enter any data into the table. This can be frustrating. You will first have to learn how to use the Table Design dialog before you can correct this error. (See Chapter 3 of the Base Guide.) So when using the table wizard always have this checked on Page 3: Create a primary key.


 53) There are three choices on this page of the table wizard once you have made sure that Create primary key has been selected. This should be the default setting, but make sure anyway. The choices are Automatically add a primary key, Use an existing field as a primary key, and Define primary key as a combination of several fields.
 54) The first option adds an additional field, ID as the table's primary key. Its field type is Integer. However, Auto value is set to No. This means you would have to manually enter each value for the field, ID. Using the second option instead of this one will permit you to have Base create the values for the primary key for you.
 55) The second option selection has been selected in the figure below. The field name has been selected from the drop-down list of field names. Check the Auto value checkbox to have Base select the values for this field automatically.
 56) [image: ]
Figure 8: Table Wizard Step 3

 57) The third option allows you to select two or more fields to use for the primary key. If you select this, you can select the fields from the Available fields list and move them to the Primary key field list using the right arrow in the middle. You can even change the order in the Primary key field list using the up or down arrow.
 58) If you want to experiment with a multiple field primary key, select the Personal Category and the Addresses sample table. Select FirstName, LastName, and any other fields you want. Then in this page, select the third option. Move FirstName and LastName from Available fields to Primary key fields. When you added data to this table make sure that you do not use the same first name last name combination more than once.
· Practice exercise
 4) Select option Use an existing field as a primary key.
 5) Select InventoryID to be the primary key for the table and give it the Auto value property.
 59) Click Next to go to page 4.
· Step 4: Create table
 60) [image: ]
Figure 9: Table Wizard Step 4

	 61) Tip
	 62) A common naming practice has been to make two or more words into one word for the name of a field or database. (Each word is capitalized when joining them.) HouseholdInventory and InventoryID are two examples. You may use spaces in names used in a database if you want. Such names may require double quotes when using SQL to create, delete, or modify a table or field. (See Chapter 3 of the Base Guide for detailed information.)


 63) Use this page to name the table you are creating. You can use the name suggested, modify it, or give it a name of your choice. Then you have three options regarding what to do next: Insert data immediately, Modify the table design, or Create a form based on this table. After making any modification in the table name and selecting your option, close the table wizard.
 64) When the first option is selected and the table wizard is closed, the Table Data View dialog opens. At this point you can add information in this table. (See Figure Error: Reference source not found.)
 65) When the second option is selected and the table wizard is closed, the Table Design dialog opens. With this you can modify the fields of the table. (See Chapter 3, “Tables” in the Base Guide.)
 66) With the third option and the Table Wizard closed, the Form Wizard opens. With this you can create a form for the Household Inventory table. (See .)
· Practice exercise
 67) Modify the name of the table to Household Inventory. Then select the first option, Insert data immediately. Click Finish to close the Table Wizard. The Table Data View dialog (Error: Reference source not found) opens.
· Enter or remove data using the Table Data View dialog
 68) Data can be entered into a table using this dialog or the form based upon this table. Instructions are give here about how to enter data using this dialog; later instructions will be given for how to insert, modify, or remove data in a form at the end of the  section.
	 69) Note
	 70) This section contains basic instructions for adding and removing data in a table.  Chapters 3 and 4 of the Base Guide discuss this in more detail.


 71) To insert or remove data using this dialog, it has to be opened. This can be done while creating the table by selecting Insert data immediately in the last step of creation. Also, you can always open any table at any time from the Main Database window to edit its data.
 6) In the Fieldname drop down list, select CollectionID.
 7) Click the Tables icon in the Database section.
 72) Right-click the name of the table in the list of tables.
 73) Select Open from the context menu. The table data view dialog opens.
 74) [image: ][image: ][image: ]
Figure 10: Table Data View dialog

· Enter data into a table
 75) When the table is first created, it contains no data as shown in the above figure. It consists of a row and a column for each field contained in the table. (The table is divided into three snapshots because of the width of the table.) The heading for each column is the name of field whose data is contained in it.
 76) Before entering data into the cells, you may need some reminders about the rows and columns of a table. All the data contained in a given row apply to a given item. All the data contained in a given column belong to the field whose name appears as the heading of that column.
 77) For example, each row in the figure above contains data about a distinct item, say a sofa which is in the living room. The data entered in this row are its name, Item; its location, Room; information about it, Description; identification number, SerialNumber; who built it, Manufacturer; its model, ModelNumber; where bought, PlacePurchased; bought when, DatePurchased; cost, PurchasePrice; its worth, AppaisedValue; insurance, Insured; other information, Notes; and primary key value, InventoryID.
 78) For a second example, a second sofa is also in the inventory. It is an older sofa that is in the family den. The row of data that applies to this sofa has some differences from the row that applies to the first sofa. (DatePurchased is one such difference.)
 79) Because of these differences, care must be taken when entering data to make sure that all of the data entered into a given row applies to only one item. Otherwise, the data you obtain from the table contains errors.
 80) Now consider the columns of our two examples about the sofas. The Item column contains the name of the items. The Room column contains their locations. The Description column contains information about them … The InventoryID column contains their unique identification numbers.
 81) So, this is another are in which care must be taken. The data entered into a table must be placed into the correct column. Otherwise, this too will produce errors in the data.
	 82) Note
	 83) An item's serial number should be unique for a given manufacturer, we have no guarantee that different manufacturers may use the same serial number. That is why we need to use a unique identification number for the items of our inventory.


 84) When the dialog is opened, a cursor appears in the first cell of the row. It is ready for you to enter data into that cell. Once you have entered data into a cell, you can move the cursor into the other cells so that data can be entered there as well.
 85) Entering data into the dialog is similar to entering data into the cells of a spreadsheet. The cursor can be moved from one cell to another using the arrow keys. (In a spreadsheet, sometimes the Enter key must be used.) Typing data only places it into the cell where the cursor is located.
 86) There are important differences as well. Typing data into a cell of a table does not enter the data into the table as it does in a spreadsheet. The data only appears in the cell. To enter it into the cell, the cursor must be moved by either the Enter or by an arrow key. Finally, using the Enter key when the cursor is in the last column of a row moves the cursor to the first column of the next row.
 87) Entering data into an empty table: (The cursor is located in the first column of the first row.)
 88) The first row:
 a) Type the data into the first cell.
 b) Move the cursor to the next cell. (Use the Enter or right arrow key.)
 c) Repeat steps a) and b) until the cursor is in the last cell of the row.
 d) Type the data into the last cell.
 e) Move the cursor to the first cell of the second row. (Use the Enter key.)
 89) Additional rows:
 90) Repeat steps a) – e) in 1).
 91) Close the table data view dialog, saving it if necessary.
 92) Entering data into any empty cell of a table is very similar to the above steps.
 93) Use the mouse to move the cursor to the empty cell.
 94) Type the data into it.
 95) Move the cursor to another cell. (Use the Enter or right arrow key.)
 96) Close the table data view dialog, saving it if necessary.
 97) When creating lists of the data that you want to enter into a table, you should consider the format of the list. Consider which of the following two lists is easier to use.
 98) This is a list of data separated by commas and semicolons: 
 99) Row 1: Item, Keyboard; Room, Den; Description, “ “; Serial Number, 1426894123; Manufacturer, Casio; Model Number, CTK-720; Place Purchased, Target; Date Purchased, 05/16/2008; Purchase Price, 90.00; Appraised Value, 75.00 …
 100) The table below shows the same data in table format.
	 101) Item
	 102) Room
	 103) Description
	 104) Serial Number
	 105) Manufacturer
	 106) Model Number

	 107) Keyboard
	 108) Den
	 109) 
	 110) 1426894123
	 111) Casio
	 112) CTK-720

	 113) HP Pavillion
	 114) Computer
	 115) Computer w/printer
	 116) KQ946AA#AB
	 117) Hewlett Packard
	 118) a6503f


 119) Practical exercise
 120) Enter this data into the Household Inventory table:
 121) Table 6: Sample data (first 6 fields)
	 122) Item
	 123) Room
	 124) Description
	 125) SerialNumber
	 126) Manufacturer
	 127) ModelNumber

	 128) Keyboard
	 129) Den
	 130) 
	 131) 14268941235
	 132) Casio
	 133) CTK-720

	 134) HP Pavillion
	 135) Computer
	 136) computer w/printer
	 137) KQ946AA#ABA
	 138) Hewlett Packard
	 139) A6503f

	 140) Piano
	 141) Living
	 142) Upright 
	 143) STE112211
	 144) Steinway
	 145) 2002STE4556

	 146) Table
	 147) Dining
	 148) round
	 149) WW2113
	 150) Woodworks, Inc.
	 151) WW126

	 152) Microwave
	 153) Kitchen
	 154) 900W
	 155) SHR4568de222
	 156) Sharp
	 157) SHR54678KL


 158) Table 7: Sample data (last 7 fields)
	 159) Place Purchased
	 160) Date Purchased
	 161) Purchase Price
	 162) Appraised Value
	 163) Insured
	 164) Notes
	 165) InventoryID

	 166) Target
	 167) 05/16/08
	 168) 90
	 169) 75
	 170) TRUE
	 171) 
	 172) 1

	 173) Best Buy
	 174) 09/04/11
	 175) 1097
	 176) 1097
	 177) TRUE	
	 178) 
	 179) 2

	 180) Classical Instruments
	 181) 08/12/02
	 182) 5895
	 183) 6000
	 184) TRUE
	 185) 
	 186) 3

	 187) Sonny's Furniture
	 188) 10/19/67
	 189) 825
	 190) 125
	 191) TRUE
	 192) 6 chairs
	 193) 4

	 194) Service Deluxe
	 195) 08/30/11
	 196) 145.99
	 197) 145.99	
	 198) TRUE
	 199) 
	 200) 5


· Modify data in a cell of a table
 201) Modifying data requires only five steps:
 202) Open the table.
 203) Click the cell containing the data.
 204) Change the data as you would data in any text box.
 205) Save the table.
 206) Close the table.
· Delete data from a table
 207) Deleting data involves one of two things: either deleting the data from a single cell or deleting the data from all the cells of a row. Deleting data from a single cell is done the same way as modifying the data of a single cell. In step 3, you delete the data that you no longer want.
 208) Deleting all the data in a table's row requires only a few steps:
 209) Open the table.
 210) Click the gray box to the left of the row whose data you want to delete to highlight it.
 211) Right the gray box and select Delete Row from the context menu. A dialog appears labeled Do you want to delete the selected data?
 8) Check Auto value Click OK if that is the row of data you want to delete. Click NO if it is not already checked.
 9) Save the table.
 212) Close it.
	 213) Caution
 214) [image: ]
	 215) Be very careful when deleting a row of data.
 216) If you delete the wrong row, you will have to reenter the data. This will take an unnecessary use of time but it may not be too much of a problem if you have a copy of the data somewhere.
 217) If you do not have a copy and can not obtain the data somewhere else, you have permanently deleted data that you need.


 a) Forms: using the Forms Wizard
 218) If we had to enter all of our data directly into our table, it would be more time consuming than it needs to be. Creating a form based upon the table we created will allow us to enter our data in a more meaningful way. When we look at a table, we see many rows of data simultaneously. The form allows us to see only one row (one record) at a time.
· Create a simple form using the Form Wizard
 219) The wizard guides us through some fairly easy steps for creating a form based on the table we have already created. The wizard creates a layout of controls (the table's fields and their labels) based upon the choices we make while using it.
 220) Once the form is created, it can be edited. Because of the additional complexity that editing involves, editing of forms is discussed in Chapter 3 of the Base Guide.
 221) Here are two ways to open the wizard for create a form. Use 1) OR 2). Do not use both.
 222) Click the Table icon in the Database section of the main database window.
 a) Right-click the table you want to use. (Right click the Inventory table.)
 b) Select Form Wizard from the context menu.
 223) OR, click the Forms icon in the Database section of the main window, then in the Task section, click Use Wizard to create form.
 224) Step 1: Field selection (Error: Reference source not found)
 225) Select the table, Inventory, in the Tables and queries drop-down list.
 226) If you right-clicked the Inventory table and selected Form Wizard from the context menu, Table: Inventory will already be selected. OR
 227) If you had earlier clicked Use Wizard to create form, select Table: Household Inventory.
 228) Choose fields from the Household Inventory table to be used in the form.
 229) Since we want to use all of the fields, click the right double arrow to move all the fields listed under Available fields to the Fields in the form list.
 230) OR, if you only want to move part of the fields, click the field you want to move and click the right arrow to move this field.
 231) Repeat for the rest of the fields to be moved.
 10) Click Next.
· Note
A primary key uniquely identifies an item (or record) in the table. For example, you might know two people called “Randy Herring” or three people living at the same address and the database needs to distinguish between them.
The simplest method is to assign a unique number to each one: number the first person 1, the second 2, and so on. Each entry has one number and every number is different, so it is easy to say “record ID 172”. This is the option chosen here: CollectionID is just a number assigned automatically by Base to each record of this table.
Step 4: Create the table
1. If desired, rename the table at this point. If you rename it, make the name meaningful to you. For this example, make no changes.
 12) Leave the option Insert data immediately checked.
 13) Click Finish to complete the table wizard. Close the window created by the table wizard. You are now back to the main window of the database with the listing of the tables, queries, forms, and reports. Notice that a table named “CD-Collection” is now listed in the Tables portion of the window.
 14) Click the Save button at the top of the main window.
Creating a table by copying an existing table
If you have a large collection of music, you might want to create a table for each type of music you have. Rather than creating each table from the wizard, you can make copies of the original table, naming each according to the type of music contained in it.
1. Click on the Tables icon in the Database pane to see the existing tables.
 16) Right-click on the CD-Collection table icon. Choose Copy from the pop-up menu.
 17) Move the mouse pointer below this table, right-click, and select Paste. The Copy table dialog opens.
 18) Change the table name to CD-Jazz and click Next.
 19) Click the >> button to move all the fields from the left box to the right box and click Next.
 20) Since all the fields already have the proper Field type, no changes should be needed. However, this is the time and place to make any changes if they are needed. (See Caution below for the reason why.) Click Create. The new table is created.
 21) Click the Save button at the top of the main database window.
· Caution
Once tables have been created using the wizard, and data has been entered, editing a table should be very limited. You can add or delete fields, but adding a field requires you to enter the data for that one field for every existing record with an entry for that field.
Deleting a field deletes all the data once contained in that field. Changing the field type of a field can lead to data being lost either partially or completely. When creating a new table, it pays to create the fields with the correct names, length, and format before you add any data.
Deleting a table removes all of the data contained in every field of the table. Unless you are sure, do not delete a table.
Creating tables in Design View
Design View is a more advanced method for creating a new table, in which you directly enter information about each field in the table. We will use this method for the tables of our database.
· Note
While the Field type and formatting are different in Design View, the concepts are the same as in the Wizard.
The first table to be created is Fuel. Its fields are FuelID, Date, FuelCost, FuelQuantity, Odometer, and PaymentType.
1. Click Create Table in Design View (which opens the Table Design dialog).
 23) FuelID field: Type FuelID as the first Field Name. Press the Tab key to move to the Field Type column. Select Integer [INTEGER] as the Field Type from the drop down list. (The default setting is Text [VARCHAR].)
· Tip
A shortcut for selecting from the Field Type drop down list: press the key for the first letter of the choice. You can cycle through the choices for a given letter by repeatedly pressing that key.
a) Change the Field Properties in the bottom section.
Change AutoValue from No to Yes.
b) Set FuelID as the Primary key.
Click in the Field Name cell directly below FuelID. The dialog automatically sets FuelID as the primary key and places a key icon in front of FuelID. (Figure 11)
[image: ]
[bookmark: Ref_Figure288_label_and_number]Figure 11: Defining the primary key field

· Tip
Certain of the Integer filed types (Integer and BigInt for example) have an AutoValue Field Property. When using one of these field types, your selection of Yes for the AutoValue value automatically makes the field the primary key. 
Primary keys for any other field type must be selected by right-clicking the rectangle before the field and selecting Primary key in the context menu.
· Note
The primary key serves only one purpose: to identify each record uniquely. Any name can be used for this field. We have used FuelID for convenience, so we know to which table it belongs.
 24) All other fields (Date, FuelCost, FuelQuantity, Odometer, and PaymentType):
1. Type the next field name in the Field Name column.
d) Select the Field Type for each field.
· For Date use Date[DATE]. (Press the D key to select it.)
· All other fields use Number [NUMERIC]. (Press the N key once to select it.)
· PaymentType uses Text [VARCHAR], the default setting.
e) FuelCost, FuelQuantity, and Odometer need changes in the Field Properties section (Figure 12).
· FuelCost: Change the Length to 5 and Decimal places to 2. Click the Format example ellipse button (...) (Figure 12). This opens the Field Format window (Figure 13). Use Currency as the Category and your currency as the Format. My currency has two decimal places. Use what is appropriate for yours.
· FuelQuantity: Change Length to 6 and Decimal places to 3. (Many fuel pumps measure fuel to thousandths of a gallon in the USA, where I live.)Odometer: Change the Length to 10 and the Decimal places to 1.
f) Repeat steps a) through c) until you have entered all of the fields.
[image: ]
[bookmark: Ref_Figure289_label_and_number][bookmark: Ref_Figure289_number_only]Figure 12: Changing field properties

g) To access additional formatting options, click the ellipse button (…) to the right of the Format example field.
Description can be any of the categories listed in the figure below, or can be left blank.
[image: ]
[bookmark: Ref_Figure290_number_only]Figure 13: Format example options

 232) To save and close the table, select File > Save. Name the table Fuel. Close the Fuel table.
 233) In the main database window, click the Save button.
[image: ]
[bookmark: Ref_Figure291_label_and_number]Figure 14: Fields in Vacations table

Follow the same steps to create the Vacations table. The fields, field types, and Descriptions are listed in Figure 14.
Making Date the primary key has to be done in a different way because this field’s field type is Date, not Integer.
 a) Right-click to the left of the field name Date.
 b) Select Primary Key in the context menu.
Defining relationships
Now that the tables have been created, what are the relationships between our tables? This is the time to define them based upon the questions we asked and answered in the beginning.
When on vacation, we want to enter all of our expenses at once each day. Most of these expenses are in the Vacations table, but the fuel we buy is not. So we will link these two tables using the Date fields. Since the Fuel table may have more than one entry per date, this relationship between the Vacations and Fuel tables is one to many (it is designated 1:n.)
The Fuel and Maintenance tables do not really have a relationship even though they share similar fields: Date and Odometer readings.
· Tip
As you create your own databases, you will also need to determine if tables are related and how.
1. To begin defining relationships, select Tools > Relationships. The Automobile – LibreOffice Base: Relation Design window opens and the Add Tables dialog pops up. (You can also open it by clicking the Add Tables icon on the Relation Design window.)
 26) In the Add Tables dialog, use either of these ways to add a table to the Relation Design window:
· Double-click the name of the table. In our case, do this for both Vacations and Fuel.
· Or, for each table, click the name of the table and then click Add.
 27) Click Close to close the Add Tables dialog when you have added the tables you want.
 28) Define the relationship between the Vacations and Fuel tables:  click the New Relation icon. This opens the Relations window (Figure 16). Our two tables are listed in the Tables involved section.
1. In the Fields involved section, click the drop-down list under the Fuel label.
i) Select Date from the Fuel table list.
j) Click in the cell to the right of this drop-down list. This opens a drop down list for the Vacations table.
k) Select Date from the Vacations table list. It should now look like Figure 16.
l) Modify the Update options and Delete options section of the Relation window. (Figure 20)
0. Select Update cascade.
ii) Select Delete cascade.
[image: ]
Figure 15: Designation for a 1:n relationship

	Tip
	Notice that the drop-down list we used to select the Household Inventory table is labeled, Tables or queries. This is because a form can be created from a query just as it can be from a table.


Step 2: Set up a subform.
10) We will not use another table along with the Household Inventory table. So, we will not be using a subform.
1. Click Next.
Step 3, Add Subform fields, and 4, Get joined fields.
Both of these pages only apply when you are using a second table to create a subform. Since we did not select the second table in page 2, pages 3 and 4 are grayed out.
Step 5: Arrange the controls on your form.
[image: ]
[bookmark: Ref_Figure293_label_and_number][bookmark: Ref_Figure293_number_only]Figure 16: Selected fields in a relationship

· Tip
The primary key can contain more than one field. (Its foreign key[footnoteRef:2] will contain the same number of fields.) If this were the case in  Figure 16, the other fields of the primary field for the Fuel table would be listed under Date. The corresponding fields of the foreign key would be listed under Vacations. Detailed information about this is in the Base Guide. [2: 	A field in a table that stores values of the primary key of records in another table.] 

Control
A Control consists of a label and field. The label contains the name of the control, and the Field contains the data entered into the form.
You have four choices in arranging your controls as shown in the figure from left to right: Columnar – Label left, Columnar – Label on top, As Data Sheet, and In Blocks – Labels Above. Each choice gives a slightly different layout.
Both of the columnar layouts create the controls in columns beginning with the first control at the upper left and continuing down the left side. If additional columns are needed, they are filled in from top to bottom and then columns from left to right. The first control is the top control in the left column. The last control is the bottom control in the column on the right.
The Data Sheet arrangement looks like a spreadsheet with the labels across the top. This is probably best used for a subform rather than for the main form. It is your choice.
The In Blocks – Labels Above arrangement places the controls in rows from left to right. When one row is filled, the next control is placed at the left end of the row below. So, the first control is at the left end of the top row, and the last control is at the right end of the bottom row.
We will use Columnar – Labels Left for the Household Inventory form.
The In Blocks – Labels Above arrangement places the controls in rows from left to right. When one row if filled, the next control is placed at the left end of the next row below the row that is filled. So, the first control is at the left end of the top row, and the last control is at the right end of the bottom row.
We will use Columnar – Labels Left for the Household Inventory form.
12) Label placement: Select how you want the labels to be aligned: left or right.
Accept the Default value of Align left, or click the bottom option button to select Align right.
13) Arrangement of the main form: click the graphic on the left. (See Error: Reference source not found for the correct appearance of the window.
14) Arrangement of the subform: we are using only one table in this form, so this is grayed out.
· Click Next.
Step 6: Select the data entry mode.
· The default choice match our needs. Click Next.
	Tip
	I strongly advise that you look at the data entry choices available, thinking about how each of these choices might meet your future needs. For instructions on the purpose of each of these choices, see Chapter 3 of the Base Guide.


Step 7: Apply the style of your form.
15) Apply styles: page color:
a) Chose one of the listed colors. The default color is as good as any. (This color can be changed when we modify the form.)
b) You can create your own color to use using Tools > Options > LibreOffice > Colors. You can use RGB or CMYK values in this dialog. After creating the color you want, you can select your color while modifying the form.
16) Field border:
a) Experiment with the three choices.
b) Use the mouse to move the Form window around so that you can see each of the three choices in the form.
1. Use the default value. (This choice can be changed if the form is edited. The border of the control labels could be changed then as well if you so desire.)
1. Click Next.
Step 8: Set the name of the form.
18) The suggested name for the form is the same as the table that was used to create the form: Household Inventory. Use the suggested name this time, but remember that you can choose the name you want to use. You can rename the form if you like.
19) How do you want to precede after creating the form?
· If you want to add data immediately after creating the form, use Work with the form. Select this choice for this example.
1. Click Finish.
1. Since we chose Work with the form above, the Household Inventory form opens in the “read only” mode, as in Figure Error: Reference source not found. You can start inserting data into your table.
1. If you had chosen Modify the form, the Household Inventory form would have opened in edit mode. (Modifying a form is discussed in Chapter 4 of the Base Guide.)
	Tip
	“Read only” is confusing to many people. In Edit mode, you can modify anything that you earlier created: controls, background, and text you may have added to the page. In this mode, you can not add nor remove any data previously entered into any of the fields unless you click the Design Mode On/Off icon to turn the design mode off. 
In Read Only mode, none of the controls nor styles of the form can be changed. However, you can add, delete, or modify data in any of the fields.


This form, which is actually created by Writer, can be modified in many different ways that are described in Chapter 4 of the Base Guide.
Enter or remove data from forms
The data for any of the fields in a given record can be entered, removed, or changed at the same time. There are some similarities and differences between adding data to a table and a form. This discussion involves two parts: working with individual controls, and removing an entire record from the database. The latter is similar to deleting an entire row from a table with the same possible consequences.
[image: ]
Figure 17: Newly created Household Inventory form

Enter or remove data from individual controls
The form contains a control for each of the fields in the table. Each control contains a label which identifies the field from the table and a box which contains data from the field. When the cursor is in a box, data can be typed into it.
Before entering or removing data from individual controls, you need to acquaint yourself with both the newly created form and the left side of the Form Navigation toolbar, shown in Error: Reference source not found. (The rest of the tools on it are discussed in Chapter 4, Forms, in the Base Guide.)
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Figure 18: Form Navigation toolbar
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· Record number: The form numbers the rows of the underlying table from the top row to the bottom row. The record number shown is the number of the row that appears on the form.
· Total records: This shows the total number of records of the underlying table when the number of rows is small. With larger tables, this shows only part of the total number.
· First record: Click this arrow to go to the first record. (The record number becomes 1 or whatever is the smallest number. If the present record is the first record, this arrow is grayed out and not useable.)
· Previous record: Click this arrow to go to the previous record. (The record number becomes one less than what it had been. If the present record is the first record, this arrow is grayed out and can not be used.)
· Next record: Click this arrow to go to the next record. (The record number will be one larger than what it has been. If the present record is the last one, no data will appear in this record with one exception: the form contains the table's primary key, and its field property, AutoValue, is set to Yes. Only then will the primary key show AutoValue.)
· Last record: Click this arrow to go to the last record. (The record number becomes the largest one. If the present record is the last record, this arrow is grayed out and can not be used.)
· New record: Click this icon if you want to create a new record becoming the last record. (The record number becomes one larger than the previous largest one. No data appears in the controls of this record except for a primary key control whose field property for AutoValue is Yes.)
· Save record: Click this icon to save data that has been typed into one or more controls. The data entered is saved to the table.
· Undo data entry: If you have made some entries but have not saved them, you can click this icon to remove all the entries you have made in the present record since the last time the record was saved.
· Delete record: Click this icon if you want to delete the data from all of the controls in the present record. This will remove data that you just entered as well as the data that had been saved earlier. (A window appears requiring you to verify that you want to delete the data from all the controls of the present record.)
	Caution
[image: ]
	Be very careful when clicking the Delete record icon. This is equivalent to deleting a row from a table. Only do this if you are absolutely sure that you will no longer need the data that you are deleting. The present record no longer exist in the form, and the corresponding row of the underlying table also ceases to exist.

	Tip
	Some of these tools in the Form Navigation toolbar serve other purposes. When active, these tools can be used to save data typed into a record:
· First record
· Previous record
· Next record
· Last record
· New record
· Save record

	Caution
[image: ]
	When records are saved, they are written to the underlying table. However, this is done in the computer's memory (RAM). Only when the database is closed is the data written to the Base file (.odb). As long as you are not entering a large quantity of data to your database between closing it, you should not have a problem.


Entering data in a new record requires only a few individual steps.
1. Click the New record icon to create a new record. (The cursor appears in the first control.)
22) Type the data into the first control.
23) To move to another control:
· Use the Tab or Enter key to move to the next control.
· Use the Shift+Tab key to move to the previous control.
24) Type the data into the control to where you have moved.
25) Repeat steps 1-4 to enter the data into the record.
1. After typing data into the last control, use the Tab or Enter key to save the data and create another new record.
Removing or modifying data from an individual control:
27) Go to the record that contains the data to be deleted or modified using the first, previous, next, or last record arrow.
28) Click the field (box) that contains the data you want to change.
29) Delete or modify the data.
1. Save the record.
Practice exercise
1. Create five more records in the form using the data in Tables Error: Reference source not found and Error: Reference source not found below.
1. Modify the following records with the data given:
1. Change the appraised value for the piano from 6000 to 5700.
1. Delete the Description for the WiFi. (802.11g is not needed.)
Table 8: Data for first six controls
	Item
	Room
	Description
	SerialNumber
	Manufacturer
	Model Number

	Dishwasher
	Kitchen
	built-in
	GE4581839315
	General Electric
	GE456ee781

	Refrigerator
	Kitchen
	side by side
	HP4865818634
	Hot Point
	SBS44588F1990

	Stove
	Kitchen
	counter top w/built-in oven
	456789123258
	Whirlpool
	WP5748we84

	TV
	Den
	19" Digital ready
	MOT123456789
	Motorola
	MOT57dde85815

	WiFi modem
	Computer
	802.11g compatible
	CGNC1H111980
	Linksys
	WRT54GS V7


Table 9: Data for last seven controls
	Place Purchased
	Date Purchased
	Purchase Price
	Appraised Value
	Insured
	Notes
	Inventory ID

	Lowes
	04/20/99
	450.95	
	250
	TRUE
	5 cycles
	6

	Brothers Appliances
	12/16/90
	1599.99
	528
	TRUE
	
	7

	Sears
	12/30/99
	899
	452
	TRUE
	oven built-in
	8

	Sanders TV & Repair
	03/31/09
	249.99
	143
	TRUE
	
	9

	Webster's Computers
	04/22/04
	35.99
	20
	TRUE
	4-RJ45 
	10


Deleting records in a form
This can be done fairly quickly once the specific record to be deleted is located. You click the Delete record icon in the Form Navigation toolbar and then click the Yes button in the message: You intend to delete 1 record. If you click Yes, you won't be able to undo this operation. Do you want to continue anyway.
Practice exercise:
Delete the record for the WiFi modem. While you are at it, add a new record for the WiFi modem.
Queries: using the Query Wizard
The query is used to obtain information from the database and present it in a useful way. Search conditions are applied to the database data to limit it to the specific data we are wanting. We can do this using the Query Wizard for simple queries using a single table. The Query Design dialog is designed for the more complex queries using multiple tables. It is discussed in Chapter 5, Queries, of the Base Guide.
Query example
When we are sick, we go to a doctor who gathers data about our condition.
The medical tests your doctor has ordered is a database (data source). The knowledge the doctor has from training and education is another database. A diagnosis is a query of his training and education databases for what matches the symptoms you have: the doctor seeks this information. This query will also suggest that some other symptoms may be present. The doctor searches your medical tests for them: another query.

Query
A query is a search of the database to locate specific types of information.
Some of this information may be what has been entered. We may want to know the appraised value of the items in the Living Room. This produces a query whose output is a detailed list. A query can also manipulate the data to obtain desirable information.  For example: Based upon the appraised values of the individual items, what is the total appraised value of the entire inventory? This produces a single cell containing the total appraised value of the inventory.
Detailed query
A query that produces a detailed list as its output. The data in this list are part of the data contained in the database. The list consists of one or more rows.
Summary query
A query that manipulates database data to produce its output. Unless the summary query is group, its output will contain only one row and each column will contain manipulated data.
	Tip
	Three tools are available to help you to work with your data to get the information you need. One is the View located in the Table section of the database. This tool allows you to view selected data. Another is the Query, which allows you to both view and manipulate selected data. Finally, you can use the Report to create a text document that uses a table, view, or query from the database for its information.


Plan the query
Creating a query is similar to solving a word problem in basic algebra. Doing either one of these requires asking questions, finding the answers, and then using the answers to solve the problem.
As when creating a table, some thinking needs to be done about the purposes of the query before creating it. Questions based on them should be asked, questions based upon the eight steps that the wizard uses. It is best to ask the questions before using the wizard. Then you have the answers you need to make your selections in each of the steps.
	Note
	Steps 5 and 6 are for summary queries that groups the information you seek. While an example of one of these is given, the detailed discussion of them is in Chapter 5 of the Base Guide.
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Figure 19: Query wizard Step 1

Step 1. Field Selection:
· What table or query contains the fields the query needs?
· What fields are needed?
Step 2. Sorting order:
· What fields will you use to sort the query output?
· Will the sorting for a give field be ascending or descending?
Step 3. Search conditions:
· What fields need to have conditions added to them?
· What are the specific conditions?
Step 4. Detailed or Summary:
· Do you want the output to be a detailed list or a summary of selected database data?
Step 5. Grouped by:
· (No selections are available for this step. Instead the selection in Step 2 is used.)
Step 6. Grouping conditions:
· (No selections available for this step. Instead the selection in Step 3 is used.)
Step 7. Aliases:
· What fields should have their names modified?
· What should the modifications be?
Step 8. Overview:
· In the Overview window, what does not match what you wanted?
· What should the name of the query be? (Base suggests a name.)
· Do you want to display or modify the query? (The latter is discussed in Chapter 5, Queries, in the Base Guide.)
The importance of these questions should become clearer when you create two sample queries using the Household Inventory database (detailed and summary). First we will explain what needs to be done for each of these eight steps.
Create the query
To do this, we begin with the main database window open.
33) Click the Queries icon in the Database section.
1. In the Task section, click Use Wizard to Create Query. The wizard opens.
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[bookmark: Ref_Figure294_label_and_number]Figure 20: Update options and Delete options section

m) Click OK.
n) Save the Relation Design dialog if the Save button is active.
o) Close the Relation Design dialog.
p) Step 1: Field selection
q) Click the Save button at the top of the main database window.
While these options are not strictly necessary, they do help. Having them selected permits you to update a table that has a relationship defined with another table which has been modified. It also permits you to delete a field from the table without causing inconsistencies.
Creating a database form
Databases are used to store data. But, how is the data put into the database? Forms are used to do this. In the language of databases, a form is a front end for data entry and editing.
A simple form consists of the fields from a table (Figure 21). More complex forms can contain much more, including additional text, graphics, selection boxes, and many other elements. Figure 22 is made from the same table with a text label (Fuel Purchases), a list box placed in PaymentType, and a graphic background.
A list box is useful when a field contains a fixed choice of options. It saves you from having to type data by hand, and ensures that invalid options are not entered.
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[bookmark: Ref_Figure295_label_and_number]Figure 21: Fields of a simple form
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[bookmark: Ref_Figure296_label_and_number]Figure 22:Simple form with additions
    

In our database, payments for food or fuel might be made from one of two credit cards (Dan or Kevin) or in cash, so these would be the available options for all boxes that contain payments. 
To create a list box, we first need to create a small, separate table containing the options. This is then linked to the corresponding field in the form. The topic is dealt with in detail in the Base User Guide and will not be pursued further here.
Click Tables: Select the table or query to be used from the Table list.
Using the Wizard to create a form
Select the fields to be used from the Inventory table.
We will use the Form Wizard to create a Vacations form, which will contain a form and a subform.
In the main database window (Figure 1), click the Forms icon in the left column. In the Tasks list, double-click Use Wizard to Create Form to open the Form Wizard (Figure 23). Simple forms require only some of these steps, while more complex forms may use all of them.
Step 1: Select fields
 29) Click one that is in the Available fields list.
Click the right arrow to move it to the Fields in the Query list.
 30) Under Tables or queries, select Table: Vacations. Available fields lists the fields for the Vacations table.
 31) Change the order of the fields in the Fields in the Query.
 32) Click the right double arrow to move all of these fields to the Fields in the form list. Click Next.
Click the name of the field you want to move.
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[bookmark: Ref_Figure297_number_only]Figure 23: Form Wizard steps

Use the up arrow to move it higher in the list, or the down arrow to move it lower.
35) Rearrange the order of fields if necessary (AppraisedValue, then Purchase Price, then Room).
Step 2: Set up a subformSorting order
Since we have already created a relationship between the Fuel and Vacations tables, we will use that relationship. If no relationship had been defined, this would need to be done in step 4.
1. Click the box labeled Add Subform
 34) Click Subform based upon existing relation.
 35) Fuel is listed as a relation we want to add. So click Fuel to highlight it, as in Figure 24. Click Next.
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[bookmark: Ref_Figure298_label_and_number]Figure 24: Adding a subform

Step 3: Add subform fields
Select the field to be used for sorting the information you want.
36) Open the Sort by drop-down menu by clicking the box labeled Undefined.
This step is similar to step 1. The only difference is that not all of the fields will be used in the subform.
 36) Click the field's name in this drop-down list to select it.
 37) Fuel is preselected under Tables or queries.
 38) Use the >> button to move all the fields to the right.
 39) Click the FuelID field to highlight it.
 40) Use the < button to move the FuelID to the left (Figure 25). 
 41) Select Ascending or Descending as the order of the sorting.
 42) Click Next.
Step 3: Search conditions
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[bookmark: Ref_Figure299_label_and_number]Figure 25: Selecting fields of a sub form

Define the search conditions that will be applied to the query data.
Step 4: Get joined fields
Select the field in the Fields drop-down list in the top row.
This step is for tables or queries for which no relationship has been defined. Because we have already defined the relationship, the wizard skips this step.
· Note
It is possible to create a relationship between two tables that is based upon more than one pair of fields. How to do that and why is discussed in the Base Guide.
· Caution
When selecting a pair of fields from two tables to use as a relationship, they have to have the same field type. That is why we used the Date field from both tables: both their field types are Date[DATE].
Whether a single pair of fields from two tables are chosen as the relationship, or two or more pairs are chosen, certain requirements must be met for the form to work.
· One of the fields from the main form must be the Primary key for its table. (Date would have to be used.)
· Select the first condition from the Condition drop-down list. 
· No field from the subform can be the Primary key for its table. (FuelID cannot be used.)
· Each pair of joined fields must have the same file type.
Enter the value in Value.
37) If additional conditions should be defined, follow steps 1–3 in the succeeding rows of Fields, Condition, and Value.
Step 5: Arrange controls
If you have selected multiple conditions,
A control in a form consists of two parts: label and field. This step in creating the form determines where a control’s label and field are placed relative to each other. The four choices from left to right are Columnar left, Columnar—Labels on top, As Data Sheet, and In Blocks - Labels Above.
1. Arrangement of the main form: Click the second icon (Columnar—Labels on top). The labels will be placed above their field.
 44) Arrangement of the sub form: Click the third icon (As Data Sheet). (The labels are column headings and the field entries are in spreadsheet format.) Click Next.
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Figure 26: Arrange controls

Step 6: Set data entry
Unless you have a need for any of these entries to be checked, accept the default settings. Click Next.
Step 7: Apply styles
1. Select the color you want in the Apply Styles list. (I chose the beige which is Orange 4 in the Color table.)
 46) Select the Field border you want. (I prefer the 3D look. You might want to experiment with the different possible settings.)
 47) If you want all of the data to match all conditions in your query output, select the Match all of the following option button.
 c) If you want any individual datum (singular of data) to match any of the selected search conditions, select Match any of the following option button.
 48) Click Next.
Two examples of a query with multiple search conditions: the last name must be Smith and the city must be Selma; and the last name can be Smith or Jones.
For the first example, you need two rows. Select Last Name in Fields; for Condition, select is equal to; and enter Smith in Value. For the second row, enter City in Fields; for Condition, select is equal to; and enter Selma in Value. When this query is run, the only rows in the output will be those containing Smith in the Last Name field and Selma in the City field.
For the second example, you also need two rows. Select Last Name in Fields; for Condition, select is equal to; and enter Smith in Value. For the second row, select Last Name in Fields; for Condition, select is equal to; and enter Jones in Value. With this query, the only rows in the output will be those containing either Smith or Jones in the Last Name field.
Step 8: Set name4: Detailed or Summary
1. Enter the name for the form. In this case, it is Fuel.
 50) This is where you define whether the query is detailed or summary. 
 51) Click Modify the form.
 52) Click Finish. The form opens in Edit mode.
Modifying a form
We will be moving the controls to different places in the form and changing the background to a picture. We will also modify the label for the PaymentType field as well as change the field to a list box.
First, we must decide what we want to change. The discussion will follow this ten step outline of our planned changes.
· Provide a drop-down capability for the Date field in the main form, and lengthen the field to show the day of the week, month, day, and year.
· Shorten the length of the payment fields (all fields containing the word Payment).
· Move the controls into groups: food, fuel subform, and miscellaneous.
· Change the wording of some of the labels. Some single words should be two words. Some abbreviations should be used if possible (Misc. for miscellaneous).
· Change the lengths of several fields and labels. Only Lunch, Supper, Motel, and Tolls have acceptable lengths. But for a better appearance, changes will be made to these as well.
· Lengthen the Note field vertically, add a scroll bar, and move it.
· Make changes in the Date and PaymentType columns of the subform to match the changes in the main form.
· Add headings for each group in the main form.
· Change the background to a picture, then modify some of the labels so that they can be read clearly against this background. Change the font color of the headings.
Here are some methods that we will be using in these steps. The controls in the main form consist of a label and its field. Sometimes we want to work with the entire control, sometimes with only the label or the field, and there are times when we want to work with a group of controls.
· Clicking a label or field selects the entire control. A border appears around the control with eight green handles. You can then drag and drop it where you want.
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Figure 27: A selected control

· Control+click a label or field selects only the label or the field. You can press the Tab key to change the selection from the field to the label or the label to the field.
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Figure 28: Selecting a field of a control

· Moving a group of controls is almost as easy as moving one of them.
1. Click the field of the top left control to be moved, to select it.
s) Move the cursor to just above and to the left of the selected control.
t) Drag the cursor to the bottom right of the group of controls and release the mouse button.
As you drag the cursor, a dashed box appears, showing what is contained in your selection. Make sure it is big enough to include the entire length of all the controls.
When you release the mouse button, a border with its green handles appears around the controls you selected.
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Figure 29: Selecting multiple controls

Move the cursor over one of the fields. It changes to a drag icon. Drag the group of controls to where you want them.
· Click the Tolls control to select it. Then drag it to the right close to the Lunch control.
· Tip
When either changing size or moving a control, two properties of the Form Design toolbar should be selected: Snap to Grid, and Guides when Moving. Your controls will line up better, and an outline of what you are moving moves as the cursor moves. You should also have both rulers active (View > Ruler).
Step 1: Change the Date field
1. Control+click the Date field to select it.
 54) Move the cursor over the middle green handle on the right side. It should change to a double-headed arrow.
 55) Hold the left mouse button down as you drag the cursor to the right until the length is 6 cm. The vertical dashed line is lined up with the 6. Release the mouse button.
 56) Click the Control icon in the Form Controls toolbar. If it is not visible, select View > Toolbars > Form Controls. The Properties: Date Field window opens. Each line contains a property of the field.
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[bookmark: Ref_Figure304_label_and_number][bookmark: Ref_Figure304_number_only]Figure 30: Form Controls toolbar

· Scroll down to the Date format property. This is a drop down list with Standard (short) as the default setting. Click it to open the list. Select the Standard (long) entry.
· Scroll down to the Drop down property. Its default setting is No. It is also a drop down list. Click to open the list. Select Yes.
· Tip
To see what the Date field will look like, click the Form Mode On/Off icon (the second icon from the left in Figure 30). You can do this any time you want to see the form with the changes you have made.
Step 2: Shorten the width of some fields
All of the fields with a label containing the word payment are too wide. They need to be shortened before the controls are moved.
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Figure 31: Selecting a field

1. Control+click the BPayment field.
 58) Move the cursor over the middle green handle on the right. The cursor becomes a double-headed arrow.
 59) Drag the cursor to the left until the field is 2.5 cm (1 inch) wide.
 60) Repeat these steps to shorten these fields: Lpayment, SPayment, SnPayment, Mpayment, and MiscPayment.
· Tip
If you have the Snap to Grid and Guides when moving icons selected in the Design Format toolbar, you will see how wide the field is as you shorten it.
Step 3: Move the controls to group them by category
We want to move the controls so that they look like Figure 32.
1. Click the first control you want to move. A border appears around the control with eight green handles.
 1) Move the cursor over the label or field of the control. It changes shape to a drag icon.
 2) Drag and drop the control to where you want it.
 3) Use the same steps to move the rest of the controls to where they belong.
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[bookmark: Ref_Figure306_label_and_number]Figure 32a: Positioning of controls (left side of form)
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Figure 22b: Positioning of controls (right side of form)

· Caution
Do not use Control+click when moving a field. It moves either the field or the label but not both. To move both, use a plain mouse click and drag to the desired spot.
Step 4: Change the label wording
Field names have been required to be single words for some time. However, the labels for the fields in a form can be more than one word. So we will change them by editing the text in the label.
 234) Control+click the SnackNo label. Do one of the following:
· Right-click the SnackNo label and select Control from the pop-up menu.
· Or click the Control icon in the Form Control toolbar (Figure 30).
 235) The dialog that opens is labeled Properties: Label Field. It contains all the properties of the selected label.
· In the Label selection, edit the label to Snack No.
· Close the Properties dialog.
 236) Use the same procedure to change these labels as well: BPayment to Payment, LPayment to Payment, SPayment to Payment, Miscellaneous to Misc., SnackCost to Snack Cost, MPayment to Payment, MiscPayment to Misc. Payment, and MiscNotes to Misc. Notes.
· Tip
You can modify all of the listings in the Properties window. For example, if you change the Alignment from Left to Center, the word or words in the label are centered within the label. When you have some time, you might want to experiment with different settings just to see the results you get.
Step 5: Change the widths of the labels and fields
We want the fields of the following controls to be 2 cm wide (0.8 inches): Breakfast, Lunch, Supper, Odometer, Snack No., Tolls, Snack Cost, Motel, and Misc. All of the payment fields were changed in step 2, but Misc. Payment needs to be changed to 3 cm (1.2 inches).
1. Right-click Breakfast and select Position and Size. On the Position and Size dialog, change Width to 2 cm.
 62) Repeat for the other listed controls, using 3 cm for MiscPayment.
· Caution
When changing the position or size of an entire control, use the Position and Size dialog or the drag and drop method.
When working with either the label or the field (but not both at the same time), you can use the Properties dialog to make these changes when you want to be exact. However, you need to be careful not to accidentally select the entire control for use with the Properties dialog or you will apply exactly the same values to both the label and field. For example, if you enter the values for a new position, both the field and the label moves to the same position and the field is positioned on top of the label. Then you will have to move each of them to where you really want them.
· Tip
To open the Properties dialog, right-click a control and select Control from the pop-up menu. Or, you can click the Control icon in the Form Controls toolbar. Just be careful, and use Control+Z to undo any mistakes you may make. Detailed instructions on how to use the Properties window are given in the Base Guide.
Step 6: Change the Misc. Notes field
We want the Misc. Notes control, which has a field type of Memo, to have a vertical scroll bar for additional text space if desired.
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[bookmark: Ref_Figure307_label_and_number]Figure 33: Scroll bar selections in the Properties window

1. Control+click the Misc. Notes field. The green handles should surround the field but not its label.
 64) Click the Control icon to open the Properties window (Figure 33).
 65) Scroll down to the Text type property with single-line as the default value.
· Change it to Multi-line.
 66) Scroll down to the Scrollbars setting. Change the selection from None to Vertical in this list.
 67) Close the Properties window. (Esc key)
 68) Lengthen the Misc. Notes field by moving the cursor over the middle green handle at the bottom of the field and dragging down until the length is 6 cm (2.4 inches).
Step 7: Change labels and fields in the subform
The subform is located at the bottom of the form. We want to widen the Date column,  and change the label for the PaymentType column to two words.
· To widen the Date column, move the mouse pointer over the dividing line between the Date and FuelCost columns. When the pointer changes shape, click and drag to move the divider to the right.
· To change the PaymentType column:
· Right-click the label PaymentType to open the menu. 
· Select Column to open the Properties dialog. In the Label property, change PaymentType to Payment Type.
· Close the Properties dialog.
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Step 8: Add headings to groups
This step is easier to do if you have end-of-paragraph markers visible. Choose View > Non printing Characters to turn them on.
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Figure 34: Apply Styles list

 237) Make sure the cursor is in the upper left corner. If it is not, click in that corner to move it there.
 238) Press the Enter key to move the cursor down to the space between the Date field and the Breakfast field.
 239) Change the Apply Styles drop down list from Default to Heading 2.
 240) Use the spacebar to move the cursor to where you want the heading to start.
 241) Type the heading Meals.
 242) Use the spacebar to move the cursor to the center of snack area.
 243) Type the heading Snacks.
 244) Use the Enter key to move the cursor between the Supper control and the subform.
 245) Use the spacebar to move the cursor to the center of the subform.
 246) Change the Apply Styles drop down list from Default to Heading 2.
 247)  Type the heading Fuel Data.
· Tip
If you know how to use styles, you can open the Styles and Formatting window using F11. Right-clicking the Heading 2 paragraph style allows you to modify the appearance of all three headings. See Chapter 6 of the Writer Guide for details.
Step 9: Change the background of a form
The background for a form can be a color, or a graphic (picture). You can use any of the colors in the Color Table at Tools > Options > LibreOffice > Colors. If you know how to create custom colors, you can use them. You can also use a picture (graphic file) as the background.
To add a color to the form background:
 248) Right-click the form to open a context menu.
 249) Select Page.
 250) Make sure the Area tab has been selected. (It has a white background while the other tabs have a gray one..)
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Figure 35: Page style dialog

 251) Select Color from the drop-down list below Fill. (List contains None, Color, Gradient, Hatching, and Bitmap.)
 252) Scroll down through the colors and then Click Cyan 2.
 253) Click Apply to see the effects of adding the color. OR, click OK to close the dialog.
Create other form backgrounds:
 254) Perform steps 1-3 for adding color to the background.
 255) Select the type of background from the drop-down list below Fill.
 256) Scroll down to background you want from the list of backgrounds based upon your choice in 2) above.
· None: No background.
· Gradient: You can select increments between the colors to be automatic or you can select the amount of it. Remove the check to specify the amount.
· Hatching: Select the hatching design. Then if you want a background color, check Background color and select the color.
· Bitmap: Select the bitmap design that you want.
 257) Click Apply to see what your selection will look like in your form.
 258) Change if necessary.
 259) Click OK to select your final decision.
If you selected Bitmap and Sky from the Bitmap list, the form should look like Figure 36.
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· Tip
On the left side of the form window are four icons (Figure 37). You can use the Gallery as a source for backgrounds. Click it and click Backgrounds (Figure 38). Right-click the background you want to use. Select Insert as Background > Page.
[image: ]
[bookmark: Ref_Figure312_label_and_number]Figure 38: Open Gallery

· Note
You can create custom Gradients, Hatchings, and Bitmaps using the Draw component of LibreOffice. See the Draw Guide for information how to do this.
Step 10: Change the tab order
The Tab key moves the cursor from field to field. This is much easier to do than to click each field to enter data into it. It also permits us to group our expenses into areas before we begin entering data. For example, all of our meal receipts can be grouped together as can our snacks and also our fuel purchases.
[image: ]
Figure 39: Form Design toolbar with Activation Order icon circled

 260) Control+click the Date field.
 261) Select View > Toolbar > Form Design to open this toolbar.
 262) Click the Activation Order icon (circled).
 263) Rearrange the order of the fields in the Tab Order window.
1. Find the txtMPayment listing near the bottom of the list and click it.
v) Click the Move Up button until txtPayment is just below fmtMotel.
w) Use the same two steps to put the fields in the same order as in Figure 40. Click OK.
 264) Save and close the form.
 265) Save the database.
Creating forms and sub forms in Design View
This method requires using the Form Controls and Form Design toolbars extensively. These techniques are beyond the scope of this document. Instructions for creating forms using Design view will be described in the Database Guide.
[image: ]
[bookmark: Ref_Figure314_label_and_number]Figure 40: Tab order for the main form

Entering data in a form
Records are used to organize the data we enter into a form. They also organize the data we enter into a subform.
Different types of fields allow different methods of data entry. In many cases, more than one method can be used.
The first step to entering data in a form is to open it from the main database window (Figure 1).
 266) Click the Forms icon in the Database list.
 267) Find the form’s name in the Forms list (Vacations).
 268) Double-click the form’s name.
The quickest way to enter a date in the Date field is to click the arrow that opens the drop down calendar (Figure 41). Then click the day the you want. Then press the Tab key to go to the Odometer field.
[image: ]
[bookmark: Ref_Figure315_label_and_number]Figure 41: Calendar drop down

The Odometer, Tolls, and Motel fields are numeric fields. Enter values directly into them, or use the up and down arrows. When the value has been entered, use the Tab key to go to the next field.
1. Clicking the up arrow increases the value, and the down arrow decreases the value by one unit.
· These two arrows only change the numerals to the left of the decimal place.
· Numerals to the right of the decimal place must be changed by deleting them and typing the desired ones.
The Motel’s Payment field is a drop-down list. If, as in my case, all of the elements of the list start with different letters, typing the first letter selects the desired entry.
1. If two or more elements of the list have the same first letter, repeated typing of the first letter will cycle through these elements.
· When the selection is correct, use the Tab key to go to the Misc. field.
The rest of the fields of the main form are either numeric fields or drop-down lists until we reach the Misc. Notes field. It is a text field. Type anything you desire in this field just as you would any simple text editor.
· Note
Since the Tab key is used to move between fields, it can not be used in a text field. All spacing must be done by the spacebar. Furthermore in text fields, the Enter key acts only as a line break to move the cursor to the next line. While the Enter key will move between non-text fields, it will not do so from a text field. Use the Tab key instead.
If we did not have a subform for fuel data, pressing the Tab key in the last field would save all of the fields, clear them, and make the form ready to accept data on the second record.
Since we have a subform, using the Tab key places the cursor in the first Date field of the subform with the date automatically entered to match the Date field of the main form.
The FuelCost, FuelQuantity, and Odometer fields are numeric fields. The Payment field is a drop-down list. Enter the data just as you did in the main form, and use the Tab key to go to the next field.
When you use the Tab key to leave the Payment field, it goes to the Date field of the next line and automatically enters the date. Now you can enter your second set of fuel data for this day.
To move to another record when the form has a subform, click any of the fields of the main form. In this case, click the Date field of the main form. Then use the directional arrows at the bottom; from left to right: First Record, Previous Record, Next Record, and Last Record. To the right of these arrows is the New Record icon.
To create a new record while in last record of the main form, click either the Next Record icon or the New Record icon.
· Tip
The number in the Record box is the number of the record whose data is shown in the form.
If you know the number of the record you want, you can enter it into the record box and then press Enter to take you to that record.
Figure 42 is a record with data inserted in its fields.
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[bookmark: Ref_Figure316_label_and_number]Figure 42: Sample record of the Vacation form and sub form

Creating queries
Queries are used to get specific information from a database. Query results are special tables within the database.
To demonstrate the use of queries, we will use two different methods:
· Using our CD-Collection table, we will create a list of albums by a particular artist. We will do this using the Wizard. 
· The information we might want from the Fuel table includes what our fuel economy is. We will do this using Design View. (Queries that require calculations are best created with Design view.)
Using the Wizard to create a query
Queries created by the wizard provide a list or lists of information based upon what one wants to know. It is possible to obtain a single answer or multiple answers, depending upon the circumstances.
In the main database window (Figure 1), click the Queries icon in the Database section, then in the Tasks section, click Use Wizard to Create Query. The Query Wizard window opens (Figure 43). The information we want is what albums are by a certain musical group or individual (the album’s author). We can include when each album was bought.
· Note
When working with a query, more than one table can be used. Since different tables may contain the same field names, the format for naming fields in a query is Table name.field name, with a period (.) between the table name and the field name. For example, the Lunch field of the Vacation table used in a query has the name Vacation.Lunch.
Step 1: Select the fields
 269) Select the CD-Collection table from the drop down list of tables.
 270) Select fields from the CD-Collection table in the Available fields list.
1. Click Artist, and use the > button to move it to the Fields in the Query list.
y) Move the AlbumTitle and DatePurchased fields in the same manner.
z) Click Next.
· Tip
To change the order of the fields, select the field you want to move and click the up or down arrow to the right of the Fields in the Query list.
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[bookmark: Ref_Figure317_label_and_number]Figure 43: First page of the Query Wizard

Step 2: Select the sorting order
Up to four fields can be used to sort the information of our query. A little simple logic helps at this point. Which field is most important?
In our query, the artist is most important. The album title is less important, and the date purchased is of least importance. Of course, if we were interested in what music we bought on a given day, the date purchased would be the most important.
[image: ]
Figure 44: Sorting order page

 271) Click the first Sort by drop down list.
1. Click CD-Collection.Artist to select it.
ab) To list the artists in alphabetical order (a-z), select Ascending on the right.
 272) Click the second Sort by drop down list.
· Click CD-Collection.ArtistTitle. and select Ascending.
 273) Repeat this process for CD-Collection.DatePurchased.
 274) Steps 5 and 6: Group by and Grouping conditions
 275) Grouping is only used with summary queries. Because of the very limited applications of these two steps, only an example will be given of a summary query with grouping. Chapter 5, Queries, in the Base Guide includes examples and detailed instructions about summary queries with grouping.
 276) Click Next.
Step 3: Select the search conditions7: Aliases
The search conditions allow us to compare the name we entered with the names of the artist in our database and decide whether to include a particular artist in our query results or not.
1. is equal to: the same as
· is not equal to: not the same as
· is smaller than: comes before
· is greater than: comes after 
· is equal or less than: the same as or comes before
· is equal or greater than: the same as or comes after
· like: similar to in some way
· Note
These conditions apply to numbers, letters (using alphabetical order), and dates.
 277) Since we are only searching for one thing, we will use the default setting of Match all of the following.
 278) We are looking for a particular artist, so select CD-Collection. Artist in the Fields list and is equal to as the Condition.
 279) Type the name of the artist in the Value box. Click Next.
Step 4: Select type of query
We want simple information, so the default setting: Detailed query is what we want. 
· Click Next at the bottom of the window.
· Note
Since we have a simple query, the Grouping and Grouping conditions are not needed. Steps 5 and 6 of the wizard are skipped in our query.
Step 7: Assign aliases if desired
The fields, AlbumTitle and DatePurchased, have names made up of two words.  Instead, aliases can be made containing two words each (Album Title and Date Purchased, respectively).
 280) Change AlbumTitle to Album Title.
 281) Change DatePurchased to Date Purchased.
 282) Alias
 283) A name given to a field, table, or expression that can be used instead of a name it already has.
 284) In everyday life, people are given nicknames. Sometimes they are a shorter version of the given name, and sometimes they are quite different.
 285) An alias is similar to a nickname. For example, the name of suggested fields in the table wizard are often two or more words that have been combined into one word. At this point you may wish to create aliases that have these names divided into their original words or changed to something more meaningful.
 286) Summary queries are a good place to use aliases. For example, we want the total appraised value of our furnishings. The name for this, without any changes, is SUM(“AppraisedValue”). We could use the alias: Total Appraised Value. More complex summary queries can have names that are rather involved, and an alias is recommended.
 287) Click Next.
Step 8: Overview
 288) Make sure that the query conditions listed in the Overview list are the ones you wanted. (There are only two that you need to check.)
 289) If something is wrong, use the Back button to move to the step that contains the error.
 290) Then use the Next button to move to step 8.
 291) Error: Reference source not found shows the overview of a query. It contains three parts: naming the query, what will be done next after the query is created, and an overview of the selections made using the wizard.
 292) You should enter what you want to call the query in the Name of the query text box. The suggested name combines Query with the name of the table used in the query using an underline.
 293) Do not use the name of the table as the name of the query as well; doing so will cause an error message. Because tables and queries can be used when creating queries, forms, and reports, a name for a table or query can be used only one time to prevent selecting the wrong one if duplicate names are allowed.
 294) [image: ]Figure 45: Overview of a query

 295) You have two choices after closing the query wizard: display the query results, or modify the query. The first choice runs the query to give you an output. The second choice opens the Query Design dialog. Because the second choice leads to something that is beyond the discussion of this chapter, do not change the default setting (Display Query).
 296) Like the naming of the query, the overview list is rather important. It contains three pieces of information that we need to verify matches what we originally wanted in the query.
 297) There are four fields in the query, all from the Household Inventory table: Item, AppraisedValue, PlacePurchased, and PurchasePrice. These have been given the aliases Item, Appraised Value, Place Purchased, and Purchase Price respectively.
 298) Verification: Household Inventory is the correct table, the listed fields are the correct fields, and the alias are also correct.
 299) The field, Appraised Value, is the field that will be used for sorting, and the direction of the sort is ascending (from the least value to the greatest). (The alias, Appraised Value, is used in place of the field name, AppraisedValue.)
 300) Verification: This is the correct field, and the sorting is in the correct direction.
 301) The search condition applies only to Appraised Value and it restricts its values to $50 or more. Any items worth less than or equal to $50 will not be shown when the query is run.
 302) Verification: This is the correct field, and the search condition is also correct.
 303) Verification: Since none of the fields are manipulated, we have a detailed query. This is correct.
 304) If this were a query that we wanted to use, we would click the Finish button. The query wizard would close, and a Table Data View dialog would open with the query output.
 305) Name the query (suggestion: Query_Artists). 
 306) Detailed query example
 307) To the right of this are two choices. Select Display Query. 
 308) Click Finish.
We want a listing of our inventory containing the following information about each item: the name of each item, its appraised value, the date purchased, and the place purchased. Furthermore, we want the list to contain only those items whose appraised value is greater than $50. We also want the information to be sorted using the appraised values of the items.
Create a query using the wizard by following the instructions in the eight steps above. Name the query: Query_Household Inventory. When you get to step 8 of the wizard, it should look like the figure below. Try to do all of the eight steps before referring to this figure to compare your work with it.
When you click the Finish button, the query wizard closes and the Query_Household Inventory-Inventory-LibreOffice Base: Table Data View dialog opens with the output for the query. (See Figure Error: Reference source not found.) All of the items have an appraised value greater than $50. The WiFi modem is not part of the output because its appraised value is less than $50. If an item in the inventory had an appraised value of $50, it would not be in the output either.
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Figure 46: The Table Data View for this query

[bookmark: __RefHeading__114014_136524979211]Using the Design View to create a query
Summary query example
Creating a query using Design View is not as difficult as it may first seem. It may take multiple steps, but each step is fairly simple.
What fuel economy is our vehicle getting (miles per gallon in the USA)? This question requires creating two queries, with the first query used as part of the second query.
For this example query, what you want to know is this: What is the total purchase price and appraised price for the contents of each room in our inventory? The output should be in alphabetical order by Room. Finally, only the totals that exceed $500 in a given room should be shown.
This requires grouping the values for these two fields by room. Then the SUM function is applied to the values of these two fields for each group.
Step 1: Open the first query in Design ViewField Selection.
· Click Create Query in Design View.
Step 2: Add tables
 309) The table will be Household Inventory.
 310) Select these fields from it: PurchasePrice and AppraisedValue.
 311) Click Fuel to highlight itNext.
 312) Click Add.
 313) Click Close.
[image: ]
Figure 47: Add Tables or Query dialog

· Tip
Move the cursor over the bottom edge of the fuel table (Figure 48) and drag the edge to make it longer and easier to see all of the fields in the table.
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[bookmark: Ref_Figure320_label_and_number]Figure 48: Fuel table in query

Step 3: Add fields to the table at the bottom
 314) Step 2: Sort Order.
 315) Double-click the FuelID field in the Fuel table.
 316) Select the field, Room, as the one to sort by.
 317) Double-click the Odometer field.
 318) Select Ascending as the direction of the sort.
 319) Double-click the FuelQuantity field.
The table at the bottom of the query window should now have three columns.
[image: ]Figure 49: Query table

Step 4: Set the criterion for the query
We want the query’s FuelID to begin with the numeral 1.
 320) Type >0 in the Criterion cell under FuelID in the query table.
 321) Click the Run Query icon in the Query Design toolbar. (Circled in Red.)
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[bookmark: Ref_Figure322_label_and_number]Figure 50: Query Design toolbar

Figure 51 contains the Fuel table with my entries. The query results based upon the Fuel table are in Figure 52.
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[bookmark: Ref_Figure323_label_and_number]Figure 51: Fuel table
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[bookmark: Ref_Figure324_label_and_number]Figure 52: Query of Fuel table

Step 5: Save and close the query
Since this query contains the final odometer reading for our calculations, name it End-Reading when saving it. Then close the query. Now click the Save icon in the main database window.
Step 6: Create the query to calculate the fuel economy
 322) Click Create Query in Design View to open a new query.
 323) Add the Fuel table to the query just as you did in step 2:  But, do not close the Add Tables window.
 324) Add the End-Reading query to this query.
1. Click Queries to get the list of queries in the database (Figure 53).
ad) Click End-ReadingNext.
ae) Click Add, and then click Close.
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[bookmark: Ref_Figure325_label_and_number]Figure 53: Selecting queries to add to another query

Step 7: Add fields to the table at the bottom of the query
We are going to calculate the fuel economy. To do this we need the FuelQuantity and distance traveled. Since the FuelQuantity we want to use is the final odometer reading, we will use the End-Reading query to get it. We will also use the Odometer field from both the Fuel table and End-Reading queries.
[image: ]
Figure 54: Tables in this query

 325) Double-click FuelQuantity in the End-Reading query.
 326) Double-click Odometer in the End-Reading query.
 327) Double-click Odometer in the Fuel table.
[image: ]
Figure 55: Added fields to the query

Step 8: Enter the FuelID difference field
We want the difference between the FuelID value of the Fuel table and FuelID value of the End-Reading query to equal one (1).
 328) Type "End-Reading"."FuelID" - "Fuel"."FuelID" in the field to the right of the Odometer field of the Fuel Table. (Figure 56)
 329) Type ='1'  in the Criterion cell of this column.
 330) Leave the Visible cell of this column unchecked.
 331) Calculate the distance traveled:
· Type in the Field cell.(Figure 57)
"End-Reading"."Odometer" - "Fuel"."Odometer"
· In the Alias row, type Distance.
· Type >'0' in the Criterion cell.
 332) Calculate fuel economy: Type 
("End-Reading"."Odometer" - "Fuel"."Odometer")/"End-Reading"."FuelQuantity" 
in the next column to the right of the word Field. (Figure 58)
 333) Type Fuel Economy as the alias.
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[bookmark: Ref_Figure328_label_and_number]Figure 56: Typing in calculation of fields
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[bookmark: Ref_Figure329_label_and_number]Figure 57: Field for distance traveled calculations
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[bookmark: Ref_Figure330_label_and_number]Figure 58: Fuel economy calculation field

· Note
When entering fields for these calculations, you must follow this format: table or query name followed by a period followed by the field name. For hyphenated or multiple-word names (table or query), use double quotes around the table or query name. The query will then add the rest of the double quotes as in Figure 58.
Use the arithmetical symbol between the two. More than one calculation can be done by using parentheses to group the arithmetical operations. 
Step 9: Run the query and make some modification
After we run the query to make sure it works correctly, we will hide all of the fields that we do not need.
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[bookmark: Ref_Figure331_label_and_number]Figure 59: Result of running the fuel economy query

 334) Click the Run Query icon in the Design Query toolbar (Figure 50). The results are in Figure 59.
Two of the column headers are identical. By giving these two headers different aliases, we can distinguish them.
 335) Add Aliases:
Type the aliases as they are listed in Figure 60.
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[bookmark: Ref_Figure332_label_and_number]Figure 60: Query table with aliases added

 336) Run the query again. The results are in Figure 61.
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[bookmark: Ref_Figure333_label_and_number]Figure 61: Query run with aliases

Step 10: Close, save, and name the query
My suggestion for a name is Fuel Economy.
 337) Click the Save icon.
 338) Name the query.
 339) Close the query.
 340) Save the database file.
There are obviously other calculations that can be made in this query such as cost per distance traveled and how much of the cost belongs to each of the payment types.
· Note
To fully use queries requires a knowledge of set operations (unions, intersections, and, or, complements, or any combinations of these). Having a copy of the HSQLDB User Guide, available from , is also extremely useful.
Creating reports
Reports provide information found in the database arranged in a useful way. In this respect, they are similar to queries. They are different in that they are designed to be distributed to people. Queries are only designed to answer a question about the database. Reports are generated from the database’s tables, views, or queries.
All reports are based upon a single table, view, or query, so you need first to decide what fields you want to use in the report. If you want to use fields from different tables, you must first combine these fields in a single query or view. Then you can create a report from this.
For example, a report on vacation expenses includes both fuel costs and meal costs. These values are contained in fields of two different tables: Vacations and Fuel. So this report requires you to create a query or view.
· Caution
Dynamic reports update only the data that is changed or added to a table or query. They do not show any modifications made to the table or query itself. For example, after creating the report below, open the fuel economy query created in the previous section. For the "End-Reading".”Odometer” – “Fuel.”Odometer” column, change the number 1 to the number 3. The report will be identical before and after you make the change. But if you add more data to the query and run the report again, it will contain the new data. However, all data will be based upon "End-Reading".”Odometer” – “Fuel.”Odometer”  having the value 1. No data will be present in the report for which "End-Reading".”Odometer” – “Fuel.”Odometer”  has the value 3.
Creating a report: Example
We will create a report on vacation expenses. Certain questions need to be asked before creating the report.
1. What information do we want in the report?
· How do we want the information arranged?
· What fields are required to provide this information?
· Will a query or view have to be created because these fields are in different tables?
· Are any calculations required in the data before being added to the report?
The expenses for our vacation are motel, tolls, miscellaneous, breakfast, lunch, supper, snacks, and fuel. One possible report could list the totals of each of these expense groups. Another could list the expense totals for each day of the vacation. A third could list the totals for each expense group for each type of payment. (This would let us know where the money came from to pay the expenses.) Once you create a query to do any one of these, you can create a report based upon the query.
We will create two reports, one listing the expenses each day (other than fuel) and the second listing fuel statistics. The fields we need for the first report from the Vacations table are: Date, Motel, Toll, Breakfast, Lunch, Supper, SnackCost, and Miscellaneous. This report only requires the Vacation table. Had the report listed the total expenses for each of these fields, we would have to create a query to provide us with these totals which is beyond the scope of this chapter.
The second report involves the Fuel table. Since this table includes fuel purchases at times other than during the vacation, we need to create a query that contains only the fuel purchased during vacation periods.
Report wizard vs Report Design View
 341) When you open the Report Wizard, the Report Builder also opens. As you make your selections in the wizard, these appear in layout in the Report Builder. When you have finished making your selections, you save the report, name it and then close it.
 342) When using Design View to create a report, you open the Report Builder to design the layout of it. (There is only one layout available when the wizard is used.)
Vacations table report
To create a new report.
 343) Click the Reports icon in the Database list in the Automobile – LibreOffice Base window (Figure 1).
 344) In the Tasks list, click Use Wizard to Create Report. The Report Wizard and then the Report Builder opens.
Step 1: Field selection
 345) Select Table: Vacations in the Tables or Queries drop down list.
 346) Use the > to move these fields from the Available fields list to the Fields in report list: Date, Motel, Tolls, Miscellaneous, Breakfast, Lunch, Supper, and SnackCost. Click Next.
	Tip
	When you create a summary query with grouping of the results, enter the field by which the grouping is done in Step 2 instead of Step 5.
When the summary query also contains a restriction on the values for each group, use Step 3 to do this instead of Step 6.


[image: ]
Figure 62: Adding fields to a report

Step 2: Labeling fields3: Search Condition.
Change any field labels you wish. We will shorten Miscellaneous to Misc. and make SnackCost into two words.
Select Room as the Fields.
38) Select is greater than as the Condition.
39) Enter 500 as the Value.
40) Since there is only one condition, Match all of the following (Default) is appropriate.
41) Click Next.
42) Step 4: Detailed or Summary.
[image: ]
Figure 63: Giving aliases to fields

 347) Select the Summary query (Shows only results of aggregate functions.)
 348) Aggregate functions
 a) Click the arrows at the right end of its drop-down list.
 b) From this list, select get the sum of.
 c) From the Fields dropdown list, select Household Inventory.PurchasePrice
 d) Click the plus (+) button to reveal a second row of drop-down lists.
 e) From the Aggregate functions drop-down list, select get the sum of.
 f) From the Fields dropdown list, select Household Inventory.AppraisedValue.
 349) Click Next.
 350) Steps 5 and 6. (These are not used by the wizard, which uses Steps 2 and 3 instead.)
 351) Click Next in Step 5 and then in Step 6.
 352) Step 7: Aliases.
 353) Shorten Miscellaneous to Misc.
 354) Change PurchasePrice to Purchase Price.
 355) Add a space to separate SnackCost into Snack Cost.
 356) Change AppraisedValue to Appraised Value.
 357) Click Next.
Step 3: Grouping
Since we are grouping by the date, use the > button to move the Date field to the Grouping list. Click Next.
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Figure 64: Selecting fields for grouping data

Step 4: Sort options8: Overview.
We do not want to do any additional sorting.
· Name the query Household Inventory Summary.
· Display the query after closing the query (Default selection).
· Check the Overview:
· The table used is Household Inventory. (Correct)
· The fields used are Room, PurchasePrice, and AppraisedValue. (Correct)
· The Sorting order is Room. (This is really the field by which the data will be grouped because we are creating a summary query.)
· The Searching conditions is Room is greater than 500. (Correct) (This is really the grouping condition because of the limitations of the wizard.)
· To close the wizard and display the query in a Table Data View dialog, click Finish.
· [image: ]
· Reports: use wizard to create reports
· Reports present information found in the database in a useful way. In this respect they are similar to queries. Reports are generated from the database’s tables or queries. They can contain all of the fields of the table or query or just a selected group of fields. Since the data that concerns us is contained in a query, we will use that.
· Reports can be static or dynamic. Static reports contain the data from the selected fields at the time the report was created. Dynamic reports can be updated to show the latest data. If you are sure that data for your report does not change with time, creating a static report is a good choice. A report of your inventory’s total appraised value for the year 2008 is an example of a static report. (It is very unlikely that the data for 2008 will change.) But a similar report for your insurance agent for updating your policy needs to be a dynamic report. This report needs to contain any purchases made since the last report was made. When you purchase or replace an item, this report can tell you whether you even need to contact your agent or not.
· The report that we will create, is based upon Query_Household Inventory. We will look for all items listed in this query.
· Follow these steps to create a report.
· Step 1: Open the Report Wizard. (See Figure Error: Reference source not found.)
· In the main database window, click the Report icon in the Database section.
· In the Task section, click Use Wizard to Create Report. (The Report Wizard opens with the Report Builder opening in the background.)
	· Tip
	· As you go through the steps of the Report Wizard, use the mouse to move it so that you can see what effects your selections in the wizard have on the Report Builder.


· Under Tables or queries, a drop-down list contains the tables and queries you have created.
· [image: ]
1
Move available fields to the right
3
Change order of report fields
2
Move report fields to the left


Figure 65: Report Wizard field selection

· Step 2: Select the table and its field for the report.
· Select Query_Household Inventory from the Tables or queries drop-down list.
· Move the list of Available fields to the list of Fields in report using the double right arrow button.
· If you want to change the order of the fields in the Fields in report list, click the field you want to move up or down in this list. Click one of the arrows (#3 above) to move the field up or down to where you want it.
· The fields in your report should match the ones in the figure below.
· [image: ]
· Step 3: Labeling fields.
· Here you can give aliases to one or more fields. The report suggests using the name of the fields of the query. If you have added the aliases you wanted when creating the query, you will not have to make any changes in this step. If, however, you want to make some changes, now is the time to make them.
· Review the suggested labels for the fields. Change them if you think your name is better.
· Remember to use the vertical scrollbar if all of the fields are not visible, and then review the rest of the suggested labels.
· We added aliases for these fields in the query earlier: AppraisedValue, DatePurchased, and PurchasePrice. So, the report will use the aliases of the query instead: Appraised Value, Date Purchased, and Purchase Price respectively.
· Click Next.
Step 5: Choose layout4: Grouping.
[image: ]
Use Columnar, three columns for the layout. 
 358) Click Date Purchased in the Fields list.
 359) Select Columnar, three columns for the Layout of data.
 360) Click the right arrow button to move it to the Groupings list.
 361) Make sure your lists match those in the figure above. If a field is in the wrong list, select it and use the right or left arrow button to move it the correct list.
 362) Layout of headers and footers has no possible selections.
 363) Step 5: Sort options.
 364) Select Landscape as the Orientation for the page layout.
 365) [image: ]
 366) By selecting how the report should group the data, we have already selected the field, Date Purchased, as the first sort option. We want the field’s sorting order to be ascending. No more fields will be used in the sorting.
 367) If you want to sort by more fields of the report, do so now.
 a) Click the drop-down list below Then by to open the list.
 b) Select the field you want to use to sort the report by. This sorting will be in addition to the sorting by the Date Purchased field.
 368) Click Next.
Step 5: Choose layout.
[image: ]
Figure 66: Report Builder template determined by the Report Wizard

Step 6: Create report
 369) Page orientation can be either Landscape or Portrait. Which one you use depends upon the number of fields contained in the report. For a large number of fields in the report, use the Landscape orientation. For a smaller number of fields, Portrait will probably be the best selection.
 370) To see each of the data layout choices, move the Report Wizard so you can see the layout in the Report Builder. Then select the layouts one at a time while observing what happens in the Report Builder.
 371) Select the Layout of data that meets your needs. For this example, select Columnar, three columns.
 372) Label the report: Vacation Expenses.
 373) Select the Orientation for your report. For this example, select Portrait.
 374) Select Dynamic report.
 375) Select Create report now.
 376) Click FinishNext.
The report (Figure 67) has been created, but it needs some editing. The date could be formatted better, and all the numbers need to be formatted as currency. It could use a heading that includes its name, its author, and the date it was prepared. If the report had more than one page, the page numbers could be put in a footer of each page, perhaps including the total number of pages. But to do these things, you must use Report Builder.
[image: ]
[bookmark: Ref_Figure338_label_and_number]Figure 67: Report without modifications

Report Builder: another way to create reports
Step 6: Create report.
With Report Builder, you can create complex and stylish database reports. You can define group and page headers, group and page footers, and calculation fields. Report Builder is installed with LibreOffice.
When we used the Report Wizard, we created a template in Report Builder for our report. If we edit our report, we open Report Builder with this template. By modifying the template, we also modify the report. For example, we can change the Date field’s format, and it will change the format of all the dates contained in that field in the above report. Similarly, we can change the field formatting of any of the other fields and change the format everywhere that field appears in the report.
Report Builder can also create reports by itself. To do this, click Create Report in Design View. For instructions on how to use the Report Builder, see Chapter 6, Reports, in the Base Handbook.
Accessing other data sources
LibreOffice allows data sources to be accessed and then linked into LibreOffice documents. For example, a mail merge links an external document containing a list of names and addresses into a letter, with one copy of the letter being generated for each entry.
To access a data source that is not a *.odb file:
 377) File > New > Database opens the Database Wizard window.
 378) Select Connect to an existing database. Click the arrow next to the Database type field and select the database type from the drop down list. Click Next.
 379) Click Browse and select the database. Click Next.
 380) Accept the default settings: Register the database for me, and Open the database for editing. Click Finish. Name and save the database in the location of your choice.
· Caution
One of the choices available when you select Connect to an existing database is LDAP Address Book. Beginning with LibreOffice 4.0.0, this option no longer works.
Accessing a spreadsheet as a data source
Accessing a spreadsheet is similar to accessing other databases:
 381) Choose File > New > Database.
 382) Select Connect to an existing database. Select Spreadsheet as the Database type.
 383) Click Browse to locate the spreadsheet you want to access. If the spreadsheet is password protected, check the Password required box. Click Next.
 384) If the spreadsheet requires a user’s name, enter it. If a password is also required, check its box. Click Next.
· Note
Using this method of accessing a spreadsheet, you cannot change anything in the spreadsheet. You can only view the contents of the spreadsheet, run queries, and create reports based upon the data already entered into the spreadsheet.
All changes in a spreadsheet must be made in the spreadsheet itself, using Calc. After modifying the spreadsheet and saving it, you will see the changes in the database. If you create and save an additional sheet in your spreadsheet, the database will have a new table the next time you access it.
Registering *.odb databases
Databases created by LibreOffice are in the *.odb (OpenDocument Base) format. Other programs can also produce databases in this format. Registering a *.odb database is simple: 
 385) Choose Tools > Options > LibreOffice Base > Databases.
 386) Under Registered databases, click New.
 387) Browse to where the database is located.
 388) Make sure the registered name is correct.
 389) Click OK.
· Note
Sometimes when updating LibreOffice to a newer version, your list of registered database files disappears. When that happens, you need to use these steps to register your database files with your latest version of LibreOffice.
Using data sources in LibreOffice
Having registered the data source, whether a spreadsheet, text document, external database or other accepted data source, you can use it in other LibreOffice components including Writer and Calc.
Viewing data sources
Open a document in Writer or Calc. To view the data sources available, press F4 or select View > Data Sources from the pull-down menu. This brings up a list of registered databases, which will include Bibliography and any other database registered, such as the Automobile database created earlier in this chapter.
To view each database, click on the arrow to the left of the database’s name (see Figure 68). This brings up Queries and Tables. Click on the [image: ] next to Tables to view the individual tables created. Now click on a table to see all the records held in it.
[image: ]
[bookmark: Ref_Figure339_label_and_number]Figure 68: Databases

Editing data sources
Some data sources (but not spreadsheets) can be edited in the Data View window. A record can be edited, added, or deleted.
View a table’s data
If you click on a table its rows and columns of data appear on the right side of the Data Source window. Editing this data requires only a click in the cell whose data should be changed, change the data, and click in the row above or below it to save the new data.
Beneath the records are five tiny buttons. The first four move the cursor to the beginning, to the left, to the right, and to the end respectively. The fifth button, with a small star, inserts a new record.
[image: ]
Figure 69: View Data Sources navigation buttons

To delete a record, right-click on the gray box to the left of a row to highlight the entire row, and select Delete Rows to remove the selected row.
[image: ]
Figure 70: Deleting a row in the Data View window

Launching Base to work on data sources
You can launch LibreOffice Base at any time from the Data Source window. Just right-click on a database or its Tables or Queries icons and select Edit Database File. Once in Base, you can edit, add, and delete tables, queries, forms, and reports.
Using data sources in Writer and Calc
Data can be placed into Writer and Calc documents from the tables in the data source window. In Writer, values from individual fields can be inserted. Or a complete table can be created in the Writer document. One common way to use a data source is to perform a mail merge.
[image: ]
Figure 71: Toolbar for the Data Sources window

· Tip
Choosing Tools > Mail Merge Wizard or clicking on the Mail Merge icon (circled in red) in the Data Sources window launches the Mail Merge wizard which steps you through creating a mail merge document. See Chapter 11 in the Writer Guide.
Writer documents
To insert a field from a table opened in the data source window into a Writer document, click on the field name (the gray square at the top of the field list) and, with the left mouse button held down, drag the field onto the document. In a Writer document, it will appear as <FIELD> (where FIELD is the name of the field you dragged).
For example, to enter the cost of meals and who paid for them on a certain date of a vacation:
 390) Open the list of data sources (F4) and select the Vacations table in the Automobile database.
 391) Use this sentence: “On (date), our breakfast cost (amount) paid by (name), our lunch cost (amount) paid by (name), and our supper cost (amount) paid by (name).” But only type 
“On, our breakfast cost paid by , our lunch cost paid by , and our supper cost paid by .”
 392) To replace (date), click the field name Date in the data source window and drag it to the right of the word On. The result: On <Date>. If you have Field shadings turned on (View > Field shading), <Date> has a gray background. Otherwise it does not.
 393) To replace first (amount), click the Breakfast field name and drag it to the right of our breakfast cost. Make sure you have the proper spacing between the field names and the words before and after them. Result: breakfast cost <Breakfast>.
 394) To replace the first (name), click the Bpayment field name and drag it to the right of paid by. Result: paid by <Bpayment>.
 395) In the same way, fill in the rest of the fields in the sentence.
· Use <Lunch> and <LPayment> for the second set of (amount) and (name) in the sentence.
· Use <Supper> and <SPayment> for the third set of (amount) and (name) in the sentence.
 396) Final result: On <Date>, our breakfast cost <Breakfast> paid by <BPayment>, our lunch cost <Lunch> paid by <LPayment>, and our supper cost <Supper> paid by <SPayment>.
 397) Add data to the fields of the sentence:
· Click the gray box to the left of the row of data you want to add. That row should be highlighted like the second row of Figure 72.
· Click the Data to Fields icon (circled). This should fill the fields with the data from the row you chose.
· Click another row and then click this icon again. The data in the sentence changes to this selected row of data.
· Save the document if you want to use it as an example later.
[image: ]
[bookmark: Ref_Figure343_number_only]Figure 72: Selected row in data source window

Adding data in table format is a little easier and takes perhaps fewer steps. Some of the steps will be quite similar.
 398) Navigate to the place you want to place the table and click the location.
 399) Control+Click the gray box to the left of each row of the data source that you want to be a row in your table if the rows are not consecutive. To select consecutive rows, click the gray box to the left of the top desired row and Shift+click the bottom desired row.
 400) Click the Data to text icon to open the Insert Database Columns dialog (Figure 73). (The Data to text icon is to the left of the Data to Fields icon in Figure 72.)
[image: ]
[bookmark: Ref_Figure344_number_only]Figure 73: Insert Database Columns dialog

 401) Move the fields you want in your table from the Database Columns list to the Table column(s) list.
· To place the fields in the order you select, click the field and use the single arrow to move the fields in the order you desire. You can also limit the fields you use to less than all of the fields available.
· If you want to use all of the fields, use the double arrow pointing to the right to move all of them at one time. The order of the fields in the table you create will be the same as in the data source table.
· To remove a single field from the Table Column(s) list, click the field and use the single arrow pointing to the left.
 402) To start over, click the double arrow pointing to the left.
 403) Select the settings for your table. Use the default settings as in Figure 73.
 404) Name the report. The suggestion given is Query_Household Inventory. This is the same name as the query we used to create this report. Change Query_Household Inventory to Report_Household Inventory.
 405) You can create two types of report: static or dynamic. A static report is a Writer document which can be modified like any text document, but any changes in the data in the underlying query will not change the report. A dynamic report is much more flexible. Changes in the data of the database will change the report the next time the report is run.
 406) The Report Builder can also be used to modify the fields of the report. For example, the date format for the Date Purchased can be changed and the Report saved. The next time the Report is run, the data in this field will have the changed format. In a static report, you would have to change the date format for each place this field appears in the report.
 407) The final selection involves what should happen next. Selecting Modify report layout will open the Report Builder so that the report can be edited. This is beyond the scope of this chapter. (See Chapter 6 for how to use the Report Builder.) So, use the Default choice, Create report now.
 408) Click OK. Save the documentFinish.
Calc spreadsheets
There are two ways to transfer data into a Calc spreadsheet. One enters the data into the spreadsheet cells. The other creates complete new records in the spreadsheet. While you can directly access the data inserted into the spreadsheet cells, new records created in the spreadsheet are read-only.
Entering data directly to the spreadsheet cells uses the Data to Text icon as when making a table in a Writer document. But there are certain differences.
The steps are straightforward.
 409) Click the cell of the spreadsheet which you want to be the top left cell of your data, including the column names. 
 410) Use F4 to open the database source window and select the table whose data you want to use. 
 411) Select the rows of data you want to add to the spreadsheet:
· Click the gray box to the left of the row you want to select if only selecting one row. That row is highlighted.
· To select multiple rows, hold down the Control key while clicking the gray box of the rows you need. Those rows are highlighted.
· To select all the rows, click the gray box in the upper left corner. All rows are highlighted.
 412) Click the Data to text icon to insert the data into the spreadsheet cells.
 413) Save the spreadsheet.
Adding records to a spreadsheet is fairly easy. You need to have the Data Source window open, your spreadsheet open, and the table you want to use selected.
 414) Click the gray box containing the field name for the table’s ID field.
 415) Drop and drag the gray box for the table’s ID field to where you want the record to appear in the spreadsheet.
 416) Repeat until you have moved all of the fields you need to where you want them.
 417) Name and save the spreadsheet.
 418) Click a row of the table in the Data Source window.
 419) Drag the data in the ID field in the selected row onto the ID field in the spreadsheet. The Save icon should activate.
 420)  Click the Edit File button to make the spreadsheet read-only. Click Save when asked if you want to save the file.
The Data Sources window goes blank, the fields in the spreadsheet are populated with data from the row you selected, and the Form Navigation toolbar appears at the bottom of the spreadsheet.
 421) Click the arrows on the Form Navigation toolbar to view the different records of the table. (The arrows are circled in red.) The number in the box changes when you change the record number by clicking an arrow. The data in the fields changes correspondingly to the data for that particular record number.
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Figure 74: Navigation arrows of a form

Documentation for LibreOffice is available at http://www.libreoffice.org/get-help/documentation
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Figure Error: Reference source not found shows that sometimes the report needs to be edited once created. The layout did not allow enough room for the word Refrigerator, and the space allowed for the field label Item is wider than it needs to be. The data format might be changed as well, and this might require a change in the length of this field. The fields containing currency amounts should be modified to the currency being used in the Inventory database.
Mixing Base with the rest of LibreOffice
Base can be used alone or be used with other components of LibreOffice. Your choice depends on what you want to do with the information in the database.
This section mentions a few ways in which Base can be used with the other components of LibreOffice. Chapter 7, Exchanging Data, in the Base Guide, as well as the individual guides for the other components of LibreOffice, contain instructions how to do this.
Writer
One very common database is the address book. Base will connect to several of them. Using Writer with Base, you can print envelopes using the postal addresses in the address book and you can send an email to several people in the address book at one time. This process is called mail merge. It is explained in Chapter 11, Mail Merge, of the Writer Guide.
To include in a Writer document data that exists in one of our databases. we could look up the data and type it into the document, but we might make a mistake in typing. By using Base with Writer, we can place a field linked to the desired data in the document. Doing it this way guarantees the data shown in the document will be as accurate as the data in the corresponding database. This is explained in Chapter 14, Working with Fields, of the Writer Guide.
Using Writer, tables in text documents can be copied into a table in a database. A new table can be created in the database including the data in the text document table. Or, a new table can be created in the database without any data. Or, if the data in the table is arranged properly, this data can be added to an existing table of a database. This is discussed in Chapter 7 of the Base Guide.
Calc
Base and Calc work together well. Using F4 or View Data Sources in Calc opens the Data window. Data and column names can be copied from the data source to the spreadsheet that is open in Calc. Data can also be copied from the spreadsheet to the data source. These methods are discussed in the Calc Guide and in Chapter 7 of the Base Guide.
Once the data has been copied from the data source to the spreadsheet, you can apply all of the available Calc functions to the data, including creating charts from the data. This is also discussed in the Calc Guide and in Chapter 7 of the Base Guide.
There are different ways to use the data in a spreadsheet as a data source. One way is to create a Base file to connect to the spreadsheet. A second way is to save the spreadsheet using the .dbf file format. This is the file format used by dBase. Base will open this file format. This is discussed in Chapter 7 of the Base Guide.
Impress
Base and Impress are not directly used together, but they can be used together in an indirect way. Calc spreadsheets can be inserted into slides. So when you want to use data from a database in a slide, you first copy the data into a spreadsheet and then insert 


this spreadsheet into the slide. This is discussed in Chapter 7, Inserting Spreadsheets, Charts, and Other Objects, in the Impress Guide.
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Using Base with other data sources
Base can be used with a variety of data sources, including Oracle, Groupwise, Evolution (LDAP and Local), KDE Address Book, Thunderbird/Icedove Address Book, Spreadsheet, dBASE, Text, MySQL, and Postgresql. Also included are the data sources which Base can access using JDBC (java database connectivity or ODBC (open database connectivity).
You can connect Base directly to some of these data sources (text files and spreadsheets) by making only a few selections in the Base Wizard. Chapter 7 of the Base Guide contains instructions for how to work with these data sources.
Base requires a special driver to connect to some data sources. PostgreSQL, MySQL, JDBC, and Oracle JDBC are examples of these data sources. Chapter 7 of the Base Guide discusses how to connect to these database sources as well as how to work with them.
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Getting Started with Math


LibreOffice’s Formula (Equation)'s Equation Editor


Introduction
LibreOfficeMath is a formula editor you can use to create or edit formulas (equations), in a symbolic form, within LibreOffice documents or as standalone objects. Example formulas are shown below. However, if you want to evaluate numeric values using formulas, then refer to the Calc Guide for more information as Math does not carry out any actual calculation.

[bookmark: __RefHeading__71693_1611026022111][bookmark: __RefHeading__71693_1611026022111]
92 | Getting Started with LibreOffice 5.0
	Appendix B   Open Source, Open Standards, OpenDocument | 91
What is Math?
0 | Getting Started with LibreOffice 5.0
Index | 0
Math is LibreOffice’s component for writing mathematical and chemical equations. It is most commonly used as an equation editor for text documents, but it can also be used with other types of documents or stand-alone. When used inside Writer, the equation is treated as an object inside the text document.
	Note
	The equation editor is for writing equations in symbolic form, as in equation Error: Reference source not found, below. If you want to evaluate a numeric value, see the Calc Guide.



	
	(1)


oror
The Formula Editor in Math uses a markup language to represent formulas. This markup language is designed to be easily read wherever possible, for example, a over b produces the fractionwhen used in a formula.
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Using the Formula Editor, you You can create a formulaan equation (formula) as a separate document or file for a formula library, or insert formulas directly insert it into a document using LibreOffice Writer, Calc, Impress, or Drawin Writer or another component of LibreOffice.
Formulas as separate documents or files
Creating an equation as a separate document
[image: ]
[bookmark: Ref_Figure346_label_and_number]Figure 75: An empty formula document in Math

To create a formulaan equation as a separate document or file, use one of the following methods to open an empty formula document in LibreOffice Math (Figure 75), open the Math component of LibreOffice using one of these methods:
· On the Menu bar, choose File > New > Formula.
· On the menu bar, go to File > New > Formula.
· On the Standard Toolbar, click the triangle to the right of the New icon and choose Formula.
· From the Start Center, click Math Formula.
· On the Standard toolbar, click the triangle to the right of the New icon [image: ] and select Formula from the context menu.
· In Math, use the keyboard shortcut Ctrl+N.
An empty Math document opens (see Error: Reference source not found).
As you enter the markup language in the Formula Editor, the formula will appear in the Preview window during and after input of the markup language. The Elements window to the left of the Preview window may also appear, if it has been selected in View on the menu bar. For more information on creating formulas, see “Creating formulas” on page 60.
Formulas in LibreOffice documents
To insert a formula into a LibreOffice document, open the document in Writer, Calc, Draw, or Impress. The LibreOffice module you are using affects how you position the cursor to insert the formula.
· In Writer, click in the paragraph where you want to insert the formula.
· In Calc, click in the spreadsheet cell where you want to insert the formula.
· In Draw and Impress, the formula is inserted into the center of the drawing or slide.
Then, go to Insert > Object > Formula on the menu bar to open the Formula Editor. Alternatively, go to Insert > Object > OLE Object on the menu bar to open the Insert OLE Object dialog, select Create new option and Formula from the sub-menu, then click OK to open the Formula Editor. The Elements window to the left of the Preview window may also appear, if it has been selected in View on the menu bar. For more information on creating formulas, see “Creating formulas” on page 60.
Figure 76 shows an example Writer document with the formula box selected ready for a formula to be entered.
[image: ]
[bookmark: Ref_Figure347_label_and_number]Figure 76: Empty formula in a Writer document

When you have completed entering the markup language for the formula, close the Formula Editor by pressing the Esc key or by clicking an area outside the formula in your document. Double-clicking on the formula object in the document will open the Formula Editor again so that you can edit the formula.
Formulas are inserted as OLE objects into documents. You can, as with any OLE object, change how the object is placed within the document. For more information on OLE objects, see the user guides for Math, Writer, Calc, Draw, and Impress.
If you frequently insert formulas into documents, it is recommended to add the Formula button to the Standard toolbar or create a keyboard shortcut. See Chapter 14, Customizing LibreOffice, for more information.
Creating formulas
You can insert elements into a formula using one of the following methods:
· Select a category from the drop-down list, then a symbol using the Elements window.
· Right-click in the Formula Editor and select a category, then a symbol from the context menu.
· Enter markup language directly in the Formula Editor.
· Note
Using the Elements window or the context menus to insert a formula provides a convenient way to learn the markup language used by LibreOffice Math.
Elements window
The Elements window can easily be used when entering formula data. In addition to the list of categories at the top of the window, it also provides an Example category which gives you example formulas to use as a starting point for your formula or equation.
 422) Go to View on the menu bar and select Elements to open the Elements window.
 423) Select the category you want to use in the formula from the drop-down list at the top of the Elements window.
 424) Select the symbol you want to use in the formula from the Elements window. The symbols that are available change according to the selected category.
· Note
The Elements window is positioned by default to the left of the Preview and Formula Editor windows, as shown in Figure 75 and Figure 76. It can be floated in the same way as other docked windows.
· Tip
When using the Elements window, it is recommended to have Tips selected in the LibreOffice Options. This will help you identify the categories and symbols you want to use in the formula. Go to Tools > Options > LibreOffice > General and select Tips in the Help section.
Context menu
The Formula Editor also provides a context menu to access categories and symbols when creating a formula. Right-click in the Formula Editor to open the context menu. Select a category and then select the markup example that you want to use from the sub-context menu. An example is shown in Figure 77.
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[bookmark: Ref_Figure348_label_and_number]Figure 77: Context menu in Formula Editor

· Note
The Elements window and the context menu contain only the most common commands that are used in formulas. For some seldom-used commands, you must always enter the command using the markup language. For a complete list of commands, see the Math Guide.
The upper area on the right is the preview window, where the equation will appear during and after input. The lower area on the right is the equation editor, where the markup code for the equation is entered. On the left is the Elements Dock.
Inserting a formula into a Writer document
To insert a formula into a Writer document, open the document and then choose Insert > Object > Formula from the Menu bar.
The formula editor opens at the bottom of the Writer window. You will also see a small box with a gray border in your document, where the formula will be displayed. Depending on your setup, the Elements Dock or the Elements window may also appear.
When you are done entering the formula, you can close the editor by pressing the Esc key or by clicking an area outside the formula in the main document. A double-click on the box will open the editor again, so you can edit the formula.
Formulas are inserted as OLE objects. In a Writer document, the formula is anchored as a character, so it is embedded in the continuous text. You can, as with any other OLE object, change the anchor and make the formula floating. In Calc, Impress and Draw documents, formulas are embedded as floating OLE objects.
If you frequently need to insert formulas, you may wish to add the Formula button to the Standard toolbar or create a keyboard shortcut. See Chapter 14, Customizing LibreOffice, for more information.
Entering a formula
The equation editor uses a markup language to represent formulas. For example, %beta creates the Greek character beta (). This markup is designed to read similar to English whenever possible. For example, a over b produces a fraction: .
You can enter a formula in three ways:
· Select a symbol from the Elements Dock or Elements window.
· Right-click on the equation editor and select the symbol from the context menu.
Markup language
Type markup in the equation editor.
Markup language is entered directly into the Formula Editor. For example, typing the markup language 5 times 4 into the Formula Editor creates the simple formula . If you are experienced in using markup language, it can be the quickest way to enter a formula. Table 1 shows some examples of using markup language to enter commands. For a full list of commands that can be used in the Formula Editor, see the Math Guide.
The context menu, the Elements Dock, and the Elements window all insert the markup corresponding to a symbol. This provides a convenient way to learn the LibreOffice Math markup.
	Note
	Click on the document body to exit the formula editor.
Double-click on a formula to enter the formula editor again.


Elements Dock
The simplest method for entering a formula is by using Elements. By default, an Elements Dock is visible at the left of the equation editor when first opening Math. If a greater area is needed to display the preview window or equation editor, the Elements Dock can be hidden with View > Elements Dock.
The Elements Dock is divided into two main parts.
· The drop-down list at the top of the Dock shows symbol categories.
· The symbols are displayed beneath the drop-down list.  These symbols change according to the category selected.
[image: ]
Figure 78:Selecting a category in the Elements Dock

Example 1:
For this example we will enter a simple formula:. On the Elements Dock:
1) Ensure the Unary/Binary Operators category is selected in the drop-down list (see Error: Reference source not found).
2) Click the multiplication symbol (see Error: Reference source not found).
[image: ]
Figure 79: Selecting the multiplication symbol

When you select the multiplication symbol, two things happen:
· The equation editor shows the markup:
· The body of the document shows a gray box like this:
[image: ]
Figure 80: Result of selecting the multiplication symbol

The <?> symbols shown in Error: Reference source not found are placeholders that you can replace by other text, for example 5 and 4. The equation will update automatically, as shown in Error: Reference source not found.
	Tip
	When you add a formula, reserved placeholders are indicated by squares in the formula and <?> in the command window. You can navigate through these placeholders using F4 and Shift+F4.

	Tip
	To keep the equation from updating automatically, select View > AutoUpdate display to deselect it. To update a formula manually, press F9 or select View > Update.


[image: ]
Figure 81: Result of entering 5 and 4 next to the times operator

Elements window
Elements can also be accessed in a separate floating window.  To display the Elements window, go to View > Elements.
The Elements window operates in a similar manner to the Elements Dock and is also divided into two main parts (see Error: Reference source not found).
· The upper area shows the symbol categories. Click on these to change the list of symbols.
· The lower area shows the symbols available in the current category.
[image: ]
Figure 82: The Elements window

Right-click (context) menu
Another way to access mathematical symbols is to right-click on the equation editor. This pops up the menu shown in Error: Reference source not found. The items in this menu correspond to those in the Elements window, with some extra commands.
[image: ]
Figure 83: Right-click (context) menu

	Note
	Neither the window elements, nor the context menu contain a complete list of commands. For some seldom-used commands, you must always enter the markup. A complete list of commands can be found in the appendix of the Math Guide.


Markup
You can type the markup directly in the equation editor. For example, you can type 5 times 4 to obtain . If you know the markup, this can be the fastest way to enter a formula.
	Tip
	The formula markup resembles the way the formula reads in English.


Table 1: Example commands using markup language
	Display
	Command
	Display
	Command

	
	a = b
	
	sqrt {a}

	
	a^2
	
	a_n

	
	int f(x) dx
	
	sum a_n

	
	a <= b
	
	infinity

	
	a times b
	
	x cdot y
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Using markup language
Greek characters are commonly used in formulas, but Greek characters cannot be entered into a formula using the Elements window or the context menu. Use the English names of Greek characters in markup language when entering Greek characters into a formula. See Appendix A, Commands Reference, in the Math Guide for a list of Greek characters that can be entered using markup language.
· Greek characters (, etc) are common in mathematical formulas. These characters are not available in the Elements window or the right-click menu. Fortunately, the markup for Greek characters is simple: Type a % sign followed by the name of the character, in English.
· For To write a lowercase Greek character, type a percentage % sign, then type the name of the character name in lowercase using the English name. For example, typing %lambda creates the Greek character λin lowercase.
· For an UPPERCASE Greek character, type a percentage % sign, then type the character name in UPPERCASE using the English name. For example, typing %LAMBDA creates the Greek character Λ.
· To write an uppercase character, type the name of the character in uppercase.
· For an italic Greek character, type a percentage % sign followed by the i character, then the English name of the Greek character in lower or UPPER case. For example, typing %iTHETA creates the italic Greek character Θ.
Symbols dialog
Greek characters can also be entered into a formula using the Symbols dialog.
 425)  To write in italic, just add an i between the % sign and the name of the character.
 426) Make sure your cursor is in the correct position in the Formula Editor.
 427) Go to Tools > Catalog on the menu bar or click on the Catalog icon [image: ] in the Tools toolbar to open the Symbols dialog (Figure 84)
 428) Select Greek from the Symbol set drop-down list. For italic characters, select iGreek from the drop-down list.
 429) Select the Greek character from the symbol list, then click Insert. When selected, the name of a Greek character is shown below the symbol list.
 430) A complete table of Greek characters is provided in the appendix of the Math Guide. See the table below for some examples.
 431) Click Close when you have finished entering Greek characters into the formula.
	Lowercase
	Uppercase
	Italic lowercase
	Italic uppercase

	%alpha
	%ALPHA
	%ialpha
	%iALPHA

	%beta 
	%BETA 
	%ibeta 
	%iBETA 

	%gamma
	%GAMMA
	%igamma
	%iGAMMA

	%psi  
	%PSI  
	%ipsi  
	%iPSI  

	%phi  
	%PHI  
	%iphi  
	%iPHI  

	%theta
	%THETA
	%itheta
	%iTHETA


Another way to enter Greek characters is by using the Symbols catalog window. Choose Tools > Catalog. This window is shown in Error: Reference source not found. Under Symbol set, select Greek and double-click on a Greek letter from the list. The markup name of the character is shown below the list window.
[image: ]
[bookmark: Ref_Figure349_label_and_number]Figure 84: Symbols dialog

Formula examples
Example 2:
Example 1
For this example we will suppose that:
The simple formula  can be created using LibreOffice Math as follows:
 432) We want to enter the above formula (the value of pi rounded to 5 decimal places).
 433) Make sure your cursor is flashing in the Formula Editor, then select the category Unary/Binary Operators and symbol Multiplication using one of the following methods:
· In the Elements window, select Unary/Binary Operators from the drop-down list and then select the Multiplication icon [image: ].
· Right-click in the Formula Editor and select Unary/Binary Operators > a times b from the context menu.
 434) Select the first placeholder <?> before the word times in the Formula Editor and replace it with the character 5. The formula in the document updates automatically.
 435) Select the second placeholder <?> after the word times in the Formula Editor and replace it with the character 4. The formula in the document updates automatically.
This method initially places the formula text <?> times <?> in the Formula Editor and the symbol [image: ] appears in the document. These placeholders must then be replaced with real numbers. Using markup language in the Formula Editor places the formula  directly into the document. To use markup language, enter 5 times 4 in the Formula Editor. appears in the document.
· Tip
To move forward from one placeholder to the next placeholder in a formula, press the F4 key. To move backward from one placeholder to the previous placeholder in a formula, use the key combination Shift+F4.
· Note
If necessary, you can prevent a formula in a document from updating automatically. Go to View on the menu bar and deselect AutoUpdate display. To then manually update a formula, press F9 key or select View > Update on the menu bar.
Example 2
We know the name of the Greek character (pi).
· But we do not know the markup associated with the  symbol.
You want to enter the formulawhere the value of pi is rounded to 5 decimal places. You know the name of the Greek character (pi), but do not know the markup associated with the Is Similar Or Equal symbol.
 436) Step 1: Type % followed by the text pi. This displays the Greek character .
 437) Make sure your cursor is flashing in the Formula Editor.
 438) Step 2: Open the Elements window (View > Elements).
 439) Enter %pi in the Formula Editor to enter the Greek character for pi (π).
 440) Step 3: The  symbol is a relation, so we click on the Relations button. If you hover the mouse over this button you see the tooltip Relations (Error: Reference source not found).
 441) Select the category Relations and symbol Is Similar Or Equal using one of the following methods:
· Error: Reference source not found shows the Elements window after clicking the Relations button. The symbol we want is circled.
· In the Elements window, select Relations from the drop-down list and then select the Is Similar Or Equal icon [image: ].
· Right-click in the Formula Editor and select Relations > a simeq b from the context menu.
 442) Delete the first placeholder <?> before the word simeq in the Formula Editor.
 443) Select the second placeholder <?> after the word simeq in the Formula Editor and replace it with the characters 3.14159. The formulanow appears in the document.
	[image: ]
Figure 317: Tooltip indicates the Relations button
	[image: ]
Figure 318: After selecting Relations


Step 4: Click on the ab symbol. The equation editor now shows the markup
%pi<?> simeq <?>.
Step 5: Delete the first <?> text, then press the F4 key to move to the next <?> entry. Type 3.14159 to replace the <?> at the end of the equation. We end up with the markup %pi simeq 3.14159. The result is shown in Error: Reference source not found.
[image: ]
Figure 85: Final result

Editing formulas
Changing a formula
How you edit a formula and switch into formula editing mode depends on whether the formula is in Math or another LibreOffice component.
 444) In Math, double-click on a formula element in the formula that appears in the Preview window to select the formula element in the Formula Editor, or directly select a formula element in the Formula Editor.
 445) You can change a formula at any time. To switch into edit mode, double-click on the formula.
 446) In Writer, Calc, Impress, or Draw, double-click on the formula, or right-click on the formula and select Edit form the context menu to open the Formula Editor in editing mode. The cursor is positioned at the start of the formula in the Formula Editor.
· Note
If you cannot select a formula element using the cursor, click on the Formula Cursor icon [image: ] in the Tools toolbar to activate the formula cursor.
 447) Select the formula element you want to change use To get to the appropriate section in the markup code, do any one of the following methods:
· Click on the formula element in the preview window, position the cursor at the beginning of the formula element in the Formula Editor, then select the formula element in the Formula Editor.
· Double-click on the formula element in the preview window to select the formula element in the Formula Editor.
· In the equation editor, click on the location.
· Position the cursor in the Formula Editor at the formula element you want to edit, then select that formula element.
· Select an area of the markup code that you wish to change.
· Double-click directly on the formula element in the Formula Editor to select it.
 448) Click on an element in the preview area; the cursor will automatically move to the corresponding point in the equation editor.
 449) Make your changes to the formula element you have selected.
 450) Double-click on an element in the preview area; the corresponding section in the equation editor will be selected.
 451) Go to View > Update on the menu bar, or press the F9 key, or click on the Update icon [image: ] in the Tools toolbar to update the formula in the preview window or the document.
 452) In Math, save your changes to the formula after editing.
 453) In Writer, Calc, Impress, or Draw, click anywhere in your document away from the formula to leave editing mode, then save the document to save your changes to the formula.
To be able to work in the upper (preview) area in the stand-alone Math window (Error: Reference source not found), the formula cursor must be activated. Use the Formula Cursor button on the Tools toolbar.
[image: ]
You can change an equation by overwriting selected text or by inserting new markup code at the cursor position.
[bookmark: __RefHeading__58795_1954213482]Formula layout
This section provides some advice on how to layout complex formulas in Math or in your LibreOffice document.
The most difficult part of using LibreOffice Math comes when writing complicated formulas. This section provides some advice.
Using braces
Brackets 
LibreOffice Math knows nothing about order of operation within a formula. You must use braces (also known as curly brackets)brackets to state the order of operations that occur within a formula. The following examples show how brackets can be used in a formulaexplicitly. Consider the following examples.
Example 1
2 over x + 1 gives the result
	Markup
	Result
	Markup
	Result

	2 over x + 1
	
	2 over {x + 1}
	

	– 1 over 2
	  
	– {1 over 2}
	  


In the first example, Math has recognized that the 2 before and the x after the over as belonging belong to the fraction, and has represented them accordingly. If you want x+1 rather than x to be the denominator, you must bracket them together using braces so that both will be placed there.
Inserting braces into 2 over {x + 1} gives the resultwhere x+1 is now the denominator.
Example 2
– 1 over 2 gives the result
In the second example, Math has recognized the minus sign as a prefix for the 1 and has therefore placed it in the numerator of the fraction. If you wish to show that the whole fractionthing is negative, with the minus sign in front of the fraction, you must put the fraction in bracesbrackets in order to signify to Math that the characters belong together.
Adding braces to into the markup language {1 over 2} gives the resultand the whole fraction is now negative.
Example 3
When braces are used in markup language, they are used to define The braces belong solely to the layout of the formula markup code and are not displayed or printed. If you wantwish to use braces within yourin the formula, you use the commands lbrace and rbrace within the markup language.
x over {–x + 1} gives the result
Compare the following examples:
Replace the braces using the commands lbrace and rbrace in the markup language. Writing x over lbrace –x + 1 rbrace and the result is 
Brackets and matrices
If you want to use a matrix in a formula, you have to use a matrix command. For example, matrix { a # b ## c # d } gives the resulting matrixin the formula, where rows are separated by two hashes (#) and entries within each row are separated by one hash (#).
Normally, when you use brackets within a matrix, the brackets do not scale as the matrix increases in size. For example, ( matrix { a # b ## c # d } ) gives the result
To overcome this problem of brackets with a matrix, LibreOffice Math provides scalable brackets that grow in size to match the size of a matrix. The commands left( and right) have to be used to create scalable brackets within a matrix. For example, left( matrix { a # b ## c # d } right) gives the resultwhere the matrix is now bracketed by scalable brackets.
Scalable brackets can be used with any element of a formula, such as fraction, square root, and so on.
· Tip
Use the commands left[ and right] to obtain square brackets. A list of all brackets available within Math can be found in Appendix A, Commands Reference, in the Math Guide.
· Tip
If you want all brackets to be scalable, go to Format > Spacing to open the Spacing dialog. Click on Category, select Brackets from the drop-down list and then select the option Scale all brackets.
Unpaired brackets
When using brackets in a formula, Math expects that for every opening bracket there will be a closing one. If you forget to add a closing bracket, Math places an inverted question mark next to where the closing bracket should have been placed. This inverted question mark disappears when all the brackets are paired. However, an unpaired bracket is sometimes necessary and you have the following options.
Non-scalable brackets
A backslash \ is placed before a non-scalable bracket to indicate that the following character should not be regarded as a bracket, but as a literal character.
For example, the unpaired brackets in the formula [ a; b [ are deliberate, but gives the result. To remove the inverted question marks and create unpaired brackets, backslashes are added. The formula now becomes \ [ a; b \ [ and the resultshows unpaired brackets without the inverted question marks.
	Markup
	Result
	Markup
	Result

	x over {–x + 1}
	 
	x over lbrace –x + 1 rbrace
	 


[bookmark: __RefHeading__17437_901305723]Scalable brackets
For background, we start with an overview of the matrix command.
	Markup
	Result

	matrix { a # b ## c # d }
	

	Note
	Rows are separated by two # symbols and entries within each row are separated by one #.


The first problem people have with matrices is that brackets do not scale with the matrix:
	Markup
	Result

	(  matrix { a # b ## c # d }  ) 
	


To create unpaired scalable brackets or braces in a formula, the markup commands left, right, and none are used.
Math provides scalable brackets. That is, the brackets grow in size to match the size of their contents. Use the commands left( and right) to make scalable brackets.
Example
You want to create the formulaand in the Formula Editor you enter abs = x lbrace stack {x "for" x >= 0 # -x "for" x < 0. However, this gives the incorrect result. To remove the inverted question marks and create the correct formula, you have to use the markup commands left, right, and none. Change the entry in the Formula Editor to abs x = left lbrace stack {x "for" x >= 0 # -x "for" x < 0} right none and this creates the correct formula.
	Markup
	Result

	left(  matrix { a # b ## c # d }  right)
	

	Tip
	Use left[ and right] to obtain square brackets. The list of all available brackets is available in the appendix of the Math Guide.


These scalable brackets may also be used with any element, such as a fraction, square root, etc.
Isolated and unpaired brackets
Math expects that for every opening bracket there will be a closing one. If you forget a bracket, Math places an inverted question mark by the corresponding bracket. This disappears when all brackets are matched. Sometimes forgetting a bracket causes the whole structure of the formula to fall apart.
However, an unpaired bracket is sometimes necessary. In such cases, you have two options:
· With non-scalable brackets, use a preceding backslash \ to indicate that the following character should not be regarded as a bracket but as a literal character. So the half-open interval [a;b[ is represented by \[a;b\[ — try comparing this with [a;b[ 
· Scalable brackets can also be unpaired. The same half-open interval is represented by
    left [ a; b right [ 
For scalable brackets, you can also use the command none to replace a non-existent paired bracket.

can be represented by 
abs x = left lbrace stack {x "for" x >= 0 # -x "for" x < 0} right none
[bookmark: __RefHeading__18187_270489466]Recognizing functions in Math
In the basic installation of Math, Math outputs functions in normal characters and variables in italic characters. However, if Math fails to recognize a function, you can tell Math that you have just entered a function. Enter the markup command func before a function forces Math to recognize the following text as a function and uses normal characters.
In the basic installation, Math outputs variables in italics. If you enter a function, Math usually recognizes it and outputs it normally (a list of recognized functions is available in the Math Guide). If Math fails to recognize a function, you can inform Math about it. Enter the markup code func before the function, and the text that follows will be recognized as a function.
Some functions recognized by Math need to be followed by numbers or variables. If these are missing, Math puts an inverted red question mark ¿ in their place, which you can only remove by correcting the formula: enter a variable or a number, or a pair of empty braces { } as a placeholder.
	Tip
	You can navigate through errors using F3 and Shift+F3.


For a full list of functions within Math, see the Math Guide.
Equations over more than one line
Some Math functions have to be followed by a number or a variable. If these are missing, Math places an inverted question mark where the missing number or variable should be. To remove the inverted question mark and correct the formula, you have to enter a number, a variable or a pair of empty brackets as a placeholder.
· Tip
You can navigate through errors in a formula using the key F3 or the key combination Shift+F3.
Formulas over multiple lines
Suppose you want to make an equation covering more than one line, for example:
Suppose you want to create a formula that requires more than one line, for exampleand your Your first reaction would normally be to simply press the Enter key. However, if you press the Enter key, although the markup language in the Formula Editor goes to a new line, but the resulting formulaequation does not have two lines. You must type the macro command newline each time you want to create and display a new line in a formulanewline command explicitly. This is illustrated in the table below.
Example
x = 3
y = 1
gives the incorrect result
x = 3 newline y = 1 gives the correct result
	Markup
	Result

	x = 3
y = 1
	

	x = 3 newline
y = 1
	


It is not possible in Math to create multiple-line formulas when a line ends with an equals sign and you want to continue the calculation on a new line without completing the term on the right side of the equals sign. If you require a multiple line formula to have an equals sign at the end of a line without a term after the equals sign, then use either empty quotes “” or empty braces {} or the space characters grave ` or tilde ˜.
Continuing the calculation on a new line without writing a complete new equation is not directly possible, because Math expects a term on the left hand side of an equals sign. You can substitute:
By default, the alignment of a multiple line formula is center aligned. For more information on alignment using the equals sign, see the Math Guide.
Spacing between the elements in a formula is not set by using space characters in the markup language. If you want to add spaces into the formula, use one of the following options:
· Grave ` to add a small space.
· Tilde ~ for a large space.
· Add space characters between quotes “ ”. These spaces will be considered as text.
Any spaces at the end of a line in the markup language are ignored by default. For more information, see the Math Guide.
Adding limits to sum/integral commands
The sum and integral commands can take the parameters from and to if you want to set the lower and upper limits respectively. The parameters from and to can be used singly or together as shown by the following examples. For more information on the sum and integral commands, see the Math Guide.
Examples
sum from k = 1 to n a_k gives the result
int from 0 to x f(t) dt gives the result
int_0^x f(t) dt gives the result
int from Re f gives the result
sum to infinity 2^{-n} gives the result
Writing derivatives
When writing derivatives, you have to tell Math that it is a fraction by using the over command. The over command is combined with the character d for a total derivative or the partial command for a partial derivative to achieve the effect of a derivative. Braces {} are used each side of the element to surround the element and make the derivative as shown by the following examples.
Examples
{df} over {dx} gives the result
{partial f} over {partial y} gives the result
{partial^2 f} over {partial t^2} gives the result
· Note
To write function names with primes, as is normal in school notation, you must first add the symbols to the catalog. See the Math Guide for more information.
Markup language characters as normal characters
Characters that are used as controls in markup language cannot be entered directly as normal characters. These characters are: %, {, }, &, |, _, ^ and ". For example, you cannot write 2% = 0.02 in markup language and expect the same characters to appear in the formula. To overcome this limitation in markup language, use one of the following methods:
· Use double quotes either side of the character to mark that character as text, for example 2"%"= 0.02 will appear in the formula as. However, this method cannot be used for the double-quote character itself, see “Text in formulas” below.
· Add the character to the Math Catalog, for example the double quote character.
· Use commands, for example lbrace and rbrace give you literal braces.
· Note
The Special Characters dialog used by other LibreOffice modules is not available in Math. If you are going to regularly require special characters in Math, then it is recommended to add the characters to the Math Catalog, see the Math Guide for more information.
Text in formulas
To include text in a formula, you have to enclose it in double-quotes, for example x " for " x >= 0 in markup language will create the formula. All characters, except double quotes, can be used in text. However, if you require double quotes in the formula text, then you have to create the text with double quotes in LibreOffice Writer, then copy and paste the text into the Formula Editor as shown in Figure 86.
The font used for text in a formula will be the default font that has been set in the Fonts dialog. For more information on how to change fonts used for in formulas, see “Changing formula appearance” on page 74.
By default, text alignment is left-justified in formulas. To change text alignment, see “Adjusting formula alignment” on page 78.
Empty quotes "". This will automatically cause the line to be left-justified.
Formatting commands are not interpreted within text used in formulas. If you want to use formatting commands within formula text, then you must break up the text using double quotes in the Formula Editor.
[image: ]
[bookmark: Ref_Figure350_label_and_number]Figure 86: Example of double quotes in formula text

Example
Enter the following in the Formula Editor:
"In " color blue bold "isosceles" "triangles, the base angles are equal"
creates the following text in a formula
Empty braces { }. The following line will then be centered.
· Spaces characters ` or ~. The line will be centered with the spaces.
Aligning formulas using equals sign
The alignment of equals signs under each other is described on page 73.
LibreOffice Math does not have a command for aligning formulas on a particular character. However, you can use a matrix to align formulas on a character and this character is normally the equals sign (=).
Example
Additionally, spacing between elements in formulas are not set by space characters in the code. You need to use special markup to add spaces: ` (grave) for a small space, ~ (tilde) for a large space. Another solution would be to add space characters between quotes, to be considered as text. Space markup at the end of a formula are ignored by default.
How do I add limits to my sum/integral?
The sum and int commands (see complete list in the appendix of the Math Guide) can (optionally) take the parameters from and to. These are used for lower and upper limits respectively. These parameters can be used individually or can be combined.
	Markup
	Result

	sum from k = 1 to n a_k
	

	int from 0 to x f(t) dt
or 
int_0^x f(t) dt
	 or 

	int from Re f
	

	sum to infinity 2^{-n}
	


Creating the matrix:
How do I write a derivative?
matrix{ alignr x+y # {}={} # alignl 2 ## alignr x   # {}={} # alignl 2-y }
gives the following result where formulas are aligned on the equals sign
· Note
The empty braces each side of the equals sign are necessary because the equals sign is a binary operator and requires an expression on each side. You can use spaces, or ` or ~ characters each side of the equals sign, but braces are recommended as they are easier to see within the markup language.
You can reduce the spacing on each side of the equals sign if you change the inter-column spacing of the matrix. See “Adjusting formula spacing” on page 76 for information on how to adjust adjust formula spacing.
Changing formula appearance
Writing derivatives essentially comes down to one trick: Tell LibreOffice it’s a fraction.
In other words, you have to use the over command. Combine this with either the letter d (for a total derivative) or the partial command (for a partial derivative) to achieve the effect of a derivative.
	Markup
	Result

	{df} over {dx}
	

	{partial f} over {partial y}
	

	{partial^2 f} over {partial t^2}
	

	Note
	Notice that we have to use braces (squiggly brackets) to make the derivative.


To write function names with primes, as is usual in school notation, you must first add the signs to the catalog. Using single and double quotes is typographically ugly. See “Error: Reference source not found” on page Error: Reference source not found.
Formula font size
Markup characters as regular characters
Characters that are used for controlling markup cannot be entered directly as normal characters. The characters concerned are:  %, {, }, &, |, _, ^ and ". So, for example, you cannot write 2% = 0.02 or 1" = 2.56cm. Two methods are available to overcome this limitation:
· Use double quotes to mark the character as text, for example 2"%"= 0.02. This is not possible for the double-quote character itself.
· Add the character to the catalog. See the section  “Error: Reference source not found” on page Error: Reference source not found.
In some cases you can use commands. For example:
· lbrace and rbrace give you literal braces .
Conversion into a character entity as in HTML or the use of an escape character is not possible in Math.
Current formula font size
Text in a formula
To change the font size used for a formula already inserted in Math or another LibreOffice module:
 454) To include text in a formula, enclose it in straight double-quotes:
 455) Click in the markup language in the Formula Editor.
 456) Go to Format > Font size on the menu bar to open the Font Sizes dialog (Figure 87).
 457) Select a different font size using the Base size spinner or type a new font size in the Base Size box.
 458) Click OK to save your changes and close the dialog. An example result when you change font size is shown below.
Example
Default font size 12pt:
After font size change to 18pt:
abs x = left lbrace matrix {x # "for " x >= 0 ## -x # "for " x < 0} right none
[image: ]
[bookmark: Ref_Figure351_label_and_number]Figure 87: Font Sizes dialog

Default formula font size
All characters except double quotes are permissible in text. Unfortunately the Special characters dialog is not available. If necessary, you can write the text in a text document and copy it into the equation editor via the clipboard. In this way smart quotes can be inserted, as shown below.
[image: ]
Figure 88: Smart quotes included by copy and paste from Writer

Text is shown in the font that is selected from the Text list in the Fonts dialog (see “Formula fonts” on page 75). To select a font for the lower window of the equation editor, set the attribute Serif, Sans or Fixed before typing the text.
To change the default font size used for all formulas in Math or another LibreOffice module:
 459) By default, text is left-justified. You can change the justification with alignc or alignr.
 460) Before inserting any formulas into your document, go to Format > Font size on the menu bar to open the Font Sizes dialog (Figure 87).
 461) Select a different font size using the Base size spinner or type a new font size in the Base Size box.
 462) Click Default and confirm your changes to the base size font. Any formulas created from this point on will use the new base size font for formulas.
 463) Click OK to save your changes and close the Font Sizes dialog.
· Note
If you have already inserted formulas into your document and you change the default font size, only formulas inserted after the change in default font size will use the new default settings. You have to individually change the font size of formulas already inserted if you want these formulas to use the same font size as the default settings. For more information on changing the font size, see the Math Guide.
Formula fonts
Current formula fonts
To change the fonts used for the current formula in Math or another LibreOffice module:
 464) Click in the markup language in the Formula Editor.
 465) Go to Format > Fonts on the menu bar to open the Fonts dialog (Figure 89).
 466) Select a new font for each the various options from the drop-down lists.
 467) If the font you want to use does not appear in the drop-down list, click Modify and select the option from the context menu to open a fonts dialog. Select the font you want to use and click OK to add it to the drop-down list for that option.
 468) Click OK to save your changes and close the Fonts dialog.
Commands are not interpreted within text. Use quotes to break up the text if you wish to use special formatting commands.
"In " color blue bold "isosceles" " triangles, the base angles are equal"
[image: ]
[bookmark: Ref_Figure352_label_and_number]Figure 89: Fonts dialog

Default formula fonts
To change the default fonts used for all formulas in Math or another LibreOffice module:
 469) Before inserting any formulas into your document, go to Format > Fonts on the menu bar to open the Fonts dialog (Figure 89).
 470) Select a new font where required for each of the various options from the drop-down lists.
 471) If the font you want to use does not appear in the drop-down list, click Modify and select the option from the context menu to open a fonts dialog. Select the font you want to use and click OK to add it to the drop-down list for that option.
 472) Click Default and confirm your changes to the fonts. Any formulas created from this point on will use the new fonts for formulas.
 473) Click OK to save your changes and close the Fonts dialog.
· Note
If you have already inserted formulas into your document and you change the default fonts, only formulas inserted after the change in default fonts will use the new default settings. You have to individually change the font of formulas already inserted if you want these formulas to use the same font as the default settings. For more information on changing the font, see the Math Guide.
Adjusting formula spacing
Use the Spacing dialog (Figure 90) to determine the spacing between formula elements. The spacing is specified as a percentage in relation to the defined base size for font sizes.
Current formula spacing
To change the spacing used for the current formula in Math or another LibreOffice module:
 474) Click in the markup language in the Formula Editor.
 475) Go to Format > Spacing on the menu bar to open the Spacing dialog (Figure 90).
 476) Click Category and select one of the options from the drop-down list. The options in the Spacing dialog change according to the category selected.
 477) How do I align my equations at the equals sign?
 478) Enter new values for the spacing category and click OK.
 479) Math does not have a command for aligning equations on a particular character, but you can use a matrix to do this, as shown below.
 480) Check the result in your formula. If not to your satisfaction, repeat the above steps.
[image: ]
[bookmark: Ref_Figure353_label_and_number]Figure 90: Spacing dialog

Default formula spacing
	Markup
	Result

	matrix{
   alignr x+y # {}={} # alignl 2 ##
   alignr x   # {}={} # alignl 2-y
}
	


The empty braces around = are necessary because = is a binary operator and thus needs an expression on each side.
To change the default spacing used for all formulas in Math or another LibreOffice module:
 481) You can reduce the spacing around = if you change the inter-column spacing of the matrix:
 482) Before inserting any formulas into your document, go to With the equation editor open, choose Format > Spacing on the menu bar to open the Spacing dialog (Figure 90)from the Menu bar.
 483) Click Category and select one of the options from the drop-down list. The options in the Spacing dialog change according to the category selected.
 484) In the Spacing dialog (Error: Reference source not found), click the Category button and select Matrices in the drop-down menu.
 485) Click Default and confirm your changes to the formula spacing. Any formulas created from this point on will use the new spacing for formulas.
 486) Click OK to save your changes and close the Spacing dialog.
· Enter 0% for Column spacing and click OK.
· Note
If you have already inserted formulas into your document and you change the spacing, only formulas inserted after the change in spacing will use the new default settings. You have to individually change the spacing of formulas already inserted if you want these formulas to use the same spacing as the default settings. For more information on changing the formula spacing, see the Math Guide.
[image: ]
Figure 91: Changing spacing in a formula

Adjusting formula alignment
Changing the appearance of formulas
The alignment settings determine how formula elements located above one another are aligned horizontally relative to each other.
· Note
It is not possible to align formulas on a particular character and formula alignment does not apply to text elements. Text elements are always aligned left.
· Note
Independent of using formula alignment given below, it is possible to align formulas using the commands alignl, alignc and alignr. These commands also work for text elements.
Current formula alignment
Changing the font size
To change the alignment used for the current formula in Math or another LibreOffice module:
 487) This is one of the most common questions people ask about LibreOffice Math. The answer is simple, but not intuitive:
 488) Click in the markup language in the Formula Editor.
 489) Start the formula editor and choose Format > Font size.
 490) Go to Format > Alignment on the menu bar to open the Alignment dialog (Figure 93).
 491) Select either Left, Centered, or Right for horizontal alignment.
 492) Select a larger font size under Base size (upper-most entry).
 493) [image: ]
Figure 92: Edit Base size (top) to make a formula bigger

 494) Click OK and check the result in your formula. If not to your satisfaction, repeat the above steps.
The result of this change is illustrated in Error: Reference source not found.
[image: ]
[bookmark: Ref_Figure354_label_and_number]Figure 93: Alignment dialog

	Note
	The change in font size applies only to the current formula. To change the default font size, click on the Default button and then OK. A change in the default font size might, for example, make your work easier when you are preparing a big presentation and want all the formulas in it to have a base size of 28pt—but do not forget to set the font size back to its original value when the work is finished.
Warning: this will modify only the current formula and future formulas you write. To modify existing formulas in the document, you need to use a macro (see section about macros in the Math Guide).


The size of a subset of characters in a formula may be modified using the size command. For example: b size 5{a}  gives the result . In the context menu (see Error: Reference source not found, above), the Attributes listing gives the size command. The value just after size may be absolute (numeric value) or relative to the context (base size by default): for example, +6, -3, /2, or *2.
Default formula alignment
Changing the font
To change the default alignment used for all formulas in Math or another LibreOffice module:
 495) The fonts used in formulas can be changed using Format > Fonts. 
 496) Before inserting any formulas into your document, go to Format > Alignment on the menu bar to open the Alignment dialog (Figure 93).
 497) Select either Left, Centered, or Right for horizontal alignment.
 498) Click Default and confirm your changes to the formula alignment. Any formulas created from this point on will use the new alignment for formulas.
 499) Click OK and check the result in your formula. If not to your satisfaction, repeat the above steps.
· Note
If you have already inserted formulas into your document and you change the formula alignment, only formulas inserted after the change in alignment will use the new default settings. You have to individually change the alignment of formulas already inserted if you want these formulas to use the same alignment as the default settings.
Changing formula color
Character color
Formula color for the characters used in a formula is changed by using the command color in the mark up language. This command only works on the formula element immediately after the color name. For example, entering the markup language color red ABC 5 times 4 gives the result  .
To change the color of the whole formula, you have to enclose the whole formula within brackets. For example, entering the markup language color red {ABC 5 times 4} gives the result.
For information on the colors available in Math, see the Math Guide.
· Tip
For ease of use, the Elements window includes the category Attributes, which lists standard colors. Click on the required color to insert the command into your formula.
Background color
It is not possible to select a background color for formulas in LibreOffice Math. The background color for a formula is by default the same color as the document or frame that the formula has been inserted into. However, in LibreOffice documents, you can use object properties to change the background color for a formula. For more information on using a background color (area fill for objects) with a formula, please refer to the user guides for Writer, Calc, Draw, and Impress.
Formula library
If you regularly insert the same formulas into your documents, you can create a formula library using formulas that you have created using the Formula Editor. Individual formulas can be saved as separate files using the ODF format for formulas with the file suffix of .odf, or in MathML format with the file suffix of .mml.
You can use LibreOffice Math, Writer, Calc, Draw, or Impress to create formulas and build up your formula library.
Using Math
 500) Create a folder on your computer to contain your formulas and give the folder a memorable name, for example Formula Library.
 501) In LibreOffice, go to File > New > Formula on the menu bar, or click on Math Formula in the opening splash screen to open LibreOffice Math and create your formula using the Formula Editor. See “Formulas as separate documents or files” on page 58 for more information.
 502) Go to File > Save As on the menu bar or use the keyboard shortcut Ctrl+Shift+S to open a Save As dialog.
 503) Navigate to the folder you have created for your formula library.
 504) Type in a memorable name for your formula in the File name text box.
 505) Select from the drop-down list for File type either ODF Formula (.odf) or MathML 1.01 (.mml) as the file type for your formula.
 506) Click Save to save the formula and close the Save As dialog.
Using Writer, Calc, Draw, or Impress
 507) Create a folder on your computer to contain your formulas and give the folder a memorable name, for example Formula Library.
 508) Open a document using Writer, Calc, Draw, or Impress.
 509) Go to Insert > Object > Formula on the menu bar to open the Formula Editor and create your formula. See “Formulas in LibreOffice documents” on page 59 for more information.
 510) Right-click on the formula object and select Save Copy as from the context menu to open a Save As dialog.
 511) Navigate to the folder you have created for your formula library.
 512) Type in a memorable name for your formula in the File name text box.
 513) Select from the drop-down list for File type either ODF Formula (.odf) or MathML 1.01 (.mml) as the file type for your formula.
 514) Click Save to save the formula and close the Save As dialog.
The Formula fonts section of the Fonts dialog (Error: Reference source not found) refers to the four specified formula elements. The font for operators, relationships and brackets is not affected, as these elements normally come from the OpenSymbol font. Similarly elements from the catalog (see “Error: Reference source not found” on page Error: Reference source not found) continue to be displayed in the font specified there.
[image: ]
Figure 94: Fonts dialog

The Custom fonts section determines which font will be used when the attribute font serif, font sans or font fixed is specified.
To change a font, first click on Modify and choose the type of entry you wish to modify. The Fonts dialog opens, showing all the fonts available on your system.
[image: ]
Figure 95: Font modification dialog

The Font text input box uses predictive text as you type to assist locating the wanted font. If you do not know its name, use the scrollbar to scroll through them. Click on any name and the preview box will show a sample.
Variables should be written in italics, so make sure that the Italic box is checked. For all other elements, use the basic (Roman) form. The style can be easily altered in the formula itself by using the commands italic or bold to set these characteristics and nitalic or nbold to unset them.
Using your formula library
When you have chosen a new font for a formula, the old font remains in the list alongside the new one and can be selected again. This applies only to the current session; the old font is not stored permanently.
You cannot insert a formula from your library into a document by dragging and dropping using the mouse, nor by using Insert > File on the menu bar. You must insert a formula from your library into your document as an OLE object.
 515) You can choose any fonts from the list, but if you are exchanging documents with someone else, you should choose fonts that are present on your colleague’s computer.
 516) Open the document in Writer, Calc, Draw, or Impress.
 517) Changing the color
 518) Go to Insert > Object > OLE Object on the menu bar to open the Insert OLE Object dialog.
 519) Select the option Create from file.
 520) Use the command color to change the color of a subset of a formula: color red ABC gives . Choose from 8 colors: white, black, cyan, magenta, red, blue, green, yellow.
 521) You may set a color for a subset of a formula if it is enclosed between { } or other parentheses. For instance: A B color green {C D} E gives .
 522) Color commands can be nested in subsets of formulas as shown in this example : color blue {A B color yellow C D} gives . The space between C and D limits the color to the variable following the command.
 523) It is not possible to select a background color: it is always transparent in Math. The background color of the whole formula is then the same as the background of the document or frame (in a text document for instance). In Writer, you can use object properties (right-click the formula Object) to choose a background color for the whole formula (see “Error: Reference source not found” on page Error: Reference source not found).
 524) Click Search to open your file browser dialog.
 525) Formulas in Writer documents
 526) Navigate to the folder you have created for your formula library.
 527) Select the formula you want to insert and click Open, or double-click on the formula you want to insert.
 528) Click OK to insert the formula as an OLE object in the document and close the OLE Object dialog.
Formulas in Writer
When a formula is inserted into a document, LibreOffice Writer inserts the formula into a frame and treats the formula as an OLE object. Double-clicking on an inserted formula will open the Formula Editor in LibreOffice Math, where you can edit the formula. 
This section explains what options you can change for each individual formula within a Writer document. Please refer to the chapters on styles in the Writer Guide for information on how to change the default settings for frame styles for OLE objects.
Automatic formula numbering
Numbering equations
Automatic numbering of formulas for cross-reference purposes can only be carried out in LibreOffice Writer.
Numbering
 529) Equation numbering is one of Writer’s best hidden features. The steps are simple, but obscure:
 530) Start a new line in your document.
 531) Type fn and then press the F3 key. A two-column table with no borders is inserted into your document with the left column containing a sample formula and the right column containing a reference number, as shown below.
	
	(1)


 532) Delete the sample formula and insert your formula as an object in the left column. See “Creating formulas” on page 60 for more information on inserting formulas.
Alternatively, you can first insert your formula into the document, then carry out Steps 1 and 2 above, replacing the sample formula with your formula.
· Note
If you want to use square parentheses instead of round ones around the formula number, or if you want the formula number to be separated from the formula by tabs instead of using a table, then you need to modify the AutoText entry for fn. Refer to the section on AutoText in Chapter 4, Getting Started with Writer.
Type fn and then press F3. Note this is NOT the keyboard Fn key.
Cross-referencing
 533) The fn is replaced by a numbered formula:
 534) Click in the document where you want the cross-reference to appear.
 535) Go to Insert > Cross-reference on the menu bar to open the Fields dialog (Figure 96).
 536) Click on the Cross-references tab, then select Text in the Type section.
	
	(3)


 537) In the Selection section, select the formula number you want to refer to. 
 538) Now you can double-click on the formula to edit it. Click in any blank space within the document to revert to standard Writer menu. Click again to deselect the formula.
 539) In the Insert reference to section, select Reference and click Insert.
 540) You can insert a cross-reference to an equation (for example “as shown in Equation Error: Reference source not found”) as follows:
 541) When you have finished creating cross-references, click Close to close the Fields dialog.
· Choose Insert > Cross-reference from the Menu bar.
· Tip
To insert the cross-reference number without parentheses, select Numbering instead of Reference in the Insert reference to section.
On the Cross-references tab (Error: Reference source not found), under Type, select Text.
[image: ]
[bookmark: Ref_Figure355_label_and_number]Figure 96: Fields dialog – Cross-references page

[image: ]Anchoring formulas
A formula is treated as an object within Writer and its default anchoring is As character within a paragraph when it is inserted into a document. To change the anchoring of a formula object:
 542) Right-click on the selected formula object and select Anchor from the context menu.
 543) Under Selection, select the equation number. 
 544) Select a new anchoring option from the context sub-menu. The anchoring positions available are To page, To paragraph, To character, or As character.
Alternatively,
 545) Right-click on the selected formula object and select Object from the context menu, or go to Format > Frame/Object on the menu bar to open the Object dialog (Figure 97).
 546) Make sure the Type page is selected and select a new anchoring position from the Anchor section.
 547) Under Insert reference to, select Reference.
 548) Click OK to save your changes and close the Object dialog.
[image: ]
[bookmark: Ref_Figure356_label_and_number]Figure 97: Object dialog – Type page with Anchor options

· Note
The anchoring options are not available in the Object dialog when you are making changes to the various options available for frame styles. For more information on how to modify frame styles, please refer to the chapters on styles in the Writer Guide.
Vertical alignment
Click Insert.
The normal default setting for vertical alignment for formula objects is to use the text base line as a reference. This default setting can be changed by modifying the formula frame style, see the chapters on styles in the Writer Guide for more information.
To change the vertical alignment position of an individual formula object:
 549) Right-click on the selected formula object and select Object from the context menu, or go to Format > Frame/Object to open the Object dialog (Figure 98).
 550) Make sure the Type page is selected and select a new alignment position from the drop-down list in the Position section. The vertical alignment options available are Top, Bottom, Center or From bottom.
 551) If necessary, type in the text box a plus or minus value for vertical alignment. This option is only available if From bottom vertical alignment has been selected.
 552) Select the type of text alignment from the drop-down list in the Position section. The text alignment options available are Base line, Character and Row.
 553) Click OK to save your changes and close the Object dialog.
If you later add more equations in a position above the referenced equation, all the equations will automatically renumber and the cross-references will update.
	Tip
	To insert the equation number in the cross-reference without parentheses around it, choose Numbering instead of Reference under Insert reference to.


The AutoText inserted as a result of the above procedure consists of a 1x2 table. The left cell contains the formula and the right one the number. The number is an automatic counter named Text. You can edit the AutoText if, for example, you prefer square rather than round brackets, or if you want formula and number to be separated by tabs rather than formatted as a table. For more information, read the section on “Using AutoText” in Chapter 3 (Working with Text) in the Writer Guide.
[image: ]
[bookmark: Ref_Figure357_label_and_number]Figure 98: Object dialog – Wrap page

· Note
Position
Normally a formula is anchored As character in a Writer document. But as with any other OLE object, you can change the anchoring mode to position the formula where you want it. For more information, see Chapter 11 (Graphics, the Gallery, and Fontwork) of this guide.
If the Position section in the Object dialog is grayed out and not available, then By default, formula objects anchored As character are automatically aligned vertically to the baseline of the surrounding text. To align the formula manually, go to Tools > Options > LibreOffice Writer > Formatting Aids and uncheck the option Math baseline alignment. This setting is stored with the document and applies to all formulas within it. Any new documents created will also use this setting for Math baseline alignmentNew documents use the current setting from this dialog.
Object spacing
A formula object, when inserted into a Writer document, has spacing on each side. The default value used for spacing is set within the frame style for formula objects and can be changed by modifying the formula frame style, see the chapters on styles in the Writer Guide for more information.
You can individually adjust the spacing for each formula object within your document as follows:
 554) Margins
 555) An inserted Math object has margins to left and right of it, separating it from surrounding text. If you do not want this, it is best to alter the frame style for formulas, as this will apply simultaneously to all existing formulas and those still to be inserted in the document. Proceed as follows:
 556) Press F11. The Styles and Formatting dialog opens.
 557) Create the formula in your Writer document.
 558) Click on the Frame Styles icon.
 559) Find the Formula frame style and right-click on it.
 560) Right-click on the selected formula object and select Object Choose Modify from the context menu, or go to Format > Frame/Object on the menu bar to open the Object dialog. The Frame Style dialog opens.
 561) Click onSwitch to the Wrap tab to open the Wrap page of the dialog. Change the values for Left and Right in the Object dialog (Figure 98)Spacing section to 0.00.
 562) In the Spacing section, enter the spacing value for Left, Right, Top and Bottom spacing.
 563) Click OK to save your changes and close the Objectclose the dialog.
This changes the spacing for all formulas that have not had their spacing adjusted manually. You can find more information on using styles in “Error: Reference source not found” on page Error: Reference source not found and in Chapter 3 (Using Styles and Templates) of this guide.
[bookmark: __RefHeading__60617_1954213482]Text mode
In large formulas placed within a line of text, the formula elements can often be higher than the text height. Therefore, to make large formulas easier to read, it is recommended to always insert large formulas into a separate paragraph of their own so that it is separated from text.
Larger formulas should always be in a paragraph of their own, separated from the text. When you use formula elements in running text, they can often be higher than the letter height.
However, if it is necessary to place a large formula within a line of text, double-click on the formula to open the Formula Editor and then running text, switch into the equation editor and go to Format > Text Mode on the menu bar. The Formula Editor mode. Math will try to shrink the formula to fit the textletter height. The numerators and denominators of fractions are shrunk, and the limits of integrals and sums are placed beside the integral/sum sign, as shown in the following example.
Example:
A formula in a separate paragraph:

and the same formula embedded into a line of text using text mode formatin text mode: 
[bookmark: __RefHeading__60619_1954213482]Background and borders, borders, and size
The default setting for background (area fill) and borders for formula objects is set by the formula frame style. To change this default setting for formula frame style, refer to the chapters on styles in the Writer Guide. However, for individual formulas in your document, you can change the background and borders.
· Note
The size of the frame that a formula is placed in when inserted into a document cannot be changed. The frame size for a formula object depends on the setting of the formula font size; see the Math Guide for more information.
Backgrounds
 564) In the document, select the formula where you change the background.
 565) Right-click on the formula and select Object from the context menu, or go to Format > Frame/Object on the menu bar to open the object dialog.
 566) Click on the Area tab and select the type of fill you want to use for the formula from the Fill drop-down list (Figure 99).
 567) Select the options you want to use for the formula background. The options change depending on the type of fill selected.
 568) Click OK to save your changes and close the Object dialog.
[image: ]
[bookmark: Ref_Figure358_label_and_number]Figure 99: Object dialog – Area page

Borders
 569) In the document, select the formula where you want to change the borders.
 570) Right-click on the formula and select Object from the context menu, or go to Format > Frame/Object on the menu bar to open the object dialog.
 571) Click on the Borders tab and select the options you want to use for the formula borders (Figure 100).
 572) Click OK to save your changes and close the Object dialog.
[image: ]
[bookmark: Ref_Figure359_label_and_number]Figure 100: Object dialog – Borders page

Quick insertion of formulas
To quickly insert a formula into a Writer document without opening the Formula Editor, where you know the markup language for the formula:
 573) Enter the formula markup language into the document at the position where you want the formula.
 574) Select the markup language.
 575) Go to Insert > Object on the menu bar and select Formula, or click on the Formula icon [image: ] on the Standard toolbar to create a formula from the selected markup language.
· Note
If the Formula icon is not displayed on the Standard toolbar, then right-click in an empty area on the toolbar, select Visible Buttons from the context menu, then select Formula from the available options.
Formulas in Calc, Draw, and Impress
In Calc, Draw, and Impress, formulas are inserted as OLE objects without any background (area fill) or borders. See the Math Guide for more information.
Each formula object is inserted into a spreadsheet, drawing, or slide as follows:
· In Calc, formulas are inserted into a selected cell in a spreadsheet with no style assigned to the formula object.
· In Draw and Impress, formulas are inserted into a central position on a drawing or slide and, by default, are assigned the drawing object style Object with no fill and no line. For more information on how to modify or assign drawing object styles, see the Draw Guide or the Impress Guide.
Anchoring formulas
Calc
A formula object can be anchored into a spreadsheet as To Page (default setting), or as To Cell. To change the anchoring type of formulas in a Calc spreadsheet:
 576) Select the formula object in the spreadsheet.
 577) Right-click on the formula and select Anchor > To Page or To Cell from the context menu
 578) Alternatively, go to Format > Anchor on the menu bar and select To Page or To Cell.
Draw and Impress
When a formula is inserted into a drawing or slide, it is inserted as a floating OLE object and is not anchored to any particular position in a drawing or slide.
Formula object properties
Formula objects in Calc, Draw, and Impress can be modified just like any other object that has been placed in a spreadsheet, drawing, or presentation, with the exception of formula object size and changing the format of any text within a formula. For more information on how to change object properties, see the Calc Guide, Draw Guide, and Impress Guide. For more information on formula object size and formatting formula text, see the Math Guide.
The following points will help you select which dialog to use if you want to change the properties of formula objects.
· For formula backgrounds, use the various options in the pages of the Area dialog.
· For formula borders, use the various options in the Line dialog. Note that formula borders are separate from cell borders in a Calc spreadsheet.
· To accurately re-position a formula object, use the various options in pages of the Position and Size dialog.
· In Draw and Impress, you can be arrange, align, group, flip, convert, break, combine and edit points of formula objects.
· You cannot change the text attributes of a formula object. The text used in a formula is set when you create the formula in the Formula Editor.
· Formula object size is set by the formula font size when the formula is created in the Formula Editor. The formula object size is protected in the Position and Size dialog, but this can be deselected if you so wish. However, this is not recommended as resizing a formula object using the Position and Size dialog could lead to distortion of a formula making it difficult to read.
Formulas in charts
A chart in a Calc spreadsheet is itself an OLE object, therefore, you cannot use the Formula Editor to create and insert a formula into a chart.
To insert a formula into a chart, create the formula first using the Formula Editor and copy the formula to the clipboard. You then create the chart in Calc and paste your formula into the chart. The formula is automatically converted into the correct format for insertion into a chart.
If you want to change the formula at a later date, then you must repeat the whole process of creating, copying and pasting.
With regard to formatting, formulas are treated as objects of the Frame Style type with the Formula frame style. Background color and borders can be set using this style or directly with Format > Frame/Object, or by right-clicking the formula and choosing Object from the context menu. In the default installation, formulas have a transparent background and no borders. The size of a formula cannot be adjusted; in a Writer document it depends directly on the way the formula is constructed (see “Formula font size” on page 74).
Creating a formula library
When you use the Math component of LibreOffice directly from the Start Center or with File > New > Formula, you create documents with the file suffix ODF, each containing a single formula. You can use these to build up a library of frequently-used formulas. Embedded formulas can also be stored as separate Math documents by right-clicking on the formula and choosing Save copy as from the context menu. To insert such a Math document into a Writer document, use Insert > Object > OLE Object. Select the option Create from file and enter the path name of the file or browse for it using your system’s file manager by pressing the Search button.
	Note
	You cannot insert the document by dragging and dropping with the mouse, nor by using Insert > File.


Formulas cannot be stored in the gallery because they are not in graphical format. You can however store a formula as AutoText. Write the formula in a separate paragraph, select it and go to Edit > AutoText. For further information see “Using AutoText” in Chapter 3 (Working with Text) in the Writer Guide.
Fast insertion of formulas
If you already know the markup of your formula, here is a faster method to build your formula:
· Write the formula markup in Writer.
· Select the markup.
· Insert the formula using a toolbar button, a menu item, or a keyboard shortcut.
This method avoids the need to open and close the Math window and thus saves time.
Customizations
Customizing the catalog
If you need to use a symbol that is not available in Math, you can add it to the catalog yourself. The following example shows the procedure for symbols that are used in marking school work.
3) Go to Tools > Catalog or click on the catalog button [image: ] to open the Symbols catalog (Error: Reference source not found).
4) Click the Edit button. The Edit symbols dialog (Error: Reference source not found) opens.
5) The symbols are arranged in symbol sets. In the lower part of the window, choose an available set for your new symbol from the Symbol set list, for example the Special set. Or you can type the name of a new symbol set directly into the box.
6) From the Font list, choose a font that contains the desired symbol.
When you have selected a font, its characters appear in the font summary window. You can scroll through it using the scrollbar at the side, or use the Subset list to go straight to the place you need.
To follow this example, choose the font DejaVu Sans and the subset General punctuation.
7) Click on the desired symbol (here Ux2032). It appears enlarged in the right-hand preview box (see Error: Reference source not found). Make sure that the symbol set is set to Special.
8) In the Symbol field, enter a name for the symbol, for example prime.
9) If the name is not already in use, the Add button becomes active. Click on it.
10) You can immediately add more symbols. In the example, the “U+2033” symbol, named dblprime, and the “U+2034” symbol, named triprime, are added (see Error: Reference source not found).
11) Click OK to close the dialog.
[image: ]Figure 101: Edit Symbols dialog

[image: ]
Figure 102: Edit Symbols dialog: characters selected

Now the Symbol set view area shows the new symbol. It can be selected just like the other symbols, either from here, or by writing them directly into the equation editor in the form %prime.
	Caution
[image: ]
	Symbols (Greek or Special), in contrast to commands, are case sensitive (lowercase/uppercase). 


Numerous free fonts contain a great number of mathematical symbols. The “STIX[footnoteRef:3]” font is worthy of special mention here. It was developed specially for writing mathematical/technical texts. The DejaVu[footnoteRef:4] and Lucida[footnoteRef:5] fonts also have a wide range of symbols. [3: 	Font files for STIX are available from http://www.stixfonts.org ]  [4: 	Font files for DejaVu Sans are available from http://www.dejavu-fonts.org ]  [5: 	Lucida Sans belongs to the JRE package, which is probably already on your computer.] 

[image: ]
Figure 103: Catalog with new symbol

	Note
	Many symbols occur in more than one font. If you want to exchange documents with others, take care to use a font that is installed on their machine.


In the default LibreOffice installation, only those user-defined symbols that actually occur in the document are stored with it. Sometimes it is useful to embed all the user-defined symbols, for example when the document is going to be further edited by another person. Go to Tools > Options > LibreOffice Math and on the Settings page, uncheck the option Embed only used symbols (smaller file size).This setting is only available when you are working on a Math document.
Default layout with style
In Writer, formulas are formatted according to the Formula frame style. In the Style and Formatting window (displayed with F11), click on the third icon at the top: Frame Styles. Right-click on Formula and select Modify. By this means, you can directly modify all formulas in your document, with regard to spacing (page Error: Reference source not found) or background (page Error: Reference source not found), unless you manually modify formula formatting.[image: ]
Figure 104 : Modify Frame Style Formula

To apply this style in all your new Writer documents, you must include the Formula style in your default template. To do so, create a new Writer document and modify the Formula frame style as you wish. Save the document using File > Save as Template and save it into My Templates with a name of your choice. To define this template as your default template, select the template you just created and choose Set as default. If you wish to return to the default template given at installation, open the Template Manager (File > Templates > Manage), click on the Action Menu and point to Reset Default Template, on the drop-down menu, and click Text Document. This menu choice does not appear unless a custom template has been set as the default.
The next time that you create a document by choosing File > New, the document will be created from the new default template.
For more information on the Template Manager, see Chapter 9, Styles and Templates.
Application to chemical formulas
Math was designed to build mathematical formulas, but it can also be used to write chemical formulas. In chemistry, formulas look like H2O: names are usually non-italic uppercase. To write chemical formulas with Math, deselect the Italic attribute in the Fonts dialog (see “Formula fonts” on page 75).
Here some examples of chemical formulas:
	Construction
	Example
	Entry

	Molecules
	
	H_2 SO_4 (please note the space!)

	Isotopes
	
	U lsub 92 lsup 238

	Ions
	
	SO_4^{2-{}} or SO_4^{2"-"}


Notes: lsub or lsup are abbreviations for left subscript and left superscript. Empty braces after 2- are necessary to avoid errors as there is no right member after the minus sign.
For reversible reactions, there is no satisfactory double arrow in Math. If you have a font with a suitable symbol, you may use the method described in “Error: Reference source not found” on page Error: Reference source not found. For instance, DejaVu fonts have these double arrows ⇄ ⇆ ⇋ ⇌.
Alternatively, if you find a special character in a document you can copy it, for example here in this formula:  "⇌". Other double arrows can be found here:	
 from character x021C4, or here: , which is a subset of this location: http://www.unicode.org/charts/#symbols
Math commands – Reference
The complete list of commands and reserved words used by Math is available in the Math Guide:
· Unary / binary operators
· Relations
· Set operations
· Functions
· Operators
· Attributes
· Brackets
· Formats
· Others
· Characters – Greek
· Characters – Special
· Reserved words in alphabetic order
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[bookmark: __RefHeading___Toc135360_811363531]Quick printing
Click the Print File Directly icon ([image: ]) to send the entire document to the default printer defined for your computer.
· Note
You can change the action of the Print File Directly icon to send the document to the printer defined for the document instead of the default printer for the computer. Go to Tools > Options > Load/Save > General and select the Load printer settings with the document option.
	Note
	You can change the action of the Print File Directly icon to send the document to the printer defined for the document instead of the default printer for the computer. Go to Tools > Options > Load/Save > General and select the Load printer settings with the document option.


[bookmark: __RefHeading__171723_780470623]Controlling printing
For more control over printing, use the Print dialog (File > Print or Ctrl+P).
[image: ]
Figure 105: The Print dialog

· Note
The options selected on the Print dialog apply to this printing of this document only.
To specify default printing settings for LibreOffice, go to Tools > Options > LibreOffice > Print and Tools > Options > LibreOffice [Component] > Print. See Chapter 2, Setting Up LibreOffice, for more details.
	Note
	The options selected on the Print dialog apply to this printing of this document only.
To specify default printing settings for LibreOffice, go to Tools > Options > LibreOffice – Print and Tools > Options > LibreOffice Writer – Print. See Chapter 2, Setting Up LibreOffice, for more details.


The Print dialog has four pages, from which you can choose a range of options, as described in the following sections.
The different components of LibreOffice have different available print settings, as summarized in Table 2.
[bookmark: Ref_Table10_number_only]Table 2: Print options in LibreOffice components
	Feature
	Writer
	Calc
	Impress
	Draw

	Select pages/sheets/slides to print
	Yes
	Yes
	Yes
	Yes

	Print multiple pages/sheets/slides on one page
	Yes
	Yes
	Yes
	Yes

	Print a brochure
	Yes
	No
	Yes
	Yes

	Print envelopes
	Yes
	No
	No
	No

	Print labels or business cards
	Yes
	No
	No
	No

	Preview pages/sheets before printing
	Yes
	Yes
	No
	No


[bookmark: __RefHeading__18347_1712854287]Selecting general printing options
On the General tab of the Print dialog, you can choose:
· The printer (from the printers available).
· Which pages to print, the number of copies to print, and whether to collate multiple copies (Range and copies section).
· Whether to print any comments that are in the document, and where to print the comments.
Some selections may not be available all the time. For example, if the document contains no comments, the Print – Comments drop-down list does not work.
[image: ]
Figure 106: Choosing whether and where to print comments

Select the Properties button to display the selected printer’'s properties dialog where you can choose portrait or landscape orientation, which paper tray to use, and the paper size to print on.
On the Options tab of the Print dialog (Figure 107), the last item, Use only paper tray from printer preference, is not available in Calc.
[image: ]
[bookmark: Ref_Figure362_label_and_number]Figure 107: General print options

[bookmark: __RefHeading__8511_1712854287]Printing multiple pages on a single sheet of paper
You can print multiple pages of a document on one sheet of paper. To do this:
 579) In the Print dialog, select the Page Layout tab (Figure 108).
[image: ]
[bookmark: Ref_Figure363_label_and_number]Figure 108: Printing multiple page per sheet of paper

 580) In the Layout section, select from the drop-down list the number of pages to print per sheet. The preview panel on the left of the Print dialog shows how the printed document will look.
When printing more than 2 pages per sheet, you can choose the order in which they are printing across and down the paper. 
[image: ]
 581) In the Page sides section, select whether to print all pages or only some pages. Click the OK button.
· Tip
In Writer, to print two pages per sheet in “facing pages” (book layout) style, print from Print Preview instead. See page 101.
	Tip
	In Writer, to print two pages per sheet in “facing pages” (book layout) style, print from Print Preview instead. See page 101.


[bookmark: __RefHeading__74168_1365249792]Selecting pages/sheets/slides to print
In addition to printing a full document, you can choose to print individual pages/sheets/slides, ranges of pages/sheets/slides, or a selection of a document. The details vary slightly in Writer, Calc, Draw and Impress, as described in this section.
[bookmark: __RefHeading__8519_1712854287]Writer
Printing an individual page:
 582) Choose File > Print from the Menu bar, or press Ctrl+P.
 583) On the Print dialog, select the page to print.
1. In the RangeRanges and copies section of the General page, select the Pages option. The text input box displays the current page number.
ag) Enter the page number of the page you want to print. The preview box changes to show the selected page.
 584) Click OKthe OK button.
Printing a range of pages:
 585) Choose File > Print from the Menu bar, or press Ctrl+P.
 586) On the Print dialog, select the range of pages to print.
1. In the RangeRanges and copies section of the General page, select the Pages option.
ai) Enter the sequence numbers of the pages to print (for example, 1–4 or 1,3,7,11).
 587) Click OKthe OK button.
Printing a selection of text:
 588) In the document, select the material (text and graphics) to print.
 589) Choose File > Print from the Menu bar, or press Ctrl+P.
 590) The RangeRanges and copies section of the Print dialog now includes a Selection option and the preview box shows the selected material. See Figure 109.
 591) Click OKthe OK button.
[image: ]
[bookmark: Ref_Figure364_label_and_number]Figure 109: Printing a selection of text

[bookmark: __RefHeading__8521_1712854287]Calc
You can choose single sheets, multiple sheets, and selections of cells for printing.
[image: ]
Figure 110: Choosing what to print in Calc

Printing an individual sheet:
1. In the spreadsheet, click on the sheet tab to select the sheet you want to print.
1) Choose File > Print from the Menu bar, or press Ctrl+P.
2) In the RangeRanges and copies section of the Print dialog, choose the Selected sheets option.
3) Click OKthe OK button.
Printing a range of sheets:
4) In the spreadsheet, select the sheets to print.
1. Select the first sheet.
ak) Hold down the Control key.
al) Click on the additional sheet tabs.
am) Release the Control key when all required sheets are selected.
5) Choose File > Print from the Menu bar, or press Ctrl+P.
6) In the RangeRanges and copies section of the Print dialog, choose the Selected sheets option.
7) Click OKthe OK button.
Printing a selection of cells:
 592) In the document, select the section of cells to print.
 593) Choose File > Print from the Menu bar, or press Ctrl+P.
 594) In the Ranges and copies section of the Print dialog, select the Selected cells option.
 595) Click OKthe OK button.
· Caution
After printing, be sure to deselect the extra sheets. If you keep them selected, the next time you enter data on one sheet, you enter data on all the selected sheets. This might not be what you want.
	Caution
[image: ]
	After printing, be sure to deselect the extra sheets. If you keep them selected, the next time you enter data on one sheet, you enter data on all the selected sheets. This might not be what you want.


[bookmark: __RefHeading__8523_1712854287]Impress and Draw
You can choose individual slides, ranges of slides, or selections of slides for printing.
[image: ]
Figure 111: Choosing what to print in Impress and Draw

Printing an individual slide:
 596) Choose File > Print from the Menu bar, or press Ctrl+P.
 597) Select the slide to print.
1. In the RangeRanges and copies section of the Print dialog, select the Slides option.
ao) Enter the number of the slide to print.
 598) Click OKthe OK button.
Printing a range of slides:
 599) Choose File > Print from the Menu bar, or press Ctrl+P.
 600) Select the slides to print.
1. In the RangeRanges and copies section of the Print dialog, select the Slides option.
aq) Enter the number of the slides to print (for example 1-4 or 1,3,7,11).
 601) Click OKthe OK button.
Printing a selection from a slide, or a selection from multiple slides:
 602) In the document, select the section of the slide to print.
 603) Choose File > Print from the Menu bar, or press Ctrl+P.
 604) Select the Selection option in the RangeRanges and copies section of the Print dialog.
 605) Click OKthe OK button.
[bookmark: __RefHeading__8525_1712854287]Printing handouts, notes, or outlines in Impress
Handouts prints the slides in reduced size on the page, from one to nine slides per page. The slides can be printed horizontally (landscape orientation) or vertically (portrait orientation) on the page.
Notes prints a single slide per page with any notes entered for that slide in Notes View.
Outline prints the title and headings of each slide in outline format.
To print handouts, notes, or outlines:
 606) Choose File > Print from the Menu bar, or press Ctrl+P.
 607) In the Print section of the Print dialog, select the required option.
 608) For Handouts, you can then choose how many slides to print per page, and the order in which they are printed.
 609) Click OKthe OK button.
[image: ]
[bookmark: __RefHeading__11351_1712854287]Printing a brochure
In Writer, Impress, and Draw, you can print a document with two pages on each side of a sheet of paper, arranged so that when the printed pages are folded in half, the pages are in the correct order to form a booklet or brochure.
· Tip
Plan your document so it will look good when printed half size; choose appropriate margins, font sizes, and so on. You may need to experiment.
	Tip
	Plan your document so it will look good when printed half size; choose appropriate margins, font sizes, and so on. You may need to experiment.


To print a brochure on a single-sided printer:
 610) Choose File > Print, or press Ctrl+P.
 611) In the Print dialog, click Properties.
 612) Check the printer is set to the same orientation (portrait or landscape) as specified in the page setup for your document. Usually the orientation does not matter, but it does for brochures. Click OK to return to the Print dialog.
 613) Select the Page layout tab in the Print dialog.
 614) Select the Brochure option.
 615) In the Page sides section, select the Back sides / left pages option from the Include drop-down list. Click OK.
[image: ]
Figure 112: Selecting which pages to print

 616) Click the OK button.
 617) Take the printed pages out of the printer, turn the pages over, and put them back into the printer in the correct orientation to print on the blank side. You may need to experiment a bit to find out what the correct arrangement is for your printer.
 618) On the Print dialog, in the Page sides section, select the Front sides / right pages option from the Include drop-down box. Click OK down box.
· Tip
If your printer can print double-sided automatically, choose All pages.
Click the OK button.
	12) Tip
	13) If your printer can print double-sided automatically, choose All pages.


[bookmark: __RefHeading__19566_697337876]Printing envelopes, labels, business cards
Printing envelopes, labels, or business cards using Writer involves two steps: setup and printing.
For details of how to set these up, see Chapter 11, Using Mail Merge, in the Writer Guide. To print:
1. Choose File > Print from the Menu bar, or press Ctrl+P.
 1) On the Print dialog, under Range and copies, choose Pages and type 1 in the box. Click OKthe OK button.
[bookmark: __RefHeading__18349_1712854287]Printing in black and white (on a color printer)
You may wish to print documents in black and white on a color printer. Several choices are available. Please note that some color printers may print in color regardless of the settings you choose.
Change the printer settings to print in black and white or grayscale:
 619) Choose File > Print, or press Ctrl+P, to open the Print dialog.
 620) Click Properties to open the Properties dialog for the printer. The available choices vary from one printer to another, but you should find options for the Color settings. See your printer’s help or user manual for more information.
 621) The choices for color might include black and white or grayscale. Choose the required setting.
 622) Click OK to confirm your choice and return to the Print dialog,
 623) Click OKthe OK button to print the document.
· Tip
Grayscale is best if you have any graphics in the document.
	Tip
	Grayscale is best if you have any graphics in the document.


Change the LibreOffice settings to print all color text and graphics as grayscale:
1. Choose Tools > Options > LibreOffice > Print.
 1) Select the Convert colors to grayscale option. Click OK to save the change.
 2) Open the Print dialog (File > Print), or press Ctrl+P.
 3) Click OKthe OK button to print the document.
Change the LibreOffice Writer (or Calc, Impress, Draw) settings to print all color text as black, and all graphics as grayscale:
1. Choose Tools > Options > LibreOffice Writer > Print.
 1) Under Contents, select the Print text in black option. Click OK to save the change.
 2) Open the Print dialog (File > Print), or press Ctrl+P.
 3) Click OKthe OK button to print the document.
[bookmark: __RefHeading__18351_1712854287]Previewing pages/sheets before printing
You can use the previewing options in Writer and Calc to view the document as it will be printed. Different viewing options are available.
[bookmark: __RefHeading__8515_1712854287]Writer
The normal page view in Writer shows you what each page will look like when printed and you can edit the pages in that view. If you are designing a document to be printed double-sided, you may want to see what facing pages look like. Writer provides two ways to do this:
· View Layout (editable view): use the Facing Pages (Book viewPreview) button on the status bar.
[image: ]
· PrintPage Preview (read-only view).
To use PrintPage Preview:
1. Choose File > PrintPage Preview, click the PrintPage Preview button ([image: ]) on the Standard toolbar or press Ctrl+Shift+O.
Writer now displays the PrintPage Preview toolbar instead of the Formatting toolbar.
[image: ]
Figure 113: Print Preview toolbar (Writer)

1) Select the required preview icon: Two Pages ([image: ]), Multiple Pages ([image: ]) or Book Preview ([image: ]).
2) To print the document from this view, click the Print document icon ([image: ]) to open the Print dialog. Choose the print options and click the OK button.
[bookmark: __RefHeading__8517_1712854287]Calc
To preview the sheets in Calc before printing:
 3) Choose File > PrintPage Preview.
The Calc window now displays the PrintPage Preview toolbar instead of the Formatting toolbar.
[image: ]
Figure 114: Print Preview toolbar (Calc)

4) To print the document from this view, click the Print document icon ([image: ]) to open the Print dialog.
5) Choose the print options and click the Print button.
[bookmark: __RefHeading__8527_1712854287]Exporting to PDF
LibreOffice can export documents to PDF (Portable Document Format). This industry-standard file format is ideal for sending the file to someone else to view using Adobe Reader or other PDF viewers.
The process and dialogs are the same for Writer, Calc, Impress, and Draw, with a few minor differences mentioned in this section.
[bookmark: __RefHeading__171727_780470623]Quick export to PDF
Click the Export Directly as PDF icon ([image: ]) to export the entire document using the PDF settings you most recently selected on the PDF Options dialog (see below). You are asked to enter the file name and location for the PDF file, but you do not get a chance to choose a page range, the image compression, or other options.
[bookmark: __RefHeading__171729_780470623]Controlling PDF content and quality
For more control over the content and quality of the resulting PDF, use File > Export as PDF. The PDF Options dialog opens. This dialog has sixfive pages (General, Initial View, User Interface, Links, Security, and Digital Signaturesand Security). Select the appropriate settings, and then click Export. Then you are asked to enter the location and file name of the PDF to be created, and click Save to export the file.
· Note
Another choice is to use File >  Export. This opens the Export dialog. Select the PDF file format, file name and location and click Export. This then opens the PDF Options dialog. Click Export when all the selections have been made.
	Note
	Another choice is to use File >  Export. This opens the Export dialog. Select the PDF file format, file name and location and click Export. This then opens the PDF Options dialog, as described above. Click Export when all the selections have been made.


[bookmark: __RefHeading__171731_780470623]General page of PDF Options dialog
On the General page, you can choose which pages to include in the PDF, the type of compression to use for images (which affects the quality of images in the PDF), and other options.
[image: ]
Figure 115: General page of PDF Options dialog

Range section
1. All: Exports the entire document to PDF.
· Pages: To export a range of pages, use the format 3-6 (pages 3 to 6). To export single pages, use the format 7;9;11 (pages 7, 9 and 11). You can also export a combination of page ranges and single pages, by using a format like 3-6;8;10;12.
· Selection: Exports all the selected material.
Images section
1. Lossless compression:  Images are stored without any loss of quality. Tends to make large files when used with photographs. Recommended for other kinds of images or graphics.
· JPEG compression: Allows for varying degrees of quality. A setting of 90% works well with photographs (small file size, little perceptible loss of quality).
· Reduce image resolution: Lower DPI (dots per inch) images have lower quality. For viewing on a computer screen, generally a resolution of 72dpi (for Windows) or 96dpi (GNU/Linux) is sufficient, while for printing it is generally preferable to use at least 300 or 600dpi, depending on the capability of the printer. Higher DPI settings greatly increase the size of the exported file.
· Note
EPS (Encapsulated PostScript) images with embedded previews are exported only as previews. EPS images without embedded previews are exported as empty placeholders.
	Note
	EPS (Encapsulated PostScript) images with embedded previews are exported only as previews. EPS images without embedded previews are exported as empty placeholders.


Watermark section
· Sign with Watermark: When this option is selected, a transparent overlay of the text you enter into the Watermark Text box will appear on each page of the PDF.
General section
· Hybid PDF (embed ODF file)Embed OpenDocument file: Use this setting to export the document as a PDF file containing two file formats: PDF and ODF. In PDF viewers it behaves like a normal PDF file, and it remains fully editable in LibreOffice.
1. Archive PDF/A-1a (ISO 19005-1): PDF/A is an ISO standard for long-term preservation of documents, by embedding all the information necessary for faithful reproduction (such as fonts) while forbidding other elements (including forms, security, and encryption). PDF tags are written. If you select PDF/A-1a, the forbidden elements are grayed-out (not available).
· Tagged PDF: Tagged PDF contains information about the structure of the document’s contents. This can help to display the document on devices with different screens, and when using screen reader software. Some tags that are exported are table of contents, hyperlinks, and controls. This option can increase file sizes significantly.
· Create PDF form – Submit format: Choose the format of submitting forms from within the PDF file. This setting overrides the control’s URL property that you set in the document. There is only one common setting valid for the whole PDF document: PDF (sends the whole document), FDF (sends the control contents), HTML, and XML. Most often you will choose the PDF format.
Allow duplicate field names: If enabled, the same field name can be used for multiple fields in the generated PDF file. If disabled, field names will be exported using generated unique names.
· Export bookmarks: Exports headings in Writer documents, and page or slide names in Impress and Draw documents, as “bookmarks” (a table of contents list displayed by most PDF viewers, including Adobe Reader).
· Export comments: Exports comments as PDF notes. You may not want this!
· Export automatically inserted blank pages: If selected, automatically inserted blank pages are exported to the PDF. This is best if you are printing the PDF double-sided. For example, books usually have chapters set to always start on an odd-numbered (right-hand) page. When the previous chapter ends on an odd page, LibreOffice inserts a blank page between the two odd pages. This option controls whether to export that blank page.
· View PDF after export: Your default PDF viewer will open and display the newly exported PDF.
Earlier versions of LibreOffice had the option:
· Embed standard fonts: Normally the 14 standard PostScript fonts were not embedded in a PDF file, because PDF readers already contained these fonts. However, you could choose to embed these fonts in all PDF documents created by LibreOffice to enhance display accuracy in PDF viewers. The PostScript fonts are now embedded by default.
[bookmark: __RefHeading__171733_780470623]Initial View page of PDF Options dialog
On the Initial View page (Figure 116), you can choose how the PDF opens by default in a PDF viewer. The selections should be self-explanatory.
If you have Complex Text Layout enabled (in Tools > Options > Language settings > Languages), an additional selection is available under Continuous facing: First page is left (normally, the first page is on the right when using the Continuous facing option).
[image: ]
[bookmark: Ref_Figure371_label_and_number]Figure 116: Initial View page of PDF Options dialog

[bookmark: __RefHeading__4236_1385231065]User Interface page of PDF Options dialog
On the User Interface page, you can choose more settings to control how a PDF viewer displays the file. Some of these choices are particularly useful when you are creating a PDF to be used as a presentation or a kiosk-type display.
[image: ]
Figure 117: User Interface page of the PDF Options dialog

Window options section
1. Resize window to initial page. Causes the PDF viewer window to resize to fit the first page of the PDF.
· Center window on screen. Causes the PDF viewer window to be centered on the computer screen.
· Open in full screen mode. Causes the PDF viewer to open full-screen instead of in a smaller window.
· Display document title. Causes the PDF viewer to display the document’s title in the title bar.
User interface options section
1. Hide menubar. Causes the PDF viewer to hide the menu bar.
· Hide toolbar. Causes the PDF viewer to hide the toolbar.
· Hide window controls. Causes the PDF viewer to hide other window controls.
Transitions
In Impress, displays slide transition effects as their respective PDF effects.
Bookmarks
Select how many heading levels are displayed as bookmarks, if Export bookmarks is selected on the General page.
[bookmark: __RefHeading__171737_780470623]Links page of PDF Options dialog
On the Links page, you can choose how links are exported to PDF.
[image: ]
Figure 118: Links page of PDF Options dialog

Export bookmarks as named destinations
If you have defined Writer bookmarks, Impress or Draw slide names, or Calc sheet names, this option exports them as “named destinations” to which Web pages and PDF documents can link.
Convert document references to PDF targets
If you have defined links to other documents with OpenDocument extensions (such as .odt, .ods, and .odp), this option converts the files’' extensions to .pdf in the exported PDF document.
Export URLs relative to file system
If you have defined relative links in a document, this option exports those links to the PDF.
Cross-document links
Defines the behavior of links clicked in PDF files. Select one among the following alternatives:
· Default mode: The PDF links will be handled as specified in your operating system.
· Open with PDF reader application: Use the same application used to display the PDF document to open linked PDF documents.
· Open with Internet browser: Use the default Internet browser to display linked PDF documents.
[bookmark: __RefHeading__171739_780470623]Security page of PDF Options dialog
PDF export includes options to encrypt the PDF (so it cannot be opened without a password) and apply some digital rights management (DRM) features.
· With an open password set, the PDF can only be opened with the password. Once opened, there are no restrictions on what the user can do with the document (for example, print, copy, or change it).
· With a permissions password set, the PDF can be opened by anyone, but its permissions can be restricted. See Figure 119. After you set a password for permissions, the other choices on the Security page become available.
· With both the open password and permission password set, the PDF can only be opened with the correct password, and its permissions can be restricted.
· Note
Permissions settings are effective only if the user’s PDF viewer respects the settings.
	Note
	Permissions settings are effective only if the user’s PDF viewer respects the settings.


[image: ]
[bookmark: Ref_Figure374_label_and_number]Figure 119: Security page of PDF Options dialog

Figure 120 shows the pop-up dialog displayed when you click the Set passwordsopen password button on the Security page of the PDF Options dialog.
WhenOnce you have set all the options you require, click on Export to open the Export dialog, where you can set the file name and the save location.
[image: ]
[bookmark: Ref_Figure375_label_and_number]Figure 120: Setting a password to encrypt a PDF

Digital Signatures page of PDF Options dialog
This page contains the options related to exporting to a digitally signed PDF.
Digital signatures are used to ensure that the PDF was really created by the original author (that is, you), and that the document has not been modified since it was signed.
The signed PDF export uses the keys and X.509 certificates already stored in your default key store location or on a smartcard. The key store to be used can be selected under Tools > Options > LibreOffice > Security > Certificate Path. When using a smartcard, it must already be configured for use by your key store. This is usually done during installation of the smartcard software. Details about using these features is outside the scope of this chapter.
[image: ]
· Use this certificate to digitally sign PDF documents: Click Select to open the Select Certificate dialog, where all certificates found in your selected key store are displayed. If the key store is protected by a password, you are prompted for it. When using a smartcard that is protected by a PIN, you are also prompted for that. 
Select the certificate to use for digitally signing the exported PDF, then click OK.
All other fields on the Digital Signatures tab are accessible only after a certificate has been selected.
· Certificate password: Enter the password used for protecting the private key associated with the selected certificate. Usually this is the key store password. If the key store password has already been entered in the Select Certificate dialog, the key store may already be unlocked and not require the password again.
When using a smartcard, enter the PIN here. Some smartcard software will prompt you for the PIN again before signing.
· Location, Contact information, Reason: Optionally enter additional information about the digital signature that will be applied to the PDF. This information will be embedded in the appropriate PDF fields and will be visible to anyone viewing the PDF. Each or all of the three fields may be left blank.
· Time Stamp Authority: Optionally select a Time Stamping Authority (TSA) URL. During the PDF signing process, the TSA will be used to obtain a digitally signed timestamp that is then embedded in the signature. Anyone viewing the PDF can use this timestamp to verify when the document was signed.
The list of TSA URLs that can be selected is maintained under Tools > Options > LibreOffice > Security > TSAs. If no TSA URL is selected (the default), the signature will not be timestamped, but will use the current time from your local computer.
[bookmark: __RefHeading__4238_1385231065]Exporting to other formats
LibreOffice uses the term “export” for some file operations involving a change of file type. If you cannot find what you want under File > Save As, look under File > Export as well.
LibreOffice can export files to XHTML. In addition, Draw and Impress can export to Adobe Flash (SWF) and a range of image formats.
To export to one of these formats, choose File > Export. On the Export dialog, specify a file name for the exported document, then select the required format in the File format list and click the Export button.
[bookmark: __RefHeading__171743_780470623]E-mailing documents
LibreOffice provides several ways to send documents quickly and easily as e-mail attachments in one of three formats: OpenDocument (LibreOffice’s default format), Microsoft Office formats, or PDF.
· Note
Documents can only be sent from the LibreOffice menu if a mail profile has been set up in Tools > Options > LibreOffice Writer > Mail Merge E-mail.
	Note
	Documents can only be sent from the LibreOffice menu if a mail profile has been set up in Tools > Options > LibreOffice Writer > Mail Merge E-mail.


To send the current document in OpenDocument format:
1. Choose File > Send > Document as E-mail. LibreOffice opens your default e-mail program. The document is attached.
 1) In your e-mail program, enter the recipient, subject, and any text you want to add, then send the e-mail.
File > Send > E-mail as OpenDocument [(Text, Spreadsheet, or Presentation]) has the same effect.
If you choose E-mail as Microsoft [Word, Excel, or PowerPoint], LibreOffice first creates a file in one of those formats and then opens your e-mail program with the file attached.
Similarly, if you choose E-mail as PDF, LibreOffice first creates a PDF using your default PDF settings (as when using the Export Directly as PDF toolbar button) and then opens your email program with the PDF file attached.
[bookmark: __RefHeading__171745_780470623]E-mailing a document to several recipients
To e-mail a document to several recipients, you can use the features in your e-mail program or you can use LibreOffice’s mail merge facilities to extract email addresses from an address book.
You can use LibreOffice’s mail merge to send e-mail in two ways:
1. Use the Mail Merge Wizard to create the document and send it. See Chapter 11, Using Mail Merge, in the Writer Guide for details.
· Create the document in Writer without using the Wizard, then use the Wizard to send it. This method is described here.
To use the Mail Merge Wizard to send a previously-created Writer document:
1. Click Tools > Mail Merge Wizard. On the first page of the wizard, select Use the current document and click Next.
[image: ]
Figure 121: Select starting document

 1) On the second page, select E-mail message and click Next.
[image: ]
Figure 122: Select document type

 2) On the third page, click the Select Address List button. Select the required address list (even if only one is shown) and then click OK. (If the address list you need is not shown here, you can click Add to find it and add it to the list.)
[image: ]
Figure 123: Selecting an address list

 3) Back on the Select address list page, click Next. On the Create salutation page, deselect This document should contain a salutation.
[image: ]
Figure 124: Deselecting a salutation

 4) In the left-hand list, click 8. Save, print or send. LibreOffice displays a “Creating documents” message and then displays the Save, print or send page of the Wizard.
 5) Select Send merged document as E-Mail. The lower part of the page changes to show e‑-mail settings choices. See Figure 125.
 6) Type a subject for your email and click Send documents. LibreOffice sends the e-mails.
[image: ]
[bookmark: Ref_Figure380_label_and_number]Figure 125: Sending a document as an email message

[bookmark: __RefHeading__171747_780470623]Digital signing of documents
To sign a document digitally, you need a personal key, also known as a certificate. A personal key is stored on your computer as a combination of a private key, which must be kept secret, and a public key, which you add to your documents when you sign them. You can get a certificate from a certification authority, which may be a private company or a governmental institution.
When you apply a digital signature to a document, a kind of checksum is computed from the document’s content plus your personal key. The checksum and your public key are stored together with the document.
When someone later opens the document on any computer with a recent version of LibreOffice, the program will compute the checksum again and compare it with the stored checksum. If both are the same, the program will signal that you see the original, unchanged document. In addition, the program can show you the public key information from the certificate. You can compare the public key with the public key that is published on the web site of the certificate authority. Whenever someone changes something in the document, this change breaks the digital signature.
On Windows operating systems, the Windows features of validating a signature are used. On Solaris and Linux systems, files that are supplied by Thunderbird, Mozilla or Firefox are used. For a more detailed description of how to get and manage a certificate, and signature validation, see “About Digital Signatures” in the LibreOffice Help.
To sign a document:
 624) Choose File > Digital Signatures. If you have set LibreOffice to warn you when the document contains comments (see “” below), you may see a message box asking whether you want to want to continue signing the document. 
 625) Choose File > Digital Signatures.
 626) If you have not saved the document since the last change, a message box appears. Click Yes to save the file. 
 627) The Digital Signatures dialog opens. Click Sign Document to add a public key to the document.
 628) In the Select Certificate dialog, select your certificate and click OK to return to the Digital Signatures dialog.
 629) The certificate used is displayed in the dialog with an icon next to its name.
This icon indicates the status of the digital signature.
· An icon with a red seal ([image: ]) indicates that the document was signed and the certificate was validated.
· An icon with a yellow caution triangle overlaying the red seal ([image: ]) indicates that the document is signed but that the certificate could not be validated.
· An icon of a yellow caution triangle ([image: ]) indicates an invalid digital signature.
 630) Click Close to apply the digital signature.
A signed document shows an icon in the status bar. You can double-click the icon to view the certificate. More than one signature can be added to a document.
[bookmark: __RefHeading__9455_1957009194]Removing personal data
You may wish to ensure that personal data, versions, notes, hidden information, or recorded changes are removed from files before you send them to other people or create PDFs from them.
In Tools > Options > LibreOffice > Security > Options, you can set LibreOffice to remind (warn) you when files contain certain information and remove personal information automatically on saving.
[bookmark: __RefHeading__5648_15665686447]To remove personal and some other data from a file, go to File > Properties. On the General tab, uncheck Apply user data and then click the Reset Properties button. This removes any names in the created and modified fields, deletes the modification and printing dates, and resets the editing time to zero, the creation date to the current date and time, and the version number to 1.
To remove version information, either (a) go to File > Versions, select the versions from the list and click Delete; or (b) use File > Save As and save the file with a different name.
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[bookmark: __RefHeading___Toc135362_811363531]Introduction
You can add graphic and image files, including photos, drawings, scanned images, and others, to LibreOffice documents. LibreOffice can import various vector (line drawing) and raster (bitmap) file formats. The most commonly used graphic formats are GIF, JPG, PNG, and BMP. See Appendix B for a full list of the graphic formats LibreOffice can import.
Graphics in LibreOffice are of three basic types:
· Image files, such as photos, drawings, and scanned images
· Diagrams created using LibreOffice’s drawing tools
· Charts created using LibreOffice’s Chart component
This chapter covers images and diagrams.
More detailed descriptions on working with drawing tools can be found in the Draw Guide and Impress Guide. Instructions on how to create charts are given in the Calc Guide.
[bookmark: __RefHeading__13175_2065861793]Adding images to a document
Images can be added to a document in several ways: by inserting an image file, directly from a graphics program or a scanner, from a file stored on your computer, or by copying and pasting from a source being viewed on your computer.
[bookmark: __RefHeading__13177_2065861793]Inserting an image file
When the image is in a file stored on the computer, you can insert it into an LibreOffice document using either of the following methods.
[bookmark: __RefHeading__13801_2065861793]Drag and drop
 631) Open a file browser window and locate the image you want to insert.
 632) Drag the image into the LibreOffice document and drop it where you want it to appear. A faint vertical line marks where the image will be dropped.
This method embeds (saves a copy of) the image file in the document. To link the file instead of embedding it, hold down the Ctrl+Shift keys while dragging the image.
[bookmark: __RefHeading__13179_2065861793]Insert Image dialog
 633) Click in the LibreOffice document where you want the image to appear.
 634) Choose Insert > Image > From File from the menu bar.
 635) On the Insert Image dialog, navigate to the file to be inserted, and select it.
 636) At the bottom of the dialog (Figure 126) are two options, Preview and Link. Select Preview to view a thumbnail of the selected image in the preview pane on the right, so that you can verify that you have the correct file. See page 116 for the use of Link.
 637) Click Open.
· Note
If you choose the Link option, a message box appears when you click Open. It asks if you want to embed the graphic instead. Choose Keep Link if you want the link, or Embed Graphic if you do not. To prevent this message from appearing again, deselect the option Ask when linking a graphic at the bottom of the message.
	Note
	If you choose the Link option, a message box appears when you click Open. The message states that the picture will not be stored with the document, but only referenced as a link, and asks if you want to embed the graphic instead. Choose Keep Link if you want the link, or Embed Graphic if you do not. To prevent this message from appearing again, deselect the box by Ask when linking a graphic at the bottom of the message.


[image: ]
[bookmark: Ref_Figure381_label_and_number]Figure 126: Insert Image dialog

[bookmark: __RefHeading__13183_2065861793]Linking an image file
If the Link option in the Insert picture dialog is selected, LibreOffice creates a link to the file containing the image instead of saving a copy of the image in the document. The result is that the image is displayed in the document, but when the document is saved, it contains only a reference to the image file, —not the image itself. The document and the image remain as two separate files, and they are merged together only when you open the document again.
Linking an image has two advantages and one disadvantage:
· Advantage – Linking can reduce the size of the document when it is saved, because the image file itself is not included. File size is usually not a problem on a modern computer with a reasonable amount of memory, unless the document includes many large graphics files; LibreOffice can handle quite large files.
· Advantage – You can modify the image file separately without changing the document because the link to the file remains valid, and the modified image will appear when you next open the document. This can be a big advantage if you (or someone else, perhaps a graphic artist) is updating images.
· Disadvantage – If you send the document to someone else, or move it to a different computer, you must also send the image files, or the receiver will not be able to see the linked images. You need to keep track of the location of the images and make sure the recipient knows where to put them on another machine, so that the document can find them. For example, you might keep images in a subfolder named Images (under the folder containing the document); the recipient of the file needs to put the images in a subfolder with the same name and in the same place relative to the document.
· Note
When inserting the same image several times in the document, it would appear beneficial to link rather than embed; however, this is not necessary as LibreOffice embeds only one copy of the image file in the document.
	Note
	When inserting the same image several times in the document, it would appear beneficial to link rather than embed; however, this is not necessary as LibreOffice embeds only one copy of the image file in the document.


[bookmark: __RefHeading__13185_2065861793]Embedding linked images
If you originally linked the images, you can easily embed one or more of them later if you wish. To do so:
1. Open the document in LibreOffice and choose Edit > Links.
 1) The Edit Links dialog (Figure 127) shows all the linked files. In the Source file list, select the files you want to change from linked to embedded.
 2) Click the Break Link button.
 3) Save the document.
· Note
Going the other way, from embedded to linked, is not so easy—you must replace the images, one at a time, selecting the Link option when you do so.
	Note
	Going the other way, from embedded to linked, is not so easy—you must delete and reinsert the images, one at a time, selecting the Link option when you do so.


[image: ]
[bookmark: Ref_Figure382_label_and_number]Figure 127: The Edit Links dialog

[bookmark: __RefHeading__13187_2065861793]Inserting an image from the clipboard
Using the clipboard, you can copy images into a LibreOffice document from another LibreOffice document and from other programs. To do this:
 638) Open both the source document and the target document.
 639) In the source document, select the image to be copied.
 640) Click once on the selected image and press Ctrl+C to copy the image to the clipboard.
 641) Switch to the target document.
 642) Click to place the cursor where the graphic is to be inserted.
 643) Press Ctrl+V to insert the image.
· Caution
If the application from which the graphic was copied is closed before the graphic is pasted into the target, the image stored on the clipboard could be lost.
	Caution
[image: ]
	If the application from which the graphic was copied is closed before the graphic is pasted into the target, the image stored on the clipboard could be lost.


[bookmark: __RefHeading__13189_2065861793]Inserting an image using a scanner
If a scanner is connected to your computer, LibreOffice can call the scanning application and insertinserted the scanned item into the LibreOffice document as an image. To start this procedure, place the cursor where you want the graphic to be inserted and choose Insert > Image > Scan > Select Source.
Although this practice is quick and easy, it is unlikely to result in a high-quality image of the correct size. You may get better results by passing scanned material into a graphics program and cleaning it up there before inserting the resulting image into LibreOffice.
[bookmark: __RefHeading__11392_454530774]Inserting an image from the Gallery
The Gallery (Figure 128) provides a convenient way to group reusable objects such as graphics and sounds that you can insert into your documents. The Gallery is available in all components of LibreOffice. See “Managing the LibreOffice Gallery”“ on page 119. You can copy or link an object from the Gallery into a document.
To insert an object:
1. Click the Gallery icon in the Sidebar.
 1) Choose Tools > Gallery or click the Gallery icon [image: ] on the Standard toolbar (in Writer and Calc) or the Drawing toolbar (in Impress, Writer, and Draw). The Gallery is also accessible in the Sidebar (View > Sidebar and click the Gallery tab).
 2) Select a theme.
 3) Select an object with a single click.
 4) Drag and drop the image into the document. (See Error: Reference source not found.)
You can also right-click on the object and choose Insert > Copy.
[image: ]
[bookmark: Ref_Figure383_label_and_number][bookmark: Ref_Figure383_number_only]Figure 128: The Gallery in the Sidebar

This then causes the Frame toolbar to replace the Formatting toolbar and opens the Picture toolbar, docked to the Status bar.
To insert an object as a link:
1. Choose Tools > Gallery and select a theme.
 1) Select an object with a single click, then while pressing the Shift and Ctrl keys, drag and drop the object into the document.
[bookmark: __RefHeading__34926_261791260]Inserting an image as a background
To insert an image as the background to a page or paragraph:
 1) Choose Tools > Gallery and select a theme.
 2) Select an object with a single click, right-click on the object, and choose Insert > Background > Page or > Paragraph.
[bookmark: __RefHeading__72324_1784677349]Modifying and positioning graphics
LibreOffice provides many tools for cropping, resizing, modifying, filtering, and positioning graphics; wrapping text around graphics; and using graphics as backgrounds and watermarks. These tools are described in relevant chapters of the other guides. Some sophisticated adjustments of the graphics are best done in an image manipulation program and the results brought into LibreOffice, rather than using LibreOffice’s built-in tools.
[image: ]
Figure 129: Copying a graphic object from the Gallery into a document (the Hide/Show button for the Gallery is indicated by the ellipse)

[bookmark: __RefHeading__13193_2065861793]Managing the LibreOffice Gallery
Graphics in the Gallery are grouped by themes, such as Arrows, DiagramsBullets, Rulers, and PeopleBackgrounds. You can create other groups or themes and add your own pictures or find extensions containing more graphics. Click on a theme to see its contents displayed in the Gallery window.
The Gallery list box lists the available themes. Click on a theme to see its contents displayed in the Gallery window.
You can display the Gallery in Icon View (Figure 128) or Detailed View (Figure 130), and you can hide or show the Gallery by clicking on the Sidebar’s Hide buttonHide button (similar to the Hide button for the Navigator and the Styles and Formatting windows when they are docked).
By default, the Gallery is docked above the workspace unless opened in the Sidebar when it is opened in a vertical orientation to the right of the work space. To expand the Gallery, position the pointer over the line that divides it from the top (or the left if the Sidebar Gallery) of the workspace. When the pointer changes to parallel lines with arrows, click and drag downward. The workspace resizes in response.
As with other docked windows, you can “float” the Gallery by moving the mouse pointer over an edge of the Gallery window, holding down the Ctrl key, and double-clicking. Drag the floating window to any of the edges of the LibreOffice window to dock the Gallery again.
	Note
	In a default installation, only the My themes theme is customizable, although new themes can be added as explained in “” on page 121. The locked themes are easily recognizable by right-clicking on them; the only available option in the context menu is Properties. In some installations, or when you are running LibreOffice as an Administrator, all themes are customizable.


[image: ]
[bookmark: Ref_Figure384_label_and_number]Figure 130: Gallery in Detailed View

· Note
In some installations, only the My themes theme is customizable, although new themes can be added as explained in “” on page 121. The locked themes are easily recognizable by right-clicking on them; the only available option in the context menu is Properties.
By default, the Gallery is opened in the Sidebar. You can float the Gallery as you can other Sidebar panes; see Chapter 1, Introducing LibreOffice, for more information.
[bookmark: __RefHeading__13203_2065861793]Adding objects to the Gallery
You may wish to add to the Gallery any images that you use frequently, for example, a company logo. You can then very easily insert these graphics into a document later.
 1) Method 1 (selecting a file)
 2) Right-click on the desired theme and select Properties from the context menu.
 3) In the theme’s Properties dialog, click the Files tab (Figure 131).
[image: ]
[bookmark: Ref_Figure385_label_and_number]Figure 131: Gallery Properties dialog

To add several files at once:
 1) On the Files tab, you can either:
 2)  Click the Find Files button.
 3) The Select path dialog (not shown) opens. You can enter the path for the file’s directory in the Path text box, or you can navigate to locate the file’s directory.
 4) Click the Select button to start the search. A list of graphic files is then displayed in the Properties dialog. You can use the File type drop-down list to limit the files displayed.
 5) To add all of the files shown in the list, click Add All. Otherwise, select the files to add and then click Add (hold down either the Shift key or the Ctrl key while clicking on the files).
ToOr, to add a single file:
1. Click Addthe Add button to open the Gallery dialog.
 7) Use the navigation controls to locate the image to add to the theme. Select it and then click Open to add it to the theme.
 8) Click OK onthe OK button of the Properties dialog to close it.
[image: ]
Figure 132: Gallery Properties dialog

Method 2 (drag and drop)
You can drag and drop an image into the Gallery from a document.
1. Open the document containing an image you want to add to the Gallery, and display the Gallery theme to which you want to add it.
1) Position the mouse pointer above the image, without clicking.
2) If the mouse pointer changes to a hand symbol, the image refers to a hyperlink. In this case, press the Alt key while you click the image, to select it without activating the link. If the mouse pointer does not change to a hand symbol, you can simply click the image to select it.
3) Once the image is selected, evident from the colored selection handles around it, release the mouse button. Click again on the image, keeping the mouse button pressed for more than two seconds. Without releasing the mouse button, drag the image into the Gallery.
4) Release the mouse button.
[bookmark: __RefHeading__13205_2065861793]Deleting images from the Gallery
To delete an image from a theme:
1. Right-click on the name of the image file or its thumbnail in the Gallery.
 1) Click Delete in the context menu. A message appears, asking if you want to delete this object. Click Yes.
· Note
Deleting the name of a file from the list in the Gallery does not delete the file from the hard disk or other location.
	Note
	Deleting the name of a file from the list in the Gallery does not delete the file from the hard disk or other location. This includes the drag-drop folder in the Gallery.


[bookmark: Ref_Add_new_theme_to_Gallery][bookmark: __RefHeading__13207_206586179311][bookmark: Ref_Add_new_theme_to_Gallery2][bookmark: Ref_Add_new_theme_to_Gallery1]Adding a new theme to the Gallery
To add a new theme to the Gallery:
1. Click the New Theme button above the list of themes (Figure 130).
 1) In the Properties of New Theme dialog, click the General tab and type a name for the new theme.
 2) Click the Files tab and add images to the theme, as described earlier.
[bookmark: __RefHeading__13209_2065861793]Deleting a theme from the Gallery
To delete a theme from the Gallery:
1. Go to Tools > Gallery.
 1) Select from the list of themes the theme you wish to delete.
 2) Right-click on the theme, then click Delete on the context menu.
[bookmark: __RefHeading__13211_2065861793]Location of the Gallery and the objects in it
Graphics and other objects shown in the Gallery can be located anywhere on your computer’s hard disk, on a network drive, or other removable media. Listings in the Gallery show the location of each object. When you add graphics to the Gallery using method 1, the files are not moved or copied; only the location of each new object is simply added as a reference. When files are added using drag and drop, they are copied into a folder (dragdrop) in the Gallery, and allocated a file name.
Error: Reference source not found shows in Detailed View, two files in the My Theme in the Gallery, one is contained in the dragdrop folder, and the other is a reference path to its actual location.
[image: ]
Figure 133: Theme showing files inserted with drag-and-drop and by reference

In a workgroup, you may have access to a shared Gallery (where you cannot change the contents unless authorized to do so) and a user Gallery, where you can add, change, or delete objects.
The location of the user Gallery is specified in Tools > Options > LibreOffice > Paths. You can change this location, and you can copy your gallery files (SDV) to other computers.
Gallery contents provided with LibreOffice are stored in a different location. You cannot change this location.
[bookmark: __RefHeading__15492_2065861793]Creating an image map
An image map defines areas of an image (called hotspots) with hyperlinks to web addresses, other files on the computer, or parts of the same document. Hotspots are the graphic equivalent of text hyperlinks (described in Chapter 12). Clicking on a hotspot causes LibreOffice to open the linked page in the appropriate program (for example, the default browser for an HTML page; LibreOffice Calc for an ODS file; a PDF viewer for a PDF file). You can create hotspots of various shapes and include several hotspots in the same image.
To use the image map editor:
1. In your LibreOffice document, click on the picture in which you want to create the hotspots.
 1) Choose Edit > ImageMap from the menu bar. The ImageMap Editor (Figure 134) opens.
 2) Use the tools and fields in the dialog (described below) to define the hotspots and links necessary.
 3) Click the Apply icon [image: ] to apply the settings.
 4) When done, click the Save icon [image: ] to save the image map to a file, then click the X in the upper right corner to close the dialog.
The main part of the dialog shows the image on which the hotspots are defined. A hotspot is identified by a line indicating its shape.
The toolbar at the top of the dialog contains the following tools:
· Apply button: click this button to apply the changes.
· Load, Save, and Select icons.
· Tools for drawing a hotspot shape: these tools work in exactly the same way as the corresponding tools in the Drawing toolbar.
· Edit, Move, Insert, Delete Points: advanced editing tools to manipulate the shape of a polygon hotspot. Choose the Edit Points tool to activate the other tools.
· Active icon: toggles the status of a selected hotspot between active and inactive.
· Macro: associates a macro with the hotspot instead of just associating a hyperlink.
· Properties: sets the hyperlink properties and adds the Name attribute to the hyperlink.
[image: ]
[bookmark: Ref_Figure386_label_and_number]Figure 134: The dialog to create or edit an image map

Below the toolbar, specify for the selected hotspot:
· Address: the address pointed to by the hyperlink. You can also point to an anchor in a document; to do this, write the address in this format: file:///<path>/document_name#anchor_name
· Text: type the text that you want to be displayed when the mouse pointer is moved over the hotspot.
· Frame: where the target of the hyperlink will open: pick among _blank (opens in a new browser window), _self (opens in the active browser window), _top or _parent.
· Tip
The value _self for the target frame will usually work just fine. It is therefore not recommended to use the other choices unless absolutely necessary.
	Tip
	The value _self for the target frame will usually work just fine. It is therefore not recommended to use the other choices unless absolutely necessary.


[bookmark: __RefHeading__17037_2065861793]Using LibreOffice’s drawing tools
You can use LibreOffice’s drawing tools to create graphics such as simple diagrams using rectangles, circles, lines, text, and other predefined shapes. You can also group several drawing objects to make sure they maintain their relative position and proportion.
You can place the drawing objects directly on a page in your document, or you can insert them into a frame.
You can also use the drawing tools to annotate photographs, screen captures, or other illustrations produced by other programs, but this is not recommended because:
1. You cannot include images in a group with drawing objects, so they may not remain aligned in your document.
· If you convert a document to another format, such as HTML, the drawing objects and the graphics will not remain associated; they are saved separately.
In general, if you need to create complex drawings, it is recommended to use LibreOffice Draw, which includes many more features such as layers, styles, and so on.
[bookmark: __RefHeading__7009_2065861793]Creating drawing objects
To begin using the drawing tools, display the Drawing toolbar (Figure 135) by clicking View > Toolbars > Drawing.
If you are planning to use the drawing tools repeatedly, you can tear off this toolbar and move it to a convenient place on the window.
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	Figure 135: The Drawing toolbar
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	Figure 370: The Drawing toolbar


To use a drawing tool:
1. Click in the document where you want the drawing to be anchored. You can change the anchor later, if necessary.
 1) Choose the tool from the Drawing toolbar (Figure 135). The mouse pointer changes to a drawing-functions pointer similar to this one for a rectangle shape [image: ].
 2) Move the cross-hair pointer to the place in the document where you want the graphic to appear and then click and drag to create the drawing object. Release the mouse button. The selected drawing function remains active, so that you can draw another object of the same type.
 3) To cancel the selected drawing function, press the Esc key or click on the Select icon (the arrow) on the Drawing toolbar.
 4) You can now change the properties (fill color, line type and weight, anchoring, and others) of the drawing object using either the Drawing Object Properties toolbar (Figure 136) or the choices and dialogs reached by right-clicking on the drawing object.
[bookmark: __RefHeading__7011_2065861793]Set or change properties for drawing objects
To set the properties for a drawing object before you draw it:
1. On the Drawing toolbar (Figure 135), click the Select tool.
 1) On the Drawing Object Properties toolbar (Figure 136), click on the icon for each property and select the value you want for that property.
 2) For more control, or to define new attributes, you can click on the Area or Line icons on the toolbar to display detailed dialogs.
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	Figure 136: Drawing Object Properties toolbar
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	Figure 372: Drawing Object Properties toolbar


The default you set applies to the current document and session. It is not retained when you close the document or close Writer, and it does not apply to any other document you open. The defaults apply to all the drawing objects except text objects.
To change the properties for an existing drawing object:
1. Select the object.
 1) Continue as described above.
You can also specify the position and size, rotation, and slant and corner radius properties of the drawing object:
1. Right-click on the drawing object and then choose Position and Size from the context menu. The Position and Size dialog is displayed.
 1) Choose any properties, as required.
[bookmark: __RefHeading__7013_2065861793]Resizing a drawing object
An object is resized in a similar way to an image. Select the object, click on one of the eight handles around it and drag it to its new position. For a scaled resizing, select one of the corner handles and keep the Shift key pressed while dragging the handle to its new position.
For more sophisticated control of the size of the object, choose Format > Object > Position and Size from the Menu bar. Use the Position and Size dialog to set the width and height independently. If the Keep ratio option is selected, then the two dimensions change so that the proportion is maintained, allowing for a scaled resizing.
[bookmark: __RefHeading__7015_2065861793]Grouping drawing objects
To group drawing objects:
 2) Select one object, then hold down the Shift key and select the others you want to include in the group. The bounding box expands to include all the selected objects.
 3) With the objects selected, hover the mouse pointer over one of the objects and choose Format > Group > Group from the Menu bar or right-click and choose Group > Group from the pop-up menu.
· Note
You cannot include an embedded or linked graphic in a group with drawing objects.
	Note
	You cannot include an embedded or linked graphic in a group with drawing objects.


[bookmark: __RefHeading__17039_2065861793]Using Fontwork
With Fontwork you can create graphical text art objects to make your work more attractive. There are many different settings for text art objects (line, area, position, size, and more), so you have a large choice.
Fontwork is available with each component of LibreOffice, but you will notice small differences in the way that each component displays it.
The Fontwork toolbars
You can use two different toolbars for creating and editing a Fontwork object.
Choose either View > Toolbars > Fontwork or View > Toolbars > Drawing.
[image: ]
Figure 137: The floating Fontwork toolbar

If you click on an existing Fontwork object, the Formatting toolbar changes to display the Fontwork options as shown in Error: Reference source not found. The contents of this toolbar vary depending on the LibreOffice component with which it is being used.
[bookmark: __RefHeading__13217_2065861793]Creating a Fontwork object
 644) On the Fontwork toolbar (View > Toolbars > Fontwork) or the Drawing toolbar (View > Toolbars > Drawing)chosen toolbar, click the Fontwork Gallery icon [image: ].
 645) In the Fontwork Gallery (Figure 138), select a Fontwork style, then click OK. The Fontwork object will appear in your document. Notice the colored squares around the edge (indicating that the object is selected) and the yellow dot; these are discussed in “” on page 131.
[image: ]
[bookmark: Ref_Figure389_label_and_number]Figure 138: The Fontwork Gallery

 646) Double-click the object to edit the Fontwork text (see Figure 139). Select the text and type your own text in place of the black Fontwork text that appears over the object.
[image: ]
[bookmark: Ref_Figure390_label_and_number]Figure 139: Editing Fontwork text

 647) Click anywhere in a free space or press Esc to apply your changes.
[image: ]
Figure 140: Editing Fontwork text

[bookmark: __RefHeading__13219_2065861793]Editing a Fontwork object
Now that the Fontwork object is created, you can edit some of its attributes. To do this, you can use the Fontwork toolbar, the Formatting toolbar, or menu options as described in this section. If the selected Fontwork object is a 3-D object, you can also use the 3D-Settings toolbar.
[bookmark: __RefHeading__13221_2065861793]Using the Fontwork toolbar
Make sure that the Fontwork toolbar, shown in Figure 141, is visible. If you do not see it, go to View > Toolbars > Fontwork. Click on the different icons to edit Fontwork objects.
[image: ]
[bookmark: Ref_Figure391_label_and_number]Figure 141: The floating Fontwork toolbar

	[image: ]
	Fontwork Shape: Edits the shape of the selected object. You can choose from a palette of shapes.
	[image: ]
Figure 142: Fontwork toolbar showing palette of shapes


	[image: ]
	Fontwork Same Letter Heights: Changes the height of characters in the object. Toggles between normal height (some characters taller than others, for example capital letters, d, h, l and others) and all letters the same height.


[image: ]
Figure 143: Left: normal letters; right: same letter heights

	[image: ]
	Fontwork Alignment: Changes the alignment of characters. Choices are left align, center, right align, word justify, and stretch justify. The effects of the text alignment can only be seen if the text spans over two or more lines. In the stretch justify mode, all the lines are filled completely.
	[image: ]

	[image: ]
	Fontwork Character Spacing: Changes the character spacing and kerning in the object. Select from the choices in the drop-down list.
	[image: ]


[bookmark: __RefHeading__13223_2065861793]Using the Formatting toolbar
Now let us go further and customize the Fontwork object with several more attributes.
Click on the Fontwork object. The Formatting toolbar changes to show the options for editing the object. (The toolbar shown in Figure 144 appears when you use Fontwork in Writer.)
[image: ]
[bookmark: Ref_Figure394_label_and_number]Figure 144: Formatting toolbar for a Fontwork object in Writer

This figure shows the toolbar floating. In its default, docked position it is one of the toolbars located below the menu bar. The example toolbar has also been customized to show all of the available options; by default only a subset of these options is shown.
The Formatting toolbar provides a large choice of options for customizing your object. These choices are the same as the ones for other drawing objects. For more information, see the Draw Guide.
[bookmark: __RefHeading__13225_2065861793]Line options
Line icon: Opens a dialog with three tabs: Line, Line Styles, Arrow Styles. Use the Line tab to edit the most common properties of the line around the selected Fontwork object, by choosing from previously-defined attributes including line style, line color, and arrow styles. Use the Lines Styles and Arrow Styles tabs to edit the properties of line and arrow styles, and define new styles.
Arrow Style icon: Choose from the different arrow styles.
Line Style box: Choose from the available line styles.
Line Width box: Set the width of the line.
Line Color box: Select the color of the line.
[bookmark: __RefHeading__13227_2065861793]Area options
Area icon: Opens a dialog with seven tabs: Area, Shadow, Transparency, Colors, Gradients, Hatching, Bitmaps.
· Area tab: Choose from the predefined list a color, bitmap, gradient or hatching pattern to fill the selected object.
· Shadow tab: Set the shadow properties of the selected object.
· Transparency tab: Set the transparency properties of the selected object.
· Colors tab: Modify the available colors or add new ones to appear on the Area tab.
· Gradients tab: Modify the available gradients or add new ones to appear on the Area tab.
· Hatching tab: Modify the available hatching patterns or add new ones to appear on the Area tab.
· Bitmaps tab: Create simple bitmap patterns and import bitmaps, to make them available on the Area tab.
Area Style / Filling boxes: Select the type of the fill of the selected object. For more detailed settings, use the Area icon.
[bookmark: __RefHeading__13229_2065861793]Positioning options
Rotate icon: Rotate the selected object manually using the mouse to drag the object.
To Foreground icon: Move the selected object in front of the text.
To Background icon: Move the selected object behind the text.
Alignment icon: Modify the alignment of the selected objects.
Bring to front icon: Move the selected object in front of the others.
Send to back icon: Move the selected object behind the others.
Change Anchor icon: Choose between anchoring options:
· To Page—The object keeps the same position in relation to the page margins. It does not move as you add or delete text.
· To Paragraph—The object is associated with a paragraph and moves with the paragraph. It may be placed in the margin or another location.
· To Character—The object is associated with a character but is not in the text sequence. It moves with the paragraph but may be placed in the margin or another location. This method resembles anchoring to a paragraph.
· As Character—The object is placed in the document like any character and moves with the paragraph as you add or delete text before the object.
Ungroup icon: Ungroup a selection of grouped objects, so that they can be managed individually.
Group icon: Group the selected objects, so you can manage them as a single object.
[bookmark: __RefHeading__13231_2065861793]Using menu options
You can use some the choices on the Format menu to anchor, align, arrange, and group selected Fontwork objects, wrap text around them, and flip them horizontally and vertically.
You can also right-click on a Fontwork object and choose many of the same options from the pop-up menu. The pop-up menu also provides quick access to the Line, Area, Text, and Position and Size dialogs. The Text dialog offers only a few options for Fontwork objects and is not discussed here. On the Position and Size dialog, you can enter precise values forconcerning size and position. For more information on all of these menu options, see the Draw Guide.
[bookmark: __RefHeading__13233_2065861793]Using the 3D-Settings toolbar
If the selected Fontwork object is a 3-D object, you can also use the options on the 3D-Settings toolbar. You can also change a 2-D Fontwork object into a 3-D object (or change a 3-D object into a 2-D object) by clicking the Extrusion On/Off icon on the 3D-Settings toolbar. For more information, see the Draw Guide.
[image: ]
Figure 145: 3D-Settings toolbars

[bookmark: __RefHeading__13235_2065861793][bookmark: Ref_Moving_and_resizing_Fontwork_objects][bookmark: Ref_Moving_and_resizing_Fontwork_objects]Moving and resizing Fontwork objects
When you select a Fontwork object, eight colored squares (known as handles) appear around the edge of the object, as shown below. You can drag these handles to resize the object.
	A yellow dot also appears on the object. This dot may be along an edge of the object, or it may be somewhere else; in the example on the right. If you hover the pointer over this yellow dot, the pointer turns into a hand symbol. You can drag the dot in different directions to distort the object.
Hovering the pointer over other parts of the object turns the pointer into the usual symbol for dragging the object to another part of the page.
	[bookmark: __RefHeading__5648_156656864412][image: ]


For precise control of the location and size of the object, use the Position and Size dialog.
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[bookmark: __RefHeading___Toc86657_8113635311111111]Chapter 12  
Creating Web Pages
Saving Documents as HTML Files

[bookmark: __RefHeading___Toc135364_811363531]Introduction
HTML capabilities in LibreOffice include saving and exporting existing documents in HTML format.
This chapter describes how to do the following in Writer, Calc, Impress, and Draw:
· Create hyperlinks within a document and to other documents such as web pages, PDFs, and other files.
· Save documents as web pages (HTML documents) and create web pages using the Web Wizard included with LibreOffice.
When creating a document that you plan to deliver as a web page, you need to consider the following:
· In an HTML document, hyperlinks are active (clickable), but other cross-references inserted by LibreOffice are not active links.
· An object such as ana image is saved as a separate file. However, if that object has been placed in a frame (for example, with an associated caption), it is not saved and does not appear in the HTML document; instead, the name of the frame appears.
[bookmark: __RefHeading__35834_1130598086]Relative and absolute hyperlinks
Hyperlinks stored within a file can be either relative or absolute.
A relative hyperlink says, Here is how to get there starting from where you are now (meaning from the folder in which your current document is saved) while an absolute hyperlink says, Here is how to get there no matter where you start from.
An absolute link will stop working if the target is moved. A relative link will stop working if the start and target locations change relative to each other. For instance, if you have two spreadsheets in the same folder linked to each other and you move the entire folder to a new location, an absolute hyperlink will break but a relative one will not.
To change the way that LibreOffice stores the hyperlinks in your file, select Tools > Options > Load/Save > General and choose if you want URLs saved relatively when referencing the File System, or the Internet, or both.
Calc will always display an absolute hyperlink. Do not be alarmed when it does this even when you have saved a relative hyperlink. This ‘absolute’ target address will be updated if you move the file.
· Note
Make sure that the folder structure on your computer is the same as the file structure on your web server if you save your links as relative to the file system and you are going to upload pages to the Internet.
· Tip
When you rest the mouse pointer on a hyperlink, a help tip displays the absolute reference, because LibreOffice uses absolute path names internally. The complete path and address can only be seen when you view the result of the HTML export (saving the spreadsheet as an HTML file), by loading the HTML file as text, or by opening it with a text editor.
	Note
	Make sure that the folder structure on your computer is the same as the file structure on your web server if you save your links as relative to the file system and you are going to upload pages to the Internet.

	Tip
	When you rest the mouse pointer on a hyperlink, a help tip displays the absolute reference, because LibreOffice uses absolute path names internally. The complete path and address can only be seen when you view the result of the HTML export (saving the spreadsheet as an HTML file), by loading the HTML file as text, or by opening it with a text editor.


[bookmark: __RefHeading__12704_761994490]Creating hyperlinks
When you type text (such as a website addresses or URL) that can be used as a hyperlink, and then press the spacebar or the Enter key, LibreOffice automatically creates the hyperlink and applies formatting to the text (usually a color and underlining). If this does not happen, you can enable this feature by going to Tools > AutoCorrect Options > Options on the main menu bar and selecting the URL Recognition option.
If you do not want LibreOffice to convert a specific URL to a hyperlink, go to Edit > Undo Insert on the main menu bar, or press Ctrl+Z immediately after the formatting has been applied, or place the cursor in the hyperlink, right-click, and select Remove Hyperlink from the context menu.
· Tip
To change the color of hyperlinks, go to Tools > Options > LibreOffice > Appearance, scroll to Unvisited links and/or Visited links, pick the new colors and click OK. Caution: this will change the color for all hyperlinks in all components of LibreOffice; this may not be what you want.
In Writer and Calc (but not Draw or Impress), you can also change the Internet link character style or define and apply new styles to selected links.
	Tip
	To change the color of hyperlinks, go to Tools > Options > LibreOffice > Appearance, scroll to Unvisited links and/or Visited links, pick the new colors and click OK. Caution: this will change the color for all hyperlinks in all components of LibreOffice; this may not be what you want.
In Writer and Calc (but not Draw or Impress), you can also change the Internet link character style or define and apply new styles to selected links.


[bookmark: __RefHeading__778_802680472]Using the Navigator
You can insert hyperlinks using the Navigator and this is an easy way to insert a hyperlink to another part of the same document.
 648) Open the documents containing the items you want to cross-reference.
 649) Click on the Navigator icon in the Sidebar[image: ], or go to View > Navigator on the main menu bar, or press the F5 key to open the Navigator dialog.
 650) Click the triangle to right of the Drag Mode icon and select Insert as Hyperlink (Figure 146). Note that the Drag Mode icon changes shape depending on the type of insert that was previously selected. The default icon for Drag Mode is to show the Hyperlink icon [image: ].
[image: ]
[bookmark: Ref_Figure396_label_and_number]Figure 146: Inserting hyperlink using the Navigator

 651) Select the document from the drop- down list at the bottom of the Navigator that contains the item that you want to link tocross-reference.
 652) In the Navigator list, select the item that you want to insert as a hyperlink.
 653) Drag the item to where you want to insert the hyperlink in the document. The name of the item is inserted in the document as an active hyperlink.
[image: ]
Figure 147: Inserting hyperlink using the Navigator

When using the Navigator to insert a hyperlink to an object such as a graphic, it is recommended to have the hyperlink show a useful name, for example 2009 Sales Graph. You need to give such objects useful names instead of leaving them as the default names, for example Graphics6, or you will have to edit the name of the resulting link using the Hyperlink dialog, as described below.
You can also use the Navigator to insert a hyperlink from one document (the source) to a specific place in another document (the target). Open the Navigator in the target document and drag the item to the position in the source document where you want the hyperlink to appear.
[bookmark: __RefHeading__12708_761994490]Using the Hyperlink dialog
You can use the Hyperlink dialog to insert a hyperlink and modify all hyperlinks.
 654) Highlight the existing text you want to use as a link.
 655) Click the Hyperlink icon [image: ] on the Standard toolbar or go to Insert > Hyperlink on the main menu bar to open the Hyperlink dialog (Figure 148).
 656) On the left side, select one of the four categories of hyperlink:
· Internet: the hyperlink points to a web address, normally starting with http://.
· Mail & News: the hyperlink opens an email message that is pre-addressed to a particular recipient.
· Document: the hyperlink points to another document or to another place in the current document
· New document: the hyperlink creates a new document.
 657) The Hyperlink dialog changes depending on the type of hyperlink selected. Enter all necessary details to create the hyperlink.
 658) Click Apply to create the hyperlink and the Hyperlink dialog remains open allowing you to create another hyperlink.
 659) Click Close to close the Hyperlink dialog.
[image: ]
[bookmark: Ref_Figure397_label_and_number]Figure 148. Hyperlink dialog showing details for Internet links

The dialog changes according to the choice made for the hyperlink category in the left panel. A full description of all the choices and their interactions is beyond the scope of this chapter. Here is a summary of the most common choices.
· For an Internet hyperlink, choose the type of hyperlink (Web, FTP, or Telnet), and enter the required web address (URL).
· For a Mail and News hyperlink, specify whether it is a mail or news link, the address of the receiver and, for email, the subject.
· For a Document hyperlink, specify the document path (clicking Open File opens a file browser) or leave this blank if you want to link to a target in the same document. Optionally specify the target in the document (for example a specific slide). Click the Target in Document icon [image: ] to open the Target in Document dialog where you can select the type of target; or, if you know the name of the target, you can type it into the box.
· For a New Document hyperlink, specify whether to edit the newly created document immediately (Edit now) or just create it (Edit later). Enter the file name and select the type of document to create (text, spreadsheet, and so on). Click the Select Path icon [image: ] to open a file browser and choose where to store the file.
The Further settings section in the bottom right part of the dialog is common to all the hyperlink categories, although some choices are more relevant to some types of links.
· Frame value determines how the hyperlink will open. This applies to documents that open in a Web browser.
· Form specifies if the link is to be presented as text or as a button. See the Writer Guide Chapter 15 Using Forms in Writer for more information.
· Text specifies the text that will be visible to the user. If you do not enter anything here, LibreOffice uses the full URL or path as the link text. Note that if the link is relative and you move the file, this text will not change, though the target will.
· Name is applicable to HTML documents. It specifies text that will be added as a NAME attribute in the HTML code behind the hyperlink.
· Events [image: ]: click this icon to open the Assign Macro dialog and select a macro to run when the link is clicked. See Chapter 13 Getting Started with Macros for more information.
[bookmark: __RefHeading__1352_1458240272]Editing hyperlinks
To edit an existing link:
 660) Click anywhere in the hyperlink text.
 661) Click the Hyperlink icon [image: ] on the Standard toolbar or go to Edit > Hyperlink on the main menu bar or right-click and select Edit Hyperlink from the context menu. The Hyperlink dialog opens.
 662) Make your changes and click Apply to save your changes. The Hyperlink dialog remains open allowing you to continue editing hyperlinks. Click Apply after editing each hyperlink.
 663) When you are finished editing hyperlinks, click Close.
The standard (default) behavior for activating hyperlinks within LibreOffice is to use Ctrl+click. This behavior can be changed in Tools > Options > LibreOffice > Security > Options and deselecting the option Ctrl-click required to follow hyperlinks. If clicking in your links activates them, check that page to see if the option has been deselected.
[bookmark: __RefHeading__301809_625523294]Removing hyperlinks
You can remove the link from hyperlink text and leave just the text by right-clicking on the link and selecting Remove Hyperlink from the context menu. You may then need to re-apply some formatting to match the text with the rest of your document.
To erase the link text or button from the document completely, select it and press the Backspace or Delete key.
ExportingCreating web pages using the Web Wizard
The Web Wizard in LibreOffice allows you to create several types of standard web pages from and is available all LibreOffice components except Math. Each modules. However, each time you startopen the Web Wizard in a LibreOffice componentmodule, Writer will automatically start before the Web Wizard dialog opens. The Web Wizard is linked to Writer and is normally used in Writer for creating web pages.
1. Go to File > Wizards > Web Page on the menu bar to open the Web Wizard dialog (Error: Reference source not found).
[image: ]
Figure 149: Introduction page of Web Wizard dialog

 1) On the first page of the Wizard, choose settings and click Next >. If this is your first web page, the only choice is <default>.
 2) Select or browse to the document you would like to format. The information for Title, Summary and Author is taken from the document properties. If necessary, edit this information (Figure 150).
 3) Click Next > and select a layout for the web site by clicking on the layout boxes (Figure 151).
 4) Click Next > to customize the layout and select the information to be listed and screen resolution (Figure 152).
 5) Click Next > and select a style for the page. Use the drop-down list to choose different styles and color combinations. Browse to select a background image and icon set from the Gallery (Figure 153).
 6) Click Next > and enter general information for the web site such as Title and HTML Metadata information (Figure 154).
 7) Click Next > and enter the information of where to publish your new web site (Figure 155).
 8) Click Finish to save the file and close the Web Wizard.
[image: ]
[bookmark: Ref_Figure399_label_and_number]Figure 150: Documents page of Web Wizard dialog

Click Next > and select a layout for the web site by clicking on the layout boxes (Error: Reference source not found).
[image: ]
[bookmark: Ref_Figure400_label_and_number]Figure 151: Main layout page of Web Wizard dialog

Click Next > to customize the layout and select the information to be listed and screen resolution (Error: Reference source not found).
14) Click Next > and select a style for the page. Use the drop-down list to choose different styles and color combinations. Browse to select a background image and icon set from the Gallery (Error: Reference source not found).
[image: ]
[bookmark: Ref_Figure401_label_and_number]Figure 152: Layout details page of Web Wizard dialog

[image: ]
[bookmark: Ref_Figure402_label_and_number]Figure 153: Style page of Web Wizard dialog

Click Next > and enter general information for the web site such as Title and HTML Metadata information (Error: Reference source not found).
[image: ]
[bookmark: Ref_Figure403_label_and_number]Figure 154: Web site information page of Web Wizard dialog

Click Next > and select where to save the file and preview the page if you wish (Error: Reference source not found).
15) Enter the information of where to publish your new web site.
16) Click Finish to save the file and close the Web Wizard.
[image: ]
[bookmark: Ref_Figure404_label_and_number]Figure 155: Preview page of Web Wizard dialog

[bookmark: __RefHeading__1819_1458240272]Saving and exporting documents as web pages
HTML capabilities in LibreOffice include saving and exporting existing documents in HTML format. You can also create several different types of web pages using the Web Wizard included with LibreOffice, see “Exporting web pages using the Web Wizard” on page 137 for more information.
The easiest way to create HTML documents in LibreOffice is to start with an existing document. You can get a good idea of how it will appear as a web page by using View > Web Layout. However, web layout view does not show you which features will or will not be saved correctly in HTML format. Refer to “” on page 132 on what to consider before creating a web page from a document.
[bookmark: __RefHeading__1590_374395303]Writer documents
[bookmark: __RefHeading__12714_761994490]Single web page
To save a document as a single web page (HTML format), go  by going to File > Save As on the menu bar and specify HTML Document (Writer) as the file type or File > Export and specifyspecifying XHTML format as the file type.
· Note
Writer does not replace multiple spaces in the original document with the HTML code for non-breaking spaces. If you want to have extra spaces in your HTML file or web page, you need to insert non-breaking spaces in LibreOffice. To do this, press Ctrl+Spacebar instead of just Spacebar.
	Note
	Writer does not replace multiple spaces in the original document with the HTML code for non-breaking spaces. If you want to have extra spaces in your HTML file or web page, you need to insert non-breaking spaces in LibreOffice. To do this, press Ctrl+Spacebar instead of just Spacebar.


[bookmark: __RefHeading__1354_1458240272]Series of web pages
Writer can save a large document as a series of web pages (HTML files) with a table of contents page.
 1) Decide which headings in the document should start on a new page and make sure all those headings have the same paragraph style (for example, Heading 1).
 2) Go to File > Send > Create HTML Document on the menu bar to open the Name and Path of the HTML Document dialog (Figure 157).
 3) [image: ]
Figure 156. Creating a series of web pages from one document

 4) Type the file name to save the pages under.
 5) Specify which style indicates a new page using the Styles drop list at the bottom of the dialog (for example Heading 1).
 6) Click Save to create the multi-page HTML document. The resulting HTML files conforms to the HTML 4 Transitional.
[bookmark: __RefHeading___Toc13004_1702108669]Calc spreadsheets
Calc can save files as HTML documents by going to File > Save As on the menu bar and select HTML Document (Calc) format as the file type. This is similar to “Single web page” aboveon page 140.
If the file contains more than one sheet and the web pages are created using the Web Wizard (see “Exporting web pages using the Web Wizard” on page 137), the additional sheets will follow one another in the HTML file. Links to each sheet will be placed at the top of the document.
Calc also allows the insertion of links directly into the spreadsheet using the Hyperlink dialog. See “Creating hyperlinks” on page 133 for more information on hyperlinks.
[image: ]
[bookmark: Ref_Figure405_label_and_number]Figure 157. Creating a series of web pages from one document

[bookmark: __RefHeading__12722_761994490]Impress presentations
· Note
Saving as web pages in HTML format does not retain animation and slide transitions.
	Note
	Saving as web pages in HTML format does not retain animation and slide transitions.


Impress presentations cannot be saved in HTML format, but have to be exported as HTML documents. Note that you can click Create at any step in the following procedure. The web pages created will then use the default settings that you have not changed in any way.
 664) Go to File > Export on the menu bar and specify the file name and location of where to save the web page version of your presentation.
 665) Select HTML document (Impress) as the file type and click Save to open the HTML Export dialog (Figure 158).
[image: ]
[bookmark: Ref_Figure406_label_and_number]Figure 158: HTML Export dialog - Assign design page

 666) On the Assign design page you can choose to create a new design and select or delete an existing design. Specify a New design or an Existing design and click Next>>. If you have not previously saved a web page design, the Existing Design choice is not available. 
· New design – creates a new design in the next pages of the Wizard.
· Existing design – loads an existing design from the design list to use as a starting point for the steps that follow. The list box displays all existing designs. 
· Delete Selected Design deletes the selected design from the design list. If you delete a design, you will only delete the design information. An export file will not be deleted by this action.
667) [image: ]
Figure 159: HTML Export dialog - Assign design page

 668) [image: ]
Figure 160: HTML Export dialog – Publication type page

669) Specify the Publication type for the web pages (Figure 161), then click Next>>. The publication type defines the basic settings for the intended export. The choices are:
· Standard HTML format – creates standard HTML pages from export pages.
· Standard HTML with frames – creates standard HTML pages with frames. The exported page will be placed in the main frame and the frame to the left will display a table of contents in the form of hyperlinks.
· Automatic – creates a default HTML presentation as a kiosk export in which the slides are automatically advanced after a specified amount of time.
· WebCast – in a WebCast export, automatic scripts will be generated with Perl or ASP support. This enables the speaker (for example, a speaker in a telephone conference using a slide show on the Internet) to change the slides in the web browsers used by the audience.
For more information on the options available for this page of the HTML Export dialog, click Help to open the help pages.
[image: ]
[bookmark: Ref_Figure407_label_and_number]Figure 161: HTML Export dialog – Publication type page

 670) Specify the options for Save graphics as, Monitor resolution and Effects used for the web pages (Figure 162), then click Next>>. The options for this page of the HTML Export dialog are as follows:
· Save graphics as – determines the image format. You can also define the compression value for the export.
· Monitor resolution – defines the resolution for the target screen. Depending on the selected resolution, the image will be displayed in a reduced size. You can specify a reduction of up to 80% from the original size. When selecting a resolution, consider what the majority of your viewers might be using. If you specify a high resolution, then a viewer with a medium-resolution monitor will have to scroll sideways to see the entire slide, which is probably not desirable.
· Effects – specifies whetherthat sound files defined as an effect for slide transitions are exported and whether any hidden slides are exported.
For more information on the options available for this page of the HTML Export dialog, click Help to open the help pages.
[image: ]
[bookmark: Ref_Figure408_label_and_number]Figure 162: HTML Export dialog – graphics and monitor resolution

 671) Specify the Information for the title page to be used with the web version of your presentation (Figure 163). The title page normally contains the author's name, an e-mail address and home page, along with any additional information you may want to include. This page is not available if you have selected not to create a title page and either Automatic or WebCast publication type.
[image: ]
[bookmark: Ref_Figure409_label_and_number]Figure 163: HTML Export dialog – title page information

 672) Select Link to a copy of the original presentation if you want to create a hyperlink to download a copy of the presentation file and then click Next>>.
 673) Select button style to be used for the web pages from the designs available (Figure 164) and then click Next>>.
If you do not select a button style, LibreOffice will create a text navigator.
This page is not available if you have selected either Automatic or WebCast publication type.
[image: ]
[bookmark: Ref_Figure410_label_and_number]Figure 164: HTML Export dialog – button style page

 674) Select color scheme to be used for the web pages (Figure 165) such as the color scheme and colors for text and background. This page is not available if you have selected either Automatic or WebCast publication type.
[image: ]
[bookmark: Ref_Figure411_label_and_number]Figure 165: HTML Export dialog – color scheme page

675) [image: ]
Figure 166: HTML Export dialog – color scheme page

676) Click Create.
677) If you have created a new design for your web pages, type in a name for your design and click Save.
· Note
Depending on the size of your presentation and the number of graphics it contains, the HTML export function creates several HTML, JPG, and GIF files. For example, if you simply save to your desktop and not in a specific folder, these separate HTML and graphics files will be placed all over your desktop. It is recommended to create a folder to hold all the files created for the web version of your presentation.
	Note
	Depending on the size of your presentation and the number of graphics it contains, the HTML export function creates several HTML, JPG, and GIF files. For example, if you simply save to your desktop and not in a specific folder, these separate HTML and graphics files will be placed all over your desktop. It is recommended to create a folder to hold all the files created for the web version of your presentation.


[bookmark: __RefHeading__12724_761994490][bookmark: __RefHeading__5648_156656864413]Draw documents
Draw documents cannot be saved in HTML format, but have to be exported as HTML documents. Exporting drawings as web pages from Draw is similar to exporting a presentation from Impress. Go to File > Export and select HTML Document (Draw) as the file type, then follow the procedure above for exporting Impress presentations.
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[bookmark: __RefHeading___Toc86657_8113635311111111]Chapter 13  
Getting Started with Macros
Using the Macro Recorder … and Beyond



[bookmark: __RefHeading___Toc135366_811363531]Introduction
A macro is a saved sequence of commands or keystrokes that are stored for later use. An example of a simple macro is one that “types” your address. The LibreOffice macro language is very flexible, allowing automation of both simple and complex tasks. Macros are very useful when you have to repeat the same task in the same way over and over again.
LibreOffice macros are usually written in a language called LibreOffice Basic, sometimes abbreviated to Basic. Although you can learn Basic and write macros, there is a steep learning curve to writing macros from scratch. The usual methods for a beginner are to use macros that someone else has written or use the built-in macro recorder, which records keystrokes and saves them for use.
Most tasks in LibreOffice are accomplished by “dispatching a command” (sending a command), which is intercepted and used. The macro recorder works by recording the commands that are dispatched (see “” on page 161).
[bookmark: __RefHeading__8588_1448150400]Your first macros
[bookmark: __RefHeading__19068_44446367]Adding a macro
The first step in learning macro programming is to find and use existing macros. This section assumes that you have a macro that you want to use, which may be in an email, on a web page, or even in a book. For this example, the macro in Listing 1 is used. You must create a library and module to contain your macro; see “” on page 162 for more information.
[bookmark: Ref_Listing0_label_and_number]Listing 1: Simple macro that says hello

Sub HelloMacro
  Print "Hello"
End Sub
[image: ]
Figure 167: LibreOffice Basic Macros dialog

[image: ]
Figure 168: LibreOffice Basic Macro Organizer dialog

[image: ]
Figure 169: Integrated Debugging Environment dialog

Use the following steps to create a library to contain your macro:
 678) Use Tools > Macros > Organize Macros > LibreOffice Basic to open the LibreOffice Basic Macro dialog (Figure 170).
 679) Click Organizer to open the Basic Macro Organizer dialog (Figure 171) and select the Libraries tab.
 680) Set the Location to My Macros & Dialogs, which is the default location.
 681) Click New to open the New Library dialog.
 682) Enter a library name, for example TestLibrary, and click OK.
 683) Select the Modules tab.
 684) In the Module list, expand My Macros and select, for example TestLibrary. A module named Module1 already exists and can contain your macro. If you wish, you can click New to create another module in the library.
 685) Select Module1, or the new module that you created, and click Edit to open the Integrated Debugging Environment (IDE) (Figure 172). The IDE is a text editor included with LibreOffice that allows you to create and edit macros.
 686) When a new module is created, it contains a comment and an empty macro named Main, which does nothing.
 687) Add the new macro either before Sub Main or after End Sub. Listing 2 shows the new macro has been added before Sub Main.
[image: ]
[bookmark: Ref_Figure412_full][bookmark: Ref_Figure412_label_and_number]Figure 170: LibreOffice Basic Macros dialog

[image: ]
[bookmark: Ref_Figure413_full][bookmark: Ref_Figure413_label_and_number]Figure 171: LibreOffice Basic Macro Organizer dialog

 688) Click the Compile icon [image: ] on the Macro toolbar to compile the macro.
 689) Place the cursor in the HelloMacro subroutine and click the Run BASIC icon [image: ] on the Macro toolbar, or press the F5 key, to run the HelloMacro in the module. A small dialog will open with the word “Hello” displayed. If the cursor is not in a subroutine or function, a dialog will open; select the macro to run.
 690) Click OK to close this small dialog.
 691) To select and run any macro in the module, click the Select Macro icon [image: ] on the Standard toolbar or go to Tools > Macros > Organize Macros > LibreOffice Basic.
 692) Select a macro and then click Run.
[image: ]
[bookmark: Ref_Figure414_full][bookmark: Ref_Figure414_label_and_number]Figure 172: Integrated Debugging Environment dialog

[bookmark: Ref_Listing1_label_and_number]Listing 2: Module1 after adding the new macro.

REM  *****  BASIC  *****

Sub HelloMacro
  Print "Hello"
End Sub

Sub Main

End Sub
[bookmark: __RefHeading__5136_1196992793]Recording a macro
If you have to repeatedly enter the same information, you can copy this information after it has been entered into your document for the first time, then paste the information into your document each time you want to use it. However, if something else is copied to the clipboard, the contents on the clipboard are changed. This means that you have to re-copy your repeated information. To overcome this problem, you can create a macro that enters your repeated information.
· Note
For some types of information that you want to repeatedly enter into a document, it may be more convenient to create an AutoText file. See the Writer Guide Chapter 3 Working with Text for more information.
	Note
	For some types of information that you want to repeatedly enter into a document, it maybe more convenient to create an AutoText file. See the Writer Guide Chapter 3 Working with Text for more information.


Make sure macro recording is enabled by going to Tools > Options > LibreOffice > Advanced on the main menu bar and selecting the option Enable macro recording. By default, this feature is turned off when LibreOffice was installed on your computer.
 693) Go to Tools > Macros > Record Macro on the main menu bar to start recording a macro. A small dialog is displayed indicating that LibreOffice is recording a macro.
 694) Type the desired information or perform an appropriate series of operations. As an example, type your name.
 695) Click Stop Recording on the small Recording dialog to stop recording and the LibreOffice Basic Macros dialog opens (Figure 170 on page 151).
 696) Open the library container My Macros.
 697) Find the library named Standard in My Macros. Note that every library container has a library named Standard.
 698) Select the Standard library and click New Module to create a new module to contain the macro. This opens the New Module dialog (Error: Reference source not found).
 699) [image: ]
Figure 173: New Module dialog

 700) Type a descriptive name for the new module, for example Recorded, and click OK to create the module. The LibreOffice Basic Macros dialog now displays the name of the new module in the Standard library.
 701) In the Macro name text box, type a name for the macro you have just recorded, for example EnterMyName.
 702) Click Save to save the macro and close the LibreOffice Basic Macros dialog.
If you followed all of the above steps, the Standard library now contains a module named Recorded and this module contains the EnterMyName macro.
· Note
When LibreOffice creates a new module, it automatically adds the macro named Main.
	Note
	When LibreOffice creates a new module, it automatically adds the macro named Main.


[bookmark: __RefHeading__5138_1196992793]Running a macro
 703) Go to Tools > Macros > Run Macro on the main menu bar to open the Macro Selector dialog (Figure 174).
 704) For example, select your newly created macro EnterMyName and click Run.
 705) Alternatively, go to Tools > Macros > Organize Macros > LibreOffice Basic on the main menu bar to open the LibreOffice Basic Macros dialog, select your macro and click Run.
[image: ]
[bookmark: Ref_Figure415_full][bookmark: Ref_Figure415_label_and_number]Figure 174: Macro Selector dialog

[bookmark: __RefHeading__5140_1196992793]Viewing and editing macros
To view and/or edit the macro that you created:
 706) Go to Tools > Macros > Organize Macros > LibreOffice Basic to open the LibreOffice Basic Macros dialog.
 707) Select your new macro EnterMyName and click Edit to open the macro in the Basic IDE. The macro EnterMyName is shown in Listing 3.
The EnterMyName macro is not as complicated as it first appears. Learning a few things helps significantly in understanding macros. The discussion starts with features near the top of the macro listing and describes them.
[bookmark: Ref_Listing2_label_and_number]Listing 3: Generated “EnterMyname” macro
REM  *****  BASIC  *****
Sub Main

End Sub

sub EnterMyName
rem -------------------------------------------------------------
rem define variables
dim document   as object
dim dispatcher as object
rem -------------------------------------------------------------
rem get access to the document
document   = ThisComponent.CurrentController.Frame
dispatcher = createUnoService("com.sun.star.frame.DispatchHelper")

rem -------------------------------------------------------------
dim args1(0) as new com.sun.star.beans.PropertyValue
args1(0).Name = "Text"
args1(0).Value = "Your name"

dispatcher.executeDispatch(document, ".uno:InsertText", "", 0, args1())
end sub
Commenting with REM
REM comments
All comments in macro coding begin with REM, which stands for remark. All text after REM and on the same line is ignored. As a short cut, the single quote character (') can also be used to start a comment.
LibreOffice Basic is not case-sensitive for keywords, so REM, Rem, and rem can all start a comment. If you use symbolic constants defined by the Application Programming Interface (API), it is safer to assume that the names are case-sensitive. Symbolic constants are an advanced topic not covered by this user guide and are not required when using the macro recorder in LibreOffice.
[bookmark: __RefHeading__5144_1196992793]Defining subroutines with SUB
Individual macros are stored in subroutines and these subroutines begin with the keyword SUB. The end of a subroutine is indicated by the words END SUB. The code starts by defining the subroutine named Main, which is empty and does nothing. The next subroutine, EnterMyName, contains the generated code for your macro.
· Note
LibreOffice always creates an empty subroutine named Main when it creates a module.
	Note
	LibreOffice always creates an empty subroutine named Main when it creates a module.


There are advanced topics that are beyond the scope of this user guide, but knowing about them might be of interest:
· You can write a macro so that values can be passed to the subroutine. The values are called arguments. However, recorded macros in LibreOffice do not accept arguments.
· Another kind of subroutine is called a function, which is a subroutine that returns a value. Functions are defined by the keyword FUNCTION at the beginning. However, recorded macros in LibreOffice always create subroutines, not functions.
[bookmark: __RefHeading__5146_1196992793]Defining variables using Dim
You can write information on a piece of paper so that you can look at it later. A variable, like a piece of paper, contains information that can be changed and read. The Dim keyword originally stood for Dimension and was used to define the dimensions of an array. The dim statement used in the EnterMyName macro is similar to setting aside a piece of paper to be used to store a message or note.
In the EnterMyName macro, the variables document and dispatcher are defined as the type object. Other common variable types include string, integer, and date. A third variable, named args1, is an array of property values. A variable of type array allows a single variable to contain multiple values, similar to storing multiple pages in a single book. Values in an array are usually numbered starting from zero. The number in the parentheses indicates the highest usable number to access a storage location. In this example, there is only one value, and it is numbered zero.
[bookmark: __RefHeading__5148_1196992793]Explaining macro code
The following is an explanation of the code used in the EnterMyName macro. You may not understand all the details, but the explanation of each line of code may give you some idea of how a macro works.
sub EnterMyName
Defines the start of the macro
dim document   as object
Defined as a variable
dim dispatcher as object
Defined as a variable
document = ThisComponent.CurrentController.Frame
ThisComponent refers to the current document.
CurrentController is a property referring to a service that controls the document. For example, when you type, it is the current controller that takes note of what you type. CurrentController then dispatches the changes to the document frame.
Frame is a controller property that returns the main frame for a document. Therefore, the variable named document refers to a document’s frame, which receives dispatched commands.
dispatcher = createUnoService("com.sun.star.frame.DispatchHelper")
Most tasks in LibreOffice are accomplished by dispatching a command. LibreOffice includes a dispatch helper service, which does most of the work when using dispatches in macros. The method CreateUnoService accepts the name of a service and it tries to create an instance of that service. On completion, the dispatcher variable contains a reference to a DispatchHelper.
dim args1(0) as new com.sun.star.beans.PropertyValue
Declares an array of properties. Each property has a name and a value. In other words, it is a name/value pair. The created array has one property at index zero.
args1(0).Name = "Text"
args1(0).Value = "Your name"
Gives the property the name “Text” and the value “Your name”, which is the text that is inserted when the macro is run.
dispatcher.executeDispatch(document, ".uno:InsertText", "", 0, args1())
This is where the magic happens. The dispatch helper sends a dispatch to the document frame (stored in the variable named document) with the command .uno:InsertText. The next two arguments, frame name and search flags, are beyond the scope of this document. The last argument is the array of property values to be used while executing the command InsertText.
end sub
The last line of the code ends the subroutine.
[bookmark: __RefHeading__5150_1196992793]Creating a macro
When creating a macro, it is important to ask two questions before recording:
1. Can the task be written as a simple set of commands?
 1) Can the steps be arranged so that the last command leaves the cursor ready for the next command or entering text or data into the document?
[bookmark: __RefHeading__8592_1448150400]A more complicated example of a macro
A common task is to copy rows and columns of data from a web site and format them as a table in a text document as follows:
 708) Copy the data from the web site to the clipboard.
 709) To avoid strange formatting and fonts, paste the text into a Writer document as unformatted text.
 710) Reformat the text with tabs between columns so that it can be converted into a table using Table > Convert > Text to Table on the main menu bar.

Figure 175: Example of copied data
DONTKNOW 	The font weight is not specified/known.  
THIN 	specifies a 50% font weight.  
ULTRALIGHT 	specifies a 60% font weight.  
LIGHT 	specifies a 75% font weight.  
SEMILIGHT 	specifies a 90% font weight.  
NORMAL 	specifies a normal font weight.  
SEMIBOLD 	specifies a 110% font weight.  
BOLD 	specifies a 150% font weight.  
ULTRABOLD 	specifies a 175% font weight.  
BLACK 	specifies a 200% font weight.  

With the two questions given above in mind, inspect the text to see if a macro can be recorded to format the text. An example of copied data showing the FontWeight constants group from the API web site (Figure 176). The first column in this example indicates a constant name and each name is followed by a space and a tab, and each line has two trailing spaces.
The first column in the table should contain a numeric value, the second column the name, and the third column the description. This conversion is easily accomplished for every row except for DONTKNOW and NORMAL, which do not contain a numeric value, but the values are between 0 and 100 and can be entered manually.

[bookmark: Ref_Figure416_label_and_number]Figure 176: Example of copied data
DONTKNOW 	The font weight is not specified/known.  
THIN 	specifies a 50% font weight.  
ULTRALIGHT 	specifies a 60% font weight.  
LIGHT 	specifies a 75% font weight.  
SEMILIGHT 	specifies a 90% font weight.  
NORMAL 	specifies a normal font weight.  
SEMIBOLD 	specifies a 110% font weight.  
BOLD 	specifies a 150% font weight.  
ULTRABOLD 	specifies a 175% font weight.  
BLACK 	specifies a 200% font weight.  

The data can be cleaned up in several ways, all of them easy to accomplish. The example given below uses keystrokes that assume the cursor is at the start of the line with the text THIN.
 711) Make sure macro recording is enabled by going to Tools > Options > LibreOffice > Advanced on the main menu bar and selecting the option Enable macro recording. By default, this feature is turned off when LibreOffice was installed on your computer.
 712) Go to Tools > Macros > Record Macro on the main menu bar to start recording.
 713) Press Ctrl+Right Arrow to move the cursor to the start of “specifies”.
 714) Press Backspace twice to remove the tab and the space.
 715) Press Tab to add the tab without the space after the constant name.
 716) Press Delete to delete the lower case s and then press Shift+S to add an upper case S.
 717) Press Ctrl+Right Arrow twice to move the cursor to the start of the number.
 718) Press Ctrl+Shift+Right Arrow to select and move the cursor before the % sign.
 719) Press Ctrl+C to copy the selected text to the clipboard.
 720) Press End to move the cursor to the end of the line.
 721) Press Backspace twice to remove the two trailing spaces.
 722) Press Home to move the cursor to the start of the line.
 723) Press Ctrl+V to paste the selected number to the start of the line.
 724) Pasting the value also pasted an extra space, so press Backspace to remove the extra space.
 725) Press Tab to insert a tab between the number and the name.
 726) Press Home to move to the start of the line.
 727) Press down arrow to move to the next line.
 728) Stop recording the macro and save the macro, see “Recording a macro” on page 152.
It takes much longer to read and write the steps than to record the macro. Work slowly and think about the steps as you do them. With practice this becomes second nature.
The generated macro code in Listing 4 has been modified to contain the step number in the comments to match the code to the step above.
[bookmark: Ref_Listing3_label_and_number]Listing 4: Copying numeric value to start of the column

sub CopyNumToCol1
rem -------------------------------------------------------------
rem define variables
dim document   as object
dim dispatcher as object
rem -------------------------------------------------------------
rem get access to the document
document   = ThisComponent.CurrentController.Frame
dispatcher = createUnoService("com.sun.star.frame.DispatchHelper")

rem (3) Press Ctrl+Right Arrow to move the cursor to the start of “specifies”.
dispatcher.executeDispatch(document, ".uno:GoToNextWord", "", 0, Array())

rem (4) Press Backspace twice to remove the tab and the space.
dispatcher.executeDispatch(document, ".uno:SwBackspace", "", 0, Array())

rem -------------------------------------------------------------
dispatcher.executeDispatch(document, ".uno:SwBackspace", "", 0, Array())

rem (5) Press Tab to add the tab without the space after the constant name.
dim args4(0) as new com.sun.star.beans.PropertyValue
args4(0).Name = "Text"
args4(0).Value = CHR$(9)

dispatcher.executeDispatch(document, ".uno:InsertText", "", 0, args4())

rem (6) Press Delete to delete the lower case s ....
dispatcher.executeDispatch(document, ".uno:Delete", "", 0, Array())

rem (6) ... and then press Shift+S to add an upper case S.
dim args6(0) as new com.sun.star.beans.PropertyValue
args6(0).Name = "Text"
args6(0).Value = "S"

dispatcher.executeDispatch(document, ".uno:InsertText", "", 0, args6())

rem (7) Press Ctrl+Right Arrow twice to move the cursor to the number.
dispatcher.executeDispatch(document, ".uno:GoToNextWord", "", 0, Array())

rem -------------------------------------------------------------
dispatcher.executeDispatch(document, ".uno:GoToNextWord", "", 0, Array())

rem (8) Press Ctrl+Shift+Right Arrow to select the number.
dispatcher.executeDispatch(document, ".uno:WordRightSel", "", 0, Array())

rem (9) Press Ctrl+C to copy the selected text to the clipboard.
dispatcher.executeDispatch(document, ".uno:Copy", "", 0, Array())

rem (10) Press End to move the cursor to the end of the line.
dispatcher.executeDispatch(document, ".uno:GoToEndOfLine", "", 0, Array())

rem (11) Press Backspace twice to remove the two trailing spaces.
dispatcher.executeDispatch(document, ".uno:SwBackspace", "", 0, Array())


rem -------------------------------------------------------------
dispatcher.executeDispatch(document, ".uno:SwBackspace", "", 0, Array())

rem (12) Press Home to move the cursor to the start of the line.
dispatcher.executeDispatch(document, ".uno:GoToStartOfLine", "", 0, Array())

rem (13) Press Ctrl+V to paste the selected number to the start of the line.
dispatcher.executeDispatch(document, ".uno:Paste", "", 0, Array())

rem (14) Press Backspace to remove the extra space.
dispatcher.executeDispatch(document, ".uno:SwBackspace", "", 0, Array())

rem (15) Press Tab to insert a tab between the number and the name.
dim args17(0) as new com.sun.star.beans.PropertyValue
args17(0).Name = "Text"
args17(0).Value = CHR$(9)

dispatcher.executeDispatch(document, ".uno:InsertText", "", 0, args17())
rem (16) Press Home to move to the start of the line.
dispatcher.executeDispatch(document, ".uno:GoToStartOfLine", "", 0, Array())

rem (17) Press Down Arrow to move to the next line.
dim args19(1) as new com.sun.star.beans.PropertyValue
args19(0).Name = "Count"
args19(0).Value = 1
args19(1).Name = "Select"
args19(1).Value = false

dispatcher.executeDispatch(document, ".uno:GoDown", "", 0, args19())
end sub
Cursor movements are used for all operations (as opposed to searching). If run on the DONTKNOW line, the word weight is moved to the front of the line, and the first “The” is changed to “She”. This is not perfect, but you should not run the macro on the lines that did not have the proper format. You need to do these manually.
[bookmark: __RefHeading__5154_1196992793]Running a macro quickly
It is tedious to repeatedly run the macro using Tools > Macros > Run Macro on the main menu bar when the macro can be run from the IDE (Figure 172 on page 152).
 729) Go to Tools > Macros > Organize Macros > LibreOffice Basic on the main menu bar to open the Basic Macro dialog (Figure 170 on page 151).
 730) Select your macro and click Edit to open the macro in the IDE.
 731) Click the Run BASIC icon [image: ] on the Macro toolbar, or press the F5 key, to run the macro.
 732) Unless you change the first macro, it is the empty macro named Main. Modify Main so that it reads as shown in Listing 5.
 733) Now, you can run CopyNumToCol1 by repeatedly clicking the Run Basic icon in the toolbar of the IDE. This is very fast and easy, especially for temporary macros that will be used a few times and then discarded.
[bookmark: Ref_Listing4_label_and_number]Listing 5: Modify Main to call CopyNumToCol1.

Sub Main
  CopyNumToCol1
End Sub
[bookmark: __RefHeading__5156_1196992793]Macro recorder failures
Sometimes the macro recorder has a failure and understanding LibreOffice internal workings helps to understand how and why the macro recorder sometimes fails. The primary offender is related to the dispatch framework and its relationship to the macro recorder.
[bookmark: __RefHeading__5158_1196992793][bookmark: Ref_The_dispatch_framework_section]Dispatch framework
The purpose of the dispatch framework is to provide uniform access to components (documents) for commands that usually correspond to menu items. Using File > Save from the main menu bar, the shortcut keys Ctrl+S, or clicking the Save icon are all of commands that are translated into the same “dispatch command”.
The dispatch framework can also be used to send “commands” back to the User Interface (UI). For example, after saving the document, the File Save command is disabled. As soon as the document has been changed, the File Save command is enabled.
A dispatch command is text, for example .uno:InsertObject or .uno:GoToStartOfLine. The command is sent to the document frame and this passes on the command until an object is found that can handle the command.
[bookmark: __RefHeading__5160_1196992793]How the macro recorder uses the dispatch framework
The macro recorder records the generated dispatches. The recorder is relatively simple tool to use and the same commands that are issued are recorded for later use. The problem is that not all dispatched commands are complete. For example, inserting an object generates the following code:
dispatcher.executeDispatch(document, ".uno:InsertObject", "", 0, Array())
It is not possible to specify what kind of object to create or insert. If an object is inserted from a file, you cannot specify which file to insert.
Recording a macro and using Tools > Options on the main menu bar to open and modify configuration items, the generated macro does not record any configuration changes. In fact, the generated code is commented so it will not even be run.
rem dispatcher.executeDispatch(document,
    ".uno:OptionsTreeDialog", "", 0, Array())
If a dialog is opened, a command to open the dialog is likely to be generated. Any work done inside the dialog is not usually recorded. Examples of this include macro organization dialogs, inserting special characters, and similar types of dialogs. Other possible problems using the macro recorder include things such as inserting a formula, setting user data, setting filters in Calc, actions in database forms, and exporting a document to an encrypted PDF file. You never know for certain what will work unless you try it. For example, the actions from the search dialog are properly captured.
[bookmark: __RefHeading__5162_1196992793]Other options
When the macro recorder is not able to solve a specific problem, the usual solution is to write code using the LibreOffice objects. Unfortunately, there is a steep learning curve for these LibreOffice objects. It is usually best to start with simple examples and then increase the scope of macros as you learn more. Learning to read generated macros is a good place to start.
If you record Calc macros, and the recorder can correctly generate a macro, there is an add-in available which converts Calc macros when they are recorded. The final code manipulates LibreOffice objects rather than generating dispatches. This can be very useful for learning the object model and can be downloaded directly from the web site:
http://www.paolo-mantovani.org/downloads/DispatchToApiRecorder/
[bookmark: __RefHeading__5164_1196992793]Macro organization
In LibreOffice, macros are grouped in modules, modules are grouped in libraries, and libraries are grouped in library containers. A library is usually used as a major grouping for either an entire category of macros, or for an entire application. Modules usually split functionality, such as user interaction and calculations. Individual macros are subroutines and functions. Figure 177 shows an example of the hierarchical structure of macro libraries in LibreOffice.
Go to Tools > Macros > Organize Macros > LibreOffice Basic on the main menu bar to open the LibreOffice Basic Macros dialog (Figure 170 on page 151). All available library containers are shown in the Macro from list. Every document is a library container, capable of containing multiple libraries. The application itself acts as two library containers, one container for macros distributed with LibreOffice called LibreOffice Macros, and one container for personal macros called My Macros.
The LibreOffice Macros are stored with the application runtime code, which may not be editable to you unless you are an administrator. This helps protect these macros because they should not be changed and you should not store your own macros in the LibreOffice container.
Unless your macros are applicable to a single document, and only to a single document, your macros will probably be stored in the My Macros container. The My Macros container is stored in your user area or home directory.
[image: ]
[bookmark: Ref_Figure417_label_and_number]Figure 177: Macro Library hierarchy

If a macro is contained in a document, then a recorded macro will attempt to work on that document; because it primarily uses “ThisComponent” for its actions.
Every library container contains a library named Standard. It is better to create your own libraries with meaningful names than to use the Standard library. Not only are meaningful names easier to manage, but they can also be imported into other library containers whereas the Standard library cannot.
· Caution
LibreOffice allows you to import libraries into a library container, but it will not allow you to overwrite the library named Standard. Therefore, if you store your macros in the Standard library, you cannot import them into another library container.
	Caution
[image: ]
	LibreOffice allows you to import libraries into a library container, but it will not allow you to overwrite the library named Standard. Therefore, if you store your macros in the Standard library, you cannot import them into another library container.


Just as it makes good sense to give your libraries meaningful names, it is prudent to use meaningful names for your modules. By default, LibreOffice uses names such as Module1, Module2 and so on.
As you create your macros, you must decide where to store them. Storing a macro in a document is useful if the document will be shared and you want the macro to be included with the document. Macros stored in the application library container named My Macros, however, are globally available to all documents.
Macros are not available until the library that contains them is loaded. The Standard library and Template library, however, are automatically loaded. A loaded library is displayed differently from a library that is not loaded. To load the library and the modules it contains, double-click on the library.
[bookmark: __RefHeading__5166_1196992793]Where are macros stored?
LibreOffice stores user-specific data in a directory in the home directory for each user. The location is operating system specific. Go to Tools > Options > LibreOffice > Paths on the main menu bar to view where other configuration data are stored. For example, on computer running Windows XP, this is C:\Documents and Settings\<user name>\Application Data. User macros are stored in LibreOffice\4\user\basic. Each library is stored in its own directory off the basic directory.
For casual use, it It is not necessaryimportant to understand where macros are stored for casual use. If you know where they are stored, however, you can create a backup, share your macros, or inspect them if there is an error.
Go to Tools > Macros > Organize Dialogs on the main menu bar to open the LibreOffice Macro Organizer dialog (Figure 171 on page 151). Alternatively, go to Tools > Macros > Organize Macros > LibreOffice Basic on the main menu bar to open the LibreOffice Macros dialog (Figure 170 on page 151) and then click the Organizer button.
[bookmark: __RefHeading__5168_1196992793]Importing macros
The LibreOffice Macro Organizer dialog allows you to import macro libraries into your document as well as creating, deleting, and renaming libraries, modules, and dialogs.
 734) Select the library container to use and then click Import to import macro libraries (Figure 171 on page 151).
 735) Navigate to the directory containing the library to import (Figure 178). There are usually two files from which to choose, dialog.xlb and script.xlb. It does not matter which of these two files you select; both will be imported. Macros can be stored in libraries inside LibreOffice documents. Select a document rather than a directory on disk to import libraries contained in a document.
· Note
You cannot import the library named Standard.
	Note
	You cannot import the library named Standard.


[image: ]
[bookmark: Ref_Figure418_label_and_number]Figure 178: Navigating to a macro library

· Tip
On a computer operating Linux, the LibreOffice specific files are stored in the home directory of a user in a directory whose name begins with a period. Directories and files with names beginning with a period may be hidden and not shown in a normal selection dialog. If using LibreOffice dialogs, rather than the operating system specific dialogs, type the name of the desired directory in the Name field.
	Tip
	On a computer operating Linux, the LibreOffice specific files are stored in the home directory of a user in a directory whose name begins with a period. Directories and files with names beginning with a period may be hidden and not shown in a normal selection dialog. If using LibreOffice dialogs, rather than the operating system specific dialogs, type the name of the desired directory in the Name field.


 736) Select a file and click Open to continue and open the Import Libraries dialog (Figure 179).
[image: ]
[bookmark: Ref_Figure419_label_and_number]Figure 179: Choose library import options

 737) Select the following options for importing libraries:
1. If no options are selected, the library is copied to your user macro directory. However, if the library you are importing has the same name and you are importing into the same location, it will not be copied.
as) Select Replace existing libraries if the library you want to import has the same name and you want to replace the existing library.
at) Select Insert as reference if you want to use the library as reference, but not import the library into your document. When a library is used as a reference, it remains in its current location and is read only.
 738) Click OK to import the macro library you selected.
[bookmark: __RefHeading__5170_1196992793]Downloading macros to import
Macros are available for download. Some macros are contained in documents, some as regular files that you must select and import, and some as macro text that should be copied and pasted into the Basic IDE. See “Adding a macro” on page 148 on how to add macros to your macro library and “” on page 154 on how to edit macros using the Basic IDE.
Some macros are available as free downloads on the Internet (see Table 3). 
[bookmark: Ref_Table11_label_and_number]Table 3. Macro examples
	Location
	Description

	 
	Reference materials regarding macros.

	 
	Reference materials regarding database macros.

	 
	Lots of links to macros.

	 
 
	Forums, with many examples and help.

	Location
	Description

	
	Reference materials regarding macros.

	
	Reference materials regarding database macros.

	 
	Lots of links to everything.

	
	A forum, with many examples and help.

	
	Another forum, with many examples and help.


[bookmark: __RefHeading__5172_1196992793]How to run a macro
Although you can use Tools > Macros > Run Macro to run all macros, this is not efficient for frequently run macros. See “” on page 153 for more information.
A more common technique for frequently used macros is to linkassign the macro to a toolbar icon, menu item, keyboard shortcut, or a button embedded in a document. While choosing a method, it is also good to ask questions such as:
1. Should the macro be available for only one document, or globally for all documents?
· Is the macro for a specific document type, such as a Calc document?
· How frequently will the macro be used?
The answers will determine where to store the macro and how to make it available. For example, you will probably not add a rarely used macro to a toolbar. To help determine your choices, see Table 4.
[bookmark: Ref_Table12_label_and_number]Table 4. Methods for starting a macro
	Type
	LibreOffice
	Document Type
	Document

	Toolbar
	No
	Yes
	Yes

	Menu
	No
	Yes
	Yes

	Shortcut
	Yes
	Yes
	No

	Event
	Yes
	No
	Yes


[bookmark: __RefHeading__197251_1448150400]Toolbars, menu items, and keyboard shortcuts
To add a menu item, keyboard shortcut, or toolbar icon that calls a macro, use the Customize dialog (Figure 180). The Customize dialog contains pages to configure menus, keyboard shortcuts, toolbars, and events. To open this dialog, go to Tools > Customize on the main menu bar or right-click in an empty space on a toolbar and select Customize Toolbar from the context menu.
Complete coverage of the Customize dialog is beyond the scope of this chapter. Click the Help button to access the help pages included with LibreOffice or see Chapter 14 Customizing LibreOffice.
[image: ]
[bookmark: Ref_Figure420_label_and_number]Figure 180: Menus page in Customize dialog

[bookmark: __RefHeading__197253_1448150400]Events
Whenever In LibreOffice, when something happens in LibreOffice, it is calledit means that an event occurred. For example, opening a document, pressing a key, or moving the mouse cursor are all events. LibreOffice allows events to trigger the execution of a macrocause a macro to be called; the macro is then called an event handler. Full coverage of event handlers is well beyond the scope of this document, but a little knowledge can accomplish much.
· Caution
Be careful when you configure an event handler. For example, assume that you write an event handler that is called every time that a key is pressed, but you make a mistake so the event is not properly handled. One possible result is that your event handler will consume all key presses, forcing you to kill LibreOffice.
	Caution
[image: ]
	Be careful when you configure an event handler. For example, assume that you write an event handler that is called every time that a key is pressed, but you make a mistake so the event is not properly handled. One possible result is that your event handler will consume all key presses, forcing you to forcibly terminate LibreOffice.


 739) Go to Tools > Customize on the main menu bar to open the Customize dialog and select the Events tab (Figure 181). The events in the Customize dialog are related to the entire application and specific documents.
 740) In Save In, select LibreOffice, or a specific document from the drop down menu to save your event.
 741) A common use is to assign the Open Document event to call a specific macro. The macro then performs certain setup tasks for the document. Select the desired event and click Macro to open the Macro Selector dialog (Figure 174 on page 154).
 742) Select the desired macro and click OK to assign the macro to the event. The Events page shows that the event has been assigned to a macro.
[image: ]
[bookmark: Ref_Figure421_label_and_number]Figure 181: Events page in Customize dialog

Many objects in a document can be set to call macros when events occur. The most common use is to add a control, such as a button, into a document. Even double-clicking on a graphic opens a dialog with a Macros tab that allows you to assign a macro to an event.
[bookmark: __RefHeading__5182_1196992793]Extensions
An extension is a package that can be installed into LibreOffice to add new functionality. Extensions can be written in almost any programming language and may be simple or sophisticated. Extensions can be grouped into types:
1. Calc Add-Ins, which provide new functionality for Calc, including new functions that act like normal built-in functions
· New components and functionality, which normally include some level of User Interface (UI) integration such as new menus or toolbars
· Pivot Tables that are used directly in Calc
· Chart Add-Ins with new chart types
· Linguistic components such as spellingspell checkers
· Document templates and images
Although individual extensions can be found in several places, there is currently an extension repository at: http://extensions.libreoffice.org/ and some documentation at http://libreplanet.org/wiki/Group:OpenOfficeExtensions/List.
For more about obtaining and installing extensions, see Chapter 14, Customizing LibreOffice.
[bookmark: __RefHeading__5184_1196992793]Writing macros without the recorder
The examples covered in this chapter are created using the macro recorder and the dispatcher. You can also write macros that directly access the objects that comprise LibreOffice if you are confident in writing computer code. In other words, you can create a macro that directly manipulates a document.
Directly manipulating LibreOffice internal objects is an advanced topic that is beyond the scope of this chapter. A simple example, however, demonstrates how this works.
Listing 6: Append the text “Hello” to the current document.

Sub AppendHello
  Dim oDoc
  Dim sTextService$
  Dim oCurs
  
  REM ThisComponent refers to the currently active document.
  oDoc = ThisComponent

  REM Verify that this is a text document
  sTextService = "com.sun.star.text.TextDocument"
  If NOT oDoc.supportsService(sTextService) Then
    MsgBox "This macro only works with a text document"
    Exit Sub
  End If
  
  REM Get the view cursor from the current controller.
  oCurs = oDoc.currentController.getViewCursor()
  
  REM Move the cursor to the end of the document
  oCurs.gotoEnd(False)
  
  REM Insert text "Hello" at the end of the document
  oCurs.Text.insertString(oCurs, "Hello", False)  
End Sub
[bookmark: __RefHeading__5186_1196992793]Finding more information
Numerous resources are available that provide help with writing macros. Use Help > LibreOffice Help to open the LibreOffice help pages. The upper left corner of the LibreOffice help system contains a drop-down list that determines which help set is displayed. To view the help for Basic, choose LibreOffice Basic from this list.
[bookmark: __RefHeading__5188_1196992793]Included material
Many excellent macros are included with LibreOffice. Use Tools > Macros > Organize Macros > LibreOffice Basic to open the Macro dialog. Expand the Tools library in the LibreOffice library container. Inspect the Debug module—some good examples include WritedbgInfo(document) and printdbgInfo(sheet).
[bookmark: __RefHeading__5190_1196992793]Online resources
The following links and references contain information regarding macro programming:
http://ask.libreoffice.org/ (a Q & A site where volunteers answer questions related to LibreOffice)
http://forum.openoffice.org/en/forum/ (Apache OpenOffice community forum; volunteers answer questions about LibreOffice as well)
 (Unofficial LibreOffice community forum)
http://api.openoffice.org/docs/common/ref/com/sun/star/module-ix.html (official IDL reference; here you will find almost every command with a description)
https://wiki.documentfoundation.org/Documentation/Other_Documentation_and_Resources (look in Programmers section for BASIC Programmers’ Guide and Developers’ Guide; the latter contains a detailed explanation)
http://www.pitonyak.org/oo.php (macro page for Andrew Pitonyak)
http://www.pitonyak.org/AndrewMacro.odt (numerous examples of working macros)
http://www.pitonyak.org/OOME_3_0.odt (Andrew Pitonyak’s book on macros)
http://www.pitonyak.org/database/ (numerous macro examples using Base)
[bookmark: __RefHeading__7688_1972615798]Printed and eBook materials
There are currently no books specific to LibreOffice macros that are available for download.
Information in the following books is mostly applicable to LibreOffice; the books are available for purchase in both printed and eBook form from their publishers:
Dr. Mark Alexander Bain’s Learn OpenOffice.org Spreadsheet Macro Programming.
See http://www.packtpub.com/openoffice-ooobasic-calc-automation/book.
Roberto Benitez's Database Programming with OpenOffice.org Base & Basic. 
See http://www.lulu.com/product/paperback/database-programming-with-openofficeorg-base-basic/3568728
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[bookmark: __RefHeading___Toc86657_8113635311111111]Chapter 14  
Customizing LibreOffice


[bookmark: __RefHeading___Toc135368_811363531]Introduction
This chapter describes some common customizations that you may wish to carry out.
You can customize menus, toolbars, and keyboard shortcuts in LibreOffice, add new menus and toolbars, and assign macros to events. However, you cannot customize context (right-click) menus.
Other customizations are made easy by extensions that you can install from the LibreOffice website or from other providers.
· Note
Customizations to menus and toolbars can be saved in a template. To do so, first save them in a document and then save the document as a template as described in Chapter 3, Using Styles and Templates.
	Note
	Customizations to menus and toolbars can be saved in a template. To do so, first save them in a document and then save the document as a template as described in Chapter 3, Using Styles and Templates.


[bookmark: __RefHeading__10261_2122281821]Customizing menu content
In addition to changing the menu font (described in Chapter 2, Setting up LibreOffice), you can add and rearrange categories on the menu bar, add commands to menus, and make other changes.
To customize menus:
 743) Choose Tools > Customize.
 744) On the Customize dialog (Figure 182), choose the Menus page.
[image: ]
[bookmark: Ref_Figure422_label_and_number]Figure 182: The Menus page of the Customize dialog

 745) In the Save In drop-down list, choose whether to save this changed menu for the application (for example, LibreOffice Writer) or for a selected document (for example, SampleDocument.odt).
 746) In the section LibreOffice [name of the program (example: Writer)] Menus, select from the Menu drop-down list the menu that you want to customize. The list includes all the main menus as well as submenus (menus that are contained under another menu). For example, in addition to File, Edit, View, and so on, there is File | Send and Edit | Changes. The commands available for the selected menu are shown in the central part of the dialog.
 747) To customize the selected menu, click on the Modify button. You can also add commands to a menu by clicking on the Add button. These actions are described in the following sections. Use the up and down arrows next to the Entries list to move the selected menu item to a different position.
 748) When you have finished making all your changes, click OK (not shown in illustration) to save them.
[bookmark: __RefHeading__10263_2122281821]Creating a new menu
In the Menus page of the Customize dialog, click New to display the New Menu dialog, shown in Figure 183.
1. Type a name for your new menu in the Menu name box.
 1) Use the up and down arrow buttons to move the new menu into the required position on the menu bar.
 2) Click OK to save.
The new menu now appears on the list of menus in the Customize dialog. (It will appear on the menu bar itself after you save your customizations.)
After creating a new menu, you need to add some commands to it, as described in “Adding a command to a menu” on page 174.
[image: ]
[bookmark: Ref_Figure423_label_and_number]Figure 183: Adding a new menu

[bookmark: __RefHeading__10265_2122281821]Modifying existing menus
To modify an existing menu, either user-made or inbuilt, select it in the Menu list and click the Menu button to drop down a list of modifications: Move, Rename, Delete. Not all of these modifications can be applied to all the entries in the Menu list. For example, Rename and Delete are not available for the supplied menus, and Move is not available for submenus.
To move a menu (such as File), choose Menu > Move. A dialog similar to the one shown in Figure 183 (but without the Menu name box) opens. Use the up and down arrow buttons to move the menu into the required position.
To move submenus (such as File | Send), select the main menu (File) in the Menu list and then, in the Menu Content section of the dialog, select the submenu (Send) in the Entries list and use the arrow keys to move it up or down in the sequence. Submenus are easily identified in the Entries list by a small black triangle on the right hand side of the name.
In addition to renaming, you can allocate a letter in a custom menu’s name, which will become underlined, to be used as a keyboard shortcut, allowing you to select that menu by pressing Alt+ that letter. Existing submenus can be edited to change the letter which is used to select their defaulttheirdefault shortcut.
1. Select a custom menu or a submenu in the Menu drop-down list.
 1) Click the Menu button and select Rename.
 2) Add a tilde (~) in front of the letter that you want to use as an accelerator. For example, to select the Send submenu command by pressing S (after opening the File menu using Alt+F), enter ~Send. This changes it from the default d.
· Note
It is possible to use a letter already in use in the menu list (for example, in the Insert menu, the letter v is used in Envelope and in Movie and sound as an accelerator). However, you should use an unused letter if possible, to make it simpler for the user to navigate.
	Note
	It is possible to use a letter already in use in the menu list (for example, in the Insert menu, the letter v is used in Envelope and in Movie and sound as an accelerator). However, you should use an unused letter if possible, to make it simpler for the user to navigate.


[bookmark: __RefHeading__308913_625523294]Adding a command to a menu
You can add commands to both the supplied menus and menus you have created. On the Customize dialog, select the menu in the Menu list and click the Add button in the Menu Content section of the dialog.
[image: ]
[bookmark: Ref_Figure424_label_and_number]Figure 184: Adding a command to a menu

On the Add Commands dialog (Figure 184), select a category and then the command, and click Add. The dialog remains open, so you can select several commands. When you have finished adding commands, click Close. Back on the Customize dialog, you can use the up and down arrow buttons to arrange the commands in your preferred sequence.
[image: ]
Figure 185: Adding a command to a menu

[bookmark: __RefHeading__12828_1845620561]Modifying menu entries
In addition to changing the sequence of entries on a menu or submenu, you can add submenus, rename or delete the entries, and add group separators.
To begin, select the menu or submenu to be modified, from the Menu list near the top of the Customize page, then select the entry in the Entries list under Menu Content. Click the Modify button and choose the required action from the drop-down list of actions.
Most of the actions should be self-explanatory. Begin a group adds a separator line after the highlighted entry.
[bookmark: __RefHeading__10269_2122281821]Customizing toolbars
You can customize toolbars in several ways, including choosing which icons are visible and locking the position of a docked toolbar (as described in Chapter 1, Introducing LibreOffice), and adding or deleting icons (commands) in the list of those available on a toolbar.  You can also create new toolbars. This section describes how to create new toolbars and add or delete icons on existing ones.
To get to the toolbar customization dialog (Figure 186), do any of the following:
· On the toolbar, right-click in the toolbar and choose Customize Toolbar.
· Choose View > Toolbars > Customize from the menu bar.
· Choose Tools > Customize from the menu bar and go to the Toolbars page.
[image: ]
[bookmark: Ref_Figure425_label_and_number]Figure 186: The Toolbars page of the Customize dialog

[bookmark: __RefHeading__6921_1909759735]Modifying existing toolbars
To modify an existing toolbar:
1. In the Save In drop-down list, choose whether to save this changed toolbar for the application (for example, Writer) or for a selected document.
 1) In the section LibreOffice [name of the program (example: Writer)] > Toolbars, select from the Toolbar drop-down list the toolbar that you want to customize.
 2) Click on the Toolbar or Modify buttons, and add commands to a toolbar by clicking on the Add button. You can also create a new toolbar by clicking on the New button. These actions are described in the following sections.
 3) When you have finished making all your changes, click OK to save them.
[bookmark: __RefHeading__10271_2122281821]Creating a new toolbar
To create a new toolbar:
1. Choose Tools > Customize > Toolbars from the menu bar.
 1) Click New. On the Name dialog, type the new toolbar's name and choose from the Save In drop-down list where to save this changed menu: for the application (for example, Writer) or for a selected document. Click OK.
[image: ]
The new toolbar now appears on the list of toolbars in the Customize dialog. After creating a new toolbar, you need to add some commands to it, as described below.
[bookmark: __RefHeading__10273_2122281821]Adding a command to a toolbar
If the list of available buttons for a toolbar does not include all the commands you want on that toolbar, you can add commands. When you create a new toolbar, you need to add commands to it.
1. On the Toolbars page of the Customize dialog, select the toolbar in the Toolbar list and click the Add button in the Toolbar Content section of the dialog.
 1) The Add Commands dialog is the same as for adding commands to menus (Figure 184). Select a category and then the command, and click Add. The dialog remains open, so you can select several commands. When you have finished adding commands, click Close. If you insert an item which does not have an associated icon, the toolbar will display the full name of the item: the next section describes how to choose an icon for a toolbar command.
 2) Back on the Customize dialog, you can use the up and down arrow buttons to arrange the commands in your preferred sequence.
 3) When you have finished making changes, click OK to save.
[bookmark: __RefHeading__10275_2122281821]Choosing icons for toolbar commands
Toolbar buttons usually have icons, not words, on them, but not all of the commands have associated icons.
To choose an icon for a command, select the command and click Modify > Change icon. On the Change Icon dialog, you can scroll through the available icons, select one, and click OK to assign it to the command (Figure 187).
[image: ]
[bookmark: Ref_Figure426_label_and_number]Figure 187: Change Icon dialog

To use a custom icon, create it in a graphics program and import it into LibreOffice by clicking the Import button on the Change Icon dialog. Custom icons should be 16 x 16 pixels in size to achieve the best quality and should not contain more than 256 colors.
[bookmark: __RefHeading__10277_2122281821]Example: Adding a Fax icon to a toolbar
You can customize LibreOffice so that a single click on an icon automatically sends the current document as a fax.
 749) Be sure the fax driver is installed. Consult the documentation for your fax modem for more information.
 750) Choose Tools > Options > LibreOffice Writer > Print. The dialog shown in Figure 188 opens.
 751) Select the fax driver from the Fax list and click OK.
 752) Right-click in the Standard toolbar. In the drop-down menu, choose Customize Toolbar. The Toolbars page of the Customize dialog appears (Figure 186). Click Add.
 753) On the Add Commands dialog (Figure 189), select Documents in the Category list, then select Send Default Fax in the Commands list. Click Add. Now you can see the new icon in the Commands list.
 754) In the Commands list, click the up or down arrow button to position the new icon where you want it. Click OK and then click Close.
[image: ]
[bookmark: Ref_Figure427_label_and_number]Figure 188: Setting up LibreOffice for sending faxes

Your toolbar now has a new icon to send the current document as a fax.
[image: ]
[bookmark: Ref_Figure428_label_and_number]Figure 189: Adding a Send Fax command to a toolbar

[bookmark: __RefHeading__10279_2122281821]Assigning shortcut keys
In addition to using the built-in keyboard shortcuts (listed in Appendix A), you can define your own. You can assign shortcuts to standard LibreOffice functions or your own macros and save them for use with the entire LibreOffice suite.
· Caution
Be careful when reassigning your operating system’s or LibreOffice’s predefined shortcut keys. Many key assignments are universally understood shortcuts, such as F1 for Help, and are always expected to provide certain results. Although you can easily reset the shortcut key assignments to the LibreOffice defaults, changing some common shortcut keys can cause confusion, especially if other users share your computer.
	Caution
[image: ]
	Be careful when reassigning your operating system’s or LibreOffice’s predefined shortcut keys. Many key assignments are universally understood shortcuts, such as F1 for Help, and are always expected to provide certain results. Although you can easily reset the shortcut key assignments to the LibreOffice defaults, changing some common shortcut keys can cause confusion, especially if other users share your computer.


To adapt shortcut keys to your needs, use the Customize dialog, as described below.
1. Select Tools > Customize > Keyboard. The Customize dialog opens.
 1) To have the shortcut key assignment available in all components of LibreOffice select the LibreOffice button.
 2) Next select the required function from the Category and Function lists.
 3) Now select the desired shortcut keys in the Shortcut keys list and click the Modify button at the upper right.
 4) Click OK to accept the change. Now the chosen shortcut keys will execute the function chosen in step 3 above whenever they are pressed.
· Note
All existing shortcut keys for the currently selected Function are listed in the Keys selection box. If the Keys list is empty, it indicates that the chosen key combination is free for use. If it were not, and you wanted to reassign a shortcut key combination that is already in use, you must first delete the existing key.
Shortcut keys that are grayed-out in the listing on the Customize dialog, such as F1 and F10, are not available for reassignment.
	Note
	All existing shortcut keys for the currently selected Function are listed in the Keys selection box. If the Keys list is empty, it indicates that the chosen key combination is free for use. If it were not, and you wanted to reassign a shortcut key combination that is already in use, you must first delete the existing key.
Shortcut keys that are grayed-out in the listing on the Customize dialog, such as F1 and F10, are not available for reassignment.


[bookmark: __RefHeading__10281_2122281821]Example: Assigning styles to shortcut keys
You can configure shortcut keys to quickly assign styles in your document. Some shortcuts are predefined, such as Ctrl+0 for the Text body paragraph style, Ctrl+1 for the Heading 1 style, and Ctrl+2 for Heading 2. You can modify these shortcuts and create your own.
1. Click Tools > Customize > Keyboard. The Keyboard page of the Customize dialog (Figure 190) opens.
 1) To have the shortcut key assignment available only with one component (for example, Writer), select that component’s name in the upper right corner of the page; otherwise select LibreOffice to make it available to every component.
 2) Choose the shortcut keys you want to assign a style to. In this example, we have chosen Ctrl+9. This enables the Modify button.
 3) In the Functions section at the bottom of the dialog, scroll down in the Category list to Styles. Click the expansion symbol (usually a + sign or triangle) to expand the list of styles.
 4) Choose the category of style. (This example uses a paragraph style, but you can also choose character styles and others.) The Function list will display the names of the available styles for the selected category. The example shows some of LibreOffice’s predefined styles.
 5) To assign Ctrl+9 to be the shortcut key combination for the List 1 style, select List 1 in the Function list, and then click Modify. Ctrl+9 now appears in the Keys list on the right, and List 1 appears next to Ctrl+9 in the Shortcut keys box at the top.
 6) Make any other required changes, and then click OK to save these settings and close the dialog.
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[bookmark: Ref_Figure429_label_and_number]Figure 190: Defining keyboard shortcuts for applying styles

[bookmark: __RefHeading__10283_2122281821]Saving changes to a file
Changes to the shortcut key assignments can be saved in a keyboard configuration file for use at a later time, thus permitting you to create and apply different configurations as the need arises. To save keyboard shortcuts to a file:
1. After making your keyboard shortcut assignments, click the Save button at the right of the Customize dialog (Figure 190).
 1) In the Save Keyboard Configuration dialog, select All files from the Save as Type list.
 2) Next enter a name for the keyboard configuration file in the File name box, or select an existing file from the list. If you need to, browse to find a file from another location.
 3) Click Save. A confirmation dialog appears if you are about to overwrite an existing file, otherwise there will be no feedback and the file will be saved.
[bookmark: __RefHeading__10285_2122281821]Loading a saved keyboard configuration
To load a saved keyboard configuration file and replace your existing configuration, click the Load button at the right of the Customize dialog, and then select the configuration file from the Load Keyboard Configuration dialog.
[bookmark: __RefHeading__10287_2122281821]Resetting the shortcut keys
To reset all of the keyboard shortcuts to their default values, click the Reset button near the bottom right of the Customize dialog. Use this feature with care as no confirmation dialog will be displayed; the defaults will be set without any further notice or user input.
[bookmark: __RefHeading__10289_2122281821]Assigning macros to events
In LibreOffice, when something happens, we say that an event occurred. For example, a document was opened, a key was pressed, or the mouse moved. You can associate a macro with an event, so the macro is run when the event occurs. A common use is to assign the “open document” event to run a macro that performs certain setup tasks for the document.
To associate a macro with an event, use the Events page of the Customize dialog. For more information, see Chapter 13, Getting Started with Macros.
[bookmark: __RefHeading__10291_2122281821]Adding functionality with extensions
An extension is a package that can be installed into LibreOffice to add new functionality.
Several extensions are shipped bundled with LibreOffice and are installed with the program. Others can be downloaded from various websites. The official extension repository is located at http://extensions.libreoffice.org/. These extensions are free of charge.
Some extensions from other sources are free of charge; others are available for a fee. Check the descriptions to see what licenses and fees apply to the ones that interest you.
[bookmark: __RefHeading__10293_2122281821]Installing extensions
Extensions can be installed in any of three ways.
 755) Directly from the *.oxt file in your system’'s file browser.
 756) From your web browser, if it can be configured to open this file type from a web page hyperlink.
 757) Directly from Tools > Extension Manager by clicking Add (Figure 191).
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[bookmark: Ref_Figure430_label_and_number]Figure 191: Using the Extension Manager

To install directly from a saved *.oxt file on your system, double-click the file.
To install from a suitably enabled web browser, select the hyperlink, and then select to Open the file.
In both cases, after the Extension Manager opens, a warning dialog opens for you to verify the installation and then continue (Error: Reference source not found). The file is installed as a “user only” file in a multi-user system.
[image: ]
Figure 192: Using the Extension Manager

[image: ]
Figure 193: Installation warning dialog

To install directly from Extension Manager:
 1) In LibreOffice, select Tools > Extension Manager from the menu bar. The option to view the extensions bundled with LibreOffice can be deselected to view more easily those installations that have been added by a user.
 2) In the Extension Manager dialog (Figure 191), click Add.
 3) A file browser window opens. Find and select the extension you want to install and click Open.
 4) Users with administrator or root privileges will see a dialog (Error: Reference source not found) where they can choose to install extensions “for all users” (shared) or “only for me” (user). Normal users without those privileges can install, remove, or modify extensions only for their own use (user).
 5) [image: ]
Figure 194: Dialog showing the installation choices

 6) The extension begins installing.
In all three cases, during the process you may be asked to accept a license agreement. When the installation is complete, the extension is listed in the Extension Manager dialog.
· Tip
To get extensions that are listed in the repository, you can open the Extension Manager and click the Get more extensions online link. You do not need to download them separately.

	Tip
	To get extensions that are listed in the repository, you can open the Extension Manager and click the Get more extensions online link. You do not need to download them separately.
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[bookmark: __RefHeading___Toc135370_811363531]Appendix A  
Keyboard Shortcuts


[bookmark: __RefHeading___Toc135372_811363531]Introduction
You can use LibreOffice without requiring a pointing device, such as a mouse or touchpad, by using its built-in keyboard shortcuts.
This appendix lists some of the most common built-in keyboard shortcuts that apply to all components of LibreOffice. For shortcuts specific to Writer, Calc, Impress, Draw, or Base, read the relevant component guide or search the application Help.
· Note
Some of the shortcuts listed here may not work if your operating system uses the same shortcuts for other tasks.
To resolve any conflicts, assign different keys to these shortcuts by reconfiguring either LibreOffice (see Chapter 14) or your operating system (see system documentation).
Assistive tools in LibreOffice
In addition to keyboard shortcuts, LibreOffice supports some assistive technology tools like screen magnification software, screen readers, and on-screen keyboards. Please note that accessibility support relies on Java technology for communications with assistive technology tools. This means that the first program startup may take a few seconds longer, because the Java runtime environment has to be started as well.
A current list of supported assistive tools can be found on the Wiki at .
	Note
	Some of the shortcuts listed here may not work if your operating system uses the same shortcuts for other tasks.
To resolve any conflicts, assign different keys to these shortcuts by reconfiguring either LibreOffice (see Chapter 14) or your operating system (see system documentation).


[bookmark: __RefHeading__6646_1474499666]Tip for Macintosh users
Some keystrokes are different on a Mac from those used in Windows and Linux. The following table gives some common substitutions for the instructions in this chapter. For a more detailed list, see the application Help.
	Windows or Linux
	Mac equivalent
	Effect

	Right-click
	Control+click and/or right-click depending on computer system
	Opens a context menu

	Ctrl (Control)
	⌘ (Command)
	Used with other keys

	F5
	Shift+⌘+F5
	Opens the Navigator

	F11
	⌘+T
	Opens the Styles and Formatting window


Getting help
	Shortcut Keys
	Result

	F1
	Opens the LibreOffice Help dialog. In LibreOffice Help: jumps to the first help page of the selected tab.

	Shift+F1
	Turns the cursor into the What’s This? question mark. Shows the tip for an item underneath the cursor.

	Shift+F2
	Shows tip for a selected item.

	Esc
	In LibreOffice Help: goes up one level.


[bookmark: __RefHeading__3055_280305268]General keyboard shortcuts
[bookmark: __RefHeading__7990_1196992793]Opening menus and menu items
	Shortcut Keys
	Result

	Alt+<?>
	Opens a menu where <?> is the underlined character of the menu you want to open. For example, Alt+F opens the menu File.
With the menu open, you will again find underlined characters. You can access these menu items directly by pressing the underlined character key. Where two menu items have the same underlined character, press the character key again to move to the next item.
Example: to access the Printer Settings item of the File menu after opening it, press R twice to move from the initial Digital Signatures selection to Printer Settings.
There may be instances where an item in a menu has no underlined character. This will have to be clicked directly.

	Esc
	Closes an open menu.

	F6
	Repeatedly pressing F6 switches the focus and circles through the following objects:
· Menu bar
· Every toolbar from top to bottom and from left to right
· Every free window from left to right
· Document

	Shift+F6
	Switches through objects in the opposite direction.

	Ctrl+F6
	Switches the focus to the document.

	F10 or Alt
	Switches to the Menu bar and back.

	Esc
	Closes an open menu.

	Shortcut Keys
	Result

	Alt+<?>
	Opens a menu where <?> is the underlined character of the menu you want to open. For example, Alt+F opens the menu File
With the menu open, you will again find underlined characters. You can access these menu items directly by simply pressing the underlined character key. Where two menu items have the same underlined character, press the character key again to move to the next item.
Example: to access the Printer Settings item of the File menu after opening it, press R twice to move from the initial Digital Signatures selection to Printer Settings.
There may be instances where an item in a menu has no underlined character. This will have to be clicked directly.

	Esc
	Closes an open menu.

	F6
	Repeatedly pressing F6 switches the focus and circles through the following objects:
· Menu bar
· Every toolbar from top to bottom and from left to right
· Every free window from left to right
· Document

	Shift+F6
	Switches through objects in the opposite direction.

	Ctrl+F6
	Switches the focus to the document.

	F10 or Alt
	Switches to the Menu bar and back.

	Esc
	Closes an open menu.


[bookmark: __RefHeading__9176_964876837]Accessing a menu command
Press Alt or F6 or F10 to select the first item on the menu bar (the File menu). With the right‑arrow, the next menu to the right is selected; with the left-arrow, the previous menu. The Home and End keys select the first and the last item on the Menu bar.
The down-arrow opens a selected menu. An additional down-arrow or up-arrow moves the selection through the menu commands. The right-arrow opens any existing submenus.
Press Enter to runexecute the selected menu command.
RunningExecuting a toolbar command
Press F6 repeatedly until the first icon on the toolbar is selected. Use the right and left arrows to select anyan icon on a horizontal toolbar. Similarly, use the up and down arrows to select anyan icon on a vertical toolbar. The Home key selects the first icon on a toolbar, and the End key, the last.
Press Enter to runexecute the selected icon. If the selected icon normally demands a consecutive mouse action, such as inserting a rectangle, then pressing the Enter key is not sufficient: in these cases press Ctrl+Enter.
Press Ctrl+Enter on an icon for creating a draw object. A draw object will be placed into the middle of the view, with a predefined size.
Press Ctrl+Enter on the Selection tool to select the first draw object in the document. If you want to edit, size, or move the selected draw object, first use Ctrl+F6 to move the focus into the document.
[bookmark: __RefHeading__9178_964876837]Navigating and selecting with the keyboard
You can navigate through a document and make selections with the keyboard.
· To move the cursor, press the key or key combination given in the following table.
· To select the characters under the moving cursor, additionally hold down the Shift key when you move the cursor.
	Key
	Function
	Plus Ctrl key

	Right, left arrow keys
	Moves the cursor one character to the left or to the right.
	Moves the cursor one word to the left or to the right.

	Up, down arrow keys
	Moves the cursor up or down one line.
	(Ctrl+Alt) Moves the cursor  up or down one paragraph.

	Home
	Moves the cursor to the beginning of the current line.
	Moves the cursor to the beginning of the document.

	End
	Moves the cursor to the end of the current line.
	Moves the cursor to the end of the document.

	PgUp
	Scrolls up one page.
	Moves the cursor to the header.

	PgDn
	Scroll down one page.
	Moves the cursor to the footer.

	Key
	Function
	Plus Ctrl key

	Right, left arrow keys
	Moves the cursor one character to the left or to the right.
	Moves the cursor one word to the left or to the right.

	Up, down arrow keys
	Moves the cursor up or down one line.
	(Ctrl+Alt) Moves the current paragraph up or down.

	Home
	Moves the cursor to the beginning of the current line.
	Moves the cursor to the beginning of the document.

	End
	Moves the cursor to the end of the current line.
	Moves the cursor to the end of the document.

	PgUp
	Scrolls up one page.
	Moves the cursor to the header.

	PgDn
	Scroll down one page.
	Moves the cursor to the footer.


[bookmark: __RefHeading__3057_280305268]Controlling dialogs
[bookmark: __RefHeading__7992_1196992793]When you open any dialog, one element (such as a button, an option field, an entry in a list box, or a checkbox) is highlighted or indicated by a dotted box around the field or button name. This element is said to have the focus on it.
	Shortcut Keys
	Result

	Enter
	Activates selected button. In most cases where no button is selected, Enter is equivalent to clicking OK.

	Esc
	Closes dialog without saving any changes made while it was open. In most cases, Esc is equivalent to clicking Cancel. When an open drop-down list is selected, Esc closes the list.

	Spacebar
	Checks an empty checkbox. Clears a checked checkbox.

	Up, down arrow keys 
	Moves focus up and down a list. Increases or decreases value of a variable. Moves focus vertically within a section of dialog.

	Left, right arrow keys
	Moves focus horizontally within a section of a dialog.

	Tab
	Advances focus to the next section or element of a dialog.

	Shift+Tab
	Returns focus to the previous section or element in a dialog.

	Alt+Down Arrow
	Shows items in a drop-down list.


Controlling macros
	Shortcut Keys
	Result

	Ctrl+* (multiplication sign: on number pad only)
	Runs a macro field. (See Chapter 9 for more about macros.)

	Shift+Ctrl+Q
	Stops a running macro.

	Shortcut Keys
	Result

	Ctrl+* (multiplication sign: on number pad only)
	Runs a macro field.

	Shift+Ctrl+Q
	Stops a running macro.


Getting help
	Shortcut Keys
	Result

	F1
	Opens the LibreOffice Help dialog. In LibreOffice Help: jumps to the first help page of the selected tab.

	Shift+F1
	Turns the cursor into the What’s This? question mark. Shows the tip for an item underneath the cursor.

	Shift+F2
	Shows tip for a selected item.

	Esc
	In LibreOffice Help: goes up one level.


[bookmark: __RefHeading__3063_280305268]Managing documents
	Shortcut Keys
	Result

	Ctrl+F4 or Alt+F4
	Closes the current document. Closes LibreOffice when the last open document is closed.

	Ctrl+O
	Launches the Open dialog to open a document.

	Ctrl+S
	Saves the current document. If you are working on a previously unsaved file, the shortcut launches the Save As dialog.

	Ctrl+N
	Creates a new document.

	Shift+Ctrl+N
	Opens the Templates and Documents dialog.

	Ctrl+P
	Opens the Print dialog to print the document.

	Ctrl+Q
	Closes the application.

	Del
	In the Save and Open dialogs, deletes the selected files or folders. Items can be retrieved from the Recycle Bin (Trash).

	Shift+Del
	In the Save and Open dialogs, deletes the selected files or folders. Items are permanently deleted: they can not be retrieved from the Recycle Bin, if your desktop has one.

	Backspace
	In the Save and Open dialogs, shows contents of the current directory’s parent folder. 

	Shortcut Keys
	Result

	Ctrl+F4 or Alt+F4
	Closes the current document. Closes LibreOffice when the last open document is closed.

	Ctrl+O
	Launches the Open dialog to open a document.

	Ctrl+S
	Saves the current document. If you are working on a previously unsaved file, the shortcut launches the Save As dialog.

	Ctrl+N
	Creates a new document.

	Shift+Ctrl+N
	Opens the Templates and Documents dialog.

	Ctrl+P
	Opens the Print dialog to print the document.

	Ctrl+Q
	Closes the application.

	Del
	In the Save and Open dialogs, deletes the selected files or folders. Items can be retrieved from the Recycle Bin (Trash).

	Shift+Del
	In the Save and Open dialogs, deletes the selected files or folders. Items are permanently deleted: they can not be retrieved from the Recycle Bin.

	Backspace
	In the Save and Open dialogs, shows contents of the current directory's parent folder. 


[bookmark: __RefHeading__3065_280305268]Editing
	Shortcut Keys
	Result

	Ctrl+X
	Cuts selected items.

	Ctrl+C
	Copies selected items to the clipboard.

	Ctrl+V
	Pastes copied or cut items from the clipboard.

	Ctrl+Shift+V
	Opens the Paste Special dialog.

	Ctrl+A
	Selects all.

	Ctrl+Z
	Undoes last action.

	Ctrl+Y
	Redoes last action.

	Ctrl+Shift+Y
	Repeats last command.

	Ctrl+F
	Opens the Find dialog

	Ctrl+H
	Opens the Find & Replace dialog.

	Ctrl+Shift+F
	Searches for the last entered search term.

	Ctrl+Shift+R
	Refreshes (redraws) the document view.

	Ctrl+Shift+I
	Shows or hides the cursor in read-only text.


[bookmark: __RefHeading__4070_474125404]Selecting rows and columns in a database table opened by F4
	Shortcut keys
	Result

	Spacebar
	Toggles row selection, except when the row is in edit mode.

	Ctrl+Spacebar
	Toggles row selection.

	Shift+Spacebar
	Selects the current column.

	Ctrl+Page Up
	Moves pointer to the first row.

	Ctrl+Page Down
	Moves pointer to the last row.


[bookmark: __RefHeading__5929_1920147500]Shortcut keys for drawing objects
	Shortcut keys
	Result

	Select the toolbar with F6. Use the Down Arrow and Right Arrow to select the desired toolbar icon and press Ctrl+Enter.
	Inserts a Drawing Object.

	Select the document with Ctrl+F6 and press Tab.
	Selects a Drawing Object.

	Tab
	Selects the next Drawing Object.

	Shift+Tab
	Selects the previous Drawing Object.

	Ctrl+Home
	Selects the first Drawing Object.

	Ctrl+End
	Selects the last Drawing Object.

	Esc
	Ends Drawing Object selection.

	Esc (in Handle Selection Mode)
	Exit Handle Selection Mode and return to Object Selection Mode.

	Up/Down/Left/Right Arrow
	Move the selected point (the snap-to-grid functions are temporarily disabled, but end points still snap to each other).

	Alt+Up/Down/Left/Right Arrow
	Moves the selected Drawing Object one pixel (in Selection Mode).
Re-sizes a Drawing Object (in Handle Selection Mode).
Rotates a Drawing Object (in Rotation Mode).
Opens the properties dialog for a Drawing Object.
Activates the Point Selection mode for the selected drawing object.

	Spacebar
	Select a point of a drawing object (in Point Selection mode) / Cancel selection.
The selected point blinks once per second.

	Shift+Spacebar
	Select an additional point in Point Selection mode.

	Ctrl+Tab
	Select the next point of the drawing object (Point Selection mode).
In Rotation mode, the center of rotation can also be selected.

	Ctrl+Shift+Tab
	Select the previous point of the drawing object (Point Selection mode).

	Ctrl+Enter
	A new drawing object with default size is placed in the center of the current view.

	Ctrl+Enter at the Selection icon
	Activates the first drawing object in the document.

	Esc
	Leave the Point Selection mode. The drawing object is selected afterwards.
Edit a point of a drawing object (Point Edit mode).

	Any text or numerical key
	If a drawing object is selected, switches to edit mode and places the cursor at the end of the text in the drawing object. A printable character is inserted.

	Alt key while creating or scaling a graphic object
	The position of the object’s center is fixed.

	Shift key while creating or scaling a graphic object
	The ratio of the object’s width to height is fixed.


[bookmark: __RefHeading__3071_280305268]Defining keyboard shortcuts
In addition to using the built-in keyboard shortcuts listed in this Appendix, you can define your own. See Chapter 14, Customizing LibreOffice, for instructions.
[bookmark: __RefHeading__3073_280305268][bookmark: __RefHeading__5648_156656864415]Further reading
For help with LibreOffice’s keyboard shortcuts, or using LibreOffice with a keyboard only, search the application Help using the “shortcut keys” or “accessibility” keywords.
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[bookmark: __RefHeading___Toc135374_811363531]Appendix B  
Open Source, Open Standards, OpenDocument


[bookmark: __RefHeading___Toc135376_811363531]Introduction
LibreOffice is a productivity suite that is compatible with other major office suites and available on a variety of platforms. It is open source software and therefore free to download, use, and distribute. If you are new to LibreOffice, this appendix will provide some information regarding its history, its community, and some of its technical specifications.
[bookmark: __RefHeading__182218_780470623]A short history of LibreOffice
The OpenOffice.org project began when Sun Microsystems released the source code (“blueprints”) for its StarOffice® software to the open source community on October 13, 2000. OpenOffice.org 1.0, the product, was released on April 30, 2002. Major updates to OpenOffice.org included version 2.0 in October 2005 and version 3.0 in October 2008. On January 26, 2010, Oracle Corporation acquired Sun Microsystems.
On September 28, 2010, the community of volunteers who develop and promote OpenOffice.org announce a major change in project structure. After ten years’ successful growth with Sun Microsystems as founding and principle sponsor, the project launched an independent foundation called The Document Foundation, to fulfill the promise of independence written in the original charter. This foundation is the cornerstone of a new ecosystem where individuals and organizations can contribute to and benefit from the availability of a truly free office suite.
Unable to acquire the trademarked OpenOffice.org name from Oracle Corporation, The Document Foundation named its product LibreOffice. Continuing the version numbers from OpenOffice.org, LibreOffice 3.3 was released in January 2011. Version 5.0 was released in July 2015; version 5.1 was releases in February 2016.
In February 2012, The Document Foundation was incorporated in Berlin as a German Stiftung. You can read more about The Document Foundation at: http://www.documentfoundation.org/
[bookmark: __RefHeading__182220_780470623]The LibreOffice community
The Document Foundation's mission is:
“...to facilitate the evolution of the OpenOffice.org Community into a new open, independent, and meritocratic organizational structure within the next few months. An independent Foundation is a better match to the values of our contributors, users, and supporters, and will enable a more effective, efficient, transparent, and inclusive Community. We will protect past investments by building on the solid achievements of our first decade, encourage wide participation in the Community, and co-ordinate activity across the Community.”
Some of our corporate supporters include Canonical, The GNOME Foundation, Google, Novell and Red Hat. Additionally, over 450,000 people from nearly every part of the globe have joined this project with the idea of creating the best possible office suite that all can use. This is the essence of an “open source” community!
With its open source software license, LibreOffice is key in the drive to provide an office suite that is available to anyone, anywhere, for commercial or personal use. The software has been translated into many languages and runs on all major operating systems. New functionality can be added in the form of extensions.
The LibreOffice community invites contributors in all areas, including translators, software developers, graphic artists, technical writers, editors, donors and end-user support. Whatever you do best, you can make a difference in LibreOffice. The communityCommunity operates internationally in all time zones and in many languages, linked through the internet at www.libreoffice.org and www.documentfoundation.org.
[bookmark: __RefHeading__182222_780470623]How is LibreOffice licensed?
LibreOffice is distributed under the Mozilla Public License (MPL) 2.0. 
See  Open Source Initiative (OSI) approved Lesser General Public License (LGPL).
The LGPL license is available from the LibreOffice website:  
[bookmark: __RefHeading__182224_780470623]What is “open source”?
The four essential rights of open-source software are embodied within the Free Software Foundation’s General Public License (GPL):
· The right to use the software for any purpose.
· Freedom to redistribute the software for free or for a fee.
· Access to the complete source code of the program (that is, the “blueprints”).
· The right to modify any part of the source, or use portions of it in other programs.
The basic idea behind open source is very simple: When programmers can read, redistribute, and modify the source code for a piece of software, the software evolves. People improve it, people adapt it, people fix bugs.
For more information on Free and Open Source software, visit these websites:
Open Source Initiative (OSI): http://www.opensource.org
Free Software Foundation (FSF): http://www.gnu.org
[bookmark: __RefHeading__3272_1372004992]What are “open standards”?
An open standard provides a means of doing something that is independent of manufacturer or vendor, thus enabling competing software programs to freely use the same file formats. HTML, XML, and ODF are examples of open standards for documents.
An open standard meets the following requirements:
· It is well documented with the complete specification publicly available, either free or at a nominal charge.
· It can be freely copied, distributed and used. The intellectual property of the standard is made irrevocably available on a royalty-free basis.
· It is standardized and maintained in an independent, open forum (also called “standards organization”"standards organization") using an open process.
[bookmark: __RefHeading__182226_780470623]What is OpenDocument?
OpenDocument (ODF) is an XML-based file format for office documents (text documents, spreadsheets, drawings, presentations and more), developed at OASIS (http://www.oasis-open.org/who/), an independent, international standards group.
Unlike other file formats, ODF is an open standard. It is publicly available, royalty-free, and without legal or other restrictions; therefore ODF files are not tied to a specific office suite and anybody can build a program that interprets these files. For this reason ODF is quickly becoming the preferred file format for government agencies, schools and other companies who prefer not to be too dependent on any one software supplier.
LibreOffice saves documents in OpenDocument Format by default. LibreOffice 3 adopted version 1.2 of the OpenDocument standard and LibreOffice 54 continues to use this standard. LibreOffice can also open and save many other file formats, as summarized below; see “File formats LibreOffice can open” on this page, “File formats LibreOffice can save to” on page 197, and “Exporting to other formats” on page 199.
For a full list of file formats that LibreOffice can read and write, see https://en.wikipedia.org/wiki/LibreOffice#Supported_file_formats 
[bookmark: __RefHeading__3274_1372004992]OpenDocument filename extensions
The most common filename extensions used for OpenDocument documents are:
*.odt for word processing (text) documents
*.ods for spreadsheets 
*.odp for presentations 
*.odb for databases 
*.odg for graphics (vector drawings) 
*.odf for formulas (mathematical equations) 
[bookmark: __RefHeading__5835_1372004992]File formats LibreOffice can open
LibreOffice can open a wide variety of file formats in addition to the OpenDocument formats, including Portable Document Format (PDF), if an ODF file is embedded in the PDF (see Chapter 10 Printing, Exporting, and Emailing for more information).
[bookmark: __RefHeading__182230_780470623]Opening text documents
In addition to OpenDocument formats (.odt, .ott, .oth, .odm, and .fodt), Writer can open the formats used by OpenOffice.org 1.x (.sxw, .stw, and .sxg), the following text document formats, and a variety of legacy formats not listed below:
Microsoft Word 6.0/95/97/2000/XP/Mac) (.doc and .dot)
Microsoft Word 2003 XML (.xml)
Microsoft Word 2007/2010 XML (.docx, .docm, .dotx, .dotm)
	Microsoft WinWord 5 (.doc)
	WordPerfect Document (.wpd)

	Microsoft Works (.wps)
	Lotus WordPro (.lwp)

	Abiword Document (.abw, .zabw)
	ClarisWorks/Appleworks Document (.cwk)

	MacWrite Document (.mw, .mcw)
	Rich Text Format (.rtf)

	Text CSV (.csv and .txt)
	StarWriter formats (.sdw, .sgl, .vor)

	DocBook (.xml)
	Unified Office Format text (.uot, .uof)

	Ichitaro 8/9/10/11 (.jtd and .jtt)
	Hangul WP 97 (.hwp)

	T602 Document (.602, .txt)
	AportisDoc (Palm) (.pdb)

	Pocket Word (.psw)
	eBook (.pdb)

	Apple Pages 4 (.pages)
	HTML Document (.htm, .html)

	... and many others
	


Microsoft WinWord 5 (.doc)	WordPerfect Document (.wpd)
Microsoft Works (.wps)	Lotus WordPro (.lwp)
Abiword Document (.abw, .zabw)	ClarisWorks/Appleworks Document (.cwk)
MacWrite Document (.mw, .mcw)	Rich Text Format (.rtf)
Text CSV (.csv and .txt)	StarWriter formats (.sdw, .sgl, .vor)
DocBook (.xml)	Unified Office Format text (.uot, .uof)
Ichitaro 8/9/10/11 (.jtd and .jtt)	Hangul WP 97 (.hwp)
T602 Document (.602, .txt)	AportisDoc (Palm) (.pdb)
Pocket Word (.psw)	eBook (.pdb)
HTML Document (.htm, .html)
Most of these file types are automatically detected by LibreOffice, so they can be opened without explicitly selecting the document type in the file picker.
When opening .htm or .html files (used for web pages), LibreOffice customizes Writer for working with these files.
[bookmark: __RefHeading__182232_780470623]Opening spreadsheets
In addition to OpenDocument formats (.ods, .ots, and .fods), Calc can open the formats used by OpenOffice.org 1.x (.sxc and .stc) and the following spreadsheet formats:
Microsoft Excel 97/2000/XP (.xls, .xlw, and .xlt)
Microsoft Excel 4.x–5.0/95 (.xls, .xlw, and .xlt)
Microsoft Excel 2003 XML (.xml)
Microsoft Excel 2007/2010 XML (.xlsx, .xlsm, .xlts, .xltm)
Microsoft Excel 2007/2010 binary (.xlsb)
Lotus 1-2-3 (.wk1, .wks, and .123)
Data Interchange Format (.dif)
Rich Text Format (.rtf)
Text CSV (.csv and .txt)
StarCalc formats (.sdc and .vor)
dBASE (.dbf)
SYLK (.slk)
Unified Office Format spreadsheet (.uos, .uof)
HTML Document (.htm and .html files, including Web page queries)
Pocket Excel (pxl)
Quattro Pro 6.0 (.wb2)
Apple Numbers 2 (.numbers)
... and many others
[bookmark: __RefHeading__182234_780470623]Opening presentations
In addition to OpenDocument formats (.odp, .odg, .otp, and .fopd), Impress can open the formats used by OpenOffice.org 1.x (.sxi and .sti) and the following presentation formats:
Microsoft PowerPoint 97/2000/XP (.ppt and .pot)
Microsoft PowerPoint 2007/2010 (.pptx, .pptm, .potx, .potm)
StarDraw and StarImpress (.sda, .sdd, .sdp, and .vor)
Unified Office Format presentation (.uop, .uof)
CGM – Computer Graphics Metafile (.cgm)
Portable Document Format (.pdf)
Apple Keynote 5 (.key)
... and many others
[bookmark: __RefHeading__182236_780470623]Opening graphic files
In addition to OpenDocument formats (.odg and .otg), Draw can open the formats used by OpenOffice.org 1.x (.sxd and .std) and the following graphic formats:
Adobe Photoshop (*.psd)
AutoCAD Interchange Format (*.dxf)
Corel Draw (*.cdr)
Corel Presentation Exchange (*.cmx)
Microsoft Publisher 98-2010 (*.pub)
Microsoft Visio 2000-2013 (*.vdx; *.vsd; *.vsdm; *.vsdx)
WordPerfect Graphics (*.wpg)
	BMP
	JPEG, JPG
	PCX
	PSD
	SGV
	WMF

	DXF
	MET
	PGM
	RAS
	SVM
	XBM

	EMF
	PBM
	PLT
	SDA
	TGA
	XPM

	EPS
	PCD
	PNG
	SDD
	TIF, TIFF
	

	GIF
	PCT
	PPM
	SGF
	VOR
	


[bookmark: __RefHeading__182238_780470623]Opening formula files
In addition to OpenDocument Formula (.odf) files, Math can open the format used by OpenOffice.org 1.x (.sxm), StarMath, (.smf), and MathML (.mml) files.
When opening a Word document that contains an embedded equation editor object, if the option for it (MathType to LibreOffice Math or reverse) is checked in Tools > Options > Load/Save > Microsoft Office, the object will be automatically converted to an LibreOffice Math object.
[bookmark: __RefHeading__182240_780470623]File formats LibreOffice can save to
Saving in an OpenDocument format guarantees the correct rendering of the file when it is transferred to another person or when the file is re-opened with a later version of LibreOffice or with another program. It is strongly recommended that you use OpenDocument as the default file formats. However, you can save files in other formats, if you wish.
· Tip
When sharing a document that you do not expect or want the recipient to modify, the safest option is to convert the document to PDF. LibreOffice provides a very straightforward way to convert documents to PDF. See Chapter 10 Printing, Exporting, and E-Mailing in this guide.
	Tip
	When sharing a document that you do not expect or want the recipient to modify, the safest option is to convert the document to PDF. LibreOffice provides a very straightforward way to convert documents to PDF. See Chapter 10 Printing, Exporting, and E-Mailing in this guide.


[bookmark: __RefHeading__182242_780470623]Saving text documents
In addition to OpenDocument formats (.odt, .ott, and .fodt), Writer can save in these formats:
	Microsoft Word 97–2003 (.doc)
	Microsoft Word 2003 XML (.xml)

	Microsoft Word 2007–2013 XML (.docx)
	Office Open XML Text (.docx)

	Rich Text Format (.rtf)
	Text (.txt)

	Text Encoded (.txt)
	Unified Office Format text (.uot, .uof)

	HTML Document (.html and .htm)
	DocBook (.xml)


OpenOffice.org 1.x Text Document (.sxw)
OpenOffice.org 1.x Text Document Template (.stw)
Microsoft Word 6.0, 95, and 97/2000/XP (.doc)
Microsoft Word 2003 XML (.xml)
Microsoft Word 2007/2010 XML (.docx)
Office Open XML Text (.docx)
Rich Text Format (.rtf)
StarWriter 3.0, 4.0, and 5.0 (.sdw)
StarWriter 3.0, 4.0, and 5.0 Template (.vor)
Text (.txt)
Text Encoded (.txt)
Unified Office Format text (.uot, .uof)
HTML Document (OpenOffice.org Writer) (.html and .htm)
DocBook (.xml)
AportisDoc (Palm) (.pdb)
Pocket Word (.psw)
Encryption support within the Microsoft Word 97/2000/XP filter allows password protected Microsoft Word documents to be saved.
· Note
The .rtf format is a common format for transferring text files between applications, but you are likely to experience loss of formatting and images. For this reason, other formats should be used.
	Note
	The .rtf format is a common format for transferring text files between applications, but you are likely to experience loss of formatting and images. For this reason, other formats should be used.


[bookmark: __RefHeading__182244_780470623]Saving spreadsheet files
In addition to OpenDocument formats (.ods and .ots), Calc can save in these formats:
	Microsoft Excel 97–2003 (.xls and .xlw)
	Data Interchange Format (.dif)

	Microsoft Excel 97–2003 Template (.xlt)
	dBase (.dbf)

	Microsoft Excel 2003 XML (.xml)
	SYLK (.slk)

	Microsoft Excel 2007–2013 XML (.xlsx)
	Text CSV (.csv and .txt)

	Office Open XML Spreadsheet (.xlsx)
	Unified Office Format spreadsheet (.uos)

	HTML Document (Calc) (.html and .htm)
	


· Note
The Java Runtime Environment is required to use the mobile device filters for AportisDoc (Palm), Pocket Word, and Pocket Excel.
OpenOffice.org 1.x Spreadsheet (.sxc)
OpenOffice.org 1.x Spreadsheet Template (.stc)
Microsoft Excel 97/2000/XP (.xls and .xlw)
Microsoft Excel 97/2000/XP Template (.xlt)
Microsoft Excel 5.0 and 95 (.xls and .xlw)
Microsoft Excel 2003 XML (.xml)
Microsoft Excel 2007/2010 XML (.xlsx)
Office Open XML Spreadsheet (.xlsx)
Data Interchange Format (.dif)
dBase (.dbf)
SYLK (.slk)
Text CSV (.csv and .txt)
StarCalc 3.0, 4.0, and 5.0 formats (.sdc and .vor)
Unified Office Format spreadsheet (.uos)
HTML Document (OpenOffice.org Calc) (.html and .htm)
Pocket Excel (.pxl)
	Note
	The Java Runtime Environment is required to use the mobile device filters for AportisDoc (Palm), Pocket Word, and Pocket Excel.


[bookmark: __RefHeading__182246_780470623]Saving presentations
In addition to OpenDocument formats (.odp, .otp, .fodp, and .odg), Impress can save in these formats:
Microsoft PowerPoint 97–2003 (.ppt)
Microsoft PowerPoint 97–2003OpenOffice.org 1.x Presentation (.sxi)
OpenOffice.org 1.x Presentation Template (.potsti)
Microsoft PowerPoint 97–2003 AutoPlay (.pps/2000/XP (.ppt)
Microsoft PowerPoint 2007–2013 XML (.pptx, .potm97/2000/XP Template (.pot)
Microsoft PowerPoint 2007–2013 XML AutoPlay (.ppsx/2010 XML (.pptx, .potm)
Office Open XML Presentation (.pptx, .potm, .ppsx)
StarDraw, StarImpress (.sda, .sdd, and .vor)
Unified Office Format presentation (.uop)
Impress can also export to MacroMedia Flash (.swf) and any of the graphics formats listed for Draw.
[bookmark: __RefHeading__182248_780470623]Saving drawings
Draw can only save in the OpenDocument Drawing formats (.odg, .otg, and .fodg), the OpenOffice.org 1.x formats (.sxd and .std) and StarDraw format (.sda, .sdd, and .vor).
However, Draw can also export to BMP, EMF, EPS, GIF, JPEG, MET, PBM, PCT, PGM, PNG, PPM, RAS, SVG, SVM, TIFF, WMF, and XPM.
[bookmark: __RefHeading__182250_780470623]Writer/Web can save in these formats
HTML document (.html and .htm), as HTML 4.0 Transitional
OpenOffice.org 1.0 HTML Template (.stw)
OpenOffice.org 2.x HTML Template (.oth)
StarWriter/Web 4.0 and 5.0 (.vor)
Text and Text Encoded (LibreOffice Writer/Web) (.txt)
[bookmark: __RefHeading__184177_780470623]Exporting to other formats
LibreOffice uses the term “export” for some file operations involving a change of file type. If you cannot find the file type you are looking for under Save As, look under Export for additional types.
[bookmark: __RefHeading__5648_156656864416]LibreOffice can export files to HTML and XHTML. In addition, Draw and Impress can export to Adobe Flash (.swf) and a range of image formats.
To export to one of these formats, choose File > Export. On the Export dialog, specify a file name for the exported document, then select the desired format in the File format list and click the Export button.
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This book has no indexindex is incomplete. We apologize, but no one has volunteered to update it. Our choices were to have no index, or an incomplete index, or to delay publication for so long that the book would be very out of date.

	3  
3D objects  221
A  
accepting or rejecting changes  108
accessibility options  46
adding macros from other sources  342
Advanced  
experimental features  47
macro recording  47
Advanced options  47
advantages of LibreOffice  17
antialiasing screen font  37
appearance options  45
Apply Style list  64
arrow keys  
navigating within spreadsheets  123
arrows  214
Asian language support  55
AutoCorrect  59, 95
AutoFormat, Calc  147
AutoLayout  173
automatic saving  29
AutoRecovery  29, 50
AutoUpdate styles  66
B  
background images from Gallery  313
Basic  342
bitmaps  221
BitTorrent  18
book preview  298
booklet printing  296
bookmarks  109
brackets (Math)  273
brochure printing  296
Bullets and Numbering dialog  178
C  
Calc  
AutoFormat  147
editing data  142
hiding and showing data  149
printing  152
sorting records  150
themes  148
viewing  132
Calc macros  352
cells  
description  114, 116
range  126
toolbars  116
cells, in Calc  
navigating  122
selecting  126
change tracking  108
changes, undo and redo  31
check for updates automatically  48
chemical formulas  286
clipboard  38
closing a document  31
closing LibreOffice  31
CMYK  197
color options  40
color palette  197
color scheme  45
colors  197
Color Picker  40
columns  
deleting  129
inserting  128
columns, in Calc  
freezing  132
selecting  127
comma separated values (CSV)  119
comments, adding  105
complex text layout (CTL)  17, 55
components of OpenOffice.org  16
conditional formatting  148
Context menu  213
context menus  24
Controlling dialogs  377
conversion  221
copy and paste  89
copying object from Gallery  313
create document from template  69
creating a document  25
cross-references  
inserting references  110
overview  109
CSV file  
open  119
CSV files  119
Ctrl-click required to follow hyperlinks  44
custom dictionary  56
Customize dialog  356
customizing  
Enter key  126
keyboard shortcuts  368
menus  362
toolbars  365
D  
dashes  92
data editing, Calc  
changing data in a cell  142
removing data from a cell  142
replacing all data in a cell  142
data entry, Calc  
Fill tool  138
selection lists  141
sharing content  141
speeding up  138
validating cell contents  141
data validity  141
database tables  379
decks  83, 118
default file format  51
default template  73
deleting  
columns and rows  129
sheets  131
deleting files  29
derivative markup (Math)  276
dictionaries, installing  54
dictionary  94
different first page  76
digital rights management (DRM)  303
digital signature  307
Dim  347
dispatch framework  351
dispatch helper  347
divide document into chapters  76
document  
closing  31
create from template  69
creating  25
starting new  25
document status option  35
document views  85
Documentation  11
download updates automatically  48
drag and drop  310
Draw  222
main window  192
toolbars  195
drawing  
arrows  200
banners  207
block arrows  206
connectors  204
curve  201
HTML export  222
polygon  201
rectangles  200
squares  200
Drawing Object Properties toolbar  319
drawing objects  379
3D objects  221
grouping  320
properties  319
drawing toolbar  319
drawing tools  318
duplication  218
dynamic gradients  218
E  
E-mail options  58
e-mailing  
Mail Merge Wizard  305
several recipients  305
Writer document as attachment  304
edit document properties before saving  50
editing data, Calc  142
en-dash and em-dash  92
Enter key  126
envelope  
printing  297
envelope printing  297
EPS images in PDF  300
equation  
numbering  281
equation editor  266
brackets  273
derivative markup  276
Elements  267
equations over more than one line  275
font size  278
formula layout  273
limits to sum/integral  276
markup  271
matrix markup  274
right-click menu  269
event handling  357
export directly as PDF  299
export HTML  53
exporting  
Flash  304
PDF  298
XHTML  304
extended tips  35
extensions  358, 371
extensions and addons  
navigator  30
sources of  18
F  
fax icon, adding to toolbar  367
features  114
Impress  158
Writer  80
fields  
bookmarks  109
cross-reference  109
file locations  39
file sharing options  42
Fill tool, Calc  138
floating toolbars  22
font  
history  38
ignore settings when importing HTML  53
options  41
preview  37
replacement table  41
replacements  41
sizes for HTML  52
Fontwork  
alignment  323
anchoring  324
area options  324
attributes  323
character spacing  323
creating an object  321
editing an object  322
Formatting toolbar  323
gallery  321
grouping  324
line options  324
moving and resizing objects  325
positioning options  324
same letter heights  322
toolbar  321, 322
formatting pages  101
formatting toolbar  21
formatting, Calc  
AutoFormat  147
conditional  148
themes  148
formula bar  116
formula files, opening  386
formula layout  273
Free Software Foundation (FSF)  383
Function Wizard  116
functions  352
G  
Gallery  
adding objects  315
creating a new theme  316
deleting images  316
deleting objects  316
hide/show  314
inserting object as background  313
location  316
opening  313
themes  314
views (icon/detailed)  314
general options  35
GNU/Linux  
system requirements  18
gradients  218
graphic files  
opening  385
saving  387
graphic styles  
  176
graphics  
adding from file  310
linking  311
grid points  215
grouping  220
H  
header  
different on right and left pages  77
headers and footers, Calc  154
Help system  10
Help Tips  35
hidden objects  207
hiding and showing data, Calc  149
history of LibreOffice  382
HTML compatibility  52
HTML export  53
hyperlinks  
absolute  328
editing  331
inserting  328
relative  328
removing  331
hyphenation  
manual  100
I  
icon size and style (user interface)  36
icons in menus  37
IDE  346
ignore font settings when importing HTML  53
image map  317
images  
adding from file  310
linking  311
scanned  313
importing files  384
importing numbers from an HTML page  53
Impress  
  158
 font resizing  174
 main window  159
indents  93
indexes and bibliographies  107
Insert Bookmark dialog  110
Insert Picture dialog  310
inserting  
columns and rows  128
sheets  129
installing and setting up  18
International Support  11
Internet options  58
J  
JRE (Java Runtime Environment)  18, 47
K  
keyboard keys  
navigating within spreadsheets  123
keyboard shortcuts  
assigning  368, 380
customizing  369
loading from a file  370
resetting to default values  370
saving to a file  370
keyboard shortcuts (macros)  356
L  
landscape pages  77
language settings  53
language support  17
layout methods  101
LGPL  14
libraries of macros  352
library containers  352
LibreOffice Basic  342
LibreOffice Basic Macros dialog  344
licensing of LibreOffice  14, 383
limits to sum/integral  276
linking object from gallery  313
Linux  
system requirements  18
load Basic code to edit  51
Load/Save  
Always save as  51
locale settings  54
M  
Mac OS X  
system requirements  18
Macro Organizer dialog  354
macro security options  43
macros  342
assigning to events  371
Calc  352
creating  348
Dim  347
dispatch framework  351
dispatch helper  347
downloading  355
editing  346
event handling  357
example  348
functions  352
IDE  346, 351
library container  344
library containers  352
menu items  356
module  345
modules  352
organization  352
recording  344
REM  346
resources  359
running  345, 356
storage  353
subroutines  346, 352
variables  347
viewing  346
writing  359
mail merge  107
Mail Merge Wizard  
e-mailing Writer document  305
main window, description  114
Managing documents  378
margins (Writer)  104
master pages  182
creating  182
mathematical and chemical equations  266
mathematical markup  271
mathematical symbols  267
matrix markup (Math)  274
measurement unit  93
memory options  36
menu bar  21, 114
menus  
adding commands  364
creating  363
customizing  362
modifying  363
modifying entries  365
Microsoft Office file conversion  52
Microsoft Windows  
system requirements  18
middle mouse button function  38
mouse positioning  38
moving from sheet to sheet  123
N  
Navigation toolbar  85
Navigator  123
new document  25
non-breaking hyphen  92
non-breaking spaces  92
nonconsecutive items, selecting  87
numbering equations  281
numbering pages  103
numbers  
  134
O  
OASIS  17
objects  
aligning  221
arranging  221
distributing  221
framing  207
hidden  207
ODF format version, saving  51
Open and Save As dialogs  29
Open Source Initiative (OSI)  14, 383
Open/Save dialogs  35
OpenDocument Format  17, 51
Opening menus  375
orientation of page  77
P  
page break, Calc  154
page layout  
different first page  76
landscape page  77
orientation  77
page layouts  101
page margins  104, 194
page numbering  103
parts of the main window  21
password protection  28
password-protect PDF  303
paste text  89
path options  39
PDF  
blank page export  300
digital rights management (DRM)  303
embed standard fonts  300
encrypt  303
EPS image  300
export documents to  298
FDF  300
form  300
image compression and resolution  300
initial view selection  301
pages to export  299
password-protect  303
security settings  303
tagged  300
user interface options  301
PDF Options dialog  299
PDF/A-1a  300
personal data, removing  308
Personalization  45
pictures  
adding from file  310
linking  311
pixels  192
Powerpoint  
  158
presentation  
  168
presentations  
saving  387
Print dialog  290
print file directly  290
print options  
general  38
print preview  
Calc  298
Writer  298
print ranges, Calc  152
printer settings  50
printing  
black and white on color printer  297
booklet  296
brochure  296
Calc  152, 294
envelopes, labels, business cards  297
general options  291
grayscale on color printer  297
handouts  295
headers and footers, Calc  154
Impress and Draw  295
multiple pages per sheet  292
notes (Impress)  295
page break, Calc  154
page order, details, scale, in Calc  153
page orientation  291
rows or columns  153
selecting what to print  293
Writer  293
Q  
Quickstarter  
enabling  36
R  
raster graphics  221
rectangle, drawing  200
redlines  108
regular expressions  89
REM  346
remove personal information on saving  44
removing personal data  308
renaming  
sheets  131
renaming files  29
replacement table (font)  41
revision marks  108
RGB  197
right to left (RTL) layout  17
right-click (context) menus  24
rows  
deleting  129
inserting  128
rows, in Calc  
freezing  132
selecting  127
rulers  194
S  
save as  
web page  335
save AutoRecovery information  50
save original Basic code  51
save relative URLs  50
saving files  27
saving spreadsheets  
methods  121
scaling factor (user interface)  36
scanner  313
screen font antialiasing  37
security  28
security options  42
selecting  
nonconsecutive items  87
vertical block of text  88
selection clipboard  38
selection lists, Calc  141
selection, in Calc  
cells  126
sheets  128
send document as e-mail  304
sequence of styles, automatic  77
setup options  34
sheet tabs  117
sheets  
copying sheets  130
description  114
inserting  129
navigating  123
renaming  131
sheets, in Calc  
selecting  128
Sidebar  25
slide master  172
slide show  
automatically advance  189
transitions  188
  158
slides  
slide master  181
  172
snap function  215
snap to grid  215
sorting records, Calc  150
special characters  91, 95
spelling checker  93
spelling options  56
spreadsheets  
description  114
navigate  122
opening  385
saving  121, 387
saving as Microsoft Excel  121
starting a new document  25
starting LibreOffice  18
status bar  24, 117
Writer  81
Style dialog  66
styles  215
Apply Style list  64
assigning to shortcut keys  369
AutoUpdate  66
changing using Style dialog  66
creating by dragging and dropping  67
creating from selection  67
creating new  67
creating using Style dialog  67
custom  67
defining a sequence  77
deleting  69
description  62
Fill Format  64
linking  67
modifying  65
types supported  62
updating from a selection  66
  176
Styles and Formatting window  63
Styles dialog  67
SUB  346
subroutines  352
subroutines in macros  346
Sun Microsystems  382
support  10
system font (user interface)  36
T  
Tab panel  83, 118
tab stops  92
table of contents, automated  106
template  
create document from  69
create from document  70
create using wizard  70
deleting  75
description  62
editing  71
exporting  76
folders  74
text  
bulleted or numbered list  176
outline level  177
pasting  174
text boundaries (show/hide)  45
text box  
AutoLayout  173, 176
text documents  
opening  384
Text Formatting toolbar  176
theme  
deleting  316
themes  314
themes (Gallery)  316
title bar  114
tool palettes  22
toolbar command  376
toolbar icons (macros)  356
toolbars  161
adding commands  366
block arrows  206
choosing icons for commands  367
connectors  204
creating  366
curve  201
customizing  23
displaying or hiding  21
Draw  195
Fontwork  321
Line and Filling toolbar  196
lines and arrows  200
moving  22
overview  21
show or hide icons  23
Text Formatting toolbar  196
tooltips  35, 171
track changes  108
transparency  218
two-digit years  35
U  
undo change  31
ungrouping  220
unsaved changes flag  82
URL Recognition  328
user data options  34
User guides  11
user interface options  36
user interface, parts of  12
user-specific settings  49
V  
validating cell contents, Calc  141
variables in macros  347
VBA properties load/save options  51
vector graphics  192
vertical block of text, select  88
view options  36
W  
Web Layout  335
web page export  
Calc spreadsheets  336
Impress presentations  336
Web wizard (Writer)  332
Writer documents  332
wildcards  89
wizard  
web  332
  166
workspace  
Draw  192
Writer  
document views  85
features  80
Navigation toolbar  85
workspace  80
zoom  82, 85
Y  
year (two digits)  35
Z  
zoom  82, 85, 132
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