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Read This!

LYXBook is a collection of layouts and customizations designed
specifically for typesetting books in LYX, the what-you-see-is-
what-you-mean document (not word) processor:

www.lyx.org

This documentation was written not just to tell you how to use
LYXBook but also to show you how to use it. The LYX file of this
documentation (LYXBook.lyx) is itself an example of how to put
together a (very short) book. It uses the default LYXBook layout
(LYXBook–Default.layout), which must be installed before the LYX
file of this documentation will work correctly.

LYXBook is compatible with LYXConverter, a Microsoft Word
add-in that converts Word documents into LYX documents.
LYXConverter includes additional LYXBook layouts along with var-
ious modules and customized keyboard shortcuts for use with
LYX. You can learn more here:

www.editorium.com/lyxconverter.htm

xi





Part I
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Illustration





Chapter 1

Installing LYXBook

Before installing LYXBook, you’ll need to have LYX (including a
LATEX distribution) installed on your computer. You can download
everything you need here:

www.lyx.org/Download#toc2

• If you’re using a Windows computer, install the version of
LYX that’s bundled with LATEX: LYX-2.x.x-Bundle-2.exe or sim-
ilar. If LATEX is already installed on your computer, the LYX
installer is all you need: LYX-2.x.x-Installer-2.exe or similar.

• If you’re using a Macintosh or Linux computer, follow the
requirements listed on the web page. Many Linux distribu-
tions already include LYX and LATEX.

After installing LYX, you should do the following:

1. If you haven’t used LYX before, read the LYX Introduction
and Tutorial (both under the Help menu). If you need more
information, read the User’s Guide.
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4 Installing LYXBook

2. Make sure that LYX can produce a typeset PDF version of
a document (try one of the Help files) by clicking View >
[PDF (pdflatex)].

If you need help, consult the LYX wiki and mailing lists:

wiki.lyx.org/
www.lyx.org/MailingLists

The Editorium cannot help you with LYX but will try to help you
with LYXBook if necessary:

editor@editorium.com

Suggestions for improvements, additional layouts, more modules,
and so on, are welcome.

Layout Files

After installing LYX, you can install the LYXBook layout files:

• LYXBook–Default.layout

• LYXBook–Archaic.layout

• LYXBook–Plain.layout (included with LYXConverter)

• LYXBook–Deco.layout (included with LYXConverter)

• LYXBook–Ruled.layout (included with LYXConverter)

• LYXBook–RuledThick.layout (included with LYXConverter)

You’ll find detailed instructions for installing layout files here:
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wiki.lyx.org/Layouts/Layouts

Basically, you just put the files into your user directory under
~\LYX2.0\layouts. You can find out where that is on your com-
puter by starting LYX and then clicking Help > About LYX. On my
Windows computer, the path to the directory looks like this:

C:\Users\Jack\AppData\Roaming\LYX2.0\layouts

Those who are interested can open the layout files in a text editor
to see how they’re constructed. LYX and LATEX experts should feel
free to modify the layouts to their liking.

Module Files

If you have LYXConverter, you can also install the LYXBook mod-
ule files:

• LB–UseArabicNumbersWithParts.module

• LB–OmitPartNumbers.module

• LB–OmitChapterNumbers.module

• LB–NumberSections.module

• LB–IncludeSectionsInContents.module

• LB–IncludeSectionsInHeaders.module

• LB–IncludePartsInHeaders.module

• LB-OmitRunningHeads.module

• LB–ChangePartToNothing.module
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• LB–ChangeChapterToNothing.module

• LB–IndentFirstParagraphs.module

• LB–AllowRaggedBottoms.module

• LB–SetLeading1.4.module

• LB–SetLeading1.5.module

• LB–UseHangingPunctuation.module

Put them in the “layouts” folder along with the layout files.

Customized Keyboard Shortcuts

If you have LYXConverter, you can also install LYXBook’s key-
board file, user.bind. Put the file into your user directory under
~\LYX2.0\bind. Note that this file replaces some of LYX’s default
keyboard shortcuts (see “Keyboard Shortcuts,” below). If you
don’t want that to happen, you shouldn’t install user.bind.

Reconfigure and Restart

After installing the layout files or other files, you’ll need to re-
configure and restart LYX:

1. In LYX, click Tools > Reconfigure.

2. Wait for Reconfigure to finish.

3. Close and then restart LYX.

At this point, LYXBook’s features will be available in LYX.
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Uninstalling LYXBook

If you install LYXBook and later decide you don’t want it, just
remove its files (discussed above) from the directories where you
put them. Then reconfigure and restart LYX.

A Sample Book!

LYXBook includes The Merry Adventures of Robin Hood, already
styled and ready to typeset as a PDF. It’s a good example of how
to set up a book using LYXBook, and it’s fun to try using it with
the different layout files. (See “Layouts,” below.) By default, this
book uses the LYXBook–Archaic layout.

Check out those automatically generated chapter “numbers” in
the PDF! Try doing that in Microsoft Word.





Chapter 2

Using LYXBook

Using LYXBook is simple (if you don’t count the actual writing of
your book):

1. Create a new document in LYX by clicking File > New.

2. Apply one of the LYXBook layouts by clicking Document >
Settings > Document Class and selecting a layout from the
Document Class dropdown list. The LYXBook layouts .are
listed under “book,” like this: “book (LYXBook—Default).”

3. Write your book in LYX. Unlike working in a word processor,
writing in LYX is clean, fast, and reliable.

4. As you write, use the LYXBook styles to format your text.
You’ll find the styles in the dropdown style list at the up-
per left of your LYX window. You can access the list with
your mouse. If you’ve installed LYXConverter’s user.bind
keyboard file, you can also access the list by pressing the
F5 key.

5. Typeset your book as a PDF by clicking View > [PDF (pdfla-
tex)].
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LYXBook Styles

By default, LYX includes several useful styles, mainly for writ-
ing technical articles. LYXBook, on the other hand, includes all
the styles you’ll need to format a regular book (novel, biogra-
phy, family history), with a title page, chapters, running heads,
page numbers, and everything else you’d expect to see in a pro-
fessionally typeset book. If you apply the styles as explained in
this documentation, LYX will automatically create and paginate
your book.

Most of the styles are self-explanatory; use Chapter to desig-
nate a chapter title, Section to designate a subheading within a
chapter, and so on. This document provides many examples. A
few of the styles, however, need further explanation.

Styles That Format Text

Style Purpose

Standard The regular body text in your book.

Standard 2 An additional kind of body text, if you
need it, which you almost never will.

Text Break Used to style a break in the text. Such
breaks are used in novels to mark a
change of scene (often with three spaced
asterisks: * * *).

Chapter* The same as Chapter, but chapter titles
styled with this starred version won’t be
numbered or included in the table of
contents. The same is true for Part* and
Section*. You’ll hardly ever need to use
these.
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Half-Title Used on the first page of a book (the
half-title page) to display the book’s
title—and that’s all. The half-title page
comes before the actual title page. To see
an example, look at any professionally
published book.

Pretitle A line that appears on the title page
above the book’s title, if needed (“The
Merry Adventures of”).

Title The title of the book as it appears on the
title page (“Robin Hood”).

Styles That Provide Special Functions

Don’t use the following styles to format text; instead, use them
on their own line to provide special functions. For example, the
Contents style automatically generates a table of contents (as it
does in this document; see above).

Style Purpose

Contents Automatically generates a table of
contents, based on the book’s part and
chapter titles.

Start Two Columns Sets the following text in two columns
rather than one.

End Two Columns Returns the text to one column (the
default).
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Front Matter This should be the very first style in your
document. Front matter includes the
half-title page, title page, copyright
page, contents page, and so on. LYXBook
sets page numbers in front matter as
Roman numerals (i, ii, iii). Both running
heads include the chapter-level title (for
example, “Preface”). Chapter-level titles
in front matter are not numbered.

Main Matter Marks the end of the front matter and
the beginning of the actual chapters.
LYXBook sets page numbers in main
matter as Arabic numbers (1, 2, 3). The
left running head includes the part or
chapter title; the right running head
includes the chapter or section title.
Chapters are automatically numbered.

Back Matter Marks the end of the main matter and
the beginning of such items as
bibliography and index. Both running
heads include the chapter-level title (for
example, “Bibliography”). Chapter-level
titles in the back matter are not
numbered.

LYX is not WYSIWYG; what you see is not what you get. In fact,
that’s half the point of using LYX. Don’t worry about how your
text looks; just use the styles to mark up your text. LYX will do the
final formatting when it creates the typeset PDF.

As you apply styles to text, you’ll notice that some of them
make the text a certain format and color. For example, block
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quotes appear in blue. That’s so you’ll recognize them as block
quotes while you’re writing your book. Similarly, chapter-level
headings are centered in blue. Part headings appear in red. Sec-
tion headings appear in green. And so on. But don’t worry—later,
when your book is typeset, everything will be in good old black
and white. Also, even though part and chapter numbers aren’t
displayed when using LYXBook, they will be appropriately dis-
played in the typeset PDF.

Adjusting Document Settings

Ordinarily when using LYX, you can adjust many different set-
tings under Document > Settings. However, using the LYXBook
layouts, certain things under LYX’s document settings simply don’t
work. For example, you can still set the level of section num-
bering under Document > Settings > Numbering & TOC, but
your settings will have no effect. If you change line spacing un-
der Document > Settings > Text Layout > Spacing to anything
but “Single,” you’ll get an error message. But the whole point of
using LYXBook is to let LYXBook control the formatting. If that’s
not what you want, you should try some of the other document
classes under Document > Settings > Document Classes.

Basically, using LYXBook, you can (and should) adjust the fol-
lowing under Document > Settings:

• Document Class: Select a LYXBook document class (layout).
No matter which LYXBook layout you select, the appearance
of your text in LYX will remain the same. But when you
typeset your document, the appearance of your text in the
PDF will depend on the formatting specified in the layout.
To typeset your text and view the PDF, click View > [PDF
(pdflatex)].
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• Fonts: Adjust as needed. LYX has access to several good Ro-
man fonts, but the following are particularly well suited
for typesetting books: Bitstream Charter, Bookman, Century
Schoolbook, and Palatino. If you want to use other fonts on
your computer, check the box labeled “Use non-TEX fonts
(via XeTEX/LuaTEX)” and select the font you want to use
for Roman. If you’re going to use this option, you’ll need to
typeset your text and view the PDF by clicking View > View
(Other Formats) > PDF (XeTEX). Set the base font size to 10
or 11, with a maximum of 12.

• Page Layout: Set a custom size as needed. For books, height
and width should usually be 9 by 6 inches; other common
sizes are 8.5 by 5.5 and 10 by 7. Don’t change the Headings
style!

• Page Margins: Adjust as needed. For books, set the inner
margin at about an inch, which will provide enough space
to bind the pages when printed. Try a bottom margin of
1.25 inch.

Unless you really know what you’re doing, you should leave all
other settings alone.

Modules

The LYXBook modules (included with LYXConverter) do allow
you to change some of the things you’d ordinarily change through
LYX’s document settings, along with many other things as well:

• LB-UseArabicNumbersWithParts: By default, Part numbers
are set in Roman numerals (I, II, III). This module sets them
in Arabic numbers (1, 2, 3).

• LB-OmitPartNumbers: Keeps parts from being numbered.
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• LB-OmitChapterNumbers: Keeps chapters from being num-
bered.

• LB-NumberSections: Numbers sections.

• LB-IncludeSectionsInContents: Includes section titles in the
table of contents.

• LB-IncludeSectionsInHeaders: Includes section titles in the
recto (right-hand) running heads, and chapter titles in the
verso (left-hand) running heads.

• LB-IncludePartsInHeaders: Includes part titles in the verso
(left-hand) running heads, and chapter titles in the recto
(right-hand) running heads.

• LB-OmitRunningHeads: Omits running heads, leaving page
numbers only. This might be used in a novel whose only
chapter titles are Chapter 1, Chapter 2, and so on.

• LB-ChangePartToNothing: Changes the part name “Part” to
nothing. Parts are still numbered, however.

• LB-ChangeChapterToNothing: Changes the chapter name
“Chapter” to nothing. Chapters are still numbered, however.

• LB-IndentFirstParagraphs: Adds a first-line indent to body-
text paragraphs following headings.

• LB-AllowRaggedBottoms: Allows the bottom lines of facing
pages to be uneven rather than aligned.

• LB-SetLeading1.4: Sets leading (line spacing) at 1.4 the size
of the text for the styles Standard, Standard2, Block Quote,
Poem, and Letter. (Default is 1.3.)
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• LB-SetLeading1.5: Sets leading (line spacing) at 1.5 the size
of the text for the styles Standard, Standard2, Block Quote,
Poem, and Letter. (Default is 1.3.)

• LB-UseHangingPunctuation: Enables hanging punctuation
(character protrusion) and font expansion using the Mi-
crotype package for LATEX. Highly recommended!

To use the modules:

1. Click Document > Settings > Modules.

2. Select the module you want to use.

3. Click the Add button to activate the module.

4. Click the OK button.

LYX also includes several modules of its own, which you can ex-
plore at your leisure. Modules are activated in the order of their
position in the “Selected” list; if there are any conflicts between
modules, those lower on the list override those above.

Using Short (Optional) Titles

Sometimes in a book, you want a chapter heading to have dif-
ferent (usually shorter) wording in the table of contents and run-
ning heads than at the beginning of the chapter itself. Here’s how
to make that happen with LYXBook:

1. Put your cursor in front of the heading.

2. Click Insert > Short Title.

3. In the “opt” box that appears, type the optional wording
that should appear in the table of contents.
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4. Move your cursor after the “opt” box and in front of the
heading.

5. Click Insert > Short Title.

6. In the “opt” (for “optional”) box that appears, type the op-
tional wording that should appear in the running heads.

If you use two “opt” boxes, the first one (on the left) will be used
in the table of contents, the second one (on the right) in the run-
ning heads. If you use just one “opt” box, the text you provide will
be used in the table of contents and the running heads.

This feature is also useful if you need to rebreak an unsightly
chapter heading by using a “soft” return (CTRL_ENTER). If you
don’t provide an optional title in an “opt” box, the heading will
also be broken on the contents page and in the running heads,
which you don’t want. The solution is to provide an unbroken
version in an “opt” box.

Outline Pane

LYX’s Outline pane helps you see the structure of your docu-
ment as you write. To activate the pane, click the compass icon
(a toggle) on LYX’s standard toolbar. The pane will open on the
left side of your document. Click an item in the Outline pane to
navigate to that item.

Keyboard Shortcuts

Keyboard shortcuts help you work efficiently, without having to
reach for the mouse all the time. If you installed the user.bind key-
board file included with LYXConverter, the following shortcuts are
available, in some cases replacing LYX’s default shortcuts (which
are explained under Help > Shortcuts):
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Editing

The F keys (F2, F3, etc.) are the function keys at the top of your
keyboard. LYXConverter’s user.bind file sets these keys to perform
common editorial tasks:

F2 Track changes (toggle)

F3 Find and replace

F4 Reject tracked change

F5 Select styles (from the dropdown style list)

F6 Format with small caps (toggle)

F7 Format with emphasis (italics) (toggle)

F8 Emphasize (italicize) word and move to next word

F9 Capitalize word and move to next word

F10 Lowercase word and move to next word

F11 Transpose words

F12 Transpose characters

Document Formatting

In the following list, C represents the CONTROL key, and S rep-
resents the SHIFT key. LYXConverter’s user.bind file sets the fol-
lowing key combinations to apply some of the most commonly
used paragraph styles:

C-S-1 Part

C-S-2 Chapter
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C-S-3 Section

C-S-4 Subsection

C-S-5 Subsubsection

C-S-s Standard

C-S-b Block Quote

C-S-p Poem

C-S-e Enumerate (numbered list)

C-S-i Itemize (bulleted list)

Paragraph Formatting and Spacing

In the following list, C represents the CONTROL key, and S repre-
sents the SHIFT key. LYXConverter’s user.bind file sets the follow-
ing key combinations to apply paragraph formatting and spacing.
You should hardly ever need to use these; they’re for fine-tuning
only.

C-S-l Align left

C-S-c Align center

C-S-r Align right

C-S-j Align justified

C-S-d Toggle first-line indent (for text styled with Stan-
dard, Quotation, and a few others). You can use this
to “outdent” (unindent) the first line of a paragraph
that is normally indented.
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C-S-h Insert horizontal space in the form of an em space,
or quad, as some typesetters call it. If you put your
cursor in front of this space and right-click, you can
change it to some other kind of space. You can use
this to indent paragraphs that aren’t normally in-
dented, to format poetry, and so on. Use this spar-
ingly; don’t go merrily using it to further indent ev-
ery paragraph in sight.

C-S-v Insert vertical space, or leading, as typographers call
it. If you put your cursor in front of this space and
right-click, you can change it to some other kind of
space. You can also insert vertical space by press-
ing C-ENTER, which produces a “soft” line break.
Again, use these sparingly; LYXBook should take care
of most vertical spacing.

Local Formatting

In the following list, C represents the CONTROL key.
LYXConverter’s user.bind file sets the following key combinations
to apply local formatting:

C-i Toggle emphasis (italics)

C-u Toggle emphasis (italics rather than underline; un-
derlining is a holdover from the days of the type-
writer and shouldn’t be used for emphasis in type-
setting books)

C-b Toggle bold
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Special Characters

In the following list, C represents the CONTROL key, and M rep-
resents the Meta key. In Windows, this is the ALT key; on a Mac-
intosh, it’s the Apple key. LYXConverter’s user.bind file sets the
following key combinations to insert these commonly used spe-
cial characters:

C-M-m Em dash (—)

C-M-n En dash (–)

C-M-p Pound sign (£)

C-M-e Euro sign (C)

C-M-c Copyright (©)

C-M-t Trademark (™)

C-M-r Registered (®)

If you need other special characters (those not on your keyboard),
you’ll probably find them under Insert > Special Character.

Other Shortcuts

In addition to the keyboard shortcuts listed above:

• You can make an em dash by typing three hyphens in a
row—like this.

• You can make an en dash by typing two hyphens in a row.
(En dashes are used to separate a range of numbers, like
this: 12–24.)

• If you’ve installed LYXConverter’s user.bind file, CTRL-
DELETE deletes the current word even if the cursor isn’t at
the beginning of the word.
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